Lassalle.Flow Namespace

AddFlow for Winforms 2015
Lassalle.Flow Namespace
AddFlow for WinForms is a general purpose Flowcharting/Diagramming .NET Windows form control. Each time you need to graphically display interactive diagrams, you should consider using AddFlow, a royalty-free control that offers unique support to create diagrams interactively or programmatically: workflow diagrams, database diagrams, communication networks, organizational charts, process flows, state transitions diagrams, CTI applications, CRM (Customer Relationship Management), expert systems, graph theory, quality control diagrams, ...Small deployment assembly. Small programming interface. Full integration with the .NET environment. Great Flexibility. Runtime royalty free.
Classes
 | Class | Description
Public class | AddFlow | AddFlow for Winforms 2015
Public class | AddFlowException | AddFlow exception class
Public class | AddFlowLicenseProvider |
Public class | AfterAddCaptionEventArgs | Event parameters used for the AfterAddCaption event
Public class | AfterAddLinkEventArgs | Event parameters used for the AfterAddLink event
Public class | AfterAddNodeEventArgs | Event parameters used for the AfterAddNode event
Public class | AfterEditEventArgs | Event parameters used for the AfterEdit event
Public class | AfterRemoveCaptionEventArgs | Event parameters used for the AfterRemoveCaption event
Public class | AfterRemoveLinkEventArgs | Event parameters used for the AfterRemoveLink event
Public class | AfterRemoveNodeEventArgs | Event parameters used for the AfterRemoveNode event
Public class | BeforeAddCaptionEventArgs | Event parameters used for the BeforeAddCaption event
Public class | BeforeAddLinkEventArgs | Event parameters used for the BeforeAddLink event
Public class | BeforeAddNodeEventArgs | Event parameters used for the BeforeAddNode event
Public class | BeforeChangeDstEventArgs | Event parameters used for the BeforeChangeDst event
Public class | BeforeChangeOrgEventArgs | Event parameters used for the BeforeChangeOrg event
Public class | BeforeEditEventArgs | Event parameters used for the BeforeEdit event
Public class | BeforeRemoveCaptionEventArgs | Event parameters used for the beforeRemoveCaption event
Public class | BeforeRemoveLinkEventArgs | Event parameters used for the BeforeRemoveLink event
Public class | BeforeRemoveNodeEventArgs | Event parameters used for the beforeRemoveNode event
Public class | CancelEditEventArgs | Event parameters used for the CancelEdit event
Public class | Caption | Represents a caption (also called label or note) in the diagram. A caption is a ContentItem object that can be owned by an Item
Public class | ContentItem | Represents an Item object that has a content which may be a string or/and an image. Nodes and captions are ContentItem objects.
Public class | ContentItemOwnerDrawEventArgs | Event parameters used for the ContentItemOwnerDraw event
Public class | DiagramOwnerDrawEventArgs | Event parameters used for the DiagramOwnerDraw event
Public class | ErrorEventArgs | Event parameters used for the Error event
Public class | Item | Represents an item in the diagram. All classes representing diagram elements derive from Item.
Public class | Link | Represents a link (also called edge or relation or arc) in the diagram. A link is an Item object allowing linking two nodes.
Public class | LinkOwnerDrawEventArgs | Event parameters used for the LinkOwnerDraw event
Public class | Node | Represents a node (also called vertice or entity) in the diagram. A node is a ContentItem object that be linked to another node.
Public class | PropertyBag | Allows adding new custom properties to AddFlow items
Public class | PropertyBagProperty | The Property class is an inner class to PropertyBag.
Public class | Quadtree | A class for managing a quadtree structure It allows improving speed performance of diagram display and item selection
Public class | SelectedItemsLayoutingEventArgs | Event parameters used for the SelectedItemsLayouting event
Public class | SelectedLinkStretchingEventArgs | Event parameters used for the SelectedLinkStretching event
Public class | SelectionChangeArgs | Event parameters used for the SelectionChange event
Public class | Task | Represents an action that can be undone and redone.
Public class | TaskManager | The class managing the list of tasks and allowing undo/redo.
Public class | UpdatedEventArgs | A subclass of EventArgs that contains the custom event arguments for the OnUpdated event
Public class | UpdatingEventArgs | A subclass of UpdatedEventArgs that contains the custom event arguments for the OnUpdating event.
Interfaces
 | Interface | Description
Public interface | IMoveable | Common interface for items (nodes, captions) that can be moved
Public interface | ISelectable | Common interface for items (nodes, links, captions) that can be selected.
Public interface | ISizeable | Common interface for items (nodes, captions) that can be resized
Delegates
 | Delegate | Description
Public delegate | AddFlowAfterAddCaptionEventHandler | Represents the method that will handle the AfterAddCaption event.
Public delegate | AddFlowAfterAddLinkEventHandler | Represents the method that will handle the AfterAddLink event.
Public delegate | AddFlowAfterAddNodeEventHandler | Represents the method that will handle the AfterAddNode event.
Public delegate | AddFlowAfterChangeDstEventHandler | Represents the method that will handle the AfterChangeDst event.
Public delegate | AddFlowAfterChangeOrgEventHandler | Represents the method that will handle the AfterChangeOrg event.
Public delegate | AddFlowAfterEditEventHandler | Represents the method that will handle the AfterEdit event.
Public delegate | AddFlowAfterMoveEventHandler | Represents the method that will handle the AfterMove event.
Public delegate | AddFlowAfterRemoveCaptionEventHandler | Represents the method that will handle the AfterRemoveCaption event.
Public delegate | AddFlowAfterRemoveLinkEventHandler | Represents the method that will handle the AfterRemoveLink event.
Public delegate | AddFlowAfterRemoveNodeEventHandler | Represents the method that will handle the AfterRemoveNode event.
Public delegate | AddFlowAfterResizeEventHandler | Represents the method that will handle the AfterResize event.
Public delegate | AddFlowAfterSelectEventHandler | Represents the method that will handle the AfterSelect event.
Public delegate | AddFlowAfterStretchEventHandler | Represents the method that will handle the AfterStretch event.
Public delegate | AddFlowBeforeAddCaptionEventHandler | Represents the method that will handle the BeforeAddCaption event.
Public delegate | AddFlowBeforeAddLinkEventHandler | Represents the method that will handle the BeforeAddLink event.
Public delegate | AddFlowBeforeAddNodeEventHandler | Represents the method that will handle the BeforeAddNode event.
Public delegate | AddFlowBeforeChangeDstEventHandler | Represents the method that will handle the BeforeChangeDst event.
Public delegate | AddFlowBeforeChangeOrgEventHandler | Represents the method that will handle the BeforeChangeOrg event.
Public delegate | AddFlowBeforeEditEventHandler | Represents the method that will handle the BeforeEdit event.
Public delegate | AddFlowBeforeRemoveCaptionEventHandler | Represents the method that will handle the BeforeRemoveCaption event.
Public delegate | AddFlowBeforeRemoveLinkEventHandler | Represents the method that will handle the BeforeRemoveLink event.
Public delegate | AddFlowBeforeRemoveNodeEventHandler | Represents the method that will handle the BeforeRemoveNode event.
Public delegate | AddFlowCancelEditEventHandler | Represents the method that will handle the CancelEdit event.
Public delegate | AddFlowDiagramOwnerDrawEventHandler | Represents the method that will handle the DiagramOwnerDraw event.
Public delegate | AddFlowErrorEventHandler | Represents the method that will handle the Error event.
Public delegate | AddFlowExtentChangeEventHandler | Represents the method that will handle the ExtentChange event.
Public delegate | AddFlowLinkOwnerDrawEventHandler | Represents the method that will handle the LinkOwnerDraw event.
Public delegate | AddFlowNodeOwnerDrawEventHandler | Represents the method that will handle the NodeOwnerDraw event.
Public delegate | AddFlowScrollPositionChangeEventHandler | Represents the method that will handle the ScrollPositionChange event.
Public delegate | AddFlowSelectedItemsLayoutingEventHandler | Represents the method that will handle the SelectedItemsLayouting event.
Public delegate | AddFlowSelectedLinkStretchingEventHandler | Represents the method that will handle the SelectedLinkStretching event.
Public delegate | AddFlowSelectionChangeEventHandler | Represents the method that will handle the SelectionChange event.
Public delegate | UpdatedEventHandler | Interface definition for the OnUpdated event
Public delegate | UpdatingEventHandler | Interface definition for the OnUpdating event
Enumerations
 | Enumeration | Description
Public enumeration | Action | Used to specify an action that changes the diagram.
Public enumeration | BackMode | Used to specify whether the background will remain untouched or not for the text in a node.
Public enumeration | ContentItemDrawFlags | Use to specify how the IsOwnerDraw property of a ContentItem object is used.
Public enumeration | CursorSetting | Cursor settings
Public enumeration | DrawFlags | Use to specify how the IsOwnerDraw property is used.
Public enumeration | ErrorEventType | Used to specify the type of the Error event
Public enumeration | GridStyle | Used to specify the drawing style of the grid.
Public enumeration | ImagePosition | Used to specify the position of the image in the node.
Public enumeration | LineStyle | Used to specify the style used to draw a link.
Public enumeration | LinkDrawFlags | Use to specify how the IsOwnerDraw property of the link is used.
Public enumeration | MouseAction | Used to specify the selection rectangle action with the mouse.
Public enumeration | MouseArea | Used to specify the type of the area pointed by the mouse.
Public enumeration | ScrollbarsDisplayMode | Used to specify how the AutoScrollMinSize is set
Public enumeration | ShadowStyle | Used to specify the node shadow style.
Public enumeration | ShapeFamily | Used to specify a node family style.
Public enumeration | TextPlacementMode | Used to specify the position of the link text near the link.
Public enumeration | TextPosition | Used to specify the position of the text in the node.

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Action Enumeration

Action Enumeration
Used to specify an action that changes the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum Action
Public Enumeration Action
public enum class Action
type Action
Members
Member name | Value | Description
DeleteSel | -1 | The selected items are deleted
Dst | -2 | The destination node of a link is changed
ItemLayout | -3 | A node or a caption is moved or resized
CaptionAdd | -4 | A caption is created
CaptionRemove | -5 | A caption is deleted
InPlaceTextEdition | -6 | The text of a node has been changed directly in the node
LineStyle | -7 | The LineStyle property of a link is changed
LinkAdd | -8 | A link is created
LinkRemove | -9 | A link is deleted
LinkStretch | -10 | A link is stretched
NodeAdd | -11 | A node is created
NodeRemove | -12 | A node is deleted
None | -13 | No action
Org | -14 | The origin node of a link is changed
Owner | -15 | The owner of a caption is changed
PinDstIndex | -16 | The index of the destination pin is changed
PinOrgIndex | -17 | The index of the origin pin is changed
Points | -18 | The points collection of a link is changed
ZOrder | -19 | The ZOrder of an item is changed
Remarks
Selection actions are omitted because they do not change the document
See Also

Reference

Lassalle.Flow Namespace


AddFlow Class

AddFlow Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Lassalle.FlowAddFlow

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AddFlow : UserControl
Public Class AddFlow
    Inherits UserControl
public ref class AddFlow : public UserControl
type AddFlow =
    class
        inherit UserControl
    end

The AddFlow type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlow | Constructor
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AddCaption | Add a caption object to the AddFlow control.
Public method | AddLink | Add a link between 2 nodes.
Public method | AddNode | Add a node object to the AddFlow control.
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the AddFlow control.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clear the diagram
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteSel | Delete the selected items (nodes and links).
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AddFlow and optionally releases the managed resources (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the AddFlow control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportMetafile(Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiagramSize | Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHitItem | Retrieves the item at the specified location.
Public method | GetItemsInRectangle(RectangleF) | Get the nodes and links placed in a rectangle.
Public method | GetItemsInRectangle(RectangleF, Boolean) | Get the nodes and links placed in a rectangle.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterAddCaption | Raises the AfterAddCaption event
Protected method | OnAfterAddLink | Raises the AfterAddLink event
Protected method | OnAfterAddNode | Raises the AfterAddNode event
Protected method | OnAfterChangeDst | Raises the AfterChangeDst event
Protected method | OnAfterChangeOrg | Raises the AfterChangeOrg event
Protected method | OnAfterEdit | Raises the AfterEdit event
Protected method | OnAfterMove | Raises the AfterMove event
Protected method | OnAfterRemoveCaption | Raises the AfterRemoveCaption event
Protected method | OnAfterRemoveLink | Raises the AfterRemoveLink event
Protected method | OnAfterRemoveNode | Raises the AfterRemoveNode event
Protected method | OnAfterResize | Raises the AfterResize event
Protected method | OnAfterSelect | Raises the AfterSelect event
Protected method | OnAfterStretch | Raises the AfterStretch event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeAddCaption | Raises the BeforeAddCaption event
Protected method | OnBeforeAddLink | Raises the BeforeAddLink event
Protected method | OnBeforeAddNode | Raises the BeforeAddNode event
Protected method | OnBeforeChangeDst | Raises the BeforeChangeDst event
Protected method | OnBeforeChangeOrg | Raises the BeforeChangeOrg event
Protected method | OnBeforeEdit | Raises the BeforeEdit event
Protected method | OnBeforeRemoveCaption | Raises the BeforeRemoveCaption event
Protected method | OnBeforeRemoveLink | Raises the BeforeRemoveLink event
Protected method | OnBeforeRemoveNode | Raises the BeforeRemoveNode event
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCancelEdit | Raises the CancelEdit event
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDiagramOwnerDraw | Raises the DiagramOwnerDraw event
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnError | Raises the Error event
Protected method | OnExtentChange | Raises the ExtentChange event
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkOwnerDraw | Raises the LinkOwnerDraw event
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | MouseDown event handler (Overrides UserControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | MouseMove event handler (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | MouseUp event handler (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNodeOwnerDraw | Raises the NodeOwnerDraw event
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Paint event handler (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Resize event handler (Overrides UserControlOnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnScrollPositionChange | Raises the ScrollPositionChange event
Protected method | OnSelectedItemsLayouting | Raises the SelectedItemsLayouting event. Cancelling the action aborts the resizing or moving action.
Protected method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected method | OnSelectionChange | Raises the SelectionChange event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFToAddFlow | Convert a PointF object in device coordinates to AddFlow coordinates
Public method | PointFToDevice | Convert a PointF object in AddFlow coordinates to device coordinates
Public method | PointToAddFlow | Convert a Point object in device coordinates to AddFlow coordinates
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToDevice | Convert a Point object in AddFlow coordinates to device coordinates
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveCaption | Remove the specified caption from the AddFlow control
Public method | RemoveLink | Removes the specified link from the diagram.
Public method | RemoveNode | Removes the specified node from the Nodes collection. The links attached to the node are also removed.
Public method | Render | Display the diagram in a GDI+ drawing area
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectAll | Selects all the items of the diagram
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Public method | SetSelChangedFlag | Allow to set a flag indicating that the selection has changed or not.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | ShouldSerializeBezierSelectionLineColor | Returns true if BezierSelectionLineColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeCaptionModel | Returns true if CaptionModel should be serialized.
Public method | ShouldSerializeGridColor | Returns true if GridColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeGridSize | Returns true if GridSize should be serialized.
Public method | ShouldSerializeHandleColor1 | Returns true if HandleColor1 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeHandleColor2 | Returns true if HandleColor2 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeHandleDrawColor | Returns true if HandleDrawColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeLinkModel | Returns true if LinkModel should be serialized.
Public method | ShouldSerializeNodeModel | Returns true if NodeModel should be serialized.
Public method | ShouldSerializePinColor1 | Returns true if PinColor1 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializePinColor2 | Returns true if PinColor2 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializePinDrawColor | Returns true if PinDrawColor has not the the default value and therefore needs to be serialized.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnselectAll | Command that unselects all the items of the diagram
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | ZoomPoint | Zoom the diagram and center it on a point.
Public method | ZoomRectangle | Zoom a rectangular portion of the diagram.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BezierSelectionLineColor | Returns/sets the drawing color of the lines used for selected bezier links
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanChangeDst | Determines whether the user can interactively change the destination of a link.
Public property | CanChangeOrg | Determines whether the user can interactively change the origin of a link.
Public property | CanDragScroll | Determines whether drag scrolling is allowed or not.
Public property | CanDrawCaption | Determines whether interactive creation of captions is allowed or not.
Public property | CanDrawLink | Determines whether interactive creation of links is allowed or not.
Public property | CanDrawNode | Determines whether interactive creation of nodes is allowed or not.
Public property | CanEditContentItem | Determines whether the user can edit the text of ContentItem objects.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFireError | Determines if the error event is fired or not.
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanMoveItems | Determines whether interactive dragging of items is allowed or not.
Public property | CanMultiLink | Determines whether you can create several links between two nodes or not.
Public property | CanMultiSelect | Determines whether multiselection mode of nodes and links is allowed or not.
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public property | CanShowTooltips | Determines whether the tooltips are displayed or not.
Public property | CanSizeItems | Determines whether you can resize items interactively or not.
Public property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.
Public property | CaptionModel | Returns a Caption object that contains the default property values for captions. When a caption is created, it receives these property values.
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CursorSetting | Returns/sets a value that determines whether default cursors are displayed.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Extent | Returns the diagram size.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GridColor | Returns/sets the grid color.
Public property | GridDraw | Determines whether the grid is displayed or not.
Public property | GridSize | Returns/sets the horizontal and vertical grid size.
Public property | GridSnap | Determines whether nodes are aligned on the grid.
Public property | GridStyle | Returns/sets the grid style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleColor1 | Returns/sets a value which defines the first color used for the brush of the selection handles.
Public property | HandleColor2 | Returns/sets a value which defines the second color used for the brush of the selection handles.
Public property | HandleDrawColor | Returns/sets a value which defines the color used for the pen of the selection handles.
Public property | HandleSize | Returns/sets a value which defines the size of the selection handles of the selected node or link
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HitArea | Returns the area pointed by the mouse: sizing square, stretching square, linking square, node, over no special area.
Public property | HitItem | Returns the item (node or link) pointed by the mouse.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsChanged | Indicates if the AddFlow diagram has changed.
Public property | IsCreatingCaption | Indicates if the user is currently creating a caption
Public property | IsCreatingLink | Indicates if the user is currently creating a link
Public property | IsCreatingNode | Indicates if the user is currently creating a node
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInPlaceEditing | Indicates if the user is currently editing the text of a ContentItem object
Public property | IsInteractiveEventsOnly | Determines whether events can occur only with interactive actions.
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsMoving | Indicates if the user is currently moving nodes
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for the diagram.
Public property | IsPanning | Indicates if the user is currently panning the diagram
Public property | IsQuadtree | Determines whether a Quadtree structure is used to improve speed when the diagram is big
Public property | IsResizing | Indicates if the user is currently resising nodes
Public property | IsSelChanged | Indicates if the selection in the AddFlow diagram has changed.
Public property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public property | IsSelectionChangeEventFired | Determines whether the SelectionChange event is fired or not.
Public property | IsSelectionHandleDisplayed | Determines whether the handles used for selection are displayed or not.
Public property | IsStretchingLink | Indicates if the user is currently stretching a link
Public property | IsZooming | Indicates if the user is currently zooming the diagram
Public property | Items | Returns the collection of all the items of the diagram.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | LicenseKey |
Public property | LinkModel | Returns a Link object that contains the default property values for links. When a link is created, it receives these property values.
Public property | LinkSelectionAreaWidth | Returns/sets a value that determines the width of the area where the user has to click to select a link.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseAction | Returns/sets the current interactive action (select items, zoom,...).
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NodeModel | Returns a Node object that contains the default property values for nodes. When a node is created, it receives these property values.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageScale | Returns/sets a value that determines the scaling used to display the graph.
Public property | PageUnit | Returns/sets a value that determines the unit of measure used to display the graph.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PinColor1 | Returns/sets a value which defines the first color used for the brush of the node pins.
Public property | PinColor2 | Returns/sets a value which defines the second color used for the brush of the node pins.
Public property | PinDrawColor | Returns/sets a value which defines the color used for the pen of the node pins.
Public property | PinSize | Returns/sets a value which defines the size of the node pins.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Properties | Returns the PropertyBag instance associated to the AddFlow control
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollbarsDisplayMode | Returns/sets the scrollbars display mode
Public property | ScrollPosition | Returns/sets the scrolling offset.
Public property | SelectedItems | Returns the collection of all the selected items of the diagram.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchingPoint | Returns the index of the current stretching point.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Returns/sets the zoom factor.
Top
Events
 | Name | Description
Public event | AfterAddCaption | Occurs after a user creates a caption.
Public event | AfterAddLink | Occurs after a user creates a link.
Public event | AfterAddNode | Occurs after a user creates a node.
Public event | AfterChangeDst | Occurs after a user has changed the destination node of a link.
Public event | AfterChangeOrg | Occurs after a user has changed the origin node of a link.
Public event | AfterEdit | Occurs after a user edits the text of the selected node.
Public event | AfterMove | Occurs after a user drags the selected nodes.
Public event | AfterRemoveCaption | Occurs after a caption is removed.
Public event | AfterRemoveLink | Occurs after a link is removed.
Public event | AfterRemoveNode | Occurs after a node is removed.
Public event | AfterResize | Occurs after a user resizes a node.
Public event | AfterSelect | Occurs after a user has finished drawing a selection rectangle with the mouse.
Public event | AfterStretch | Occurs after a user stretches a link.
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeAddCaption | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | BeforeAddLink | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | BeforeAddNode | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | BeforeChangeDst | Occurs when a user attempts to change the destination node of a link. Cancelling the action aborts the destination change.
Public event | BeforeChangeOrg | Occurs when a user attempts to change the origin node of a link. Cancelling the action aborts the origin change.
Public event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public event | BeforeRemoveCaption | Occurs before a caption is removed.
Public event | BeforeRemoveLink | Occurs before a link is removed.
Public event | BeforeRemoveNode | Occurs before a node is removed.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DiagramOwnerDraw | This event is fired each time the diagram is repainted. The IsOwnerDraw property of AddFlow must be set.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | Error | This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false - creating a link towards a node that does not accept incoming links - creating a link from a node that does not accept outgoing links The CanFireError property must be set.
Public event | ExtentChange | This event is fired each time the size of the diagram is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkOwnerDraw | This event is fired each time the link is repainted. The IsOwnerDraw property of the link must be set.
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeOwnerDraw | This event is fired each time the node is repainted. The IsOwnerDraw property of the node must be set.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ScrollPositionChange | This event is fired each time the scroll position of the diagram is changed.
Public event | SelectedItemsLayouting | Occurs when a user is currently moving or resizing a node or a caption
Public event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public event | SelectionChange | Occurs when the selection status of an item is changed
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow Constructor

AddFlow Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AddFlow()
Public Sub New
public:
AddFlow()
new : unit -> AddFlow
See Also

Reference

AddFlow Class


AddFlow Methods

AddFlow Methods

The AddFlow type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AddCaption | Add a caption object to the AddFlow control.
Public method | AddLink | Add a link between 2 nodes.
Public method | AddNode | Add a node object to the AddFlow control.
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the AddFlow control.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clear the diagram
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteSel | Delete the selected items (nodes and links).
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the AddFlow control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportMetafile(Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiagramSize | Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHitItem | Retrieves the item at the specified location.
Public method | GetItemsInRectangle(RectangleF) | Get the nodes and links placed in a rectangle.
Public method | GetItemsInRectangle(RectangleF, Boolean) | Get the nodes and links placed in a rectangle.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterAddCaption | Raises the AfterAddCaption event
Protected method | OnAfterAddLink | Raises the AfterAddLink event
Protected method | OnAfterAddNode | Raises the AfterAddNode event
Protected method | OnAfterChangeDst | Raises the AfterChangeDst event
Protected method | OnAfterChangeOrg | Raises the AfterChangeOrg event
Protected method | OnAfterEdit | Raises the AfterEdit event
Protected method | OnAfterMove | Raises the AfterMove event
Protected method | OnAfterRemoveCaption | Raises the AfterRemoveCaption event
Protected method | OnAfterRemoveLink | Raises the AfterRemoveLink event
Protected method | OnAfterRemoveNode | Raises the AfterRemoveNode event
Protected method | OnAfterResize | Raises the AfterResize event
Protected method | OnAfterSelect | Raises the AfterSelect event
Protected method | OnAfterStretch | Raises the AfterStretch event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeAddCaption | Raises the BeforeAddCaption event
Protected method | OnBeforeAddLink | Raises the BeforeAddLink event
Protected method | OnBeforeAddNode | Raises the BeforeAddNode event
Protected method | OnBeforeChangeDst | Raises the BeforeChangeDst event
Protected method | OnBeforeChangeOrg | Raises the BeforeChangeOrg event
Protected method | OnBeforeEdit | Raises the BeforeEdit event
Protected method | OnBeforeRemoveCaption | Raises the BeforeRemoveCaption event
Protected method | OnBeforeRemoveLink | Raises the BeforeRemoveLink event
Protected method | OnBeforeRemoveNode | Raises the BeforeRemoveNode event
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCancelEdit | Raises the CancelEdit event
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDiagramOwnerDraw | Raises the DiagramOwnerDraw event
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnError | Raises the Error event
Protected method | OnExtentChange | Raises the ExtentChange event
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkOwnerDraw | Raises the LinkOwnerDraw event
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | MouseDown event handler (Overrides UserControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | MouseMove event handler (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | MouseUp event handler (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNodeOwnerDraw | Raises the NodeOwnerDraw event
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Paint event handler (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Resize event handler (Overrides UserControlOnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnScrollPositionChange | Raises the ScrollPositionChange event
Protected method | OnSelectedItemsLayouting | Raises the SelectedItemsLayouting event. Cancelling the action aborts the resizing or moving action.
Protected method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected method | OnSelectionChange | Raises the SelectionChange event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFToAddFlow | Convert a PointF object in device coordinates to AddFlow coordinates
Public method | PointFToDevice | Convert a PointF object in AddFlow coordinates to device coordinates
Public method | PointToAddFlow | Convert a Point object in device coordinates to AddFlow coordinates
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToDevice | Convert a Point object in AddFlow coordinates to device coordinates
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveCaption | Remove the specified caption from the AddFlow control
Public method | RemoveLink | Removes the specified link from the diagram.
Public method | RemoveNode | Removes the specified node from the Nodes collection. The links attached to the node are also removed.
Public method | Render | Display the diagram in a GDI+ drawing area
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectAll | Selects all the items of the diagram
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Public method | SetSelChangedFlag | Allow to set a flag indicating that the selection has changed or not.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | ShouldSerializeBezierSelectionLineColor | Returns true if BezierSelectionLineColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeCaptionModel | Returns true if CaptionModel should be serialized.
Public method | ShouldSerializeGridColor | Returns true if GridColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeGridSize | Returns true if GridSize should be serialized.
Public method | ShouldSerializeHandleColor1 | Returns true if HandleColor1 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeHandleColor2 | Returns true if HandleColor2 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeHandleDrawColor | Returns true if HandleDrawColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeLinkModel | Returns true if LinkModel should be serialized.
Public method | ShouldSerializeNodeModel | Returns true if NodeModel should be serialized.
Public method | ShouldSerializePinColor1 | Returns true if PinColor1 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializePinColor2 | Returns true if PinColor2 has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializePinDrawColor | Returns true if PinDrawColor has not the the default value and therefore needs to be serialized.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnselectAll | Command that unselects all the items of the diagram
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | ZoomPoint | Zoom the diagram and center it on a point.
Public method | ZoomRectangle | Zoom a rectangular portion of the diagram.
Top
See Also

Reference

AddFlow Class


AddFlow.AddCaption Method

AddFlowAddCaption Method
Add a caption object to the AddFlow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCaption(
    Caption caption
)
Public Sub AddCaption (
    caption As Caption
)
public:
void AddCaption(
    Caption^ caption
)
member AddCaption :
        caption : Caption -> unit

Parameters

caption
Type: Lassalle.FlowCaption
A reference to the caption object to add
Exceptions
Exception | Condition
AddFlowException | Thrown if the caption object is already owned by an AddFlow control
Remarks
A Caption object can only be assigned to one AddFlow control at a time. To add the caption to a new AddFlow control, you must remove it from the other AddFlow first, or clone it.
See Also

Reference

AddFlow Class


AddFlow.AddLink Method

AddFlowAddLink Method
Add a link between 2 nodes.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddLink(
    Link link
)
Public Sub AddLink (
    link As Link
)
public:
void AddLink(
    Link^ link
)
member AddLink :
        link : Link -> unit

Parameters

link
Type: Lassalle.FlowLink
A reference to the link to add
See Also

Reference

AddFlow Class


AddFlow.AddNode Method

AddFlowAddNode Method
Add a node object to the AddFlow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddNode(
    Node node
)
Public Sub AddNode (
    node As Node
)
public:
void AddNode(
    Node^ node
)
member AddNode :
        node : Node -> unit

Parameters

node
Type: Lassalle.FlowNode
A reference to the node object to add
Exceptions
Exception | Condition
AddFlowException | Thrown if the node object is already owned by an AddFlow control
Remarks
A Node object can only be assigned to one AddFlow control at a time. To add the node to a new AddFlow control, you must remove it from the other AddFlow first, or clone it.
See Also

Reference

AddFlow Class


AddFlow.BeginUpdate Method

AddFlowBeginUpdate Method
Disables any redrawing of the AddFlow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
Remarks
To maintain performance while items are added to the AddFlow control, call the BeginUpdate method. The BeginUpdate method prevents the control from painting until the EndUpdate method is called. Also, between the calls to BeginUpdate and EndUpdate, the size of the diagram is not updated. It is updated only when the EndUpdate method is called. If you need the size of the diagram before the call to endUpdate, you can use the GetDiagramSize method.
See Also

Reference

AddFlow Class


AddFlow.Clear Method

AddFlowClear Method
Clear the diagram

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Remarks
This action is not undoable.
See Also

Reference

AddFlow Class


AddFlow.DeleteSel Method

AddFlowDeleteSel Method
Delete the selected items (nodes and links).

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteSel()
Public Sub DeleteSel
public:
void DeleteSel()
member DeleteSel : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.Dispose Method

AddFlowDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AddFlow and optionally releases the managed resources (Overrides ContainerControlDispose(Boolean).)
Top
See Also

Reference

AddFlow Class


AddFlow.Dispose Method (Boolean)

AddFlowDispose Method (Boolean)
Releases the unmanaged resources used by the AddFlow and optionally releases the managed resources

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

AddFlow Class
Dispose Overload


AddFlow.EndUpdate Method

AddFlowEndUpdate Method
Enables the redrawing of the AddFlow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
Remarks
To maintain performance while items are added to the AddFlow control, call the BeginUpdate method. The BeginUpdate method prevents the control from painting until the EndUpdate method is called. Also, between the calls to BeginUpdate and EndUpdate, the size of the diagram is not updated. It is updated only when the EndUpdate method is called. If you need the size of the diagram before the call to endUpdate, you can use the GetDiagramSize method.
See Also

Reference

AddFlow Class


AddFlow.ExportMetafile Method

AddFlowExportMetafile Method
Overload List
 | Name | Description
Public method | ExportMetafile(Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Public method | ExportMetafile(Boolean, Boolean, Boolean, Boolean, Boolean) | Export the diagram as a metafile.
Top
See Also

Reference

AddFlow Class


AddFlow.ExportMetafile Method (Boolean, Boolean, Boolean)

AddFlowExportMetafile Method (Boolean, Boolean, Boolean)
Export the diagram as a metafile.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Metafile ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin
)
Public Function ExportMetafile (
    selected As Boolean,
    includeBackColor As Boolean,
    zeroOrigin As Boolean
) As Metafile
public:
Metafile^ ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin
)
member ExportMetafile :
        selected : bool *
        includeBackColor : bool *
        zeroOrigin : bool -> Metafile

Parameters

selected
Type: SystemBoolean
If True, then only the selected items are taken into account in the export. If false, all the diagram is exported.
includeBackColor
Type: SystemBoolean
If True, the backColor is taken into account.
zeroOrigin
Type: SystemBoolean
If True, then the origin (0,0) is considered as the left top most point of the diagram. If False, then the diagram starts at the left most top most item(node or link).

Return Value

Type: Metafile
A Metafile object
Remarks
If the grid is displayed in the AddFlow control, then it will be exported with the diagram. If you wish to avoid that, you can put the value of the GridDraw property to False just before calling ExportMetafile and reset it after.
See Also

Reference

AddFlow Class
ExportMetafile Overload


AddFlow.ExportMetafile Method (Boolean, Boolean, Boolean, Boolean)

AddFlowExportMetafile Method (Boolean, Boolean, Boolean, Boolean)
Export the diagram as a metafile.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Metafile ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin,
    bool keepZoom
)
Public Function ExportMetafile (
    selected As Boolean,
    includeBackColor As Boolean,
    zeroOrigin As Boolean,
    keepZoom As Boolean
) As Metafile
public:
Metafile^ ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin,
    bool keepZoom
)
member ExportMetafile :
        selected : bool *
        includeBackColor : bool *
        zeroOrigin : bool *
        keepZoom : bool -> Metafile

Parameters

selected
Type: SystemBoolean
If True, then only the selected items are taken into account in the export. If false, all the diagram is exported.
includeBackColor
Type: SystemBoolean
If True, the backColor is taken into account.
zeroOrigin
Type: SystemBoolean
If True, then the origin (0,0) is considered as the left top most point of the diagram. If False, then the diagram starts at the left most top most item(node or link).
keepZoom
Type: SystemBoolean
If True, then the current zoom value is taken into account.

Return Value

Type: Metafile
A Metafile object
Remarks
If the grid is displayed in the AddFlow control, then it will be exported with the diagram. If you wish to avoid that, you can put the value of the ShowGrid property to False just before calling ExportMetafile and reset it after.
See Also

Reference

AddFlow Class
ExportMetafile Overload


AddFlow.ExportMetafile Method (Boolean, Boolean, Boolean, Boolean, Boolean)

AddFlowExportMetafile Method (Boolean, Boolean, Boolean, Boolean, Boolean)
Export the diagram as a metafile.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Metafile ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin,
    bool keepZoom,
    bool printerResolution
)
Public Function ExportMetafile (
    selected As Boolean,
    includeBackColor As Boolean,
    zeroOrigin As Boolean,
    keepZoom As Boolean,
    printerResolution As Boolean
) As Metafile
public:
Metafile^ ExportMetafile(
    bool selected,
    bool includeBackColor,
    bool zeroOrigin,
    bool keepZoom,
    bool printerResolution
)
member ExportMetafile :
        selected : bool *
        includeBackColor : bool *
        zeroOrigin : bool *
        keepZoom : bool *
        printerResolution : bool -> Metafile

Parameters

selected
Type: SystemBoolean
If True, then only the selected items are taken into account in the export. If false, all the diagram is exported.
includeBackColor
Type: SystemBoolean
If True, the backColor is taken into account.
zeroOrigin
Type: SystemBoolean
If True, then the origin (0,0) is considered as the left top most point of the diagram. If False, then the diagram starts at the left most top most item(node or link).
keepZoom
Type: SystemBoolean
If True, then the current zoom value is taken into account.
printerResolution
Type: SystemBoolean
If True, then the metafile is based on the printer resolution. If False, it is based on the video display resolution.

Return Value

Type: Metafile
A Metafile object
Remarks
If the grid is displayed in the AddFlow control, then it will be exported with the diagram. If you wish to avoid that, you can put the value of the ShowGrid property to False just before calling ExportMetafile and reset it after.
See Also

Reference

AddFlow Class
ExportMetafile Overload


AddFlow.GetDiagramSize Method

AddFlowGetDiagramSize Method
Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SizeF GetDiagramSize()
Public Function GetDiagramSize As SizeF
public:
SizeF GetDiagramSize()
member GetDiagramSize : unit -> SizeF

Return Value

Type: SizeF
The size of the diagram.
Remarks
Generally, this method returns the same information as the Extent property. However it recalculates the size of the rectangle just before returning it, which is not the case of the Extent property. This method can be useful in some cases where the diagram size has not been updated, for instance between the calls to the BeginUpdate and EndUpdate methods.
See Also

Reference

AddFlow Class


AddFlow.GetHitItem Method

AddFlowGetHitItem Method
Retrieves the item at the specified location.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item GetHitItem(
    Point pt
)
Public Function GetHitItem (
    pt As Point
) As Item
public:
Item^ GetHitItem(
    Point pt
)
member GetHitItem :
        pt : Point -> Item

Parameters

pt
Type: System.DrawingPoint
The Point to evaluate and retrieve the item from

Return Value

Type: Item
The item at the specified point
Remarks
The point is given in AddFlow coordinates.
See Also

Reference

AddFlow Class


AddFlow.GetItemsInRectangle Method

AddFlowGetItemsInRectangle Method
Overload List
 | Name | Description
Public method | GetItemsInRectangle(RectangleF) | Get the nodes and links placed in a rectangle.
Public method | GetItemsInRectangle(RectangleF, Boolean) | Get the nodes and links placed in a rectangle.
Top
See Also

Reference

AddFlow Class


AddFlow.GetItemsInRectangle Method (RectangleF)

AddFlowGetItemsInRectangle Method (RectangleF)
Get the nodes and links placed in a rectangle.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Item> GetItemsInRectangle(
    RectangleF selRectangle
)
Public Function GetItemsInRectangle (
    selRectangle As RectangleF
) As List(Of Item)
public:
List<Item^>^ GetItemsInRectangle(
    RectangleF selRectangle
)
member GetItemsInRectangle :
        selRectangle : RectangleF -> List<Item>

Parameters

selRectangle
Type: System.DrawingRectangleF
A rectangular portion of the diagram.

Return Value

Type: List Item
A list of items
Remarks
This version returns all the nodes and links that are partially contained in the rectangle.
See Also

Reference

AddFlow Class
GetItemsInRectangle Overload


AddFlow.GetItemsInRectangle Method (RectangleF, Boolean)

AddFlowGetItemsInRectangle Method (RectangleF, Boolean)
Get the nodes and links placed in a rectangle.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Item> GetItemsInRectangle(
    RectangleF selRectangle,
    bool partial
)
Public Function GetItemsInRectangle (
    selRectangle As RectangleF,
    partial As Boolean
) As List(Of Item)
public:
List<Item^>^ GetItemsInRectangle(
    RectangleF selRectangle,
    bool partial
)
member GetItemsInRectangle :
        selRectangle : RectangleF *
        partial : bool -> List<Item>

Parameters

selRectangle
Type: System.DrawingRectangleF
A rectangular portion of the diagram.
partial
Type: SystemBoolean
If True, it returns all the nodes and links that are partially contained in the rectangle. If False, it returns all the nodes and links that are completely contained in the rectangle.

Return Value

Type: List Item
A list of items
See Also

Reference

AddFlow Class
GetItemsInRectangle Overload


AddFlow.OnAfterAddCaption Method

AddFlowOnAfterAddCaption Method
Raises the AfterAddCaption event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterAddCaption(
    AfterAddCaptionEventArgs e
)
Protected Overridable Sub OnAfterAddCaption (
    e As AfterAddCaptionEventArgs
)
protected:
virtual void OnAfterAddCaption(
    AfterAddCaptionEventArgs^ e
)
abstract OnAfterAddCaption :
        e : AfterAddCaptionEventArgs -> unit
override OnAfterAddCaption :
        e : AfterAddCaptionEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterAddCaptionEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterAddCaption(Lassalle.Flow.AfterAddCaptionEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterAddLink Method

AddFlowOnAfterAddLink Method
Raises the AfterAddLink event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterAddLink(
    AfterAddLinkEventArgs e
)
Protected Overridable Sub OnAfterAddLink (
    e As AfterAddLinkEventArgs
)
protected:
virtual void OnAfterAddLink(
    AfterAddLinkEventArgs^ e
)
abstract OnAfterAddLink :
        e : AfterAddLinkEventArgs -> unit
override OnAfterAddLink :
        e : AfterAddLinkEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterAddLinkEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterAddLink(Lassalle.Flow.AfterAddLinkEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterAddNode Method

AddFlowOnAfterAddNode Method
Raises the AfterAddNode event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterAddNode(
    AfterAddNodeEventArgs e
)
Protected Overridable Sub OnAfterAddNode (
    e As AfterAddNodeEventArgs
)
protected:
virtual void OnAfterAddNode(
    AfterAddNodeEventArgs^ e
)
abstract OnAfterAddNode :
        e : AfterAddNodeEventArgs -> unit
override OnAfterAddNode :
        e : AfterAddNodeEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterAddNodeEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterAddNode(Lassalle.Flow.AfterAddNodeEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterChangeDst Method

AddFlowOnAfterChangeDst Method
Raises the AfterChangeDst event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterChangeDst(
    EventArgs e
)
Protected Overridable Sub OnAfterChangeDst (
    e As EventArgs
)
protected:
virtual void OnAfterChangeDst(
    EventArgs^ e
)
abstract OnAfterChangeDst :
        e : EventArgs -> unit
override OnAfterChangeDst :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterChangeDst(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterChangeOrg Method

AddFlowOnAfterChangeOrg Method
Raises the AfterChangeOrg event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterChangeOrg(
    EventArgs e
)
Protected Overridable Sub OnAfterChangeOrg (
    e As EventArgs
)
protected:
virtual void OnAfterChangeOrg(
    EventArgs^ e
)
abstract OnAfterChangeOrg :
        e : EventArgs -> unit
override OnAfterChangeOrg :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterChangeOrg(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterEdit Method

AddFlowOnAfterEdit Method
Raises the AfterEdit event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterEdit(
    AfterEditEventArgs e
)
Protected Overridable Sub OnAfterEdit (
    e As AfterEditEventArgs
)
protected:
virtual void OnAfterEdit(
    AfterEditEventArgs^ e
)
abstract OnAfterEdit :
        e : AfterEditEventArgs -> unit
override OnAfterEdit :
        e : AfterEditEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterEdit(Lassalle.Flow.AfterEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterMove Method

AddFlowOnAfterMove Method
Raises the AfterMove event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterMove(
    EventArgs e
)
Protected Overridable Sub OnAfterMove (
    e As EventArgs
)
protected:
virtual void OnAfterMove(
    EventArgs^ e
)
abstract OnAfterMove :
        e : EventArgs -> unit
override OnAfterMove :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterMove(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterRemoveCaption Method

AddFlowOnAfterRemoveCaption Method
Raises the AfterRemoveCaption event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterRemoveCaption(
    AfterRemoveCaptionEventArgs e
)
Protected Overridable Sub OnAfterRemoveCaption (
    e As AfterRemoveCaptionEventArgs
)
protected:
virtual void OnAfterRemoveCaption(
    AfterRemoveCaptionEventArgs^ e
)
abstract OnAfterRemoveCaption :
        e : AfterRemoveCaptionEventArgs -> unit
override OnAfterRemoveCaption :
        e : AfterRemoveCaptionEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterRemoveCaptionEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterRemoveCaption(Lassalle.Flow.AfterRemoveCaptionEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterRemoveLink Method

AddFlowOnAfterRemoveLink Method
Raises the AfterRemoveLink event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterRemoveLink(
    AfterRemoveLinkEventArgs e
)
Protected Overridable Sub OnAfterRemoveLink (
    e As AfterRemoveLinkEventArgs
)
protected:
virtual void OnAfterRemoveLink(
    AfterRemoveLinkEventArgs^ e
)
abstract OnAfterRemoveLink :
        e : AfterRemoveLinkEventArgs -> unit
override OnAfterRemoveLink :
        e : AfterRemoveLinkEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterRemoveLinkEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterRemoveLink(Lassalle.Flow.AfterRemoveLinkEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterRemoveNode Method

AddFlowOnAfterRemoveNode Method
Raises the AfterRemoveNode event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterRemoveNode(
    AfterRemoveNodeEventArgs e
)
Protected Overridable Sub OnAfterRemoveNode (
    e As AfterRemoveNodeEventArgs
)
protected:
virtual void OnAfterRemoveNode(
    AfterRemoveNodeEventArgs^ e
)
abstract OnAfterRemoveNode :
        e : AfterRemoveNodeEventArgs -> unit
override OnAfterRemoveNode :
        e : AfterRemoveNodeEventArgs -> unit

Parameters

e
Type: Lassalle.FlowAfterRemoveNodeEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterRemoveNode(Lassalle.Flow.AfterRemoveNodeEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterResize Method

AddFlowOnAfterResize Method
Raises the AfterResize event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterResize(
    EventArgs e
)
Protected Overridable Sub OnAfterResize (
    e As EventArgs
)
protected:
virtual void OnAfterResize(
    EventArgs^ e
)
abstract OnAfterResize :
        e : EventArgs -> unit
override OnAfterResize :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterResize(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterSelect Method

AddFlowOnAfterSelect Method
Raises the AfterSelect event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterSelect(
    EventArgs e
)
Protected Overridable Sub OnAfterSelect (
    e As EventArgs
)
protected:
virtual void OnAfterSelect(
    EventArgs^ e
)
abstract OnAfterSelect :
        e : EventArgs -> unit
override OnAfterSelect :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterSelect(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnAfterStretch Method

AddFlowOnAfterStretch Method
Raises the AfterStretch event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterStretch(
    EventArgs e
)
Protected Overridable Sub OnAfterStretch (
    e As EventArgs
)
protected:
virtual void OnAfterStretch(
    EventArgs^ e
)
abstract OnAfterStretch :
        e : EventArgs -> unit
override OnAfterStretch :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnAfterStretch(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeAddCaption Method

AddFlowOnBeforeAddCaption Method
Raises the BeforeAddCaption event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeAddCaption(
    BeforeAddCaptionEventArgs e
)
Protected Overridable Sub OnBeforeAddCaption (
    e As BeforeAddCaptionEventArgs
)
protected:
virtual void OnBeforeAddCaption(
    BeforeAddCaptionEventArgs^ e
)
abstract OnBeforeAddCaption :
        e : BeforeAddCaptionEventArgs -> unit
override OnBeforeAddCaption :
        e : BeforeAddCaptionEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeAddCaptionEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeAddCaption(Lassalle.Flow.BeforeAddCaptionEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeAddLink Method

AddFlowOnBeforeAddLink Method
Raises the BeforeAddLink event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeAddLink(
    BeforeAddLinkEventArgs e
)
Protected Overridable Sub OnBeforeAddLink (
    e As BeforeAddLinkEventArgs
)
protected:
virtual void OnBeforeAddLink(
    BeforeAddLinkEventArgs^ e
)
abstract OnBeforeAddLink :
        e : BeforeAddLinkEventArgs -> unit
override OnBeforeAddLink :
        e : BeforeAddLinkEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeAddLinkEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeAddLink(Lassalle.Flow.BeforeAddLinkEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeAddNode Method

AddFlowOnBeforeAddNode Method
Raises the BeforeAddNode event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeAddNode(
    BeforeAddNodeEventArgs e
)
Protected Overridable Sub OnBeforeAddNode (
    e As BeforeAddNodeEventArgs
)
protected:
virtual void OnBeforeAddNode(
    BeforeAddNodeEventArgs^ e
)
abstract OnBeforeAddNode :
        e : BeforeAddNodeEventArgs -> unit
override OnBeforeAddNode :
        e : BeforeAddNodeEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeAddNodeEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeAddNode(Lassalle.Flow.BeforeAddNodeEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeChangeDst Method

AddFlowOnBeforeChangeDst Method
Raises the BeforeChangeDst event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeChangeDst(
    BeforeChangeDstEventArgs e
)
Protected Overridable Sub OnBeforeChangeDst (
    e As BeforeChangeDstEventArgs
)
protected:
virtual void OnBeforeChangeDst(
    BeforeChangeDstEventArgs^ e
)
abstract OnBeforeChangeDst :
        e : BeforeChangeDstEventArgs -> unit
override OnBeforeChangeDst :
        e : BeforeChangeDstEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeChangeDstEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeChangeDst(Lassalle.Flow.BeforeChangeDstEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeChangeOrg Method

AddFlowOnBeforeChangeOrg Method
Raises the BeforeChangeOrg event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeChangeOrg(
    BeforeChangeOrgEventArgs e
)
Protected Overridable Sub OnBeforeChangeOrg (
    e As BeforeChangeOrgEventArgs
)
protected:
virtual void OnBeforeChangeOrg(
    BeforeChangeOrgEventArgs^ e
)
abstract OnBeforeChangeOrg :
        e : BeforeChangeOrgEventArgs -> unit
override OnBeforeChangeOrg :
        e : BeforeChangeOrgEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeChangeOrgEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeChangeOrg(Lassalle.Flow.BeforeChangeOrgEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeEdit Method

AddFlowOnBeforeEdit Method
Raises the BeforeEdit event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeEdit(
    BeforeEditEventArgs e
)
Protected Overridable Sub OnBeforeEdit (
    e As BeforeEditEventArgs
)
protected:
virtual void OnBeforeEdit(
    BeforeEditEventArgs^ e
)
abstract OnBeforeEdit :
        e : BeforeEditEventArgs -> unit
override OnBeforeEdit :
        e : BeforeEditEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeEdit(Lassalle.Flow.BeforeEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeRemoveCaption Method

AddFlowOnBeforeRemoveCaption Method
Raises the BeforeRemoveCaption event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeRemoveCaption(
    BeforeRemoveCaptionEventArgs e
)
Protected Overridable Sub OnBeforeRemoveCaption (
    e As BeforeRemoveCaptionEventArgs
)
protected:
virtual void OnBeforeRemoveCaption(
    BeforeRemoveCaptionEventArgs^ e
)
abstract OnBeforeRemoveCaption :
        e : BeforeRemoveCaptionEventArgs -> unit
override OnBeforeRemoveCaption :
        e : BeforeRemoveCaptionEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeRemoveCaptionEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeRemoveCaption(Lassalle.Flow.BeforeRemoveCaptionEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeRemoveLink Method

AddFlowOnBeforeRemoveLink Method
Raises the BeforeRemoveLink event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeRemoveLink(
    BeforeRemoveLinkEventArgs e
)
Protected Overridable Sub OnBeforeRemoveLink (
    e As BeforeRemoveLinkEventArgs
)
protected:
virtual void OnBeforeRemoveLink(
    BeforeRemoveLinkEventArgs^ e
)
abstract OnBeforeRemoveLink :
        e : BeforeRemoveLinkEventArgs -> unit
override OnBeforeRemoveLink :
        e : BeforeRemoveLinkEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeRemoveLinkEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeRemoveLink(Lassalle.Flow.BeforeRemoveLinkEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeRemoveNode Method

AddFlowOnBeforeRemoveNode Method
Raises the BeforeRemoveNode event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeRemoveNode(
    BeforeRemoveNodeEventArgs e
)
Protected Overridable Sub OnBeforeRemoveNode (
    e As BeforeRemoveNodeEventArgs
)
protected:
virtual void OnBeforeRemoveNode(
    BeforeRemoveNodeEventArgs^ e
)
abstract OnBeforeRemoveNode :
        e : BeforeRemoveNodeEventArgs -> unit
override OnBeforeRemoveNode :
        e : BeforeRemoveNodeEventArgs -> unit

Parameters

e
Type: Lassalle.FlowBeforeRemoveNodeEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnBeforeRemoveNode(Lassalle.Flow.BeforeRemoveNodeEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCancelEdit Method

AddFlowOnCancelEdit Method
Raises the CancelEdit event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCancelEdit(
    CancelEditEventArgs e
)
Protected Overridable Sub OnCancelEdit (
    e As CancelEditEventArgs
)
protected:
virtual void OnCancelEdit(
    CancelEditEventArgs^ e
)
abstract OnCancelEdit :
        e : CancelEditEventArgs -> unit
override OnCancelEdit :
        e : CancelEditEventArgs -> unit

Parameters

e
Type: Lassalle.FlowCancelEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnCancelEdit(Lassalle.Flow.CancelEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnDiagramOwnerDraw Method

AddFlowOnDiagramOwnerDraw Method
Raises the DiagramOwnerDraw event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnDiagramOwnerDraw(
    DiagramOwnerDrawEventArgs e
)
Protected Overridable Sub OnDiagramOwnerDraw (
    e As DiagramOwnerDrawEventArgs
)
protected:
virtual void OnDiagramOwnerDraw(
    DiagramOwnerDrawEventArgs^ e
)
abstract OnDiagramOwnerDraw :
        e : DiagramOwnerDrawEventArgs -> unit
override OnDiagramOwnerDraw :
        e : DiagramOwnerDrawEventArgs -> unit

Parameters

e
Type: Lassalle.FlowDiagramOwnerDrawEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnDiagramOwnerDraw(Lassalle.Flow.DiagramOwnerDrawEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnError Method

AddFlowOnError Method
Raises the Error event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnError(
    ErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As ErrorEventArgs
)
protected:
virtual void OnError(
    ErrorEventArgs^ e
)
abstract OnError :
        e : ErrorEventArgs -> unit
override OnError :
        e : ErrorEventArgs -> unit

Parameters

e
Type: Lassalle.FlowErrorEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnError(Lassalle.Flow.ErrorEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnExtentChange Method

AddFlowOnExtentChange Method
Raises the ExtentChange event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnExtentChange(
    EventArgs e
)
Protected Overridable Sub OnExtentChange (
    e As EventArgs
)
protected:
virtual void OnExtentChange(
    EventArgs^ e
)
abstract OnExtentChange :
        e : EventArgs -> unit
override OnExtentChange :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnExtentChange(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLinkOwnerDraw Method

AddFlowOnLinkOwnerDraw Method
Raises the LinkOwnerDraw event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnLinkOwnerDraw(
    LinkOwnerDrawEventArgs e
)
Protected Overridable Sub OnLinkOwnerDraw (
    e As LinkOwnerDrawEventArgs
)
protected:
virtual void OnLinkOwnerDraw(
    LinkOwnerDrawEventArgs^ e
)
abstract OnLinkOwnerDraw :
        e : LinkOwnerDrawEventArgs -> unit
override OnLinkOwnerDraw :
        e : LinkOwnerDrawEventArgs -> unit

Parameters

e
Type: Lassalle.FlowLinkOwnerDrawEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnLinkOwnerDraw(Lassalle.Flow.LinkOwnerDrawEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnMouseDown Method

AddFlowOnMouseDown Method
MouseDown event handler

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
abstract OnMouseDown :
        e : MouseEventArgs -> unit
override OnMouseDown :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs that contains the event data
See Also

Reference

AddFlow Class


AddFlow.OnMouseMove Method

AddFlowOnMouseMove Method
MouseMove event handler

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
abstract OnMouseMove :
        e : MouseEventArgs -> unit
override OnMouseMove :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs that contains the event data
See Also

Reference

AddFlow Class


AddFlow.OnMouseUp Method

AddFlowOnMouseUp Method
MouseUp event handler

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseUp(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
abstract OnMouseUp :
        e : MouseEventArgs -> unit
override OnMouseUp :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs that contains the event data
See Also

Reference

AddFlow Class


AddFlow.OnNodeOwnerDraw Method

AddFlowOnNodeOwnerDraw Method
Raises the NodeOwnerDraw event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnNodeOwnerDraw(
    ContentItemOwnerDrawEventArgs e
)
Protected Overridable Sub OnNodeOwnerDraw (
    e As ContentItemOwnerDrawEventArgs
)
protected:
virtual void OnNodeOwnerDraw(
    ContentItemOwnerDrawEventArgs^ e
)
abstract OnNodeOwnerDraw :
        e : ContentItemOwnerDrawEventArgs -> unit
override OnNodeOwnerDraw :
        e : ContentItemOwnerDrawEventArgs -> unit

Parameters

e
Type: Lassalle.FlowContentItemOwnerDrawEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnNodeOwnerDraw(Lassalle.Flow.ContentItemOwnerDrawEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnPaint Method

AddFlowOnPaint Method
Paint event handler

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parameters

e
Type: System.Windows.FormsPaintEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnResize Method

AddFlowOnResize Method
Resize event handler

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnResize(
    EventArgs e
)
Protected Overrides Sub OnResize (
    e As EventArgs
)
protected:
virtual void OnResize(
    EventArgs^ e
) override
abstract OnResize :
        e : EventArgs -> unit
override OnResize :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnResize(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnScrollPositionChange Method

AddFlowOnScrollPositionChange Method
Raises the ScrollPositionChange event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnScrollPositionChange(
    EventArgs e
)
Protected Overridable Sub OnScrollPositionChange (
    e As EventArgs
)
protected:
virtual void OnScrollPositionChange(
    EventArgs^ e
)
abstract OnScrollPositionChange :
        e : EventArgs -> unit
override OnScrollPositionChange :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnScrollPositionChange(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectedItemsLayouting Method

AddFlowOnSelectedItemsLayouting Method
Raises the SelectedItemsLayouting event. Cancelling the action aborts the resizing or moving action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectedItemsLayouting(
    SelectedItemsLayoutingEventArgs e
)
Protected Overridable Sub OnSelectedItemsLayouting (
    e As SelectedItemsLayoutingEventArgs
)
protected:
virtual void OnSelectedItemsLayouting(
    SelectedItemsLayoutingEventArgs^ e
)
abstract OnSelectedItemsLayouting :
        e : SelectedItemsLayoutingEventArgs -> unit
override OnSelectedItemsLayouting :
        e : SelectedItemsLayoutingEventArgs -> unit

Parameters

e
Type: Lassalle.FlowSelectedItemsLayoutingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnSelectedItemsLayouting(Lassalle.Flow.SelectedItemsLayoutingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectedLinkStretching Method

AddFlowOnSelectedLinkStretching Method
Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectedLinkStretching(
    SelectedLinkStretchingEventArgs e
)
Protected Overridable Sub OnSelectedLinkStretching (
    e As SelectedLinkStretchingEventArgs
)
protected:
virtual void OnSelectedLinkStretching(
    SelectedLinkStretchingEventArgs^ e
)
abstract OnSelectedLinkStretching :
        e : SelectedLinkStretchingEventArgs -> unit
override OnSelectedLinkStretching :
        e : SelectedLinkStretchingEventArgs -> unit

Parameters

e
Type: Lassalle.FlowSelectedLinkStretchingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnSelectedLinkStretching(Lassalle.Flow.SelectedLinkStretchingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectionChange Method

AddFlowOnSelectionChange Method
Raises the SelectionChange event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectionChange(
    SelectionChangeArgs e
)
Protected Overridable Sub OnSelectionChange (
    e As SelectionChangeArgs
)
protected:
virtual void OnSelectionChange(
    SelectionChangeArgs^ e
)
abstract OnSelectionChange :
        e : SelectionChangeArgs -> unit
override OnSelectionChange :
        e : SelectionChangeArgs -> unit

Parameters

e
Type: Lassalle.FlowSelectionChangeArgs

[Missing <param name="e"/> documentation for "M:Lassalle.Flow.AddFlow.OnSelectionChange(Lassalle.Flow.SelectionChangeArgs)"]

See Also

Reference

AddFlow Class


AddFlow.PointFToAddFlow Method

AddFlowPointFToAddFlow Method
Convert a PointF object in device coordinates to AddFlow coordinates

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PointF PointFToAddFlow(
    PointF pt
)
Public Function PointFToAddFlow (
    pt As PointF
) As PointF
public:
PointF PointFToAddFlow(
    PointF pt
)
member PointFToAddFlow :
        pt : PointF -> PointF

Parameters

pt
Type: System.DrawingPointF
The PointF object in device coordinates

Return Value

Type: PointF
The PointF object in addflow coordinates
See Also

Reference

AddFlow Class


AddFlow.PointFToDevice Method

AddFlowPointFToDevice Method
Convert a PointF object in AddFlow coordinates to device coordinates

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PointF PointFToDevice(
    PointF pt
)
Public Function PointFToDevice (
    pt As PointF
) As PointF
public:
PointF PointFToDevice(
    PointF pt
)
member PointFToDevice :
        pt : PointF -> PointF

Parameters

pt
Type: System.DrawingPointF
The PointF object in AddFlow coordinates

Return Value

Type: PointF
The PointF object in device coordinates
See Also

Reference

AddFlow Class


AddFlow.PointToAddFlow Method

AddFlowPointToAddFlow Method
Convert a Point object in device coordinates to AddFlow coordinates

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Point PointToAddFlow(
    Point pt
)
Public Function PointToAddFlow (
    pt As Point
) As Point
public:
Point PointToAddFlow(
    Point pt
)
member PointToAddFlow :
        pt : Point -> Point

Parameters

pt
Type: System.DrawingPoint
The Point object in device coordinates

Return Value

Type: Point
The Point object in addflow coordinates
See Also

Reference

AddFlow Class


AddFlow.PointToDevice Method

AddFlowPointToDevice Method
Convert a Point object in AddFlow coordinates to device coordinates

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Point PointToDevice(
    Point pt
)
Public Function PointToDevice (
    pt As Point
) As Point
public:
Point PointToDevice(
    Point pt
)
member PointToDevice :
        pt : Point -> Point

Parameters

pt
Type: System.DrawingPoint
The Point object in AddFlow coordinates

Return Value

Type: Point
The Point object in device coordinates
See Also

Reference

AddFlow Class


AddFlow.RemoveCaption Method

AddFlowRemoveCaption Method
Remove the specified caption from the AddFlow control

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCaption(
    Caption caption
)
Public Sub RemoveCaption (
    caption As Caption
)
public:
void RemoveCaption(
    Caption^ caption
)
member RemoveCaption :
        caption : Caption -> unit

Parameters

caption
Type: Lassalle.FlowCaption
The caption to be removed
See Also

Reference

AddFlow Class


AddFlow.RemoveLink Method

AddFlowRemoveLink Method
Removes the specified link from the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLink(
    Link link
)
Public Sub RemoveLink (
    link As Link
)
public:
void RemoveLink(
    Link^ link
)
member RemoveLink :
        link : Link -> unit

Parameters

link
Type: Lassalle.FlowLink
The link to be removed from the diagram.
See Also

Reference

AddFlow Class


AddFlow.RemoveNode Method

AddFlowRemoveNode Method
Removes the specified node from the Nodes collection. The links attached to the node are also removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveNode(
    Node node
)
Public Sub RemoveNode (
    node As Node
)
public:
void RemoveNode(
    Node^ node
)
member RemoveNode :
        node : Node -> unit

Parameters

node
Type: Lassalle.FlowNode
The node to be removed from the collection
See Also

Reference

AddFlow Class


AddFlow.Render Method

AddFlowRender Method
Display the diagram in a GDI+ drawing area

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Render(
    Graphics grfx
)
Public Sub Render (
    grfx As Graphics
)
public:
void Render(
    Graphics^ grfx
)
member Render :
        grfx : Graphics -> unit

Parameters

grfx
Type: System.DrawingGraphics
A GDI+ drawing area
See Also

Reference

AddFlow Class


AddFlow.ResetChangedFlag Method

AddFlowResetChangedFlag Method
Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetChangedFlag()
Public Sub ResetChangedFlag
public:
void ResetChangedFlag()
member ResetChangedFlag : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SelectAll Method

AddFlowSelectAll Method
Selects all the items of the diagram

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SetSelChangedFlag Method

AddFlowSetSelChangedFlag Method
Allow to set a flag indicating that the selection has changed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelChangedFlag(
    bool selChanged
)
Public Sub SetSelChangedFlag (
    selChanged As Boolean
)
public:
void SetSelChangedFlag(
    bool selChanged
)
member SetSelChangedFlag :
        selChanged : bool -> unit

Parameters

selChanged
Type: SystemBoolean
True if you want to indicate that the diagram selection has changed else False.
See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeBezierSelectionLineColor Method

AddFlowShouldSerializeBezierSelectionLineColor Method
Returns true if BezierSelectionLineColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBezierSelectionLineColor()
Public Function ShouldSerializeBezierSelectionLineColor As Boolean
public:
bool ShouldSerializeBezierSelectionLineColor()
member ShouldSerializeBezierSelectionLineColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeBezierSelectionLineColor"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeCaptionModel Method

AddFlowShouldSerializeCaptionModel Method
Returns true if CaptionModel should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeCaptionModel()
Public Function ShouldSerializeCaptionModel As Boolean
public:
bool ShouldSerializeCaptionModel()
member ShouldSerializeCaptionModel : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeCaptionModel"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeGridColor Method

AddFlowShouldSerializeGridColor Method
Returns true if GridColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeGridColor()
Public Function ShouldSerializeGridColor As Boolean
public:
bool ShouldSerializeGridColor()
member ShouldSerializeGridColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeGridColor"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeGridSize Method

AddFlowShouldSerializeGridSize Method
Returns true if GridSize should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeGridSize()
Public Function ShouldSerializeGridSize As Boolean
public:
bool ShouldSerializeGridSize()
member ShouldSerializeGridSize : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeGridSize"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeHandleColor1 Method

AddFlowShouldSerializeHandleColor1 Method
Returns true if HandleColor1 has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHandleColor1()
Public Function ShouldSerializeHandleColor1 As Boolean
public:
bool ShouldSerializeHandleColor1()
member ShouldSerializeHandleColor1 : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeHandleColor1"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeHandleColor2 Method

AddFlowShouldSerializeHandleColor2 Method
Returns true if HandleColor2 has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHandleColor2()
Public Function ShouldSerializeHandleColor2 As Boolean
public:
bool ShouldSerializeHandleColor2()
member ShouldSerializeHandleColor2 : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeHandleColor2"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeHandleDrawColor Method

AddFlowShouldSerializeHandleDrawColor Method
Returns true if HandleDrawColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHandleDrawColor()
Public Function ShouldSerializeHandleDrawColor As Boolean
public:
bool ShouldSerializeHandleDrawColor()
member ShouldSerializeHandleDrawColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeHandleDrawColor"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeLinkModel Method

AddFlowShouldSerializeLinkModel Method
Returns true if LinkModel should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLinkModel()
Public Function ShouldSerializeLinkModel As Boolean
public:
bool ShouldSerializeLinkModel()
member ShouldSerializeLinkModel : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeLinkModel"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializeNodeModel Method

AddFlowShouldSerializeNodeModel Method
Returns true if NodeModel should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeNodeModel()
Public Function ShouldSerializeNodeModel As Boolean
public:
bool ShouldSerializeNodeModel()
member ShouldSerializeNodeModel : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializeNodeModel"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializePinColor1 Method

AddFlowShouldSerializePinColor1 Method
Returns true if PinColor1 has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePinColor1()
Public Function ShouldSerializePinColor1 As Boolean
public:
bool ShouldSerializePinColor1()
member ShouldSerializePinColor1 : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializePinColor1"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializePinColor2 Method

AddFlowShouldSerializePinColor2 Method
Returns true if PinColor2 has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePinColor2()
Public Function ShouldSerializePinColor2 As Boolean
public:
bool ShouldSerializePinColor2()
member ShouldSerializePinColor2 : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializePinColor2"]

See Also

Reference

AddFlow Class


AddFlow.ShouldSerializePinDrawColor Method

AddFlowShouldSerializePinDrawColor Method
Returns true if PinDrawColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePinDrawColor()
Public Function ShouldSerializePinDrawColor As Boolean
public:
bool ShouldSerializePinDrawColor()
member ShouldSerializePinDrawColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlow.ShouldSerializePinDrawColor"]

See Also

Reference

AddFlow Class


AddFlow.UnselectAll Method

AddFlowUnselectAll Method
Command that unselects all the items of the diagram

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void UnselectAll()
Public Sub UnselectAll
public:
void UnselectAll()
member UnselectAll : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.ZoomPoint Method

AddFlowZoomPoint Method
Zoom the diagram and center it on a point.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ZoomPoint(
    PointF point,
    float zoom
)
Public Sub ZoomPoint (
    point As PointF,
    zoom As Single
)
public:
void ZoomPoint(
    PointF point,
    float zoom
)
member ZoomPoint :
        point : PointF *
        zoom : float32 -> unit

Parameters

point
Type: System.DrawingPointF
The zoom center point
zoom
Type: SystemSingle
The zoom factor
See Also

Reference

AddFlow Class


AddFlow.ZoomRectangle Method

AddFlowZoomRectangle Method
Zoom a rectangular portion of the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ZoomRectangle(
    RectangleF zoomRectangle
)
Public Sub ZoomRectangle (
    zoomRectangle As RectangleF
)
public:
void ZoomRectangle(
    RectangleF zoomRectangle
)
member ZoomRectangle :
        zoomRectangle : RectangleF -> unit

Parameters

zoomRectangle
Type: System.DrawingRectangleF
A rectangular portion of the diagram.
See Also

Reference

AddFlow Class


AddFlow Properties

AddFlow Properties

The AddFlow type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BezierSelectionLineColor | Returns/sets the drawing color of the lines used for selected bezier links
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanChangeDst | Determines whether the user can interactively change the destination of a link.
Public property | CanChangeOrg | Determines whether the user can interactively change the origin of a link.
Public property | CanDragScroll | Determines whether drag scrolling is allowed or not.
Public property | CanDrawCaption | Determines whether interactive creation of captions is allowed or not.
Public property | CanDrawLink | Determines whether interactive creation of links is allowed or not.
Public property | CanDrawNode | Determines whether interactive creation of nodes is allowed or not.
Public property | CanEditContentItem | Determines whether the user can edit the text of ContentItem objects.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFireError | Determines if the error event is fired or not.
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanMoveItems | Determines whether interactive dragging of items is allowed or not.
Public property | CanMultiLink | Determines whether you can create several links between two nodes or not.
Public property | CanMultiSelect | Determines whether multiselection mode of nodes and links is allowed or not.
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public property | CanShowTooltips | Determines whether the tooltips are displayed or not.
Public property | CanSizeItems | Determines whether you can resize items interactively or not.
Public property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.
Public property | CaptionModel | Returns a Caption object that contains the default property values for captions. When a caption is created, it receives these property values.
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CursorSetting | Returns/sets a value that determines whether default cursors are displayed.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Extent | Returns the diagram size.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GridColor | Returns/sets the grid color.
Public property | GridDraw | Determines whether the grid is displayed or not.
Public property | GridSize | Returns/sets the horizontal and vertical grid size.
Public property | GridSnap | Determines whether nodes are aligned on the grid.
Public property | GridStyle | Returns/sets the grid style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleColor1 | Returns/sets a value which defines the first color used for the brush of the selection handles.
Public property | HandleColor2 | Returns/sets a value which defines the second color used for the brush of the selection handles.
Public property | HandleDrawColor | Returns/sets a value which defines the color used for the pen of the selection handles.
Public property | HandleSize | Returns/sets a value which defines the size of the selection handles of the selected node or link
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HitArea | Returns the area pointed by the mouse: sizing square, stretching square, linking square, node, over no special area.
Public property | HitItem | Returns the item (node or link) pointed by the mouse.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsChanged | Indicates if the AddFlow diagram has changed.
Public property | IsCreatingCaption | Indicates if the user is currently creating a caption
Public property | IsCreatingLink | Indicates if the user is currently creating a link
Public property | IsCreatingNode | Indicates if the user is currently creating a node
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInPlaceEditing | Indicates if the user is currently editing the text of a ContentItem object
Public property | IsInteractiveEventsOnly | Determines whether events can occur only with interactive actions.
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsMoving | Indicates if the user is currently moving nodes
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for the diagram.
Public property | IsPanning | Indicates if the user is currently panning the diagram
Public property | IsQuadtree | Determines whether a Quadtree structure is used to improve speed when the diagram is big
Public property | IsResizing | Indicates if the user is currently resising nodes
Public property | IsSelChanged | Indicates if the selection in the AddFlow diagram has changed.
Public property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public property | IsSelectionChangeEventFired | Determines whether the SelectionChange event is fired or not.
Public property | IsSelectionHandleDisplayed | Determines whether the handles used for selection are displayed or not.
Public property | IsStretchingLink | Indicates if the user is currently stretching a link
Public property | IsZooming | Indicates if the user is currently zooming the diagram
Public property | Items | Returns the collection of all the items of the diagram.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | LicenseKey |
Public property | LinkModel | Returns a Link object that contains the default property values for links. When a link is created, it receives these property values.
Public property | LinkSelectionAreaWidth | Returns/sets a value that determines the width of the area where the user has to click to select a link.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseAction | Returns/sets the current interactive action (select items, zoom,...).
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NodeModel | Returns a Node object that contains the default property values for nodes. When a node is created, it receives these property values.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageScale | Returns/sets a value that determines the scaling used to display the graph.
Public property | PageUnit | Returns/sets a value that determines the unit of measure used to display the graph.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PinColor1 | Returns/sets a value which defines the first color used for the brush of the node pins.
Public property | PinColor2 | Returns/sets a value which defines the second color used for the brush of the node pins.
Public property | PinDrawColor | Returns/sets a value which defines the color used for the pen of the node pins.
Public property | PinSize | Returns/sets a value which defines the size of the node pins.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Properties | Returns the PropertyBag instance associated to the AddFlow control
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollbarsDisplayMode | Returns/sets the scrollbars display mode
Public property | ScrollPosition | Returns/sets the scrolling offset.
Public property | SelectedItems | Returns the collection of all the selected items of the diagram.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchingPoint | Returns the index of the current stretching point.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Returns/sets the zoom factor.
Top
See Also

Reference

AddFlow Class


AddFlow.BezierSelectionLineColor Property

AddFlowBezierSelectionLineColor Property
Returns/sets the drawing color of the lines used for selected bezier links

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color BezierSelectionLineColor { get; set; }
Public Property BezierSelectionLineColor As Color
    Get
    Set
public:
property Color BezierSelectionLineColor {
    Color get ();
    void set (Color value);
}
member BezierSelectionLineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.CanChangeDst Property

AddFlowCanChangeDst Property
Determines whether the user can interactively change the destination of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeDst { get; set; }
Public Property CanChangeDst As Boolean
    Get
    Set
public:
property bool CanChangeDst {
    bool get ();
    void set (bool value);
}
member CanChangeDst : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanChangeOrg Property

AddFlowCanChangeOrg Property
Determines whether the user can interactively change the origin of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeOrg { get; set; }
Public Property CanChangeOrg As Boolean
    Get
    Set
public:
property bool CanChangeOrg {
    bool get ();
    void set (bool value);
}
member CanChangeOrg : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanDragScroll Property

AddFlowCanDragScroll Property
Determines whether drag scrolling is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDragScroll { get; set; }
Public Property CanDragScroll As Boolean
    Get
    Set
public:
property bool CanDragScroll {
    bool get ();
    void set (bool value);
}
member CanDragScroll : bool with get, set

Property Value

Type: Boolean
Remarks
Drag scrolling means for instance that when the user moves a node out of the visible part of the control, the control scrolls automatically so that the node stays visible.
See Also

Reference

AddFlow Class


AddFlow.CanDrawCaption Property

AddFlowCanDrawCaption Property
Determines whether interactive creation of captions is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawCaption { get; set; }
Public Property CanDrawCaption As Boolean
    Get
    Set
public:
property bool CanDrawCaption {
    bool get ();
    void set (bool value);
}
member CanDrawCaption : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanDrawLink Property

AddFlowCanDrawLink Property
Determines whether interactive creation of links is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawLink { get; set; }
Public Property CanDrawLink As Boolean
    Get
    Set
public:
property bool CanDrawLink {
    bool get ();
    void set (bool value);
}
member CanDrawLink : bool with get, set

Property Value

Type: Boolean
Remarks
If the value of this property is False, then the handle at the middle of the node is not displayed.
See Also

Reference

AddFlow Class


AddFlow.CanDrawNode Property

AddFlowCanDrawNode Property
Determines whether interactive creation of nodes is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawNode { get; set; }
Public Property CanDrawNode As Boolean
    Get
    Set
public:
property bool CanDrawNode {
    bool get ();
    void set (bool value);
}
member CanDrawNode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanEditContentItem Property

AddFlowCanEditContentItem Property
Determines whether the user can edit the text of ContentItem objects.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEditContentItem { get; set; }
Public Property CanEditContentItem As Boolean
    Get
    Set
public:
property bool CanEditContentItem {
    bool get ();
    void set (bool value);
}
member CanEditContentItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanFireError Property

AddFlowCanFireError Property
Determines if the error event is fired or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFireError { get; set; }
Public Property CanFireError As Boolean
    Get
    Set
public:
property bool CanFireError {
    bool get ();
    void set (bool value);
}
member CanFireError : bool with get, set

Property Value

Type: Boolean
Remarks
For instance, suppose that your diagram has two nodes A and B and a link from A to B. Suppose also that the CanMultiLink property is false. If the user draws a new link from A to B, the link will not be created because CanMultiLink is false. If CanFireError is true, an Error event is fired and by default, this causes an error message box to be displayed (this default behaviour can be modified). If CanFireError is false, no event is fired. The user just sees that the link is not created.
See Also

Reference

AddFlow Class


AddFlow.CanMoveItems Property

AddFlowCanMoveItems Property
Determines whether interactive dragging of items is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveItems { get; set; }
Public Property CanMoveItems As Boolean
    Get
    Set
public:
property bool CanMoveItems {
    bool get ();
    void set (bool value);
}
member CanMoveItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanMultiLink Property

AddFlowCanMultiLink Property
Determines whether you can create several links between two nodes or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMultiLink { get; set; }
Public Property CanMultiLink As Boolean
    Get
    Set
public:
property bool CanMultiLink {
    bool get ();
    void set (bool value);
}
member CanMultiLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanMultiSelect Property

AddFlowCanMultiSelect Property
Determines whether multiselection mode of nodes and links is allowed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMultiSelect { get; set; }
Public Property CanMultiSelect As Boolean
    Get
    Set
public:
property bool CanMultiSelect {
    bool get ();
    void set (bool value);
}
member CanMultiSelect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanReflexLink Property

AddFlowCanReflexLink Property
Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanReflexLink { get; set; }
Public Property CanReflexLink As Boolean
    Get
    Set
public:
property bool CanReflexLink {
    bool get ();
    void set (bool value);
}
member CanReflexLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanShowJumps Property

AddFlowCanShowJumps Property
Determines whether jumps are displayed at the intersection of links. The default value is false.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowJumps { get; set; }
Public Property CanShowJumps As Boolean
    Get
    Set
public:
property bool CanShowJumps {
    bool get ();
    void set (bool value);
}
member CanShowJumps : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanShowTooltips Property

AddFlowCanShowTooltips Property
Determines whether the tooltips are displayed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowTooltips { get; set; }
Public Property CanShowTooltips As Boolean
    Get
    Set
public:
property bool CanShowTooltips {
    bool get ();
    void set (bool value);
}
member CanShowTooltips : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanSizeItems Property

AddFlowCanSizeItems Property
Determines whether you can resize items interactively or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSizeItems { get; set; }
Public Property CanSizeItems As Boolean
    Get
    Set
public:
property bool CanSizeItems {
    bool get ();
    void set (bool value);
}
member CanSizeItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanStretchLink Property

AddFlowCanStretchLink Property
Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStretchLink { get; set; }
Public Property CanStretchLink As Boolean
    Get
    Set
public:
property bool CanStretchLink {
    bool get ();
    void set (bool value);
}
member CanStretchLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CaptionModel Property

AddFlowCaptionModel Property
Returns a Caption object that contains the default property values for captions. When a caption is created, it receives these property values.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption CaptionModel { get; set; }
Public Property CaptionModel As Caption
    Get
    Set
public:
property Caption^ CaptionModel {
    Caption^ get ();
    void set (Caption^ value);
}
member CaptionModel : Caption with get, set

Property Value

Type: Caption
See Also

Reference

AddFlow Class


AddFlow.CursorSetting Property

AddFlowCursorSetting Property
Returns/sets a value that determines whether default cursors are displayed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CursorSetting CursorSetting { get; set; }
Public Property CursorSetting As CursorSetting
    Get
    Set
public:
property CursorSetting CursorSetting {
    CursorSetting get ();
    void set (CursorSetting value);
}
member CursorSetting : CursorSetting with get, set

Property Value

Type: CursorSetting
See Also

Reference

AddFlow Class


AddFlow.Extent Property

AddFlowExtent Property
Returns the diagram size.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SizeF Extent { get; }
Public ReadOnly Property Extent As SizeF
    Get
public:
property SizeF Extent {
    SizeF get ();
}
member Extent : SizeF with get

Property Value

Type: SizeF
See Also

Reference

AddFlow Class


AddFlow.GridColor Property

AddFlowGridColor Property
Returns/sets the grid color.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color GridColor {
    Color get ();
    void set (Color value);
}
member GridColor : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.GridDraw Property

AddFlowGridDraw Property
Determines whether the grid is displayed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GridDraw { get; set; }
Public Property GridDraw As Boolean
    Get
    Set
public:
property bool GridDraw {
    bool get ();
    void set (bool value);
}
member GridDraw : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.GridSize Property

AddFlowGridSize Property
Returns/sets the horizontal and vertical grid size.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Size GridSize { get; set; }
Public Property GridSize As Size
    Get
    Set
public:
property Size GridSize {
    Size get ();
    void set (Size value);
}
member GridSize : Size with get, set

Property Value

Type: Size
See Also

Reference

AddFlow Class


AddFlow.GridSnap Property

AddFlowGridSnap Property
Determines whether nodes are aligned on the grid.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool GridSnap { get; set; }
Public Property GridSnap As Boolean
    Get
    Set
public:
property bool GridSnap {
    bool get ();
    void set (bool value);
}
member GridSnap : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.GridStyle Property

AddFlowGridStyle Property
Returns/sets the grid style.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GridStyle GridStyle { get; set; }
Public Property GridStyle As GridStyle
    Get
    Set
public:
property GridStyle GridStyle {
    GridStyle get ();
    void set (GridStyle value);
}
member GridStyle : GridStyle with get, set

Property Value

Type: GridStyle
See Also

Reference

AddFlow Class


AddFlow.HandleColor1 Property

AddFlowHandleColor1 Property
Returns/sets a value which defines the first color used for the brush of the selection handles.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color HandleColor1 { get; set; }
Public Property HandleColor1 As Color
    Get
    Set
public:
property Color HandleColor1 {
    Color get ();
    void set (Color value);
}
member HandleColor1 : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.HandleColor2 Property

AddFlowHandleColor2 Property
Returns/sets a value which defines the second color used for the brush of the selection handles.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color HandleColor2 { get; set; }
Public Property HandleColor2 As Color
    Get
    Set
public:
property Color HandleColor2 {
    Color get ();
    void set (Color value);
}
member HandleColor2 : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.HandleDrawColor Property

AddFlowHandleDrawColor Property
Returns/sets a value which defines the color used for the pen of the selection handles.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color HandleDrawColor { get; set; }
Public Property HandleDrawColor As Color
    Get
    Set
public:
property Color HandleDrawColor {
    Color get ();
    void set (Color value);
}
member HandleDrawColor : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.HandleSize Property

AddFlowHandleSize Property
Returns/sets a value which defines the size of the selection handles of the selected node or link

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float HandleSize { get; set; }
Public Property HandleSize As Single
    Get
    Set
public:
property float HandleSize {
    float get ();
    void set (float value);
}
member HandleSize : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow.HitArea Property

AddFlowHitArea Property
Returns the area pointed by the mouse: sizing square, stretching square, linking square, node, over no special area.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public MouseArea HitArea { get; }
Public ReadOnly Property HitArea As MouseArea
    Get
public:
property MouseArea HitArea {
    MouseArea get ();
}
member HitArea : MouseArea with get

Property Value

Type: MouseArea
See Also

Reference

AddFlow Class


AddFlow.HitItem Property

AddFlowHitItem Property
Returns the item (node or link) pointed by the mouse.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item HitItem { get; }
Public ReadOnly Property HitItem As Item
    Get
public:
property Item^ HitItem {
    Item^ get ();
}
member HitItem : Item with get

Property Value

Type: Item
See Also

Reference

AddFlow Class


AddFlow.IsChanged Property

AddFlowIsChanged Property
Indicates if the AddFlow diagram has changed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsChanged { get; }
Public ReadOnly Property IsChanged As Boolean
    Get
public:
property bool IsChanged {
    bool get ();
}
member IsChanged : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingCaption Property

AddFlowIsCreatingCaption Property
Indicates if the user is currently creating a caption

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingCaption { get; }
Public ReadOnly Property IsCreatingCaption As Boolean
    Get
public:
property bool IsCreatingCaption {
    bool get ();
}
member IsCreatingCaption : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingLink Property

AddFlowIsCreatingLink Property
Indicates if the user is currently creating a link

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingLink { get; }
Public ReadOnly Property IsCreatingLink As Boolean
    Get
public:
property bool IsCreatingLink {
    bool get ();
}
member IsCreatingLink : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingNode Property

AddFlowIsCreatingNode Property
Indicates if the user is currently creating a node

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingNode { get; }
Public ReadOnly Property IsCreatingNode As Boolean
    Get
public:
property bool IsCreatingNode {
    bool get ();
}
member IsCreatingNode : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsInPlaceEditing Property

AddFlowIsInPlaceEditing Property
Indicates if the user is currently editing the text of a ContentItem object

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInPlaceEditing { get; }
Public ReadOnly Property IsInPlaceEditing As Boolean
    Get
public:
property bool IsInPlaceEditing {
    bool get ();
}
member IsInPlaceEditing : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsInteractiveEventsOnly Property

AddFlowIsInteractiveEventsOnly Property
Determines whether events can occur only with interactive actions.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInteractiveEventsOnly { get; set; }
Public Property IsInteractiveEventsOnly As Boolean
    Get
    Set
public:
property bool IsInteractiveEventsOnly {
    bool get ();
    void set (bool value);
}
member IsInteractiveEventsOnly : bool with get, set

Property Value

Type: Boolean
Remarks
If this property is true, events occured only with interactive events (Mouse events, keybord events, node or link creation with the mouse, etc...). If this property is false, then events can occur also with programmatic actions: for instance, if a node is added programmaticaly, the BeforeAddNode and the AfterAddNode events will be fired.
See Also

Reference

AddFlow Class


AddFlow.IsMoving Property

AddFlowIsMoving Property
Indicates if the user is currently moving nodes

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMoving { get; }
Public ReadOnly Property IsMoving As Boolean
    Get
public:
property bool IsMoving {
    bool get ();
}
member IsMoving : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsOwnerDraw Property

AddFlowIsOwnerDraw Property
Determines whether you want to provide custom drawing for the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOwnerDraw { get; set; }
Public Property IsOwnerDraw As Boolean
    Get
    Set
public:
property bool IsOwnerDraw {
    bool get ();
    void set (bool value);
}
member IsOwnerDraw : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsPanning Property

AddFlowIsPanning Property
Indicates if the user is currently panning the diagram

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPanning { get; }
Public ReadOnly Property IsPanning As Boolean
    Get
public:
property bool IsPanning {
    bool get ();
}
member IsPanning : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsQuadtree Property

AddFlowIsQuadtree Property
Determines whether a Quadtree structure is used to improve speed when the diagram is big

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsQuadtree { get; set; }
Public Property IsQuadtree As Boolean
    Get
    Set
public:
property bool IsQuadtree {
    bool get ();
    void set (bool value);
}
member IsQuadtree : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsResizing Property

AddFlowIsResizing Property
Indicates if the user is currently resising nodes

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsResizing { get; }
Public ReadOnly Property IsResizing As Boolean
    Get
public:
property bool IsResizing {
    bool get ();
}
member IsResizing : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsSelChanged Property

AddFlowIsSelChanged Property
Indicates if the selection in the AddFlow diagram has changed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelChanged { get; }
Public ReadOnly Property IsSelChanged As Boolean
    Get
public:
property bool IsSelChanged {
    bool get ();
}
member IsSelChanged : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsSelecting Property

AddFlowIsSelecting Property
Indicates if the user is currently selecting items with the mouse

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelecting { get; }
Public ReadOnly Property IsSelecting As Boolean
    Get
public:
property bool IsSelecting {
    bool get ();
}
member IsSelecting : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsSelectionChangeEventFired Property

AddFlowIsSelectionChangeEventFired Property
Determines whether the SelectionChange event is fired or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectionChangeEventFired { get; set; }
Public Property IsSelectionChangeEventFired As Boolean
    Get
    Set
public:
property bool IsSelectionChangeEventFired {
    bool get ();
    void set (bool value);
}
member IsSelectionChangeEventFired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsSelectionHandleDisplayed Property

AddFlowIsSelectionHandleDisplayed Property
Determines whether the handles used for selection are displayed or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectionHandleDisplayed { get; set; }
Public Property IsSelectionHandleDisplayed As Boolean
    Get
    Set
public:
property bool IsSelectionHandleDisplayed {
    bool get ();
    void set (bool value);
}
member IsSelectionHandleDisplayed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsStretchingLink Property

AddFlowIsStretchingLink Property
Indicates if the user is currently stretching a link

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStretchingLink { get; }
Public ReadOnly Property IsStretchingLink As Boolean
    Get
public:
property bool IsStretchingLink {
    bool get ();
}
member IsStretchingLink : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsZooming Property

AddFlowIsZooming Property
Indicates if the user is currently zooming the diagram

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsZooming { get; }
Public ReadOnly Property IsZooming As Boolean
    Get
public:
property bool IsZooming {
    bool get ();
}
member IsZooming : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.Items Property

AddFlowItems Property
Returns the collection of all the items of the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Item> Items { get; }
Public ReadOnly Property Items As List(Of Item)
    Get
public:
property List<Item^>^ Items {
    List<Item^>^ get ();
}
member Items : List<Item> with get

Property Value

Type: List Item
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. You may however use this property for enumeration purposes.
See Also

Reference

AddFlow Class


AddFlow.LicenseKey Property

AddFlowLicenseKey Property

[Missing <summary> documentation for "P:Lassalle.Flow.AddFlow.LicenseKey"]

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public static string LicenseKey { set; }
Public Shared WriteOnly Property LicenseKey As String
    Set
public:
static property String^ LicenseKey {
    void set (String^ value);
}
static member LicenseKey : string with set

Property Value

Type: String
See Also

Reference

AddFlow Class


AddFlow.LinkModel Property

AddFlowLinkModel Property
Returns a Link object that contains the default property values for links. When a link is created, it receives these property values.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link LinkModel { get; set; }
Public Property LinkModel As Link
    Get
    Set
public:
property Link^ LinkModel {
    Link^ get ();
    void set (Link^ value);
}
member LinkModel : Link with get, set

Property Value

Type: Link
See Also

Reference

AddFlow Class


AddFlow.LinkSelectionAreaWidth Property

AddFlowLinkSelectionAreaWidth Property
Returns/sets a value that determines the width of the area where the user has to click to select a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float LinkSelectionAreaWidth { get; set; }
Public Property LinkSelectionAreaWidth As Single
    Get
    Set
public:
property float LinkSelectionAreaWidth {
    float get ();
    void set (float value);
}
member LinkSelectionAreaWidth : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow.MouseAction Property

AddFlowMouseAction Property
Returns/sets the current interactive action (select items, zoom,...).

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public MouseAction MouseAction { get; set; }
Public Property MouseAction As MouseAction
    Get
    Set
public:
property MouseAction MouseAction {
    MouseAction get ();
    void set (MouseAction value);
}
member MouseAction : MouseAction with get, set

Property Value

Type: MouseAction
See Also

Reference

AddFlow Class


AddFlow.NodeModel Property

AddFlowNodeModel Property
Returns a Node object that contains the default property values for nodes. When a node is created, it receives these property values.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node NodeModel { get; set; }
Public Property NodeModel As Node
    Get
    Set
public:
property Node^ NodeModel {
    Node^ get ();
    void set (Node^ value);
}
member NodeModel : Node with get, set

Property Value

Type: Node
See Also

Reference

AddFlow Class


AddFlow.PageScale Property

AddFlowPageScale Property
Returns/sets a value that determines the scaling used to display the graph.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float PageScale { get; set; }
Public Property PageScale As Single
    Get
    Set
public:
property float PageScale {
    float get ();
    void set (float value);
}
member PageScale : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow.PageUnit Property

AddFlowPageUnit Property
Returns/sets a value that determines the unit of measure used to display the graph.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsUnit PageUnit { get; set; }
Public Property PageUnit As GraphicsUnit
    Get
    Set
public:
property GraphicsUnit PageUnit {
    GraphicsUnit get ();
    void set (GraphicsUnit value);
}
member PageUnit : GraphicsUnit with get, set

Property Value

Type: GraphicsUnit
Remarks
The World unit is ignored.
See Also

Reference

AddFlow Class


AddFlow.PinColor1 Property

AddFlowPinColor1 Property
Returns/sets a value which defines the first color used for the brush of the node pins.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color PinColor1 { get; set; }
Public Property PinColor1 As Color
    Get
    Set
public:
property Color PinColor1 {
    Color get ();
    void set (Color value);
}
member PinColor1 : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.PinColor2 Property

AddFlowPinColor2 Property
Returns/sets a value which defines the second color used for the brush of the node pins.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color PinColor2 { get; set; }
Public Property PinColor2 As Color
    Get
    Set
public:
property Color PinColor2 {
    Color get ();
    void set (Color value);
}
member PinColor2 : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.PinDrawColor Property

AddFlowPinDrawColor Property
Returns/sets a value which defines the color used for the pen of the node pins.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color PinDrawColor { get; set; }
Public Property PinDrawColor As Color
    Get
    Set
public:
property Color PinDrawColor {
    Color get ();
    void set (Color value);
}
member PinDrawColor : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.PinSize Property

AddFlowPinSize Property
Returns/sets a value which defines the size of the node pins.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float PinSize { get; set; }
Public Property PinSize As Single
    Get
    Set
public:
property float PinSize {
    float get ();
    void set (float value);
}
member PinSize : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow.Properties Property

AddFlowProperties Property
Returns the PropertyBag instance associated to the AddFlow control

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyBag Properties { get; }
Public ReadOnly Property Properties As PropertyBag
    Get
public:
property PropertyBag^ Properties {
    PropertyBag^ get ();
}
member Properties : PropertyBag with get

Property Value

Type: PropertyBag
See Also

Reference

AddFlow Class


AddFlow.RemovePointDistance Property

AddFlowRemovePointDistance Property
Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float RemovePointDistance { get; set; }
Public Property RemovePointDistance As Single
    Get
    Set
public:
property float RemovePointDistance {
    float get ();
    void set (float value);
}
member RemovePointDistance : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow.ScrollbarsDisplayMode Property

AddFlowScrollbarsDisplayMode Property
Returns/sets the scrollbars display mode

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollbarsDisplayMode ScrollbarsDisplayMode { get; set; }
Public Property ScrollbarsDisplayMode As ScrollbarsDisplayMode
    Get
    Set
public:
property ScrollbarsDisplayMode ScrollbarsDisplayMode {
    ScrollbarsDisplayMode get ();
    void set (ScrollbarsDisplayMode value);
}
member ScrollbarsDisplayMode : ScrollbarsDisplayMode with get, set

Property Value

Type: ScrollbarsDisplayMode
See Also

Reference

AddFlow Class


AddFlow.ScrollPosition Property

AddFlowScrollPosition Property
Returns/sets the scrolling offset.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set
public:
property Point ScrollPosition {
    Point get ();
    void set (Point value);
}
member ScrollPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

AddFlow Class


AddFlow.SelectedItems Property

AddFlowSelectedItems Property
Returns the collection of all the selected items of the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Item> SelectedItems { get; }
Public ReadOnly Property SelectedItems As List(Of Item)
    Get
public:
property List<Item^>^ SelectedItems {
    List<Item^>^ get ();
}
member SelectedItems : List<Item> with get

Property Value

Type: List Item
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. You may however use this property for enumeration purposes.
See Also

Reference

AddFlow Class


AddFlow.StretchingPoint Property

AddFlowStretchingPoint Property
Returns the index of the current stretching point.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int StretchingPoint { get; }
Public ReadOnly Property StretchingPoint As Integer
    Get
public:
property int StretchingPoint {
    int get ();
}
member StretchingPoint : int with get

Property Value

Type: Int32
See Also

Reference

AddFlow Class


AddFlow.TaskManager Property

AddFlowTaskManager Property
Returns the object managing the list of tasks and allowing undo/redo.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public TaskManager TaskManager { get; }
Public ReadOnly Property TaskManager As TaskManager
    Get
public:
property TaskManager^ TaskManager {
    TaskManager^ get ();
}
member TaskManager : TaskManager with get

Property Value

Type: TaskManager
See Also

Reference

AddFlow Class


AddFlow.Zoom Property

AddFlowZoom Property
Returns/sets the zoom factor.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float Zoom { get; set; }
Public Property Zoom As Single
    Get
    Set
public:
property float Zoom {
    float get ();
    void set (float value);
}
member Zoom : float32 with get, set

Property Value

Type: Single
See Also

Reference

AddFlow Class


AddFlow Events

AddFlow Events

The AddFlow type exposes the following members.

Events
 | Name | Description
Public event | AfterAddCaption | Occurs after a user creates a caption.
Public event | AfterAddLink | Occurs after a user creates a link.
Public event | AfterAddNode | Occurs after a user creates a node.
Public event | AfterChangeDst | Occurs after a user has changed the destination node of a link.
Public event | AfterChangeOrg | Occurs after a user has changed the origin node of a link.
Public event | AfterEdit | Occurs after a user edits the text of the selected node.
Public event | AfterMove | Occurs after a user drags the selected nodes.
Public event | AfterRemoveCaption | Occurs after a caption is removed.
Public event | AfterRemoveLink | Occurs after a link is removed.
Public event | AfterRemoveNode | Occurs after a node is removed.
Public event | AfterResize | Occurs after a user resizes a node.
Public event | AfterSelect | Occurs after a user has finished drawing a selection rectangle with the mouse.
Public event | AfterStretch | Occurs after a user stretches a link.
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeAddCaption | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | BeforeAddLink | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | BeforeAddNode | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | BeforeChangeDst | Occurs when a user attempts to change the destination node of a link. Cancelling the action aborts the destination change.
Public event | BeforeChangeOrg | Occurs when a user attempts to change the origin node of a link. Cancelling the action aborts the origin change.
Public event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public event | BeforeRemoveCaption | Occurs before a caption is removed.
Public event | BeforeRemoveLink | Occurs before a link is removed.
Public event | BeforeRemoveNode | Occurs before a node is removed.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DiagramOwnerDraw | This event is fired each time the diagram is repainted. The IsOwnerDraw property of AddFlow must be set.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | Error | This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false - creating a link towards a node that does not accept incoming links - creating a link from a node that does not accept outgoing links The CanFireError property must be set.
Public event | ExtentChange | This event is fired each time the size of the diagram is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkOwnerDraw | This event is fired each time the link is repainted. The IsOwnerDraw property of the link must be set.
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeOwnerDraw | This event is fired each time the node is repainted. The IsOwnerDraw property of the node must be set.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ScrollPositionChange | This event is fired each time the scroll position of the diagram is changed.
Public event | SelectedItemsLayouting | Occurs when a user is currently moving or resizing a node or a caption
Public event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public event | SelectionChange | Occurs when the selection status of an item is changed
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

AddFlow Class


AddFlow.AfterAddCaption Event

AddFlowAfterAddCaption Event
Occurs after a user creates a caption.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterAddCaptionEventHandler AfterAddCaption
Public Event AfterAddCaption As AddFlowAfterAddCaptionEventHandler
public:
 event AddFlowAfterAddCaptionEventHandler^ AfterAddCaption {
    void add (AddFlowAfterAddCaptionEventHandler^ value);
    void remove (AddFlowAfterAddCaptionEventHandler^ value);
}
member AfterAddCaption : IEvent<AddFlowAfterAddCaptionEventHandler,
    AfterAddCaptionEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterAddCaptionEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterAddLink Event

AddFlowAfterAddLink Event
Occurs after a user creates a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterAddLinkEventHandler AfterAddLink
Public Event AfterAddLink As AddFlowAfterAddLinkEventHandler
public:
 event AddFlowAfterAddLinkEventHandler^ AfterAddLink {
    void add (AddFlowAfterAddLinkEventHandler^ value);
    void remove (AddFlowAfterAddLinkEventHandler^ value);
}
member AfterAddLink : IEvent<AddFlowAfterAddLinkEventHandler,
    AfterAddLinkEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterAddLinkEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterAddNode Event

AddFlowAfterAddNode Event
Occurs after a user creates a node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterAddNodeEventHandler AfterAddNode
Public Event AfterAddNode As AddFlowAfterAddNodeEventHandler
public:
 event AddFlowAfterAddNodeEventHandler^ AfterAddNode {
    void add (AddFlowAfterAddNodeEventHandler^ value);
    void remove (AddFlowAfterAddNodeEventHandler^ value);
}
member AfterAddNode : IEvent<AddFlowAfterAddNodeEventHandler,
    AfterAddNodeEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterAddNodeEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterChangeDst Event

AddFlowAfterChangeDst Event
Occurs after a user has changed the destination node of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterChangeDstEventHandler AfterChangeDst
Public Event AfterChangeDst As AddFlowAfterChangeDstEventHandler
public:
 event AddFlowAfterChangeDstEventHandler^ AfterChangeDst {
    void add (AddFlowAfterChangeDstEventHandler^ value);
    void remove (AddFlowAfterChangeDstEventHandler^ value);
}
member AfterChangeDst : IEvent<AddFlowAfterChangeDstEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterChangeDstEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterChangeOrg Event

AddFlowAfterChangeOrg Event
Occurs after a user has changed the origin node of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterChangeOrgEventHandler AfterChangeOrg
Public Event AfterChangeOrg As AddFlowAfterChangeOrgEventHandler
public:
 event AddFlowAfterChangeOrgEventHandler^ AfterChangeOrg {
    void add (AddFlowAfterChangeOrgEventHandler^ value);
    void remove (AddFlowAfterChangeOrgEventHandler^ value);
}
member AfterChangeOrg : IEvent<AddFlowAfterChangeOrgEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterChangeOrgEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterEdit Event

AddFlowAfterEdit Event
Occurs after a user edits the text of the selected node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterEditEventHandler AfterEdit
Public Event AfterEdit As AddFlowAfterEditEventHandler
public:
 event AddFlowAfterEditEventHandler^ AfterEdit {
    void add (AddFlowAfterEditEventHandler^ value);
    void remove (AddFlowAfterEditEventHandler^ value);
}
member AfterEdit : IEvent<AddFlowAfterEditEventHandler,
    AfterEditEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterMove Event

AddFlowAfterMove Event
Occurs after a user drags the selected nodes.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterMoveEventHandler AfterMove
Public Event AfterMove As AddFlowAfterMoveEventHandler
public:
 event AddFlowAfterMoveEventHandler^ AfterMove {
    void add (AddFlowAfterMoveEventHandler^ value);
    void remove (AddFlowAfterMoveEventHandler^ value);
}
member AfterMove : IEvent<AddFlowAfterMoveEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterMoveEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterRemoveCaption Event

AddFlowAfterRemoveCaption Event
Occurs after a caption is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterRemoveCaptionEventHandler AfterRemoveCaption
Public Event AfterRemoveCaption As AddFlowAfterRemoveCaptionEventHandler
public:
 event AddFlowAfterRemoveCaptionEventHandler^ AfterRemoveCaption {
    void add (AddFlowAfterRemoveCaptionEventHandler^ value);
    void remove (AddFlowAfterRemoveCaptionEventHandler^ value);
}
member AfterRemoveCaption : IEvent<AddFlowAfterRemoveCaptionEventHandler,
    AfterRemoveCaptionEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterRemoveCaptionEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterRemoveLink Event

AddFlowAfterRemoveLink Event
Occurs after a link is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterRemoveLinkEventHandler AfterRemoveLink
Public Event AfterRemoveLink As AddFlowAfterRemoveLinkEventHandler
public:
 event AddFlowAfterRemoveLinkEventHandler^ AfterRemoveLink {
    void add (AddFlowAfterRemoveLinkEventHandler^ value);
    void remove (AddFlowAfterRemoveLinkEventHandler^ value);
}
member AfterRemoveLink : IEvent<AddFlowAfterRemoveLinkEventHandler,
    AfterRemoveLinkEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterRemoveLinkEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterRemoveNode Event

AddFlowAfterRemoveNode Event
Occurs after a node is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterRemoveNodeEventHandler AfterRemoveNode
Public Event AfterRemoveNode As AddFlowAfterRemoveNodeEventHandler
public:
 event AddFlowAfterRemoveNodeEventHandler^ AfterRemoveNode {
    void add (AddFlowAfterRemoveNodeEventHandler^ value);
    void remove (AddFlowAfterRemoveNodeEventHandler^ value);
}
member AfterRemoveNode : IEvent<AddFlowAfterRemoveNodeEventHandler,
    AfterRemoveNodeEventArgs>

Value

Type: Lassalle.FlowAddFlowAfterRemoveNodeEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterResize Event

AddFlowAfterResize Event
Occurs after a user resizes a node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterResizeEventHandler AfterResize
Public Event AfterResize As AddFlowAfterResizeEventHandler
public:
 event AddFlowAfterResizeEventHandler^ AfterResize {
    void add (AddFlowAfterResizeEventHandler^ value);
    void remove (AddFlowAfterResizeEventHandler^ value);
}
member AfterResize : IEvent<AddFlowAfterResizeEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterResizeEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterSelect Event

AddFlowAfterSelect Event
Occurs after a user has finished drawing a selection rectangle with the mouse.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterSelectEventHandler AfterSelect
Public Event AfterSelect As AddFlowAfterSelectEventHandler
public:
 event AddFlowAfterSelectEventHandler^ AfterSelect {
    void add (AddFlowAfterSelectEventHandler^ value);
    void remove (AddFlowAfterSelectEventHandler^ value);
}
member AfterSelect : IEvent<AddFlowAfterSelectEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterSelectEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterStretch Event

AddFlowAfterStretch Event
Occurs after a user stretches a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterStretchEventHandler AfterStretch
Public Event AfterStretch As AddFlowAfterStretchEventHandler
public:
 event AddFlowAfterStretchEventHandler^ AfterStretch {
    void add (AddFlowAfterStretchEventHandler^ value);
    void remove (AddFlowAfterStretchEventHandler^ value);
}
member AfterStretch : IEvent<AddFlowAfterStretchEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowAfterStretchEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeAddCaption Event

AddFlowBeforeAddCaption Event
Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeAddCaptionEventHandler BeforeAddCaption
Public Event BeforeAddCaption As AddFlowBeforeAddCaptionEventHandler
public:
 event AddFlowBeforeAddCaptionEventHandler^ BeforeAddCaption {
    void add (AddFlowBeforeAddCaptionEventHandler^ value);
    void remove (AddFlowBeforeAddCaptionEventHandler^ value);
}
member BeforeAddCaption : IEvent<AddFlowBeforeAddCaptionEventHandler,
    BeforeAddCaptionEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeAddCaptionEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeAddLink Event

AddFlowBeforeAddLink Event
Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeAddLinkEventHandler BeforeAddLink
Public Event BeforeAddLink As AddFlowBeforeAddLinkEventHandler
public:
 event AddFlowBeforeAddLinkEventHandler^ BeforeAddLink {
    void add (AddFlowBeforeAddLinkEventHandler^ value);
    void remove (AddFlowBeforeAddLinkEventHandler^ value);
}
member BeforeAddLink : IEvent<AddFlowBeforeAddLinkEventHandler,
    BeforeAddLinkEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeAddLinkEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeAddNode Event

AddFlowBeforeAddNode Event
Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeAddNodeEventHandler BeforeAddNode
Public Event BeforeAddNode As AddFlowBeforeAddNodeEventHandler
public:
 event AddFlowBeforeAddNodeEventHandler^ BeforeAddNode {
    void add (AddFlowBeforeAddNodeEventHandler^ value);
    void remove (AddFlowBeforeAddNodeEventHandler^ value);
}
member BeforeAddNode : IEvent<AddFlowBeforeAddNodeEventHandler,
    BeforeAddNodeEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeAddNodeEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeChangeDst Event

AddFlowBeforeChangeDst Event
Occurs when a user attempts to change the destination node of a link. Cancelling the action aborts the destination change.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeChangeDstEventHandler BeforeChangeDst
Public Event BeforeChangeDst As AddFlowBeforeChangeDstEventHandler
public:
 event AddFlowBeforeChangeDstEventHandler^ BeforeChangeDst {
    void add (AddFlowBeforeChangeDstEventHandler^ value);
    void remove (AddFlowBeforeChangeDstEventHandler^ value);
}
member BeforeChangeDst : IEvent<AddFlowBeforeChangeDstEventHandler,
    BeforeChangeDstEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeChangeDstEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeChangeOrg Event

AddFlowBeforeChangeOrg Event
Occurs when a user attempts to change the origin node of a link. Cancelling the action aborts the origin change.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeChangeOrgEventHandler BeforeChangeOrg
Public Event BeforeChangeOrg As AddFlowBeforeChangeOrgEventHandler
public:
 event AddFlowBeforeChangeOrgEventHandler^ BeforeChangeOrg {
    void add (AddFlowBeforeChangeOrgEventHandler^ value);
    void remove (AddFlowBeforeChangeOrgEventHandler^ value);
}
member BeforeChangeOrg : IEvent<AddFlowBeforeChangeOrgEventHandler,
    BeforeChangeOrgEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeChangeOrgEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeEdit Event

AddFlowBeforeEdit Event
Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeEditEventHandler BeforeEdit
Public Event BeforeEdit As AddFlowBeforeEditEventHandler
public:
 event AddFlowBeforeEditEventHandler^ BeforeEdit {
    void add (AddFlowBeforeEditEventHandler^ value);
    void remove (AddFlowBeforeEditEventHandler^ value);
}
member BeforeEdit : IEvent<AddFlowBeforeEditEventHandler,
    BeforeEditEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeRemoveCaption Event

AddFlowBeforeRemoveCaption Event
Occurs before a caption is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeRemoveCaptionEventHandler BeforeRemoveCaption
Public Event BeforeRemoveCaption As AddFlowBeforeRemoveCaptionEventHandler
public:
 event AddFlowBeforeRemoveCaptionEventHandler^ BeforeRemoveCaption {
    void add (AddFlowBeforeRemoveCaptionEventHandler^ value);
    void remove (AddFlowBeforeRemoveCaptionEventHandler^ value);
}
member BeforeRemoveCaption : IEvent<AddFlowBeforeRemoveCaptionEventHandler,
    BeforeRemoveCaptionEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeRemoveCaptionEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeRemoveLink Event

AddFlowBeforeRemoveLink Event
Occurs before a link is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeRemoveLinkEventHandler BeforeRemoveLink
Public Event BeforeRemoveLink As AddFlowBeforeRemoveLinkEventHandler
public:
 event AddFlowBeforeRemoveLinkEventHandler^ BeforeRemoveLink {
    void add (AddFlowBeforeRemoveLinkEventHandler^ value);
    void remove (AddFlowBeforeRemoveLinkEventHandler^ value);
}
member BeforeRemoveLink : IEvent<AddFlowBeforeRemoveLinkEventHandler,
    BeforeRemoveLinkEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeRemoveLinkEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeRemoveNode Event

AddFlowBeforeRemoveNode Event
Occurs before a node is removed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeRemoveNodeEventHandler BeforeRemoveNode
Public Event BeforeRemoveNode As AddFlowBeforeRemoveNodeEventHandler
public:
 event AddFlowBeforeRemoveNodeEventHandler^ BeforeRemoveNode {
    void add (AddFlowBeforeRemoveNodeEventHandler^ value);
    void remove (AddFlowBeforeRemoveNodeEventHandler^ value);
}
member BeforeRemoveNode : IEvent<AddFlowBeforeRemoveNodeEventHandler,
    BeforeRemoveNodeEventArgs>

Value

Type: Lassalle.FlowAddFlowBeforeRemoveNodeEventHandler
See Also

Reference

AddFlow Class


AddFlow.CancelEdit Event

AddFlowCancelEdit Event
Occurs after a user cancels the text edition of the selected node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCancelEditEventHandler CancelEdit
Public Event CancelEdit As AddFlowCancelEditEventHandler
public:
 event AddFlowCancelEditEventHandler^ CancelEdit {
    void add (AddFlowCancelEditEventHandler^ value);
    void remove (AddFlowCancelEditEventHandler^ value);
}
member CancelEdit : IEvent<AddFlowCancelEditEventHandler,
    CancelEditEventArgs>

Value

Type: Lassalle.FlowAddFlowCancelEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.DiagramOwnerDraw Event

AddFlowDiagramOwnerDraw Event
This event is fired each time the diagram is repainted. The IsOwnerDraw property of AddFlow must be set.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowDiagramOwnerDrawEventHandler DiagramOwnerDraw
Public Event DiagramOwnerDraw As AddFlowDiagramOwnerDrawEventHandler
public:
 event AddFlowDiagramOwnerDrawEventHandler^ DiagramOwnerDraw {
    void add (AddFlowDiagramOwnerDrawEventHandler^ value);
    void remove (AddFlowDiagramOwnerDrawEventHandler^ value);
}
member DiagramOwnerDraw : IEvent<AddFlowDiagramOwnerDrawEventHandler,
    DiagramOwnerDrawEventArgs>

Value

Type: Lassalle.FlowAddFlowDiagramOwnerDrawEventHandler
See Also

Reference

AddFlow Class


AddFlow.Error Event

AddFlowError Event
This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false - creating a link towards a node that does not accept incoming links - creating a link from a node that does not accept outgoing links The CanFireError property must be set.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowErrorEventHandler Error
Public Event Error As AddFlowErrorEventHandler
public:
 event AddFlowErrorEventHandler^ Error {
    void add (AddFlowErrorEventHandler^ value);
    void remove (AddFlowErrorEventHandler^ value);
}
member Error : IEvent<AddFlowErrorEventHandler,
    ErrorEventArgs>

Value

Type: Lassalle.FlowAddFlowErrorEventHandler
See Also

Reference

AddFlow Class


AddFlow.ExtentChange Event

AddFlowExtentChange Event
This event is fired each time the size of the diagram is changed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowExtentChangeEventHandler ExtentChange
Public Event ExtentChange As AddFlowExtentChangeEventHandler
public:
 event AddFlowExtentChangeEventHandler^ ExtentChange {
    void add (AddFlowExtentChangeEventHandler^ value);
    void remove (AddFlowExtentChangeEventHandler^ value);
}
member ExtentChange : IEvent<AddFlowExtentChangeEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowExtentChangeEventHandler
Remarks
This event is not fired if the redrawing is disabled (see the BeginUpdate and EndUpdate methods).
See Also

Reference

AddFlow Class


AddFlow.LinkOwnerDraw Event

AddFlowLinkOwnerDraw Event
This event is fired each time the link is repainted. The IsOwnerDraw property of the link must be set.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowLinkOwnerDrawEventHandler LinkOwnerDraw
Public Event LinkOwnerDraw As AddFlowLinkOwnerDrawEventHandler
public:
 event AddFlowLinkOwnerDrawEventHandler^ LinkOwnerDraw {
    void add (AddFlowLinkOwnerDrawEventHandler^ value);
    void remove (AddFlowLinkOwnerDrawEventHandler^ value);
}
member LinkOwnerDraw : IEvent<AddFlowLinkOwnerDrawEventHandler,
    LinkOwnerDrawEventArgs>

Value

Type: Lassalle.FlowAddFlowLinkOwnerDrawEventHandler
See Also

Reference

AddFlow Class


AddFlow.NodeOwnerDraw Event

AddFlowNodeOwnerDraw Event
This event is fired each time the node is repainted. The IsOwnerDraw property of the node must be set.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowNodeOwnerDrawEventHandler NodeOwnerDraw
Public Event NodeOwnerDraw As AddFlowNodeOwnerDrawEventHandler
public:
 event AddFlowNodeOwnerDrawEventHandler^ NodeOwnerDraw {
    void add (AddFlowNodeOwnerDrawEventHandler^ value);
    void remove (AddFlowNodeOwnerDrawEventHandler^ value);
}
member NodeOwnerDraw : IEvent<AddFlowNodeOwnerDrawEventHandler,
    ContentItemOwnerDrawEventArgs>

Value

Type: Lassalle.FlowAddFlowNodeOwnerDrawEventHandler
See Also

Reference

AddFlow Class


AddFlow.ScrollPositionChange Event

AddFlowScrollPositionChange Event
This event is fired each time the scroll position of the diagram is changed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowScrollPositionChangeEventHandler ScrollPositionChange
Public Event ScrollPositionChange As AddFlowScrollPositionChangeEventHandler
public:
 event AddFlowScrollPositionChangeEventHandler^ ScrollPositionChange {
    void add (AddFlowScrollPositionChangeEventHandler^ value);
    void remove (AddFlowScrollPositionChangeEventHandler^ value);
}
member ScrollPositionChange : IEvent<AddFlowScrollPositionChangeEventHandler,
    EventArgs>

Value

Type: Lassalle.FlowAddFlowScrollPositionChangeEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectedItemsLayouting Event

AddFlowSelectedItemsLayouting Event
Occurs when a user is currently moving or resizing a node or a caption

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectedItemsLayoutingEventHandler SelectedItemsLayouting
Public Event SelectedItemsLayouting As AddFlowSelectedItemsLayoutingEventHandler
public:
 event AddFlowSelectedItemsLayoutingEventHandler^ SelectedItemsLayouting {
    void add (AddFlowSelectedItemsLayoutingEventHandler^ value);
    void remove (AddFlowSelectedItemsLayoutingEventHandler^ value);
}
member SelectedItemsLayouting : IEvent<AddFlowSelectedItemsLayoutingEventHandler,
    SelectedItemsLayoutingEventArgs>

Value

Type: Lassalle.FlowAddFlowSelectedItemsLayoutingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectedLinkStretching Event

AddFlowSelectedLinkStretching Event
Occurs when a user is currently stretching a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectedLinkStretchingEventHandler SelectedLinkStretching
Public Event SelectedLinkStretching As AddFlowSelectedLinkStretchingEventHandler
public:
 event AddFlowSelectedLinkStretchingEventHandler^ SelectedLinkStretching {
    void add (AddFlowSelectedLinkStretchingEventHandler^ value);
    void remove (AddFlowSelectedLinkStretchingEventHandler^ value);
}
member SelectedLinkStretching : IEvent<AddFlowSelectedLinkStretchingEventHandler,
    SelectedLinkStretchingEventArgs>

Value

Type: Lassalle.FlowAddFlowSelectedLinkStretchingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectionChange Event

AddFlowSelectionChange Event
Occurs when the selection status of an item is changed

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectionChangeEventHandler SelectionChange
Public Event SelectionChange As AddFlowSelectionChangeEventHandler
public:
 event AddFlowSelectionChangeEventHandler^ SelectionChange {
    void add (AddFlowSelectionChangeEventHandler^ value);
    void remove (AddFlowSelectionChangeEventHandler^ value);
}
member SelectionChange : IEvent<AddFlowSelectionChangeEventHandler,
    SelectionChangeArgs>

Value

Type: Lassalle.FlowAddFlowSelectionChangeEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterAddCaptionEventHandler Delegate

AddFlowAfterAddCaptionEventHandler Delegate
Represents the method that will handle the AfterAddCaption event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterAddCaptionEventHandler(
    Object sender,
    AfterAddCaptionEventArgs e
)
Public Delegate Sub AfterAddCaptionEventHandler (
    sender As Object,
    e As AfterAddCaptionEventArgs
)
public delegate void AfterAddCaptionEventHandler(
    Object^ sender,
    AfterAddCaptionEventArgs^ e
)
type AfterAddCaptionEventHandler =
    delegate of
        sender : Object *
        e : AfterAddCaptionEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterAddCaptionEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterAddLinkEventHandler Delegate

AddFlowAfterAddLinkEventHandler Delegate
Represents the method that will handle the AfterAddLink event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterAddLinkEventHandler(
    Object sender,
    AfterAddLinkEventArgs e
)
Public Delegate Sub AfterAddLinkEventHandler (
    sender As Object,
    e As AfterAddLinkEventArgs
)
public delegate void AfterAddLinkEventHandler(
    Object^ sender,
    AfterAddLinkEventArgs^ e
)
type AfterAddLinkEventHandler =
    delegate of
        sender : Object *
        e : AfterAddLinkEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterAddLinkEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterAddNodeEventHandler Delegate

AddFlowAfterAddNodeEventHandler Delegate
Represents the method that will handle the AfterAddNode event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterAddNodeEventHandler(
    Object sender,
    AfterAddNodeEventArgs e
)
Public Delegate Sub AfterAddNodeEventHandler (
    sender As Object,
    e As AfterAddNodeEventArgs
)
public delegate void AfterAddNodeEventHandler(
    Object^ sender,
    AfterAddNodeEventArgs^ e
)
type AfterAddNodeEventHandler =
    delegate of
        sender : Object *
        e : AfterAddNodeEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterAddNodeEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterChangeDstEventHandler Delegate

AddFlowAfterChangeDstEventHandler Delegate
Represents the method that will handle the AfterChangeDst event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterChangeDstEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterChangeDstEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterChangeDstEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterChangeDstEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterChangeOrgEventHandler Delegate

AddFlowAfterChangeOrgEventHandler Delegate
Represents the method that will handle the AfterChangeOrg event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterChangeOrgEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterChangeOrgEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterChangeOrgEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterChangeOrgEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterEditEventHandler Delegate

AddFlowAfterEditEventHandler Delegate
Represents the method that will handle the AfterEdit event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterEditEventHandler(
    Object sender,
    AfterEditEventArgs e
)
Public Delegate Sub AfterEditEventHandler (
    sender As Object,
    e As AfterEditEventArgs
)
public delegate void AfterEditEventHandler(
    Object^ sender,
    AfterEditEventArgs^ e
)
type AfterEditEventHandler =
    delegate of
        sender : Object *
        e : AfterEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterEditEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterMoveEventHandler Delegate

AddFlowAfterMoveEventHandler Delegate
Represents the method that will handle the AfterMove event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterMoveEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterMoveEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterMoveEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterMoveEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterRemoveCaptionEventHandler Delegate

AddFlowAfterRemoveCaptionEventHandler Delegate
Represents the method that will handle the AfterRemoveCaption event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterRemoveCaptionEventHandler(
    Object sender,
    AfterRemoveCaptionEventArgs e
)
Public Delegate Sub AfterRemoveCaptionEventHandler (
    sender As Object,
    e As AfterRemoveCaptionEventArgs
)
public delegate void AfterRemoveCaptionEventHandler(
    Object^ sender,
    AfterRemoveCaptionEventArgs^ e
)
type AfterRemoveCaptionEventHandler =
    delegate of
        sender : Object *
        e : AfterRemoveCaptionEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterRemoveCaptionEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterRemoveLinkEventHandler Delegate

AddFlowAfterRemoveLinkEventHandler Delegate
Represents the method that will handle the AfterRemoveLink event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterRemoveLinkEventHandler(
    Object sender,
    AfterRemoveLinkEventArgs e
)
Public Delegate Sub AfterRemoveLinkEventHandler (
    sender As Object,
    e As AfterRemoveLinkEventArgs
)
public delegate void AfterRemoveLinkEventHandler(
    Object^ sender,
    AfterRemoveLinkEventArgs^ e
)
type AfterRemoveLinkEventHandler =
    delegate of
        sender : Object *
        e : AfterRemoveLinkEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterRemoveLinkEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterRemoveNodeEventHandler Delegate

AddFlowAfterRemoveNodeEventHandler Delegate
Represents the method that will handle the AfterRemoveNode event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterRemoveNodeEventHandler(
    Object sender,
    AfterRemoveNodeEventArgs e
)
Public Delegate Sub AfterRemoveNodeEventHandler (
    sender As Object,
    e As AfterRemoveNodeEventArgs
)
public delegate void AfterRemoveNodeEventHandler(
    Object^ sender,
    AfterRemoveNodeEventArgs^ e
)
type AfterRemoveNodeEventHandler =
    delegate of
        sender : Object *
        e : AfterRemoveNodeEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowAfterRemoveNodeEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterResizeEventHandler Delegate

AddFlowAfterResizeEventHandler Delegate
Represents the method that will handle the AfterResize event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterResizeEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterResizeEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterResizeEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterResizeEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterSelectEventHandler Delegate

AddFlowAfterSelectEventHandler Delegate
Represents the method that will handle the AfterSelect event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterSelectEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterSelectEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterSelectEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterSelectEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.AfterStretchEventHandler Delegate

AddFlowAfterStretchEventHandler Delegate
Represents the method that will handle the AfterStretch event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterStretchEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub AfterStretchEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void AfterStretchEventHandler(
    Object^ sender,
    EventArgs^ e
)
type AfterStretchEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeAddCaptionEventHandler Delegate

AddFlowBeforeAddCaptionEventHandler Delegate
Represents the method that will handle the BeforeAddCaption event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeAddCaptionEventHandler(
    Object sender,
    BeforeAddCaptionEventArgs e
)
Public Delegate Sub BeforeAddCaptionEventHandler (
    sender As Object,
    e As BeforeAddCaptionEventArgs
)
public delegate void BeforeAddCaptionEventHandler(
    Object^ sender,
    BeforeAddCaptionEventArgs^ e
)
type BeforeAddCaptionEventHandler =
    delegate of
        sender : Object *
        e : BeforeAddCaptionEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeAddCaptionEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeAddLinkEventHandler Delegate

AddFlowBeforeAddLinkEventHandler Delegate
Represents the method that will handle the BeforeAddLink event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeAddLinkEventHandler(
    Object sender,
    BeforeAddLinkEventArgs e
)
Public Delegate Sub BeforeAddLinkEventHandler (
    sender As Object,
    e As BeforeAddLinkEventArgs
)
public delegate void BeforeAddLinkEventHandler(
    Object^ sender,
    BeforeAddLinkEventArgs^ e
)
type BeforeAddLinkEventHandler =
    delegate of
        sender : Object *
        e : BeforeAddLinkEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeAddLinkEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeAddNodeEventHandler Delegate

AddFlowBeforeAddNodeEventHandler Delegate
Represents the method that will handle the BeforeAddNode event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeAddNodeEventHandler(
    Object sender,
    BeforeAddNodeEventArgs e
)
Public Delegate Sub BeforeAddNodeEventHandler (
    sender As Object,
    e As BeforeAddNodeEventArgs
)
public delegate void BeforeAddNodeEventHandler(
    Object^ sender,
    BeforeAddNodeEventArgs^ e
)
type BeforeAddNodeEventHandler =
    delegate of
        sender : Object *
        e : BeforeAddNodeEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeAddNodeEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeChangeDstEventHandler Delegate

AddFlowBeforeChangeDstEventHandler Delegate
Represents the method that will handle the BeforeChangeDst event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeChangeDstEventHandler(
    Object sender,
    BeforeChangeDstEventArgs e
)
Public Delegate Sub BeforeChangeDstEventHandler (
    sender As Object,
    e As BeforeChangeDstEventArgs
)
public delegate void BeforeChangeDstEventHandler(
    Object^ sender,
    BeforeChangeDstEventArgs^ e
)
type BeforeChangeDstEventHandler =
    delegate of
        sender : Object *
        e : BeforeChangeDstEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeChangeDstEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeChangeOrgEventHandler Delegate

AddFlowBeforeChangeOrgEventHandler Delegate
Represents the method that will handle the BeforeChangeOrg event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeChangeOrgEventHandler(
    Object sender,
    BeforeChangeOrgEventArgs e
)
Public Delegate Sub BeforeChangeOrgEventHandler (
    sender As Object,
    e As BeforeChangeOrgEventArgs
)
public delegate void BeforeChangeOrgEventHandler(
    Object^ sender,
    BeforeChangeOrgEventArgs^ e
)
type BeforeChangeOrgEventHandler =
    delegate of
        sender : Object *
        e : BeforeChangeOrgEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeChangeOrgEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeEditEventHandler Delegate

AddFlowBeforeEditEventHandler Delegate
Represents the method that will handle the BeforeEdit event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeEditEventHandler(
    Object sender,
    BeforeEditEventArgs e
)
Public Delegate Sub BeforeEditEventHandler (
    sender As Object,
    e As BeforeEditEventArgs
)
public delegate void BeforeEditEventHandler(
    Object^ sender,
    BeforeEditEventArgs^ e
)
type BeforeEditEventHandler =
    delegate of
        sender : Object *
        e : BeforeEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeEditEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeRemoveCaptionEventHandler Delegate

AddFlowBeforeRemoveCaptionEventHandler Delegate
Represents the method that will handle the BeforeRemoveCaption event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeRemoveCaptionEventHandler(
    Object sender,
    BeforeRemoveCaptionEventArgs e
)
Public Delegate Sub BeforeRemoveCaptionEventHandler (
    sender As Object,
    e As BeforeRemoveCaptionEventArgs
)
public delegate void BeforeRemoveCaptionEventHandler(
    Object^ sender,
    BeforeRemoveCaptionEventArgs^ e
)
type BeforeRemoveCaptionEventHandler =
    delegate of
        sender : Object *
        e : BeforeRemoveCaptionEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeRemoveCaptionEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeRemoveLinkEventHandler Delegate

AddFlowBeforeRemoveLinkEventHandler Delegate
Represents the method that will handle the BeforeRemoveLink event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeRemoveLinkEventHandler(
    Object sender,
    BeforeRemoveLinkEventArgs e
)
Public Delegate Sub BeforeRemoveLinkEventHandler (
    sender As Object,
    e As BeforeRemoveLinkEventArgs
)
public delegate void BeforeRemoveLinkEventHandler(
    Object^ sender,
    BeforeRemoveLinkEventArgs^ e
)
type BeforeRemoveLinkEventHandler =
    delegate of
        sender : Object *
        e : BeforeRemoveLinkEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeRemoveLinkEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeRemoveNodeEventHandler Delegate

AddFlowBeforeRemoveNodeEventHandler Delegate
Represents the method that will handle the BeforeRemoveNode event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeRemoveNodeEventHandler(
    Object sender,
    BeforeRemoveNodeEventArgs e
)
Public Delegate Sub BeforeRemoveNodeEventHandler (
    sender As Object,
    e As BeforeRemoveNodeEventArgs
)
public delegate void BeforeRemoveNodeEventHandler(
    Object^ sender,
    BeforeRemoveNodeEventArgs^ e
)
type BeforeRemoveNodeEventHandler =
    delegate of
        sender : Object *
        e : BeforeRemoveNodeEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowBeforeRemoveNodeEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.CancelEditEventHandler Delegate

AddFlowCancelEditEventHandler Delegate
Represents the method that will handle the CancelEdit event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CancelEditEventHandler(
    Object sender,
    CancelEditEventArgs e
)
Public Delegate Sub CancelEditEventHandler (
    sender As Object,
    e As CancelEditEventArgs
)
public delegate void CancelEditEventHandler(
    Object^ sender,
    CancelEditEventArgs^ e
)
type CancelEditEventHandler =
    delegate of
        sender : Object *
        e : CancelEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowCancelEditEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.DiagramOwnerDrawEventHandler Delegate

AddFlowDiagramOwnerDrawEventHandler Delegate
Represents the method that will handle the DiagramOwnerDraw event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void DiagramOwnerDrawEventHandler(
    Object sender,
    DiagramOwnerDrawEventArgs e
)
Public Delegate Sub DiagramOwnerDrawEventHandler (
    sender As Object,
    e As DiagramOwnerDrawEventArgs
)
public delegate void DiagramOwnerDrawEventHandler(
    Object^ sender,
    DiagramOwnerDrawEventArgs^ e
)
type DiagramOwnerDrawEventHandler =
    delegate of
        sender : Object *
        e : DiagramOwnerDrawEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowDiagramOwnerDrawEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.ErrorEventHandler Delegate

AddFlowErrorEventHandler Delegate
Represents the method that will handle the Error event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorEventHandler(
    Object sender,
    ErrorEventArgs e
)
Public Delegate Sub ErrorEventHandler (
    sender As Object,
    e As ErrorEventArgs
)
public delegate void ErrorEventHandler(
    Object^ sender,
    ErrorEventArgs^ e
)
type ErrorEventHandler =
    delegate of
        sender : Object *
        e : ErrorEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowErrorEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.ExtentChangeEventHandler Delegate

AddFlowExtentChangeEventHandler Delegate
Represents the method that will handle the ExtentChange event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ExtentChangeEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub ExtentChangeEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void ExtentChangeEventHandler(
    Object^ sender,
    EventArgs^ e
)
type ExtentChangeEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.LinkOwnerDrawEventHandler Delegate

AddFlowLinkOwnerDrawEventHandler Delegate
Represents the method that will handle the LinkOwnerDraw event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkOwnerDrawEventHandler(
    Object sender,
    LinkOwnerDrawEventArgs e
)
Public Delegate Sub LinkOwnerDrawEventHandler (
    sender As Object,
    e As LinkOwnerDrawEventArgs
)
public delegate void LinkOwnerDrawEventHandler(
    Object^ sender,
    LinkOwnerDrawEventArgs^ e
)
type LinkOwnerDrawEventHandler =
    delegate of
        sender : Object *
        e : LinkOwnerDrawEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowLinkOwnerDrawEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.NodeOwnerDrawEventHandler Delegate

AddFlowNodeOwnerDrawEventHandler Delegate
Represents the method that will handle the NodeOwnerDraw event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeOwnerDrawEventHandler(
    Object sender,
    ContentItemOwnerDrawEventArgs e
)
Public Delegate Sub NodeOwnerDrawEventHandler (
    sender As Object,
    e As ContentItemOwnerDrawEventArgs
)
public delegate void NodeOwnerDrawEventHandler(
    Object^ sender,
    ContentItemOwnerDrawEventArgs^ e
)
type NodeOwnerDrawEventHandler =
    delegate of
        sender : Object *
        e : ContentItemOwnerDrawEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowContentItemOwnerDrawEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.ScrollPositionChangeEventHandler Delegate

AddFlowScrollPositionChangeEventHandler Delegate
Represents the method that will handle the ScrollPositionChange event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ScrollPositionChangeEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub ScrollPositionChangeEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void ScrollPositionChangeEventHandler(
    Object^ sender,
    EventArgs^ e
)
type ScrollPositionChangeEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectedItemsLayoutingEventHandler Delegate

AddFlowSelectedItemsLayoutingEventHandler Delegate
Represents the method that will handle the SelectedItemsLayouting event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectedItemsLayoutingEventHandler(
    Object sender,
    SelectedItemsLayoutingEventArgs e
)
Public Delegate Sub SelectedItemsLayoutingEventHandler (
    sender As Object,
    e As SelectedItemsLayoutingEventArgs
)
public delegate void SelectedItemsLayoutingEventHandler(
    Object^ sender,
    SelectedItemsLayoutingEventArgs^ e
)
type SelectedItemsLayoutingEventHandler =
    delegate of
        sender : Object *
        e : SelectedItemsLayoutingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowSelectedItemsLayoutingEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectedLinkStretchingEventHandler Delegate

AddFlowSelectedLinkStretchingEventHandler Delegate
Represents the method that will handle the SelectedLinkStretching event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectedLinkStretchingEventHandler(
    Object sender,
    SelectedLinkStretchingEventArgs e
)
Public Delegate Sub SelectedLinkStretchingEventHandler (
    sender As Object,
    e As SelectedLinkStretchingEventArgs
)
public delegate void SelectedLinkStretchingEventHandler(
    Object^ sender,
    SelectedLinkStretchingEventArgs^ e
)
type SelectedLinkStretchingEventHandler =
    delegate of
        sender : Object *
        e : SelectedLinkStretchingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowSelectedLinkStretchingEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectionChangeEventHandler Delegate

AddFlowSelectionChangeEventHandler Delegate
Represents the method that will handle the SelectionChange event.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectionChangeEventHandler(
    Object sender,
    SelectionChangeArgs e
)
Public Delegate Sub SelectionChangeEventHandler (
    sender As Object,
    e As SelectionChangeArgs
)
public delegate void SelectionChangeEventHandler(
    Object^ sender,
    SelectionChangeArgs^ e
)
type SelectionChangeEventHandler =
    delegate of
        sender : Object *
        e : SelectionChangeArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowSelectionChangeArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlowException Class

AddFlowException Class
AddFlow exception class
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Lassalle.FlowAddFlowException

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AddFlowException : ApplicationException
Public Class AddFlowException
    Inherits ApplicationException
public ref class AddFlowException : public ApplicationException
type AddFlowException =
    class
        inherit ApplicationException
    end

The AddFlowException type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlowException | AddFlow exception class constructor with 1 parameter: the message text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlowException Constructor

AddFlowException Constructor
AddFlow exception class constructor with 1 parameter: the message text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AddFlowException(
    string message
)
Public Sub New (
    message As String
)
public:
AddFlowException(
    String^ message
)
new :
        message : string -> AddFlowException

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

AddFlowException Class


AddFlowException Methods

AddFlowException Methods

The AddFlowException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowException Properties

AddFlowException Properties

The AddFlowException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowException Events

AddFlowException Events

The AddFlowException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowLicenseProvider Class

AddFlowLicenseProvider Class

[Missing <summary> documentation for "T:Lassalle.Flow.AddFlowLicenseProvider"]

Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
System.ComponentModelLicFileLicenseProvider
Lassalle.FlowAddFlowLicenseProvider

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AddFlowLicenseProvider : LicFileLicenseProvider
Public Class AddFlowLicenseProvider
    Inherits LicFileLicenseProvider
public ref class AddFlowLicenseProvider : public LicFileLicenseProvider
type AddFlowLicenseProvider =
    class
        inherit LicFileLicenseProvider
    end

The AddFlowLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlowLicenseProvider | Initializes a new instance of the AddFlowLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | (Overrides LicFileLicenseProviderGetKey(Type).)
Public method | GetLicense | Returns a license for the instance of the component, if one is available. (Inherited from LicFileLicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsKeyValid | (Overrides LicFileLicenseProviderIsKeyValid(String, Type).)
 | IsLicensePro | Indicates if it is a professional license
 | IsLicenseStd | Indicates if it is a standard license
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AddFlowLicenseProvider Constructor

AddFlowLicenseProvider Constructor
Initializes a new instance of the AddFlowLicenseProvider class

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AddFlowLicenseProvider()
Public Sub New
public:
AddFlowLicenseProvider()
new : unit -> AddFlowLicenseProvider
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider Methods

AddFlowLicenseProvider Methods

The AddFlowLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | (Overrides LicFileLicenseProviderGetKey(Type).)
Public method | GetLicense | Returns a license for the instance of the component, if one is available. (Inherited from LicFileLicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsKeyValid | (Overrides LicFileLicenseProviderIsKeyValid(String, Type).)
 | IsLicensePro | Indicates if it is a professional license
 | IsLicenseStd | Indicates if it is a standard license
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.GetKey Method

AddFlowLicenseProviderGetKey Method

[Missing <summary> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override string GetKey(
    Type type
)
Protected Overrides Function GetKey (
    type As Type
) As String
protected:
virtual String^ GetKey(
    Type^ type
) override
abstract GetKey :
        type : Type -> string
override GetKey :
        type : Type -> string

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsKeyValid Method

AddFlowLicenseProviderIsKeyValid Method

[Missing <summary> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected override bool IsKeyValid(
    string key,
    Type type
)
Protected Overrides Function IsKeyValid (
    key As String,
    type As Type
) As Boolean
protected:
virtual bool IsKeyValid(
    String^ key,
    Type^ type
) override
abstract IsKeyValid :
        key : string *
        type : Type -> bool
override IsKeyValid :
        key : string *
        type : Type -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsLicensePro Method

AddFlowLicenseProviderIsLicensePro Method
Indicates if it is a professional license

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLicensePro()
Public Shared Function IsLicensePro As Boolean
public:
static bool IsLicensePro()
static member IsLicensePro : unit -> bool

Return Value

Type: Boolean
true if it is a professional license
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsLicenseStd Method

AddFlowLicenseProviderIsLicenseStd Method
Indicates if it is a standard license

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLicenseStd()
Public Shared Function IsLicenseStd As Boolean
public:
static bool IsLicenseStd()
static member IsLicenseStd : unit -> bool

Return Value

Type: Boolean
true if it is a standard license
See Also

Reference

AddFlowLicenseProvider Class


AfterAddCaptionEventArgs Class

AfterAddCaptionEventArgs Class
Event parameters used for the AfterAddCaption event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterAddCaptionEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterAddCaptionEventArgs : EventArgs
Public Class AfterAddCaptionEventArgs
    Inherits EventArgs
public ref class AfterAddCaptionEventArgs : public EventArgs
type AfterAddCaptionEventArgs =
    class
        inherit EventArgs
    end

The AfterAddCaptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterAddCaptionEventArgs | Constructor. Creates a new AfterAddCaptionEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Caption | The caption that has just been created (read-only
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterAddCaptionEventArgs Constructor

AfterAddCaptionEventArgs Constructor
Constructor. Creates a new AfterAddCaptionEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterAddCaptionEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
AfterAddCaptionEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> AfterAddCaptionEventArgs

Parameters

caption
Type: Lassalle.FlowCaption
The created caption
See Also

Reference

AfterAddCaptionEventArgs Class


AfterAddCaptionEventArgs Methods

AfterAddCaptionEventArgs Methods

The AfterAddCaptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterAddCaptionEventArgs Class


AfterAddCaptionEventArgs Properties

AfterAddCaptionEventArgs Properties

The AfterAddCaptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption that has just been created (read-only
Top
See Also

Reference

AfterAddCaptionEventArgs Class


AfterAddCaptionEventArgs.Caption Property

AfterAddCaptionEventArgsCaption Property
The caption that has just been created (read-only

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

AfterAddCaptionEventArgs Class


AfterAddLinkEventArgs Class

AfterAddLinkEventArgs Class
Event parameters used for the AfterAddLink event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterAddLinkEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterAddLinkEventArgs : EventArgs
Public Class AfterAddLinkEventArgs
    Inherits EventArgs
public ref class AfterAddLinkEventArgs : public EventArgs
type AfterAddLinkEventArgs =
    class
        inherit EventArgs
    end

The AfterAddLinkEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterAddLinkEventArgs | Constructor. Creates a new AfterAddLinkEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Link | The link that has just been created (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterAddLinkEventArgs Constructor

AfterAddLinkEventArgs Constructor
Constructor. Creates a new AfterAddLinkEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterAddLinkEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
AfterAddLinkEventArgs(
    Link^ link
)
new :
        link : Link -> AfterAddLinkEventArgs

Parameters

link
Type: Lassalle.FlowLink
The created link
See Also

Reference

AfterAddLinkEventArgs Class


AfterAddLinkEventArgs Methods

AfterAddLinkEventArgs Methods

The AfterAddLinkEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterAddLinkEventArgs Class


AfterAddLinkEventArgs Properties

AfterAddLinkEventArgs Properties

The AfterAddLinkEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Link | The link that has just been created (read-only)
Top
See Also

Reference

AfterAddLinkEventArgs Class


AfterAddLinkEventArgs.Link Property

AfterAddLinkEventArgsLink Property
The link that has just been created (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

AfterAddLinkEventArgs Class


AfterAddNodeEventArgs Class

AfterAddNodeEventArgs Class
Event parameters used for the AfterAddNode event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterAddNodeEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterAddNodeEventArgs : EventArgs
Public Class AfterAddNodeEventArgs
    Inherits EventArgs
public ref class AfterAddNodeEventArgs : public EventArgs
type AfterAddNodeEventArgs =
    class
        inherit EventArgs
    end

The AfterAddNodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterAddNodeEventArgs | Constructor. Creates a new AfterAddNodeEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node | The node that has just been created (read-only
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterAddNodeEventArgs Constructor

AfterAddNodeEventArgs Constructor
Constructor. Creates a new AfterAddNodeEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterAddNodeEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
AfterAddNodeEventArgs(
    Node^ node
)
new :
        node : Node -> AfterAddNodeEventArgs

Parameters

node
Type: Lassalle.FlowNode
The created node
See Also

Reference

AfterAddNodeEventArgs Class


AfterAddNodeEventArgs Methods

AfterAddNodeEventArgs Methods

The AfterAddNodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterAddNodeEventArgs Class


AfterAddNodeEventArgs Properties

AfterAddNodeEventArgs Properties

The AfterAddNodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | The node that has just been created (read-only
Top
See Also

Reference

AfterAddNodeEventArgs Class


AfterAddNodeEventArgs.Node Property

AfterAddNodeEventArgsNode Property
The node that has just been created (read-only

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

AfterAddNodeEventArgs Class


AfterEditEventArgs Class

AfterEditEventArgs Class
Event parameters used for the AfterEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterEditEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterEditEventArgs : EventArgs
Public Class AfterEditEventArgs
    Inherits EventArgs
public ref class AfterEditEventArgs : public EventArgs
type AfterEditEventArgs =
    class
        inherit EventArgs
    end

The AfterEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterEditEventArgs | Constructor. Creates a new AfterEditEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem object that is going to be edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem object being edited.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterEditEventArgs Constructor

AfterEditEventArgs Constructor
Constructor. Creates a new AfterEditEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterEditEventArgs(
    string text,
    ContentItem contentItem
)
Public Sub New (
    text As String,
    contentItem As ContentItem
)
public:
AfterEditEventArgs(
    String^ text,
    ContentItem^ contentItem
)
new :
        text : string *
        contentItem : ContentItem -> AfterEditEventArgs

Parameters

text
Type: SystemString
Text of the ContentItem object being edited.
contentItem
Type: Lassalle.FlowContentItem
A reference to the ContentItem object that has just been edited.
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs Methods

AfterEditEventArgs Methods

The AfterEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs Properties

AfterEditEventArgs Properties

The AfterEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem object that is going to be edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem object being edited.
Top
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.Cancel Property

AfterEditEventArgsCancel Property
Gets/sets a value indicating whether the edition should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.ContentItem Property

AfterEditEventArgsContentItem Property
The ContentItem object that is going to be edited (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.Text Property

AfterEditEventArgsText Property
Gets/sets the text of the ContentItem object being edited.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

AfterEditEventArgs Class


AfterRemoveCaptionEventArgs Class

AfterRemoveCaptionEventArgs Class
Event parameters used for the AfterRemoveCaption event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterRemoveCaptionEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterRemoveCaptionEventArgs : EventArgs
Public Class AfterRemoveCaptionEventArgs
    Inherits EventArgs
public ref class AfterRemoveCaptionEventArgs : public EventArgs
type AfterRemoveCaptionEventArgs =
    class
        inherit EventArgs
    end

The AfterRemoveCaptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterRemoveCaptionEventArgs | Constructor. Creates a new AfterRemoveCaptionEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Caption | The caption that has just been removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterRemoveCaptionEventArgs Constructor

AfterRemoveCaptionEventArgs Constructor
Constructor. Creates a new AfterRemoveCaptionEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterRemoveCaptionEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
AfterRemoveCaptionEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> AfterRemoveCaptionEventArgs

Parameters

caption
Type: Lassalle.FlowCaption
The removed caption
See Also

Reference

AfterRemoveCaptionEventArgs Class


AfterRemoveCaptionEventArgs Methods

AfterRemoveCaptionEventArgs Methods

The AfterRemoveCaptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterRemoveCaptionEventArgs Class


AfterRemoveCaptionEventArgs Properties

AfterRemoveCaptionEventArgs Properties

The AfterRemoveCaptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption that has just been removed (read-only)
Top
See Also

Reference

AfterRemoveCaptionEventArgs Class


AfterRemoveCaptionEventArgs.Caption Property

AfterRemoveCaptionEventArgsCaption Property
The caption that has just been removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

AfterRemoveCaptionEventArgs Class


AfterRemoveLinkEventArgs Class

AfterRemoveLinkEventArgs Class
Event parameters used for the AfterRemoveLink event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterRemoveLinkEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterRemoveLinkEventArgs : EventArgs
Public Class AfterRemoveLinkEventArgs
    Inherits EventArgs
public ref class AfterRemoveLinkEventArgs : public EventArgs
type AfterRemoveLinkEventArgs =
    class
        inherit EventArgs
    end

The AfterRemoveLinkEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterRemoveLinkEventArgs | Constructor. Creates a new AfterRemoveLinkEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterRemoveLinkEventArgs Constructor

AfterRemoveLinkEventArgs Constructor
Constructor. Creates a new AfterRemoveLinkEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterRemoveLinkEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
AfterRemoveLinkEventArgs(
    Link^ link
)
new :
        link : Link -> AfterRemoveLinkEventArgs

Parameters

link
Type: Lassalle.FlowLink
The removed link
See Also

Reference

AfterRemoveLinkEventArgs Class


AfterRemoveLinkEventArgs Methods

AfterRemoveLinkEventArgs Methods

The AfterRemoveLinkEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterRemoveLinkEventArgs Class


AfterRemoveLinkEventArgs Properties

AfterRemoveLinkEventArgs Properties

The AfterRemoveLinkEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

AfterRemoveLinkEventArgs Class


AfterRemoveLinkEventArgs.Link Property

AfterRemoveLinkEventArgsLink Property
The link that has just been removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

AfterRemoveLinkEventArgs Class


AfterRemoveNodeEventArgs Class

AfterRemoveNodeEventArgs Class
Event parameters used for the AfterRemoveNode event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowAfterRemoveNodeEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class AfterRemoveNodeEventArgs : EventArgs
Public Class AfterRemoveNodeEventArgs
    Inherits EventArgs
public ref class AfterRemoveNodeEventArgs : public EventArgs
type AfterRemoveNodeEventArgs =
    class
        inherit EventArgs
    end

The AfterRemoveNodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterRemoveNodeEventArgs | Constructor. Creates a new AfterRemoveNodeEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


AfterRemoveNodeEventArgs Constructor

AfterRemoveNodeEventArgs Constructor
Constructor. Creates a new AfterRemoveNodeEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AfterRemoveNodeEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
AfterRemoveNodeEventArgs(
    Node^ node
)
new :
        node : Node -> AfterRemoveNodeEventArgs

Parameters

node
Type: Lassalle.FlowNode
The removed node
See Also

Reference

AfterRemoveNodeEventArgs Class


AfterRemoveNodeEventArgs Methods

AfterRemoveNodeEventArgs Methods

The AfterRemoveNodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AfterRemoveNodeEventArgs Class


AfterRemoveNodeEventArgs Properties

AfterRemoveNodeEventArgs Properties

The AfterRemoveNodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

AfterRemoveNodeEventArgs Class


AfterRemoveNodeEventArgs.Node Property

AfterRemoveNodeEventArgsNode Property
The node that has just been removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

AfterRemoveNodeEventArgs Class


BackMode Enumeration

BackMode Enumeration
Used to specify whether the background will remain untouched or not for the text in a node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum BackMode
Public Enumeration BackMode
public enum class BackMode
type BackMode
Members
Member name | Value | Description
Transparent | 0 | The background remains untouched
Opaque | 1 | The background is filled with the background color before the text (default).
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeAddCaptionEventArgs Class

BeforeAddCaptionEventArgs Class
Event parameters used for the BeforeAddCaption event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeAddCaptionEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeAddCaptionEventArgs : EventArgs
Public Class BeforeAddCaptionEventArgs
    Inherits EventArgs
public ref class BeforeAddCaptionEventArgs : public EventArgs
type BeforeAddCaptionEventArgs =
    class
        inherit EventArgs
    end

The BeforeAddCaptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeAddCaptionEventArgs | Constructor. Creates a new BeforeAddCaptionEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption creation should be canceled.
Public property | Location | The location of the rectangle of the caption to create (read-only)
Public property | Rect | Returns rectangle of the caption to create
Public property | Size | The size of the rectangle of the caption to create (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeAddCaptionEventArgs Constructor

BeforeAddCaptionEventArgs Constructor
Constructor. Creates a new BeforeAddCaptionEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeAddCaptionEventArgs(
    RectangleF rectangle
)
Public Sub New (
    rectangle As RectangleF
)
public:
BeforeAddCaptionEventArgs(
    RectangleF rectangle
)
new :
        rectangle : RectangleF -> BeforeAddCaptionEventArgs

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the caption that is going to be created.
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs Methods

BeforeAddCaptionEventArgs Methods

The BeforeAddCaptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs Properties

BeforeAddCaptionEventArgs Properties

The BeforeAddCaptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption creation should be canceled.
Public property | Location | The location of the rectangle of the caption to create (read-only)
Public property | Rect | Returns rectangle of the caption to create
Public property | Size | The size of the rectangle of the caption to create (read-only)
Top
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs.Cancel Property

BeforeAddCaptionEventArgsCancel Property
Gets/sets a value indicating whether the caption creation should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs.Location Property

BeforeAddCaptionEventArgsLocation Property
The location of the rectangle of the caption to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PointF Location { get; set; }
Public Property Location As PointF
    Get
    Set
public:
property PointF Location {
    PointF get ();
    void set (PointF value);
}
member Location : PointF with get, set

Property Value

Type: PointF
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs.Rect Property

BeforeAddCaptionEventArgsRect Property
Returns rectangle of the caption to create

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public RectangleF Rect { get; set; }
Public Property Rect As RectangleF
    Get
    Set
public:
property RectangleF Rect {
    RectangleF get ();
    void set (RectangleF value);
}
member Rect : RectangleF with get, set

Property Value

Type: RectangleF
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddCaptionEventArgs.Size Property

BeforeAddCaptionEventArgsSize Property
The size of the rectangle of the caption to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SizeF Size { get; set; }
Public Property Size As SizeF
    Get
    Set
public:
property SizeF Size {
    SizeF get ();
    void set (SizeF value);
}
member Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

BeforeAddCaptionEventArgs Class


BeforeAddLinkEventArgs Class

BeforeAddLinkEventArgs Class
Event parameters used for the BeforeAddLink event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeAddLinkEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeAddLinkEventArgs : EventArgs
Public Class BeforeAddLinkEventArgs
    Inherits EventArgs
public ref class BeforeAddLinkEventArgs : public EventArgs
type BeforeAddLinkEventArgs =
    class
        inherit EventArgs
    end

The BeforeAddLinkEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeAddLinkEventArgs | Constructor. Creates a new BeforeAddLinkEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeAddLinkEventArgs Constructor

BeforeAddLinkEventArgs Constructor
Constructor. Creates a new BeforeAddLinkEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeAddLinkEventArgs(
    Node org,
    Node dst
)
Public Sub New (
    org As Node,
    dst As Node
)
public:
BeforeAddLinkEventArgs(
    Node^ org,
    Node^ dst
)
new :
        org : Node *
        dst : Node -> BeforeAddLinkEventArgs

Parameters

org
Type: Lassalle.FlowNode
The origin node of the link that is going to be created
dst
Type: Lassalle.FlowNode
The destination node of the link that is going to be created
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs Methods

BeforeAddLinkEventArgs Methods

The BeforeAddLinkEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs Properties

BeforeAddLinkEventArgs Properties

The BeforeAddLinkEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Cancel Property

BeforeAddLinkEventArgsCancel Property
Gets/sets a value indicating whether the link creation should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Dst Property

BeforeAddLinkEventArgsDst Property
The destination node of the link to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; }
Public ReadOnly Property Dst As Node
    Get
public:
property Node^ Dst {
    Node^ get ();
}
member Dst : Node with get

Property Value

Type: Node
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Org Property

BeforeAddLinkEventArgsOrg Property
The origin node of the link to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; }
Public ReadOnly Property Org As Node
    Get
public:
property Node^ Org {
    Node^ get ();
}
member Org : Node with get

Property Value

Type: Node
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddNodeEventArgs Class

BeforeAddNodeEventArgs Class
Event parameters used for the BeforeAddNode event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeAddNodeEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeAddNodeEventArgs : EventArgs
Public Class BeforeAddNodeEventArgs
    Inherits EventArgs
public ref class BeforeAddNodeEventArgs : public EventArgs
type BeforeAddNodeEventArgs =
    class
        inherit EventArgs
    end

The BeforeAddNodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeAddNodeEventArgs | Constructor. Creates a new BeforeAddNodeEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Location | The location of the rectangle of the node to create (read-only)
Public property | Rect | Returns rectangle of the node to create
Public property | Size | The size of the rectangle of the node to create (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeAddNodeEventArgs Constructor

BeforeAddNodeEventArgs Constructor
Constructor. Creates a new BeforeAddNodeEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeAddNodeEventArgs(
    RectangleF rectangle
)
Public Sub New (
    rectangle As RectangleF
)
public:
BeforeAddNodeEventArgs(
    RectangleF rectangle
)
new :
        rectangle : RectangleF -> BeforeAddNodeEventArgs

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the node that is going to be created.
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs Methods

BeforeAddNodeEventArgs Methods

The BeforeAddNodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs Properties

BeforeAddNodeEventArgs Properties

The BeforeAddNodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Location | The location of the rectangle of the node to create (read-only)
Public property | Rect | Returns rectangle of the node to create
Public property | Size | The size of the rectangle of the node to create (read-only)
Top
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs.Cancel Property

BeforeAddNodeEventArgsCancel Property
Gets/sets a value indicating whether the link creation should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs.Location Property

BeforeAddNodeEventArgsLocation Property
The location of the rectangle of the node to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PointF Location { get; set; }
Public Property Location As PointF
    Get
    Set
public:
property PointF Location {
    PointF get ();
    void set (PointF value);
}
member Location : PointF with get, set

Property Value

Type: PointF
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs.Rect Property

BeforeAddNodeEventArgsRect Property
Returns rectangle of the node to create

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public RectangleF Rect { get; set; }
Public Property Rect As RectangleF
    Get
    Set
public:
property RectangleF Rect {
    RectangleF get ();
    void set (RectangleF value);
}
member Rect : RectangleF with get, set

Property Value

Type: RectangleF
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeAddNodeEventArgs.Size Property

BeforeAddNodeEventArgsSize Property
The size of the rectangle of the node to create (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SizeF Size { get; set; }
Public Property Size As SizeF
    Get
    Set
public:
property SizeF Size {
    SizeF get ();
    void set (SizeF value);
}
member Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

BeforeAddNodeEventArgs Class


BeforeChangeDstEventArgs Class

BeforeChangeDstEventArgs Class
Event parameters used for the BeforeChangeDst event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeChangeDstEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeChangeDstEventArgs : EventArgs
Public Class BeforeChangeDstEventArgs
    Inherits EventArgs
public ref class BeforeChangeDstEventArgs : public EventArgs
type BeforeChangeDstEventArgs =
    class
        inherit EventArgs
    end

The BeforeChangeDstEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeChangeDstEventArgs | Constructor. Creates a new BeforeChangeDsttEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Dst | The new destination node (read-only)
Public property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeChangeDstEventArgs Constructor

BeforeChangeDstEventArgs Constructor
Constructor. Creates a new BeforeChangeDsttEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeChangeDstEventArgs(
    Link link,
    Node dst
)
Public Sub New (
    link As Link,
    dst As Node
)
public:
BeforeChangeDstEventArgs(
    Link^ link,
    Node^ dst
)
new :
        link : Link *
        dst : Node -> BeforeChangeDstEventArgs

Parameters

link
Type: Lassalle.FlowLink
The created link
dst
Type: Lassalle.FlowNode
The new destination node
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeDstEventArgs Methods

BeforeChangeDstEventArgs Methods

The BeforeChangeDstEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeDstEventArgs Properties

BeforeChangeDstEventArgs Properties

The BeforeChangeDstEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Dst | The new destination node (read-only)
Public property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeDstEventArgs.Cancel Property

BeforeChangeDstEventArgsCancel Property
Gets/sets a value indicating whether the change of the destination node of the link should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeDstEventArgs.Dst Property

BeforeChangeDstEventArgsDst Property
The new destination node (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; }
Public ReadOnly Property Dst As Node
    Get
public:
property Node^ Dst {
    Node^ get ();
}
member Dst : Node with get

Property Value

Type: Node
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeDstEventArgs.Link Property

BeforeChangeDstEventArgsLink Property
The link whose destination node is changed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

BeforeChangeDstEventArgs Class


BeforeChangeOrgEventArgs Class

BeforeChangeOrgEventArgs Class
Event parameters used for the BeforeChangeOrg event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeChangeOrgEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeChangeOrgEventArgs : EventArgs
Public Class BeforeChangeOrgEventArgs
    Inherits EventArgs
public ref class BeforeChangeOrgEventArgs : public EventArgs
type BeforeChangeOrgEventArgs =
    class
        inherit EventArgs
    end

The BeforeChangeOrgEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeChangeOrgEventArgs | Constructor. Creates a new BeforeChangeDsttEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | Org | The new origin node (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeChangeOrgEventArgs Constructor

BeforeChangeOrgEventArgs Constructor
Constructor. Creates a new BeforeChangeDsttEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeChangeOrgEventArgs(
    Link link,
    Node org
)
Public Sub New (
    link As Link,
    org As Node
)
public:
BeforeChangeOrgEventArgs(
    Link^ link,
    Node^ org
)
new :
        link : Link *
        org : Node -> BeforeChangeOrgEventArgs

Parameters

link
Type: Lassalle.FlowLink
The created link
org
Type: Lassalle.FlowNode
The new origin node
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeChangeOrgEventArgs Methods

BeforeChangeOrgEventArgs Methods

The BeforeChangeOrgEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeChangeOrgEventArgs Properties

BeforeChangeOrgEventArgs Properties

The BeforeChangeOrgEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | Org | The new origin node (read-only)
Top
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeChangeOrgEventArgs.Cancel Property

BeforeChangeOrgEventArgsCancel Property
Gets/sets a value indicating whether the change of the origin node of the link should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeChangeOrgEventArgs.Link Property

BeforeChangeOrgEventArgsLink Property
The link whose origin node is changed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeChangeOrgEventArgs.Org Property

BeforeChangeOrgEventArgsOrg Property
The new origin node (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; }
Public ReadOnly Property Org As Node
    Get
public:
property Node^ Org {
    Node^ get ();
}
member Org : Node with get

Property Value

Type: Node
See Also

Reference

BeforeChangeOrgEventArgs Class


BeforeEditEventArgs Class

BeforeEditEventArgs Class
Event parameters used for the BeforeEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeEditEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeEditEventArgs : EventArgs
Public Class BeforeEditEventArgs
    Inherits EventArgs
public ref class BeforeEditEventArgs : public EventArgs
type BeforeEditEventArgs =
    class
        inherit EventArgs
    end

The BeforeEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeEditEventArgs | Default constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem object that is going to be edited (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeEditEventArgs Constructor

BeforeEditEventArgs Constructor
Default constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeEditEventArgs(
    ContentItem contentItem
)
Public Sub New (
    contentItem As ContentItem
)
public:
BeforeEditEventArgs(
    ContentItem^ contentItem
)
new :
        contentItem : ContentItem -> BeforeEditEventArgs

Parameters

contentItem
Type: Lassalle.FlowContentItem
A reference to the ContentItem object that is going to be edited.
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs Methods

BeforeEditEventArgs Methods

The BeforeEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs Properties

BeforeEditEventArgs Properties

The BeforeEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem object that is going to be edited (read-only)
Top
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs.Cancel Property

BeforeEditEventArgsCancel Property
Gets/sets a value indicating whether the edition should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs.ContentItem Property

BeforeEditEventArgsContentItem Property
The ContentItem object that is going to be edited (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

BeforeEditEventArgs Class


BeforeRemoveCaptionEventArgs Class

BeforeRemoveCaptionEventArgs Class
Event parameters used for the beforeRemoveCaption event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeRemoveCaptionEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeRemoveCaptionEventArgs : EventArgs
Public Class BeforeRemoveCaptionEventArgs
    Inherits EventArgs
public ref class BeforeRemoveCaptionEventArgs : public EventArgs
type BeforeRemoveCaptionEventArgs =
    class
        inherit EventArgs
    end

The BeforeRemoveCaptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeRemoveCaptionEventArgs | Constructor. Creates a new BeforeRemoveCaptionEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption removing should be canceled.
Public property | Caption | The caption to be removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeRemoveCaptionEventArgs Constructor

BeforeRemoveCaptionEventArgs Constructor
Constructor. Creates a new BeforeRemoveCaptionEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeRemoveCaptionEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
BeforeRemoveCaptionEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> BeforeRemoveCaptionEventArgs

Parameters

caption
Type: Lassalle.FlowCaption
The caption to be removed
See Also

Reference

BeforeRemoveCaptionEventArgs Class


BeforeRemoveCaptionEventArgs Methods

BeforeRemoveCaptionEventArgs Methods

The BeforeRemoveCaptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeRemoveCaptionEventArgs Class


BeforeRemoveCaptionEventArgs Properties

BeforeRemoveCaptionEventArgs Properties

The BeforeRemoveCaptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption removing should be canceled.
Public property | Caption | The caption to be removed (read-only)
Top
See Also

Reference

BeforeRemoveCaptionEventArgs Class


BeforeRemoveCaptionEventArgs.Cancel Property

BeforeRemoveCaptionEventArgsCancel Property
Gets/sets a value indicating whether the caption removing should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeRemoveCaptionEventArgs Class


BeforeRemoveCaptionEventArgs.Caption Property

BeforeRemoveCaptionEventArgsCaption Property
The caption to be removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

BeforeRemoveCaptionEventArgs Class


BeforeRemoveLinkEventArgs Class

BeforeRemoveLinkEventArgs Class
Event parameters used for the BeforeRemoveLink event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeRemoveLinkEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeRemoveLinkEventArgs : EventArgs
Public Class BeforeRemoveLinkEventArgs
    Inherits EventArgs
public ref class BeforeRemoveLinkEventArgs : public EventArgs
type BeforeRemoveLinkEventArgs =
    class
        inherit EventArgs
    end

The BeforeRemoveLinkEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeRemoveLinkEventArgs | Constructor. Creates a new BeforeRemoveLinkEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link removing should be canceled.
Public property | Link | The link to be removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeRemoveLinkEventArgs Constructor

BeforeRemoveLinkEventArgs Constructor
Constructor. Creates a new BeforeRemoveLinkEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeRemoveLinkEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
BeforeRemoveLinkEventArgs(
    Link^ link
)
new :
        link : Link -> BeforeRemoveLinkEventArgs

Parameters

link
Type: Lassalle.FlowLink
The link to be removed
See Also

Reference

BeforeRemoveLinkEventArgs Class


BeforeRemoveLinkEventArgs Methods

BeforeRemoveLinkEventArgs Methods

The BeforeRemoveLinkEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeRemoveLinkEventArgs Class


BeforeRemoveLinkEventArgs Properties

BeforeRemoveLinkEventArgs Properties

The BeforeRemoveLinkEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link removing should be canceled.
Public property | Link | The link to be removed (read-only)
Top
See Also

Reference

BeforeRemoveLinkEventArgs Class


BeforeRemoveLinkEventArgs.Cancel Property

BeforeRemoveLinkEventArgsCancel Property
Gets/sets a value indicating whether the link removing should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeRemoveLinkEventArgs Class


BeforeRemoveLinkEventArgs.Link Property

BeforeRemoveLinkEventArgsLink Property
The link to be removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

BeforeRemoveLinkEventArgs Class


BeforeRemoveNodeEventArgs Class

BeforeRemoveNodeEventArgs Class
Event parameters used for the beforeRemoveNode event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowBeforeRemoveNodeEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class BeforeRemoveNodeEventArgs : EventArgs
Public Class BeforeRemoveNodeEventArgs
    Inherits EventArgs
public ref class BeforeRemoveNodeEventArgs : public EventArgs
type BeforeRemoveNodeEventArgs =
    class
        inherit EventArgs
    end

The BeforeRemoveNodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeRemoveNodeEventArgs | Constructor. Creates a new BeforeRemoveNodeEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node removing should be canceled.
Public property | Node | The node to be removed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


BeforeRemoveNodeEventArgs Constructor

BeforeRemoveNodeEventArgs Constructor
Constructor. Creates a new BeforeRemoveNodeEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BeforeRemoveNodeEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
BeforeRemoveNodeEventArgs(
    Node^ node
)
new :
        node : Node -> BeforeRemoveNodeEventArgs

Parameters

node
Type: Lassalle.FlowNode
The node to be removed
See Also

Reference

BeforeRemoveNodeEventArgs Class


BeforeRemoveNodeEventArgs Methods

BeforeRemoveNodeEventArgs Methods

The BeforeRemoveNodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeRemoveNodeEventArgs Class


BeforeRemoveNodeEventArgs Properties

BeforeRemoveNodeEventArgs Properties

The BeforeRemoveNodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node removing should be canceled.
Public property | Node | The node to be removed (read-only)
Top
See Also

Reference

BeforeRemoveNodeEventArgs Class


BeforeRemoveNodeEventArgs.Cancel Property

BeforeRemoveNodeEventArgsCancel Property
Gets/sets a value indicating whether the node removing should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeRemoveNodeEventArgs Class


BeforeRemoveNodeEventArgs.Node Property

BeforeRemoveNodeEventArgsNode Property
The node to be removed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

BeforeRemoveNodeEventArgs Class


CancelEditEventArgs Class

CancelEditEventArgs Class
Event parameters used for the CancelEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowCancelEditEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class CancelEditEventArgs : EventArgs
Public Class CancelEditEventArgs
    Inherits EventArgs
public ref class CancelEditEventArgs : public EventArgs
type CancelEditEventArgs =
    class
        inherit EventArgs
    end

The CancelEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CancelEditEventArgs | Constructor. Creates a new CancelEditEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContentItem | The ContentItem object that has just been edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem object being edited.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


CancelEditEventArgs Constructor

CancelEditEventArgs Constructor
Constructor. Creates a new CancelEditEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEditEventArgs(
    string text,
    ContentItem contentItem
)
Public Sub New (
    text As String,
    contentItem As ContentItem
)
public:
CancelEditEventArgs(
    String^ text,
    ContentItem^ contentItem
)
new :
        text : string *
        contentItem : ContentItem -> CancelEditEventArgs

Parameters

text
Type: SystemString
Text of the ContentItem object being edited.
contentItem
Type: Lassalle.FlowContentItem
A reference to the ContentItem object that has just been edited.
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs Methods

CancelEditEventArgs Methods

The CancelEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs Properties

CancelEditEventArgs Properties

The CancelEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContentItem | The ContentItem object that has just been edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem object being edited.
Top
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs.ContentItem Property

CancelEditEventArgsContentItem Property
The ContentItem object that has just been edited (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs.Text Property

CancelEditEventArgsText Property
Gets/sets the text of the ContentItem object being edited.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

CancelEditEventArgs Class


Caption Class

Caption Class
Represents a caption (also called label or note) in the diagram. A caption is a ContentItem object that can be owned by an Item
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Lassalle.FlowItem
Lassalle.FlowContentItem
Lassalle.FlowCaption

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class Caption : ContentItem
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class Caption
    Inherits ContentItem
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class Caption : public ContentItem
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type Caption =
    class
        inherit ContentItem
    end

The Caption type exposes the following members.

Constructors
 | Name | Description
Public method | Caption | Caption constructor
Public method | Caption(Single, Single, Single, Single, String, Item, AddFlow) | Initializes a new instance of the Caption class with an initial position and size, an initial text.
Public method | Caption(Single, Single, Single, Single, String, Item, Caption) | Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the node is drawn. (Inherited from ContentItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | AnchorPositionOnLink | Returns/sets a value which defines the position of the caption near the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | Dock | Returns/sets the DockStyle of the caption.
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor (Inherited from ContentItem.)
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node. (Inherited from ContentItem.)
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn. (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the node. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the node can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the node can be vertically resized or not. (Inherited from ContentItem.)
Public property | Location | Sets or returns the location of the node. (Overrides ContentItemLocation.)
Public property | Owner | Returns/sets the reference of the owner item of this caption
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the caption object. (Overrides ContentItemShapeFamily.)
Public property | Size | Sets or returns the size of the node. (Overrides ContentItemSize.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Caption Constructor

Caption Constructor
Overload List
 | Name | Description
Public method | Caption | Caption constructor
Public method | Caption(Single, Single, Single, Single, String, Item, AddFlow) | Initializes a new instance of the Caption class with an initial position and size, an initial text.
Public method | Caption(Single, Single, Single, Single, String, Item, Caption) | Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object
Top
See Also

Reference

Caption Class


Caption Constructor

Caption Constructor
Caption constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption()
Public Sub New
public:
Caption()
new : unit -> Caption
See Also

Reference

Caption Class
Caption Overload


Caption Constructor (Single, Single, Single, Single, String, Item, AddFlow)

Caption Constructor (Single, Single, Single, Single, String, Item, AddFlow)
Initializes a new instance of the Caption class with an initial position and size, an initial text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption(
    float left,
    float top,
    float width,
    float height,
    string text,
    Item owner,
    AddFlow addflow
)
Public Sub New (
    left As Single,
    top As Single,
    width As Single,
    height As Single,
    text As String,
    owner As Item,
    addflow As AddFlow
)
public:
Caption(
    float left,
    float top,
    float width,
    float height,
    String^ text,
    Item^ owner,
    AddFlow^ addflow
)
new :
        left : float32 *
        top : float32 *
        width : float32 *
        height : float32 *
        text : string *
        owner : Item *
        addflow : AddFlow -> Caption

Parameters

left
Type: SystemSingle
The x-coordinate of the caption position
top
Type: SystemSingle
The y-coordinate of the caption position
width
Type: SystemSingle
The horizontal size of the caption
height
Type: SystemSingle
The vertical size of the caption
text
Type: SystemString
The text displayed in the caption
owner
Type: Lassalle.FlowItem
The item that will own this caption
addflow
Type: Lassalle.FlowAddFlow
The AddFlow control that will supply default property values for the caption
See Also

Reference

Caption Class
Caption Overload


Caption Constructor (Single, Single, Single, Single, String, Item, Caption)

Caption Constructor (Single, Single, Single, Single, String, Item, Caption)
Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Caption(
    float left,
    float top,
    float width,
    float height,
    string text,
    Item owner,
    Caption caption
)
Public Sub New (
    left As Single,
    top As Single,
    width As Single,
    height As Single,
    text As String,
    owner As Item,
    caption As Caption
)
public:
Caption(
    float left,
    float top,
    float width,
    float height,
    String^ text,
    Item^ owner,
    Caption^ caption
)
new :
        left : float32 *
        top : float32 *
        width : float32 *
        height : float32 *
        text : string *
        owner : Item *
        caption : Caption -> Caption

Parameters

left
Type: SystemSingle
The x-coordinate of the caption position
top
Type: SystemSingle
The y-coordinate of the caption position
width
Type: SystemSingle
The horizontal size of the caption
height
Type: SystemSingle
The vertical size of the caption
text
Type: SystemString
The text of the caption
owner
Type: Lassalle.FlowItem
The item that will own this caption
caption
Type: Lassalle.FlowCaption
An object containing the default property values of captions.
See Also

Reference

Caption Class
Caption Overload


Caption Methods

Caption Methods

The Caption type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the node is drawn. (Inherited from ContentItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Caption Class


Caption Properties

Caption Properties

The Caption type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | AnchorPositionOnLink | Returns/sets a value which defines the position of the caption near the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | Dock | Returns/sets the DockStyle of the caption.
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor (Inherited from ContentItem.)
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node. (Inherited from ContentItem.)
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn. (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the node. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the node can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the node can be vertically resized or not. (Inherited from ContentItem.)
Public property | Location | Sets or returns the location of the node. (Overrides ContentItemLocation.)
Public property | Owner | Returns/sets the reference of the owner item of this caption
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the caption object. (Overrides ContentItemShapeFamily.)
Public property | Size | Sets or returns the size of the node. (Overrides ContentItemSize.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Caption Class


Caption.AnchorPositionOnLink Property

CaptionAnchorPositionOnLink Property
Returns/sets a value which defines the position of the caption near the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float AnchorPositionOnLink { get; set; }
Public Property AnchorPositionOnLink As Single
    Get
    Set
public:
property float AnchorPositionOnLink {
    float get ();
    void set (float value);
}
member AnchorPositionOnLink : float32 with get, set

Property Value

Type: Single
Remarks
It is a value betwwen 0 and 1. If it is 0, then the caption is placed near the origin node of the link. If it is 1, then the caption is placed near the destination node of the link. If it is for instance 0.5, then the caption is placed near the middle of the link.
See Also

Reference

Caption Class


Caption.Dock Property

CaptionDock Property
Returns/sets the DockStyle of the caption.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public DockStyle Dock { get; set; }
Public Property Dock As DockStyle
    Get
    Set
public:
property DockStyle Dock {
    DockStyle get ();
    void set (DockStyle value);
}
member Dock : DockStyle with get, set

Property Value

Type: DockStyle
Remarks
This property is relevant only if the caption is attached to a ContentItem object
See Also

Reference

Caption Class


Caption.Location Property

CaptionLocation Property
Sets or returns the location of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override PointF Location { get; set; }
Public Overrides Property Location As PointF
    Get
    Set
public:
virtual property PointF Location {
    PointF get () override;
    void set (PointF value) override;
}
abstract Location : PointF with get, set
override Location : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Caption Class


Caption.Owner Property

CaptionOwner Property
Returns/sets the reference of the owner item of this caption

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item Owner { get; set; }
Public Property Owner As Item
    Get
    Set
public:
property Item^ Owner {
    Item^ get ();
    void set (Item^ value);
}
member Owner : Item with get, set

Property Value

Type: Item
See Also

Reference

Caption Class


Caption.ShapeFamily Property

CaptionShapeFamily Property
Returns/sets the shape family style of the caption object.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override ShapeFamily ShapeFamily { get; set; }
Public Overrides Property ShapeFamily As ShapeFamily
    Get
    Set
public:
virtual property ShapeFamily ShapeFamily {
    ShapeFamily get () override;
    void set (ShapeFamily value) override;
}
abstract ShapeFamily : ShapeFamily with get, set
override ShapeFamily : ShapeFamily with get, set

Property Value

Type: ShapeFamily
Remarks
If the GraphicsPath property is null, then this is this shape that will be used to draw the caption
See Also

Reference

Caption Class


Caption.Size Property

CaptionSize Property
Sets or returns the size of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override SizeF Size { get; set; }
Public Overrides Property Size As SizeF
    Get
    Set
public:
virtual property SizeF Size {
    SizeF get () override;
    void set (SizeF value) override;
}
abstract Size : SizeF with get, set
override Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

Caption Class


ContentItem Class

ContentItem Class
Represents an Item object that has a content which may be a string or/and an image. Nodes and captions are ContentItem objects.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Lassalle.FlowItem
Lassalle.FlowContentItem
Lassalle.FlowCaption
Lassalle.FlowNode

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ContentItem : Item,
    IMoveable, ISizeable
Public MustInherit Class ContentItem
    Inherits Item
    Implements IMoveable, ISizeable
public ref class ContentItem abstract : public Item,
    IMoveable, ISizeable
[<AbstractClassAttribute>]
type ContentItem =
    class
        inherit Item
        interface IMoveable
        interface ISizeable
    end

The ContentItem type exposes the following members.

Constructors
 | Name | Description
Protected method | ContentItem | Initializes a new instance of the ContentItem class
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the node is drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized.
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node.
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn.
Public property | Image | Returns/sets the image displayed in the node.
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node.
Public property | ImagePosition | Returns/sets the picture position in the node.
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not.
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not.
Public property | IsYMoveable | Determines whether the node can be vertically moved or not.
Public property | IsYSizeable | Determines whether the node can be vertically resized or not.
Public property | Location | Sets or returns the location of the item.
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the node object.
Public property | Size | Sets or returns the size of the item.
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node.
Public property | TextPosition | Returns/sets the position style of the text of the node.
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
Remarks
The main purpose is to provide common methods and properties for nodes and captions. Note that it is an abstract class. You cannot use it directly but instead use objects that derive from Node or Caption classes.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ContentItem Constructor

ContentItem Constructor
Initializes a new instance of the ContentItem class

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected ContentItem()
Protected Sub New
protected:
ContentItem()
new : unit -> ContentItem
See Also

Reference

ContentItem Class


ContentItem Methods

ContentItem Methods

The ContentItem type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the node is drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized.
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContentItem Class


ContentItem.BeginEdit Method

ContentItemBeginEdit Method
Initiates the editing of the ContentItem text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginEdit()
Public Sub BeginEdit
public:
void BeginEdit()
member BeginEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.CancelEdit Method

ContentItemCancelEdit Method
Cancels the editing of the ContentItem text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void CancelEdit()
Public Sub CancelEdit
public:
void CancelEdit()
member CancelEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.EndEdit Method

ContentItemEndEdit Method
Ends the editing of the ContentItem text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EndEdit()
Public Sub EndEdit
public:
void EndEdit()
member EndEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.GetPath Method

ContentItemGetPath Method
Returns the path information which defines how the node is drawn.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath GetPath()
Public Function GetPath As GraphicsPath
public:
GraphicsPath^ GetPath()
member GetPath : unit -> GraphicsPath

Return Value

Type: GraphicsPath
The path
See Also

Reference

ContentItem Class


ContentItem.ShouldSerializeImageMargin Method

ContentItemShouldSerializeImageMargin Method
Returns true if ImageMargin should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeImageMargin()
Public Function ShouldSerializeImageMargin As Boolean
public:
bool ShouldSerializeImageMargin()
member ShouldSerializeImageMargin : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.ContentItem.ShouldSerializeImageMargin"]

See Also

Reference

ContentItem Class


ContentItem.ShouldSerializeTextMargin Method

ContentItemShouldSerializeTextMargin Method
Returns true if TextMargin should be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeTextMargin()
Public Function ShouldSerializeTextMargin As Boolean
public:
bool ShouldSerializeTextMargin()
member ShouldSerializeTextMargin : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.ContentItem.ShouldSerializeTextMargin"]

See Also

Reference

ContentItem Class


ContentItem Properties

ContentItem Properties

The ContentItem type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node.
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn.
Public property | Image | Returns/sets the image displayed in the node.
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node.
Public property | ImagePosition | Returns/sets the picture position in the node.
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not.
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not.
Public property | IsYMoveable | Determines whether the node can be vertically moved or not.
Public property | IsYSizeable | Determines whether the node can be vertically resized or not.
Public property | Location | Sets or returns the location of the item.
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the node object.
Public property | Size | Sets or returns the size of the item.
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node.
Public property | TextPosition | Returns/sets the position style of the text of the node.
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

ContentItem Class


ContentItem.GradientColor Property

ContentItemGradientColor Property
Returns/sets the color used to draw a gradient with the FillColor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color GradientColor { get; set; }
Public Property GradientColor As Color
    Get
    Set
public:
property Color GradientColor {
    Color get ();
    void set (Color value);
}
member GradientColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ContentItem Class


ContentItem.GradientMode Property

ContentItemGradientMode Property
Returns/sets the direction of the linear gradient when drawn in a node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public LinearGradientMode GradientMode { get; set; }
Public Property GradientMode As LinearGradientMode
    Get
    Set
public:
property LinearGradientMode GradientMode {
    LinearGradientMode get ();
    void set (LinearGradientMode value);
}
member GradientMode : LinearGradientMode with get, set

Property Value

Type: LinearGradientMode
See Also

Reference

ContentItem Class


ContentItem.GraphicsPath Property

ContentItemGraphicsPath Property
Returns/sets the path information which defines how the of the Shape object is drawn.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath GraphicsPath { get; set; }
Public Property GraphicsPath As GraphicsPath
    Get
    Set
public:
property GraphicsPath^ GraphicsPath {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
member GraphicsPath : GraphicsPath with get, set

Property Value

Type: GraphicsPath
Remarks
If this property is null, then the shape used is determined by the ShapeFamily property (ellipse or rectangle)
See Also

Reference

ContentItem Class


ContentItem.Image Property

ContentItemImage Property
Returns/sets the image displayed in the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

ContentItem Class


ContentItem.ImageMargin Property

ContentItemImageMargin Property
Returns/sets the size of the margins for the image of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Padding ImageMargin { get; set; }
Public Property ImageMargin As Padding
    Get
    Set
public:
property Padding ImageMargin {
    Padding get ();
    void set (Padding value);
}
member ImageMargin : Padding with get, set

Property Value

Type: Padding
See Also

Reference

ContentItem Class


ContentItem.ImagePosition Property

ContentItemImagePosition Property
Returns/sets the picture position in the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ImagePosition ImagePosition { get; set; }
Public Property ImagePosition As ImagePosition
    Get
    Set
public:
property ImagePosition ImagePosition {
    ImagePosition get ();
    void set (ImagePosition value);
}
member ImagePosition : ImagePosition with get, set

Property Value

Type: ImagePosition
See Also

Reference

ContentItem Class


ContentItem.IsEditable Property

ContentItemIsEditable Property
Returns/sets a value indicating whether the text of the ContentItem object can be edited

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}
member IsEditable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsEditing Property

ContentItemIsEditing Property
Returns/sets a value indicating whether the text of the ContentItem object is currently edited

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditing { get; set; }
Public Property IsEditing As Boolean
    Get
    Set
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}
member IsEditing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsXMoveable Property

ContentItemIsXMoveable Property
Determines whether the node can be horizontally moved or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsXMoveable { get; set; }
Public Property IsXMoveable As Boolean
    Get
    Set
public:
virtual property bool IsXMoveable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsXMoveable : bool with get, set
override IsXMoveable : bool with get, set

Property Value

Type: Boolean

Implements

IMoveableIsXMoveable
See Also

Reference

ContentItem Class


ContentItem.IsXSizeable Property

ContentItemIsXSizeable Property
Determines whether the node can be horizontally resized or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsXSizeable { get; set; }
Public Property IsXSizeable As Boolean
    Get
    Set
public:
virtual property bool IsXSizeable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsXSizeable : bool with get, set
override IsXSizeable : bool with get, set

Property Value

Type: Boolean

Implements

ISizeableIsXSizeable
See Also

Reference

ContentItem Class


ContentItem.IsYMoveable Property

ContentItemIsYMoveable Property
Determines whether the node can be vertically moved or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsYMoveable { get; set; }
Public Property IsYMoveable As Boolean
    Get
    Set
public:
virtual property bool IsYMoveable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsYMoveable : bool with get, set
override IsYMoveable : bool with get, set

Property Value

Type: Boolean

Implements

IMoveableIsYMoveable
See Also

Reference

ContentItem Class


ContentItem.IsYSizeable Property

ContentItemIsYSizeable Property
Determines whether the node can be vertically resized or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsYSizeable { get; set; }
Public Property IsYSizeable As Boolean
    Get
    Set
public:
virtual property bool IsYSizeable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsYSizeable : bool with get, set
override IsYSizeable : bool with get, set

Property Value

Type: Boolean

Implements

ISizeableIsYSizeable
See Also

Reference

ContentItem Class


ContentItem.Location Property

ContentItemLocation Property
Sets or returns the location of the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract PointF Location { get; set; }
Public MustOverride Property Location As PointF
    Get
    Set
public:
virtual property PointF Location {
    PointF get () abstract;
    void set (PointF value) abstract;
}
abstract Location : PointF with get, set

Property Value

Type: PointF
See Also

Reference

ContentItem Class


ContentItem.ShapeFamily Property

ContentItemShapeFamily Property
Returns/sets the shape family style of the node object.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ShapeFamily ShapeFamily { get; set; }
Public MustOverride Property ShapeFamily As ShapeFamily
    Get
    Set
public:
virtual property ShapeFamily ShapeFamily {
    ShapeFamily get () abstract;
    void set (ShapeFamily value) abstract;
}
abstract ShapeFamily : ShapeFamily with get, set

Property Value

Type: ShapeFamily
Remarks
If the GraphicsPath property is null, then this is this shape that will be used to draw the node
See Also

Reference

ContentItem Class


ContentItem.Size Property

ContentItemSize Property
Sets or returns the size of the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract SizeF Size { get; set; }
Public MustOverride Property Size As SizeF
    Get
    Set
public:
virtual property SizeF Size {
    SizeF get () abstract;
    void set (SizeF value) abstract;
}
abstract Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

ContentItem Class


ContentItem.TextMargin Property

ContentItemTextMargin Property
Returns/sets the size of the margins for the text of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Padding TextMargin { get; set; }
Public Property TextMargin As Padding
    Get
    Set
public:
property Padding TextMargin {
    Padding get ();
    void set (Padding value);
}
member TextMargin : Padding with get, set

Property Value

Type: Padding
See Also

Reference

ContentItem Class


ContentItem.TextPosition Property

ContentItemTextPosition Property
Returns/sets the position style of the text of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public TextPosition TextPosition { get; set; }
Public Property TextPosition As TextPosition
    Get
    Set
public:
property TextPosition TextPosition {
    TextPosition get ();
    void set (TextPosition value);
}
member TextPosition : TextPosition with get, set

Property Value

Type: TextPosition
See Also

Reference

ContentItem Class


ContentItemDrawFlags Enumeration

ContentItemDrawFlags Enumeration
Use to specify how the IsOwnerDraw property of a ContentItem object is used.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ContentItemDrawFlags
Public Enumeration ContentItemDrawFlags
public enum class ContentItemDrawFlags
type ContentItemDrawFlags
Members
Member name | Value | Description
None | 0 | The node is entirely drawn by the owner
Shape | 1 | AddFlow will draw the ContentItem object shape
Fill | 2 | AddFlow will fill the ContentItem object with the fill color
Text | 4 | AddFlow will draw the ContentItem object text
Image | 8 | AddFlow will draw the ContentItem object image
Shadow | 16 | AddFlow will draw the ContentItem object shadow
All | 31 | AddFlow will draw all the ContentItem object
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ContentItemOwnerDrawEventArgs Class

ContentItemOwnerDrawEventArgs Class
Event parameters used for the ContentItemOwnerDraw event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowContentItemOwnerDrawEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ContentItemOwnerDrawEventArgs : EventArgs
Public Class ContentItemOwnerDrawEventArgs
    Inherits EventArgs
public ref class ContentItemOwnerDrawEventArgs : public EventArgs
type ContentItemOwnerDrawEventArgs =
    class
        inherit EventArgs
    end

The ContentItemOwnerDrawEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ContentItemOwnerDrawEventArgs | Constructor. Creates a new ContentItemOwnerDrawEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContentItem | The contentItem object that is to be drawn (read-only)
Public property | Flags | Gets/sets a value indicating what is to be drawn for the contentItem object.
Public property | Graphics | The Graphics surface used to draw the contentItem object.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ContentItemOwnerDrawEventArgs Constructor

ContentItemOwnerDrawEventArgs Constructor
Constructor. Creates a new ContentItemOwnerDrawEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItemOwnerDrawEventArgs(
    ContentItem contentItem,
    Graphics graphics
)
Public Sub New (
    contentItem As ContentItem,
    graphics As Graphics
)
public:
ContentItemOwnerDrawEventArgs(
    ContentItem^ contentItem,
    Graphics^ graphics
)
new :
        contentItem : ContentItem *
        graphics : Graphics -> ContentItemOwnerDrawEventArgs

Parameters

contentItem
Type: Lassalle.FlowContentItem
The contentItem object that is to be drawn
graphics
Type: System.DrawingGraphics
The Graphics surface used to draw the diagram
See Also

Reference

ContentItemOwnerDrawEventArgs Class


ContentItemOwnerDrawEventArgs Methods

ContentItemOwnerDrawEventArgs Methods

The ContentItemOwnerDrawEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContentItemOwnerDrawEventArgs Class


ContentItemOwnerDrawEventArgs Properties

ContentItemOwnerDrawEventArgs Properties

The ContentItemOwnerDrawEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContentItem | The contentItem object that is to be drawn (read-only)
Public property | Flags | Gets/sets a value indicating what is to be drawn for the contentItem object.
Public property | Graphics | The Graphics surface used to draw the contentItem object.
Top
See Also

Reference

ContentItemOwnerDrawEventArgs Class


ContentItemOwnerDrawEventArgs.ContentItem Property

ContentItemOwnerDrawEventArgsContentItem Property
The contentItem object that is to be drawn (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

ContentItemOwnerDrawEventArgs Class


ContentItemOwnerDrawEventArgs.Flags Property

ContentItemOwnerDrawEventArgsFlags Property
Gets/sets a value indicating what is to be drawn for the contentItem object.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ContentItemDrawFlags Flags { get; set; }
Public Property Flags As ContentItemDrawFlags
    Get
    Set
public:
property ContentItemDrawFlags Flags {
    ContentItemDrawFlags get ();
    void set (ContentItemDrawFlags value);
}
member Flags : ContentItemDrawFlags with get, set

Property Value

Type: ContentItemDrawFlags
See Also

Reference

ContentItemOwnerDrawEventArgs Class


ContentItemOwnerDrawEventArgs.Graphics Property

ContentItemOwnerDrawEventArgsGraphics Property
The Graphics surface used to draw the contentItem object.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
member Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

ContentItemOwnerDrawEventArgs Class


CursorSetting Enumeration

CursorSetting Enumeration
Cursor settings

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum CursorSetting
Public Enumeration CursorSetting
public enum class CursorSetting
type CursorSetting
Members
Member name | Value | Description
None | 0 | No cursor setting
Resize | 1 | The resize cursors are used when resizing nodes
ResizeAndDrag | 2 | The resize cursors are used when resizing nodes and the drag cursors is used when dragging nodes
All | 3 | A distinct cursor is used for each interactive action
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


DiagramOwnerDrawEventArgs Class

DiagramOwnerDrawEventArgs Class
Event parameters used for the DiagramOwnerDraw event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowDiagramOwnerDrawEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class DiagramOwnerDrawEventArgs : EventArgs
Public Class DiagramOwnerDrawEventArgs
    Inherits EventArgs
public ref class DiagramOwnerDrawEventArgs : public EventArgs
type DiagramOwnerDrawEventArgs =
    class
        inherit EventArgs
    end

The DiagramOwnerDrawEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DiagramOwnerDrawEventArgs | Constructor. Creates a new DiagramOwnerDrawEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Flags | Gets/sets a value indicating what is to be drawn by AddFlow.
Public property | Graphics | The Graphics surface used to draw the diagram.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


DiagramOwnerDrawEventArgs Constructor

DiagramOwnerDrawEventArgs Constructor
Constructor. Creates a new DiagramOwnerDrawEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public DiagramOwnerDrawEventArgs(
    Graphics graphics
)
Public Sub New (
    graphics As Graphics
)
public:
DiagramOwnerDrawEventArgs(
    Graphics^ graphics
)
new :
        graphics : Graphics -> DiagramOwnerDrawEventArgs

Parameters

graphics
Type: System.DrawingGraphics
The Graphics surface used to draw the diagram
See Also

Reference

DiagramOwnerDrawEventArgs Class


DiagramOwnerDrawEventArgs Methods

DiagramOwnerDrawEventArgs Methods

The DiagramOwnerDrawEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiagramOwnerDrawEventArgs Class


DiagramOwnerDrawEventArgs Properties

DiagramOwnerDrawEventArgs Properties

The DiagramOwnerDrawEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Gets/sets a value indicating what is to be drawn by AddFlow.
Public property | Graphics | The Graphics surface used to draw the diagram.
Top
See Also

Reference

DiagramOwnerDrawEventArgs Class


DiagramOwnerDrawEventArgs.Flags Property

DiagramOwnerDrawEventArgsFlags Property
Gets/sets a value indicating what is to be drawn by AddFlow.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public DrawFlags Flags { get; set; }
Public Property Flags As DrawFlags
    Get
    Set
public:
property DrawFlags Flags {
    DrawFlags get ();
    void set (DrawFlags value);
}
member Flags : DrawFlags with get, set

Property Value

Type: DrawFlags
See Also

Reference

DiagramOwnerDrawEventArgs Class


DiagramOwnerDrawEventArgs.Graphics Property

DiagramOwnerDrawEventArgsGraphics Property
The Graphics surface used to draw the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
member Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

DiagramOwnerDrawEventArgs Class


DrawFlags Enumeration

DrawFlags Enumeration
Use to specify how the IsOwnerDraw property is used.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum DrawFlags
Public Enumeration DrawFlags
public enum class DrawFlags
type DrawFlags
Members
Member name | Value | Description
None | 0 | The diagram is entirely drawn by the owner
All | 1 | The diagram is entirely drawn by AddFlow
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ErrorEventArgs Class

ErrorEventArgs Class
Event parameters used for the Error event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowErrorEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorEventArgs : EventArgs
Public Class ErrorEventArgs
    Inherits EventArgs
public ref class ErrorEventArgs : public EventArgs
type ErrorEventArgs =
    class
        inherit EventArgs
    end

The ErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorEventArgs | Constructor. Creates a new ErrorEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ErrorEventArgs Constructor

ErrorEventArgs Constructor
Constructor. Creates a new ErrorEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorEventArgs(
    ErrorEventType errorEventType
)
Public Sub New (
    errorEventType As ErrorEventType
)
public:
ErrorEventArgs(
    ErrorEventType errorEventType
)
new :
        errorEventType : ErrorEventType -> ErrorEventArgs

Parameters

errorEventType
Type: Lassalle.FlowErrorEventType
The type of the error event
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs Methods

ErrorEventArgs Methods

The ErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs Properties

ErrorEventArgs Properties

The ErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs.ErrorEventType Property

ErrorEventArgsErrorEventType Property
The type of the error event (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorEventType ErrorEventType { get; }
Public ReadOnly Property ErrorEventType As ErrorEventType
    Get
public:
property ErrorEventType ErrorEventType {
    ErrorEventType get ();
}
member ErrorEventType : ErrorEventType with get

Property Value

Type: ErrorEventType
See Also

Reference

ErrorEventArgs Class


ErrorEventType Enumeration

ErrorEventType Enumeration
Used to specify the type of the Error event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ErrorEventType
Public Enumeration ErrorEventType
public enum class ErrorEventType
type ErrorEventType
Members
Member name | Value | Description
MultilinkError | 0 | Multiple links between 2 nodes are not accepted.
ReflexiveError | 1 | Reflexive links are not accepted.
IncomingLinkError | 2 | This node does not accept incoming links.
OutgoingLinkError | 3 | This node does not accept outgoing links.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


GridStyle Enumeration

GridStyle Enumeration
Used to specify the drawing style of the grid.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum GridStyle
Public Enumeration GridStyle
public enum class GridStyle
type GridStyle
Members
Member name | Value | Description
Pixels | 0 | Draws a grid of one-pixel dots
Lines | 1 | Draws a gid of lines
DottedLines | 2 | Draws a grid of dotted lines
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ImagePosition Enumeration

ImagePosition Enumeration
Used to specify the position of the image in the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImagePosition
Public Enumeration ImagePosition
public enum class ImagePosition
type ImagePosition
Members
Member name | Value | Description
LeftTop | 0 | Picture at the left top position of the node
LeftMiddle | 1 | Picture at the left middle position of the node
LeftBottom | 2 | Picture at the left bottom position of the node
RightTop | 3 | Picture at the right top position of the node
RightMiddle | 4 | Picture at the right middle position of the node
RightBottom | 5 | Picture at the right bottom position of the node
CenterTop | 6 | Picture at the center top position of the node
CenterMiddle | 7 | Picture at the center middle position of the node
CenterBottom | 8 | Picture at the center bottom position of the node
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


IMoveable Interface

IMoveable Interface
Common interface for items (nodes, captions) that can be moved

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMoveable
Public Interface IMoveable
public interface class IMoveable
type IMoveable =  interface end

The IMoveable type exposes the following members.

Properties
 | Name | Description
Public property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Public property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


IMoveable Properties

IMoveable Properties

The IMoveable type exposes the following members.

Properties
 | Name | Description
Public property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Public property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

IMoveable Interface


IMoveable.IsXMoveable Property

IMoveableIsXMoveable Property
Determines whether the item can be horizontally moved or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsXMoveable { get; set; }
Property IsXMoveable As Boolean
    Get
    Set
property bool IsXMoveable {
    bool get ();
    void set (bool value);
}
abstract IsXMoveable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMoveable Interface


IMoveable.IsYMoveable Property

IMoveableIsYMoveable Property
Determines whether the item can be vertically moved or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsYMoveable { get; set; }
Property IsYMoveable As Boolean
    Get
    Set
property bool IsYMoveable {
    bool get ();
    void set (bool value);
}
abstract IsYMoveable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMoveable Interface


ISelectable Interface

ISelectable Interface
Common interface for items (nodes, links, captions) that can be selected.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISelectable
Public Interface ISelectable
public interface class ISelectable
type ISelectable =  interface end

The ISelectable type exposes the following members.

Properties
 | Name | Description
Public property | IsSelectable | Determines if an item is selectable or not.
Public property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ISelectable Properties

ISelectable Properties

The ISelectable type exposes the following members.

Properties
 | Name | Description
Public property | IsSelectable | Determines if an item is selectable or not.
Public property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

ISelectable Interface


ISelectable.IsSelectable Property

ISelectableIsSelectable Property
Determines if an item is selectable or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSelectable { get; set; }
Property IsSelectable As Boolean
    Get
    Set
property bool IsSelectable {
    bool get ();
    void set (bool value);
}
abstract IsSelectable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISelectable Interface


ISelectable.IsSelected Property

ISelectableIsSelected Property
Determines if an item is selected or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSelected { get; set; }
Property IsSelected As Boolean
    Get
    Set
property bool IsSelected {
    bool get ();
    void set (bool value);
}
abstract IsSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISelectable Interface


ISizeable Interface

ISizeable Interface
Common interface for items (nodes, captions) that can be resized

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISizeable
Public Interface ISizeable
public interface class ISizeable
type ISizeable =  interface end

The ISizeable type exposes the following members.

Properties
 | Name | Description
Public property | IsXSizeable | Determines whether the item can be horizontally resized or not.
Public property | IsYSizeable | Determines whether the item can be vertically resized or not.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ISizeable Properties

ISizeable Properties

The ISizeable type exposes the following members.

Properties
 | Name | Description
Public property | IsXSizeable | Determines whether the item can be horizontally resized or not.
Public property | IsYSizeable | Determines whether the item can be vertically resized or not.
Top
See Also

Reference

ISizeable Interface


ISizeable.IsXSizeable Property

ISizeableIsXSizeable Property
Determines whether the item can be horizontally resized or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsXSizeable { get; set; }
Property IsXSizeable As Boolean
    Get
    Set
property bool IsXSizeable {
    bool get ();
    void set (bool value);
}
abstract IsXSizeable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISizeable Interface


ISizeable.IsYSizeable Property

ISizeableIsYSizeable Property
Determines whether the item can be vertically resized or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
bool IsYSizeable { get; set; }
Property IsYSizeable As Boolean
    Get
    Set
property bool IsYSizeable {
    bool get ();
    void set (bool value);
}
abstract IsYSizeable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISizeable Interface


Item Class

Item Class
Represents an item in the diagram. All classes representing diagram elements derive from Item.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Lassalle.FlowItem
Lassalle.FlowContentItem
Lassalle.FlowLink

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Item : MarshalByRefObject,
    ISelectable
Public MustInherit Class Item
    Inherits MarshalByRefObject
    Implements ISelectable
public ref class Item abstract : public MarshalByRefObject,
    ISelectable
[<AbstractClassAttribute>]
type Item =
    class
        inherit MarshalByRefObject
        interface ISelectable
    end

The Item type exposes the following members.

Methods
 | Name | Description
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link).
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.
Public property | Bounds | Returns the item bounding rectangle
Public property | Captions | Returns the collection of the captions attached to this item.
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item.
Public property | DrawColor | Returns/sets the pen color used to draw the item.
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow.
Public property | Font | Returns/sets the font used to display the text associated to the item.
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected.
Public property | IsHitTestVisible | Determines whether the item can be hit tested.
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item.
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not.
Public property | Properties | Returns the PropertyBag instance associated to the item
Public property | ShadowColor | Returns/sets the shadow color.
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset.
Public property | ShadowStyle | Returns/sets the shadow style.
Public property | Tag | Sets or returns a reference to an object associated to the item.
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.
Public property | TextColor | Returns/sets the color used to display the item text.
Public property | Thickness | Returns/sets the pen width used to draw the node.
Public property | Tooltip | Returns/sets the tooltip associated with the item.
Public property | ZOrder | Returns/sets the z-order index of the item.
Top
Remarks
The main purpose is to provide common methods and properties of every diagram element: nodes, links, captions. Note that it is an abstract class. You cannot use it directly but instead use objects that derive from Node, Link or Caption classes.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Item Methods

Item Methods

The Item type exposes the following members.

Methods
 | Name | Description
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link).
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized.
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Item Class


Item.BringIntoView Method

ItemBringIntoView Method
Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void BringIntoView()
Public Sub BringIntoView
public:
void BringIntoView()
member BringIntoView : unit -> unit
See Also

Reference

Item Class


Item.Refresh Method

ItemRefresh Method
Forces a repaint of the item (node or link).

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
See Also

Reference

Item Class


Item.ShouldSerializeDrawColor Method

ItemShouldSerializeDrawColor Method
Returns true if DrawColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDrawColor()
Public Function ShouldSerializeDrawColor As Boolean
public:
bool ShouldSerializeDrawColor()
member ShouldSerializeDrawColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.Item.ShouldSerializeDrawColor"]

See Also

Reference

Item Class


Item.ShouldSerializeFillColor Method

ItemShouldSerializeFillColor Method
Returns true if FillColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFillColor()
Public Function ShouldSerializeFillColor As Boolean
public:
bool ShouldSerializeFillColor()
member ShouldSerializeFillColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.Item.ShouldSerializeFillColor"]

See Also

Reference

Item Class


Item.ShouldSerializeShadowColor Method

ItemShouldSerializeShadowColor Method
Returns true if ShadowColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeShadowColor()
Public Function ShouldSerializeShadowColor As Boolean
public:
bool ShouldSerializeShadowColor()
member ShouldSerializeShadowColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.Item.ShouldSerializeShadowColor"]

See Also

Reference

Item Class


Item.ShouldSerializeTextColor Method

ItemShouldSerializeTextColor Method
Returns true if TextColor has not the the default value and therefore needs to be serialized.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeTextColor()
Public Function ShouldSerializeTextColor As Boolean
public:
bool ShouldSerializeTextColor()
member ShouldSerializeTextColor : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.Item.ShouldSerializeTextColor"]

See Also

Reference

Item Class


Item Properties

Item Properties

The Item type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.
Public property | Bounds | Returns the item bounding rectangle
Public property | Captions | Returns the collection of the captions attached to this item.
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item.
Public property | DrawColor | Returns/sets the pen color used to draw the item.
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow.
Public property | Font | Returns/sets the font used to display the text associated to the item.
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected.
Public property | IsHitTestVisible | Determines whether the item can be hit tested.
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item.
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not.
Public property | Properties | Returns the PropertyBag instance associated to the item
Public property | ShadowColor | Returns/sets the shadow color.
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset.
Public property | ShadowStyle | Returns/sets the shadow style.
Public property | Tag | Sets or returns a reference to an object associated to the item.
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.
Public property | TextColor | Returns/sets the color used to display the item text.
Public property | Thickness | Returns/sets the pen width used to draw the node.
Public property | Tooltip | Returns/sets the tooltip associated with the item.
Public property | ZOrder | Returns/sets the z-order index of the item.
Top
See Also

Reference

Item Class


Item.AddFlow Property

ItemAddFlow Property
Gets the parent AddFlow that the item is assigned to.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public AddFlow AddFlow { get; }
Public ReadOnly Property AddFlow As AddFlow
    Get
public:
property AddFlow^ AddFlow {
    AddFlow^ get ();
}
member AddFlow : AddFlow with get

Property Value

Type: AddFlow
See Also

Reference

Item Class


Item.BackMode Property

ItemBackMode Property
Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public BackMode BackMode { get; set; }
Public Property BackMode As BackMode
    Get
    Set
public:
property BackMode BackMode {
    BackMode get ();
    void set (BackMode value);
}
member BackMode : BackMode with get, set

Property Value

Type: BackMode
See Also

Reference

Item Class


Item.Bounds Property

ItemBounds Property
Returns the item bounding rectangle

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public RectangleF Bounds { get; }
Public ReadOnly Property Bounds As RectangleF
    Get
public:
property RectangleF Bounds {
    RectangleF get ();
}
member Bounds : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

Item Class


Item.Captions Property

ItemCaptions Property
Returns the collection of the captions attached to this item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Caption> Captions { get; }
Public ReadOnly Property Captions As List(Of Caption)
    Get
public:
property List<Caption^>^ Captions {
    List<Caption^>^ get ();
}
member Captions : List<Caption> with get

Property Value

Type: List Caption
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. To manipulate the collection of captions of an AddFlow item, you should use the Owner property of captions. You may however use this property for enumeration purposes.
See Also

Reference

Item Class


Item.DashStyle Property

ItemDashStyle Property
Returns/sets the DashStyle of the pen used to draw the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public DashStyle DashStyle { get; set; }
Public Property DashStyle As DashStyle
    Get
    Set
public:
property DashStyle DashStyle {
    DashStyle get ();
    void set (DashStyle value);
}
member DashStyle : DashStyle with get, set

Property Value

Type: DashStyle
Remarks
The Custom DashStyle is ignored.
See Also

Reference

Item Class


Item.DrawColor Property

ItemDrawColor Property
Returns/sets the pen color used to draw the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color DrawColor { get; set; }
Public Property DrawColor As Color
    Get
    Set
public:
property Color DrawColor {
    Color get ();
    void set (Color value);
}
member DrawColor : Color with get, set

Property Value

Type: Color
Remarks
If the item is a node and if its shape style is a 3DStyle rectangle (RectEdgeBump, RectEdgeEtched, RectEdgeRaised, RectEdgeSunken), then this property has no effect.
See Also

Reference

Item Class


Item.FillColor Property

ItemFillColor Property
Returns/sets the color used to fill the node or the link arrow.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}
member FillColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Item Class


Item.Font Property

ItemFont Property
Returns/sets the font used to display the text associated to the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

Property Value

Type: Font
See Also

Reference

Item Class


Item.IsCaptionsHilighted Property

ItemIsCaptionsHilighted Property
Determines if the captions are highlighted when the itemnode is selected.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCaptionsHilighted { get; set; }
Public Property IsCaptionsHilighted As Boolean
    Get
    Set
public:
property bool IsCaptionsHilighted {
    bool get ();
    void set (bool value);
}
member IsCaptionsHilighted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.IsHitTestVisible Property

ItemIsHitTestVisible Property
Determines whether the item can be hit tested.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHitTestVisible { get; set; }
Public Property IsHitTestVisible As Boolean
    Get
    Set
public:
property bool IsHitTestVisible {
    bool get ();
    void set (bool value);
}
member IsHitTestVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.IsInView Property

ItemIsInView Property
Returns true if any part of the item is in the viewable area of the control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInView { get; }
Public ReadOnly Property IsInView As Boolean
    Get
public:
property bool IsInView {
    bool get ();
}
member IsInView : bool with get

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.IsOwnerDraw Property

ItemIsOwnerDraw Property
Determines whether you want to provide custom drawing for this item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOwnerDraw { get; set; }
Public Property IsOwnerDraw As Boolean
    Get
    Set
public:
property bool IsOwnerDraw {
    bool get ();
    void set (bool value);
}
member IsOwnerDraw : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.IsSelectable Property

ItemIsSelectable Property
Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectable { get; set; }
Public Property IsSelectable As Boolean
    Get
    Set
public:
virtual property bool IsSelectable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsSelectable : bool with get, set
override IsSelectable : bool with get, set

Property Value

Type: Boolean

Implements

ISelectableIsSelectable
See Also

Reference

Item Class


Item.IsSelected Property

ItemIsSelected Property
Returns/sets a flag indicating if the item is selected or not.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsSelected : bool with get, set
override IsSelected : bool with get, set

Property Value

Type: Boolean

Implements

ISelectableIsSelected
See Also

Reference

Item Class


Item.Properties Property

ItemProperties Property
Returns the PropertyBag instance associated to the item

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyBag Properties { get; }
Public ReadOnly Property Properties As PropertyBag
    Get
public:
property PropertyBag^ Properties {
    PropertyBag^ get ();
}
member Properties : PropertyBag with get

Property Value

Type: PropertyBag
Remarks
The PropertyBag allows adding custom properties to an AddFlow item.
See Also

Reference

Item Class


Item.ShadowColor Property

ItemShadowColor Property
Returns/sets the shadow color.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color ShadowColor { get; set; }
Public Property ShadowColor As Color
    Get
    Set
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
member ShadowColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Item Class


Item.ShadowSize Property

ItemShadowSize Property
Returns/sets the horizontal and vertical shadow offset.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Size ShadowSize { get; set; }
Public Property ShadowSize As Size
    Get
    Set
public:
property Size ShadowSize {
    Size get ();
    void set (Size value);
}
member ShadowSize : Size with get, set

Property Value

Type: Size
See Also

Reference

Item Class


Item.ShadowStyle Property

ItemShadowStyle Property
Returns/sets the shadow style.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public ShadowStyle ShadowStyle { get; set; }
Public Property ShadowStyle As ShadowStyle
    Get
    Set
public:
property ShadowStyle ShadowStyle {
    ShadowStyle get ();
    void set (ShadowStyle value);
}
member ShadowStyle : ShadowStyle with get, set

Property Value

Type: ShadowStyle
See Also

Reference

Item Class


Item.Tag Property

ItemTag Property
Sets or returns a reference to an object associated to the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
member Tag : Object with get, set

Property Value

Type: Object
Remarks
This is one of the way to extend the functionality of an AddFlow item. Other ways are the class derivation and the property bag.
See Also

Reference

Item Class


Item.Text Property

ItemText Property
Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

Item Class


Item.TextColor Property

ItemTextColor Property
Returns/sets the color used to display the item text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
member TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Item Class


Item.Thickness Property

ItemThickness Property
Returns/sets the pen width used to draw the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float Thickness { get; set; }
Public Property Thickness As Single
    Get
    Set
public:
property float Thickness {
    float get ();
    void set (float value);
}
member Thickness : float32 with get, set

Property Value

Type: Single
See Also

Reference

Item Class


Item.Tooltip Property

ItemTooltip Property
Returns/sets the tooltip associated with the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Property Value

Type: String
See Also

Reference

Item Class


Item.ZOrder Property

ItemZOrder Property
Returns/sets the z-order index of the item.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int ZOrder { get; set; }
Public Property ZOrder As Integer
    Get
    Set
public:
property int ZOrder {
    int get ();
    void set (int value);
}
member ZOrder : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value is less than 0 or greater or equal to the number of items.
Remarks
The zorder index is zero-based. Setting it to 0 is equivalent to sending the item at the back of the zorder list. Setting it to n - 1 where n is the number of items is equivalent to sending it at the front of the zorder list.
See Also

Reference

Item Class


LineStyle Enumeration

LineStyle Enumeration
Used to specify the style used to draw a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum LineStyle
Public Enumeration LineStyle
public enum class LineStyle
type LineStyle
Members
Member name | Value | Description
Polyline | 0 | A series of connected lines
Bezier | 1 | A Bezier curve
Spline | 2 | A Cubic spline curve
Database | 3 | Database style
Orthogonal | 4 | Orthogonal style
VH | 5 | 2 segments: vertical horizontal
HV | 6 | 2 segments: horizontal vertical
VHV | 7 | 3 segments: vertical horizontal vertical
HVH | 8 | 3 segments: horizontal vertical horizontal
VHVH | 9 | 4 segments: vert horz vert horz
HVHV | 10 | 4 segments: horz vert horz vert
VHVHV | 11 | 5 segments: vert horz vert horz vert
HVHVH | 12 | 5 segments: horz vert horz vert horz
VHVHVH | 13 | 6 segments: vert horz vert horz vert horz
HVHVHV | 14 | 6 segments: horz vert horz vert horz vert
VHVHVHV | 15 | 7 segments: vert horz vert horz vert horz vert
HVHVHVH | 16 | 7 segments: horz vert horz vert horz vert horz
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Link Class

Link Class
Represents a link (also called edge or relation or arc) in the diagram. A link is an Item object allowing linking two nodes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Lassalle.FlowItem
Lassalle.FlowLink

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class Link : Item
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class Link
    Inherits Item
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class Link : public Item
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type Link =
    class
        inherit Item
    end

The Link type exposes the following members.

Constructors
 | Name | Description
Public method | Link | Initializes a new instance of the Link class.
Public method | Link(Node, Node, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.
Public method | Link(Node, Node, String, Link) | Initializes a new instance of the Link class with an origin, a destination node and a text.
Public method | Link(Node, Node, Int32, Int32, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control
Public method | Link(Node, Node, Int32, Int32, String, Link) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.
Top
Methods
 | Name | Description
Public method | AddPoint | Add a point to the collection of points of a link.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public method | CountPoints | Gets the total number of points in the collection of points of a link.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the link is drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public method | SetPoint | Sets a point at the specified index.
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | ArrowDst | Returns/sets the arrow shape at the end of the link.
Public property | ArrowMid | Returns/sets the arrow shape at the middle of each segment of the link.
Public property | ArrowOrg | Returns/sets the origin arrow shape of the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | Dst | Returns/sets the reference of the destination node of the link.
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | IsAdjustDst | Determines whether it is possible to adjust the position of the last point of the link.
Public property | IsAdjustOrg | Determines whether it is possible to adjust the position of the first point of the link.
Public property | IsArrowDst | Determines whether the link has an arrow at its destination point
Public property | IsArrowMid | Determines whether the link has an arrow at the middle of each segment
Public property | IsArrowOrg | Determines whether the link has an arrow at its origin point
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOrientedText | Determines whether the link text can be drawn in the same direction as the link itself.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public property | JumpSize | Returns/sets the size of the jumps at the intersection of links.
Public property | LineStyle | Returns/sets the style of the line.
Public property | Org | Returns/sets the reference of the origin node of the link.
Public property | PinDstIndex | Returns/sets the index of the destination pin
Public property | PinOrgIndex | Returns/sets the index of the origin pin
Public property | Points | The collection of link points
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | RoundedCornerSize | Returns/sets the size of the rounded corners of the link segments
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Link Constructor

Link Constructor
Overload List
 | Name | Description
Public method | Link | Initializes a new instance of the Link class.
Public method | Link(Node, Node, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.
Public method | Link(Node, Node, String, Link) | Initializes a new instance of the Link class with an origin, a destination node and a text.
Public method | Link(Node, Node, Int32, Int32, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control
Public method | Link(Node, Node, Int32, Int32, String, Link) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.
Top
See Also

Reference

Link Class


Link Constructor

Link Constructor
Initializes a new instance of the Link class.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link()
Public Sub New
public:
Link()
new : unit -> Link
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, String, AddFlow)

Link Constructor (Node, Node, String, AddFlow)
Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    string text,
    AddFlow addflow
)
Public Sub New (
    org As Node,
    dst As Node,
    text As String,
    addflow As AddFlow
)
public:
Link(
    Node^ org,
    Node^ dst,
    String^ text,
    AddFlow^ addflow
)
new :
        org : Node *
        dst : Node *
        text : string *
        addflow : AddFlow -> Link

Parameters

org
Type: Lassalle.FlowNode
A reference to the origin node
dst
Type: Lassalle.FlowNode
A reference to the destination node
text
Type: SystemString
The text displayed with the link
addflow
Type: Lassalle.FlowAddFlow
The AddFlow control that will supply default values for the node
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, String, Link)

Link Constructor (Node, Node, String, Link)
Initializes a new instance of the Link class with an origin, a destination node and a text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    string text,
    Link link
)
Public Sub New (
    org As Node,
    dst As Node,
    text As String,
    link As Link
)
public:
Link(
    Node^ org,
    Node^ dst,
    String^ text,
    Link^ link
)
new :
        org : Node *
        dst : Node *
        text : string *
        link : Link -> Link

Parameters

org
Type: Lassalle.FlowNode
A reference to the origin node
dst
Type: Lassalle.FlowNode
A reference to the destination node
text
Type: SystemString
The text displayed with the link
link
Type: Lassalle.FlowLink
An object containing the default property values of link.
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, Int32, Int32, String, AddFlow)

Link Constructor (Node, Node, Int32, Int32, String, AddFlow)
Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    int pinOrgIndex,
    int pinDstIndex,
    string text,
    AddFlow addflow
)
Public Sub New (
    org As Node,
    dst As Node,
    pinOrgIndex As Integer,
    pinDstIndex As Integer,
    text As String,
    addflow As AddFlow
)
public:
Link(
    Node^ org,
    Node^ dst,
    int pinOrgIndex,
    int pinDstIndex,
    String^ text,
    AddFlow^ addflow
)
new :
        org : Node *
        dst : Node *
        pinOrgIndex : int *
        pinDstIndex : int *
        text : string *
        addflow : AddFlow -> Link

Parameters

org
Type: Lassalle.FlowNode
A reference to the origin node
dst
Type: Lassalle.FlowNode
A reference to the destination node
pinOrgIndex
Type: SystemInt32
Origin pin index
pinDstIndex
Type: SystemInt32
Destination pin index
text
Type: SystemString
The text displayed with the link
addflow
Type: Lassalle.FlowAddFlow
The AddFlow control that will supply default values for the node
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, Int32, Int32, String, Link)

Link Constructor (Node, Node, Int32, Int32, String, Link)
Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    int pinOrgIndex,
    int pinDstIndex,
    string text,
    Link link
)
Public Sub New (
    org As Node,
    dst As Node,
    pinOrgIndex As Integer,
    pinDstIndex As Integer,
    text As String,
    link As Link
)
public:
Link(
    Node^ org,
    Node^ dst,
    int pinOrgIndex,
    int pinDstIndex,
    String^ text,
    Link^ link
)
new :
        org : Node *
        dst : Node *
        pinOrgIndex : int *
        pinDstIndex : int *
        text : string *
        link : Link -> Link

Parameters

org
Type: Lassalle.FlowNode
A reference to the origin node
dst
Type: Lassalle.FlowNode
A reference to the destination node
pinOrgIndex
Type: SystemInt32
Origin pin index
pinDstIndex
Type: SystemInt32
Destination pin index
text
Type: SystemString
The text displayed with the link
link
Type: Lassalle.FlowLink
An object containing the default property values of link.
See Also

Reference

Link Class
Link Overload


Link Methods

Link Methods

The Link type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Add a point to the collection of points of a link.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public method | CountPoints | Gets the total number of points in the collection of points of a link.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPath | Returns the path information which defines how the link is drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public method | SetPoint | Sets a point at the specified index.
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Link Class


Link.AddPoint Method

LinkAddPoint Method
Add a point to the collection of points of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddPoint(
    PointF pt
)
Public Sub AddPoint (
    pt As PointF
)
public:
void AddPoint(
    PointF pt
)
member AddPoint :
        pt : PointF -> unit

Parameters

pt
Type: System.DrawingPointF
The point to add
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.ClearPoints Method

LinkClearPoints Method
Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearPoints()
Public Sub ClearPoints
public:
void ClearPoints()
member ClearPoints : unit -> unit
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.CountPoints Method

LinkCountPoints Method
Gets the total number of points in the collection of points of a link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int CountPoints()
Public Function CountPoints As Integer
public:
int CountPoints()
member CountPoints : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Lassalle.Flow.Link.CountPoints"]

See Also

Reference

Link Class


Link.GetPath Method

LinkGetPath Method
Returns the path information which defines how the link is drawn.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath GetPath()
Public Function GetPath As GraphicsPath
public:
GraphicsPath^ GetPath()
member GetPath : unit -> GraphicsPath

Return Value

Type: GraphicsPath
The path
See Also

Reference

Link Class


Link.RemovePoint Method

LinkRemovePoint Method
Removes the point at the specified index from the collection of points of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RemovePoint(
    int index
)
Public Sub RemovePoint (
    index As Integer
)
public:
void RemovePoint(
    int index
)
member RemovePoint :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the point to be removed from the collection.
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.SetPoint Method

LinkSetPoint Method
Sets a point at the specified index.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPoint(
    PointF pt,
    int index
)
Public Sub SetPoint (
    pt As PointF,
    index As Integer
)
public:
void SetPoint(
    PointF pt,
    int index
)
member SetPoint :
        pt : PointF *
        index : int -> unit

Parameters

pt
Type: System.DrawingPointF

[Missing <param name="pt"/> documentation for "M:Lassalle.Flow.Link.SetPoint(System.Drawing.PointF,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Lassalle.Flow.Link.SetPoint(System.Drawing.PointF,System.Int32)"]

See Also

Reference

Link Class


Link Properties

Link Properties

The Link type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | ArrowDst | Returns/sets the arrow shape at the end of the link.
Public property | ArrowMid | Returns/sets the arrow shape at the middle of each segment of the link.
Public property | ArrowOrg | Returns/sets the origin arrow shape of the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | Dst | Returns/sets the reference of the destination node of the link.
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | IsAdjustDst | Determines whether it is possible to adjust the position of the last point of the link.
Public property | IsAdjustOrg | Determines whether it is possible to adjust the position of the first point of the link.
Public property | IsArrowDst | Determines whether the link has an arrow at its destination point
Public property | IsArrowMid | Determines whether the link has an arrow at the middle of each segment
Public property | IsArrowOrg | Determines whether the link has an arrow at its origin point
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOrientedText | Determines whether the link text can be drawn in the same direction as the link itself.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public property | JumpSize | Returns/sets the size of the jumps at the intersection of links.
Public property | LineStyle | Returns/sets the style of the line.
Public property | Org | Returns/sets the reference of the origin node of the link.
Public property | PinDstIndex | Returns/sets the index of the destination pin
Public property | PinOrgIndex | Returns/sets the index of the origin pin
Public property | Points | The collection of link points
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | RoundedCornerSize | Returns/sets the size of the rounded corners of the link segments
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Link Class


Link.ArrowDst Property

LinkArrowDst Property
Returns/sets the arrow shape at the end of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath ArrowDst { get; set; }
Public Property ArrowDst As GraphicsPath
    Get
    Set
public:
property GraphicsPath^ ArrowDst {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
member ArrowDst : GraphicsPath with get, set

Property Value

Type: GraphicsPath
See Also

Reference

Link Class


Link.ArrowMid Property

LinkArrowMid Property
Returns/sets the arrow shape at the middle of each segment of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath ArrowMid { get; set; }
Public Property ArrowMid As GraphicsPath
    Get
    Set
public:
property GraphicsPath^ ArrowMid {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
member ArrowMid : GraphicsPath with get, set

Property Value

Type: GraphicsPath
See Also

Reference

Link Class


Link.ArrowOrg Property

LinkArrowOrg Property
Returns/sets the origin arrow shape of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsPath ArrowOrg { get; set; }
Public Property ArrowOrg As GraphicsPath
    Get
    Set
public:
property GraphicsPath^ ArrowOrg {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
member ArrowOrg : GraphicsPath with get, set

Property Value

Type: GraphicsPath
See Also

Reference

Link Class


Link.Dst Property

LinkDst Property
Returns/sets the reference of the destination node of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; set; }
Public Property Dst As Node
    Get
    Set
public:
property Node^ Dst {
    Node^ get ();
    void set (Node^ value);
}
member Dst : Node with get, set

Property Value

Type: Node
See Also

Reference

Link Class


Link.IsAdjustDst Property

LinkIsAdjustDst Property
Determines whether it is possible to adjust the position of the last point of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdjustDst { get; set; }
Public Property IsAdjustDst As Boolean
    Get
    Set
public:
property bool IsAdjustDst {
    bool get ();
    void set (bool value);
}
member IsAdjustDst : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsAdjustOrg Property

LinkIsAdjustOrg Property
Determines whether it is possible to adjust the position of the first point of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdjustOrg { get; set; }
Public Property IsAdjustOrg As Boolean
    Get
    Set
public:
property bool IsAdjustOrg {
    bool get ();
    void set (bool value);
}
member IsAdjustOrg : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsArrowDst Property

LinkIsArrowDst Property
Determines whether the link has an arrow at its destination point

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsArrowDst { get; set; }
Public Property IsArrowDst As Boolean
    Get
    Set
public:
property bool IsArrowDst {
    bool get ();
    void set (bool value);
}
member IsArrowDst : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsArrowMid Property

LinkIsArrowMid Property
Determines whether the link has an arrow at the middle of each segment

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsArrowMid { get; set; }
Public Property IsArrowMid As Boolean
    Get
    Set
public:
property bool IsArrowMid {
    bool get ();
    void set (bool value);
}
member IsArrowMid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsArrowOrg Property

LinkIsArrowOrg Property
Determines whether the link has an arrow at its origin point

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsArrowOrg { get; set; }
Public Property IsArrowOrg As Boolean
    Get
    Set
public:
property bool IsArrowOrg {
    bool get ();
    void set (bool value);
}
member IsArrowOrg : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsOrientedText Property

LinkIsOrientedText Property
Determines whether the link text can be drawn in the same direction as the link itself.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrientedText { get; set; }
Public Property IsOrientedText As Boolean
    Get
    Set
public:
property bool IsOrientedText {
    bool get ();
    void set (bool value);
}
member IsOrientedText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsStretchable Property

LinkIsStretchable Property
Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStretchable { get; set; }
Public Property IsStretchable As Boolean
    Get
    Set
public:
property bool IsStretchable {
    bool get ();
    void set (bool value);
}
member IsStretchable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.JumpSize Property

LinkJumpSize Property
Returns/sets the size of the jumps at the intersection of links.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float JumpSize { get; set; }
Public Property JumpSize As Single
    Get
    Set
public:
property float JumpSize {
    float get ();
    void set (float value);
}
member JumpSize : float32 with get, set

Property Value

Type: Single
See Also

Reference

Link Class


Link.LineStyle Property

LinkLineStyle Property
Returns/sets the style of the line.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyle LineStyle { get; set; }
Public Property LineStyle As LineStyle
    Get
    Set
public:
property LineStyle LineStyle {
    LineStyle get ();
    void set (LineStyle value);
}
member LineStyle : LineStyle with get, set

Property Value

Type: LineStyle
See Also

Reference

Link Class


Link.Org Property

LinkOrg Property
Returns/sets the reference of the origin node of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; set; }
Public Property Org As Node
    Get
    Set
public:
property Node^ Org {
    Node^ get ();
    void set (Node^ value);
}
member Org : Node with get, set

Property Value

Type: Node
See Also

Reference

Link Class


Link.PinDstIndex Property

LinkPinDstIndex Property
Returns/sets the index of the destination pin

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int PinDstIndex { get; set; }
Public Property PinDstIndex As Integer
    Get
    Set
public:
property int PinDstIndex {
    int get ();
    void set (int value);
}
member PinDstIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

Link Class


Link.PinOrgIndex Property

LinkPinOrgIndex Property
Returns/sets the index of the origin pin

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int PinOrgIndex { get; set; }
Public Property PinOrgIndex As Integer
    Get
    Set
public:
property int PinOrgIndex {
    int get ();
    void set (int value);
}
member PinOrgIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

Link Class


Link.Points Property

LinkPoints Property
The collection of link points

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<PointF> Points { get; }
Public ReadOnly Property Points As List(Of PointF)
    Get
public:
property List<PointF>^ Points {
    List<PointF>^ get ();
}
member Points : List<PointF> with get

Property Value

Type: List PointF
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. To manipulate the collection of link points, you should use instead the methods AddPoint, RemovePoints, ClearPoints, CountPoints, GetPoint and SetPoint.
See Also

Reference

Link Class


Link.RoundedCornerSize Property

LinkRoundedCornerSize Property
Returns/sets the size of the rounded corners of the link segments

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public float RoundedCornerSize { get; set; }
Public Property RoundedCornerSize As Single
    Get
    Set
public:
property float RoundedCornerSize {
    float get ();
    void set (float value);
}
member RoundedCornerSize : float32 with get, set

Property Value

Type: Single
See Also

Reference

Link Class


Link.TextPlacementMode Property

LinkTextPlacementMode Property
Returns/sets the TextPlacementMode style of the text of the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public TextPlacementMode TextPlacementMode { get; set; }
Public Property TextPlacementMode As TextPlacementMode
    Get
    Set
public:
property TextPlacementMode TextPlacementMode {
    TextPlacementMode get ();
    void set (TextPlacementMode value);
}
member TextPlacementMode : TextPlacementMode with get, set

Property Value

Type: TextPlacementMode
See Also

Reference

Link Class


LinkDrawFlags Enumeration

LinkDrawFlags Enumeration
Use to specify how the IsOwnerDraw property of the link is used.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinkDrawFlags
Public Enumeration LinkDrawFlags
public enum class LinkDrawFlags
type LinkDrawFlags
Members
Member name | Value | Description
None | 0 | The link is entirely drawn by the owner
Shape | 1 | AddFlow will draw the link shape
Arrows | 2 | AddFlow will draw the arrows
Text | 4 | AddFlow will draw the link text
All | 7 | AddFlow will draw all the link
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


LinkOwnerDrawEventArgs Class

LinkOwnerDrawEventArgs Class
Event parameters used for the LinkOwnerDraw event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowLinkOwnerDrawEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkOwnerDrawEventArgs : EventArgs
Public Class LinkOwnerDrawEventArgs
    Inherits EventArgs
public ref class LinkOwnerDrawEventArgs : public EventArgs
type LinkOwnerDrawEventArgs =
    class
        inherit EventArgs
    end

The LinkOwnerDrawEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkOwnerDrawEventArgs | Constructor. Creates a new LinkOwnerDrawEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Flags | Gets/sets a value indicating what is to be drawn for the link.
Public property | Graphics | The Graphics surface used to draw the link.
Public property | Link | The link that is to be drawn (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


LinkOwnerDrawEventArgs Constructor

LinkOwnerDrawEventArgs Constructor
Constructor. Creates a new LinkOwnerDrawEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public LinkOwnerDrawEventArgs(
    Link link,
    Graphics graphics
)
Public Sub New (
    link As Link,
    graphics As Graphics
)
public:
LinkOwnerDrawEventArgs(
    Link^ link,
    Graphics^ graphics
)
new :
        link : Link *
        graphics : Graphics -> LinkOwnerDrawEventArgs

Parameters

link
Type: Lassalle.FlowLink
The link that is to be drawn
graphics
Type: System.DrawingGraphics
The Graphics surface used to draw the diagram
See Also

Reference

LinkOwnerDrawEventArgs Class


LinkOwnerDrawEventArgs Methods

LinkOwnerDrawEventArgs Methods

The LinkOwnerDrawEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinkOwnerDrawEventArgs Class


LinkOwnerDrawEventArgs Properties

LinkOwnerDrawEventArgs Properties

The LinkOwnerDrawEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Gets/sets a value indicating what is to be drawn for the link.
Public property | Graphics | The Graphics surface used to draw the link.
Public property | Link | The link that is to be drawn (read-only)
Top
See Also

Reference

LinkOwnerDrawEventArgs Class


LinkOwnerDrawEventArgs.Flags Property

LinkOwnerDrawEventArgsFlags Property
Gets/sets a value indicating what is to be drawn for the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public LinkDrawFlags Flags { get; set; }
Public Property Flags As LinkDrawFlags
    Get
    Set
public:
property LinkDrawFlags Flags {
    LinkDrawFlags get ();
    void set (LinkDrawFlags value);
}
member Flags : LinkDrawFlags with get, set

Property Value

Type: LinkDrawFlags
See Also

Reference

LinkOwnerDrawEventArgs Class


LinkOwnerDrawEventArgs.Graphics Property

LinkOwnerDrawEventArgsGraphics Property
The Graphics surface used to draw the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
member Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

LinkOwnerDrawEventArgs Class


LinkOwnerDrawEventArgs.Link Property

LinkOwnerDrawEventArgsLink Property
The link that is to be drawn (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

LinkOwnerDrawEventArgs Class


MouseAction Enumeration

MouseAction Enumeration
Used to specify the selection rectangle action with the mouse.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum MouseAction
Public Enumeration MouseAction
public enum class MouseAction
type MouseAction
Members
Member name | Value | Description
DrawRectangle | 0 | Just draw a rectangle without any action
Caption | 1 | Caption creation
Node | 2 | Node creation
Selection | 3 | Select the items partially inside the rectangle
Selection2 | 4 | Select the items completely inside the rectangle
Zoom | 5 | Zoom the rectangle while ensuring a 1:1 aspect ratio
Pan | 6 | Panning mode. Scroll the diagram with the mouse.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


MouseArea Enumeration

MouseArea Enumeration
Used to specify the type of the area pointed by the mouse.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum MouseArea
Public Enumeration MouseArea
public enum class MouseArea
type MouseArea
Members
Member name | Value | Description
OutSide | 0 | The mouse is outside any special area, therefore on nothing
LeftUpSquare | 1 | The mouse is on the handle at the top left corner of a node
UpSquare | 2 | The mouse is on the handle at the top of a node
RightUpSquare | 3 | The mouse is on the handle at the top right corner of a node
LeftSquare | 4 | The mouse is on the handle at the left of a node
RightSquare | 5 | The mouse is on the handle at the right of a node
LeftDownSquare | 6 | The mouse is on the handle at the bottom left corner of a node
DownSquare | 7 | The mouse is on the handle at the bottom of a node
RightDownSquare | 8 | The mouse is on the handle at the bottom right corner of a node
StretchSquare | 9 | The mouse is on a stretching handle area of a link
LinkSquare | 10 | The mouse is on a linking handle area at the center of a node
Caption | 11 | The mouse is on a caption area
Link | 12 | The mouse is on a link area
Node | 13 | The mouse is on a node area
Pin | 14 | The mouse is on a node pin
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Node Class

Node Class
Represents a node (also called vertice or entity) in the diagram. A node is a ContentItem object that be linked to another node.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Lassalle.FlowItem
Lassalle.FlowContentItem
Lassalle.FlowNode

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class Node : ContentItem
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class Node
    Inherits ContentItem
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class Node : public ContentItem
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type Node =
    class
        inherit ContentItem
    end

The Node type exposes the following members.

Constructors
 | Name | Description
Public method | Node | Initializes a new instance of the Node class.
Public method | Node(Single, Single, Single, Single, String, AddFlow) | Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.
Public method | Node(Single, Single, Single, Single, String, Node) | Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLinkedNode | Returns the node connected via a given link.
Public method | GetPath | Returns the path information which defines how the node is drawn. (Inherited from ContentItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializePins | Returns true if the Pins property need to be serialized
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor (Inherited from ContentItem.)
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node. (Inherited from ContentItem.)
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn. (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the node. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInLinkable | Determines whether the node accept incoming links.
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOutLinkable | Determines whether the node accept outgoing links.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the node can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the node can be vertically resized or not. (Inherited from ContentItem.)
Public property | Links | Returns the collection of links that come to the node or that leave it.
Public property | Location | Sets or returns the location of the node. (Overrides ContentItemLocation.)
Public property | Pins | Sets or gets the list of node pins
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the node object. (Overrides ContentItemShapeFamily.)
Public property | Size | Sets or returns the size of the node. (Overrides ContentItemSize.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Node Constructor

Node Constructor
Overload List
 | Name | Description
Public method | Node | Initializes a new instance of the Node class.
Public method | Node(Single, Single, Single, Single, String, AddFlow) | Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.
Public method | Node(Single, Single, Single, Single, String, Node) | Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object
Top
See Also

Reference

Node Class


Node Constructor

Node Constructor
Initializes a new instance of the Node class.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node()
Public Sub New
public:
Node()
new : unit -> Node
See Also

Reference

Node Class
Node Overload


Node Constructor (Single, Single, Single, Single, String, AddFlow)

Node Constructor (Single, Single, Single, Single, String, AddFlow)
Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node(
    float left,
    float top,
    float width,
    float height,
    string text,
    AddFlow addflow
)
Public Sub New (
    left As Single,
    top As Single,
    width As Single,
    height As Single,
    text As String,
    addflow As AddFlow
)
public:
Node(
    float left,
    float top,
    float width,
    float height,
    String^ text,
    AddFlow^ addflow
)
new :
        left : float32 *
        top : float32 *
        width : float32 *
        height : float32 *
        text : string *
        addflow : AddFlow -> Node

Parameters

left
Type: SystemSingle
The x-coordinate of the node position
top
Type: SystemSingle
The y-coordinate of the node position
width
Type: SystemSingle
The horizontal size of the node
height
Type: SystemSingle
The vertical size of the node
text
Type: SystemString
The text displayed in the node
addflow
Type: Lassalle.FlowAddFlow
The AddFlow control that will supply default property values for the node
See Also

Reference

Node Class
Node Overload


Node Constructor (Single, Single, Single, Single, String, Node)

Node Constructor (Single, Single, Single, Single, String, Node)
Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node(
    float left,
    float top,
    float width,
    float height,
    string text,
    Node node
)
Public Sub New (
    left As Single,
    top As Single,
    width As Single,
    height As Single,
    text As String,
    node As Node
)
public:
Node(
    float left,
    float top,
    float width,
    float height,
    String^ text,
    Node^ node
)
new :
        left : float32 *
        top : float32 *
        width : float32 *
        height : float32 *
        text : string *
        node : Node -> Node

Parameters

left
Type: SystemSingle
The x-coordinate of the node position
top
Type: SystemSingle
The y-coordinate of the node position
width
Type: SystemSingle
The horizontal size of the node
height
Type: SystemSingle
The vertical size of the node
text
Type: SystemString
The text displayed in the node
node
Type: Lassalle.FlowNode
A node containing the default property values of nodes.
See Also

Reference

Node Class
Node Overload


Node Methods

Node Methods

The Node type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | EndEdit | Ends the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLinkedNode | Returns the node connected via a given link.
Public method | GetPath | Returns the path information which defines how the node is drawn. (Inherited from ContentItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Refresh | Forces a repaint of the item (node or link). (Inherited from Item.)
Public method | ShouldSerializeDrawColor | Returns true if DrawColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeFillColor | Returns true if FillColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializePins | Returns true if the Pins property need to be serialized
Public method | ShouldSerializeShadowColor | Returns true if ShadowColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextColor | Returns true if TextColor has not the the default value and therefore needs to be serialized. (Inherited from Item.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Node Class


Node.GetLinkedNode Method

NodeGetLinkedNode Method
Returns the node connected via a given link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Node GetLinkedNode(
    Link link
)
Public Function GetLinkedNode (
    link As Link
) As Node
public:
Node^ GetLinkedNode(
    Link^ link
)
member GetLinkedNode :
        link : Link -> Node

Parameters

link
Type: Lassalle.FlowLink
A reference to a link object attached to the node

Return Value

Type: Node
A reference to the connected node
Remarks
This method has been added to manage undirected graphs. In some situations, it may be useful to get the node B linked to the node A via a given link, without having to wonder if node A is the origin or the destination.
See Also

Reference

Node Class


Node.ShouldSerializePins Method

NodeShouldSerializePins Method
Returns true if the Pins property need to be serialized

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePins()
Public Function ShouldSerializePins As Boolean
public:
bool ShouldSerializePins()
member ShouldSerializePins : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.Flow.Node.ShouldSerializePins"]

See Also

Reference

Node Class


Node Properties

Node Properties

The Node type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | Gets the parent AddFlow that the item is assigned to. (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DrawColor | Returns/sets the pen color used to draw the item. (Inherited from Item.)
Public property | FillColor | Returns/sets the color used to fill the node or the link arrow. (Inherited from Item.)
Public property | Font | Returns/sets the font used to display the text associated to the item. (Inherited from Item.)
Public property | GradientColor | Returns/sets the color used to draw a gradient with the FillColor (Inherited from ContentItem.)
Public property | GradientMode | Returns/sets the direction of the linear gradient when drawn in a node. (Inherited from ContentItem.)
Public property | GraphicsPath | Returns/sets the path information which defines how the of the Shape object is drawn. (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the node. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsCaptionsHilighted | Determines if the captions are highlighted when the itemnode is selected. (Inherited from Item.)
Public property | IsEditable | Returns/sets a value indicating whether the text of the ContentItem object can be edited (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsInLinkable | Determines whether the node accept incoming links.
Public property | IsInView | Returns true if any part of the item is in the viewable area of the control. (Inherited from Item.)
Public property | IsOutLinkable | Determines whether the node accept outgoing links.
Public property | IsOwnerDraw | Determines whether you want to provide custom drawing for this item. (Inherited from Item.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the node can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the node can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the node can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the node can be vertically resized or not. (Inherited from ContentItem.)
Public property | Links | Returns the collection of links that come to the node or that leave it.
Public property | Location | Sets or returns the location of the node. (Overrides ContentItemLocation.)
Public property | Pins | Sets or gets the list of node pins
Public property | Properties | Returns the PropertyBag instance associated to the item (Inherited from Item.)
Public property | ShadowColor | Returns/sets the shadow color. (Inherited from Item.)
Public property | ShadowSize | Returns/sets the horizontal and vertical shadow offset. (Inherited from Item.)
Public property | ShadowStyle | Returns/sets the shadow style. (Inherited from Item.)
Public property | ShapeFamily | Returns/sets the shape family style of the node object. (Overrides ContentItemShapeFamily.)
Public property | Size | Sets or returns the size of the node. (Overrides ContentItemSize.)
Public property | Tag | Sets or returns a reference to an object associated to the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextColor | Returns/sets the color used to display the item text. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | Thickness | Returns/sets the pen width used to draw the node. (Inherited from Item.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | ZOrder | Returns/sets the z-order index of the item. (Inherited from Item.)
Top
See Also

Reference

Node Class


Node.IsInLinkable Property

NodeIsInLinkable Property
Determines whether the node accept incoming links.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInLinkable { get; set; }
Public Property IsInLinkable As Boolean
    Get
    Set
public:
property bool IsInLinkable {
    bool get ();
    void set (bool value);
}
member IsInLinkable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.IsOutLinkable Property

NodeIsOutLinkable Property
Determines whether the node accept outgoing links.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOutLinkable { get; set; }
Public Property IsOutLinkable As Boolean
    Get
    Set
public:
property bool IsOutLinkable {
    bool get ();
    void set (bool value);
}
member IsOutLinkable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.Links Property

NodeLinks Property
Returns the collection of links that come to the node or that leave it.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<Link> Links { get; }
Public ReadOnly Property Links As List(Of Link)
    Get
public:
property List<Link^>^ Links {
    List<Link^>^ get ();
}
member Links : List<Link> with get

Property Value

Type: List Link
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. You may however use this property for enumeration purposes.
See Also

Reference

Node Class


Node.Location Property

NodeLocation Property
Sets or returns the location of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override PointF Location { get; set; }
Public Overrides Property Location As PointF
    Get
    Set
public:
virtual property PointF Location {
    PointF get () override;
    void set (PointF value) override;
}
abstract Location : PointF with get, set
override Location : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Node Class


Node.Pins Property

NodePins Property
Sets or gets the list of node pins

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public List<PointF> Pins { get; set; }
Public Property Pins As List(Of PointF)
    Get
    Set
public:
property List<PointF>^ Pins {
    List<PointF>^ get ();
    void set (List<PointF>^ value);
}
member Pins : List<PointF> with get, set

Property Value

Type: List PointF
See Also

Reference

Node Class


Node.ShapeFamily Property

NodeShapeFamily Property
Returns/sets the shape family style of the node object.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override ShapeFamily ShapeFamily { get; set; }
Public Overrides Property ShapeFamily As ShapeFamily
    Get
    Set
public:
virtual property ShapeFamily ShapeFamily {
    ShapeFamily get () override;
    void set (ShapeFamily value) override;
}
abstract ShapeFamily : ShapeFamily with get, set
override ShapeFamily : ShapeFamily with get, set

Property Value

Type: ShapeFamily
Remarks
If the GraphicsPath property is null, then this is this shape that will be used to draw the node
See Also

Reference

Node Class


Node.Size Property

NodeSize Property
Sets or returns the size of the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public override SizeF Size { get; set; }
Public Overrides Property Size As SizeF
    Get
    Set
public:
virtual property SizeF Size {
    SizeF get () override;
    void set (SizeF value) override;
}
abstract Size : SizeF with get, set
override Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

Node Class


PropertyBag Class

PropertyBag Class
Allows adding new custom properties to AddFlow items
Inheritance Hierarchy
SystemObject
Lassalle.FlowPropertyBag

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PropertyBag
<SerializableAttribute>
Public Class PropertyBag
[SerializableAttribute]
public ref class PropertyBag
[<SerializableAttribute>]
type PropertyBag =  class end

The PropertyBag type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyBag | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Item | Indexer which retrieves a property from the PropertyBag based on the property Name
Public property | Owner | A reference to the owner of the property bag
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


PropertyBag Constructor

PropertyBag Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyBag(
    Object owner
)
Public Sub New (
    owner As Object
)
public:
PropertyBag(
    Object^ owner
)
new :
        owner : Object -> PropertyBag

Parameters

owner
Type: SystemObject
The owner of the PropertyBag
See Also

Reference

PropertyBag Class


PropertyBag Methods

PropertyBag Methods

The PropertyBag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyBag Class


PropertyBag Properties

PropertyBag Properties

The PropertyBag type exposes the following members.

Properties
 | Name | Description
Public property | Item | Indexer which retrieves a property from the PropertyBag based on the property Name
Public property | Owner | A reference to the owner of the property bag
Top
See Also

Reference

PropertyBag Class


PropertyBag.Item Property

PropertyBagItem Property
Indexer which retrieves a property from the PropertyBag based on the property Name

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyBagProperty this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As PropertyBagProperty
    Get
public:
property PropertyBagProperty^ default[String^ name] {
    PropertyBagProperty^ get (String^ name);
}
member Item : PropertyBagProperty with get

Parameters

name
Type: SystemString

Property Value

Type: PropertyBagProperty
See Also

Reference

PropertyBag Class


PropertyBag.Owner Property

PropertyBagOwner Property
A reference to the owner of the property bag

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object Owner { get; }
Public ReadOnly Property Owner As Object
    Get
public:
property Object^ Owner {
    Object^ get ();
}
member Owner : Object with get

Property Value

Type: Object
See Also

Reference

PropertyBag Class


PropertyBag.Property Class

PropertyBagProperty Class
The Property class is an inner class to PropertyBag.
Inheritance Hierarchy
SystemObject
Lassalle.FlowPropertyBagProperty

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Property
<SerializableAttribute>
Public Class Property
[SerializableAttribute]
public ref class Property
[<SerializableAttribute>]
type Property =  class end

The PropertyBagProperty type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyBagProperty | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnUpdated | Raises the Updated Event
Protected method | OnUpdating | Raises the Updating Event
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | The name of the Property
Public property | Owner | The owner of the PropertyBag
Public property | Value | The property value
Top
Events
 | Name | Description
Public event | Updated | Occurs after the value of a property is changed
Public event | Updating | Occurs just before the value of a property is changed
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


PropertyBag.Property Constructor

PropertyBagProperty Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Property(
    string name,
    Object owner
)
Public Sub New (
    name As String,
    owner As Object
)
public:
Property(
    String^ name,
    Object^ owner
)
new :
        name : string *
        owner : Object -> Property

Parameters

name
Type: SystemString
The name of the new property
owner
Type: SystemObject
The owner of the PropertyBag
See Also

Reference

PropertyBagProperty Class


Property Methods

Property Methods

The PropertyBagProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnUpdated | Raises the Updated Event
Protected method | OnUpdating | Raises the Updating Event
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.OnUpdated Method

PropertyBagPropertyOnUpdated Method
Raises the Updated Event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected void OnUpdated(
    UpdatedEventArgs e
)
Protected Sub OnUpdated (
    e As UpdatedEventArgs
)
protected:
void OnUpdated(
    UpdatedEventArgs^ e
)
member OnUpdated :
        e : UpdatedEventArgs -> unit

Parameters

e
Type: Lassalle.FlowUpdatedEventArgs
The updated event args
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.OnUpdating Method

PropertyBagPropertyOnUpdating Method
Raises the Updating Event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
protected void OnUpdating(
    UpdatingEventArgs e
)
Protected Sub OnUpdating (
    e As UpdatingEventArgs
)
protected:
void OnUpdating(
    UpdatingEventArgs^ e
)
member OnUpdating :
        e : UpdatingEventArgs -> unit

Parameters

e
Type: Lassalle.FlowUpdatingEventArgs
The updating event args
See Also

Reference

PropertyBagProperty Class


Property Properties

Property Properties

The PropertyBagProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the Property
Public property | Owner | The owner of the PropertyBag
Public property | Value | The property value
Top
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.Name Property

PropertyBagPropertyName Property
The name of the Property

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.Owner Property

PropertyBagPropertyOwner Property
The owner of the PropertyBag

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object Owner { get; }
Public ReadOnly Property Owner As Object
    Get
public:
property Object^ Owner {
    Object^ get ();
}
member Owner : Object with get

Property Value

Type: Object
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.Value Property

PropertyBagPropertyValue Property
The property value

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

PropertyBagProperty Class


Property Events

Property Events

The PropertyBagProperty type exposes the following members.

Events
 | Name | Description
Public event | Updated | Occurs after the value of a property is changed
Public event | Updating | Occurs just before the value of a property is changed
Top
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.Updated Event

PropertyBagPropertyUpdated Event
Occurs after the value of a property is changed

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event UpdatedEventHandler Updated
Public Event Updated As UpdatedEventHandler
public:
 event UpdatedEventHandler^ Updated {
    void add (UpdatedEventHandler^ value);
    void remove (UpdatedEventHandler^ value);
}
member Updated : IEvent<UpdatedEventHandler,
    UpdatedEventArgs>

Value

Type: Lassalle.FlowUpdatedEventHandler
See Also

Reference

PropertyBagProperty Class


PropertyBag.Property.Updating Event

PropertyBagPropertyUpdating Event
Occurs just before the value of a property is changed

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public event UpdatingEventHandler Updating
Public Event Updating As UpdatingEventHandler
public:
 event UpdatingEventHandler^ Updating {
    void add (UpdatingEventHandler^ value);
    void remove (UpdatingEventHandler^ value);
}
member Updating : IEvent<UpdatingEventHandler,
    UpdatingEventArgs>

Value

Type: Lassalle.FlowUpdatingEventHandler
See Also

Reference

PropertyBagProperty Class


Quadtree Class

Quadtree Class
A class for managing a quadtree structure It allows improving speed performance of diagram display and item selection
Inheritance Hierarchy
SystemObject
Lassalle.FlowQuadtree

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class Quadtree
Public Class Quadtree
public ref class Quadtree
type Quadtree =  class end

The Quadtree type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Quadtree Methods

Quadtree Methods

The Quadtree type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Quadtree Class


ScrollbarsDisplayMode Enumeration

ScrollbarsDisplayMode Enumeration
Used to specify how the AutoScrollMinSize is set

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScrollbarsDisplayMode
Public Enumeration ScrollbarsDisplayMode
public enum class ScrollbarsDisplayMode
type ScrollbarsDisplayMode
Members
Member name | Value | Description
AddControlSize | 0 | The AutoScrollMinSize is set to the size of the diagram plus the size of the control.
SizeOfDiagramOnly | 1 | The AutoScrollMinSize is set to the size of the diagram.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


SelectedItemsLayoutingEventArgs Class

SelectedItemsLayoutingEventArgs Class
Event parameters used for the SelectedItemsLayouting event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowSelectedItemsLayoutingEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class SelectedItemsLayoutingEventArgs : EventArgs
Public Class SelectedItemsLayoutingEventArgs
    Inherits EventArgs
public ref class SelectedItemsLayoutingEventArgs : public EventArgs
type SelectedItemsLayoutingEventArgs =
    class
        inherit EventArgs
    end

The SelectedItemsLayoutingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedItemsLayoutingEventArgs | Constructor. Creates a new SelectedItemsLayoutingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


SelectedItemsLayoutingEventArgs Constructor

SelectedItemsLayoutingEventArgs Constructor
Constructor. Creates a new SelectedItemsLayoutingEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SelectedItemsLayoutingEventArgs()
Public Sub New
public:
SelectedItemsLayoutingEventArgs()
new : unit -> SelectedItemsLayoutingEventArgs
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs Methods

SelectedItemsLayoutingEventArgs Methods

The SelectedItemsLayoutingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs Properties

SelectedItemsLayoutingEventArgs Properties

The SelectedItemsLayoutingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs.Cancel Property

SelectedItemsLayoutingEventArgsCancel Property
Gets/sets a value indicating whether the moving or resizing action should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedLinkStretchingEventArgs Class

SelectedLinkStretchingEventArgs Class
Event parameters used for the SelectedLinkStretching event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowSelectedLinkStretchingEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class SelectedLinkStretchingEventArgs : EventArgs
Public Class SelectedLinkStretchingEventArgs
    Inherits EventArgs
public ref class SelectedLinkStretchingEventArgs : public EventArgs
type SelectedLinkStretchingEventArgs =
    class
        inherit EventArgs
    end

The SelectedLinkStretchingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedLinkStretchingEventArgs | Constructor. Creates a new SelectedLinkStretchingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public property | Link | The link being stretched (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


SelectedLinkStretchingEventArgs Constructor

SelectedLinkStretchingEventArgs Constructor
Constructor. Creates a new SelectedLinkStretchingEventArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SelectedLinkStretchingEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
SelectedLinkStretchingEventArgs(
    Link^ link
)
new :
        link : Link -> SelectedLinkStretchingEventArgs

Parameters

link
Type: Lassalle.FlowLink
The link being stretched
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs Methods

SelectedLinkStretchingEventArgs Methods

The SelectedLinkStretchingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs Properties

SelectedLinkStretchingEventArgs Properties

The SelectedLinkStretchingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public property | Link | The link being stretched (read-only)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs.Cancel Property

SelectedLinkStretchingEventArgsCancel Property
Gets/sets a value indicating whether the stretching action should be canceled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs.Link Property

SelectedLinkStretchingEventArgsLink Property
The link being stretched (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectionChangeArgs Class

SelectionChangeArgs Class
Event parameters used for the SelectionChange event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowSelectionChangeArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class SelectionChangeArgs : EventArgs
Public Class SelectionChangeArgs
    Inherits EventArgs
public ref class SelectionChangeArgs : public EventArgs
type SelectionChangeArgs =
    class
        inherit EventArgs
    end

The SelectionChangeArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionChangeArgs | Constructor. Creates a new SelectionChangeArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


SelectionChangeArgs Constructor

SelectionChangeArgs Constructor
Constructor. Creates a new SelectionChangeArgs instance.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public SelectionChangeArgs(
    Item item
)
Public Sub New (
    item As Item
)
public:
SelectionChangeArgs(
    Item^ item
)
new :
        item : Item -> SelectionChangeArgs

Parameters

item
Type: Lassalle.FlowItem
The item whose selection status has changed
See Also

Reference

SelectionChangeArgs Class


SelectionChangeArgs Methods

SelectionChangeArgs Methods

The SelectionChangeArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectionChangeArgs Class


SelectionChangeArgs Properties

SelectionChangeArgs Properties

The SelectionChangeArgs type exposes the following members.

Properties
 | Name | Description
Public property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

SelectionChangeArgs Class


SelectionChangeArgs.Item Property

SelectionChangeArgsItem Property
The item whose selection status has changed (read-only)

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item Item { get; }
Public ReadOnly Property Item As Item
    Get
public:
property Item^ Item {
    Item^ get ();
}
member Item : Item with get

Property Value

Type: Item
See Also

Reference

SelectionChangeArgs Class


ShadowStyle Enumeration

ShadowStyle Enumeration
Used to specify the node shadow style.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShadowStyle
Public Enumeration ShadowStyle
public enum class ShadowStyle
type ShadowStyle
Members
Member name | Value | Description
None | 0 | No Shadow (default)
RightBottom | 1 | Right Bottom Shadow
RightTop | 2 | Right Top Shadow
LeftTop | 3 | Left Top Shadow
LeftBottom | 4 | Left Bottom Shadow
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


ShapeFamily Enumeration

ShapeFamily Enumeration
Used to specify a node family style.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShapeFamily
Public Enumeration ShapeFamily
public enum class ShapeFamily
type ShapeFamily
Members
Member name | Value | Description
Ellipse | 0 |
Rectangle | 1 |
Other | 2 |
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Task Class

Task Class
Represents an action that can be undone and redone.
Inheritance Hierarchy
SystemObject
Lassalle.FlowTask

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Task
Public MustInherit Class Task
public ref class Task abstract
[<AbstractClassAttribute>]
type Task =  class end

The Task type exposes the following members.

Constructors
 | Name | Description
Public method | Task | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Allows redoing the action
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Allows undoing the action
Top
Properties
 | Name | Description
Public property | Code | A Code allowing identifying an action
Top
Remarks
This class is an abstract class which which defines the interface expected by the AddFlow undo manager for undoing or redoing actions. The Undo and Redo methods are abstract and must be implemented by derived classes.
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Task Constructor

Task Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Task()
Public Sub New
public:
Task()
new : unit -> Task
See Also

Reference

Task Class


Task Methods

Task Methods

The Task type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Allows redoing the action
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Allows undoing the action
Top
See Also

Reference

Task Class


Task.Redo Method

TaskRedo Method
Allows redoing the action

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Redo()
Public Overridable Sub Redo
public:
virtual void Redo()
abstract Redo : unit -> unit
override Redo : unit -> unit
See Also

Reference

Task Class


Task.Undo Method

TaskUndo Method
Allows undoing the action

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Undo()
Public Overridable Sub Undo
public:
virtual void Undo()
abstract Undo : unit -> unit
override Undo : unit -> unit
See Also

Reference

Task Class


Task Properties

Task Properties

The Task type exposes the following members.

Properties
 | Name | Description
Public property | Code | A Code allowing identifying an action
Top
See Also

Reference

Task Class


Task.Code Property

TaskCode Property
A Code allowing identifying an action

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Action Code { get; set; }
Public Property Code As Action
    Get
    Set
public:
property Action Code {
    Action get ();
    void set (Action value);
}
member Code : Action with get, set

Property Value

Type: Action
See Also

Reference

Task Class


TaskManager Class

TaskManager Class
The class managing the list of tasks and allowing undo/redo.
Inheritance Hierarchy
SystemObject
Lassalle.FlowTaskManager

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class TaskManager
Public Class TaskManager
public ref class TaskManager
type TaskManager =  class end

The TaskManager type exposes the following members.

Methods
 | Name | Description
Public method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
 | BeginAction | Start a group of actions that can be undone in one time.
Public method | Clear | Clears the undo/redo buffer.
Public method | EndAction | Terminate a group of actions that can be undone in one time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo, if possible, the last action.
Public method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Undo the last action performed in the diagram.
Top
Properties
 | Name | Description
Public property | CanRedo | Indicates if there is an action that can be redone.
Public property | CanUndo | Indicates if there is an action that can be undone.
Public property | CanUndoRedo | Determines whether undo/redo is allowed.
Public property | RedoCode | Returns the code of the next redoable action.
Public property | RedoItem | Returns the item involved in the next redoable action.
Public property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public property | UndoCode | Returns the code of the next undoable action.
Public property | UndoItem | Returns the item involved in the next undoable action.
Public property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


TaskManager Methods

TaskManager Methods

The TaskManager type exposes the following members.

Methods
 | Name | Description
Public method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
 | BeginAction | Start a group of actions that can be undone in one time.
Public method | Clear | Clears the undo/redo buffer.
Public method | EndAction | Terminate a group of actions that can be undone in one time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo, if possible, the last action.
Public method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Undo the last action performed in the diagram.
Top
See Also

Reference

TaskManager Class


TaskManager.AddToLastAction Method

TaskManagerAddToLastAction Method
Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void AddToLastAction()
Public Sub AddToLastAction
public:
void AddToLastAction()
member AddToLastAction : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.BeginAction Method

TaskManagerBeginAction Method
Start a group of actions that can be undone in one time.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginAction(
    int code
)
Public Sub BeginAction (
    code As Integer
)
public:
void BeginAction(
    int code
)
member BeginAction :
        code : int -> unit

Parameters

code
Type: SystemInt32
A positive integer. This code allows to identify a group of action. This code is returned by the UndoCode and RedoCode properties.
Examples
For instance, if, in your application, the user can open a dialog box allowing to change the image of the node, its color and its Text property, you will probably allow that user to undo these 3 basic actions in one time. To do that, add a call to BeginAction before invoking the dialog box and a call to EndAction just after the dialog box termination.
See Also

Reference

TaskManager Class


TaskManager.Clear Method

TaskManagerClear Method
Clears the undo/redo buffer.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.EndAction Method

TaskManagerEndAction Method
Terminate a group of actions that can be undone in one time.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void EndAction()
Public Sub EndAction
public:
void EndAction()
member EndAction : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.Redo Method

TaskManagerRedo Method
Redo, if possible, the last action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
void Redo()
member Redo : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.RemoveLastTask Method

TaskManagerRemoveLastTask Method
Remove the last task that has been added in the undo/redo buffer.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLastTask()
Public Sub RemoveLastTask
public:
void RemoveLastTask()
member RemoveLastTask : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.SubmitTask Method

TaskManagerSubmitTask Method
Submit a task (or action) that can be undone and redone.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void SubmitTask(
    Task task
)
Public Sub SubmitTask (
    task As Task
)
public:
void SubmitTask(
    Task^ task
)
member SubmitTask :
        task : Task -> unit

Parameters

task
Type: Lassalle.FlowTask
A task to include in the undo list
See Also

Reference

TaskManager Class


TaskManager.Undo Method

TaskManagerUndo Method
Undo the last action performed in the diagram.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
void Undo()
member Undo : unit -> unit
See Also

Reference

TaskManager Class


TaskManager Properties

TaskManager Properties

The TaskManager type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Indicates if there is an action that can be redone.
Public property | CanUndo | Indicates if there is an action that can be undone.
Public property | CanUndoRedo | Determines whether undo/redo is allowed.
Public property | RedoCode | Returns the code of the next redoable action.
Public property | RedoItem | Returns the item involved in the next redoable action.
Public property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public property | UndoCode | Returns the code of the next undoable action.
Public property | UndoItem | Returns the item involved in the next undoable action.
Public property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
See Also

Reference

TaskManager Class


TaskManager.CanRedo Property

TaskManagerCanRedo Property
Indicates if there is an action that can be redone.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRedo { get; }
Public ReadOnly Property CanRedo As Boolean
    Get
public:
property bool CanRedo {
    bool get ();
}
member CanRedo : bool with get

Property Value

Type: Boolean
Remarks
Typically, this method allows to enable or disable the "Redo" menu item of your application.
See Also

Reference

TaskManager Class


TaskManager.CanUndo Property

TaskManagerCanUndo Property
Indicates if there is an action that can be undone.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndo { get; }
Public ReadOnly Property CanUndo As Boolean
    Get
public:
property bool CanUndo {
    bool get ();
}
member CanUndo : bool with get

Property Value

Type: Boolean
Remarks
Typically, this method allows to enable or disable the "Undo" menu item of your application.
See Also

Reference

TaskManager Class


TaskManager.CanUndoRedo Property

TaskManagerCanUndoRedo Property
Determines whether undo/redo is allowed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndoRedo { get; set; }
Public Property CanUndoRedo As Boolean
    Get
    Set
public:
property bool CanUndoRedo {
    bool get ();
    void set (bool value);
}
member CanUndoRedo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TaskManager Class


TaskManager.RedoCode Property

TaskManagerRedoCode Property
Returns the code of the next redoable action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Action RedoCode { get; }
Public ReadOnly Property RedoCode As Action
    Get
public:
property Action RedoCode {
    Action get ();
}
member RedoCode : Action with get

Property Value

Type: Action
See Also

Reference

TaskManager Class


TaskManager.RedoItem Property

TaskManagerRedoItem Property
Returns the item involved in the next redoable action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item RedoItem { get; }
Public ReadOnly Property RedoItem As Item
    Get
public:
property Item^ RedoItem {
    Item^ get ();
}
member RedoItem : Item with get

Property Value

Type: Item
See Also

Reference

TaskManager Class


TaskManager.SkipUndo Property

TaskManagerSkipUndo Property
Determines whether the next actions are recorded in the task manager.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public bool SkipUndo { get; set; }
Public Property SkipUndo As Boolean
    Get
    Set
public:
property bool SkipUndo {
    bool get ();
    void set (bool value);
}
member SkipUndo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TaskManager Class


TaskManager.UndoCode Property

TaskManagerUndoCode Property
Returns the code of the next undoable action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Action UndoCode { get; }
Public ReadOnly Property UndoCode As Action
    Get
public:
property Action UndoCode {
    Action get ();
}
member UndoCode : Action with get

Property Value

Type: Action
See Also

Reference

TaskManager Class


TaskManager.UndoItem Property

TaskManagerUndoItem Property
Returns the item involved in the next undoable action.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Item UndoItem { get; }
Public ReadOnly Property UndoItem As Item
    Get
public:
property Item^ UndoItem {
    Item^ get ();
}
member UndoItem : Item with get

Property Value

Type: Item
See Also

Reference

TaskManager Class


TaskManager.UndoLimit Property

TaskManagerUndoLimit Property
Returns/sets the number of undo commands that can be performed.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public int UndoLimit { get; set; }
Public Property UndoLimit As Integer
    Get
    Set
public:
property int UndoLimit {
    int get ();
    void set (int value);
}
member UndoLimit : int with get, set

Property Value

Type: Int32
Remarks
  1. UndoLimit limits the size of the Undo buffer. Therefore, you can use this property to save memory.
  2. Setting UndoLimit to zero means that the size of the Undo buffer is unlimited.
See Also

Reference

TaskManager Class


TextPlacementMode Enumeration

TextPlacementMode Enumeration
Used to specify the position of the link text near the link.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextPlacementMode
Public Enumeration TextPlacementMode
public enum class TextPlacementMode
type TextPlacementMode
Members
Member name | Value | Description
MiddleSegment | 0 | The text is placed at the middle of the medium segment of the link
MiddleLine | 1 | The text is placed at the middle of the link line
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


TextPosition Enumeration

TextPosition Enumeration
Used to specify the position of the text in the node.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextPosition
Public Enumeration TextPosition
public enum class TextPosition
type TextPosition
Members
Member name | Value | Description
LeftTop | 0 | Text at the left top position of the node
LeftMiddle | 1 | Text at the left middle position of the node
LeftBottom | 2 | Text at the left bottom position of the node
RightTop | 3 | Text at the right top position of the node
RightMiddle | 4 | Text at the right middle position of the node
RightBottom | 5 | Text at the right bottom position of the node
CenterTop | 6 | Text at the center top position of the node
CenterMiddle | 7 | Text at the center middle position of the node
CenterBottom | 8 | Text at the center bottom position of the node
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


UpdatedEventArgs Class

UpdatedEventArgs Class
A subclass of EventArgs that contains the custom event arguments for the OnUpdated event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowUpdatedEventArgs
Lassalle.FlowUpdatingEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdatedEventArgs : EventArgs
Public Class UpdatedEventArgs
    Inherits EventArgs
public ref class UpdatedEventArgs : public EventArgs
type UpdatedEventArgs =
    class
        inherit EventArgs
    end

The UpdatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatedEventArgs | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | The property name
Public property | NewValue | The property value after the change
Public property | OldValue | The property value before the change
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


UpdatedEventArgs Constructor

UpdatedEventArgs Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public UpdatedEventArgs(
    string name,
    Object oldValue,
    Object newValue
)
Public Sub New (
    name As String,
    oldValue As Object,
    newValue As Object
)
public:
UpdatedEventArgs(
    String^ name,
    Object^ oldValue,
    Object^ newValue
)
new :
        name : string *
        oldValue : Object *
        newValue : Object -> UpdatedEventArgs

Parameters

name
Type: SystemString
The property name
oldValue
Type: SystemObject
The value before the change
newValue
Type: SystemObject
The value after the change
See Also

Reference

UpdatedEventArgs Class


UpdatedEventArgs Methods

UpdatedEventArgs Methods

The UpdatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatedEventArgs Class


UpdatedEventArgs Properties

UpdatedEventArgs Properties

The UpdatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Name | The property name
Public property | NewValue | The property value after the change
Public property | OldValue | The property value before the change
Top
See Also

Reference

UpdatedEventArgs Class


UpdatedEventArgs.Name Property

UpdatedEventArgsName Property
The property name

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

UpdatedEventArgs Class


UpdatedEventArgs.NewValue Property

UpdatedEventArgsNewValue Property
The property value after the change

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object NewValue { get; }
Public ReadOnly Property NewValue As Object
    Get
public:
property Object^ NewValue {
    Object^ get ();
}
member NewValue : Object with get

Property Value

Type: Object
See Also

Reference

UpdatedEventArgs Class


UpdatedEventArgs.OldValue Property

UpdatedEventArgsOldValue Property
The property value before the change

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public Object OldValue { get; }
Public ReadOnly Property OldValue As Object
    Get
public:
property Object^ OldValue {
    Object^ get ();
}
member OldValue : Object with get

Property Value

Type: Object
See Also

Reference

UpdatedEventArgs Class


UpdatedEventHandler Delegate

UpdatedEventHandler Delegate
Interface definition for the OnUpdated event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UpdatedEventHandler(
    Object sender,
    UpdatedEventArgs e
)
Public Delegate Sub UpdatedEventHandler (
    sender As Object,
    e As UpdatedEventArgs
)
public delegate void UpdatedEventHandler(
    Object^ sender,
    UpdatedEventArgs^ e
)
type UpdatedEventHandler =
    delegate of
        sender : Object *
        e : UpdatedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowUpdatedEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


UpdatingEventArgs Class

UpdatingEventArgs Class
A subclass of UpdatedEventArgs that contains the custom event arguments for the OnUpdating event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.FlowUpdatedEventArgs
Lassalle.FlowUpdatingEventArgs

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdatingEventArgs : UpdatedEventArgs
Public Class UpdatingEventArgs
    Inherits UpdatedEventArgs
public ref class UpdatingEventArgs : public UpdatedEventArgs
type UpdatingEventArgs =
    class
        inherit UpdatedEventArgs
    end

The UpdatingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatingEventArgs | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Indicates whether the value change should be cancelled.
Public property | Name | The property name (Inherited from UpdatedEventArgs.)
Public property | NewValue | The property value after the change (Inherited from UpdatedEventArgs.)
Public property | OldValue | The property value before the change (Inherited from UpdatedEventArgs.)
Top
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


UpdatingEventArgs Constructor

UpdatingEventArgs Constructor
Constructor

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public UpdatingEventArgs(
    string name,
    Object oldValue,
    Object newValue
)
Public Sub New (
    name As String,
    oldValue As Object,
    newValue As Object
)
public:
UpdatingEventArgs(
    String^ name,
    Object^ oldValue,
    Object^ newValue
)
new :
        name : string *
        oldValue : Object *
        newValue : Object -> UpdatingEventArgs

Parameters

name
Type: SystemString
The property name
oldValue
Type: SystemObject
The property value before the change
newValue
Type: SystemObject
The property value after the change
See Also

Reference

UpdatingEventArgs Class


UpdatingEventArgs Methods

UpdatingEventArgs Methods

The UpdatingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatingEventArgs Class


UpdatingEventArgs Properties

UpdatingEventArgs Properties

The UpdatingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Indicates whether the value change should be cancelled.
Public property | Name | The property name (Inherited from UpdatedEventArgs.)
Public property | NewValue | The property value after the change (Inherited from UpdatedEventArgs.)
Public property | OldValue | The property value before the change (Inherited from UpdatedEventArgs.)
Top
See Also

Reference

UpdatingEventArgs Class


UpdatingEventArgs.Cancel Property

UpdatingEventArgsCancel Property
Indicates whether the value change should be cancelled.

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

UpdatingEventArgs Class


UpdatingEventHandler Delegate

UpdatingEventHandler Delegate
Interface definition for the OnUpdating event

Namespace: Lassalle.Flow
Assembly: Lassalle.Flow (in Lassalle.Flow.dll) Version: 3.0.2.0 (3.0.2.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UpdatingEventHandler(
    Object sender,
    UpdatingEventArgs e
)
Public Delegate Sub UpdatingEventHandler (
    sender As Object,
    e As UpdatingEventArgs
)
public delegate void UpdatingEventHandler(
    Object^ sender,
    UpdatingEventArgs^ e
)
type UpdatingEventHandler =
    delegate of
        sender : Object *
        e : UpdatingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.FlowUpdatingEventArgs
See Also

Reference

Lassalle.Flow Namespace

Copyright (c) 2003-2016 Lassalle Technologies. All Rights Reserved

Send comments on this topic to plassalle@lassalle.com


Lassalle.Flow.Layout Namespace

Lassalle.Flow.Layout Namespace
LayoutFlow is a component that performs layouts on a graph. Performing a layout automatically positions its vertices (also called nodes) and edges (also called links). As LayoutFlow applies to AddFlow diagrams, it can be viewed as an extension of AddFlow for Winforms, a control dedicated to the creation and the use of flowchart diagrams or graphs. Note that it is necessary to use AddFlow for Winforms to be able to use LayoutFlow.
Classes
 | Class | Description
Public class | LayoutFlow | LayoutFlow is a class that performs some graph layout algorithms.
Public class | StepEventArgs | Event parameters used for the Step event
Enumerations
 | Enumeration | Description
Public enumeration | Orientation | Used to specify the general direction in which the automatic layout algorithm will position vertices.
Public enumeration | SPDrawingStyle | Used to specify the Series Parallel drawing style
Public enumeration | TreeDrawingStyle | Used to specify the tree drawing style


LayoutFlow Class

LayoutFlow Class
LayoutFlow is a class that performs some graph layout algorithms.
Inheritance Hierarchy
SystemObject
Lassalle.Flow.LayoutLayoutFlow

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static class LayoutFlow
Public NotInheritable Class LayoutFlow
public ref class LayoutFlow abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LayoutFlow =  class end
Methods
Name | Description
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Single, Single, Orientation, SizeF, Int32) | Performs the hierarchical layout
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, SizeF, Int32, SizeF) | Performs the orthogonal grid layout
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Single, Single, SizeF, SizeF) | Performs the Series parallel layout.
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF, Boolean, Boolean, Boolean, Boolean) | Performs the symmetic layout.
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Single, Single) | Performs the tree layout
TreeLayout(AddFlow, Single, Single, TreeDrawingStyle, Orientation, SizeF) | Performs the tree layout
Top
See Also

Reference

Lassalle.Flow.Layout Namespace


LayoutFlow Methods

LayoutFlow Methods
Methods
Name | Description
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Single, Single, Orientation, SizeF, Int32) | Performs the hierarchical layout
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, SizeF, Int32, SizeF) | Performs the orthogonal grid layout
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Single, Single, SizeF, SizeF) | Performs the Series parallel layout.
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF, Boolean, Boolean, Boolean, Boolean) | Performs the symmetic layout.
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Single, Single) | Performs the tree layout
TreeLayout(AddFlow, Single, Single, TreeDrawingStyle, Orientation, SizeF) | Performs the tree layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method

LayoutFlowHierarchicLayout Method
Overload List
Name | Description
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Single, Single, Orientation, SizeF, Int32) | Performs the hierarchical layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method (AddFlow)

LayoutFlowHierarchicLayout Method (AddFlow)
Performs the hierarchical layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void HierarchicLayout(
    AddFlow addflow
)
Public Shared Sub HierarchicLayout (
    addflow As AddFlow
)
public:
static void HierarchicLayout(
    AddFlow^ addflow
)
static member HierarchicLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
HierarchicLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method (AddFlow, Single, Single, Orientation, SizeF, Int32)

LayoutFlowHierarchicLayout Method (AddFlow, Single, Single, Orientation, SizeF, Int32)
Performs the hierarchical layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void HierarchicLayout(
    AddFlow addflow,
    float layerDistance,
    float vertexDistance,
    Orientation orientation,
    SizeF marginSize,
    int layerWidth
)
Public Shared Sub HierarchicLayout (
    addflow As AddFlow,
    layerDistance As Single,
    vertexDistance As Single,
    orientation As Orientation,
    marginSize As SizeF,
    layerWidth As Integer
)
public:
static void HierarchicLayout(
    AddFlow^ addflow,
    float layerDistance,
    float vertexDistance,
    Orientation orientation,
    SizeF marginSize,
    int layerWidth
)
static member HierarchicLayout :
        addflow : AddFlow *
        layerDistance : float32 *
        vertexDistance : float32 *
        orientation : Orientation *
        marginSize : SizeF *
        layerWidth : int -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemSingle
The distance between two adjacent layers.
vertexDistance
Type: SystemSingle
The distance between two adjacent vertices
orientation
Type: Lassalle.Flow.LayoutOrientation
The general direction in which the automatic layout algorithm will position vertices.
marginSize
Type: System.DrawingSizeF
The horizontal and vertical margin size.
layerWidth
Type: SystemInt32
The maximum number of vertices in a layer. If it is 0, then there is no maximum number of vertices.
See Also

Reference

LayoutFlow Class
HierarchicLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method

LayoutFlowOrthogonalGridLayout Method
Overload List
Name | Description
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, SizeF, Int32, SizeF) | Performs the orthogonal grid layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method (AddFlow)

LayoutFlowOrthogonalGridLayout Method (AddFlow)
Performs the orthogonal grid layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void OrthogonalGridLayout(
    AddFlow addflow
)
Public Shared Sub OrthogonalGridLayout (
    addflow As AddFlow
)
public:
static void OrthogonalGridLayout(
    AddFlow^ addflow
)
static member OrthogonalGridLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
OrthogonalGridLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method (AddFlow, Orientation, SizeF, Int32, SizeF)

LayoutFlowOrthogonalGridLayout Method (AddFlow, Orientation, SizeF, Int32, SizeF)
Performs the orthogonal grid layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void OrthogonalGridLayout(
    AddFlow addflow,
    Orientation orientation,
    SizeF gridSize,
    int nodeSizeRatio,
    SizeF marginSize
)
Public Shared Sub OrthogonalGridLayout (
    addflow As AddFlow,
    orientation As Orientation,
    gridSize As SizeF,
    nodeSizeRatio As Integer,
    marginSize As SizeF
)
public:
static void OrthogonalGridLayout(
    AddFlow^ addflow,
    Orientation orientation,
    SizeF gridSize,
    int nodeSizeRatio,
    SizeF marginSize
)
static member OrthogonalGridLayout :
        addflow : AddFlow *
        orientation : Orientation *
        gridSize : SizeF *
        nodeSizeRatio : int *
        marginSize : SizeF -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
orientation
Type: Lassalle.Flow.LayoutOrientation
Layout orientation
gridSize
Type: System.DrawingSizeF
The horizontal and vertical grid size
nodeSizeRatio
Type: SystemInt32
The node size expressed in percentage of the grid size
marginSize
Type: System.DrawingSizeF
The horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
OrthogonalGridLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method

LayoutFlowSeriesParallelLayout Method
Overload List
Name | Description
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Single, Single, SizeF, SizeF) | Performs the Series parallel layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method (AddFlow)

LayoutFlowSeriesParallelLayout Method (AddFlow)
Performs the Series parallel layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void SeriesParallelLayout(
    AddFlow addflow
)
Public Shared Sub SeriesParallelLayout (
    addflow As AddFlow
)
public:
static void SeriesParallelLayout(
    AddFlow^ addflow
)
static member SeriesParallelLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
SeriesParallelLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method (AddFlow, SPDrawingStyle, Orientation, Single, Single, SizeF, SizeF)

LayoutFlowSeriesParallelLayout Method (AddFlow, SPDrawingStyle, Orientation, Single, Single, SizeF, SizeF)
Performs the Series parallel layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void SeriesParallelLayout(
    AddFlow addflow,
    SPDrawingStyle drawingStyle,
    Orientation orientation,
    float layerDistance,
    float vertexDistance,
    SizeF vertexSize,
    SizeF marginSize
)
Public Shared Sub SeriesParallelLayout (
    addflow As AddFlow,
    drawingStyle As SPDrawingStyle,
    orientation As Orientation,
    layerDistance As Single,
    vertexDistance As Single,
    vertexSize As SizeF,
    marginSize As SizeF
)
public:
static void SeriesParallelLayout(
    AddFlow^ addflow,
    SPDrawingStyle drawingStyle,
    Orientation orientation,
    float layerDistance,
    float vertexDistance,
    SizeF vertexSize,
    SizeF marginSize
)
static member SeriesParallelLayout :
        addflow : AddFlow *
        drawingStyle : SPDrawingStyle *
        orientation : Orientation *
        layerDistance : float32 *
        vertexDistance : float32 *
        vertexSize : SizeF *
        marginSize : SizeF -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
drawingStyle
Type: Lassalle.Flow.LayoutSPDrawingStyle
the Series Parallel drawing style
orientation
Type: Lassalle.Flow.LayoutOrientation
the general direction in which the automatic layout algorithm will position vertices
layerDistance
Type: SystemSingle
the distance between two adjacent layers
vertexDistance
Type: SystemSingle
the distance between two adjacent vertices
vertexSize
Type: System.DrawingSizeF
the horizontal and vertical vertex size
marginSize
Type: System.DrawingSizeF
the horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
SeriesParallelLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method

LayoutFlowSymmetricLayout Method
Overload List
Name | Description
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Single, SizeF, Boolean, Boolean, Boolean, Boolean) | Performs the symmetic layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow)

LayoutFlowSymmetricLayout Method (AddFlow)
Performs the symmetic layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow
)
public:
static void SymmetricLayout(
    AddFlow^ addflow
)
static member SymmetricLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow, Single, SizeF)

LayoutFlowSymmetricLayout Method (AddFlow, Single, SizeF)
Performs the symmetic layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow,
    float distance,
    SizeF marginSize
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow,
    distance As Single,
    marginSize As SizeF
)
public:
static void SymmetricLayout(
    AddFlow^ addflow,
    float distance,
    SizeF marginSize
)
static member SymmetricLayout :
        addflow : AddFlow *
        distance : float32 *
        marginSize : SizeF -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
distance
Type: SystemSingle
The distance between two vertices
marginSize
Type: System.DrawingSizeF
The horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow, Single, SizeF, Boolean, Boolean, Boolean, Boolean)

LayoutFlowSymmetricLayout Method (AddFlow, Single, SizeF, Boolean, Boolean, Boolean, Boolean)
Performs the symmetic layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow,
    float distance,
    SizeF marginSize,
    bool isUnmoveableNodesAccepted,
    bool isRandom,
    bool isSendStepEvent,
    bool isAnimated
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow,
    distance As Single,
    marginSize As SizeF,
    isUnmoveableNodesAccepted As Boolean,
    isRandom As Boolean,
    isSendStepEvent As Boolean,
    isAnimated As Boolean
)
public:
static void SymmetricLayout(
    AddFlow^ addflow,
    float distance,
    SizeF marginSize,
    bool isUnmoveableNodesAccepted,
    bool isRandom,
    bool isSendStepEvent,
    bool isAnimated
)
static member SymmetricLayout :
        addflow : AddFlow *
        distance : float32 *
        marginSize : SizeF *
        isUnmoveableNodesAccepted : bool *
        isRandom : bool *
        isSendStepEvent : bool *
        isAnimated : bool -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
distance
Type: SystemSingle
The distance between two vertices
marginSize
Type: System.DrawingSizeF
The horizontal and vertical margin size
isUnmoveableNodesAccepted
Type: SystemBoolean
Determines whether the layout takes account of the IsXMoveable and IsYMoveable properties of the nodes.
isRandom
Type: SystemBoolean
If isRandom is false, then all the random effects are removed in the layout algorithm. By default, - the nodes are placed randomly at the beginning of the layout - the nodes are selected randomly during the execution of the layout - a random "shaking" force is used during the execution of the layout Setting isRandom to false removes these 3 random effects, which may be useful if you wish that the algorithm allways produced the same layout. (However it still depends on the initial position of nodes but you can give them all the same (0,0) position before executing the layout)
isSendStepEvent
Type: SystemBoolean
Determines whether the Step event is fired at each iteration of the layout algorithm. This property could be used for instance to terminate the algorithm.
isAnimated
Type: SystemBoolean
If true, an animation of the layout can be viewed
Remarks
If the IsXMoveable property of a node is false and if UnmoveableNodesAccepted is true, then the SFlow layout will move it only vertically. If the IsYMoveable property of a node is false and if UnmoveableNodesAccepted is true, then the SFlow layout will move it only horizontally. If both the IsXMoveable and IsYMoveable properties are false (and if UnmoveableNodesAccepted is true), the node will not move neither vertically neither horizontally.
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.TreeLayout Method

LayoutFlowTreeLayout Method
Overload List
Name | Description
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Single, Single) | Performs the tree layout
TreeLayout(AddFlow, Single, Single, TreeDrawingStyle, Orientation, SizeF) | Performs the tree layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow)

LayoutFlowTreeLayout Method (AddFlow)
Performs the tree layout.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow
)
Public Shared Sub TreeLayout (
    addflow As AddFlow
)
public:
static void TreeLayout(
    AddFlow^ addflow
)
static member TreeLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow, Single, Single)

LayoutFlowTreeLayout Method (AddFlow, Single, Single)
Performs the tree layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow,
    float layerDistance,
    float vertexDistance
)
Public Shared Sub TreeLayout (
    addflow As AddFlow,
    layerDistance As Single,
    vertexDistance As Single
)
public:
static void TreeLayout(
    AddFlow^ addflow,
    float layerDistance,
    float vertexDistance
)
static member TreeLayout :
        addflow : AddFlow *
        layerDistance : float32 *
        vertexDistance : float32 -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemSingle
Distance between two adjacent layers.
vertexDistance
Type: SystemSingle
Distance between two adjacent vertices
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow, Single, Single, TreeDrawingStyle, Orientation, SizeF)

LayoutFlowTreeLayout Method (AddFlow, Single, Single, TreeDrawingStyle, Orientation, SizeF)
Performs the tree layout

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow,
    float layerDistance,
    float vertexDistance,
    TreeDrawingStyle drawingStyle,
    Orientation orientation,
    SizeF marginSize
)
Public Shared Sub TreeLayout (
    addflow As AddFlow,
    layerDistance As Single,
    vertexDistance As Single,
    drawingStyle As TreeDrawingStyle,
    orientation As Orientation,
    marginSize As SizeF
)
public:
static void TreeLayout(
    AddFlow^ addflow,
    float layerDistance,
    float vertexDistance,
    TreeDrawingStyle drawingStyle,
    Orientation orientation,
    SizeF marginSize
)
static member TreeLayout :
        addflow : AddFlow *
        layerDistance : float32 *
        vertexDistance : float32 *
        drawingStyle : TreeDrawingStyle *
        orientation : Orientation *
        marginSize : SizeF -> unit

Parameters

addflow
Type: Lassalle.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemSingle
Distance between two adjacent layers.
vertexDistance
Type: SystemSingle
Distance between two adjacent vertices
drawingStyle
Type: Lassalle.Flow.LayoutTreeDrawingStyle
tree drawing style
orientation
Type: Lassalle.Flow.LayoutOrientation
Layout orientation
marginSize
Type: System.DrawingSizeF
Horizontal and vertical margin size.
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.Flow.Layout Namespace


Orientation Enumeration

Orientation Enumeration
Used to specify the general direction in which the automatic layout algorithm will position vertices.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public enum Orientation
Public Enumeration Orientation
public enum class Orientation
type Orientation
Members
Member name | Value | Description
North | 0 | Start at the top and proceed downwards
East | 1 | Start at the right side and proceed toward the left
South | 2 | Start at the bottom and proceed upwards
West | 3 | Start on the left side and proceed toward the right
See Also

Reference

Lassalle.Flow.Layout Namespace


SPDrawingStyle Enumeration

SPDrawingStyle Enumeration
Used to specify the Series Parallel drawing style

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public enum SPDrawingStyle
Public Enumeration SPDrawingStyle
public enum class SPDrawingStyle
type SPDrawingStyle
Members
Member name | Value | Description
BusOrthogonalDrawing | 0 | The has a bus above. The sink has a bus below. All other vertices have exactly one bus above and one bus below.
StraightLine | 1 | Each edge is a straight line.
VisibilityDrawing | 2 | Each vertex is mapped as a horizontal lne segment and each edge to a vertical line segment
See Also

Reference

Lassalle.Flow.Layout Namespace


StepEventArgs Class

StepEventArgs Class
Event parameters used for the Step event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.Flow.LayoutStepEventArgs

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public class StepEventArgs : EventArgs
Public Class StepEventArgs
    Inherits EventArgs
public ref class StepEventArgs : public EventArgs
type StepEventArgs =
    class
        inherit EventArgs
    end

The StepEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StepEventArgs | Constructor. Creates a new StepEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

Lassalle.Flow.Layout Namespace


StepEventArgs Constructor

StepEventArgs Constructor
Constructor. Creates a new StepEventArgs instance.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public StepEventArgs(
    int iteration
)
Public Sub New (
    iteration As Integer
)
public:
StepEventArgs(
    int iteration
)
new :
        iteration : int -> StepEventArgs

Parameters

iteration
Type: SystemInt32
Current iteration of the layout algorithm
See Also

Reference

StepEventArgs Class
Lassalle.Flow.Layout Namespace


StepEventArgs Methods

StepEventArgs Methods

The StepEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StepEventArgs Class
Lassalle.Flow.Layout Namespace


StepEventArgs Properties

StepEventArgs Properties

The StepEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

StepEventArgs Class
Lassalle.Flow.Layout Namespace


StepEventArgs.Cancel Property

StepEventArgsCancel Property
Gets/sets a value indicating whether the layout should be canceled.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StepEventArgs Class
Lassalle.Flow.Layout Namespace


StepEventArgs.Iteration Property

StepEventArgsIteration Property
Gets the current iteration of the layout algorithm.

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public int Iteration { get; }
Public ReadOnly Property Iteration As Integer
    Get
public:
property int Iteration {
    int get ();
}
member Iteration : int with get

Property Value

Type: Int32
See Also

Reference

StepEventArgs Class
Lassalle.Flow.Layout Namespace


TreeDrawingStyle Enumeration

TreeDrawingStyle Enumeration
Used to specify the tree drawing style

Namespace: Lassalle.Flow.Layout
Assembly: Lassalle.Flow.Layout (in Lassalle.Flow.Layout.dll) Version: 3.0.0.5 (3.0.0.5)
Syntax
C#
VB
C++
F#
Copy
public enum TreeDrawingStyle
Public Enumeration TreeDrawingStyle
public enum class TreeDrawingStyle
type TreeDrawingStyle
Members
Member name | Value | Description
Layered | 0 | Layered tree drawing: vertices are arranged in horizontal (or vertical, depending of the choosen orientation) layers
Radial | 1 | Radial tree drawing: the root is placed origin and the layers are concentric circles centered at the origin
See Also

Reference

Lassalle.Flow.Layout Namespace