Introduction

Products | Support | Back to Introduction | Email a link to this topic. | Back to Introduction - All Topics | Help Version 19.0.12.8
LEADTOOLS Licensing Agreements Help > Introduction

LEADTOOLS Licensing Summary

SDK Licensing

Licensing Overview

LEADTOOLS Software License Agreement (EULA)

Copyright Notice

Development Licensing

SDK Licensing

Development Seat Frequently Asked Questions

Single End User Application License Examples

OEM License Frequently Asked Questions

Deployment Licensing

About LEADTOOLS Deployment Licenses

Deployment Types

Deployment License Frequently Asked Questions

Commercial Distribution License

Deployment License Application

Deployment License Prices

LEAD Deployment License Prices - Pro Family

LEAD Deployment License Prices - Document Family

LEAD Deployment License Prices - Medical Family

LEAD Deployment License Prices - Multimedia Family

Products | Support | Contact Us | Copyright Notices
© 1991-2014 LEAD Technologies, Inc. All Rights Reserved.


Licensing Overview

LEADTOOLS Licensing Agreements Help > SDK Licensing > Licensing Overview

LEADTOOLS Licensing Overview

A customer's use of a LEADTOOLS software development toolkit (SDK) or add-on is governed by the license agreement that accompanies the product: LEAD's standard end-user software license agreement (EULA),

The SDK license has two (2) primary licensing components:

  • A "Development License" that allows a programmer to develop with the SDK.
  • A "Deployment License" permitting the customer to deploy or distribute the resulting application containing LEAD’s intellectual property contained in the SDK redistributable files.

I. Development License for SDK products:

A Development License is required to program with LEADTOOLS. The Development License may be purchased directly from LEAD or from a LEAD authorized distributor or reseller. The Development License allows the customer to install the SDK on a development computer and use the SDK for development of an end user application, by integrating certain redistributable libraries and files into the end user application using the SDK sample code and documentation. The basic development license rules are here: (About Development Licenses).

II. Deployment License

The Deployment License governs the customer’s use of the resulting end user application ("End User Software") that is developed with the SDK. Unlike a license agreement for a typical end user application, an SDK license generally grants the user a license to copy and redistribute a portion of the SDK. LEAD’s customers must obtain the appropriate deployment license in order to copy LEAD’s intellectual property and deploy it along with the end user software developed with the LEAD SDK. For more information about deployment licenses, refer to About LEADTOOLS Deployment Licenses. LEAD SDK deployment licensing requirements also vary depending upon the type of deployment being made by the customer (e. g. internal, commercial, hosted service, desk top/single user, mobile device/single user, concurrent user, deployment to server, deployment to kiosk).

III. Other Licensing Requirements

Additional licensing requirements apply to applications developed using LEAD SDKs:

  • Copyright Notice. An application that is developed with LEADTOOLS must contain the following copyright notice in the "about box" or software documentation/help file: "Portions of this program were developed using LEADTOOLS 1991-2014 LEAD Technologies, Inc. ALL RIGHTS RESERVED. Portions of this product are licensed under US patent 5,327,254 and foreign counterparts."

  • End User License Agreement. The end user application developed with LEADTOOLS must be distributed with an EULA which prohibits reverse engineering, disassembly, modification and copying (other than for back up purposes) and which preserves LEAD's intellectual property rights in the software to a commercially reasonable degree.

  • OEMs. If LEAD's customer develops an application and wishes to allow a third party OEM to modify and redistribute the application, an OEM distribution license needs to be obtained by the customer for each OEM that will be modifying the software and redistributing it. Please contact oemsales@leadtools.com regarding OEM Distribution Licenses.
    How does LEAD define "OEM application" for purposes of the Deployment License?

  • Export Restrictions. Any end user application developed with LEADTOOLS is subject to the US Export Regulations. Thus, a LEAD customer may not ship the end user application to any country or any person where US law restricts exports, such as Cuba, Sudan, Iran or North Korea. (Please contact US Import Control Agency for a current list of prohibited territories and persons.)

For more information, refer to:

LEADTOOLS Licensing Summary

LEADTOOLS Standard End-User Software License Agreement (EULA)

Single End User Application License Examples

Development Seat Frequently Asked Questions

OEM License Frequently Asked Questions

About LEADTOOLS Deployment Licenses

Deployment Types


LEADTOOLS Standard End-User Software License Agreement (EULA)

LEADTOOLS Licensing Agreements Help > SDK Licensing > LEADTOOLS Standard End-User Software License Agreement (EULA)

LEADTOOLS Software License Agreement (EULA)

IMPORTANT

LEAD TECHNOLOGIES, INC. IS WILLING TO LICENSE LEAD SDK(S) TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THE LICENSE AGREEMENT PRINTED BELOW, INCLUDING WITHOUT LIMITATION, THE WARRANTY DISCLAIMERS, LIMITATIONS OF LIABILITY AND INDEMNITY PROVISIONS. PLEASE READ THE TERMS CAREFULLY BEFORE CLICKING THE ACCEPT BUTTON DURING INSTALLATION, AS SUCH CONDUCT INDICATES YOUR ACCEPTANCE TO ALL OF THE TERMS OF THE LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS, LEAD TECHNOLOGIES, INC. IS UNWILLING TO LICENSE THE LEAD SDK(S) TO YOU AND YOU ARE NOT PERMITTED TO INSTALL OR USE THE LEAD SDK(S).

This License Agreement (“Agreement”) is a legal agreement between LEAD Technologies, Inc. (“LEAD”), a North Carolina corporation, principally located in Charlotte, North Carolina, and you (either an individual or single entity) (“Licensee”), and is effective the date Licensee installs and uses the applicable LEAD SDK(s).

1. DEFINITIONS

As used herein, the following terms, when capitalized, will have the following meanings:

“LEAD SDK” means one or more of the following LEADTOOLS® developer toolkit products: LEADTOOLS Imaging Pro, LEADTOOLS Barcode Pro, LEADTOOLS PDF Pro, LEADTOOLS Pro Suite, LEADTOOLS Document Imaging, LEADTOOLS Document Imaging Suite, LEADTOOLS Recognition, LEADTOOLS Medical Imaging, LEADTOOLS Medical Imaging Suite, LEADTOOLS PACS Imaging, LEADTOOLS Multimedia, LEADTOOLS Multimedia Suite, LEADTOOLS OCR Modules, LEADTOOLS ICR Module, LEADTOOLS Medical Multimedia Module, LEADTOOLS DVD Module, LEADTOOLS Video Streaming Module and LEADTOOLS MPEG-2 Transport Module. This Agreement also applies to any updates or supplements to the LEAD SDK(s) provided by LEAD, unless LEAD provides new license terms and conditions with the update or supplement.

“Licensee” means the person or entity entering into this Agreement with LEAD. Any person who is entering into this Agreement on behalf of an organizational entity represents that he or she has the authority to bind such entity.

“End User Software” means an end user program which Licensee develops using the LEAD SDK and into which the Redistributables are incorporated, and which contains significant additional functionality over and above the functionality contained in the LEAD SDK.

“Redistributables” are those runtime libraries and files intended for duplication and distribution with the End User Software. The Redistributables are identified in the “Files to be Included with Your Application” section of the LEAD SDK help file.

“Development License” means the license granted pursuant to section 2 below allowing Licensee to use the LEAD SDK to develop End User Software by integrating the Redistributables into End User Software.

“Deployment License” means the license granted pursuant to section 3 below allowing Licensee to copy, deploy and redistribute the Redistributables to end users as part of the End User Software.

“Deployment of End User Software” includes any and all copies of End User Software installed, used, distributed, leased, sold or otherwise disposed of by Licensee, and any of its customers, employees, distributors, resellers, affiliates or other channel partners, and includes, Internal Deployments, Hosted Service Deployments and Commercial Deployments.

“Commercial Deployment” means any distribution and other disposition of End User Software by Licensee to third party end users, either directly or through distribution channels. Commercial Deployments occur where Licensee is acting as an ISV, OEM or solution provider offering End User Software to the public in the form of Single User Deployments, Concurrent Deployments, Server Deployments, Multi-User Deployments and/or in some other deployment model approved by LEAD.

“Internal Deployment” means Licensee is deploying End User Software, including Single User Deployments, Concurrent Deployments, Server Deployments, Multi-user Deployments and/or some other deployment model approved by LEAD on hardware devices owned or controlled by Licensee for internal business use limited to Licensee’s employees and contractors.

“Hosted Service Deployment” is a type of Server Deployment where Licensee is hosting End User Software on Licensee’s machines for consumption or commercial use by customers, vendors and other third parties. Examples of a “Hosted Service Deployment” include End User Software operated by a service bureau, application service provider, outsource facility, and any public facing End User Software hosted by Licensee accessible by customers and third parties via the internet or other network.

“Single User Deployment” means installation of the End User Software by Licensee and/or its customer on a stand-alone PC, work station, mobile device or other hardware for use by a single named user. End User Software that is deployed as Single User is intended for interactive use by the named end user, and has a GUI requiring the user to control the application by mouse, keyboard, touch-screen or similar means. A Single User Deployment also is applicable where End User Software is distributed to client machines through a deployment server or other network device via a CAB file or similar mechanism and installed on the client machine. Single User Deployments are commonly referred to as desktop licenses, client licenses, stand-alone licenses, app licenses and user licenses.

“Concurrent Deployment” means Licensee has built a reasonable method of concurrency into the End User Software so that, although installed on multiple PCs for single user usage, only a limited number of users are technically permitted to use the End User Software at the same time. For example, if the End User Software is installed on one hundred (100) PCs, but only ten (10) users may be logged in to use the End User Software at the same time, licensing for ten (10) Concurrent Deployments would be required instead of 100 Single User Deployment licenses. The fact that a server application is “queuing” jobs sent to it, and processing one job at a time, is not considered concurrency for purposes hereof. This type of deployment would be a Server Deployment. A Concurrent Deployment also occurs if Licensee issues client licenses on a subscription type model and wishes to recapture client licenses that are no longer subscribed and assign such licenses to another user. Concurrent licenses are also commonly referred to as floating licenses.

“Server Deployment” includes the following: (i) End User Software installed on a networked device accessible by more than one person who can independently operate the End User Software from another machine; (ii) End User Software installed on a networked device running as a service that accepts connections from other machines or applications (for example, a headless process to watch a folder or other data sources for work originating from other machines), and (iii) End User Software deployed to a browser from a webserver, such as an HTML5 based application, where the End User Software is not installed on the client machine but is in use by the client machine while the user is connected to the webserver.

“Multi-User Deployment” means a computer installation designed to service the public or multiple un-named users, and not a single named user or set of concurrent named users, such as a kiosk or a scan station.

“Deployment License Fee” means the required payment by Licensee to LEAD for each Deployment of End User Software made by Licensee.

2. GRANT OF DEVELOPMENT LICENSE

For each Development License of the LEAD SDK purchased by Licensee, LEAD grants Licensee a non-exclusive, non-transferable, perpetual, worldwide license for one (1) named programmer to install the LEAD SDK on a personal computer and use the LEAD SDK, including its documentation and sample code, in the development of End User Software. Licensee may install the LEAD SDK on one additional development computer, such as a laptop computer, for use by Licensee’s named programmer when such person’s primary development computer is not available. Licensee may also install the LEAD SDK on up to two (2) additional “build” machines in use by other developers, provided that the other developers are not programming with the LEAD SDK. Only one (1) named programmer is permitted to program using the LEAD SDK for each Development License purchased by Licensee. Additional Development Licenses, (including licenses for additional named programmers and/or additional build machines) may be procured at discounted pricing by contacting LEAD’s sales department. The license granted hereunder applies only to the designated version of the accompanying LEAD SDK. If the LEAD SDK is an upgrade, it, and the product that was upgraded constitutes a single copy of the LEAD SDK for purposes hereof and the new version and product that was upgraded may only be used by the same named programmer.

3. GRANT OF DEPLOYMENT LICENSE

LEAD grants Licensee (and only Licensee) a non-exclusive, non-transferable, worldwide license to reproduce (and have reproduced) exact copies of the Redistributables and include such files in the End User Software, and to make Internal Deployments, Hosted Service Deployments and Commercial Deployments of the End User Software, to end users for their use, without further distribution, subject to the following terms and conditions:

(a) Deployment License Application Process. First, Licensee will apply for a Deployment License by completing a Deployment License Application form (“DLA”) which, among other things, will identify whether Licensee’s End User Software is for Internal Deployment, Hosted Service Deployment or Commercial Deployment and the type and manner of deployment (Single User, Concurrent, Multi-User, Server).

(b) Deployment License Grants for Internal Deployments and Hosted Service Deployments. For all LEAD SDKs, Licensee must pay a Deployment Licensee Fee for each Single User Deployment, Concurrent User Deployment, Server Deployment, Multi-User Deployment and Hosted Service Deployment made by Licensee. Based on the information provided in Licensee’s DLA, LEAD will provide Licensee a firm Deployment License Fee quotation for the number and type of Deployment Licenses for Internal Deployments or Hosted Service Deployments being acquired by Licensee. Upon payment of the required Deployment License Fees, LEAD will issue Licensee a license certificate evidencing the number, type and duration of Deployment Licenses granted to Licensee for Internal Deployment. No Deployment License is granted until such time as Licensee has purchased the applicable Deployment License.

(c) Deployment License Grants for Commercial Deployments. For all LEAD SDKs, Licensee must execute a Commercial Distribution License agreement prior to making any Commercial Deployment. The Commercial Deployment License agreement will contain the pricing and other terms and conditions for Commercial Deployment of End User Software. Under no circumstances may Licensee make any Commercial Deployment until such time as LEAD and Licensee have executed a Commercial Distribution License agreement.

(d) Deployment Files. Runtime license files, developer keys or similar items (“Deployment Files”) are required to be included with the End User Software when deployed. Without the appropriate Deployment Files, the End User Software will expire. For Internal Deployments, LEAD will provide Licensee its Deployment Files when Licensee has completed the Deployment License Application form and purchased its required Deployment Licenses. For Commercial Deployments, LEAD will provide Licensee its Deployment Files when Licensee has executed the Commercial Distribution License.

(e) Record Keeping and Reporting. Licensee agrees to maintain full, clear and accurate records regarding its use of the LEAD SDK and the deployment of the End User Software and will promptly respond to inquiries from LEAD’s license compliance department, including responding to an annual deployment activity report. Deployment License Fees for any Deployments of End User Software that Licensee deploys without first purchasing the appropriate Deployment License will be billed at a default rate equal to LEAD’s standard rates for quantity one (1) of the applicable Deployment License Type. Volume discounts for Deployment Licenses are only available for Deployment Licenses that are purchased prior to Deployment by Licensee. LEAD shall have the right, no more than once during any calendar year, to have an independent certified public accountant or other disinterested third party inspect the relevant records of Licensee on thirty (30) days’ notice and during regular business hours to verify the reports and payments required to be made hereunder. Should an underpayment in excess of five percent (5%) be discovered, Licensee will pay the cost of the audit.

(f) Duration of Deployment Licenses. Unless otherwise stated in a duly executed License Certificate, Deployment Licenses for Internal Deployments and Hosted Service Deployments are valid for one (1) year and may be renewed on an annual basis. Deployment Licenses for Commercial Deployments will have the duration set forth in the applicable Commercial Distribution License executed by LEAD and Licensee.

(g) New Versions; Upgrades. Minor version updates to the LEAD SDK (e. g. patches or point releases) are provided to Licensee free of charge. Licensee may license major new versions of the LEAD SDK (designated either as a whole number or a .5 release, e. g. LEADTOOLS version 19, 19.5, 20 or such other major version designation as may be hereafter adopted by LEAD) by purchasing a Development License to the new version at LEAD’s then prevailing upgrade price. No additional deployment licensing is required for deploying minor version updates to Licensee’s duly licensed install base for the End User Software. For Internal Deployments and Hosted Service Deployments, if a major new version of the LEAD SDK is included in an upgrade to the End User Software, no additional Deployment License Fee will be required for so long as Licensee is paying the required annual Deployment License Fees. For Commercial Deployments, the Deployment License upgrade pricing and maintenance options will be set forth in the Commercial Distribution License executed by LEAD and Licensee.

(h) OEM Distribution. If Licensee wishes to use an OEM who will modify the End User Software and copy it, Licensee must first obtain an OEM distribution license from LEAD or must require the OEM to obtain a license from LEAD. Duplication or redistribution of the End User Software, or any portion thereof, by the users of the End User Software, without a separate written redistribution license from LEAD, is prohibited.

(i) Registration. No rights to copy or redistribute the End User Software are granted until such time as Licensee has properly registered and activated the LEAD SDK with LEAD and obtained its Deployment Files.

4. OTHER LICENSE TERMS AND RESTRICTIONS

The licenses granted under this Agreement are expressly conditioned upon Licensee’s compliance with all the terms and conditions of this Agreement. Licensee may not use, copy, rent, lease, sell, sublicense, assign or otherwise transfer the LEAD SDK except as expressly provided for in this Agreement. Licensee may make a reasonable number of archival copies of the LEAD SDK. Except for the Redistributables, Licensee shall not distribute any files contained in the LEAD SDK, including without limitation, .LIB, .H, .MAK, .DEF, .TXT, .PDF, .HLP files or any sample source code. Licensee acknowledges that the LEAD SDK, in source code form, remains a confidential trade secret of LEAD and/or its suppliers and therefore Licensee agrees that it shall not modify, decompile, disassemble or reverse engineer the LEAD SDK, or attempt to do so, except as permitted by applicable legislation. Licensee shall not reproduce, copy or transfer any Documentation, except Licensee may use the sample source code examples contained in the Documentation for the purpose of developing the End User Software subject to the following limitations: (i) Licensee may not use the sample source code for any purpose other than developing the End User Software and (ii) Licensee may not disclose, redistribute or otherwise transfer any of the sample source code, or any source code derived from the sample source code. Licensee acknowledges that the sample source code is a confidential trade secret of LEAD, and Licensee shall treat the sample source code in the same manner as Licensee treats its own trade secret information, but in no event less than a reasonable degree of protection. Any Licensee employee or contractor who has access to the sample source code must be bound by a written nondisclosure agreement prohibiting him from disclosing any trade secret information of Licensee and/or its suppliers. Licensee may not use the LEAD SDK to develop an application that directly or indirectly utilizes LEAD’s Redistributables existing in another application that has been developed by Licensee or some third party. Licensee agrees to refrain from disclosing any unlock keys, serial numbers or activation codes to any third party or otherwise take any action intended to circumvent copyright protection or other anti-piracy measures implemented by LEAD with respect to the LEAD SDK. The End User Software developed by Licensee must be an “end user application.” An “end user application” is a specific application program that is licensed to a person or firm for business or personal use and not with a view toward redistributing the application or any part of the application, and may be either an application that is used by Licensee internally, or an application that is commercially distributed to end users for their use. A user of an end user application may not modify or redistribute the application and may not copy it (other than for archival purposes). The End User Software may only be offered to end users in object code form. Licensee’s license agreement covering the End User Software must contain restrictions prohibiting redistribution, modification and copying of the End User Software. Only one (1) end user application may be developed for each Development License purchased by Licensee. Nothing herein will be deemed to allow use of LEAD SDKs in the development of products offered as web services, ActiveX control, development toolkits, dynamic link libraries (DLLs), software with an application programming interface (API), compilers, operating systems or any other software not falling within the above definition of End User Software. If Licensee wishes to use the LEAD SDK in a manner prohibited by this Agreement, Licensee should contact LEAD’s OEM department to determine whether a special license may be obtained. Upon LEAD’s request, Licensee agrees to send LEAD one demonstration copy of the End User Software.

5. EVALUATION VERSION LICENSE

If Licensee is using an "evaluation version" of the LEAD SDK, then the licenses granted hereunder are limited as follows: (a) Licensee is granted a license to use the LEAD SDK for a period of sixty (60) days counted from the day of installation (the "Evaluation Period") solely for purposes of evaluation and testing the LEAD SDK to determine if Licensee wishes to purchase a license for the release version of the LEAD SDK; (b) upon completion of the Evaluation Period, Licensee shall either i) delete the LEAD SDK from the computer containing the installation, or ii) obtain a paid Development and Deployment License of the LEAD SDK from LEAD or any of its resellers; and (c) any End User Software developed with the evaluation version of the LEAD SDK may not be deployed other than internally for testing purposes, and will not be distributed or used for any purpose other than evaluating the functionality and performance of the LEAD SDK.

6. PAYMENT TERMS; PURCHASE ORDERS

Licensee will pay all valid LEAD invoices on a timely basis. If Licensee is more than 30 days past due on any invoice, Licensee agrees to pay finance charges equal to one and a half percent (1.5%) per month or at the maximum rate permitted by law, whichever is less, on all over due and unpaid invoices until paid in full. All license fees and other amounts due LEAD are denominated and will be paid in United States Dollars and are exclusive of any and all applicable taxes. Licensee is responsible for paying any sales, use, value added or other taxes (other than federal and state taxes levied on LEAD’s income) in connection with the licenses granted hereby and will indemnify LEAD from any claims or damages associated with the nonpayment of such taxes. LEAD accepts purchase orders provided Licensee obtains credit approval from LEAD’s credit department. To the extent any term of a purchase order is inconsistent with the terms of this Agreement, Licensee agrees that the terms of this Agreement are controlling.

7. PROPRIETARY RIGHTS; COPYRIGHT NOTICES

Except for the limited license granted herein, LEAD, and its suppliers, retain exclusive ownership of all proprietary rights (including all ownership rights, title, and interest) in and to the LEAD SDK. Licensee agrees not to represent that LEAD is affiliated with or approves of Licensee’s End User Software in any way. Except as required hereby, Licensee shall not use LEAD’s name, trademarks, or any LEAD designation in association with Licensee’s End User Software. The End User Software must contain the following copyright and patent notices in the “About Box”: “Portions of this product were created using LEADTOOLS ©1991-2014, LEAD Technologies, Inc. ALL RIGHTS RESERVED. Portions of this product are licensed under US patent 5,327,254 and foreign counterparts.” Additional third party attribution requirements are found in the LEAD SDK documentation under Intellectual Property Notices.

8. EXPORT LAW

Licensee acknowledges and agrees that the LEAD SDK and End User Software may be subject to restrictions and controls imposed by the United States Export Administration Act, as amended (the “ACT”), and the regulations thereunder. Licensee agrees and certifies that neither the LEAD SDK nor any direct product thereof (e.g. the End User Software) is being or will be acquired, shipped, transferred or re-exported, directly or indirectly, to any person or into any country prohibited by the ACT and the regulations thereunder or will be used for any purpose prohibited by the same. Licensee bears all responsibility for export law compliance of the End User Software and will indemnify LEAD against all claims based on Licensee’s unauthorized exporting of the End User Software.

9. U.S. GOVERNMENT RESTRICTED RIGHTS LEGEND

Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer LEAD SDK clause at DFARS 252.227-7013 and FAR 52.227-19, as applicable. Manufacturer/Contractor is LEAD Technologies, Inc., 1927 South Tryon Street, Suite 200, Charlotte, NC 28203.

10. TERM: TERMINATION

The Development License granted hereunder is effective until terminated as provided below. Deployment Licenses are effective for the period described on the applicable duly executed license certificate/commercial distribution license agreement. Licensee may terminate this Agreement at any time by providing notice to LEAD and executing a certificate of destruction or other termination document required by LEAD. Further, any material breach of this Agreement or any corresponding Commercial Distribution License shall automatically terminate the licenses granted by this Agreement, including any Deployment Licenses. In the event Licensee ceases doing business, is adjudged bankrupt or becomes insolvent, LEAD may, at its sole option, terminate this Agreement by giving ten (10) days written notice. Upon termination, Licensee shall cease using the LEAD SDK and cease using or distributing the End User Software containing the Redistributables and will cause any and all resellers and distributors to cease distributing the End User Software. All restrictions prohibiting Licensee’s use of the LEAD SDK and intellectual property provisions relating to LEAD SDK running to the benefit of LEAD will survive termination of the license pursuant hereto. Termination will not affect properly granted end user licenses of the End User Software distributed by Licensee prior to termination, provided all Deployment License Fees have been paid for such end user licenses granted by Licensee.

11. EXCLUSION OF WARRANTIES

LICENSEE HAS HAD FULL OPPORTUNITY TO EVALUATE AND TEST THE LEAD SDK TO DETERMINE IF IT MEETS LICENSEE’S REQUIREMENTS. ACCORDINGLY, LEAD SDK IS PROVIDED “AS IS” AND LEAD MAKES NO PERFORMANCE WARRANTY OR OTHER WARRANTY OF ANY KIND, WHATSOEVER, AND LICENSEE ACKNOWLEDGES THAT NO REPRESENTATIONS OF ANY KIND HAVE BEEN MADE CONCERNING THE LEAD SDK ON WHICH LICENSEE IS RELYING IN ENTERING INTO THIS AGREEMENT AND LICENSING THE LEAD SDK.

ALL WARRANTIES, EXPRESS OR IMPLIED, ARE EXCLUDED FROM THIS AGREEMENT, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. NOT ALL JURISDICTIONS ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, AND THUS THE FOREGOING LIMITATION MAY NOT APPLY TO LICENSEE.

12. INDEMNIFICATION

In the event that a claim is filed in a court of competent jurisdiction alleging that the LEAD SDK used within the scope of the license granted hereunder directly infringes any copyright or trade secret of any third party (“Infringement Action”), LEAD shall indemnify, defend and hold Licensee harmless from and against such Infringement Action and any and all costs, damages, penalties and expenses, including reasonable attorneys’ fees, finally resulting from or awarded in actions attributable to such claim, provided that (a) Licensee promptly notifies LEAD in writing of the existence of such Infringement Action when Licensee becomes aware of such Infringement Action, (b) LEAD has control of the defense of such Infringement Action and all related settlement negotiations, and (c) Licensee provides all reasonable assistance and cooperation in such defense. In the event of an infringement claim for which LEAD is obligated to indemnify Licensee, LEAD may, at its sole discretion, (i) obtain a license that allows Licensee to continue using the LEAD SDK, or (ii) replace or modify the LEAD SDK so as to be non-infringing in a manner that does not materially affect its functionality. The foregoing represents LEAD’s sole responsibility to Licensee in the event of a third party infringement claim of any kind, and it is agreed that LEAD will have no responsibility or liability whatsoever in connection with any third party patent claims.

Licensee is fully responsible for the marketing, sale, support, installation, and distribution of the End User Software to Licensee’s customers. Licensee will indemnify and hold LEAD harmless from and against all liability, loss, cost, damage or expense, including reasonable attorney’s fees, arising from Licensee’s distribution of the End User Software, including any claims made by Licensee’s customers or other third parties.

13. LICENSEE’S REMEDIES: LIMITATIONS

IN NO EVENT SHALL LEAD BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, PUNITIVE OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH OR ARISING OUT OF THIS AGREEMENT OR THE USE OF THE LEAD SDK, REGARDLESS OF WHETHER LEAD HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL LEAD’S AGGREGATE LIABILITY UNDER THIS AGREEMENT EXCEED AMOUNTS PAID TO LEAD BY LICENSEE UNDER THE TERMS OF THIS AGREEMENT. LICENSEE UNDERSTANDS AND AGREES THAT THE FOREGOING LIABILITY LIMITATIONS ARE ESSENTIAL ELEMENTS OF THIS AGREEMENT AND THAT IN THE ABSENCE OF SUCH LIMITATIONS THE MATERIAL AND ECONOMIC TERMS OF THIS AGREEMENT WOULD BE SUBSTANTIALLY DIFFERENT. NOT ALL JURISDICTIONS ALLOW LIMITATIONS OF LIABILITY, AND THUS THE FOREGOING LIMITATION MAY NOT APPLY TO LICENSEE.

14. Standards Licensing: rights of content owners

Certain technologies such as MPEG 2, MPEG 4, AAC and H.264 may be subject to third party patents, including patents managed by MPEG LA and Via Licensing, Inc. LEAD has obtained a patent license from MPEG LA and Via Licensing which covers LEAD’s distribution of its products. LEAD’s license does not extend to Licensee’s End User Software. Licensee is responsible for obtaining any and all third party patent licenses for the deployment and distribution of the End User Software, including any licenses required by MPEG LA or Via Licensing, and will indemnify and hold LEAD harmless from any and all patent claims asserted against LEAD which arise by virtue of Licensee’s distribution or deployment of the End User Software. Additionally, Licensee agrees that it will not use the LEAD SDK or End User Software for any unlawful purpose, including without limitation, for copying, distributing, broadcasting or publishing the copyrighted works of any third party without a proper content license, and Licensee will indemnify and hold LEAD harmless from any and all claims asserted against LEAD as the result of any wrongful actions taken by Licensee.

15. TECHNICAL SUPPORT AND MAINTENANCE

LEAD’s technical support policies and annual maintenance plan benefits are posted on LEAD’s website ( www.leadtools.com ) and LEAD reserves the right to amend and modify its technical support policies and annual maintenance plan from time to time, in its sole discretion. Licensee agrees that LEAD may collect and freely use any and all technical information or other submissions regarding the LEAD SDK, including feature requests and product suggestions, provided by Licensee to LEAD’s support and technical sales departments. Licensee agrees that LEAD is not responsible for providing technical support to Licensee’s customers or other end users of the End User Software.

16. GENERAL

This Agreement shall be interpreted, construed, and enforced according to the laws of the State of North Carolina. In the event of any action under this Agreement, the parties agree that federal and state courts located in Charlotte, North Carolina will have exclusive jurisdiction and that a suit may only be brought in Charlotte, North Carolina and Licensee submits itself for the jurisdiction and venue of the state and federal courts located in Charlotte, North Carolina. This Agreement constitutes the entire agreement and understanding of the parties and may be modified only in writing signed by both parties. No officer, salesman, or agent has any authority to obligate LEAD by any terms, stipulations or conditions not expressed in the Agreement. All previous representations and agreements, if any, either verbal or written, referring to the subject matter of this Agreement are void. If any portion of this Agreement is determined to be legally invalid or unenforceable, such portion will be severed from this Agreement and the remainder of the Agreement will continue to be fully enforceable and valid. This Agreement, and the rights hereunder, may not be assigned by Licensee, whether by oral or written assignment, sale of assets, merger, consolidation or otherwise, without the express written consent of LEAD. Licensee agrees to be responsible for any and all losses or damages arising out of or incurred in connection with the End User Software. Licensee agrees to defend, indemnify and hold LEAD harmless from any such loss or damage, including attorney’s fees, arising from Licensee’s breach of any term of this Agreement Portions of the LEAD SDK are protected by copyright and other proprietary rights of third party LEAD SDK vendors, who shall be deemed to be intended third party beneficiaries of this Agreement. Licensee may be held directly responsible by third party vendors for acts relating to the LEAD SDK which are not authorized by this Agreement.

Copyright © 1991-2014 LEAD Technologies, Inc., 1927 South Tryon Street, Suite 200, Charlotte, NC 28203. ALL RIGHTS RESERVED. LEAD, LEADTOOLS and LEADVIEW are registered trademarks of LEAD Technologies, Inc. All other product names are trademarks of their respective owners.


Copyright Notice

LEADTOOLS Licensing Agreements Help > SDK Licensing > Copyright Notice

Intellectual Property Rights Notices

General Copyright Notice of Publisher

All software, documentation and other material contained in this work is Copyright © LEAD Technologies, Inc. 1991-2014. ALL RIGHTS RESERVED

Portions hereof licensed under US patent 5,327,254 and foreign counterparts.

Third Party Copyright Notices

Portions of certain files, demo programs or other material listed below may include the copyrighted work of certain third parties and are included herein pursuant to license grants. Compliance with such license grants may require display of the following notices:

Portions of the PCDLIB32.DLL, PCDLIB.DLL, LFFPX7.DLL, LFKODAK.DLL, EKFPIXJPEG140.DLL, PDC_SDK.DLL, PROFIRE.DLL, DC120V154_32.DLL, LFDCRu.dll, DCSPROBACK.DLL, DCSPRO3SLR.DLL, LFDCSu.dll, and LFKDCu.dll files contain material that is Copyright © Eastman Kodak Company, 1996-2001. This software is based in part on the work of the Independent JPEG Group.

Portions of the LFCRWu.dll, CDSDK.reg, CDSDK.dll, CDRAPCLS.dll, czs_ui.dll, deimg.dll, deImg010.dll, deImg110.dll, deImg153.dll, deimg301.dll, deimg401.dll, deImg404.dll, deimg602.dll, Deimg603.dll, DeImgd60.dll, pscAdimg.dll, pscCllct.dll, pscCStUI.dll, pscDcd.dll, pscDevUI.dll, pscDvlp.dll, Pscl2STI.dll, pscll.dll, pscParse.dll, pscSetup.dll, psdkdll.dll, psdkReg.dll, psParse.dll. file contain material that is Copyright © Canon, Inc. 2002.

Portions of the LFFPX7.DLL and LFKODAK.DLL files contain material that is Copyright © Hewlett Packard, 1996.

Portions of the Vorbis Audio Codec are copyright © 2002, Xiph.org Foundation.

Portions of the Ogg Filters are copyright © 2001 Tobias Waldvogel.

Portions of the Professional and Plus OCR and ICR Modules are Copyright © Nuance Communications, Inc. 1995-2009. ALL RIGHTS RESERVED.

Portions of the Advantage OCR Module contain software developed using the Tesseract Open Source OCR Engine, originally developed at Hewlett Packard Laboratories Bristol and at Hewlett Packard Co, Greeley Colorado and are distributed under the Apache License, Version 2.0 (the "License"). A copy of the License may be obtained at http://www.apache.org/licenses/LICENSE-2.0. Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

Portions of the LEADTOOLS Raster PDF Read Plug In are Copyright © 1996, 2000 Artifex Software Inc. All rights reserved.

The "FlashPix" format uses Microsoft's OLE structured storage.

Portions of the DICOM help files in Medical Imaging product line are reprinted with permission from the National Electrical Manufacturers Association -Copyright 1998 by the National Electrical Manufacturers Association. All rights including translation into other languages, reserved under the Universal Copyright Convention, the Berne Convention or the Protection of Literacy and Artistic Works, and the International and Pan American Copyright Conventions.

Portions of LEADTOOLS PACS Imaging contain software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/), including cryptographic software written by Eric Young (eay@cryptsoft.com) and by Tim Hudson (tjh@cryptsoft.com). Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved. Copyright Tim Hudson 1995-1998 (tjh@cryptsoft.com) All rights reserved.

Portions of LEADTOOLS PACS Imaging contain software based on the MD5 Message Digest Algorithm developed by RSA Data Security, Inc. Copyright (c) 1991-92 RSA Data Security, Inc. All Rights Reserved.

Portions of LEADTOOLS Multimedia (RTSP Source Filter) use the MDS Message-Digest Algorithm, Copyright (C) 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.

Portions of the V8 Codec are Copyright (c) 2010, Google Inc. All rights reserved. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of Google nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

A portion of the ePub filter is based on the pugixml library ( http://pugixml.org ). pugixml has a Copyright (c) 2006-2012 by Arseny Kapoulkine.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions of the HTML5 demos and the WinRT JS demos are Copyright (c) 2012 jQuery Foundation and other contributors ( http://jquery.com/ ). Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: (i) The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software and (ii) THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Portions of the LEADTOOLS JavaScript demo applications are Copyright (c) 2011-2014 Twitter, Inc.

Those portions are governed by the MIT License: “Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Portions of LEADTOOLS PACS Imaging contain material that is Copyright (c) 2007 James Newton-King.

Those portions are governed by the MIT License: “Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Portions of the Medical Web Viewer for iOS / OS X and Android Demo are developed with the PhoneGap Code contributed to the Apache Software Foundation under the name Apache Cordova. This code is distributed under the Apache License, Version 2.0 (the "License"); A copy of the License may be obtained at http://www.apache.org/licenses/LICENSE-2.0. Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

Portions of the WinRT Kernel DLL are distributed under the Microsoft Permissive License. Copyright Microsoft Corporation, ALL RIGHTS RESERVED.

Trademarks

LEAD®, LEADTOOLS® and LEADVIEW® are registered trademarks of LEAD Technologies, Inc.

Microsoft, Windows, Windows NT, Windows Mobile, Windows Phone, Visual Basic, Visual FoxPro, Vista, and Access are either trademarks or registered trademarks of the Microsoft Corporation.

All other brands or product names used in this help file are either registered trademarks or trademarks of their respective holders.

Address and Contact Information

LEAD Technologies, Inc.

Suite 200

1927 South Tryon Street

Charlotte, NC 28203

(704) 332-5532

FAX: (704) 372-8139

E-mail: support@leadtools.com

Technical support: (704) 372-9681 or support@leadtools.com

Home page: https://www.leadtools.com


SDK Licensing

LEADTOOLS Licensing Agreements Help > Development Licensing > SDK Licensing

About Development Licenses

LEAD's EULA allows the user to install the SDK on a development computer and use the SDK for development of an end user application, by integrating certain LEAD redistributable libraries and files into the end user application using the SDK sample code and documentation. The basic rules for the development licenses are as follows:

  • License Needed for Each Developer. A copy of LEADTOOLS must be licensed for each programmer who uses the SDK. For example, if there are three (3) programmers building a single application with LEADTOOLS, three (3) development licenses of LEADTOOLS need to be purchased. (Discounts are available for additional development licenses.)
    Development Seat Frequently Asked Questions

  • License Needed for Each Application Developed. A copy of LEADTOOLS must be licensed for each application that is developed. For example, if three (3) separate applications are developed, three (3) LEADTOOLS Development Licenses need to be purchased. (Discounts are available for additional development licenses.) How do we define "single application" for purposes of the Development License?

  • End User Applications Only. LEADTOOLS may only be used to develop an "end user" application. An end user application is an application for business or personal use that may not be copied or redistributed by the user or used to develop software. LEADTOOLS may not be used in a developer oriented product, such as a development toolkit or a product that contains an API. In addition, if all or any portion of an application is redistributed by our customer's customer, the application is not an end user application within the meaning of the LEADTOOLS EULA. If a customer wishes to use LEADTOOLS in connection with the development of an application that is not an "end user" application, the customer may be able to obtain a customized license from LEAD. LEAD's licensing department can be contacted at oemsales@leadtools.com.

For more information, refer to:

LEADTOOLS Licensing Summary

LEADTOOLS Standard End-User Software License Agreement (EULA)

Single End User Application License Examples

Development Seat Frequently Asked Questions

OEM License Frequently Asked Questions

About LEADTOOLS Deployment Licenses

Deployment Types


Development Seat Frequently Asked Questions

LEADTOOLS Licensing Agreements Help > Development Licensing > Development Seat Frequently Asked Questions

Development Seat Frequently Asked Questions (FAQ)

Q. Can I install LEADTOOLS on my work computer and my laptop without purchasing 2 licenses?

A. Yes, as long as you are the only developer using these computers, you are not required to purchase 2 licenses.

Q. I am the only developer using LEADTOOLS, although we must install LEADTOOLS on all development team machines for build purposes. Do we have to purchase a license for each machine?

A. The license allows you to install LEADTOOLS on your machine for programming and also to install LEADTOOLS on up to 2 additional machines for build purposes, provided no developers other than you are programming with LEADTOOLS installed on the build machines. Licenses for additional build machines, if necessary, are available at a discount. Please contact oemsales@leadtools.com for more information.

Q. Can multiple developers use the same copy of LEADTOOLS as long as they are not using it at the same time?

A. No, a developer license is not a concurrent or floating license. It is personal to the registered developer. If an employee leaves the company, the development seat can be transferred to the new employee, but different developers are not permitted to share the same development license. To transfer the registered user, please contact your LEAD sales representative.

Q. If I am the only developer in my group using LEADTOOLS, and I make a DLL, class or web service that is then used by my colleagues, do they have to have LEADTOOLS SDK licenses also?

A. You are not permitted to develop a .DLL or other product that software developers use. A special license is required for using LEADTOOLS in a developer oriented product. The special license would normally require a fee for each programmer using the developer oriented application you develop.

Q. Can I use my version 16 and let my colleague use my upgrade to version 19?

A. No, an upgrade is personal to the person who is registered to use the product that was upgraded.

Q. Can I permanently assign my development license to another company?

A. You may permanently assign a development license provided you obtain LEAD's prior written consent. The assignee may only use the development seat for maintaining the application that you have developed. The assignee may not develop a new project if you have already developed an application. Contact LEAD to obtain the necessary assignment forms if you are wishing to assign your development license. Once you have assigned the license, you must delete the software and no longer use it.

Q. Is maintenance required for development licenses?

A. No, maintenance is not required. However, the cost of annual maintenance is less than the cost of upgrading to a new version of LEADTOOLS. LEAD typically releases chargeable upgrades every 6-8 months.

Q. Can I purchase the development seats and add maintenance later?

A. Yes, you can add maintenance to the currently shipping LEADTOOLS version after purchase. When maintenance is purchased after the fact, the maintenance start date will begin on the original purchase date of the current SDK license.

Q. I want to purchase an SDK with an add-on. Do I purchase maintenance on just the SDK?

A. No, maintenance is required for the SDK and any associated add-ons.

Q. I have three development seats. Can I purchase maintenance for just one seat?

A. Typically no, maintenance is required for all seats. One exception to this is if you are listed as a LEADTOOLS 3rd party developer\consultant and each license is specific to a client. In that case, one of your clients may opt to have maintenance added to their specific development seat. If the three development seats are tied to the same application or project, then all three would need to be covered by maintenance.

Q. I am a college student working on a research project. Can I get a free copy?

A. We suggest that you use our evaluation version. We have the ability to provide an extension of the evaluation. If that is not satisfactory, please contact our sales department and we will try to work something out.

Q. I am a college professor working on a research grant - do you offer any discounts?

A. We can provide a 20% discount on the development seat license for college professors working on research projects.

Q. Do you offer any discounts for Non-Profit organizations?

A. Non-profit organizations may quality for a development seat license discount. Documentation is required. Contact LEAD sales for details.

Q. I would like to replace my current SDK with LEADTOOLS. Do you offer a competitive upgrade discount?

A. Customers upgrading from a competitor's SDK may receive a substantial discount depending on the licensing opportunity. Documentation is required. Please contact LEAD sales to discuss your project.

Q. I used LEADTOOLS with my previous employer - do I qualify for an existing customer discount?

A. Yes, a 20% loyalty discount can be applied for development seat licenses. You will need to provide some proof of previous purchase (such as a serial number) or we may be able to verify you if you registered while at the previous employer. We appreciate your business.

For more information, refer to:

About Development Licenses

Single End User Application License Examples

LEADTOOLS Standard End-User Software License Agreement (EULA)

OEM License Frequently Asked Questions


Single End User Application License Examples

Modular Application / System for Internal Use

A customer is developing a system for internal use. The system is composed of multiple software modules. Each module was developed with LEADTOOLS, but all modules are part of the same internal system. LEAD considers the system and all of its component modules to be one "application" for development licensing purposes.

Application Suite for External Sale

A customer develops a "suite" of applications that are always sold as a suite. LEAD considers the suite to be a single application for development licensing purposes.

Evaluation and "Light" Application Versions

A customer develops an evaluation version or a light version of its application. LEAD does not require a separate development license for the evaluation/lite version.

New Versions and Updates of Existing Applications

A customer develops a new version of or update to an existing application. LEAD does not consider the update or new version to require an additional development license.

Versions for Various Operating Systems

A customer develops an application for Windows 7, and later develops a Linux version and an Android version of the same application. One development license covers all of the different OS versions of the application.

Same Software Engine, Multiple Products

A customer develops a software engine that is contained in two products that are sold separately. In this case, the customer must buy a development license for each product, even if the engine is basically the same in each of the separate products.

Consultants and Works Made for Hire

A customer who develops a custom application for a client may not use the toolkit to develop an application for another client unless the customer purchases a second development license. For example, if a consultant develops an application for one customer, and then subsequently develops an application for another customer, a second development license would be required.

Upgrades Are Not Counted as Additional Development Licenses

A LEAD product version or platform upgrade does not count as a second toolkit for the above-described purposes. For example, if a customer originally licensed LEADTOOLS Version 12, then later ordered an upgrade to Version 19, the customer holds only one product license. If two programmers are using the LEAD product at the same time, or two applications have been developed using the LEAD product, a second toolkit development license must be purchased.

Unlimited Enterprise Licenses

LEAD may offer an Enterprise License for organizations requiring an unlimited license. An Enterprise License allows the customer to use the LEADTOOLS SDK for the development of an unlimited number of end user applications. Please contact oemsales@leadtools.com if you are interested in obtaining an Enterprise License.

For more information, refer to:

About Development Licenses

LEADTOOLS Standard End-User Software License Agreement (EULA)

Development Seat Frequently Asked Questions

OEM License Frequently Asked Questions


OEM License Frequently Asked Questions

LEADTOOLS Licensing Agreements Help > Development Licensing > OEM License Frequently Asked Questions

OEM License Frequently Asked Questions (FAQ)

Q. We want to include LEADTOOLS in a development product such as an ActiveX or API. Is this permitted by the LEADTOOLS EULA?

A. No, the LEADTOOLS EULA does not permit inclusion in a development product, but a special license agreement may be possible. In such cases, LEAD normally requires a license fee for each development seat that is granted by the customer. LEAD also requires that the customer’s license agreement contain certain pass through restrictions. If the customer is using a product requiring deployment licenses, these licenses are required to be collected and paid to LEAD. Contact oemsales@leadtools.com to inquire about a special license for your API product.

Q. We want to grant OEMs the right to modify/redistribute the application that is developed. Is this type of deployment permitted by the LEADTOOLS EULA?

A. No, the LEADTOOLS EULA does not permit re-development/redistribution of the resulting application. If an OEM is modifying and redistributing the application, the OEM needs its own LEADTOOLS license. We can enter into an agreement that permits our customers to obtain these licenses on behalf of their OEMs on a discounted basis.

Q. We provide source code to our end user, so the end user may maintain the application. Is this permitted by the LEADTOOLS EULA?

A. No, a customer’s end user must purchase a copy of LEADTOOLS if the end user receives the source code to the application, since the source code gives the end user development capability with regard to the application. LEAD's customer can assign its LEADTOOLS license to the end user, if LEAD's customer relinquishes its development license.

For more information, refer to:

About Development Licenses

LEADTOOLS Standard End-User Software License Agreement (EULA)

Single End User Application License Examples

Development Seat Frequently Asked Questions


Runtime Licenses

LEADTOOLS Licensing Agreements Help > Deployment Licensing > Runtime Licenses

About LEADTOOLS Deployment Licenses

To deploy LEAD intellectual property with End User Software, customers must purchase a “Deployment License”. The deployment license terms and conditions vary depending on whether the application developed with the LEAD SDK (“End User Software”) is being used internally by customer’s employees, is being hosted by customer for use by third parties or is being commercially distributed to end users. Refer to Deployment Types.

The Licensing Dialog

When you download an evaluation version or purchase the development license for a LEAD SDK, you will receive a temporary license file that allows you to install the LEAD SDK and program with it. Customers will notice that when compiling an application or running LEAD demos, a dialog box will occasionally appear to remind the customer of the deployment license requirement and that the temporary license file will expire:

LEAD uses this licensing dialog so that customers can begin programming right away without having to wait for management or legal department approval of the required licensing documentation. This allows the developer to begin their project while management is working on the deployment licensing documents and license procurement with LEAD's licensing department. Once the temporary license file has expired, the toolkit will display an "expired" message and will cease to function. After the expiration date, the developer must use a Release License File for the LEAD SDK to function.

Steps for Obtaining a Release License File:

  1. Complete Deployment License Application form and submit it to LEAD.
  2. Obtain a Deployment License Fee Quotation from LEAD or an authorized reseller (If you are an ISV/OEM commercially deploying your software, LEAD will send you a Commercial Distribution License Agreement for execution).
  3. Purchase applicable Deployment Licenses and, if applicable, send in the signed Commercial Distribution License Agreement.
  4. Upon completion of 1-3, LEAD will provide you with a Release License File (with developer keys), a License Certificate for the deployment licenses you purchased and, if applicable, a counter-signed copy of the Commercial Distribution License Agreement.

Deployment License Application: Commercial Distribution License

To obtain a Release License File to deploy LEAD SDK intellectual property with the End User Software, the customer must first complete a Deployment License Application form. The purpose of this form is to identify the type of deployment license required by the customer, the various LEAD modules that will be deployed and to establish the pricing and other terms and conditions for the deployment license. Completion of the application will be required as a condition of obtaining a deployment license and Release License File. Once LEAD has processed the Deployment License Application, LEAD will provide the customer with a Deployment License Fee quotation covering the Deployment Licenses that the customer needs to purchase.

Purchasing Deployment Licenses and Commercial Distribution Licenses

Deployment Licenses must be purchased before the customer receives the Release License File with developer keys. Once customer has received an official quotation from LEAD, deployment licenses may be purchased with a valid credit card or customer may issue a purchase order provided customer has been approved for credit purchases by LEAD’s accounting department. Certain products require the purchase of a server deployment license as a condition for obtaining the development license (e. g. LEADTOOLS Pro Suite, LEADTOOLS Medical Imaging Suite and LEADTOOLS Document Imaging Suite) since by definition, the components included with the products must be deployed to a webserver. If you are an ISV/OEM selling End User Software, deployment licenses may be purchased at the prices and in the manner set forth in the Commercial Distribution License you have executed.

Grant of Deployment License: Release License File and Unlock Instructions

When a customer has completed the Deployment License Application form, purchased the necessary deployment licenses and, if applicable, executed and returned a Commercial Distribution License Agreement, LEAD will provide the customer with a Release License File with developer key(s) and the instructions to eliminate the licensing dialog. Note that the Release License File and developer key(s) are different depending on whether the deployment licenses are for deployment to desk tops or servers so customers need to be sure to identify the type of deployment licenses that they need when completing the Deployment License Application and purchasing the deployment licenses. Once the customer has received the Release License File and developer key(s), the customer will be able to deploy the End User Software in production without any nag messages or expiration notices. Implementing the Release License File and developer key(s) will only take a couple of minutes. Deployment licenses purchased by the customer for internal deployments and hosted service deployments will be evidenced by a License Certificate which will identify the type of deployment license, the quantity of deployment licenses granted and the duration of the licenses.

NOTE: LEAD packages our SDKs so that all product sets are enabled in the installation while the license dialog/watermark is present. Therefore, if the licensing dialog/watermark is being displayed, substantially ALL FEATURES of our entire product line will be enabled. When we provide customer the Release License File and developer key(s), only the features that are included in the specific product(s) that customer has licensed will be available. The features of products that are not under license will be locked. Customers may consult the help file or contact LEAD sales department to determine which product configuration includes the functions customer plans to use.

Record Keeping and Reporting

The Commercial Distribution License Agreement requires that customer account to LEAD by sending a quarterly report indicating the number of deployments the customer made during each quarter. LEAD will email customer the necessary deployment reporting forms on a quarterly basis well in advance of the due date for reporting. The form is very simple to complete and customer can respond by email, fax or mail. For internal deployment licenses and hosted service deployments, an annual deployment activity report is required to determine that the customer has the appropriate number of deployment licenses for its install base of End User Software. Deployment License Fees for any Deployments of End User Software that customer deploys without first purchasing the appropriate Deployment License will be billed at a default rate equal to LEAD’s standard pricing for quantity one (1) of the applicable type of Deployment License. Volume discounts for Deployment Licenses are only available for a Deployment Licenses that are purchased prior to deployment by the customer. LEAD does offer site licenses and enterprise licenses for some of our products. With site licenses and enterprise licenses, the customer is not required to report deployment quantities or pay per copy deployment fees. The cost of site licenses and enterprise licenses are quoted on a case-by case basis taking into account such factors as an estimated number of users, the functionality involved and the customer’s revenue model. To inquire further about our site and enterprise deployment license options, please send an email to oemsales@leadtools.com or call our sales department at 704-332-5532.

License Termination and Suspension

The reporting requirements described above must be complied with in order to maintain the license. If customer does not submit deployment reports, its account will be flagged and it will not be eligible to receive technical support or upgrades. If a customer is not actively deploying copies of your its application, the customer can request suspension of the reporting requirement. In addition, customer can also voluntarily terminate license and be relieved of the obligation to complete the deployment reports going forward by certifying that customer is not developing or deploying software with LEADTOOLS.

Duration of Deployment Licenses

Unless otherwise stated in a duly executed License Certificate, Deployment Licenses for Internal Deployments and Hosted Service Deployments are valid for one (1) year and may be renewed on an annual basis. Deployment Licenses for Commercial Deployments will have the duration set forth in the applicable Commercial Distribution License Agreement executed by LEAD and customer.

New Versions

For commercial deployments, if a major new version of the LEAD SDK is included in an upgrade to the End User Software, each user that is upgraded will require an upgrade deployment license. The upgrade deployment license price is 40% of LEAD’s standard price of the deployment license for the new version of the LEADTOOLS SDK for the applicable quantity of licenses being purchased. Any prepaid deployment licenses that have not been deployed at the time the customer licenses a major new version of the LEAD SDK will be carried forward and may be applied to deployments of End User Software made with the major new version of the LEAD SDK. A customer is under no obligation to update previously deployed user or client licenses with the new version of the End User Software that includes the major new version of the LEAD SDK. Customers also have the option of purchasing annual maintenance for their deployment licenses. Annual maintenance for a deployment license is priced at 20% per year and entitles the customer to upgrade the deployment license with any new versions released during the maintenance period. No additional deployment licensing is required for minor version updates. For internal deployments and hosted services, the annual deployment license fee includes maintenance so a customer is licensed to deploy major new versions of LEADTOOLS to its validly licensed deployments for as long as customer is continuing to renew the licenses.

For more information, refer to:

LEADTOOLS Licensing Summary

Deployment License Application

Deployment Types

Deployment License Frequently Asked Questions

Commercial Distribution License

Deployment License Prices

About Development Licenses


Deployment Types

LEAD deployment licensing requirements and prices vary depending upon the type of deployment. The following are some of the typical types of deployments of End User Software developed with LEAD SDKs:

Commercial Deployments

“Commercial Deployment” is any distribution and other disposition of End User Software by a customer to third party end users, either directly or through distribution channels. Commercial Deployments are typical when our customer is acting as an ISV, OEM or solution provider offering End User Software to the public for license, lease, subscription or other form of disposition.

Internal Deployments

“Internal Deployment” is where our customer is deploying End User Software, including Single User Deployments, Concurrent Deployments, Server Deployments, Multi-user Deployments and/or some other deployment model approved by LEAD on hardware devices owned or controlled by our customer for internal business use limited to our customer’s employees and contractors.

Hosted Service Deployments

“Hosted Service Deployment” is a type of Server Deployment where our customer is hosting End User Software on customer’s machines for consumption or commercial use by its customers, vendors and other third parties. Examples of a “Hosted Service Deployment” include End User Software operated by a service bureau, application service provider, outsource facility, and any public facing End User Software hosted by our customer accessible by third parties via the internet or other network.

Single User Deployments

“Single User Deployment” is installation of End User Software by our customer and/or its customer on a stand-alone PC, work station, mobile device or other hardware for use by a single named user. End User Software that is deployed as Single User is intended for interactive use by the named end user, and has a GUI requiring the user to control the application by mouse, keyboard, touch-screen or similar means. A Single User Deployment also is applicable where End User Software is distributed to client machines through a deployment server or other network device via a CAB file or similar mechanism and installed on the client machine. Single User Deployments are commonly referred to as desk top licenses, client licenses, stand-alone licenses, app licenses and user licenses.

Concurrent Deployments

“Concurrent Deployment” is where our customer has built a reasonable method of concurrency into the End User Software so that, although installed on multiple PCs for single user uses, only a limited number of users are technically permitted to use the End User Software at the same time. For example, if the End User Software is installed on one hundred (100) PCs, but only ten (10) users may be logged in to use the End User Software at the same time, licensing for ten (10) Concurrent Deployments would be required instead of 100 Single User Deployment licenses. The fact that a server application is “queuing” jobs sent to it, and processing one job at a time, is not considered concurrency for purposes hereof. This type of deployment would be a Server Deployment. A Concurrent Deployment also occurs if our customer issues client licenses on a subscription type model and wishes to recapture client licenses that are no longer subscribed and assign such licenses to another user. Concurrent licenses are also commonly referred to as floating licenses.

Server Deployments

“Server Deployment” includes the following: (i) End User Software installed on a networked device accessible by more than one person who can independently operate the End User Software from another machine; (ii) End User Software installed on a networked device running as a service that accepts connections from other machines or applications (for example, a headless process to watch a folder or other data source for work originating from other machines), and (iii) End User Software deployed to a browser from a webserver, such as an HTML5 based application, where the End User Software is not installed on the client machine but is in use by the client machine while the user is connected to the webserver.

Multi-User Deployments

“Multi-User Deployment” is a computer installation designed to service the public or multiple un-named users, and not a single named user or set of concurrent named users, such as a kiosk or a scan station.

Modular Deployments

A "modular deployment" means our customer has different LEADTOOLS features enabled in an "application", with some modules being installed and enabled on one or more machines and other modules being installed and enabled on other machines. For example, a Document Management system may be comprised of some scan stations for OCR and Barcode recognition operations as well as some annotation/markup stations for image markup and editing operations. The deployment licenses for OCR, Barcode and image markup features are priced separately. The applicable deployment licenses only need to be purchased where the technology is enabled. Thus, OCR- and Barcode-enabled licenses will need to be purchased for the scan stations, while the lower priced Document Imaging licenses will need to be purchased for the image markup stations.

Other Licensing Options

If none of these deployment licenses fit your licensing model, LEAD can tailor a licensing program to meet your particular facts and circumstances. We offer fully paid up licenses, site licenses, and percentage of revenue licenses in certain cases. Please contact oemsales@leadtools.com to initiate a dialog regarding your unique license requirements.

For more information, refer to:

About LEADTOOLS Deployment Licenses

Deployment License Frequently Asked Questions

LEADTOOLS Commercial Distribution License

Deployment License Prices


Deployment License Frequently Asked Questions

LEADTOOLS Licensing Agreements Help > Deployment Licensing > Deployment License Frequently Asked Questions

Deployment License Frequently Asked Questions (FAQ)

Q. My application is only used internally. I do not distribute the application commercially. Am I exempt from paying deployment licenses?

A. No, you are not exempt. Deployment licenses are required for each user of the application software whether the copies are used internally or are distributed commercially.

Q. How long do deployment licenses last?

A. It depends if you are deploying End User Software internally, hosting services, or commercially deploying end user software as an ISV/OEM. If you are deploying End User Software internally or are hosting software internally for consumption/use by third parties, the deployment license is annual and must be renewed each year as long as you are using it. If you are deploying End User Software commercially, the deployment licenses are perpetual and do not need to be renewed or maintained to remain in effect.

Q. How do upgrades work? Do I have to upgrade my deployment licenses?

A. For internal deployments and hosted services, the deployment license fee includes maintenance so you are licensed to deploy major new versions of LEADTOOLS to your validly licensed deployments for as long as you continuing renewing the licenses. For commercial deployments, a customer deploying a new version of LEADTOOLS (e. g. 19, 20) to its install base must upgrade the deployment licenses. Upgraded deployment licenses are priced at 40% of the published deployment price for the new version. Any unused prepaid deployment licenses may be carried forward to the new version. LEAD offers an annual maintenance program for deployment licenses allowing you to deploy major new versions during the maintenance period. If a customer does not wish to deploy new versions to a deployment, then the customer is not required to upgrade the deployment license. Minor version updates may be deployed free of charge to any seats that have already been licensed.

Q. I want to have a demo or evaluation version of my application. Do I have to pay deployment licenses for these?

A. Provided the demo software expires within 30 days and is offered free of charge to prospects of an application the customer is charging the customer for, then LEAD will provide permission for royalty free evaluation/demo software. If a customer simply has a free version of software that does not expire, deployment licenses are required.

Q. Do you require deployment licenses for internal testing, Q/A, beta testers, etc.?

A. Yes, a deployment license is required for any computer on which the End User Software is installed. LEAD does permit you to re-use deployment licenses that are used for internal testing, beta testing etc.. For example, if you purchase 50 deployment licenses, and have 25 testers to whom the application was deployed temporarily for Q/A purposes, the 25 deployment licenses issued to the testers may be reused along with the remaining prepaid unused licenses for commercial/production deployments.

Q. Do you require deployment licenses for sales agents who use the application software for demonstration purposes?

A. No, as long as our customer has purchased at least an equal number of deployment licenses as licenses issued to sales agents. For example, if you have 10 sales agents to whom you have deployed the application software, you are not required to purchase a separate license for the sales agents provided you have purchased at least 10 deployment licenses to be used for commercial deployments.

Q. How are licenses delivered? Does your software use dongles?

A. Dongles are not required. The licensing is contract-based and customers deploying software commercially are required to provide LEAD with a quarterly accounting of deployments. Customers deploying software internally may be required to report usage on an annual basis. Customers will receive a unique Release License File upon completing the required license documentation and purchasing the required deployment license. The Release License File is distributed with each copy of the application software that is deployed. Internal deployment licenses are evidenced by a license certificate which is delivered to you along with the Release License File. Deployment to a server requires a special type of Release License File/unlock code.

Q. I am only using a small subset of features. Do I have to pay the full deployment license?

A. Every customer is only using a small subset of features. Feature usage is not typically a basis for deployment license fee reduction.

Q. How do I license software installed on a server?

A. If software is installed on a server, a server deployment license is required. The cost for the server license may depend upon a number of factors including number of machines connected, internal or commercial use, number of core processors, etc..

Q. My application is installed on a server, but only a few users are connected to the server who can log on and use the application. Can I simply purchase user desk top licenses or concurrent licenses?

A. No. A server license is required if the application is installed on a server. The number of potential users will be a factor in determining the cost of the server license.

Q. I charge my customers an annual subscription. If one of my customers does not renew their license can I assign the client license I had assigned to them to a new customer?

A. No. Typically, once a client license has been deployed it cannot be re-assigned to a new subscription customer. However, if you purchase concurrent licenses, these licenses can be re-assigned since the customers who unsubscribed are no longer using the software.

Q. I have a standard machine that processes batches of images that are routed to the machine by employees in my organization. The machine does not have an assigned user. Is a desktop license or a server license required?

A. A server license is required for this type of deployment. A single user license is for named users on stand-alone computers or mobile devices. Factors in the cost of the server license will include volume of images, number of users who can route images to the machine, whether it is internal or commercial and the processing power of the machine.

Q. My application is installed on a server, but will also be distributed down to client machines (such as a Silverlight type of deployment). Can I simply purchase user desk top licenses?

A. If all of the LEADTOOLS functionality in the application is being used on the client machines, a server license would not be required since you would be purchasing single user deployment licenses for each user. However, if some functionality is only residing on the server (OCR for example), then a server license would be required for the modules that are hosted on the server only and not distributed to the client machines.

Q. I am using the HTML5 functionality within a LEADTOOLS SDK. What deployment license is needed for this?

A. Use of LEADTOOLS HTML5 functionality requires that a server license for the underlying LEADTOOLS SDK be purchased. For example, if you are using the HTML5 functionality within LEADTOOLS Document Imaging Suite, a Document Imaging Suite server license would be required for each server installation that uses the HTML5 functionality. No individual client licensing is required in connection with the LEADTOOLS HTML5 functionality.

Q. How does a server license apply to a virtual server deployments?

A. Server licensing is based on the number of core processors that are available for use on the machines running the end user software. It does not matter if there are multiple “virtual” instances of the application running on the same machine.

Q. My application will be hosted in the cloud on a platform like Azure. How does a server license apply to a cloud deployment?

A. A server license will be required for each machine running in the cloud and pricing will be based on the maximum number of core processors available.

Q. My application will be hosted in the cloud and we will leverage dynamic servers to handle demand. What type of deployment license do I need?

A. A special license will be negotiated by LEAD and customer based on the maximum number of potential servers and core processors.

Q. How are redundancy or disaster recovery servers handled? Do I need a server license for these?

A. Yes, server licenses are required for contingency server installations. However, LEAD provides a discount for these types of licenses. Please contact oemsales@leadtools.com for pricing.

Q. I host the software on a server and provide a service to customers. How is this handled from a licensing stand-point?

A. A server license is required for ASP/SAAS types of deployment. The pricing of the server license will be based on the revenue that is generated on the service, with a minimum annual fee per core processor.

For more information, refer to:

About LEADTOOLS Deployment Licenses

Deployment Types

LEADTOOLS Commercial Distribution License

Deployment License Prices


Commercial Distribution License

LEADTOOLS Licensing Agreements Help > Deployment Licensing > Commercial Distribution License

LEADTOOLS
Commercial Distribution License

Company Name: _____________________________________________________ (herein “Licensee”)

Address: ____________________________________________________________________________

(Street Address)

____________________________________________________________________________

(City, State, Postal Code, Country)

Phone No.: ___________________________ Fax No.: _______________________________

LEADTOOLS SDK(s) and Add Ons licensed: See attached Schedule 1 (herein “LEAD SDK”)

This Commercial Distribution License (“Agreement”) is made by and between LEAD Technologies, Inc., a North Carolina corporation, principally located at 1927 South Tryon Street, Suite 200, Charlotte, North Carolina 28203, USA (“LEAD”) and Licensee.

Recitals

1. Licensee has heretofore obtained a development license to use the LEAD SDK in connection with the development of the End User Software identified on Schedule 1 (“End User Software”) in accordance with the terms of the LEADTOOLS LEAD SDK License Agreement, a copy of which is included in the LEAD SDK packaging and online help file, and the terms of which are hereby incorporated herein by this reference (herein the “License Agreement”). Capitalized terms not otherwise defined herein will have the meanings set forth in the License Agreement.

2. Licensee now wishes to obtain a license whereby it may commercially distribute the End User Software to end users, and LEAD is willing to grant the licenses described herein provided Licensee complies with the terms and conditions of this Agreement.

NOW, THEREFORE, in consideration of the mutual covenants and promises set forth herein, the parties hereto, intending to be legally bound, do hereby agree as follows:

1. Effectiveness of License Agreement; Grant of Duplication and Distribution License.

(a) License Agreement. Licensee acknowledges that its use of the LEAD SDK is governed by the terms, conditions, limitations and restrictions contained in the License Agreement and hereby agrees to faithfully abide by such terms and conditions and will not take any action with respect to the LEAD SDK prohibited by the License Agreement. This Agreement is supplementary to the License Agreement, and this Agreement and the License Agreement together will govern Licensee’s use of the LEAD SDK and its deployment of the End User Software. Unless otherwise modified by the terms of this Agreement, all of the terms and conditions of the License Agreement remain in full force and effect. In the event of an inconsistency between this Agreement and the License Agreement, this Agreement will control.

(b) Commercial Distribution License. Subject to all the terms and conditions set forth in this Agreement and the License Agreement, including without limitation, the payment of the deployment licensing fees described in paragraphs 2 and 3 hereof, LEAD hereby grants Licensee a non-exclusive, non-transferable, worldwide license to reproduce (and have reproduced) exact copies of the LEAD SDK Redistributables (as such term is defined in the License Agreement) and include such files in the End User Software, and to commercially distribute and deploy the End User Software, directly and through customary distribution channels, to end users for their use without further distribution. The type of Deployment (e.g. Single user, Server, Mobile, Multi-user) that is permitted hereunder is set forth on Schedule 1.

2. License Fees for Deployments of End User Software. Licensee must purchase a deployment license for each Deployment of End User Software (“Deployment License”). For purposes hereof, a “Deployment of End User Software” includes any and all copies of End User Software installed, used, distributed, leased, sold or otherwise disposed of by Licensee, and any of its employees, distributors, resellers, affiliates or other channel partners.

3. Deployment License Pricing.

(a) Deployment License Pricing. The pricing for Deployment Licenses is set forth on Schedule 2 hereof.

(b) Evaluation and Demo Versions. Licensee may have an evaluation version of the End User Software that it makes available free of charge to prospects, provided the evaluation version expires within 30 days of a prospect’s installation of the evaluation version, and provided it is covered by an evaluation license agreement that provides that the prospect may only use it for evaluation purposes. In addition, Licensee may issue a reasonable number of demonstration copies of the End User Software to its sales and support staff, for their use in connection with selling and supporting the End User Software. No deployment license fees will be payable for evaluation and demo versions of the End User Software deployed in accordance with this paragraph.

4. Record Keeping; Reporting and Payment. Licensee agrees to maintain full, clear and accurate records as to all Deployments of the End User Software. If Licensee is commercially distributing the End User Software through distributors or resellers, Licensee will ensure that its distributors and resellers maintain adequate records to reflect all licenses in the End User Software that are sold or otherwise distributed by such parties. LEAD will send Licensee a quarterly deployment report form to complete at the end of each quarter and Licensee will submit the report to LEAD, within thirty (30) days of the close of each calendar quarter, setting forth the number of Deployments of End User Software made during such quarter. If Licensee has new Deployments for the quarter and does not have any unused prepaid deployment licenses, Licensee will pay LEAD the applicable non-prepaid deployment license fee as set forth on Schedule 2 hereof. If Licensee has purchased prepaid deployment licenses, Licensee will report any new Deployments made during the quarter, and subtract the new Deployments from its inventory of prepaid Deployment Licenses. If no Deployments have been made during said quarter, Licensee will return the report form stating that no Deployments have been made. LEAD shall have the right, no more than once during any calendar year, to have an independent certified public accountant or other disinterested third party inspect the relevant records of Licensee on thirty (30) days notice and during regular business hours to verify the reports and payments required to be made hereunder. Should an underpayment in excess of five percent (5%) be discovered, Licensee shall pay the cost of the audit. If Licensee is more than thirty (30) days late with any payment of amount due hereunder, interest will accrue from the date due until paid at the lesser of (i) 1.5% per month or (ii) the maximum rate of interest permitted by law. All amounts due hereunder are based on United States currency.

5. Duration of Deployment License; New Versions; Upgrades; Annual Maintenance for Deployment Licenses. A Deployment License is a perpetual license and the Deployment License fee is a one-time license fee for use of the End User Software for the applicable type of Deployment. Termination of the License Agreement does not affect Deployment Licenses issued to Licensee’s customers for which Licensee has paid LEAD the applicable Deployment License Fee. Minor version updates to the LEAD SDK (e. g. patches or point releases) are provided to Licensee free of charge via LEAD’s web site. Licensee may license major new versions of the LEAD SDK (e. g. LEADTOOLS version 18, 19 LEADTOOLS 2014 or such other major version designation as may be hereafter adopted by LEAD) by purchasing a development license to the new version at LEAD’s then prevailing upgrade price. No additional deployment licensing is required for minor version updates. If a major new version of the LEAD SDK is included in an upgrade to the End User Software, each Deployment License that is upgraded will require an Upgrade Deployment License. The Upgrade Deployment License price is 40% of the published price of the Deployment License for the new version of the LEAD SDK for the applicable quantity of Deployment Licenses being purchased. Any prepaid deployment licenses that have not been deployed at the time Licensee takes a license to a major new version of the LEAD SDK will be carried forward and may be applied to Deployments of End User Software made with the major new version of the LEAD SDK. If LEAD has changed its Deployment License pricing for the new version, the parties will execute an addendum to this Agreement setting forth the pricing of Deployment Licenses for the new version. A customer is under no obligation to update previously deployed user or client licenses with the new version of the End User Software that includes the major new version of the LEAD SDK. Licensee may also purchase annual maintenance for its Deployment Licenses and by purchasing annual maintenance, Licensee may deploy new versions of the LEAD SDK to End User Software duly licensed users during the maintenance period. Annual Deployment License maintenance may be purchased at the rate of 20% of the cost of the applicable Deployment License and must be purchased at the time the Deployment license is initially purchased and may be renewed annually at the same price for as long as Licensee desires to continue the Deployment License maintenance for the End User Software.

LEAD and Licensee have caused this Agreement to be executed in their names by the following authorized representatives.

LEAD TECHNOLOGIES, INC. _______________________________________________

(Print Your Company Name Here)

By:_________________________________(SEAL) By:____________________________________(SEAL)

(Authorized Signature)

Title:_________________________ Title:___________________________

Date:______________________ Date:_____________________

Schedule 1

I. LEAD SDKs Licensed :

____ v19

II. Description and/or name of End User Software developed by Licensee with LEADTOOLS:

_______________________________________________________________________

_______________________________________________________________________

III. Deployment Type:

Schedule 2

Deployment License Pricing

I. Trailing Reporting Option

Deployment License price for non-prepaid Deployment is $________ per license.

II. Prepaid Option

Minimum Purchase Block Price Per License

Notes.

The pricing set forth in section I is applicable for any and all Deployments for which Licensee has not purchased a Deployment License before the applicable Deployment of End User Software to the end user.

To select a volume prepaid option in Section II, Licensee shall send LEAD a purchase order covering the desired quantity before making the Deployments covered by the purchase order, and LEAD will generate an invoice covering the prepaid licenses and issue Licensee a License Certificate reflecting the number of prepaid Deployment Licenses.

For example, if Licensee projects 50 Deployments, and would like to take advantage of the quantity 50 prepaid volume discount, Licensee must prepay for 50 Deployment Licenses at the volume discount rate shown above. Thereafter, from time to time, if Licensee requires additional Deployment Licenses and wishes to pay a rate of less than the non-prepaid rate described in Section I above for such additional Deployment Licenses, Licensee will be required to send LEAD another purchase order for the volume required.

For quantity purposes, each purchase order will be viewed separately, and not cumulatively. For example, if Licensee prepays for 250 Deployments and subsequently places another order for 250 additional Deployments, the price for the additional 250 unit purchase will be at the quantity 250 prepaid price, not the quantity 500 prepaid price.

Any Deployment for which Deployment Licenses has not been prepaid prior to distribution is governed by the Trailing Reporting Option and will require the non-prepaid rate set forth in section I above.

Server license pricing is based on the number of core processors that are present on a server machine. Any configuration of up to 4 core processors will require a single server license. Additional server licenses are required if there are more than 4 core processors, with one additional server license being required for each full or partial set of 4 additional cores. For example, a server containing either a single core, dual or quad-core processor will require one server license. A server with two quad-core processors will require 2 server licenses. A server with a single multi-core processor with 8 cores will require two server licenses. A server with 6 single core processors will require two server licenses. A server with 3 quad core processors will require 3 server licenses.


published runtime prices

LEADTOOLS Licensing Agreements Help > Deployment Licensing > published runtime prices

LEAD Deployment License Prices

LEAD Deployment License Prices - Pro Family
LEAD Deployment License Prices - Document Family
LEAD Deployment License Prices - Medical Family
LEAD Deployment License Prices - Multimedia Family


leaddeploymentlicensepricesimagingpro

LEADTOOLS Licensing Agreements Help > Deployment Licensing > leaddeploymentlicensepricesimagingpro

LEAD Deployment License Prices - Pro Family

Pricing below is for single user deployments for internal applications developed with LEADTOOLS. Please contact LEAD's Sales Department for quantities higher than 100, as substantial discounts are available for larger quantities.

If you are using your application on a server, please contact LEAD’s Sales Department for server license pricing.

If you are an ISV distributing commercial software, please contact LEAD’s Sales Department for pricing.

If you are hosting your application for use by your customers, vendors or other third parties, please contact LEAD’s Sales Department for pricing.

If you are deploying software to mobile devices via public spaces such as App Store, Android Market, Windows please contact LEAD’s Sales Department for pricing.

LEAD offers enterprise-wide unlimited licenses, site licenses and other types of licenses for some of our SDKs. Please call for pricing. If you are licensing an SDK along with multiple add-ons or plug ins, additional discounts based on combined product licensing may be applicable.

Sales contact information:
Telephone: 704-332-5532
email: oemsales@leadtools.com

LT Imaging Pro | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 10.00
 | 10 | $ 9.00
 | 25 | $ 8.00
 | 50 | $ 7.50
 | 100 | $ 7.00
Barcode Pro | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 75.00
 | 10 | $ 70.00
 | 25 | $ 65.00
 | 50 | $ 60.00
 | 100 | $ 50.00
PDF Pro | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 50.00
 | 10 | $ 45.00
 | 25 | $ 40.00
 | 50 | $ 35.00
 | 100 | $ 30.00
Pro Suite | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 120.00
 | 10 | $ 110.00
 | 25 | $ 100.00
 | 50 | $ 90.00
 | 100 | $ 75.00


LEADRuntime License Prices Document

LEADTOOLS Licensing Agreements Help > Deployment Licensing > LEADRuntime License Prices Document

LEAD Deployment License Prices - Document Family

Pricing below is for single user deployments for internal applications developed with LEADTOOLS. Please contact LEAD's Sales Department for quantities higher than 100, as substantial discounts are available for larger quantities.

If you are using your application on a server, please contact LEAD’s Sales Department for server license pricing.

If you are an ISV distributing commercial software, please contact LEAD’s Sales Department for pricing.

If you are hosting your application for use by your customers, vendors or other third parties, please contact LEAD’s Sales Department for pricing.

If you are deploying software to mobile devices via public spaces such as App Store, Android Market, Windows please contact LEAD’s Sales Department for pricing.

LEAD offers enterprise-wide unlimited licenses, site licenses and other types of licenses for some of our SDKs. Please call for pricing. If you are licensing an SDK along with multiple add-ons or plug ins, additional discounts based on combined product licensing may be applicable.

Sales contact information:
Telephone: 704-332-5532
email: oemsales@leadtools.com

Document Imaging | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 175.00
 | 10 | $ 165.00
 | 25 | $ 150.00
 | 50 | $ 135.00
 | 100 | $ 100.00
Recognition | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 225.00
 | 10 | $ 210.00
 | 25 | $ 195.00
 | 50 | $ 180.00
 | 100 | $ 160.00
Document Imaging Suite | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 250.00
 | 10 | $ 240.00
 | 25 | $ 220.00
 | 50 | $ 200.00
 | 100 | $ 180.00
Advantage OCR | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 75.00
 | 10 | $ 65.00
 | 25 | $ 55.00
 | 50 | $ 45.00
 | 100 | $ 30.00
Pro OCR | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 175.00
 | 10 | $ 165.00
 | 25 | $ 155.00
 | 50 | $ 145.00
 | 100 | $ 130.00
Pro Asian | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 175.00
 | 10 | $ 165.00
 | 25 | $ 155.00
 | 50 | $ 145.00
 | 100 | $ 130.00
Pro Arabic | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 375.00
 | 10 | $ 350.00
 | 25 | $ 325.00
 | 50 | $ 300.00
 | 100 | $ 250.00
Pro ICR | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 500.00
 | 10 | $ 450.00
 | 25 | $ 400.00
 | 50 | $ 350.00
 | 100 | $ 300.00


LEADRuntime License Prices Medical

LEADTOOLS Licensing Agreements Help > Deployment Licensing > LEADRuntime License Prices Medical

LEAD Deployment License Prices - Medical Family

Pricing below is for single user deployments for internal applications developed with LEADTOOLS. Please contact LEAD's Sales Department for quantities higher than 100, as substantial discounts are available for larger quantities.

If you are using your application on a server, please contact LEAD’s Sales Department for server license pricing.

If you are an ISV distributing commercial software, please contact LEAD’s Sales Department for pricing.

If you are hosting your application for use by your customers, vendors or other third parties, please contact LEAD’s Sales Department for pricing.

If you are deploying software to mobile devices via public spaces such as App Store, Android Market, Windows please contact LEAD’s Sales Department for pricing.

LEAD offers enterprise-wide unlimited licenses, site licenses and other types of licenses for some of our SDKs. Please call for pricing. If you are licensing an SDK along with multiple add-ons or plug ins, additional discounts based on combined product licensing may be applicable.

Sales contact information:
Telephone: 704-332-5532
email: oemsales@leadtools.com

Medical Imaging | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 250.00
 | 10 | $ 240.00
 | 25 | $ 225.00
 | 50 | $ 210.00
 | 100 | $ 185.00
PACS Imaging | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 350.00
 | 10 | $ 340.00
 | 25 | $ 325.00
 | 50 | $ 300.00
 | 100 | $ 275.00
Medical Imaging Suite | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 450.00
 | 10 | $ 440.00
 | 25 | $ 425.00
 | 50 | $ 400.00
 | 100 | $ 375.00
Medical Multimedia Module | Dicom Writer - MPEG2 |
 | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 85.00
 | 10 | $ 75.00
 | 25 | $ 65.00
 | 50 | $ 50.00
 | 100 | $ 35.00
 | Dicom Reader - MPEG 2 |
 | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 10.00
 | 10 | $ 9.00
 | 25 | $ 8.00
 | 50 | $ 7.00
 | 100 | $ 5.00
Dental Display Module | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 150.00
 | 10 | $ 140.00
 | 25 | $ 130.00
 | 50 | $ 120.00
 | 100 | $ 100.00


LEAD Deployment License Prices - Multimedia

LEADTOOLS Licensing Agreements Help > Deployment Licensing > LEAD Deployment License Prices - Multimedia

LEAD Deployment License Prices - Multimedia Suite and Modules

Pricing below is for single user deployments for internal applications developed with LEADTOOLS. Please contact LEAD's Sales Department for quantities higher than 100, as substantial discounts are available for larger quantities.

If you are using your application on a server, please contact LEAD’s Sales Department for server license pricing.

If you are an ISV distributing commercial software, please contact LEAD’s Sales Department for pricing.

If you are hosting your application for use by your customers, vendors or other third parties, please contact LEAD’s Sales Department for pricing.

LEAD offers enterprise-wide unlimited licenses, site licenses and other types of licenses for some of our SDKs. Please call for pricing. If you are licensing an SDK along with multiple add-ons or plug ins, additional discounts based on combined product licensing may be applicable.

Sales contact information:
Telephone: 704-332-5532
email: oemsales@leadtools.com

Multimedia | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 10.00
 | 10 | $ 9.00
 | 25 | $ 8.00
 | 50 | $ 7.50
 | 100 | $ 7.00
Multimedia Suite | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 250.00
 | 10 | $ 225.00
 | 25 | $ 200.00
 | 50 | $ 175.00
 | 100 | $ 150.00
Video Streaming |  |
Encoder | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 100.00
 | 10 | $ 90.00
 | 25 | $ 80.00
 | 50 | $ 70.00
 | 100 | $ 60.00
Decoder | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 20.00
 | 10 | $ 15.00
 | 25 | $ 10.00
 | 50 | $ 7.50
 | 100 | $ 5.00
DVD Module | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 40.00
 | 10 | $ 35.00
 | 25 | $ 30.00
 | 50 | $ 25.00
 | 100 | $ 15.00
MPEG2 Transport Module | Quantity of Single User Licenses | Annual Fee Per License
 | 1 | $ 225.00
 | 10 | $ 200.00
 | 25 | $ 175.00
 | 50 | $ 150.00
 | 100 | $ 125.00

Ala Carte Pricing available for individual codecs and filters - Call LEAD for pricing