Welcome

IntegralUI TabControl
v2.0 for .NET

The IntegralUI TabControl is advanced control which has an option to merge a set of tabs and a toolbar in single line. In this way allowing you to use the same tools for each tab. The control is easy to use and very customizable with plenty of options for changing the overall appearance.

Some of major features are:

  • High customization of every control part, including use of animated gifs in each tab
  • Unique ability to make combination of toolbar and tabs
  • Many options to change appearance of tabs and behavior of tabs
  • Option to use standard tab navigation or use tab selector
  • Tab can contain command buttons for specific tasks or information
  • Themes

For more information you can visit us on: http://www.lidorsystems.com

Send comments on this topic.

Copyright © 2006-2009 Lidor Systems. All rights reserved.


Copyright

Lidor Systems IntegralUI Documentation

Copyright Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Lidor Systems.

Lidor Systems may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Lidor Systems, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2010 Lidor Systems. All rights reserved.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


LidorSystems.Collector

.NET Framework Class Library

LidorSystems.Collector Namespace

Classes

Class | Description
AutoHideBar | AutoHideBar control represents container control that holds the auto-hidden Group controls.
Bar | Bar control represents container control for arranging, managing and ordering of Group controls.
Bar.GroupCollection | Contains a collection of Group objects.
CancelableCollectorEventArgs | Provides data for a cancelable event.
CollectorDragEventArgs | Provides data for the DragOver events.
CollectorDropEventArgs | Provides data for the DragDrop events.
CollectorEventArgs | Provides data for custom events from Bar, Group, Page controls.
Group | Group control represents container control that manages related set of Page controls.
Group.PageCollection | Contains a collection of Page objects.
Layer | Layer class represents object that holds layout logic for management of tool windows.
Margin | Stores a set of four integers that represent the distance (in pixels) from border of container control.
Page | Page control represents container control with ability to arrange custom controls in a tabular format.
PageTable | Arrange controls in a tabular format.
PageTableCell | Represents a cell in a PageTable object.
PageTableCellCollection | Contains a collection of PageTableCell objects.
PageTableColumn | Represents a column in a PageTable object.
PageTableColumnCollection | Contains a collection of PageTableColumn objects.
PageTableRow | Represents a row in a PageTable object.
PageTableRowCollection | Contains a collection of PageTableRow objects.

Delegates

Delegate | Description
CancelableCollectorEventHandler | Represents the method that will handle the cancelable events of a Bar, Group, Page control.
CollectorDragEventHandler | Represents the method that will handle dragging events of a Bar, Group, Page control.
CollectorDropEventHandler | Represents the method that will handle dropping events of a Bar, Group, Page control.
CollectorEventHandler | Represents the method that will handle custom events of a Bar, Group, Page control.

Enumerations

Enumeration | Description
AcceptType | Determines objects that can be accepted by the Bar or Group control.
ActiveMode | Determines how many Groups are active in the Bar control.
AnimationSpeed | Enumerator used to determine the speed of the animation within the LidorSystems.Collector controls.
CloseAction | Determines how the object will be closed.
ControlCondition | Determines the current condition of the control.
ControlState | Determines the current state of the control.
ControlType | Determines the type of control.
DockHintStyle | Determines the docking hint style of the control.
DockPermission | Determines the dock side on which control can be docked.
SizeType | Enumerator used to determine the type of PageTableColumn and PageTableRow size.
SpliterType | Enumerator used to determine the type of spliter.
TabMode | Specifies how tabs in a Bar, Group control are sized.
VerticalAlignment | Specifies how an object or text in a control is vertically aligned relative to an element of the control.

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBar Class

AutoHideBar control represents container control that holds the auto-hidden Group controls.

For a list of all members of this type, see AutoHideBar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.Collector.AutoHideBar

[Visual Basic]
Public Class AutoHideBar
   Inherits Control
[C#]
public class AutoHideBar : Control
[C++]
public __gc class AutoHideBar : public Control
[JScript]
public class AutoHideBar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBar Members

AutoHideBar overview

Public Constructors

public constructor AutoHideBar Constructor Initializes a new instance of the AutoHideBar class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BackgroundImage (inherited from Control) | See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property OuterControl | Gets or sets the Control object representing the boundary control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the AutoHideBarStyle object representing the style of the AutoHideBar control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme | Determines whether the AutoHideBar control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the AutoHideBar control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Updates the layout logic of the AutoHideBar control.
protected method UpdateStyleParams | Updates the appearance of AutoHideBar control from the style of specific Group control.

Public Events

public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

AutoHideBar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBar Constructor

Initializes a new instance of the AutoHideBar class.

[Visual Basic]
Public Sub New()
[C#]
public AutoHideBar();
[C++]
public: AutoHideBar();
[JScript]
public function AutoHideBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBar Properties

The properties of the AutoHideBar class are listed here. For a complete list of AutoHideBar class members, see the AutoHideBar Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BackgroundImage (inherited from Control) | See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property OuterControl | Gets or sets the Control object representing the boundary control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the AutoHideBarStyle object representing the style of the AutoHideBar control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme | Determines whether the AutoHideBar control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the AutoHideBar control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

AutoHideBar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dock Property

Lidor Systems Collector Class Library

AutoHideBar.Dock Property

This member overrides Control.Dock.

[Visual Basic]
Public Overridable Property Dock As DockStyle
[C#]
public virtual DockStyle Dock {get; set;}
[C++]
public: __property virtual DockStyle get_Dock();
public: __property virtual void set_Dock(DockStyle);
[JScript]
public function get Dock() : DockStyle;
public function set Dock(DockStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OuterControl Property

Lidor Systems Collector Class Library

AutoHideBar.OuterControl Property

Gets or sets the Control object representing the boundary control.

[Visual Basic]
Public Property OuterControl As Control
[C#]
public Control OuterControl { get; set; }
[C++]
public: __property Control* get_OuterControl();
public: __property void set_OuterControl(Control* );
[JScript]
public function get OuterControl() : Control
public function set OuterControl(Control);

Property Value

A Control object that represents the boundary control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Style Property

Lidor Systems Collector Class Library

AutoHideBar.Style Property

Gets or sets the AutoHideBarStyle object representing the style of the AutoHideBar control.

[Visual Basic]
Public Property Style As AutoHideBarStyle
[C#]
public AutoHideBarStyle Style { get; set; }
[C++]
public: __property AutoHideBarStyle* get_Style();
public: __property void set_Style(AutoHideBarStyle* );
[JScript]
public function get Style() : AutoHideBarStyle
public function set Style(AutoHideBarStyle);

Property Value

AutoHideBarStyle object represents the style of the AutoHideBar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UseTheme Property

Lidor Systems Collector Class Library

AutoHideBar.UseTheme Property

Determines whether the AutoHideBar control will render according to current system theme and color scheme.

[Visual Basic]
Public Property UseTheme As Boolean
[C#]
public bool UseTheme { get; set; }
[C++]
public: __property bool get_UseTheme();
public: __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VisualStyle Property

Lidor Systems Collector Class Library

AutoHideBar.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the AutoHideBar control.

[Visual Basic]
Public Property VisualStyle As VisualStyle
[C#]
public VisualStyle VisualStyle {get; set;}
[C++]
public: __property VisualStyle get_VisualStyle();
public: __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBar Methods

The methods of the AutoHideBar class are listed here. For a complete list of AutoHideBar class members, see the AutoHideBar Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Updates the layout logic of the AutoHideBar control.
protected method UpdateStyleParams | Updates the appearance of AutoHideBar control from the style of specific Group control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

AutoHideBar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose Method

Lidor Systems Collector Class Library

AutoHideBar.Dispose Method

Overload List

Releases all resources used by the System.ComponentModel.Component.

[Visual Basic] Overloads Overrides Protected Sub Dispose(Boolean)
[C#] protected override void Dispose(bool);
[C++] protected: void Dispose(bool);
[JScript] protected override function Dispose(Boolean);

Exits edit mode and cleans up any resources being used.

[Visual Basic] Overloads Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#] public virtual void Dispose();
[C++] public: virtual void Dispose();
[JScript] public function Dispose();

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose () Method

Lidor Systems Collector Class Library

AutoHideBar.Dispose () Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose (Boolean) Method

Lidor Systems Collector Class Library

AutoHideBar.Dispose (Boolean) Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);
[C++]
protected: void Dispose(
   bool disposing
);
[JScript]
protected override function Dispose(
   disposing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UpdateLayout Method

Lidor Systems Collector Class Library

AutoHideBar.UpdateLayout Method

Updates the layout logic of the AutoHideBar control.

[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[JScript]
public function UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar Class

Bar control represents container control for arranging, managing and ordering of Group controls.

For a list of all members of this type, see Bar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.Collector.Bar

[Visual Basic]
Public Class Bar
   Inherits Control
[C#]
public class Bar : Control
[C++]
public __gc class Bar : public Control
[JScript]
public class Bar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar Members

Bar overview

Public Constructors

public constructor Bar Constructor Initializes a new instance of the Bar class.

Public Properties

public property AcceptType | Gets or sets an enumeration that determine objects that can be accepted by the Bar control.
public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property ActiveMode | Gets or sets an enumeration that determines how many Groups are active in the Bar control.
public property AllowDocking | Gets or sets an enumeration that determines the dock side on which control can be docked.
public property AllowDrag | Determines whether the Bar control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowFloat | Determines whether the Bar control can became floating window.
public property AllowReorder | Determines whether the Bar control allow reordering of contained Group controls.
public property AllowResize | Determines whether the Bar control and contained controls can be resized.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property Animation | Gets or sets whether animation is used when opening and closing Groups.
public property AnimationSpeed | Gets or sets the speed of the animation when opening and closing Groups.
public property BackgroundImage | Overridden. See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle | Gets or sets the border style of the Bar control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Gets or sets an enumeration that determines how the object will be closed.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ControlCondition | Gets or sets an enumeration that determines the current condition of the Bar control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property ControlState | Gets or sets an enumeration that determines the current state of the Bar control.
public property ControlType | Gets or sets an enumeration that determines the type of the Bar control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property DockHintStyle | Gets or sets an enumeration that determines the docking hint style of the Bar control.
public property DropAllowed | Determines whether other controls can be accepted by the Bar control in drag-drop operations.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FloatingLocation | Gets or sets the location of floating window created by the Bar control.
public property FloatingSize | Gets or sets the size of the floating window created by the Bar control.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusRectangle | Determines whether the Bar control and contained controls will display dash rectangle when they receive focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Groups | Gets the collection of Groups in this Bar control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Header | Gets or sets whether the header of the Bar is visible.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the header of a Bar control.
public property ImageList | Gets or sets the ImageList that contains the list of images used by the Groups.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property RootLayer | Gets or sets the Layer object representing the root layer which holds layout logic for management of tool windows in the Bar control.
public property SelectedGroup | Gets or sets the selected Group.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the BarStyle object representing the style of Bar control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Gets or sets the way the Bar tabs are sized.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStrip | Gets or sets whether tab strip is visible in the Bar control.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Bar control.
public property TransparentMode | Gets or sets the value indicating the Bar control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Bar control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Bar control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
protected method Close | Closes the Bar control.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetHeaderRect | Gets the rectangle of header of Bar control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
protected method IsFloating | Determines if the Bar control is floating.
protected method MakeControlFloat | Sets Bar control in floating window.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh | Overloaded. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the Bar control.

Public Events

public event BarClosed | Occurs when the Bar is closed.
public event BarClosing | Occurs when the Bar is closing.
public event BarDragging | Occurs before a Bar has started dragging.
public event BarDragOver | Occurs when a Bar is dragged.
public event BarDropped | Occurs after a Bar has been dropped.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuButtonClick | Occurs when a ContextMenuButton is clicked.
public event ControlConditionChanged | Occurs when the control condition is changed.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event GroupAdded | Occurs when a new Group is added.
public event GroupAdding | Occurs when a new Group is adding.
public event GroupClosed | Occurs when the Group is closed.
public event GroupClosing | Occurs when the Group is closing.
public event GroupDragging | Occurs before a Group has started dragging.
public event GroupDragOver | Occurs when a Group is dragged over a valid drop location.
public event GroupDropped | Occurs after a Group has been dropped in a new location.
public event GroupRemoved | Occurs when a Group is removed.
public event GroupRemoving | Occurs when a Group is removing.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedGroupChanged | Occurs when the SelectedGroup property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabSelectButtonClick | Occurs when a TabSelectButton is clicked.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBarClosed | Raises the BarClosed event.
protected method OnBarClosing | Raises the BarClosing event.
protected method OnBarDragging | Occurs before a Bar control has started dragging.
protected method OnBarDragOver | Occurs when a Bar control is dragged.
protected method OnBarDropped | Occurs after a Bar control has been dropped.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuButtonClick | Raises the ContextMenuButtonClick event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlConditionChanged | Raises the ControlConditionChanged event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnGroupAdded | Occurs when a new Group control has been added.
protected method OnGroupAdding | Occurs when a new Group control is adding.
protected method OnGroupClosed | Raises the GroupClosed event.
protected method OnGroupClosing | Raises the GroupClosing event.
protected method OnGroupDragging | Occurs before a Group control has started dragging.
protected method OnGroupDragOver | Occurs when a Group control is dragged.
protected method OnGroupDropped | Occurs after a Group control has been dropped.
protected method OnGroupRemoved | Occurs when a Group control has been removed.
protected method OnGroupRemoving | Occurs when a Group control is removing.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout | Overridden. Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedGroupChanged | Occurs whe the SelectedGroup property changes.
protected method OnSelectedGroupChanging | Occurs when the SelectedGroup property is changing.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabSelectButtonClick | Raises the TabSelectButtonClick event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RemoveAll | Removes all the groups and additional controls from this bar control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

Bar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar Constructor

Initializes a new instance of the Bar class.

[Visual Basic]
Public Sub New()
[C#]
public Bar();
[C++]
public: Bar();
[JScript]
public function Bar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar Properties

The properties of the Bar class are listed here. For a complete list of Bar class members, see the Bar Members topic.

Public Properties

public property AcceptType | Gets or sets an enumeration that determine objects that can be accepted by the Bar control.
public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property ActiveMode | Gets or sets an enumeration that determines how many Groups are active in the Bar control.
public property AllowDocking | Gets or sets an enumeration that determines the dock side on which control can be docked.
public property AllowDrag | Determines whether the Bar control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowFloat | Determines whether the Bar control can became floating window.
public property AllowReorder | Determines whether the Bar control allow reordering of contained Group controls.
public property AllowResize | Determines whether the Bar control and contained controls can be resized.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property Animation | Gets or sets whether animation is used when opening and closing Groups.
public property AnimationSpeed | Gets or sets the speed of the animation when opening and closing Groups.
public property BackgroundImage | Overridden. See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle | Gets or sets the border style of the Bar control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Gets or sets an enumeration that determines how the object will be closed.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ControlCondition | Gets or sets an enumeration that determines the current condition of the Bar control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property ControlState | Gets or sets an enumeration that determines the current state of the Bar control.
public property ControlType | Gets or sets an enumeration that determines the type of the Bar control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property DockHintStyle | Gets or sets an enumeration that determines the docking hint style of the Bar control.
public property DropAllowed | Determines whether other controls can be accepted by the Bar control in drag-drop operations.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FloatingLocation | Gets or sets the location of floating window created by the Bar control.
public property FloatingSize | Gets or sets the size of the floating window created by the Bar control.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusRectangle | Determines whether the Bar control and contained controls will display dash rectangle when they receive focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Groups | Gets the collection of Groups in this Bar control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Header | Gets or sets whether the header of the Bar is visible.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the header of a Bar control.
public property ImageList | Gets or sets the ImageList that contains the list of images used by the Groups.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property RootLayer | Gets or sets the Layer object representing the root layer which holds layout logic for management of tool windows in the Bar control.
public property SelectedGroup | Gets or sets the selected Group.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the BarStyle object representing the style of Bar control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Gets or sets the way the Bar tabs are sized.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStrip | Gets or sets whether tab strip is visible in the Bar control.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Bar control.
public property TransparentMode | Gets or sets the value indicating the Bar control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Bar control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Bar control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

Bar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AcceptType Property

Lidor Systems Collector Class Library

Bar.AcceptType Property

Gets or sets an enumeration that determine objects that can be accepted by the Bar control.

[Visual Basic]
Public Property AcceptType As AcceptType
[C#]
public AcceptType AcceptType {get; set;}
[C++]
public: __property AcceptType get_AcceptType();
public: __property void set_AcceptType(AcceptType);
[JScript]
public function get AcceptType() : AcceptType;
public function set AcceptType(AcceptType);

Property Value

The AcceptType assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ActiveMode Property

Lidor Systems Collector Class Library

Bar.ActiveMode Property

Gets or sets an enumeration that determines how many Groups are active in the Bar control.

[Visual Basic]
Public Property ActiveMode As ActiveMode
[C#]
public ActiveMode ActiveMode {get; set;}
[C++]
public: __property ActiveMode get_ActiveMode();
public: __property void set_ActiveMode(ActiveMode);
[JScript]
public function get ActiveMode() : ActiveMode;
public function set ActiveMode(ActiveMode);

Property Value

The ActiveMode assigned to the control.

Remarks

This property value only applies when the parent Bar control has Appearance set to Vertical.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDocking Property

Lidor Systems Collector Class Library

Bar.AllowDocking Property

Gets or sets an enumeration that determines the dock side on which control can be docked.

[Visual Basic]
Public Property AllowDocking As DockPermission
[C#]
public DockPermission AllowDocking {get; set;}
[C++]
public: __property DockPermission get_AllowDocking();
public: __property void set_AllowDocking(DockPermission);
[JScript]
public function get AllowDocking() : DockPermission;
public function set AllowDocking(DockPermission);

Property Value

The DockPermission assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDrag Property

Lidor Systems Collector Class Library

Bar.AllowDrag Property

Determines whether the Bar control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowFloat Property

Lidor Systems Collector Class Library

Bar.AllowFloat Property

Determines whether the Bar control can became floating window.

[Visual Basic]
Public Property AllowFloat As Boolean
[C#]
public bool AllowFloat { get; set; }
[C++]
public: __property bool get_AllowFloat();
public: __property void set_AllowFloat(bool );
[JScript]
public function get AllowFloat() : bool
public function set AllowFloat(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowReorder Property

Lidor Systems Collector Class Library

Bar.AllowReorder Property

Determines whether the Bar control allow reordering of contained Group controls.

[Visual Basic]
Public Property AllowReorder As Boolean
[C#]
public bool AllowReorder { get; set; }
[C++]
public: __property bool get_AllowReorder();
public: __property void set_AllowReorder(bool );
[JScript]
public function get AllowReorder() : bool
public function set AllowReorder(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowResize Property

Lidor Systems Collector Class Library

Bar.AllowResize Property

Determines whether the Bar control and contained controls can be resized.

[Visual Basic]
Public Property AllowResize As Boolean
[C#]
public bool AllowResize { get; set; }
[C++]
public: __property bool get_AllowResize();
public: __property void set_AllowResize(bool );
[JScript]
public function get AllowResize() : bool
public function set AllowResize(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Animation Property

Lidor Systems Collector Class Library

Bar.Animation Property

Gets or sets whether animation is used when opening and closing Groups.

[Visual Basic]
Public Property Animation As Boolean
[C#]
public bool Animation { get; set; }
[C++]
public: __property bool get_Animation();
public: __property void set_Animation(bool);
[JScript]
public function get Animation() : boolean
public function set Animation(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AnimationSpeed Property

Lidor Systems Collector Class Library

Bar.AnimationSpeed Property

Gets or sets the speed of the animation when opening and closing Groups

[Visual Basic]
Public Property AnimationSpeed As AnimationSpeed
[C#]
public AnimationSpeed AnimationSpeed {get; set;}
[C++]
public: __property AnimationSpeed get_AnimationSpeed();
public: __property void set_AnimationSpeed(AnimationSpeed);
[JScript]
public function get AnimationSpeed() : AnimationSpeed;
public function set AnimationSpeed(AnimationSpeed);

Property Value

The AnimationSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundImage Property

Lidor Systems Collector Class Library

Bar.BackgroundImage Property

This member overrides Control.BackgroundImage.

[Visual Basic]
Overrides Public Property BackgroundImage As Image
[C#]
public override Image BackgroundImage {get; set;}
[C++]
public: __property Image* get_BackgroundImage();
public: __property void set_BackgroundImage(Image*);
[JScript]
public override function get BackgroundImage() : Image;
public override function set BackgroundImage(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BorderStyle Property

Lidor Systems Collector Class Library

Bar.BorderStyle Property

Gets or sets the border style of the Bar control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle);
[JScript]
public function get BorderStyle() : BorderStyle;
public function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle values. The default is BorderStyle.None.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseAction Property

Lidor Systems Collector Class Library

Bar.CloseAction Property

Gets or sets an enumeration that determines how the object will be closed.

[Visual Basic]
Public Property CloseAction As CloseAction
[C#]
public CloseAction CloseAction {get; set;}
[C++]
public: __property CloseAction get_CloseAction();
public: __property void set_CloseAction(CloseAction);
[JScript]
public function get CloseAction() : CloseAction;
public function set CloseAction(CloseAction);

Property Value

The CloseAction assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlCondition Property

Lidor Systems Collector Class Library

Bar.ControlCondition Property

Gets an enumeration that determines the current condition of the Bar control.

[Visual Basic]
Public Property ControlCondition As ControlCondition
[C#]
public ControlCondition ControlCondition {get; set;}
[C++]
public: __property ControlCondition get_ControlCondition();
public: __property void set_ControlCondition(ControlCondition);
[JScript]
public function get ControlCondition() : ControlCondition;
public function set ControlCondition(ControlCondition);

Property Value

The ControlCondition assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlState Property

Lidor Systems Collector Class Library

Bar.ControlState Property

Gets or sets an enumeration that determines the current state of the Bar control.

[Visual Basic]
Public Property ControlState As ControlState
[C#]
public ControlState ControlState {get; set;}
[C++]
public: __property ControlState get_ControlState();
public: __property void set_ControlState(ControlState);
[JScript]
public function get ControlState() : ControlState;
public function set ControlState(ControlState);

Property Value

The ControlState assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlType Property

Lidor Systems Collector Class Library

Bar.ControlType Property

Gets or sets an enumeration that determines the type of the Bar control.

[Visual Basic]
Public Property ControlType As ControlType
[C#]
public ControlType ControlType {get; set;}
[C++]
public: __property ControlType get_ControlType();
public: __property void set_ControlType(ControlType);
[JScript]
public function get ControlType() : ControlType;
public function set ControlType(ControlType);

Property Value

The ControlType assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DefaultSize Property

Lidor Systems Collector Class Library

Bar.DefaultSize Property

This member overrides Control.DefaultSize.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override Size DefaultSize {get;}
[C++]
protected: __property Size get_DefaultSize();
[JScript]
protected override function get DefaultSize() : Size;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dock Property

Lidor Systems Collector Class Library

Bar.Dock Property

This member overrides Control.Dock.

[Visual Basic]
Public Overridable Property Dock As DockStyle
[C#]
public virtual DockStyle Dock {get; set;}
[C++]
public: __property virtual DockStyle get_Dock();
public: __property virtual void set_Dock(DockStyle);
[JScript]
public function get Dock() : DockStyle;
public function set Dock(DockStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DockHintStyle Property

Lidor Systems Collector Class Library

Bar.DockHintStyle Property

Gets or sets an enumeration that determines the docking hint style of the Bar control.

[Visual Basic]
Public Property DockHintStyle As DockHintStyle
[C#]
public DockHintStyle DockHintStyle {get; set;}
[C++]
public: __property DockHintStyle get_DockHintStyle();
public: __property void set_DockHintStyle(DockHintStyle);
[JScript]
public function get DockHintStyle() : DockHintStyle;
public function set DockHintStyle(DockHintStyle);

Property Value

The DockHintStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DropAllowed Property

Lidor Systems Collector Class Library

Bar.DropAllowed Property

Determines whether other controls can be accepted by the Bar control in drag-drop operations.

[Visual Basic]
Public Property DropAllowed As Boolean
[C#]
public bool DropAllowed { get; set; }
[C++]
public: __property bool get_DropAllowed();
public: __property void set_DropAllowed(bool );
[JScript]
public function get DropAllowed() : bool
public function set DropAllowed(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FloatingLocation Property

Lidor Systems Collector Class Library

Bar.FloatingLocation Property

Gets or sets the location of floating window created by the Bar control.

[Visual Basic]
Public Property FloatingLocation As Point
[C#]
public Point FloatingLocation { get; set; }
[C++]
public: __property Point get_FloatingLocation();
public: __property void set_FloatingLocation(Point);
[JScript]
public function get FloatingLocation() : Point
public function set FloatingLocation(Point);

Property Value

The Point that represents the location of floating window.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Size Property

Lidor Systems Collector Class Library

Bar.FloatingSize Property

Gets or sets the size of the floating window created by the Bar control.

[Visual Basic]
Public Property FloatingSize As Size
[C#]
public Size FloatingSize { get; set; }
[C++]
public: __property Size get_FloatingSize();
public: __property void set_FloatingSize(Size);
[JScript]
public function get FloatingSize() : Size
public function set FloatingSize(Size);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FocusRectangle Property

Lidor Systems Collector Class Library

Bar.FocusRectangle Property

Determines whether the Bar control and contained controls will display dash rectangle when they receive focus.

[Visual Basic]
Public Property FocusRectangle As Boolean
[C#]
public bool FocusRectangle { get; set; }
[C++]
public: __property bool get_FocusRectangle();
public: __property void set_FocusRectangle(bool );
[JScript]
public function get FocusRectangle() : bool
public function set FocusRectangle(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Groups Property

Lidor Systems Collector Class Library

Bar.Groups Property

Gets the collection of Groups in this Bar control.

[Visual Basic]
Public ReadOnly Property Groups As Bar.GroupCollection
[C#]
public Bar.GroupCollection Groups {get;}
[C++]
public: __property Bar.GroupCollection* get_Groups();
[JScript]
public function get Groups() : Bar.GroupCollection;

Property Value

A Bar.GroupCollection that contains the Group objects in this Bar.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Header Property

Lidor Systems Collector Class Library

Bar.Header Property

Gets or sets whether the header of the Bar is visible.

[Visual Basic]
Public Property Header As Boolean
[C#]
public bool Header { get; set; }
[C++]
public: __property bool get_Header();
public: __property void set_Header(bool );
[JScript]
public function get Header() : bool
public function set Header(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Image Property

Lidor Systems Collector Class Library

Bar.Image Property

Specifies the image object inside the header of a Bar control

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Property Value

The Image assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageList Property

Lidor Systems Collector Class Library

Bar.ImageList Property

Gets or sets the ImageList that contains the Image objects used by the Groups.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Property Value

An ImageList that specifies the images to display on the tabs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RootLayer Property

Lidor Systems Collector Class Library

Bar.RootLayer Property

Gets or sets the Layer object representing the root layer which holds layout logic for management of tool windows in the Bar control.

[Visual Basic]
Public Property RootLayer As Layer
[C#]
public Layer RootLayer { get; set; }
[C++]
public: __property Layer* get_RootLayer();
public: __property void set_RootLayer(Layer* );
[JScript]
public function get RootLayer() : Layer
public function set RootLayer(Layer);

Property Value

Layer object holds layout logic for management of tool windows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedGroup Property

Lidor Systems Collector Class Library

Bar.SelectedGroup Property

Gets or sets the selected Group.

[Visual Basic]
Public Property SelectedGroup As Group
[C#]
public Group SelectedGroup {get; set;}
[C++]
public: __property Group* get_SelectedGroup();
public: __property void set_SelectedGroup(Group*);
[JScript]
public function get SelectedGroup() : Group;
public function set SelectedGroup(Group);

Property Value

A Group that represents the selected group. If no group is selected, the value is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Style Property

Lidor Systems Collector Class Library

Bar.Style Property

Gets or sets the BarStyle object representing the style of the Bar control.

[Visual Basic]
Public Property Style As BarStyle
[C#]
public BarStyle Style { get; set; }
[C++]
public: __property BarStyle* get_Style();
public: __property void set_Style(BarStyle* );
[JScript]
public function get Style() : BarStyle
public function set Style(BarStyle);

Property Value

BarStyle object represents the style of the Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabMode Property

Lidor Systems Collector Class Library

Bar.TabMode Property

Gets or sets the way the Bar tabs are sized.

[Visual Basic]
Public Property TabMode As TabMode
[C#]
public TabMode TabMode {get; set;}
[C++]
public: __property TabMode get_TabMode();
public: __property void set_TabMode(TabMode);
[JScript]
public function get TabMode() : TabMode;
public function set TabMode(TabMode);

Property Value

One of the TabMode values. The default is AutoSized.

Exceptions

Exception Type | Condition
InvalidEnumArgumentException | The property value is not a valid TabMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStrip Property

Lidor Systems Collector Class Library

Bar.TabStrip Property

Gets or sets whether tab strip is visible in the Bar control.

[Visual Basic]
Public Property TabStrip As Boolean
[C#]
public bool TabStrip { get; set; }
[C++]
public: __property bool get_TabStrip();
public: __property void set_TabStrip(bool);
[JScript]
public function get TabStrip() : boolean
public function set TabStrip(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Transparency Property

Lidor Systems Collector Class Library

Bar.Transparency Property

A value specifying the level of transparency of the Bar control.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}
[C++]
public: __property int get_Transparency();
public: __property void set_Transparency(int);
[JScript]
public function get Transparency() : int;
public function set Transparency(int);

Property Value

Transparency is in percentage, so the value can be from 0 to 100. Default setting is 50.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TransparentMode Property

Lidor Systems Collector Class Library

Bar.TransparentMode Property

Determines whether the Bar background will be transparent.

[Visual Basic]
Public Property TransparentMode As Boolean
[C#]
public bool TransparentMode { get; set; }
[C++]
public: __property bool get_TransparentMode();
public: __property void set_TransparentMode(bool );
[JScript]
public function get TransparentMode() : bool
public function set TransparentMode(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UseTheme Property

Lidor Systems Collector Class Library

Bar.UseTheme Property

Determines whether the Bar control will render according to current system theme and color scheme.

[Visual Basic]
Public Property UseTheme As Boolean
[C#]
public bool UseTheme { get; set; }
[C++]
public: __property bool get_UseTheme();
public: __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VisualStyle Property

Lidor Systems Collector Class Library

Bar.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the Bar control.

[Visual Basic]
Public Property VisualStyle As VisualStyle
[C#]
public VisualStyle VisualStyle {get; set;}
[C++]
public: __property VisualStyle get_VisualStyle();
public: __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Methods

The methods of the Group class are listed here. For a complete list of Group class members, see the Group Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
protected method Close | Closes the Group control.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetHeaderRect | Gets the rectangle of header of Group control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
protected method IsFloating | Determines if the Group control is floating.
protected method MakeControlFloat | Sets the Group control in floating window.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh | Overloaded. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the Group control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAutoHideChanged | Raises the AutoHideChanged event.
protected method OnAutoHideChanging | Raises the AutoHideChanging event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuButtonClick | Raises the ContextMenuButtonClick event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlConditionChanged | Raises the ControlConditionChanged event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnGroupClosed | Raises the GroupClosed event.
protected method OnGroupClosing | Raises the GroupClosing event.
protected method OnGroupCollapsed | Raises the GroupCollapsed event.
protected method OnGroupCollapsing | Raises the GroupCollapsing event.
protected method OnGroupDragging | Occurs before a Group control has started dragging.
protected method OnGroupDragOver | Occurs when a Group control is dragged.
protected method OnGroupDropped | Occurs after a Group control has been dropped.
protected method OnGroupExpanded | Raises the GroupExpanded event.
protected method OnGroupExpanding | Raises the GroupExpanding event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout | Overridden. Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMaximizeButtonClick | Raises the MaximizeButtonClick event.
protected method OnMinimizeButtonClick | Raises the MinimizeButtonClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnPageAdded | Occurs after a Page control has been added.
protected method OnPageAdding | Occurs before a Page control is added.
protected method OnPageClosed | Raises the PageClosed event.
protected method OnPageClosing | Raises the PageClosing event.
protected method OnPageDragging | Occurs before a Page control has started dragging.
protected method OnPageDragOver | Occurs when a Page control is dragged.
protected method OnPageDropped | Occurs after a Page control has been dropped.
protected method OnPageRemoved | Occurs after a Page control has been removed.
protected method OnPageRemoving | Occurs before a Page control is removed.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedPageChanged | Occurs after the SelectedPage changes.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabSelectButtonClick | Raises the TabSelectButtonClick event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RemoveAll | Removes all the Pages and additional controls from this Group control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

Group Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Close Method

Lidor Systems Collector Class Library

Bar.Close Method

Closes the Bar control.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

Remarks

When a Bar control is closed, all resources created within the object are closed and the Bar control is disposed. You can prevent the closing of a Bar control at run time by handling the BarClosing event and setting the Cancel property of the CancelableCollectorEventArgs passed as a parameter to your event-handling method.

CAUTION When you drag&drop or move child Group controls or Page controls, the Close method may be called if the parent Bar control doesn't contain any Group control. To prevent disposing of a Bar control at run time you must handle the BarClosing event, set the Cancel property to TRUE and use the Control.Hide method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose Method

Lidor Systems Collector Class Library

Bar.Dispose Method

Overload List

Releases all resources used by the System.ComponentModel.Component.

[Visual Basic] Overloads Overrides Protected Sub Dispose(Boolean)
[C#] protected override void Dispose(bool);
[C++] protected: void Dispose(bool);
[JScript] protected override function Dispose(Boolean);

Exits edit mode and cleans up any resources being used.

[Visual Basic] Overloads Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#] public virtual void Dispose();
[C++] public: virtual void Dispose();
[JScript] public function Dispose();

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose () Method

Lidor Systems Collector Class Library

Bar.Dispose () Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose (Boolean) Method

Lidor Systems Collector Class Library

Bar.Dispose (Boolean) Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);
[C++]
protected: void Dispose(
   bool disposing
);
[JScript]
protected override function Dispose(
   disposing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GetHeaderRect Method

Lidor Systems Collector Class Library

Bar.GetHeaderRect Method

Gets the rectangle of header of Bar control.

[Visual Basic]
Public Function GetHeaderRect() As Rectangle
[C#]
public Rectangle GetHeaderRect();
[C++]
public: Rectangle GetHeaderRect();
[JScript]
public function GetHeaderRect() : Rectangle;

Return Value

A Rectangle that represents the space reserved for header of the Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IsFloating Method

Lidor Systems Collector Class Library

Bar.IsFloating Method

Determines if the Bar control is floating.

[Visual Basic]
Public Function IsFloating() As Boolean
[C#]
public bool IsFloating();
[C++]
public: bool IsFloating();
[JScript]
public function IsFloating() : Boolean;

Return Value

true if the Bar control is floating; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MakeControlFloat Method

Lidor Systems Collector Class Library

Bar.MakeControlFloat Method

Sets the Bar control in floating window.

[Visual Basic]
Public Sub MakeControlFloat()
[C#]
public void MakeControlFloat();
[C++]
public: void MakeControlFloat();
[JScript]
public function MakeControlFloat();

Remarks

In order to create floating window, control must have AllowFloat property value set to True. When calling this function, the ControlState property is automatically changed to Floating value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBarClosed Method

Lidor Systems Collector Class Library

Bar.OnBarClosed Method

Raises the BarClosed event.

[Visual Basic]
Protected Overridable Sub OnBarClosed( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnBarClosed(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnBarClosed(
   CollectorEventArgs* e
);
[JScript]
protected function OnBarClosed(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBarClosed in a derived class, be sure to call the base class's OnBarClosed method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBarClosing Method

Lidor Systems Collector Class Library

Bar.OnBarClosing Method

Raises the BarClosing event.

[Visual Basic]
Protected Overridable Sub OnBarClosing( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnBarClosing(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnBarClosing(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnBarClosing(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBarClosing in a derived class, be sure to call the base class's OnBarClosing method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBarDragging Method

Lidor Systems Collector Class Library

Bar.OnBarDragging Method

Occurs before a Bar control has started dragging.

[Visual Basic]
Protected Overridable Sub OnBarDragging( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnBarDragging(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnBarDragging(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnBarDragging(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBarDragging in a derived class, be sure to call the base class's OnBarDragging method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBarDragOver Method

Lidor Systems Collector Class Library

Bar.OnBarDragOver Method

Occurs when a Bar control is dragged.

[Visual Basic]
Protected Overridable Sub OnBarDragOver( _
   ByVal de As CollectorDragEventArgs _
)
[C#]
protected virtual void OnBarDragOver(
   CollectorDragEventArgs de
);
[C++]
protected: virtual void OnBarDragOver(
   CollectorDragEventArgs* de
);
[JScript]
protected function OnBarDragOver(
   de : CollectorDragEventArgs
);

Parameters

de
A CollectorDragEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBarDragOver in a derived class, be sure to call the base class's OnBarDragOver method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBarDropped Method

Lidor Systems Collector Class Library

Bar.OnBarDropped Method

Occurs after a Bar control has been dropped.

[Visual Basic]
Protected Overridable Sub OnBarDropped( _
   ByVal de As CollectorDropEventArgs _
)
[C#]
protected virtual void OnBarDropped(
   CollectorDropEventArgs de
);
[C++]
protected: virtual void OnBarDropped(
   CollectorDropEventArgs* de
);
[JScript]
protected function OnBarDropped(
   de : CollectorDropEventArgs
);

Parameters

de
A CollectorDropEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBarDropped in a derived class, be sure to call the base class's OnBarDropped method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnControlConditionChanged Method

Lidor Systems Collector Class Library

Bar.OnControlConditionChanged Method

Occurs when the control condition is changed.

[Visual Basic]
Protected Overridable Sub OnControlConditionChanged( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnControlConditionChanged(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnControlConditionChanged(
   CollectorEventArgs* e
);
[JScript]
protected function OnControlConditionChanged(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupAdded Method

Lidor Systems Collector Class Library

Bar.OnGroupAdded Method

Occurs when a new Group control has been added.

[Visual Basic]
Protected Overridable Sub OnGroupAdded( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupAdded(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupAdded(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupAdded(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupAdding Method

Lidor Systems Collector Class Library

Bar.OnGroupAdding Method

Occurs when a new Group control is adding.

[Visual Basic]
Protected Overridable Sub OnGroupAdding( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupAdding(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupAdding(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupAdding(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupClosed Method

Lidor Systems Collector Class Library

Bar.OnGroupClosed Method

Raises the GroupClosed event.

[Visual Basic]
Protected Overridable Sub OnGroupClosed( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupClosed(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupClosed(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupClosed(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupClosed in a derived class, be sure to call the base class's OnGroupClosed method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupClosing Method

Lidor Systems Collector Class Library

Bar.OnGroupClosing Method

Raises the GroupClosing event.

[Visual Basic]
Protected Overridable Sub OnGroupClosing( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupClosing(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupClosing(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupClosing(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupClosing in a derived class, be sure to call the base class's OnGroupClosing method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDragging Method

Lidor Systems Collector Class Library

Bar.OnGroupDragging Method

Occurs before a Group control has started dragging.

[Visual Basic]
Protected Overridable Sub OnGroupDragging( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupDragging(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupDragging(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupDragging(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDragging in a derived class, be sure to call the base class's OnGroupDragging method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDragOver Method

Lidor Systems Collector Class Library

Bar.OnGroupDragOver Method

Occurs when a Group control is dragged.

[Visual Basic]
Protected Overridable Sub OnGroupDragOver( _
   ByVal de As CollectorDragEventArgs _
)
[C#]
protected virtual void OnGroupDragOver(
   CollectorDragEventArgs de
);
[C++]
protected: virtual void OnGroupDragOver(
   CollectorDragEventArgs* de
);
[JScript]
protected function OnGroupDragOver(
   de : CollectorDragEventArgs
);

Parameters

de
A CollectorDragEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDragOver in a derived class, be sure to call the base class's OnGroupDragOver method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDropped Method

Lidor Systems Collector Class Library

Bar.OnGroupDropped Method

Occurs after a Group control has been dropped.

[Visual Basic]
Protected Overridable Sub OnGroupDropped( _
   ByVal de As CollectorDropEventArgs _
)
[C#]
protected virtual void OnGroupDropped(
   CollectorDropEventArgs de
);
[C++]
protected: virtual void OnGroupDropped(
   CollectorDropEventArgs* de
);
[JScript]
protected function OnGroupDropped(
   de : CollectorDropEventArgs
);

Parameters

de
A CollectorDropEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDropped in a derived class, be sure to call the base class's OnGroupDropped method so that registered delegates receive the event.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupRemoved Method

Lidor Systems Collector Class Library

Bar.OnGroupRemoved Method

Occurs when a Group control has been removed.

[Visual Basic]
Protected Overridable Sub OnGroupRemoved( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupRemoved(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupRemoved(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupRemoved(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupRemoving Method

Lidor Systems Collector Class Library

Bar.OnGroupRemoving Method

Occurs when a Group control is removing.

[Visual Basic]
Protected Overridable Sub OnGroupRemoving( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupRemoving(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupRemoving(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupRemoving(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnLayout Method

Lidor Systems Collector Class Library

Bar.OnLayout Method

This member overrides Control.OnLayout

[Visual Basic]
Overrides Protected Sub OnLayout( _
   ByVal levent As LayoutEventArgs _
)
[C#]
protected override void OnLayout(
   LayoutEventArgs levent
);
[C++]
protected: void OnLayout(
   LayoutEventArgs* levent
);
[JScript]
protected override function OnLayout(
   levent : LayoutEventArgs
);

Parameters

levent
A LayoutEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnResize Method

Lidor Systems Collector Class Library

Bar.OnResize Method

This member overrides Control.OnResize.

[Visual Basic]
Overrides Protected Sub OnResize( _
   ByVal e As EventArgs _
)
[C#]
protected override void OnResize(
   EventArgs e
);
[C++]
protected: void OnResize(
   EventArgs* e
);
[JScript]
protected override function OnResize(
   e : EventArgs
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnSelectedGroupChanged Method

Lidor Systems Collector Class Library

Bar.OnSelectedGroupChanged Method

Occurs when the SelectedGroup property changes.

[Visual Basic]
Protected Overridable Sub OnSelectedGroupChanged( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnSelectedGroupChanged(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnSelectedGroupChanged(
   CollectorEventArgs* e
);
[JScript]
protected function OnSelectedGroupChanged(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ProcessCmdKey Method

Lidor Systems Collector Class Library

Bar.ProcessCmdKey Method

This member overrides Control.ProcessCmdKey

[Visual Basic]
Overrides Protected Function ProcessCmdKey( _
   ByRef msg As Message, _
   ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
);
[C++]
protected: bool ProcessCmdKey(
   Message* msg,
   Keys keyData
);
[JScript]
protected override function ProcessCmdKey(
   msg : Message,
   keyData : Keys
) : Boolean;

Parameters

msg
A Message, passed by reference, that represents the window message to process.
keyData
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Refresh Method

Lidor Systems Collector Class Library

Bar.Refresh Method

This member overrides Control.Refresh

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();
[C++]
public: void Refresh();
[JScript]
public override function Refresh();

Remarks

Notes to Inheritors: When overriding Refresh in a derived class, be sure to call the base class's Refresh method so the control and its child controls are invalidated and redrawn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RemoveAll Method

Lidor Systems Collector Class Library

Bar.RemoveAll Method

Removes all the groups and additional controls from this Bar control.

[Visual Basic]
Protected Sub RemoveAll()
[C#]
protected void RemoveAll();
[C++]
protected: void RemoveAll();
[JScript]
protected function RemoveAll();

Remarks

All controls are removed through the Groups property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UpdateLayout Method

Lidor Systems Collector Class Library

Bar.UpdateLayout Method

Update layout logic of the Bar control.

[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[JScript]
public function UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar Events

The events of the Bar class are listed here. For a complete list of Bar class members, see the Bar Members topic.

Public Events

public event BarClosed | Occurs when the Bar is closed.
public event BarClosing | Occurs when the Bar is closing.
public event BarDragging | Occurs before a Bar has started dragging.
public event BarDragOver | Occurs when a Bar is dragged.
public event BarDropped | Occurs after a Bar has been dropped.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuButtonClick | Occurs when a ContextMenuButton is clicked.
public event ControlConditionChanged | Occurs when the control condition is changed.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event GroupAdded | Occurs when a new Group is added.
public event GroupAdding | Occurs when a new Group is adding.
public event GroupClosed | Occurs when the Group is closed.
public event GroupClosing | Occurs when the Group is closing.
public event GroupDragging | Occurs before a Group has started dragging.
public event GroupDragOver | Occurs when a Group is dragged over a valid drop location.
public event GroupDropped | Occurs after a Group has been dropped in a new location.
public event GroupRemoved | Occurs when a Group is removed.
public event GroupRemoving | Occurs when a Group is removing.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedGroupChanged | Occurs when the SelectedGroup property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabSelectButtonClick | Occurs when a TabSelectButton is clicked.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

Bar Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButtonClick Event

Lidor Systems Collector Class Library

Bar.ContextMenuButtonClick Event

Occurs when a ContextMenuButton is clicked.

[Visual Basic]
Public Event ContextMenuButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler ContextMenuButtonClick;
[C++]
public: __event CollectorEventHandler* ContextMenuButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlConditionChanged Event

Lidor Systems Collector Class Library

Bar.ControlConditionChanged Event

Occurs when the control condition is changed.

[Visual Basic]
Public Event ControlConditionChanged As CollectorEventHandler
[C#]
public event CollectorEventHandler ControlConditionChanged;
[C++]
public: __event CollectorEventHandler* ControlConditionChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarClosed Event

Lidor Systems Collector Class Library

Bar.BarClosed Event

Occurs when the Bar is closed.

[Visual Basic]
Public Event BarClosed As CollectorEventHandler
[C#]
public event CollectorEventHandler BarClosed;
[C++]
public: __event CollectorEventHandler* BarClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

This event occurs after the Bar control has been closed by the user. To prevent a control from closing, handle the BarClosing event and set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

You can use this event to perform tasks such as freeing resources used by the Bar control and to save information entered in the Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarClosing Event

Lidor Systems Collector Class Library

Bar.BarClosing Event

Occurs when the Bar is closing.

[Visual Basic]
Public Event BarClosing As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler BarClosing;
[C++]
public: __event CancelableCollectorEventHandler* BarClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

The BarClosing event occurs as the Bar control is being closed. When a control is closed, all resources created within the object are released and the control is disposed. If you cancel this event, the control remains opened. To cancel the closure of a control, set the Cancel property of the CancelableCollectorEventArgs passed to your event handler to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarDragging Event

Lidor Systems Collector Class Library

Bar.BarDragging Event

Occurs before a Bar has started dragging.

[Visual Basic]
Public Event BarDragging As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler BarDragging;
[C++]
public: __event CancelableCollectorEventHandler* BarDragging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarDragOver Event

Lidor Systems Collector Class Library

Bar.BarDragOver Event

Occurs when a Bar is dragged.

[Visual Basic]
Public Event BarDragOver As CollectorDragEventHandler
[C#]
public event CollectorDragEventHandler BarDragOver;
[C++]
public: __event CollectorDragEventHandler* BarDragOver;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDragEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarDropped Event

Lidor Systems Collector Class Library

Bar.BarDropped Event

Occurs after a Bar has been dropped.

[Visual Basic]
Public Event BarDropped As CollectorDropEventHandler
[C#]
public event CollectorDropEventHandler BarDropped;
[C++]
public: __event CollectorDropEventHandler* BarDropped;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDropEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupAdded Event

Lidor Systems Collector Class Library

Bar.GroupAdded Event

Occurs when a new Group is added.

[Visual Basic]
Public Event GroupAdded As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupAdded;
[C++]
public: __event CollectorEventHandler* GroupAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupAdding Event

Lidor Systems Collector Class Library

Bar.GroupAdding Event

Occurs when a new Group is adding.

[Visual Basic]
Public Event GroupAdding As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupAdding;
[C++]
public: __event CancelableCollectorEventHandler* GroupAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupClosed Event

Lidor Systems Collector Class Library

Bar.GroupClosed Event

Occurs when the Group is closed.

[Visual Basic]
Public Event GroupClosed As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupClosed;
[C++]
public: __event CollectorEventHandler* GroupClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

This event occurs after the Group control has been closed by the user. To prevent a control from closing, handle the GroupClosing event and set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

You can use this event to perform tasks such as freeing resources used by the Group control and to save information entered in the Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupClosing Event

Lidor Systems Collector Class Library

Bar.GroupClosing Event

Occurs when the Group is closing.

[Visual Basic]
Public Event GroupClosing As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupClosing;
[C++]
public: __event CancelableCollectorEventHandler* GroupClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

The GroupClosing event occurs as the Group control is being closed. When a control is closed, all resources created within the object are released and the control is disposed. If you cancel this event, the control remains opened. To cancel the closure of a control, set the Cancel property of the CancelableCollectorEventArgs passed to your event handler to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDragging Event

Lidor Systems Collector Class Library

Bar.GroupDragging Event

Occurs before a Group has started dragging.

[Visual Basic]
Public Event GroupDragging As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupDragging;
[C++]
public: __event CollectorEventHandler* GroupDragging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDragOver Event

Lidor Systems Collector Class Library

Bar.GroupDragOver Event

Occurs when a Group is dragged.

[Visual Basic]
Public Event GroupDragOver As CollectorDragEventHandler
[C#]
public event CollectorDragEventHandler GroupDragOver;
[C++]
public: __event CollectorDragEventHandler* GroupDragOver;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDragEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDropped Event

Lidor Systems Collector Class Library

Bar.GroupDropped Event

Occurs after a Group has been dropped.

[Visual Basic]
Public Event GroupDropped As CollectorDropEventHandler
[C#]
public event CollectorDropEventHandler GroupDropped;
[C++]
public: __event CollectorDropEventHandler* GroupDropped;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDropEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupRemoved Event

Lidor Systems Collector Class Library

Bar.GroupRemoved Event

Occurs when a Group is removed.

[Visual Basic]
Public Event GroupRemoved As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupRemoved;
[C++]
public: __event CollectorEventHandler* GroupRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupRemoving Event

Lidor Systems Collector Class Library

Bar.GroupRemoving Event

Occurs when a Group is removing.

[Visual Basic]
Public Event GroupRemoving As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupRemoving;
[C++]
public: __event CancelableCollectorEventHandler* GroupRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedGroupChanged Event

Lidor Systems Collector Class Library

Bar.SelectedGroupChanged Event

Occurs when the SelectedGroup property value changes.

[Visual Basic]
Public Event SelectedGroupChanged As CollectorEventHandler
[C#]
public event CollectorEventHandler SelectedGroupChanged;
[C++]
public: __event CollectorEventHandler* SelectedGroupChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButtonClick Event

Lidor Systems Collector Class Library

Bar.TabSelectButtonClick Event

Occurs when a TabSelectButton is clicked.

[Visual Basic]
Public Event TabSelectButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler TabSelectButtonClick;
[C++]
public: __event CollectorEventHandler* TabSelectButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Class

Contains a collection of Group objects.

For a list of all members of this type, see Bar.GroupCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.Collector.Bar.GroupCollection

[Visual Basic]
Public Class Bar.GroupCollection
   Inherits CollectionBase
[C#]
public class Bar.GroupCollection : CollectionBase
[C++]
public __gc class Bar.GroupCollection : public CollectionBase
[JScript]
public class Bar.GroupCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Members

Bar.GroupCollection overview

Public Constructors

public constructor Bar.GroupCollection Constructor Initializes a new instance of the Bar.GroupCollection class.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a Group at the specified location in the collection.
public property Parent | Gets the Bar control that owns the Bar.GroupCollection.

Public Methods

public method Add | Adds a new Group to the end of the Bar.GroupCollection.
public method AddRange | Adds an array of groups to the Bar.GroupCollection.
public method Clear | Removes all groups from the collection.
public method Contains | Determines whether the specified Group object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified Group object in the collection.
public method Remove | Removes the specified Group from the Bar.GroupCollection.
public method RemoveAt | Removes the Group at the specified index of the Bar.GroupCollection.
public method SetChildIndex | Sets the index of the specified Group in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

Bar.GroupCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Constructor Method

Lidor Systems Collector Class Library

Bar.GroupCollection Constructor Method

Overload List

Initializes a new instance of the Bar.GroupCollection class and associates it with the given Bar class.

public Bar.GroupCollection(Bar);

Initializes a new instance of the Bar.GroupCollection class and adds the specified collection to the newly created object instance.

public Bar.GroupCollection(Bar, Bar.GroupCollection);

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Constructor (Bar)

Initializes a new instance of the Bar.GroupCollection class and assigns to Bar control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Bar _
)
[C#]
public Bar.GroupCollection(
   Bar owner
);
[C++]
public: Bar.GroupCollection(
   Bar* owner
);
[JScript]
public function Bar.GroupCollection(
   owner : Bar
);

Parameters

owner
The Bar to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Constructor (Bar, Bar.GroupCollection)

Initializes a new instance of the Bar.GroupCollection class, assigns to Bar control and adds the specified collection to the newly created object instance.

[Visual Basic]
Public Sub New( _
   ByVal owner As Bar, _
   ByVal groups As Bar.GroupCollection _
)
[C#]
public Bar.GroupCollection(
   Bar owner,
   Bar.GroupCollection groups
);
[C++]
public: Bar.GroupCollection(
   Bar* owner,
   Bar.GroupCollection* groups
);
[JScript]
public function Bar.GroupCollection(
   owner : Bar,
   groups : Bar.GroupCollection
);

Parameters

owner
The Bar to be the owner of the created collection instance.
groups
Instance of the Bar.GroupCollection being added to the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Properties

The properties of the Bar.GroupCollection class are listed here. For a complete list of Bar.GroupCollection class members, see the Bar.GroupCollection Members topic.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a Group at the specified location in the collection.
public property Parent | Gets the Bar control that owns the Bar.GroupCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

Bar.GroupCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Item Property

Lidor Systems Collector Class Library

Bar.GroupCollection.Item Property

Gets or sets a Group at the specified location in the collection.

[Visual Basic]
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As Group
[C#]
public virtual Group this[
   int index
] {get; set;}
[C++]
public: __property virtual Group* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Group*
);

Parameters

index
The 0-based index of the group to get or set.

Property Value

The Group at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The value is not a Group.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

Bar.GroupCollection.Parent Property

Gets or sets the Bar that owns the Bar.GroupCollection.

[Visual Basic]
Public Property Parent As Bar
[C#]
public Bar Parent { get; set; }
[C++]
public: __property Bar* get_Parent();
public: __property void set_Parent(Bar);
[JScript]
public function get Parent() : Bar
public function set Parent(Bar);

Property Value

Represents the Bar control that owns the Bar.GroupCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bar.GroupCollection Methods

The methods of the Bar.GroupCollection class are listed here. For a complete list of Bar.GroupCollection class members, see the Bar.GroupCollection Members topic.

Public Methods

public method Add | Adds a new Group to the end of the Bar.GroupCollection.
public method AddRange | Adds an array of groups to the Bar.GroupCollection.
public method Clear | Removes all groups from the collection.
public method Contains | Retrieves a boolean value indicating if the specified Group object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified Group object in the collection.
public method Remove | Removes the specified Group from the Bar.GroupCollection.
public method RemoveAt | Removes the Group at the specified index of the Bar.GroupCollection.
public method SetChildIndex | Sets the index of the specified Group in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

Bar.GroupCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add Method

Overload List

Adds a new Group to the end of the Bar.GroupCollection.

[Visual Basic] Public Sub Add(Group)
[C#] public void Add(Group);
[C++] public: void Add(Group);
[JScript] public function Add(Group);

Adds an collection of previously created groups to the Bar.GroupCollection.

[Visual Basic] Public Sub Add(Bar.GroupCollection)
[C#] public void Add(Bar.GroupCollection);
[C++] public: void Add(Bar.GroupCollection);
[JScript] public function Add(Bar.GroupCollection);

Adds a new Group to the end of the Bar.GroupCollection, with inheritance of parent property values.

[Visual Basic] Public Sub Add(Group, bool)
[C#] public void Add(GroupGroup, bool);
[C++] public: void Add(GroupGroup, bool);
[JScript] public function Add(GroupGroup, bool);

Adds a new Group to the Bar.GroupCollection, and splits the target Group.

[Visual Basic] Public Sub Add(Group, Group, DockStyle)
[C#] public void Add(GroupGroup, Group, DockStyle);
[C++] public: void Add(GroupGroup, Group, DockStyle);
[JScript] public function Add(GroupGroup, Group, DockStyle);

Adds a new Group to the Bar.GroupCollection, and splits the target Group with inheritance of parent property values.

[Visual Basic] Public Sub Add(Group, Group, bool, DockStyle, bool)
[C#] public void Add(GroupGroup, Group, bool, DockStyle, bool);
[C++] public: void Add(GroupGroup, Group, bool, DockStyle, bool);
[JScript] public function Add(GroupGroup, Group, bool, DockStyle, bool);

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Group) Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add (Group) Method

Adds a new Group to the end of the Bar.GroupCollection.

[Visual Basic]
Public Sub Add( _
   ByVal group As Group _
)
[C#]
public void Add(
   Group group
);
[C++]
public: void Add(
   Group* group
);
[JScript]
public function Add(
   group : Group
);

Parameters

group
The Group to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Bar.GroupCollection) Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add (Bar.GroupCollection) Method

Adds an collection of previously created groups to the Bar.GroupCollection.

[Visual Basic]
Public Sub Add( _
   ByVal groups As Bar.GroupCollection _
)
[C#]
public void Add(
   Bar.GroupCollection groups
);
[C++]
public: void Add(
   Bar.GroupCollection* groups
);
[JScript]
public function Add(
   groups : Bar.GroupCollection
);

Parameters

groups
The Bar.GroupCollection to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Group, bool) Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add (Group, bool) Method

Adds a new Group to the end of the Bar.GroupCollection.

[Visual Basic]
Public Sub Add( _
   ByVal group As Group _
   ByVal propFromParent As Boolean _
)
[C#]
public void Add(
   Group group
   bool propFromParent
);
[C++]
public: void Add(
   Group* group
   bool* propFromParent
);
[JScript]
public function Add(
   group : Group
   propFromParent : Boolean
);

Parameters

group
The Group to add to the collection.
propFromParent
Inheriths property values from the parent Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Group, Group, DockStyle) Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add (Group, Group, DockStyle) Method

Adds a new Group to the Bar.GroupCollection.

[Visual Basic]
Public Sub Add( _
   ByVal targetGroup As Group _
   ByVal group As Group _
   ByVal dockSide As DockStyle _
)
[C#]
public void Add(
   Group targetGroup
   Group group
   DockStyle dockSide
);
[C++]
public: void Add(
   Group* targetGroup
   Group* group
   DockStyle* dockSide
);
[JScript]
public function Add(
   targetGroup : Group
   group : Group
   dockSide : DockStyle
);

Parameters

targetGroup
The Group control which will be splited. Apllicable when the parent control is Bar and appearance is set to ToolWindow.
group
The Group to add to the collection.
dockSide
Side in which group will be docked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Group, Group, bool, DockStyle, bool) Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Add (Group, Group, bool, DockStyle, bool) Method

Adds a new Group to the Bar.GroupCollection.

[Visual Basic]
Public Sub Add( _
   ByVal targetGroup As Group _
   ByVal group As Group _
   ByVal inner As Boolean _
   ByVal dockSide As DockStyle _
   ByVal propFromParent As Boolean _
)
[C#]
public void Add(
   Group targetGroup
   Group group
   bool inner
   DockStyle dockSide
   bool propFromParent
);
[C++]
public: void Add(
   Group* targetGroup
   Group* group
   bool* inner
   DockStyle* dockSide
   bool* propFromParent
);
[JScript]
public function Add(
   targetGroup : Group
   group : Group
   inner : Boolean
   dockSide : DockStyle
   propFromParent : Boolean
);

Parameters

targetGroup
The Group control which will be splited. Apllicable when the parent control is Bar and appearance is set to ToolWindow.
group
The Group to add to the collection.
inner
Permission for splitting the targetGroup .
dockSide
Side in which group will be docked.
propFromParent
Inheriths property values from the parent Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AddRange Method

Lidor Systems Collector Class Library

Bar.GroupCollection.AddRange Method

Adds an array of groups to the Bar.GroupCollection.

[Visual Basic]
Public Sub AddRange( _
   ByVal groups() As Group _
)
[C#]
public void AddRange(
   Group[] groups
);
[C++]
public: void AddRange(
   Group* groups[]
);
[JScript]
public function AddRange(
   groups : Group[]
);

Parameters

groups
An array of type Group that contains the groups to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of groups equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clear Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Clear Method

Removes all groups from the collection.

[Visual Basic]
Public Sub Clear()
[C#]
new public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Contains Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Contains Method

Determines whether the specified Group object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal group As Group _
) As Boolean
[C#]
public bool Contains(
   Group group
);
[C++]
public: bool Contains(
   Group* group
);
[JScript]
public function Contains(
   group : Group
) : Boolean;

Parameters

group
The Group to locate in the collection.

Return Value

true if the specified Group is in the collection; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of group is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IndexOf Method

Lidor Systems Collector Class Library

Bar.GroupCollection.IndexOf Method

Returns the index of the specified Group object in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal group As Group _
) As Integer
[C#]
public int IndexOf(
   Group group
);
[C++]
public: int IndexOf(
   Group* group
);
[JScript]
public function IndexOf(
   group : Group
) : int;

Parameters

group
The Group to locate in the collection.

Return Value

The zero-based index of the item found in the Bar.GroupCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RemoveAt Method

Lidor Systems Collector Class Library

Bar.GroupCollection.RemoveAt Method

RemoveAts the Group at the specified index of the Bar.GroupCollection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
new public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The 0-based index of the Group to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Remove Method

Lidor Systems Collector Class Library

Bar.GroupCollection.Remove Method

Removes a Group from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal group As Group _
)
[C#]
public void Remove(
   Group group
);
[C++]
public: void Remove(
   Group* group
);
[JScript]
public function Remove(
   group : Group
);

Parameters

group
The Group to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The group parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SetChildIndex Method

Lidor Systems Collector Class Library

Bar.GroupCollection.SetChildIndex Method

Sets the index of the specified Group in the collection to the specified index value.

[Visual Basic]
Public Sub SetChildIndex( _
   ByVal group As Group, _
   ByVal index As Integer _
)
[C#]
public void SetChildIndex(
   Group group,
   int index
);
[C++]
public: void SetChildIndex(
   Group* group,
   int index
);
[JScript]
public function SetChildIndex(
   group : Group,
   index : int
);

Parameters

group
The Group to search for.
index
The new index value of the Group.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Bar.GroupCollection Class | Bar.GroupCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CancelableCollectorEventArgs Class

Provides data for a cancelable event.

For a list of all members of this type, see CancelableCollectorEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.Collector.CancelableCollectorEventArgs

[Visual Basic]
Public Class CancelableCollectorEventArgs
   Inherits CancelEventArgs
[C#]
public class CancelableCollectorEventArgs : CancelEventArgs
[C++]
public __gc class CancelableCollectorEventArgs : public CancelEventArgs
[JScript]
public class CancelableCollectorEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A cancelable event is raised by a component when it is about to perform an action that can be canceled, such as the BarClosing event of a Bar control.

A CancelableCollectorEventArgs provides the Cancel property to indicate whether the event should be canceled.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CancelableCollectorEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CancelableCollectorEventArgs Members

CancelableCollectorEventArgs overview

Public Constructors

public constructor CancelableCollectorEventArgs Constructor Initializes a new instance of the CancelableCollectorEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property CollectorObject | Read-only property that returns the object associated with the CancelableCollectorEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CancelableCollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CancelableCollectorEventArgs Constructor

Initializes a new instance of the CancelableCollectorEventArgs class.

[Visual Basic]
Public Sub CancelableCollectorEventArgs( _
   ByVal value As Object _
)
[C#]
public CancelableCollectorEventArgs(
   object value
);
[C++]
public: CancelableCollectorEventArgs(
   Object* value
);
[JScript]
public function CancelableCollectorEventArgs(
   value : Object
);

Parameters

value

The object associated with this event. Can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CancelableCollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CancelableCollectorEventArgs Properties

The properties of the CancelableCollectorEventArgs class are listed here. For a complete list of CancelableCollectorEventArgs class members, see the CancelableCollectorEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property CollectorObject | Read-only property that returns the object associated with the CancelableCollectorEventArgs.

See Also

CancelableCollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorObject Property

Lidor Systems Collector Class Library

CancelableCollectorEventArgs.CollectorObject Property

Read-only property that returns the object associated with the CancelableCollectorEventArgs.

[Visual Basic]
Public ReadOnly Property CollectorObject As Object
[C#]
public object CollectorObject {get;}
[C++]
public: __property Object* get_CollectorObject();
[JScript]
public function get CollectorObject() : Object;

Property Value

The object can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CancelableCollectorEventArgs Class | CancelableCollectorEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDragEventArgs Class

Provides data for the DragOver events.

For a list of all members of this type, see CollectorDragEventArgs Members.

System.Object
System.EventArgs
LidorSystems.Collector.CollectorDragEventArgs

[Visual Basic]
Public Class CollectorDragEventArgs
   Inherits EventArgs
[C#]
public class CollectorDragEventArgs : EventArgs
[C++]
public __gc class CollectorDragEventArgs : public EventArgs
[JScript]
public class CollectorDragEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CollectorDragEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDragEventArgs Members

CollectorDragEventArgs overview

Public Constructors

public constructor CollectorDragEventArgs Constructor Initializes a new instance of the CollectorDragEventArgs class.

Public Properties

public property AllowDrop | Gets or sets whether drag-and-drop operations are allowed by the source of the drag event.
public property CollectorObject | Read-only property that returns the object associated with the CollectorDragEventArgs.
public property X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
public property Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectorDragEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDragEventArgs Constructor

Initializes a new instance of the CollectorDragEventArgs class.

[Visual Basic]
Public Sub CollectorDragEventArgs( _
   ByVal value As Object, _
   ByVal allowDrop As Boolean, _
   ByVal dragPoint As Point _
)
[C#]
public CollectorDragEventArgs(
   object value,
   bool allowDrop,
   Point dragPoint
);
[C++]
public: CollectorDragEventArgs(
   Object* value,
   bool allowDrop,
   Point dragPoint
);
[JScript]
public function CollectorDragEventArgs(
   value : Object,
   allowDrop : boolean,
   dragPoint : Point
);

Parameters

value

The object associated with this event. Can be any of the following:

Bar

Group

Page

allowDrop

Whether drop opeartion is allowed.

dragPoint

Position of mouse cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDragEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDragEventArgs Properties

The properties of the CollectorDragEventArgs class are listed here. For a complete list of CollectorDragEventArgs class members, see the CollectorDragEventArgs Members topic.

Public Properties

public property AllowDrop | Gets or sets whether drag-and-drop operations are allowed by the originator (or source) of the drag event.
public property CollectorObject | Read-only property that returns the object associated with the CollectorDragEventArgs.
public property X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
public property Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

CollectorDragEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDrop Property

Lidor Systems Collector Class Library

CollectorDragEventArgs.AllowDrop Property

Gets or sets whether drag-and-drop operations are allowed by the source of the drag event.

[Visual Basic]
Public Property AllowDrop As Boolean
[C#]
public bool AllowDrop { get; set; }
[C++]
public: __property bool get_AllowDrop();
public: __property void set_AllowDrop(bool);
[JScript]
public function get AllowDrop() : boolean
public function set AllowDrop(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDragEventArgs Class | CollectorDragEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorObject Property

Lidor Systems Collector Class Library

CollectorDragEventArgs.CollectorObject Property

Read-only property that returns the object associated with the CollectorDragEventArgs.

[Visual Basic]
Public ReadOnly Property CollectorObject As Object
[C#]
public object CollectorObject {get;}
[C++]
public: __property Object* get_CollectorObject();
[JScript]
public function get CollectorObject() : Object;

Property Value

The object can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDragEventArgs Class | CollectorDragEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


X Property

Lidor Systems Collector Class Library

CollectorDragEventArgs.X Property

Gets the x-coordinate of the mouse pointer, in screen coordinates.

[Visual Basic]
Public ReadOnly Property X As Integer
[C#]
public int X {get;}
[C++]
public: __property int get_X();
[JScript]
public function get X() : int;

Property Value

The x-coordinate of the mouse pointer in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDragEventArgs Class | CollectorDragEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Y Property

Lidor Systems Collector Class Library

CollectorDragEventArgs.Y Property

Gets the y-coordinate of the mouse pointer, in screen coordinates.

[Visual Basic]
Public ReadOnly Property Y As Integer
[C#]
public int Y {get;}
[C++]
public: __property int get_Y();
[JScript]
public function get Y() : int;

Property Value

The y-coordinate of the mouse pointer in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDragEventArgs Class | CollectorDragEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDropEventArgs Class

Provides data for the DragDrop events.

For a list of all members of this type, see CollectorDropEventArgs Members.

System.Object
System.EventArgs
LidorSystems.Collector.CollectorDropEventArgs

[Visual Basic]
Public Class CollectorDropEventArgs
   Inherits EventArgs
[C#]
public class CollectorDropEventArgs : EventArgs
[C++]
public __gc class CollectorDropEventArgs : public EventArgs
[JScript]
public class CollectorDropEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CollectorDropEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDropEventArgs Members

CollectorDropEventArgs overview

Public Constructors

public constructor CollectorDropEventArgs Constructor Initializes a new instance of the CollectorDropEventArgs class.

Public Properties

public property CollectorObject | Read-only property that returns the object associated with the CollectorDropEventArgs.
public property Index | Gets the index of the CollectorObject in the begging of drag&drop operations.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectorDropEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDropEventArgs Constructor

Initializes a new instance of the CollectorDropEventArgs class.

[Visual Basic]
Public Sub CollectorDropEventArgs( _
   ByVal value As Object, _
   ByVal index As Integer
)
[C#]
public CollectorDropEventArgs(
   object value
   int index,
);
[C++]
public: CollectorDropEventArgs(
   Object* value
   int index,
);
[JScript]
public function CollectorDropEventArgs(
   value : Object
   index : int,
);

Parameters

value

The object associated with this event. Can be any of the following:

Bar

Group

Page

index

The position of the control contained in the parent control collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDropEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDropEventArgs Properties

The properties of the CollectorDropEventArgs class are listed here. For a complete list of CollectorDropEventArgs class members, see the CollectorDropEventArgs Members topic.

Public Properties

public property CollectorObject | Read-only property that returns the object associated with the CollectorDropEventArgs.
public property Index | Gets the index of the CollectorObject in the begging of drag & drop operations.

See Also

CollectorDropEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorObject Property

Lidor Systems Collector Class Library

CollectorDropEventArgs.CollectorObject Property

Read-only property that returns the object associated with the CollectorDropEventArgs.

[Visual Basic]
Public ReadOnly Property CollectorObject As Object
[C#]
public object CollectorObject {get;}
[C++]
public: __property Object* get_CollectorObject();
[JScript]
public function get CollectorObject() : Object;

Property Value

The object can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDropEventArgs Class | CollectorDropEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Index Property

Lidor Systems Collector Class Library

CollectorDropEventArgs.Index Property

Gets the index of the CollectorObject in the begging of drag & drop operations.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorDropEventArgs Class | CollectorDropEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorEventArgs Class

Provides data for custom events from Bar, Group, Page controls.

For a list of all members of this type, see CollectorEventArgs Members.

System.Object
System.EventArgs
LidorSystems.Collector.CollectorEventArgs

[Visual Basic]
Public Class CollectorEventArgs
   Inherits CancelEventArgs
[C#]
public class CollectorEventArgs : CancelEventArgs
[C++]
public __gc class CollectorEventArgs : public CancelEventArgs
[JScript]
public class CollectorEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CollectorEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorEventArgs Members

CollectorEventArgs overview

Public Constructors

public constructor CollectorEventArgs Constructor Initializes a new instance of the CollectorEventArgs class.

Public Properties

public property CollectorObject Read-only property that returns the object associated with the CollectorEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorEventArgs Constructor

Initializes a new instance of the CollectorEventArgs class.

[Visual Basic]
Public Sub CollectorEventArgs( _
   ByVal value As Object _
)
[C#]
public CollectorEventArgs(
   object value
);
[C++]
public: CollectorEventArgs(
   Object* value
);
[JScript]
public function CollectorEventArgs(
   value : Object
);

Parameters

value

The object associated with this event. Can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorEventArgs Properties

The properties of the CollectorEventArgs class are listed here. For a complete list of CollectorEventArgs class members, see the CollectorEventArgs Members topic.

Public Properties

public property CollectorObject Read-only property that returns the object associated with the CollectorEventArgs.

See Also

CollectorEventArgs Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorObject Property

Lidor Systems Collector Class Library

CollectorEventArgs.CollectorObject Property

Read-only property that returns the object associated with the CollectorEventArgs.

[Visual Basic]
Public ReadOnly Property CollectorObject As Object
[C#]
public object CollectorObject {get;}
[C++]
public: __property Object* get_CollectorObject();
[JScript]
public function get CollectorObject() : Object;

Property Value

The object can be any of the following:

Bar

Group

Page

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollectorEventArgs Class | CollectorEventArgs Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Class

Group control represents container control that manages related set of Page controls.

For a list of all members of this type, see Group Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.Collector.Group

[Visual Basic]
Public Class Group
   Inherits Control
[C#]
public class Group : Control
[C++]
public __gc class Group : public Control
[JScript]
public class Group extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Members

Group overview

Public Constructors

public constructor Group Constructor Initializes a new instance of the Group class.

Public Properties

public property AcceptType | Gets or sets an enumeration that determine objects that can be accepted by the Group control.
public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDocking | Gets or sets an enumeration that determines the dock side on which control can be docked.
public property AllowDrag | Determines whether the Group control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowFloat | Determines whether the Group control can became floating window.
public property AllowReorder | Determines whether the Group control allow reordering of contained Page controls.
public property AllowResize | Determines whether the Group control can be resized.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property Animation | Gets or sets whether animation is used when expanding and collapsing the Group control.
public property AnimationSpeed | Gets or sets the speed of the animation when expanding and collapsing the Group control.
public property AutoHide | Determines whether the Group is auto-hiden to one side of the Form.
public property AutoHideOuterControl | Gets or sets the Control object representing the boundary control during autohide.
public property BackgroundImage | Overridden. See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle | Gets or sets the border style of the Group control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Gets or sets an enumeration that determines how the object will be closed.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ControlCondition | Gets or sets an enumeration that determines the current condition of the Group control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property ControlState | Gets or sets an enumeration that determines the current state of the Group control.
public property ControlType | Gets or sets an enumeration that determines the type of the Group control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property DockHintStyle | Gets or sets an enumeration that determines the docking hint style of the Group control.
public property DockStyle | Gets or sets an enumeration that determines on which edge the Group is docked in the parent Bar control.
public property DropAllowed | Determines whether other controls can be accepted by the Group control in drag-drop operations.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Gets or sets whether the Group is expanded.
public property FloatingLocation | Gets or sets the location of floating window created by the Group control.
public property FloatingSize | Gets or sets the size of the floating window created by the Group control.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusRectangle | Determines whether the Group control and contained controls will display dash rectangle when they receive focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Header | Gets or sets whether the header of the Group is visible.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the header of a Group control.
public property ImageIndex | Gets or sets the index to the image displayed inside the header of a Group control.
public property ImageList | Gets or sets the ImageList that contains the list of images used by the Pages.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property MinimumHeight | Gets or sets the minimum size of the Group control.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Pages | Gets the collection of Pages in this Group control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedPage | Gets or sets the selected Page.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the GroupStyle object representing the style of the Group control.
public property StyleFromParent | Determines whether the Group should use style from his parent (if it exists), to draw.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Gets or sets the way the Group tabs are sized.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStrip | Gets or sets whether tab strip is visible in the Group control.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Group control.
public property TransparentMode | Gets or sets the value indicating the Group control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Group control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Group control.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WindowState | Determines the window state of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
protected method Close | Closes the Group control.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetHeaderRect | Gets the rectangle of header of Group control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
protected method IsFloating | Determines if the Group control is floating.
protected method MakeControlFloat | Sets the Group control in floating window.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh | Overloaded. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the Group control.

Public Events

public event AutoHideChanged | Occurs after a Group change his state to AutoHide mode.
public event AutoHideChanging | Occurs before a Group change his state to AutoHide mode.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuButtonClick | Occurs when a ContextMenuButton is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlConditionChanged | Occurs when the control condition is changed.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event GroupClosed | Occurs when the Group is closed.
public event GroupClosing | Occurs when the Group is closing.
public event GroupCollapsed | Occurs after a Group is collapsed.
public event GroupCollapsing | Occurs before a Group is collapsed.
public event GroupDragging | Occurs before a Group has started dragging.
public event GroupDragOver | Occurs when a Group is dragged.
public event GroupDropped | Occurs after a Group has been dropped.
public event GroupExpanded | Occurs after a Group is expanded.
public event GroupExpanding | Occurs before a Group is expanded.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MaximizeButtonClick | Occurs when a MaximizeButton is clicked.
public event MinimizeButtonClick | Occurs when a MinimizeButton is clicked.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event PageAdded | Occurs after a Page is added.
public event PageAdding | Occurs before a Page is added.
public event PageClosed | Occurs when the Page is closed.
public event PageClosing | Occurs when the Page is closing.
public event PageDragging | Occurs before a Page has started dragging.
public event PageDragOver | Occurs when a Page is dragged.
public event PageDropped | Occurs after a Page has been dropped.
public event PageRemoved | Occurs after a Page is removed.
public event PageRemoving | Occurs before a Page is removed.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedPageChanged | Occurs after the SelectedPage changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabSelectButtonClick | Occurs when a TabSelectButton is clicked.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAutoHideChanged | Raises the AutoHideChanged event.
protected method OnAutoHideChanging | Raises the AutoHideChanging event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuButtonClick | Raises the ContextMenuButtonClick event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlConditionChanged | Raises the ControlConditionChanged event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnGroupClosed | Raises the GroupClosed event.
protected method OnGroupClosing | Raises the GroupClosing event.
protected method OnGroupCollapsed | Raises the GroupCollapsed event.
protected method OnGroupCollapsing | Raises the GroupCollapsing event.
protected method OnGroupDragging | Occurs before a Group control has started dragging.
protected method OnGroupDragOver | Occurs when a Group control is dragged.
protected method OnGroupDropped | Occurs after a Group control has been dropped.
protected method OnGroupExpanded | Raises the GroupExpanded event.
protected method OnGroupExpanding | Raises the GroupExpanding event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout | Overridden. Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMaximizeButtonClick | Raises the MaximizeButtonClick event.
protected method OnMinimizeButtonClick | Raises the MinimizeButtonClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnPageAdded | Occurs after a Page control has been added.
protected method OnPageAdding | Occurs before a Page control is added.
protected method OnPageClosed | Raises the PageClosed event.
protected method OnPageClosing | Raises the PageClosing event.
protected method OnPageDragging | Occurs before a Page control has started dragging.
protected method OnPageDragOver | Occurs when a Page control is dragged.
protected method OnPageDropped | Occurs after a Page control has been dropped.
protected method OnPageRemoved | Occurs after a Page control has been removed.
protected method OnPageRemoving | Occurs before a Page control is removed.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedPageChanged | Occurs after the SelectedPage changes.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabSelectButtonClick | Raises the TabSelectButtonClick event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RemoveAll | Removes all the Pages and additional controls from this Group control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

Group Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Constructor

Initializes a new instance of the Group class.

[Visual Basic]
Public Sub New()
[C#]
public Group();
[C++]
public: Group();
[JScript]
public function Group();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Properties

The properties of the Group class are listed here. For a complete list of Group class members, see the Group Members topic.

Public Properties

public property AcceptType | Gets or sets an enumeration that determine objects that can be accepted by the Group control.
public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDocking | Gets or sets an enumeration that determines the dock side on which control can be docked.
public property AllowDrag | Determines whether the Group control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowFloat | Determines whether the Group control can became floating window.
public property AllowReorder | Determines whether the Group control allow reordering of contained Page controls.
public property AllowResize | Determines whether the Group control can be resized.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property Animation | Gets or sets whether animation is used when expanding and collapsing the Group control.
public property AnimationSpeed | Gets or sets the speed of the animation when expanding and collapsing the Group control.
public property AutoHide | Determines whether the Group is auto-hiden to one side of the Form.
public property AutoHideOuterControl | Gets or sets the Control object representing the boundary control during autohide.
public property BackgroundImage | Overridden. See Control.BackgroundImage.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle | Gets or sets the border style of the Group control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Gets or sets an enumeration that determines how the object will be closed.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ControlCondition | Gets or sets an enumeration that determines the current condition of the Group control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property ControlState | Gets or sets an enumeration that determines the current state of the Group control.
public property ControlType | Gets or sets an enumeration that determines the type of the Group control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle(inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock | Overriden. Gets or sets which edge of the parent container a control is docked to.
public property DockHintStyle | Gets or sets an enumeration that determines the docking hint style of the Group control.
public property DockStyle | Gets or sets an enumeration that determines on which edge the Group is docked in the parent Bar control.
public property DropAllowed | Determines whether other controls can be accepted by the Group control in drag-drop operations.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Gets or sets whether the Group is expanded.
public property FloatingLocation | Gets or sets the location of floating window created by the Group control.
public property FloatingSize | Gets or sets the size of the floating window created by the Group control.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusRectangle | Determines whether the Group control and contained controls will display dash rectangle when they receive focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Header | Gets or sets whether the header of the Group is visible.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the header of a Group control.
public property ImageIndex | Gets or sets the index to the image displayed inside the header of a Group control.
public property ImageList | Gets or sets the ImageList that contains the list of images used by the Pages.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property MinimumHeight | Gets or sets the minimum size of the Group control.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Pages | Gets the collection of Pages in this Group control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedPage | Gets or sets the selected Page.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the GroupStyle object representing the style of the Group control.
public property StyleFromParent | Determines whether the Group should use style from his parent (if it exists), to draw.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Gets or sets the way the Group tabs are sized.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStrip | Gets or sets whether tab strip is visible in the Group control.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Group control.
public property TransparentMode | Gets or sets the value indicating the Group control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Group control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Group control.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WindowState | Determines the window state of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

Group Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AcceptType Property

Lidor Systems Collector Class Library

Group.AcceptType Property

Gets or sets an enumeration that determine objects that can be accepted by the Group control.

[Visual Basic]
Public Property AcceptType As AcceptType
[C#]
public AcceptType AcceptType {get; set;}
[C++]
public: __property AcceptType get_AcceptType();
public: __property void set_AcceptType(AcceptType);
[JScript]
public function get AcceptType() : AcceptType;
public function set AcceptType(AcceptType);

Property Value

The AcceptType assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDocking Property

Lidor Systems Collector Class Library

Group.AllowDocking Property

Gets or sets an enumeration that determines the dock side on which control can be docked.

[Visual Basic]
Public Property AllowDocking As DockPermission
[C#]
public DockPermission AllowDocking {get; set;}
[C++]
public: __property DockPermission get_AllowDocking();
public: __property void set_AllowDocking(DockPermission);
[JScript]
public function get AllowDocking() : DockPermission;
public function set AllowDocking(DockPermission);

Property Value

The DockPermission assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDrag Property

Lidor Systems Collector Class Library

Group.AllowDrag Property

Determines whether the Group control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowFloat Property

Lidor Systems Collector Class Library

Group.AllowFloat Property

Determines whether the Group control can became floating window.

[Visual Basic]
Public Property AllowFloat As Boolean
[C#]
public bool AllowFloat { get; set; }
[C++]
public: __property bool get_AllowFloat();
public: __property void set_AllowFloat(bool );
[JScript]
public function get AllowFloat() : bool
public function set AllowFloat(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowReorder Property

Lidor Systems Collector Class Library

Group.AllowReorder Property

Determines whether the Group control allow reordering of contained Page controls.

[Visual Basic]
Public Property AllowReorder As Boolean
[C#]
public bool AllowReorder { get; set; }
[C++]
public: __property bool get_AllowReorder();
public: __property void set_AllowReorder(bool );
[JScript]
public function get AllowReorder() : bool
public function set AllowReorder(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowResize Property

Lidor Systems Collector Class Library

Group.AllowResize Property

Determines whether the Group control can be resized.

[Visual Basic]
Public Property AllowResize As Boolean
[C#]
public bool AllowResize { get; set; }
[C++]
public: __property bool get_AllowResize();
public: __property void set_AllowResize(bool );
[JScript]
public function get AllowResize() : bool
public function set AllowResize(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Animation Property

Lidor Systems Collector Class Library

Group.Animation Property

Gets or sets whether animation is used when expanding and collapsing the Group control.

[Visual Basic]
Public Property Animation As Boolean
[C#]
public bool Animation { get; set; }
[C++]
public: __property bool get_Animation();
public: __property void set_Animation(bool);
[JScript]
public function get Animation() : boolean
public function set Animation(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AnimationSpeed Property

Lidor Systems Collector Class Library

Group.AnimationSpeed Property

Gets or sets the speed of the animation when expanding and collapsing the Group control.

[Visual Basic]
Public Property AnimationSpeed As AnimationSpeed
[C#]
public AnimationSpeed AnimationSpeed {get; set;}
[C++]
public: __property AnimationSpeed get_AnimationSpeed();
public: __property void set_AnimationSpeed(AnimationSpeed);
[JScript]
public function get AnimationSpeed() : AnimationSpeed;
public function set AnimationSpeed(AnimationSpeed);

Property Value

The AnimationSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHide Property

Lidor Systems Collector Class Library

Group.AutoHide Property

Determines whether the Group is auto-hiden to one side of the Form.

[Visual Basic]
Public Property AutoHide As Boolean
[C#]
public bool AutoHide { get; set; }
[C++]
public: __property bool get_AutoHide();
public: __property void set_AutoHide(bool );
[JScript]
public function get AutoHide() : bool
public function set AutoHide(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideOuterControl Property

Lidor Systems Collector Class Library

Group.AutoHideOuterControl Property

Gets or sets the Control object representing the boundary control during autohide.

[Visual Basic]
Public Property AutoHideOuterControl As Control
[C#]
public Control AutoHideOuterControl { get; set; }
[C++]
public: __property Control* get_AutoHideOuterControl();
public: __property void set_AutoHideOuterControl(Control* );
[JScript]
public function get AutoHideOuterControl() : Control
public function set AutoHideOuterControl(Control);

Property Value

A Control object that represents the boundary control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundImage Property

Lidor Systems Collector Class Library

Group.BackgroundImage Property

This member overrides Control.BackgroundImage.

[Visual Basic]
Overrides Public Property BackgroundImage As Image
[C#]
public override Image BackgroundImage {get; set;}
[C++]
public: __property Image* get_BackgroundImage();
public: __property void set_BackgroundImage(Image*);
[JScript]
public override function get BackgroundImage() : Image;
public override function set BackgroundImage(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BorderStyle Property

Lidor Systems Collector Class Library

Group.BorderStyle Property

Gets or sets the border style of the Group control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle);
[JScript]
public function get BorderStyle() : BorderStyle;
public function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle values. The default is BorderStyle.None.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseAction Property

Lidor Systems Collector Class Library

Group.CloseAction Property

Gets or sets an enumeration that determines how the object will be closed.

[Visual Basic]
Public Property CloseAction As CloseAction
[C#]
public CloseAction CloseAction {get; set;}
[C++]
public: __property CloseAction get_CloseAction();
public: __property void set_CloseAction(CloseAction);
[JScript]
public function get CloseAction() : CloseAction;
public function set CloseAction(CloseAction);

Property Value

The CloseAction assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlCondition Property

Lidor Systems Collector Class Library

Group.ControlCondition Property

Gets an enumeration that determines the current condition of the Group control.

[Visual Basic]
Public Property ControlCondition As ControlCondition
[C#]
public ControlCondition ControlCondition {get; set;}
[C++]
public: __property ControlCondition get_ControlCondition();
public: __property void set_ControlCondition(ControlCondition);
[JScript]
public function get ControlCondition() : ControlCondition;
public function set ControlCondition(ControlCondition);

Property Value

The ControlCondition assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlState Property

Lidor Systems Collector Class Library

Group.ControlState Property

Gets or sets an enumeration that determines the current state of the Group control.

[Visual Basic]
Public Property ControlState As ControlState
[C#]
public ControlState ControlState {get; set;}
[C++]
public: __property ControlState get_ControlState();
public: __property void set_ControlState(ControlState);
[JScript]
public function get ControlState() : ControlState;
public function set ControlState(ControlState);

Property Value

The ControlState assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlType Property

Lidor Systems Collector Class Library

Group.ControlType Property

Gets or sets an enumeration that determines the type of the Group control.

[Visual Basic]
Public Property ControlType As ControlType
[C#]
public ControlType ControlType {get; set;}
[C++]
public: __property ControlType get_ControlType();
public: __property void set_ControlType(ControlType);
[JScript]
public function get ControlType() : ControlType;
public function set ControlType(ControlType);

Property Value

The ControlType assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DefaultSize Property

Lidor Systems Collector Class Library

Group.DefaultSize Property

This member overrides Control.DefaultSize.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override Size DefaultSize {get;}
[C++]
protected: __property Size get_DefaultSize();
[JScript]
protected override function get DefaultSize() : Size;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dock Property

Lidor Systems Collector Class Library

Group.Dock Property

This member overrides Control.Dock.

[Visual Basic]
Public Overridable Property Dock As DockStyle
[C#]
public virtual DockStyle Dock {get; set;}
[C++]
public: __property virtual DockStyle get_Dock();
public: __property virtual void set_Dock(DockStyle);
[JScript]
public function get Dock() : DockStyle;
public function set Dock(DockStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DockHintStyle Property

Lidor Systems Collector Class Library

Group.DockHintStyle Property

Gets or sets an enumeration that determines the docking hint style of the Group control.

[Visual Basic]
Public Property DockHintStyle As DockHintStyle
[C#]
public DockHintStyle DockHintStyle {get; set;}
[C++]
public: __property DockHintStyle get_DockHintStyle();
public: __property void set_DockHintStyle(DockHintStyle);
[JScript]
public function get DockHintStyle() : DockHintStyle;
public function set DockHintStyle(DockHintStyle);

Property Value

The DockHintStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DockStyle Property

Lidor Systems Collector Class Library

Group.DockStyle Property

Gets or sets an enumeration that determines on which edge the Group is docked in the parent Bar control.

[Visual Basic]
Public Property DockStyle As DockStyle
[C#]
public DockStyle DockStyle {get; set;}
[C++]
public: __property DockStyle get_DockStyle();
public: __property void set_DockStyle(DockStyle);
[JScript]
public function get DockStyle() : DockStyle;
public function set DockStyle(DockStyle);

Property Value

The DockStyle assigned to the control.

Remarks

Only valid when the parent Bar control has style with Appearance property value set to ToolWindow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DropAllowed Property

Lidor Systems Collector Class Library

Group.DropAllowed Property

Determines whether other controls can be accepted by the Group control in drag-drop operations.

[Visual Basic]
Public Property DropAllowed As Boolean
[C#]
public bool DropAllowed { get; set; }
[C++]
public: __property bool get_DropAllowed();
public: __property void set_DropAllowed(bool );
[JScript]
public function get DropAllowed() : bool
public function set DropAllowed(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Expanded Property

Lidor Systems Collector Class Library

Group.Expanded Property

Gets or sets whether the Group is expanded.

[Visual Basic]
Public Property Expanded As Boolean
[C#]
public bool Expanded { get; set; }
[C++]
public: __property bool get_Expanded();
public: __property void set_Expanded(bool );
[JScript]
public function get Expanded() : bool
public function set Expanded(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FloatingLocation Property

Lidor Systems Collector Class Library

Group.FloatingLocation Property

Gets or sets the location of floating window created by the Group control.

[Visual Basic]
Public Property FloatingLocation As Point
[C#]
public Point FloatingLocation { get; set; }
[C++]
public: __property Point get_FloatingLocation();
public: __property void set_FloatingLocation(Point);
[JScript]
public function get FloatingLocation() : Point
public function set FloatingLocation(Point);

Property Value

The Point that represents the location of floating window.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Size Property

Lidor Systems Collector Class Library

Group.FloatingSize Property

Gets or sets the size of the floating window created by the Group control.

[Visual Basic]
Public Property FloatingSize As Size
[C#]
public Size FloatingSize { get; set; }
[C++]
public: __property Size get_FloatingSize();
public: __property void set_FloatingSize(Size);
[JScript]
public function get FloatingSize() : Size
public function set FloatingSize(Size);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FocusRectangle Property

Lidor Systems Collector Class Library

Group.FocusRectangle Property

Determines whether the Group control and contained controls will display dash rectangle when they receive focus.

[Visual Basic]
Public Property FocusRectangle As Boolean
[C#]
public bool FocusRectangle { get; set; }
[C++]
public: __property bool get_FocusRectangle();
public: __property void set_FocusRectangle(bool );
[JScript]
public function get FocusRectangle() : bool
public function set FocusRectangle(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Header Property

Lidor Systems Collector Class Library

Group.Header Property

Gets or sets whether the header of the Group is visible.

[Visual Basic]
Public Property Header As Boolean
[C#]
public bool Header { get; set; }
[C++]
public: __property bool get_Header();
public: __property void set_Header(bool );
[JScript]
public function get Header() : bool
public function set Header(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Image Property

Lidor Systems Collector Class Library

Group.Image Property

Specifies the image object inside the header of a Group control.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Property Value

The Image assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageIndex Property

Lidor Systems Collector Class Library

Group.ImageIndex Property

Gets or sets the index to the image displayed inside the header of a Group.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

The zero-based index to the image in the ImageList that appears on the Group. The default is -1, which signifies no image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageList Property

Lidor Systems Collector Class Library

Group.ImageList Property

Gets or sets the ImageList that contains that contains the list of images used by the Pages.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Property Value

An ImageList that specifies the images to display on tabs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MinimumHeight Property

Lidor Systems Collector Class Library

Group.MinimumHeight Property

Gets or sets the minimum height the Group control can be resized to.

[Visual Basic]
Public Property MinimumHeight As Integer
[C#]
public int MinimumHeight {get; set;}
[C++]
public: __property int get_MinimumHeight();
public: __property void set_MinimumHeight(int);
[JScript]
public function get MinimumHeight() : int;
public function set MinimumHeight(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Remarks

Used only when the parent is Bar control and Appearance property value is set to ControlAppearance.Vertical.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Pages Property

Lidor Systems Collector Class Library

Group.Pages Property

Gets the collection of Pages in this Group control.

[Visual Basic]
Public ReadOnly Property Pages As Group.PageCollection
[C#]
public Group.PageCollection Pages {get;}
[C++]
public: __property Group.PageCollection* get_Pages();
[JScript]
public function get Pages() : Group.PageCollection;

Property Value

A Group.PageCollection that contains the Page objects in this Group.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedPage Property

Lidor Systems Collector Class Library

Group.SelectedPage Property

Gets or sets the currently-selected Page.

[Visual Basic]
Public Property SelectedPage As Page
[C#]
public Page SelectedPage {get; set;}
[C++]
public: __property Page* get_SelectedPage();
public: __property void set_SelectedPage(Page*);
[JScript]
public function get SelectedPage() : Page;
public function set SelectedPage(Page);

Property Value

A Page that represents the selected page. If no page is selected, the value is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Style Property

Lidor Systems Collector Class Library

Group.Style Property

Gets or sets the GroupStyle object representing the style of the Group control.

[Visual Basic]
Public Property Style As GroupStyle
[C#]
public GroupStyle Style { get; set; }
[C++]
public: __property GroupStyle* get_Style();
public: __property void set_Style(GroupStyle* );
[JScript]
public function get Style() : GroupStyle
public function set Style(GroupStyle);

Property Value

GroupStyle object represents the style of the Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


StyleFromParent Property

Lidor Systems Collector Class Library

Group.StyleFromParent Property

Determines whether the Group should use style from his parent (if it exists), to draw.

[Visual Basic]
Public Property StyleFromParent As Boolean
[C#]
public bool StyleFromParent { get; set; }
[C++]
public: __property bool get_StyleFromParent();
public: __property void set_StyleFromParent(bool );
[JScript]
public function get StyleFromParent() : bool
public function set StyleFromParent(bool);

Property Value

True if the Group uses style from his parent to draw; otherwise False, which creates new GroupStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabMode Property

Lidor Systems Collector Class Library

Group.TabMode Property

Gets or sets the way the Group tabs are sized.

[Visual Basic]
Public Property TabMode As TabMode
[C#]
public TabMode TabMode {get; set;}
[C++]
public: __property TabMode get_TabMode();
public: __property void set_TabMode(TabMode);
[JScript]
public function get TabMode() : TabMode;
public function set TabMode(TabMode);

Property Value

One of the TabMode values. The default is AutoSized.

Exceptions

Exception Type | Condition
InvalidEnumArgumentException | The property value is not a valid TabMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStrip Property

Lidor Systems Collector Class Library

Group.TabStrip Property

Gets or sets whether tab strip is visible in the Group control.

[Visual Basic]
Public Property TabStrip As Boolean
[C#]
public bool TabStrip { get; set; }
[C++]
public: __property bool get_TabStrip();
public: __property void set_TabStrip(bool);
[JScript]
public function get TabStrip() : boolean
public function set TabStrip(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Transparency Property

Lidor Systems Collector Class Library

Group.Transparency Property

A value specifying the level of transparency of the Group control.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}
[C++]
public: __property int get_Transparency();
public: __property void set_Transparency(int);
[JScript]
public function get Transparency() : int;
public function set Transparency(int);

Property Value

Transparency is in percentage, so the value can be from 0 to 100. Default setting is 50.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TransparentMode Property

Lidor Systems Collector Class Library

Group.TransparentMode Property

Determines whether the Group background will be transparent.

[Visual Basic]
Public Property TransparentMode As Boolean
[C#]
public bool TransparentMode { get; set; }
[C++]
public: __property bool get_TransparentMode();
public: __property void set_TransparentMode(bool );
[JScript]
public function get TransparentMode() : bool
public function set TransparentMode(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UseTheme Property

Lidor Systems Collector Class Library

Group.UseTheme Property

Determines whether the Group control will render according to current system theme and color scheme.

[Visual Basic]
Public Property UseTheme As Boolean
[C#]
public bool UseTheme { get; set; }
[C++]
public: __property bool get_UseTheme();
public: __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VisualStyle Property

Lidor Systems Collector Class Library

Group.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the Group control.

[Visual Basic]
Public Property VisualStyle As VisualStyle
[C#]
public VisualStyle VisualStyle {get; set;}
[C++]
public: __property VisualStyle get_VisualStyle();
public: __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


WindowState Property

Lidor Systems Collector Class Library

Group.WindowState Property

Gets or sets an enumeration that determines the window state of the control.

[Visual Basic]
Public Property WindowState As FormWindowState
[C#]
public FormWindowState WindowState {get; set;}
[C++]
public: __property FormWindowState get_WindowState();
public: __property void set_WindowState(FormWindowState);
[JScript]
public function get WindowState() : FormWindowState;
public function set WindowState(FormWindowState);

Property Value

The FormWindowState that represents the window state of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Close Method

Lidor Systems Collector Class Library

Group.Close Method

Closes the Group control.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

Remarks

When a Group control is closed, all resources created within the object are closed and the Group control is disposed. You can prevent the closing of a Group control at run time by handling the GroupClosing event and setting the Cancel property of the CancelableCollectorEventArgs passed as a parameter to your event-handling method.

CAUTION When you drag&drop or move child Page controls, the Close method may be called if the parent Group control doesn't contain any Page control. To prevent disposing of a Group control at run time you must handle the GroupClosing event, set the Cancel property to TRUE and use the Control.Hide method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose Method

Lidor Systems Collector Class Library

Group.Dispose Method

Overload List

Releases all resources used by the System.ComponentModel.Component.

[Visual Basic] Overloads Overrides Protected Sub Dispose(Boolean)
[C#] protected override void Dispose(bool);
[C++] protected: void Dispose(bool);
[JScript] protected override function Dispose(Boolean);

Exits edit mode and cleans up any resources being used.

[Visual Basic] Overloads Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#] public virtual void Dispose();
[C++] public: virtual void Dispose();
[JScript] public function Dispose();

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose () Method

Lidor Systems Collector Class Library

Group.Dispose () Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose (Boolean) Method

Lidor Systems Collector Class Library

Group.Dispose (Boolean) Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);
[C++]
protected: void Dispose(
   bool disposing
);
[JScript]
protected override function Dispose(
   disposing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GetHeaderRect Method

Lidor Systems Collector Class Library

Group.GetHeaderRect Method

Gets the rectangle of header of Group control.

[Visual Basic]
Public Function GetHeaderRect() As Rectangle
[C#]
public Rectangle GetHeaderRect();
[C++]
public: Rectangle GetHeaderRect();
[JScript]
public function GetHeaderRect() : Rectangle;

Return Value

A Rectangle that represents the space reserved for header of the Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IsFloating Method

Lidor Systems Collector Class Library

Group.IsFloating Method

Determines if the Group control is floating.

[Visual Basic]
Public Function IsFloating() As Boolean
[C#]
public bool IsFloating();
[C++]
public: bool IsFloating();
[JScript]
public function IsFloating() : Boolean;

Return Value

true if the Group control is floating; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MakeControlFloat Method

Lidor Systems Collector Class Library

Group.MakeControlFloat Method

Sets the Group control in floating window.

[Visual Basic]
Public Sub MakeControlFloat()
[C#]
public void MakeControlFloat();
[C++]
public: void MakeControlFloat();
[JScript]
public function MakeControlFloat();

Remarks

In order to create floating window, control must have AllowFloat property value set to True. When calling this function, the ControlState property is automatically changed to Floating value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnContextMenuButtonClick Method

Lidor Systems Collector Class Library

Group.OnContextMenuButtonClick Method

Occurs when a ContextMenuButton is clicked.

[Visual Basic]
Protected Overridable Sub OnContextMenuButtonClick( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnContextMenuButtonClick(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnContextMenuButtonClick(
   CollectorEventArgs* e
);
[JScript]
protected function OnContextMenuButtonClick(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnControlConditionChanged Method

Lidor Systems Collector Class Library

Group.OnControlConditionChanged Method

Occurs when the control condition is changed.

[Visual Basic]
Protected Overridable Sub OnControlConditionChanged( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnControlConditionChanged(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnControlConditionChanged(
   CollectorEventArgs* e
);
[JScript]
protected function OnControlConditionChanged(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupClosed Method

Lidor Systems Collector Class Library

Group.OnGroupClosed Method

Raises the GroupClosed event.

[Visual Basic]
Protected Overridable Sub OnGroupClosed( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupClosed(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupClosed(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupClosed(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupClosed in a derived class, be sure to call the base class's OnGroupClosed method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupCollapsed Method

Lidor Systems Collector Class Library

Group.OnGroupCollapsed Method

Raises the GroupCollapsed event.

[Visual Basic]
Protected Overridable Sub OnGroupCollapsed( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupCollapsed(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupCollapsed(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupCollapsed(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupCollapsed in a derived class, be sure to call the base class's OnGroupCollapsed method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupCollapsing Method

Lidor Systems Collector Class Library

Group.OnGroupCollapsing Method

Raises the GroupCollapsing event.

[Visual Basic]
Protected Overridable Sub OnGroupCollapsing( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupCollapsing(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupCollapsing(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupCollapsing(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupCollapsing in a derived class, be sure to call the base class's OnGroupCollapsing method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDragging Method

Lidor Systems Collector Class Library

Group.OnGroupDragging Method

Occurs before a Group control has started dragging.

[Visual Basic]
Protected Overridable Sub OnGroupDragging( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupDragging(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupDragging(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupDragging(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDragging in a derived class, be sure to call the base class's OnGroupDragging method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDragOver Method

Lidor Systems Collector Class Library

Group.OnGroupDragOver Method

Occurs when a Group control is dragged.

[Visual Basic]
Protected Overridable Sub OnGroupDragOver( _
   ByVal de As CollectorDragEventArgs _
)
[C#]
protected virtual void OnGroupDragOver(
   CollectorDragEventArgs de
);
[C++]
protected: virtual void OnGroupDragOver(
   CollectorDragEventArgs* de
);
[JScript]
protected function OnGroupDragOver(
   de : CollectorDragEventArgs
);

Parameters

de
A CollectorDragEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDragOver in a derived class, be sure to call the base class's OnGroupDragOver method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupDropped Method

Lidor Systems Collector Class Library

Group.OnGroupDropped Method

Occurs after a Group control has been dropped.

[Visual Basic]
Protected Overridable Sub OnGroupDropped( _
   ByVal de As CollectorDropEventArgs _
)
[C#]
protected virtual void OnGroupDropped(
   CollectorDropEventArgs de
);
[C++]
protected: virtual void OnGroupDropped(
   CollectorDropEventArgs* de
);
[JScript]
protected function OnGroupDropped(
   de : CollectorDropEventArgs
);

Parameters

de
A CollectorDropEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupDropped in a derived class, be sure to call the base class's OnGroupDropped method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupExpanded Method

Lidor Systems Collector Class Library

Group.OnGroupExpanded Method

Raises the GroupExpanded event.

[Visual Basic]
Protected Overridable Sub OnGroupExpanded( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnGroupExpanded(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnGroupExpanded(
   CollectorEventArgs* e
);
[JScript]
protected function OnGroupExpanded(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupExpanded in a derived class, be sure to call the base class's OnGroupExpanded method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupExpanding Method

Lidor Systems Collector Class Library

Group.OnGroupExpanding Method

Raises the GroupExpanding event.

[Visual Basic]
Protected Overridable Sub OnGroupExpanding( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupExpanding(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupExpanding(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupExpanding(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupExpanding in a derived class, be sure to call the base class's OnGroupExpanding method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnLayout Method

Lidor Systems Collector Class Library

Group.OnLayout Method

This member overrides Control.OnLayout

[Visual Basic]
Overrides Protected Sub OnLayout( _
   ByVal levent As LayoutEventArgs _
)
[C#]
protected override void OnLayout(
   LayoutEventArgs levent
);
[C++]
protected: void OnLayout(
   LayoutEventArgs* levent
);
[JScript]
protected override function OnLayout(
   levent : LayoutEventArgs
);

Parameters

levent
A LayoutEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageAdded Method

Lidor Systems Collector Class Library

Group.OnPageAdded Method

Occurs after a Page control has been added.

[Visual Basic]
Protected Overridable Sub OnPageAdded( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnPageAdded(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnPageAdded(
   CollectorEventArgs* e
);
[JScript]
protected function OnPageAdded(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageAdding Method

Lidor Systems Collector Class Library

Group.OnPageAdding Method

Occurs before a Page control is added.

[Visual Basic]
Protected Overridable Sub OnPageAdding( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnPageAdding(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnPageAdding(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnPageAdding(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageClosed Method

Lidor Systems Collector Class Library

Group.OnPageClosed Method

Raises the PageClosed event.

[Visual Basic]
Protected Overridable Sub OnPageClosed( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnPageClosed(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnPageClosed(
   CollectorEventArgs* e
);
[JScript]
protected function OnPageClosed(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageClosed in a derived class, be sure to call the base class's OnPageClosed method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageClosing Method

Lidor Systems Collector Class Library

Group.OnPageClosing Method

Raises the PageClosing event.

[Visual Basic]
Protected Overridable Sub OnPageClosing( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnPageClosing(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnPageClosing(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnPageClosing(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageClosing in a derived class, be sure to call the base class's OnPageClosing method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageDragging Method

Lidor Systems Collector Class Library

Group.OnPageDragging Method

Occurs before a Page control has started dragging.

[Visual Basic]
Protected Overridable Sub OnPageDragging( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnPageDragging(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnPageDragging(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnPageDragging(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageDragging in a derived class, be sure to call the base class's OnPageDragging method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageDragOver Method

Lidor Systems Collector Class Library

Group.OnPageDragOver Method

Occurs when a Page control is dragged.

[Visual Basic]
Protected Overridable Sub OnPageDragOver( _
   ByVal de As CollectorDragEventArgs _
)
[C#]
protected virtual void OnPageDragOver(
   CollectorDragEventArgs de
);
[C++]
protected: virtual void OnPageDragOver(
   CollectorDragEventArgs* de
);
[JScript]
protected function OnPageDragOver(
   de : CollectorDragEventArgs
);

Parameters

de
A CollectorDragEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageDragOver in a derived class, be sure to call the base class's OnPageDragOver method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageDropped Method

Lidor Systems Collector Class Library

Group.OnPageDropped Method

Occurs after a Page control has been dropped.

[Visual Basic]
Protected Overridable Sub OnPageDropped( _
   ByVal de As CollectorDropEventArgs _
)
[C#]
protected virtual void OnPageDropped(
   CollectorDropEventArgs de
);
[C++]
protected: virtual void OnPageDropped(
   CollectorDropEventArgs* de
);
[JScript]
protected function OnPageDropped(
   de : CollectorDropEventArgs
);

Parameters

de
A CollectorDropEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageDropped in a derived class, be sure to call the base class's OnPageDropped method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageRemoved Method

Lidor Systems Collector Class Library

Group.OnPageRemoved Method

Occurs after a Page control has been removed.

[Visual Basic]
Protected Overridable Sub OnPageRemoved( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnPageRemoved(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnPageRemoved(
   CollectorEventArgs* e
);
[JScript]
protected function OnPageRemoved(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageRemoving Method

Lidor Systems Collector Class Library

Group.OnPageRemoving Method

Occurs before a Page control is removed.

[Visual Basic]
Protected Overridable Sub OnPageRemoving( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnPageRemoving(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnPageRemoving(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnPageRemoving(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnResize Method

Lidor Systems Collector Class Library

Group.OnResize Method

This member overrides Control.OnResize.

[Visual Basic]
Overrides Protected Sub OnResize( _
   ByVal e As EventArgs _
)
[C#]
protected override void OnResize(
   EventArgs e
);
[C++]
protected: void OnResize(
   EventArgs* e
);
[JScript]
protected override function OnResize(
   e : EventArgs
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnSelectedPageChanged Method

Lidor Systems Collector Class Library

Group.OnSelectedPageChanged Method

Occurs after the SelectedPage changes.

[Visual Basic]
Protected Overridable Sub OnSelectedPageChanged( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnSelectedPageChanged(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnSelectedPageChanged(
   CollectorEventArgs* e
);
[JScript]
protected function OnSelectedPageChanged(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ProcessCmdKey Method

Lidor Systems Collector Class Library

Group.ProcessCmdKey Method

This member overrides Control.ProcessCmdKey

[Visual Basic]
Overrides Protected Function ProcessCmdKey( _
   ByRef msg As Message, _
   ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
);
[C++]
protected: bool ProcessCmdKey(
   Message* msg,
   Keys keyData
);
[JScript]
protected override function ProcessCmdKey(
   msg : Message,
   keyData : Keys
) : Boolean;

Parameters

msg
A Message, passed by reference, that represents the window message to process.
keyData
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Refresh Method

Lidor Systems Collector Class Library

Group.Refresh Method

This member overrides Control.Refresh

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();
[C++]
public: void Refresh();
[JScript]
public override function Refresh();

Remarks

Notes to Inheritors: When overriding Refresh in a derived class, be sure to call the base class's Refresh method so the control and its child controls are invalidated and redrawn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RemoveAll Method

Lidor Systems Collector Class Library

Group.RemoveAll Method

Removes all the Pages and additional controls from this Group control.

[Visual Basic]
Protected Sub RemoveAll()
[C#]
protected void RemoveAll();
[C++]
protected: void RemoveAll();
[JScript]
protected function RemoveAll();

Remarks

All controls are removed through the Pages property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UpdateLayout Method

Lidor Systems Collector Class Library

Group.UpdateLayout Method

Update layout logic of the Group control.

[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[JScript]
public function UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Events

The events of the Group class are listed here. For a complete list of Group class members, see the Group Members topic.

Public Events

public event AutoHideChanged | Occurs after a Group change his state to AutoHide mode.
public event AutoHideChanging | Occurs before a Group change his state to AutoHide mode.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuButtonClick | Occurs when a ContextMenuButton is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlConditionChanged | Occurs when the control condition is changed.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event GroupClosed | Occurs when the Group is closed.
public event GroupClosing | Occurs when the Group is closing.
public event GroupCollapsed | Occurs after a Group is collapsed.
public event GroupCollapsing | Occurs before a Group is collapsed.
public event GroupDragging | Occurs before a Group has started dragging.
public event GroupDragOver | Occurs when a Group is dragged.
public event GroupDropped | Occurs after a Group has been dropped.
public event GroupExpanded | Occurs after a Group is expanded.
public event GroupExpanding | Occurs before a Group is expanded.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MaximizeButtonClick | Occurs when a MaximizeButton is clicked.
public event MinimizeButtonClick | Occurs when a MinimizeButton is clicked.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event PageAdded | Occurs after a Page is added.
public event PageAdding | Occurs before a Page is added.
public event PageClosed | Occurs when the Page is closed.
public event PageClosing | Occurs when the Page is closing.
public event PageDragging | Occurs before a Page has started dragging.
public event PageDragOver | Occurs when a Page is dragged.
public event PageDropped | Occurs after a Page has been dropped.
public event PageRemoved | Occurs after a Page is removed.
public event PageRemoving | Occurs before a Page is removed.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedPageChanged | Occurs after the SelectedPage changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabSelectButtonClick | Occurs when a TabSelectButton is clicked.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

Group Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideChanged Event

Lidor Systems Collector Class Library

Group.AutoHideChanged Event

Occurs after a Group change his state to AutoHide mode.

[Visual Basic]
Public Event AutoHideChanged As CollectorEventHandler
[C#]
public event CollectorEventHandler AutoHideChanged;
[C++]
public: __event CollectorEventHandler* AutoHideChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideChanging Event

Lidor Systems Collector Class Library

Group.AutoHideChanging Event

Occurs before a Group change his state to AutoHide mode.

[Visual Basic]
Public Event AutoHideChanging As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler AutoHideChanging;
[C++]
public: __event CancelableCollectorEventHandler* AutoHideChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButtonClick Event

Lidor Systems Collector Class Library

Group.ContextMenuButtonClick Event

Occurs when a ContextMenuButton is clicked.

[Visual Basic]
Public Event ContextMenuButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler ContextMenuButtonClick;
[C++]
public: __event CollectorEventHandler* ContextMenuButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlConditionChanged Event

Lidor Systems Collector Class Library

Group.ControlConditionChanged Event

Occurs when the control condition is changed.

[Visual Basic]
Public Event ControlConditionChanged As CollectorEventHandler
[C#]
public event CollectorEventHandler ControlConditionChanged;
[C++]
public: __event CollectorEventHandler* ControlConditionChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupClosed Event

Lidor Systems Collector Class Library

Group.GroupClosed Event

Occurs when the Group is closed.

[Visual Basic]
Public Event GroupClosed As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupClosed;
[C++]
public: __event CollectorEventHandler* GroupClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

This event occurs after the Group control has been closed by the user. To prevent a control from closing, handle the GroupClosing event and set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

You can use this event to perform tasks such as freeing resources used by the Group control and to save information entered in the Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupClosing Event

Lidor Systems Collector Class Library

Group.GroupClosing Event

Occurs when the Group is closing.

[Visual Basic]
Public Event GroupClosing As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupClosing;
[C++]
public: __event CancelableCollectorEventHandler* GroupClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

The GroupClosing event occurs as the Group control is being closed. When a control is closed, all resources created within the object are released and the control is disposed. If you cancel this event, the control remains opened. To cancel the closure of a control, set the Cancel property of the CancelableCollectorEventArgs passed to your event handler to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupCollapsed Event

Lidor Systems Collector Class Library

Group.GroupCollapsed Event

Occurs after a Group is collapsed.

[Visual Basic]
Public Event GroupCollapsed As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupCollapsed;
[C++]
public: __event CollectorEventHandler* GroupCollapsed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

Use the GroupCollapsing event if you want to validate and cancel the collapse of the Group.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupCollapsing Event

Lidor Systems Collector Class Library

Group.GroupCollapsing Event

Occurs before a Group is collapsed.

[Visual Basic]
Public Event GroupCollapsing As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupCollapsing;
[C++]
public: __event CancelableCollectorEventHandler* GroupCollapsing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

Use this event to validate the Group that is going to be collapsed. To prevent a group from collapsing, set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDragging Event

Lidor Systems Collector Class Library

Group.GroupDragging Event

Occurs before a Group has started dragging.

[Visual Basic]
Public Event GroupDragging As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupDragging;
[C++]
public: __event CancelableCollectorEventHandler* GroupDragging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDragOver Event

Lidor Systems Collector Class Library

Group.GroupDragOver Event

Occurs when a Group is dragged.

[Visual Basic]
Public Event GroupDragOver As CollectorDragEventHandler
[C#]
public event CollectorDragEventHandler GroupDragOver;
[C++]
public: __event CollectorDragEventHandler* GroupDragOver;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDragEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupDropped Event

Lidor Systems Collector Class Library

Group.GroupDropped Event

Occurs after a Group has been dropped.

[Visual Basic]
Public Event GroupDropped As CollectorDropEventHandler
[C#]
public event CollectorDropEventHandler GroupDropped;
[C++]
public: __event CollectorDropEventHandler* GroupDropped;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDropEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupExpanded Event

Lidor Systems Collector Class Library

Group.GroupExpanded Event

Occurs after a Group is expanded.

[Visual Basic]
Public Event GroupExpanded As CollectorEventHandler
[C#]
public event CollectorEventHandler GroupExpanded;
[C++]
public: __event CollectorEventHandler* GroupExpanded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

Use the GroupExpanding event if you want to validate and cancel the expand of the Group.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupExpanding Event

Lidor Systems Collector Class Library

Group.GroupExpanding Event

Occurs before a Group is expanded.

[Visual Basic]
Public Event GroupExpanding As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler GroupExpanding;
[C++]
public: __event CancelableCollectorEventHandler* GroupExpanding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

Use this event to validate the Group that is going to be expanded. To prevent a group from expanding, set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MaximizeButtonClick Event

Lidor Systems Collector Class Library

Group.MaximizeButtonClick Event

Occurs when a MaximizeButton is clicked.

[Visual Basic]
Public Event MaximizeButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler MaximizeButtonClick;
[C++]
public: __event CollectorEventHandler* MaximizeButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MinimizeButtonClick Event

Lidor Systems Collector Class Library

Group.MinimizeButtonClick Event

Occurs when a MinimizeButton is clicked.

[Visual Basic]
Public Event MinimizeButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler MinimizeButtonClick;
[C++]
public: __event CollectorEventHandler* MinimizeButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageAdded Event

Lidor Systems Collector Class Library

Group.PageAdded Event

Occurs after a Page is added.

[Visual Basic]
Public Event PageAdded As CollectorEventHandler
[C#]
public event CollectorEventHandler PageAdded;
[C++]
public: __event CollectorEventHandler* PageAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageAdding Event

Lidor Systems Collector Class Library

Group.PageAdding Event

Occurs before a Page is added.

[Visual Basic]
Public Event PageAdding As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler PageAdding;
[C++]
public: __event CancelableCollectorEventHandler* PageAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageClosed Event

Lidor Systems Collector Class Library

Group.PageClosed Event

Occurs when the Page is closed.

[Visual Basic]
Public Event PageClosed As CollectorEventHandler
[C#]
public event CollectorEventHandler PageClosed;
[C++]
public: __event CollectorEventHandler* PageClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Remarks

This event occurs after the Page control has been closed by the user. To prevent a control from closing, handle the PageClosing event and set the Cancel property of the CancelableCollectorEventArgs passed to your event-handling method to true.

You can use this event to perform tasks such as freeing resources used by the Page control and to save information entered in the Page control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageClosing Event

Lidor Systems Collector Class Library

Group.PageClosing Event

Occurs when the Page is closing.

[Visual Basic]
Public Event PageClosing As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler PageClosing;
[C++]
public: __event CancelableCollectorEventHandler* PageClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs containing data related to this event. The following CancelableCollectorEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Remarks

The PageClosing event occurs as the Page control is being closed. When a control is closed, all resources created within the object are released and the control is disposed. If you cancel this event, the control remains opened. To cancel the closure of a control, set the Cancel property of the CancelableCollectorEventArgs passed to your event handler to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageDragging Event

Lidor Systems Collector Class Library

Group.PageDragging Event

Occurs before a Page has started dragging.

[Visual Basic]
Public Event PageDragging As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler PageDragging;
[C++]
public: __event CancelableCollectorEventHandler* PageDragging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageDragOver Event

Lidor Systems Collector Class Library

Group.PageDragOver Event

Occurs when a Page is dragged.

[Visual Basic]
Public Event PageDragOver As CollectorDragEventHandler
[C#]
public event CollectorDragEventHandler PageDragOver;
[C++]
public: __event CollectorDragEventHandler* PageDragOver;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDragEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageDropped Event

Lidor Systems Collector Class Library

Group.PageDropped Event

Occurs after a Page has been dropped.

[Visual Basic]
Public Event PageDropped As CollectorDropEventHandler
[C#]
public event CollectorDropEventHandler PageDropped;
[C++]
public: __event CollectorDropEventHandler* PageDropped;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorDropEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageRemoved Event

Lidor Systems Collector Class Library

Group.PageRemoved Event

Occurs after a Page is removed.

[Visual Basic]
Public Event PageRemoved As CollectorEventHandler
[C#]
public event CollectorEventHandler PageRemoved;
[C++]
public: __event CollectorEventHandler* PageRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageRemoving Event

Lidor Systems Collector Class Library

Group.PageRemoving Event

Occurs before a Page is removed.

[Visual Basic]
Public Event PageRemoving As CancelableCollectorEventHandler
[C#]
public event CancelableCollectorEventHandler PageRemoving;
[C++]
public: __event CancelableCollectorEventHandler* PageRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CancelableCollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedPageChanged Event

Lidor Systems Collector Class Library

Group.SelectedPageChanged Event

Occurs after the SelectedPage changes.

[Visual Basic]
Public Event SelectedPageChanged As CollectorEventHandler
[C#]
public event CollectorEventHandler SelectedPageChanged;
[C++]
public: __event CollectorEventHandler* SelectedPageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButtonClick Event

Lidor Systems Collector Class Library

Group.TabSelectButtonClick Event

Occurs when a TabSelectButton is clicked.

[Visual Basic]
Public Event TabSelectButtonClick As CollectorEventHandler
[C#]
public event CollectorEventHandler TabSelectButtonClick;
[C++]
public: __event CollectorEventHandler* TabSelectButtonClick;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type CollectorEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Class

Contains a collection of Page objects.

For a list of all members of this type, see Group.PageCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.Collector.Group.PageCollection

[Visual Basic]
Public Class Group.PageCollection
   Inherits CollectionBase
[C#]
public class Group.PageCollection : CollectionBase
[C++]
public __gc class Group.PageCollection : public CollectionBase
[JScript]
public class Group.PageCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Members

Group.PageCollection overview

Public Constructors

public constructor Group.PageCollection Constructor Initializes a new instance of the Group.PageCollection class.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a Page at the specified location in the collection.
public property Parent | Gets the Group control that owns the Group.PageCollection.

Public Methods

public method Add | Adds a new Page to the end of the Group.PageCollection.
public method AddRange | Adds an array of pages to the Group.PageCollection.
public method Clear | Removes all pages from the collection.
public method Contains | Determines whether the specified Page object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified Page in the collection.
public method Remove | Removes the specified Page from the Group.PageCollection.
public method RemoveAt | Removes the Page at the specified index of the Group.PageCollection.
public method SetChildIndex | Sets the index of the specified Page in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

Group.PageCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Constructor Method

Lidor Systems Collector Class Library

Group.PageCollection Constructor Method

Overload List

Initializes a new instance of the Group.PageCollection class and associates it with the given Group class.

public Group.PageCollection(Group);

Initializes a new instance of the Group.PageCollection class and adds the specified collection to the newly created object instance.

public Group.PageCollection(Group, Group.PageCollection);

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Constructor (Group)

Initializes a new instance of the Group.PageCollection class and assigns to Group control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Group _
)
[C#]
public Group.PageCollection(
   Group owner
);
[C++]
public: Group.PageCollection(
   Group* owner
);
[JScript]
public function Group.PageCollection(
   owner : Group
);

Parameters

owner
The Group to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Constructor (Group, Group.PageCollection)

Initializes a new instance of the Group.PageCollection class, assigns to Group control and adds the specified collection to the newly created object instance.

[Visual Basic]
Public Sub New( _
   ByVal owner As Group, _
   ByVal pages As Group.PageCollection _
)
[C#]
public Group.PageCollection(
   Group owner,
   Group.PageCollection pages
);
[C++]
public: Group.PageCollection(
   Group* owner,
   Group.PageCollection* pages
);
[JScript]
public function Group.PageCollection(
   owner : Group,
   pages : Group.PageCollection
);

Parameters

owner
The Group to be the owner of the created collection instance.
pages
Instance of the Group.PageCollection being added to the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Properties

The properties of the Group.PageCollection class are listed here. For a complete list of Group.PageCollection class members, see the Group.PageCollection Members topic.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a Page at the specified location in the collection.
public property Parent | Gets the Group control that owns the Group.PageCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

Group.PageCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Item Property

Lidor Systems Collector Class Library

Group.PageCollection.Item Property

Gets or sets a Page at the specified location in the collection.

[Visual Basic]
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As Page
[C#]
public virtual Page this[
   int index
] {get; set;}
[C++]
public: __property virtual Page* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Page*
);

Parameters

index
The 0-based index of the page to get or set.

Property Value

The Page at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The value is not a Page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

Group.PageCollection.Parent Property

Gets or sets the Group that owns the Group.PageCollection.

[Visual Basic]
Public Property Parent As Group
[C#]
public Group Parent { get; set; }
[C++]
public: __property Group* get_Parent();
public: __property void set_Parent(Group);
[JScript]
public function get Parent() : Group
public function set Parent(Group);

Property Value

Represents the Group control that owns the Group.PageCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group.PageCollection Methods

The methods of the Group.PageCollection class are listed here. For a complete list of Group.PageCollection class members, see the Group.PageCollection Members topic.

Public Methods

public method Add | Adds a new Page to the end of the Group.PageCollection.
public method AddRange | Adds an array of pages to the Group.PageCollection.
public method Clear | Removes all pages from the collection.
public method Contains | Determines whether the specified Page object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified Page in the collection.
public method Remove | Removes the specified Page from the Group.PageCollection.
public method RemoveAt | Removes the Page at the specified index of the Group.PageCollection.
public method SetChildIndex | Sets the index of the specified Page in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

Group.PageCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add Method

Lidor Systems Collector Class Library

Group.PageCollection.Add Method

Overload List

Adds a new Page to the end of the Group.PageCollection.

[Visual Basic] Public Sub Add(Page)
[C#] public void Add(Page);
[C++] public: void Add(Page);
[JScript] public function Add(Page);

Adds an collection of previously created pages to the Group.PageCollection.

[Visual Basic] Public Sub Add(Group.PageCollection)
[C#] public void Add(Group.PageCollection);
[C++] public: void Add(Group.PageCollection);
[JScript] public function Add(Group.PageCollection);

Adds a new Page to the end of the Group.PageCollection, with inheritance of parent property values.

[Visual Basic] Public Sub Add(Page, bool)
[C#] public void Add(Page, bool);
[C++] public: void Add(Page, bool);
[JScript] public function Add(Page, bool);

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Page) Method

Lidor Systems Collector Class Library

Group.PageCollection.Add (Page) Method

Adds a new Page to the end of the Group.PageCollection.

[Visual Basic]
Public Sub Add( _
   ByVal page As Page _
)
[C#]
public void Add(
   Page page
);
[C++]
public: void Add(
   Page* page
);
[JScript]
public function Add(
   page : Page
);

Parameters

page
The Page to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Group.PageCollection) Method

Lidor Systems Collector Class Library

Group.PageCollection.Add (Group.PageCollection) Method

Adds an collection of previously created pages to the Group.PageCollection.

[Visual Basic]
Public Sub Add( _
   ByVal pages As Group.PageCollection _
)
[C#]
public void Add(
   Group.PageCollection pages
);
[C++]
public: void Add(
   Group.PageCollection* pages
);
[JScript]
public function Add(
   pages : Group.PageCollection
);

Parameters

pages
The Group.PageCollection to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (Page, bool) Method

Lidor Systems Collector Class Library

Group.PageCollection.Add (Page, bool) Method

Adds a new Page to the end of the Group.PageCollection.

[Visual Basic]
Public Sub Add( _
   ByVal page As Page _
   ByVal propFromParent As Boolean _
)
[C#]
public void Add(
   Page page
   bool propFromParent
);
[C++]
public: void Add(
   Page* page
   bool* propFromParent
);
[JScript]
public function Add(
   page : Page
   propFromParent : Boolean
);

Parameters

page
The Page to add to the collection.
propFromParent
Inheriths property values from the parent Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AddRange Method

Lidor Systems Collector Class Library

Group.PageCollection.AddRange Method

Adds an array of pages to the Group.PageCollection.

[Visual Basic]
Public Sub AddRange( _
   ByVal pages() As Page _
)
[C#]
public void AddRange(
   Page[] pages
);
[C++]
public: void AddRange(
   Page* pages[]
);
[JScript]
public function AddRange(
   pages : Page[]
);

Parameters

pages
An array of type Page that contains the pages to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of pages equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clear Method

Lidor Systems Collector Class Library

Group.PageCollection.Clear Method

Removes all pages from the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Contains Method

Lidor Systems Collector Class Library

Group.PageCollection.Contains Method

Determines whether the specified Page object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal page As Page _
) As Boolean
[C#]
public bool Contains(
   Page page
);
[C++]
public: bool Contains(
   Page* page
);
[JScript]
public function Contains(
   page : Page
) : Boolean;

Parameters

page
The Page to locate in the collection.

Return Value

true if the specified Page is in the collection; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of page is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IndexOf Method

Lidor Systems Collector Class Library

Group.PageCollection.IndexOf Method

Returns the index of the specified Page in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal page As Page _
) As Integer
[C#]
public int IndexOf(
   Page page
);
[C++]
public: int IndexOf(
   Page* page
);
[JScript]
public function IndexOf(
   page : Page
) : int;

Parameters

page
The Page to locate in the collection.

Return Value

The zero-based index of the item found in the Group.PageCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RemoveAt Method

Lidor Systems Collector Class Library

Group.PageCollection.RemoveAt Method

RemoveAts the Page at the specified index of the Group.PageCollection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
new public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The 0-based index of the Page to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Remove Method

Lidor Systems Collector Class Library

Group.PageCollection.Remove Method

Removes a Page from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal page As Page _
)
[C#]
public void Remove(
   Page page
);
[C++]
public: void Remove(
   Page* page
);
[JScript]
public function Remove(
   page : Page
);

Parameters

page
The Page to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The page parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SetChildIndex Method

Lidor Systems Collector Class Library

Group.PageCollection.SetChildIndex Method

Sets the index of the specified Page in the collection to the specified index value.

[Visual Basic]
Public Sub SetChildIndex( _
   ByVal page As Page, _
   ByVal index As Integer _
)
[C#]
public void SetChildIndex(
   Page page,
   int index
);
[C++]
public: void SetChildIndex(
   Page* page,
   int index
);
[JScript]
public function SetChildIndex(
   page : Page,
   index : int
);

Parameters

page
The Page to search for.
index
The new index value of the Page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Group.PageCollection Class | Group.PageCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Layer Class

Layer class represents object that holds layout logic for management of tool windows.

For a list of all members of this type, see Layer Members.

System.Object
LidorSystems.Collector.Layer

[Visual Basic]
Public Class Layer
   Inherits Control
[C#]
public class Layer : Control
[C++]
public __gc class Layer : public Control
[JScript]
public class Layer extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Layer Members

Layer overview

Public Constructors

public constructor Layer Constructor Initializes a new instance of the Layer class.

Public Properties

public property Bounds | Gets or sets the size and location of the Layer object.
public property Group | Gets or sets the Group object that is contained in the Layer object.
public property LeftLayer | Gets or sets the Layer object to the left of the parent Layer object.
public property RightLayer | Gets or sets the Layer object to the right of the parent Layer object.
public property SpliterType | Gets or sets an enumeration that determines the type of spliter.
public property SplitRectangle | Gets or sets the size and location of spliter in the Layer object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Layer Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Layer Constructor

Initializes a new instance of the Layer class.

[Visual Basic]
Public Sub New()
[C#]
public Layer();
[C++]
public: Layer();
[JScript]
public function Layer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Page Properties

The properties of the Page class are listed here. For a complete list of Page class members, see the Page Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether the Page control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainerImage | Gets or sets the container image of the Page.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle | Overriden. Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the tab of a Page control.
public property ImageIndex | Gets or sets the index to the image object inside the tab of a Page control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the PageStyle object representing the style of the Page control.
public property StyleFromParent | Determines whether the Page should use style from his parent (if it exists), to draw.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TableObject | Gets or sets the PageTable object used for arrangement of child controls in tabular format.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Page control.
public property TransparentMode | Gets or sets the value indicating the Page control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Page control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Page control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

Page Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bounds Property

Lidor Systems Collector Class Library

Layer.Bounds Property

Gets or sets the size and location of the Layer object.

[Visual Basic]
Public Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get; set;}
[C++]
public: __property Rectangle get_Bounds();
public: __property void set_Bounds(Rectangle);
[JScript]
public function get Bounds() : Rectangle;
public function set Bounds(Rectangle);

Property Value

The Rectangle that represents the size and location of the Layer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Group Property

Lidor Systems Collector Class Library

Layer.Group Property

Gets or sets the Group object that is contained in the Layer object.

[Visual Basic]
Public Property Group As Group
[C#]
public Group Group { get; set; }
[C++]
public: __property Group* get_Group();
public: __property void set_Group(Group* );
[JScript]
public function get Group() : Group
public function set Group(Group);

Property Value

Group object contained in the Layer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


LeftLayer Property

Lidor Systems Collector Class Library

Layer.LeftLayer Property

Gets or sets the Layer object to the left of the parent Layer object.

[Visual Basic]
Public Property LeftLayer As Layer
[C#]
public Layer LeftLayer { get; set; }
[C++]
public: __property Layer* get_LeftLayer();
public: __property void set_LeftLayer(Layer* );
[JScript]
public function get LeftLayer() : Layer
public function set LeftLayer(Layer);

Property Value

Layer object set to the left of the parent Layer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RightLayer Property

Lidor Systems Collector Class Library

Layer.RightLayer Property

Gets or sets the Layer object to the right of the parent Layer object.

[Visual Basic]
Public Property RightLayer As Layer
[C#]
public Layer RightLayer { get; set; }
[C++]
public: __property Layer* get_RightLayer();
public: __property void set_RightLayer(Layer* );
[JScript]
public function get RightLayer() : Layer
public function set RightLayer(Layer);

Property Value

Layer object set to the right of the parent Layer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SpliterType Property

Lidor Systems Collector Class Library

Layer.SpliterType Property

Gets or sets an enumeration that determines the type of spliter.

[Visual Basic]
Public Property SpliterType As SpliterType
[C#]
public SpliterType SpliterType {get; set;}
[C++]
public: __property SpliterType get_SpliterType();
public: __property void set_SpliterType(SpliterType);
[JScript]
public function get SpliterType() : SpliterType;
public function set SpliterType(SpliterType);

Property Value

The SpliterType assigned to the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SplitRectangle Property

Lidor Systems Collector Class Library

Layer.SplitRectangle Property

Gets or sets the size and location of spliter in the Layer object.

[Visual Basic]
Public Property SplitRectangle As Rectangle
[C#]
public Rectangle SplitRectangle {get; set;}
[C++]
public: __property Rectangle get_SplitRectangle();
public: __property void set_SplitRectangle(Rectangle);
[JScript]
public function get SplitRectangle() : Rectangle;
public function set SplitRectangle(Rectangle);

Property Value

The Rectangle that represents the size and location of spliter in the Layer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Layer Class | Layer Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Margin Structure

Stores a set of four integers that represent the distance (in pixels) from border of container control.

For a list of all members of this type, see Margin Members.

System.Object
System.ValueType
LidorSystems.Collector.Margin

[Visual Basic]
Public Structure Margin
[C#]
public struct Margin
[C++]
public __value struct Margin

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Margin Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bottom Property

Lidor Systems Collector Class Library

Margin.Bottom Property

Gets or sets distance (in pixels) from the bottom border of container control.

[Visual Basic]
Public Property Bottom As Integer
[C#]
public int Bottom {get; set;}
[C++]
public: __property int get_Bottom();
public: __property void set_Bottom(int);
[JScript]
public function get Bottom() : int;
public function set Bottom(int);

Property Value

Distance (in pixels) from the bottom border of container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Margin Structure | Margin Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Left Property

Lidor Systems Collector Class Library

Margin.Left Property

Gets or sets distance (in pixels) from the left border of container control.

[Visual Basic]
Public Property Left As Integer
[C#]
public int Left {get; set;}
[C++]
public: __property int get_Left();
public: __property void set_Left(int);
[JScript]
public function get Left() : int;
public function set Left(int);

Property Value

Distance (in pixels) from the left border of container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Margin Structure | Margin Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Right Property

Lidor Systems Collector Class Library

Margin.Right Property

Gets or sets distance (in pixels) from the right border of container control.

[Visual Basic]
Public Property Right As Integer
[C#]
public int Right {get; set;}
[C++]
public: __property int get_Right();
public: __property void set_Right(int);
[JScript]
public function get Right() : int;
public function set Right(int);

Property Value

Distance (in pixels) from the right border of container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Margin Structure | Margin Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Top Property

Lidor Systems Collector Class Library

Margin.Top Property

Gets or sets distance (in pixels) from the top border of container control.

[Visual Basic]
Public Property Top As Integer
[C#]
public int Top {get; set;}
[C++]
public: __property int get_Top();
public: __property void set_Top(int);
[JScript]
public function get Top() : int;
public function set Top(int);

Property Value

Distance (in pixels) from the top border of container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Margin Structure | Margin Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Page Class

Page control represents container control with ability to arrange custom controls in a tabular format.

For a list of all members of this type, see Page Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.Collector.Page

[Visual Basic]
Public Class Page
   Inherits Control
[C#]
public class Page : Control
[C++]
public __gc class Page : public Control
[JScript]
public class Page extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Page Members

Page overview

Public Constructors

public constructor Page Constructor Initializes a new instance of the Page class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether the Page control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainerImage | Gets or sets the container image of the Page.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisplayRectangle | Overriden. Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property Image | Specifies the image object inside the tab of a Page control.
public property ImageIndex | Gets or sets the index to the image of a Page control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Style | Gets or sets the PageStyle object representing the style of the Page control.
public property StyleFromParent | Determines whether the Page should use style from his parent (if it exists), to draw.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TableObject | Gets or sets the PageTable object used for arrangement of child controls in tabular format.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property Transparency | A value specifying the level of transparency of the Page control.
public property TransparentMode | Gets or sets the value indicating the Page control uses Transparency value to make it transparent.
public property UseTheme | Determines whether the Page control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the Page control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh | Overriden. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Events

public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize | Overridden. See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded | Overriden. Raises the ControlAdded event.
protected method OnControlRemoved | Overriden. Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout | Overridden. Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RemoveAll | Removes all the controls from this Page control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

Page Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Page Constructor

Initializes a new instance of the Page class.

[Visual Basic]
Public Sub New()
[C#]
public Page();
[C++]
public: Page();
[JScript]
public function Page();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AllowDrag Property

Lidor Systems Collector Class Library

Page.AllowDrag Property

Determines whether the Page control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BorderStyle Property

Lidor Systems Collector Class Library

Page.BorderStyle Property

Gets or sets the border style of the Page control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle);
[JScript]
public function get BorderStyle() : BorderStyle;
public function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle values. The default is BorderStyle.None.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Image Property

Lidor Systems Collector Class Library

Page.ContainerImage Property

Gets or sets the container image of the Page.

[Visual Basic]
Public Property ContainerImage As ContainerImage

[C#]
public ContainerImage ContainerImage { get; set; }
[C++]
public: __property ContainerImage* get_ContainerImage();
public: __property void set_ContainerImage(ContainerImage*);
[JScript]
public function get ContainerImage() : ContainerImage
public function set ContainerImage(ContainerImage);

Property Value

The ContainerImage assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DefaultSize Property

Lidor Systems Collector Class Library

Page.DefaultSize Property

This member overrides Control.DefaultSize.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override Size DefaultSize {get;}
[C++]
protected: __property Size get_DefaultSize();
[JScript]
protected override function get DefaultSize() : Size;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DisplayRectangle Property

Lidor Systems Collector Class Library

Page.DisplayRectangle Property

This member overrides Control.DisplayRectangle.

[Visual Basic]
Overrides Protected ReadOnly Property DisplayRectangle As Rectangle
[C#]
protected override Rectangle DisplayRectangle {get;}
[C++]
protected: __property Rectangle get_DisplayRectangle();
[JScript]
protected override function get DisplayRectangle() : Rectangle;

Property Value

A Rectangle that represents the display area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Image Property

Lidor Systems Collector Class Library

Page.Image Property

Specifies the image object inside the tab of a Page control.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Property Value

The Image assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageIndex Property

Lidor Systems Collector Class Library

Page.ImageIndex Property

Gets or sets the index to the image object inside the tab of a Page control.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

The zero-based index to the image in the ImageList that appears on the Page. The default is -1, which signifies no image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Style Property

Lidor Systems Collector Class Library

Page.Style Property

Gets or sets the PageStyle object representing the style of the Page control.

[Visual Basic]
Public Property Style As PageStyle
[C#]
public PageStyle Style { get; set; }
[C++]
public: __property PageStyle* get_Style();
public: __property void set_Style(PageStyle* );
[JScript]
public function get Style() : PageStyle
public function set Style(PageStyle);

Property Value

PageStyle object represents the style of the Page control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


StyleFromParent Property

Lidor Systems Collector Class Library

Page.StyleFromParent Property

Determines whether the Page should use style from his parent (if it exists), to draw.

[Visual Basic]
Public Property StyleFromParent As Boolean
[C#]
public bool StyleFromParent { get; set; }
[C++]
public: __property bool get_StyleFromParent();
public: __property void set_StyleFromParent(bool );
[JScript]
public function get StyleFromParent() : bool
public function set StyleFromParent(bool);

Property Value

True if the Page uses style from his parent to draw; otherwise False, which creates new PageStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TableObject Property

Lidor Systems Collector Class Library

Page.TableObject Property

Gets or sets the PageTable object used for arrangement of child controls in tabular format.

[Visual Basic]
Public Property TableObject As PageTable
[C#]
public PageTable TableObject { get; set; }
[C++]
public: __property PageTable* get_TableObject();
public: __property void set_TableObject(PageTable* );
[JScript]
public function get TableObject() : PageTable
public function set TableObject(PageTable);

Property Value

PageTable object represents the table of the Page control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Transparency Property

Lidor Systems Collector Class Library

Page.Transparency Property

A value specifying the level of transparency of the Page control.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}
[C++]
public: __property int get_Transparency();
public: __property void set_Transparency(int);
[JScript]
public function get Transparency() : int;
public function set Transparency(int);

Property Value

Transparency is in percentage, so the value can be from 0 to 100. Default setting is 50.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TransparentMode Property

Lidor Systems Collector Class Library

Page.TransparentMode Property

Determines whether the Page background will be transparent.

[Visual Basic]
Public Property TransparentMode As Boolean
[C#]
public bool TransparentMode { get; set; }
[C++]
public: __property bool get_TransparentMode();
public: __property void set_TransparentMode(bool );
[JScript]
public function get TransparentMode() : bool
public function set TransparentMode(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UseTheme Property

Lidor Systems Collector Class Library

Page.UseTheme Property

Determines whether the Page control will render according to current system theme and color scheme.

[Visual Basic]
Public Property UseTheme As Boolean
[C#]
public bool UseTheme { get; set; }
[C++]
public: __property bool get_UseTheme();
public: __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VisualStyle Property

Lidor Systems Collector Class Library

Page.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the Page control.

[Visual Basic]
Public Property VisualStyle As VisualStyle
[C#]
public VisualStyle VisualStyle {get; set;}
[C++]
public: __property VisualStyle get_VisualStyle();
public: __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Page Methods

The methods of the Page class are listed here. For a complete list of Page class members, see the Page Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh | Overloaded. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded | Overriden. Raises the ControlAdded event.
protected method OnControlRemoved | Overriden. Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout | Overridden. Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RemoveAll | Removes all the controls from this Page control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

Page Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose Method

Lidor Systems Collector Class Library

Page.Dispose Method

Overload List

Releases all resources used by the System.ComponentModel.Component.

[Visual Basic] Overloads Overrides Protected Sub Dispose(Boolean)
[C#] protected override void Dispose(bool);
[C++] protected: void Dispose(bool);
[JScript] protected override function Dispose(Boolean);

Exits edit mode and cleans up any resources being used.

[Visual Basic] Overloads Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#] public virtual void Dispose();
[C++] public: virtual void Dispose();
[JScript] public function Dispose();

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose () Method

Lidor Systems Collector Class Library

Page.Dispose () Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Dispose (Boolean) Method

Lidor Systems Collector Class Library

Page.Dispose (Boolean) Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);
[C++]
protected: void Dispose(
   bool disposing
);
[JScript]
protected override function Dispose(
   disposing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnControlAdded Method

Lidor Systems Collector Class Library

Page.OnControlAdded Method

This member overrides Control.OnControlAdded

[Visual Basic]
Protected Overridable Sub OnControlAdded( _
   ByVal e As ControlEventArgs _
)
[C#]
protected virtual void OnControlAdded(
   ControlEventArgs e
);
[C++]
protected: virtual void OnControlAdded(
   ControlEventArgs* e
);
[JScript]
protected function OnControlAdded(
   e : ControlEventArgs
);

Parameters

e
A ControlEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnControlRemoved Method

Lidor Systems Collector Class Library

Page.OnControlRemoved Method

This member overrides Control.OnControlRemoved

[Visual Basic]
Protected Overridable Sub OnControlRemoved( _
   ByVal e As ControlEventArgs _
)
[C#]
protected virtual void OnControlRemoved(
   ControlEventArgs e
);
[C++]
protected: virtual void OnControlRemoved(
   ControlEventArgs* e
);
[JScript]
protected function OnControlRemoved(
   e : ControlEventArgs
);

Parameters

e
A ControlEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnLayout Method

Lidor Systems Collector Class Library

Page.OnLayout Method

This member overrides Control.OnLayout

[Visual Basic]
Overrides Protected Sub OnLayout( _
   ByVal levent As LayoutEventArgs _
)
[C#]
protected override void OnLayout(
   LayoutEventArgs levent
);
[C++]
protected: void OnLayout(
   LayoutEventArgs* levent
);
[JScript]
protected override function OnLayout(
   levent : LayoutEventArgs
);

Parameters

levent
A LayoutEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnResize Method

Lidor Systems Collector Class Library

Page.OnResize Method

This member overrides Control.OnResize.

[Visual Basic]
Overrides Protected Sub OnResize( _
   ByVal e As EventArgs _
)
[C#]
protected override void OnResize(
   EventArgs e
);
[C++]
protected: void OnResize(
   EventArgs* e
);
[JScript]
protected override function OnResize(
   e : EventArgs
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ProcessCmdKey Method

Lidor Systems Collector Class Library

Page.ProcessCmdKey Method

This member overrides Control.ProcessCmdKey

[Visual Basic]
Overrides Protected Function ProcessCmdKey( _
   ByRef msg As Message, _
   ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
);
[C++]
protected: bool ProcessCmdKey(
   Message* msg,
   Keys keyData
);
[JScript]
protected override function ProcessCmdKey(
   msg : Message,
   keyData : Keys
) : Boolean;

Parameters

msg
A Message, passed by reference, that represents the window message to process.
keyData
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Refresh Method

Lidor Systems Collector Class Library

Page.Refresh Method

This member overrides Control.Refresh

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();
[C++]
public: void Refresh();
[JScript]
public override function Refresh();

Remarks

Notes to Inheritors: When overriding Refresh in a derived class, be sure to call the base class's Refresh method so the control and its child controls are invalidated and redrawn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


RemoveAll Method

Lidor Systems Collector Class Library

Page.RemoveAll Method

Removes all the controls from this Page control.

[Visual Basic]
Protected Sub RemoveAll()
[C#]
protected void RemoveAll();
[C++]
protected: void RemoveAll();
[JScript]
protected function RemoveAll();

Remarks

All controls are removed through the Controls property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Page Class | Page Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTable Class

PageTable object arrange controls in a tabular format within the Page control.

For a list of all members of this type, see PageTable Members.

System.Object
LidorSystems.Collector.PageTable

[Visual Basic]
Public Class PageTable
[C#]
public class PageTable
[C++]
public __gc class PageTable
[JScript]
public class PageTable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTable Members

PageTable overview

Public Constructors

public constructor PageTable Constructor Initializes a new instance of the PageTable class.

Public Properties

public property AutoSize | Gets or sets a value indicating whether the table is automatically resized to parent control size.
public property CellPadding | Gets or sets the amount of space to insert between the cell content and cell margins.
public property CellSpacing | Gets or sets the amount of space to insert between the cells in table object.
public property Columns | Gets the collection of PageTableColumns in the PageTable object.
public property Parent | Gets the Page control that the PageTable object is assigned to.
public property PreferredColumnWidth | Gets or sets the default width of the PageTable columns in pixels.
public property PreferredRowHeight | Gets or sets the default height of the PageTable rows in pixels.
public property Rows | Gets the collection of PageTableRows in the PageTable object.
public property SelectedCell | Gets or sets the selected PageTableCell.
public property Size | Gets or sets the size of the PageTable object.

Public Methods

public method DeleteColumn | Deletes the specified PageTableColumn object from the PageTable object.
public method DeleteRow | Deletes the specified PageTableRow object from the PageTable object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetCell | Gets the PageTableCell object from the specified location or from his content.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method InsertColumn | Inserts a new PageTableColumn object in a PageTable object.
public method InsertRow | Inserts a new PageTableRow object in a PageTable object.
public method MarkCells | Mark cells that belong to specified rectangle.
public method MergeCells | Combines marked cells into a parent cell.
public method MergingAllowed | Determines whether merging operation is allowed.
public method SplitCellInColumns | Splits the specified cell in custom number of columns.
public method SplitCellInRows | Splits the specified cell in custom number of rows.
public method SplitingAllowed | Determines whether spliting operation is allowed.
public method ToString (inherited from Object) | Returns a String that represents the current Object.
public method UpdateLayout | Updates layout of the PageTable object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageTable Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTable Constructor

Initializes a new instance of the PageTable class.

[Visual Basic]
Public Sub New()
[C#]
public PageTable();
[C++]
public: PageTable();
[JScript]
public function PageTable();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTable Properties

The properties of the PageTable class are listed here. For a complete list of PageTable class members, see the PageTable Members topic.

Public Properties

public property AutoSize | Gets or sets a value indicating whether the table is automatically resized to parent control size.
public property CellPadding | Gets or sets the amount of space to insert between the cell content and cell margins.
public property CellSpacing | Gets or sets the amount of space to insert between the cells in table object.
public property Columns | Gets the collection of PageTableColumns in the PageTable object.
public property Parent | Gets the Page control that the PageTable object is assigned to.
public property PreferredColumnWidth | Gets or sets the default width of the PageTable columns in pixels.
public property PreferredRowHeight | Gets or sets the default height of the PageTable rows in pixels.
public property Rows | Gets the collection of PageTableRows in the PageTable object.
public property SelectedCell | Gets or sets the selected PageTableCell.
public property Size | Gets or sets the size of the PageTable object.

See Also

PageTable Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoSize Property

Lidor Systems Collector Class Library

PageTable.AutoSize Property

Gets or sets a value indicating whether the table is automatically resized to parent Page control size.

[Visual Basic]
Public Property AutoSize As Boolean
[C#]
public bool AutoSize { get; set; }
[C++]
public: __property bool get_AutoSize();
public: __property void set_AutoSize(bool );
[JScript]
public function get AutoSize() : bool
public function set AutoSize(bool);

Property Value

true if the table adjusts its size to parent control size; otherwise, false. The default is false.

Remarks

When the value is set to true and the Page control contains any docked child controls, then the PageTable object size is adjusted to remaining space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CellPadding Property

Lidor Systems Collector Class Library

PageTableCellPadding Property

Gets or sets the amount of space to insert between the cell content and cell margins.

[Visual Basic]
Public Property CellPadding As Integer
[C#]
public int CellPadding {get; set;}
[C++]
public: __property int get_CellPadding();
public: __property void set_CellPadding(int);
[JScript]
public function get CellPadding() : int;
public function set CellPadding(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CellSpacing Property

Lidor Systems Collector Class Library

PageTableCellSpacing Property

Gets or sets the amount of space to insert between the cells in table object.

[Visual Basic]
Public Property CellSpacing As Integer
[C#]
public int CellSpacing {get; set;}
[C++]
public: __property int get_CellSpacing();
public: __property void set_CellSpacing(int);
[JScript]
public function get CellSpacing() : int;
public function set CellSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Columns Property

Lidor Systems Collector Class Library

PageTableColumns Property

Gets the collection of PageTableColumns in the PageTable object.

[Visual Basic]
Public ReadOnly Property Columns As PageTableColumnCollection
[C#]
public PageTableColumnCollection Columns {get;}
[C++]
public: __property PageTableColumnCollection* get_Columns();
[JScript]
public function get Columns() : PageTableColumnCollection;

Property Value

A PageTableColumnCollection that contains the PageTableColumn objects in this PageTable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

PageTable.Parent Property

Gets the Page control that the PageTable object is assigned to.

[Visual Basic]
Public Property Parent As Page
[C#]
public Page Parent { get; set; }
[C++]
public: __property Page* get_Parent();
public: __property void set_Parent(Page);
[JScript]
public function get Parent() : Page
public function set Parent(Page);

Property Value

Represents the Page control that uses the PageTable object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PreferredColumnWidth Property

Lidor Systems Collector Class Library

PageTable.PreferredColumnWidth Property

Gets or sets the default width of the PageTable columns in pixels.

[Visual Basic]
Public Property PreferredColumnWidth As Integer
[C#]
public int PreferredColumnWidth {get; set;}
[C++]
public: __property int get_PreferredColumnWidth();
public: __property void set_PreferredColumnWidth(int);
[JScript]
public function get PreferredColumnWidth() : int;
public function set PreferredColumnWidth(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PreferredRowHeight Property

Lidor Systems Collector Class Library

PageTable.PreferredRowHeight Property

Gets or sets the default height of the PageTable rows in pixels.

[Visual Basic]
Public Property PreferredRowHeight As Integer
[C#]
public int PreferredRowHeight {get; set;}
[C++]
public: __property int get_PreferredRowHeight();
public: __property void set_PreferredRowHeight(int);
[JScript]
public function get PreferredRowHeight() : int;
public function set PreferredRowHeight(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Rows Property

Lidor Systems Collector Class Library

PageTableRows Property

Gets the collection of PageTableRows in the PageTable object.

[Visual Basic]
Public ReadOnly Property Rows As PageTableRowCollection
[C#]
public PageTableRowCollection Rows {get;}
[C++]
public: __property PageTableRowCollection* get_Rows();
[JScript]
public function get Rows() : PageTableRowCollection;

Property Value

A PageTableRowCollection that contains the PageTableRow objects in this PageTable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedCell Property

Lidor Systems Collector Class Library

PageTable.SelectedCell Property

Gets or sets the selected PageTableCell.

[Visual Basic]
Public Property SelectedCell As PageTableCell
[C#]
public PageTableCell SelectedCell {get; set;}
[C++]
public: __property PageTableCell* get_SelectedCell();
public: __property void set_SelectedCell(PageTableCell*);
[JScript]
public function get SelectedCell() : PageTableCell;
public function set SelectedCell(PageTableCell);

Property Value

A PageTableCell that represents the selected cell. If no cell is selected, the value is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Size Property

Lidor Systems Collector Class Library

PageTable.Size Property

Gets or sets the size of the PageTable object.

[Visual Basic]
Public Property Size As Size
[C#]
public Size Size { get; set; }
[C++]
public: __property Size get_Size();
public: __property void set_Size(Size);
[JScript]
public function get Size() : Size
public function set Size(Size);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTable Methods

The methods of the PageTable class are listed here. For a complete list of PageTable class members, see the PageTable Members topic.

Public Methods

public method DeleteColumn | Deletes the specified PageTableColumn object from the PageTable object.
public method DeleteRow | Deletes the specified PageTableRow object from the PageTable object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetCell | Gets the PageTableCell object from the specified location or from his content.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method InsertColumn | Inserts a new PageTableColumn object in a PageTable object.
public method InsertRow | Inserts a new PageTableRow object in a PageTable object.
public method MarkCells | Mark cells that belong to specified rectangle.
public method MergeCells | Combines marked cells into a parent cell.
public method MergingAllowed | Determines whether merging operation is allowed.
public method SplitCellInColumns | Splits the specified cell in custom number of columns.
public method SplitCellInRows | Splits the specified cell in custom number of rows.
public method SplitingAllowed | Determines whether spliting operation is allowed.
public method ToString (inherited from Object) | Returns a String that represents the current Object.
public method UpdateLayout | Updates layout of the PageTable object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageTable Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DeleteColumn Method

Lidor Systems Collector Class Library

PageTable.DeleteColumn Method

Deletes the specified PageTableColumn object from the PageTable object.

[Visual Basic]
Public Function DeleteColumn( _
   ByVal nCol As Integer _
) As Boolean
[C#]
public bool DeleteColumn(
   int nCol
);
[C++]
public: bool DeleteColumn(
   int nCol
);
[JScript]
public function DeleteColumn(
   nCol : int
) : Boolean;

Parameters

nCol
Index of the column to be deleted.

Return Value

true if the specified column is deleted; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DeleteRow Method

Lidor Systems Collector Class Library

PageTable.DeleteRow Method

Deletes the specified PageTableRow object from the PageTable object.

[Visual Basic]
Public Function DeleteRow( _
   ByVal nRow As Integer _
) As Boolean
[C#]
public bool DeleteRow(
   int nRow
);
[C++]
public: bool DeleteRow(
   int nRow
);
[JScript]
public function DeleteRow(
   nRow : int
) : Boolean;

Parameters

nRow
Index of the row to be deleted.

Return Value

true if the specified row is deleted; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GetCell Method

Lidor Systems Collector Class Library

PageTable.GetCell Method

Overload List

Gets the PageTableCell object from the specified location.

[Visual Basic] Public Sub GetCell(Integer, Integer)
[C#] public void GetCell(int, int);
[C++] public: void GetCell(int, int);
[JScript] public function GetCell(Integer, Integer);

Gets the PageTableCell object from his content.

[Visual Basic] Public Sub GetCell(Object)
[C#] public void GetCell(object);
[C++] public: void GetCell(Object);
[JScript] public function GetCell(Object);

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GetCell (Integer, Integer) Method

Lidor Systems Collector Class Library

PageTable.GetCell (Integer, Integer) Method

Gets the PageTableCell object from the specified location.

[Visual Basic]
Public Function GetCell( _
   ByVal nRow As Integer _
   ByVal nCol As Integer _
) As PageTableCell
[C#]
public PageTableCell GetCell(
   int nRow
   int nCol
);
[C++]
public: PageTableCell GetCell(
   int nRow
   int nCol
);
[JScript]
public function GetCell(
   nRow : int
   nCol : int
) : PageTableCell;

Parameters

nRow
Index of the row to which this cell belongs.
nCol
Index of the column to which this cell belongs.

Return Value

The PageTableCell object that is located in specified row and column, otherwise a null value (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GetCell (Object) Method

Lidor Systems Collector Class Library

PageTable.GetCell (Object) Method

Gets the PageTableCell object from his content.

[Visual Basic]
Public Function GetCell( _
   ByVal obj As Object _
) As PageTableCell
[C#]
public PageTableCell GetCell(
   object obj
);
[C++]
public: PageTableCell GetCell(
   Object obj
);
[JScript]
public function GetCell(
   obj : Object
) : PageTableCell;

Parameters

obj
The object contained by cell.

Return Value

The PageTableCell that contains specified object, otherwise a null value (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


InsertColumn Method

Lidor Systems Collector Class Library

PageTable.InsertColumn Method

Inserts a new PageTableColumn object in a PageTable object.

[Visual Basic]
Public Function InsertColumn( _
   ByVal nCol As Integer _
   ByVal nWidth As Integer _
) As Integer
[C#]
public int InsertColumn(
   int nCol
   int nWidth
);
[C++]
public: int InsertColumn(
   int nCol
   int nWidth
);
[JScript]
public function InsertColumn(
   nCol : int
   nWidth : int
) : int;

Parameters

nCol
The index of the new column.
nWidth
Width of the column, in pixels. If this parameter is -1, the column width is not set.

Return Value

The index of the new column if successful or -1 otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


InsertRow Method

Lidor Systems Collector Class Library

PageTable.InsertRow Method

Inserts a new PageTableRow object in a PageTable object.

[Visual Basic]
Public Function InsertRow( _
   ByVal nRow As Integer _
   ByVal nHeight As Integer _
) As Integer
[C#]
public int InsertRow(
   int nRow
   int nHeight
);
[C++]
public: int InsertRow(
   int nRow
   int nHeight
);
[JScript]
public function InsertRow(
   nRow : int
   nHeight : int
) : int;

Parameters

nRow
The index of the new row.
nHeight
Height of the row, in pixels. If this parameter is -1, the row height is not set.

Return Value

The index of the new row if successful or -1 otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MarkCells Method

Lidor Systems Collector Class Library

PageTable.MarkCells Method

Mark cells that belong to specified rectangle.

[Visual Basic]
Public Function MarkCells( _
   ByVal startPos As Point _
   ByVal endPos As Point _
) As Integer
[C#]
public int MarkCells(
   Point startPos
   Point endPos
);
[C++]
public: int MarkCells(
   Point startPos
   Point endPos
);
[JScript]
public function MarkCells(
   startPos : Point
   endPos : Point
) : int;

Parameters

startPos
The Point representing the upper-left corner of rectangle.
endPos
The Point representing the bottom-right corner of rectangle.

Return Value

Number of marked cells.

Remarks

To use only in design-time environment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MergeCells Method

Lidor Systems Collector Class Library

PageTable.MergeCells Method

Combines marked cells into a parent cell.

[Visual Basic]
Public Sub MergeCells()
[C#]
public void MergeCells();
[C++]
public: void MergeCells();
[JScript]
public function MergeCells();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MergingAllowed Method

Lidor Systems Collector Class Library

PageTable.MergingAllowed Method

Determines whether merging operation is allowed.

[Visual Basic]
Public Sub MergingAllowed() As Boolean
[C#]
public bool MergingAllowed();
[C++]
public: bool MergingAllowed();
[JScript]
public function MergingAllowed() : Boolean;

Return Value

true if the merging operation is allowed; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SplitCellInRows Method

Lidor Systems Collector Class Library

PageTable.SplitCellInRows Method

Splits the specified cell in custom number of rows.

[Visual Basic]
Public Sub SplitCellInRows( _
   ByVal cellPos As Point _
   ByVal nHeight As Integer _
   ByVal nRow As Integer _
)
[C#]
public void SplitCellInRows(
   Point cellPos
   int nHeight
   int nRow
);
[C++]
public: void SplitCellInRows(
   Point cellPos
   int nHeight
   int nRow
);
[JScript]
public function SplitCellInRows(
   cellPos : Point
   nHeight : int
   nRow : int
);

Parameters

cellPos
The Point representing location of the PageTableCell object to be splited.
nHeight
Height of the row, in pixels. If this parameter is -1, the row height is not set.
nRow
Number of rows to which PageTableCell object is splited.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SplitCellInColumns Method

Lidor Systems Collector Class Library

PageTable.SplitCellInColumns Method

Splits the specified cell in custom number of columns.

[Visual Basic]
Public Sub SplitCellInColumns( _
   ByVal cellPos As Point _
   ByVal nWidth As Integer _
   ByVal nCol As Integer _
)
[C#]
public void SplitCellInColumns(
   Point cellPos
   int nWidth
   int nCol
);
[C++]
public: void SplitCellInColumns(
   Point cellPos
   int nWidth
   int nCol
);
[JScript]
public function SplitCellInColumns(
   cellPos : Point
   nWidth : int
   nCol : int
);

Parameters

cellPos
The Point representing location of the PageTableCell object to be splited.
nWidth
Width of the column, in pixels. If this parameter is -1, the column width is not set.
nCol
Number of columns to which PageTableCell object is splited.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SplitingAllowed Method

Lidor Systems Collector Class Library

PageTable.SplitingAllowed Method

Determines whether spliting operation is allowed.

[Visual Basic]
Public Sub SplitingAllowed() As Boolean
[C#]
public bool SplitingAllowed();
[C++]
public: bool SplitingAllowed();
[JScript]
public function SplitingAllowed() : Boolean;

Return Value

true if the spliting operation is allowed; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


UpdateLayout Method

Lidor Systems Collector Class Library

PageTable.UpdateLayout Method

Updates layout of the PageTable object.

[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[JScript]
public function UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTable Class | PageTable Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCell Class

Represents a cell in a PageTable object.

For a list of all members of this type, see PageTableCell Members.

System.Object
LidorSystems.Collector.PageTableCell

[Visual Basic]
Public Class PageTableCell
[C#]
public class PageTableCell
[C++]
public __gc class PageTableCell
[JScript]
public class PageTableCell

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCell Members

PageTableCell overview

Public Constructors

public constructor PageTableCell Constructor Initializes a new instance of the PageTableCell class.

Public Properties

public property Alignment | Gets or sets the alignment of content object in the PageTableCell.
public property Bounds | Gets or sets the size and location of the PageTableCell object.
public property ContainedColumnCells | Gets or sets the number of contained cells in horizontal direction.
public property ContainedRowCells | Gets or sets the number of contained cells in vertical direction.
public property Content | Gets or sets the object in the PageTableCell.
public property Merged | Determines whether the PageTableCell object is merged by another cell.
public property ParentCell | Gets or sets the location of cell to which a PageTableCell object is merged.
public property Position | Gets or sets the location of cell in a PageTable object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageTableCell Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCell Constructor

Initializes a new instance of the PageTableCell class.

[Visual Basic]
Public Sub New()
[C#]
public PageTableCell();
[C++]
public: PageTableCell();
[JScript]
public function PageTableCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCell Properties

The properties of the PageTableCell class are listed here. For a complete list of PageTableCell class members, see the PageTableCell Members topic.

Public Properties

public property Alignment | Gets or sets the alignment of content object in the PageTableCell.
public property Bounds | Gets or sets the size and location of the PageTableCell object.
public property ContainedColumnCells | Gets or sets the number of contained cells in horizontal direction.
public property ContainedRowCells | Gets or sets the number of contained cells in vertical direction.
public property Content | Gets or sets the object in the PageTableCell.
public property Merged | Determines whether the PageTableCell object is merged by another cell.
public property ParentCell | Gets or sets the location of cell to which a PageTableCell object is merged.
public property Position | Gets or sets the location of cell in a PageTable object.

See Also

PageTableCell Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Alignment Property

Lidor Systems Collector Class Library

PageTableCell.Alignment Property

Gets or sets the alignment of content object in the PageTableCell.

[Visual Basic]
Public Property Alignment As ContentAlignment
[C#]
public ContentAlignment Alignment { get; set; }
[C++]
public: __property ContentAlignment get_Alignment();
public: __property void set_Alignment(ContentAlignment);
[JScript]
public function get Alignment() : ContentAlignment
public function set Alignment(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Bounds Property

Lidor Systems Collector Class Library

PageTableCell.Bounds Property

Gets or sets the size and location of the PageTableCell object.

[Visual Basic]
Public Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get; set;}
[C++]
public: __property Rectangle get_Bounds();
public: __property void set_Bounds(Rectangle);
[JScript]
public function get Bounds() : Rectangle;
public function set Bounds(Rectangle);

Property Value

The Rectangle that represents the size and location of the PageTableCell object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainedColumnCells Property

Lidor Systems Collector Class Library

PageTableCell.ContainedColumnCells Property

Gets or sets the number of contained cells in horizontal direction.

[Visual Basic]
Public Property ContainedColumnCells As Integer
[C#]
public int ContainedColumnCells {get; set;}
[C++]
public: __property int get_ContainedColumnCells();
public: __property void set_ContainedColumnCells(int);
[JScript]
public function get ContainedColumnCells() : int;
public function set ContainedColumnCells(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainedRowCells Property

Lidor Systems Collector Class Library

PageTableCell.ContainedRowCells Property

Gets or sets the number of contained cells in vertical direction.

[Visual Basic]
Public Property ContainedRowCells As Integer
[C#]
public int ContainedRowCells {get; set;}
[C++]
public: __property int get_ContainedRowCells();
public: __property void set_ContainedRowCells(int);
[JScript]
public function get ContainedRowCells() : int;
public function set ContainedRowCells(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Content Property

Lidor Systems Collector Class Library

PageTableCell.Content Property

Gets or sets the object in the PageTableCell.

[Visual Basic]
Public Property Content As Object
[C#]
public object Content {get; set;}
[C++]
public: __property Object* get_Content();
public: __property void set_Content(Object*);
[JScript]
public function get Content() : Object;
public function set Content(Object);

Property Value

The object to be contained in the PageTableCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Merged Property

Lidor Systems Collector Class Library

PageTableCell.Merged Property

Determines whether the PageTableCell object is merged by another cell.

[Visual Basic]
Public Property Merged As Boolean
[C#]
public bool Merged { get; set; }
[C++]
public: __property bool get_Merged();
public: __property void set_Merged(bool );
[JScript]
public function get Merged() : bool
public function set Merged(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ParentCell Property

Lidor Systems Collector Class Library

PageTableCell.ParentCell Property

Gets or sets the location of cell to which a PageTableCell object is merged.

[Visual Basic]
Public Property ParentCell As Point
[C#]
public Point ParentCell { get; set; }
[C++]
public: __property Point get_ParentCell();
public: __property void set_ParentCell(Point);
[JScript]
public function get ParentCell() : Point
public function set ParentCell(Point);

Property Value

The Point that represents the location of parent cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Position Property

Lidor Systems Collector Class Library

PageTableCell.Position Property

Gets or sets the location of cell in a PageTable object.

[Visual Basic]
Public Property Position As Point
[C#]
public Point Position { get; set; }
[C++]
public: __property Point get_Position();
public: __property void set_Position(Point);
[JScript]
public function get Position() : Point
public function set Position(Point);

Property Value

The Point that represents the location of cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCell Class | PageTableCell Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCellCollection Class

Contains a collection of PageTableCell objects.

For a list of all members of this type, see PageTableCellCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.Collector.PageTableCellCollection

[Visual Basic]
Public Class PageTableCellCollection
   Inherits CollectionBase
[C#]
public class PageTableCellCollection : CollectionBase
[C++]
public __gc class PageTableCellCollection : public CollectionBase
[JScript]
public class PageTableCellCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCellCollection Members

PageTableCellCollection overview

Public Constructors

public constructor PageTableCellCollection Constructor Initializes a new instance of the PageTableCellCollection class.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableCell at the specified location in the collection.
public property Parent | Gets the PageTableColumn object that owns the PageTableCellCollection.

Public Methods

public method Add | Adds a new PageTableCell to the end of the PageTableCellCollection.
public method AddRange | Adds an array of cells to the PageTableCellCollection.
public method Contains | Determines whether the specified PageTableCell object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableCell in the collection.
public method Insert | Inserts an existing PageTableCell object in the PageTableCellCollection at the specified location.
public method Remove | Removes the specified PageTableCell from the PageTableCellCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableCellCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCellCollection Constructor (PageTableColumn)

Initializes a new instance of the PageTableCellCollection class and assigns to PageTableColumn object.

[Visual Basic]
Public Sub New( _
   ByVal owner As PageTableColumn _
)
[C#]
public PageTableCellCollection(
   PageTableColumn owner
);
[C++]
public: PageTableCellCollection(
   PageTableColumn* owner
);
[JScript]
public function PageTableCellCollection(
   owner : PageTableColumn
);

Parameters

owner
The PageTableColumn to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCellCollection Properties

The properties of the PageTableCellCollection class are listed here. For a complete list of PageTableCellCollection class members, see the PageTableCellCollection Members topic.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableCell at the specified location in the collection.
public property Parent | Gets the PageTableColumn object that owns the PageTableCellCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

PageTableCellCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Item Property

Lidor Systems Collector Class Library

PageTableCellCollection.Item Property

Gets or sets a PageTableCell at the specified location in the collection.

[Visual Basic]
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As PageTableCell
[C#]
public virtual PageTableCell this[
   int index
] {get; set;}
[C++]
public: __property virtual PageTableCell* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   PageTableCell*
);

Parameters

index
The 0-based index of the PageTableCell to get or set.

Property Value

The PageTableCell at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The value is not a PageTableCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

PageTableCellCollection.Parent Property

Gets or sets the PageTableColumn that owns the PageTableCellCollection.

[Visual Basic]
Public Property Parent As PageTableColumn
[C#]
public PageTableColumn Parent { get; set; }
[C++]
public: __property PageTableColumn* get_Parent();
public: __property void set_Parent(PageTableColumn);
[JScript]
public function get Parent() : PageTableColumn
public function set Parent(PageTableColumn);

Property Value

Represents the PageTableColumn object that owns the PageTableCellCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableCellCollection Methods

The methods of the PageTableCellCollection class are listed here. For a complete list of PageTableCellCollection class members, see the PageTableCellCollection Members topic.

Public Methods

public method Add | Adds a new PageTableCell to the end of the PageTableCellCollection.
public method AddRange | Adds an array of cells to the PageTableCellCollection.
public method Contains | Determines whether the specified PageTableCell object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableCell in the collection.
public method Insert | Inserts an existing PageTableCell object in the PageTableCellCollection at the specified location.
public method Remove | Removes the specified PageTableCell from the PageTableCellCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableCellCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (PageTableCell) Method

Lidor Systems Collector Class Library

PageTableCellCollection.Add (PageTableCell) Method

Adds a new PageTableCell to the end of the PageTableCellCollection.

[Visual Basic]
Public Sub Add( _
   ByVal cell As PageTableCell _
)
[C#]
public void Add(
   PageTableCell cell
);
[C++]
public: void Add(
   PageTableCell* cell
);
[JScript]
public function Add(
   cell : PageTableCell
);

Parameters

cell
The PageTableCell object to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AddRange Method

Lidor Systems Collector Class Library

PageTableCellCollection.AddRange Method

Adds an array of cells to the PageTableCellCollection.

[Visual Basic]
Public Sub AddRange( _
   ByVal cells() As PageTableCell _
)
[C#]
public void AddRange(
   PageTableCell[] cells
);
[C++]
public: void AddRange(
   PageTableCell* cells[]
);
[JScript]
public function AddRange(
   cells : PageTableCell[]
);

Parameters

cells
An array of type PageTableCell that contains the cells to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of cells equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Contains Method

Lidor Systems Collector Class Library

PageTableCellCollection.Contains Method

Determines whether the specified PageTableCell object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal cell As PageTableCell _
) As Boolean
[C#]
public bool Contains(
   PageTableCell cell
);
[C++]
public: bool Contains(
   PageTableCell* cell
);
[JScript]
public function Contains(
   cell : PageTableCell
) : Boolean;

Parameters

cell
The PageTableCell to locate in the collection.

Return Value

true if the specified PageTableCell is in the collection; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of cell is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IndexOf Method

Lidor Systems Collector Class Library

PageTableCellCollection.IndexOf Method

Returns the index of the specified PageTableCell in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal cell As PageTableCell _
) As Integer
[C#]
public int IndexOf(
   PageTableCell cell
);
[C++]
public: int IndexOf(
   PageTableCell* cell
);
[JScript]
public function IndexOf(
   cell : PageTableCell
) : int;

Parameters

cell
The PageTableCell to locate in the collection.

Return Value

The zero-based index of the item found in the PageTableCellCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Insert Method

Lidor Systems Collector Class Library

PageTableCellCollection.Insert Method

Inserts a PageTableCell object in the PageTableCellCollection at the specified location.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal cell As PageTableCell _
)
[C#]
public void Insert(
   int index,
   PageTableCell cell
);
[C++]
public: void Insert(
   int index,
   PageTableCell* cell
);
[JScript]
public function Insert(
   index : int,
   cell : PageTableCell
);

Parameters

index
The indexed location within the collection to insert the PageTableCell.
cell
The PageTableCell to insert into the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Remove Method

Lidor Systems Collector Class Library

PageTableCellCollection.Remove Method

Removes a PageTableCell from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal cell As PageTableCell _
)
[C#]
public void Remove(
   PageTableCell cell
);
[C++]
public: void Remove(
   PageTableCell* cell
);
[JScript]
public function Remove(
   cell : PageTableCell
);

Parameters

cell
The PageTableCell to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The cell parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableCellCollection Class | PageTableCellCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumn Class

Represents a column in a PageTable object.

For a list of all members of this type, see PageTableColumn Members.

System.Object
LidorSystems.Collector.PageTableColumn

[Visual Basic]
Public Class PageTableColumn
[C#]
public class PageTableColumn
[C++]
public __gc class PageTableColumn
[JScript]
public class PageTableColumn

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableColumn Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumn Members

PageTableColumn overview

Public Constructors

public constructor PageTableColumn Constructor Initializes a new instance of the PageTableColumn class.

Public Properties

public property Alignment | Gets or sets the alignment of contained objects in the PageTableColumn cells.
public property Cells | Gets the collection of PageTableCells in the PageTableColumn object.
public property SizeType | Gets or sets the type of column size.
public property Width | Gets or sets the width of the column.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageTableColumn Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumn Constructor

Initializes a new instance of the PageTableColumn class.

[Visual Basic]
Public Sub New()
[C#]
public PageTableColumn();
[C++]
public: PageTableColumn();
[JScript]
public function PageTableColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumn Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumn Properties

The properties of the PageTableColumn class are listed here. For a complete list of PageTableColumn class members, see the PageTableColumn Members topic.

Public Properties

public property Alignment | Gets or sets the alignment of contained objects in the PageTableColumn cells.
public property Cells | Gets the collection of PageTableCells in the PageTableColumn object.
public property SizeType | Gets or sets an enumeration that determines the type of column size.
public property Width | Gets or sets the width of the column.

See Also

PageTableColumn Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Alignment Property

Lidor Systems Collector Class Library

PageTableColumn.Alignment Property

Gets or sets the alignment of contained objects in the PageTableColumn cells.

[Visual Basic]
Public Property Alignment As ContentAlignment
[C#]
public ContentAlignment Alignment { get; set; }
[C++]
public: __property ContentAlignment get_Alignment();
public: __property void set_Alignment(ContentAlignment);
[JScript]
public function get Alignment() : ContentAlignment
public function set Alignment(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumn Class | PageTableColumn Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Cells Property

Lidor Systems Collector Class Library

PageTableColumn.Cells Property

Gets the collection of PageTableCells in the PageTableColumn object.

[Visual Basic]
Public ReadOnly Property Cells As PageTableCellCollection
[C#]
public PageTableCellCollection Cells {get;}
[C++]
public: __property PageTableCellCollection* get_Cells();
[JScript]
public function get Cells() : PageTableCellCollection;

Property Value

A PageTableCellCollection that contains the PageTableCell objects in this PageTableColumn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumn Class | PageTableColumn Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SizeType Property

Lidor Systems Collector Class Library

PageTableColumn.SizeType Property

Gets or sets an enumeration that determines the type of column size.

[Visual Basic]
Public Property SizeType As SizeTypes
[C#]
public SizeTypes SizeType {get; set;}
[C++]
public: __property SizeTypes get_SizeType();
public: __property void set_SizeType(SizeTypes);
[JScript]
public function get SizeType() : SizeTypes;
public function set SizeType(SizeTypes);

Property Value

The SizeTypes assigned to the PageTableColumn object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumn Class | PageTableColumn Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Width Property

Lidor Systems Collector Class Library

PageTableColumn.Width Property

Gets or sets the width of the column.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(int);
[JScript]
public function get Width() : int;
public function set Width(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumn Class | PageTableColumn Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumnCollection Class

Contains a collection of PageTableColumn objects.

For a list of all members of this type, see PageTableColumnCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.Collector.PageTableColumnCollection

[Visual Basic]
Public Class PageTableColumnCollection
   Inherits CollectionBase
[C#]
public class PageTableColumnCollection : CollectionBase
[C++]
public __gc class PageTableColumnCollection : public CollectionBase
[JScript]
public class PageTableColumnCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumnCollection Members

PageTableColumnCollection overview

Public Constructors

public constructor PageTableColumnCollection Constructor Initializes a new instance of the PageTableColumnCollection class.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableColumn at the specified location in the collection.
public property Parent | Gets the PageTable object that owns the PageTableColumnCollection.

Public Methods

public method Add | Adds a new PageTableColumn to the end of the PageTableColumnCollection.
public method AddRange | Adds an array of columns to the PageTableColumnCollection.
public method Contains | Determines whether the specified PageTableColumn object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableColumn in the collection.
public method Insert | Inserts an existing PageTableColumn object in the PageTableColumnCollection at the specified location.
public method Remove | Removes the specified PageTableColumn from the PageTableColumnCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableColumnCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumnCollection Constructor (PageTable)

Initializes a new instance of the PageTableColumnCollection class and assigns to PageTable object.

[Visual Basic]
Public Sub New( _
   ByVal owner As PageTable _
)
[C#]
public PageTableColumnCollection(
   PageTable owner
);
[C++]
public: PageTableColumnCollection(
   PageTable* owner
);
[JScript]
public function PageTableColumnCollection(
   owner : PageTable
);

Parameters

owner
The PageTable to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumnCollection Properties

The properties of the PageTableColumnCollection class are listed here. For a complete list of PageTableColumnCollection class members, see the PageTableColumnCollection Members topic.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableColumn at the specified location in the collection.
public property Parent | Gets the PageTable object that owns the PageTableColumnCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

PageTableColumnCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Item Property

Lidor Systems Collector Class Library

PageTableColumnCollection.Item Property

Gets or sets a PageTableColumn at the specified location in the collection.

[Visual Basic]
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As PageTableColumn
[C#]
public virtual PageTableColumn this[
   int index
] {get; set;}
[C++]
public: __property virtual PageTableColumn* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   PageTableColumn*
);

Parameters

index
The 0-based index of the PageTableColumn to get or set.

Property Value

The PageTableColumn at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The value is not a PageTableColumn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

PageTableColumnCollection.Parent Property

Gets or sets the PageTable that owns the PageTableColumnCollection.

[Visual Basic]
Public Property Parent As PageTable
[C#]
public PageTable Parent { get; set; }
[C++]
public: __property PageTable* get_Parent();
public: __property void set_Parent(PageTable);
[JScript]
public function get Parent() : PageTable
public function set Parent(PageTable);

Property Value

Represents the PageTable object that owns the PageTableColumnCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableColumnCollection Methods

The methods of the PageTableColumnCollection class are listed here. For a complete list of PageTableColumnCollection class members, see the PageTableColumnCollection Members topic.

Public Methods

public method Add | Adds a new PageTableColumn to the end of the PageTableColumnCollection.
public method AddRange | Adds an array of columns to the PageTableColumnCollection.
public method Contains | Determines whether the specified PageTableColumn object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableColumn in the collection.
public method Insert | Inserts an existing PageTableColumn object in the PageTableColumnCollection at the specified location.
public method Remove | Removes the specified PageTableColumn from the PageTableColumnCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableColumnCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (PageTableColumn) Method

Lidor Systems Collector Class Library

PageTableColumnCollection.Add (PageTableColumn) Method

Adds a new PageTableColumn to the end of the PageTableColumnCollection.

[Visual Basic]
Public Sub Add( _
   ByVal col As PageTableColumn _
)
[C#]
public void Add(
   PageTableColumn col
);
[C++]
public: void Add(
   PageTableColumn* col
);
[JScript]
public function Add(
   col : PageTableColumn
);

Parameters

col
The PageTableColumn to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AddRange Method

Lidor Systems Collector Class Library

PageTableColumnCollection.AddRange Method

Adds an array of columns to the PageTableColumnCollection.

[Visual Basic]
Public Sub AddRange( _
   ByVal columns() As PageTableColumn _
)
[C#]
public void AddRange(
   PageTableColumn[] columns
);
[C++]
public: void AddRange(
   PageTableColumn* columns[]
);
[JScript]
public function AddRange(
   columns : PageTableColumn[]
);

Parameters

columns
An array of type PageTableColumn that contains the columns to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of columns equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Contains Method

Lidor Systems Collector Class Library

PageTableColumnCollection.Contains Method

Determines whether the specified PageTableColumn object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal col As PageTableColumn _
) As Boolean
[C#]
public bool Contains(
   PageTableColumn col
);
[C++]
public: bool Contains(
   PageTableColumn* col
);
[JScript]
public function Contains(
   col : PageTableColumn
) : Boolean;

Parameters

col
The PageTableColumn to locate in the collection.

Return Value

true if the specified PageTableColumn is in the collection; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of col is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IndexOf Method

Lidor Systems Collector Class Library

PageTableColumnCollection.IndexOf Method

Returns the index of the specified PageTableColumn in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal col As PageTableColumn _
) As Integer
[C#]
public int IndexOf(
   PageTableColumn col
);
[C++]
public: int IndexOf(
   PageTableColumn* col
);
[JScript]
public function IndexOf(
   col : PageTableColumn
) : int;

Parameters

col
The PageTableColumn to locate in the collection.

Return Value

The zero-based index of the item found in the PageTableColumnCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Insert Method

Lidor Systems Collector Class Library

PageTableColumnCollection.Insert Method

Inserts a PageTableColumn object in the PageTableColumnCollection at the specified location.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal col As PageTableColumn _
)
[C#]
public void Insert(
   int index,
   PageTableColumn col
);
[C++]
public: void Insert(
   int index,
   PageTableColumn* col
);
[JScript]
public function Insert(
   index : int,
   col : PageTableColumn
);

Parameters

index
The indexed location within the collection to insert the PageTableColumn.
col
The PageTableColumn to insert into the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Remove Method

Lidor Systems Collector Class Library

PageTableColumnCollection.Remove Method

Removes a PageTableColumn from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal col As PageTableColumn _
)
[C#]
public void Remove(
   PageTableColumn col
);
[C++]
public: void Remove(
   PageTableColumn* col
);
[JScript]
public function Remove(
   col : PageTableColumn
);

Parameters

col
The PageTableColumn to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The col parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableColumnCollection Class | PageTableColumnCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRow Class

Represents a row in a PageTable object.

For a list of all members of this type, see PageTableRow Members.

System.Object
LidorSystems.Collector.PageTableRow

[Visual Basic]
Public Class PageTableRow
[C#]
public class PageTableRow
[C++]
public __gc class PageTableRow
[JScript]
public class PageTableRow

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableRow Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRow Members

PageTableRow overview

Public Constructors

public constructor PageTableRow Constructor Initializes a new instance of the PageTableRow class.

Public Properties

public property SizeType | Gets or sets the type of row size.
public property Height | Gets or sets the height of the row.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageTableRow Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRow Constructor

Initializes a new instance of the PageTableRow class.

[Visual Basic]
Public Sub New()
[C#]
public PageTableRow();
[C++]
public: PageTableRow();
[JScript]
public function PageTableRow();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRow Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRow Properties

The properties of the PageTableRow class are listed here. For a complete list of PageTableRow class members, see the PageTableRow Members topic.

Public Properties

public property Alignment | Gets or sets the alignment of contained objects in the PageTableRow cells.
public property SizeType | Gets or sets an enumeration that determines the type of row size.
public property Height | Gets or sets the height of the row.

See Also

PageTableRow Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Alignment Property

Lidor Systems Collector Class Library

PageTableRow.Alignment Property

Gets or sets the alignment of contained objects in the PageTableRow cells.

[Visual Basic]
Public Property Alignment As ContentAlignment
[C#]
public ContentAlignment Alignment { get; set; }
[C++]
public: __property ContentAlignment get_Alignment();
public: __property void set_Alignment(ContentAlignment);
[JScript]
public function get Alignment() : ContentAlignment
public function set Alignment(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRow Class | PageTableRow Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Height Property

Lidor Systems Collector Class Library

PageTableRow.Height Property

Gets or sets the height of the row.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(int);
[JScript]
public function get Height() : int;
public function set Height(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRow Class | PageTableRow Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SizeType Property

Lidor Systems Collector Class Library

PageTableRow.SizeType Property

Gets or sets an enumeration that determines the type of row size.

[Visual Basic]
Public Property SizeType As SizeTypes
[C#]
public SizeTypes SizeType {get; set;}
[C++]
public: __property SizeTypes get_SizeType();
public: __property void set_SizeType(SizeTypes);
[JScript]
public function get SizeType() : SizeTypes;
public function set SizeType(SizeTypes);

Property Value

The SizeTypes assigned to the PageTableRow object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRow Class | PageTableRow Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRowCollection Class

Contains a collection of PageTableRow objects.

For a list of all members of this type, see PageTableRowCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.Collector.PageTableRowCollection

[Visual Basic]
Public Class PageTableRowCollection
   Inherits CollectionBase
[C#]
public class PageTableRowCollection : CollectionBase
[C++]
public __gc class PageTableRowCollection : public CollectionBase
[JScript]
public class PageTableRowCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRowCollection Members

PageTableRowCollection overview

Public Constructors

public constructor PageTableRowCollection Constructor Initializes a new instance of the PageTableRowCollection class.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableRow at the specified location in the collection.
public property Parent | Gets the PageTable object that owns the PageTableRowCollection.

Public Methods

public method Add | Adds a new PageTableRow to the end of the PageTableRowCollection.
public method AddRange | Adds an array of rows to the PageTableRowCollection.
public method Contains | Determines whether the specified PageTableRow object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableRow in the collection.
public method Insert | Inserts an existing PageTableRow object in the PageTableRowCollection at the specified location.
public method Remove | Removes the specified PageTableRow from the PageTableRowCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableRowCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRowCollection Constructor (PageTable)

Initializes a new instance of the PageTableRowCollection class and assigns to PageTable object.

[Visual Basic]
Public Sub New( _
   ByVal owner As PageTable _
)
[C#]
public PageTableRowCollection(
   PageTable owner
);
[C++]
public: PageTableRowCollection(
   PageTable* owner
);
[JScript]
public function PageTableRowCollection(
   owner : PageTable
);

Parameters

owner
The PageTable to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRowCollection Properties

The properties of the PageTableRowCollection class are listed here. For a complete list of PageTableRowCollection class members, see the PageTableRowCollection Members topic.

Public Properties

public property Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
public property Item | Gets or sets a PageTableRow at the specified location in the collection.
public property Parent | Gets the PageTable object that owns the PageTableRowCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

PageTableRowCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Item Property

Lidor Systems Collector Class Library

PageTableRowCollection.Item Property

Gets or sets a PageTableRow at the specified location in the collection.

[Visual Basic]
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As PageTableRow
[C#]
public virtual PageTableRow this[
   int index
] {get; set;}
[C++]
public: __property virtual PageTableRow* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   PageTableRow*
);

Parameters

index
The 0-based index of the PageTableRow to get or set.

Property Value

The PageTableRow at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The value is not a PageTableRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

PageTableRowCollection.Parent Property

Gets or sets the PageTable that owns the PageTableRowCollection.

[Visual Basic]
Public Property Parent As PageTable
[C#]
public PageTable Parent { get; set; }
[C++]
public: __property PageTable* get_Parent();
public: __property void set_Parent(PageTable);
[JScript]
public function get Parent() : PageTable
public function set Parent(PageTable);

Property Value

Represents the PageTable object that owns the PageTableRowCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageTableRowCollection Methods

The methods of the PageTableRowCollection class are listed here. For a complete list of PageTableRowCollection class members, see the PageTableRowCollection Members topic.

Public Methods

public method Add | Adds a new PageTableRow to the end of the PageTableRowCollection.
public method AddRange | Adds an array of rows to the PageTableRowCollection.
public method Contains | Determines whether the specified PageTableRow object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified PageTableRow in the collection.
public method Insert | Inserts an existing PageTableRow object in the PageTableRowCollection at the specified location.
public method Remove | Removes the specified PageTableRow from the PageTableRowCollection.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PageTableRowCollection Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Add (PageTableRow) Method

Lidor Systems Collector Class Library

PageTableRowCollection.Add (PageTableRow) Method

Adds a new PageTableRow to the end of the PageTableRowCollection.

[Visual Basic]
Public Sub Add( _
   ByVal row As PageTableRow _
)
[C#]
public void Add(
   PageTableRow row
);
[C++]
public: void Add(
   PageTableRow* row
);
[JScript]
public function Add(
   row : PageTableRow
);

Parameters

row
The PageTableRow to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AddRange Method

Lidor Systems Collector Class Library

PageTableRowCollection.AddRange Method

Adds an array of rows to the PageTableRowCollection.

[Visual Basic]
Public Sub AddRange( _
   ByVal rows() As PageTableRow _
)
[C#]
public void AddRange(
   PageTableRow[] rows
);
[C++]
public: void AddRange(
   PageTableRow* rows[]
);
[JScript]
public function AddRange(
   rows : PageTableRow[]
);

Parameters

rows
An array of type PageTableRow that contains the rows to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of rows equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Contains Method

Lidor Systems Collector Class Library

PageTableRowCollection.Contains Method

Determines whether the specified PageTableRow object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal row As PageTableRow _
) As Boolean
[C#]
public bool Contains(
   PageTableRow row
);
[C++]
public: bool Contains(
   PageTableRow* row
);
[JScript]
public function Contains(
   row : PageTableRow
) : Boolean;

Parameters

row
The PageTableRow to locate in the collection.

Return Value

true if the specified PageTableRow is in the collection; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of row is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


IndexOf Method

Lidor Systems Collector Class Library

PageTableRowCollection.IndexOf Method

Returns the index of the specified PageTableRow in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal row As PageTableRow _
) As Integer
[C#]
public int IndexOf(
   PageTableRow row
);
[C++]
public: int IndexOf(
   PageTableRow* row
);
[JScript]
public function IndexOf(
   row : PageTableRow
) : int;

Parameters

row
The PageTableRow to locate in the collection.

Return Value

The zero-based index of the item found in the PageTableRowCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Insert Method

Lidor Systems Collector Class Library

PageTableRowCollection.Insert Method

Inserts a PageTableRow object in the PageTableRowCollection at the specified location.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal row As PageTableRow _
)
[C#]
public void Insert(
   int index,
   PageTableRow row
);
[C++]
public: void Insert(
   int index,
   PageTableRow* row
);
[JScript]
public function Insert(
   index : int,
   row : PageTableRow
);

Parameters

index
The indexed location within the collection to insert the PageTableRow.
row
The PageTableRow to insert into the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Remove Method

Lidor Systems Collector Class Library

PageTableRowCollection.Remove Method

Removes a PageTableRow from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal row As PageTableRow _
)
[C#]
public void Remove(
   PageTableRow row
);
[C++]
public: void Remove(
   PageTableRow* row
);
[JScript]
public function Remove(
   row : PageTableRow
);

Parameters

row
The PageTableRow to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The row parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageTableRowCollection Class | PageTableRowCollection Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CancelableCollectorEventHandler Delegate

Represents the method that will handle the cancelable events of a Bar, Group, Page control.

[Visual Basic]
Public Delegate Sub CancelableCollectorEventHandler( _
   ByVal sender As Object, _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
public Delegate void CancelableCollectorEventHandler(
   object sender,
   CancelableCollectorEventArgs e
);
[C++]
public __gc __delegate void CancelableCollectorEventHandler(
   Object* sender,
   CancelableCollectorEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the CancelableCollectorEventHandler Delegate declaration.

sender
The source of the event.
e
A CancelableCollectorEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDragEventHandler Delegate

Represents the method that will handle dragging events of a Bar, Group, Page control.

[Visual Basic]
Public Delegate Sub CollectorDragEventHandler( _
   ByVal sender As Object, _
   ByVal de As CollectorDragEventArgs _
)
[C#]
public Delegate void CollectorDragEventHandler(
   object sender,
   CollectorDragEventArgs de
);
[C++]
public __gc __delegate void CollectorDragEventHandler(
   Object* sender,
   CollectorDragEventArgs* de
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the CollectorDragEventHandler Delegate declaration.

sender
The source of the event.
de
A CollectorDragEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorDropEventHandler Delegate

Represents the method that will handle dropping events of a Bar, Group, Page control.

[Visual Basic]
Public Delegate Sub CollectorDropEventHandler( _
   ByVal sender As Object, _
   ByVal de As CollectorDropEventArgs _
)
[C#]
public Delegate void CollectorDropEventHandler(
   object sender,
   CollectorDropEventArgs de
);
[C++]
public __gc __delegate void CollectorDropEventHandler(
   Object* sender,
   CollectorDropEventArgs* de
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the CollectorDropEventHandler Delegate declaration.

sender
The source of the event.
de
A CollectorDropEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CollectorEventHandler Delegate

Represents the method that will handle custom events of a Bar, Group, Page control.

[Visual Basic]
Public Delegate Sub CollectorEventHandler( _
   ByVal sender As Object, _
   ByVal e As CollectorEventArgs _
)
[C#]
public Delegate void CollectorEventHandler(
   object sender,
   CollectorEventArgs e
);
[C++]
public __gc __delegate void CollectorEventHandler(
   Object* sender,
   CollectorEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the CollectorEventHandler Delegate declaration.

sender
The source of the event.
e
A CollectorEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AcceptType Enumeration

Enumerator used to determine objects that can be accepted by the Bar or Group control.

[Visual Basic]
Public Enum AcceptType
[C#]
public enum AcceptType
[C++]
__value public enum AcceptType
[JScript]
public
   enum AcceptType

Members

Member name | Description
Documents | Only one Documents can be accepted.
ToolWindows | Only one ToolWindows can be accepted.
Both | There is no restriction.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ActiveMode Enumeration

Enumerator used to determine how many Groups are active in the Bar control.

[Visual Basic]
Public Enum ActiveMode
[C#]
public enum ActiveMode
[C++]
__value public enum ActiveMode
[JScript]
public
   enum ActiveMode

Members

Member name | Description
Single | Only one Groups can be active.
Multiple | Multiple Groups can be active, depending of the height of their parent Bar control and height of their MinimumHeight property.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AnimationSpeed Enumeration

Enumerator used to determine the speed of the animation within the LidorSystems.Collector controls.

[Visual Basic]
Public Enum AnimationSpeed
[C#]
public enum AnimationSpeed
[C++]
__value public enum AnimationSpeed
[JScript]
public
   enum AnimationSpeed

Members

Member name | Description
Slow | Animation speed is half then the normal speed.
Normal | Animation speed is normal.
Fast | Animation speed is double then the normal speed.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseAction Enumeration

Enumerator used to determine how the object will be closed.

[Visual Basic]
Public Enum CloseAction
[C#]
public enum CloseAction
[C++]
__value public enum CloseAction
[JScript]
public
   enum CloseAction

Members

Member name | Description
Dispose | The closing object will be disposed.
Hide | The closing object will be hidden.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlCondition Enumeration

Enumerator used to determine the current condition of the control.

[Visual Basic]
Public Enum ControlCondition
[C#]
public enum ControlCondition
[C++]
__value public enum ControlCondition
[JScript]
public
   enum ControlCondition

Members

Member name | Description
Disabled | The control is disabled.
Hover | The mouse pointer hovers over control space.
Normal | A default condition of control.
Selected | The control is selected.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlState Enumeration

Enumerator used to determine the current state of the control.

[Visual Basic]
Public Enum ControlState
[C#]
public enum ControlState
[C++]
__value public enum ControlState
[JScript]
public
   enum ControlState

Members

Member name | Description
Static | The control placed in container can not be moved.
Docked | The control is docked to one edge of its container.
Floating | The control is floating.
Framed | The control is framed. Used for creation of standard MDI. Only applies to Group controls.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlType Enumeration

Enumerator used to determine the type of control.

[Visual Basic]
Public Enum ControlType
[C#]
public enum ControlType
[C++]
__value public enum ControlType
[JScript]
public
   enum ControlType

Members

Member name | Description
Document | The control act like document window.
ToolWindow | The control act like tool window.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DockHintStyle Enumeration

Enumerator used to determine the docking hint style of the control.

[Visual Basic]
Public Enum DockHintStyle
[C#]
public enum DockHintStyle
[C++]
__value public enum DockHintStyle
[JScript]
public
   enum DockHintStyle

Members

Member name | Description
RubberBand | When control is dragged displays reversable frame to show the location where can be droped.
TranslucentClone | When control is dragged displays translucent clone of itself and reversable frame to show the location where can be droped.
TranslucentFill | When control is dragged displays translucent frame to show the location where can be droped.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DockPermission Enumeration

Enumerator used to determine the dock side on which control can be docked.

[Visual Basic]
<Flags>
Public Enum DockPermission
[C#]
[Flags]
public enum DockPermission
[C++]
[Flags]
__value public enum DockPermission
[JScript]
public
   Flags
enum DockPermission

Members

Member name | Description | Value
All | The control can be docked to all edges of target container. | 31
Bottom | The control can be docked to the bottom edge of target container. | 8
Fill | The control can be added or fill to the target container. | 16
Left | The control can be docked to the left edge of target container. | 1
None | The control can not be docked to any edge of target container. | 0
Right | The control can be docked to the right edge of target container. | 4
Top | The control can be docked to the top edge of target container. | 2

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SizeType Enumeration

Enumerator used to determine the type of PageTableColumn and PageTableRow size.

[Visual Basic]
Public Enum SizeType
[C#]
public enum SizeType
[C++]
__value public enum SizeType
[JScript]
public
   enum SizeType

Members

Member name | Description
AutoSize | Resize column width and row height to the size of the bigest contained object.
Fixed | The column width and row height are fixed.
Percent | The column width and row height values represents percent of grid width and height.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SpliterType Enumeration

Enumerator used to determine the type of spliter.

[Visual Basic]
Public Enum SpliterType
[C#]
public enum SpliterType
[C++]
__value public enum SpliterType
[JScript]
public
   enum SpliterType

Members

Member name | Description
Horizontal | The spliter is horizontal.
Undefined | The spliter is not defined.
Vertical | The spliter is vertical.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabMode Enumeration

Specifies how tabs in a Bar, Group control are sized.

[Visual Basic]
Public Enum TabMode
[C#]
public enum TabMode
[C++]
__value public enum TabMode
[JScript]
public
   enum TabMode

Remarks

This enumeration is used by members such as Bar.TabMode, Group.TabMode.

Members

Member name | Description
AutoSized | The width of each tab is sized so that each tab contains text and image.
Compressed | Only the active tab shows text and image, others show only image.
Justified | Size split amongst tabs if not enough room, otherwise auto-sized.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VerticalAlignment Enumeration

Specifies how an object or text in a control is vertically aligned relative to an element of the control.

[Visual Basic]
Public Enum VerticalAlignment
[C#]
public enum VerticalAlignment
[C++]
__value public enum VerticalAlignment
[JScript]
public
   enum VerticalAlignment

Remarks

This enumeration is used by members such as PageTableRow.Alignment.

Members

Member name | Description
Top | The object or text is aligned on the top of the control element.
Center | The object or text is aligned in the center of the control element.
Bottom | The object or text is aligned on the bottom of the control element.

Requirements

Namespace: LidorSystems.Collector

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


LidorSystems.Collector.Style

.NET Framework Class Library

LidorSystems.Collector.Style Namespace

Classes

Class | Description
AutoHideBarStyle | Represents the style of the AutoHideBar control.
BarStyle | Represents the style of the Bar control.
CommonButtonStyle | Represents the style with common attributes for all buttons.
CommonHeaderStyle | Represents the style with common attributes for all headers.
CommonStyle | Represents the style with common attributes for all styles.
ContainerImage | Specifies the image for a container control which is being shown inside it.
GroupStyle | Represents the style of the Group control.
HeaderStyle | Represents the style of header.
PageStyle | Represents the style of the Page control.
TabStripButtonStyle | Represents the style of tabstrip buttons.
TabStyle | Represents the style of tabs.

Enumerations

Enumeration | Description
ColorScheme | Enumerator used to set the style colors of the Bar, Group, Page control.
ControlAppearance | Enumerator used to determine the appearance of the Bar control.
FillStyle | Specifies the fill mode of the internal area of the Bar, Group, Page control.
ImageSize | Specifies the size of the image of a container control.
TabOrientation | Specifies orientation of tabs on the drawing surface.
VisualStyle | Specifies the visual style of the Bar, Group, Page control.

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Class

Represents the style of the AutoHideBar control.

For a list of all members of this type, see AutoHideBarStyle Members.

System.Object
LidorSystems.Collector.Style.AutoHideBarStyle

[Visual Basic]
Public Class AutoHideBarStyle
[C#]
public class AutoHideBarStyle
[C++]
public __gc class AutoHideBarStyle
[JScript]
public class AutoHideBarStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Members

AutoHideBarStyle overview

Public Constructors

public constructor AutoHideBarStyle Constructor Initializes a new instance of the AutoHideBarStyle class.

Public Properties

public property BackgroundStyle | Gets or sets the background style.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the AutoHideBar.
public property Font | Gets or sets the font used to display the text in the AutoHideBar control.
public property TabStyle | Gets or sets the style of tabs.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

AutoHideBarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Constructor ()

Initializes a new instance of the AutoHideBarStyle class.

[Visual Basic]
Public Sub New()
[C#]
public AutoHideBarStyle();
[C++]
public: AutoHideBarStyle();
[JScript]
public function AutoHideBarStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Properties

The properties of the AutoHideBarStyle class are listed here. For a complete list of AutoHideBarStyle class members, see the AutoHideBarStyle Members topic.

Public Properties

public property BackgroundStyle | Gets or sets the background style.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the AutoHideBar.
public property Font | Gets or sets the font used to display the text in the AutoHideBar control.
public property TabStyle | Gets or sets the style of tabs.

See Also

AutoHideBarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyle Property

Lidor Systems Collector Class Library

AutoHideBarStyle.BackgroundStyle Property

Gets or sets the background style of AutoHideBar control.

[Visual Basic]
Public Property BackgroundStyle As CommonStyle
[C#]
public CommonStyle BackgroundStyle {get; set;}
[C++]
public: __property CommonStyle get_BackgroundStyle();
public: __property void set_BackgroundStyle(CommonStyle);
[JScript]
public function get BackgroundStyle() : CommonStyle;
public function set BackgroundStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorScheme Property

Lidor Systems Collector Class Library

AutoHideBarStyle.ColorScheme Property

Gets or sets an enumeration that determines the ColorScheme of the AutoHideBar control.

[Visual Basic]
Public Property ColorScheme As ColorScheme
[C#]
public ColorScheme ColorScheme {get; set;}
[C++]
public: __property ColorScheme get_ColorScheme();
public: __property void set_ColorScheme(ColorScheme);
[JScript]
public function get ColorScheme() : ColorScheme;
public function set ColorScheme(ColorScheme);

Property Value

The ColorScheme assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Font Property

Lidor Systems Collector Class Library

AutoHideBarStyle.Font Property

Gets or sets the font used to display the text in the AutoHideBar control.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the text in the AutoHideBar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Property

Lidor Systems Collector Class Library

AutoHideBarStyle.TabStyle Property

Gets or sets the style of tabs.

[Visual Basic]
Public Property TabStyle As CommonStyle
[C#]
public CommonStyle TabStyle {get; set;}
[C++]
public: __property CommonStyle get_TabStyle();
public: __property void set_TabStyle(CommonStyle);
[JScript]
public function get TabStyle() : CommonStyle;
public function set TabStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Methods

The methods of the AutoHideBarStyle class are listed here. For a complete list of AutoHideBarStyle class members, see the AutoHideBarStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

AutoHideBarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackgroundStyleChanged Method

Lidor Systems Collector Class Library

AutoHideBarStyle.OnBackgroundStyleChanged Method

Raises the BackgroundStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackgroundStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackgroundStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackgroundStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnBackgroundStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackgroundStyleChanged in a derived class, be sure to call the base class's OnBackgroundStyleChanged method so that registered delegates receive the event.

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnColorSchemeChanged Method

Lidor Systems Collector Class Library

AutoHideBarStyle.OnColorSchemeChanged Method

Raises the ColorSchemeChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnColorSchemeChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnColorSchemeChanged(
   EventHandler e
);
[C++]
protected: virtual void OnColorSchemeChanged(
   EventHandler* e
);
[JScript]
protected function OnColorSchemeChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnColorSchemeChanged in a derived class, be sure to call the base class's OnColorSchemeChanged method so that registered delegates receive the event.

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnFontChanged Method

Lidor Systems Collector Class Library

AutoHideBarStyle.OnFontChanged Method

Raises the FontChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnFontChanged(
   EventHandler e
);
[C++]
protected: virtual void OnFontChanged(
   EventHandler* e
);
[JScript]
protected function OnFontChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnFontChanged in a derived class, be sure to call the base class's OnFontChanged method so that registered delegates receive the event.

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabStyleChanged Method

Lidor Systems Collector Class Library

AutoHideBarStyle.OnTabStyleChanged Method

Raises the TabStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnTabStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabStyleChanged in a derived class, be sure to call the base class's OnTabStyleChanged method so that registered delegates receive the event.

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideBarStyle Events

The events of the AutoHideBarStyle class are listed here. For a complete list of AutoHideBarStyle class members, see the AutoHideBarStyle Members topic.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

See Also

AutoHideBarStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyleChanged Event

Lidor Systems Collector Class Library

AutoHideBarStyle.BackgroundStyleChanged Event

Occurs when the value of the BackgroundStyle property changes.

[Visual Basic]
Public Event BackgroundStyleChanged As EventHandler
[C#]
public event EventHandler BackgroundStyleChanged;
[C++]
public: __event EventHandler* BackgroundStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorSchemeChanged Event

Lidor Systems Collector Class Library

AutoHideBarStyle.ColorSchemeChanged Event

Occurs when the value of the ColorScheme property changes.

[Visual Basic]
Public Event ColorSchemeChanged As EventHandler
[C#]
public event EventHandler ColorSchemeChanged;
[C++]
public: __event EventHandler* ColorSchemeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FontChanged Event

Lidor Systems Collector Class Library

AutoHideBarStyle.FontChanged Event

Occurs when the value of the Font property changes.

[Visual Basic]
Public Event FontChanged As EventHandler
[C#]
public event EventHandler FontChanged;
[C++]
public: __event EventHandler* FontChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyleChanged Event

Lidor Systems Collector Class Library

AutoHideBarStyle.TabStyleChanged Event

Occurs when the value of the TabStyle property changes.

[Visual Basic]
Public Event TabStyleChanged As EventHandler
[C#]
public event EventHandler TabStyleChanged;
[C++]
public: __event EventHandler* TabStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBarStyle Class | AutoHideBarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Class

Represents the style of the Bar control.

For a list of all members of this type, see BarStyle Members.

System.Object
LidorSystems.Collector.Style.BarStyle

[Visual Basic]
Public Class BarStyle
[C#]
public class BarStyle
[C++]
public __gc class BarStyle
[JScript]
public class BarStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Members

BarStyle overview

Public Constructors

public constructor BarStyle Constructor Initializes a new instance of the BarStyle class.

Public Properties

public property Appearance | Gets or sets an enumeration that determines the Appearance of pages in tab strip of the Bar.
public property BackgroundStyle | Gets or sets the background style.
public property CloseButton | Gets or sets the visibility of the close button of the Bar.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Bar.
public property ContextMenuButton | Gets or sets the visibility of the context menu button of the Bar.
public property Font | Gets or sets the font used to display the text in the Bar control.
public property GroupPadding | Gets or sets the amount of space used for alignment of Group caption text, in pixels.
public property GroupSpacing | Gets or sets the amount of space between tabs in tabstrip of Bar, in pixels.
public property GroupStyle | Gets or sets the GroupStyle of the groups in the Bar control.
public property HeaderStyle | Gets or sets the header style.
public property MoveButton | Gets or sets the visibility of the move button of the Bar.
public property ScrollingButtons | Gets or sets the visibility of the scrolling buttons of the Bar.
public property TabCloseButton | Gets or sets the visibility of the tab close button of the Bar.
public property TabSelectButton | Gets or sets the visibility of the tab select button of the Bar.
public property TabStripButtonStyle | Gets or sets the style of tabstrip buttons.

Public Events

public event AppearanceChanged | Occurs when the Appearance property value changes.
public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event CloseButtonChanged | Occurs when the CloseButton property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event ContextMenuButtonChanged | Occurs when the ContextMenuButton property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event GroupPaddingChanged | Occurs when the GroupPadding property value changes.
public event GroupSpacingChanged | Occurs when the GroupSpacing property value changes.
public event GroupStyleChanged | Occurs when the GroupStyle property value changes.
public event HeaderStyleChanged | Occurs when the HeaderStyle property value changes.
public event MoveButtonChanged | Occurs when the MoveButton property value changes.
public event ScrollingButtonsChanged | Occurs when the ScrollingButtons property value changes.
public event TabCloseButtonChanged | Occurs when the TabCloseButton property value changes.
public event TabSelectButtonChanged | Occurs when the TabSelectButton property value changes.
public event TabStripButtonStyleChanged | Occurs when the TabStripButtonStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAppearanceChanged | Raises the AppearanceChanged event.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnCloseButtonChanged | Raises the CloseButtonChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnContextMenuButtonChanged | Raises the ContextMenuButtonChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnGroupPaddingChanged | Raises the GroupPaddingChanged event.
protected method OnGroupSpacingChanged | Raises the GroupSpacingChanged event.
protected method OnGroupStyleChanged | Raises the GroupStyleChanged event.
protected method OnHeaderStyleChanged | Raises the HeaderStyleChanged event.
protected method OnMoveButtonChanged | Raises the MoveButtonChanged event.
protected method OnScrollingButtonsChanged | Raises the ScrollingButtonsChanged event.
protected method OnTabCloseButtonChanged | Raises the TabCloseButtonChanged event.
protected method OnTabSelectButtonChanged | Raises the TabSelectButtonChanged event.
protected method OnTabStripButtonStyleChanged | Raises the TabStripButtonStyleChanged event.

See Also

BarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Constructor ()

Initializes a new instance of the BarStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BarStyle();
[C++]
public: BarStyle();
[JScript]
public function BarStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Properties

The properties of the BarStyle class are listed here. For a complete list of BarStyle class members, see the BarStyle Members topic.

Public Properties

public property Appearance | Gets or sets an enumeration that determines the Appearance of pages in tab strip of the Bar.
public property BackgroundStyle | Gets or sets the background style.
public property CloseButton | Gets or sets the visibility of the close button of the Bar.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Bar.
public property ContextMenuButton | Gets or sets the visibility of the context menu button of the Bar.
public property Font | Gets or sets the font used to display the text in the Bar control.
public property GroupPadding | Gets or sets the amount of space used for alignment of Group caption text, in pixels.
public property GroupSpacing | Gets or sets the amount of space between tabs in tabstrip of Bar, in pixels.
public property GroupStyle | Gets or sets the GroupStyle of the groups in the Bar control.
public property HeaderStyle | Gets or sets the header style.
public property MoveButton | Gets or sets the visibility of the move button of the Bar.
public property ScrollingButtons | Gets or sets the visibility of the scrolling buttons of the Bar.
public property TabCloseButton | Gets or sets the visibility of the tab close button of the Bar.
public property TabSelectButton | Gets or sets the visibility of the tab select button of the Bar.
public property TabStripButtonStyle | Gets or sets the style of tabstrip buttons.

See Also

BarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Appearance Property

Lidor Systems Collector Class Library

BarStyle.Appearance Property

Gets or sets an enumeration that determines the Appearance of the Bar.

[Visual Basic]
Public Property Appearance As ControlAppearance
[C#]
public ControlAppearance Appearance {get; set;}
[C++]
public: __property ControlAppearance get_Appearance();
public: __property void set_Appearance(ControlAppearance);
[JScript]
public function get Appearance() : ControlAppearance;
public function set Appearance(ControlAppearance);

Property Value

The ControlAppearance assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyle Property

Lidor Systems Collector Class Library

BarStyle.BackgroundStyle Property

Gets or sets the background style of header.

[Visual Basic]
Public Property BackgroundStyle As CommonStyle
[C#]
public CommonStyle BackgroundStyle {get; set;}
[C++]
public: __property CommonStyle get_BackgroundStyle();
public: __property void set_BackgroundStyle(CommonStyle);
[JScript]
public function get BackgroundStyle() : CommonStyle;
public function set BackgroundStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseButton Property

Lidor Systems Collector Class Library

BarStyle.CloseButton Property

Gets or sets the visibility of the close button of the Bar.

[Visual Basic]
Public Property CloseButton As Boolean
[C#]
public bool CloseButton { get; set; }
[C++]
public: __property bool get_CloseButton();
public: __property void set_CloseButton(bool);
[JScript]
public function get CloseButton() : boolean
public function set CloseButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorScheme Property

Lidor Systems Collector Class Library

BarStyle.ColorScheme Property

Gets or sets an enumeration that determines the ColorScheme of the Bar control.

[Visual Basic]
Public Property ColorScheme As ColorScheme
[C#]
public ColorScheme ColorScheme {get; set;}
[C++]
public: __property ColorScheme get_ColorScheme();
public: __property void set_ColorScheme(ColorScheme);
[JScript]
public function get ColorScheme() : ColorScheme;
public function set ColorScheme(ColorScheme);

Property Value

The ColorScheme assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButton Property

Lidor Systems Collector Class Library

BarStyle.ContextMenuButton Property

Gets or sets the visibility of the context menu button of the Bar.

[Visual Basic]
Public Property ContextMenuButton As Boolean
[C#]
public bool ContextMenuButton { get; set; }
[C++]
public: __property bool get_ContextMenuButton();
public: __property void set_ContextMenuButton(bool);
[JScript]
public function get ContextMenuButton() : boolean
public function set ContextMenuButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Font Property

Lidor Systems Collector Class Library

BarStyle.Font Property

Gets or sets the font used to display the text in the Bar control.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the text in the Bar control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupPadding Property

Lidor Systems Collector Class Library

BarStyle.GroupPadding Property

Gets or sets the amount of space used for alignment of Group caption text, in pixels.

[Visual Basic]
Public Property GroupPadding As Integer
[C#]
public int GroupPadding {get; set;}
[C++]
public: __property int get_GroupPadding();
public: __property void set_GroupPadding(int);
[JScript]
public function get GroupPadding() : int;
public function set GroupPadding(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupSpacing Property

Lidor Systems Collector Class Library

BarStyle.GroupSpacing Property

Gets or sets the amount of space between tabs in tabstrip of Bar, in pixels.

[Visual Basic]
Public Property GroupSpacing As Integer
[C#]
public int GroupSpacing {get; set;}
[C++]
public: __property int get_GroupSpacing();
public: __property void set_GroupSpacing(int);
[JScript]
public function get GroupSpacing() : int;
public function set GroupSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Property

Lidor Systems Collector Class Library

BarStyle.GroupStyle Property

Gets or sets the GroupStyle of the groups in the Bar control.

[Visual Basic]
Public Property GroupStyle As GroupStyle
[C#]
public GroupStyle GroupStyle { get; set; }
[C++]
public: __property GroupStyle* get_GroupStyle();
public: __property void set_GroupStyle(GroupStyle* );
[JScript]
public function get GroupStyle() : GroupStyle
public function set GroupStyle(GroupStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Property

Lidor Systems Collector Class Library

BarStyle.HeaderStyle Property

Gets or sets the style of header.

[Visual Basic]
Public Property HeaderStyle As CommonStyle
[C#]
public CommonStyle HeaderStyle {get; set;}
[C++]
public: __property CommonStyle get_HeaderStyle();
public: __property void set_HeaderStyle(CommonStyle);
[JScript]
public function get HeaderStyle() : CommonStyle;
public function set HeaderStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MoveButton Property

Lidor Systems Collector Class Library

BarStyle.MoveButton Property

Gets or sets the visibility of the move button of the Bar.

[Visual Basic]
Public Property MoveButton As Boolean
[C#]
public bool MoveButton { get; set; }
[C++]
public: __property bool get_MoveButton();
public: __property void set_MoveButton(bool);
[JScript]
public function get MoveButton() : boolean
public function set MoveButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ScrollingButtons Property

Lidor Systems Collector Class Library

BarStyle.ScrollingButtons Property

Gets or sets the visibility of the scrolling buttons of the Bar.

[Visual Basic]
Public Property ScrollingButtons As Boolean
[C#]
public bool ScrollingButtons { get; set; }
[C++]
public: __property bool get_ScrollingButtons();
public: __property void set_ScrollingButtons(bool);
[JScript]
public function get ScrollingButtons() : boolean
public function set ScrollingButtons(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabCloseButton Property

Lidor Systems Collector Class Library

BarStyle.TabCloseButton Property

Gets or sets the visibility of the tab close button of the Bar.

[Visual Basic]
Public Property TabCloseButton As Boolean
[C#]
public bool TabCloseButton { get; set; }
[C++]
public: __property bool get_TabCloseButton();
public: __property void set_TabCloseButton(bool);
[JScript]
public function get TabCloseButton() : boolean
public function set TabCloseButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButton Property

Lidor Systems Collector Class Library

BarStyle.TabSelectButton Property

Gets or sets the visibility of the tab select button of the Bar.

[Visual Basic]
Public Property TabSelectButton As Boolean
[C#]
public bool TabSelectButton { get; set; }
[C++]
public: __property bool get_TabSelectButton();
public: __property void set_TabSelectButton(bool);
[JScript]
public function get TabSelectButton() : boolean
public function set TabSelectButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Property

Lidor Systems Collector Class Library

BarStyle.TabStripButtonStyle Property

Gets or sets the style of tabstrip buttons.

[Visual Basic]
Public Property TabStripButtonStyle As CommonStyle
[C#]
public CommonStyle TabStripButtonStyle {get; set;}
[C++]
public: __property CommonStyle get_TabStripButtonStyle();
public: __property void set_TabStripButtonStyle(CommonStyle);
[JScript]
public function get TabStripButtonStyle() : CommonStyle;
public function set TabStripButtonStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Methods

The methods of the BarStyle class are listed here. For a complete list of BarStyle class members, see the BarStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAppearanceChanged | Raises the AppearanceChanged event.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnCloseButtonChanged | Raises the CloseButtonChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnContextMenuButtonChanged | Raises the ContextMenuButtonChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnGroupPaddingChanged | Raises the GroupPaddingChanged event.
protected method OnGroupSpacingChanged | Raises the GroupSpacingChanged event.
protected method OnGroupStyleChanged | Raises the GroupStyleChanged event.
protected method OnHeaderStyleChanged | Raises the HeaderStyleChanged event.
protected method OnMoveButtonChanged | Raises the MoveButtonChanged event.
protected method OnScrollingButtonsChanged | Raises the ScrollingButtonsChanged event.
protected method OnTabCloseButtonChanged | Raises the TabCloseButtonChanged event.
protected method OnTabSelectButtonChanged | Raises the TabSelectButtonChanged event.
protected method OnTabStripButtonStyleChanged | Raises the TabStripButtonStyleChanged event.

See Also

BarStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

BarStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As BarStyle
[C#]
public virtual BarStyle Clone();
[C++]
public: virtual BarStyle Clone();
[JScript]
public function Clone() : BarStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnAppearanceChanged Method

Lidor Systems Collector Class Library

BarStyle.OnAppearanceChanged Method

Raises the AppearanceChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnAppearanceChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnAppearanceChanged(
   EventHandler e
);
[C++]
protected: virtual void OnAppearanceChanged(
   EventHandler* e
);
[JScript]
protected function OnAppearanceChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnAppearanceChanged in a derived class, be sure to call the base class's OnAppearanceChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackgroundStyleChanged Method

Lidor Systems Collector Class Library

BarStyle.OnBackgroundStyleChanged Method

Raises the BackgroundStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackgroundStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackgroundStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackgroundStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnBackgroundStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackgroundStyleChanged in a derived class, be sure to call the base class's OnBackgroundStyleChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnCloseButtonChanged Method

Lidor Systems Collector Class Library

BarStyle.OnCloseButtonChanged Method

Raises the CloseButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnCloseButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnCloseButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnCloseButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnCloseButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnCloseButtonChanged in a derived class, be sure to call the base class's OnCloseButtonChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnColorSchemeChanged Method

Lidor Systems Collector Class Library

BarStyle.OnColorSchemeChanged Method

Raises the ColorSchemeChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnColorSchemeChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnColorSchemeChanged(
   EventHandler e
);
[C++]
protected: virtual void OnColorSchemeChanged(
   EventHandler* e
);
[JScript]
protected function OnColorSchemeChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnColorSchemeChanged in a derived class, be sure to call the base class's OnColorSchemeChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnContextMenuButtonChanged Method

Lidor Systems Collector Class Library

BarStyle.OnContextMenuButtonChanged Method

Raises the ContextMenuButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnContextMenuButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnContextMenuButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnContextMenuButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnContextMenuButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnContextMenuButtonChanged in a derived class, be sure to call the base class's OnContextMenuButtonChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnFontChanged Method

Lidor Systems Collector Class Library

BarStyle.OnFontChanged Method

Raises the FontChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnFontChanged(
   EventHandler e
);
[C++]
protected: virtual void OnFontChanged(
   EventHandler* e
);
[JScript]
protected function OnFontChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnFontChanged in a derived class, be sure to call the base class's OnFontChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupPaddingChanged Method

Lidor Systems Collector Class Library

BarStyle.OnGroupPaddingChanged Method

Raises the GroupPaddingChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnGroupPaddingChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnGroupPaddingChanged(
   EventHandler e
);
[C++]
protected: virtual void OnGroupPaddingChanged(
   EventHandler* e
);
[JScript]
protected function OnGroupPaddingChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupPaddingChanged in a derived class, be sure to call the base class's OnGroupPaddingChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupSpacingChanged Method

Lidor Systems Collector Class Library

BarStyle.OnGroupSpacingChanged Method

Raises the GroupSpacingChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnGroupSpacingChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnGroupSpacingChanged(
   EventHandler e
);
[C++]
protected: virtual void OnGroupSpacingChanged(
   EventHandler* e
);
[JScript]
protected function OnGroupSpacingChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupSpacingChanged in a derived class, be sure to call the base class's OnGroupSpacingChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupStyleChanged Method

Lidor Systems Collector Class Library

BarStyle.OnGroupStyleChanged Method

Raises the GroupStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnGroupStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnGroupStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnGroupStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnGroupStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupStyleChanged in a derived class, be sure to call the base class's OnGroupStyleChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHeaderStyleChanged Method

Lidor Systems Collector Class Library

BarStyle.OnHeaderStyleChanged Method

Raises the HeaderStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHeaderStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHeaderStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHeaderStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHeaderStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHeaderStyleChanged in a derived class, be sure to call the base class's OnHeaderStyleChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMoveButtonChanged Method

Lidor Systems Collector Class Library

BarStyle.OnMoveButtonChanged Method

Raises the MoveButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnMoveButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnMoveButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnMoveButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnMoveButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnMoveButtonChanged in a derived class, be sure to call the base class's OnMoveButtonChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnScrollingButtonsChanged Method

Lidor Systems Collector Class Library

BarStyle.OnScrollingButtonsChanged Method

Raises the ScrollingButtonsChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnScrollingButtonsChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnScrollingButtonsChanged(
   EventHandler e
);
[C++]
protected: virtual void OnScrollingButtonsChanged(
   EventHandler* e
);
[JScript]
protected function OnScrollingButtonsChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnScrollingButtonsChanged in a derived class, be sure to call the base class's OnScrollingButtonsChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabCloseButtonChanged Method

Lidor Systems Collector Class Library

BarStyle.OnTabCloseButtonChanged Method

Raises the TabCloseButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabCloseButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabCloseButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabCloseButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnTabCloseButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabCloseButtonChanged in a derived class, be sure to call the base class's OnTabCloseButtonChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabSelectButtonChanged Method

Lidor Systems Collector Class Library

BarStyle.OnTabSelectButtonChanged Method

Raises the TabSelectButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabSelectButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabSelectButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabSelectButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnTabSelectButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabSelectButtonChanged in a derived class, be sure to call the base class's OnTabSelectButtonChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabStripButtonStyleChanged Method

Lidor Systems Collector Class Library

BarStyle.OnTabStripButtonStyleChanged Method

Raises the TabStripButtonStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabStripButtonStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabStripButtonStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabStripButtonStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnTabStripButtonStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabStripButtonStyleChanged in a derived class, be sure to call the base class's OnTabStripButtonStyleChanged method so that registered delegates receive the event.

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BarStyle Events

The events of the BarStyle class are listed here. For a complete list of BarStyle class members, see the BarStyle Members topic.

Public Events

public event AppearanceChanged | Occurs when the Appearance property value changes.
public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event CloseButtonChanged | Occurs when the CloseButton property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event ContextMenuButtonChanged | Occurs when the ContextMenuButton property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event GroupPaddingChanged | Occurs when the GroupPadding property value changes.
public event GroupSpacingChanged | Occurs when the GroupSpacing property value changes.
public event GroupStyleChanged | Occurs when the GroupStyle property value changes.
public event HeaderStyleChanged | Occurs when the HeaderStyle property value changes.
public event MoveButtonChanged | Occurs when the MoveButton property value changes.
public event ScrollingButtonsChanged | Occurs when the ScrollingButtons property value changes.
public event TabCloseButtonChanged | Occurs when the TabCloseButton property value changes.
public event TabSelectButtonChanged | Occurs when the TabSelectButton property value changes.
public event TabStripButtonStyleChanged | Occurs when the TabStripButtonStyle property value changes.

See Also

BarStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AppearanceChanged Event

Lidor Systems Collector Class Library

BarStyle.AppearanceChanged Event

Occurs when the value of the Appearance property changes.

[Visual Basic]
Public Event AppearanceChanged As EventHandler
[C#]
public event EventHandler AppearanceChanged;
[C++]
public: __event EventHandler* AppearanceChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyleChanged Event

Lidor Systems Collector Class Library

BarStyle.BackgroundStyleChanged Event

Occurs when the value of the BackgroundStyle property changes.

[Visual Basic]
Public Event BackgroundStyleChanged As EventHandler
[C#]
public event EventHandler BackgroundStyleChanged;
[C++]
public: __event EventHandler* BackgroundStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseButtonChanged Event

Lidor Systems Collector Class Library

BarStyle.CloseButtonChanged Event

Occurs when the value of the CloseButton property changes.

[Visual Basic]
Public Event CloseButtonChanged As EventHandler
[C#]
public event EventHandler CloseButtonChanged;
[C++]
public: __event EventHandler* CloseButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorSchemeChanged Event

Lidor Systems Collector Class Library

BarStyle.ColorSchemeChanged Event

Occurs when the value of the ColorScheme property changes.

[Visual Basic]
Public Event ColorSchemeChanged As EventHandler
[C#]
public event EventHandler ColorSchemeChanged;
[C++]
public: __event EventHandler* ColorSchemeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButtonChanged Event

Lidor Systems Collector Class Library

BarStyle.ContextMenuButtonChanged Event

Occurs when the value of the ContextMenuButton property changes.

[Visual Basic]
Public Event ContextMenuButtonChanged As EventHandler
[C#]
public event EventHandler ContextMenuButtonChanged;
[C++]
public: __event EventHandler* ContextMenuButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FontChanged Event

Lidor Systems Collector Class Library

BarStyle.FontChanged Event

Occurs when the value of the Font property changes.

[Visual Basic]
Public Event FontChanged As EventHandler
[C#]
public event EventHandler FontChanged;
[C++]
public: __event EventHandler* FontChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupPaddingChanged Event

Lidor Systems Collector Class Library

BarStyle.GroupPaddingChanged Event

Occurs when the value of the GroupPadding property changes.

[Visual Basic]
Public Event GroupPaddingChanged As EventHandler
[C#]
public event EventHandler GroupPaddingChanged;
[C++]
public: __event EventHandler* GroupPaddingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupSpacingChanged Event

Lidor Systems Collector Class Library

BarStyle.GroupSpacingChanged Event

Occurs when the value of the GroupSpacing property changes.

[Visual Basic]
Public Event GroupSpacingChanged As EventHandler
[C#]
public event EventHandler GroupSpacingChanged;
[C++]
public: __event EventHandler* GroupSpacingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyleChanged Event

Lidor Systems Collector Class Library

BarStyle.GroupStyleChanged Event

Occurs when the value of the GroupStyle property changes.

[Visual Basic]
Public Event GroupStyleChanged As EventHandler
[C#]
public event EventHandler GroupStyleChanged;
[C++]
public: __event EventHandler* GroupStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyleChanged Event

Lidor Systems Collector Class Library

BarStyle.HeaderStyleChanged Event

Occurs when the value of the HeaderStyle property changes.

[Visual Basic]
Public Event HeaderStyleChanged As EventHandler
[C#]
public event EventHandler HeaderStyleChanged;
[C++]
public: __event EventHandler* HeaderStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MoveButtonChanged Event

Lidor Systems Collector Class Library

BarStyle.MoveButtonChanged Event

Occurs when the value of the MoveButton property changes.

[Visual Basic]
Public Event MoveButtonChanged As EventHandler
[C#]
public event EventHandler MoveButtonChanged;
[C++]
public: __event EventHandler* MoveButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ScrollingButtonsChanged Event

Lidor Systems Collector Class Library

BarStyle.ScrollingButtonsChanged Event

Occurs when the value of the ScrollingButtons property changes.

[Visual Basic]
Public Event ScrollingButtonsChanged As EventHandler
[C#]
public event EventHandler ScrollingButtonsChanged;
[C++]
public: __event EventHandler* ScrollingButtonsChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabCloseButtonChanged Event

Lidor Systems Collector Class Library

BarStyle.TabCloseButtonChanged Event

Occurs when the value of the TabCloseButton property changes.

[Visual Basic]
Public Event TabCloseButtonChanged As EventHandler
[C#]
public event EventHandler TabCloseButtonChanged;
[C++]
public: __event EventHandler* TabCloseButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButtonChanged Event

Lidor Systems Collector Class Library

BarStyle.TabSelectButtonChanged Event

Occurs when the value of the TabSelectButton property changes.

[Visual Basic]
Public Event TabSelectButtonChanged As EventHandler
[C#]
public event EventHandler TabSelectButtonChanged;
[C++]
public: __event EventHandler* TabSelectButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyleChanged Event

Lidor Systems Collector Class Library

BarStyle.TabStripButtonStyleChanged Event

Occurs when the value of the TabStripButtonStyle property changes.

[Visual Basic]
Public Event TabStripButtonStyleChanged As EventHandler
[C#]
public event EventHandler TabStripButtonStyleChanged;
[C++]
public: __event EventHandler* TabStripButtonStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BarStyle Class | BarStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Class

Represents the style with common attributes for all buttons.

For a list of all members of this type, see CommonButtonStyle Members.

System.Object
LidorSystems.Collector.Style.CommonButtonStyle

[Visual Basic]
Public Class CommonButtonStyle
[C#]
public class CommonButtonStyle
[C++]
public __gc class CommonButtonStyle
[JScript]
public class CommonButtonStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CommonButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Members

CommonButtonStyle overview

Public Constructors

public constructor CommonButtonStyle Constructor Initializes a new instance of the CommonButtonStyle class.

Public Properties

public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.

Public Events

public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.

See Also

CommonButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Constructor ()

Initializes a new instance of the CommonButtonStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommonButtonStyle();
[C++]
public: CommonButtonStyle();
[JScript]
public function CommonButtonStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Properties

The properties of the CommonButtonStyle class are listed here. For a complete list of CommonButtonStyle class members, see the CommonButtonStyle Members topic.

Public Properties

public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.

See Also

CommonButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyle Property

Lidor Systems Collector Class Library

CommonButtonStyle.HoverStyle Property

Gets or sets the Hover style.

[Visual Basic]
Public Property HoverStyle As CommonStyle
[C#]
public CommonStyle HoverStyle {get; set;}
[C++]
public: __property CommonStyle get_HoverStyle();
public: __property void set_HoverStyle(CommonStyle);
[JScript]
public function get HoverStyle() : CommonStyle;
public function set HoverStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyle Property

Lidor Systems Collector Class Library

CommonButtonStyle.NormalStyle Property

Gets or sets the Normal style.

[Visual Basic]
Public Property NormalStyle As CommonStyle
[C#]
public CommonStyle NormalStyle {get; set;}
[C++]
public: __property CommonStyle get_NormalStyle();
public: __property void set_NormalStyle(CommonStyle);
[JScript]
public function get NormalStyle() : CommonStyle;
public function set NormalStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Methods

The methods of the CommonButtonStyle class are listed here. For a complete list of CommonButtonStyle class members, see the CommonButtonStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.

See Also

CommonButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

CommonButtonStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As CommonButtonStyle
[C#]
public virtual CommonButtonStyle Clone();
[C++]
public: virtual CommonButtonStyle Clone();
[JScript]
public function Clone() : CommonButtonStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHoverStyleChanged Method

Lidor Systems Collector Class Library

CommonButtonStyle.OnHoverStyleChanged Method

Raises the HoverStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHoverStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHoverStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHoverStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHoverStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHoverStyleChanged in a derived class, be sure to call the base class's OnHoverStyleChanged method so that registered delegates receive the event.

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnNormalStyleChanged Method

Lidor Systems Collector Class Library

CommonButtonStyle.OnNormalStyleChanged Method

Raises the NormalStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnNormalStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnNormalStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnNormalStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnNormalStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnNormalStyleChanged in a derived class, be sure to call the base class's OnNormalStyleChanged method so that registered delegates receive the event.

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonButtonStyle Events

The events of the CommonButtonStyle class are listed here. For a complete list of CommonButtonStyle class members, see the CommonButtonStyle Members topic.

Public Events

public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.

See Also

CommonButtonStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyleChanged Event

Lidor Systems Collector Class Library

CommonButtonStyle.HoverStyleChanged Event

Occurs when the value of the HoverStyle property changes.

[Visual Basic]
Public Event HoverStyleChanged As EventHandler
[C#]
public event EventHandler HoverStyleChanged;
[C++]
public: __event EventHandler* HoverStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyleChanged Event

Lidor Systems Collector Class Library

CommonButtonStyle.NormalStyleChanged Event

Occurs when the value of the NormalStyle property changes.

[Visual Basic]
Public Event NormalStyleChanged As EventHandler
[C#]
public event EventHandler NormalStyleChanged;
[C++]
public: __event EventHandler* NormalStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonButtonStyle Class | CommonButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Class

Represents the style with common attributes for all headers.

For a list of all members of this type, see CommonHeaderStyle Members.

System.Object
LidorSystems.Collector.Style.CommonHeaderStyle

[Visual Basic]
Public Class CommonHeaderStyle
[C#]
public class CommonHeaderStyle
[C++]
public __gc class CommonHeaderStyle
[JScript]
public class CommonHeaderStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CommonHeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Members

CommonHeaderStyle overview

Public Constructors

public constructor CommonHeaderStyle Constructor Initializes a new instance of the CommonHeaderStyle class.

Public Properties

public property BackgroundStyle | Gets or sets the background style of header.
public property ButtonStyle | Gets or sets the style of header buttons.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ButtonStyleChanged | Occurs when the ButtonStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnButtonStyleChanged | Raises the ButtonStyleChanged event.

See Also

CommonHeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Constructor ()

Initializes a new instance of the CommonHeaderStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommonHeaderStyle();
[C++]
public: CommonHeaderStyle();
[JScript]
public function CommonHeaderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Properties

The properties of the CommonHeaderStyle class are listed here. For a complete list of CommonHeaderStyle class members, see the CommonHeaderStyle Members topic.

Public Properties

public property BackgroundStyle | Gets or sets the background style of header.
public property ButtonStyle | Gets or sets the style of header buttons.

See Also

CommonHeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyle Property

Lidor Systems Collector Class Library

CommonHeaderStyle.BackgroundStyle Property

Gets or sets the background style of header.

[Visual Basic]
Public Property BackgroundStyle As CommonStyle
[C#]
public CommonStyle BackgroundStyle {get; set;}
[C++]
public: __property CommonStyle get_BackgroundStyle();
public: __property void set_BackgroundStyle(CommonStyle);
[JScript]
public function get BackgroundStyle() : CommonStyle;
public function set BackgroundStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ButtonStyle Property

Lidor Systems Collector Class Library

CommonHeaderStyle.ButtonStyle Property

Gets or sets the style of header buttons.

[Visual Basic]
Public Property ButtonStyle As CommonButtonStyle
[C#]
public CommonButtonStyle ButtonStyle {get; set;}
[C++]
public: __property CommonButtonStyle get_ButtonStyle();
public: __property void set_ButtonStyle(CommonButtonStyle);
[JScript]
public function get ButtonStyle() : CommonButtonStyle;
public function set ButtonStyle(CommonButtonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Methods

The methods of the CommonHeaderStyle class are listed here. For a complete list of CommonHeaderStyle class members, see the CommonHeaderStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnButtonStyleChanged | Raises the ButtonStyleChanged event.

See Also

CommonHeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

CommonHeaderStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As CommonHeaderStyle
[C#]
public virtual CommonHeaderStyle Clone();
[C++]
public: virtual CommonHeaderStyle Clone();
[JScript]
public function Clone() : CommonHeaderStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackgroundStyleChanged Method

Lidor Systems Collector Class Library

CommonHeaderStyle.OnBackgroundStyleChanged Method

Raises the BackgroundStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackgroundStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackgroundStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackgroundStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnBackgroundStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackgroundStyleChanged in a derived class, be sure to call the base class's OnBackgroundStyleChanged method so that registered delegates receive the event.

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnButtonStyleChanged Method

Lidor Systems Collector Class Library

CommonHeaderStyle.OnButtonStyleChanged Method

Raises the ButtonStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnButtonStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnButtonStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnButtonStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnButtonStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnButtonStyleChanged in a derived class, be sure to call the base class's OnButtonStyleChanged method so that registered delegates receive the event.

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonHeaderStyle Events

The events of the CommonHeaderStyle class are listed here. For a complete list of CommonHeaderStyle class members, see the CommonHeaderStyle Members topic.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ButtonStyleChanged | Occurs when the ButtonStyle property value changes.

See Also

CommonHeaderStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyleChanged Event

Lidor Systems Collector Class Library

CommonHeaderStyle.BackgroundStyleChanged Event

Occurs when the value of the BackgroundStyle property changes.

[Visual Basic]
Public Event BackgroundStyleChanged As EventHandler
[C#]
public event EventHandler BackgroundStyleChanged;
[C++]
public: __event EventHandler* BackgroundStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ButtonStyleChanged Event

Lidor Systems Collector Class Library

CommonHeaderStyle.ButtonStyleChanged Event

Occurs when the value of the ButtonStyle property changes.

[Visual Basic]
Public Event ButtonStyleChanged As EventHandler
[C#]
public event EventHandler ButtonStyleChanged;
[C++]
public: __event EventHandler* ButtonStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonHeaderStyle Class | CommonHeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Class

Represents the style with common attributes for all styles.

For a list of all members of this type, see CommonStyle Members.

System.Object
LidorSystems.Collector.Style.CommonStyle

[Visual Basic]
Public Class CommonStyle
[C#]
public class CommonStyle
[C++]
public __gc class CommonStyle
[JScript]
public class CommonStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Members

CommonStyle overview

Public Constructors

public constructor CommonStyle Constructor Initializes a new instance of the CommonStyle class.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property ForeColor | Gets or sets the foreground Color.

Public Events

public event BackColorChanged | Occurs when the BackColor property value changes.
public event BackFadeColorChanged | Occurs when the BackFadeColor property value changes.
public event BorderColorChanged | Occurs when the BorderColor property value changes.
public event FillStyleChanged | Occurs when the FillStyle property value changes.
public event ForeColorChanged | Occurs when the ForeColor property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged | Raises the BackColorChanged event.
protected method OnBackFadeColorChanged | Raises the BackFadeColorChanged event.
protected method OnBorderColorChanged | Raises the BorderColorChanged event.
protected method OnFillStyleChanged | Raises the FillStyleChanged event.
protected method OnForeColorChanged | Raises the ForeColorChanged event.

See Also

CommonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Constructor ()

Initializes a new instance of the CommonStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommonStyle();
[C++]
public: CommonStyle();
[JScript]
public function CommonStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Properties

The properties of the CommonStyle class are listed here. For a complete list of CommonStyle class members, see the CommonStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property ForeColor | Gets or sets the foreground Color.

See Also

CommonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackColor Property

Lidor Systems Collector Class Library

CommonStyle.BackColor Property

Gets or sets the background Color.

[Visual Basic]
Public Overridable Property BackColor As Color
[C#]
public virtual Color BackColor {get; set;}
[C++]
public: __property virtual Color get_BackColor();
public: __property virtual void set_BackColor(Color);
[JScript]
public function get BackColor() : Color;
public function set BackColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackFadeColor Property

Lidor Systems Collector Class Library

CommonStyle.BackFadeColor Property

Gets or sets the background fade Color.

[Visual Basic]
Public Overridable Property BackFadeColor As Color
[C#]
public virtual Color BackFadeColor {get; set;}
[C++]
public: __property virtual Color get_BackFadeColor();
public: __property virtual void set_BackFadeColor(Color);
[JScript]
public function get BackFadeColor() : Color;
public function set BackFadeColor(Color);

Property Value

A Color represents the background fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BorderColor Property

Lidor Systems Collector Class Library

CommonStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Overridable Property BorderColor As Color
[C#]
public virtual Color BorderColor {get; set;}
[C++]
public: __property virtual Color get_BorderColor();
public: __property virtual void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FillStyle Property

Lidor Systems Collector Class Library

CommonStyle.FillStyle Property

Gets or sets an enumeration that determines the gradient direction.

[Visual Basic]
Public Overridable Property FillStyle As Color
[C#]
public virtual Color FillStyle {get; set;}
[C++]
public: __property virtual Color get_FillStyle();
public: __property virtual void set_FillStyle(Color);
[JScript]
public function get FillStyle() : Color;
public function set FillStyle(Color);

Property Value

The FillStyle assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ForeColor Property

Lidor Systems Collector Class Library

CommonStyle.ForeColor Property

Gets or sets the foreground Color.

[Visual Basic]
Public Overridable Property ForeColor As Color
[C#]
public virtual Color ForeColor {get; set;}
[C++]
public: __property virtual Color get_ForeColor();
public: __property virtual void set_ForeColor(Color);
[JScript]
public function get ForeColor() : Color;
public function set ForeColor(Color);

Property Value

A Color represents the foreground color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Methods

The methods of the CommonStyle class are listed here. For a complete list of CommonStyle class members, see the CommonStyle Members topic.

Public Methods

public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackColorChanged | Raises the BackColorChanged event.
protected method OnBackFadeColorChanged | Raises the BackFadeColorChanged event.
protected method OnBorderColorChanged | Raises the BorderColorChanged event.
protected method OnFillStyleChanged | Raises the FillStyleChanged event.
protected method OnForeColorChanged | Raises the ForeColorChanged event.

See Also

CommonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackColorChanged Method

Lidor Systems Collector Class Library

CommonStyle.OnBackColorChanged Method

Raises the BackColorChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackColorChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackColorChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackColorChanged(
   EventHandler* e
);
[JScript]
protected function OnBackColorChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackColorChanged in a derived class, be sure to call the base class's OnBackColorChanged method so that registered delegates receive the event.

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackFadeColorChanged Method

Lidor Systems Collector Class Library

CommonStyle.OnBackFadeColorChanged Method

Raises the BackFadeColorChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackFadeColorChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackFadeColorChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackFadeColorChanged(
   EventHandler* e
);
[JScript]
protected function OnBackFadeColorChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackFadeColorChanged in a derived class, be sure to call the base class's OnBackFadeColorChanged method so that registered delegates receive the event.

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBorderColorChanged Method

Lidor Systems Collector Class Library

CommonStyle.OnBorderColorChanged Method

Raises the BorderColorChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBorderColorChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBorderColorChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBorderColorChanged(
   EventHandler* e
);
[JScript]
protected function OnBorderColorChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBorderColorChanged in a derived class, be sure to call the base class's OnBorderColorChanged method so that registered delegates receive the event.

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnFillStyleChanged Method

Lidor Systems Collector Class Library

CommonStyle.OnFillStyleChanged Method

Raises the FillStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnFillStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnFillStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnFillStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnFillStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnFillStyleChanged in a derived class, be sure to call the base class's OnFillStyleChanged method so that registered delegates receive the event.

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnForeColorChanged Method

Lidor Systems Collector Class Library

CommonStyle.OnForeColorChanged Method

Raises the ForeColorChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnForeColorChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnForeColorChanged(
   EventHandler e
);
[C++]
protected: virtual void OnForeColorChanged(
   EventHandler* e
);
[JScript]
protected function OnForeColorChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnForeColorChanged in a derived class, be sure to call the base class's OnForeColorChanged method so that registered delegates receive the event.

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CommonStyle Events

The events of the CommonStyle class are listed here. For a complete list of CommonStyle class members, see the CommonStyle Members topic.

Public Events

public event BackColorChanged | Occurs when the BackColor property value changes.
public event BackFadeColorChanged | Occurs when the BackFadeColor property value changes.
public event BorderColorChanged | Occurs when the BorderColor property value changes.
public event FillStyleChanged | Occurs when the FillStyle property value changes.
public event ForeColorChanged | Occurs when the ForeColor property value changes.

See Also

CommonStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackColorChanged Event

Lidor Systems Collector Class Library

CommonStyle.BackColorChanged Event

Occurs when the value of the BackColor property changes.

[Visual Basic]
Public Event BackColorChanged As EventHandler
[C#]
public event EventHandler BackColorChanged;
[C++]
public: __event EventHandler* BackColorChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackFadeColorChanged Event

Lidor Systems Collector Class Library

CommonStyle.BackFadeColorChanged Event

Occurs when the value of the BackFadeColor property changes.

[Visual Basic]
Public Event BackFadeColorChanged As EventHandler
[C#]
public event EventHandler BackFadeColorChanged;
[C++]
public: __event EventHandler* BackFadeColorChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BorderColorChanged Event

Lidor Systems Collector Class Library

CommonStyle.BorderColorChanged Event

Occurs when the value of the BorderColor property changes.

[Visual Basic]
Public Event BorderColorChanged As EventHandler
[C#]
public event EventHandler BorderColorChanged;
[C++]
public: __event EventHandler* BorderColorChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FillStyleChanged Event

Lidor Systems Collector Class Library

CommonStyle.FillStyleChanged Event

Occurs when the value of the FillStyle property changes.

[Visual Basic]
Public Event FillStyleChanged As EventHandler
[C#]
public event EventHandler FillStyleChanged;
[C++]
public: __event EventHandler* FillStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ForeColorChanged Event

Lidor Systems Collector Class Library

CommonStyle.ForeColorChanged Event

Occurs when the value of the ForeColor property changes.

[Visual Basic]
Public Event ForeColorChanged As EventHandler
[C#]
public event EventHandler ForeColorChanged;
[C++]
public: __event EventHandler* ForeColorChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainerImage Class

Specifies the image for a container control which is being shown inside it.

For a list of all members of this type, see ContainerImage Members.

System.Object
LidorSystems.Collector.Style.ContainerImage

[Visual Basic]
Public Class ContainerImage
[C#]
public class ContainerImage
[C++]
public __gc class ContainerImage
[JScript]
public class ContainerImage

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainerImage Members

ContainerImage overview

Public Constructors

public constructor ContainerImage Constructor Initializes a new instance of the ContainerImage class.

Public Properties

public property Alignment | Gets or sets the alignment of the image inside the container control.
public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image of a container control.
public property Image | Specifies the image object to use as a watermark inside the container control.
public property ImageSize | Gets or sets an enumeration that determines the size of the image in a container control.
public property Parent | Gets or sets the Control that uses ContainerImage.

Public Methods

public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContainerImage Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Constructor Method

Lidor Systems Collector Class Library

ContainerImage Constructor Method

Overload List

Initializes a new instance of the ContainerImage class.

public ContainerImage();

Initializes a new instance of the ContainerImage class and associates it with the given Control.

public ContainerImage(Control);

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainerImage Constructor ()

Initializes a new instance of the ContainerImage class.

[Visual Basic]
Public Sub New()
[C#]
public ContainerImage();
[C++]
public: ContainerImage();
[JScript]
public function ContainerImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainerImage Constructor (Control)

Initializes a new instance of the ContainerImage class and associates it with the given Control.

[Visual Basic]
Public Sub New( _
   ByVal parent As Control _
)
[C#]
public ContainerImage(
   Control parent
);
[C++]
public: ContainerImage(
   Control* parent
);
[JScript]
public function ContainerImage(
   parent : Control
);

Parameters

parent
The Control to be the parent of the ContainerImage.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContainerImage Properties

The properties of the ContainerImage class are listed here. For a complete list of ContainerImage class members, see the ContainerImage Members topic.

Public Properties

public property Alignment | Gets or sets the alignment of the image inside the container control.
public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image of a container control.
public property Image | Specifies the image object to use as a watermark inside the container control.
public property ImageSize | Gets or sets an enumeration that determines the size of the image in a container control.
public property Parent | Gets or sets the Control that uses ContainerImage.

See Also

ContainerImage Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Alignment Property

Lidor Systems Collector Class Library

ContainerImage.Alignment Property

Gets or sets the alignment of the image inside the container control.

[Visual Basic]
Public Property Alignment As ContentAlignment
[C#]
public ContentAlignment Alignment { get; set; }
[C++]
public: __property ContentAlignment get_Alignment();
public: __property void set_Alignment(ContentAlignment);
[JScript]
public function get Alignment() : ContentAlignment
public function set Alignment(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Alpha Property

Lidor Systems Collector Class Library

ContainerImage.Alpha Property

Gets or sets the alpha value that will be applied to the colors in the image of a container control.

[Visual Basic]
Public Property Alpha As Integer
[C#]
public int Alpha {get; set;}
[C++]
public: __property int get_Alpha();
public: __property void set_Alpha(int);
[JScript]
public function get Alpha() : int;
public function set Alpha(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Image Property

Lidor Systems Collector Class Library

ContainerImage.Image Property

Specifies the image object to use as a watermark inside the container control.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Property Value

The Image assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageSize Property

Lidor Systems Collector Class Library

ContainerImage.ImageSize Property

Gets or sets an enumeration that determines the size of the image in a container control.

[Visual Basic]
Public Property ImageSize As ImageSize
[C#]
public ImageSize ImageSize {get; set;}
[C++]
public: __property ImageSize get_ImageSize();
public: __property void set_ImageSize(ImageSize);
[JScript]
public function get ImageSize() : ImageSize;
public function set ImageSize(ImageSize);

Property Value

The ImageSize assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Parent Property

Lidor Systems Collector Class Library

ContainerImage.Parent Property

Gets or sets the Control that uses ContainerImage.

[Visual Basic]
Public Property Parent As Control
[C#]
public Control Parent { get; set; }
[C++]
public: __property Control get_Parent();
public: __property void set_Parent(Control);
[JScript]
public function get Parent() : Control
public function set Parent(Control);

Property Value

Represents the parent Control that uses the ContainerImage.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerImage Class | ContainerImage Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Class

Represents the style of the Group control.

For a list of all members of this type, see GroupStyle Members.

System.Object
LidorSystems.Collector.Style.GroupStyle

[Visual Basic]
Public Class GroupStyle
[C#]
public class GroupStyle
[C++]
public __gc class GroupStyle
[JScript]
public class GroupStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Members

GroupStyle overview

Public Constructors

public constructor GroupStyle Constructor Initializes a new instance of the GroupStyle class.

Public Properties

public property AutoHideButton | Gets or sets the visibility of the autohide button of the Group.
public property BackgroundStyle | Gets or sets the background style.
public property CloseButton | Gets or sets the visibility of the close button of the Group.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Group.
public property ContextMenuButton | Gets or sets the visibility of the context menu button of the Group.
public property ExpandButton | Gets or sets the visibility of the expand button of the Group.
public property Font | Gets or sets the font used to display the text in the Group control.
public property HeaderStyle | Gets or sets the header style.
public property Margin | Gets or sets an enumeration that determines the margins of client area of the Group control.
public property MoveButton | Gets or sets the visibility of the move button of the Group.
public property Orientation | Gets or sets an enumeration that determines the Orientation of pages in tab strip of the Group.
public property PagePadding | Gets or sets the amount of space used for alignment of Page caption text, in pixels.
public property PageSpacing | Gets or sets the amount of space between tabs in group strip of Group, in pixels.
public property PageStyle | Gets or sets the PageStyle of the pages in the Group control.
public property ScrollingButtons | Gets or sets the visibility of the scrolling buttons of the Group.
public property TabCloseButton | Gets or sets the visibility of the tab close button of the Group.
public property TabSelectButton | Gets or sets the visibility of the tab select button of the Group.
public property TabStripButtonStyle | Gets or sets the style of tabstrip buttons.
public property TabStyle | Gets or sets the style of tabs.

Public Events

public event AutoHideButtonChanged | Occurs when the AutoHideButton property value changes.
public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event CloseButtonChanged | Occurs when the CloseButton property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event ContextMenuButtonChanged | Occurs when the ContextMenuButton property value changes.
public event ExpandButtonChanged | Occurs when the ExpandButton property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event HeaderStyleChanged | Occurs when the HeaderStyle property value changes.
public event MarginChanged | Occurs when the Margin property value changes.
public event MoveButtonChanged | Occurs when the MoveButton property value changes.
public event OrientationChanged | Occurs when the Orientation property value changes.
public event PagePaddingChanged | Occurs when the PagePadding property value changes.
public event PageSpacingChanged | Occurs when the PageSpacing property value changes.
public event PageStyleChanged | Occurs when the PageStyle property value changes.
public event ScrollingButtonsChanged | Occurs when the ScrollingButtons property value changes.
public event TabCloseButtonChanged | Occurs when the TabCloseButton property value changes.
public event TabSelectButtonChanged | Occurs when the TabSelectButton property value changes.
public event TabStripButtonStyleChanged | Occurs when the TabStripButtonStyle property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAutoHideButtonChanged | Raises the AutoHideButtonChanged event.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnCloseButtonChanged | Raises the CloseButtonChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnContextMenuButtonChanged | Raises the ContextMenuButtonChanged event.
protected method OnExpandButtonChanged | Raises the ExpandButtonChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnHeaderStyleChanged | Raises the HeaderStyleChanged event.
protected method OnMarginChanged | Raises the MarginChanged event.
protected method OnMoveButtonChanged | Raises the MoveButtonChanged event.
protected method OnOrientationChanged | Raises the OrientationChanged event.
protected method OnPagePaddingChanged | Raises the PagePaddingChanged event.
protected method OnPageSpacingChanged | Raises the PageSpacingChanged event.
protected method OnPageStyleChanged | Raises the PageStyleChanged event.
protected method OnScrollingButtonsChanged | Raises the ScrollingButtonsChanged event.
protected method OnTabCloseButtonChanged | Raises the TabCloseButtonChanged event.
protected method OnTabSelectButtonChanged | Raises the TabSelectButtonChanged event.
protected method OnTabStripButtonStyleChanged | Raises the TabStripButtonStyleChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

GroupStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Constructor ()

Initializes a new instance of the GroupStyle class.

[Visual Basic]
Public Sub New()
[C#]
public GroupStyle();
[C++]
public: GroupStyle();
[JScript]
public function GroupStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Properties

The properties of the GroupStyle class are listed here. For a complete list of GroupStyle class members, see the GroupStyle Members topic.

Public Properties

public property AutoHideButton | Gets or sets the visibility of the autohide button of the Group.
public property BackgroundStyle | Gets or sets the background style.
public property CloseButton | Gets or sets the visibility of the close button of the Group.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Group.
public property ContextMenuButton | Gets or sets the visibility of the context menu button of the Group.
public property ExpandButton | Gets or sets the visibility of the expand button of the Group.
public property Font | Gets or sets the font used to display the text in the Group control.
public property HeaderStyle | Gets or sets the header style.
public property Margin | Gets or sets an enumeration that determines the margins of client area of the Group control.
public property MoveButton | Gets or sets the visibility of the move button of the Group.
public property Orientation | Gets or sets an enumeration that determines the Orientation of pages in tab strip of the Group.
public property PagePadding | Gets or sets the amount of space used for alignment of Page caption text, in pixels.
public property PageSpacing | Gets or sets the amount of space between tabs in group strip of Group, in pixels.
public property PageStyle | Gets or sets the PageStyle of the pages in the Group control.
public property ScrollingButtons | Gets or sets the visibility of the scrolling buttons of the Group.
public property TabCloseButton | Gets or sets the visibility of the tab close button of the Group.
public property TabSelectButton | Gets or sets the visibility of the tab select button of the Group.
public property TabStripButtonStyle | Gets or sets the style of tabstrip buttons.
public property TabStyle | Gets or sets the style of tabs.

See Also

GroupStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideButton Property

Lidor Systems Collector Class Library

GroupStyle.AutoHideButton Property

Gets or sets the visibility of the autohide button of the Group.

[Visual Basic]
Public Property AutoHideButton As Boolean
[C#]
public bool AutoHideButton { get; set; }
[C++]
public: __property bool get_AutoHideButton();
public: __property void set_AutoHideButton(bool);
[JScript]
public function get AutoHideButton() : boolean
public function set AutoHideButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyle Property

Lidor Systems Collector Class Library

GroupStyle.BackgroundStyle Property

Gets or sets the background style of header.

[Visual Basic]
Public Property BackgroundStyle As CommonStyle
[C#]
public CommonStyle BackgroundStyle {get; set;}
[C++]
public: __property CommonStyle get_BackgroundStyle();
public: __property void set_BackgroundStyle(CommonStyle);
[JScript]
public function get BackgroundStyle() : CommonStyle;
public function set BackgroundStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseButton Property

Lidor Systems Collector Class Library

GroupStyle.CloseButton Property

Gets or sets the visibility of the close button of the Group.

[Visual Basic]
Public Property CloseButton As Boolean
[C#]
public bool CloseButton { get; set; }
[C++]
public: __property bool get_CloseButton();
public: __property void set_CloseButton(bool);
[JScript]
public function get CloseButton() : boolean
public function set CloseButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorScheme Property

Lidor Systems Collector Class Library

GroupStyle.ColorScheme Property

Gets or sets an enumeration that determines the ColorScheme of the Group control.

[Visual Basic]
Public Property ColorScheme As ColorScheme
[C#]
public ColorScheme ColorScheme {get; set;}
[C++]
public: __property ColorScheme get_ColorScheme();
public: __property void set_ColorScheme(ColorScheme);
[JScript]
public function get ColorScheme() : ColorScheme;
public function set ColorScheme(ColorScheme);

Property Value

The ColorScheme assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButton Property

Lidor Systems Collector Class Library

GroupStyle.ContextMenuButton Property

Gets or sets the visibility of the context menu button of the Group.

[Visual Basic]
Public Property ContextMenuButton As Boolean
[C#]
public bool ContextMenuButton { get; set; }
[C++]
public: __property bool get_ContextMenuButton();
public: __property void set_ContextMenuButton(bool);
[JScript]
public function get ContextMenuButton() : boolean
public function set ContextMenuButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ExpandButton Property

Lidor Systems Collector Class Library

GroupStyle.ExpandButton Property

Gets or sets the visibility of the expand button of the Group.

[Visual Basic]
Public Property ExpandButton As Boolean
[C#]
public bool ExpandButton { get; set; }
[C++]
public: __property bool get_ExpandButton();
public: __property void set_ExpandButton(bool);
[JScript]
public function get ExpandButton() : boolean
public function set ExpandButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Font Property

Lidor Systems Collector Class Library

GroupStyle.Font Property

Gets or sets the font used to display the text in the Group control.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the text in the Group control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Property

Lidor Systems Collector Class Library

GroupStyle.HeaderStyle Property

Gets or sets the style of header.

[Visual Basic]
Public Property HeaderStyle As CommonStyle
[C#]
public CommonStyle HeaderStyle {get; set;}
[C++]
public: __property CommonStyle get_HeaderStyle();
public: __property void set_HeaderStyle(CommonStyle);
[JScript]
public function get HeaderStyle() : CommonStyle;
public function set HeaderStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Margin Property

Lidor Systems Collector Class Library

GroupStyle.Margin Property

Gets or sets an enumeration that determines the margins of client area of the Group control.

[Visual Basic]
Public Property Margin As Margin
[C#]
public Margin Margin {get; set;}
[C++]
public: __property Margin get_Margin();
public: __property void set_Margin(Margin);
[JScript]
public function get Margin() : Margin;
public function set Margin(Margin);

Property Value

The Margin assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MoveButton Property

Lidor Systems Collector Class Library

GroupStyle.MoveButton Property

Gets or sets the visibility of the move button of the Group.

[Visual Basic]
Public Property MoveButton As Boolean
[C#]
public bool MoveButton { get; set; }
[C++]
public: __property bool get_MoveButton();
public: __property void set_MoveButton(bool);
[JScript]
public function get MoveButton() : boolean
public function set MoveButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Orientation Property

Lidor Systems Collector Class Library

GroupStyle.Orientation Property

Gets or sets an enumeration that determines the Orientation of pages in group strip of the Group.

[Visual Basic]
Public Property Orientation As TabOrientation
[C#]
public TabOrientation Orientation {get; set;}
[C++]
public: __property TabOrientation get_Orientation();
public: __property void set_Orientation(TabOrientation);
[JScript]
public function get Orientation() : TabOrientation;
public function set Orientation(TabOrientation);

Property Value

The TabOrientation assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PagePadding Property

Lidor Systems Collector Class Library

GroupStyle.PagePadding Property

Gets or sets the amount of space used for alignment of Page caption text, in pixels.

[Visual Basic]
Public Property PagePadding As Integer
[C#]
public int PagePadding {get; set;}
[C++]
public: __property int get_PagePadding();
public: __property void set_PagePadding(int);
[JScript]
public function get PagePadding() : int;
public function set PagePadding(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageSpacing Property

Lidor Systems Collector Class Library

GroupStyle.PageSpacing Property

Gets or sets the amount of space between tabs in group strip of Group, in pixels.

[Visual Basic]
Public Property PageSpacing As Integer
[C#]
public int PageSpacing {get; set;}
[C++]
public: __property int get_PageSpacing();
public: __property void set_PageSpacing(int);
[JScript]
public function get PageSpacing() : int;
public function set PageSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Property

Lidor Systems Collector Class Library

GroupStyle.GroupStyle Property

Gets or sets the PageStyle of the pages in the Group control.

[Visual Basic]
Public Property PageStyle As PageStyle
[C#]
public PageStyle PageStyle { get; set; }
[C++]
public: __property PageStyle* get_PageStyle();
public: __property void set_PageStyle(PageStyle* );
[JScript]
public function get PageStyle() : PageStyle
public function set PageStyle(PageStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ScrollingButtons Property

Lidor Systems Collector Class Library

GroupStyle.ScrollingButtons Property

Gets or sets the visibility of the scrolling buttons of the Group.

[Visual Basic]
Public Property ScrollingButtons As Boolean
[C#]
public bool ScrollingButtons { get; set; }
[C++]
public: __property bool get_ScrollingButtons();
public: __property void set_ScrollingButtons(bool);
[JScript]
public function get ScrollingButtons() : boolean
public function set ScrollingButtons(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabCloseButton Property

Lidor Systems Collector Class Library

GroupStyle.TabCloseButton Property

Gets or sets the visibility of the tab close button of the Group.

[Visual Basic]
Public Property TabCloseButton As Boolean
[C#]
public bool TabCloseButton { get; set; }
[C++]
public: __property bool get_TabCloseButton();
public: __property void set_TabCloseButton(bool);
[JScript]
public function get TabCloseButton() : boolean
public function set TabCloseButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButton Property

Lidor Systems Collector Class Library

GroupStyle.TabSelectButton Property

Gets or sets the visibility of the tab select button of the Group.

[Visual Basic]
Public Property TabSelectButton As Boolean
[C#]
public bool TabSelectButton { get; set; }
[C++]
public: __property bool get_TabSelectButton();
public: __property void set_TabSelectButton(bool);
[JScript]
public function get TabSelectButton() : boolean
public function set TabSelectButton(boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Property

Lidor Systems Collector Class Library

GroupStyle.TabStripButtonStyle Property

Gets or sets the style of tabstrip buttons.

[Visual Basic]
Public Property TabStripButtonStyle As CommonStyle
[C#]
public CommonStyle TabStripButtonStyle {get; set;}
[C++]
public: __property CommonStyle get_TabStripButtonStyle();
public: __property void set_TabStripButtonStyle(CommonStyle);
[JScript]
public function get TabStripButtonStyle() : CommonStyle;
public function set TabStripButtonStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Property

Lidor Systems Collector Class Library

GroupStyle.TabStyle Property

Gets or sets the style of tabs.

[Visual Basic]
Public Property TabStyle As TabStyle
[C#]
public TabStyle TabStyle {get; set;}
[C++]
public: __property TabStyle get_TabStyle();
public: __property void set_TabStyle(TabStyle);
[JScript]
public function get TabStyle() : TabStyle;
public function set TabStyle(TabStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Methods

The methods of the GroupStyle class are listed here. For a complete list of GroupStyle class members, see the GroupStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAutoHideButtonChanged | Raises the AutoHideButtonChanged event.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnCloseButtonChanged | Raises the CloseButtonChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnContextMenuButtonChanged | Raises the ContextMenuButtonChanged event.
protected method OnExpandButtonChanged | Raises the ExpandButtonChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnHeaderStyleChanged | Raises the HeaderStyleChanged event.
protected method OnMarginChanged | Raises the MarginChanged event.
protected method OnMoveButtonChanged | Raises the MoveButtonChanged event.
protected method OnOrientationChanged | Raises the OrientationChanged event.
protected method OnPagePaddingChanged | Raises the PagePaddingChanged event.
protected method OnPageSpacingChanged | Raises the PageSpacingChanged event.
protected method OnPageStyleChanged | Raises the PageStyleChanged event.
protected method OnScrollingButtonsChanged | Raises the ScrollingButtonsChanged event.
protected method OnTabCloseButtonChanged | Raises the TabCloseButtonChanged event.
protected method OnTabSelectButtonChanged | Raises the TabSelectButtonChanged event.
protected method OnTabStripButtonStyleChanged | Raises the TabStripButtonStyleChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

GroupStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

GroupStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As GroupStyle
[C#]
public virtual GroupStyle Clone();
[C++]
public: virtual GroupStyle Clone();
[JScript]
public function Clone() : GroupStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnAutoHideButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnAutoHideButtonChanged Method

Raises the AutoHideButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnAutoHideButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnAutoHideButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnAutoHideButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnAutoHideButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnAutoHideButtonChanged in a derived class, be sure to call the base class's OnAutoHideButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackgroundStyleChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnBackgroundStyleChanged Method

Raises the BackgroundStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackgroundStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackgroundStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackgroundStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnBackgroundStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackgroundStyleChanged in a derived class, be sure to call the base class's OnBackgroundStyleChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnCloseButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnCloseButtonChanged Method

Raises the CloseButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnCloseButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnCloseButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnCloseButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnCloseButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnCloseButtonChanged in a derived class, be sure to call the base class's OnCloseButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnColorSchemeChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnColorSchemeChanged Method

Raises the ColorSchemeChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnColorSchemeChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnColorSchemeChanged(
   EventHandler e
);
[C++]
protected: virtual void OnColorSchemeChanged(
   EventHandler* e
);
[JScript]
protected function OnColorSchemeChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnColorSchemeChanged in a derived class, be sure to call the base class's OnColorSchemeChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnContextMenuButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnContextMenuButtonChanged Method

Raises the ContextMenuButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnContextMenuButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnContextMenuButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnContextMenuButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnContextMenuButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnContextMenuButtonChanged in a derived class, be sure to call the base class's OnContextMenuButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnExpandButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnExpandButtonChanged Method

Raises the ExpandButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnExpandButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnExpandButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnExpandButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnExpandButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnExpandButtonChanged in a derived class, be sure to call the base class's OnExpandButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnFontChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnFontChanged Method

Raises the FontChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnFontChanged(
   EventHandler e
);
[C++]
protected: virtual void OnFontChanged(
   EventHandler* e
);
[JScript]
protected function OnFontChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnFontChanged in a derived class, be sure to call the base class's OnFontChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHeaderStyleChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnHeaderStyleChanged Method

Raises the HeaderStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHeaderStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHeaderStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHeaderStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHeaderStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHeaderStyleChanged in a derived class, be sure to call the base class's OnHeaderStyleChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMarginChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnMarginChanged Method

Raises the MarginChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnMarginChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnMarginChanged(
   EventHandler e
);
[C++]
protected: virtual void OnMarginChanged(
   EventHandler* e
);
[JScript]
protected function OnMarginChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnMarginChanged in a derived class, be sure to call the base class's OnMarginChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMoveButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnMoveButtonChanged Method

Raises the MoveButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnMoveButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnMoveButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnMoveButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnMoveButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnMoveButtonChanged in a derived class, be sure to call the base class's OnMoveButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnOrientationChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnOrientationChanged Method

Raises the OrientationChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnOrientationChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnOrientationChanged(
   EventHandler e
);
[C++]
protected: virtual void OnOrientationChanged(
   EventHandler* e
);
[JScript]
protected function OnOrientationChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnOrientationChanged in a derived class, be sure to call the base class's OnOrientationChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPagePaddingChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnPagePaddingChanged Method

Raises the PagePaddingChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnPagePaddingChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnPagePaddingChanged(
   EventHandler e
);
[C++]
protected: virtual void OnPagePaddingChanged(
   EventHandler* e
);
[JScript]
protected function OnPagePaddingChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPagePaddingChanged in a derived class, be sure to call the base class's OnPagePaddingChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageSpacingChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnPageSpacingChanged Method

Raises the PageSpacingChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnPageSpacingChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnPageSpacingChanged(
   EventHandler e
);
[C++]
protected: virtual void OnPageSpacingChanged(
   EventHandler* e
);
[JScript]
protected function OnPageSpacingChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageSpacingChanged in a derived class, be sure to call the base class's OnPageSpacingChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnPageStyleChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnPageStyleChanged Method

Raises the PageStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnPageStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnPageStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnPageStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnPageStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnPageStyleChanged in a derived class, be sure to call the base class's OnPageStyleChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnScrollingButtonsChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnScrollingButtonsChanged Method

Raises the ScrollingButtonsChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnScrollingButtonsChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnScrollingButtonsChanged(
   EventHandler e
);
[C++]
protected: virtual void OnScrollingButtonsChanged(
   EventHandler* e
);
[JScript]
protected function OnScrollingButtonsChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnScrollingButtonsChanged in a derived class, be sure to call the base class's OnScrollingButtonsChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabCloseButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnTabCloseButtonChanged Method

Raises the TabCloseButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabCloseButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabCloseButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabCloseButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnTabCloseButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabCloseButtonChanged in a derived class, be sure to call the base class's OnTabCloseButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabSelectButtonChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnTabSelectButtonChanged Method

Raises the TabSelectButtonChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabSelectButtonChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabSelectButtonChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabSelectButtonChanged(
   EventHandler* e
);
[JScript]
protected function OnTabSelectButtonChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabSelectButtonChanged in a derived class, be sure to call the base class's OnTabSelectButtonChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabStripButtonStyleChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnTabStripButtonStyleChanged Method

Raises the TabStripButtonStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabStripButtonStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabStripButtonStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabStripButtonStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnTabStripButtonStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabStripButtonStyleChanged in a derived class, be sure to call the base class's OnTabStripButtonStyleChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabStyleChanged Method

Lidor Systems Collector Class Library

GroupStyle.OnTabStyleChanged Method

Raises the TabStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnTabStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabStyleChanged in a derived class, be sure to call the base class's OnTabStyleChanged method so that registered delegates receive the event.

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


GroupStyle Events

The events of the GroupStyle class are listed here. For a complete list of GroupStyle class members, see the GroupStyle Members topic.

Public Events

public event AutoHideButtonChanged | Occurs when the AutoHideButton property value changes.
public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event CloseButtonChanged | Occurs when the CloseButton property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event ContextMenuButtonChanged | Occurs when the ContextMenuButton property value changes.
public event ExpandButtonChanged | Occurs when the ExpandButton property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event HeaderStyleChanged | Occurs when the HeaderStyle property value changes.
public event MarginChanged | Occurs when the Margin property value changes.
public event MoveButtonChanged | Occurs when the MoveButton property value changes.
public event OrientationChanged | Occurs when the Orientation property value changes.
public event PagePaddingChanged | Occurs when the PagePadding property value changes.
public event PageSpacingChanged | Occurs when the PageSpacing property value changes.
public event PageStyleChanged | Occurs when the PageStyle property value changes.
public event ScrollingButtonsChanged | Occurs when the ScrollingButtons property value changes.
public event TabCloseButtonChanged | Occurs when the TabCloseButton property value changes.
public event TabSelectButtonChanged | Occurs when the TabSelectButton property value changes.
public event TabStripButtonStyleChanged | Occurs when the TabStripButtonStyle property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

See Also

GroupStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


AutoHideButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.AutoHideButtonChanged Event

Occurs when the value of the AutoHideButton property changes.

[Visual Basic]
Public Event AutoHideButtonChanged As EventHandler
[C#]
public event EventHandler AutoHideButtonChanged;
[C++]
public: __event EventHandler* AutoHideButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyleChanged Event

Lidor Systems Collector Class Library

GroupStyle.BackgroundStyleChanged Event

Occurs when the value of the BackgroundStyle property changes.

[Visual Basic]
Public Event BackgroundStyleChanged As EventHandler
[C#]
public event EventHandler BackgroundStyleChanged;
[C++]
public: __event EventHandler* BackgroundStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


CloseButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.CloseButtonChanged Event

Occurs when the value of the CloseButton property changes.

[Visual Basic]
Public Event CloseButtonChanged As EventHandler
[C#]
public event EventHandler CloseButtonChanged;
[C++]
public: __event EventHandler* CloseButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorSchemeChanged Event

Lidor Systems Collector Class Library

GroupStyle.ColorSchemeChanged Event

Occurs when the value of the ColorScheme property changes.

[Visual Basic]
Public Event ColorSchemeChanged As EventHandler
[C#]
public event EventHandler ColorSchemeChanged;
[C++]
public: __event EventHandler* ColorSchemeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ContextMenuButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.ContextMenuButtonChanged Event

Occurs when the value of the ContextMenuButton property changes.

[Visual Basic]
Public Event ContextMenuButtonChanged As EventHandler
[C#]
public event EventHandler ContextMenuButtonChanged;
[C++]
public: __event EventHandler* ContextMenuButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ExpandButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.ExpandButtonChanged Event

Occurs when the value of the ExpandButton property changes.

[Visual Basic]
Public Event ExpandButtonChanged As EventHandler
[C#]
public event EventHandler ExpandButtonChanged;
[C++]
public: __event EventHandler* ExpandButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FontChanged Event

Lidor Systems Collector Class Library

GroupStyle.FontChanged Event

Occurs when the value of the Font property changes.

[Visual Basic]
Public Event FontChanged As EventHandler
[C#]
public event EventHandler FontChanged;
[C++]
public: __event EventHandler* FontChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyleChanged Event

Lidor Systems Collector Class Library

GroupStyle.HeaderStyleChanged Event

Occurs when the value of the HeaderStyle property changes.

[Visual Basic]
Public Event HeaderStyleChanged As EventHandler
[C#]
public event EventHandler HeaderStyleChanged;
[C++]
public: __event EventHandler* HeaderStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MarginChanged Event

Lidor Systems Collector Class Library

GroupStyle.MarginChanged Event

Occurs when the value of the Margin property changes.

[Visual Basic]
Public Event MarginChanged As EventHandler
[C#]
public event EventHandler MarginChanged;
[C++]
public: __event EventHandler* MarginChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MoveButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.MoveButtonChanged Event

Occurs when the value of the MoveButton property changes.

[Visual Basic]
Public Event MoveButtonChanged As EventHandler
[C#]
public event EventHandler MoveButtonChanged;
[C++]
public: __event EventHandler* MoveButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OrientationChanged Event

Lidor Systems Collector Class Library

GroupStyle.OrientationChanged Event

Occurs when the value of the Orientation property changes.

[Visual Basic]
Public Event OrientationChanged As EventHandler
[C#]
public event EventHandler OrientationChanged;
[C++]
public: __event EventHandler* OrientationChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PagePaddingChanged Event

Lidor Systems Collector Class Library

GroupStyle.PagePaddingChanged Event

Occurs when the value of the PagePadding property changes.

[Visual Basic]
Public Event PagePaddingChanged As EventHandler
[C#]
public event EventHandler PagePaddingChanged;
[C++]
public: __event EventHandler* PagePaddingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageSpacingChanged Event

Lidor Systems Collector Class Library

GroupStyle.PageSpacingChanged Event

Occurs when the value of the PageSpacing property changes.

[Visual Basic]
Public Event PageSpacingChanged As EventHandler
[C#]
public event EventHandler PageSpacingChanged;
[C++]
public: __event EventHandler* PageSpacingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyleChanged Event

Lidor Systems Collector Class Library

GroupStyle.PageStyleChanged Event

Occurs when the value of the PageStyle property changes.

[Visual Basic]
Public Event PageStyleChanged As EventHandler
[C#]
public event EventHandler PageStyleChanged;
[C++]
public: __event EventHandler* PageStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ScrollingButtonsChanged Event

Lidor Systems Collector Class Library

GroupStyle.ScrollingButtonsChanged Event

Occurs when the value of the ScrollingButtons property changes.

[Visual Basic]
Public Event ScrollingButtonsChanged As EventHandler
[C#]
public event EventHandler ScrollingButtonsChanged;
[C++]
public: __event EventHandler* ScrollingButtonsChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabCloseButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.TabCloseButtonChanged Event

Occurs when the value of the TabCloseButton property changes.

[Visual Basic]
Public Event TabCloseButtonChanged As EventHandler
[C#]
public event EventHandler TabCloseButtonChanged;
[C++]
public: __event EventHandler* TabCloseButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabSelectButtonChanged Event

Lidor Systems Collector Class Library

GroupStyle.TabSelectButtonChanged Event

Occurs when the value of the TabSelectButton property changes.

[Visual Basic]
Public Event TabSelectButtonChanged As EventHandler
[C#]
public event EventHandler TabSelectButtonChanged;
[C++]
public: __event EventHandler* TabSelectButtonChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyleChanged Event

Lidor Systems Collector Class Library

GroupStyle.TabStripButtonStyleChanged Event

Occurs when the value of the TabStripButtonStyle property changes.

[Visual Basic]
Public Event TabStripButtonStyleChanged As EventHandler
[C#]
public event EventHandler TabStripButtonStyleChanged;
[C++]
public: __event EventHandler* TabStripButtonStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyleChanged Event

Lidor Systems Collector Class Library

GroupStyle.TabStyleChanged Event

Occurs when the value of the TabStyle property changes.

[Visual Basic]
Public Event TabStyleChanged As EventHandler
[C#]
public event EventHandler TabStyleChanged;
[C++]
public: __event EventHandler* TabStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GroupStyle Class | GroupStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Class

Represents the style of header.

For a list of all members of this type, see HeaderStyle Members.

System.Object
LidorSystems.Collector.Style.HeaderStyle

[Visual Basic]
Public Class HeaderStyle
[C#]
public class HeaderStyle
[C++]
public __gc class HeaderStyle
[JScript]
public class HeaderStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Members

HeaderStyle overview

Public Constructors

public constructor HeaderStyle Constructor Initializes a new instance of the HeaderStyle class.

Public Properties

public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.
public property SelectedStyle | Gets or sets the Selected style.

Public Events

public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.
public event SelectedStyleChanged | Occurs when the SelectedStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.
protected method OnSelectedStyleChanged | Raises the SelectedStyleChanged event.

See Also

HeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Constructor ()

Initializes a new instance of the HeaderStyle class.

[Visual Basic]
Public Sub New()
[C#]
public HeaderStyle();
[C++]
public: HeaderStyle();
[JScript]
public function HeaderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Properties

The properties of the HeaderStyle class are listed here. For a complete list of HeaderStyle class members, see the HeaderStyle Members topic.

Public Properties

public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.
public property SelectedStyle | Gets or sets the Selected style.

See Also

HeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyle Property

Lidor Systems Collector Class Library

HeaderStyle.HoverStyle Property

Gets or sets the Hover style.

[Visual Basic]
Public Property HoverStyle As CommonHeaderStyle
[C#]
public CommonHeaderStyle HoverStyle {get; set;}
[C++]
public: __property CommonHeaderStyle get_HoverStyle();
public: __property void set_HoverStyle(CommonHeaderStyle);
[JScript]
public function get HoverStyle() : CommonHeaderStyle;
public function set HoverStyle(CommonHeaderStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyle Property

Lidor Systems Collector Class Library

HeaderStyle.NormalStyle Property

Gets or sets the Normal style.

[Visual Basic]
Public Property NormalStyle As CommonHeaderStyle
[C#]
public CommonHeaderStyle NormalStyle {get; set;}
[C++]
public: __property CommonHeaderStyle get_NormalStyle();
public: __property void set_NormalStyle(CommonHeaderStyle);
[JScript]
public function get NormalStyle() : CommonHeaderStyle;
public function set NormalStyle(CommonHeaderStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedStyle Property

Lidor Systems Collector Class Library

HeaderStyle.SelectedStyle Property

Gets or sets the Selected style.

[Visual Basic]
Public Property SelectedStyle As CommonHeaderStyle
[C#]
public CommonHeaderStyle SelectedStyle {get; set;}
[C++]
public: __property CommonHeaderStyle get_SelectedStyle();
public: __property void set_SelectedStyle(CommonHeaderStyle);
[JScript]
public function get SelectedStyle() : CommonHeaderStyle;
public function set SelectedStyle(CommonHeaderStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Methods

The methods of the HeaderStyle class are listed here. For a complete list of HeaderStyle class members, see the HeaderStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.
protected method OnSelectedStyleChanged | Raises the SelectedStyleChanged event.

See Also

HeaderStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

HeaderStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As HeaderStyle
[C#]
public virtual HeaderStyle Clone();
[C++]
public: virtual HeaderStyle Clone();
[JScript]
public function Clone() : HeaderStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHoverStyleChanged Method

Lidor Systems Collector Class Library

HeaderStyle.OnHoverStyleChanged Method

Raises the HoverStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHoverStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHoverStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHoverStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHoverStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHoverStyleChanged in a derived class, be sure to call the base class's OnHoverStyleChanged method so that registered delegates receive the event.

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnNormalStyleChanged Method

Lidor Systems Collector Class Library

HeaderStyle.OnNormalStyleChanged Method

Raises the NormalStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnNormalStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnNormalStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnNormalStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnNormalStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnNormalStyleChanged in a derived class, be sure to call the base class's OnNormalStyleChanged method so that registered delegates receive the event.

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnSelectedStyleChanged Method

Lidor Systems Collector Class Library

HeaderStyle.OnSelectedStyleChanged Method

Raises the SelectedStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnSelectedStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnSelectedStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnSelectedStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnSelectedStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnSelectedStyleChanged in a derived class, be sure to call the base class's OnSelectedStyleChanged method so that registered delegates receive the event.

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HeaderStyle Events

The events of the HeaderStyle class are listed here. For a complete list of HeaderStyle class members, see the HeaderStyle Members topic.

Public Events

public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.
public event SelectedStyleChanged | Occurs when the SelectedStyle property value changes.

See Also

HeaderStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyleChanged Event

Lidor Systems Collector Class Library

HeaderStyle.HoverStyleChanged Event

Occurs when the value of the HoverStyle property changes.

[Visual Basic]
Public Event HoverStyleChanged As EventHandler
[C#]
public event EventHandler HoverStyleChanged;
[C++]
public: __event EventHandler* HoverStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyleChanged Event

Lidor Systems Collector Class Library

HeaderStyle.NormalStyleChanged Event

Occurs when the value of the NormalStyle property changes.

[Visual Basic]
Public Event NormalStyleChanged As EventHandler
[C#]
public event EventHandler NormalStyleChanged;
[C++]
public: __event EventHandler* NormalStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedStyleChanged Event

Lidor Systems Collector Class Library

HeaderStyle.SelectedStyleChanged Event

Occurs when the value of the SelectedStyle property changes.

[Visual Basic]
Public Event SelectedStyleChanged As EventHandler
[C#]
public event EventHandler SelectedStyleChanged;
[C++]
public: __event EventHandler* SelectedStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

HeaderStyle Class | HeaderStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Class

Represents the style of the Page control.

For a list of all members of this type, see PageStyle Members.

System.Object
LidorSystems.Collector.Style.PageStyle

[Visual Basic]
Public Class PageStyle
[C#]
public class PageStyle
[C++]
public __gc class PageStyle
[JScript]
public class PageStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Members

PageStyle overview

Public Constructors

public constructor PageStyle Constructor Initializes a new instance of the PageStyle class.

Public Properties

public property BackgroundStyle | Gets or sets the background style.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Page.
public property Font | Gets or sets the font used to display the text in the Page control.
public property Margin | Gets or sets an enumeration that determines the margins of client area of the Page control.
public property TabStyle | Gets or sets the style of tabs.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event MarginChanged | Occurs when the Margin property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnMarginChanged | Raises the MarginChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

PageStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Constructor ()

Initializes a new instance of the PageStyle class.

[Visual Basic]
Public Sub New()
[C#]
public PageStyle();
[C++]
public: PageStyle();
[JScript]
public function PageStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Properties

The properties of the PageStyle class are listed here. For a complete list of PageStyle class members, see the PageStyle Members topic.

Public Properties

public property BackgroundStyle | Gets or sets the background style.
public property ColorScheme | Gets or sets an enumeration that determines the ColorScheme of the Page.
public property Font | Gets or sets the font used to display the text in the Page control.
public property Margin | Gets or sets an enumeration that determines the margins of client area of the Page control.
public property TabStyle | Gets or sets the style of tabs.

See Also

PageStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyle Property

Lidor Systems Collector Class Library

PageStyle.BackgroundStyle Property

Gets or sets the background style of Page control.

[Visual Basic]
Public Property BackgroundStyle As CommonStyle
[C#]
public CommonStyle BackgroundStyle {get; set;}
[C++]
public: __property CommonStyle get_BackgroundStyle();
public: __property void set_BackgroundStyle(CommonStyle);
[JScript]
public function get BackgroundStyle() : CommonStyle;
public function set BackgroundStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorScheme Property

Lidor Systems Collector Class Library

PageStyle.ColorScheme Property

Gets or sets an enumeration that determines the ColorScheme of the Page control.

[Visual Basic]
Public Property ColorScheme As ColorScheme
[C#]
public ColorScheme ColorScheme {get; set;}
[C++]
public: __property ColorScheme get_ColorScheme();
public: __property void set_ColorScheme(ColorScheme);
[JScript]
public function get ColorScheme() : ColorScheme;
public function set ColorScheme(ColorScheme);

Property Value

The ColorScheme assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Font Property

Lidor Systems Collector Class Library

PageStyle.Font Property

Gets or sets the font used to display the text in the Page control.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the text in the Page control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Margin Property

Lidor Systems Collector Class Library

PageStyle.Margin Property

Gets or sets an enumeration that determines the margins of client area of the Page control.

[Visual Basic]
Public Property Margin As Margin
[C#]
public Margin Margin {get; set;}
[C++]
public: __property Margin get_Margin();
public: __property void set_Margin(Margin);
[JScript]
public function get Margin() : Margin;
public function set Margin(Margin);

Property Value

The Margin assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Property

Lidor Systems Collector Class Library

PageStyle.TabStyle Property

Gets or sets the style of tabs.

[Visual Basic]
Public Property TabStyle As TabStyle
[C#]
public TabStyle TabStyle {get; set;}
[C++]
public: __property TabStyle get_TabStyle();
public: __property void set_TabStyle(TabStyle);
[JScript]
public function get TabStyle() : TabStyle;
public function set TabStyle(TabStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Methods

The methods of the PageStyle class are listed here. For a complete list of PageStyle class members, see the PageStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBackgroundStyleChanged | Raises the BackgroundStyleChanged event.
protected method OnColorSchemeChanged | Raises the ColorSchemeChanged event.
protected method OnFontChanged | Raises the FontChanged event.
protected method OnMarginChanged | Raises the MarginChanged event.
protected method OnTabStyleChanged | Raises the TabStyleChanged event.

See Also

PageStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

PageStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As PageStyle
[C#]
public virtual PageStyle Clone();
[C++]
public: virtual PageStyle Clone();
[JScript]
public function Clone() : PageStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnBackgroundStyleChanged Method

Lidor Systems Collector Class Library

PageStyle.OnBackgroundStyleChanged Method

Raises the BackgroundStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnBackgroundStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnBackgroundStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnBackgroundStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnBackgroundStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBackgroundStyleChanged in a derived class, be sure to call the base class's OnBackgroundStyleChanged method so that registered delegates receive the event.

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnColorSchemeChanged Method

Lidor Systems Collector Class Library

PageStyle.OnColorSchemeChanged Method

Raises the ColorSchemeChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnColorSchemeChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnColorSchemeChanged(
   EventHandler e
);
[C++]
protected: virtual void OnColorSchemeChanged(
   EventHandler* e
);
[JScript]
protected function OnColorSchemeChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnColorSchemeChanged in a derived class, be sure to call the base class's OnColorSchemeChanged method so that registered delegates receive the event.

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnFontChanged Method

Lidor Systems Collector Class Library

PageStyle.OnFontChanged Method

Raises the FontChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnFontChanged(
   EventHandler e
);
[C++]
protected: virtual void OnFontChanged(
   EventHandler* e
);
[JScript]
protected function OnFontChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnFontChanged in a derived class, be sure to call the base class's OnFontChanged method so that registered delegates receive the event.

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMarginChanged Method

Lidor Systems Collector Class Library

PageStyle.OnMarginChanged Method

Raises the MarginChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnMarginChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnMarginChanged(
   EventHandler e
);
[C++]
protected: virtual void OnMarginChanged(
   EventHandler* e
);
[JScript]
protected function OnMarginChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnMarginChanged in a derived class, be sure to call the base class's OnMarginChanged method so that registered delegates receive the event.

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabStyleChanged Method

Lidor Systems Collector Class Library

PageStyle.OnTabStyleChanged Method

Raises the TabStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnTabStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnTabStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnTabStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnTabStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnTabStyleChanged in a derived class, be sure to call the base class's OnTabStyleChanged method so that registered delegates receive the event.

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


PageStyle Events

The events of the PageStyle class are listed here. For a complete list of PageStyle class members, see the PageStyle Members topic.

Public Events

public event BackgroundStyleChanged | Occurs when the BackgroundStyle property value changes.
public event ColorSchemeChanged | Occurs when the ColorScheme property value changes.
public event FontChanged | Occurs when the Font property value changes.
public event MarginChanged | Occurs when the Margin property value changes.
public event TabStyleChanged | Occurs when the TabStyle property value changes.

See Also

PageStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundStyleChanged Event

Lidor Systems Collector Class Library

PageStyle.BackgroundStyleChanged Event

Occurs when the value of the BackgroundStyle property changes.

[Visual Basic]
Public Event BackgroundStyleChanged As EventHandler
[C#]
public event EventHandler BackgroundStyleChanged;
[C++]
public: __event EventHandler* BackgroundStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorSchemeChanged Event

Lidor Systems Collector Class Library

PageStyle.ColorSchemeChanged Event

Occurs when the value of the ColorScheme property changes.

[Visual Basic]
Public Event ColorSchemeChanged As EventHandler
[C#]
public event EventHandler ColorSchemeChanged;
[C++]
public: __event EventHandler* ColorSchemeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FontChanged Event

Lidor Systems Collector Class Library

PageStyle.FontChanged Event

Occurs when the value of the Font property changes.

[Visual Basic]
Public Event FontChanged As EventHandler
[C#]
public event EventHandler FontChanged;
[C++]
public: __event EventHandler* FontChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


MarginChanged Event

Lidor Systems Collector Class Library

PageStyle.MarginChanged Event

Occurs when the value of the Margin property changes.

[Visual Basic]
Public Event MarginChanged As EventHandler
[C#]
public event EventHandler MarginChanged;
[C++]
public: __event EventHandler* MarginChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyleChanged Event

Lidor Systems Collector Class Library

PageStyle.TabStyleChanged Event

Occurs when the value of the TabStyle property changes.

[Visual Basic]
Public Event TabStyleChanged As EventHandler
[C#]
public event EventHandler TabStyleChanged;
[C++]
public: __event EventHandler* TabStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

PageStyle Class | PageStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Class

Represents the style of tabs.

For a list of all members of this type, see TabStyle Members.

System.Object
LidorSystems.Collector.Style.TabStyle

[Visual Basic]
Public Class TabStyle
[C#]
public class TabStyle
[C++]
public __gc class TabStyle
[JScript]
public class TabStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Members

TabStyle overview

Public Constructors

public constructor TabStyle Constructor Initializes a new instance of the TabStyle class.

Public Properties

public property DisabledStyle | Gets or sets the Disabled style.
public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.
public property SelectedStyle | Gets or sets the Selected style.

Public Events

public event DisabledStyleChanged | Occurs when the DisabledStyle property value changes.
public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.
public event SelectedStyleChanged | Occurs when the SelectedStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnDisabledStyleChanged | Raises the DisabledStyleChanged event.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.
protected method OnSelectedStyleChanged | Raises the SelectedStyleChanged event.

See Also

TabStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Constructor ()

Initializes a new instance of the TabStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TabStyle();
[C++]
public: TabStyle();
[JScript]
public function TabStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Properties

The properties of the TabStyle class are listed here. For a complete list of TabStyle class members, see the TabStyle Members topic.

Public Properties

public property DisabledStyle | Gets or sets the Disabled style.
public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.
public property SelectedStyle | Gets or sets the Selected style.

See Also

TabStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DisabledStyle Property

Lidor Systems Collector Class Library

TabStyle.DisabledStyle Property

Gets or sets the Disabled style.

[Visual Basic]
Public Property DisabledStyle As CommonStyle
[C#]
public CommonStyle DisabledStyle {get; set;}
[C++]
public: __property CommonStyle get_DisabledStyle();
public: __property void set_DisabledStyle(CommonStyle);
[JScript]
public function get DisabledStyle() : CommonStyle;
public function set DisabledStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyle Property

Lidor Systems Collector Class Library

TabStyle.HoverStyle Property

Gets or sets the Hover style.

[Visual Basic]
Public Property HoverStyle As CommonStyle
[C#]
public CommonStyle HoverStyle {get; set;}
[C++]
public: __property CommonStyle get_HoverStyle();
public: __property void set_HoverStyle(CommonStyle);
[JScript]
public function get HoverStyle() : CommonStyle;
public function set HoverStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyle Property

Lidor Systems Collector Class Library

TabStyle.NormalStyle Property

Gets or sets the Normal style.

[Visual Basic]
Public Property NormalStyle As CommonStyle
[C#]
public CommonStyle NormalStyle {get; set;}
[C++]
public: __property CommonStyle get_NormalStyle();
public: __property void set_NormalStyle(CommonStyle);
[JScript]
public function get NormalStyle() : CommonStyle;
public function set NormalStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedStyle Property

Lidor Systems Collector Class Library

TabStyle.SelectedStyle Property

Gets or sets the Selected style.

[Visual Basic]
Public Property SelectedStyle As CommonStyle
[C#]
public CommonStyle SelectedStyle {get; set;}
[C++]
public: __property CommonStyle get_SelectedStyle();
public: __property void set_SelectedStyle(CommonStyle);
[JScript]
public function get SelectedStyle() : CommonStyle;
public function set SelectedStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Methods

The methods of the TabStyle class are listed here. For a complete list of TabStyle class members, see the TabStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnDisabledStyleChanged | Raises the DisabledStyleChanged event.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.
protected method OnSelectedStyleChanged | Raises the SelectedStyleChanged event.

See Also

TabStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

TabStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As TabStyle
[C#]
public virtual TabStyle Clone();
[C++]
public: virtual TabStyle Clone();
[JScript]
public function Clone() : TabStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnDisabledStyleChanged Method

Lidor Systems Collector Class Library

TabStyle.OnDisabledStyleChanged Method

Raises the DisabledStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnDisabledStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnDisabledStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnDisabledStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnDisabledStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnDisabledStyleChanged in a derived class, be sure to call the base class's OnDisabledStyleChanged method so that registered delegates receive the event.

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHoverStyleChanged Method

Lidor Systems Collector Class Library

TabStyle.OnHoverStyleChanged Method

Raises the HoverStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHoverStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHoverStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHoverStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHoverStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHoverStyleChanged in a derived class, be sure to call the base class's OnHoverStyleChanged method so that registered delegates receive the event.

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnNormalStyleChanged Method

Lidor Systems Collector Class Library

TabStyle.OnNormalStyleChanged Method

Raises the NormalStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnNormalStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnNormalStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnNormalStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnNormalStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnNormalStyleChanged in a derived class, be sure to call the base class's OnNormalStyleChanged method so that registered delegates receive the event.

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnSelectedStyleChanged Method

Lidor Systems Collector Class Library

TabStyle.OnSelectedStyleChanged Method

Raises the SelectedStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnSelectedStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnSelectedStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnSelectedStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnSelectedStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnSelectedStyleChanged in a derived class, be sure to call the base class's OnSelectedStyleChanged method so that registered delegates receive the event.

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStyle Events

The events of the TabStyle class are listed here. For a complete list of TabStyle class members, see the TabStyle Members topic.

Public Events

public event DisabledStyleChanged | Occurs when the DisabledStyle property value changes.
public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.
public event SelectedStyleChanged | Occurs when the SelectedStyle property value changes.

See Also

TabStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DisabledStyleChanged Event

Lidor Systems Collector Class Library

TabStyle.DisabledStyleChanged Event

Occurs when the value of the DisabledStyle property changes.

[Visual Basic]
Public Event DisabledStyleChanged As EventHandler
[C#]
public event EventHandler DisabledStyleChanged;
[C++]
public: __event EventHandler* DisabledStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyleChanged Event

Lidor Systems Collector Class Library

TabStyle.HoverStyleChanged Event

Occurs when the value of the HoverStyle property changes.

[Visual Basic]
Public Event HoverStyleChanged As EventHandler
[C#]
public event EventHandler HoverStyleChanged;
[C++]
public: __event EventHandler* HoverStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyleChanged Event

Lidor Systems Collector Class Library

TabStyle.NormalStyleChanged Event

Occurs when the value of the NormalStyle property changes.

[Visual Basic]
Public Event NormalStyleChanged As EventHandler
[C#]
public event EventHandler NormalStyleChanged;
[C++]
public: __event EventHandler* NormalStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


SelectedStyleChanged Event

Lidor Systems Collector Class Library

TabStyle.SelectedStyleChanged Event

Occurs when the value of the SelectedStyle property changes.

[Visual Basic]
Public Event SelectedStyleChanged As EventHandler
[C#]
public event EventHandler SelectedStyleChanged;
[C++]
public: __event EventHandler* SelectedStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStyle Class | TabStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Class

Represents the style of tabstrip buttons.

For a list of all members of this type, see TabStripButtonStyle Members.

System.Object
LidorSystems.Collector.Style.TabStripButtonStyle

[Visual Basic]
Public Class TabStripButtonStyle
[C#]
public class TabStripButtonStyle
[C++]
public __gc class TabStripButtonStyle
[JScript]
public class TabStripButtonStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Members

TabStripButtonStyle overview

Public Constructors

public constructor TabStripButtonStyle Constructor Initializes a new instance of the TabStripButtonStyle class.

Public Properties

public property DisabledStyle | Gets or sets the Disabled style.
public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.

Public Events

public event DisabledStyleChanged | Occurs when the DisabledStyle property value changes.
public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.

Public Methods

public method Clone Creates an exact copy of the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnDisabledStyleChanged | Raises the DisabledStyleChanged event.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.

See Also

TabStripButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Constructor ()

Initializes a new instance of the TabStripButtonStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TabStripButtonStyle();
[C++]
public: TabStripButtonStyle();
[JScript]
public function TabStripButtonStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Properties

The properties of the TabStripButtonStyle class are listed here. For a complete list of TabStripButtonStyle class members, see the TabStripButtonStyle Members topic.

Public Properties

public property DisabledStyle | Gets or sets the Disabled style.
public property HoverStyle | Gets or sets the Hover style.
public property NormalStyle | Gets or sets the Normal style.

See Also

TabStripButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DisabledStyle Property

Lidor Systems Collector Class Library

TabStripButtonStyle.DisabledStyle Property

Gets or sets the Disabled style.

[Visual Basic]
Public Property DisabledStyle As CommonStyle
[C#]
public CommonStyle DisabledStyle {get; set;}
[C++]
public: __property CommonStyle get_DisabledStyle();
public: __property void set_DisabledStyle(CommonStyle);
[JScript]
public function get DisabledStyle() : CommonStyle;
public function set DisabledStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyle Property

Lidor Systems Collector Class Library

TabStripButtonStyle.HoverStyle Property

Gets or sets the Hover style.

[Visual Basic]
Public Property HoverStyle As CommonStyle
[C#]
public CommonStyle HoverStyle {get; set;}
[C++]
public: __property CommonStyle get_HoverStyle();
public: __property void set_HoverStyle(CommonStyle);
[JScript]
public function get HoverStyle() : CommonStyle;
public function set HoverStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyle Property

Lidor Systems Collector Class Library

TabStripButtonStyle.NormalStyle Property

Gets or sets the Normal style.

[Visual Basic]
Public Property NormalStyle As CommonStyle
[C#]
public CommonStyle NormalStyle {get; set;}
[C++]
public: __property CommonStyle get_NormalStyle();
public: __property void set_NormalStyle(CommonStyle);
[JScript]
public function get NormalStyle() : CommonStyle;
public function set NormalStyle(CommonStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Methods

The methods of the TabStripButtonStyle class are listed here. For a complete list of TabStripButtonStyle class members, see the TabStripButtonStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current Object.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnDisabledStyleChanged | Raises the DisabledStyleChanged event.
protected method OnHoverStyleChanged | Raises the HoverStyleChanged event.
protected method OnNormalStyleChanged | Raises the NormalStyleChanged event.

See Also

TabStripButtonStyle Class | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

TabStripButtonStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As TabStripButtonStyle
[C#]
public virtual TabStripButtonStyle Clone();
[C++]
public: virtual TabStripButtonStyle Clone();
[JScript]
public function Clone() : TabStripButtonStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnDisabledStyleChanged Method

Lidor Systems Collector Class Library

TabStripButtonStyle.OnDisabledStyleChanged Method

Raises the DisabledStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnDisabledStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnDisabledStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnDisabledStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnDisabledStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnDisabledStyleChanged in a derived class, be sure to call the base class's OnDisabledStyleChanged method so that registered delegates receive the event.

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnHoverStyleChanged Method

Lidor Systems Collector Class Library

TabStripButtonStyle.OnHoverStyleChanged Method

Raises the HoverStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnHoverStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnHoverStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnHoverStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnHoverStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnHoverStyleChanged in a derived class, be sure to call the base class's OnHoverStyleChanged method so that registered delegates receive the event.

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnNormalStyleChanged Method

Lidor Systems Collector Class Library

TabStripButtonStyle.OnNormalStyleChanged Method

Raises the NormalStyleChangedEvent event.

[Visual Basic]
Protected Overridable Sub OnNormalStyleChanged( _
   ByVal e As EventHandler _
)
[C#]
protected virtual void OnNormalStyleChanged(
   EventHandler e
);
[C++]
protected: virtual void OnNormalStyleChanged(
   EventHandler* e
);
[JScript]
protected function OnNormalStyleChanged(
   e : EventHandler
);

Parameters

e
A EventHandler that contains the event data.

Remarks

Notes to Inheritors: When overriding OnNormalStyleChanged in a derived class, be sure to call the base class's OnNormalStyleChanged method so that registered delegates receive the event.

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabStripButtonStyle Events

The events of the TabStripButtonStyle class are listed here. For a complete list of TabStripButtonStyle class members, see the TabStripButtonStyle Members topic.

Public Events

public event DisabledStyleChanged | Occurs when the DisabledStyle property value changes.
public event HoverStyleChanged | Occurs when the HoverStyle property value changes.
public event NormalStyleChanged | Occurs when the NormalStyle property value changes.

See Also

TabStripButtonStyle Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


DisabledStyleChanged Event

Lidor Systems Collector Class Library

TabStripButtonStyle.DisabledStyleChanged Event

Occurs when the value of the DisabledStyle property changes.

[Visual Basic]
Public Event DisabledStyleChanged As EventHandler
[C#]
public event EventHandler DisabledStyleChanged;
[C++]
public: __event EventHandler* DisabledStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


HoverStyleChanged Event

Lidor Systems Collector Class Library

TabStripButtonStyle.HoverStyleChanged Event

Occurs when the value of the HoverStyle property changes.

[Visual Basic]
Public Event HoverStyleChanged As EventHandler
[C#]
public event EventHandler HoverStyleChanged;
[C++]
public: __event EventHandler* HoverStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


NormalStyleChanged Event

Lidor Systems Collector Class Library

TabStripButtonStyle.NormalStyleChanged Event

Occurs when the value of the NormalStyle property changes.

[Visual Basic]
Public Event NormalStyleChanged As EventHandler
[C#]
public event EventHandler NormalStyleChanged;
[C++]
public: __event EventHandler* NormalStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripButtonStyle Class | TabStripButtonStyle Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ColorScheme Enumeration

Enumerator used to set the style colors of the Bar, Group, Page control.

[Visual Basic]
Public Enum ColorScheme
[C#]
public enum ColorScheme
[C++]
__value public enum ColorScheme
[JScript]
public
   enum ColorScheme

Members

Default, Carrot, Coral, DarkForest, DarkWood, DeepSea, Forest, Gold, GoldRose, Lily, Metalic, Midnight, Rose, Sand, Sea, Silver, Strawberry, Sunset, Vinegar, Violet, Wood, Custom.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ControlAppearance Enumeration

Enumerator used to determine the appearance of the Bar control.

[Visual Basic]
Public Enum ControlAppearance
[C#]
public enum ControlAppearance
[C++]
__value public enum ControlAppearance
[JScript]
public
   enum ControlAppearance

Members

Member name | Description
Vertical | Groups are shown in vertical order.
Horizontal | Groups are shown in horizontal order.
Selection | Only selected Group is shown, and others can be selected.
ToolWindow | Groups are shown like toolwindows.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


FillStyle Enumeration

Specifies the fill mode of the internal area of the Bar, Group, Page control.

[Visual Basic]
Public Enum FillStyle
[C#]
public enum FillStyle
[C++]
__value public enum FillStyle
[JScript]
public
   enum FillStyle

Members

Member name | Description
Flat | Specifies solid color.
Vertical | Specifies a gradient from top to bottom.
BackwardVertical | Specifies a gradient from bottom to top.
Horizontal | Specifies a gradient from left to right.
BackwardHorizontal | Specifies a gradient from right to left.
ForwardDiagonal | Specifies a gradient from upper left to lower right.
BackwardDiagonal | Specifies a gradient from upper right to lower left.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


ImageSize Enumeration

Specifies the size of the image of a container control.

[Visual Basic]
Public Enum ImageSize
[C#]
public enum ImageSize
[C++]
__value public enum ImageSize
[JScript]
public
   enum ImageSize

Members

Member name | Description
Small | The image size is half size smaller than the normal image size.
Normal | The normal size of image of a container control.
Large | The image size is one size larger than the normal image size.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


TabOrientation Enumeration

Specifies orientation of tabs on the drawing surface.

[Visual Basic]
Public Enum TabOrientation
[C#]
public enum TabOrientation
[C++]
__value public enum TabOrientation
[JScript]
public
   enum TabOrientation

Members

Member name | Description
Left | Tabs are in vertical position at the left side of drawing surface of the control.
Top | Tabs are in horizontal position at the top side of drawing surface of the control.
Right | Tabs are in vertical position at the right side of drawing surface of the control.
Bottom | Tabs are in horizontal position at the bottom side of drawing surface of the control.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


VisualStyle Enumeration

Specifies the visual style of the Bar, Group, Page control.

[Visual Basic]
Public Enum VisualStyle
[C#]
public enum VisualStyle
[C++]
__value public enum VisualStyle
[JScript]
public
   enum VisualStyle

Members

Member name | Description
Classic | Used to render controls in Windows Classic control style.
Office2003 | Used to render controls in Office 2003 control style.
VS2003 | Used to render controls in Visual Studio 2003 control style.
VS2005 | Used to render controls in Visual Studio 2005 control style.
Default | Used to render controls in Windows XP and Collector control style.

Requirements

Namespace: LidorSystems.Collector.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.Collector (in LidorSystems.Collector.dll)

See Also

LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


LidorSystems.IntegralUI

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI Namespace

Classes

Class | Description
ControlBase | Provides a common implementation of members for controls.
ObjectBase | Provides a common implementation of members for objects.
ObjectCancelClickEventArgs | Provides data for common clickable events which can be canceled.
ObjectCancelEventArgs | Provides data for common cancelable events.
ObjectClickEventArgs | Provides data for common clickable events.
ObjectEditEventArgs | Provides data for common editing events.
ObjectEventArgs | Provides data for common events.
PageBase | Provides a common implementation of members for panel controls.
UpdateEventArgs | Provides data for events used to notify about control layout or display changes.

Delegates

Delegate | Description
ObjectCancelClickEventHandler | Represents the method that will handle common clickable events which can be canceled.
ObjectCancelEventHandler | Represents the method that will handle common cancelable events.
ObjectClickEventHandler | Represents the method that will handle common clickable events.
ObjectEditEventHandler | Represents the method that will handle common editing events.
ObjectEventHandler | Represents the method that will handle common events.
UpdateEventHandler | Represents the method that will handle events used to notify about control layout or display changes.

Enumerations

Enumeration | Description
ActionType | Enumerator used to specify the action assigned to some object.
BackgroundImageSpace | Enumerator used to specify where the background image will be placed.
CheckMode | Enumerator used to determine whether check boxes can accept two or three values.
CloseAction | Enumerator used to determine how an object will be closed.
DragDropMode | Enumerator used to determine the type of drag-and-drop operation.
FadingEffect | Enumerator used to determine the fading effect that is used during hovering over items.
FadingSpeed | Enumerator used to determine the speed of fading that is used during hovering over objects.
ObjectState | Enumerator used to determine the current state of the object.
VerticalAlignment | Specifies how an object or text in a control is vertically aligned relative to an element of the control.


ControlBase Class

Provides a common implementation of members for controls.

For a list of all members of this type, see ControlBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.ControlBase
LidorSystems.IntegralUI.Containers.ContainerBase
LidorSystems.IntegralUI.Lists.ListBase

[Visual Basic]
MustInherit Public Class ControlBase
   Inherits Control
[C#]
public abstract class ControlBase : Control
[C++]
public __gc __abstract class ControlBase : public Control
[JScript]
public abstract class ControlBase extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Members

ControlBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint | Resumes the painting of the control.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint | Temporarily suspends the painting of the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


ControlBase Properties

The properties of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


AllowDrag Property

Lidor Systems IntegralUI Class Library

ControlBase.AllowDrag Property

Determines whether the objects from ControlBase control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


DragDropMode Property

Lidor Systems IntegralUI Class Library

ControlBase.DragDropMode Property

Gets or sets the type of drag-and-drop operation.

[Visual Basic]
Public Property DragDropMode As DragDropMode
[C#]
public DragDropMode DragDropMode {get; set;}
[C++]
public: __property DragDropMode get_DragDropMode();
public: __property void set_DragDropMode(DragDropMode);
[JScript]
public function get DragDropMode() : DragDropMode;
public function set DragDropMode(DragDropMode);

Property Value

The DragDropMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


DragDropReorder Property

Lidor Systems IntegralUI Class Library

ControlBase.DragDropReorder Property

Determines whether reordering of objects is allowed during drag&drop operation.

[Visual Basic]
Public Property DragDropReorder As Boolean
[C#]
public bool DragDropReorder { get; set; }
[C++]
public: __property bool get_DragDropReorder();
public: __property void set_DragDropReorder(bool );
[JScript]
public function get DragDropReorder() : bool
public function set DragDropReorder(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FadingEffect Property

Lidor Systems IntegralUI Class Library

ControlBase.FadingEffect Property

Gets or sets an enumeration that determines the fading effect used during hovering over objects.

[Visual Basic]
Public Property FadingEffect As FadingEffect
[C#]
public FadingEffect FadingEffect {get; set;}
[C++]
public: __property FadingEffect get_FadingEffect();
public: __property void set_FadingEffect(FadingEffect);
[JScript]
public function get FadingEffect() : FadingEffect;
public function set FadingEffect(FadingEffect);

Property Value

The FadingEffect assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FadingSpeed Property

Lidor Systems IntegralUI Class Library

ControlBase.FadingSpeed Property

Gets or sets an enumeration that determines the speed of fading used during hovering over objects.

[Visual Basic]
Public Property FadingSpeed As FadingSpeed
[C#]
public FadingSpeed FadingSpeed {get; set;}
[C++]
public: __property FadingSpeed get_FadingSpeed();
public: __property void set_FadingSpeed(FadingSpeed);
[JScript]
public function get FadingSpeed() : FadingSpeed;
public function set FadingSpeed(FadingSpeed);

Property Value

The FadingSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ShowDropMarker Property

Lidor Systems IntegralUI Class Library

ControlBase.ShowDropMarker Property

Gets or sets a value indicating whether a marker is shown during drag&drop operation.

[Visual Basic]
 Public Property ShowDropMarker As Boolean
[C#]
 public bool ShowDropMarker { get; set; }
[C++]
 public: __property bool
 get_ShowDropMarker();
public: __property void set_ShowDropMarker(bool );
[JScript]
public function get ShowDropMarker() : bool
public function set ShowDropMarker(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


UseTheme Property

Lidor Systems IntegralUI Class Library

ControlBase.UseTheme Property

Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Overridable Property UseTheme As Boolean
[C#]
public virtual bool UseTheme { get; set; }
[C++]
public: __property virtual bool get_UseTheme();
 public:
__property virtual void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


VisualStyle Property

Lidor Systems IntegralUI Class Library

ControlBase.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Overridable Property VisualStyle As VisualStyle
[C#]
public virtual VisualStyle VisualStyle {get; set;}
[C++]
public: __property virtual VisualStyle get_VisualStyle();
public: __property virtual void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Methods

The methods of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint | Resumes the painting of the control.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint | Temporarily suspends the painting of the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ControlBase.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


GetClientRect Method

Lidor Systems IntegralUI Class Library

ControlBase.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


OnContentObjectClicked Method

Lidor Systems IntegralUI Class Library

ControlBase.OnContentObjectClicked Method

Raises the ContentObjectClicked event.

[Visual Basic]
Protected Overridable Sub OnContentObjectClicked( _
   ByVal e As ObjectClickEventArgs _
)
[C#]
protected virtual void OnContentObjectClicked(
   ObjectClickEventArgs e
);
[C++]
protected: virtual void OnContentObjectClicked(
   ObjectClickEventArgs* e
);
[JScript]
protected function OnContentObjectClicked(
   e : ObjectClickEventArgs
);

Parameters

e
A ObjectClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


OnContentObjectClicking Method

Lidor Systems IntegralUI Class Library

ControlBase.OnContentObjectClicking Method

Raises the ContentObjectClicking event.

[Visual Basic]
Protected Overridable Sub OnContentObjectClicking( _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
protected virtual void OnContentObjectClicking(
   ObjectCancelClickEventArgs e
);
[C++]
protected: virtual void OnContentObjectClicking(
   ObjectCancelClickEventArgs* e
);
[JScript]
protected function OnContentObjectClicking(
   e : ObjectCancelClickEventArgs
);

Parameters

e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumePaint Method

Lidor Systems IntegralUI Class Library

ControlBase.ResumePaint Method

Resumes the painting of the control.

[Visual Basic]
Public Overridable Sub ResumePaint()
[C#]
public virtual void ResumePaint();
[C++]
public: virtual void * ResumePaint();
[JScript]
public function ResumePaint() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumeUpdate Method

Lidor Systems IntegralUI Class Library

ControlBase.ResumeUpdate Method

Resumes the update of the control layout.

Overload List

Resumes only the layout logic of the control.

[Visual Basic] Overridable Public Sub ResumeUpdate()
[C#] public virtual ResumeUpdate();
[C++] public: virtual ResumeUpdate();
[JScript] public function ResumeUpdate();

Resumes the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub ResumeUpdate(Boolean)
[C#] public virtual ResumeUpdate(bool);
[C++] public: virtual ResumeUpdate(bool);
[JScript] public function ResumeUpdate(Boolean);

See Also

ResumeUpdate Class | ResumeUpdate Members | LidorSystems.IntegralUI Namespace


ResumeUpdate () Method

Lidor Systems IntegralUI Class Library

ControlBase.ResumeUpdate () Method

Resumes only the layout logic of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate()
[C#]
public virtual void ResumeUpdate();
[C++]
public: virtual void * ResumeUpdate();
[JScript]
public function ResumeUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumeUpdate Method

Lidor Systems IntegralUI Class Library

ControlBase.ResumeUpdate (Boolean) Method

Resumes the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void ResumeUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * ResumeUpdate(
   bool includeDrawing
);
[JScript]
public function ResumeUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendPaint Method

Lidor Systems IntegralUI Class Library

ControlBase.SuspendPaint Method

Temporarily suspends the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendPaint()
[C#]
public virtual void SuspendPaint();
[C++]
public: virtual void * SuspendPaint();
[JScript]
public function SuspendPaint() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendUpdate Method

Lidor Systems IntegralUI Class Library

ControlBase.SuspendUpdate Method

Temporarily suspends the update of the control layout.

Overload List

Suspends only the layout logic of the control.

[Visual Basic] Overridable Public Sub SuspendUpdate()
[C#] public virtual SuspendUpdate();
[C++] public: virtual SuspendUpdate();
[JScript] public function SuspendUpdate();

Suspends the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub SuspendUpdate(Boolean)
[C#] public virtual SuspendUpdate(bool);
[C++] public: virtual SuspendUpdate(bool);
[JScript] public function SuspendUpdate(Boolean);

See Also

SuspendUpdate Class | SuspendUpdate Members | LidorSystems.IntegralUI Namespace


SuspendUpdate () Method

Lidor Systems IntegralUI Class Library

ControlBase.SuspendUpdate () Method

Temporarily suspends only the layout logic of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate()
[C#]
public virtual void SuspendUpdate();
[C++]
public: virtual void * SuspendUpdate();
[JScript]
public function SuspendUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendUpdate Method

Lidor Systems IntegralUI Class Library

ControlBase.SuspendUpdate (Boolean) Method

Temporarily suspends the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void SuspendUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * SuspendUpdate(
   bool includeDrawing
);
[JScript]
public function SuspendUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

ControlBase.UpdateLayout () Method

Update layout logic of the control.

[Visual Basic]
Public Overridable Sub UpdateLayout()
[C#]
public virtual void UpdateLayout();
[C++]
 public: virtual void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Events

The events of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


ContentObjectClicked Event

Lidor Systems IntegralUI Class Library

ControlBase.ContentObjectClicked Event

Occurs after an object is clicked (placed with XML encoding) in the control content space.

[Visual Basic]
Public Event ContentObjectClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler ContentObjectClicked;
[C++]
public: __event ObjectClickEventHandler* ContentObjectClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ContentObjectClicking Event

Lidor Systems IntegralUI Class Library

ControlBase.ContentObjectClicking Event

Occurs before an object is clicked (placed with XML encoding) in the control content space.

[Visual Basic]
Public Event ContentObjectClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler ContentObjectClicking;
[C++]
public: __event ObjectCancelClickEventHandler* ContentObjectClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Class

Provides a common implementation of members for objects.

For a list of all members of this type, see ObjectBase Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Lists.ListBaseItem
LidorSystems.IntegralUI.Lists.ListBaseSubItem

[Visual Basic]

MustInherit Public Class ObjectBase
   Inherits MarshalByRefObject
   Implements IDisposable, ICloneable
[C#]

public abstract class ObjectBase : MarshalByRefObject, IDisposable,
   ICloneable
[C++]

public __gc __abstract class ObjectBase : public MarshalByRefObject,
   IDisposable, ICloneable
[JScript]
public

 abstract class ObjectBase extends MarshalByRefObject implements
   IDisposable, ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Members

ObjectEventArgs overview

Public Constructors

public constructor ObjectEventArgs Constructor Initializes a new instance of the ObjectEventArgs class.

Public Properties

public property Object Read-only property that returns the object associated with the ObjectEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectBase Constructor

Initializes a new instance of the ObjectBase class.

Overload List

Initializes a new instance of the ObjectBase class.

[Visual Basic] Public Sub New()
[C#] public ObjectBase();
[C++] public: ObjectBase();
[JScript] public function ObjectBase();

Initializes a new instance of the ObjectBase class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ObjectBase(string);
[C++] public: ObjectBase(String*);
[JScript] public function ObjectBase(String);

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Constructor ()

Initializes a new instance of the ObjectBase class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectBase();
[C++]
public: ObjectBase();
[JScript]
public function ObjectBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


ObjectBase Constructor (String)

Initializes a new instance of the ObjectBase class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ObjectBase(
   string text
);
[C++]
public: ObjectBase(
   String* text
);
[JScript]
public function ObjectBase(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


ObjectBase Properties

The properties of the ObjectBase class are listed here. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Properties

public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Index | Gets the position of the object in the object collection.
public property Key | Gets or sets a string that uniquely identifies object in a collection.
public property State | Gets a value indicating the current state of the object.
public property Tag | Gets or sets the object that contains data about the item.
public property TagString | Gets or sets the tag string of the object.
public property Text | Gets or sets the object text.
public property Visible | Gets or sets a value indicating whether the object is displayed.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


Enabled Property

Lidor Systems IntegralUI Class Library

ObjectBase.Enabled Property

Gets or sets a value indicating whether the object can respond to user interaction.

[Visual Basic]
Public Overridable Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Index Property

Lidor Systems IntegralUI Class Library

ObjectBase.Index Property

Gets the position of the object in the object collection.

[Visual Basic]
Public Overridable ReadOnly Property Index As Integer
[C#]
public virtual int Index {get;}
[C++]
public: __property virtual int get_Index();
[JScript]
public function get Index() : int;

Property Value

A zero-based index value that represents the position of the item in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Key Property

Lidor Systems IntegralUI Class Library

ObjectBase.Key Property

Gets or sets a string that uniquely identifies object in a collection.

[Visual Basic]
Public Property Key As String
[C#]
public String Key {get; set;}
[C++]
public: __property String* get_Key();
public: __property void set_Key(String*);
[JScript]
public function get Key() : String;
public function set Key(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


State Property

Lidor Systems IntegralUI Class Library

ObjectBase.State Property

Gets a value indicating the current state of the object.

[Visual Basic]
Public Overridable ReadOnly Property State As ObjectState
[C#]
public virtual ObjectState State {get;}
[C++]
public: __property virtual ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Tag Property

Lidor Systems IntegralUI Class Library

ObjectBase.Tag Property

Gets or sets the object that contains data about the object.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object*);
[JScript]
public function get Tag() : Object;
public function set Tag(Object);

Property Value

An Object that contains data about the item. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


TagString Property

Lidor Systems IntegralUI Class Library

ObjectBase.TagString Property

Gets or sets the tag string of the object.

[Visual Basic]
Public Property TagString As String
[C#]
public String TagString {get; set;}
[C++]
public: __property String* get_TagString();
public: __property void set_TagString(String*);
[JScript]
public function get TagString() : String;
public function set TagString(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Text Property

Lidor Systems IntegralUI Class Library

ObjectBase.Text Property

Gets or sets the object text.

[Visual Basic]
Public Overridable Property Text As String
[C#]
public virtual String Text {get; set;}
[C++]
public: __property virtual String* get_Text();
public: __property virtual void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Visible Property

Lidor Systems IntegralUI Class Library

ObjectBase.Visible Property

Gets or sets a value indicating whether the object is displayed.

[Visual Basic]
Public Overridable Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}
[C++]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Methods

The methods of the ObjectBase class are listed here. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Methods

public method Clone | Creates an exact copy of the current ObjectBase.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ObjectBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Updates the layout of parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ObjectBase.Clone Method

Creates an exact copy of the current ObjectBase.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ObjectBase object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ObjectBase.Dispose Method

Releases all resources used by this ObjectBase object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


RepaintParent Method

Lidor Systems IntegralUI Class Library

ObjectBase.RepaintParent Method

Repaints the parent object, if any.

[Visual Basic]
Public Overridable Sub RepaintParent()
[C#]
public virtual void RepaintParent();
[C++]
public: virtual void RepaintParent();
[JScript]
public function RepaintParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


UpdateParent Method

Lidor Systems IntegralUI Class Library

ObjectBase.UpdateParent Method

Updates the layout of parent object, if any.

[Visual Basic]
Public Overridable Sub UpdateParent()
[C#]
public virtual void UpdateParent();
[C++]
public: virtual void UpdateParent();
[JScript]
public function UpdateParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Class

Provides data for common clickable events which can be canceled.

For a list of all members of this type, see ObjectCancelClickEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs
LidorSystems.IntegralUI.ObjectCancelClickEventArgs

[Visual Basic]
Public Class ObjectCancelClickEventArgs
   Inherits ObjectCancelEventArgs
[C#]
public class ObjectCancelClickEventArgs : ObjectCancelEventArgs
[C++]
public __gc class ObjectCancelClickEventArgs : public ObjectCancelEventArgs
[JScript]
public class ObjectCancelClickEventArgs extends ObjectCancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Members

ObjectCancelClickEventArgs overview

Public Constructors

public constructor ObjectCancelClickEventArgs Constructor Initializes a new instance of the ObjectCancelClickEventArgs class.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCancelClickEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCancelClickEventArgs();
[C++] public: ObjectCancelClickEventArgs();
[JScript] public function ObjectCancelClickEventArgs();

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse buttons that are pressed and the position of mouse cursor.

[Visual Basic] Public Sub ObjectCancelClickEventArgs(Object, MouseButtons, Point)
[C#] public ObjectCancelClickEventArgs(object, MouseButtons, Point);
[C++] public: ObjectCancelClickEventArgs(Object*, MouseButtons, Point);
[JScript] public function ObjectCancelClickEventArgs(Object, MouseButtons, Point);

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse buttons that are pressed, position of mouse cursor and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCancelClickEventArgs(Object, MouseButtons, Point, Boolean)
[C#] public ObjectCancelClickEventArgs(object, MouseButtons, Point, bool);
[C++] public: ObjectCancelClickEventArgs(Object*, MouseButtons, Point, bool);
[JScript] public function ObjectCancelClickEventArgs(Object, MouseButtons, Point, Boolean);

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor ()

Initializes a new instance of the ObjectCancelClickEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCancelClickEventArgs();
[C++]
public: ObjectCancelClickEventArgs();
[JScript]
public function ObjectCancelClickEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor (Object, MouseButtons, Point)

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse button that are pressed and the position of mouse cursor.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
)
[C#]
public ObjectCancelClickEventArgs(
   object value
   MouseButtons button
   Point position
);
[C++]
public: ObjectCancelClickEventArgs(
   Object* value
   MouseButtons button
   Point position
);
[JScript]
public function ObjectCancelClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor (Object, MouseButtons, Point, Boolean)

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCancelClickEventArgs(
   object value
   MouseButtons button
   Point position
   bool cancel
);
[C++]
public: ObjectCancelClickEventArgs(
   Object* value
   MouseButtons button
   Point position
   bool* cancel
);
[JScript]
public function ObjectCancelClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
   cancel : Boolean
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Properties

The properties of the ObjectCancelClickEventArgs class are listed here. For a complete list of ObjectCancelClickEventArgs class members, see the ObjectCancelClickEventArgs Members topic.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


Button Property

Lidor Systems IntegralUI Class Library

ObjectCancelClickEventArgs.Button Property

Gets which mouse button was pressed.

[Visual Basic]
Public ReadOnly Property Button As MouseButtons
[C#]
public MouseButtons Button {get;}
[C++]
public: __property MouseButtons get_Button();
[JScript]
public function get Button() : MouseButtons;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

Lidor Systems IntegralUI Class Library

ObjectCancelClickEventArgs.Object Property

Read-only property that returns the object associated with the ObjectCancelClickEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


Position Property

Lidor Systems IntegralUI Class Library

ObjectCancelClickEventArgs.Position Property

Gets the position of mouse cursor.

[Visual Basic]
Public ReadOnly Property Position As Point
[C#]
public Point Position {get;}
[C++]
public: __property Point get_Position();
[JScript]
public function get Position() : Point;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Class

Provides data for common cancelable events.

For a list of all members of this type, see ObjectCancelEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs

[Visual Basic]
Public Class ObjectCancelEventArgs
   Inherits CancelEventArgs
[C#]
public class ObjectCancelEventArgs : CancelEventArgs
[C++]
public __gc class ObjectCancelEventArgs : public CancelEventArgs
[JScript]
public class ObjectCancelEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Members

ObjectCancelEventArgs overview

Public Constructors

public constructor ObjectCancelEventArgs Constructor Initializes a new instance of the ObjectCancelEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCancelEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCancelEventArgs();
[C++] public: ObjectCancelEventArgs();
[JScript] public function ObjectCancelEventArgs();

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectCancelEventArgs(Object)
[C#] public ObjectCancelEventArgs(object);
[C++] public: ObjectCancelEventArgs(Object*);
[JScript] public function ObjectCancelEventArgs(Object);

Initializes a new instance of the ObjectCancelEventArgs class with the specified object and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCancelEventArgs(Object, Boolean)
[C#] public ObjectCancelEventArgs(object, bool);
[C++] public: ObjectCancelEventArgs(Object*, bool);
[JScript] public function ObjectCancelEventArgs(Object, Boolean);

See Also

ObjectCancelEventArgs Class | ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor ()

Initializes a new instance of the ObjectCancelEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCancelEventArgs();
[C++]
public: ObjectCancelEventArgs();
[JScript]
public function ObjectCancelEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor (Object)

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectCancelEventArgs(
   object value
);
[C++]
public: ObjectCancelEventArgs(
   Object* value
);
[JScript]
public function ObjectCancelEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor (Object, Boolean)

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCancelEventArgs(
   object value
   bool cancel
);
[C++]
public: ObjectCancelEventArgs(
   Object* value
   bool* cancel
);
[JScript]
public function ObjectCancelEventArgs(
   value : Object
   cancel : Boolean
);

Parameters

value

The object associated with this event.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Properties

The properties of the ObjectCancelEventArgs class are listed here. For a complete list of ObjectCancelEventArgs class members, see the ObjectCancelEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelEventArgs.

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


Object Property

Lidor Systems IntegralUI Class Library

ObjectCancelEventArgs.Object Property

Read-only property that returns the object associated with the ObjectCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Class

Provides data for common clickable events.

For a list of all members of this type, see ObjectClickEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.ObjectEventArgs
LidorSystems.IntegralUI.ObjectClickEventArgs

[Visual Basic]
Public Class ObjectClickEventArgs
   Inherits ObjectEventArgsClass
[C#]
public class ObjectClickEventArgs : ObjectEventArgsClass
[C++]
public __gc class ObjectClickEventArgs : public ObjectEventArgsClass
[JScript]
public class ObjectClickEventArgs extends ObjectEventArgsClass

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Members

ObjectClickEventArgs overview

Public Constructors

public constructor ObjectClickEventArgs Constructor Initializes a new instance of the ObjectClickEventArgs class.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Object (inherited from ObjectEventArgs) | Read-only property that returns the object associated with the ObjectClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor

Overload List

Initializes a new instance of the ObjectClickEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectClickEventArgs();
[C++] public: ObjectClickEventArgs();
[JScript] public function ObjectClickEventArgs();

Initializes a new instance of the ObjectClickEventArgs class with the specified object, mouse buttons that are pressed and the position of mouse cursor.

[Visual Basic] Public Sub ObjectClickEventArgs(Object, MouseButtons, Point)
[C#] public ObjectClickEventArgs(object, MouseButtons, Point);
[C++] public: ObjectClickEventArgs(Object*, MouseButtons, Point);
[JScript] public function ObjectClickEventArgs(Object, MouseButtons, Point);

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor ()

Initializes a new instance of the ObjectClickEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectClickEventArgs();
[C++]
public: ObjectClickEventArgs();
[JScript]
public function ObjectClickEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor (Object, MouseButtons, Point)

Initializes a new instance of the ObjectClickEventArgs class with the specified object, mouse button that are pressed and the position of mouse cursor.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
)
[C#]
public ObjectClickEventArgs(
   object value
   MouseButtons button
   Point position
);
[C++]
public: ObjectClickEventArgs(
   Object* value
   MouseButtons button
   Point position
);
[JScript]
public function ObjectClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Properties

The properties of the ObjectClickEventArgs class are listed here. For a complete list of ObjectClickEventArgs class members, see the ObjectClickEventArgs Members topic.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Object (inherited from ObjectEventArgs) | Read-only property that returns the object associated with the ObjectClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


Button Property

Lidor Systems IntegralUI Class Library

ObjectClickEventArgs.Button Property

Gets which mouse button was pressed.

[Visual Basic]
Public ReadOnly Property Button As MouseButtons
[C#]
public MouseButtons Button {get;}
[C++]
public: __property MouseButtons get_Button();
[JScript]
public function get Button() : MouseButtons;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

Lidor Systems IntegralUI Class Library

ObjectEventArgs.Object Property

Read-only property that returns the object associated with the ObjectEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectEventArgs Class | ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


Position Property

Lidor Systems IntegralUI Class Library

ObjectClickEventArgs.Position Property

Gets the position of mouse cursor.

[Visual Basic]
Public ReadOnly Property Position As Point
[C#]
public Point Position {get;}
[C++]
public: __property Point get_Position();
[JScript]
public function get Position() : Point;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Class

Provides data for common editing events which can be canceled.

For a list of all members of this type, see ObjectEditEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs
LidorSystems.IntegralUI.ObjectEditEventArgs

[Visual Basic]
Public Class ObjectEditEventArgs
   Inherits ObjectCancelEventArgs
[C#]
public class ObjectEditEventArgs : ObjectCancelEventArgs
[C++]
public __gc class ObjectEditEventArgs : public ObjectCancelEventArgs
[JScript]
public class ObjectEditEventArgs extends ObjectCancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Members

ObjectEditEventArgs overview

Public Constructors

public constructor ObjectEditEventArgs Constructor Initializes a new instance of the ObjectEditEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object (inherited from CancelEventArgs) | Read-only property that returns the object associated with the ObjectEditEventArgs.
public property Label | Gets the new text to associate with the object.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor

Overload List

Initializes a new instance of the ObjectEditEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectEditEventArgs();
[C++] public: ObjectEditEventArgs();
[JScript] public function ObjectEditEventArgs();

Initializes a new instance of the ObjectEditEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectEditEventArgs(Object)
[C#] public ObjectEditEventArgs(object);
[C++] public: ObjectEditEventArgs(Object*);
[JScript] public function ObjectEditEventArgs(Object);

Initializes a new instance of the ObjectEditEventArgs class with the specified object and the specified text for updating the object label.

[Visual Basic] Public Sub ObjectEditEventArgs(Object, String)
[C#] public ObjectEditEventArgs(object, String);
[C++] public: ObjectEditEventArgs(Object*, String);
[JScript] public function ObjectEditEventArgs(Object, String);

Initializes a new instance of the ObjectEditEventArgs class with the specified object, the specified text for updating the object label and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectEditEventArgs(Object, String, Boolean)
[C#] public ObjectEditEventArgs(object, String, bool);
[C++] public: ObjectEditEventArgs(Object*, String*, bool);
[JScript] public function ObjectEditEventArgs(Object, String, Boolean);

See Also

ObjectEditEventArgs Class | ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor ()

Initializes a new instance of the ObjectEditEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectEditEventArgs();
[C++]
public: ObjectEditEventArgs();
[JScript]
public function ObjectEditEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object)

Initializes a new instance of the ObjectEditEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectEditEventArgs(
   object value
);
[C++]
public: ObjectEditEventArgs(
   Object* value
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object, String)

Initializes a new instance of the ObjectEditEventArgs class with the specified object and the specified text for updating the object label.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal label As String _
)
[C#]
public ObjectEditEventArgs(
   object value
   String label
);
[C++]
public: ObjectEditEventArgs(
   Object* value
   String* label
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
   label : String
);

Parameters

value

The object associated with this event.

label

The new text to associate with the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object, String)

Initializes a new instance of the ObjectEditEventArgs class with the specified object, the specified text for updating the object label and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal label As String _
   ByVal cancel As Boolean _
)
[C#]
public ObjectEditEventArgs(
   object value
   String label
   bool cancel
);
[C++]
public: ObjectEditEventArgs(
   Object* value
   String* label
   bool cancel
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
   label : String
   cancel : Boolean
);

Parameters

value

The object associated with this event.

label

The new text to associate with the object.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Properties

The properties of the ObjectEditEventArgs class are listed here. For a complete list of ObjectEditEventArgs class members, see the ObjectEditEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object (inherited from CancelEventArgs) | Read-only property that returns the object associated with the ObjectEditEventArgs.
public property Label | Gets the new text to associate with the object.

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


Label Property

Lidor Systems IntegralUI Class Library

ObjectEditEventArgs.Label Property

Gets the new text to associate with the object.

[Visual Basic]
Public ReadOnly Property Label As String
[C#]
public String Label {get;}
[C++]
public: __property String* get_Label();
[JScript]
public function get Label() : String;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Class

Provides data for common events.

For a list of all members of this type, see ObjectEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.ObjectEventArgs

[Visual Basic]
Public Class ObjectEventArgs
   Inherits EventArgs
[C#]
public class ObjectEventArgs : EventArgs
[C++]
public __gc class ObjectEventArgs : public EventArgs
[JScript]
public class ObjectEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor

Overload List

Initializes a new instance of the ObjectEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectEventArgs();
[C++] public: ObjectEventArgs();
[JScript] public function ObjectEventArgs();

Initializes a new instance of the ObjectEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectEventArgs(Object)
[C#] public ObjectEventArgs(object);
[C++] public: ObjectEventArgs(Object*);
[JScript] public function ObjectEventArgs(Object);

See Also

ObjectEventArgs Class | ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor ()

Initializes a new instance of the ObjectEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectEventArgs();
[C++]
public: ObjectEventArgs();
[JScript]
public function ObjectEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor (Object)

Initializes a new instance of the ObjectEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectEventArgs(
   object value
);
[C++]
public: ObjectEventArgs(
   Object* value
);
[JScript]
public function ObjectEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEventArgs Properties

The properties of the ObjectEventArgs class are listed here. For a complete list of ObjectEventArgs class members, see the ObjectEventArgs Members topic.

Public Properties

public property Object Read-only property that returns the object associated with the ObjectEventArgs.

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventHandler Delegate

Represents the method that will handle common clickable events which can be canceled.

[Visual Basic]
Public Delegate Sub ObjectCancelClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
public Delegate void ObjectCancelClickEventHandler(
   object sender,
   ObjectCancelClickEventArgs e
);
[C++]
public __gc __delegate void ObjectCancelClickEventHandler(
   Object* sender,
   ObjectCancelClickEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCancelClickEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ObjectCancelEventHandler Delegate

Represents the method that will handle common cancelable events.

[Visual Basic]
Public Delegate Sub ObjectCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
public Delegate void ObjectCancelEventHandler(
   object sender,
   ObjectCancelEventArgs e
);
[C++]
public __gc __delegate void ObjectCancelEventHandler(
   Object* sender,
   ObjectCancelEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCancelEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCancelEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ObjectClickEventHandler Delegate

Represents the method that will handle common clickable events.

[Visual Basic]
Public Delegate Sub ObjectClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectClickEventArgs _
)
[C#]
public Delegate void ObjectClickEventHandler(
   object sender,
   ObjectClickEventArgs e
);
[C++]
public __gc __delegate void ObjectClickEventHandler(
   Object* sender,
   ObjectClickEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectClickEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectClickEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ObjectEditEventHandler Delegate

Represents the method that will handle common editing events which can be canceled.

[Visual Basic]
Public Delegate Sub ObjectEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectEditEventArgs _
)
[C#]
public Delegate void ObjectEditEventHandler(
   object sender,
   ObjectEditEventArgs e
);
[C++]
public __gc __delegate void ObjectEditEventHandler(
   Object* sender,
   ObjectEditEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectEditEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectEditEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ObjectEventHandler Delegate

Represents the method that will handle common events.

[Visual Basic]
Public Delegate Sub ObjectEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectEventArgs _
)
[C#]
public Delegate void ObjectEventHandler(
   object sender,
   ObjectEventArgs e
);
[C++]
public __gc __delegate void ObjectEventHandler(
   Object* sender,
   ObjectEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ActionType Enumeration

Enumerator used to specify the action assigned to some object.

[Visual Basic]
Public Enum ActionType
[C#]
public enum ActionType
[C++]
__value public enum ActionType
[JScript]
public
   enum ActionType

Members

Member name | Description
Recreate | The object will recreate itself before make any updates.
Repaint | The object will repaint it's client area.
Update | The object will update and repaint it's client area.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


CheckMode Enumeration

Enumerator used to determine whether check boxes can accept two or three values.

[Visual Basic]
Public Enum CheckMode
[C#]
public enum CheckMode
[C++]
__value public enum CheckMode
[JScript]
public
   enum CheckMode

Members

Member name | Description
TwoState | Check boxes can be in unchecked or checked state.
ThreeState | Check boxes can be in unchecked, indeterminate or checked state.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


DragDropMode Enumeration

Enumerator used to determine the type of drag-and-drop operation.

[Visual Basic]
Public Enum DragDropMode
[C#]
public enum DragDropMode
[C++]
__value public enum DragDropMode
[JScript]
public
   enum DragDropMode

Members

Member name | Description
Predefined | A predefined drag-and-drop operation.
Custom | You need to create your own drag-and-drop operations.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


FadingEffect Enumeration

Enumerator used to determine the fading effect that is used during hovering over items.

[Visual Basic]
Public Enum FadingEffect
[C#]
public enum FadingEffect
[C++]
__value public enum FadingEffect
[JScript]
public
   enum FadingEffect

Members

Member name | Description
Default | No fading.
Office2007 | Mimics the fading effect of Office 2007.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


FadingSpeed Enumeration

Enumerator used to determine the speed of fading that is used during hovering over objects.

[Visual Basic]
Public Enum FadingSpeed
[C#]
public enum FadingSpeed
[C++]
__value public enum FadingSpeed
[JScript]
public
   enum FadingSpeed

Members

Member name | Description
VerySlow | The speed of fading is very slow.
Slow | The speed of fading is slower then usual.
Normal | The speed of fading is normal.
Fast | The speed of fading is faster then usual.
VeryFast | The speed of fading is instant.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


ObjectState Enumeration

Enumerator used to determine the current state of the object.

[Visual Basic]
Public Enum ObjectState
[C#]
public enum ObjectState
[C++]
__value public enum ObjectState
[JScript]
public
   enum ObjectState

Members

Member name | Description
Disabled | The object is disabled.
Focused | The object has the input focus.
Hovered | The mouse pointer hovers over object space.
Normal | A default state of object.
Selected | The object is selected.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


VerticalAlignment Enumeration

Specifies how an object or text in a control is vertically aligned relative to an element of the control.

[Visual Basic]
Public Enum VerticalAlignment
[C#]
public enum VerticalAlignment
[C++]
__value public enum VerticalAlignment
[JScript]
public
   enum VerticalAlignment

Members

Member name | Description
Top | The object or text is aligned on the top of the control element.
Center | The object or text is aligned in the center of the control element.
Bottom | The object or text is aligned on the bottom of the control element.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


LidorSystems.IntegralUI.Collections

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Collections Namespace

Classes

Class | Description
ObjectCollectionCancelEventArgs | Provides data for a cancelable events for objects of ObjectCollection class.
ObjectCollection | Contains a collection of objects.
ObjectCollectionEventArgs | Provides data for common events for objects of ObjectCollection class.

Delegates

Delegate | Description
ObjectCollectionCancelEventHandler | Represents the method that will handle cancelable events of ObjectCollection class.
ObjectCollectionEventHandler | Represents the method that will handle common events of ObjectCollection class.


ObjectCollectionCancelEventArgs Class

Provides data for cancelable events for objects of ObjectCollection class.

For a list of all members of this type, see ObjectCollectionCancelEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.Collections.ObjectCollectionCancelEventArgs

[Visual Basic]
Public Class ObjectCollectionCancelEventArgs
   Inherits CancelEventArgs
[C#]
public class ObjectCollectionCancelEventArgs : CancelEventArgs
[C++]
public __gc class ObjectCollectionCancelEventArgs : public CancelEventArgs
[JScript]
public class ObjectCollectionCancelEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A cancelable event is raised by a object when it is about to perform an action that can be canceled. A ObjectCollectionCancelEventArgs provides the Cancel property to indicate whether the event should be canceled.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Collections (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Members

ObjectCollectionCancelEventArgs overview

Public Constructors

public constructor ObjectCollectionCancelEventArgs Constructor Initializes a new instance of the ObjectCollectionCancelEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCollectionCancelEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollectionCancelEventArgs();
[C++] public: ObjectCollectionCancelEventArgs();
[JScript] public function ObjectCollectionCancelEventArgs();

Initializes a new instance of the ObjectCollectionCancelEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCollectionCancelEventArgs(Boolean, Object, Integer)
[C#] public ObjectCollectionCancelEventArgs(bool, object, int);
[C++] public: ObjectCollectionCancelEventArgs(bool, Object*, int);
[JScript] public function ObjectCollectionCancelEventArgs(Boolean, Object, int);

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor ()

Initializes a new instance of the ObjectCollectionCancelEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollectionCancelEventArgs();
[C++]
public: ObjectCollectionCancelEventArgs();
[JScript]
public function ObjectCollectionCancelEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor (Object, Integer, Boolean)

Initializes a new instance of the ObjectCollectionCancelEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal index As Integer _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCollectionCancelEventArgs(
   object value
   int index
   bool cancel
);
[C++]
public: ObjectCollectionCancelEventArgs(
   Object* value
   int index
   bool cancel
);
[JScript]
public function ObjectCollectionCancelEventArgs(
   value : Object
   index : int
   cancel : Boolean
);

Parameters

value

The object associated with this event.

index

The indexed location of the object in the ObjectCollection.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Properties

The properties of the ObjectCollectionCancelEventArgs class are listed here. For a complete list of ObjectCollectionCancelEventArgs class members, see the ObjectCollectionCancelEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


Index Property

Lidor Systems IntegralUI Class Library

ObjectCollectionCancelEventArgs.Index Property

Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


Value Property

Lidor Systems IntegralUI Class Library

ObjectCollectionCancelEventArgs.Value Property

Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Class

Contains a collection of objects.

For a list of all members of this type, see ObjectCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection

[Visual Basic]
Public Class ObjectCollection
   Inherits CollectionBase
[C#]
public class ObjectCollection : CollectionBase
[C++]
public __gc class ObjectCollection : public CollectionBase
[JScript]
public class ObjectCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Members

ObjectCollection overview

Public Constructors

public constructor ObjectCollection Constructor Initializes a new instance of the ObjectCollection class.

Public Properties

public property Item | Gets or sets an object at the specified location in the collection.
public property Owner | Gets the object that owns the ObjectCollection.

Public Methods

public method Add | Adds a new object to the end of the ObjectCollection.
public method AddRange | Adds an array of objects to the ObjectCollection.
public method Clear | Removes all objects from the collection.
public method Contains | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified object in the collection.
public method Insert | Inserts an existing object in the ObjectCollection at the specified location.
public method Remove | Removes the specified object from the ObjectCollection.
public method RemoveAt | Removes the object at the specified index of the ObjectCollection.
public method SetChildIndex | Sets the index of the specified object in the collection to the specified index value.
public method Sort | Sorts the elements in the entire ObjectCollection using the specified comparer.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added | Occurs after an object is added.
public event Adding | Occurs before an object is added.
public event Cleared | Occurs after all objects are removed from the collection.
public event Clearing | Occurs before all objects are removed from the collection.
public event Removed | Occurs after an object is removed.
public event Removing | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Occurs after an object is added.
protected method OnAdding | Occurs before an object is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnIndexChanged | Occurs after an object index in collection has changed.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Occurs after an object is removed.
protected method OnRemoving | Occurs before an object is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor

Overload List

Initializes a new instance of the ObjectCollection class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollection();
[C++] public: ObjectCollection();
[JScript] public function ObjectCollection();

Initializes a new instance of the ObjectCollection class and associates it with the given object.

[Visual Basic] Public Sub ObjectCollection(Object)
[C#] public ObjectCollection(object);
[C++] public: ObjectCollection(Object*);
[JScript] public function ObjectCollection(Object);

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor ()

Initializes a new instance of the ObjectCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollection();
[C++]
public: ObjectCollection();
[JScript]
public function ObjectCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor (Object)

Initializes a new instance of the ObjectCollection class and associates it with the given object.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ObjectCollection(
   object owner
);
[C++]
public: ObjectCollection(
   Object* owner
);
[JScript]
public function ObjectCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Properties

The properties of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Properties

public property Item | Gets or sets an object at the specified location in the collection.
public property Owner | Gets the object that owns the ObjectCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Item Property

Lidor Systems IntegralUI Class Library

ObjectCollection.Item Property

Gets or sets a object at the specified location in the collection.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {get; set;}
[C++]
public: __property Object* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Object*
);

Parameters

index
The 0-based index of the object to get or set.

Property Value

The object at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Owner Property

Lidor Systems IntegralUI Class Library

ObjectCollection.Owner Property

Gets the object that owns the ObjectCollection.

[Visual Basic]
Public Property Owner As object
[C#]
public object Owner { get; }
[C++]
public: __property Object* get_Owner();
[JScript]
public function get Owner() : object

Property Value

Represents the object that owns the ObjectCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Methods

The methods of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Methods

public method Add | Adds a new object to the end of the ObjectCollection.
public method AddRange | Adds an array of objects to the ObjectCollection.
public method Clear | Removes all objects from the collection.
public method Contains | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified object in the collection.
public method Insert | Inserts an existing object in the ObjectCollection at the specified location.
public method Remove | Removes the specified object from the ObjectCollection.
public method RemoveAt | Removes the object at the specified index of the ObjectCollection.
public method SetChildIndex | Sets the index of the specified object in the collection to the specified index value.
public method Sort | Sorts the elements in the entire ObjectCollection using the specified comparer.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Occurs after an object is added.
protected method OnAdding | Occurs before an object is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnIndexChanged | Occurs after an object index in collection has changed.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Occurs after an object is removed.
protected method OnRemoving | Occurs before an object is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Add Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Add Method

Adds a new object to the end of the ObjectCollection.

[Visual Basic]
Public Overridable Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int Add(
   object value
);
[C++]
public: virtual int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
The object to add to the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Return Value

The zero-based index value of the Object added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


AddRange Method

Lidor Systems IntegralUI Class Library

ObjectCollection.AddRange Method

Adds an array of objects to the ObjectCollection.

[Visual Basic]
Public Overridable Sub AddRange( _
   ByVal values() As Object _
)
[C#]
public virtual void AddRange(
   object[] values
);
[C++]
public: virtual void AddRange(
   Object* values[]
);
[JScript]
public function AddRange(
   values : Object[]
);

Parameters

values
An array of type object that contains the values to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of values equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Clear Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Clear Method

Removes all objects from the collection.

[Visual Basic]
Public Shadows Sub Clear()
[C#]
public new void Clear();
[C++]
public: void Clear();
[JScript]
public hide function Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Contains Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Contains Method

Determines whether the specified object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
The object to locate in the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Return Value

true if the specified object is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


IndexOf Method

Lidor Systems IntegralUI Class Library

ObjectCollection.IndexOf Method

Returns the index of the specified object in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
The object to locate in the collection.

Return Value

The zero-based index of the item found in the ObjectCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Insert Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Insert Method

Inserts an existing object in the ObjectCollection at the specified location.

[Visual Basic]
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void Insert(
   int index,
   object value
);
[C++]
public: virtual void Insert(
   int index,
   Object* value
);
[JScript]
public function Insert(
   index : int,
   value : Object
);

Parameters

index
The indexed location within the collection to insert the object.
value
The Object to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnAdded Method

Lidor Systems IntegralUI Class Library

ObjectCollection.OnAdded Method

Occurs after an object is added.

[Visual Basic]
Protected Overridable Sub OnAdded( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnAdded(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnAdded(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnAdded(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnAdding Method

Lidor Systems IntegralUI Class Library

ObjectCollection.OnAdding Method

Occurs before an object is added.

[Visual Basic]
Protected Overridable Sub OnAdding( _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
protected virtual void OnAdding(
   ObjectCollectionCancelEventArgs e
);
[C++]
protected: virtual void OnAdding(
   ObjectCollectionCancelEventArgs* e
);
[JScript]
protected function OnAdding(
   e : ObjectCollectionCancelEventArgs
);

Parameters

e
An ObjectCollectionCancelEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnIndexChanged Method

Lidor Systems IntegralUI Class Library

ObjectCollection.OnIndexChanged Method

Occurs after an object index in collection has changed.

[Visual Basic]
Protected Overridable Sub OnIndexChanged( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnIndexChanged(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnIndexChanged(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnIndexChanged(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnRemoved Method

Lidor Systems IntegralUI Class Library

ObjectCollection.OnRemoved Method

Occurs after an object is removed.

[Visual Basic]
Protected Overridable Sub OnRemoved( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnRemoved(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnRemoved(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnRemoved(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnRemoving Method

Lidor Systems IntegralUI Class Library

ObjectCollection.OnRemoving Method

Occurs before an object is removed.

[Visual Basic]
Protected Overridable Sub OnRemoving( _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
protected virtual void OnRemoving(
   ObjectCollectionCancelEventArgs e
);
[C++]
protected: virtual void OnRemoving(
   ObjectCollectionCancelEventArgs* e
);
[JScript]
protected function OnRemoving(
   e : ObjectCollectionCancelEventArgs
);

Parameters

e
An ObjectCollectionCancelEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


RemoveAt Method

Lidor Systems IntegralUI Class Library

ObjectCollection.RemoveAt Method

Removes the object at the specified index of the ObjectCollection.

[Visual Basic]
Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public new void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public hide function RemoveAt(
   index : int
);

Parameters

index
The 0-based index of the object to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Remove Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Remove Method

Removes a object from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
The object to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The value parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


SetChildIndex Method

Lidor Systems IntegralUI Class Library

ObjectCollection.SetChildIndex Method

Sets the index of the specified object in the collection to the specified index value.

[Visual Basic]
Public Sub SetChildIndex( _
   ByVal value As Object, _
   ByVal index As Integer _
)
[C#]
public void SetChildIndex(
   object value,
   int index
);
[C++]
public: void SetChildIndex(
   Object* value,
   int index
);
[JScript]
public function SetChildIndex(
   value : Object,
   index : int
);

Parameters

value
The object to search for.
index
The new index value of the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Sort Method

Lidor Systems IntegralUI Class Library

ObjectCollection.Sort Method

Sorts the elements in the entire ObjectCollection using the specified comparer.

[Visual Basic]
Public Sub Sort( _ ByVal
   comparer  As IComparer _
)
[C#]
 public void Sort(
   IComparer comparer
);
[C++]
public: void Sort(
   IComparer* comparer
);
[JScript]
 public function Sort(
   comparer : IComparer
);

Parameters

comparer
The IComparer implementation to use when comparing elements.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Events

The events of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Events

public event Added | Occurs after an object is added.
public event Adding | Occurs before an object is added.
public event Cleared | Occurs after all objects are removed from the collection.
public event Clearing | Occurs before all objects are removed from the collection.
public event Removed | Occurs after an object is removed.
public event Removing | Occurs before an object is removing.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Added Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Added Event

Occurs after an object is added.

[Visual Basic]
Public Event Added As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Added;
[C++]
public: __event ObjectCollectionEventHandler* Added;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Adding Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Adding Event

Occurs before an object is added.

[Visual Basic]
Public Event Adding As ObjectCollectionCancelEventHandler
[C#]
public event ObjectCollectionCancelEventHandler Adding;
[C++]
public: __event ObjectCollectionCancelEventHandler* Adding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionCancelEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Cleared Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Cleared Event

Occurs after all objects are removed from the collection.

[Visual Basic]
Public Event Cleared As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Cleared;
[C++]
public: __event ObjectCollectionEventHandler* Cleared;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Clearing Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Clearing Event

Occurs before all objects are removed from the collection.

[Visual Basic]
Public Event Clearing As EventHandler
[C#]
public event EventHandler Clearing;
[C++]
public: __event EventHandler* Clearing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


IndexChanged Event

Lidor Systems IntegralUI Class Library

ObjectCollection.IndexChanged Event

Occurs when the index of some object in collection has changed.

[Visual Basic]
Public Event IndexChanged As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler IndexChanged;
[C++]
public: __event ObjectCollectionEventHandler* IndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Removed Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Removed Event

Occurs after an object is removed.

[Visual Basic]
Public Event Removed As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Removed;
[C++]
public: __event ObjectCollectionEventHandler* Removed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Removing Event

Lidor Systems IntegralUI Class Library

ObjectCollection.Removing Event

Occurs before an object is removed.

[Visual Basic]
Public Event Removing As ObjectCollectionCancelEventHandler
[C#]
public event ObjectCollectionCancelEventHandler Removing;
[C++]
public: __event ObjectCollectionCancelEventHandler* Removing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionCancelEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Class

Provides data for a common events of ObjectCollection class.

For a list of all members of this type, see ObjectCollectionEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.Collections.ObjectCollectionEventArgs

[Visual Basic]
Public Class ObjectCollectionEventArgs
   Inherits EventArgs
[C#]
public class ObjectCollectionEventArgs : EventArgs
[C++]
public __gc class ObjectCollectionEventArgs : public EventArgs
[JScript]
public class ObjectCollectionEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Members

ObjectCollectionEventArgs overview

Public Constructors

public constructor ObjectCollectionEventArgs Constructor Initializes a new instance of the ObjectCollectionEventArgs class.

Public Properties

public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCollectionEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollectionEventArgs();
[C++] public: ObjectCollectionEventArgs();
[JScript] public function ObjectCollectionEventArgs();

Initializes a new instance of the ObjectCollectionEventArgs class with the specified object and the object index.

[Visual Basic] Public Sub ObjectCollectionEventArgs(Object, Integer)
[C#] public ObjectCollectionEventArgs(object, int);
[C++] public: ObjectCollectionEventArgs(Object*, int);
[JScript] public function ObjectCollectionEventArgs(Object, int);

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor ()

Initializes a new instance of the ObjectCollectionEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollectionEventArgs();
[C++]
public: ObjectCollectionEventArgs();
[JScript]
public function ObjectCollectionEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor (Object, Integer)

Initializes a new instance of the ObjectCollectionEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal index As Integer _
)
[C#]
public ObjectCollectionEventArgs(
   object value
   int index
);
[C++]
public: ObjectCollectionEventArgs(
   Object* value
   int index
);
[JScript]
public function ObjectCollectionEventArgs(
   value : Object
   index : int
);

Parameters

value

The object associated with this event.

index

The indexed location of the object in the ObjectCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Properties

The properties of the ObjectCollectionEventArgs class are listed here. For a complete list of ObjectCollectionEventArgs class members, see the ObjectCollectionEventArgs Members topic.

Public Properties

public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionEventArgs.

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


Index Property

Lidor Systems IntegralUI Class Library

ObjectCollectionEventArgs.Index Property

Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


Value Property

Lidor Systems IntegralUI Class Library

ObjectCollectionEventArgs.Value Property

Read-only property that returns the object associated with the ObjectCollectionEventArgs.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventHandler Delegate

Represents the method that will handle cancelable events of ObjectCollection class.

[Visual Basic]
Public Delegate Sub ObjectCollectionCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
public Delegate void ObjectCollectionCancelEventHandler(
   object sender,
   ObjectCollectionCancelEventArgs e
);
[C++]
public __gc __delegate void ObjectCollectionCancelEventHandler(
   Object* sender,
   ObjectCollectionCancelEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCollectionCancelEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCollectionCancelEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventHandler Delegate

Represents the method that will handle common events of ObjectCollection class.

[Visual Basic]
Public Delegate Sub ObjectCollectionEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
public Delegate void ObjectCollectionEventHandler(
   object sender,
   ObjectCollectionEventArgs e
);
[C++]
public __gc __delegate void ObjectCollectionEventHandler(
   Object* sender,
   ObjectCollectionEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCollectionEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCollectionEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Collections Namespace


LidorSystems.IntegralUI.Containers

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Containers Namespace

Classes

Class | Description
ContainerBase | Provides a common implementation of members for container controls.
TabControl | Represents a control that contains multiple scrollable panels that share the same space on the screen.
TabPage | Represents a panel used in TabControl.

Enumerations

Enumeration | Description
SplitContainerMode | Enumerator used to specify the type of splitter in SplitContainer control.
TabContentRelation | Enumerator used to specify how text and image are aligned in tab content space.
TabContentStyle | Enumerator used to specify whether text and/or image are displayed.
TabCornerShape | Enumerator used to specify the appearance of corners of tab border.
TabDockAlignment | Enumerator used to determine how page tab is aligned in parent control.
TabMode | Enumerator used to specify how tabs are sized.
TabNavigationMode | Enumerator used to specify how tabs are navigated.
TabShape | Enumerator used to specify the shape of tab.
TabStripPlacement | Enumerator used to specify the side on which tabs are arranged.


ContainerBase Class

Provides a common implementation of members for container controls.

For a list of all members of this type, see ContainerBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.ControlBase
LidorSystems.IntegralUI.Containers.ContainerBase
LidorSystems.IntegralUI.Containers.SplitContainer
LidorSystems.IntegralUI.Containers.TabControl

[Visual Basic]
MustInherit Public Class ContainerBase
   Inherits LidorSystems.IntegralUI.ControlBase
[C#]
public abstract class ContainerBase : LidorSystems.IntegralUI.ControlBase
[C++]
public __gc __abstract class ContainerBase : public LidorSystems.IntegralUI.ControlBase
[JScript]
public abstract class ContainerBase extends LidorSystems.IntegralUI.ControlBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

ContainerBase Members | LidorSystems.IntegralUI.Containers Namespace


ContainerBase Members

ContainerBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ControlBase) | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from ControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode (inherited from ControlBase) | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder (inherited from ControlBase) | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect (inherited from ControlBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ControlBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from ControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ShowDropMarker (inherited from ControlBase) | Determines whether the drop marker is shown during drag-drop operation.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from ControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from ControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ControlBase) | Resumes the painting of the control.
public method ResumeUpdate (inherited from ControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ControlBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate (inherited from ControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout (inherited from ControlBase) | Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked (inherited from ControlBase) | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking (inherited from ControlBase) | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CalcLayout | Calculates the container layout when XML encoding is in use.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose (inherited from ControlBase) | Overloaded. Overridden. See Control.Dispose.
protected method DrawButton | Draws the contained command buttons.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method FormatXML | Process the XML tags used to create formatted content.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetCmdButtonImage | Retrieves image for specified command button.
protected method GetResource | Gets specified resource which is embedded in the container assembly.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateButtonBarSize | Updates the size of bar with command buttons.
protected method UpdateCommandButtonSize | Updates the size of specified command button.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ContainerBase Class | LidorSystems.IntegralUI Namespace


ContainerBase Constructor ()

Initializes a new instance of the ContainerBase class.

[Visual Basic]
Public Sub New()
[C#]
public ContainerBase();
[C++]
public: ContainerBase();
[JScript]
public function ContainerBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ContainerBase Class | LidorSystems.IntegralUI.Containers Namespace


ContainerBase Methods

The methods of the ContainerBase class are listed here. For a complete list of ContainerBase class members, see the ContainerBase Members topic.

Public Methods

public method Clone | Creates an exact copy of the current ContainerBase.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ContainerBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CalcLayout | Calculates the container layout when XML encoding is in use.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose (inherited from ControlBase) | Overloaded. Overridden. See Control.Dispose.
protected method DrawButton | Draws the contained command buttons.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method FormatXML | Process the XML tags used to create formatted content.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetCmdButtonImage | Retrieves image for specified command button.
protected method GetResource | Gets specified resource which is embedded in the container assembly.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateButtonBarSize | Updates the size of bar with command buttons.
protected method UpdateContainerBaseSize | Updates the size of specified command button.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ContainerBase Class | LidorSystems.IntegralUI.Containers Namespace


TabControl Class

Represents a control that contains multiple scrollable panels that share the same space on the screen.

For a list of all members of this type, see TabControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.ControlBase
LidorSystems.IntegralUI.Containers.ContainerBase
LidorSystems.IntegralUI.Containers.TabControl

[Visual Basic]
 Public Class TabControl
   Inherits LidorSystems.IntegralUI.Containers.ContainerBase
[C#]
public class TabControl : LidorSystems.IntegralUI.Containers.ContainerBase
[C++]
 public __gc class TabControl : public LidorSystems.IntegralUI.Containers.ContainerBase
[JScript]
public class TabControl extends LidorSystems.IntegralUI.Containers.ContainerBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabControl Members

TabControl overview

Public Constructors

public constructor TabControl Constructor Initializes a new instance of the TabControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ControlBase) | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from ControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonImageList | Defines the image list for contained command buttons in page tab.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Determines how the page will be closed.
public property ColorStyle (inherited from ControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledPageStyle | Gets or sets the drawing style of the disabled page.
public property DisabledTabButtonStyle | Gets or sets the drawing style of tab page command buttons in disabled state.
public property DisabledTabStripButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisabledToolItemStyle | Gets or sets the drawing style of toolbar, when items are in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode (inherited from ControlBase) | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder (inherited from ControlBase) | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect (inherited from ControlBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ControlBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from ControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverPageStyle | Gets or sets the drawing style of the hovered page.
public property HoverTabButtonStyle | Gets or sets the drawing style of tab page command buttons in hover state.
public property HoverTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in hovered state.
public property HoverToolItemStyle | Gets or sets the drawing style of toolbar, when items are in hover state.
public property ImageIndex | Gets or sets the image list index value of the default image that is displayed by the page.
public property Image | Defines the image list for contained pages in the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MaxTextSize | If its not empty, specifies the maximum size which tab text can have. Usable only when TabMode is set to AutoSized.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalPageStyle | Gets or sets the default drawing style of the page.
public property NormalTabButtonStyle | Gets or sets the drawing style of tab page command buttons in normal state.
public property NormalTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in normal state.
public property NormalToolItemStyle | Gets or sets the drawing style of toolbar, when items are in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property PageFormatStyle | Gets or sets the format style of the page.
public property Pages | Gets the collection of pages that are assigned to the TabControl.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ScrollPos | Gets or sets the current scrolling position.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tab page is selected.
public property SelectedPage | Gets or sets the currently selected page.
public property SelectedPageStyle | Gets or sets the drawing style of selected page.
public property SelectedTabButtonStyle | Gets or sets the drawing style of tab page command buttons in normal state.
public property SelectedTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in selected state.
public property SelectedToolItemStyle | Gets or sets the drawing style of toolbar, when items are in checked/selected state.
public property ShowCloseButton | Determines whether the close button is being shown in tabstrip.
public property ShowDropMarker (inherited from ControlBase) | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolBar | Gets or sets a value indicating whether toolbar is shown.
public property ShowToolTips | Gets or sets a value indicating whether tab tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabButtonFormatStyle | Gets or sets the formatting style of tab page command buttons.
public property TabButtons | Gets the collection of command buttons placed in every page tab.
public property TabContentOrientation | Specifies how the content of tabs is arranged.
public property TabCornerShape | Specifies the appearance of corners of tab border.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Specifies how tabs are sized.
public property TabNavigationMode | Specifies how tabs are navigated.
public property TabShape | Specifies the shape of page tab.
public property TabSpacing | Gets or sets the spacing between tabs.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStripButtonFormatStyle | Gets or sets the formatting style of tabstrip command buttons.
public property TabStripPlacement | Specifies on which side tabs are placed.Middle value is not supported in this control.
public property TabStripStyle | Gets or sets the drawing style of control tabstrip.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolBar | Gets the collection of tool items placed in the control toolbar.
public property ToolContentOrientation | Specifies how the content of tool items is arranged.
public property ToolImageList | Defines the image list for control toolbar.
public property ToolItemFormatStyle | Gets or sets the formatting style of toolbar items.
public property ToolTipStyle | Gets or sets the spacing between tabs.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from ControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of tab pages that can be fully visible in the tabstrip.
public property VisualStyle (inherited from ControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method EnsureVisible | Ensures that the specified page is visible, scrolling the tabstrip of the control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from ControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command buttondinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetHoverCmdButton | Returns the command button that is currently hovered.
public method GetHoverPage | Returns the page which tab is currently hovered.
public method GetHoverToolItem | Returns the tool item that is currently hovered.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPageAt | Retrieves the page that is at the specified location.
public method GetPageState | Returns the current state of the page.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetToolItemAt | Retrieves the tool item that is located at the specified coordinates.
public method GetToolItemState | Returns the current state of the tool item.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ControlBase) | Resumes the painting of the control.
public method ResumeUpdate (inherited from ControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method StartAnimation | Starts an animation of animated gifs contained in the page tab.
public method StopAnimation | Stops the animation of animated gifs contained in the page tab.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ControlBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate (inherited from ControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout (inherited from ControlBase) | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked (inherited from ControlBase) | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking (inherited from ControlBase) | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event OrientationChanged | Occurs when control changes its orientation.
public event PageAdded | Occurs after page is added.
public event PageAdding | Occurs before page is added.
public event PageClosed | Occurs after page is closed.
public event PageClosing | Occurs before page is closed.
public event PageRemoved | Occurs after page is removed.
public event PageRemoving | Occurs before page is removed.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when scrolling position of tabs has changed.
public event SelectedPageChanged | Occurs after the SelectedPage is changed.
public event SelectedPageChanging | Occurs before the SelectedPage is changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TabButtonAdded | Occurs after a command button is added.
public event TabButtonAdding | Occurs before a command button is added.
public event TabButtonClicked | Occurs after a command button is clicked.
public event TabButtonClicking | Occurs before a command button is clicked.
public event TabButtonRemoved | Occurs after a command button is removed.
public event TabButtonRemoving | Occurs before a command button is removed.
public event TabMouseHover | Occurs when the mouse cursor hovers for some time over the page tab space.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event ToolItemAdded | Occurs after a tool item is added.
public event ToolItemAdding | Occurs before a tool item is added.
public event ToolItemClicked | Occurs after a tool item is clicked.
public event ToolItemClicking | Occurs before a tool item is clicked.
public event ToolItemRemoved | Occurs after a tool item is removed.
public event ToolItemRemoving | Occurs before a tool item is removed.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CalcLayout (inherited from ContainerBase) | Calculates the container layout when XML encoding is in use.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose (inherited from ControlBase) | Overloaded. Overridden. See Control.Dispose.
protected method DrawButton | Draws the contained command buttons.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method FormatXML (inherited from ContainerBase) | Process the XML tags used to create formatted content.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetCmdButtonImage (inherited from ContainerBase) | Retrieves image for specified command button.
protected method GetResource (inherited from ContainerBase) | Gets specified resource which is embedded in the container assembly.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked (inherited from ControlBase) | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking (inherited from ControlBase) | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPageAdded | Raises the PageAdded event.
protected method OnPageAdding | Raises the PageAdding event.
protected method OnPageClosed | Raises the PageClosed event.
protected method OnPageClosing | Raises the PageClosing event.
protected method OnPageRemoved | Raises the PageRemoved event.
protected method OnPageRemoving | Raises the PageRemoving event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectedPageChanged | Raises the SelectedPageChanged event.
protected method OnSelectedPageChanging | Raises the SelectedPageChanging event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTabButtonAdded | Raises the TabButtonAdded event.
protected method OnTabButtonAdding | Raises the TabButtonAdding event.
protected method OnTabButtonClicked | Raises the TabButtonClicked event.
protected method OnTabButtonClicking | Raises the TabButtonClicking event.
protected method OnTabButtonRemoved | Raises the TabButtonRemoved event.
protected method OnTabButtonRemoving | Raises the TabButtonRemoving event.
protected method OnTabMouseHover | Raises the TabMouseHover event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnToolItemAdded | Raises the ToolItemAdded event.
protected method OnToolItemAdding | Raises the ToolItemAdding event.
protected method OnToolItemClicked | Raises the ToolItemClicked event.
protected method OnToolItemClicking | Raises the ToolItemClicking event.
protected method OnToolItemRemoved | Raises the ToolItemRemoved event.
protected method OnToolItemRemoving | Raises the ToolItemRemoving event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateButtonBarSize (inherited from ContainerBase) | Updates the size of bar with command buttons.
protected method UpdateCommandButtonSize (inherited from ContainerBase) | Updates the size of specified command button.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TabControl Class | LidorSystems.IntegralUI Namespace


TabControl Constructor ()

Initializes a new instance of the TabControl class.

[Visual Basic]
Public Sub New()
[C#]
public TabControl();
[C++]
public: TabControl();
[JScript]
public function TabControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabControl Class | LidorSystems.IntegralUI.Containers Namespace


TabControl Properties

The properties of the TabControl class are listed here. For a complete list of TabControl class members, see the TabControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ControlBase) | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from ControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonImageList | Defines the image list for contained command buttons in page tab.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CloseAction | Determines how the page will be closed.
public property ColorStyle (inherited from ControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledPageStyle | Gets or sets the drawing style of the disabled page.
public property DisabledTabButtonStyle | Gets or sets the drawing style of tab page command buttons in disabled state.
public property DisabledTabStripButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisabledToolItemStyle | Gets or sets the drawing style of toolbar, when items are in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode (inherited from ControlBase) | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder (inherited from ControlBase) | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect (inherited from ControlBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ControlBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from ControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverPageStyle | Gets or sets the drawing style of the hovered page.
public property HoverTabButtonStyle | Gets or sets the drawing style of tab page command buttons in hover state.
public property HoverTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in hovered state.
public property HoverToolItemStyle | Gets or sets the drawing style of toolbar, when items are in hover state.
public property ImageIndex | Gets or sets the image list index value of the default image that is displayed by the page.
public property Image | Defines the image list for contained pages in the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MaxTextSize | If its not empty, specifies the maximum size which tab text can have. Usable only when TabMode is set to AutoSized.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalPageStyle | Gets or sets the default drawing style of the page.
public property NormalTabButtonStyle | Gets or sets the drawing style of tab page command buttons in normal state.
public property NormalTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in normal state.
public property NormalToolItemStyle | Gets or sets the drawing style of toolbar, when items are in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property PageFormatStyle | Gets or sets the format style of the page.
public property Pages | Gets the collection of pages that are assigned to the TabControl.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ScrollPos | Gets or sets the current scrolling position.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tab page is selected.
public property SelectedPage | Gets or sets the currently selected page.
public property SelectedPageStyle | Gets or sets the drawing style of selected page.
public property SelectedTabButtonStyle | Gets or sets the drawing style of tab page command buttons in normal state.
public property SelectedTabStripButtonStyle | Gets or sets the drawing style of tab strip command buttons in selected state.
public property SelectedToolItemStyle | Gets or sets the drawing style of toolbar, when items are in checked/selected state.
public property ShowCloseButton | Determines whether the close button is being shown in tabstrip.
public property ShowDropMarker (inherited from ControlBase) | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolBar | Gets or sets a value indicating whether toolbar is shown.
public property ShowToolTips | Gets or sets a value indicating whether tab tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabButtonFormatStyle | Gets or sets the formatting style of tab page command buttons.
public property TabButtons | Gets the collection of command buttons placed in every page tab.
public property TabContentOrientation | Specifies how the content of tabs is arranged.
public property TabCornerShape | Specifies the appearance of corners of tab border.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabMode | Specifies how tabs are sized.
public property TabNavigationMode | Specifies how tabs are navigated.
public property TabShape | Specifies the shape of page tab.
public property TabSpacing | Gets or sets the spacing between tabs.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property TabStripButtonFormatStyle | Gets or sets the formatting style of tabstrip command buttons.
public property TabStripPlacement | Specifies on which side tabs are placed.Middle value is not supported in this control.
public property TabStripStyle | Gets or sets the drawing style of control tabstrip.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolBar | Gets the collection of tool items placed in the control toolbar.
public property ToolContentOrientation | Specifies how the content of tool items is arranged.
public property ToolImageList | Defines the image list for control toolbar.
public property ToolItemFormatStyle | Gets or sets the formatting style of toolbar items.
public property ToolTipStyle | Gets or sets the spacing between tabs.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from ControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of tab pages that can be fully visible in the tabstrip.
public property VisualStyle (inherited from ControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TabControl Class | LidorSystems.IntegralUI.Containers Namespace


ButtonImageList Property

Lidor Systems IntegralUI Class Library

TabControl.ButtonImageList Property

Defines the image list for contained command buttons in page tab.

[Visual Basic]
Public Property ButtonImageList As ImageList
[C#]
public ImageList ButtonImageList {get; set;}
[C++]
public: __property ImageList* get_ButtonImageList();
public: __property void set_ButtonImageList(ImageList*);
[JScript]
public function get ButtonImageList() : ImageList;
public function set ButtonImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


CloseAction Property

Lidor Systems IntegralUI Class Library

TabControl.CloseAction Property

Determines how the page will be closed.

[Visual Basic]
Public Property CloseAction As CloseAction
[C#]
public CloseAction CloseAction {get; set;}
[C++]
public: __property CloseAction get_CloseAction();
public: __property void set_CloseAction(CloseAction);
[JScript]
public function get CloseAction() : CloseAction;
public function set CloseAction(CloseAction);

Property Value

The CloseAction assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


DisabledPageStyle Property

Lidor Systems IntegralUI Class Library

TabControl.DisabledPageStyle Property

Gets or sets the drawing style of the disabled page.

[Visual Basic]
Public Property DisabledPageStyle As TabPageColorStyle
[C#]
public TabPageColorStyle DisabledPageStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_DisabledPageStyle();
public: __property void set_DisabledPageStyle(TabPageColorStyle);
[JScript]
public function get DisabledPageStyle() : TabPageColorStyle;
public function set DisabledPageStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


DisabledTabButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.DisabledTabButtonStyle Property

Gets or sets the drawing style of tab page command buttons in disabled state.

[Visual Basic]
Public Property DisabledTabButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledTabButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledTabButtonStyle();
public: __property void set_DisabledTabButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledTabButtonStyle() : CommandButtonColorStyle;
public function set DisabledTabButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


DisabledTabStripButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.DisabledTabStripButtonStyle Property

Gets or sets the drawing style of tabstrip command buttons in disabled state.

[Visual Basic]
Public Property DisabledTabStripButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledTabStripButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledTabStripButtonStyle();
public: __property void set_DisabledTabStripButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledTabStripButtonStyle() : CommandButtonColorStyle;
public function set DisabledTabStripButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


DisabledToolItemStyle Property

Lidor Systems IntegralUI Class Library

TabControl.DisabledToolItemStyle Property

Gets or sets the drawing style of toolbar, when items are in disabled state.

[Visual Basic]
Public Property DisabledToolItemStyle As ToolItemColorStyle
[C#]
public ToolItemColorStyle DisabledToolItemStyle {get; set;}
[C++]
public: __property ToolItemColorStyle get_DisabledToolItemStyle();
public: __property void set_DisabledToolItemStyle(ToolItemColorStyle);
[JScript]
public function get DisabledToolItemStyle() : ToolItemColorStyle;
public function set DisabledToolItemStyle(ToolItemColorStyle);

Property Value

A ToolItemColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


HoverPageStyle Property

Lidor Systems IntegralUI Class Library

TabControl.HoverPageStyle Property

Gets or sets the drawing style of the hovered page.

[Visual Basic]
Public Property HoverPageStyle As TabPageColorStyle
[C#]
public TabPageColorStyle HoverPageStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_HoverPageStyle();
public: __property void set_HoverPageStyle(TabPageColorStyle);
[JScript]
public function get HoverPageStyle() : TabPageColorStyle;
public function set HoverPageStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


HoverTabButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.HoverTabButtonStyle Property

Gets or sets the drawing style of tab page command buttons in hover state.

[Visual Basic]
Public Property HoverTabButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverTabButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverTabButtonStyle();
public: __property void set_HoverTabButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverTabButtonStyle() : CommandButtonColorStyle;
public function set HoverTabButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


HoverTabStripButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.HoverTabStripButtonStyle Property

Gets or sets the drawing style of tab strip command buttons in hovered state.

[Visual Basic]
Public Property HoverTabStripButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverTabStripButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverTabStripButtonStyle();
public: __property void set_HoverTabStripButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverTabStripButtonStyle() : CommandButtonColorStyle;
public function set HoverTabStripButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


HoverToolItemStyle Property

Lidor Systems IntegralUI Class Library

TabControl.HoverToolItemStyle Property

Gets or sets the drawing style of toolbar, when items are in hover state.

[Visual Basic]
Public Property HoverToolItemStyle As ToolItemColorStyle
[C#]
public ToolItemColorStyle HoverToolItemStyle {get; set;}
[C++]
public: __property ToolItemColorStyle get_HoverToolItemStyle();
public: __property void set_HoverToolItemStyle(ToolItemColorStyle);
[JScript]
public function get HoverToolItemStyle() : ToolItemColorStyle;
public function set HoverToolItemStyle(ToolItemColorStyle);

Property Value

A ToolItemColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

TabControl.ImageIndex Property

Gets or sets the image list index value of the default image that is displayed by the page.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ImageList Property

Lidor Systems IntegralUI Class Library

TabControl.ImageList Property

Defines the image list for contained pages in the control.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


MaxTextSize Property

Lidor Systems IntegralUI Class Library

TabControl.MaxTextSize Property

If its not empty, specifies the maximum size which tab text can have. Usable only when TabMode is set to AutoSized.

[Visual Basic]
Public ReadOnly Property MaxTextSize As Size
[C#]
public Size MaxTextSize {get;}
[C++]
public: __property Size get_MaxTextSize();
[JScript]
public function get MaxTextSize() : Size;

Property Value

The Size of the page tab text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


NormalPageStyle Property

Lidor Systems IntegralUI Class Library

TabControl.NormalPageStyle Property

Gets or sets the default drawing style of the page.

[Visual Basic]
Public Property NormalPageStyle As TabPageColorStyle
[C#]
public TabPageColorStyle NormalPageStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_NormalPageStyle();
public: __property void set_NormalPageStyle(TabPageColorStyle);
[JScript]
public function get NormalPageStyle() : TabPageColorStyle;
public function set NormalPageStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


NormalTabButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.NormalTabButtonStyle Property

Gets or sets the drawing style of tab page command buttons in normal state.

[Visual Basic]
Public Property NormalTabButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalTabButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalTabButtonStyle();
public: __property void set_NormalTabButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalTabButtonStyle() : CommandButtonColorStyle;
public function set NormalTabButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


NormalTabStripButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.NormalTabStripButtonStyle Property

Gets or sets the drawing style of tab strip command buttons in normal state.

[Visual Basic]
Public Property NormalTabStripButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalTabStripButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalTabStripButtonStyle();
public: __property void set_NormalTabStripButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalTabStripButtonStyle() : CommandButtonColorStyle;
public function set NormalTabStripButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


NormalToolItemStyle Property

Lidor Systems IntegralUI Class Library

TabControl.NormalToolItemStyle Property

Gets or sets the drawing style of toolbar, when items are in normal state.

[Visual Basic]
Public Property NormalToolItemStyle As ToolItemColorStyle
[C#]
public ToolItemColorStyle NormalToolItemStyle {get; set;}
[C++]
public: __property ToolItemColorStyle get_NormalToolItemStyle();
public: __property void set_NormalToolItemStyle(ToolItemColorStyle);
[JScript]
public function get NormalToolItemStyle() : ToolItemColorStyle;
public function set NormalToolItemStyle(ToolItemColorStyle);

Property Value

A ToolItemColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageFormatStyle Property

Lidor Systems IntegralUI Class Library

TabControl.PageFormatStyle Property

Gets or sets the format style of the page.

[Visual Basic]
Public Property PageFormatStyle As TabPageFormatStyle
[C#]
public TabPageFormatStyle PageFormatStyle {get; set;}
[C++]
public: __property TabPageFormatStyle get_PageFormatStyle();
public: __property void set_PageFormatStyle(TabPageFormatStyle);
[JScript]
public function get PageFormatStyle() : TabPageFormatStyle;
public function set PageFormatStyle(TabPageFormatStyle);

Property Value

The TabPageFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


Pages Property

Lidor Systems IntegralUI Class Library

TabControl.Pages Property

Gets the collection of pages that are assigned to the TabControl.

[Visual Basic]
Public ReadOnly Property Pages As TabPageCollection
[C#]
public TabPageCollection Pages {get;}
[C++]
public: __property TabPageCollection* get_Pages();
[JScript]
public function get Pages() : TabPageCollection;

Property Value

A TabPageCollectionn that represents the pages assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ScrollPos Property

Lidor Systems IntegralUI Class Library

TabControl.ScrollPos Property

Gets or sets the current scrolling position.

[Visual Basic]
Public ReadOnly Property ScrollPos As Point
[C#]
public Point ScrollPos {get;}
[C++]
public: __property Point get_ScrollPos();
[JScript]
public function get ScrollPos() : Point;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedImageIndex Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when a tab page is selected.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}
[C++]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(int);
[JScript]
public function get SelectedImageIndex() : int;
public function set SelectedImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedPage Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedPage Property

Gets or sets the currently selected page.

[Visual Basic]
Public Property SelectedPage As TabPage
[C#]
public TabPage SelectedPage {get; set;}
[C++]
public: __property TabPage* get_SelectedPage();
public: __property void set_SelectedPage(TabPage*);
[JScript]
public function get SelectedPage() : TabPage;
public function set SelectedPage(TabPage);

Property Value

The TabPage that is currently selected in the TabControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedPageStyle Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedPageStyle Property

Gets or sets the drawing style of selected page.

[Visual Basic]
Public Property SelectedPageStyle As TabPageColorStyle
[C#]
public TabPageColorStyle SelectedPageStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_SelectedPageStyle();
public: __property void set_SelectedPageStyle(TabPageColorStyle);
[JScript]
public function get SelectedPageStyle() : TabPageColorStyle;
public function set SelectedPageStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedTabButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedTabButtonStyle Property

Gets or sets the drawing style of tab page command buttons in normal state.

[Visual Basic]
Public Property SelectedTabButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedTabButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedTabButtonStyle();
public: __property void set_SelectedTabButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedTabButtonStyle() : CommandButtonColorStyle;
public function set SelectedTabButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedTabStripButtonStyle Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedTabStripButtonStyle Property

Gets or sets the drawing style of tab strip command buttons in selected state.

[Visual Basic]
Public Property SelectedTabStripButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedTabStripButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedTabStripButtonStyle();
public: __property void set_SelectedTabStripButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedTabStripButtonStyle() : CommandButtonColorStyle;
public function set SelectedTabStripButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ShowCloseButton Property

Lidor Systems IntegralUI Class Library

TabControl.ShowCloseButton Property

Determines whether the close button is being shown in tabstrip.

[Visual Basic]
Public Overridable Property ShowCloseButton As Boolean
[C#]
public virtual bool ShowCloseButton { get; set; }
[C++]
public: __property virtual bool get_ShowCloseButton();
 public:
__property virtual void set_ShowCloseButton(bool );
[JScript]
public function get ShowCloseButton() : bool
public function set ShowCloseButton(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ShowToolBar Property

Lidor Systems IntegralUI Class Library

TabControl.ShowToolBar Property

Gets or sets a value indicating whether toolbar is shown.

[Visual Basic]
Public Overridable Property ShowToolBar As Boolean
[C#]
public virtual bool ShowToolBar { get; set; }
[C++]
public: __property virtual bool get_ShowToolBar();
 public:
__property virtual void set_ShowToolBar(bool );
[JScript]
public function get ShowToolBar() : bool
public function set ShowToolBar(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ShowToolTips Property

Lidor Systems IntegralUI Class Library

TabControl.ShowToolTips Property

Gets or sets a value indicating whether tab tooltip is shown.

[Visual Basic]
Public Overridable Property ShowToolTips As Boolean
[C#]
public virtual bool ShowToolTips { get; set; }
[C++]
public: __property virtual bool get_ShowToolTips();
 public:
__property virtual void set_ShowToolTips(bool );
[JScript]
public function get ShowToolTips() : bool
public function set ShowToolTips(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonFormatStyle Property

Lidor Systems IntegralUI Class Library

TabControl.TabButtonFormatStyle Property

Gets or sets the formatting style of tab page command buttons.

[Visual Basic]
Public Property TabButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle TabButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_TabButtonFormatStyle();
public: __property void set_TabButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get TabButtonFormatStyle() : CommandButtonFormatStyle;
public function set TabButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtons Property

Lidor Systems IntegralUI Class Library

TabControl.TabButtons Property

Gets the collection of command buttons placed in every page tab.

[Visual Basic]
Public ReadOnly Property TabButtons As CommandButtonCollection
[C#]
public CommandButtonCollection TabButtons {get;}
[C++]
public: __property CommandButtonCollection* get_TabButtons();
[JScript]
public function get TabButtons() : CommandButtonCollection;

Property Value

A CommandButtonCollection that represents the command buttons assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabCornerShape Property

Lidor Systems IntegralUI Class Library

TabControl.TabCornerShape Property

Specifies the appearance of corners of tab border.

[Visual Basic]
Public Property TabCornerShape As TabCornerShape
[C#]
public TabCornerShape TabCornerShape {get; set;}
[C++]
public: __property TabCornerShape get_TabCornerShape();
public: __property void set_TabCornerShape(TabCornerShape);
[JScript]
public function get TabCornerShape() : TabCornerShape;
public function set TabCornerShape(TabCornerShape);

Property Value

The TabCornerShape assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabMode Property

Lidor Systems IntegralUI Class Library

TabControl.TabMode Property

Specifies how tabs are sized.

[Visual Basic]
Public Property TabMode As TabMode
[C#]
public TabMode TabMode {get; set;}
[C++]
public: __property TabMode get_TabMode();
public: __property void set_TabMode(TabMode);
[JScript]
public function get TabMode() : TabMode;
public function set TabMode(TabMode);

Property Value

The TabMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabNavigationMode Property

Lidor Systems IntegralUI Class Library

TabControl.TabNavigationMode Property

Specifies how tabs are navigated.

[Visual Basic]
Public Property TabNavigationMode As TabNavigationMode
[C#]
public TabNavigationMode TabNavigationMode {get; set;}
[C++]
public: __property TabNavigationMode get_TabNavigationMode();
public: __property void set_TabNavigationMode(TabNavigationMode);
[JScript]
public function get TabNavigationMode() : TabNavigationMode;
public function set TabNavigationMode(TabNavigationMode);

Property Value

The TabNavigationMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabShape Property

Lidor Systems IntegralUI Class Library

TabControl.TabShape Property

Specifies the shape of page tab.

[Visual Basic]
Public Property TabShape As TabShape
[C#]
public TabShape TabShape {get; set;}
[C++]
public: __property TabShape get_TabShape();
public: __property void set_TabShape(TabShape);
[JScript]
public function get TabShape() : TabShape;
public function set TabShape(TabShape);

Property Value

The TabShape assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabSpacing Property

Lidor Systems IntegralUI Class Library

TabControl.TabSpacing Property

Gets or sets the spacing between tabs.

[Visual Basic]
Public Property TabSpacing As Integer
[C#]
public int TabSpacing {get; set;}
[C++]
public: __property int get_TabSpacing();
public: __property void set_TabSpacing(int);
[JScript]
public function get TabSpacing() : int;
public function set TabSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabStripButtonFormatStyle Property

Lidor Systems IntegralUI Class Library

TabControl.TabStripButtonFormatStyle Property

Gets or sets the formatting style of tabstrip command buttons.

[Visual Basic]
Public Property TabStripButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle TabStripButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_TabStripButtonFormatStyle();
public: __property void set_TabStripButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get TabStripButtonFormatStyle() : CommandButtonFormatStyle;
public function set TabStripButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabStripPlacement Property

Lidor Systems IntegralUI Class Library

TabControl.TabStripPlacement Property

Specifies on which side tabs are placed. Middle value is not supported in this control.

[Visual Basic]
Public Property TabStripPlacement As TabStripPlacement
[C#]
public TabStripPlacement TabStripPlacement {get; set;}
[C++]
public: __property TabStripPlacement get_TabStripPlacement();
public: __property void set_TabStripPlacement(TabStripPlacement);
[JScript]
public function get TabStripPlacement() : TabStripPlacement;
public function set TabStripPlacement(TabStripPlacement);

Property Value

The TabStripPlacement assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabStripStyle Property

Lidor Systems IntegralUI Class Library

TabControl.TabStripStyle Property

Gets or sets the drawing style of control tabstrip.

[Visual Basic]
Public Property TabStripStyle As TabStripStyle
[C#]
public TabStripStyle TabStripStyle {get; set;}
[C++]
public: __property TabStripStyle get_TabStripStyle();
public: __property void set_TabStripStyle(TabStripStyle);
[JScript]
public function get TabStripStyle() : TabStripStyle;
public function set TabStripStyle(TabStripStyle);

Property Value

A TabStripStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolBar Property

Lidor Systems IntegralUI Class Library

TabControl.ToolBar Property

Gets the collection of tool items placed in the control toolbar.

[Visual Basic]
Public ReadOnly Property ToolBar As ToolItemCollection
[C#]
public ToolItemCollection ToolBar {get;}
[C++]
public: __property ToolItemCollection* get_ToolBar();
[JScript]
public function get ToolBar() : ToolItemCollection;

Property Value

A ToolItemCollection that represents the tool items assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolContentOrientation Property

Lidor Systems IntegralUI Class Library

TabControl.ToolContentOrientation Property

Specifies how the content of toolbar items is arranged.

[Visual Basic]
Public Property ToolContentOrientation As Orientation
[C#]
public Orientation ToolContentOrientation {get; set;}
[C++]
public: __property Orientation get_ToolContentOrientation();
public: __property void set_ToolContentOrientation(Orientation);
[JScript]
public function get ToolContentOrientation() : Orientation;
public function set ToolContentOrientation(Orientation);

Property Value

The Orientation assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolImageList Property

Lidor Systems IntegralUI Class Library

TabControl.ToolImageList Property

Defines the image list for control toolbar.

[Visual Basic]
Public Property ToolImageList As ImageList
[C#]
public ImageList ToolImageList {get; set;}
[C++]
public: __property ImageList* get_ToolImageList();
public: __property void set_ToolImageList(ImageList*);
[JScript]
public function get ToolImageList() : ImageList;
public function set ToolImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemFormatStyle Property

Lidor Systems IntegralUI Class Library

TabControl.ToolItemFormatStyle Property

Gets or sets the formatting style of toolbar items.

[Visual Basic]
Public Property ToolItemFormatStyle As ToolItemFormatStyle
[C#]
public ToolItemFormatStyle ToolItemFormatStyle {get; set;}
[C++]
public: __property ToolItemFormatStyle get_ToolItemFormatStyle();
public: __property void set_ToolItemFormatStyle(ToolItemFormatStyle);
[JScript]
public function get ToolItemFormatStyle() : ToolItemFormatStyle;
public function set ToolItemFormatStyle(ToolItemFormatStyle);

Property Value

The ToolItemFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolTipStyle Property

Lidor Systems IntegralUI Class Library

TabControl.ToolTipStyle Property

Gets or sets the drawing style of the page tooltip.

[Visual Basic]
Public Property ToolTipStyle As ToolTipStyle
[C#]
public ToolTipStyle ToolTipStyle {get; set;}
[C++]
public: __property ToolTipStyle get_ToolTipStyle();
public: __property void set_ToolTipStyle(ToolTipStyle);
[JScript]
public function get ToolTipStyle() : ToolTipStyle;
public function set ToolTipStyle(ToolTipStyle);

Property Value

A ToolTipStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


VisibleCount Property

Lidor Systems IntegralUI Class Library

TabControl.VisibleCount Property

Gets the number of tab pages that can be fully visible in the tabstrip.

[Visual Basic]
Public Property VisibleCount As Integer
[C#]
public int VisibleCount {get; set;}
[C++]
public: __property int get_VisibleCount();
public: __property void set_VisibleCount(int);
[JScript]
public function get VisibleCount() : int;
public function set VisibleCount(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabControl Methods

The methods of the TabControl class are listed here. For a complete list of TabControl class members, see the TabControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method EnsureVisible | Ensures that the specified page is visible, scrolling the tabstrip of the control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from ControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command buttondinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetHoverCmdButton | Returns the command button that is currently hovered.
public method GetHoverPage | Returns the page which tab is currently hovered.
public method GetHoverToolItem | Returns the tool item that is currently hovered.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPageAt | Retrieves the page that is at the specified location.
public method GetPageState | Returns the current state of the page.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetToolItemAt | Retrieves the tool item that is located at the specified coordinates.
public method GetToolItemState | Returns the current state of the tool item.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ControlBase) | Resumes the painting of the control.
public method ResumeUpdate (inherited from ControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method StartAnimation | Starts an animation of animated gifs contained in the page tab.
public method StopAnimation | Stops the animation of animated gifs contained in the page tab.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ControlBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate (inherited from ControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout (inherited from ControlBase) | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CalcLayout (inherited from ContainerBase) | Calculates the container layout when XML encoding is in use.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose (inherited from ControlBase) | Overloaded. Overridden. See Control.Dispose.
protected method DrawButton | Draws the contained command buttons.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method FormatXML (inherited from ContainerBase) | Process the XML tags used to create formatted content.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetCmdButtonImage (inherited from ContainerBase) | Retrieves image for specified command button.
protected method GetResource (inherited from ContainerBase) | Gets specified resource which is embedded in the container assembly.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked (inherited from ControlBase) | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking (inherited from ControlBase) | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPageAdded | Raises the PageAdded event.
protected method OnPageAdding | Raises the PageAdding event.
protected method OnPageClosed | Raises the PageClosed event.
protected method OnPageClosing | Raises the PageClosing event.
protected method OnPageRemoved | Raises the PageRemoved event.
protected method OnPageRemoving | Raises the PageRemoving event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectedPageChanged | Raises the SelectedPageChanged event.
protected method OnSelectedPageChanging | Raises the SelectedPageChanging event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTabButtonAdded | Raises the TabButtonAdded event.
protected method OnTabButtonAdding | Raises the TabButtonAdding event.
protected method OnTabButtonClicked | Raises the TabButtonClicked event.
protected method OnTabButtonClicking | Raises the TabButtonClicking event.
protected method OnTabButtonRemoved | Raises the TabButtonRemoved event.
protected method OnTabButtonRemoving | Raises the TabButtonRemoving event.
protected method OnTabMouseHover | Raises the TabMouseHover event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnToolItemAdded | Raises the ToolItemAdded event.
protected method OnToolItemAdding | Raises the ToolItemAdding event.
protected method OnToolItemClicked | Raises the ToolItemClicked event.
protected method OnToolItemClicking | Raises the ToolItemClicking event.
protected method OnToolItemRemoved | Raises the ToolItemRemoved event.
protected method OnToolItemRemoving | Raises the ToolItemRemoving event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateButtonBarSize (inherited from ContainerBase) | Updates the size of bar with command buttons.
protected method UpdateCommandButtonSize (inherited from ContainerBase) | Updates the size of specified command button.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TabControl Class | LidorSystems.IntegralUI.Containers Namespace


EnsureVisible Method

Lidor Systems IntegralUI Class Library

TabControl.EnsureVisible Method

Ensures that the specified page is visible, scrolling the tabstrip of the control as necessary.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal page As TabPage _
)
[C#]
 public void EnsureVisible(
   TabPage page
);
[C++]
public: void EnsureVisible(
   TabPage page
);
[JScript]
 public function EnsureVisible(
   page : TabPage
);

Parameters

page
The TabPage that needs to be visible.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetCmdButtonAt (Point) Method

Lidor Systems IntegralUI Class Library

TabControl.GetCmdButtonAt (Point) Method

Retrieves the command button located at the specified coordinates.

[Visual Basic]
Overloads Public Function GetCmdButtonAt( _
   ByVal pos As Point _
) As CommandButton
[C#]
public CommandButton GetCmdButtonAt(
   Point pos
);
[C++]
public: CommandButton* GetCmdButtonAt(
   Point pos
);
[JScript]
public function GetCmdButtonAt(
   pos : Point
) : CommandButton;

Parameters

pos
The Point to evaluate and retrieve the command button from.

Return Value

The CommandButton at the specified point, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetCmdButtonState (CommandButton) Method

Lidor Systems IntegralUI Class Library

TabControl.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetHoverCmdButton Method

Lidor Systems IntegralUI Class Library

TabControl.GetHoverCmdButton Method

Returns the command button that is currently hovered.

[Visual Basic]
Overloads Public Function GetHoverCmdButton() As CommandButton
[C#]
public CommandButton GetHoverCmdButton();
[C++]
public: CommandButton* GetHoverCmdButton();
[JScript]
public function GetHoverCmdButton() : CommandButton;

Return Value

The CommandButton that is currently hovered.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetHoverPage Method

Lidor Systems IntegralUI Class Library

TabControl.GetHoverPage Method

Returns the page which tab is currently hovered.

[Visual Basic]
Overloads Public Function GetHoverPage() As TabPage
[C#]
public TabPage GetHoverPage();
[C++]
public: TabPage* GetHoverPage();
[JScript]
public function GetHoverPage() : TabPage;

Return Value

The TabPage that is currently hovered.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetHoverToolItem Method

Lidor Systems IntegralUI Class Library

TabControl.GetHoverToolItem Method

Returns the tool item that is currently hovered.

[Visual Basic]
Overloads Public Function GetHoverToolItem() As ToolItemBase
[C#]
public ToolItemBase GetHoverToolItem();
[C++]
public: ToolItemBase* GetHoverToolItem();
[JScript]
public function GetHoverToolItem() : ToolItemBase;

Return Value

The ToolItemBase that is currently hovered.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetPageAt Method

Lidor Systems IntegralUI Class Library

TabControl.GetPageAt Method

Retrieves the page that is at the specified location.

Overload List

Retrieves the page that is at the specified point.

[Visual Basic] Overloads Public Function GetPageAt(Point) As TreeNode
[C#] public TreeNode GetPageAt(Point);
[C++] public: TreeNode* GetPageAt(Point);
[JScript] public function GetPageAt(Point) : TreeNode;

Retrieves the page at the point with the specified coordinates.

[Visual Basic] Overloads Public Function GetPageAt(Integer, Integer) As TreeNode
[C#] public TreeNode GetPageAt(int, int);
[C++] public: TreeNode* GetPageAt(int, int);
[JScript] public function GetPageAt(int, int) : TreeNode;

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetPageAt (Point) Method

Lidor Systems IntegralUI Class Library

TabControl.GetPageAt (Point) Method

Retrieves the page which tab is located at the specified coordinates.

[Visual Basic]
Overloads Public Function GetPageAt( _
   ByVal pos As Point _
) As TabPage
[C#]
public TabPage GetPageAt(
   Point pos
);
[C++]
public: TabPage* GetPageAt(
   Point pos
);
[JScript]
public function GetPageAt(
   pos : Point
) : TabPage;

Parameters

pos
The Point to evaluate and retrieve the page from.

Return Value

The TabPage at the specified point, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetPageAt (Int32, Int32) Method

Lidor Systems IntegralUI Class Library

TabControl.GetPageAt (Int32, Int32) Method

Retrieves the page at the point with the specified coordinates.

[Visual Basic]
Overloads Public Function GetPageAt( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TabPage
[C#]
public TabPage GetPageAt(
   int x,
   int y
);
[C++]
public: TabPage* GetPageAt(
   int x,
   int y
);
[JScript]
public function GetPageAt(
   x : int,
   y : int
) : TabPage;

Parameters

x
The X position to evaluate and retrieve the page from.
y
The Y position to evaluate and retrieve the page from.

Return Value

The TabPage at the specified location, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetPageState (TabPage) Method

Lidor Systems IntegralUI Class Library

TabControl.GetPageState (TabPage) Method

Returns the current state of the page.

[Visual Basic]
Overloads Public Function GetPageState( _
   ByVal page As TabPage _
) As ObjectState
[C#]
public ObjectState GetPageState(
   TabPage page
);
[C++]
public: ObjectState* GetPageState(
   TabPage page
);
[JScript]
public function GetPageState(
   page : TabPage
) : ObjectState;

Parameters

page
The TabPage to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetToolItemAt (Point) Method

Lidor Systems IntegralUI Class Library

TabControl.GetToolItemAt (Point) Method

Retrieves the tool item that is located at the specified coordinates.

[Visual Basic]
Overloads Public Function GetToolItemAt( _
   ByVal pos As Point _
) As ToolItemBase
[C#]
public ToolItemBase GetToolItemAt(
   Point pos
);
[C++]
public: ToolItemBase* GetToolItemAt(
   Point pos
);
[JScript]
public function GetToolItemAt(
   pos : Point
) : ToolItemBase;

Parameters

pos
The Point to evaluate and retrieve the tool item from.

Return Value

The ToolItemBase at the specified point, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


GetToolItemState (ToolItemBase) Method

Lidor Systems IntegralUI Class Library

TabControl.GetToolItemState (ToolItemBase) Method

Returns the current state of the tool item.

[Visual Basic]
Overloads Public Function GetToolItemState( _
   ByVal toolItem As ToolItemBase _
) As ObjectState
[C#]
public ObjectState GetToolItemState(
   ToolItemBase toolItem
);
[C++]
public: ObjectState* GetToolItemState(
   ToolItemBase toolItem
);
[JScript]
public function GetToolItemState(
   toolItem : ToolItemBase
) : ObjectState;

Parameters

toolItem
The ToolItemBase to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified tool item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnPageAdded Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageAdded Method

Raises the PageAdded event.

[Visual Basic]
Protected Overridable Sub OnPageAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnPageAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnPageAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnPageAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnPageAdding Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageAdding Method

Raises the PageAdding event.

[Visual Basic]
Protected Overridable Sub OnPageAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnPageAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnPageAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnPageAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnScrollPosChanged Method

Lidor Systems IntegralUI Class Library

TabControl.OnScrollPosChanged Method

Raises the ScrollPosChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollPosChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollPosChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollPosChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollPosChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnSelectedPageChanged Method

Lidor Systems IntegralUI Class Library

TabControl.OnSelectedPageChanged Method

Raises the SelectedPageChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedPageChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedPageChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedPageChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedPageChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnSelectedPageChanging Method

Lidor Systems IntegralUI Class Library

TabControl.OnSelectedPageChanging Method

Raises the SelectedPageChanging event.

[Visual Basic]
Protected Overridable Sub OnSelectedPageChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnSelectedPageChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnSelectedPageChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnSelectedPageChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonAdded Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonAdded Method

Raises the TabButtonAdded event.

[Visual Basic]
Protected Overridable Sub OnTabButtonAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnTabButtonAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnTabButtonAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnTabButtonAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonAdding Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonAdding Method

Raises the TabButtonAdding event.

[Visual Basic]
Protected Overridable Sub OnTabButtonAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnTabButtonAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnTabButtonAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnTabButtonAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonClicked Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonClicked Method

Raises the TabButtonClicked event.

[Visual Basic]
Protected Overridable Sub OnTabButtonClicked( _
   ByVal e As ObjectClickEventArgs _
)
[C#]
protected virtual void OnTabButtonClicked(
   ObjectClickEventArgs e
);
[C++]
protected: virtual void OnTabButtonClicked(
   ObjectClickEventArgs* e
);
[JScript]
protected function OnTabButtonClicked(
   e : ObjectClickEventArgs
);

Parameters

e
A ObjectClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonClicking Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonClicking Method

Raises the TabButtonClicking event.

[Visual Basic]
Protected Overridable Sub OnTabButtonClicking( _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
protected virtual void OnTabButtonClicking(
   ObjectCancelClickEventArgs e
);
[C++]
protected: virtual void OnTabButtonClicking(
   ObjectCancelClickEventArgs* e
);
[JScript]
protected function OnTabButtonClicking(
   e : ObjectCancelClickEventArgs
);

Parameters

e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonRemoved Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonRemoved Method

Raises the TabButtonRemoved event.

[Visual Basic]
Protected Overridable Sub OnTabButtonRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnTabButtonRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnTabButtonRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnTabButtonRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabButtonRemoving Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabButtonRemoving Method

Raises the TabButtonRemoving event.

[Visual Basic]
Protected Overridable Sub OnTabButtonRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnTabButtonRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnTabButtonRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnTabButtonRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemAdded Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemAdded Method

Raises the ToolItemAdded event.

[Visual Basic]
Protected Overridable Sub OnToolItemAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnToolItemAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnToolItemAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnToolItemAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemAdding Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemAdding Method

Raises the ToolItemAdding event.

[Visual Basic]
Protected Overridable Sub OnToolItemAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnToolItemAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnToolItemAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnToolItemAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemClicked Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemClicked Method

Raises the ToolItemClicked event.

[Visual Basic]
Protected Overridable Sub OnToolItemClicked( _
   ByVal e As ObjectClickEventArgs _
)
[C#]
protected virtual void OnToolItemClicked(
   ObjectClickEventArgs e
);
[C++]
protected: virtual void OnToolItemClicked(
   ObjectClickEventArgs* e
);
[JScript]
protected function OnToolItemClicked(
   e : ObjectClickEventArgs
);

Parameters

e
A ObjectClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemClicking Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemClicking Method

Raises the ToolItemClicking event.

[Visual Basic]
Protected Overridable Sub OnToolItemClicking( _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
protected virtual void OnToolItemClicking(
   ObjectCancelClickEventArgs e
);
[C++]
protected: virtual void OnToolItemClicking(
   ObjectCancelClickEventArgs* e
);
[JScript]
protected function OnToolItemClicking(
   e : ObjectCancelClickEventArgs
);

Parameters

e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemRemoved Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemRemoved Method

Raises the ToolItemRemoved event.

[Visual Basic]
Protected Overridable Sub OnToolItemRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnToolItemRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnToolItemRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnToolItemRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnToolItemRemoving Method

Lidor Systems IntegralUI Class Library

TabControl.OnToolItemRemoving Method

Raises the ToolItemRemoving event.

[Visual Basic]
Protected Overridable Sub OnToolItemRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnToolItemRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnToolItemRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnToolItemRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StartAnimation Method

Lidor Systems IntegralUI Class Library

TabControl.StartAnimation Method

Overload List

Starts an animation of animated gifs contained in the page tab.

[Visual Basic] Public Sub StartAnimation(TabPage page)
[C#] public StartAnimation(TabPage page);
[C++] public: StartAnimation(TabPage* page);
[JScript] public function StartAnimation(TabPage page);

Starts an animation of specified animated gif contained in the page tab.

[Visual Basic] Public Sub StartAnimation(TabPage page, Image img)
[C#] public StartAnimation(TabPage page, Image img);
[C++] public: StartAnimation(TabPage* page, Image* img);
[JScript] public function StartAnimation(TabPage page, Image img);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StartAnimation (TabPage) Method

Lidor Systems IntegralUI Class Library

TabControl.StartAnimation (TabPage) Method

Starts an animation of animated gifs contained in the page tab.

[Visual Basic]
Public  Sub StartAnimation( _
   ByVal page As TabPage _
)
[C#]
public  void StartAnimation(
   TabPage page
);
[C++]
public: void StartAnimation(
   TabPage* page
);
[JScript]
public function StartAnimation(
   page : TabPage
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StartAnimation (TabPage, Image) Method

Lidor Systems IntegralUI Class Library

TabControl.StartAnimation (TabPage, Image) Method

Starts an animation of specified animated gif contained in the page tab.

[Visual Basic]
Public  Sub StartAnimation( _
   ByVal page As TabPage _
   ByVal img As Image _
)
[C#]
public  void StartAnimation(
   TabPage page
   Image img
);
[C++]
public: void StartAnimation(
   TabPage* page
   Image* img
);
[JScript]
public function StartAnimation(
   page : TabPage
   img : Image
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StopAnimation Method

Lidor Systems IntegralUI Class Library

TabControl.StopAnimation Method

Overload List

Stops the animation of animated gifs contained in the page tab.

[Visual Basic] Public Sub StopAnimation(TabPage page)
[C#] public StopAnimation(TabPage page);
[C++] public: StopAnimation(TabPage* page);
[JScript] public function StopAnimation(TabPage page);

Stops the animation of specified animated gif contained in the page tab.

[Visual Basic] Public Sub StopAnimation(TabPage page, Image img)
[C#] public StopAnimation(TabPage page, Image img);
[C++] public: StopAnimation(TabPage* page, Image* img);
[JScript] public function StopAnimation(TabPage page, Image img);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StopAnimation (TabPage) Method

Lidor Systems IntegralUI Class Library

TabControl.StopAnimation (TabPage) Method

Stops the animation of animated gifs contained in the page tab.

[Visual Basic]
Public  Sub StopAnimation( _
   ByVal page As TabPage _
)
[C#]
public  void StopAnimation(
   TabPage page
);
[C++]
public: void StopAnimation(
   TabPage* page
);
[JScript]
public function StopAnimation(
   page : TabPage
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


StopAnimation (TabPage, Image) Method

Lidor Systems IntegralUI Class Library

TabControl.StopAnimation (TabPage, Image) Method

Stops the an animation of specified animated gif contained in the page tab.

[Visual Basic]
Public  Sub StopAnimation( _
   ByVal page As TabPage _
   ByVal img As Image _
)
[C#]
public  void StopAnimation(
   TabPage page
   Image img
);
[C++]
public: void StopAnimation(
   TabPage* page
   Image* img
);
[JScript]
public function StopAnimation(
   page : TabPage
   img : Image
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

TabControl.UpdateLayout () Method

Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabControl Events

The events of the TabControl class are listed here. For a complete list of TabControl class members, see the TabControl Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked (inherited from ControlBase) | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking (inherited from ControlBase) | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event OrientationChanged | Occurs when control changes its orientation.
public event PageAdded | Occurs after page is added.
public event PageAdding | Occurs before page is added.
public event PageClosed | Occurs after page is closed.
public event PageClosing | Occurs before page is closed.
public event PageRemoved | Occurs after page is removed.
public event PageRemoving | Occurs before page is removed.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when scrolling position of tabs has changed.
public event SelectedPageChanged | Occurs after the SelectedPage is changed.
public event SelectedPageChanging | Occurs before the SelectedPage is changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TabButtonAdded | Occurs after a command button is added.
public event TabButtonAdding | Occurs before a command button is added.
public event TabButtonClicked | Occurs after a command button is clicked.
public event TabButtonClicking | Occurs before a command button is clicked.
public event TabButtonRemoved | Occurs after a command button is removed.
public event TabButtonRemoving | Occurs before a command button is removed.
public event TabMouseHover | Occurs when the mouse cursor hovers for some time over the page tab space.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event ToolItemAdded | Occurs after a tool item is added.
public event ToolItemAdding | Occurs before a tool item is added.
public event ToolItemClicked | Occurs after a tool item is clicked.
public event ToolItemClicking | Occurs before a tool item is clicked.
public event ToolItemRemoved | Occurs after a tool item is removed.
public event ToolItemRemoving | Occurs before a tool item is removed.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabControl Class | LidorSystems.IntegralUI.Containers Namespace


PageAdded Event

Lidor Systems IntegralUI Class Library

TabControl.PageAdded Event

Occurs after page is added.

[Visual Basic]
Public Event PageAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler PageAdded;
[C++]
public: __event ObjectEventHandler* PageAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageAdding Event

Lidor Systems IntegralUI Class Library

TabControl.PageAdding Event

Occurs before page is added.

[Visual Basic]
Public Event PageAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler PageAdding;
[C++]
public: __event ObjectCancelEventHandler* PageAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageClosed Event

Lidor Systems IntegralUI Class Library

TabControl.PageClosed Event

Occurs after page is closed.

[Visual Basic]
Public Event PageClosed As ObjectEventHandler
[C#]
public event ObjectEventHandler PageClosed;
[C++]
public: __event ObjectEventHandler* PageClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageClosing Event

Lidor Systems IntegralUI Class Library

TabControl.PageClosing Event

Occurs before page is closed.

[Visual Basic]
Public Event PageClosing As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler PageClosing;
[C++]
public: __event ObjectCancelEventHandler* PageClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageRemoved Event

Lidor Systems IntegralUI Class Library

TabControl.PageRemoved Event

Occurs after page is removed.

[Visual Basic]
Public Event PageRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler PageRemoved;
[C++]
public: __event ObjectEventHandler* PageRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


PageRemoving Event

Lidor Systems IntegralUI Class Library

TabControl.PageRemoving Event

Occurs before page is removed.

[Visual Basic]
Public Event PageRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler PageRemoving;
[C++]
public: __event ObjectCancelEventHandler* PageRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ScrollPosChanged Event

Lidor Systems IntegralUI Class Library

TabControl.ScrollPosChanged Event

Occurs when scrolling position of tabs has changed.

[Visual Basic]
Public Event ScrollPosChanged As EventHandler
[C#]
public event EventHandler ScrollPosChanged;
[C++]
public: __event EventHandler* ScrollPosChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedPageChanged Event

Lidor Systems IntegralUI Class Library

TabControl.SelectedPageChanged Event

Occurs after the SelectedPage is changed.

[Visual Basic]
Public Event SelectedPageChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedPageChanged;
[C++]
public: __event ObjectEventHandler* SelectedPageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedPageChanging Event

Lidor Systems IntegralUI Class Library

TabControl.SelectedPageChanging Event

Occurs before the SelectedPage is changed.

[Visual Basic]
Public Event SelectedPageChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler SelectedPageChanging;
[C++]
public: __event ObjectCancelEventHandler* SelectedPageChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonAdded Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonAdded Event

Occurs after a command button is added.

[Visual Basic]
Public Event TabButtonAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler TabButtonAdded;
[C++]
public: __event ObjectEventHandler* TabButtonAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonAdding Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonAdding Event

Occurs before a command button is added.

[Visual Basic]
Public Event TabButtonAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler TabButtonAdding;
[C++]
public: __event ObjectCancelEventHandler* TabButtonAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonClicked Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonClicked Event

Occurs after a command button is clicked.

[Visual Basic]
Public Event TabButtonClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler TabButtonClicked;
[C++]
public: __event ObjectClickEventHandler* TabButtonClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonClicking Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonClicking Event

Occurs before a command button is clicked.

[Visual Basic]
Public Event TabButtonClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler TabButtonClicking;
[C++]
public: __event ObjectCancelClickEventHandler* TabButtonClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonRemoved Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonRemoved Event

Occurs after a command button is removed.

[Visual Basic]
Public Event TabButtonRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler TabButtonRemoved;
[C++]
public: __event ObjectEventHandler* TabButtonRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabButtonRemoving Event

Lidor Systems IntegralUI Class Library

TabControl.TabButtonRemoving Event

Occurs before a command button is removed.

[Visual Basic]
Public Event TabButtonRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler TabButtonRemoving;
[C++]
public: __event ObjectCancelEventHandler* TabButtonRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabMouseHover Event

Lidor Systems IntegralUI Class Library

TabControl.TabMouseHover Event

Occurs when the mouse cursor hovers for some time over the page tab space.

[Visual Basic]
Public Event TabMouseHover As ObjectEventHandler
[C#]
public event ObjectEventHandler TabMouseHover;
[C++]
public: __event ObjectEventHandler* TabMouseHover;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemAdded Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemAdded Event

Occurs after a tool item is added.

[Visual Basic]
Public Event ToolItemAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ToolItemAdded;
[C++]
public: __event ObjectEventHandler* ToolItemAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemAdding Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemAdding Event

Occurs before a tool item is added.

[Visual Basic]
Public Event ToolItemAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ToolItemAdding;
[C++]
public: __event ObjectCancelEventHandler* ToolItemAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemClicked Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemClicked Event

Occurs after a tool item is clicked.

[Visual Basic]
Public Event ToolItemClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler ToolItemClicked;
[C++]
public: __event ObjectClickEventHandler* ToolItemClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemClicking Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemClicking Event

Occurs before a tool item is clicked.

[Visual Basic]
Public Event ToolItemClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler ToolItemClicking;
[C++]
public: __event ObjectCancelClickEventHandler* ToolItemClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemRemoved Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemRemoved Event

Occurs after a tool item is removed.

[Visual Basic]
Public Event ToolItemRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ToolItemRemoved;
[C++]
public: __event ObjectEventHandler* ToolItemRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


ToolItemRemoving Event

Lidor Systems IntegralUI Class Library

TabControl.ToolItemRemoving Event

Occurs before a tool item is removed.

[Visual Basic]
Public Event ToolItemRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ToolItemRemoving;
[C++]
public: __event ObjectCancelEventHandler* ToolItemRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabPage Class

Represents a panel used in TabControl.

For a list of all members of this type, see TabPage Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
LidorSystems.IntegralUI.PageBase
LidorSystems.IntegralUI.Containers.TabPage

[Visual Basic]
MustInherit Public Class TabPage
   Inherits LidorSystems.IntegralUI.PageBase
[C#]
public abstract class TabPage : LidorSystems.IntegralUI.PageBase
[C++]
public __gc __abstract class TabPage : public LidorSystems.IntegralUI.PageBase
[JScript]
public abstract class TabPage extends LidorSystems.IntegralUI.PageBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

TabPage Members | LidorSystems.IntegralUI.Containers Namespace


TabPage Members

TabPage overview

Public Constructors

public constructor TabPage Constructor Initializes a new instance of the TabPage class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowImageAnimation | Determines whether page's images can be animated.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
public property AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
public property AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
public property AutoSize (inherited from Panel) | Overridden.
public property AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle (inherited from Panel) | Indicates the border style for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property Buttons | Gets the collection of command buttons displayed in page tab.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledStyle | Gets or sets the drawing style of the disabled page.
public property DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the page.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
public property HoverStyle | Gets or sets the drawing style of the hovered page.
public property Image | Gets or sets the image of the page when it is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the page is in normal state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property Key | Gets or sets a string that uniquely identifies page in a collection.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalStyle | Gets or sets the default drawing style of the page.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedImage | Gets or sets the image displayed when the page is in selected state.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the page is in the selected state.
public property SelectedStyle | Gets or sets the drawing style of the selected page.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property StyleFromParent | Determines whether the page should use the styles from his parent.
public property TabContent | Specifies the content of the page tab.
public property TabControl | Gets the parent TabControl.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. The text associated with the page.
public property TextBounds (inherited from PageBase) | For internal use.
public property TextSize (inherited from PageBase) | For internal use.
public property ToolTip | Gets or sets the page tooltip text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseParentButtons | Specifies whether the page will use the command buttons from it's parent control.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
public property Visible | Overridden. Gets or sets a value indicating whether the page is displayed.
public property WatermarkImage (inherited from PageBase) | Specifies the image used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WordWrap | Determines whether the tab content will be automatically divided in multiple lines.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method RepaintParent | Repaints the parent control, if any.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Events

public event AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property changes.
public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FadingChanged | Occurs when fade value of the page has changed during active fading process.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property HScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
protected property VScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFadingChanged | Raises the FadingChanged event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaddingChanged (inherited from ScrollableControl) | Raises the PaddingChanged event event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize (inherited from Panel) | Overridden.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method RepaintParent | Repaints the parent control, if any.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
protected method SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


TabPage Constructor

Initializes a new instance of the TabPage class.

Overload List

Initializes a new instance of the TabPage class.

[Visual Basic] Public Sub New()
[C#] public TabPage();
[C++] public: TabPage();
[JScript] public function TabPage();

Initializes a new instance of the TabPage class with the specified text.

[Visual Basic] Public Sub New()
[C#] public TabPage(String);
[C++] public: TabPage(String*);
[JScript] public function TabPage(String);

Initializes a new instance of the TabPage class with the specified text and image index.

[Visual Basic] Public Sub New(String, Integer)
[C#] public TabPage(String, int);
[C++] public: TabPage(String*, int);
[JScript] public function TabPage(String, int);

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Controls Namespace


TabPage Constructor ()

Initializes a new instance of the TabPage class.

[Visual Basic]
Public Sub New()
[C#]
public TabPage();
[C++]
public: TabPage();
[JScript]
public function TabPage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


TabPage Constructor (String)

Initializes a new instance of the TabPage class with the specified text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public TabPage(
   String text
);
[C++]
public: TabPage(
   String* text
);
[JScript]
public function TabPage(
   text : String
);

Parameters

text
The text of the page tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


TabPage Constructor (String, Int32)

Initializes a new instance of the TabPage class with the specified text and image index.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
   ByVal imageIndex As Int32 _
)
[C#]
public TabPage(
   String text
   Int32 imageIndex
);
[C++]
public: TabPage(
   String* text
   Int32* imageIndex
);
[JScript]
public function TabPage(
   text : String
   imageIndex : Int32
);

Parameters

text
The text of the page tab.
imageIndex
The iindex of the image displayed in the page tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


TabPage Properties

The properties of the TabPage class are listed here. For a complete list of TabPage class members, see the TabPage Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowImageAnimation | Determines whether page's images can be animated.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
public property AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
public property AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
public property AutoSize (inherited from Panel) | Overridden.
public property AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle (inherited from Panel) | Indicates the border style for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property Buttons | Gets the collection of command buttons displayed in page tab.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledStyle | Gets or sets the drawing style of the disabled page.
public property DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the page.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
public property HoverStyle | Gets or sets the drawing style of the hovered page.
public property Image | Gets or sets the image of the page when it is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the page is in normal state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property Key | Gets or sets a string that uniquely identifies page in a collection.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalStyle | Gets or sets the default drawing style of the page.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedImage | Gets or sets the image displayed when the page is in selected state.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the page is in the selected state.
public property SelectedStyle | Gets or sets the drawing style of the selected page.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property StyleFromParent | Determines whether the page should use the styles from his parent.
public property TabContent | Specifies the content of the page tab.
public property TabControl | Gets the parent TabControl.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. The text associated with the page.
public property TextBounds (inherited from PageBase) | For internal use.
public property TextSize (inherited from PageBase) | For internal use.
public property ToolTip | Gets or sets the page tooltip text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseParentButtons | Specifies whether the page will use the command buttons from it's parent control.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
public property Visible | Overridden. Gets or sets a value indicating whether the page is displayed.
public property WatermarkImage (inherited from PageBase) | Specifies the image used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WordWrap | Determines whether the tab content will be automatically divided in multiple lines.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property HScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
protected property VScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


AllowImageAnimation Property

Lidor Systems IntegralUI Class Library

TabPage.AllowImageAnimation Property

Determines whether page's images can be animated.

[Visual Basic]
Public Overridable Property AllowImageAnimation As Boolean
[C#]
public virtual bool AllowImageAnimation {get; set;}
[C++]
public: __property virtual bool get_AllowImageAnimation();
public: __property virtual void set_AllowImageAnimation(bool);
[JScript]
public function get AllowImageAnimation() : Boolean;
public function set AllowImageAnimation(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


Buttons Property

Lidor Systems IntegralUI Class Library

TabPage.Buttons Property

Gets the collection of command buttons displayed in page tab.

[Visual Basic]
Public ReadOnly Property Buttons As CommandButtonCollection
[C#]
public CommandButtonCollection Buttons {get;}
[C++]
public: __property CommandButtonCollection* get_Buttons();
[JScript]
public function get Buttons() : CommandButtonCollection;

Property Value

A CommandButtonCollection that represents the command buttons assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


DisabledStyle Property

Lidor Systems IntegralUI Class Library

TabPage.DisabledStyle Property

Gets or sets the drawing style of the disabled page.

[Visual Basic]
Public Property DisabledStyle As TabPageColorStyle
[C#]
public TabPageColorStyle DisabledStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_DisabledStyle();
public: __property void set_DisabledStyle(TabPageColorStyle);
[JScript]
public function get DisabledStyle() : TabPageColorStyle;
public function set DisabledStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


FormatStyle Property

Lidor Systems IntegralUI Class Library

TabPage.FormatStyle Property

Gets or sets the format style of the page.

[Visual Basic]
Public Property FormatStyle As TabPageFormatStyle
[C#]
public TabPageFormatStyle FormatStyle {get; set;}
[C++]
public: __property TabPageFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(TabPageFormatStyle);
[JScript]
public function get FormatStyle() : TabPageFormatStyle;
public function set FormatStyle(TabPageFormatStyle);

Property Value

The TabPageFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


HoverStyle Property

Lidor Systems IntegralUI Class Library

TabPage.HoverStyle Property

Gets or sets the drawing style of the hovered page.

[Visual Basic]
Public Property HoverStyle As TabPageColorStyle
[C#]
public TabPageColorStyle HoverStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_HoverStyle();
public: __property void set_HoverStyle(TabPageColorStyle);
[JScript]
public function get HoverStyle() : TabPageColorStyle;
public function set HoverStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

TabPage.ImageIndex Property

Gets or sets the image list index value of the image displayed when the page is in normal state.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


Image Property

Lidor Systems IntegralUI Class Library

TabPage.Image Property

Gets or sets the image of the page when it is in normal state.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


Key Property

Lidor Systems IntegralUI Class Library

TabPage.Key Property

Gets or sets a string that uniquely identifies page in a collection.

[Visual Basic]
Public Property Key As String
[C#]
public String Key {get; set;}
[C++]
public: __property String* get_Key();
public: __property void set_Key(String*);
[JScript]
public function get Key() : String;
public function set Key(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


NormalStyle Property

Lidor Systems IntegralUI Class Library

TabPage.NormalStyle Property

Gets or sets the default drawing style of the page.

[Visual Basic]
Public Property NormalStyle As TabPageColorStyle
[C#]
public TabPageColorStyle NormalStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_NormalStyle();
public: __property void set_NormalStyle(TabPageColorStyle);
[JScript]
public function get NormalStyle() : TabPageColorStyle;
public function set NormalStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


SelectedImageIndex Property

Lidor Systems IntegralUI Class Library

TabPage.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when the page is in the selected state.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}
[C++]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(int);
[JScript]
public function get SelectedImageIndex() : int;
public function set SelectedImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


SelectedImage Property

Lidor Systems IntegralUI Class Library

TabPage.SelectedImage Property

Gets or sets the image displayed when the page is in selected state.

[Visual Basic]
Public Property SelectedImage As Image
[C#]
public Image SelectedImage { get; set; }
[C++]
public: __property Image* get_SelectedImage();
public: __property void set_SelectedImage(Image* );
[JScript]
public function get SelectedImage() : Image
public function set SelectedImage(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


SelectedStyle Property

Lidor Systems IntegralUI Class Library

TabPage.SelectedStyle Property

Gets or sets the drawing style of the selected page.

[Visual Basic]
Public Property SelectedStyle As TabPageColorStyle
[C#]
public TabPageColorStyle SelectedStyle {get; set;}
[C++]
public: __property TabPageColorStyle get_SelectedStyle();
public: __property void set_SelectedStyle(TabPageColorStyle);
[JScript]
public function get SelectedStyle() : TabPageColorStyle;
public function set SelectedStyle(TabPageColorStyle);

Property Value

A TabPageColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


StyleFromParent Property

Lidor Systems IntegralUI Class Library

TabPage.StyleFromParent Property

Determines whether the page should use the styles from his parent.

[Visual Basic]
Public Overridable Property StyleFromParent As Boolean
[C#]
public virtual bool StyleFromParent {get; set;}
[C++]
public: __property virtual bool get_StyleFromParent();
public: __property virtual void set_StyleFromParent(bool);
[JScript]
public function get StyleFromParent() : Boolean;
public function set StyleFromParent(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


TabContent Property

Lidor Systems IntegralUI Class Library

TabPage.TabContent Property

Specifies the content of the page tab.

[Visual Basic]
Public Overridable Property TabContent As String
[C#]
public virtual String TabContent {get; set;}
[C++]
public: __property virtual String* get_TabContent();
public: __property virtual void set_TabContent(String*);
[JScript]
public function get TabContent() : String;
public function set TabContent(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


TabControl Property

Lidor Systems IntegralUI Class Library

TabPage.TabControl Property

Gets the parent TabControl.

[Visual Basic]
Public ReadOnly Property TabControl As TabControl
[C#]
public TabControl TabControl {get;}
[C++]
public: __property TabControl* get_TabControl();
[JScript]
public function get TabControl() : TabControl;

Property Value

A TabControl that represents a parent container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


ToolTip Property

Lidor Systems IntegralUI Class Library

TabPage.ToolTip Property

Gets or sets the page tooltip text.

[Visual Basic]
Public Property ToolTip As String
[C#]
public String ToolTip {get; set;}
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String*);
[JScript]
public function get ToolTip() : String;
public function set ToolTip(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


UseParentButtons Property

Lidor Systems IntegralUI Class Library

TabPage.UseParentButtons Property

Specifies whether the page will use the command buttons from it's parent control.

[Visual Basic]
Public Overridable Property UseParentButtons As Boolean
[C#]
public virtual bool UseParentButtons {get; set;}
[C++]
public: __property virtual bool get_UseParentButtons();
public: __property virtual void set_UseParentButtons(bool);
[JScript]
public function get UseParentButtons() : Boolean;
public function set UseParentButtons(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


Visible Property

Lidor Systems IntegralUI Class Library

TabPage.Visible Property

Gets or sets a value indicating whether the page is displayed.

[Visual Basic]
Public Shadows Property Visible As Boolean
[C#]
public new bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


WordWrap Property

Lidor Systems IntegralUI Class Library

TabPage.WordWrap Property

Determines whether the tab content will be automatically divided in multiple lines.

[Visual Basic]
Public Property WordWrap As Boolean
[C#]
public bool WordWrap {get; set;}
[C++]
public: __property bool get_WordWrap();
public: __property void set_WordWrap(bool);
[JScript]
public function get WordWrap() : Boolean;
public function set WordWrap(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


TabPage Methods

The methods of the TabPage class are listed here. For a complete list of TabPage class members, see the TabPage Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method RepaintParent | Repaints the parent control, if any.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFadingChanged | Raises the FadingChanged event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaddingChanged (inherited from ScrollableControl) | Raises the PaddingChanged event event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize (inherited from Panel) | Overridden.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method RepaintParent | Repaints the parent control, if any.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
protected method SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


OnFadingChanged Method

Lidor Systems IntegralUI Class Library

TabPage.OnFadingChanged Method

Raises the FadingChanged event.

[Visual Basic]
Protected Sub OnFadingChanged( _
   ByVal e As EventArgs _
)
[C#]
 protected void OnFadingChanged(
   EventArgs e
);
[C++]
 protected: void OnFadingChanged(
   EventArgs* e
);
[JScript]
protected function OnFadingChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


RepaintParent Method

Lidor Systems IntegralUI Class Library

TabPage.RepaintParent Method

Repaints the parent control, if any.

[Visual Basic]
Public Overridable Sub RepaintParent()
[C#]
public virtual void RepaintParent();
[C++]
public: virtual void RepaintParent();
[JScript]
public function RepaintParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


TabPage Events

The events of the TabPage class are listed here. For a complete list of TabPage class members, see the TabPage Members topic.

Public Events

public event AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property changes.
public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FadingChanged | Occurs when fade value of the page has changed during active fading process.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabPage Class | LidorSystems.IntegralUI.Containers Namespace


FadingChanged Event

Lidor Systems IntegralUI Class Library

TabPage.FadingChanged Event

Occurs when fade value of the page has changed during active fading process.

[Visual Basic]
Public Event FadingChanged As EventHandler
[C#]
public event EventHandler FadingChanged;
[C++]
public: __event EventHandler* FadingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPage Class | TabPage Members | LidorSystems.IntegralUI.Containers Namespace


SplitContainerMode Enumeration

Enumerator used to specify the type of splitter in SplitContainer control.

[Visual Basic]
Public Enum SplitContainerMode
[C#]
public enum SplitContainerMode
[C++]
__value public enum SplitContainerMode
[JScript]
public
   enum SplitContainerMode

Members

Member name | Description
Default | The standard splitter is used.
CollapseButtons | The splitter contains expand/collapse buttons.
Tabs | The splitter is merged with tab strip containing tabs and command buttons.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabContentRelation Enumeration

Enumerator used to specify how text and image are aligned in tab content space.

[Visual Basic]
Public Enum TabContentRelation
[C#]
public enum TabContentRelation
[C++]
__value public enum TabContentRelation
[JScript]
public
   enum TabContentRelation

Members

Member name | Description
ImageBeforeText | The image is displayed in front of text.
ImageAboveText | The image is displayed above text.
TextBeforeImage | The text is displayed in front of image.
TextAboveImage | The text is displayed above image.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabContentStyle Enumeration

Enumerator used to specify whether text and/or image are displayed.

[Visual Basic]
Public Enum TabContentStyle
[C#]
public enum TabContentStyle
[C++]
__value public enum TabContentStyle
[JScript]
public
   enum TabContentStyle

Members

Member name | Description
None | The tab content is empty.
Text | Only text is displayed.
Image | Only image is displayed.
All | Both, the text and image are displayed.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabCornerShape Enumeration

Enumerator used to specify the appearance of corners of tab border.

[Visual Basic]
Public Enum TabCornerShape
[C#]
public enum TabCornerShape
[C++]
__value public enum TabCornerShape
[JScript]
public
   enum TabCornerShape

Members

Member name | Description
Squared | The corners of tab border are squared.
Rounded | The corners of tab border are rounded.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabDockAlignment Enumeration

Enumerator used to determine how page tab is aligned in parent control.

[Visual Basic]
Public Enum TabDockAlignment
[C#]
public enum TabDockAlignment
[C++]
__value public enum TabDockAlignment
[JScript]
public
   enum TabDockAlignment

Members

Member name | Description
Left | The page tab is aligned to the left side of the control tabstrip.
Right | The page tab is aligned to the right side of the control tabstrip.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabMode Enumeration

Enumerator used to specify how tabs are sized.

[Visual Basic]
Public Enum TabMode
[C#]
public enum TabMode
[C++]
__value public enum TabMode
[JScript]
public
   enum TabMode

Members

Member name | Description
AutoSized | The tab size is determined by its content.
Compressed | Only the active tab shows its content, others show only image.
Justified | Size split amongst tabs if not enough room, otherwise auto-sized.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabNavigationMode Enumeration

Enumerator used to specify how tabs are navigated.

[Visual Basic]
Public Enum TabNavigationMode
[C#]
public enum TabNavigationMode
[C++]
__value public enum TabNavigationMode
[JScript]
public
   enum TabNavigationMode

Members

Member name | Description
Default | Tabs are navigated by using scroll buttons.
Multiline | Tabs are presented in mulltiple lines.
Selection | Tabs are navigated by using tab selector button.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabShape Enumeration

Enumerator used to specify the shape of tab.

[Visual Basic]
Public Enum TabShape
[C#]
public enum TabShape
[C++]
__value public enum TabShape
[JScript]
public
   enum TabShape

Members

Member name | Description
Line | The tab is displayed with a line which separates it from other tabs.
Rectangular | The tab shape has rectangular form.
ParallelogrammicLeft | The tab shape has form of a parallelogram with left orientation.
ParallelogrammicRight | The tab shape has form of a parallelogram with right orientation.
Trapezoidal | The tab shape has trapezoidal form.
TrapezoidalLeft | The tab shape has form of a trapezoid with left orientation.
TrapezoidalRight | The tab shape has form of a trapezoid with right orientation.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


TabStripPlacement Enumeration

Enumerator used to specify the side on which tabs are arranged.

[Visual Basic]
Public Enum TabStripPlacement
[C#]
public enum TabStripPlacement
[C++]
__value public enum TabStripPlacement
[JScript]
public
   enum TabStripPlacement

Members

Member name | Description
Left | The tabs are placed on the left side of the parent control.
Top | The tabs are placed on the top side of the parent control.
Middle | The tabs are placed in middle area of the parent control.
Right | The tabs are placed on the right side of the parent control.
Bottom | The tabs are placed on the bottom side of the parent control.

Requirements

Namespace: LidorSystems.IntegralUI.Containers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

LidorSystems.IntegralUI.Containers Namespace


LidorSystems.IntegralUI.Controls

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Controls.Collections Namespace

Classes

Class | Description
CommandButtonCollection | Contains a collection of CommandButton objects.
ListControlItemCollection | Contains a collection of ListControlItem objects.
ToolItemCollection | Contains a collection of ToolItemBase objects.


TabPageCollection Class

Contains a collection of TabPage objects.

For a list of all members of this type, see TabPageCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Containers.Collections.TabPageCollection

[Visual Basic]
Public Class TabPageCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class TabPageCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class TabPageCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class TabPageCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Containers (in LidorSystems.IntegralUI.Containers.dll)

See Also

TabPageCollection Members | LidorSystems.IntegralUI.Containers.Collections Namespace


TabPageCollection Members

TabPageCollection overview

Public Constructors

public constructor TabPageCollection Constructor Initializes a new instance of the TabPageCollection class.

Public Properties

public property Item | Gets a TabPage at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the TabPageCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the TabPageCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the TabPageCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the TabPageCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the TabPageCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the TabPageCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an TabPage is added.
protected method OnAdding | Overridden. Occurs before an TabPage is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an TabPage is removed.
protected method OnRemoving | Overridden. Occurs before an TabPage is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TabPageCollection Class | LidorSystems.IntegralUI.Containers.Collections Namespace


TabPageCollection Constructor

Overload List

Initializes a new instance of the TabPageCollection class.

[Visual Basic] Public Sub New()
[C#] public TabPageCollection();
[C++] public: TabPageCollection();
[JScript] public function TabPageCollection();

Initializes a new instance of the TabPageCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public TabPageCollection(object);
[C++] public: TabPageCollection(Object*);
[JScript] public function TabPageCollection(Object);

See Also

TabPageCollection Class | TabPageCollection Members | LidorSystems.IntegralUI.Containers.Collections Namespace


TabPageCollection Constructor ()

Initializes a new instance of the TabPageCollection class.

[Visual Basic]
Public Sub New()
[C#]
public TabPageCollection();
[C++]
public: TabPageCollection();
[JScript]
public function TabPageCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPageCollection Class | LidorSystems.IntegralUI.Containers.Collections Namespace


TabPageCollection Constructor (Object)

Initializes a new instance of the TabPageCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public TabPageCollection(
   object owner
);
[C++]
public: TabPageCollection(
   Object* owner
);
[JScript]
public function TabPageCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPageCollection Class | LidorSystems.IntegralUI.Containers.Collections Namespace


TabPageCollection Properties

The properties of the TabPageCollection class are listed here. For a complete list of TabPageCollection class members, see the TabPageCollection Members topic.

Public Properties

public property Item | Gets a TabPage at the specified location in the collection.
public property Owner (inherited from TabPageCollection) | Gets the object that owns the TabPageCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

TabPageCollection Class | LidorSystems.IntegralUI.Containers.Collections Namespace


Item Method

Lidor Systems IntegralUI Class Library

TabPageCollection.Item Property

Gets or sets a button within the collection.

Overload List

Gets a TabPage at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a TabPage with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

TabPageCollection Class | TabPageCollection Members | LidorSystems.IntegralUI.Containers.Collections Namespace


LidorSystems.IntegralUI.Style

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Style Namespace

Classes

Class | Description
BackgroundStyle | Represents the common style for drawing the background of all objects.
BackgroundProcessStyle | Represents the style for drawing the form displayed when the background process is active.
BorderCornerShape | Represents the class that controls the border corners for all objects.
BorderStyle | Represents the common style for drawing the border of all controls.
CheckButtonBoxStyle | Represents the style for drawing the checkbox button.
ControlColorStyle | Represents the style for drawing the control.
ControlFormatStyle | Represents the basic format style for controls.
ExpandBoxStyle | Represents the style for drawing the expandbox button.
ScrollBarStyle | Represents the style for drawing the scrollbar.
StyleEventArgs | Provides data for style events.
WatermarkImage | Specifies the image which can be used as a watermark.

Delegates

Delegate | Description
StyleEventHandler | Represents the method that will handle style events.

Enumerations

Enumeration | Description
BorderVisibility | Enumerator used to determine the border visibility.
CornerShape | Enumerator used to set the shape of border corners.
FillStyle | Specifies the fill mode used to draw the client area.
LineStyle | Enumerator used to determine the type of the line.
StyleAction | Enumerator used to specify the action assigned to some style.
TransparencyLevel | Enumerator used to specify the level of transparency.
VisualStyle | Enumerator used to specify the appearance of object according to predefined style.

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


TabPageColorStyle Class

Represents the style for drawing tab pages.

For a list of all members of this type, see TabPageColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Containers.Style.TabPageColorStyle

[Visual Basic]
Public Class TabPageColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class TabPageColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class TabPageColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class TabPageColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageColorStyle Members

TabPageColorStyle overview

Public Constructors

public constructor TabPageColorStyle Constructor Initializes a new instance of the TabPageColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the page content.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TabImage | Gets or sets an image used as a background texture for the page tab.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current TabPageColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TabPageColorStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageColorStyle Constructor ()

Initializes a new instance of the TabPageColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TabPageColorStyle();
[C++]
public: TabPageColorStyle();
[JScript]
public function TabPageColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPageColorStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageColorStyle Properties

The properties of the TabPageColorStyle class are listed here. For a complete list of TabPageColorStyle class members, see the TabPageColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the page content.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TabImage | Gets or sets an image used as a background texture for the page tab.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

TabPageColorStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

TabPageColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

TabPageColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

TabPageColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageColorStyle Methods

The methods of the TabPageColorStyle class are listed here. For a complete list of TabPageColorStyle class members, see the TabPageColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current TabPageColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TabPageColorStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

TabPageColorStyle.Clone Method

Creates an exact copy of the current TabPageColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TabPageColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

TabPageColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TabPageColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

TabPageColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Class

Represents the format style for tab pages.

For a list of all members of this type, see TabPageFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Containers.Style.TabPageFormatStyle

[Visual Basic]
Public Class TabPageFormatStyle Implements
   ICloneable, IDisposable
[C#]
public class TabPageFormatStyle : ICloneable, IDisposable
[C++]
public __gc class TabPageFormatStyle : public ICloneable, IDisposable
[JScript]
public class TabPageFormatStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Members

TabPageFormatStyle overview

Public Constructors

public constructor TabPageFormatStyle Constructor Initializes a new instance of the TabPageFormatStyle class.

Public Properties

public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property ContentSpacing | Specifies the distance between objects in page tab.
public property Font | Gets or sets the font used to display the tab text.
public property Padding | Gets or sets the amount of space from the tab border, in pixels.
public property TabContentAlign | Determines the position of objects within the page tab.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged Occurs when the TabPageFormatStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current TabPageFormatStyle.
public method Dispose | Releases all resources used by this TabPageFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TabPageFormatStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Constructor ()

Initializes a new instance of the TabPageFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TabPageFormatStyle();
[C++]
public: TabPageFormatStyle();
[JScript]
public function TabPageFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabPageFormatStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Properties

The properties of the TabPageFormatStyle class are listed here. For a complete list of TabPageFormatStyle class members, see the TabPageFormatStyle Members topic.

Public Properties

public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property ContentSpacing | Specifies the distance between objects in page tab.
public property Font | Gets or sets the font used to display the tab text.
public property Padding | Gets or sets the amount of space from the tab border, in pixels.
public property TabContentAlign | Determines the position of objects within the page tab.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

TabPageFormatStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


BorderCornerRadius Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


ContentSpacing Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.ContentSpacing Property

Specifies the distance between objects in page tab.

[Visual Basic]
Public Property ContentSpacing As Integer
[C#]
public int ContentSpacing {get; set;}
[C++]
public: __property int get_ContentSpacing();
public: __property void set_ContentSpacing(int);
[JScript]
public function get ContentSpacing() : int;
public function set ContentSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.Font Property

Gets or sets the font used to display the tab text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the tab text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Padding Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.Padding Property

Gets or sets the amount of space from the tab border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabContentAlign Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.TabContentAlign Property

Determines the position of objects within the page tab.

[Visual Basic]
Public Property TabContentAlign As ContentAlignment
[C#]
public ContentAlignment TabContentAlign {get; set;}
[C++]
public: __property ContentAlignment get_TabContentAlign();
public: __property void set_TabContentAlign(ContentAlignment);
[JScript]
public function get TabContentAlign() : ContentAlignment;
public function set TabContentAlign(ContentAlignment);

Property Value

This property specifies a member of the ContentAlignment enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TextRendering Property

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Methods

The methods of the TabPageFormatStyle class are listed here. For a complete list of TabPageFormatStyle class members, see the TabPageFormatStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current TabPageFormatStyle.
public method Dispose | Releases all resources used by this TabPageFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TabPageFormatStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.Clone Method

Creates an exact copy of the current TabPageFormatStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new TabPageFormatStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.Dispose Method

Releases all resources used by this TabPageFormatStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the TabPageFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabPageFormatStyle Events

The events of the TabPageFormatStyle class are listed here. For a complete list of TabPageFormatStyle class members, see the TabPageFormatStyle Members topic.

Public Events

public event StyleChanged Occurs when the TabPageFormatStyle changes.

See Also

TabPageFormatStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

TabPageFormatStyle.StyleChanged Event

Occurs when the TabPageFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageFormatStyle Class | TabPageFormatStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabStripStyle Class

Represents the style for drawing a tabstrip.

For a list of all members of this type, see TabStripStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Containers.Style.TabStripStyle

[Visual Basic]
Public Class TabStripStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class TabStripStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class TabStripStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class TabStripStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Containers.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabStripStyle Members

TabStripStyle overview

Public Constructors

public constructor TabStripStyle Constructor Initializes a new instance of the TabStripStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the tab strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current TabStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TabStripStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabStripStyle Constructor ()

Initializes a new instance of the TabStripStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TabStripStyle();
[C++]
public: TabStripStyle();
[JScript]
public function TabStripStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TabStripStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


TabStripStyle Properties

The properties of the TabStripStyle class are listed here. For a complete list of TabStripStyle class members, see the TabStripStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the tab strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

TabStripStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

TabStripStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabStripStyle Class | TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Padding Property

Lidor Systems IntegralUI Class Library

TabStripStyle.Padding Property

Gets or sets the amount of space from the tab strip border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabStripStyle Class | TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabStripStyle Methods

The methods of the TabStripStyle class are listed here. For a complete list of TabStripStyle class members, see the TabStripStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current TabStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TabStripStyle Class | LidorSystems.IntegralUI.Containers.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

TabStripStyle.Clone Method

Creates an exact copy of the current TabStripStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TabStripStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabStripStyle Class | TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

TabStripStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TabStripStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabStripStyle Class | TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

TabStripStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabStripStyle Class | TabStripStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


LidorSystems.IntegralUI.Controls

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Controls Namespace

Classes

Class | Description
CheckBox | Represents a check box control.
ComboBox | Represents a combo box control.
CommandButton | Represents a button used to trigger custom operations.
CommonControlBase | Provides a common implementation of members for controls.
DateTimePicker | Represents a date time picker control.
DropDownControl | Represents a common implementation of members for drop down controls.
ListControl | Displays a collection of ListControlItems.
ListControlItem | class representing the items in the ListControl control.
MonthCalendar | Represents a control that enables selection of a date using calendar.
NumericUpDown | Represents a up-down control that displays numeric values.
ProgressBar | Represents a control that displays progress of an operation.
TextControl | Represents a text box control.
ToolButton | A class representing a selectable button that can contain text and image.
ToolItemBase | Provides a common implementation of members for tool item objects.
ToolLabel | A class representing a non-selectable tool item that renders text and images and can display hyperlinks.
ToolSeparator | A class representing a line used to group tool items.

Enumerations

Enumeration | Description
CalendarDisplayMode | Enumerator used to determine how date is displayed in MonthCalendar control.
CharacterMode | Enumerator used to determine the type of characters that can be inserted.
CommandButtonType | Enumerator used to specify some predfined types of command buttons.
CommandButtonVisibility | Enumerator used to determine how command buttons are displayed.
NumericButtonAlignment | Enumerator used to determine how control will align buttons relative to its edit box in NumericUpDown control.
ToolContentRelation | Enumerator used to specify how content of tool items are arranged.
ToolDisplayStyle | Enumerator used to specify what objects are showed in tool item space.
ToolItemAlignment | Enumerator used to determine the alignment of tool item in the parent container.
ToolItemType | Enumerator used to specify the type of tool item.
ToolLinkUnderlineStyle | Enumerator used to specify when an underline is shown below the text in tool label.


CheckBox Class

Represents a check box control.

For a list of all members of this type, see CheckBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.CheckBox

[Visual Basic]
 Public Class CheckBox
   Inherits Control
[C#]
public class CheckBox : Control
[C++]
 public __gc class CheckBox : public Control
[JScript]
public class CheckBox extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Members

CheckBox overview

Public Constructors

public constructor CheckBox Constructor Initializes a new instance of the CheckBox class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoCheck | Determines whether the check box state is altered when control is clicked.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxRect | Gets the bounds of the check box.
public property CheckButtonStyle | Gets or sets the drawing style of the check box.
public property CheckState | Gets or sets a value representing the current state of the check box.
public property Checked | Indicates whether the check box is checked or unchecked.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event CheckedChanged | Occurs when the Checked property value changes.
public event CheckStateChanged | Occurs when the CheckState property value changes.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckBox Constructor ()

Initializes a new instance of the CheckBox class.

[Visual Basic]
Public Sub New()
[C#]
public CheckBox();
[C++]
public: CheckBox();
[JScript]
public function CheckBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckBox Properties

The properties of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoCheck | Determines whether the check box state is altered when control is clicked.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxRect | Gets the space reserved for check button box.
public property CheckButtonStyle | Gets or sets the drawing style of the check box.
public property CheckState | Gets or sets a value representing the current state of the check box.
public property Checked | Indicates whether the check box is checked or unchecked.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for check box text.
public property ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


AutoCheck Property

Lidor Systems IntegralUI Class Library

CheckBox.AutoCheck Property

Determines whether the check box state is altered when control is clicked.

[Visual Basic]
Public Overridable Property AutoCheck As Boolean
[C#]
public virtual bool AutoCheck { get; set; }
[C++]
public: __property virtual bool get_AutoCheck();
 public:
__property virtual void set_AutoCheck(bool );
[JScript]
public function get AutoCheck() : bool
public function set AutoCheck(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBoxRect Property

Lidor Systems IntegralUI Class Library

CheckBox.CheckBoxRect Property

Gets the space reserved for check button box.

[Visual Basic]
Public ReadOnly Property CheckBoxRect As Rectangle
[C#]
public Rectangle CheckBoxRect {get;}
[C++]
public: __property Rectangle get_CheckBoxRect();
[JScript]
public function get CheckBoxRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check button box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckButtonStyle Property

Lidor Systems IntegralUI Class Library

CheckBox.CheckButtonStyle Property

Gets or sets the drawing style of the check box.

[Visual Basic]
Public Property CheckButtonStyle As CheckButtonBoxStyle
[C#]
public CheckButtonBoxStyle CheckButtonStyle {get; set;}
[C++]
public: __property CheckButtonBoxStyle get_CheckButtonStyle();
public: __property void set_CheckButtonStyle(CheckButtonBoxStyle);
[JScript]
public function get CheckButtonStyle() : CheckButtonBoxStyle;
public function set CheckButtonStyle(CheckButtonBoxStyle);

Property Value

The CheckButtonBoxStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


Checked Property

Lidor Systems IntegralUI Class Library

CheckBox.Checked Property

Indicates whether the check box is checked or unchecked.

[Visual Basic]
 Public Property Checked As Boolean
[C#]
 public bool Checked { get; set; }
[C++]
 public: __property bool
 get_Checked();
public: __property void set_Checked(bool );
[JScript]
public function get Checked() : bool
public function set Checked(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckState Property

Lidor Systems IntegralUI Class Library

CheckBox.CheckState Property

Gets or sets a value representing the current state of the check box.

[Visual Basic]
Public Overridable Property CheckState As CheckState
[C#]
public virtual CheckState CheckState {get; set;}
[C++]
public: __property virtual CheckState get_CheckState();
public: __property virtual void set_CheckState(CheckState);
[JScript]
public function get CheckState() : CheckState;
public function set CheckState(CheckState);

Property Value

The CheckState assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

Lidor Systems IntegralUI Class Library

CheckBox.TextRect Property

Gets the space reserved for check box text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check box text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


ThreeState Property

Lidor Systems IntegralUI Class Library

CheckBox.ThreeState Property

Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.

[Visual Basic]
Public Overridable Property ThreeState As Boolean
[C#]
public virtual bool ThreeState { get; set; }
[C++]
public: __property virtual bool get_ThreeState();
 public:
__property virtual void set_ThreeState(bool );
[JScript]
public function get ThreeState() : bool
public function set ThreeState(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Methods

The methods of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

CheckBox.Dispose Method

Releases all resources used by this CheckBox object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentCheckButtonStyle Method

Lidor Systems IntegralUI Class Library

CheckBox.GetCurrentCheckButtonStyle Method

Returns the current drawing style of the check button box.

[Visual Basic]
Overloads Public Function GetCurrentCheckButtonStyle() As CheckBoxButtonStyle
[C#]
public CheckBoxButtonStyle GetCurrentCheckButtonStyle();
[C++]
public: CheckBoxButtonStyle* GetCurrentCheckButtonStyle();
[JScript]
public function GetCurrentCheckButtonStyle() : CheckBoxButtonStyle;

Return Value

The style that represents the current drawing style of the check button box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckedChanged Method

Lidor Systems IntegralUI Class Library

CheckBox.OnCheckedChanged Method

Raises the CheckedChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckedChanged( _
   ByVal e As EventArgsClass _
)
[C#]
protected virtual void OnCheckedChanged(
   EventArgsClass e
);
[C++]
protected: virtual void OnCheckedChanged(
   EventArgsClass* e
);
[JScript]
protected function OnCheckedChanged(
   e : EventArgsClass
);

Parameters

e
A EventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckStateChanged Method

Lidor Systems IntegralUI Class Library

CheckBox.OnCheckStateChanged Method

Raises the CheckStateChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckStateChanged( _
   ByVal e As EventArgsClass _
)
[C#]
protected virtual void OnCheckStateChanged(
   EventArgsClass e
);
[C++]
protected: virtual void OnCheckStateChanged(
   EventArgsClass* e
);
[JScript]
protected function OnCheckStateChanged(
   e : EventArgsClass
);

Parameters

e
A EventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

CheckBox.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Events

The events of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event CheckedChanged | Occurs when the Checked property value changes.
public event CheckStateChanged | Occurs when the CheckState property value changes.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckedChanged Event

Lidor Systems IntegralUI Class Library

CheckBox.CheckedChanged Event

Occurs when the Checked property value has changed.

[Visual Basic]
Public Event CheckedChanged As EventHandler
[C#]
public event EventHandler CheckedChanged;
[C++]
public: __event EventHandler* CheckedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckStateChanged Event

Lidor Systems IntegralUI Class Library

CheckBox.CheckStateChanged Event

Occurs when the CheckState property value has changed.

[Visual Basic]
Public Event CheckStateChanged As EventHandler
[C#]
public event EventHandler CheckStateChanged;
[C++]
public: __event EventHandler* CheckStateChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Class

Represents a combo box control.

For a list of all members of this type, see ComboBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ComboBox

[Visual Basic]
 Public Class ComboBox
   Inherits Control
[C#]
public class ComboBox : Control
[C++]
 public __gc class ComboBox : public Control
[JScript]
public class ComboBox extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Members

ComboBox overview

Public Constructors

public constructor ComboBox Constructor Initializes a new instance of the ComboBox class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSelectedItemChanged | Raises the SelectedItemChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnTextUpdate | Raises the TextUpdate event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


ComboBox Constructor ()

Initializes a new instance of the ComboBox class.

[Visual Basic]
Public Sub New()
[C#]
public ComboBox();
[C++]
public: ComboBox();
[JScript]
public function ComboBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


ComboBox Properties

The properties of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


DropDownHeight Property

Lidor Systems IntegralUI Class Library

ComboBox.DropDownHeight Property

Specifies the height of drop down window.

[Visual Basic]
Public Property DropDownHeight As Integer
[C#]
public int DropDownHeight {get; set;}
[C++]
public: __property int get_DropDownHeight();
public: __property void set_DropDownHeight(int);
[JScript]
public function get DropDownHeight() : int;
public function set DropDownHeight(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


DropDownList Property

Lidor Systems IntegralUI Class Library

ComboBox.DropDownList Property

Gets the drop down list control.

[Visual Basic]
Public ReadOnly Property DropDownList As ListControl
[C#]
public ListControl DropDownList {get;}
[C++]
public: __property ListControl* get_DropDownList();
[JScript]
public function get DropDownList() : ListControl;

Property Value

A ListControl that represents the drop down list assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


DropDownWidth Property

Lidor Systems IntegralUI Class Library

ComboBox.DropDownWidth Property

Specifies the width of drop down window.

[Visual Basic]
Public Property DropDownWidth As Integer
[C#]
public int DropDownWidth {get; set;}
[C++]
public: __property int get_DropDownWidth();
public: __property void set_DropDownWidth(int);
[JScript]
public function get DropDownWidth() : int;
public function set DropDownWidth(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

ComboBox.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ImageList Property

Lidor Systems IntegralUI Class Library

ComboBox.ImageList Property

Gets or sets the ImageList that contains the Image objects used by items.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


IntegralHeight Property

Lidor Systems IntegralUI Class Library

ComboBox.IntegralHeight Property

Determines whether the combo box should resize its drop-down window to avoid showing partial items.

[Visual Basic]
 Public Property IntegralHeight As Boolean
[C#]
 public bool IntegralHeight { get; set; }
[C++]
 public: __property bool
 get_IntegralHeight();
public: __property void set_IntegralHeight(bool );
[JScript]
public function get IntegralHeight() : bool
public function set IntegralHeight(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


Items Property

Lidor Systems IntegralUI Class Library

ComboBox.Items Property

Gets the collection of items that are assigned to the control.

[Visual Basic]
Public ReadOnly Property Items As ListControlItemCollection
[C#]
public ListControlItemCollection Items {get;}
[C++]
public: __property ListControlItemCollection* get_Items();
[JScript]
public function get Items() : ListControlItemCollection;

Property Value

A ListControlItemCollection that represents the items assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


MaxDropDownItems Property

Lidor Systems IntegralUI Class Library

ComboBox.MaxDropDownItems Property

Specifies the maximum number of items displayed in drop down list.

[Visual Basic]
Public Property MaxDropDownItems As Integer
[C#]
public int MaxDropDownItems {get; set;}
[C++]
public: __property int get_MaxDropDownItems();
public: __property void set_MaxDropDownItems(int);
[JScript]
public function get MaxDropDownItems() : int;
public function set MaxDropDownItems(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedIndex Property

Lidor Systems IntegralUI Class Library

ComboBox.SelectedIndex Property

Gets or sets the index specifying the currently selected item.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}
[C++]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(int);
[JScript]
public function get SelectedIndex() : int;
public function set SelectedIndex(int);

Property Value

A index, that represents the position of a selected item. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItem Property

Lidor Systems IntegralUI Class Library

ComboBox.SelectedItem Property

Gets or sets currently selected item in the combo box.

[Visual Basic]
Public Property SelectedItem As ListControlItem
[C#]
public ListControlItem SelectedItem {get; set;}
[C++]
public: __property ListControlItem get_SelectedItem();
public: __property void set_SelectedItem(ListControlItem);
[JScript]
public function get SelectedItem() : ListControlItem;
public function set SelectedItem(ListControlItem);

Property Value

A ListControlItem assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


Sorted Property

Lidor Systems IntegralUI Class Library

ComboBox.Sorted Property

Specifies whether items in drop down list are sortable.

[Visual Basic]
 Public Property Sorted As Boolean
[C#]
 public bool Sorted { get; set; }
[C++]
 public: __property bool
 get_Sorted();
public: __property void set_Sorted(bool );
[JScript]
public function get Sorted() : bool
public function set Sorted(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Methods

The methods of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSelectedItemChanged | Raises the SelectedItemChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnTextUpdate | Raises the TextUpdate event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ComboBox.Dispose Method

Releases all resources used by this ComboBox object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedIndexChanged Method

Lidor Systems IntegralUI Class Library

ComboBox.OnSelectedIndexChanged Method

Raises the SelectedIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedIndexChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedIndexChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedIndexChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedItemChanged Method

Lidor Systems IntegralUI Class Library

ComboBox.OnSelectedItemChanged Method

Raises the SelectedItemChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedItemChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedItemChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedItemChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedItemChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnTextUpdate Method

Lidor Systems IntegralUI Class Library

ComboBox.OnTextUpdate Method

Raises the TextUpdate event.

[Visual Basic]
Protected Overridable Sub OnTextUpdate( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnTextUpdate(
   EventArgs e
);
[C++]
protected: virtual void OnTextUpdate(
   EventArgs* e
);
[JScript]
protected function OnTextUpdate(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

DropDownControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Events

The events of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


SelectedIndexChanged Event

Lidor Systems IntegralUI Class Library

ComboBox.SelectedIndexChanged Event

Occurs when SelectedIndex property value changes.

[Visual Basic]
Public Event SelectedIndexChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedIndexChanged;
[C++]
public: __event ObjectEventHandler* SelectedIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItemChanged Event

Lidor Systems IntegralUI Class Library

ComboBox.SelectedItemChanged Event

Occurs when SelectedItem property value changes.

[Visual Basic]
Public Event SelectedItemChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedItemChanged;
[C++]
public: __event ObjectEventHandler* SelectedItemChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


TextUpdate Event

Lidor Systems IntegralUI Class Library

ComboBox.TextUpdate Event

Occurs when the control has updated its text value.

[Visual Basic]
Public Event TextUpdate As EventHandler
[C#]
public event EventHandler TextUpdate;
[C++]
public: __event EventHandler* TextUpdate;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Class

Represents a button used to trigger custom operations.

For a list of all members of this type, see CommandButton Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.CommandButton

[Visual Basic]

Public Class CommandButton
   Inherits MarshalByRefObject
   Implements IDisposable, ICloneable
[C#]

public class CommandButton : MarshalByRefObject, IDisposable,
   ICloneable
[C++]

 public __gc class CommandButton : public MarshalByRefObject,
   IDisposable, ICloneable
[JScript]
public

  class CommandButton extends MarshalByRefObject implements
   IDisposable, ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Members

CommandButton overview

Public Constructors

public constructor CommandButton Constructor Initializes a new instance of the CommandButton class.

Public Properties

public property Bounds | Gets or sets a value specifying the button space. For internal use only.
public property ButtonType | Gets or sets the the type of the button.
public property ContentSize | Gets or sets the size of button content space. For internal use only.
public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | Gets or sets the image displayed in the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the button is in normal state.
public property Key | Gets or sets a string that uniquely identifies button in a collection.
public property Selected | Gets or sets a value indicating whether the button is selected.
public property Size | Gets or sets the size of the button space. For internal use only.
public property State | Gets a value indicating the current state of the button.
public property Tag | Gets or sets the object that contains data about the button.
public property TagString | Gets or sets the tag string of the button.
public property Visible | Gets or sets a value indicating whether the button is displayed.

Public Methods

public method Clone | Creates an exact copy of the current CommandButton.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this CommandButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Public Events

public event ButtonTypeChanged | Occurs when the ButtonType property value has changed.
public event EnabledChanged | Occurs when the Enabled property value has changed.
public event ImageChanged | Occurs when the value of the Image or ImageIndex property changes.
public event SelectedChanged | Occurs when the Selected property value has changed.
public event VisibleChanged | Occurs when the Visible property value changes.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnButtonTypeChanged | Raises the ButtonTypeChanged event.
protected method OnEnabledChanged | Raises the EnabledChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnSelectedChanged | Raises the SelectedChanged event.
protected method OnVisibleChanged | Raises the VisibleChanged event.

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor

Initializes a new instance of the CommandButton class.

Overload List

Initializes a new instance of the CommandButton class.

[Visual Basic] Public Sub New()
[C#] public CommandButton();
[C++] public: CommandButton();
[JScript] public function CommandButton();

Initializes a new instance of the CommandButton class with the specified type.

[Visual Basic] Public Sub New(CommandButtonType)
[C#] public CommandButton(CommandButtonType);
[C++] public: CommandButton(CommandButtonType*);
[JScript] public function CommandButton(CommandButtonType);

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor ()

Initializes a new instance of the CommandButton class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButton();
[C++]
public: CommandButton();
[JScript]
public function CommandButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor (CommandButtonType)

Initializes a new instance of the CommandButton class with the specified type.

[Visual Basic]
Public Sub New( _
   ByVal type As CommandButtonType _
)
[C#]
public CommandButton(
   CommandButtonType type
);
[C++]
public: CommandButton(
   CommandButtonType* type
);
[JScript]
public function CommandButton(
   type : CommandButtonType
);

Parameters

type
The type of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Properties

The properties of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Properties

public property Bounds | Gets or sets a value specifying the button space. For internal use only.
public property ButtonType | Gets or sets the the type of the button.
public property ContentSize | Gets or sets the size of button content space. For internal use only.
public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | Gets or sets the image displayed in the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the button is in normal state.
public property Key | Gets or sets a string that uniquely identifies button in a collection.
public property Selected | Gets or sets a value indicating whether the button is selected.
public property Size | Gets or sets the size of the button space. For internal use only.
public property State | Gets a value indicating the current state of the button.
public property Tag | Gets or sets the object that contains data about the button.
public property TagString | Gets or sets the tag string of the button.
public property Visible | Gets or sets a value indicating whether the button is displayed.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


Bounds Property

Lidor Systems IntegralUI Class Library

CommandButton.Bounds Property

Gets or sets a value specifying the button space. For internal use only.

[Visual Basic]
Public Overrides Overloads ReadOnly Property Bounds As Rectangle
[C#]
public override Rectangle Bounds {get;}
[C++]
public: override __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ButtonType Property

Lidor Systems IntegralUI Class Library

CommandButton.ButtonType Property

Gets or sets the the type of the button.

[Visual Basic]
Public Overrides Overloads Property ButtonType As CommandButtonType
[C#]
public override CommandButtonType ButtonType {get; set;}
[C++]
public: override __property CommandButtonType get_ButtonType();
public: override __property void set_ButtonType(CommandButtonType);
[JScript]
public function get ButtonType() : CommandButtonType;
public function set ButtonType(CommandButtonType);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentSize Property

Lidor Systems IntegralUI Class Library

CommandButton.ContentSize Property

Gets or sets the size of button content space. For internal use only.

[Visual Basic]
Public ReadOnly Property ContentSize As Size
[C#]
public Size ContentSize {get;}
[C++]
public: __property Size get_ContentSize();
[JScript]
public function get ContentSize() : Size;

Property Value

The Size of the button content space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Enabled Property

Lidor Systems IntegralUI Class Library

CommandButton.Enabled Property

Gets or sets a value indicating whether the button can respond to user interaction.

[Visual Basic]
Public Overridable Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

CommandButton.ImageIndex Property

Gets or sets the image list index value of the image displayed when the button is in normal state.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

Lidor Systems IntegralUI Class Library

CommandButton.Image Property

Gets or sets the image displayed when the button is in normal state.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Key Property

Lidor Systems IntegralUI Class Library

CommandButton.Key Property

Gets or sets a string that uniquely identifies button in a collection.

[Visual Basic]
Public Property Key As String
[C#]
public String Key {get; set;}
[C++]
public: __property String* get_Key();
public: __property void set_Key(String*);
[JScript]
public function get Key() : String;
public function set Key(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Selected Property

Lidor Systems IntegralUI Class Library

CommandButton.Selected Property

Gets or sets a value indicating whether the button is selected.

[Visual Basic]
Public Overridable Property Selected As Boolean
[C#]
public virtual bool Selected {get; set;}
[C++]
public: virtual __property bool get_Selected();
public: virtual __property void set_Selected(bool);
[JScript]
public function get Selected() : Boolean;
public function set Selected(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Size Property

Lidor Systems IntegralUI Class Library

CommandButton.Size Property

Gets or sets the size of the button space. For internal use only.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

Property Value

The Size of the button space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


State Property

Lidor Systems IntegralUI Class Library

CommandButton.State Property

Gets a value indicating the current state of the button.

[Visual Basic]
Public Overridable ReadOnly Property State As ObjectState
[C#]
public virtual ObjectState State {get;}
[C++]
public: __property virtual ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Tag Property

Lidor Systems IntegralUI Class Library

CommandButton.Tag Property

Gets or sets the object that contains data about the button.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object*);
[JScript]
public function get Tag() : Object;
public function set Tag(Object);

Property Value

An Object that contains data about the button. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


TagString Property

Lidor Systems IntegralUI Class Library

CommandButton.TagString Property

Gets or sets the tag string of the button.

[Visual Basic]
Public Property TagString As String
[C#]
public String TagString {get; set;}
[C++]
public: __property String* get_TagString();
public: __property void set_TagString(String*);
[JScript]
public function get TagString() : String;
public function set TagString(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Visible Property

Lidor Systems IntegralUI Class Library

CommandButton.Visible Property

Gets or sets a value indicating whether the button is displayed.

[Visual Basic]
Public Overridable Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}
[C++]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Methods

The methods of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Methods

public method Clone | Creates an exact copy of the current CommandButton.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this CommandButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnButtonTypeChanged | Raises the ButtonTypeChanged event.
protected method OnEnabledChanged | Raises the EnabledChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnSelectedChanged | Raises the SelectedChanged event.
protected method OnVisibleChanged | Raises the VisibleChanged event.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


Clone Method

Lidor Systems IntegralUI Class Library

CommandButton.Clone Method

Creates an exact copy of the current CommandButton.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new CommandButton object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

CommandButton.Dispose Method

Releases all resources used by this CommandButton object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonTypeChanged Method

Lidor Systems IntegralUI Class Library

CommandButton.OnButtonTypeChanged Method

Raises the ButtonTypeChanged event.

[Visual Basic]
Protected Overridable Sub OnButtonTypeChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnButtonTypeChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnButtonTypeChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnButtonTypeChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnEnabledChanged Method

Lidor Systems IntegralUI Class Library

CommandButton.OnEnabledChanged Method

Raises the EnabledChanged event.

[Visual Basic]
Protected Overridable Sub OnEnabledChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnEnabledChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnEnabledChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnEnabledChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

Lidor Systems IntegralUI Class Library

CommandButton.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedChanged Method

Lidor Systems IntegralUI Class Library

CommandButton.OnSelectedChanged Method

Raises the SelectedChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnSelectedChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnSelectedChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnSelectedChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnVisibleChanged Method

Lidor Systems IntegralUI Class Library

CommandButton.OnVisibleChanged Method

Raises the VisibleChanged event.

[Visual Basic]
Protected Overridable Sub OnVisibleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnVisibleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnVisibleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnVisibleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Events

The events of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Events

public event ButtonTypeChanged | Occurs when the ButtonType property value has changed.
public event EnabledChanged | Occurs when the Enabled property value has changed.
public event ImageChanged | Occurs when the value of the Image or ImageIndex property changes.
public event SelectedChanged | Occurs when the Selected property value has changed.
public event VisibleChanged | Occurs when the Visible property value changes.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


ButtonTypeChanged Event

Lidor Systems IntegralUI Class Library

CommandButton.ButtonTypeChanged Event

Occurs when the ButtonType property value has changed.

[Visual Basic]
Public Event ButtonTypeChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ButtonTypeChanged;
[C++]
public: __event UpdateEventHandler* ButtonTypeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


EnabledChanged Event

Lidor Systems IntegralUI Class Library

CommandButton.EnabledChanged Event

Occurs when the Enabled property value has changed.

[Visual Basic]
Public Event EnabledChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler EnabledChanged;
[C++]
public: __event UpdateEventHandler* EnabledChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

Lidor Systems IntegralUI Class Library

CommandButton.ImageChanged Event

Occurs when the value of the Image or ImageIndex property changes.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


SelectedChanged Event

Lidor Systems IntegralUI Class Library

CommandButton.SelectedChanged Event

Occurs when the Selected property value has changed.

[Visual Basic]
Public Event SelectedChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler SelectedChanged;
[C++]
public: __event UpdateEventHandler* SelectedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


VisibleChanged Event

Lidor Systems IntegralUI Class Library

CommandButton.VisibleChanged Event

Occurs when the Visible property value has changed.

[Visual Basic]
Public Event VisibleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler VisibleChanged;
[C++]
public: __event UpdateEventHandler* VisibleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Class

Provides a common implementation of members for controls.

For a list of all members of this type, see CommonControlBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.CheckBox
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ListControl
LidorSystems.IntegralUI.Controls.MonthCalendar
LidorSystems.IntegralUI.Controls.NumericUpDown
LidorSystems.IntegralUI.Controls.ProgressBar
LidorSystems.IntegralUI.Controls.TextControl

[Visual Basic]
MustInherit Public Class CommonControlBase
   Inherits Control
[C#]
public abstract class CommonControlBase : Control
[C++]
public __gc __abstract class CommonControlBase : public Control
[JScript]
public abstract class CommonControlBase extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Members

CommonControlBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle | Returns the current color style of the control.
public method GetCurrentFormatStyle | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Constructor ()

Initializes a new instance of the CommonControlBase class.

[Visual Basic]
Public Sub New()
[C#]
public CommonControlBase();
[C++]
public: CommonControlBase();
[JScript]
public function CommonControlBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Properties

The properties of the CommonControlBase class are listed here. For a complete list of CommonControlBase class members, see the CommonControlBase Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


BackgroundImageSpace Property

Lidor Systems IntegralUI Class Library

CommonControlBase.BackgroundImageSpace Property

Gets or sets the space at which background image will be drawn.

[Visual Basic]
Public Property BackgroundImageSpace As BackgroundImageSpace
[C#]
public BackgroundImageSpace BackgroundImageSpace {get; set;}
[C++]
public: __property BackgroundImageSpace get_BackgroundImageSpace();
public: __property void set_BackgroundImageSpace(BackgroundImageSpace);
[JScript]
public function get BackgroundImageSpace() : BackgroundImageSpace;
public function set BackgroundImageSpace(BackgroundImageSpace);

Property Value

The BackgroundImageSpace assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

Lidor Systems IntegralUI Class Library

CommonControlBase.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Property ColorStyle As ControlColorStyle
[C#]
public ControlColorStyle ColorStyle {get; set;}
[C++]
public: __property ControlColorStyle get_ColorStyle();
public: __property void set_ColorStyle(ControlColorStyle);
[JScript]
public function get ColorStyle() : ControlColorStyle;
public function set ColorStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

Lidor Systems IntegralUI Class Library

CommonControlBase.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Property FormatStyle As ControlFormatStyle
[C#]
public ControlFormatStyle FormatStyle {get; set;}
[C++]
public: __property ControlFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ControlFormatStyle);
[JScript]
public function get FormatStyle() : ControlFormatStyle;
public function set FormatStyle(ControlFormatStyle);

Property Value

The ControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


UseTheme Property

Lidor Systems IntegralUI Class Library

CommonControlBase.UseTheme Property

Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Overridable Property UseTheme As Boolean
[C#]
public virtual bool UseTheme { get; set; }
[C++]
public: __property virtual bool get_UseTheme();
 public:
__property virtual void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


VisualStyle Property

Lidor Systems IntegralUI Class Library

CommonControlBase.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Overridable Property VisualStyle As VisualStyle
[C#]
public virtual VisualStyle VisualStyle {get; set;}
[C++]
public: __property virtual VisualStyle get_VisualStyle();
public: __property virtual void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Methods

The methods of the CommonControlBase class are listed here. For a complete list of CommonControlBase class members, see the CommonControlBase Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle | Returns the current color style of the control.
public method GetCurrentFormatStyle | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

CommonControlBase.Dispose Method

Releases all resources used by this CommonControlBase object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetClientRect Method

Lidor Systems IntegralUI Class Library

CommonControlBase.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

Lidor Systems IntegralUI Class Library

CommonControlBase.GetCurrentColorStyle Method

Returns the current color style of the control.

[Visual Basic]
Overloads Public Function GetCurrentColorStyle() As ControlColorStyle
[C#]
public ControlColorStyle GetCurrentColorStyle();
[C++]
public: ControlColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : ControlColorStyle;

Return Value

The style that represents the current color style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentFormatStyle Method

Lidor Systems IntegralUI Class Library

CommonControlBase.GetCurrentFormatStyle Method

Returns the current format style of the control.

[Visual Basic]
Overloads Public Function GetCurrentFormatStyle() As ControlFormatStyle
[C#]
public ControlFormatStyle GetCurrentFormatStyle();
[C++]
public: ControlFormatStyle* GetCurrentFormatStyle();
[JScript]
public function GetCurrentFormatStyle() : ControlFormatStyle;

Return Value

The style that represents the current format style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetDisplayRect Method

Lidor Systems IntegralUI Class Library

CommonControlBase.GetDisplayRect Method

Returns the display rectangle of the control.

[Visual Basic]
Overloads Public Function GetDisplayRect() As Rectangle
[C#]
public Rectangle GetDisplayRect();
[C++]
public: Rectangle* GetDisplayRect();
[JScript]
public function GetDisplayRect() : Rectangle;

Return Value

The rectangle that represents the visible area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

Lidor Systems IntegralUI Class Library

CommonControlBase.IsControlFocused Method

Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overridable Function IsControlFocused() As Boolean
[C#]
public virtual bool IsControlFocused();
[C++]
public: virtual bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate Method

Lidor Systems IntegralUI Class Library

CommonControlBase.ResumeUpdate Method

Resumes the update of the control layout.

Overload List

Resumes only the layout logic of the control.

[Visual Basic] Overridable Public Sub ResumeUpdate()
[C#] public virtual ResumeUpdate();
[C++] public: virtual ResumeUpdate();
[JScript] public function ResumeUpdate();

Resumes the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub ResumeUpdate(Boolean)
[C#] public virtual ResumeUpdate(bool);
[C++] public: virtual ResumeUpdate(bool);
[JScript] public function ResumeUpdate(Boolean);

See Also

ResumeUpdate Class | ResumeUpdate Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate () Method

Lidor Systems IntegralUI Class Library

CommonControlBase.ResumeUpdate () Method

Resumes only the layout logic of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate()
[C#]
public virtual void ResumeUpdate();
[C++]
public: virtual void * ResumeUpdate();
[JScript]
public function ResumeUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate Method

Lidor Systems IntegralUI Class Library

CommonControlBase.ResumeUpdate (Boolean) Method

Resumes the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void ResumeUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * ResumeUpdate(
   bool includeDrawing
);
[JScript]
public function ResumeUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate Method

Lidor Systems IntegralUI Class Library

CommonControlBase.SuspendUpdate Method

Temporarily suspends the update of the control layout.

Overload List

Suspends only the layout logic of the control.

[Visual Basic] Overridable Public Sub SuspendUpdate()
[C#] public virtual SuspendUpdate();
[C++] public: virtual SuspendUpdate();
[JScript] public function SuspendUpdate();

Suspends the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub SuspendUpdate(Boolean)
[C#] public virtual SuspendUpdate(bool);
[C++] public: virtual SuspendUpdate(bool);
[JScript] public function SuspendUpdate(Boolean);

See Also

SuspendUpdate Class | SuspendUpdate Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate () Method

Lidor Systems IntegralUI Class Library

CommonControlBase.SuspendUpdate () Method

Temporarily suspends only the layout logic of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate()
[C#]
public virtual void SuspendUpdate();
[C++]
public: virtual void * SuspendUpdate();
[JScript]
public function SuspendUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate Method

Lidor Systems IntegralUI Class Library

CommonControlBase.SuspendUpdate (Boolean) Method

Temporarily suspends the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void SuspendUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * SuspendUpdate(
   bool includeDrawing
);
[JScript]
public function SuspendUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

CommonControlBase.UpdateLayout () Method

Update layout logic of the control.

[Visual Basic]
Public Overridable Sub UpdateLayout()
[C#]
public virtual void UpdateLayout();
[C++]
 public: virtual void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Class

Represents a date time picker control.

For a list of all members of this type, see DateTimePicker Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.DateTimePicker

[Visual Basic]
 Public Class DateTimePicker
   Inherits Control
[C#]
public class DateTimePicker : Control
[C++]
 public __gc class DateTimePicker : public Control
[JScript]
public class DateTimePicker extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Members

DateTimePicker overview

Public Constructors

public constructor DateTimePicker Constructor Initializes a new instance of the DateTimePicker class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property CustomFormat | A custom string used to format the date displayed in the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DropDownCalendar | Gets the drop down calendar control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Format | Determines how date is displayed.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets current date/time value.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Constructor ()

Initializes a new instance of the DateTimePicker class.

[Visual Basic]
Public Sub New()
[C#]
public DateTimePicker();
[C++]
public: DateTimePicker();
[JScript]
public function DateTimePicker();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Properties

The properties of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property CustomFormat | A custom string used to format the date displayed in the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DropDownCalendar | Gets the drop down calendar control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Format | Determines how date is displayed.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets current date/time value.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


CustomFormat Property

Lidor Systems IntegralUI Class Library

DateTimePicker.CustomFormat Property

A custom string used to format the date displayed in the control.

[Visual Basic]
Public Overridable Property CustomFormat As String
[C#]
public virtual String CustomFormat {get; set;}
[C++]
public: __property virtual String* get_CustomFormat();
public: __property virtual void set_CustomFormat(String*);
[JScript]
public function get CustomFormat() : String;
public function set CustomFormat(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DropDownCalendar Property

Lidor Systems IntegralUI Class Library

DateTimePicker.DropDownCalendar Property

Gets the drop down control.

[Visual Basic]
Public ReadOnly Property DropDownCalendar As MonthCalendar
[C#]
public MonthCalendar DropDownCalendar {get;}
[C++]
public: __property MonthCalendar* get_DropDownCalendar();
[JScript]
public function get DropDownCalendar() : MonthCalendar;

Property Value

A MonthCalendar that represents the drop down control assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


Format Property

Lidor Systems IntegralUI Class Library

DateTimePicker.Format Property

Determines how date is displayed.

[Visual Basic]
Public Overrides Overloads Property Format As DateTimePickerFormat
[C#]
public override DateTimePickerFormat Format {get; set;}
[C++]
public: override __property DateTimePickerFormat get_Format();
public: override __property void set_Format(DateTimePickerFormat);
[JScript]
public function get Format() : DateTimePickerFormat;
public function set Format(DateTimePickerFormat);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

Lidor Systems IntegralUI Class Library

DateTimePicker.Value Property

Gets or sets current date/time value.

[Visual Basic]
Public Overrides Overloads Property Value As DateTime
[C#]
public override DateTime Value {get; set;}
[C++]
public: override __property DateTime get_Value();
public: override __property void set_Value(DateTime);
[JScript]
public function get Value() : DateTime;
public function set Value(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Methods

The methods of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

DateTimePicker.Dispose Method

Releases all resources used by this DateTimePicker object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

Lidor Systems IntegralUI Class Library

DateTimePicker.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanging Method

Lidor Systems IntegralUI Class Library

DateTimePicker.OnValueChanging Method

Raises the ValueChanging event.

[Visual Basic]
Protected Overridable Sub OnValueChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnValueChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnValueChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnValueChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

DateTimePicker.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Events

The events of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

Lidor Systems IntegralUI Class Library

DateTimePicker.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


ValueChanging Event

Lidor Systems IntegralUI Class Library

DateTimePicker.ValueChanging Event

Occurs before the Value property changes.

[Visual Basic]
Public Event ValueChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ValueChanging;
[C++]
public: __event ObjectCancelEventHandler* ValueChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Class

Represents a common implementation of members for drop down controls.

For a list of all members of this type, see DropDownControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ComboBox
LidorSystems.IntegralUI.Controls.DateTimePicker

[Visual Basic]
MustInherit Public Class DropDownControl
   Inherits Control
[C#]
public abstract class DropDownControl : Control
[C++]
public __gc __abstract class DropDownControl : public Control
[JScript]
public abstract class DropDownControl extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Members

DropDownControl overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonImageList | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded | Raises the ButtonAdded event.
protected method OnButtonAdding | Raises the ButtonAdding event.
protected method OnButtonClicked | Raises the ButtonClicked event.
protected method OnButtonClicking | Raises the ButtonClicking event.
protected method OnButtonRemoved | Raises the ButtonRemoved event.
protected method OnButtonRemoving | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed | Raises the DropDownClosed event.
protected method OnDropDownClosing | Raises the DropDownClosing event.
protected method OnDropDownOpened | Raises the DropDownOpened event.
protected method OnDropDownOpening | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Properties

The properties of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonImageList | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


ButtonFormatStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonFormatStyle Property

Gets or sets the format style of command buttons.

[Visual Basic]
Public Property ButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle ButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_ButtonFormatStyle();
public: __property void set_ButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get ButtonFormatStyle() : CommandButtonFormatStyle;
public function set ButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonImageList Property

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonImageList Property

Gets or sets the ImageList that contains the Image objects used by command buttons.

[Visual Basic]
Public Property ButtonImageList As ImageList
[C#]
public ImageList ButtonImageList {get; set;}
[C++]
public: __property ImageList* get_ButtonImageList();
public: __property void set_ButtonImageList(ImageList*);
[JScript]
public function get ButtonImageList() : ImageList;
public function set ButtonImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


Buttons Property

Lidor Systems IntegralUI Class Library

DropDownControl.Buttons Property

Gets the collection of buttons displayed in the button strip.

[Visual Basic]
Public ReadOnly Property Buttons As CommandButtonCollection
[C#]
public CommandButtonCollection Buttons {get;}
[C++]
public: __property CommandButtonCollection* get_Buttons();
[JScript]
public function get Buttons() : CommandButtonCollection;

Property Value

A CommandButtonCollection that represents the command buttons assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripSpace Property

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonStripSpace Property

Gets the bounds of the space reserved for buttons.

[Visual Basic]
Public ReadOnly Property ButtonStripSpace As Rectangle
[C#]
public Rectangle ButtonStripSpace {get;}
[C++]
public: __property Rectangle get_ButtonStripSpace();
[JScript]
public function get ButtonStripSpace() : Rectangle;

Property Value

The Rectangle that represents the space reserved for buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonStripStyle Property

Gets or sets the drawing style of control button strip.

[Visual Basic]
Public Property ButtonStripStyle As ControlStripStyle
[C#]
public ControlStripStyle ButtonStripStyle {get; set;}
[C++]
public: __property ControlStripStyle get_ButtonStripStyle();
public: __property void set_ButtonStripStyle(ControlStripStyle);
[JScript]
public function get ButtonStripStyle() : ControlStripStyle;
public function set ButtonStripStyle(ControlStripStyle);

Property Value

The ControlStripStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ContentRect Property

Lidor Systems IntegralUI Class Library

DropDownControl.ContentRect Property

Gets the bounds of the space reserved for control content.

[Visual Basic]
Public ReadOnly Property ContentRect As Rectangle
[C#]
public Rectangle ContentRect {get;}
[C++]
public: __property Rectangle get_ContentRect();
[JScript]
public function get ContentRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DisabledButtonStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.DisabledButtonStyle Property

Gets or sets the drawing style of command buttons in disabled state.

[Visual Basic]
Public Property DisabledButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledButtonStyle();
public: __property void set_DisabledButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledButtonStyle() : CommandButtonColorStyle;
public function set DisabledButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


Expanded Property

Lidor Systems IntegralUI Class Library

DropDownControl.Expanded Property

Determines whether the drop down window is expanded or not.

[Visual Basic]
Public Overridable Property Expanded As Boolean
[C#]
public virtual bool Expanded { get; set; }
[C++]
public: __property virtual bool get_Expanded();
 public:
__property virtual void set_Expanded(bool );
[JScript]
public function get Expanded() : bool
public function set Expanded(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverButtonStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.HoverButtonStyle Property

Gets or sets the drawing style of command buttons in hover state.

[Visual Basic]
Public Property HoverButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverButtonStyle();
public: __property void set_HoverButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverButtonStyle() : CommandButtonColorStyle;
public function set HoverButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageRect Property

Lidor Systems IntegralUI Class Library

DropDownControl.ImageRect Property

Gets the space reserved for control image.

[Visual Basic]
Public ReadOnly Property ImageRect As Rectangle
[C#]
public Rectangle ImageRect {get;}
[C++]
public: __property Rectangle get_ImageRect();
[JScript]
public function get ImageRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


NormalButtonStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.NormalButtonStyle Property

Gets or sets the drawing style of command buttons in normal state.

[Visual Basic]
Public Property NormalButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalButtonStyle();
public: __property void set_NormalButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalButtonStyle() : CommandButtonColorStyle;
public function set NormalButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedButtonStyle Property

Lidor Systems IntegralUI Class Library

DropDownControl.SelectedButtonStyle Property

Gets or sets the drawing style of command buttons in selected state.

[Visual Basic]
Public Property SelectedButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedButtonStyle();
public: __property void set_SelectedButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedButtonStyle() : CommandButtonColorStyle;
public function set SelectedButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowDropDownButton Property

Lidor Systems IntegralUI Class Library

DropDownControl.ShowDropDownButton Property

Determines whether the drop down button is visible.

[Visual Basic]
Public Overridable Property ShowDropDownButton As Boolean
[C#]
public virtual bool ShowDropDownButton { get; set; }
[C++]
public: __property virtual bool get_ShowDropDownButton();
 public:
__property virtual void set_ShowDropDownButton(bool );
[JScript]
public function get ShowDropDownButton() : bool
public function set ShowDropDownButton(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

Lidor Systems IntegralUI Class Library

DropDownControl.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Methods

The methods of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded | Raises the ButtonAdded event.
protected method OnButtonAdding | Raises the ButtonAdding event.
protected method OnButtonClicked | Raises the ButtonClicked event.
protected method OnButtonClicking | Raises the ButtonClicking event.
protected method OnButtonRemoved | Raises the ButtonRemoved event.
protected method OnButtonRemoving | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed | Raises the DropDownClosed event.
protected method OnDropDownClosing | Raises the DropDownClosing event.
protected method OnDropDownOpened | Raises the DropDownOpened event.
protected method OnDropDownOpening | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

DropDownControl.Dispose Method

Releases all resources used by this DropDownControl object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonAt (Point) Method

Lidor Systems IntegralUI Class Library

DropDownControl.GetCmdButtonAt (Point) Method

Retrieves the command button located at the specified coordinates.

[Visual Basic]
Overloads Public Function GetCmdButtonAt( _
   ByVal pos As Point _
) As CommandButton
[C#]
public CommandButton GetCmdButtonAt(
   Point pos
);
[C++]
public: CommandButton* GetCmdButtonAt(
   Point pos
);
[JScript]
public function GetCmdButtonAt(
   pos : Point
) : CommandButton;

Parameters

pos
The Point to evaluate and retrieve the command button from.

Return Value

The CommandButton at the specified point, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonState (CommandButton) Method

Lidor Systems IntegralUI Class Library

DropDownControl.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonColorStyle Method

Lidor Systems IntegralUI Class Library

DropDownControl.GetCurrentButtonColorStyle Method

Returns the current drawing style of buttons in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonColorStyle() As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle GetCurrentButtonColorStyle();
[C++]
public: CommandButtonColorStyle* GetCurrentButtonColorStyle();
[JScript]
public function GetCurrentButtonColorStyle() : CommandButtonColorStyle;

Return Value

The style that represents the current drawing style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonFormatStyle Method

Lidor Systems IntegralUI Class Library

DropDownControl.GetCurrentButtonFormatStyle Method

Returns the current format style of buttons in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonFormatStyle() As CommandButtonFormatStylee
[C#]
public CommandButtonFormatStyle GetCurrentButtonFormatStyle();
[C++]
public: CommandButtonFormatStylee* GetCurrentButtonFormatStyle();
[JScript]
public function GetCurrentButtonFormatStyle() : CommandButtonFormatStylee;

Return Value

The style that represents the current format style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonStripStyle Method

Lidor Systems IntegralUI Class Library

DropDownControl.GetCurrentButtonStripStyle Method

Returns the current drawing style of the button strip in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonStripStyle() As ControlStripStyle
[C#]
public ControlStripStyle GetCurrentButtonStripStyle();
[C++]
public: ControlStripStyle* GetCurrentButtonStripStyle();
[JScript]
public function GetCurrentButtonStripStyle() : ControlStripStyle;

Return Value

The style that represents the current drawing style of the the button strip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

Lidor Systems IntegralUI Class Library

DropDownControl.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonAdded Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnButtonAdded Method

Raises the ButtonAdded event.

[Visual Basic]
Protected Overridable Sub OnButtonAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnButtonAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnButtonAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnButtonAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonAdding Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnButtonAdding Method

Raises the ButtonAdding event.

[Visual Basic]
Protected Overridable Sub OnButtonAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonClicked Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnButtonClicked Method

Raises the ButtonClicked event.

[Visual Basic]
Protected Overridable Sub OnButtonClicked( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnButtonClicked(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnButtonClicked(
   ObjectEventArgs* e
);
[JScript]
protected function OnButtonClicked(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonClicking Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnButtonClicking Method

Raises the ButtonClicking event.

[Visual Basic]
Protected Overridable Sub OnButtonClicking( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonClicking(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonClicking(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonClicking(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoved Method

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonRemoved Method

Raises the ButtonRemoved event.

[Visual Basic]
Protected Overridable Sub ButtonRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void ButtonRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void ButtonRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function ButtonRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonRemoving Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnButtonRemoving Method

Raises the ButtonRemoving event.

[Visual Basic]
Protected Overridable Sub OnButtonRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownClosed Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnDropDownClosed Method

Raises the DropDownClosed event.

[Visual Basic]
Protected Overridable Sub OnDropDownClosed( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnDropDownClosed(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnDropDownClosed(
   ObjectEventArgs* e
);
[JScript]
protected function OnDropDownClosed(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownClosing Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnDropDownClosing Method

Raises the DropDownClosing event.

[Visual Basic]
Protected Overridable Sub OnDropDownClosing( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnDropDownClosing(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnDropDownClosing(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnDropDownClosing(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownOpened Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnDropDownOpened Method

Raises the DropDownOpened event.

[Visual Basic]
Protected Overridable Sub OnDropDownOpened( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnDropDownOpened(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnDropDownOpened(
   ObjectEventArgs* e
);
[JScript]
protected function OnDropDownOpened(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownOpening Method

Lidor Systems IntegralUI Class Library

DropDownControl.OnDropDownOpening Method

Raises the DropDownOpening event.

[Visual Basic]
Protected Overridable Sub OnDropDownOpening( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnDropDownOpening(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnDropDownOpening(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnDropDownOpening(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Events

The events of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


ButtonAdded Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonAdded Event

Occurs after a command button is added.

[Visual Basic]
Public Event ButtonAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ButtonAdded;
[C++]
public: __event ObjectEventHandler* ButtonAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonAdding Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonAdding Event

Occurs before a command button is added.

[Visual Basic]
Public Event ButtonAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ButtonAdding;
[C++]
public: __event ObjectCancelEventHandler* ButtonAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonClicked Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonClicked Event

Occurs after a command button is clicked.

[Visual Basic]
Public Event ButtonClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler ButtonClicked;
[C++]
public: __event ObjectClickEventHandler* ButtonClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonClicking Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonClicking Event

Occurs before a command button is clicked.

[Visual Basic]
Public Event ButtonClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler ButtonClicking;
[C++]
public: __event ObjectCancelClickEventHandler* ButtonClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoved Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonRemoved Event

Occurs after a command button is removed.

[Visual Basic]
Public Event ButtonRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ButtonRemoved;
[C++]
public: __event ObjectEventHandler* ButtonRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoving Event

Lidor Systems IntegralUI Class Library

DropDownControl.ButtonRemoving Event

Occurs before a command button is removed.

[Visual Basic]
Public Event ButtonRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ButtonRemoving;
[C++]
public: __event ObjectCancelEventHandler* ButtonRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownClosed Event

Lidor Systems IntegralUI Class Library

DropDownControl.DropDownClosed Event

Occurs after a drop down window is closed.

[Visual Basic]
Public Event DropDownClosed As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler DropDownClosed;
[C++]
public: __event ObjectClickEventHandler* DropDownClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownClosing Event

Lidor Systems IntegralUI Class Library

DropDownControl.DropDownClosing Event

Occurs before a drop down window is closed.

[Visual Basic]
Public Event DropDownClosing As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler DropDownClosing;
[C++]
public: __event ObjectCancelClickEventHandler* DropDownClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownOpened Event

Lidor Systems IntegralUI Class Library

DropDownControl.DropDownOpened Event

Occurs after a drop down window is opened.

[Visual Basic]
Public Event DropDownOpened As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler DropDownOpened;
[C++]
public: __event ObjectClickEventHandler* DropDownOpened;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownOpening Event

Lidor Systems IntegralUI Class Library

DropDownControl.DropDownOpening Event

Occurs before a drop down window is opened.

[Visual Basic]
Public Event DropDownOpening As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler DropDownOpening;
[C++]
public: __event ObjectCancelClickEventHandler* DropDownOpening;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Class

Displays a collection of ListControlItems.

For a list of all members of this type, see ListControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.ListControl

[Visual Basic]
 Public Class ListControl
   Inherits LidorSystems.IntegralUI.Controls.ListBase
[C#]
public class ListControl : LidorSystems.IntegralUI.Controls.ListBase
[C++]
 public __gc __class ListControl : public LidorSystems.IntegralUI.Controls.ListBase
[JScript]
public class ListControl extends LidorSystems.IntegralUI.Controls.ListBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls.ListControl (in LidorSystems.IntegralUI.Controls.ListControl.dll)

See Also

ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Members

ListControl overview

Public Constructors

public constructor ListControl Constructor Initializes a new instance of the ListControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property SelectionMode | Overridden. Gets or sets the method in which items are selected in the list control control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopItem | Gets the first fully-visible item in the list control control.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of items that can be fully visible in the list control control.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EnsureVisible | Ensures that the specified item is visible, scrolling the list control control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
protected method FindItem | Finds the first item that begins with the given text value.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Overridden. Sorts the items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the ListControlItem is added.
public event ItemAdding | OOccurs before the ListControlItem is added.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the ListControlItem is removed.
public event ItemRemoving | Occurs before the ListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


ListControl Constructor ()

Initializes a new instance of the ListControl class.

[Visual Basic]
Public Sub New()
[C#]
public ListControl();
[C++]
public: ListControl();
[JScript]
public function ListControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


ListControl Properties

The properties of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property SelectionMode | Overridden. Gets or sets the method in which items are selected in the list control control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopItem | Gets the first fully-visible item in the list control control.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of items that can be fully visible in the list control control.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


AllowDrag Property

Lidor Systems IntegralUI Class Library

ListControl.AllowDrag Property

Determines whether the objects from ListControl control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ComparerObjectType Property

Lidor Systems IntegralUI Class Library

ListControl.ComparerObjectType Property

Gets or sets the type of objects in IComparer derived class.

[Visual Basic]
Public Property ComparerObjectType As ComparerObjectType
[C#]
public ComparerObjectType ComparerObjectType {get; set;}
[C++]
public: __property ComparerObjectType get_ComparerObjectType();
public: __property void set_ComparerObjectType(ComparerObjectType);
[JScript]
public function get ComparerObjectType() : ComparerObjectType;
public function set ComparerObjectType(ComparerObjectType);

Property Value

The ComparerObjectType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


DisabledItemStyle Property

Lidor Systems IntegralUI Class Library

ListControl.DisabledItemStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledItemStyle();
public: __property void set_DisabledItemStyle(ListItemColorStyle);
[JScript]
public function get DisabledItemStyle() : ListItemColorStyle;
public function set DisabledItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


DragDropMode Property

Lidor Systems IntegralUI Class Library

ListControl.DragDropMode Property

Gets or sets the type of drag-and-drop operation.

[Visual Basic]
Public Property DragDropMode As DragDropMode
[C#]
public DragDropMode DragDropMode {get; set;}
[C++]
public: __property DragDropMode get_DragDropMode();
public: __property void set_DragDropMode(DragDropMode);
[JScript]
public function get DragDropMode() : DragDropMode;
public function set DragDropMode(DragDropMode);

Property Value

The DragDropMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingEffect Property

Lidor Systems IntegralUI Class Library

ListControl.FadingEffect Property

Gets or sets an enumeration that determines the fading effect used during hovering over objects.

[Visual Basic]
Public Property FadingEffect As FadingEffect
[C#]
public FadingEffect FadingEffect {get; set;}
[C++]
public: __property FadingEffect get_FadingEffect();
public: __property void set_FadingEffect(FadingEffect);
[JScript]
public function get FadingEffect() : FadingEffect;
public function set FadingEffect(FadingEffect);

Property Value

The FadingEffect assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingSpeed Property

Lidor Systems IntegralUI Class Library

ListControl.FadingSpeed Property

Gets or sets an enumeration that determines the speed of fading used during hovering over objects.

[Visual Basic]
Public Property FadingSpeed As FadingSpeed
[C#]
public FadingSpeed FadingSpeed {get; set;}
[C++]
public: __property FadingSpeed get_FadingSpeed();
public: __property void set_FadingSpeed(FadingSpeed);
[JScript]
public function get FadingSpeed() : FadingSpeed;
public function set FadingSpeed(FadingSpeed);

Property Value

The FadingSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HideSelection Property

Lidor Systems IntegralUI Class Library

ListControl.HideSelection Property

Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection { get; set; }
[C++]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(bool );
[JScript]
public function get HideSelection() : bool
public function set HideSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverItemStyle Property

Lidor Systems IntegralUI Class Library

ListControl.HoverItemStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverItemStyle();
public: __property void set_HoverItemStyle(ListItemColorStyle);
[JScript]
public function get HoverItemStyle() : ListItemColorStyle;
public function set HoverItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverSelection Property

Lidor Systems IntegralUI Class Library

ListControl.HoverSelection Property

Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.

[Visual Basic]
Public Property HoverSelection As Boolean
[C#]
public bool HoverSelection { get; set; }
[C++]
public: __property bool get_HoverSelection();
public: __property void set_HoverSelection(bool );
[JScript]
public function get HoverSelection() : bool
public function set HoverSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

ListControl.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageList Property

Lidor Systems IntegralUI Class Library

ListControl.ImageList Property

Gets or sets the ImageList that contains the Image objects used by the ListControlItems.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemFormatStyle Property

Lidor Systems IntegralUI Class Library

ListControl.ItemFormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property ItemFormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle ItemFormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_ItemFormatStyle();
public: __property void set_ItemFormatStyle(ListItemFormatStyle);
[JScript]
public function get ItemFormatStyle() : ListItemFormatStyle;
public function set ItemFormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemHighlightType Property

Lidor Systems IntegralUI Class Library

ListControl.ItemHighlightType Property

Gets or sets the value indicating how the item is drawn.

[Visual Basic]
Public Property ItemHighlightType As ListItemHighlightType
[C#]
public ListItemHighlightType ItemHighlightType {get; set;}
[C++]
public: __property ListItemHighlightType get_ItemHighlightType();
public: __property void set_ItemHighlightType(ListItemHighlightType);
[JScript]
public function get ItemHighlightType() : ListItemHighlightType;
public function set ItemHighlightType(ListItemHighlightType);

Property Value

The ListItemHighlightType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemSpacing Property

Lidor Systems IntegralUI Class Library

ListControl.ItemSpacing Property

Gets or sets the vertical spacing between items.

[Visual Basic]
Public Property ItemSpacing As Integer
[C#]
public int ItemSpacing {get; set;}
[C++]
public: __property int get_ItemSpacing();
public: __property void set_ItemSpacing(int);
[JScript]
public function get ItemSpacing() : int;
public function set ItemSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Items Property

Lidor Systems IntegralUI Class Library

ListControl.Items Property

Gets the collection of items that are assigned to the list box control.

[Visual Basic]
Public ReadOnly Property Items As ListControlItemCollection
[C#]
public ListControlItemCollection Items {get;}
[C++]
public: __property ListControlItemCollection* get_Items();
[JScript]
public function get Items() : ListControlItemCollection;

Property Value

A ListControlItemCollection that represents the items assigned to the list box control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


KeySearchMode Property

Lidor Systems IntegralUI Class Library

ListControl.KeySearchMode Property

Specifies the search method for an item when key is pressed.

[Visual Basic]
Public Property KeySearchMode As KeySearchMode
[C#]
public KeySearchMode KeySearchMode {get; set;}
[C++]
public: __property KeySearchMode get_KeySearchMode();
public: __property void set_KeySearchMode(KeySearchMode);
[JScript]
public function get KeySearchMode() : KeySearchMode;
public function set KeySearchMode(KeySearchMode);

Property Value

The KeySearchMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListItemSorter Property

Lidor Systems IntegralUI Class Library

ListControl.ListItemSorter Property

Gets or sets the IComparer class used to sort the items in list control.

[Visual Basic]
Public Property ListItemSorter As IComparer
[C#]
public IComparer ListItemSorter {get; set;}
[C++]
public: __property IComparer get_ListItemSorter();
public: __property void set_ListItemSorter(IComparer);
[JScript]
public function get ListItemSorter() : IComparer;
public function set ListItemSorter(IComparer);

Property Value

The IComparer assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


NormalItemStyle Property

Lidor Systems IntegralUI Class Library

ListControl.NormalItemStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalItemStyle();
public: __property void set_NormalItemStyle(ListItemColorStyle);
[JScript]
public function get NormalItemStyle() : ListItemColorStyle;
public function set NormalItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Scrollable Property

Lidor Systems IntegralUI Class Library

ListControl.Scrollable Property

Gets or sets a value indicating whether the list control displays scroll bars when they are needed.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}
[C++]
public: __property bool get_Scrollable();
public: __property void set_Scrollable(bool);
[JScript]
public function get Scrollable() : Boolean;
public function set Scrollable(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollBarStyle Property

Lidor Systems IntegralUI Class Library

ListControl.ScrollBarStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ScrollBarStyle As ScrollBarStyle
[C#]
public ScrollBarStyle ScrollBarStyle {get; set;}
[C++]
public: __property ScrollBarStyle get_ScrollBarStyle();
public: __property void set_ScrollBarStyle(ScrollBarStyle);
[JScript]
public function get ScrollBarStyle() : ScrollBarStyle;
public function set ScrollBarStyle(ScrollBarStyle);

Property Value

The ScrollBarStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItem Property

Lidor Systems IntegralUI Class Library

ListControl.SelectedItem Property

Gets or sets the item that is currently selected in the list control.

[Visual Basic]
Public Property SelectedItem As ListControlItem
[C#]
public ListControlItem SelectedItem {get; set;}
[C++]
public: __property ListControlItem* get_SelectedItem();
public: __property void set_SelectedItem(ListControlItem*);
[JScript]
public function get SelectedItem() : ListControlItem;
public function set SelectedItem(ListControlItem);

Property Value

The ListControlItem that is currently selected in the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItemStyle Property

Lidor Systems IntegralUI Class Library

ListControl.SelectedItemStyle Property

Gets or sets the drawing style of selected item.

[Visual Basic]
Public Property SelectedItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedItemStyle();
public: __property void set_SelectedItemStyle(ListItemColorStyle);
[JScript]
public function get SelectedItemStyle() : ListItemColorStyle;
public function set SelectedItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowDropMarker Property

Lidor Systems IntegralUI Class Library

ListControl.ShowDropMarker Property

Gets or sets a value indicating whether a marker is shown during drag&drop operation.

[Visual Basic]
 Public Property ShowDropMarker As Boolean
[C#]
 public bool ShowDropMarker { get; set; }
[C++]
 public: __property bool
 get_ShowDropMarker();
public: __property void set_ShowDropMarker(bool );
[JScript]
public function get ShowDropMarker() : bool
public function set ShowDropMarker(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowToolTips Property

Lidor Systems IntegralUI Class Library

ListControl.ShowToolTips Property

Gets or sets a value indicating whether item tooltip is shown.

[Visual Basic]
Public Property ShowToolTips As Boolean
[C#]
public bool ShowToolTips { get; set; }
[C++]
public: __property bool get_ShowToolTips();
public: __property void set_ShowToolTips(bool );
[JScript]
public function get ShowToolTips() : bool
public function set ShowToolTips(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Sorting Property

Lidor Systems IntegralUI Class Library

ListControl.Sorting Property

Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.

[Visual Basic]
Public Property Sorting As SortOrder
[C#]
public SortOrder Sorting {get; set;}
[C++]
public: __property SortOrder get_Sorting();
public: __property void set_Sorting(SortOrder);
[JScript]
public function get Sorting() : SortOrder;
public function set Sorting(SortOrder);

Property Value

The SortOrder assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ToolTipStyle Property

Lidor Systems IntegralUI Class Library

ListControl.ToolTipStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ToolTipStyle As ToolTipStyle
[C#]
public ToolTipStyle ToolTipStyle {get; set;}
[C++]
public: __property ToolTipStyle get_ToolTipStyle();
public: __property void set_ToolTipStyle(ToolTipStyle);
[JScript]
public function get ToolTipStyle() : ToolTipStyle;
public function set ToolTipStyle(ToolTipStyle);

Property Value

The ToolTipStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


TopItem Property

Lidor Systems IntegralUI Class Library

ListControl.TopItem Property

Gets the first fully-visible item in the list control.

[Visual Basic]
Public ReadOnly Property TopItem As ListControlItem
[C#]
public ListControlItem TopItem {get;}
[C++]
public: __property ListControlItem* get_TopItem();
[JScript]
public function get TopItem() : ListControlItem;

Property Value

A ListControlItem that represents the first fully-visible item in the list box control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


VisibleCount Property

Lidor Systems IntegralUI Class Library

ListControl.VisibleCount Property

Gets the number of items that can be fully visible in the list control.

[Visual Basic]
Public ReadOnly Property VisibleCount As Integer
[C#]
public int VisibleCount {get;}
[C++]
public: __property int get_VisibleCount();
[JScript]
public function get VisibleCount() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


WatermarkImage Property

Lidor Systems IntegralUI Class Library

ListControl.WatermarkImage Property

Specifies the WatermarkImage object to use as a watermark.

[Visual Basic]
Public Property WatermarkImage As WatermarkImage
[C#]
public WatermarkImage WatermarkImage { get; set; }
[C++]
public: __property WatermarkImage* get_WatermarkImage();
public: __property void set_WatermarkImage(WatermarkImage*);
[JScript]
public function get WatermarkImage() : WatermarkImage
public function set WatermarkImage(WatermarkImage);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Methods

The methods of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EnsureVisible | Ensures that the specified item is visible, scrolling the list control control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
protected method FindItem | Finds the first item that begins with the given text value.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Overridden. Sorts the items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ListControl.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


EnsureVisible Method

Lidor Systems IntegralUI Class Library

ListControl.EnsureVisible Method

Ensures that the specified item is visible, scrolling the list control as necessary.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal index As Integer _
)
[C#]
 public void EnsureVisible(
   int index
);
[C++]
public: void EnsureVisible(
   int index
);
[JScript]
 public function EnsureVisible(
   index : int
);

Parameters

index
The 0-based index of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem Method

Lidor Systems IntegralUI Class Library

ListControl.FindItem Method

Finds the first item that begins with the given text value.

Overload List

Finds the first item that begins with the specified text value.

[Visual Basic] Overloads Public Function FindItem(String) As ListControlItem
[C#] public ListControlItem FindItem(String);
[C++] public: ListControlItem* FindItem(String);
[JScript] public function FindItem(String) : ListControlItem;

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index.

[Visual Basic] Overloads Public Function FindItem(String, Integer) As ListControlItem
[C#] public ListControlItem FindItem(String, int);
[C++] public: ListControlItem* FindItem(String, int);
[JScript]
public function FindItem(String, int) :
    ListControlItem;

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index. The matching criteria can be aplied.

[Visual Basic] Overloads Public Function FindItem(String, Integer, Boolean) As ListControlItem
[C#] public ListControlItem FindItem(String, int, bool);
[C++] public: ListControlItem* FindItem(String, int, bool);
[JScript]
public function FindItem(String, int, Boolean) :
    ListControlItem;

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String) Method

Lidor Systems IntegralUI Class Library

ListControl.FindItem (String) Method

Finds the first item that begins with the specified text value.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As String _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   String text
);
[C++]
public: ListControlItem* FindItem(
   String text
);
[JScript]
public function FindItem(
   text : String
) : ListControlItem;

Parameters

text
The String to search for.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String, Integer) Method

Lidor Systems IntegralUI Class Library

ListControl.FindItem (String, Integer) Method

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As string _
   ByVal startIndex As Integer _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   string text
   int startIndex
);
[C++]
public: ListControlItem* FindItem(
   string text
   int startIndex
);
[JScript]
public function FindItem(
   text : string
   startIndex : int
) : ListControlItem;

Parameters

text
The string to search for.
startIndex
The index of the item at which to start the search.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String, Integer, Boolean) Method

Lidor Systems IntegralUI Class Library

ListControl.FindItem (String, Integer, Boolean) Method

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index. The matching criteria can be aplied.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As string _
   ByVal startIndex As Integer _
   ByVal isPrefixSearch As Boolean _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   string text
   int startIndex
   bool isPrefixSearch
);
[C++]
public: ListControlItem* FindItem(
   string text
   int startIndex
   bool isPrefixSearch
);
[JScript]
public function FindItem(
   text : string
   startIndex : int
   isPrefixSearch : Boolean
) : ListControlItem;

Parameters

text
The string to search for.
startIndex
The index of the item at which to start the search.
isPrefixSearch
True to match the search text to the prefix of an item; otherwise False.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetClientRect Method

Lidor Systems IntegralUI Class Library

ListControl.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetDropPos (ListControlItem, Point) Method

Lidor Systems IntegralUI Class Library

ListControl.GetDropPos (ListControlItem, Point) Method

Returns the position at which item would be inserted in the item collection, during drag&drop operation.

[Visual Basic]
Overloads Public Function GetDropPos( _
   ByVal item As ListControlItem _
   ByVal mousePos As Point _
) As Integer
[C#]
public int GetDropPos(
   ListControlItem item
   Point mousePos
);
[C++]
public: int GetDropPos(
   ListControlItem item
   Point mousePos
);
[JScript]
public function GetDropPos(
   item : ListControlItem
   mousePos : Point
) : int;

Parameters

item
The ListControlItem that is currently targeted.
mousePos
The Point which represents the mouse cursor, in client coordinates.

Return Value

The index at which the dropped item would be inserted in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt Method

Lidor Systems IntegralUI Class Library

ListControl.GetItemAt Method

Retrieves the item that is at the specified location.

Overload List

Retrieves the item that is at the specified point.

[Visual Basic] Overloads Public Function GetItemAt(Point) As ListControlItem
[C#] public ListControlItem GetItemAt(Point);
[C++] public: ListControlItem* GetItemAt(Point);
[JScript] public function GetItemAt(Point) : ListControlItem;

Retrieves the item at the point with the specified coordinates.

[Visual Basic] Overloads Public Function GetItemAt(Integer, Integer) As ListControlItem
[C#] public ListControlItem GetItemAt(int, int);
[C++] public: ListControlItem* GetItemAt(int, int);
[JScript] public function GetItemAt(int, int) : ListControlItem;

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Point) Method

Lidor Systems IntegralUI Class Library

ListControl.GetItemAt (Point) Method

Retrieves the item that is at the specified point.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal pt As Point _
) As ListControlItem
[C#]
public ListControlItem GetItemAt(
   Point pt
);
[C++]
public: ListControlItem* GetItemAt(
   Point pt
);
[JScript]
public function GetItemAt(
   pt : Point
) : ListControlItem;

Parameters

pt
The Point to evaluate and retrieve the item from.

Return Value

The ListControlItem at the specified point, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Int32, Int32) Method

Lidor Systems IntegralUI Class Library

ListControl.GetItemAt (Int32, Int32) Method

Retrieves the item at the point with the specified coordinates.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As ListControlItem
[C#]
public ListControlItem GetItemAt(
   int x,
   int y
);
[C++]
public: ListControlItem* GetItemAt(
   int x,
   int y
);
[JScript]
public function GetItemAt(
   x : int,
   y : int
) : ListControlItem;

Parameters

x
The X position to evaluate and retrieve the item from.
y
The Y position to evaluate and retrieve the item from.

Return Value

The ListControlItem at the specified location, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetScrollPos Method

Lidor Systems IntegralUI Class Library

ListControl.GetScrollPos Method

Retrieves the current position of the horizontal and vertical scrollbar thumb.

[Visual Basic]
Overloads Public Function GetScrollPos() As Point
[C#]
public Point GetScrollPos();
[C++]
public: Point* GetScrollPos();
[JScript]
public function GetScrollPos() : Point;

Return Value

The current position of the horizontal and vertical scrollbar thumb.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnAfterSelect Method

Lidor Systems IntegralUI Class Library

ListControl.OnAfterSelect Method

Raises the AfterSelect event.

[Visual Basic]
Protected Overridable Sub OnAfterSelect( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterSelect(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterSelect(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnBeforeSelect Method

Lidor Systems IntegralUI Class Library

ListControl.OnBeforeSelect Method

Raises the BeforeSelect event.

[Visual Basic]
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeSelect(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeSelect(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeSelect(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdded Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemAdded Method

Raises the ItemAdded event.

[Visual Basic]
Protected Overridable Sub OnItemAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdding Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemAdding Method

Raises the ItemAdding event.

[Visual Basic]
Protected Overridable Sub OnItemAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemDrag Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemDrag Method

Raises the ItemDrag event.

[Visual Basic]
Protected Overridable Sub OnItemDrag( _
   ByVal e As ItemDragEventArgs _
)
[C#]
protected virtual void OnItemDrag(
   ItemDragEventArgs e
);
[C++]
protected: virtual void OnItemDrag(
   ItemDragEventArgs* e
);
[JScript]
protected function OnItemDrag(
   e : ItemDragEventArgs
);

Parameters

e
A ItemDragEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemMouseHover Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemMouseHover Method

Raises the ItemMouseHover event.

[Visual Basic]
Protected Overridable Sub OnItemMouseHover( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemMouseHover(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemMouseHover(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemMouseHover(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoved Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemRemoved Method

Raises the ItemRemoved event.

[Visual Basic]
Protected Overridable Sub OnItemRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoving Method

Lidor Systems IntegralUI Class Library

ListControl.OnItemRemoving Method

Raises the ItemRemoving event.

[Visual Basic]
Protected Overridable Sub OnItemRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnScrollBarVisibilityChanged Method

Lidor Systems IntegralUI Class Library

ListControl.OnScrollBarVisibilityChanged Method

Raises the ScrollBarVisibilityChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollBarVisibilityChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollBarVisibilityChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollBarVisibilityChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollBarVisibilityChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnScrollPosChanged Method

Lidor Systems IntegralUI Class Library

ListControl.OnScrollPosChanged Method

Raises the ScrollPosChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollPosChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollPosChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollPosChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollPosChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SetScrollPos (Point) Method

Lidor Systems IntegralUI Class Library

ListControl.SetScrollPos (Point) Method

Sets the position of the horizontal and vertical scroll bar thumb.

[Visual Basic]
 Public Sub SetScrollPos( _
   ByVal pt As Point _
)
[C#]
public void SetScrollPos(
   Point pt
);
[C++]
public: void SetScrollPos(
   Point pt
);
[JScript]
public function SetScrollPos(
   pt : Point
);

Parameters

pt
The Point at which the horizontal and vertical scroll bar thumb will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Sort Method

Lidor Systems IntegralUI Class Library

ListControl.Sort Method

Sorts the items in the list view control.

[Visual Basic]
Public Overloads Overrides Sub Sort()
[C#]
public override void Sort();
[C++]
 public: override void * Sort();
[JScript]
public function Sort() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


StopFadingEffect Method

Lidor Systems IntegralUI Class Library

ListControl.StopFadingEffect Method

Stops the fading of items in the list control.

[Visual Basic]
Public Overridable Sub StopFadingEffect()
[C#]
public virtual void StopFadingEffect();
[C++]
 public: virtual void * StopFadingEffect();
[JScript]
public function StopFadingEffect() ;

Remarks

Use this method to mannualy stop the fading of items in list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

ListControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Events

The events of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the ListControlItem is added.
public event ItemAdding | OOccurs before the ListControlItem is added.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the ListControlItem is removed.
public event ItemRemoving | Occurs before the ListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


AfterSelect Event

Lidor Systems IntegralUI Class Library

ListControl.AfterSelect Event

Occurs after the item is selected.

[Visual Basic]
Public Event AfterSelect As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterSelect;
[C++]
public: __event ObjectEventHandler* AfterSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


BeforeSelect Event

Lidor Systems IntegralUI Class Library

ListControl.BeforeSelect Event

Occurs before the item is selected.

[Visual Basic]
Public Event BeforeSelect As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeSelect;
[C++]
public: __event ObjectCancelEventHandler* BeforeSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdded Event

Lidor Systems IntegralUI Class Library

ListControl.ItemAdded Event

Occurs after the ListControlItem is added.

[Visual Basic]
Public Event ItemAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemAdded;
[C++]
public: __event ObjectEventHandler* ItemAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdding Event

Lidor Systems IntegralUI Class Library

ListControl.ItemAdding Event

OOccurs before the ListControlItem is added.

[Visual Basic]
Public Event ItemAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemAdding;
[C++]
public: __event ObjectCancelEventHandler* ItemAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemDrag Event

Lidor Systems IntegralUI Class Library

ListControl.ItemDrag Event

Occurs when the user begins dragging an item.

[Visual Basic]
Public Event ItemDrag As ItemDragEventHandler
[C#]
public event ItemDragEventHandler ItemDrag;
[C++]
public: __event ItemDragEventHandler* ItemDrag;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ItemDragEventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemMouseHover Event

Lidor Systems IntegralUI Class Library

ListControl.ItemMouseHover Event

Occurs when the mouse cursor hovers for some time over an item space.

[Visual Basic]
Public Event ItemMouseHover As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemMouseHover;
[C++]
public: __event ObjectEventHandler* ItemMouseHover;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoved Event

Lidor Systems IntegralUI Class Library

ListControl.ItemRemoved Event

Occurs after the ListControlItem is removed.

[Visual Basic]
Public Event ItemRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemRemoved;
[C++]
public: __event ObjectEventHandler* ItemRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoving Event

Lidor Systems IntegralUI Class Library

ListControl.ItemRemoving Event

Occurs before the ListControlItem is removed.

[Visual Basic]
Public Event ItemRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemRemoving;
[C++]
public: __event ObjectCancelEventHandler* ItemRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollBarVisibilityChanged Event

Lidor Systems IntegralUI Class Library

ListControl.ScrollBarVisibilityChanged Event

Occurs when visibility of horizontal or vertical scrollbar has changed.

[Visual Basic]
Public Event ScrollBarVisibilityChanged As EventHandler
[C#]
public event EventHandler ScrollBarVisibilityChanged;
[C++]
public: __event EventHandler* ScrollBarVisibilityChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollPosChanged Event

Lidor Systems IntegralUI Class Library

ListControl.ScrollPosChanged Event

Occurs when position of scrollbar has changed.

[Visual Basic]
Public Event ScrollPosChanged As EventHandler
[C#]
public event EventHandler ScrollPosChanged;
[C++]
public: __event EventHandler* ScrollPosChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Class

A class representing the items in the ListControl control.

For a list of all members of this type, see ListControlItem Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ListControlItem

[Visual Basic]

Public Class ListControlItem
   Inherits LidorSystems.IntegralUI.ObjectBase
[C#]

 public class ListControlItem : LidorSystems.IntegralUI.ObjectBase
[C++]

public __gc class ListControlItem : public LidorSystems.IntegralUI.ObjectBase
[JScript]
public

class ListControlItem extends LidorSystems.IntegralUI.ObjectBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls.ListControl (in LidorSystems.IntegralUI.Controls.ListControl.dll)

See Also

ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Members

ListControlItem overview

Public Constructors

public constructor ListControlItem Constructor Initializes a new instance of the ListControlItem class.

Public Properties

public property Bounds | Overridden. Gets the bounds of the item.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageRect | Gets the rectangle of item's image.
public property Index | Overridden. Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent list box control that the item is assigned to.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State | Overridden. Gets a value indicating the current state of the object.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property TextRect | Gets the rectangle of item's text.
public property TextSize | Gets the size of item's text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EnsureVisible | Ensures that the item is visible, scrolling the list view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Check whether the item is present in the current visible space of the list box control.
public method Move | Moves the item to the specified position in the item collection.
public method Remove | Removes the current item from the item collection.
public method RepaintParent | Overridden. Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Overridden. Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor

Initializes a new instance of the ListControlItem class.

Overload List

Initializes a new instance of the ListControlItem class.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New()
[C#] public ListControlItem();
[C++] public: ListControlItem();
[JScript] public function ListControlItem();

Initializes a new instance of the ListControlItem class with the specified text.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New(String)
[C#] public ListControlItem(string);
[C++] public: ListControlItem(String*);
[JScript] public function ListControlItem(String);

Initializes a new instance of the ListControlItem class with the specified text and image.

[Visual Basic] Public Sub New(String, Integer)
[C#] public ListControlItem(string, int);
[C++] public: ListControlItem(String*, int);
[JScript] public function ListControlItem(String, int);

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Properties

The properties of the ListControlItem class are listed here. For a complete list of ListControlItem class members, see the ListControlItem Members topic.

Public Properties

public property Bounds | Overridden. Gets the bounds of the item.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageRect | Gets the rectangle of item's image.
public property Index | Overridden. Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent list box control that the item is assigned to.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State | Overridden. Gets a value indicating the current state of the object.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property TextRect | Gets the rectangle of item's text.
public property TextSize | Gets the size of item's text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Bounds Property

Lidor Systems IntegralUI Class Library

ListControlItem.Bounds Property

Gets the bounds of the item.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}
[C++]
public: __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


DisabledStyle Property

Lidor Systems IntegralUI Class Library

ListControlItem.DisabledStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledStyle();
public: __property void set_DisabledStyle(ListItemColorStyle);
[JScript]
public function get DisabledStyle() : ListItemColorStyle;
public function set DisabledStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

Lidor Systems IntegralUI Class Library

ListControlItem.FormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property FormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle FormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ListItemFormatStyle);
[JScript]
public function get FormatStyle() : ListItemFormatStyle;
public function set FormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


HoverStyle Property

Lidor Systems IntegralUI Class Library

ListControlItem.HoverStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverStyle();
public: __property void set_HoverStyle(ListItemColorStyle);
[JScript]
public function get HoverStyle() : ListItemColorStyle;
public function set HoverStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ImageRect Property

Lidor Systems IntegralUI Class Library

ListControlItem.ImageRect Property

Gets the rectangle of item's image.

[Visual Basic]
Public ReadOnly Property ImageRect As Rectangle
[C#]
public Rectangle ImageRect {get;}
[C++]
public: __property Rectangle get_ImageRect();
[JScript]
public function get ImageRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for item's image, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


Index Property

Lidor Systems IntegralUI Class Library

ListControlItem.Index Property

Overridden. Gets the position of the item in the item collection.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Property Value

A zero-based index value that represents the position of the item in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


NormalStyle Property

Lidor Systems IntegralUI Class Library

ListControlItem.NormalStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalStyle();
public: __property void set_NormalStyle(ListItemColorStyle);
[JScript]
public function get NormalStyle() : ListItemColorStyle;
public function set NormalStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


Parent Property

Lidor Systems IntegralUI Class Library

ListControlItem.Parent Property

Gets the parent list control that the item is assigned to.

[Visual Basic]
Public ReadOnly Property Parent As ListControl
[C#]
public ListControl Parent {get;}
[C++]
public: __property ListControl* get_Parent();
[JScript]
public function get Parent() : ListControl;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


SelectedStyle Property

Lidor Systems IntegralUI Class Library

ListControlItem.SelectedStyle Property

Gets or sets the drawing style of the selected item.

[Visual Basic]
Public Property SelectedStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedStyle();
public: __property void set_SelectedStyle(ListItemColorStyle);
[JScript]
public function get SelectedStyle() : ListItemColorStyle;
public function set SelectedStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


SortTag Property

Lidor Systems IntegralUI Class Library

ListControlItem.SortTag Property

Gets or sets the object that contains sorting data about the item.

[Visual Basic]
Public Property SortTag As Object
[C#]
public object SortTag {get; set;}
[C++]
public: __property Object* get_SortTag();
public: __property void set_SortTag(Object*);
[JScript]
public function get SortTag() : Object;
public function set SortTag(Object);

Property Value

An Object that contains sorting data about the item. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


State Property

Lidor Systems IntegralUI Class Library

ListControlItem.State Property

Overridden. Gets a value indicating the current state of the item.

[Visual Basic]
Public Overrides Overloads ReadOnly Property State As ObjectState
[C#]
public override ObjectState State {get;}
[C++]
public: override __property ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


StyleFromParent Property

Lidor Systems IntegralUI Class Library

ListControlItem.StyleFromParent Property

Determines whether the item should use style from his parent, to draw.

[Visual Basic]
Public Property StyleFromParent As Boolean
[C#]
public bool StyleFromParent {get; set;}
[C++]
public: __property bool get_StyleFromParent();
public: __property void set_StyleFromParent(bool);
[JScript]
public function get StyleFromParent() : Boolean;
public function set StyleFromParent(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

Lidor Systems IntegralUI Class Library

ListControlItem.TextRect Property

Gets the rectangle of item's text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for item's text, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


TextSize Property

Lidor Systems IntegralUI Class Library

ListControlItem.TextSize Property

Gets the size of item's text.

[Visual Basic]
Public ReadOnly Property TextSize As Size
[C#]
public Size TextSize {get;}
[C++]
public: __property Size get_TextSize();
[JScript]
public function get TextSize() : Size;

Property Value

The Size of the item's text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ToolTip Property

Lidor Systems IntegralUI Class Library

ListControlItem.ToolTip Property

Gets or sets the item's tooltip text.

[Visual Basic]
Public Property ToolTip As String
[C#]
public String ToolTip {get; set;}
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String*);
[JScript]
public function get ToolTip() : String;
public function set ToolTip(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Methods

The methods of the ListControlItem class are listed here. For a complete list of ListControlItem class members, see the ListControlItem Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EnsureVisible | Ensures that the item is visible, scrolling the list view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Check whether the item is present in the current visible space of the list box control.
public method Move | Moves the item to the specified position in the item collection.
public method Remove | Removes the current item from the item collection.
public method RepaintParent | Overridden. Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Overridden. Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ListBoxItem.Clone Method

Overridden. Creates an exact copy of the current ListBoxItem.

[Visual Basic]
Public Overrides Overloads  Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: override Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ListBoxItem object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

Lidor Systems IntegralUI Class Library

ListBoxItem.EnsureVisible Method

Ensures that the item is visible, scrolling the list view control as necessary.

[Visual Basic]
Public Sub EnsureVisible()
[C#]
public void EnsureVisible();
[C++]
 public: void EnsureVisible();
[JScript]
public function EnsureVisible();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


IsVisible Method

Lidor Systems IntegralUI Class Library

ListBoxItem.IsVisible Method

Check whether the item is present in the current visible space of the list box control.

[Visual Basic]
Public Function IsVisible() As Boolean
[C#]
public bool IsVisible();
[C++]
public: bool IsVisible();
[JScript]
public function IsVisible() : Boolean;

Return Value

True if the item is present, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


Move Method

Lidor Systems IntegralUI Class Library

ListBoxItem.Move Method

Moves the item to the specified position in the item collection.

[Visual Basic]
public  Sub Move( _
   ByVal direction As ListItemMoveDirection _
)
[C#]
public void Move(
   ListItemMoveDirection direction
);
[C++]
public: void Move(
   ListItemMoveDirection* direction
);
[JScript]
public  function Move(
   direction : ListItemMoveDirection
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


Remove Method

Lidor Systems IntegralUI Class Library

ListBoxItem.Remove Method

Removes the current item from the item collection.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();
[C++]
 public: void Remove();
[JScript]
public function Remove();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


RepaintParent Method

Lidor Systems IntegralUI Class Library

ListBoxItem.RepaintParent Method

Invalidates the parent client area to repaint the item's changes.

[Visual Basic]
Public Overrides Overloads Sub RepaintParent()
[C#]
public override void RepaintParent();
[C++]
 public: override void RepaintParent();
[JScript]
public function RepaintParent();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


UpdateParent Method

Lidor Systems IntegralUI Class Library

ListBoxItem.UpdateParent Method

Updates the parent layout with item's changes.

[Visual Basic]
Public Overrides Overloads Sub UpdateParent()
[C#]
public override void UpdateParent();
[C++]
 public: override void UpdateParent();
[JScript]
public function UpdateParent();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


MonthCalendar Class

Represents a control that enables selection of a date using calendar.

For a list of all members of this type, see MonthCalendar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.MonthCalendar

[Visual Basic]
 Public Class MonthCalendar
   Inherits Control
[C#]
public class MonthCalendar : Control
[C++]
 public __gc class MonthCalendar : public Control
[JScript]
public class MonthCalendar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Members

MonthCalendar overview

Public Constructors

public constructor MonthCalendar Constructor Initializes a new instance of the MonthCalendar class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DateFormatStyle | Gets or sets the format style of the current date.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledHeaderButtonStyle | Gets or sets the drawing style of header command buttons in disabled state.
public property DisabledHeaderStyle | Gets or sets the drawing style when control header is disabled.
public property DisplayMode | Determines how date is displayed.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FirstDayOfWeek | Gets or sets the first day of the week.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HeaderButtonFormatStyle | Gets or sets the formatting style of header command buttons.
public property HeaderFormatStyle | Gets or sets the format style of the control header.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverDateStyle | Gets or sets the drawing style of date in hover state.
public property HoverHeaderButtonStyle | Gets or sets the drawing style of header command buttons in hover state.
public property HoverHeaderStyle | Gets or sets the drawing style when control header is hovered.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaxDate | Determines the maximum date that can be set in MonthCalendar control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinDate | Determines the minimum date that can be set in MonthCalendar control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property MonthHeaderStyle | Gets or sets the drawing style of the month header.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalDateStyle | Gets or sets the drawing style of date in normal state.
public property NormalHeaderButtonStyle | Gets or sets the drawing style of header command buttons in normal state.
public property NormalHeaderStyle | Gets or sets the default drawing style of the control header.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedDate | Gets or sets currently selected date.
public property SelectedDateStyle | Gets or sets the drawing style of date in selected state.
public property SelectedHeaderButtonStyle | Gets or sets the drawing style of header command buttons in selected state.
public property SelectedHeaderStyle | Gets or sets the drawing style when control header is selected.
public property ShowTrailingDays | Determines whether the control will display days from previous and next month.
public property ShowWeekNumbers | Determines whether the control will display the week numbers.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Spacing | Gets or sets the spacing between objects.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TodayDate | Gets or sets the current date.
public property TodayDateStyle | Gets or sets the drawing style of the current date.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TrailingDateStyle | Gets or sets the drawing style of the trailing date.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event DateChanged | Occurs when the date selected in the MonthCalendar changes.
public event DateSelected | Occurs when the user makes an explicit date selection using the mouse.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDateChangedMethod | Raises the DateChanged event.
protected method OnDateSelectedMethod | Raises the DateSelected event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Constructor ()

Initializes a new instance of the MonthCalendar class.

[Visual Basic]
Public Sub New()
[C#]
public MonthCalendar();
[C++]
public: MonthCalendar();
[JScript]
public function MonthCalendar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Properties

The properties of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DateFormatStyle | Gets or sets the format style of the current date.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledHeaderButtonStyle | Gets or sets the drawing style of header command buttons in disabled state.
public property DisabledHeaderStyle | Gets or sets the drawing style when control header is disabled.
public property DisplayMode | Determines how date is displayed.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FirstDayOfWeek | Gets or sets the first day of the week.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HeaderButtonFormatStyle | Gets or sets the formatting style of header command buttons.
public property HeaderFormatStyle | Gets or sets the format style of the control header.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverDateStyle | Gets or sets the drawing style of date in hover state.
public property HoverHeaderButtonStyle | Gets or sets the drawing style of header command buttons in hover state.
public property HoverHeaderStyle | Gets or sets the drawing style when control header is hovered.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaxDate | Determines the maximum date that can be set in MonthCalendar control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinDate | Determines the minimum date that can be set in MonthCalendar control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property MonthHeaderStyle | Gets or sets the drawing style of the month header.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalDateStyle | Gets or sets the drawing style of date in normal state.
public property NormalHeaderButtonStyle | Gets or sets the drawing style of header command buttons in normal state.
public property NormalHeaderStyle | Gets or sets the default drawing style of the control header.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedDate | Gets or sets currently selected date.
public property SelectedDateStyle | Gets or sets the drawing style of date in selected state.
public property SelectedHeaderButtonStyle | Gets or sets the drawing style of header command buttons in selected state.
public property SelectedHeaderStyle | Gets or sets the drawing style when control header is selected.
public property ShowTrailingDays | Determines whether the control will display days from previous and next month.
public property ShowWeekNumbers | Determines whether the control will display the week numbers.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Spacing | Gets or sets the spacing between objects.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TodayDate | Gets or sets the current date.
public property TodayDateStyle | Gets or sets the drawing style of the current date.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TrailingDateStyle | Gets or sets the drawing style of the trailing date.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


DateFormatStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.DateFormatStyle Property

Gets or sets the format style of the current date.

[Visual Basic]
Public Property DateFormatStyle As BorderStyle
[C#]
public BorderStyle DateFormatStyle {get; set;}
[C++]
public: __property BorderStyle get_DateFormatStyle();
public: __property void set_DateFormatStyle(BorderStyle);
[JScript]
public function get DateFormatStyle() : BorderStyle;
public function set DateFormatStyle(BorderStyle);

Property Value

The BorderStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisabledHeaderButtonStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.DisabledHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in disabled state.

[Visual Basic]
Public Property DisabledHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledHeaderButtonStyle();
public: __property void set_DisabledHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledHeaderButtonStyle() : CommandButtonColorStyle;
public function set DisabledHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisabledHeaderStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.DisabledHeaderStyle Property

Gets or sets the drawing style when control header is disabled.

[Visual Basic]
Public Property DisabledHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle DisabledHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_DisabledHeaderStyle();
public: __property void set_DisabledHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get DisabledHeaderStyle() : ControlHeaderColorStyle;
public function set DisabledHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisplayMode Property

Lidor Systems IntegralUI Class Library

MonthCalendar.DisplayMode Property

Determines how date is displayed.

[Visual Basic]
Public Property DisplayMode As CalendarDisplayMode
[C#]
public CalendarDisplayMode DisplayMode {get; set;}
[C++]
public: __property CalendarDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(CalendarDisplayMode);
[JScript]
public function get DisplayMode() : CalendarDisplayMode;
public function set DisplayMode(CalendarDisplayMode);

Property Value

The CalendarDisplayMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


FirstDayOfWeek Property

Lidor Systems IntegralUI Class Library

MonthCalendar.FirstDayOfWeek Property

Gets or sets the first day of the week.

[Visual Basic]
Public Property FirstDayOfWeek As Day
[C#]
public Day FirstDayOfWeek {get; set;}
[C++]
public: __property Day get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(Day);
[JScript]
public function get FirstDayOfWeek() : Day;
public function set FirstDayOfWeek(Day);

Property Value

The Day assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HeaderButtonFormatStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.HeaderButtonFormatStyle Property

Gets or sets the formatting style of header command buttons.

[Visual Basic]
Public Property HeaderButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle HeaderButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_HeaderButtonFormatStyle();
public: __property void set_HeaderButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get HeaderButtonFormatStyle() : CommandButtonFormatStyle;
public function set HeaderButtonFormatStyle(CommandButtonFormatStyle);

Property Value

A CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HeaderFormatStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.HeaderFormatStyle Property

Gets or sets the format style of the control header.

[Visual Basic]
Public Property HeaderFormatStyle As ControlHeaderFormatStyle
[C#]
public ControlHeaderFormatStyle HeaderFormatStyle {get; set;}
[C++]
public: __property ControlHeaderFormatStyle get_HeaderFormatStyle();
public: __property void set_HeaderFormatStyle(ControlHeaderFormatStyle);
[JScript]
public function get HeaderFormatStyle() : ControlHeaderFormatStyle;
public function set HeaderFormatStyle(ControlHeaderFormatStyle);

Property Value

A ControlHeaderFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverDateStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.HoverDateStyle Property

Gets or sets the drawing style of date in hover state.

[Visual Basic]
Public Property HoverDateStyle As ControlColorStyle
[C#]
public ControlColorStyle HoverDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_HoverDateStyle();
public: __property void set_HoverDateStyle(ControlColorStyle);
[JScript]
public function get HoverDateStyle() : ControlColorStyle;
public function set HoverDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverHeaderButtonStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.HoverHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in hover state.

[Visual Basic]
Public Property HoverHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverHeaderButtonStyle();
public: __property void set_HoverHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverHeaderButtonStyle() : CommandButtonColorStyle;
public function set HoverHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverHeaderStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.HoverHeaderStyle Property

Gets or sets the drawing style when control header is hovered.

[Visual Basic]
Public Property HoverHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle HoverHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_HoverHeaderStyle();
public: __property void set_HoverHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get HoverHeaderStyle() : ControlHeaderColorStyle;
public function set HoverHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MaxDate Property

Lidor Systems IntegralUI Class Library

MonthCalendar.MaxDate Property

Determines the maximum date that can be set in MonthCalendar control.

[Visual Basic]
Public Overrides Overloads Property MaxDate As DateTime
[C#]
public override DateTime MaxDate {get; set;}
[C++]
public: override __property DateTime get_MaxDate();
public: override __property void set_MaxDate(DateTime);
[JScript]
public function get MaxDate() : DateTime;
public function set MaxDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MinDate Property

Lidor Systems IntegralUI Class Library

MonthCalendar.MinDate Property

Determines the minimum date that can be set in MonthCalendar control.

[Visual Basic]
Public Overrides Overloads Property MinDate As DateTime
[C#]
public override DateTime MinDate {get; set;}
[C++]
public: override __property DateTime get_MinDate();
public: override __property void set_MinDate(DateTime);
[JScript]
public function get MinDate() : DateTime;
public function set MinDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthHeaderStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.MonthHeaderStyle Property

Gets or sets the drawing style of the month header.

[Visual Basic]
Public Property MonthHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle MonthHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_MonthHeaderStyle();
public: __property void set_MonthHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get MonthHeaderStyle() : ControlHeaderColorStyle;
public function set MonthHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalDateStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.NormalDateStyle Property

Gets or sets the drawing style of date in normal state.

[Visual Basic]
Public Property NormalDateStyle As ControlColorStyle
[C#]
public ControlColorStyle NormalDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_NormalDateStyle();
public: __property void set_NormalDateStyle(ControlColorStyle);
[JScript]
public function get NormalDateStyle() : ControlColorStyle;
public function set NormalDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalHeaderButtonStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.NormalHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in normal state.

[Visual Basic]
Public Property NormalHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalHeaderButtonStyle();
public: __property void set_NormalHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalHeaderButtonStyle() : CommandButtonColorStyle;
public function set NormalHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalHeaderStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.NormalHeaderStyle Property

Gets or sets the default drawing style of the control header.

[Visual Basic]
Public Property NormalHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle NormalHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_NormalHeaderStyle();
public: __property void set_NormalHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get NormalHeaderStyle() : ControlHeaderColorStyle;
public function set NormalHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedDate Property

Lidor Systems IntegralUI Class Library

MonthCalendar.SelectedDate Property

Gets or sets currently selected date.

[Visual Basic]
Public Overrides Overloads Property SelectedDate As DateTime
[C#]
public override DateTime SelectedDate {get; set;}
[C++]
public: override __property DateTime get_SelectedDate();
public: override __property void set_SelectedDate(DateTime);
[JScript]
public function get SelectedDate() : DateTime;
public function set SelectedDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedDateStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.SelectedDateStyle Property

Gets or sets the drawing style of date in selected state.

[Visual Basic]
Public Property SelectedDateStyle As ControlColorStyle
[C#]
public ControlColorStyle SelectedDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_SelectedDateStyle();
public: __property void set_SelectedDateStyle(ControlColorStyle);
[JScript]
public function get SelectedDateStyle() : ControlColorStyle;
public function set SelectedDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedHeaderButtonStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.SelectedHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in selected state.

[Visual Basic]
Public Property SelectedHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedHeaderButtonStyle();
public: __property void set_SelectedHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedHeaderButtonStyle() : CommandButtonColorStyle;
public function set SelectedHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedHeaderStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.SelectedHeaderStyle Property

Gets or sets the drawing style when control header is selected.

[Visual Basic]
Public Property SelectedHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle SelectedHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_SelectedHeaderStyle();
public: __property void set_SelectedHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get SelectedHeaderStyle() : ControlHeaderColorStyle;
public function set SelectedHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


ShowTrailingDays Property

Lidor Systems IntegralUI Class Library

MonthCalendar.ShowTrailingDays Property

Determines whether the control will display days from previous and next month.

[Visual Basic]
Public Overridable Property ShowTrailingDays As Boolean
[C#]
public virtual bool ShowTrailingDays { get; set; }
[C++]
public: __property virtual bool get_ShowTrailingDays();
 public:
__property virtual void set_ShowTrailingDays(bool );
[JScript]
public function get ShowTrailingDays() : bool
public function set ShowTrailingDays(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


ShowWeekNumbers Property

Lidor Systems IntegralUI Class Library

MonthCalendar.ShowWeekNumbers Property

Determines whether the control will display the week numbers.

[Visual Basic]
Public Overridable Property ShowWeekNumbers As Boolean
[C#]
public virtual bool ShowWeekNumbers { get; set; }
[C++]
public: __property virtual bool get_ShowWeekNumbers();
 public:
__property virtual void set_ShowWeekNumbers(bool );
[JScript]
public function get ShowWeekNumbers() : bool
public function set ShowWeekNumbers(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


Spacing Property

Lidor Systems IntegralUI Class Library

MonthCalendar.Spacing Property

Gets or sets the spacing between objects.

[Visual Basic]
Public Property Spacing As Integer
[C#]
public int Spacing {get; set;}
[C++]
public: __property int get_Spacing();
public: __property void set_Spacing(int);
[JScript]
public function get Spacing() : int;
public function set Spacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TodayDate Property

Lidor Systems IntegralUI Class Library

MonthCalendar.TodayDate Property

Gets or sets the current date.

[Visual Basic]
Public Overrides Overloads Property TodayDate As DateTime
[C#]
public override DateTime TodayDate {get; set;}
[C++]
public: override __property DateTime get_TodayDate();
public: override __property void set_TodayDate(DateTime);
[JScript]
public function get TodayDate() : DateTime;
public function set TodayDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TodayDateStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.TodayDateStyle Property

Gets or sets the drawing style of the current date.

[Visual Basic]
Public Property TodayDateStyle As ControlColorStyle
[C#]
public ControlColorStyle TodayDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_TodayDateStyle();
public: __property void set_TodayDateStyle(ControlColorStyle);
[JScript]
public function get TodayDateStyle() : ControlColorStyle;
public function set TodayDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TrailingDateStyle Property

Lidor Systems IntegralUI Class Library

MonthCalendar.TrailingDateStyle Property

Gets or sets the drawing style of the trailing date.

[Visual Basic]
Public Property TrailingDateStyle As ControlColorStyle
[C#]
public ControlColorStyle TrailingDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_TrailingDateStyle();
public: __property void set_TrailingDateStyle(ControlColorStyle);
[JScript]
public function get TrailingDateStyle() : ControlColorStyle;
public function set TrailingDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Methods

The methods of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDateChangedMethod | Raises the DateChanged event.
protected method OnDateSelectedMethod | Raises the DateSelected event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

MonthCalendar.Dispose Method

Releases all resources used by this MonthCalendar object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


OnDateChanged Method

Lidor Systems IntegralUI Class Library

MonthCalendar.OnDateChanged Method

Raises the DateChanged event.

[Visual Basic]
Protected Sub OnDateChanged( _
   ByVal e As DateRangeEventArgsClass _
)
[C#]
 protected void OnDateChanged(
   DateRangeEventArgsClass e
);
[C++]
 protected: void OnDateChanged(
   DateRangeEventArgsClass* e
);
[JScript]
protected function OnDateChanged(
   e : DateRangeEventArgsClass
);

Parameters

e
A DateRangeEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


OnDateSelected Method

Lidor Systems IntegralUI Class Library

MonthCalendar.OnDateSelected Method

Raises the DateSelected event.

[Visual Basic]
Protected Sub OnDateSelected( _
   ByVal e As DateRangeEventArgsClass _
)
[C#]
 protected void OnDateSelected(
   DateRangeEventArgsClass e
);
[C++]
 protected: void OnDateSelected(
   DateRangeEventArgsClass* e
);
[JScript]
protected function OnDateSelected(
   e : DateRangeEventArgsClass
);

Parameters

e
A DateRangeEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

MonthCalendar.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Events

The events of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event DateChanged | Occurs when the date selected in the MonthCalendar changes.
public event DateSelected | Occurs when the user makes an explicit date selection using the mouse.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


DateChanged Event

Lidor Systems IntegralUI Class Library

MonthCalendar.DateChanged Event

Occurs when the date selected in the MonthCalendar changes.

[Visual Basic]
Public Event DateChanged As DateRangeEventHandler
[C#]
public event DateRangeEventHandler DateChanged;
[C++]
public: __event DateRangeEventHandler* DateChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type DateRangeEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DateSelected Event

Lidor Systems IntegralUI Class Library

MonthCalendar.DateSelected Event

Occurs when the user makes an explicit date selection using the mouse.

[Visual Basic]
Public Event DateSelected As DateRangeEventHandler
[C#]
public event DateRangeEventHandler DateSelected;
[C++]
public: __event DateRangeEventHandler* DateSelected;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type DateRangeEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Class

Represents a up-down control that displays numeric values.

For a list of all members of this type, see NumericUpDown Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.NumericUpDown

[Visual Basic]
 Public Class NumericUpDown
   Inherits Control
[C#]
public class NumericUpDown : Control
[C++]
 public __gc class NumericUpDown : public Control
[JScript]
public class NumericUpDown extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Members

NumericUpDown overview

Public Constructors

public constructor NumericUpDown Constructor Initializes a new instance of the NumericUpDown class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowInput | Determines whether the value can also be inserted from edit box.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonAlign | Indicates how control will align buttons relative to its edit box.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DecimalPlaces | Gets or sets the number of decimal places.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DownLeftButtonRect | Gets the space reserved for down-left button.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased from button clicks.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThousandsSeparator | Determines whether the thousands separator will be inserted between every three decimal digits.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UpRightButtonRect | Gets the space reserved for up-right button.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in the control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in the control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Constructor ()

Initializes a new instance of the NumericUpDown class.

[Visual Basic]
Public Sub New()
[C#]
public NumericUpDown();
[C++]
public: NumericUpDown();
[JScript]
public function NumericUpDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Properties

The properties of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowInput | Determines whether the value can also be inserted from edit box.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonAlign | Indicates how control will align buttons relative to its edit box.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DecimalPlaces | Gets or sets the number of decimal places.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DownLeftButtonRect | Gets the space reserved for down-left button.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased from button clicks.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThousandsSeparator | Determines whether the thousands separator will be inserted between every three decimal digits.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UpRightButtonRect | Gets the space reserved for up-right button.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


AllowInput Property

Lidor Systems IntegralUI Class Library

NumericUpDown.AllowInput Property

Determines whether the value can also be inserted from edit box.

[Visual Basic]
Public Overridable Property AllowInput As Boolean
[C#]
public virtual bool AllowInput { get; set; }
[C++]
public: __property virtual bool get_AllowInput();
 public:
__property virtual void set_AllowInput(bool );
[JScript]
public function get AllowInput() : bool
public function set AllowInput(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonAlign Property

Lidor Systems IntegralUI Class Library

NumericUpDown.ButtonAlign Property

Indicates how control will align buttons relative to its edit box.

[Visual Basic]
Public Property ButtonAlign As NumericButtonAlignment
[C#]
public NumericButtonAlignment ButtonAlign {get; set;}
[C++]
public: __property NumericButtonAlignment get_ButtonAlign();
public: __property void set_ButtonAlign(NumericButtonAlignment);
[JScript]
public function get ButtonAlign() : NumericButtonAlignment;
public function set ButtonAlign(NumericButtonAlignment);

Property Value

The NumericButtonAlignment assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonFormatStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.ButtonFormatStyle Property

Gets or sets the format style of command buttons.

[Visual Basic]
Public Property ButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle ButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_ButtonFormatStyle();
public: __property void set_ButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get ButtonFormatStyle() : CommandButtonFormatStyle;
public function set ButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.ButtonStripStyle Property

Gets or sets the drawing style of control button strip.

[Visual Basic]
Public Property ButtonStripStyle As CommonColorStyle
[C#]
public CommonColorStyle ButtonStripStyle {get; set;}
[C++]
public: __property CommonColorStyle get_ButtonStripStyle();
public: __property void set_ButtonStripStyle(CommonColorStyle);
[JScript]
public function get ButtonStripStyle() : CommonColorStyle;
public function set ButtonStripStyle(CommonColorStyle);

Property Value

The CommonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Content Property

Lidor Systems IntegralUI Class Library

NumericUpDown.Content Property

Gets the control edit box.

[Visual Basic]
Public ReadOnly Property Content As NumericTextControl
[C#]
public NumericTextControl Content {get;}
[C++]
public: __property NumericTextControl* get_Content();
[JScript]
public function get Content() : NumericTextControl;

Property Value

A NumericTextControl that represents the edit box assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DecimalPlaces Property

Lidor Systems IntegralUI Class Library

NumericUpDown.DecimalPlaces Property

Gets or sets the number of decimal places.

[Visual Basic]
Public Property DecimalPlaces As Integer
[C#]
public int DecimalPlaces {get; set;}
[C++]
public: __property int get_DecimalPlaces();
public: __property void set_DecimalPlaces(int);
[JScript]
public function get DecimalPlaces() : int;
public function set DecimalPlaces(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DisabledButtonStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.DisabledButtonStyle Property

Gets or sets the drawing style of command buttons in disabled state.

[Visual Basic]
Public Property DisabledButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledButtonStyle();
public: __property void set_DisabledButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledButtonStyle() : CommandButtonColorStyle;
public function set DisabledButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DownLeftButtonRect Property

Lidor Systems IntegralUI Class Library

NumericUpDown.DownLeftButtonRect Property

Gets the space reserved for down-left button.

[Visual Basic]
Public ReadOnly Property DownLeftButtonRect As Rectangle
[C#]
public Rectangle DownLeftButtonRect {get;}
[C++]
public: __property Rectangle get_DownLeftButtonRect();
[JScript]
public function get DownLeftButtonRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check box text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


HoverButtonStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.HoverButtonStyle Property

Gets or sets the drawing style of command buttons in hover state.

[Visual Basic]
Public Property HoverButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverButtonStyle();
public: __property void set_HoverButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverButtonStyle() : CommandButtonColorStyle;
public function set HoverButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Increment Property

Lidor Systems IntegralUI Class Library

NumericUpDown.Increment Property

Gets or sets the amount by which the value is increased or decreased from button clicks.

[Visual Basic]
Public Overridable Property Increment As decimal
[C#]
public virtual decimal Increment { get; set; }
[C++]
public: __property virtual decimal get_Increment();
 public:
__property virtual void set_Increment(decimal );
[JScript]
public function get Increment() : decimal
public function set Increment(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Maximum Property

Lidor Systems IntegralUI Class Library

NumericUpDown.Maximum Property

Determines the maximum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Maximum As decimal
[C#]
public virtual decimal Maximum { get; set; }
[C++]
public: __property virtual decimal get_Maximum();
 public:
__property virtual void set_Maximum(decimal );
[JScript]
public function get Maximum() : decimal
public function set Maximum(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Minimum Property

Lidor Systems IntegralUI Class Library

NumericUpDown.Minimum Property

Determines the minimum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Minimum As decimal
[C#]
public virtual decimal Minimum { get; set; }
[C++]
public: __property virtual decimal get_Minimum();
 public:
__property virtual void set_Minimum(decimal );
[JScript]
public function get Minimum() : decimal
public function set Minimum(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NormalButtonStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.NormalButtonStyle Property

Gets or sets the drawing style of command buttons in normal state.

[Visual Basic]
Public Property NormalButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalButtonStyle();
public: __property void set_NormalButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalButtonStyle() : CommandButtonColorStyle;
public function set NormalButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


SelectedButtonStyle Property

Lidor Systems IntegralUI Class Library

NumericUpDown.SelectedButtonStyle Property

Gets or sets the drawing style of command buttons in selected state.

[Visual Basic]
Public Property SelectedButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedButtonStyle();
public: __property void set_SelectedButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedButtonStyle() : CommandButtonColorStyle;
public function set SelectedButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

Lidor Systems IntegralUI Class Library

NumericUpDown.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ThousandsSeparator Property

Lidor Systems IntegralUI Class Library

NumericUpDown.ThousandsSeparator Property

Determines whether the thousands separator will be inserted between every three decimal digits.

[Visual Basic]
Public Overridable Property ThousandsSeparator As Boolean
[C#]
public virtual bool ThousandsSeparator { get; set; }
[C++]
public: __property virtual bool get_ThousandsSeparator();
 public:
__property virtual void set_ThousandsSeparator(bool );
[JScript]
public function get ThousandsSeparator() : bool
public function set ThousandsSeparator(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


UpRightButtonRect Property

Lidor Systems IntegralUI Class Library

NumericUpDown.UpRightButtonRect Property

Gets the space reserved for up-right button.

[Visual Basic]
Public ReadOnly Property UpRightButtonRect As Rectangle
[C#]
public Rectangle UpRightButtonRect {get;}
[C++]
public: __property Rectangle get_UpRightButtonRect();
[JScript]
public function get UpRightButtonRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for up-right button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

Lidor Systems IntegralUI Class Library

NumericUpDown.Value Property

Gets or sets the current value of the control.

[Visual Basic]
Public Overridable Property Value As decimal
[C#]
public virtual decimal Value { get; set; }
[C++]
public: __property virtual decimal get_Value();
 public:
__property virtual void set_Value(decimal );
[JScript]
public function get Value() : decimal
public function set Value(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Methods

The methods of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in the control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in the control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

NumericUpDown.Dispose Method

Releases all resources used by this NumericUpDown object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonState (CommandButton) Method

Lidor Systems IntegralUI Class Library

NumericUpDown.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonColorStyle Method

Lidor Systems IntegralUI Class Library

NumericUpDown.GetCurrentButtonColorStyle Method

Returns the current drawing style of buttons in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonColorStyle() As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle GetCurrentButtonColorStyle();
[C++]
public: CommandButtonColorStyle* GetCurrentButtonColorStyle();
[JScript]
public function GetCurrentButtonColorStyle() : CommandButtonColorStyle;

Return Value

The style that represents the current drawing style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonFormatStyle Method

Lidor Systems IntegralUI Class Library

NumericUpDown.GetCurrentButtonFormatStyle Method

Returns the current format style of buttons in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonFormatStyle() As CommandButtonFormatStylee
[C#]
public CommandButtonFormatStyle GetCurrentButtonFormatStyle();
[C++]
public: CommandButtonFormatStylee* GetCurrentButtonFormatStyle();
[JScript]
public function GetCurrentButtonFormatStyle() : CommandButtonFormatStylee;

Return Value

The style that represents the current format style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonStripStyle Method

Lidor Systems IntegralUI Class Library

NumericUpDown.GetCurrentButtonStripStyle Method

Returns the current drawing style of the button strip in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonStripStyle() As CommonColorStyle
[C#]
public CommonColorStyle GetCurrentButtonStripStyle();
[C++]
public: CommonColorStyle* GetCurrentButtonStripStyle();
[JScript]
public function GetCurrentButtonStripStyle() : CommonColorStyle;

Return Value

The style that represents the current drawing style of the the button strip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

Lidor Systems IntegralUI Class Library

NumericUpDown.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

Lidor Systems IntegralUI Class Library

NumericUpDown.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanging Method

Lidor Systems IntegralUI Class Library

NumericUpDown.OnValueChanging Method

Raises the ValueChanging event.

[Visual Basic]
Protected Overridable Sub OnValueChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnValueChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnValueChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnValueChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

NumericUpDown.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Events

The events of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

Lidor Systems IntegralUI Class Library

NumericUpDown.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ValueChanging Event

Lidor Systems IntegralUI Class Library

NumericUpDown.ValueChanging Event

Occurs before the Value property changes.

[Visual Basic]
Public Event ValueChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ValueChanging;
[C++]
public: __event ObjectCancelEventHandler* ValueChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Class

Represents a control that displays progress of an operation.

For a list of all members of this type, see ProgressBar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.ProgressBar

[Visual Basic]
 Public Class ProgressBar
   Inherits Control
[C#]
public class ProgressBar : Control
[C++]
 public __gc class ProgressBar : public Control
[JScript]
public class ProgressBar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Members

ProgressBar overview

Public Constructors

public constructor ProgressBar Constructor Initializes a new instance of the ProgressBar class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BlockSize | Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.
public property BlockSpacing | Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Gets or sets the maximum value of the range of the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Gets or sets the minimum value of the range of the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Orientation | Determines whether the progress is displayed horizontally or vertically.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property ProgressStyle | Represents the visual appearance of the ProgressBar.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Step | Gets or sets the amount by which the current position of the progress bar is increased.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current position of the progress bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Gets or sets the drawing style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method Increment | Advances the current position of the ProgressBar by the specified amount.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PerformStep | Advances the current position of the ProgressBar by the amount of the Step property.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
public method OnValueChanged | Raises the ValueChanged event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Constructor ()

Initializes a new instance of the ProgressBar class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressBar();
[C++]
public: ProgressBar();
[JScript]
public function ProgressBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Properties

The properties of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BlockSize | Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.
public property BlockSpacing | Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Gets or sets the maximum value of the range of the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Gets or sets the minimum value of the range of the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Orientation | Determines whether the progress is displayed horizontally or vertically.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property ProgressStyle | Represents the visual appearance of the ProgressBar.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Step | Gets or sets the amount by which the current position of the progress bar is increased.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current position of the progress bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


BlockSize Property

Lidor Systems IntegralUI Class Library

ProgressBar.BlockSize Property

Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.

[Visual Basic]
Public Property BlockSize As Integer
[C#]
public int BlockSize {get; set;}
[C++]
public: __property int get_BlockSize();
public: __property void set_BlockSize(int);
[JScript]
public function get BlockSize() : int;
public function set BlockSize(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


BlockSpacing Property

Lidor Systems IntegralUI Class Library

ProgressBar.BlockSpacing Property

Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.

[Visual Basic]
Public Property BlockSpacing As Integer
[C#]
public int BlockSpacing {get; set;}
[C++]
public: __property int get_BlockSpacing();
public: __property void set_BlockSpacing(int);
[JScript]
public function get BlockSpacing() : int;
public function set BlockSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

Lidor Systems IntegralUI Class Library

ProgressBar.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Shadows Property ColorStyle As ProgressBarColorStyle
[C#]
public new ProgressBarColorStyle ColorStyle {get; set;}
[C++]
public: new __property ProgressBarColorStyle get_ColorStyle();
public: new __property void set_ColorStyle(ProgressBarColorStyle);
[JScript]
public function get ColorStyle() : ProgressBarColorStyle;
public function set ColorStyle(ProgressBarColorStyle);

Property Value

The ProgressBarColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Maximum Property

Lidor Systems IntegralUI Class Library

ProgressBar.Maximum Property

Gets or sets the maximum value of the range of the control.

[Visual Basic]
 Public Property Maximum As Integer
[C#]
 public int Maximum { get; set; }
[C++]
public: __property virtual int
 get_Maximum();
public: __property void set_Maximum(int );
[JScript]
public function get Maximum() : int
public function set Maximum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Minimum Property

Lidor Systems IntegralUI Class Library

ProgressBar.Minimum Property

Gets or sets the minimum value of the range of the control.

[Visual Basic]
 Public Property Minimum As Integer
[C#]
 public int Minimum { get; set; }
[C++]
public: __property virtual int
 get_Minimum();
public: __property void set_Minimum(int );
[JScript]
public function get Minimum() : int
public function set Minimum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Orientation Property

Lidor Systems IntegralUI Class Library

ProgressBar.Orientation Property

Determines whether the progress is displayed horizontally or vertically.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}
[C++]
public: __property Orientation get_Orientation();
public: __property void set_Orientation(Orientation);
[JScript]
public function get Orientation() : Orientation;
public function set Orientation(Orientation);

Property Value

The Orientation assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressStyle Property

Lidor Systems IntegralUI Class Library

ProgressBar.ProgressStyle Property

Represents the visual appearance of the ProgressBar.

[Visual Basic]
Public Property ProgressStyle As ProgressBarStyle
[C#]
public ProgressBarStyle ProgressStyle {get; set;}
[C++]
public: __property ProgressBarStyle get_ProgressStyle();
public: __property void set_ProgressStyle(ProgressBarStyle);
[JScript]
public function get ProgressStyle() : ProgressBarStyle;
public function set ProgressStyle(ProgressBarStyle);

Property Value

The ProgressBarStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Step Property

Lidor Systems IntegralUI Class Library

ProgressBar.Step Property

Gets or sets the amount by which the current position of the progress bar is increased.

[Visual Basic]
Public Property Step As Integer
[C#]
public int Step {get; set;}
[C++]
public: __property int get_Step();
public: __property void set_Step(int);
[JScript]
public function get Step() : int;
public function set Step(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

Lidor Systems IntegralUI Class Library

ProgressBar.Value Property

Gets or sets the current position of the progress bar.

[Visual Basic]
Public Property Value As Integer
[C#]
public int Value {get; set;}
[C++]
public: __property int get_Value();
public: __property void set_Value(int);
[JScript]
public function get Value() : int;
public function set Value(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Methods

The methods of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Gets or sets the drawing style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method Increment | Advances the current position of the ProgressBar by the specified amount.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PerformStep | Advances the current position of the ProgressBar by the amount of the Step property.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
public method OnValueChanged | Raises the ValueChanged event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ProgressBar.Dispose Method

Releases all resources used by this ProgressBar object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

Lidor Systems IntegralUI Class Library

ProgressBar.GetCurrentColorStyle Method

Returns the drawing style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As ProgressBarColorStyle
[C#]
public new ProgressBarColorStyle GetCurrentColorStyle();
[C++]
public: new ProgressBarColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : ProgressBarColorStyle;

Return Value

The style that represents the current drawing style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Increment Method

Lidor Systems IntegralUI Class Library

ProgressBar.Increment Method

Advances the current position of the ProgressBar by the specified amount.

[Visual Basic]
Public Sub Increment( _
   ByVal value As Integer _
)
[C#]
 public void Increment(
   int value
);
[C++]
public: void Increment(
   int value
);
[JScript]
 public function Increment(
   value : int
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

Lidor Systems IntegralUI Class Library

ProgressBar.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


PerformStep Method

Lidor Systems IntegralUI Class Library

ProgressBar.PerformStep Method

Advances the current position of the ProgressBar by the amount of the Step property.

[Visual Basic]
Public Sub PerformStep()
[C#]
 public void PerformStep();
[C++]
public: void PerformStep();
[JScript]
 public function PerformStep();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

ProgressBar.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Events

The events of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

Lidor Systems IntegralUI Class Library

ProgressBar.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Class

Represents a text box control.

For a list of all members of this type, see TextControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.TextControl

[Visual Basic]
 Public Class TextControl
   Inherits Control
[C#]
public class TextControl : Control
[C++]
 public __gc class TextControl : public Control
[JScript]
public class TextControl extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Members

TextControl overview

Public Constructors

public constructor TextControl Constructor Initializes a new instance of the TextControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSpace | Determines whether space character is allowed.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CharacterMode | Determines the type of characters that can be inserted.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Multiline | Determines whether text can span to more then one line.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Returns the drawing style of the control.
public method GetCurrentFormatStyle | Returns the format style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


TextControl Constructor ()

Initializes a new instance of the TextControl class.

[Visual Basic]
Public Sub New()
[C#]
public TextControl();
[C++]
public: TextControl();
[JScript]
public function TextControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


TextControl Properties

The properties of the TextControl class are listed here. For a complete list of TextControl class members, see the TextControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSpace | Determines whether space character is allowed.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CharacterMode | Determines the type of characters that can be inserted.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Multiline | Determines whether text can span to more then one line.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


AllowSpace Property

Lidor Systems IntegralUI Class Library

TextControl.AllowSpace Property

Determines whether space character is allowed.

[Visual Basic]
Public Overridable Property AllowSpace As Boolean
[C#]
public virtual bool AllowSpace { get; set; }
[C++]
public: __property virtual bool get_AllowSpace();
 public:
__property virtual void set_AllowSpace(bool );
[JScript]
public function get AllowSpace() : bool
public function set AllowSpace(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


CharacterMode Property

Lidor Systems IntegralUI Class Library

TextControl.CharacterMode Property

Determines the type of characters that can be inserted.

[Visual Basic]
Public Property CharacterMode As CharacterMode
[C#]
public CharacterMode CharacterMode {get; set;}
[C++]
public: __property CharacterMode get_CharacterMode();
public: __property void set_CharacterMode(CharacterMode);
[JScript]
public function get CharacterMode() : CharacterMode;
public function set CharacterMode(CharacterMode);

Property Value

The CharacterMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

Lidor Systems IntegralUI Class Library

TextControl.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Shadows Property ColorStyle As TextControlColorStyle
[C#]
public new TextControlColorStyle ColorStyle {get; set;}
[C++]
public: new __property TextControlColorStyle get_ColorStyle();
public: new __property void set_ColorStyle(TextControlColorStyle);
[JScript]
public function get ColorStyle() : TextControlColorStyle;
public function set ColorStyle(TextControlColorStyle);

Property Value

The TextControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


Content Property

Lidor Systems IntegralUI Class Library

TextControl.Content Property

Gets the control edit box.

[Visual Basic]
Public ReadOnly Property Content As TextControl.EditBox
[C#]
public TextControl.EditBox Content {get;}
[C++]
public: __property TextControl.EditBox* get_Content();
[JScript]
public function get Content() : TextControl.EditBox;

Property Value

A TextControl.EditBox that represents the edit box assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

Lidor Systems IntegralUI Class Library

TextControl.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Shadows Property FormatStyle As TextControlFormatStyle
[C#]
public new TextControlFormatStyle FormatStyle {get; set;}
[C++]
public: new __property TextControlFormatStyle get_FormatStyle();
public: new __property void set_FormatStyle(TextControlFormatStyle);
[JScript]
public function get FormatStyle() : TextControlFormatStyle;
public function set FormatStyle(TextControlFormatStyle);

Property Value

The TextControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


Multiline Property

Lidor Systems IntegralUI Class Library

TextControl.Multiline Property

Determines whether text can span to more then one line.

[Visual Basic]
Public Overridable Property Multiline As Boolean
[C#]
public virtual bool Multiline { get; set; }
[C++]
public: __property virtual bool get_Multiline();
 public:
__property virtual void set_Multiline(bool );
[JScript]
public function get Multiline() : bool
public function set Multiline(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

Lidor Systems IntegralUI Class Library

TextControl.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Methods

The methods of the TextControl class are listed here. For a complete list of TextControl class members, see the TextControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Returns the drawing style of the control.
public method GetCurrentFormatStyle | Returns the format style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

TextControl.Dispose Method

Releases all resources used by this TextControl object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

Lidor Systems IntegralUI Class Library

TextControl.GetCurrentColorStyle Method

Returns the drawing style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As TextControlColorStyle
[C#]
public new TextControlColorStyle GetCurrentColorStyle();
[C++]
public: new TextControlColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : TextControlColorStyle;

Return Value

The style that represents the current drawing style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

Lidor Systems IntegralUI Class Library

TextControl.GetCurrentColorStyle Method

Returns the current format style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As TextControlFormatStyle
[C#]
public new TextControlFormatStyle GetCurrentColorStyle();
[C++]
public: new TextControlFormatStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : TextControlFormatStyle;

Return Value

The style that represents the current format style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

Lidor Systems IntegralUI Class Library

TextControl.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

Lidor Systems IntegralUI Class Library

TextControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Class

A class representing a selectable button that can contain text and image.

For a list of all members of this type, see ToolButton Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolButton

[Visual Basic]

Public Class ToolButton
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolButton : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolButton : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolButton extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Members

ToolButton overview

Public Constructors

public constructor ToolButton Constructor Initializes a new instance of the ToolButton class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property Checked | Indicates whether the button is pressed in or not.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the button.
public property ItemType | Overridden. Gets the type of button.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolButton object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event CheckedChanged | Occurs when the Checked property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor

Initializes a new instance of the ToolButton class.

Overload List

Initializes a new instance of the ToolButton class.

[Visual Basic] Public Sub New()
[C#] public ToolButton();
[C++] public: ToolButton();
[JScript] public function ToolButton();

Initializes a new instance of the ToolButton class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolButton(string);
[C++] public: ToolButton(String*);
[JScript] public function ToolButton(String);

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor ()

Initializes a new instance of the ToolButton class.

[Visual Basic]
Public Sub New()
[C#]
public ToolButton();
[C++]
public: ToolButton();
[JScript]
public function ToolButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor (String)

Initializes a new instance of the ToolButton class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolButton(
   string text
);
[C++]
public: ToolButton(
   String* text
);
[JScript]
public function ToolButton(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Properties

The properties of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property Checked | Indicates whether the button is pressed in or not.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the button.
public property ItemType | Overridden. Gets the type of button.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


Checked Property

Lidor Systems IntegralUI Class Library

ToolButton.Checked Property

Indicates whether the button is pressed in or not.

[Visual Basic]
Public Overridable Property Checked As Boolean
[C#]
public virtual bool Checked {get; set;}
[C++]
public: __property virtual bool get_Checked();
public: __property virtual void set_Checked(bool);
[JScript]
public function get Checked() : Boolean;
public function set Checked(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentRelation Property

Lidor Systems IntegralUI Class Library

ToolButton.ContentRelation Property

Specifies how text and image are aligned.

[Visual Basic]
Public Overrides Overloads Property ContentRelation As ToolContentRelation
[C#]
public override ToolContentRelation ContentRelation {get; set;}
[C++]
public: override __property ToolContentRelation get_ContentRelation();
public: override __property void set_ContentRelation(ToolContentRelation);
[JScript]
public function get ContentRelation() : ToolContentRelation;
public function set ContentRelation(ToolContentRelation);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyle Property

Lidor Systems IntegralUI Class Library

ToolButton.DisplayStyle Property

Specifies whether text and image are displayed.

[Visual Basic]
Public Overrides Overloads Property DisplayStyle As ToolDisplayStyle
[C#]
public override ToolDisplayStyle DisplayStyle {get; set;}
[C++]
public: override __property ToolDisplayStyle get_DisplayStyle();
public: override __property void set_DisplayStyle(ToolDisplayStyle);
[JScript]
public function get DisplayStyle() : ToolDisplayStyle;
public function set DisplayStyle(ToolDisplayStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

ToolButton.ImageIndex Property

Gets or sets the image list index value of the image displayed on the button.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

Lidor Systems IntegralUI Class Library

ToolButton.Image Property

The image that will be displayed on the button.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

Lidor Systems IntegralUI Class Library

ToolButton.ItemType Property

Overridden. Gets the type of button.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Methods

The methods of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolButton object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolButton.Clone Method

Creates an exact copy of the current ToolButton.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolButton object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckedChanged Method

Lidor Systems IntegralUI Class Library

ToolButton.OnCheckedChanged Method

Raises the CheckedChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckedChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnCheckedChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnCheckedChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnCheckedChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnContentRelationChanged Method

Lidor Systems IntegralUI Class Library

ToolButton.OnContentRelationChanged Method

Raises the ContentRelationChanged event.

[Visual Basic]
Protected Overridable Sub OnContentRelationChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnContentRelationChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnContentRelationChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnContentRelationChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnDisplayStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolButton.OnDisplayStyleChanged Method

Raises the DisplayStyleChanged event.

[Visual Basic]
Protected Overridable Sub OnDisplayStyleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnDisplayStyleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

Lidor Systems IntegralUI Class Library

ToolButton.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageIndexChanged Method

Lidor Systems IntegralUI Class Library

ToolButton.OnImageIndexChanged Method

Raises the ImageIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnImageIndexChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageIndexChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageIndexChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageIndexChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Events

The events of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event CheckedChanged | Occurs when the Checked property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

See Also

ToolButton Class | LidorSystems.IntegralUI Namespace


CheckedChanged Event

Lidor Systems IntegralUI Class Library

ToolButton.CheckedChanged Event

Occurs when the Checked property value has changed.

[Visual Basic]
Public Event CheckedChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler CheckedChanged;
[C++]
public: __event UpdateEventHandler* CheckedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentRelationChanged Event

Lidor Systems IntegralUI Class Library

ToolButton.ContentRelationChanged Event

Occurs when the ContentRelation property value has changed.

[Visual Basic]
Public Event ContentRelationChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ContentRelationChanged;
[C++]
public: __event UpdateEventHandler* ContentRelationChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyleChanged Event

Lidor Systems IntegralUI Class Library

ToolButton.DisplayStyleChanged Event

Occurs when the DisplayStyle property value has changed.

[Visual Basic]
Public Event DisplayStyleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler DisplayStyleChanged;
[C++]
public: __event UpdateEventHandler* DisplayStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

Lidor Systems IntegralUI Class Library

ToolButton.ImageChanged Event

Occurs when the Image property value has changed.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndexChanged Event

Lidor Systems IntegralUI Class Library

ToolButton.ImageIndexChanged Event

Occurs when the ImageIndex property value has changed.

[Visual Basic]
Public Event ImageIndexChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageIndexChanged;
[C++]
public: __event UpdateEventHandler* ImageIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Class

Provides a common implementation of members for tool item objects.

For a list of all members of this type, see ToolItemBase Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolButton
LidorSystems.IntegralUI.Controls.ToolLabel
LidorSystems.IntegralUI.Controls.ToolSeparator

[Visual Basic]

MustInherit Public Class ToolItemBase
   Inherits LidorSystems.IntegralUI.ObjectBase
[C#]

public abstract class ToolItemBase : LidorSystems.IntegralUI.ObjectBase
[C++]

public __gc __abstract class ToolItemBase : public LidorSystems.IntegralUI.ObjectBase
[JScript]
public abstract

class ToolItemBase extends LidorSystems.IntegralUI.ObjectBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Members

ToolItemBase overview

Public Constructors

public constructor ToolItemBase Constructor Initializes a new instance of the ToolItemBase class.

Public Properties

public property Alignment | Determines how tool item is aligned in parent control.
public property Bounds | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Gets the type of tool item.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone (inherited from Object) | Creates an exact copy of the current ToolItemBase object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolItemBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged | Occurs when the Alignment property value has changed.
public event FadingChanged | Occurs when fade value of the item has changed during active fading process.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged | Raises the AlignmentChanged event.
protected method OnFadingChanged | Raises the FadingChanged event.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor

Initializes a new instance of the ToolItemBase class.

Overload List

Initializes a new instance of the ToolItemBase class.

[Visual Basic] Public Sub New()
[C#] public ToolItemBase();
[C++] public: ToolItemBase();
[JScript] public function ToolItemBase();

Initializes a new instance of the ToolItemBase class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolItemBase(string);
[C++] public: ToolItemBase(String*);
[JScript] public function ToolItemBase(String);

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor ()

Initializes a new instance of the ToolItemBase class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemBase();
[C++]
public: ToolItemBase();
[JScript]
public function ToolItemBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor (String)

Initializes a new instance of the ToolItemBase class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolItemBase(
   string text
);
[C++]
public: ToolItemBase(
   String* text
);
[JScript]
public function ToolItemBase(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Properties

The properties of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Properties

public property Alignment | Determines how tool item is aligned in parent control.
public property Bounds | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Gets the type of tool item.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


Alignment Property

Lidor Systems IntegralUI Class Library

ToolItemBase.Alignment Property

Determines how tool item is aligned in parent control.

[Visual Basic]
Public Overrides Overloads Property Alignment As ToolItemAlignment
[C#]
public override ToolItemAlignment Alignment {get; set;}
[C++]
public: override __property ToolItemAlignment get_Alignment();
public: override __property void set_Alignment(ToolItemAlignment);
[JScript]
public function get Alignment() : ToolItemAlignment;
public function set Alignment(ToolItemAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


Bounds Property

Lidor Systems IntegralUI Class Library

ToolItemBase.Bounds Property

Gets or sets a value specifying the tool item space. For internal use only.

[Visual Basic]
Public Overrides Overloads ReadOnly Property Bounds As Rectangle
[C#]
public override Rectangle Bounds {get;}
[C++]
public: override __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the tool item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ContentSize Property

Lidor Systems IntegralUI Class Library

ToolItemBase.ContentSize Property

Gets or sets the size of tool item content space. For internal use only.

[Visual Basic]
Public ReadOnly Property ContentSize As Size
[C#]
public Size ContentSize {get;}
[C++]
public: __property Size get_ContentSize();
[JScript]
public function get ContentSize() : Size;

Property Value

The Size of the tool item content space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

Lidor Systems IntegralUI Class Library

ToolItemBase.ItemType Property

Gets the type of tool item.

[Visual Basic]
Public Overridable ReadOnly Property ItemType As ToolItemType
[C#]
public virtual ToolItemType ItemType {get;}
[C++]
public: __property virtual ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the tool item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


Size Property

Lidor Systems IntegralUI Class Library

ToolItemBase.Size Property

Gets or sets the size of the tool item space. For internal use only.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

Property Value

The Size of the tool item space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Methods

The methods of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Methods

public method Clone (inherited from Object) | Creates an exact copy of the current ToolItemBase object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolItemBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged | Raises the AlignmentChanged event.
protected method OnFadingChanged | Raises the FadingChanged event.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


OnAlignmentChanged Method

Lidor Systems IntegralUI Class Library

ToolItemBase.OnAlignmentChanged Method

Raises the AlignmentChanged event.

[Visual Basic]
Protected Overridable Sub OnAlignmentChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnAlignmentChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnAlignmentChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnAlignmentChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


OnFadingChanged Method

Lidor Systems IntegralUI Class Library

ToolItemBase.OnFadingChanged Method

Raises the FadingChanged event.

[Visual Basic]
Protected Sub OnFadingChanged( _
   ByVal e As EventArgs _
)
[C#]
 protected void OnFadingChanged(
   EventArgs e
);
[C++]
 protected: void OnFadingChanged(
   EventArgs* e
);
[JScript]
protected function OnFadingChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Events

The events of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Events

public event AlignmentChanged | Occurs when the Alignment property value has changed.
public event FadingChanged | Occurs when fade value of the item has changed during active fading process.

See Also

ToolItemBase Class | LidorSystems.IntegralUI Namespace


AlignmentChanged Event

Lidor Systems IntegralUI Class Library

ToolItemBase.AlignmentChanged Event

Occurs when the Alignment property value has changed.

[Visual Basic]
Public Event AlignmentChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler AlignmentChanged;
[C++]
public: __event UpdateEventHandler* AlignmentChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


FadingChanged Event

Lidor Systems IntegralUI Class Library

ToolItemBase.FadingChanged Event

Occurs when fade value of the item has changed during active fading process.

[Visual Basic]
Public Event FadingChanged As EventHandler
[C#]
public event EventHandler FadingChanged;
[C++]
public: __event EventHandler* FadingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Class

A class representing a non-selectable tool item that renders text and images and can display hyperlinks.

For a list of all members of this type, see ToolLabel Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolLabel

[Visual Basic]

Public Class ToolLabel
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolLabel : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolLabel : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolLabel extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Members

ToolLabel overview

Public Constructors

public constructor ToolLabel Constructor Initializes a new instance of the ToolLabel class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the label.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the label.
public property IsLink | Indicates the behavior of the label.
public property ItemType | Overridden. Gets the type of label.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property LinkUnderlineStyle | The underline style of the link.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolLabel object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolLabel object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor

Initializes a new instance of the ToolLabel class.

Overload List

Initializes a new instance of the ToolLabel class.

[Visual Basic] Public Sub New()
[C#] public ToolLabel();
[C++] public: ToolLabel();
[JScript] public function ToolLabel();

Initializes a new instance of the ToolLabel class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolLabel(string);
[C++] public: ToolLabel(String*);
[JScript] public function ToolLabel(String);

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor ()

Initializes a new instance of the ToolLabel class.

[Visual Basic]
Public Sub New()
[C#]
public ToolLabel();
[C++]
public: ToolLabel();
[JScript]
public function ToolLabel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor (String)

Initializes a new instance of the ToolLabel class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolLabel(
   string text
);
[C++]
public: ToolLabel(
   String* text
);
[JScript]
public function ToolLabel(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Properties

The properties of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the label.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the label.
public property IsLink | Indicates the behavior of the label.
public property ItemType | Overridden. Gets the type of label.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property LinkUnderlineStyle | The underline style of the link.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ContentRelation Property

Lidor Systems IntegralUI Class Library

ToolLabel.ContentRelation Property

Specifies how text and image are aligned.

[Visual Basic]
Public Overrides Overloads Property ContentRelation As ToolContentRelation
[C#]
public override ToolContentRelation ContentRelation {get; set;}
[C++]
public: override __property ToolContentRelation get_ContentRelation();
public: override __property void set_ContentRelation(ToolContentRelation);
[JScript]
public function get ContentRelation() : ToolContentRelation;
public function set ContentRelation(ToolContentRelation);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyle Property

Lidor Systems IntegralUI Class Library

ToolLabel.DisplayStyle Property

Specifies whether text and image are displayed.

[Visual Basic]
Public Overrides Overloads Property DisplayStyle As ToolDisplayStyle
[C#]
public override ToolDisplayStyle DisplayStyle {get; set;}
[C++]
public: override __property ToolDisplayStyle get_DisplayStyle();
public: override __property void set_DisplayStyle(ToolDisplayStyle);
[JScript]
public function get DisplayStyle() : ToolDisplayStyle;
public function set DisplayStyle(ToolDisplayStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

Lidor Systems IntegralUI Class Library

ToolLabel.ImageIndex Property

Gets or sets the image list index value of the image displayed on the button.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

Lidor Systems IntegralUI Class Library

ToolLabel.Image Property

The image that will be displayed on the button.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


IsLink Property

Lidor Systems IntegralUI Class Library

ToolLabel.IsLink Property

Indicates the behavior of the label.

[Visual Basic]
Public Overridable Property IsLink As Boolean
[C#]
public virtual bool IsLink {get; set;}
[C++]
public: __property virtual bool get_IsLink();
public: __property virtual void set_IsLink(bool);
[JScript]
public function get IsLink() : Boolean;
public function set IsLink(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

Lidor Systems IntegralUI Class Library

ToolLabel.ItemType Property

Overridden. Gets the type of label.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the label.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


LinkUnderlineStyle Property

Lidor Systems IntegralUI Class Library

ToolLabel.LinkUnderlineStyle Property

The underline style of the link.

[Visual Basic]
Public Overrides Overloads Property LinkUnderlineStyle As ToolLinkUnderlineStyle
[C#]
public override ToolLinkUnderlineStyle LinkUnderlineStyle {get; set;}
[C++]
public: override __property ToolLinkUnderlineStyle get_LinkUnderlineStyle();
public: override __property void set_LinkUnderlineStyle(ToolLinkUnderlineStyle);
[JScript]
public function get LinkUnderlineStyle() : ToolLinkUnderlineStyle;
public function set LinkUnderlineStyle(ToolLinkUnderlineStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Methods

The methods of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolLabel object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolLabel object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolLabel.Clone Method

Creates an exact copy of the current ToolLabel.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolLabel object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnContentRelationChanged Method

Lidor Systems IntegralUI Class Library

ToolLabel.OnContentRelationChanged Method

Raises the ContentRelationChanged event.

[Visual Basic]
Protected Overridable Sub OnContentRelationChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnContentRelationChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnContentRelationChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnContentRelationChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnDisplayStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolLabel.OnDisplayStyleChanged Method

Raises the DisplayStyleChanged event.

[Visual Basic]
Protected Overridable Sub OnDisplayStyleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnDisplayStyleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

Lidor Systems IntegralUI Class Library

ToolLabel.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnImageIndexChanged Method

Lidor Systems IntegralUI Class Library

ToolLabel.OnImageIndexChanged Method

Raises the ImageIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnImageIndexChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageIndexChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageIndexChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageIndexChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Events

The events of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

See Also

ToolLabel Class | LidorSystems.IntegralUI Namespace


ContentRelationChanged Event

Lidor Systems IntegralUI Class Library

ToolLabel.ContentRelationChanged Event

Occurs when the ContentRelation property value has changed.

[Visual Basic]
Public Event ContentRelationChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ContentRelationChanged;
[C++]
public: __event UpdateEventHandler* ContentRelationChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyleChanged Event

Lidor Systems IntegralUI Class Library

ToolLabel.DisplayStyleChanged Event

Occurs when the DisplayStyle property value has changed.

[Visual Basic]
Public Event DisplayStyleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler DisplayStyleChanged;
[C++]
public: __event UpdateEventHandler* DisplayStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

Lidor Systems IntegralUI Class Library

ToolLabel.ImageChanged Event

Occurs when the Image property value has changed.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndexChanged Event

Lidor Systems IntegralUI Class Library

ToolLabel.ImageIndexChanged Event

Occurs when the ImageIndex property value has changed.

[Visual Basic]
Public Event ImageIndexChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageIndexChanged;
[C++]
public: __event UpdateEventHandler* ImageIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Class

A class representing a line used to group tool items.

For a list of all members of this type, see ToolSeparator Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolSeparator

[Visual Basic]

Public Class ToolSeparator
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolSeparator : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolSeparator : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolSeparator extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Members

ToolSeparator overview

Public Constructors

public constructor ToolSeparator Constructor Initializes a new instance of the ToolSeparator class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Overridden. Gets the type of separator.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolSeparator object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolSeparator object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Constructor ()

Initializes a new instance of the ToolSeparator class.

[Visual Basic]
Public Sub New()
[C#]
public ToolSeparator();
[C++]
public: ToolSeparator();
[JScript]
public function ToolSeparator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Properties

The properties of the ToolSeparator class are listed here. For a complete list of ToolSeparator class members, see the ToolSeparator Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Overridden. Gets the type of separator.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

Lidor Systems IntegralUI Class Library

ToolSeparator.ItemType Property

Overridden. Gets the separator type.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the separator type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolSeparator Class | ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Methods

The methods of the ToolSeparator class are listed here. For a complete list of ToolSeparator class members, see the ToolSeparator Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolSeparator object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolSeparator object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolSeparator.Clone Method

Creates an exact copy of the current ToolSeparator.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolSeparator object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolSeparator Class | ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


CalendarDisplayMode Enumeration

Enumerator used to determine how date is displayed in MonthCalendar control.

[Visual Basic]
Public Enum CalendarDisplayMode
[C#]
public enum CalendarDisplayMode
[C++]
__value public enum CalendarDisplayMode
[JScript]
public
   enum CalendarDisplayMode

Members

Member name | Description
Day | A single day is displayed.
Month | A single month with all days is displayed.
Year | A single year with all months is displayed.
Decade | A decade is displayed.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CharacterMode Enumeration

Enumerator used to determine the type of characters that can be inserted.

[Visual Basic]
Public Enum CharacterMode
[C#]
public enum CharacterMode
[C++]
__value public enum CharacterMode
[JScript]
public
   enum CharacterMode

Members

Member name | Description
AlphaNumeric | All characters are allowed.
Numeric | Only numeric characters are allowed.
Textual | Only textual characters are allowed.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CommandButtonType Enumeration

Enumerator used to specify some predfined types of command buttons.

[Visual Basic]
Public Enum CommandButtonType
[C#]
public enum CommandButtonType
[C++]
__value public enum CommandButtonType
[JScript]
public
   enum CommandButtonType

Members

Member name | Description
CollapseUp | Represents a button used for collapsing operations.
CollapseDown | Represents a button used for expanding operations.
Default | The default button type. The appearance is determined by its image.
SplitCollapse | Represents a button used for collapsing operations in SplitContainer control.
SplitHorizontal | Represents a button used for to set horizontal orientation in SplitContainer control.
SplitVertical | Represents a button used for to set vertical orientation in SplitContainer control.
SwapButton | Represents a button used for to swap panels in SplitContainer control.
TabClose | Represents a button used to close open tabs.
TabScrollLeft | Represents a button used navigate among tabs in left/up direction.
TabScrollRight | Represents a button used navigate among tabs in right/down direction.
TabSelector | Represents a button used to select and activate a particular tab.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CommandButtonVisibility Enumeration

Enumerator used to determine how command buttons are displayed.

[Visual Basic]
Public Enum CommandButtonVisibility
[C#]
public enum CommandButtonVisibility
[C++]
__value public enum CommandButtonVisibility
[JScript]
public
   enum CommandButtonVisibility

Members

Member name | Description
None | The buttons are not visible.
OnHover | The buttons are visible when their container is hovered.
OnClick | The buttons are visible when their container is selected.
AlwaysVisible | The buttons are always visible.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


NumericButtonAlignment Enumeration

Enumerator used to determine how control will align buttons relative to its edit box in NumericUpDown control.

[Visual Basic]
Public Enum NumericButtonAlignment
[C#]
public enum NumericButtonAlignment
[C++]
__value public enum NumericButtonAlignment
[JScript]
public
   enum NumericButtonAlignment

Members

Member name | Description
Horizontal | EditBox is located in the middle area surronding with buttons to the left and right side.
UpDownLeft | EditBox is placed to the right side and buttons are placed to the left side.
UpDownRight | EditBox is placed to the left side and buttons are placed to the right side.
Vertical | EditBox is located in the middle area surronding with buttons to the up and down side.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolContentRelation Enumeration

Enumerator used to specify how content of tool items are arranged.

[Visual Basic]
Public Enum ToolContentRelation
[C#]
public enum ToolContentRelation
[C++]
__value public enum ToolContentRelation
[JScript]
public
   enum ToolContentRelation

Members

Member name | Description
ImageBeforeText | Image is showed before text.
ImageAboveText | Image is showed above text.
TextBeforeImage | Text is showed before image.
TextAboveImage | Text is showed above image.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolDisplayStyle Enumeration

Enumerator used to specify what objects are showed in tool item space.

[Visual Basic]
Public Enum ToolDisplayStyle
[C#]
public enum ToolDisplayStyle
[C++]
__value public enum ToolDisplayStyle
[JScript]
public
   enum ToolDisplayStyle

Members

Member name | Description
None | The tool item doesn't display anything.
Text | Only a text is shown in the tool item space.
Image | Only an image is shown in the tool item space.
All | Both, text and image are shown in the tool item space.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolItemAlignment Enumeration

Enumerator used to determine the alignment of tool item in the parent container.

[Visual Basic]
Public Enum ToolItemAlignment
[C#]
public enum ToolItemAlignment
[C++]
__value public enum ToolItemAlignment
[JScript]
public
   enum ToolItemAlignment

Members

Member name | Description
Left | The tool item is aligned to the left side of its parent container.
Right | The tool item is aligned to the right side of its parent container.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolItemType Enumeration

Enumerator used to specify the type of tool item.

[Visual Basic]
Public Enum ToolItemType
[C#]
public enum ToolItemType
[C++]
__value public enum ToolItemType
[JScript]
public
   enum ToolItemType

Members

Member name | Description
Button | The tool item acts like a button.
Label | The tool item acts like a label.
Separator | The tool item acts like a separator for other tool items.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolLinkUnderlineStyle Enumeration

Enumerator used to specify when an underline is shown below the text in tool label.

[Visual Basic]
Public Enum ToolLinkUnderlineStyle
[C#]
public enum ToolLinkUnderlineStyle
[C++]
__value public enum ToolLinkUnderlineStyle
[JScript]
public
   enum ToolLinkUnderlineStyle

Members

Member name | Description
None | The underline is not visible.
OnHover | The underline is visible only when tool label is hovered.
Always | The underline is always visible.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CommandButtonCollection Class

Contains a collection of CommandButton objects.

For a list of all members of this type, see CommandButtonCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.CommandButtonCollection

[Visual Basic]
Public Class CommandButtonCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class CommandButtonCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class CommandButtonCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class CommandButtonCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Members

CommandButtonCollection overview

Public Constructors

public constructor CommandButtonCollection Constructor Initializes a new instance of the CommandButtonCollection class.

Public Properties

public property Item | Gets a CommandButton at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the CommandButtonCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the CommandButtonCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the CommandButtonCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the CommandButtonCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the CommandButtonCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the CommandButtonCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an CommandButton is added.
protected method OnAdding | Overridden. Occurs before an CommandButton is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an CommandButton is removed.
protected method OnRemoving | Overridden. Occurs before an CommandButton is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor

Overload List

Initializes a new instance of the CommandButtonCollection class.

[Visual Basic] Public Sub New()
[C#] public CommandButtonCollection();
[C++] public: CommandButtonCollection();
[JScript] public function CommandButtonCollection();

Initializes a new instance of the CommandButtonCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public CommandButtonCollection(object);
[C++] public: CommandButtonCollection(Object*);
[JScript] public function CommandButtonCollection(Object);

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor ()

Initializes a new instance of the CommandButtonCollection class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonCollection();
[C++]
public: CommandButtonCollection();
[JScript]
public function CommandButtonCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor (Object)

Initializes a new instance of the CommandButtonCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public CommandButtonCollection(
   object owner
);
[C++]
public: CommandButtonCollection(
   Object* owner
);
[JScript]
public function CommandButtonCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Properties

The properties of the CommandButtonCollection class are listed here. For a complete list of CommandButtonCollection class members, see the CommandButtonCollection Members topic.

Public Properties

public property Item | Gets a CommandButton at the specified location in the collection.
public property Owner (inherited from CommandButtonCollection) | Gets the object that owns the CommandButtonCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

Lidor Systems IntegralUI Class Library

CommandButtonCollection.Item Property

Gets or sets a button within the collection.

Overload List

Gets a CommandButton at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a CommandButton with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Class

Contains a collection of ListControlItem objects.

For a list of all members of this type, see ListControlItemCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.ListControlItemCollection

[Visual Basic]
Public Class ListControlItemCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class ListControlItemCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class ListControlItemCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class ListControlItemCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Members

ListControlItemCollection overview

Public Constructors

public constructor ListControlItemCollection Constructor Initializes a new instance of the ListControlItemCollection class.

Public Properties

public property Item | Gets a ListControlItem at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the ListControlItemCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the ListControlItemCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the ListControlItemCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the ListControlItemCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the ListControlItemCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the ListControlItemCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an ListControlItem is added.
protected method OnAdding | Overridden. Occurs before an ListControlItem is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an ListControlItem is removed.
protected method OnRemoving | Overridden. Occurs before an ListControlItem is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor

Overload List

Initializes a new instance of the ListControlItemCollection class.

[Visual Basic] Public Sub New()
[C#] public ListControlItemCollection();
[C++] public: ListControlItemCollection();
[JScript] public function ListControlItemCollection();

Initializes a new instance of the ListControlItemCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public ListControlItemCollection(object);
[C++] public: ListControlItemCollection(Object*);
[JScript] public function ListControlItemCollection(Object);

Initializes a new instance of the ListControlItemCollection class and associates it with the parent ListControl.

[Visual Basic] Public Sub New(ListControl)
[C#] public ListControlItemCollection(ListControl);
[C++] public: ListControlItemCollection(ListControl*);
[JScript] public function ListControlItemCollection(ListControl);

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor ()

Initializes a new instance of the ListControlItemCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ListControlItemCollection();
[C++]
public: ListControlItemCollection();
[JScript]
public function ListControlItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor (Object)

Initializes a new instance of the ListControlItemCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ListControlItemCollection(
   object owner
);
[C++]
public: ListControlItemCollection(
   Object* owner
);
[JScript]
public function ListControlItemCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor (ListControl)

Initializes a new instance of the ListControlItemCollection class and associates it with parent ListControl.

[Visual Basic]
Public Sub New( _
   ByVal owner As ListControl _
)
[C#]
public ListControlItemCollection(
   ListControl owner
);
[C++]
public: ListControlItemCollection(
   ListControl* owner
);
[JScript]
public function ListControlItemCollection(
   owner : ListControl
);

Parameters

owner

The ListControl to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Properties

The properties of the ListControlItemCollection class are listed here. For a complete list of ListControlItemCollection class members, see the ListControlItemCollection Members topic.

Public Properties

public property Item | Gets a ListControlItem at the specified location in the collection.
public property Owner (inherited from ListControlItemCollection) | Gets the object that owns the ListControlItemCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

Lidor Systems IntegralUI Class Library

ListControlItemCollection.Item Property

Gets or sets a button within the collection.

Overload List

Gets a ListControlItem at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a ListControlItem with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Class

Contains a collection of ToolItemBase objects.

For a list of all members of this type, see ToolItemCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.ToolItemCollection

[Visual Basic]
Public Class ToolItemCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class ToolItemCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class ToolItemCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class ToolItemCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Members

ToolItemCollection overview

Public Constructors

public constructor ToolItemCollection Constructor Initializes a new instance of the ToolItemCollection class.

Public Properties

public property Item | Gets a ToolItemBase at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the ToolItemCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the ToolItemCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the ToolItemCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the ToolItemCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the ToolItemCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the ToolItemCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an ToolItemBase is added.
protected method OnAdding | Overridden. Occurs before an ToolItemBase is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an ToolItemBase is removed.
protected method OnRemoving | Overridden. Occurs before an ToolItemBase is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor

Overload List

Initializes a new instance of the ToolItemCollection class.

[Visual Basic] Public Sub New()
[C#] public ToolItemCollection();
[C++] public: ToolItemCollection();
[JScript] public function ToolItemCollection();

Initializes a new instance of the ToolItemCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public ToolItemCollection(object);
[C++] public: ToolItemCollection(Object*);
[JScript] public function ToolItemCollection(Object);

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor ()

Initializes a new instance of the ToolItemCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemCollection();
[C++]
public: ToolItemCollection();
[JScript]
public function ToolItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Properties

The properties of the ToolItemCollection class are listed here. For a complete list of ToolItemCollection class members, see the ToolItemCollection Members topic.

Public Properties

public property Item | Gets a ToolItemBase at the specified location in the collection.
public property Owner (inherited from ToolItemCollection) | Gets the object that owns the ToolItemCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

Lidor Systems IntegralUI Class Library

ToolItemCollection.Item Property

Gets or sets a tool item within the collection.

Overload List

Gets a ToolItem at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a ToolItem with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


LidorSystems.IntegralUI.Controls.Style

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Controls.Style Namespace

Classes

Class | Description
CheckButtonBoxStyle | Represents the style for drawing the checkbox button.
CommandButtonColorStyle | Represents the style for drawing the command buttons.
CommandButtonFormatStyle | Represents the format style for command buttons.
ControlStripStyle | Represents the style for drawing the control strip space.
LabelEditStyle | Represents the style for drawing and formatting the text control used for editing.
ProgressBarColorStyle | Represents the style for drawing the ProgressBar control.
TextControlColorStyle | Represents the drawing style for TextControl.
TextControlFormatStyle | Represents the format style for TextControl.
ToolItemColorStyle | Represents the style for drawing the tool item.
ToolItemFormatStyle | Represents the format style for tool items.
ToolTipStyle | Represents the style for drawing and formatting the tool tip.

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


CheckButtonBoxStyle Class

Represents the style for drawing the checkbox button.

For a list of all members of this type, see CheckButtonBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.CheckButtonBoxStyle

[Visual Basic]
Public Class CheckButtonBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CheckButtonBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CheckButtonBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CheckButtonBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Members

CheckButtonBoxStyle overview

Public Constructors

public constructor CheckButtonBoxStyle Constructor Initializes a new instance of the CheckButtonBoxStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonSize | Gets or sets the button size.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Constructor ()

Initializes a new instance of the CheckButtonBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CheckButtonBoxStyle();
[C++]
public: CheckButtonBoxStyle();
[JScript]
public function CheckButtonBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Properties

The properties of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonSize | Gets or sets the button size.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ButtonSize Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.ButtonSize Property

Gets or sets the button size.

[Visual Basic]
Public Property ButtonSize As Size
[C#]
public Size ButtonSize {get; set;}
[C++]
public: __property Size get_ButtonSize();
public: __property void set_ButtonSize(Size);
[JScript]
public function get ButtonSize() : Size;
public function set ButtonSize(Size);

Property Value

A Size represents the size of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckColor Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.CheckColor Property

Gets or sets the check mark Color.

[Visual Basic]
Public Property CheckColor As Color
[C#]
public Color CheckColor {get; set;}
[C++]
public: __property Color get_CheckColor();
public: __property void set_CheckColor(Color);
[JScript]
public function get CheckColor() : Color;
public function set CheckColor(Color);

Property Value

A Color represents the check mark color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckedImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.CheckedImage Property

Gets or sets an custom image when the checkbox is checked.

[Visual Basic]
Public Property CheckedImage As Image
[C#]
public Image CheckedImage {get; set;}
[C++]
public: __property Image get_CheckedImage();
public: __property void set_CheckedImage(Image);
[JScript]
public function get CheckedImage() : Image;
public function set CheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IndeterminateImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.IndeterminateImage Property

Gets or sets an custom image when the checkbox is indeterminated.

[Visual Basic]
Public Property IndeterminateImage As Image
[C#]
public Image IndeterminateImage {get; set;}
[C++]
public: __property Image get_IndeterminateImage();
public: __property void set_IndeterminateImage(Image);
[JScript]
public function get IndeterminateImage() : Image;
public function set IndeterminateImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


UncheckedImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.UncheckedImage Property

Gets or sets an custom image when the checkbox is unchecked.

[Visual Basic]
Public Property UncheckedImage As Image
[C#]
public Image UncheckedImage {get; set;}
[C++]
public: __property Image get_UncheckedImage();
public: __property void set_UncheckedImage(Image);
[JScript]
public function get UncheckedImage() : Image;
public function set UncheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Methods

The methods of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.Clone Method

Creates an exact copy of the current CheckButtonBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CheckButtonBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CheckButtonBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Class

Represents the style for drawing the command button.

For a list of all members of this type, see CommandButtonColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.CommandButtonColorStyle

[Visual Basic]
Public Class CommandButtonColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CommandButtonColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CommandButtonColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CommandButtonColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Members

CommandButtonColorStyle overview

Public Constructors

public constructor CommandButtonColorStyle Constructor Initializes a new instance of the CommandButtonColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current CommandButtonColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Constructor ()

Initializes a new instance of the CommandButtonColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonColorStyle();
[C++]
public: CommandButtonColorStyle();
[JScript]
public function CommandButtonColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Properties

The properties of the CommandButtonColorStyle class are listed here. For a complete list of CommandButtonColorStyle class members, see the CommandButtonColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

CommandButtonColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ForeColor Property

Lidor Systems IntegralUI Class Library

CommandButtonColorStyle.ForeColor Property

Gets or sets the color used to draw the button graphics.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color);
[JScript]
public function get ForeColor() : Color;
public function set ForeColor(Color);

Property Value

A Color represents the color used to draw the button graphics.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Methods

The methods of the CommandButtonColorStyle class are listed here. For a complete list of CommandButtonColorStyle class members, see the CommandButtonColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current CommandButtonColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

CommandButtonColorStyle.Clone Method

Creates an exact copy of the current CommandButtonColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CommandButtonColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

CommandButtonColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CommandButtonColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

CommandButtonColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Class

Represents the format style for command buttons.

For a list of all members of this type, see CommandButtonFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.CommandButtonFormatStyle

[Visual Basic]
Public Class CommandButtonFormatStyle Implements
   ICloneable, IDisposable
[C#]
public class CommandButtonFormatStyle : ICloneable, IDisposable
[C++]
public __gc class CommandButtonFormatStyle : public ICloneable, IDisposable
[JScript]
public class CommandButtonFormatStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Members

CommandButtonFormatStyle overview

Public Constructors

public constructor CommandButtonFormatStyle Constructor Initializes a new instance of the CommandButtonFormatStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the button content.
public property Spacing | Specifies the distance between buttons.
public property Visibility | Specifies at which case the button is visible.

Public Events

public event StyleChanged Occurs when the CommandButtonFormatStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current CommandButtonFormatStyle.
public method Dispose | Releases all resources used by this CommandButtonFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Constructor ()

Initializes a new instance of the CommandButtonFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonFormatStyle();
[C++]
public: CommandButtonFormatStyle();
[JScript]
public function CommandButtonFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Properties

The properties of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the button content.
public property Spacing | Specifies the distance between buttons.
public property Visibility | Specifies at which case the button is visible.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ContentSize Property

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.ContentSize Property

Specifies the size of the button content.

[Visual Basic]
Public Property ContentSize As Size
[C#]
public Size ContentSize {get; set;}
[C++]
public: __property Size get_ContentSize();
public: __property void set_ContentSize(Size);
[JScript]
public function get ContentSize() : Size;
public function set ContentSize(Size);

Property Value

A Size represents the size of the button content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Spacing Property

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.Spacing Property

Specifies the distance between buttons.

[Visual Basic]
Public Property Spacing As Integer
[C#]
public int Spacing {get; set;}
[C++]
public: __property int get_Spacing();
public: __property void set_Spacing(int);
[JScript]
public function get Spacing() : int;
public function set Spacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonVisibility Property

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.Visibility Property

Specifies at which case the button is visible.

[Visual Basic]
Public Property Visibility As CommandButtonVisibility
[C#]
public CommandButtonVisibility Visibility {get; set;}
[C++]
public: __property CommandButtonVisibility get_Visibility();
public: __property void set_Visibility(CommandButtonVisibility);
[JScript]
public function get Visibility() : CommandButtonVisibility;
public function set Visibility(CommandButtonVisibility);

Property Value

The CommandButtonVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Methods

The methods of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current CommandButtonFormatStyle.
public method Dispose | Releases all resources used by this CommandButtonFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.Clone Method

Creates an exact copy of the current CommandButtonFormatStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new CommandButtonFormatStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.Dispose Method

Releases all resources used by this CommandButtonFormatStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI.Controls infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the CommandButtonFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Events

The events of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Events

public event StyleChanged Occurs when the CommandButtonFormatStyle changes.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

CommandButtonFormatStyle.StyleChanged Event

Occurs when the CommandButtonFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Class

Represents the style for drawing the control strip space.

For a list of all members of this type, see ControlStripStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ControlStripStyle

[Visual Basic]
Public Class ControlStripStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlStripStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlStripStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlStripStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Members

ControlStripStyle overview

Public Constructors

public constructor ControlStripStyle Constructor Initializes a new instance of the ControlStripStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the control strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ControlStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Constructor ()

Initializes a new instance of the ControlStripStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlStripStyle();
[C++]
public: ControlStripStyle();
[JScript]
public function ControlStripStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Properties

The properties of the ControlStripStyle class are listed here. For a complete list of ControlStripStyle class members, see the ControlStripStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the control strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ControlStripStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Padding Property

Lidor Systems IntegralUI Class Library

ControlStripStyle.Padding Property

Gets or sets the amount of space from the control strip border, in pixels.

[Visual Basic]
Public Property Padding As Padding
[C#]
public Padding Padding { get; set; }
[C++]
public: __property Padding get_Padding();
public: __property void set_Padding(Padding);
[JScript]
public function get Padding() : Padding
public function set Padding(Padding);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Methods

The methods of the ControlStripStyle class are listed here. For a complete list of ControlStripStyle class members, see the ControlStripStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ControlStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ControlStripStyle.Clone Method

Creates an exact copy of the current ControlStripStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlStripStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ControlStripStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlStripStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ControlStripStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Class

Represents the style for drawing and formatting the text control used for editing.

For a list of all members of this type, see LabelEditStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.LabelEditStyle

[Visual Basic]
Public Class LabelEditStyle Implements
   ICloneable, IDisposable
[C#]
public class LabelEditStyle : ICloneable, IDisposable
[C++]
public __gc class LabelEditStyle : public ICloneable, IDisposable
[JScript]
public class LabelEditStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Members

LabelEditStyle overview

Public Constructors

public constructor LabelEditStyle Constructor Initializes a new instance of the LabelEditStyle class.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BorderColor | Gets or sets the shape of the border corner.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderVisibility | Determines which border side will be shown.
public property TextColor | Gets or sets the Color of the text.

Public Events

public event StyleChanged Occurs when the LabelEditStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current LabelEditStyle.
public method Dispose | Releases all resources used by this LabelEditStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Constructor ()

Initializes a new instance of the LabelEditStyle class.

[Visual Basic]
Public Sub New()
[C#]
public LabelEditStyle();
[C++]
public: LabelEditStyle();
[JScript]
public function LabelEditStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Properties

The properties of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BorderColor | Gets or sets the shape of the border corner.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderVisibility | Determines which border side will be shown.
public property TextColor | Gets or sets the Color of the text.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.BorderColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerRadius Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderVisibility Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.BorderVisibility Property

Determines which border side will be shown.

[Visual Basic]
Public Property Visibility As BorderVisibility
[C#]
public BorderVisibility Visibility {get; set;}
[C++]
public: __property BorderVisibility get_Visibility();
public: __property void set_Visibility(BorderVisibility);
[JScript]
public function get Visibility() : BorderVisibility;
public function set Visibility(BorderVisibility);

Property Value

The BorderVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

LabelEditStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Methods

The methods of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current LabelEditStyle.
public method Dispose | Releases all resources used by this LabelEditStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

LabelEditStyle.Clone Method

Creates an exact copy of the current LabelEditStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new LabelEditStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

LabelEditStyle.Dispose Method

Releases all resources used by this LabelEditStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

LabelEditStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the LabelEditStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

LabelEditStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

LabelEditStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


LabelEditStyle Events

The events of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Events

public event StyleChanged Occurs when the LabelEditStyle changes.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

LabelEditStyle.StyleChanged Event

Occurs when the CommandButtonFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Class

Represents the style for drawing the ProgressBar control.

For a list of all members of this type, see ProgressBarColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ProgressBarColorStyle

[Visual Basic]
Public Class ProgressBarColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ProgressBarColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ProgressBarColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ProgressBarColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Members

ProgressBarColorStyle overview

Public Constructors

public constructor ProgressBarColorStyle Constructor Initializes a new instance of the ProgressBarColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BarImage | Specifies the image object to use as a texture for drawing the progress.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ProgressColor | Gets or sets the progress Color.
public property ProgressFadeColor | Gets or sets the progress fade Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ProgressBarColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Constructor ()

Initializes a new instance of the ProgressBarColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressBarColorStyle();
[C++]
public: ProgressBarColorStyle();
[JScript]
public function ProgressBarColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Properties

The properties of the ProgressBarColorStyle class are listed here. For a complete list of ProgressBarColorStyle class members, see the ProgressBarColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BarImage | Specifies the image object to use as a texture for drawing the progress.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ProgressColor | Gets or sets the progress Color.
public property ProgressFadeColor | Gets or sets the progress fade Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BarImage Property

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.BarImage Property

Specifies the image object to use as a texture for drawing the progress.

[Visual Basic]
Public Property BarImage As Image
[C#]
public Image BarImage {get; set;}
[C++]
public: __property Image get_BarImage();
public: __property void set_BarImage(Image);
[JScript]
public function get BarImage() : Image;
public function set BarImage(Image);

Property Value

A Image used as a background texture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressColor Property

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.ProgressColor Property

Gets or sets the progress Color.

[Visual Basic]
Public Property ProgressColor As Color
[C#]
public Color ProgressColor {get; set;}
[C++]
public: __property Color get_ProgressColor();
public: __property void set_ProgressColor(Color);
[JScript]
public function get ProgressColor() : Color;
public function set ProgressColor(Color);

Property Value

A Color represents the progress color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressFadeColor Property

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.ProgressFadeColor Property

Gets or sets the progress fade Color.

[Visual Basic]
Public Property ProgressFadeColor As Color
[C#]
public Color ProgressFadeColor {get; set;}
[C++]
public: __property Color get_ProgressFadeColor();
public: __property void set_ProgressFadeColor(Color);
[JScript]
public function get ProgressFadeColor() : Color;
public function set ProgressFadeColor(Color);

Property Value

A Color represents the progress fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Methods

The methods of the ProgressBarColorStyle class are listed here. For a complete list of ProgressBarColorStyle class members, see the ProgressBarColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ProgressBarColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.Clone Method

Creates an exact copy of the current ProgressBarColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ProgressBarColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ProgressBarColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ProgressBarColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Class

Represents the drawing style for TextControl.

For a list of all members of this type, see TextControlColorStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.TextControlColorStyle

[Visual Basic]
Public Class TextControlColorStyle Implements
   ICloneable, IDisposable
[C#]
public class TextControlColorStyle : ICloneable, IDisposable
[C++]
public __gc class TextControlColorStyle : public ICloneable, IDisposable
[JScript]
public class TextControlColorStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Members

TextControlColorStyle overview

Public Constructors

public constructor TextControlColorStyle Constructor Initializes a new instance of the TextControlColorStyle class.

Public Properties

public property BackColor | Gets or sets the background Color
public property BorderColor | Gets or sets the border Color
public property TextColor | Gets or sets the text Color

Public Events

public event StyleChanged Occurs when the TextControlColorStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current TextControlColorStyle.
public method Dispose | Releases all resources used by this TextControlColorStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Constructor ()

Initializes a new instance of the TextControlColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TextControlColorStyle();
[C++]
public: TextControlColorStyle();
[JScript]
public function TextControlColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Properties

The properties of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color
public property BorderColor | Gets or sets the border Color
public property TextColor | Gets or sets the text Color

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BackColor Property

Lidor Systems IntegralUI Class Library

TextControlColorStyle.BackColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color);
[JScript]
public function get BackColor() : Color;
public function set BackColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

TextControlColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

TextControlColorStyle.TextColor Property

Gets or sets the text Color.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Methods

The methods of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current TextControlColorStyle.
public method Dispose | Releases all resources used by this TextControlColorStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

TextControlColorStyle.Clone Method

Creates an exact copy of the current TextControlColorStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new TextControlColorStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

TextControlColorStyle.Dispose Method

Releases all resources used by this TextControlColorStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

TextControlColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI.Controls infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the TextControlColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

TextControlColorStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

TextControlColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Events

The events of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Events

public event StyleChanged Occurs when the TextControlColorStyle changes.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

TextControlColorStyle.StyleChanged Event

Occurs when the TextControlColorStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControFormatStyle Members

TextControFormatStyle overview

Public Constructors

public constructor TextControFormatStyle Constructor Initializes a new instance of the TextControFormatStyle class.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the TextControFormatStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current TextControFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


TextControFormatStyle Constructor ()

Initializes a new instance of the TextControFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TextControFormatStyle();
[C++]
public: TextControFormatStyle();
[JScript]
public function TextControFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


TextControFormatStyle Properties

The properties of the TextControFormatStyle class are listed here. For a complete list of TextControFormatStyle class members, see the TextControFormatStyle Members topic.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

TextControFormatStyle.Font Property

Gets or sets the font used to display the control text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextAlign Property

Lidor Systems IntegralUI Class Library

TextControFormatStyle.TextAlign Property

Gets or sets the alignment of the text.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign { get; set; }
[C++]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(ContentAlignment);
[JScript]
public function get TextAlign() : ContentAlignment
public function set TextAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextControFormatStyle Methods

The methods of the TextControFormatStyle class are listed here. For a complete list of TextControFormatStyle class members, see the TextControFormatStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current TextControFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

TextControFormatStyle.Clone Method

Creates an exact copy of the current TextControFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TextControFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

TextControFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TextControFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

TextControFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemColorStyle Class

Represents the style for drawing the tool item.

For a list of all members of this type, see ToolItemColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ToolItemColorStyle

[Visual Basic]
Public Class ToolItemColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ToolItemColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ToolItemColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ToolItemColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Members

ToolItemColorStyle overview

Public Constructors

public constructor ToolItemColorStyle Constructor Initializes a new instance of the ToolItemColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolItemColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Constructor ()

Initializes a new instance of the ToolItemColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemColorStyle();
[C++]
public: ToolItemColorStyle();
[JScript]
public function ToolItemColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Properties

The properties of the ToolItemColorStyle class are listed here. For a complete list of ToolItemColorStyle class members, see the ToolItemColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ForeColor Property

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.ForeColor Property

Gets or sets the color used to draw the tool item graphics.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color);
[JScript]
public function get ForeColor() : Color;
public function set ForeColor(Color);

Property Value

A Color represents the color used to draw the tool item graphics.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemColorStyle Methods

The methods of the ToolItemColorStyle class are listed here. For a complete list of ToolItemColorStyle class members, see the ToolItemColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolItemColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.Clone Method

Creates an exact copy of the current ToolItemColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ToolItemColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolItemColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ToolItemColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Class

Represents the format style for tool items.

For a list of all members of this type, see ToolItemFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.ToolItemFormatStyle

[Visual Basic]
Public Class ToolItemFormatStyle Implements
   ICloneable, IDisposable
[C#]
public class ToolItemFormatStyle : ICloneable, IDisposable
[C++]
public __gc class ToolItemFormatStyle : public ICloneable, IDisposable
[JScript]
public class ToolItemFormatStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Members

ToolItemFormatStyle overview

Public Constructors

public constructor ToolItemFormatStyle Constructor Initializes a new instance of the ToolItemFormatStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the tool item content.
public property Font | Specifies at which case the tool item is visible.
public property ItemSpacing | Specifies the distance between tool items.

Public Events

public event StyleChanged Occurs when the ToolItemFormatStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current ToolItemFormatStyle.
public method Dispose | Releases all resources used by this ToolItemFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Constructor ()

Initializes a new instance of the ToolItemFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemFormatStyle();
[C++]
public: ToolItemFormatStyle();
[JScript]
public function ToolItemFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Properties

The properties of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the tool item content.
public property Font | Specifies at which case the tool item is visible.
public property ItemSpacing | Specifies the distance between tool items.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ContentSize Property

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.ContentSize Property

Specifies the size of the tool item content.

[Visual Basic]
Public Property ContentSize As Size
[C#]
public Size ContentSize {get; set;}
[C++]
public: __property Size get_ContentSize();
public: __property void set_ContentSize(Size);
[JScript]
public function get ContentSize() : Size;
public function set ContentSize(Size);

Property Value

A Size represents the size of the tool item content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.Font Property

Gets or sets the font used to display the tool item text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the tool item text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ItemSpacing Property

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.ItemSpacing Property

Specifies the distance between tool items.

[Visual Basic]
Public Property ItemSpacing As Integer
[C#]
public int ItemSpacing {get; set;}
[C++]
public: __property int get_ItemSpacing();
public: __property void set_ItemSpacing(int);
[JScript]
public function get ItemSpacing() : int;
public function set ItemSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Methods

The methods of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current ToolItemFormatStyle.
public method Dispose | Releases all resources used by this ToolItemFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.Clone Method

Creates an exact copy of the current ToolItemFormatStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolItemFormatStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.Dispose Method

Releases all resources used by this ToolItemFormatStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolItemFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemFormatStyle Events

The events of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Events

public event StyleChanged Occurs when the ToolItemFormatStyle changes.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

ToolItemFormatStyle.StyleChanged Event

Occurs when the ToolItemFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Class

Represents the style for drawing and formatting the tool tip.

For a list of all members of this type, see ToolTipStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ToolTipStyle

[Visual Basic]
Public Class ToolTipStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ToolTipStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ToolTipStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ToolTipStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Members

ToolTipStyle overview

Public Constructors

public constructor ToolTipStyle Constructor Initializes a new instance of the ToolTipStyle class.

Public Properties

public property AutoPopDelay | Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the tool tip.
public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Font | Gets or sets the font used to display the tool tip text.
public property InitialDelay | Gets or sets the time that passes before the ToolTip appears.
public property TextColor | Gets or sets the Color of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolTipStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Constructor ()

Initializes a new instance of the ToolTipStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolTipStyle();
[C++]
public: ToolTipStyle();
[JScript]
public function ToolTipStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Properties

The properties of the ToolTipStyle class are listed here. For a complete list of ToolTipStyle class members, see the ToolTipStyle Members topic.

Public Properties

public property AutoPopDelay | Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the tool tip.
public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Font | Gets or sets the font used to display the tool tip text.
public property InitialDelay | Gets or sets the time that passes before the ToolTip appears.
public property TextColor | Gets or sets the Color of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


AutoPopDelay Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.AutoPopDelay Property

Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.

[Visual Basic]
Public Property AutoPopDelay As Integer
[C#]
public int AutoPopDelay {get; set;}
[C++]
public: __property int get_AutoPopDelay();
public: __property void set_AutoPopDelay(int);
[JScript]
public function get AutoPopDelay() : int;
public function set AutoPopDelay(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BackImage Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.BackImage Property

Gets or sets an image used as a background texture for the tool tip.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a background texture for the tool tip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerRadius Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.Font Property

Gets or sets the font used to display the tool tip text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the tool tip text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


InitialDelay Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.InitialDelay Property

Gets or sets the time that passes before the ToolTip appears.

[Visual Basic]
Public Property InitialDelay As Integer
[C#]
public int InitialDelay {get; set;}
[C++]
public: __property int get_InitialDelay();
public: __property void set_InitialDelay(int);
[JScript]
public function get InitialDelay() : int;
public function set InitialDelay(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextRendering Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

ToolTipStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Methods

The methods of the ToolTipStyle class are listed here. For a complete list of ToolTipStyle class members, see the ToolTipStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolTipStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ToolTipStyle.Clone Method

Creates an exact copy of the current ToolTipStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ToolTipStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ToolTipStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolTipStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ToolTipStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BackgroundStyle Class

Represents the common style for drawing the background of all objects.

For a list of all members of this type, see BackgroundStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle

[Visual Basic]
Public Class BackgroundStyle Implements
   ICloneable, IDisposable
[C#]
public class BackgroundStyle : ICloneable, IDisposable
[C++]
public __gc class BackgroundStyle : public ICloneable, IDisposable
[JScript]
public class BackgroundStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Members

BackgroundStyle overview

Public Constructors

public constructor BackgroundStyle Constructor Initializes a new instance of the BackgroundStyle class.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property Transparency | A value specifying the percentage of transparency.
public property TransparencyLevel | A value specifying the level of transparency.

Public Events

public event StyleChanged Occurs when the BackgroundStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current BackgroundStyle.
public method Dispose | Releases all resources used by this BackgroundStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Constructor ()

Initializes a new instance of the BackgroundStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BackgroundStyle();
[C++]
public: BackgroundStyle();
[JScript]
public function BackgroundStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Properties

The properties of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property Transparency | A value specifying the percentage of transparency.
public property TransparencyLevel | A value specifying the level of transparency.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackColor Property

Lidor Systems IntegralUI Class Library

BackgroundStyle.BackColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color);
[JScript]
public function get BackColor() : Color;
public function set BackColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackFadeColor Property

Lidor Systems IntegralUI Class Library

BackgroundStyle.BackFadeColor Property

Gets or sets the background fade Color.

[Visual Basic]
Public Property BackFadeColor As Color
[C#]
public Color BackFadeColor {get; set;}
[C++]
public: __property Color get_BackFadeColor();
public: __property void set_BackFadeColor(Color);
[JScript]
public function get BackFadeColor() : Color;
public function set BackFadeColor(Color);

Property Value

A Color represents the background fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


FillStyle Property

Lidor Systems IntegralUI Class Library

BackgroundStyle.FillStyle Property

Gets or sets an enumeration that determines the gradient direction.

[Visual Basic]
Public Property FillStyle As FillStyle
[C#]
public FillStyle FillStyle {get; set;}
[C++]
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(FillStyle);
[JScript]
public function get FillStyle() : FillStyle;
public function set FillStyle(FillStyle);

Property Value

The FillStyle assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Transparency Property

Lidor Systems IntegralUI Class Library

BackgroundStyle.Transparency Property

A value specifying the percentage of transparency.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}
[C++]
public: __property int get_Transparency();
public: __property void set_Transparency(int);
[JScript]
public function get Transparency() : int;
public function set Transparency(int);

Property Value

Transparency is in percentage, so the value can be from 0 to 100. Default setting is 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


TransparencyLevel Property

Lidor Systems IntegralUI Class Library

BackgroundStyle.TransparencyLevel Property

A value specifying the level of transparency.

[Visual Basic]
Public Property TransparencyLevel As TransparencyLevel
[C#]
public TransparencyLevel TransparencyLevel {get; set;}
[C++]
public: __property TransparencyLevel get_TransparencyLevel();
public: __property void set_TransparencyLevel(TransparencyLevel);
[JScript]
public function get TransparencyLevel() : TransparencyLevel;
public function set TransparencyLevel(TransparencyLevel);

Property Value

The TransparencyLevel assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Methods

The methods of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current BackgroundStyle.
public method Dispose | Releases all resources used by this BackgroundStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

BackgroundStyle.Clone Method

Creates an exact copy of the current BackgroundStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BackgroundStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

ListColumnColorStyle.Dispose Method

Releases all resources used by this ListColumnColorStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListColumnColorStyle Class | ListColumnColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

BackgroundStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the BackgroundStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

BackgroundStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

BackgroundStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Events

The events of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Events

public event StyleChanged Occurs when the BackgroundStyle changes.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

BackgroundStyle.StyleChanged Event

Occurs when the BackgroundStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Class

Represents the style for drawing the form displayed when the background process is active.

For a list of all members of this type, see BackgroundProcessStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.BackgroundProcessStyle

[Visual Basic]
Public Class BackgroundProcessStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class BackgroundProcessStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class BackgroundProcessStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class BackgroundProcessStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Members

BackgroundProcessStyle overview

Public Constructors

public constructor BackgroundProcessStyle Constructor Initializes a new instance of the BackgroundProcessStyle class.

Public Properties

public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property Font | Gets or sets the font used to display the information about the process progress.
public property Image | Gets or sets an image that shows the process progress.
public property Padding | Gets or sets the amount of space from the border, in pixels.
public property TextColor | Gets or sets the Color of the text.
public property Text | Gets or sets the text that gives information about the process progress.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the BackgroundProcessStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current BackgroundProcessStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Constructor ()

Initializes a new instance of the BackgroundProcessStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BackgroundProcessStyle();
[C++]
public: BackgroundProcessStyle();
[JScript]
public function BackgroundProcessStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Properties

The properties of the BackgroundProcessStyle class are listed here. For a complete list of BackgroundProcessStyle class members, see the BackgroundProcessStyle Members topic.

Public Properties

public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property Font | Gets or sets the font used to display the information about the process progress.
public property Image | Gets or sets an image that shows the process progress.
public property Padding | Gets or sets the amount of space from the border, in pixels.
public property TextColor | Gets or sets the Color of the text.
public property Text | Gets or sets the text that gives information about the process progress.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerRadius Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Font Property

Gets or sets the font used to display the information about the process progress.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the information about the process progress.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Image Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Image Property

Gets or sets an image that shows the process progress.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image {get; set;}
[C++]
public: __property Image get_Image();
public: __property void set_Image(Image);
[JScript]
public function get Image() : Image;
public function set Image(Image);

Property Value

A Image used to show the process progress. Accepts animated gifs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Padding Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Padding Property

Gets or sets the amount of space from the border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Text Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Text Property

Gets or sets the text that gives information about the process progress.

[Visual Basic]
Public Overridable Property Text As String
[C#]
public virtual String Text {get; set;}
[C++]
public: __property virtual String* get_Text();
public: __property virtual void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI Namespace


TextRendering Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Methods

The methods of the BackgroundProcessStyle class are listed here. For a complete list of BackgroundProcessStyle class members, see the BackgroundProcessStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current BackgroundProcessStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Clone Method

Creates an exact copy of the current BackgroundProcessStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new BackgroundProcessStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the BackgroundProcessStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

BackgroundProcessStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Class

Represents the class that controls the border corners for all objects.

For a list of all members of this type, see BorderCornerShape Members.

System.Object
LidorSystems.IntegralUI.Style.BorderCornerShape

[Visual Basic]
 Public Class BorderCornerShape
   Implements ICloneable
[C#]
 public class BorderCornerShape : ICloneable
[C++]
 public __gc class BorderCornerShape : public ICloneable
[JScript]
 public class BorderCornerShape implements ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Members

BorderCornerShape overview

Public Constructors

public constructor BorderCornerShape Constructor Initializes a new instance of the BorderCornerShape class.

Public Properties

public property BottomLeft | Gets or sets the bottom-left corner shape.
public property BottomRight | Gets or sets the bottom-right corner shape.
public property IsAllSquared | Checks whether all corners are squared.
public property TopLeft | Gets or sets the top-left corner shape.
public property TopRight | Gets or sets the top-right corner shape.

Public Events

public event BorderCornerChanged Occurs when the BorderCornerShape changes.

Public Methods

public method Clone Creates an exact copy of the current BorderCornerShape.
public method IsBorderChanged Determines whether the BorderCornerShape object has changed.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBorderCornerChanged | Raises the BorderCornerChanged event.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor

Overload List

Initializes a new instance of the BorderCornerShape class.

[Visual Basic] Public Sub New()
[C#] public BorderCornerShape();
[C++] public: BorderCornerShape();
[JScript] public function BorderCornerShape();

Initializes a new instance of the BorderCornerShape class and sets all corners to the given CornerShape.

[Visual Basic] Public Sub BorderCornerShape(CornerShape)
[C#] public BorderCornerShape(CornerShape);
[C++] public: BorderCornerShape(CornerShape);
[JScript] public function BorderCornerShape(CornerShape);

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor ()

Initializes a new instance of the BorderCornerShape class.

[Visual Basic]
Public Sub New()
[C#]
public BorderCornerShape();
[C++]
public: BorderCornerShape();
[JScript]
public function BorderCornerShape();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor (CornerShape)

Initializes a new instance of the BorderCornerShape class and sets all corners to the given CornerShape.

[Visual Basic]
Public Sub New( _
   ByVal shape As CornerShape _
)
[C#]
public BorderCornerShape(
   CornerShape shape
);
[C++]
public: BorderCornerShape(
   CornerShape shape
);
[JScript]
public function BorderCornerShape(
   shape : CornerShape
);

Parameters

shape

The CornerShape enumeration for the new BorderCornerShape object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Properties

The properties of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Properties

public property BottomLeft | Gets or sets the bottom-left corner shape.
public property BottomRight | Gets or sets the bottom-right corner shape.
public property IsAllSquared | Checks whether all corners are squared.
public property TopLeft | Gets or sets the top-left corner shape.
public property TopRight | Gets or sets the top-right corner shape.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI Namespace


BottomLeft Property

Lidor Systems IntegralUI Class Library

BorderCornerShape.BottomLeft Property

Gets or sets the bottom-left corner shape.

[Visual Basic]
Public Property BottomLeft As CornerShape
[C#]
public CornerShape BottomLeft {get; set;}
[C++]
public: __property CornerShape get_BottomLeft();
public: __property void set_BottomLeft(CornerShape);
[JScript]
public function get BottomLeft() : CornerShape;
public function set BottomLeft(CornerShape);

Property Value

A CornerShape enumeration for the bottom-left corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BottomRight Property

Lidor Systems IntegralUI Class Library

BorderCornerShape.BottomRight Property

Gets or sets the bottom-right corner shape.

[Visual Basic]
Public Property BottomRight As CornerShape
[C#]
public CornerShape BottomRight {get; set;}
[C++]
public: __property CornerShape get_BottomRight();
public: __property void set_BottomRight(CornerShape);
[JScript]
public function get BottomRight() : CornerShape;
public function set BottomRight(CornerShape);

Property Value

A CornerShape enumeration for the bottom-right corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


TopLeft Property

Lidor Systems IntegralUI Class Library

BorderCornerShape.TopLeft Property

Gets or sets the top-left corner shape.

[Visual Basic]
Public Property TopLeft As CornerShape
[C#]
public CornerShape TopLeft {get; set;}
[C++]
public: __property CornerShape get_TopLeft();
public: __property void set_TopLeft(CornerShape);
[JScript]
public function get TopLeft() : CornerShape;
public function set TopLeft(CornerShape);

Property Value

A CornerShape enumeration for the top-left corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


TopRight Property

Lidor Systems IntegralUI Class Library

BorderCornerShape.TopRight Property

Gets or sets the top-right corner shape.

[Visual Basic]
Public Property TopRight As CornerShape
[C#]
public CornerShape TopRight {get; set;}
[C++]
public: __property CornerShape get_TopRight();
public: __property void set_TopRight(CornerShape);
[JScript]
public function get TopRight() : CornerShape;
public function set TopRight(CornerShape);

Property Value

A CornerShape enumeration for the top-right corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Methods

The methods of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Methods

public method Clone Creates an exact copy of the current BorderCornerShape.
public method IsBorderChanged Determines whether the BorderCornerShape object has changed.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBorderCornerChanged | Raises the BorderCornerChanged event.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

BorderCornerShape.Clone Method

Creates an exact copy of the current BorderCornerShape.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BorderCornerShape object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


IsBorderChanged Method

Lidor Systems IntegralUI Class Library

BorderCornerShape.IsBorderChanged Method

Determines whether the BorderCornerShape object has changed.

[Visual Basic]
Public Overridable Function IsBorderChanged() As Boolean
[C#]
public virtual bool IsBorderChanged();
[C++]
public: virtual bool IsBorderChanged();
[JScript]
public function IsBorderChanged() : Boolean;

Return Value

Returns true if the BorderCornerShape object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


OnBorderCornerChanged Method

Lidor Systems IntegralUI Class Library

BorderCornerShape.OnBorderCornerChanged Method

Raises the BorderCornerChanged event.

[Visual Basic]
Protected Overridable Sub OnBorderCornerChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnBorderCornerChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnBorderCornerChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnBorderCornerChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBorderCornerChanged in a derived class, be sure to call the base class's OnBorderCornerChanged method so that registered delegates receive the event.

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Events

The events of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Events

public event BorderCornerChanged Occurs when the BorderCornerShape changes.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerChanged Event

Lidor Systems IntegralUI Class Library

BorderCornerShape.BorderCornerChanged Event

Occurs when the BorderCornerShape changes.

[Visual Basic]
Public Event BorderCornerChanged As StyleEventHandler
[C#]
public event StyleEventHandler BorderCornerChanged;
[C++]
public: __event StyleEventHandler* BorderCornerChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Class

Represents the common style for drawing the border of all controls.

For a list of all members of this type, see BorderStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle

[Visual Basic]
Public Class BorderStyle Implements
   ICloneable, IDisposable
[C#]
public class BorderStyle : ICloneable, IDisposable
[C++]
public __gc class BorderStyle : public ICloneable, IDisposable
[JScript]
public class BorderStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Members

BorderStyle overview

Public Constructors

public constructor BorderStyle Constructor Initializes a new instance of the BorderStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderLineStyle | Gets or sets the style of the border line.
public property BorderVisibility | Determines which border side will be shown.

Public Events

public event StyleChanged Occurs when the BorderStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current BorderStyle.
public method Dispose | Releases all resources used by this BorderStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderStyle Constructor ()

Initializes a new instance of the BorderStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BorderStyle();
[C++]
public: BorderStyle();
[JScript]
public function BorderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderStyle Properties

The properties of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderLineStyle | Gets or sets the style of the border line.
public property BorderVisibility | Determines which border side will be shown.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Property

Lidor Systems IntegralUI Class Library

BorderStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderLineStyle Property

Lidor Systems IntegralUI Class Library

BorderStyle.BorderLineStyle Property

Gets or sets the style of the border line.

[Visual Basic]
Public Property BorderLineStyle As LineStyle
[C#]
public LineStyle BorderLineStyle {get; set;}
[C++]
public: __property LineStyle get_BorderLineStyle();
public: __property void set_BorderLineStyle(LineStyle);
[JScript]
public function get BorderLineStyle() : LineStyle;
public function set BorderLineStyle(LineStyle);

Property Value

A LineStyle assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderVisibility Property

Lidor Systems IntegralUI Class Library

BorderStyle.BorderVisibility Property

Determines which border side will be shown.

[Visual Basic]
Public Property BorderVisibility As BorderVisibility
[C#]
public BorderVisibility BorderVisibility {get; set;}
[C++]
public: __property BorderVisibility get_BorderVisibility();
public: __property void set_BorderVisibility(BorderVisibility);
[JScript]
public function get BorderVisibility() : BorderVisibility;
public function set BorderVisibility(BorderVisibility);

Property Value

The BorderVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Methods

The methods of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current BorderStyle.
public method Dispose | Releases all resources used by this BorderStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

BorderStyle.Clone Method

Creates an exact copy of the current BorderStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BorderStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

Lidor Systems IntegralUI Class Library

BorderStyle.Dispose Method

Releases all resources used by this BorderStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

BorderStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the BorderStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

Lidor Systems IntegralUI Class Library

BorderStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

BorderStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Events

The events of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Events

public event StyleChanged Occurs when the BorderStyle changes.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


StyleChanged Event

Lidor Systems IntegralUI Class Library

BorderStyle.StyleChanged Event

Occurs when the BorderStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Class

Represents the style for drawing the checkbox button.

For a list of all members of this type, see CheckButtonBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.CheckButtonBoxStyle

[Visual Basic]
Public Class CheckButtonBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CheckButtonBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CheckButtonBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CheckButtonBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Members

CheckButtonBoxStyle overview

Public Constructors

public constructor CheckButtonBoxStyle Constructor Initializes a new instance of the CheckButtonBoxStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Constructor ()

Initializes a new instance of the CheckButtonBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CheckButtonBoxStyle();
[C++]
public: CheckButtonBoxStyle();
[JScript]
public function CheckButtonBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Properties

The properties of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckColor Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.CheckColor Property

Gets or sets the check mark Color.

[Visual Basic]
Public Property CheckColor As Color
[C#]
public Color CheckColor {get; set;}
[C++]
public: __property Color get_CheckColor();
public: __property void set_CheckColor(Color);
[JScript]
public function get CheckColor() : Color;
public function set CheckColor(Color);

Property Value

A Color represents the check mark color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckedImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.CheckedImage Property

Gets or sets an custom image when the checkbox is checked.

[Visual Basic]
Public Property CheckedImage As Image
[C#]
public Image CheckedImage {get; set;}
[C++]
public: __property Image get_CheckedImage();
public: __property void set_CheckedImage(Image);
[JScript]
public function get CheckedImage() : Image;
public function set CheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IndeterminateImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.IndeterminateImage Property

Gets or sets an custom image when the checkbox is indeterminated.

[Visual Basic]
Public Property IndeterminateImage As Image
[C#]
public Image IndeterminateImage {get; set;}
[C++]
public: __property Image get_IndeterminateImage();
public: __property void set_IndeterminateImage(Image);
[JScript]
public function get IndeterminateImage() : Image;
public function set IndeterminateImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


UncheckedImage Property

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.UncheckedImage Property

Gets or sets an custom image when the checkbox is unchecked.

[Visual Basic]
Public Property UncheckedImage As Image
[C#]
public Image UncheckedImage {get; set;}
[C++]
public: __property Image get_UncheckedImage();
public: __property void set_UncheckedImage(Image);
[JScript]
public function get UncheckedImage() : Image;
public function set UncheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Methods

The methods of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.Clone Method

Creates an exact copy of the current CheckButtonBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CheckButtonBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CheckButtonBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

CheckButtonBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Members

ControlColorStyle overview

Public Constructors

public constructor ControlColorStyle Constructor Initializes a new instance of the ControlColorStyle class.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property DropMarkerColor | Gets or sets the Color of the drop marker used during drag&drop operations.
public property FocusFrameColor | Gets or sets the Color of the frame that represents that the control has input focus.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Constructor ()

Initializes a new instance of the ControlColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlColorStyle();
[C++]
public: ControlColorStyle();
[JScript]
public function ControlColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Properties

The properties of the ControlColorStyle class are listed here. For a complete list of ControlColorStyle class members, see the ControlColorStyle Members topic.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property DropMarkerColor | Gets or sets the Color of the drop marker used during drag&drop operations.
public property FocusFrameColor | Gets or sets the Color of the frame that represents that the control has input focus.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


BackImage Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.BackImage Property

Gets or sets an image that fills the control background.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a control background.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


DropMarkerColor Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.DropMarkerColor Property

Gets or sets the Color of the drop marker used during drag&drop operations.

[Visual Basic]
Public Property DropMarkerColor As Color
[C#]
public Color DropMarkerColor {get; set;}
[C++]
public: __property Color get_DropMarkerColor();
public: __property void set_DropMarkerColor(Color);
[JScript]
public function get DropMarkerColor() : Color;
public function set DropMarkerColor(Color);

Property Value

A Color of the drop marker used during drag&drop operations.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


FocusFrameColor Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.FocusFrameColor Property

Gets or sets the Color of the frame that represents that the control has input focus.

[Visual Basic]
Public Property FocusFrameColor As Color
[C#]
public Color FocusFrameColor {get; set;}
[C++]
public: __property Color get_FocusFrameColor();
public: __property void set_FocusFrameColor(Color);
[JScript]
public function get FocusFrameColor() : Color;
public function set FocusFrameColor(Color);

Property Value

A Color of the frame that represents that the control has input focus.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

ControlColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Methods

The methods of the ControlColorStyle class are listed here. For a complete list of ControlColorStyle class members, see the ControlColorStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ControlColorStyle.Clone Method

Creates an exact copy of the current ControlColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ControlColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ControlColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Class

Represents the basic format style for controls.

For a list of all members of this type, see ControlFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.ControlFormatStyle

[Visual Basic]
Public Class ControlFormatStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlFormatStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlFormatStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlFormatStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Members

ControlFormatStyle overview

Public Constructors

public constructor ControlFormatStyle Constructor Initializes a new instance of the ControlFormatStyle class.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlFormatStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Constructor ()

Initializes a new instance of the ControlFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlFormatStyle();
[C++]
public: ControlFormatStyle();
[JScript]
public function ControlFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Properties

The properties of the ControlFormatStyle class are listed here. For a complete list of ControlFormatStyle class members, see the ControlFormatStyle Members topic.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Font Property

Lidor Systems IntegralUI Class Library

ControlFormatStyle.Font Property

Gets or sets the font used to display the control text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextAlign Property

Lidor Systems IntegralUI Class Library

ControlFormatStyle.TextAlign Property

Gets or sets the alignment of the text.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign { get; set; }
[C++]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(ContentAlignment);
[JScript]
public function get TextAlign() : ContentAlignment
public function set TextAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextRendering Property

Lidor Systems IntegralUI Class Library

ControlFormatStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ControlFormatStyle Methods

The methods of the ControlFormatStyle class are listed here. For a complete list of ControlFormatStyle class members, see the ControlFormatStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ControlFormatStyle.Clone Method

Creates an exact copy of the current ControlFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ControlFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ControlFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Class

Represents the style for drawing the control header.

For a list of all members of this type, see ControlHeaderColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ControlHeaderColorStyle

[Visual Basic]
Public Class ControlHeaderColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlHeaderColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlHeaderColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlHeaderColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Members

ControlHeaderColorStyle overview

Public Constructors

public constructor ControlHeaderColorStyle Constructor Initializes a new instance of the ControlHeaderColorStyle class.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlHeaderColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlHeaderColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Constructor ()

Initializes a new instance of the ControlHeaderColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlHeaderColorStyle();
[C++]
public: ControlHeaderColorStyle();
[JScript]
public function ControlHeaderColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Properties

The properties of the ControlHeaderColorStyle class are listed here. For a complete list of ControlHeaderColorStyle class members, see the ControlHeaderColorStyle Members topic.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


BackImage Property

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.BackImage Property

Gets or sets an image that fills the header background.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a header background.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextColor Property

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Methods

The methods of the ControlHeaderColorStyle class are listed here. For a complete list of ControlHeaderColorStyle class members, see the ControlHeaderColorStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlHeaderColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.Clone Method

Creates an exact copy of the current ControlHeaderColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlHeaderColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlHeaderColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ControlHeaderColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Class

Represents the basic format style for headers.

For a list of all members of this type, see ControlHeaderFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.ControlFormatStyle
LidorSystems.IntegralUI.Style.ControlHeaderFormatStyle

[Visual Basic]
Public Class ControlHeaderFormatStyle
   Inherits LidorSystems.IntegralUI.Style.ControlFormatStyle
[C#]
public class ControlHeaderFormatStyle: LidorSystems.IntegralUI.Style.ControlFormatStyle
[C++]
public __gc class ControlHeaderFormatStyle: public LidorSystems.IntegralUI.Style.ControlFormatStyle
[JScript]
public class ControlHeaderFormatStyle extends LidorSystems.IntegralUI.Style.ControlFormatStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Members

ControlHeaderFormatStyle overview

Public Constructors

public constructor ControlHeaderFormatStyle Constructor Initializes a new instance of the ControlHeaderFormatStyle class.

Public Properties

public property BorderCornerRadius (inherited from BorderStyle) | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property ContentSpacing | Specifies the distance between objects in header.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property Padding | Gets or sets the amount of space from the header border, in pixels.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged (inherited from BorderStyle) Occurs when the ControlHeaderFormatStyle changes.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ControlHeaderFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Constructor ()

Initializes a new instance of the ControlHeaderFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlHeaderFormatStyle();
[C++]
public: ControlHeaderFormatStyle();
[JScript]
public function ControlHeaderFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Properties

The properties of the ControlHeaderFormatStyle class are listed here. For a complete list of ControlHeaderFormatStyle class members, see the ControlHeaderFormatStyle Members topic.

Public Properties

public property BorderCornerRadius (inherited from BorderStyle) | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property ContentSpacing | Specifies the distance between objects in header.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property Padding | Gets or sets the amount of space from the header border, in pixels.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ContentSpacing Property

Lidor Systems IntegralUI Class Library

ControlHeaderFormatStyle.ContentSpacing Property

Specifies the distance between objects in header.

[Visual Basic]
Public Property ContentSpacing As Integer
[C#]
public int ContentSpacing {get; set;}
[C++]
public: __property int get_ContentSpacing();
public: __property void set_ContentSpacing(int);
[JScript]
public function get ContentSpacing() : int;
public function set ContentSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Padding Property

Lidor Systems IntegralUI Class Library

ControlHeaderFormatStyle.Padding Property

Gets or sets the amount of space from the header border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Methods

The methods of the ControlHeaderFormatStyle class are listed here. For a complete list of ControlHeaderFormatStyle class members, see the ControlHeaderFormatStyle Members topic.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ControlHeaderFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ControlHeaderFormatStyle.Clone Method

Creates an exact copy of the current ControlHeaderFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlHeaderFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ControlHeaderFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlHeaderFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Class

Represents the style for drawing the expandbox button.

For a list of all members of this type, see ExpandBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ExpandBoxStyle

[Visual Basic]
Public Class ExpandBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ExpandBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ExpandBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ExpandBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Members

ExpandBoxStyle overview

Public Constructors

public constructor ExpandBoxStyle Constructor Initializes a new instance of the ExpandBoxStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property CollapseImage | Gets or sets an custom image that represents the collapsed state.
public property ExpandImage | Gets or sets an custom image that represents the expanded state.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ExpandBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Constructor ()

Initializes a new instance of the ExpandBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ExpandBoxStyle();
[C++]
public: ExpandBoxStyle();
[JScript]
public function ExpandBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Properties

The properties of the ExpandBoxStyle class are listed here. For a complete list of ExpandBoxStyle class members, see the ExpandBoxStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property CollapseImage | Gets or sets an custom image that represents the collapsed state.
public property ExpandImage | Gets or sets an custom image that represents the expanded state.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonColor Property

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.ButtonColor Property

Gets or sets the button Color.

[Visual Basic]
Public Property ButtonColor As Color
[C#]
public Color ButtonColor {get; set;}
[C++]
public: __property Color get_ButtonColor();
public: __property void set_ButtonColor(Color);
[JScript]
public function get ButtonColor() : Color;
public function set ButtonColor(Color);

Property Value

A Color represents the button color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CollapseImage Property

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.CollapseImage Property

Gets or sets an custom image that represents the collapsed state.

[Visual Basic]
Public Property CollapseImage As Image
[C#]
public Image CollapseImage {get; set;}
[C++]
public: __property Image get_CollapseImage();
public: __property void set_CollapseImage(Image);
[JScript]
public function get CollapseImage() : Image;
public function set CollapseImage(Image);

Property Value

A Image used for expandbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandImage Property

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.ExpandImage Property

Gets or sets an custom image that represents the expanded state.

[Visual Basic]
Public Property ExpandImage As Image
[C#]
public Image ExpandImage {get; set;}
[C++]
public: __property Image get_ExpandImage();
public: __property void set_ExpandImage(Image);
[JScript]
public function get ExpandImage() : Image;
public function set ExpandImage(Image);

Property Value

A Image used for expandbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Methods

The methods of the ExpandBoxStyle class are listed here. For a complete list of ExpandBoxStyle class members, see the ExpandBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ExpandBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.Clone Method

Creates an exact copy of the current ExpandBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ExpandBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ExpandBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ExpandBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Class

Represents the style for drawing the scrollbar.

For a list of all members of this type, see ScrollBarStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ScrollBarStyle

[Visual Basic]
Public Class ScrollBarStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ScrollBarStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ScrollBarStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ScrollBarStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Members

ScrollBarStyle overview

Public Constructors

public constructor ScrollBarStyle Constructor Initializes a new instance of the ScrollBarStyle class.

Public Properties

public property ArrowColor | Gets or sets the arrow Color.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property ButtonFadeColor | Gets or sets the button fade Color.
public property ButtonFillStyle | Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ScrollBarStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ScrollBarStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Constructor ()

Initializes a new instance of the ScrollBarStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ScrollBarStyle();
[C++]
public: ScrollBarStyle();
[JScript]
public function ScrollBarStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Properties

The properties of the ScrollBarStyle class are listed here. For a complete list of ScrollBarStyle class members, see the ScrollBarStyle Members topic.

Public Properties

public property ArrowColor | Gets or sets the arrow Color.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property ButtonFadeColor | Gets or sets the button fade Color.
public property ButtonFillStyle | Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ArrowColor Property

Lidor Systems IntegralUI Class Library

ScrollBarStyle.ArrowColor Property

Gets or sets the arrow Color.

[Visual Basic]
Public Property ArrowColor As Color
[C#]
public Color ArrowColor {get; set;}
[C++]
public: __property Color get_ArrowColor();
public: __property void set_ArrowColor(Color);
[JScript]
public function get ArrowColor() : Color;
public function set ArrowColor(Color);

Property Value

A Color represents the arrow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

Lidor Systems IntegralUI Class Library

ScrollBarStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonColor Property

Lidor Systems IntegralUI Class Library

ScrollBarStyle.ButtonColor Property

Gets or sets the button Color.

[Visual Basic]
Public Property ButtonColor As Color
[C#]
public Color ButtonColor {get; set;}
[C++]
public: __property Color get_ButtonColor();
public: __property void set_ButtonColor(Color);
[JScript]
public function get ButtonColor() : Color;
public function set ButtonColor(Color);

Property Value

A Color represents the button color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonFadeColor Property

Lidor Systems IntegralUI Class Library

ScrollBarStyle.ButtonFadeColor Property

Gets or sets the button fade Color.

[Visual Basic]
Public Property ButtonFadeColor As Color
[C#]
public Color ButtonFadeColor {get; set;}
[C++]
public: __property Color get_ButtonFadeColor();
public: __property void set_ButtonFadeColor(Color);
[JScript]
public function get ButtonFadeColor() : Color;
public function set ButtonFadeColor(Color);

Property Value

A Color represents the button fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


FillStyle Property

Lidor Systems IntegralUI Class Library

ScrollBarStyle.FillStyle Property

Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.

[Visual Basic]
Public Property FillStyle As FillStyle
[C#]
public FillStyle FillStyle {get; set;}
[C++]
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(FillStyle);
[JScript]
public function get FillStyle() : FillStyle;
public function set FillStyle(FillStyle);

Property Value

The FillStyle assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Methods

The methods of the ScrollBarStyle class are listed here. For a complete list of ScrollBarStyle class members, see the ScrollBarStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ScrollBarStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

Lidor Systems IntegralUI Class Library

ScrollBarStyle.Clone Method

Creates an exact copy of the current ScrollBarStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ScrollBarStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

Lidor Systems IntegralUI Class Library

ScrollBarStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ScrollBarStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

Lidor Systems IntegralUI Class Library

ScrollBarStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Class

Provides data for style events.

For a list of all members of this type, see StyleEventArgs Members.

System.Object
LidorSystems.IntegralUI.Style.StyleEventArgs

[Visual Basic]
Public
   Class StyleEventArgs
[C#]
 public class StyleEventArgs
[C++]
 public __gc class StyleEventArgs
[JScript]
public class StyleEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Members

StyleEventArgs overview

Public Constructors

public constructor StyleEventArgs Constructor Initializes a new instance of the StyleEventArgs class.

Public Properties

public property Object | Read-only property that returns the object associated with the StyleEventArgs.
public property Action | Read-only property that returns the StyleAction associated with the StyleEventArgs.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor

Overload List

Initializes a new instance of the StyleEventArgs class.

[Visual Basic] Public Sub New()
[C#] public StyleEventArgs();
[C++] public: StyleEventArgs();
[JScript] public function StyleEventArgs();

Initializes a new instance of the StyleEventArgs class with the specified object.

[Visual Basic] Public Sub StyleEventArgs(Object)
[C#] public StyleEventArgs(object);
[C++] public: StyleEventArgs(Object*);
[JScript] public function StyleEventArgs(Object);

Initializes a new instance of the StyleEventArgs class with the specified object and action.

[Visual Basic] Public Sub StyleEventArgs(Object, StyleAction)
[C#] public StyleEventArgs(object, StyleAction);
[C++] public: StyleEventArgs(Object*, StyleAction);
[JScript] public function StyleEventArgs(Object, StyleAction);

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor ()

Initializes a new instance of the StyleEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public StyleEventArgs();
[C++]
public: StyleEventArgs();
[JScript]
public function StyleEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor (Object)

Initializes a new instance of the StyleEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public StyleEventArgs(
   object value
);
[C++]
public: StyleEventArgs(
   Object* value
);
[JScript]
public function StyleEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor (Object, StyleAction)

Initializes a new instance of the StyleEventArgs class with the specified object and action.

[Visual Basic]
Public Sub New( _
   ByVal value As Object
   ByVal action As StyleAction _
)
[C#]
public StyleEventArgs(
   object value
   StyleAction action
);
[C++]
public: StyleEventArgs(
   Object* value
   StyleAction* action
);
[JScript]
public function StyleEventArgs(
   value : Object
   action : StyleAction
);

Parameters

value

The object associated with this event.

action

The StyleAction associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Properties

The properties of the StyleEventArgs class are listed here. For a complete list of StyleEventArgs class members, see the StyleEventArgs Members topic.

Public Properties

public property Object | Read-only property that returns the object associated with the StyleEventArgs.
public property Action | Read-only property that returns the StyleAction associated with the StyleEventArgs.

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


Action Property

Lidor Systems IntegralUI Class Library

StyleEventArgs.Action Property

Read-only property that returns the StyleAction associated with the StyleEventArgs.

[Visual Basic]
Public ReadOnly Property Action As StyleAction
[C#]
public StyleAction Action {get;}
[C++]
public: __property StyleAction* get_Action();
[JScript]
public function get Action() : StyleAction;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


Object Property

Lidor Systems IntegralUI Class Library

StyleEventArgs.Object Property

Read-only property that returns the object associated with the StyleEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Class

Specifies the image which can be used as a watermark.

For a list of all members of this type, see WatermarkImage Members.

System.Object
LidorSystems.IntegralUI.Style.WatermarkImage

[Visual Basic]
Public
   Class WatermarkImage
[C#]
 public class WatermarkImage
[C++]
 public __gc class WatermarkImage
[JScript]
public class WatermarkImage

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Members

WatermarkImage overview

Public Constructors

public constructor WatermarkImage Constructor Initializes a new instance of the WatermarkImage class.

Public Properties

public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image.
public property Image | Specifies the image object to use as a watermark.
public property ImageAlign | Gets or sets the alignment of the image.
public property ImageSize | Gets or sets the image size.

Public Events

public event WatermarkImageChanged Occurs when the WatermarkImage changes.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnWatermarkImageChanged | Raises the WatermarkImageChanged event.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Constructor ()

Initializes a new instance of the WatermarkImage class.

[Visual Basic]
Public Sub New()
[C#]
public WatermarkImage();
[C++]
public: WatermarkImage();
[JScript]
public function WatermarkImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Properties

The properties of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Properties

public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image.
public property Image | Specifies the image object to use as a watermark.
public property ImageAlign | Gets or sets the alignment of the image.
public property ImageSize | Gets or sets the image size.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


Alpha Property

Lidor Systems IntegralUI Class Library

WatermarkImage.Alpha Property

Gets or sets the alpha value that will be applied to the colors in the image.

[Visual Basic]
Public Property Alpha As Integer
[C#]
public int Alpha {get; set;}
[C++]
public: __property int get_Alpha();
public: __property void set_Alpha(int);
[JScript]
public function get Alpha() : int;
public function set Alpha(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


ImageAlign Property

Lidor Systems IntegralUI Class Library

WatermarkImage.ImageAlign Property

Gets or sets the alignment of the image.

[Visual Basic]
Public Property ImageAlign As ContentAlignment
[C#]
public ContentAlignment ImageAlign { get; set; }
[C++]
public: __property ContentAlignment get_ImageAlign();
public: __property void set_ImageAlign(ContentAlignment);
[JScript]
public function get ImageAlign() : ContentAlignment
public function set ImageAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


Image Property

Lidor Systems IntegralUI Class Library

WatermarkImage.Image Property

Specifies the image object to use as a watermark.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

Lidor Systems IntegralUI Class Library

WatermarkImage.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Methods

The methods of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnWatermarkImageChanged | Raises the WatermarkImageChanged event.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


OnWatermarkImageChanged Method

Lidor Systems IntegralUI Class Library

WatermarkImage.OnWatermarkImageChanged Method

Raises the WatermarkImageChanged event.

[Visual Basic]
Protected Overridable Sub OnWatermarkImageChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnWatermarkImageChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnWatermarkImageChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnWatermarkImageChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnWatermarkImageChanged in a derived class, be sure to call the base class's OnWatermarkImageChanged method so that registered delegates receive the event.

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Events

The events of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Events

public event WatermarkImageChanged Occurs when the WatermarkImage changes.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImageChanged Event

Lidor Systems IntegralUI Class Library

WatermarkImage.WatermarkImageChanged Event

Occurs when the WatermarkImage changes.

[Visual Basic]
Public Event WatermarkImageChanged As StyleEventHandler
[C#]
public event StyleEventHandler WatermarkImageChanged;
[C++]
public: __event StyleEventHandler* WatermarkImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


StyleEventHandler Delegate

Represents the method that will handle style events.

[Visual Basic]
Public Delegate Sub StyleEventHandler( _
   ByVal sender As Object, _
   ByVal e As StyleEventArgs _
)
[C#]
public Delegate void StyleEventHandler(
   object sender,
   StyleEventArgs e
);
[C++]
public __gc __delegate void StyleEventHandler(
   Object* sender,
   StyleEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the StyleEventHandler Delegate declaration.

sender
The source of the event.
e
A StyleEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


BorderVisibility Enumeration

Enumerator used to determine the border visibility.

[Visual Basic]
<Flags>
Public Enum BorderVisibility
[C#]
[Flags]
public enum BorderVisibility
[C++]
[Flags]
__value public enum BorderVisibility
[JScript]
public
   Flags
enum BorderVisibility

Members

Member name | Description | Value
All | All borders are visible. | 15
Bottom | Only the bottom border is visible. | 8
Left | Only the left border is visible. | 1
None | Border is not visible. | 0
Right | Only the right border is visible. | 4
Top | Only the top border is visible. | 2

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


CornerShape Enumeration

Enumerator used to set the shape of border corners.

[Visual Basic]
Public Enum CornerShape
[C#]
public enum CornerShape
[C++]
__value public enum CornerShape
[JScript]
public
   enum CornerShape

Members

Member name | Description
Chamfered | The chamfered corner.
Rounded | The rounded corner.
Squared | The squared corner.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


FillStyle Enumeration

Specifies the fill mode used to draw the client area.

[Visual Basic]
Public Enum FillStyle
[C#]
public enum FillStyle
[C++]
__value public enum FillStyle
[JScript]
public
   enum FillStyle

Members

Member name | Description
BackwardDiagonal | Specifies a gradient from upper right to lower left.
BackwardHorizontal | Specifies a gradient from right to left.
BackwardVertical | Specifies a gradient from bottom to top.
Flat | Specifies solid color.
ForwardDiagonal | Specifies a gradient from upper left to lower right.
Horizontal | Specifies a gradient from left to right.
Texture | Specifies that custom image will be used to fill the cleint area.
Vertical | Specifies a gradient from top to bottom.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


LineStyle Enumeration

Enumerator used to determine the type of the line.

[Visual Basic]
Public Enum LineStyle
[C#]
public enum LineStyle
[C++]
__value public enum LineStyle
[JScript]
public
   enum LineStyle

Members

Member name | Description
Dash | Specifies a line consisting of dashes.
Dot | Specifies a line consisting of dots.
Double | Specifies a double solid line.
None | The line is invisible.
Solid | Specifies a solid line.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


TransparencyLevel Enumeration

Enumerator used to specify the level of transparency.

[Visual Basic]
Public Enum TransparencyLevel
[C#]
public enum TransparencyLevel
[C++]
__value public enum TransparencyLevel
[JScript]
public
   enum TransparencyLevel

Members

Member name | Description
Full | Every content (text, image, colors, etc.) of object can be transparent.
Partial | Only background and border of object can be transparent.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


VisualStyle Enumeration

Enumerator used to specify the appearance of object according to predefined style.

[Visual Basic]
Public Enum VisualStyle
[C#]
public enum VisualStyle
[C++]
__value public enum VisualStyle
[JScript]
public
   enum VisualStyle

Members

Member name | Description
Classic | Used to render objects in Windows Classic control style.
Vista | Used to render objects in Windows Vista control style.
XP | Used to render objects in Windows XP control style.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


Product Support

This support policy may be subject to change. You are advised to check the Support section of the Lidor Systems web site for any change notices prior to purchasing. Lidor Systems Technical Support can assist you with all your technical problems, from installation to troubleshooting. Before contacting technical support please read the relevant sections of the product documentation or the ReadMe files.

Reporting Issues

You can contact Technical Support by:

  • E-Mail: Include your serial number and send as many details as possible to: support@lidorsystems.com
  • World Wide Web: Submit issues and access additional support services at: http://www.lidorsystems.com/support/forums
  • Fax: Include your serial number and send as many details as possible to: +389 32 634 944

Before contacting Technical Support, please obtain and record the following information:

  • Your company name and contact information
  • Product name and version
  • Product serial number
  • Your system configuration: operating system, network configuration, amount of RAM, environment variables, and paths
  • The details of the problem; settings, error messages
  • If the problem is repeatable, the details of how to create the problem
  • The name and version of your development tools

The amount of information you can provide us with about the nature of a problem you are having will directly affect our ability to resolve it. The more information you can provide about your environment, the steps to reproduce and any other relevant information the better - please be verbose!

Submitting Suggestions

If you have any comments or concerns about this product please direct them to suggestions@lidorsystems.com. Your feedback is important to us in order to get an idea of how to make this software a better product for you. Many of its features and significant portions of its interface have been heavily influenced by comments from users. So if you have a grand idea for a new feature, or a better way of doing something, please drop us a note.


Deploying

In order to deploy your application, you will have to re-distribute the following files:

File Name | Description
LidorSystems.IntegralUI.dll | .NET Assembly containing common classes.
LidorSystems.IntegralUI.Containers.dll | .NET Assembly containing base classes for container controls.
LidorSystems.IntegralUI.Containers.TabControl.dll | .NET Assembly containing the TabControl control.

Warning! Distribution of files mentioned above is only allowed when they are properly licensed.


UpdateStyleParams Method

Lidor Systems Collector Class Library

AutoHideBar.UpdateStyleParams Method

Updates the appearance of AutoHideBar control from the style of specific Group control.

[Visual Basic]
Public Sub UpdateStyleParams( _
   ByVal gp As Group _
)
[C#]
public void UpdateStyleParams(
   Group gp
);
[C++]
public: void UpdateStyleParams(
   Group gp
);
[JScript]
public function UpdateStyleParams(
   gp : Group
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AutoHideBar Class | AutoHideBar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnContextMenuButtonClick Method

Lidor Systems Collector Class Library

Bar.OnContextMenuButtonClick Method

Occurs when a ContextMenuButton is clicked.

[Visual Basic]
Protected Overridable Sub OnContextMenuButtonClick( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnContextMenuButtonClick(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnContextMenuButtonClick(
   CollectorEventArgs* e
);
[JScript]
protected function OnContextMenuButtonClick(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnTabSelectButtonClick Method

Lidor Systems Collector Class Library

Bar.OnTabSelectButtonClick Method

Occurs when a TabSelectButton is clicked.

[Visual Basic]
Protected Overridable Sub OnTabSelectButtonClick( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnTabSelectButtonClick(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnTabSelectButtonClick(
   CollectorEventArgs* e
);
[JScript]
protected function OnTabSelectButtonClick(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Bar Class | Bar Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnAutoHideChanged Method

Lidor Systems Collector Class Library

Group.OnAutoHideChanged Method

Raises the AutoHideChanged event.

[Visual Basic]
Protected Overridable Sub OnAutoHideChanged( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnAutoHideChanged(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnAutoHideChanged(
   CollectorEventArgs* e
);
[JScript]
protected function OnAutoHideChanged(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnAutoHideChanged in a derived class, be sure to call the base class's OnAutoHideChanged method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnAutoHideChanging Method

Lidor Systems Collector Class Library

Group.OnAutoHideChanging Method

Raises the AutoHideChanging event.

[Visual Basic]
Protected Overridable Sub OnAutoHideChanging( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnAutoHideChanging(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnAutoHideChanging(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnAutoHideChanging(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnAutoHideChanging in a derived class, be sure to call the base class's OnAutoHideChanging method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnGroupClosing Method

Lidor Systems Collector Class Library

Group.OnGroupClosing Method

Raises the GroupClosing event.

[Visual Basic]
Protected Overridable Sub OnGroupClosing( _
   ByVal e As CancelableCollectorEventArgs _
)
[C#]
protected virtual void OnGroupClosing(
   CancelableCollectorEventArgs e
);
[C++]
protected: virtual void OnGroupClosing(
   CancelableCollectorEventArgs* e
);
[JScript]
protected function OnGroupClosing(
   e : CancelableCollectorEventArgs
);

Parameters

e
A CancelableCollectorEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnGroupClosing in a derived class, be sure to call the base class's OnGroupClosing method so that registered delegates receive the event.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMaximizeButtonClick Method

Lidor Systems Collector Class Library

Group.OnMaximizeButtonClick Method

Occurs when a MaximizeButton is clicked.

[Visual Basic]
Protected Overridable Sub OnMaximizeButtonClick( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnMaximizeButtonClick(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnMaximizeButtonClick(
   CollectorEventArgs* e
);
[JScript]
protected function OnMaximizeButtonClick(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


OnMinimizeButtonClick Method

Lidor Systems Collector Class Library

Group.OnMinimizeButtonClick Method

Occurs when a MinimizeButton is clicked.

[Visual Basic]
Protected Overridable Sub OnMinimizeButtonClick( _
   ByVal e As CollectorEventArgs _
)
[C#]
protected virtual void OnMinimizeButtonClick(
   CollectorEventArgs e
);
[C++]
protected: virtual void OnMinimizeButtonClick(
   CollectorEventArgs* e
);
[JScript]
protected function OnMinimizeButtonClick(
   e : CollectorEventArgs
);

Parameters

e
A CollectorEventArgs that contains the event data.

See Also

Group Class | Group Members | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Margin Constructor

Initializes a new instance of the Margin structure with the specified left, top, right and bottom distance.

[Visual Basic]
Public Sub New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
[C#]
public Rectangle(
   int left,
   int top,
   int right,
   int bottom
);
[C++]
public: Rectangle(
   int left,
   int top,
   int right,
   int bottom
);
[JScript]
public function Rectangle(
   left : int,
   top : int,
   right : int,
   bottom : int
);

Parameters

left
Distance (in pixels) from the left border of container control.
top
Distance (in pixels) from the top border of container control.
right
Distance (in pixels) from the right border of container control.
bottom
Distance (in pixels) from the bottom border of container control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Margin Structure | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Margin Members

Margin overview

Public Constructors

public constructor Margin Constructor Initializes a new instance of the Margin class.

Public Properties

public property Left | Gets or sets distance (in pixels) from the left border of container control.
public property Top | Gets or sets distance (in pixels) from the top border of container control.
public property Right | Gets or sets distance (in pixels) from the right border of container control.
public property Bottom | Gets or sets distance (in pixels) from the bottom border of container control.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator Supported by the .NET Compact Framework. | Tests whether two Margin structures are equal.
public operator static (Shared in Visual Basic) Inequality Operator Supported by the .NET Compact Framework. | Tests whether two Margin structures are different.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

Margin Class | LidorSystems.Collector Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


Clone Method

Lidor Systems Collector Class Library

CommonStyle.Clone Method

Creates an exact copy of the current Object.

[Visual Basic]
Public Overridable Sub Clone() As CommonStyle
[C#]
public virtual CommonStyle Clone();
[C++]
public: virtual CommonStyle Clone();
[JScript]
public function Clone() : CommonStyle;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonStyle Class | CommonStyle Members | LidorSystems.Collector.Style Namespace

Send comments on this topic.

Copyright © 2005 Lidor Systems. All rights reserved.


BackgroundImageSpace Property

Lidor Systems IntegralUI Class Library

ControlBase.BackgroundImageSpace Property

Gets or sets the space at which background image will be drawn.

[Visual Basic]
Public Property BackgroundImageSpace As BackgroundImageSpace
[C#]
public BackgroundImageSpace BackgroundImageSpace {get; set;}
[C++]
public: __property BackgroundImageSpace get_BackgroundImageSpace();
public: __property void set_BackgroundImageSpace(BackgroundImageSpace);
[JScript]
public function get BackgroundImageSpace() : BackgroundImageSpace;
public function set BackgroundImageSpace(BackgroundImageSpace);

Property Value

The BackgroundImageSpace assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ColorStyle Property

Lidor Systems IntegralUI Class Library

ControlBase.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Property ColorStyle As ControlColorStyle
[C#]
public ControlColorStyle ColorStyle {get; set;}
[C++]
public: __property ControlColorStyle get_ColorStyle();
public: __property void set_ColorStyle(ControlColorStyle);
[JScript]
public function get ColorStyle() : ControlColorStyle;
public function set ColorStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FormatStyle Property

Lidor Systems IntegralUI Class Library

ControlBase.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Property FormatStyle As ControlFormatStyle
[C#]
public ControlFormatStyle FormatStyle {get; set;}
[C++]
public: __property ControlFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ControlFormatStyle);
[JScript]
public function get FormatStyle() : ControlFormatStyle;
public function set FormatStyle(ControlFormatStyle);

Property Value

The ControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Members

ObjectBase overview

Public Constructors

public constructor ObjectBase Constructor Initializes a new instance of the ObjectBase class.

Public Properties

public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Index | Gets the position of the object in the object collection.
public property Key | Gets or sets a string that uniquely identifies object in a collection.
public property State | Gets a value indicating the current state of the object.
public property Tag | Gets or sets the object that contains data about the item.
public property TagString | Gets or sets the tag string of the object.
public property Text | Gets or sets the object text.
public property Visible | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Creates an exact copy of the current ObjectBase.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ObjectBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


PageBase Class

Provides a common implementation of members for panel controls.

For a list of all members of this type, see PageBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
LidorSystems.IntegralUI.PageBase
LidorSystems.IntegralUI.Containers.SplitContainerPage
LidorSystems.IntegralUI.Containers.TabPage
LidorSystems.IntegralUI.ContentPanel

[Visual Basic]
MustInherit Public Class PageBase
   Inherits Panel
[C#]
public abstract class PageBase : Panel
[C++]
public __gc __abstract class PageBase : public Panel
[JScript]
public abstract class PageBase extends Panel

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

PageBase Members | LidorSystems.IntegralUI Namespace


PageBase Members

PageBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
public property AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
public property AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
public property AutoSize (inherited from Panel) | Overridden.
public property AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle (inherited from Panel) | Indicates the border style for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. The text associated with the page.
public property TextBounds | For internal use.
public property TextSize | For internal use.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property WatermarkImage | Specifies the image used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Events

public event AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property changes.
public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property HScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
protected property VScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaddingChanged (inherited from ScrollableControl) | Raises the PaddingChanged event event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize (inherited from Panel) | Overridden.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
protected method SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

PageBase Class | LidorSystems.IntegralUI Namespace


WatermarkImage Property

Lidor Systems IntegralUI Class Library

PageBase.WatermarkImage Property

Specifies the WatermarkImage object to use as a watermark.

[Visual Basic]
Public Property WatermarkImage As WatermarkImage
[C#]
public WatermarkImage WatermarkImage { get; set; }
[C++]
public: __property WatermarkImage* get_WatermarkImage();
public: __property void set_WatermarkImage(WatermarkImage*);
[JScript]
public function get WatermarkImage() : WatermarkImage
public function set WatermarkImage(WatermarkImage);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

PageBase Class | PageBase Members | LidorSystems.IntegralUI.Lists Namespace


UpdateEventArgs Class

Provides data for events used to notify about control layout or display changes.

For a list of all members of this type, see UpdateEventArgs Members.

System.Object
LidorSystems.IntegralUI.UpdateEventArgs

[Visual Basic]
Public
   Class UpdateEventArgs
[C#]
 public class UpdateEventArgs
[C++]
 public __gc class UpdateEventArgs
[JScript]
public class UpdateEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor

Overload List

Initializes a new instance of the UpdateEventArgs class.

[Visual Basic] Public Sub New()
[C#] public UpdateEventArgs();
[C++] public: UpdateEventArgs();
[JScript] public function UpdateEventArgs();

Initializes a new instance of the UpdateEventArgs class with the specified object.

[Visual Basic] Public Sub UpdateEventArgs(Object)
[C#] public UpdateEventArgs(object);
[C++] public: UpdateEventArgs(Object*);
[JScript] public function UpdateEventArgs(Object);

Initializes a new instance of the UpdateEventArgs class with the specified object and action.

[Visual Basic] Public Sub UpdateEventArgs(Object, ActionType)
[C#] public UpdateEventArgs(object, ActionType);
[C++] public: UpdateEventArgs(Object*, ActionType);
[JScript] public function UpdateEventArgs(Object, ActionType);

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor ()

Initializes a new instance of the UpdateEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public UpdateEventArgs();
[C++]
public: UpdateEventArgs();
[JScript]
public function UpdateEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor (Object)

Initializes a new instance of the UpdateEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public UpdateEventArgs(
   object value
);
[C++]
public: UpdateEventArgs(
   Object* value
);
[JScript]
public function UpdateEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


UpdateEventArgs Members

UpdateEventArgs overview

Public Constructors

public constructor UpdateEventArgs Constructor Initializes a new instance of the UpdateEventArgs class.

Public Properties

public property Object | Read-only property that returns the object associated with the UpdateEventArgs.
public property Action | Read-only property that returns the ActionType associated with the UpdateEventArgs.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


Action Property

Lidor Systems IntegralUI Class Library

UpdateEventArgs.Action Property

Read-only property that returns the ActionType associated with the UpdateEventArgs.

[Visual Basic]
Public ReadOnly Property Action As ActionType
[C#]
public ActionType Action {get;}
[C++]
public: __property ActionType* get_Action();
[JScript]
public function get Action() : ActionType;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

Lidor Systems IntegralUI Class Library

UpdateEventArgs.Object Property

Read-only property that returns the object associated with the UpdateEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventHandler Delegate

Represents the method that will handle events used to notify about control layout or display changes.

[Visual Basic]
Public Delegate Sub UpdateEventHandler( _
   ByVal sender As Object, _
   ByVal e As UpdateEventArgs _
)
[C#]
public Delegate void UpdateEventHandler(
   object sender,
   UpdateEventArgs e
);
[C++]
public __gc __delegate void UpdateEventHandler(
   Object* sender,
   UpdateEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the UpdateEventHandler Delegate declaration.

sender
The source of the event.
e
A UpdateEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


BackgroundImageSpace Enumeration

Enumerator used to specify where the background image will be placed.

[Visual Basic]
Public Enum BackgroundImageSpace
[C#]
public enum BackgroundImageSpace
[C++]
__value public enum BackgroundImageSpace
[JScript]
public
   enum BackgroundImageSpace

Members

Member name | Description
Client | The image can occupy only the control client area.
Control | Default. The image can occupy the whole control area.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


CloseAction Enumeration

Enumerator used to determine how an object will be closed.

[Visual Basic]
Public Enum CloseAction
[C#]
public enum CloseAction
[C++]
__value public enum CloseAction
[JScript]
public
   enum CloseAction

Members

Member name | Description
Dispose | The closing object will be disposed.
Hide | The closing object will be hidden, but still will remain in memory.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.


OnPageClosed Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageClosed Method

Raises the PageClosed event.

[Visual Basic]
Protected Overridable Sub OnPageClosed( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnPageClosed(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnPageClosed(
   ObjectEventArgs* e
);
[JScript]
protected function OnPageClosed(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnPageClosing Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageClosing Method

Raises the PageClosing event.

[Visual Basic]
Protected Overridable Sub OnPageClosing( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnPageClosing(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnPageClosing(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnPageClosing(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnPageRemoved Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageRemoved Method

Raises the PageRemoved event.

[Visual Basic]
Protected Overridable Sub OnPageRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnPageRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnPageRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnPageRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnPageRemoving Method

Lidor Systems IntegralUI Class Library

TabControl.OnPageRemoving Method

Raises the PageRemoving event.

[Visual Basic]
Protected Overridable Sub OnPageRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnPageRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnPageRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnPageRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


OnTabMouseHover Method

Lidor Systems IntegralUI Class Library

TabControl.OnTabMouseHover Method

Raises the TabMouseHover event.

[Visual Basic]
Protected Overridable Sub OnTabMouseHover( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnTabMouseHover(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnTabMouseHover(
   ObjectEventArgs* e
);
[JScript]
protected function OnTabMouseHover(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedToolItemStyle Property

Lidor Systems IntegralUI Class Library

TabControl.SelectedToolItemStyle Property

Gets or sets the drawing style of toolbar, when items are in checked/selected state.

[Visual Basic]
Public Property SelectedToolItemStyle As ToolItemColorStyle
[C#]
public ToolItemColorStyle SelectedToolItemStyle {get; set;}
[C++]
public: __property ToolItemColorStyle get_SelectedToolItemStyle();
public: __property void set_SelectedToolItemStyle(ToolItemColorStyle);
[JScript]
public function get SelectedToolItemStyle() : ToolItemColorStyle;
public function set SelectedToolItemStyle(ToolItemColorStyle);

Property Value

A ToolItemColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


TabContentOrientation Property

Lidor Systems IntegralUI Class Library

TabControl.TabContentOrientation Property

Specifies how the content of tabs is arranged.

[Visual Basic]
Public Property TabContentOrientation As Orientation
[C#]
public Orientation TabContentOrientation {get; set;}
[C++]
public: __property Orientation get_TabContentOrientation();
public: __property void set_TabContentOrientation(Orientation);
[JScript]
public function get TabContentOrientation() : Orientation;
public function set TabContentOrientation(Orientation);

Property Value

The Orientation assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabControl Class | TabControl Members | LidorSystems.IntegralUI.Containers Namespace


LidorSystems.IntegralUI.Containers

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Containers.Collections Namespace

Classes

Class | Description
TabDockPageCollection | Contains a collection of TabDockPage objects.
TabPageCollection | Contains a collection of TabPage objects.


Item (Int32) Property

Lidor Systems IntegralUI Class Library

TabPageCollection.Item (Int32) Property

Gets a TabPage at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As TabPage
[C#]
public new TabPage this[
   int index
] {get;}
[C++]
public: __property TabPage* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The TabPage at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageCollection Class | TabPageCollection Members | LidorSystems.IntegralUI.Containers.Collections Namespace


Item Property

Lidor Systems IntegralUI Class Library

TabPageCollection.Item (String) Property

Gets a TabPage with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As TabPage
[C#]
 public TabPage this[
   String key
] {get;}
[C++]
public: __property TabPage* get_Item(
   String key
);

Parameters

key
The name of the TabPage to retrieve from the collection.

Property Value

The TabPage with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageCollection Class | TabPageCollection Members | LidorSystems.IntegralUI.Containers.Collections Namespace


LidorSystems.IntegralUI.Controls.Style

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI.Controls.Style Namespace

Classes

Class | Description
TabPageColorStyle | Represents the style for drawing tab pages.
TabPageFormatStyle | Represents the format style for tab pages.
TabStripStyle | Represents the style for drawing a tabstrip.

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


BackImage Property

Lidor Systems IntegralUI Class Library

TabPageColorStyle.BackImage Property

Gets or sets an image used as a background texture for the page content.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a background texture for the page content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


TabImage Property

Lidor Systems IntegralUI Class Library

TabPageColorStyle.TabImage Property

Gets or sets an image used as a background texture for the page tab.

[Visual Basic]
Public Property TabImage As Image
[C#]
public Image TabImage {get; set;}
[C++]
public: __property Image get_TabImage();
public: __property void set_TabImage(Image);
[JScript]
public function get TabImage() : Image;
public function set TabImage(Image);

Property Value

A Image used as a background texture for the page tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

TabPageColorStyle Class | TabPageColorStyle Members | LidorSystems.IntegralUI.Containers.Style Namespace


ListControlItem Constructor ()

Initializes a new instance of the ListControlItem class.

[Visual Basic]
Public Sub New()
[C#]
public ListControlItem();
[C++]
public: ListControlItem();
[JScript]
public function ListControlItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor (String)

Initializes a new instance of the ListControlItem class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ListControlItem(
   string text
);
[C++]
public: ListControlItem(
   String* text
);
[JScript]
public function ListControlItem(
   text : String
);

Parameters

text
The text of the new item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor (String, Int32)

Initializes a new instance of the ListControlItem class with the specified text and image.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageIndex As Integer, _
)
[C#]
public ListControlItem(
   string text,
   int imageIndex,
);
[C++]
public: ListControlItem(
   String* text,
   int imageIndex,
);
[JScript]
public function ListControlItem(
   text : String,
   imageIndex : int,
);

Parameters

text
The name of the new item.
imageIndex
The index value of Image to display.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Item (Int32) Property

Lidor Systems IntegralUI Class Library

CommandButtonCollection.Item (Int32) Property

Gets a CommandButton at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As CommandButton
[C#]
public new CommandButton this[
   int index
] {get;}
[C++]
public: __property CommandButton* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The CommandButton at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

Lidor Systems IntegralUI Class Library

CommandButtonCollection.Item (String) Property

Gets a CommandButton with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As CommandButton
[C#]
 public CommandButton this[
   String key
] {get;}
[C++]
public: __property CommandButton* get_Item(
   String key
);

Parameters

key
The name of the CommandButton to retrieve from the collection.

Property Value

The CommandButton with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item (Int32) Property

Lidor Systems IntegralUI Class Library

ListControlItemCollection.Item (Int32) Property

Gets a ListControlItem at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ListControlItem
[C#]
public new ListControlItem this[
   int index
] {get;}
[C++]
public: __property ListControlItem* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The ListControlItem at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

Lidor Systems IntegralUI Class Library

ListControlItemCollection.Item (String) Property

Gets a ListControlItem with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As ListControlItem
[C#]
 public ListControlItem this[
   String key
] {get;}
[C++]
public: __property ListControlItem* get_Item(
   String key
);

Parameters

key
The name of the ListControlItem to retrieve from the collection.

Property Value

The ListControlItem with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor (Object)

Initializes a new instance of the ToolItemCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ToolItemCollection(
   object owner
);
[C++]
public: ToolItemCollection(
   Object* owner
);
[JScript]
public function ToolItemCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item (Int32) Property

Lidor Systems IntegralUI Class Library

ToolItemCollection.Item (Int32) Property

Gets a ToolItemBase at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ToolItemBase
[C#]
public new ToolItemBase this[
   int index
] {get;}
[C++]
public: __property ToolItemBase* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The ToolItemBase at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

Lidor Systems IntegralUI Class Library

ToolItemCollection.Item (String) Property

Gets a ToolItemBase with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As ToolItemBase
[C#]
 public ToolItemBase this[
   String key
] {get;}
[C++]
public: __property ToolItemBase* get_Item(
   String key
);

Parameters

key
The name of the ToolItemBase to retrieve from the collection.

Property Value

The ToolItemBase with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


TextControFormatStyle Class

Represents the format style for TextControl.

For a list of all members of this type, see TextControFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.TextControFormatStyle

[Visual Basic]
Public Class TextControFormatStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class TextControFormatStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class TextControFormatStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class TextControFormatStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsAllSquared Property

Lidor Systems IntegralUI Class Library

BorderCornerShape.IsAllSquared Property

Checks whether all corners are squared.

[Visual Basic]
Public ReadOnly Property IsAllSquared As Boolean
[C#]
public bool IsAllSquared {get;}
[C++]
public: __property bool* get_IsAllSquared();
[JScript]
public function get IsAllSquared() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Class

Represents the style for drawing the control.

For a list of all members of this type, see ControlColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ControlColorStyle

[Visual Basic]
Public Class ControlColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


StyleAction Enumeration

Enumerator used to specify the action assigned to some style.

[Visual Basic]
Public Enum StyleAction
[C#]
public enum StyleAction
[C++]
__value public enum StyleAction
[JScript]
public
   enum StyleAction

Members

Member name | Description
Recreate | Recreates the control handle prior updating the control layout.
Repaint | Repaints the control.
Update | Updates the control layout.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace

Send comments on this topic.

Copyright © 2010 Lidor Systems. All rights reserved.