Welcome

IntegralUI TreeView
v4.0 for .NET

IntegralUI TreeView gives you the next step in creating professional and modern user interface. With it you can customize the hierarchical presentation of data like never before. Images, text and custom controls can be included in every node, and it gives you more flexiblity in creation of custom user interface.

Feature list

  • WYSIWYG designer
  • Customizable appearance of TreeView
  • Rich styling features
  • Advanced Drag&Drop
  • Nodes can contain text, image and custom controls
  • XML encoding and serialization
  • Office 2007 fading effect
  • Fast node list creation
  • Watermarks
  • Customizible border side appearance
  • Theme support
    • Classic
    • XP
    • Vista

For more information you can visit us on: http://www.lidorsystems.com

Send comments on this topic.

Copyright © 2013 Lidor Systems. All rights reserved.


Copyright

Lidor Systems IntegralUI Documentation

Copyright Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Lidor Systems.

Lidor Systems may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Lidor Systems, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2013 Lidor Systems. All rights reserved.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


LidorSystems.IntegralUI

Lidor Systems IntegralUI Class Library

LidorSystems.IntegralUI Namespace

Classes

Class | Description
ControlBase | Provides a common implementation of members for controls.
ObjectBase | Provides a common implementation of members for objects.
ObjectCancelClickEventArgs | Provides data for common clickable events which can be canceled.
ObjectCancelEventArgs | Provides data for common cancelable events.
ObjectClickEventArgs | Provides data for common clickable events.
ObjectEditEventArgs | Provides data for common editing events.
ObjectEventArgs | Provides data for common events.
PageBase | Provides a common implementation of members for panel controls.
UpdateEventArgs | Provides data for events used to notify about control layout or display changes.

Delegates

Delegate | Description
ObjectCancelClickEventHandler | Represents the method that will handle common clickable events which can be canceled.
ObjectCancelEventHandler | Represents the method that will handle common cancelable events.
ObjectClickEventHandler | Represents the method that will handle common clickable events.
ObjectEditEventHandler | Represents the method that will handle common editing events.
ObjectEventHandler | Represents the method that will handle common events.
UpdateEventHandler | Represents the method that will handle events used to notify about control layout or display changes.

Enumerations

Enumeration | Description
ActionType | Enumerator used to specify the action assigned to some object.
BackgroundImageSpace | Enumerator used to specify where the background image will be placed.
CheckMode | Enumerator used to determine whether check boxes can accept two or three values.
CloseAction | Enumerator used to determine how an object will be closed.
DragDropMode | Enumerator used to determine the type of drag-and-drop operation.
FadingEffect | Enumerator used to determine the fading effect that is used during hovering over items.
FadingSpeed | Enumerator used to determine the speed of fading that is used during hovering over objects.
ObjectState | Enumerator used to determine the current state of the object.
VerticalAlignment | Specifies how an object or text in a control is vertically aligned relative to an element of the control.


ControlBase Class

Provides a common implementation of members for controls.

For a list of all members of this type, see ControlBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.ControlBase
LidorSystems.IntegralUI.Containers.ContainerBase
LidorSystems.IntegralUI.Lists.ListBase

[Visual Basic]
MustInherit Public Class ControlBase
   Inherits Control
[C#]
public abstract class ControlBase : Control
[C++]
public __gc __abstract class ControlBase : public Control
[JScript]
public abstract class ControlBase extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Members

ControlBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint | Resumes the painting of the control.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint | Temporarily suspends the painting of the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


ControlBase Properties

The properties of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


AllowDrag Property

ControlBase.AllowDrag Property

Determines whether the objects from ControlBase control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


DragDropMode Property

ControlBase.DragDropMode Property

Gets or sets the type of drag-and-drop operation.

[Visual Basic]
Public Property DragDropMode As DragDropMode
[C#]
public DragDropMode DragDropMode {get; set;}
[C++]
public: __property DragDropMode get_DragDropMode();
public: __property void set_DragDropMode(DragDropMode);
[JScript]
public function get DragDropMode() : DragDropMode;
public function set DragDropMode(DragDropMode);

Property Value

The DragDropMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


DragDropReorder Property

ControlBase.DragDropReorder Property

Determines whether reordering of objects is allowed during drag&drop operation.

[Visual Basic]
Public Property DragDropReorder As Boolean
[C#]
public bool DragDropReorder { get; set; }
[C++]
public: __property bool get_DragDropReorder();
public: __property void set_DragDropReorder(bool );
[JScript]
public function get DragDropReorder() : bool
public function set DragDropReorder(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FadingEffect Property

ControlBase.FadingEffect Property

Gets or sets an enumeration that determines the fading effect used during hovering over objects.

[Visual Basic]
Public Property FadingEffect As FadingEffect
[C#]
public FadingEffect FadingEffect {get; set;}
[C++]
public: __property FadingEffect get_FadingEffect();
public: __property void set_FadingEffect(FadingEffect);
[JScript]
public function get FadingEffect() : FadingEffect;
public function set FadingEffect(FadingEffect);

Property Value

The FadingEffect assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FadingSpeed Property

ControlBase.FadingSpeed Property

Gets or sets an enumeration that determines the speed of fading used during hovering over objects.

[Visual Basic]
Public Property FadingSpeed As FadingSpeed
[C#]
public FadingSpeed FadingSpeed {get; set;}
[C++]
public: __property FadingSpeed get_FadingSpeed();
public: __property void set_FadingSpeed(FadingSpeed);
[JScript]
public function get FadingSpeed() : FadingSpeed;
public function set FadingSpeed(FadingSpeed);

Property Value

The FadingSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ShowDropMarker Property

ControlBase.ShowDropMarker Property

Gets or sets a value indicating whether a marker is shown during drag&drop operation.

[Visual Basic]
 Public Property ShowDropMarker As Boolean
[C#]
 public bool ShowDropMarker { get; set; }
[C++]
 public: __property bool
 get_ShowDropMarker();
public: __property void set_ShowDropMarker(bool );
[JScript]
public function get ShowDropMarker() : bool
public function set ShowDropMarker(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


UseTheme Property

ControlBase.UseTheme Property

Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Overridable Property UseTheme As Boolean
[C#]
public virtual bool UseTheme { get; set; }
[C++]
public: __property virtual bool get_UseTheme();
 public:
__property virtual void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


VisualStyle Property

ControlBase.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Overridable Property VisualStyle As VisualStyle
[C#]
public virtual VisualStyle VisualStyle {get; set;}
[C++]
public: __property virtual VisualStyle get_VisualStyle();
public: __property virtual void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Methods

The methods of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint | Resumes the painting of the control.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint | Temporarily suspends the painting of the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContentObjectClicked | Raises the ContentObjectClicked event.
protected method OnContentObjectClicking | Raises the ContentObjectClicking event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


Dispose Method

ControlBase.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


GetClientRect Method

ControlBase.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


OnContentObjectClicked Method

ControlBase.OnContentObjectClicked Method

Raises the ContentObjectClicked event.

[Visual Basic]
Protected Overridable Sub OnContentObjectClicked( _
   ByVal e As ObjectClickEventArgs _
)
[C#]
protected virtual void OnContentObjectClicked(
   ObjectClickEventArgs e
);
[C++]
protected: virtual void OnContentObjectClicked(
   ObjectClickEventArgs* e
);
[JScript]
protected function OnContentObjectClicked(
   e : ObjectClickEventArgs
);

Parameters

e
A ObjectClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


OnContentObjectClicking Method

ControlBase.OnContentObjectClicking Method

Raises the ContentObjectClicking event.

[Visual Basic]
Protected Overridable Sub OnContentObjectClicking( _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
protected virtual void OnContentObjectClicking(
   ObjectCancelClickEventArgs e
);
[C++]
protected: virtual void OnContentObjectClicking(
   ObjectCancelClickEventArgs* e
);
[JScript]
protected function OnContentObjectClicking(
   e : ObjectCancelClickEventArgs
);

Parameters

e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumePaint Method

ControlBase.ResumePaint Method

Resumes the painting of the control.

[Visual Basic]
Public Overridable Sub ResumePaint()
[C#]
public virtual void ResumePaint();
[C++]
public: virtual void * ResumePaint();
[JScript]
public function ResumePaint() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumeUpdate Method

ControlBase.ResumeUpdate Method

Resumes the update of the control layout.

Overload List

Resumes only the layout logic of the control.

[Visual Basic] Overridable Public Sub ResumeUpdate()
[C#] public virtual ResumeUpdate();
[C++] public: virtual ResumeUpdate();
[JScript] public function ResumeUpdate();

Resumes the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub ResumeUpdate(Boolean)
[C#] public virtual ResumeUpdate(bool);
[C++] public: virtual ResumeUpdate(bool);
[JScript] public function ResumeUpdate(Boolean);

See Also

ResumeUpdate Class | ResumeUpdate Members | LidorSystems.IntegralUI Namespace


ResumeUpdate () Method

ControlBase.ResumeUpdate () Method

Resumes only the layout logic of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate()
[C#]
public virtual void ResumeUpdate();
[C++]
public: virtual void * ResumeUpdate();
[JScript]
public function ResumeUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ResumeUpdate Method

ControlBase.ResumeUpdate (Boolean) Method

Resumes the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void ResumeUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * ResumeUpdate(
   bool includeDrawing
);
[JScript]
public function ResumeUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendPaint Method

ControlBase.SuspendPaint Method

Temporarily suspends the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendPaint()
[C#]
public virtual void SuspendPaint();
[C++]
public: virtual void * SuspendPaint();
[JScript]
public function SuspendPaint() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendUpdate Method

ControlBase.SuspendUpdate Method

Temporarily suspends the update of the control layout.

Overload List

Suspends only the layout logic of the control.

[Visual Basic] Overridable Public Sub SuspendUpdate()
[C#] public virtual SuspendUpdate();
[C++] public: virtual SuspendUpdate();
[JScript] public function SuspendUpdate();

Suspends the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub SuspendUpdate(Boolean)
[C#] public virtual SuspendUpdate(bool);
[C++] public: virtual SuspendUpdate(bool);
[JScript] public function SuspendUpdate(Boolean);

See Also

SuspendUpdate Class | SuspendUpdate Members | LidorSystems.IntegralUI Namespace


SuspendUpdate () Method

ControlBase.SuspendUpdate () Method

Temporarily suspends only the layout logic of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate()
[C#]
public virtual void SuspendUpdate();
[C++]
public: virtual void * SuspendUpdate();
[JScript]
public function SuspendUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


SuspendUpdate Method

ControlBase.SuspendUpdate (Boolean) Method

Temporarily suspends the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void SuspendUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * SuspendUpdate(
   bool includeDrawing
);
[JScript]
public function SuspendUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


UpdateLayout () Method

ControlBase.UpdateLayout () Method

Update layout logic of the control.

[Visual Basic]
Public Overridable Sub UpdateLayout()
[C#]
public virtual void UpdateLayout();
[C++]
 public: virtual void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ControlBase Events

The events of the ControlBase class are listed here. For a complete list of ControlBase class members, see the ControlBase Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContentObjectClicked | Occurs after an object is clicked (placed with XML encoding) in the control content space.
public event ContentObjectClicking | Occurs before an object is clicked (placed with XML encoding) in the control content space.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ControlBase Class | LidorSystems.IntegralUI Namespace


ContentObjectClicked Event

ControlBase.ContentObjectClicked Event

Occurs after an object is clicked (placed with XML encoding) in the control content space.

[Visual Basic]
Public Event ContentObjectClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler ContentObjectClicked;
[C++]
public: __event ObjectClickEventHandler* ContentObjectClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ContentObjectClicking Event

ControlBase.ContentObjectClicking Event

Occurs before an object is clicked (placed with XML encoding) in the control content space.

[Visual Basic]
Public Event ContentObjectClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler ContentObjectClicking;
[C++]
public: __event ObjectCancelClickEventHandler* ContentObjectClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Class

Provides a common implementation of members for objects.

For a list of all members of this type, see ObjectBase Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Lists.ListBaseItem
LidorSystems.IntegralUI.Lists.ListBaseSubItem

[Visual Basic]

MustInherit Public Class ObjectBase
   Inherits MarshalByRefObject
   Implements IDisposable, ICloneable
[C#]

public abstract class ObjectBase : MarshalByRefObject, IDisposable,
   ICloneable
[C++]

public __gc __abstract class ObjectBase : public MarshalByRefObject,
   IDisposable, ICloneable
[JScript]
public

 abstract class ObjectBase extends MarshalByRefObject implements
   IDisposable, ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Members

ObjectEventArgs overview

Public Constructors

public constructor ObjectEventArgs Constructor Initializes a new instance of the ObjectEventArgs class.

Public Properties

public property Object Read-only property that returns the object associated with the ObjectEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectBase Constructor

Initializes a new instance of the ObjectBase class.

Overload List

Initializes a new instance of the ObjectBase class.

[Visual Basic] Public Sub New()
[C#] public ObjectBase();
[C++] public: ObjectBase();
[JScript] public function ObjectBase();

Initializes a new instance of the ObjectBase class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ObjectBase(string);
[C++] public: ObjectBase(String*);
[JScript] public function ObjectBase(String);

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Constructor ()

Initializes a new instance of the ObjectBase class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectBase();
[C++]
public: ObjectBase();
[JScript]
public function ObjectBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


ObjectBase Constructor (String)

Initializes a new instance of the ObjectBase class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ObjectBase(
   string text
);
[C++]
public: ObjectBase(
   String* text
);
[JScript]
public function ObjectBase(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


ObjectBase Properties

The properties of the ObjectBase class are listed here. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Properties

public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Index | Gets the position of the object in the object collection.
public property Key | Gets or sets a string that uniquely identifies object in a collection.
public property State | Gets a value indicating the current state of the object.
public property Tag | Gets or sets the object that contains data about the item.
public property TagString | Gets or sets the tag string of the object.
public property Text | Gets or sets the object text.
public property Visible | Gets or sets a value indicating whether the object is displayed.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


Enabled Property

ObjectBase.Enabled Property

Gets or sets a value indicating whether the object can respond to user interaction.

[Visual Basic]
Public Overridable Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Index Property

ObjectBase.Index Property

Gets the position of the object in the object collection.

[Visual Basic]
Public Overridable ReadOnly Property Index As Integer
[C#]
public virtual int Index {get;}
[C++]
public: __property virtual int get_Index();
[JScript]
public function get Index() : int;

Property Value

A zero-based index value that represents the position of the item in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Key Property

ObjectBase.Key Property

Gets or sets a string that uniquely identifies object in a collection.

[Visual Basic]
Public Property Key As String
[C#]
public String Key {get; set;}
[C++]
public: __property String* get_Key();
public: __property void set_Key(String*);
[JScript]
public function get Key() : String;
public function set Key(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


State Property

ObjectBase.State Property

Gets a value indicating the current state of the object.

[Visual Basic]
Public Overridable ReadOnly Property State As ObjectState
[C#]
public virtual ObjectState State {get;}
[C++]
public: __property virtual ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Tag Property

ObjectBase.Tag Property

Gets or sets the object that contains data about the object.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object*);
[JScript]
public function get Tag() : Object;
public function set Tag(Object);

Property Value

An Object that contains data about the item. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


TagString Property

ObjectBase.TagString Property

Gets or sets the tag string of the object.

[Visual Basic]
Public Property TagString As String
[C#]
public String TagString {get; set;}
[C++]
public: __property String* get_TagString();
public: __property void set_TagString(String*);
[JScript]
public function get TagString() : String;
public function set TagString(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Text Property

ObjectBase.Text Property

Gets or sets the object text.

[Visual Basic]
Public Overridable Property Text As String
[C#]
public virtual String Text {get; set;}
[C++]
public: __property virtual String* get_Text();
public: __property virtual void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Visible Property

ObjectBase.Visible Property

Gets or sets a value indicating whether the object is displayed.

[Visual Basic]
Public Overridable Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}
[C++]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Methods

The methods of the ObjectBase class are listed here. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Methods

public method Clone | Creates an exact copy of the current ObjectBase.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ObjectBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Updates the layout of parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


Clone Method

ObjectBase.Clone Method

Creates an exact copy of the current ObjectBase.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ObjectBase object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


Dispose Method

ObjectBase.Dispose Method

Releases all resources used by this ObjectBase object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


RepaintParent Method

ObjectBase.RepaintParent Method

Repaints the parent object, if any.

[Visual Basic]
Public Overridable Sub RepaintParent()
[C#]
public virtual void RepaintParent();
[C++]
public: virtual void RepaintParent();
[JScript]
public function RepaintParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


UpdateParent Method

ObjectBase.UpdateParent Method

Updates the layout of parent object, if any.

[Visual Basic]
Public Overridable Sub UpdateParent()
[C#]
public virtual void UpdateParent();
[C++]
public: virtual void UpdateParent();
[JScript]
public function UpdateParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectBase Class | ObjectBase Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Class

Provides data for common clickable events which can be canceled.

For a list of all members of this type, see ObjectCancelClickEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs
LidorSystems.IntegralUI.ObjectCancelClickEventArgs

[Visual Basic]
Public Class ObjectCancelClickEventArgs
   Inherits ObjectCancelEventArgs
[C#]
public class ObjectCancelClickEventArgs : ObjectCancelEventArgs
[C++]
public __gc class ObjectCancelClickEventArgs : public ObjectCancelEventArgs
[JScript]
public class ObjectCancelClickEventArgs extends ObjectCancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Members

ObjectCancelClickEventArgs overview

Public Constructors

public constructor ObjectCancelClickEventArgs Constructor Initializes a new instance of the ObjectCancelClickEventArgs class.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCancelClickEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCancelClickEventArgs();
[C++] public: ObjectCancelClickEventArgs();
[JScript] public function ObjectCancelClickEventArgs();

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse buttons that are pressed and the position of mouse cursor.

[Visual Basic] Public Sub ObjectCancelClickEventArgs(Object, MouseButtons, Point)
[C#] public ObjectCancelClickEventArgs(object, MouseButtons, Point);
[C++] public: ObjectCancelClickEventArgs(Object*, MouseButtons, Point);
[JScript] public function ObjectCancelClickEventArgs(Object, MouseButtons, Point);

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse buttons that are pressed, position of mouse cursor and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCancelClickEventArgs(Object, MouseButtons, Point, Boolean)
[C#] public ObjectCancelClickEventArgs(object, MouseButtons, Point, bool);
[C++] public: ObjectCancelClickEventArgs(Object*, MouseButtons, Point, bool);
[JScript] public function ObjectCancelClickEventArgs(Object, MouseButtons, Point, Boolean);

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor ()

Initializes a new instance of the ObjectCancelClickEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCancelClickEventArgs();
[C++]
public: ObjectCancelClickEventArgs();
[JScript]
public function ObjectCancelClickEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor (Object, MouseButtons, Point)

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object, mouse button that are pressed and the position of mouse cursor.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
)
[C#]
public ObjectCancelClickEventArgs(
   object value
   MouseButtons button
   Point position
);
[C++]
public: ObjectCancelClickEventArgs(
   Object* value
   MouseButtons button
   Point position
);
[JScript]
public function ObjectCancelClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Constructor (Object, MouseButtons, Point, Boolean)

Initializes a new instance of the ObjectCancelClickEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCancelClickEventArgs(
   object value
   MouseButtons button
   Point position
   bool cancel
);
[C++]
public: ObjectCancelClickEventArgs(
   Object* value
   MouseButtons button
   Point position
   bool* cancel
);
[JScript]
public function ObjectCancelClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
   cancel : Boolean
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventArgs Properties

The properties of the ObjectCancelClickEventArgs class are listed here. For a complete list of ObjectCancelClickEventArgs class members, see the ObjectCancelClickEventArgs Members topic.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

See Also

ObjectCancelClickEventArgs Class | LidorSystems.IntegralUI Namespace


Button Property

ObjectCancelClickEventArgs.Button Property

Gets which mouse button was pressed.

[Visual Basic]
Public ReadOnly Property Button As MouseButtons
[C#]
public MouseButtons Button {get;}
[C++]
public: __property MouseButtons get_Button();
[JScript]
public function get Button() : MouseButtons;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

ObjectCancelClickEventArgs.Object Property

Read-only property that returns the object associated with the ObjectCancelClickEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


Position Property

ObjectCancelClickEventArgs.Position Property

Gets the position of mouse cursor.

[Visual Basic]
Public ReadOnly Property Position As Point
[C#]
public Point Position {get;}
[C++]
public: __property Point get_Position();
[JScript]
public function get Position() : Point;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCancelClickEventArgs Class | ObjectCancelClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Class

Provides data for common cancelable events.

For a list of all members of this type, see ObjectCancelEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs

[Visual Basic]
Public Class ObjectCancelEventArgs
   Inherits CancelEventArgs
[C#]
public class ObjectCancelEventArgs : CancelEventArgs
[C++]
public __gc class ObjectCancelEventArgs : public CancelEventArgs
[JScript]
public class ObjectCancelEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Members

ObjectCancelEventArgs overview

Public Constructors

public constructor ObjectCancelEventArgs Constructor Initializes a new instance of the ObjectCancelEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCancelEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCancelEventArgs();
[C++] public: ObjectCancelEventArgs();
[JScript] public function ObjectCancelEventArgs();

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectCancelEventArgs(Object)
[C#] public ObjectCancelEventArgs(object);
[C++] public: ObjectCancelEventArgs(Object*);
[JScript] public function ObjectCancelEventArgs(Object);

Initializes a new instance of the ObjectCancelEventArgs class with the specified object and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCancelEventArgs(Object, Boolean)
[C#] public ObjectCancelEventArgs(object, bool);
[C++] public: ObjectCancelEventArgs(Object*, bool);
[JScript] public function ObjectCancelEventArgs(Object, Boolean);

See Also

ObjectCancelEventArgs Class | ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor ()

Initializes a new instance of the ObjectCancelEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCancelEventArgs();
[C++]
public: ObjectCancelEventArgs();
[JScript]
public function ObjectCancelEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor (Object)

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectCancelEventArgs(
   object value
);
[C++]
public: ObjectCancelEventArgs(
   Object* value
);
[JScript]
public function ObjectCancelEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Constructor (Object, Boolean)

Initializes a new instance of the ObjectCancelEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCancelEventArgs(
   object value
   bool cancel
);
[C++]
public: ObjectCancelEventArgs(
   Object* value
   bool* cancel
);
[JScript]
public function ObjectCancelEventArgs(
   value : Object
   cancel : Boolean
);

Parameters

value

The object associated with this event.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelEventArgs Properties

The properties of the ObjectCancelEventArgs class are listed here. For a complete list of ObjectCancelEventArgs class members, see the ObjectCancelEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object | Read-only property that returns the object associated with the ObjectCancelEventArgs.

See Also

ObjectCancelEventArgs Class | LidorSystems.IntegralUI Namespace


Object Property

ObjectCancelEventArgs.Object Property

Read-only property that returns the object associated with the ObjectCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCancelEventArgs Class | ObjectCancelEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Class

Provides data for common clickable events.

For a list of all members of this type, see ObjectClickEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.ObjectEventArgs
LidorSystems.IntegralUI.ObjectClickEventArgs

[Visual Basic]
Public Class ObjectClickEventArgs
   Inherits ObjectEventArgsClass
[C#]
public class ObjectClickEventArgs : ObjectEventArgsClass
[C++]
public __gc class ObjectClickEventArgs : public ObjectEventArgsClass
[JScript]
public class ObjectClickEventArgs extends ObjectEventArgsClass

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Members

ObjectClickEventArgs overview

Public Constructors

public constructor ObjectClickEventArgs Constructor Initializes a new instance of the ObjectClickEventArgs class.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Object (inherited from ObjectEventArgs) | Read-only property that returns the object associated with the ObjectClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor

Overload List

Initializes a new instance of the ObjectClickEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectClickEventArgs();
[C++] public: ObjectClickEventArgs();
[JScript] public function ObjectClickEventArgs();

Initializes a new instance of the ObjectClickEventArgs class with the specified object, mouse buttons that are pressed and the position of mouse cursor.

[Visual Basic] Public Sub ObjectClickEventArgs(Object, MouseButtons, Point)
[C#] public ObjectClickEventArgs(object, MouseButtons, Point);
[C++] public: ObjectClickEventArgs(Object*, MouseButtons, Point);
[JScript] public function ObjectClickEventArgs(Object, MouseButtons, Point);

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor ()

Initializes a new instance of the ObjectClickEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectClickEventArgs();
[C++]
public: ObjectClickEventArgs();
[JScript]
public function ObjectClickEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Constructor (Object, MouseButtons, Point)

Initializes a new instance of the ObjectClickEventArgs class with the specified object, mouse button that are pressed and the position of mouse cursor.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal button As MouseButtons _
   ByVal position As Point _
)
[C#]
public ObjectClickEventArgs(
   object value
   MouseButtons button
   Point position
);
[C++]
public: ObjectClickEventArgs(
   Object* value
   MouseButtons button
   Point position
);
[JScript]
public function ObjectClickEventArgs(
   value : Object
   button : MouseButtons
   position : Point
);

Parameters

value

The object associated with this event.

button

One of the MouseButtons values indicating which mouse button was pressed.

position

The position of mouse cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectClickEventArgs Properties

The properties of the ObjectClickEventArgs class are listed here. For a complete list of ObjectClickEventArgs class members, see the ObjectClickEventArgs Members topic.

Public Properties

public property Button | Read-only property that returns which mouse button was pressed.
public property Object (inherited from ObjectEventArgs) | Read-only property that returns the object associated with the ObjectClickEventArgs.
public property Position | Read-only property that returns the position of mouse cursor.

See Also

ObjectClickEventArgs Class | LidorSystems.IntegralUI Namespace


Button Property

ObjectClickEventArgs.Button Property

Gets which mouse button was pressed.

[Visual Basic]
Public ReadOnly Property Button As MouseButtons
[C#]
public MouseButtons Button {get;}
[C++]
public: __property MouseButtons get_Button();
[JScript]
public function get Button() : MouseButtons;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

ObjectEventArgs.Object Property

Read-only property that returns the object associated with the ObjectEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectEventArgs Class | ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


Position Property

ObjectClickEventArgs.Position Property

Gets the position of mouse cursor.

[Visual Basic]
Public ReadOnly Property Position As Point
[C#]
public Point Position {get;}
[C++]
public: __property Point get_Position();
[JScript]
public function get Position() : Point;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectClickEventArgs Class | ObjectClickEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Class

Provides data for common editing events which can be canceled.

For a list of all members of this type, see ObjectEditEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.ObjectCancelEventArgs
LidorSystems.IntegralUI.ObjectEditEventArgs

[Visual Basic]
Public Class ObjectEditEventArgs
   Inherits ObjectCancelEventArgs
[C#]
public class ObjectEditEventArgs : ObjectCancelEventArgs
[C++]
public __gc class ObjectEditEventArgs : public ObjectCancelEventArgs
[JScript]
public class ObjectEditEventArgs extends ObjectCancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Members

ObjectEditEventArgs overview

Public Constructors

public constructor ObjectEditEventArgs Constructor Initializes a new instance of the ObjectEditEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object (inherited from CancelEventArgs) | Read-only property that returns the object associated with the ObjectEditEventArgs.
public property Label | Gets the new text to associate with the object.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor

Overload List

Initializes a new instance of the ObjectEditEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectEditEventArgs();
[C++] public: ObjectEditEventArgs();
[JScript] public function ObjectEditEventArgs();

Initializes a new instance of the ObjectEditEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectEditEventArgs(Object)
[C#] public ObjectEditEventArgs(object);
[C++] public: ObjectEditEventArgs(Object*);
[JScript] public function ObjectEditEventArgs(Object);

Initializes a new instance of the ObjectEditEventArgs class with the specified object and the specified text for updating the object label.

[Visual Basic] Public Sub ObjectEditEventArgs(Object, String)
[C#] public ObjectEditEventArgs(object, String);
[C++] public: ObjectEditEventArgs(Object*, String);
[JScript] public function ObjectEditEventArgs(Object, String);

Initializes a new instance of the ObjectEditEventArgs class with the specified object, the specified text for updating the object label and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectEditEventArgs(Object, String, Boolean)
[C#] public ObjectEditEventArgs(object, String, bool);
[C++] public: ObjectEditEventArgs(Object*, String*, bool);
[JScript] public function ObjectEditEventArgs(Object, String, Boolean);

See Also

ObjectEditEventArgs Class | ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor ()

Initializes a new instance of the ObjectEditEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectEditEventArgs();
[C++]
public: ObjectEditEventArgs();
[JScript]
public function ObjectEditEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object)

Initializes a new instance of the ObjectEditEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectEditEventArgs(
   object value
);
[C++]
public: ObjectEditEventArgs(
   Object* value
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object, String)

Initializes a new instance of the ObjectEditEventArgs class with the specified object and the specified text for updating the object label.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal label As String _
)
[C#]
public ObjectEditEventArgs(
   object value
   String label
);
[C++]
public: ObjectEditEventArgs(
   Object* value
   String* label
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
   label : String
);

Parameters

value

The object associated with this event.

label

The new text to associate with the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Constructor (Object, String)

Initializes a new instance of the ObjectEditEventArgs class with the specified object, the specified text for updating the object label and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal label As String _
   ByVal cancel As Boolean _
)
[C#]
public ObjectEditEventArgs(
   object value
   String label
   bool cancel
);
[C++]
public: ObjectEditEventArgs(
   Object* value
   String* label
   bool cancel
);
[JScript]
public function ObjectEditEventArgs(
   value : Object
   label : String
   cancel : Boolean
);

Parameters

value

The object associated with this event.

label

The new text to associate with the object.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEditEventArgs Properties

The properties of the ObjectEditEventArgs class are listed here. For a complete list of ObjectEditEventArgs class members, see the ObjectEditEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Object (inherited from CancelEventArgs) | Read-only property that returns the object associated with the ObjectEditEventArgs.
public property Label | Gets the new text to associate with the object.

See Also

ObjectEditEventArgs Class | LidorSystems.IntegralUI Namespace


Label Property

ObjectEditEventArgs.Label Property

Gets the new text to associate with the object.

[Visual Basic]
Public ReadOnly Property Label As String
[C#]
public String Label {get;}
[C++]
public: __property String* get_Label();
[JScript]
public function get Label() : String;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectEditEventArgs Class | ObjectEditEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Class

Provides data for common events.

For a list of all members of this type, see ObjectEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.ObjectEventArgs

[Visual Basic]
Public Class ObjectEventArgs
   Inherits EventArgs
[C#]
public class ObjectEventArgs : EventArgs
[C++]
public __gc class ObjectEventArgs : public EventArgs
[JScript]
public class ObjectEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor

Overload List

Initializes a new instance of the ObjectEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectEventArgs();
[C++] public: ObjectEventArgs();
[JScript] public function ObjectEventArgs();

Initializes a new instance of the ObjectEventArgs class with the specified object.

[Visual Basic] Public Sub ObjectEventArgs(Object)
[C#] public ObjectEventArgs(object);
[C++] public: ObjectEventArgs(Object*);
[JScript] public function ObjectEventArgs(Object);

See Also

ObjectEventArgs Class | ObjectEventArgs Members | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor ()

Initializes a new instance of the ObjectEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectEventArgs();
[C++]
public: ObjectEventArgs();
[JScript]
public function ObjectEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEventArgs Constructor (Object)

Initializes a new instance of the ObjectEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public ObjectEventArgs(
   object value
);
[C++]
public: ObjectEventArgs(
   Object* value
);
[JScript]
public function ObjectEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectEventArgs Properties

The properties of the ObjectEventArgs class are listed here. For a complete list of ObjectEventArgs class members, see the ObjectEventArgs Members topic.

Public Properties

public property Object Read-only property that returns the object associated with the ObjectEventArgs.

See Also

ObjectEventArgs Class | LidorSystems.IntegralUI Namespace


ObjectCancelClickEventHandler Delegate

Represents the method that will handle common clickable events which can be canceled.

[Visual Basic]
Public Delegate Sub ObjectCancelClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCancelClickEventArgs _
)
[C#]
public Delegate void ObjectCancelClickEventHandler(
   object sender,
   ObjectCancelClickEventArgs e
);
[C++]
public __gc __delegate void ObjectCancelClickEventHandler(
   Object* sender,
   ObjectCancelClickEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCancelClickEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCancelClickEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ObjectCancelEventHandler Delegate

Represents the method that will handle common cancelable events.

[Visual Basic]
Public Delegate Sub ObjectCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
public Delegate void ObjectCancelEventHandler(
   object sender,
   ObjectCancelEventArgs e
);
[C++]
public __gc __delegate void ObjectCancelEventHandler(
   Object* sender,
   ObjectCancelEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCancelEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCancelEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ObjectClickEventHandler Delegate

Represents the method that will handle common clickable events.

[Visual Basic]
Public Delegate Sub ObjectClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectClickEventArgs _
)
[C#]
public Delegate void ObjectClickEventHandler(
   object sender,
   ObjectClickEventArgs e
);
[C++]
public __gc __delegate void ObjectClickEventHandler(
   Object* sender,
   ObjectClickEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectClickEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectClickEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ObjectEditEventHandler Delegate

Represents the method that will handle common editing events which can be canceled.

[Visual Basic]
Public Delegate Sub ObjectEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectEditEventArgs _
)
[C#]
public Delegate void ObjectEditEventHandler(
   object sender,
   ObjectEditEventArgs e
);
[C++]
public __gc __delegate void ObjectEditEventHandler(
   Object* sender,
   ObjectEditEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectEditEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectEditEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ObjectEventHandler Delegate

Represents the method that will handle common events.

[Visual Basic]
Public Delegate Sub ObjectEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectEventArgs _
)
[C#]
public Delegate void ObjectEventHandler(
   object sender,
   ObjectEventArgs e
);
[C++]
public __gc __delegate void ObjectEventHandler(
   Object* sender,
   ObjectEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ActionType Enumeration

Enumerator used to specify the action assigned to some object.

[Visual Basic]
Public Enum ActionType
[C#]
public enum ActionType
[C++]
__value public enum ActionType
[JScript]
public
   enum ActionType

Members

Member name | Description
Recreate | The object will recreate itself before make any updates.
Repaint | The object will repaint it's client area.
Update | The object will update and repaint it's client area.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


CheckMode Enumeration

Enumerator used to determine whether check boxes can accept two or three values.

[Visual Basic]
Public Enum CheckMode
[C#]
public enum CheckMode
[C++]
__value public enum CheckMode
[JScript]
public
   enum CheckMode

Members

Member name | Description
TwoState | Check boxes can be in unchecked or checked state.
ThreeState | Check boxes can be in unchecked, indeterminate or checked state.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


DragDropMode Enumeration

Enumerator used to determine the type of drag-and-drop operation.

[Visual Basic]
Public Enum DragDropMode
[C#]
public enum DragDropMode
[C++]
__value public enum DragDropMode
[JScript]
public
   enum DragDropMode

Members

Member name | Description
Predefined | A predefined drag-and-drop operation.
Custom | You need to create your own drag-and-drop operations.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


FadingEffect Enumeration

Enumerator used to determine the fading effect that is used during hovering over items.

[Visual Basic]
Public Enum FadingEffect
[C#]
public enum FadingEffect
[C++]
__value public enum FadingEffect
[JScript]
public
   enum FadingEffect

Members

Member name | Description
Default | No fading.
Office2007 | Mimics the fading effect of Office 2007.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


FadingSpeed Enumeration

Enumerator used to determine the speed of fading that is used during hovering over objects.

[Visual Basic]
Public Enum FadingSpeed
[C#]
public enum FadingSpeed
[C++]
__value public enum FadingSpeed
[JScript]
public
   enum FadingSpeed

Members

Member name | Description
VerySlow | The speed of fading is very slow.
Slow | The speed of fading is slower then usual.
Normal | The speed of fading is normal.
Fast | The speed of fading is faster then usual.
VeryFast | The speed of fading is instant.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ObjectState Enumeration

Enumerator used to determine the current state of the object.

[Visual Basic]
Public Enum ObjectState
[C#]
public enum ObjectState
[C++]
__value public enum ObjectState
[JScript]
public
   enum ObjectState

Members

Member name | Description
Disabled | The object is disabled.
Focused | The object has the input focus.
Hovered | The mouse pointer hovers over object space.
Normal | A default state of object.
Selected | The object is selected.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


VerticalAlignment Enumeration

Specifies how an object or text in a control is vertically aligned relative to an element of the control.

[Visual Basic]
Public Enum VerticalAlignment
[C#]
public enum VerticalAlignment
[C++]
__value public enum VerticalAlignment
[JScript]
public
   enum VerticalAlignment

Members

Member name | Description
Top | The object or text is aligned on the top of the control element.
Center | The object or text is aligned in the center of the control element.
Bottom | The object or text is aligned on the bottom of the control element.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


LidorSystems.IntegralUI.Collections

LidorSystems.IntegralUI.Collections Namespace

Classes

Class | Description
ObjectCollectionCancelEventArgs | Provides data for a cancelable events for objects of ObjectCollection class.
ObjectCollection | Contains a collection of objects.
ObjectCollectionEventArgs | Provides data for common events for objects of ObjectCollection class.

Delegates

Delegate | Description
ObjectCollectionCancelEventHandler | Represents the method that will handle cancelable events of ObjectCollection class.
ObjectCollectionEventHandler | Represents the method that will handle common events of ObjectCollection class.


ObjectCollectionCancelEventArgs Class

Provides data for cancelable events for objects of ObjectCollection class.

For a list of all members of this type, see ObjectCollectionCancelEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
LidorSystems.IntegralUI.Collections.ObjectCollectionCancelEventArgs

[Visual Basic]
Public Class ObjectCollectionCancelEventArgs
   Inherits CancelEventArgs
[C#]
public class ObjectCollectionCancelEventArgs : CancelEventArgs
[C++]
public __gc class ObjectCollectionCancelEventArgs : public CancelEventArgs
[JScript]
public class ObjectCollectionCancelEventArgs extends CancelEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A cancelable event is raised by a object when it is about to perform an action that can be canceled. A ObjectCollectionCancelEventArgs provides the Cancel property to indicate whether the event should be canceled.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Collections (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Members

ObjectCollectionCancelEventArgs overview

Public Constructors

public constructor ObjectCollectionCancelEventArgs Constructor Initializes a new instance of the ObjectCollectionCancelEventArgs class.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCollectionCancelEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollectionCancelEventArgs();
[C++] public: ObjectCollectionCancelEventArgs();
[JScript] public function ObjectCollectionCancelEventArgs();

Initializes a new instance of the ObjectCollectionCancelEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic] Public Sub ObjectCollectionCancelEventArgs(Boolean, Object, Integer)
[C#] public ObjectCollectionCancelEventArgs(bool, object, int);
[C++] public: ObjectCollectionCancelEventArgs(bool, Object*, int);
[JScript] public function ObjectCollectionCancelEventArgs(Boolean, Object, int);

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor ()

Initializes a new instance of the ObjectCollectionCancelEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollectionCancelEventArgs();
[C++]
public: ObjectCollectionCancelEventArgs();
[JScript]
public function ObjectCollectionCancelEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Constructor (Object, Integer, Boolean)

Initializes a new instance of the ObjectCollectionCancelEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal index As Integer _
   ByVal cancel As Boolean _
)
[C#]
public ObjectCollectionCancelEventArgs(
   object value
   int index
   bool cancel
);
[C++]
public: ObjectCollectionCancelEventArgs(
   Object* value
   int index
   bool cancel
);
[JScript]
public function ObjectCollectionCancelEventArgs(
   value : Object
   index : int
   cancel : Boolean
);

Parameters

value

The object associated with this event.

index

The indexed location of the object in the ObjectCollection.

cancel

true to cancel the event; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventArgs Properties

The properties of the ObjectCollectionCancelEventArgs class are listed here. For a complete list of ObjectCollectionCancelEventArgs class members, see the ObjectCollectionCancelEventArgs Members topic.

Public Properties

public property Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

See Also

ObjectCollectionCancelEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


Index Property

ObjectCollectionCancelEventArgs.Index Property

Read-only property that returns the index of the object associated with the ObjectCollectionCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


Value Property

ObjectCollectionCancelEventArgs.Value Property

Read-only property that returns the object associated with the ObjectCollectionCancelEventArgs.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollectionCancelEventArgs Class | ObjectCollectionCancelEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Class

Contains a collection of objects.

For a list of all members of this type, see ObjectCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection

[Visual Basic]
Public Class ObjectCollection
   Inherits CollectionBase
[C#]
public class ObjectCollection : CollectionBase
[C++]
public __gc class ObjectCollection : public CollectionBase
[JScript]
public class ObjectCollection extends CollectionBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Members

ObjectCollection overview

Public Constructors

public constructor ObjectCollection Constructor Initializes a new instance of the ObjectCollection class.

Public Properties

public property Item | Gets or sets an object at the specified location in the collection.
public property Owner | Gets the object that owns the ObjectCollection.

Public Methods

public method Add | Adds a new object to the end of the ObjectCollection.
public method AddRange | Adds an array of objects to the ObjectCollection.
public method Clear | Removes all objects from the collection.
public method Contains | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified object in the collection.
public method Insert | Inserts an existing object in the ObjectCollection at the specified location.
public method Remove | Removes the specified object from the ObjectCollection.
public method RemoveAt | Removes the object at the specified index of the ObjectCollection.
public method SetChildIndex | Sets the index of the specified object in the collection to the specified index value.
public method Sort | Sorts the elements in the entire ObjectCollection using the specified comparer.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added | Occurs after an object is added.
public event Adding | Occurs before an object is added.
public event Cleared | Occurs after all objects are removed from the collection.
public event Clearing | Occurs before all objects are removed from the collection.
public event Removed | Occurs after an object is removed.
public event Removing | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Occurs after an object is added.
protected method OnAdding | Occurs before an object is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnIndexChanged | Occurs after an object index in collection has changed.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Occurs after an object is removed.
protected method OnRemoving | Occurs before an object is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor

Overload List

Initializes a new instance of the ObjectCollection class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollection();
[C++] public: ObjectCollection();
[JScript] public function ObjectCollection();

Initializes a new instance of the ObjectCollection class and associates it with the given object.

[Visual Basic] Public Sub ObjectCollection(Object)
[C#] public ObjectCollection(object);
[C++] public: ObjectCollection(Object*);
[JScript] public function ObjectCollection(Object);

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor ()

Initializes a new instance of the ObjectCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollection();
[C++]
public: ObjectCollection();
[JScript]
public function ObjectCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Constructor (Object)

Initializes a new instance of the ObjectCollection class and associates it with the given object.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ObjectCollection(
   object owner
);
[C++]
public: ObjectCollection(
   Object* owner
);
[JScript]
public function ObjectCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Properties

The properties of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Properties

public property Item | Gets or sets an object at the specified location in the collection.
public property Owner | Gets the object that owns the ObjectCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Item Property

ObjectCollection.Item Property

Gets or sets a object at the specified location in the collection.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {get; set;}
[C++]
public: __property Object* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Object*
);

Parameters

index
The 0-based index of the object to get or set.

Property Value

The object at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Owner Property

ObjectCollection.Owner Property

Gets the object that owns the ObjectCollection.

[Visual Basic]
Public Property Owner As object
[C#]
public object Owner { get; }
[C++]
public: __property Object* get_Owner();
[JScript]
public function get Owner() : object

Property Value

Represents the object that owns the ObjectCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Methods

The methods of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Methods

public method Add | Adds a new object to the end of the ObjectCollection.
public method AddRange | Adds an array of objects to the ObjectCollection.
public method Clear | Removes all objects from the collection.
public method Contains | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf | Returns the index of the specified object in the collection.
public method Insert | Inserts an existing object in the ObjectCollection at the specified location.
public method Remove | Removes the specified object from the ObjectCollection.
public method RemoveAt | Removes the object at the specified index of the ObjectCollection.
public method SetChildIndex | Sets the index of the specified object in the collection to the specified index value.
public method Sort | Sorts the elements in the entire ObjectCollection using the specified comparer.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Occurs after an object is added.
protected method OnAdding | Occurs before an object is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnIndexChanged | Occurs after an object index in collection has changed.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Occurs after an object is removed.
protected method OnRemoving | Occurs before an object is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Add Method

ObjectCollection.Add Method

Adds a new object to the end of the ObjectCollection.

[Visual Basic]
Public Overridable Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int Add(
   object value
);
[C++]
public: virtual int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
The object to add to the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Return Value

The zero-based index value of the Object added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


AddRange Method

ObjectCollection.AddRange Method

Adds an array of objects to the ObjectCollection.

[Visual Basic]
Public Overridable Sub AddRange( _
   ByVal values() As Object _
)
[C#]
public virtual void AddRange(
   object[] values
);
[C++]
public: virtual void AddRange(
   Object* values[]
);
[JScript]
public function AddRange(
   values : Object[]
);

Parameters

values
An array of type object that contains the values to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The value of values equals null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Clear Method

ObjectCollection.Clear Method

Removes all objects from the collection.

[Visual Basic]
Public Shadows Sub Clear()
[C#]
public new void Clear();
[C++]
public: void Clear();
[JScript]
public hide function Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Contains Method

ObjectCollection.Contains Method

Determines whether the specified object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
The object to locate in the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Return Value

true if the specified object is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


IndexOf Method

ObjectCollection.IndexOf Method

Returns the index of the specified object in the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
The object to locate in the collection.

Return Value

The zero-based index of the item found in the ObjectCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Insert Method

ObjectCollection.Insert Method

Inserts an existing object in the ObjectCollection at the specified location.

[Visual Basic]
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void Insert(
   int index,
   object value
);
[C++]
public: virtual void Insert(
   int index,
   Object* value
);
[JScript]
public function Insert(
   index : int,
   value : Object
);

Parameters

index
The indexed location within the collection to insert the object.
value
The Object to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | The value is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnAdded Method

ObjectCollection.OnAdded Method

Occurs after an object is added.

[Visual Basic]
Protected Overridable Sub OnAdded( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnAdded(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnAdded(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnAdded(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnAdding Method

ObjectCollection.OnAdding Method

Occurs before an object is added.

[Visual Basic]
Protected Overridable Sub OnAdding( _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
protected virtual void OnAdding(
   ObjectCollectionCancelEventArgs e
);
[C++]
protected: virtual void OnAdding(
   ObjectCollectionCancelEventArgs* e
);
[JScript]
protected function OnAdding(
   e : ObjectCollectionCancelEventArgs
);

Parameters

e
An ObjectCollectionCancelEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnIndexChanged Method

ObjectCollection.OnIndexChanged Method

Occurs after an object index in collection has changed.

[Visual Basic]
Protected Overridable Sub OnIndexChanged( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnIndexChanged(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnIndexChanged(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnIndexChanged(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnRemoved Method

ObjectCollection.OnRemoved Method

Occurs after an object is removed.

[Visual Basic]
Protected Overridable Sub OnRemoved( _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
protected virtual void OnRemoved(
   ObjectCollectionEventArgs e
);
[C++]
protected: virtual void OnRemoved(
   ObjectCollectionEventArgs* e
);
[JScript]
protected function OnRemoved(
   e : ObjectCollectionEventArgs
);

Parameters

e
An ObjectCollectionEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


OnRemoving Method

ObjectCollection.OnRemoving Method

Occurs before an object is removed.

[Visual Basic]
Protected Overridable Sub OnRemoving( _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
protected virtual void OnRemoving(
   ObjectCollectionCancelEventArgs e
);
[C++]
protected: virtual void OnRemoving(
   ObjectCollectionCancelEventArgs* e
);
[JScript]
protected function OnRemoving(
   e : ObjectCollectionCancelEventArgs
);

Parameters

e
An ObjectCollectionCancelEventArgs that contains the event data.

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


RemoveAt Method

ObjectCollection.RemoveAt Method

Removes the object at the specified index of the ObjectCollection.

[Visual Basic]
Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public new void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public hide function RemoveAt(
   index : int
);

Parameters

index
The 0-based index of the object to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Remove Method

ObjectCollection.Remove Method

Removes a object from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
The object to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The value parameter is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


SetChildIndex Method

ObjectCollection.SetChildIndex Method

Sets the index of the specified object in the collection to the specified index value.

[Visual Basic]
Public Sub SetChildIndex( _
   ByVal value As Object, _
   ByVal index As Integer _
)
[C#]
public void SetChildIndex(
   object value,
   int index
);
[C++]
public: void SetChildIndex(
   Object* value,
   int index
);
[JScript]
public function SetChildIndex(
   value : Object,
   index : int
);

Parameters

value
The object to search for.
index
The new index value of the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Sort Method

ObjectCollection.Sort Method

Sorts the elements in the entire ObjectCollection using the specified comparer.

[Visual Basic]
Public Sub Sort( _ ByVal
   comparer  As IComparer _
)
[C#]
 public void Sort(
   IComparer comparer
);
[C++]
public: void Sort(
   IComparer* comparer
);
[JScript]
 public function Sort(
   comparer : IComparer
);

Parameters

comparer
The IComparer implementation to use when comparing elements.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollection Events

The events of the ObjectCollection class are listed here. For a complete list of ObjectCollection class members, see the ObjectCollection Members topic.

Public Events

public event Added | Occurs after an object is added.
public event Adding | Occurs before an object is added.
public event Cleared | Occurs after all objects are removed from the collection.
public event Clearing | Occurs before all objects are removed from the collection.
public event Removed | Occurs after an object is removed.
public event Removing | Occurs before an object is removing.

See Also

ObjectCollection Class | LidorSystems.IntegralUI.Collections Namespace


Added Event

ObjectCollection.Added Event

Occurs after an object is added.

[Visual Basic]
Public Event Added As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Added;
[C++]
public: __event ObjectCollectionEventHandler* Added;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Adding Event

ObjectCollection.Adding Event

Occurs before an object is added.

[Visual Basic]
Public Event Adding As ObjectCollectionCancelEventHandler
[C#]
public event ObjectCollectionCancelEventHandler Adding;
[C++]
public: __event ObjectCollectionCancelEventHandler* Adding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionCancelEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Cleared Event

ObjectCollection.Cleared Event

Occurs after all objects are removed from the collection.

[Visual Basic]
Public Event Cleared As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Cleared;
[C++]
public: __event ObjectCollectionEventHandler* Cleared;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Clearing Event

ObjectCollection.Clearing Event

Occurs before all objects are removed from the collection.

[Visual Basic]
Public Event Clearing As EventHandler
[C#]
public event EventHandler Clearing;
[C++]
public: __event EventHandler* Clearing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


IndexChanged Event

ObjectCollection.IndexChanged Event

Occurs when the index of some object in collection has changed.

[Visual Basic]
Public Event IndexChanged As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler IndexChanged;
[C++]
public: __event ObjectCollectionEventHandler* IndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Removed Event

ObjectCollection.Removed Event

Occurs after an object is removed.

[Visual Basic]
Public Event Removed As ObjectCollectionEventHandler
[C#]
public event ObjectCollectionEventHandler Removed;
[C++]
public: __event ObjectCollectionEventHandler* Removed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


Removing Event

ObjectCollection.Removing Event

Occurs before an object is removed.

[Visual Basic]
Public Event Removing As ObjectCollectionCancelEventHandler
[C#]
public event ObjectCollectionCancelEventHandler Removing;
[C++]
public: __event ObjectCollectionCancelEventHandler* Removing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCollectionCancelEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollection Class | ObjectCollection Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Class

Provides data for a common events of ObjectCollection class.

For a list of all members of this type, see ObjectCollectionEventArgs Members.

System.Object
System.EventArgs
LidorSystems.IntegralUI.Collections.ObjectCollectionEventArgs

[Visual Basic]
Public Class ObjectCollectionEventArgs
   Inherits EventArgs
[C#]
public class ObjectCollectionEventArgs : EventArgs
[C++]
public __gc class ObjectCollectionEventArgs : public EventArgs
[JScript]
public class ObjectCollectionEventArgs extends EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Members

ObjectCollectionEventArgs overview

Public Constructors

public constructor ObjectCollectionEventArgs Constructor Initializes a new instance of the ObjectCollectionEventArgs class.

Public Properties

public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionEventArgs.

Public Methods

public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor

Overload List

Initializes a new instance of the ObjectCollectionEventArgs class.

[Visual Basic] Public Sub New()
[C#] public ObjectCollectionEventArgs();
[C++] public: ObjectCollectionEventArgs();
[JScript] public function ObjectCollectionEventArgs();

Initializes a new instance of the ObjectCollectionEventArgs class with the specified object and the object index.

[Visual Basic] Public Sub ObjectCollectionEventArgs(Object, Integer)
[C#] public ObjectCollectionEventArgs(object, int);
[C++] public: ObjectCollectionEventArgs(Object*, int);
[JScript] public function ObjectCollectionEventArgs(Object, int);

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor ()

Initializes a new instance of the ObjectCollectionEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ObjectCollectionEventArgs();
[C++]
public: ObjectCollectionEventArgs();
[JScript]
public function ObjectCollectionEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Constructor (Object, Integer)

Initializes a new instance of the ObjectCollectionEventArgs class with the specified object, the object index, and a value specifying whether the event is to be canceled.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
   ByVal index As Integer _
)
[C#]
public ObjectCollectionEventArgs(
   object value
   int index
);
[C++]
public: ObjectCollectionEventArgs(
   Object* value
   int index
);
[JScript]
public function ObjectCollectionEventArgs(
   value : Object
   index : int
);

Parameters

value

The object associated with this event.

index

The indexed location of the object in the ObjectCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventArgs Properties

The properties of the ObjectCollectionEventArgs class are listed here. For a complete list of ObjectCollectionEventArgs class members, see the ObjectCollectionEventArgs Members topic.

Public Properties

public property Index | Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.
public property Value | Read-only property that returns the object associated with the ObjectCollectionEventArgs.

See Also

ObjectCollectionEventArgs Class | LidorSystems.IntegralUI.Collections Namespace


Index Property

ObjectCollectionEventArgs.Index Property

Read-only property that returns the index of the object associated with the ObjectCollectionEventArgs.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


Value Property

ObjectCollectionEventArgs.Value Property

Read-only property that returns the object associated with the ObjectCollectionEventArgs.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ObjectCollectionEventArgs Class | ObjectCollectionEventArgs Members | LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionCancelEventHandler Delegate

Represents the method that will handle cancelable events of ObjectCollection class.

[Visual Basic]
Public Delegate Sub ObjectCollectionCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCollectionCancelEventArgs _
)
[C#]
public Delegate void ObjectCollectionCancelEventHandler(
   object sender,
   ObjectCollectionCancelEventArgs e
);
[C++]
public __gc __delegate void ObjectCollectionCancelEventHandler(
   Object* sender,
   ObjectCollectionCancelEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCollectionCancelEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCollectionCancelEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Collections Namespace


ObjectCollectionEventHandler Delegate

Represents the method that will handle common events of ObjectCollection class.

[Visual Basic]
Public Delegate Sub ObjectCollectionEventHandler( _
   ByVal sender As Object, _
   ByVal e As ObjectCollectionEventArgs _
)
[C#]
public Delegate void ObjectCollectionEventHandler(
   object sender,
   ObjectCollectionEventArgs e
);
[C++]
public __gc __delegate void ObjectCollectionEventHandler(
   Object* sender,
   ObjectCollectionEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the ObjectCollectionEventHandler Delegate declaration.

sender
The source of the event.
e
A ObjectCollectionEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Collections Namespace


LidorSystems.IntegralUI.Controls

LidorSystems.IntegralUI.Controls Namespace

Classes

Class | Description
CheckBox | Represents a check box control.
ComboBox | Represents a combo box control.
CommandButton | Represents a button used to trigger custom operations.
CommonControlBase | Provides a common implementation of members for controls.
DateTimePicker | Represents a date time picker control.
DropDownControl | Represents a common implementation of members for drop down controls.
ListControl | Displays a collection of ListControlItems.
ListControlItem | class representing the items in the ListControl control.
MonthCalendar | Represents a control that enables selection of a date using calendar.
NumberedListControl | Displays an ordered list of items used for navigation.
NumericUpDown | Represents a up-down control that displays numeric values.
ProgressBar | Represents a control that displays progress of an operation.
RatingControl | Represents a rating control.
TextControl | Represents a text box control.
ToolButton | A class representing a selectable button that can contain text and image.
ToolItemBase | Provides a common implementation of members for tool item objects.
ToolLabel | A class representing a non-selectable tool item that renders text and images and can display hyperlinks.
ToolSeparator | A class representing a line used to group tool items.

Enumerations

Enumeration | Description
CalendarDisplayMode | Enumerator used to determine how date is displayed in MonthCalendar control.
CharacterMode | Enumerator used to determine the type of characters that can be inserted.
CommandButtonType | Enumerator used to specify some predfined types of command buttons.
CommandButtonVisibility | Enumerator used to determine how command buttons are displayed.
NumericButtonAlignment | Enumerator used to determine how control will align buttons relative to its edit box in NumericUpDown control.
ToolContentRelation | Enumerator used to specify how content of tool items are arranged.
ToolDisplayStyle | Enumerator used to specify what objects are showed in tool item space.
ToolItemAlignment | Enumerator used to determine the alignment of tool item in the parent container.
ToolItemType | Enumerator used to specify the type of tool item.
ToolLinkUnderlineStyle | Enumerator used to specify when an underline is shown below the text in tool label.


CheckBox Class

Represents a check box control.

For a list of all members of this type, see CheckBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.CheckBox

[Visual Basic]
 Public Class CheckBox
   Inherits Control
[C#]
public class CheckBox : Control
[C++]
 public __gc class CheckBox : public Control
[JScript]
public class CheckBox extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Members

CheckBox overview

Public Constructors

public constructor CheckBox Constructor Initializes a new instance of the CheckBox class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoCheck | Determines whether the check box state is altered when control is clicked.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxRect | Gets the bounds of the check box.
public property CheckButtonStyle | Gets or sets the drawing style of the check box.
public property CheckState | Gets or sets a value representing the current state of the check box.
public property Checked | Indicates whether the check box is checked or unchecked.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event CheckedChanged | Occurs when the Checked property value changes.
public event CheckStateChanged | Occurs when the CheckState property value changes.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckBox Constructor ()

Initializes a new instance of the CheckBox class.

[Visual Basic]
Public Sub New()
[C#]
public CheckBox();
[C++]
public: CheckBox();
[JScript]
public function CheckBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckBox Properties

The properties of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoCheck | Determines whether the check box state is altered when control is clicked.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxRect | Gets the space reserved for check button box.
public property CheckButtonStyle | Gets or sets the drawing style of the check box.
public property CheckState | Gets or sets a value representing the current state of the check box.
public property Checked | Indicates whether the check box is checked or unchecked.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for check box text.
public property ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


AutoCheck Property

CheckBox.AutoCheck Property

Determines whether the check box state is altered when control is clicked.

[Visual Basic]
Public Overridable Property AutoCheck As Boolean
[C#]
public virtual bool AutoCheck { get; set; }
[C++]
public: __property virtual bool get_AutoCheck();
 public:
__property virtual void set_AutoCheck(bool );
[JScript]
public function get AutoCheck() : bool
public function set AutoCheck(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBoxRect Property

CheckBox.CheckBoxRect Property

Gets the space reserved for check button box.

[Visual Basic]
Public ReadOnly Property CheckBoxRect As Rectangle
[C#]
public Rectangle CheckBoxRect {get;}
[C++]
public: __property Rectangle get_CheckBoxRect();
[JScript]
public function get CheckBoxRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check button box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckButtonStyle Property

CheckBox.CheckButtonStyle Property

Gets or sets the drawing style of the check box.

[Visual Basic]
Public Property CheckButtonStyle As CheckButtonBoxStyle
[C#]
public CheckButtonBoxStyle CheckButtonStyle {get; set;}
[C++]
public: __property CheckButtonBoxStyle get_CheckButtonStyle();
public: __property void set_CheckButtonStyle(CheckButtonBoxStyle);
[JScript]
public function get CheckButtonStyle() : CheckButtonBoxStyle;
public function set CheckButtonStyle(CheckButtonBoxStyle);

Property Value

The CheckButtonBoxStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


Checked Property

CheckBox.Checked Property

Indicates whether the check box is checked or unchecked.

[Visual Basic]
 Public Property Checked As Boolean
[C#]
 public bool Checked { get; set; }
[C++]
 public: __property bool
 get_Checked();
public: __property void set_Checked(bool );
[JScript]
public function get Checked() : bool
public function set Checked(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckState Property

CheckBox.CheckState Property

Gets or sets a value representing the current state of the check box.

[Visual Basic]
Public Overridable Property CheckState As CheckState
[C#]
public virtual CheckState CheckState {get; set;}
[C++]
public: __property virtual CheckState get_CheckState();
public: __property virtual void set_CheckState(CheckState);
[JScript]
public function get CheckState() : CheckState;
public function set CheckState(CheckState);

Property Value

The CheckState assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

CheckBox.TextRect Property

Gets the space reserved for check box text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check box text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


ThreeState Property

CheckBox.ThreeState Property

Gets or sets a value indicating whether the CheckBox will allow three check states rather than two.

[Visual Basic]
Public Overridable Property ThreeState As Boolean
[C#]
public virtual bool ThreeState { get; set; }
[C++]
public: __property virtual bool get_ThreeState();
 public:
__property virtual void set_ThreeState(bool );
[JScript]
public function get ThreeState() : bool
public function set ThreeState(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Methods

The methods of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

CheckBox.Dispose Method

Releases all resources used by this CheckBox object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentCheckButtonStyle Method

CheckBox.GetCurrentCheckButtonStyle Method

Returns the current drawing style of the check button box.

[Visual Basic]
Overloads Public Function GetCurrentCheckButtonStyle() As CheckBoxButtonStyle
[C#]
public CheckBoxButtonStyle GetCurrentCheckButtonStyle();
[C++]
public: CheckBoxButtonStyle* GetCurrentCheckButtonStyle();
[JScript]
public function GetCurrentCheckButtonStyle() : CheckBoxButtonStyle;

Return Value

The style that represents the current drawing style of the check button box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckedChanged Method

CheckBox.OnCheckedChanged Method

Raises the CheckedChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckedChanged( _
   ByVal e As EventArgsClass _
)
[C#]
protected virtual void OnCheckedChanged(
   EventArgsClass e
);
[C++]
protected: virtual void OnCheckedChanged(
   EventArgsClass* e
);
[JScript]
protected function OnCheckedChanged(
   e : EventArgsClass
);

Parameters

e
A EventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckStateChanged Method

CheckBox.OnCheckStateChanged Method

Raises the CheckStateChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckStateChanged( _
   ByVal e As EventArgsClass _
)
[C#]
protected virtual void OnCheckStateChanged(
   EventArgsClass e
);
[C++]
protected: virtual void OnCheckStateChanged(
   EventArgsClass* e
);
[JScript]
protected function OnCheckStateChanged(
   e : EventArgsClass
);

Parameters

e
A EventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

CheckBox.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckBox Events

The events of the CheckBox class are listed here. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event CheckedChanged | Occurs when the Checked property value changes.
public event CheckStateChanged | Occurs when the CheckState property value changes.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CheckBox Class | LidorSystems.IntegralUI.Controls Namespace


CheckedChanged Event

CheckBox.CheckedChanged Event

Occurs when the Checked property value has changed.

[Visual Basic]
Public Event CheckedChanged As EventHandler
[C#]
public event EventHandler CheckedChanged;
[C++]
public: __event EventHandler* CheckedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


CheckStateChanged Event

CheckBox.CheckStateChanged Event

Occurs when the CheckState property value has changed.

[Visual Basic]
Public Event CheckStateChanged As EventHandler
[C#]
public event EventHandler CheckStateChanged;
[C++]
public: __event EventHandler* CheckStateChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckBox Class | CheckBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Class

Represents a combo box control.

For a list of all members of this type, see ComboBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ComboBox

[Visual Basic]
 Public Class ComboBox
   Inherits Control
[C#]
public class ComboBox : Control
[C++]
 public __gc class ComboBox : public Control
[JScript]
public class ComboBox extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Members

ComboBox overview

Public Constructors

public constructor ComboBox Constructor Initializes a new instance of the ComboBox class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSelectedItemChanged | Raises the SelectedItemChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnTextUpdate | Raises the TextUpdate event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


ComboBox Constructor ()

Initializes a new instance of the ComboBox class.

[Visual Basic]
Public Sub New()
[C#]
public ComboBox();
[C++]
public: ComboBox();
[JScript]
public function ComboBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


ComboBox Properties

The properties of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


DropDownHeight Property

ComboBox.DropDownHeight Property

Specifies the height of drop down window.

[Visual Basic]
Public Property DropDownHeight As Integer
[C#]
public int DropDownHeight {get; set;}
[C++]
public: __property int get_DropDownHeight();
public: __property void set_DropDownHeight(int);
[JScript]
public function get DropDownHeight() : int;
public function set DropDownHeight(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


DropDownList Property

ComboBox.DropDownList Property

Gets the drop down list control.

[Visual Basic]
Public ReadOnly Property DropDownList As ListControl
[C#]
public ListControl DropDownList {get;}
[C++]
public: __property ListControl* get_DropDownList();
[JScript]
public function get DropDownList() : ListControl;

Property Value

A ListControl that represents the drop down list assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


DropDownWidth Property

ComboBox.DropDownWidth Property

Specifies the width of drop down window.

[Visual Basic]
Public Property DropDownWidth As Integer
[C#]
public int DropDownWidth {get; set;}
[C++]
public: __property int get_DropDownWidth();
public: __property void set_DropDownWidth(int);
[JScript]
public function get DropDownWidth() : int;
public function set DropDownWidth(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

ComboBox.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ImageList Property

ComboBox.ImageList Property

Gets or sets the ImageList that contains the Image objects used by items.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


IntegralHeight Property

ComboBox.IntegralHeight Property

Determines whether the combo box should resize its drop-down window to avoid showing partial items.

[Visual Basic]
 Public Property IntegralHeight As Boolean
[C#]
 public bool IntegralHeight { get; set; }
[C++]
 public: __property bool
 get_IntegralHeight();
public: __property void set_IntegralHeight(bool );
[JScript]
public function get IntegralHeight() : bool
public function set IntegralHeight(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


Items Property

ComboBox.Items Property

Gets the collection of items that are assigned to the control.

[Visual Basic]
Public ReadOnly Property Items As ListControlItemCollection
[C#]
public ListControlItemCollection Items {get;}
[C++]
public: __property ListControlItemCollection* get_Items();
[JScript]
public function get Items() : ListControlItemCollection;

Property Value

A ListControlItemCollection that represents the items assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


MaxDropDownItems Property

ComboBox.MaxDropDownItems Property

Specifies the maximum number of items displayed in drop down list.

[Visual Basic]
Public Property MaxDropDownItems As Integer
[C#]
public int MaxDropDownItems {get; set;}
[C++]
public: __property int get_MaxDropDownItems();
public: __property void set_MaxDropDownItems(int);
[JScript]
public function get MaxDropDownItems() : int;
public function set MaxDropDownItems(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedIndex Property

ComboBox.SelectedIndex Property

Gets or sets the index specifying the currently selected item.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}
[C++]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(int);
[JScript]
public function get SelectedIndex() : int;
public function set SelectedIndex(int);

Property Value

A index, that represents the position of a selected item. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItem Property

ComboBox.SelectedItem Property

Gets or sets currently selected item in the combo box.

[Visual Basic]
Public Property SelectedItem As ListControlItem
[C#]
public ListControlItem SelectedItem {get; set;}
[C++]
public: __property ListControlItem get_SelectedItem();
public: __property void set_SelectedItem(ListControlItem);
[JScript]
public function get SelectedItem() : ListControlItem;
public function set SelectedItem(ListControlItem);

Property Value

A ListControlItem assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


Sorted Property

ComboBox.Sorted Property

Specifies whether items in drop down list are sortable.

[Visual Basic]
 Public Property Sorted As Boolean
[C#]
 public bool Sorted { get; set; }
[C++]
 public: __property bool
 get_Sorted();
public: __property void set_Sorted(bool );
[JScript]
public function get Sorted() : bool
public function set Sorted(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Methods

The methods of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentCheckButtonStyle | Returns the current drawing style of the check button box.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSelectedItemChanged | Raises the SelectedItemChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnTextUpdate | Raises the TextUpdate event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

ComboBox.Dispose Method

Releases all resources used by this ComboBox object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedIndexChanged Method

ComboBox.OnSelectedIndexChanged Method

Raises the SelectedIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedIndexChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedIndexChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedIndexChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedItemChanged Method

ComboBox.OnSelectedItemChanged Method

Raises the SelectedItemChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedItemChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedItemChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedItemChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedItemChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


OnTextUpdate Method

ComboBox.OnTextUpdate Method

Raises the TextUpdate event.

[Visual Basic]
Protected Overridable Sub OnTextUpdate( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnTextUpdate(
   EventArgs e
);
[C++]
protected: virtual void OnTextUpdate(
   EventArgs* e
);
[JScript]
protected function OnTextUpdate(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

DropDownControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ComboBox Events

The events of the ComboBox class are listed here. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ComboBox Class | LidorSystems.IntegralUI.Controls Namespace


SelectedIndexChanged Event

ComboBox.SelectedIndexChanged Event

Occurs when SelectedIndex property value changes.

[Visual Basic]
Public Event SelectedIndexChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedIndexChanged;
[C++]
public: __event ObjectEventHandler* SelectedIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItemChanged Event

ComboBox.SelectedItemChanged Event

Occurs when SelectedItem property value changes.

[Visual Basic]
Public Event SelectedItemChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedItemChanged;
[C++]
public: __event ObjectEventHandler* SelectedItemChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


TextUpdate Event

ComboBox.TextUpdate Event

Occurs when the control has updated its text value.

[Visual Basic]
Public Event TextUpdate As EventHandler
[C#]
public event EventHandler TextUpdate;
[C++]
public: __event EventHandler* TextUpdate;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ComboBox Class | ComboBox Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Class

Represents a button used to trigger custom operations.

For a list of all members of this type, see CommandButton Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.CommandButton

[Visual Basic]

Public Class CommandButton
   Inherits MarshalByRefObject
   Implements IDisposable, ICloneable
[C#]

public class CommandButton : MarshalByRefObject, IDisposable,
   ICloneable
[C++]

 public __gc class CommandButton : public MarshalByRefObject,
   IDisposable, ICloneable
[JScript]
public

  class CommandButton extends MarshalByRefObject implements
   IDisposable, ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Members

CommandButton overview

Public Constructors

public constructor CommandButton Constructor Initializes a new instance of the CommandButton class.

Public Properties

public property Bounds | Gets or sets a value specifying the button space. For internal use only.
public property ButtonType | Gets or sets the the type of the button.
public property ContentSize | Gets or sets the size of button content space. For internal use only.
public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | Gets or sets the image displayed in the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the button is in normal state.
public property Key | Gets or sets a string that uniquely identifies button in a collection.
public property Selected | Gets or sets a value indicating whether the button is selected.
public property Size | Gets or sets the size of the button space. For internal use only.
public property State | Gets a value indicating the current state of the button.
public property Tag | Gets or sets the object that contains data about the button.
public property TagString | Gets or sets the tag string of the button.
public property Visible | Gets or sets a value indicating whether the button is displayed.

Public Methods

public method Clone | Creates an exact copy of the current CommandButton.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this CommandButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Public Events

public event ButtonTypeChanged | Occurs when the ButtonType property value has changed.
public event EnabledChanged | Occurs when the Enabled property value has changed.
public event ImageChanged | Occurs when the value of the Image or ImageIndex property changes.
public event SelectedChanged | Occurs when the Selected property value has changed.
public event VisibleChanged | Occurs when the Visible property value changes.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnButtonTypeChanged | Raises the ButtonTypeChanged event.
protected method OnEnabledChanged | Raises the EnabledChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnSelectedChanged | Raises the SelectedChanged event.
protected method OnVisibleChanged | Raises the VisibleChanged event.

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor

Initializes a new instance of the CommandButton class.

Overload List

Initializes a new instance of the CommandButton class.

[Visual Basic] Public Sub New()
[C#] public CommandButton();
[C++] public: CommandButton();
[JScript] public function CommandButton();

Initializes a new instance of the CommandButton class with the specified type.

[Visual Basic] Public Sub New(CommandButtonType)
[C#] public CommandButton(CommandButtonType);
[C++] public: CommandButton(CommandButtonType*);
[JScript] public function CommandButton(CommandButtonType);

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor ()

Initializes a new instance of the CommandButton class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButton();
[C++]
public: CommandButton();
[JScript]
public function CommandButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Constructor (CommandButtonType)

Initializes a new instance of the CommandButton class with the specified type.

[Visual Basic]
Public Sub New( _
   ByVal type As CommandButtonType _
)
[C#]
public CommandButton(
   CommandButtonType type
);
[C++]
public: CommandButton(
   CommandButtonType* type
);
[JScript]
public function CommandButton(
   type : CommandButtonType
);

Parameters

type
The type of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButton Class | LidorSystems.IntegralUI.Controls Namespace


CommandButton Properties

The properties of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Properties

public property Bounds | Gets or sets a value specifying the button space. For internal use only.
public property ButtonType | Gets or sets the the type of the button.
public property ContentSize | Gets or sets the size of button content space. For internal use only.
public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | Gets or sets the image displayed in the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the button is in normal state.
public property Key | Gets or sets a string that uniquely identifies button in a collection.
public property Selected | Gets or sets a value indicating whether the button is selected.
public property Size | Gets or sets the size of the button space. For internal use only.
public property State | Gets a value indicating the current state of the button.
public property Tag | Gets or sets the object that contains data about the button.
public property TagString | Gets or sets the tag string of the button.
public property Visible | Gets or sets a value indicating whether the button is displayed.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


Bounds Property

CommandButton.Bounds Property

Gets or sets a value specifying the button space. For internal use only.

[Visual Basic]
Public Overrides Overloads ReadOnly Property Bounds As Rectangle
[C#]
public override Rectangle Bounds {get;}
[C++]
public: override __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ButtonType Property

CommandButton.ButtonType Property

Gets or sets the the type of the button.

[Visual Basic]
Public Overrides Overloads Property ButtonType As CommandButtonType
[C#]
public override CommandButtonType ButtonType {get; set;}
[C++]
public: override __property CommandButtonType get_ButtonType();
public: override __property void set_ButtonType(CommandButtonType);
[JScript]
public function get ButtonType() : CommandButtonType;
public function set ButtonType(CommandButtonType);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentSize Property

CommandButton.ContentSize Property

Gets or sets the size of button content space. For internal use only.

[Visual Basic]
Public ReadOnly Property ContentSize As Size
[C#]
public Size ContentSize {get;}
[C++]
public: __property Size get_ContentSize();
[JScript]
public function get ContentSize() : Size;

Property Value

The Size of the button content space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Enabled Property

CommandButton.Enabled Property

Gets or sets a value indicating whether the button can respond to user interaction.

[Visual Basic]
Public Overridable Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

CommandButton.ImageIndex Property

Gets or sets the image list index value of the image displayed when the button is in normal state.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

CommandButton.Image Property

Gets or sets the image displayed when the button is in normal state.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Key Property

CommandButton.Key Property

Gets or sets a string that uniquely identifies button in a collection.

[Visual Basic]
Public Property Key As String
[C#]
public String Key {get; set;}
[C++]
public: __property String* get_Key();
public: __property void set_Key(String*);
[JScript]
public function get Key() : String;
public function set Key(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Selected Property

CommandButton.Selected Property

Gets or sets a value indicating whether the button is selected.

[Visual Basic]
Public Overridable Property Selected As Boolean
[C#]
public virtual bool Selected {get; set;}
[C++]
public: virtual __property bool get_Selected();
public: virtual __property void set_Selected(bool);
[JScript]
public function get Selected() : Boolean;
public function set Selected(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Size Property

CommandButton.Size Property

Gets or sets the size of the button space. For internal use only.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

Property Value

The Size of the button space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


State Property

CommandButton.State Property

Gets a value indicating the current state of the button.

[Visual Basic]
Public Overridable ReadOnly Property State As ObjectState
[C#]
public virtual ObjectState State {get;}
[C++]
public: __property virtual ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Tag Property

CommandButton.Tag Property

Gets or sets the object that contains data about the button.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object*);
[JScript]
public function get Tag() : Object;
public function set Tag(Object);

Property Value

An Object that contains data about the button. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


TagString Property

CommandButton.TagString Property

Gets or sets the tag string of the button.

[Visual Basic]
Public Property TagString As String
[C#]
public String TagString {get; set;}
[C++]
public: __property String* get_TagString();
public: __property void set_TagString(String*);
[JScript]
public function get TagString() : String;
public function set TagString(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Visible Property

CommandButton.Visible Property

Gets or sets a value indicating whether the button is displayed.

[Visual Basic]
Public Overridable Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}
[C++]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Methods

The methods of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Methods

public method Clone | Creates an exact copy of the current CommandButton.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this CommandButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnButtonTypeChanged | Raises the ButtonTypeChanged event.
protected method OnEnabledChanged | Raises the EnabledChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnSelectedChanged | Raises the SelectedChanged event.
protected method OnVisibleChanged | Raises the VisibleChanged event.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


Clone Method

CommandButton.Clone Method

Creates an exact copy of the current CommandButton.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new CommandButton object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

CommandButton.Dispose Method

Releases all resources used by this CommandButton object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonTypeChanged Method

CommandButton.OnButtonTypeChanged Method

Raises the ButtonTypeChanged event.

[Visual Basic]
Protected Overridable Sub OnButtonTypeChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnButtonTypeChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnButtonTypeChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnButtonTypeChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnEnabledChanged Method

CommandButton.OnEnabledChanged Method

Raises the EnabledChanged event.

[Visual Basic]
Protected Overridable Sub OnEnabledChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnEnabledChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnEnabledChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnEnabledChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

CommandButton.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedChanged Method

CommandButton.OnSelectedChanged Method

Raises the SelectedChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnSelectedChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnSelectedChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnSelectedChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


OnVisibleChanged Method

CommandButton.OnVisibleChanged Method

Raises the VisibleChanged event.

[Visual Basic]
Protected Overridable Sub OnVisibleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnVisibleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnVisibleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnVisibleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommandButton Events

The events of the CommandButton class are listed here. For a complete list of CommandButton class members, see the CommandButton Members topic.

Public Events

public event ButtonTypeChanged | Occurs when the ButtonType property value has changed.
public event EnabledChanged | Occurs when the Enabled property value has changed.
public event ImageChanged | Occurs when the value of the Image or ImageIndex property changes.
public event SelectedChanged | Occurs when the Selected property value has changed.
public event VisibleChanged | Occurs when the Visible property value changes.

See Also

CommandButton Class | LidorSystems.IntegralUI Namespace


ButtonTypeChanged Event

CommandButton.ButtonTypeChanged Event

Occurs when the ButtonType property value has changed.

[Visual Basic]
Public Event ButtonTypeChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ButtonTypeChanged;
[C++]
public: __event UpdateEventHandler* ButtonTypeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


EnabledChanged Event

CommandButton.EnabledChanged Event

Occurs when the Enabled property value has changed.

[Visual Basic]
Public Event EnabledChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler EnabledChanged;
[C++]
public: __event UpdateEventHandler* EnabledChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

CommandButton.ImageChanged Event

Occurs when the value of the Image or ImageIndex property changes.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


SelectedChanged Event

CommandButton.SelectedChanged Event

Occurs when the Selected property value has changed.

[Visual Basic]
Public Event SelectedChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler SelectedChanged;
[C++]
public: __event UpdateEventHandler* SelectedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


VisibleChanged Event

CommandButton.VisibleChanged Event

Occurs when the Visible property value has changed.

[Visual Basic]
Public Event VisibleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler VisibleChanged;
[C++]
public: __event UpdateEventHandler* VisibleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButton Class | CommandButton Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Class

Provides a common implementation of members for controls.

For a list of all members of this type, see CommonControlBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.CheckBox
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ListControl
LidorSystems.IntegralUI.Controls.MonthCalendar
LidorSystems.IntegralUI.Controls.NumericUpDown
LidorSystems.IntegralUI.Controls.ProgressBar
LidorSystems.IntegralUI.Controls.TextControl

[Visual Basic]
MustInherit Public Class CommonControlBase
   Inherits Control
[C#]
public abstract class CommonControlBase : Control
[C++]
public __gc __abstract class CommonControlBase : public Control
[JScript]
public abstract class CommonControlBase extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Members

CommonControlBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle | Returns the current color style of the control.
public method GetCurrentFormatStyle | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Constructor ()

Initializes a new instance of the CommonControlBase class.

[Visual Basic]
Public Sub New()
[C#]
public CommonControlBase();
[C++]
public: CommonControlBase();
[JScript]
public function CommonControlBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Properties

The properties of the CommonControlBase class are listed here. For a complete list of CommonControlBase class members, see the CommonControlBase Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


BackgroundImageSpace Property

CommonControlBase.BackgroundImageSpace Property

Gets or sets the space at which background image will be drawn.

[Visual Basic]
Public Property BackgroundImageSpace As BackgroundImageSpace
[C#]
public BackgroundImageSpace BackgroundImageSpace {get; set;}
[C++]
public: __property BackgroundImageSpace get_BackgroundImageSpace();
public: __property void set_BackgroundImageSpace(BackgroundImageSpace);
[JScript]
public function get BackgroundImageSpace() : BackgroundImageSpace;
public function set BackgroundImageSpace(BackgroundImageSpace);

Property Value

The BackgroundImageSpace assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

CommonControlBase.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Property ColorStyle As ControlColorStyle
[C#]
public ControlColorStyle ColorStyle {get; set;}
[C++]
public: __property ControlColorStyle get_ColorStyle();
public: __property void set_ColorStyle(ControlColorStyle);
[JScript]
public function get ColorStyle() : ControlColorStyle;
public function set ColorStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

CommonControlBase.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Property FormatStyle As ControlFormatStyle
[C#]
public ControlFormatStyle FormatStyle {get; set;}
[C++]
public: __property ControlFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ControlFormatStyle);
[JScript]
public function get FormatStyle() : ControlFormatStyle;
public function set FormatStyle(ControlFormatStyle);

Property Value

The ControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


UseTheme Property

CommonControlBase.UseTheme Property

Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Overridable Property UseTheme As Boolean
[C#]
public virtual bool UseTheme { get; set; }
[C++]
public: __property virtual bool get_UseTheme();
 public:
__property virtual void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


VisualStyle Property

CommonControlBase.VisualStyle Property

Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Overridable Property VisualStyle As VisualStyle
[C#]
public virtual VisualStyle VisualStyle {get; set;}
[C++]
public: __property virtual VisualStyle get_VisualStyle();
public: __property virtual void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


CommonControlBase Methods

The methods of the CommonControlBase class are listed here. For a complete list of CommonControlBase class members, see the CommonControlBase Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle | Returns the current color style of the control.
public method GetCurrentFormatStyle | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

CommonControlBase Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

CommonControlBase.Dispose Method

Releases all resources used by this CommonControlBase object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetClientRect Method

CommonControlBase.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

CommonControlBase.GetCurrentColorStyle Method

Returns the current color style of the control.

[Visual Basic]
Overloads Public Function GetCurrentColorStyle() As ControlColorStyle
[C#]
public ControlColorStyle GetCurrentColorStyle();
[C++]
public: ControlColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : ControlColorStyle;

Return Value

The style that represents the current color style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentFormatStyle Method

CommonControlBase.GetCurrentFormatStyle Method

Returns the current format style of the control.

[Visual Basic]
Overloads Public Function GetCurrentFormatStyle() As ControlFormatStyle
[C#]
public ControlFormatStyle GetCurrentFormatStyle();
[C++]
public: ControlFormatStyle* GetCurrentFormatStyle();
[JScript]
public function GetCurrentFormatStyle() : ControlFormatStyle;

Return Value

The style that represents the current format style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


GetDisplayRect Method

CommonControlBase.GetDisplayRect Method

Returns the display rectangle of the control.

[Visual Basic]
Overloads Public Function GetDisplayRect() As Rectangle
[C#]
public Rectangle GetDisplayRect();
[C++]
public: Rectangle* GetDisplayRect();
[JScript]
public function GetDisplayRect() : Rectangle;

Return Value

The rectangle that represents the visible area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

CommonControlBase.IsControlFocused Method

Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overridable Function IsControlFocused() As Boolean
[C#]
public virtual bool IsControlFocused();
[C++]
public: virtual bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate Method

CommonControlBase.ResumeUpdate Method

Resumes the update of the control layout.

Overload List

Resumes only the layout logic of the control.

[Visual Basic] Overridable Public Sub ResumeUpdate()
[C#] public virtual ResumeUpdate();
[C++] public: virtual ResumeUpdate();
[JScript] public function ResumeUpdate();

Resumes the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub ResumeUpdate(Boolean)
[C#] public virtual ResumeUpdate(bool);
[C++] public: virtual ResumeUpdate(bool);
[JScript] public function ResumeUpdate(Boolean);

See Also

ResumeUpdate Class | ResumeUpdate Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate () Method

CommonControlBase.ResumeUpdate () Method

Resumes only the layout logic of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate()
[C#]
public virtual void ResumeUpdate();
[C++]
public: virtual void * ResumeUpdate();
[JScript]
public function ResumeUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


ResumeUpdate Method

CommonControlBase.ResumeUpdate (Boolean) Method

Resumes the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub ResumeUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void ResumeUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * ResumeUpdate(
   bool includeDrawing
);
[JScript]
public function ResumeUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate Method

CommonControlBase.SuspendUpdate Method

Temporarily suspends the update of the control layout.

Overload List

Suspends only the layout logic of the control.

[Visual Basic] Overridable Public Sub SuspendUpdate()
[C#] public virtual SuspendUpdate();
[C++] public: virtual SuspendUpdate();
[JScript] public function SuspendUpdate();

Suspends the layout logic and optionally the painting of the control .

[Visual Basic] Overridable Public Sub SuspendUpdate(Boolean)
[C#] public virtual SuspendUpdate(bool);
[C++] public: virtual SuspendUpdate(bool);
[JScript] public function SuspendUpdate(Boolean);

See Also

SuspendUpdate Class | SuspendUpdate Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate () Method

CommonControlBase.SuspendUpdate () Method

Temporarily suspends only the layout logic of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate()
[C#]
public virtual void SuspendUpdate();
[C++]
public: virtual void * SuspendUpdate();
[JScript]
public function SuspendUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


SuspendUpdate Method

CommonControlBase.SuspendUpdate (Boolean) Method

Temporarily suspends the layout logic and optionally the painting of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate( _
   ByVal includeDrawing As Boolean)
[C#]
public virtual void SuspendUpdate(
   bool includeDrawing
);
[C++]
public: virtual void * SuspendUpdate(
   bool includeDrawing
);
[JScript]
public function SuspendUpdate(
   includeDrawing : Boolean
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

CommonControlBase.UpdateLayout () Method

Update layout logic of the control.

[Visual Basic]
Public Overridable Sub UpdateLayout()
[C#]
public virtual void UpdateLayout();
[C++]
 public: virtual void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommonControlBase Class | CommonControlBase Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Class

Represents a date time picker control.

For a list of all members of this type, see DateTimePicker Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.DateTimePicker

[Visual Basic]
 Public Class DateTimePicker
   Inherits Control
[C#]
public class DateTimePicker : Control
[C++]
 public __gc class DateTimePicker : public Control
[JScript]
public class DateTimePicker extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Members

DateTimePicker overview

Public Constructors

public constructor DateTimePicker Constructor Initializes a new instance of the DateTimePicker class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property CustomFormat | A custom string used to format the date displayed in the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DropDownCalendar | Gets the drop down calendar control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Format | Determines how date is displayed.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets current date/time value.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Constructor ()

Initializes a new instance of the DateTimePicker class.

[Visual Basic]
Public Sub New()
[C#]
public DateTimePicker();
[C++]
public: DateTimePicker();
[JScript]
public function DateTimePicker();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Properties

The properties of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property ButtonImageList (inherited from DropDownControl) | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons (inherited from DropDownControl) | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace (inherited from DropDownControl) | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle (inherited from DropDownControl) | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle (inherited from DropDownControl) | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect (inherited from DropDownControl) | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property CustomFormat | A custom string used to format the date displayed in the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DropDownCalendar | Gets the drop down calendar control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded (inherited from DropDownControl) | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Format | Determines how date is displayed.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect (inherited from DropDownControl) | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle (inherited from DropDownControl) | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton (inherited from DropDownControl) | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from DropDownControl) | Overridden. See Control.Text.
public property TextRect (inherited from DropDownControl) | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets current date/time value.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


CustomFormat Property

DateTimePicker.CustomFormat Property

A custom string used to format the date displayed in the control.

[Visual Basic]
Public Overridable Property CustomFormat As String
[C#]
public virtual String CustomFormat {get; set;}
[C++]
public: __property virtual String* get_CustomFormat();
public: __property virtual void set_CustomFormat(String*);
[JScript]
public function get CustomFormat() : String;
public function set CustomFormat(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DropDownCalendar Property

DateTimePicker.DropDownCalendar Property

Gets the drop down control.

[Visual Basic]
Public ReadOnly Property DropDownCalendar As MonthCalendar
[C#]
public MonthCalendar DropDownCalendar {get;}
[C++]
public: __property MonthCalendar* get_DropDownCalendar();
[JScript]
public function get DropDownCalendar() : MonthCalendar;

Property Value

A MonthCalendar that represents the drop down control assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


Format Property

DateTimePicker.Format Property

Determines how date is displayed.

[Visual Basic]
Public Overrides Overloads Property Format As DateTimePickerFormat
[C#]
public override DateTimePickerFormat Format {get; set;}
[C++]
public: override __property DateTimePickerFormat get_Format();
public: override __property void set_Format(DateTimePickerFormat);
[JScript]
public function get Format() : DateTimePickerFormat;
public function set Format(DateTimePickerFormat);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

DateTimePicker.Value Property

Gets or sets current date/time value.

[Visual Basic]
Public Overrides Overloads Property Value As DateTime
[C#]
public override DateTime Value {get; set;}
[C++]
public: override __property DateTime get_Value();
public: override __property void set_Value(DateTime);
[JScript]
public function get Value() : DateTime;
public function set Value(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Methods

The methods of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt (inherited from DropDownControl) | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState (inherited from DropDownControl) | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle (inherited from DropDownControl) | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle (inherited from DropDownControl) | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle (inherited from DropDownControl) | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded (inherited from DropDownControl) | Raises the ButtonAdded event.
protected method OnButtonAdding (inherited from DropDownControl) | Raises the ButtonAdding event.
protected method OnButtonClicked (inherited from DropDownControl) | Raises the ButtonClicked event.
protected method OnButtonClicking (inherited from DropDownControl) | Raises the ButtonClicking event.
protected method OnButtonRemoved (inherited from DropDownControl) | Raises the ButtonRemoved event.
protected method OnButtonRemoving (inherited from DropDownControl) | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed (inherited from DropDownControl) | Raises the DropDownClosed event.
protected method OnDropDownClosing (inherited from DropDownControl) | Raises the DropDownClosing event.
protected method OnDropDownOpened (inherited from DropDownControl) | Raises the DropDownOpened event.
protected method OnDropDownOpening (inherited from DropDownControl) | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

DateTimePicker.Dispose Method

Releases all resources used by this DateTimePicker object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

DateTimePicker.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanging Method

DateTimePicker.OnValueChanging Method

Raises the ValueChanging event.

[Visual Basic]
Protected Overridable Sub OnValueChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnValueChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnValueChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnValueChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

DateTimePicker.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DateTimePicker Events

The events of the DateTimePicker class are listed here. For a complete list of DateTimePicker class members, see the DateTimePicker Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded (inherited from DropDownControl) | Occurs after a command button is added.
public event ButtonAdding (inherited from DropDownControl) | Occurs before a command button is added.
public event ButtonClicked (inherited from DropDownControl) | Occurs after a command button is clicked.
public event ButtonClicking (inherited from DropDownControl) | Occurs before a command button is clicked.
public event ButtonRemoved (inherited from DropDownControl) | Occurs after a command button is removed.
public event ButtonRemoving (inherited from DropDownControl) | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed (inherited from DropDownControl) | Occurs after a drop down window is closed.
public event DropDownClosing (inherited from DropDownControl) | Occurs before a drop down window is closed.
public event DropDownOpened (inherited from DropDownControl) | Occurs after a drop down window is opened.
public event DropDownOpening (inherited from DropDownControl) | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DateTimePicker Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

DateTimePicker.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


ValueChanging Event

DateTimePicker.ValueChanging Event

Occurs before the Value property changes.

[Visual Basic]
Public Event ValueChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ValueChanging;
[C++]
public: __event ObjectCancelEventHandler* ValueChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DateTimePicker Class | DateTimePicker Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Class

Represents a common implementation of members for drop down controls.

For a list of all members of this type, see DropDownControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.DropDownControl
LidorSystems.IntegralUI.Controls.ComboBox
LidorSystems.IntegralUI.Controls.DateTimePicker

[Visual Basic]
MustInherit Public Class DropDownControl
   Inherits Control
[C#]
public abstract class DropDownControl : Control
[C++]
public __gc __abstract class DropDownControl : public Control
[JScript]
public abstract class DropDownControl extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Members

DropDownControl overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonImageList | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded | Raises the ButtonAdded event.
protected method OnButtonAdding | Raises the ButtonAdding event.
protected method OnButtonClicked | Raises the ButtonClicked event.
protected method OnButtonClicking | Raises the ButtonClicking event.
protected method OnButtonRemoved | Raises the ButtonRemoved event.
protected method OnButtonRemoving | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed | Raises the DropDownClosed event.
protected method OnDropDownClosing | Raises the DropDownClosing event.
protected method OnDropDownOpened | Raises the DropDownOpened event.
protected method OnDropDownOpening | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Properties

The properties of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonImageList | Gets or sets the ImageList that contains the Image objects used by command buttons.
public property Buttons | Gets the collection of buttons displayed in the button strip.
public property ButtonStripSpace | Gets the bounds of the space reserved for buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentRect | Gets the bounds of the space reserved for control content.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Expanded | Determines whether the drop down window is expanded or not.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImageRect | Gets the space reserved for control image.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property ShowDropDownButton | Determines whether the drop down button is visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


ButtonFormatStyle Property

DropDownControl.ButtonFormatStyle Property

Gets or sets the format style of command buttons.

[Visual Basic]
Public Property ButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle ButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_ButtonFormatStyle();
public: __property void set_ButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get ButtonFormatStyle() : CommandButtonFormatStyle;
public function set ButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonImageList Property

DropDownControl.ButtonImageList Property

Gets or sets the ImageList that contains the Image objects used by command buttons.

[Visual Basic]
Public Property ButtonImageList As ImageList
[C#]
public ImageList ButtonImageList {get; set;}
[C++]
public: __property ImageList* get_ButtonImageList();
public: __property void set_ButtonImageList(ImageList*);
[JScript]
public function get ButtonImageList() : ImageList;
public function set ButtonImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


Buttons Property

DropDownControl.Buttons Property

Gets the collection of buttons displayed in the button strip.

[Visual Basic]
Public ReadOnly Property Buttons As CommandButtonCollection
[C#]
public CommandButtonCollection Buttons {get;}
[C++]
public: __property CommandButtonCollection* get_Buttons();
[JScript]
public function get Buttons() : CommandButtonCollection;

Property Value

A CommandButtonCollection that represents the command buttons assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripSpace Property

DropDownControl.ButtonStripSpace Property

Gets the bounds of the space reserved for buttons.

[Visual Basic]
Public ReadOnly Property ButtonStripSpace As Rectangle
[C#]
public Rectangle ButtonStripSpace {get;}
[C++]
public: __property Rectangle get_ButtonStripSpace();
[JScript]
public function get ButtonStripSpace() : Rectangle;

Property Value

The Rectangle that represents the space reserved for buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripStyle Property

DropDownControl.ButtonStripStyle Property

Gets or sets the drawing style of control button strip.

[Visual Basic]
Public Property ButtonStripStyle As ControlStripStyle
[C#]
public ControlStripStyle ButtonStripStyle {get; set;}
[C++]
public: __property ControlStripStyle get_ButtonStripStyle();
public: __property void set_ButtonStripStyle(ControlStripStyle);
[JScript]
public function get ButtonStripStyle() : ControlStripStyle;
public function set ButtonStripStyle(ControlStripStyle);

Property Value

The ControlStripStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ContentRect Property

DropDownControl.ContentRect Property

Gets the bounds of the space reserved for control content.

[Visual Basic]
Public ReadOnly Property ContentRect As Rectangle
[C#]
public Rectangle ContentRect {get;}
[C++]
public: __property Rectangle get_ContentRect();
[JScript]
public function get ContentRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DisabledButtonStyle Property

DropDownControl.DisabledButtonStyle Property

Gets or sets the drawing style of command buttons in disabled state.

[Visual Basic]
Public Property DisabledButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledButtonStyle();
public: __property void set_DisabledButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledButtonStyle() : CommandButtonColorStyle;
public function set DisabledButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


Expanded Property

DropDownControl.Expanded Property

Determines whether the drop down window is expanded or not.

[Visual Basic]
Public Overridable Property Expanded As Boolean
[C#]
public virtual bool Expanded { get; set; }
[C++]
public: __property virtual bool get_Expanded();
 public:
__property virtual void set_Expanded(bool );
[JScript]
public function get Expanded() : bool
public function set Expanded(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverButtonStyle Property

DropDownControl.HoverButtonStyle Property

Gets or sets the drawing style of command buttons in hover state.

[Visual Basic]
Public Property HoverButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverButtonStyle();
public: __property void set_HoverButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverButtonStyle() : CommandButtonColorStyle;
public function set HoverButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageRect Property

DropDownControl.ImageRect Property

Gets the space reserved for control image.

[Visual Basic]
Public ReadOnly Property ImageRect As Rectangle
[C#]
public Rectangle ImageRect {get;}
[C++]
public: __property Rectangle get_ImageRect();
[JScript]
public function get ImageRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


NormalButtonStyle Property

DropDownControl.NormalButtonStyle Property

Gets or sets the drawing style of command buttons in normal state.

[Visual Basic]
Public Property NormalButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalButtonStyle();
public: __property void set_NormalButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalButtonStyle() : CommandButtonColorStyle;
public function set NormalButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedButtonStyle Property

DropDownControl.SelectedButtonStyle Property

Gets or sets the drawing style of command buttons in selected state.

[Visual Basic]
Public Property SelectedButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedButtonStyle();
public: __property void set_SelectedButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedButtonStyle() : CommandButtonColorStyle;
public function set SelectedButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowDropDownButton Property

DropDownControl.ShowDropDownButton Property

Determines whether the drop down button is visible.

[Visual Basic]
Public Overridable Property ShowDropDownButton As Boolean
[C#]
public virtual bool ShowDropDownButton { get; set; }
[C++]
public: __property virtual bool get_ShowDropDownButton();
 public:
__property virtual void set_ShowDropDownButton(bool );
[JScript]
public function get ShowDropDownButton() : bool
public function set ShowDropDownButton(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

DropDownControl.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Methods

The methods of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCmdButtonAt | Retrieves the command button located at the specified coordinates.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in drop down control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in drop down control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in drop down control.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnButtonAdded | Raises the ButtonAdded event.
protected method OnButtonAdding | Raises the ButtonAdding event.
protected method OnButtonClicked | Raises the ButtonClicked event.
protected method OnButtonClicking | Raises the ButtonClicking event.
protected method OnButtonRemoved | Raises the ButtonRemoved event.
protected method OnButtonRemoving | Raises the ButtonRemoving event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnDropDownClosed | Raises the DropDownClosed event.
protected method OnDropDownClosing | Raises the DropDownClosing event.
protected method OnDropDownOpened | Raises the DropDownOpened event.
protected method OnDropDownOpening | Raises the DropDownOpening event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

DropDownControl.Dispose Method

Releases all resources used by this DropDownControl object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonAt (Point) Method

DropDownControl.GetCmdButtonAt (Point) Method

Retrieves the command button located at the specified coordinates.

[Visual Basic]
Overloads Public Function GetCmdButtonAt( _
   ByVal pos As Point _
) As CommandButton
[C#]
public CommandButton GetCmdButtonAt(
   Point pos
);
[C++]
public: CommandButton* GetCmdButtonAt(
   Point pos
);
[JScript]
public function GetCmdButtonAt(
   pos : Point
) : CommandButton;

Parameters

pos
The Point to evaluate and retrieve the command button from.

Return Value

The CommandButton at the specified point, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonState (CommandButton) Method

DropDownControl.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonColorStyle Method

DropDownControl.GetCurrentButtonColorStyle Method

Returns the current drawing style of buttons in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonColorStyle() As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle GetCurrentButtonColorStyle();
[C++]
public: CommandButtonColorStyle* GetCurrentButtonColorStyle();
[JScript]
public function GetCurrentButtonColorStyle() : CommandButtonColorStyle;

Return Value

The style that represents the current drawing style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonFormatStyle Method

DropDownControl.GetCurrentButtonFormatStyle Method

Returns the current format style of buttons in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonFormatStyle() As CommandButtonFormatStylee
[C#]
public CommandButtonFormatStyle GetCurrentButtonFormatStyle();
[C++]
public: CommandButtonFormatStylee* GetCurrentButtonFormatStyle();
[JScript]
public function GetCurrentButtonFormatStyle() : CommandButtonFormatStylee;

Return Value

The style that represents the current format style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonStripStyle Method

DropDownControl.GetCurrentButtonStripStyle Method

Returns the current drawing style of the button strip in drop down control.

[Visual Basic]
Overloads Public Function GetCurrentButtonStripStyle() As ControlStripStyle
[C#]
public ControlStripStyle GetCurrentButtonStripStyle();
[C++]
public: ControlStripStyle* GetCurrentButtonStripStyle();
[JScript]
public function GetCurrentButtonStripStyle() : ControlStripStyle;

Return Value

The style that represents the current drawing style of the the button strip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

DropDownControl.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonAdded Method

DropDownControl.OnButtonAdded Method

Raises the ButtonAdded event.

[Visual Basic]
Protected Overridable Sub OnButtonAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnButtonAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnButtonAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnButtonAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonAdding Method

DropDownControl.OnButtonAdding Method

Raises the ButtonAdding event.

[Visual Basic]
Protected Overridable Sub OnButtonAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonClicked Method

DropDownControl.OnButtonClicked Method

Raises the ButtonClicked event.

[Visual Basic]
Protected Overridable Sub OnButtonClicked( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnButtonClicked(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnButtonClicked(
   ObjectEventArgs* e
);
[JScript]
protected function OnButtonClicked(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonClicking Method

DropDownControl.OnButtonClicking Method

Raises the ButtonClicking event.

[Visual Basic]
Protected Overridable Sub OnButtonClicking( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonClicking(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonClicking(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonClicking(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoved Method

DropDownControl.ButtonRemoved Method

Raises the ButtonRemoved event.

[Visual Basic]
Protected Overridable Sub ButtonRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void ButtonRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void ButtonRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function ButtonRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnButtonRemoving Method

DropDownControl.OnButtonRemoving Method

Raises the ButtonRemoving event.

[Visual Basic]
Protected Overridable Sub OnButtonRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnButtonRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnButtonRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnButtonRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownClosed Method

DropDownControl.OnDropDownClosed Method

Raises the DropDownClosed event.

[Visual Basic]
Protected Overridable Sub OnDropDownClosed( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnDropDownClosed(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnDropDownClosed(
   ObjectEventArgs* e
);
[JScript]
protected function OnDropDownClosed(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownClosing Method

DropDownControl.OnDropDownClosing Method

Raises the DropDownClosing event.

[Visual Basic]
Protected Overridable Sub OnDropDownClosing( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnDropDownClosing(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnDropDownClosing(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnDropDownClosing(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownOpened Method

DropDownControl.OnDropDownOpened Method

Raises the DropDownOpened event.

[Visual Basic]
Protected Overridable Sub OnDropDownOpened( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnDropDownOpened(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnDropDownOpened(
   ObjectEventArgs* e
);
[JScript]
protected function OnDropDownOpened(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


OnDropDownOpening Method

DropDownControl.OnDropDownOpening Method

Raises the DropDownOpening event.

[Visual Basic]
Protected Overridable Sub OnDropDownOpening( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnDropDownOpening(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnDropDownOpening(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnDropDownOpening(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownControl Events

The events of the DropDownControl class are listed here. For a complete list of DropDownControl class members, see the DropDownControl Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event ButtonAdded | Occurs after a command button is added.
public event ButtonAdding | Occurs before a command button is added.
public event ButtonClicked | Occurs after a command button is clicked.
public event ButtonClicking | Occurs before a command button is clicked.
public event ButtonRemoved | Occurs after a command button is removed.
public event ButtonRemoving | Occurs before a command button is removed.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event DropDownClosed | Occurs after a drop down window is closed.
public event DropDownClosing | Occurs before a drop down window is closed.
public event DropDownOpened | Occurs after a drop down window is opened.
public event DropDownOpening | Occurs before a drop down window is opened.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DropDownControl Class | LidorSystems.IntegralUI.Controls Namespace


ButtonAdded Event

DropDownControl.ButtonAdded Event

Occurs after a command button is added.

[Visual Basic]
Public Event ButtonAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ButtonAdded;
[C++]
public: __event ObjectEventHandler* ButtonAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonAdding Event

DropDownControl.ButtonAdding Event

Occurs before a command button is added.

[Visual Basic]
Public Event ButtonAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ButtonAdding;
[C++]
public: __event ObjectCancelEventHandler* ButtonAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonClicked Event

DropDownControl.ButtonClicked Event

Occurs after a command button is clicked.

[Visual Basic]
Public Event ButtonClicked As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler ButtonClicked;
[C++]
public: __event ObjectClickEventHandler* ButtonClicked;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonClicking Event

DropDownControl.ButtonClicking Event

Occurs before a command button is clicked.

[Visual Basic]
Public Event ButtonClicking As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler ButtonClicking;
[C++]
public: __event ObjectCancelClickEventHandler* ButtonClicking;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoved Event

DropDownControl.ButtonRemoved Event

Occurs after a command button is removed.

[Visual Basic]
Public Event ButtonRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ButtonRemoved;
[C++]
public: __event ObjectEventHandler* ButtonRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ButtonRemoving Event

DropDownControl.ButtonRemoving Event

Occurs before a command button is removed.

[Visual Basic]
Public Event ButtonRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ButtonRemoving;
[C++]
public: __event ObjectCancelEventHandler* ButtonRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownClosed Event

DropDownControl.DropDownClosed Event

Occurs after a drop down window is closed.

[Visual Basic]
Public Event DropDownClosed As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler DropDownClosed;
[C++]
public: __event ObjectClickEventHandler* DropDownClosed;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownClosing Event

DropDownControl.DropDownClosing Event

Occurs before a drop down window is closed.

[Visual Basic]
Public Event DropDownClosing As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler DropDownClosing;
[C++]
public: __event ObjectCancelClickEventHandler* DropDownClosing;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownOpened Event

DropDownControl.DropDownOpened Event

Occurs after a drop down window is opened.

[Visual Basic]
Public Event DropDownOpened As ObjectClickEventHandler
[C#]
public event ObjectClickEventHandler DropDownOpened;
[C++]
public: __event ObjectClickEventHandler* DropDownOpened;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectClickEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


DropDownOpening Event

DropDownControl.DropDownOpening Event

Occurs before a drop down window is opened.

[Visual Basic]
Public Event DropDownOpening As ObjectCancelClickEventHandler
[C#]
public event ObjectCancelClickEventHandler DropDownOpening;
[C++]
public: __event ObjectCancelClickEventHandler* DropDownOpening;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelClickEventArgs containing data related to this event. The following ObjectCancelClickEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

DropDownControl Class | DropDownControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Class

Displays a collection of ListControlItems.

For a list of all members of this type, see ListControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.ListControl

[Visual Basic]
 Public Class ListControl
   Inherits LidorSystems.IntegralUI.Controls.ListBase
[C#]
public class ListControl : LidorSystems.IntegralUI.Controls.ListBase
[C++]
 public __gc __class ListControl : public LidorSystems.IntegralUI.Controls.ListBase
[JScript]
public class ListControl extends LidorSystems.IntegralUI.Controls.ListBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls.ListControl (in LidorSystems.IntegralUI.Controls.ListControl.dll)

See Also

ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Members

ListControl overview

Public Constructors

public constructor ListControl Constructor Initializes a new instance of the ListControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property SelectionMode | Overridden. Gets or sets the method in which items are selected in the list control control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopItem | Gets the first fully-visible item in the list control control.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of items that can be fully visible in the list control control.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EnsureVisible | Ensures that the specified item is visible, scrolling the list control control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
protected method FindItem | Finds the first item that begins with the given text value.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Overridden. Sorts the items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the ListControlItem is added.
public event ItemAdding | OOccurs before the ListControlItem is added.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the ListControlItem is removed.
public event ItemRemoving | Occurs before the ListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


ListControl Constructor ()

Initializes a new instance of the ListControl class.

[Visual Basic]
Public Sub New()
[C#]
public ListControl();
[C++]
public: ListControl();
[JScript]
public function ListControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


ListControl Properties

The properties of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property SelectionMode | Overridden. Gets or sets the method in which items are selected in the list control control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopItem | Gets the first fully-visible item in the list control control.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of items that can be fully visible in the list control control.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


AllowDrag Property

ListControl.AllowDrag Property

Determines whether the objects from ListControl control can be dragged.

[Visual Basic]
Public Property AllowDrag As Boolean
[C#]
public bool AllowDrag { get; set; }
[C++]
public: __property bool get_AllowDrag();
public: __property void set_AllowDrag(bool );
[JScript]
public function get AllowDrag() : bool
public function set AllowDrag(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ComparerObjectType Property

ListControl.ComparerObjectType Property

Gets or sets the type of objects in IComparer derived class.

[Visual Basic]
Public Property ComparerObjectType As ComparerObjectType
[C#]
public ComparerObjectType ComparerObjectType {get; set;}
[C++]
public: __property ComparerObjectType get_ComparerObjectType();
public: __property void set_ComparerObjectType(ComparerObjectType);
[JScript]
public function get ComparerObjectType() : ComparerObjectType;
public function set ComparerObjectType(ComparerObjectType);

Property Value

The ComparerObjectType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


DisabledItemStyle Property

ListControl.DisabledItemStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledItemStyle();
public: __property void set_DisabledItemStyle(ListItemColorStyle);
[JScript]
public function get DisabledItemStyle() : ListItemColorStyle;
public function set DisabledItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


DragDropMode Property

ListControl.DragDropMode Property

Gets or sets the type of drag-and-drop operation.

[Visual Basic]
Public Property DragDropMode As DragDropMode
[C#]
public DragDropMode DragDropMode {get; set;}
[C++]
public: __property DragDropMode get_DragDropMode();
public: __property void set_DragDropMode(DragDropMode);
[JScript]
public function get DragDropMode() : DragDropMode;
public function set DragDropMode(DragDropMode);

Property Value

The DragDropMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingEffect Property

ListControl.FadingEffect Property

Gets or sets an enumeration that determines the fading effect used during hovering over objects.

[Visual Basic]
Public Property FadingEffect As FadingEffect
[C#]
public FadingEffect FadingEffect {get; set;}
[C++]
public: __property FadingEffect get_FadingEffect();
public: __property void set_FadingEffect(FadingEffect);
[JScript]
public function get FadingEffect() : FadingEffect;
public function set FadingEffect(FadingEffect);

Property Value

The FadingEffect assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingSpeed Property

ListControl.FadingSpeed Property

Gets or sets an enumeration that determines the speed of fading used during hovering over objects.

[Visual Basic]
Public Property FadingSpeed As FadingSpeed
[C#]
public FadingSpeed FadingSpeed {get; set;}
[C++]
public: __property FadingSpeed get_FadingSpeed();
public: __property void set_FadingSpeed(FadingSpeed);
[JScript]
public function get FadingSpeed() : FadingSpeed;
public function set FadingSpeed(FadingSpeed);

Property Value

The FadingSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HideSelection Property

ListControl.HideSelection Property

Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection { get; set; }
[C++]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(bool );
[JScript]
public function get HideSelection() : bool
public function set HideSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverItemStyle Property

ListControl.HoverItemStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverItemStyle();
public: __property void set_HoverItemStyle(ListItemColorStyle);
[JScript]
public function get HoverItemStyle() : ListItemColorStyle;
public function set HoverItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverSelection Property

ListControl.HoverSelection Property

Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.

[Visual Basic]
Public Property HoverSelection As Boolean
[C#]
public bool HoverSelection { get; set; }
[C++]
public: __property bool get_HoverSelection();
public: __property void set_HoverSelection(bool );
[JScript]
public function get HoverSelection() : bool
public function set HoverSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

ListControl.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageList Property

ListControl.ImageList Property

Gets or sets the ImageList that contains the Image objects used by the ListControlItems.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemFormatStyle Property

ListControl.ItemFormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property ItemFormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle ItemFormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_ItemFormatStyle();
public: __property void set_ItemFormatStyle(ListItemFormatStyle);
[JScript]
public function get ItemFormatStyle() : ListItemFormatStyle;
public function set ItemFormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemHighlightType Property

ListControl.ItemHighlightType Property

Gets or sets the value indicating how the item is drawn.

[Visual Basic]
Public Property ItemHighlightType As ListItemHighlightType
[C#]
public ListItemHighlightType ItemHighlightType {get; set;}
[C++]
public: __property ListItemHighlightType get_ItemHighlightType();
public: __property void set_ItemHighlightType(ListItemHighlightType);
[JScript]
public function get ItemHighlightType() : ListItemHighlightType;
public function set ItemHighlightType(ListItemHighlightType);

Property Value

The ListItemHighlightType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemSpacing Property

ListControl.ItemSpacing Property

Gets or sets the vertical spacing between items.

[Visual Basic]
Public Property ItemSpacing As Integer
[C#]
public int ItemSpacing {get; set;}
[C++]
public: __property int get_ItemSpacing();
public: __property void set_ItemSpacing(int);
[JScript]
public function get ItemSpacing() : int;
public function set ItemSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Items Property

ListControl.Items Property

Gets the collection of items that are assigned to the list box control.

[Visual Basic]
Public ReadOnly Property Items As ListControlItemCollection
[C#]
public ListControlItemCollection Items {get;}
[C++]
public: __property ListControlItemCollection* get_Items();
[JScript]
public function get Items() : ListControlItemCollection;

Property Value

A ListControlItemCollection that represents the items assigned to the list box control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


KeySearchMode Property

ListControl.KeySearchMode Property

Specifies the search method for an item when key is pressed.

[Visual Basic]
Public Property KeySearchMode As KeySearchMode
[C#]
public KeySearchMode KeySearchMode {get; set;}
[C++]
public: __property KeySearchMode get_KeySearchMode();
public: __property void set_KeySearchMode(KeySearchMode);
[JScript]
public function get KeySearchMode() : KeySearchMode;
public function set KeySearchMode(KeySearchMode);

Property Value

The KeySearchMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListItemSorter Property

ListControl.ListItemSorter Property

Gets or sets the IComparer class used to sort the items in list control.

[Visual Basic]
Public Property ListItemSorter As IComparer
[C#]
public IComparer ListItemSorter {get; set;}
[C++]
public: __property IComparer get_ListItemSorter();
public: __property void set_ListItemSorter(IComparer);
[JScript]
public function get ListItemSorter() : IComparer;
public function set ListItemSorter(IComparer);

Property Value

The IComparer assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


NormalItemStyle Property

ListControl.NormalItemStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalItemStyle();
public: __property void set_NormalItemStyle(ListItemColorStyle);
[JScript]
public function get NormalItemStyle() : ListItemColorStyle;
public function set NormalItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Scrollable Property

ListControl.Scrollable Property

Gets or sets a value indicating whether the list control displays scroll bars when they are needed.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}
[C++]
public: __property bool get_Scrollable();
public: __property void set_Scrollable(bool);
[JScript]
public function get Scrollable() : Boolean;
public function set Scrollable(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollBarStyle Property

ListControl.ScrollBarStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ScrollBarStyle As ScrollBarStyle
[C#]
public ScrollBarStyle ScrollBarStyle {get; set;}
[C++]
public: __property ScrollBarStyle get_ScrollBarStyle();
public: __property void set_ScrollBarStyle(ScrollBarStyle);
[JScript]
public function get ScrollBarStyle() : ScrollBarStyle;
public function set ScrollBarStyle(ScrollBarStyle);

Property Value

The ScrollBarStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItem Property

ListControl.SelectedItem Property

Gets or sets the item that is currently selected in the list control.

[Visual Basic]
Public Property SelectedItem As ListControlItem
[C#]
public ListControlItem SelectedItem {get; set;}
[C++]
public: __property ListControlItem* get_SelectedItem();
public: __property void set_SelectedItem(ListControlItem*);
[JScript]
public function get SelectedItem() : ListControlItem;
public function set SelectedItem(ListControlItem);

Property Value

The ListControlItem that is currently selected in the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItemStyle Property

ListControl.SelectedItemStyle Property

Gets or sets the drawing style of selected item.

[Visual Basic]
Public Property SelectedItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedItemStyle();
public: __property void set_SelectedItemStyle(ListItemColorStyle);
[JScript]
public function get SelectedItemStyle() : ListItemColorStyle;
public function set SelectedItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowDropMarker Property

ListControl.ShowDropMarker Property

Gets or sets a value indicating whether a marker is shown during drag&drop operation.

[Visual Basic]
 Public Property ShowDropMarker As Boolean
[C#]
 public bool ShowDropMarker { get; set; }
[C++]
 public: __property bool
 get_ShowDropMarker();
public: __property void set_ShowDropMarker(bool );
[JScript]
public function get ShowDropMarker() : bool
public function set ShowDropMarker(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowToolTips Property

ListControl.ShowToolTips Property

Gets or sets a value indicating whether item tooltip is shown.

[Visual Basic]
Public Property ShowToolTips As Boolean
[C#]
public bool ShowToolTips { get; set; }
[C++]
public: __property bool get_ShowToolTips();
public: __property void set_ShowToolTips(bool );
[JScript]
public function get ShowToolTips() : bool
public function set ShowToolTips(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Sorting Property

ListControl.Sorting Property

Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.

[Visual Basic]
Public Property Sorting As SortOrder
[C#]
public SortOrder Sorting {get; set;}
[C++]
public: __property SortOrder get_Sorting();
public: __property void set_Sorting(SortOrder);
[JScript]
public function get Sorting() : SortOrder;
public function set Sorting(SortOrder);

Property Value

The SortOrder assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ToolTipStyle Property

ListControl.ToolTipStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ToolTipStyle As ToolTipStyle
[C#]
public ToolTipStyle ToolTipStyle {get; set;}
[C++]
public: __property ToolTipStyle get_ToolTipStyle();
public: __property void set_ToolTipStyle(ToolTipStyle);
[JScript]
public function get ToolTipStyle() : ToolTipStyle;
public function set ToolTipStyle(ToolTipStyle);

Property Value

The ToolTipStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


TopItem Property

ListControl.TopItem Property

Gets the first fully-visible item in the list control.

[Visual Basic]
Public ReadOnly Property TopItem As ListControlItem
[C#]
public ListControlItem TopItem {get;}
[C++]
public: __property ListControlItem* get_TopItem();
[JScript]
public function get TopItem() : ListControlItem;

Property Value

A ListControlItem that represents the first fully-visible item in the list box control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


VisibleCount Property

ListControl.VisibleCount Property

Gets the number of items that can be fully visible in the list control.

[Visual Basic]
Public ReadOnly Property VisibleCount As Integer
[C#]
public int VisibleCount {get;}
[C++]
public: __property int get_VisibleCount();
[JScript]
public function get VisibleCount() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


WatermarkImage Property

ListControl.WatermarkImage Property

Specifies the WatermarkImage object to use as a watermark.

[Visual Basic]
Public Property WatermarkImage As WatermarkImage
[C#]
public WatermarkImage WatermarkImage { get; set; }
[C++]
public: __property WatermarkImage* get_WatermarkImage();
public: __property void set_WatermarkImage(WatermarkImage*);
[JScript]
public function get WatermarkImage() : WatermarkImage
public function set WatermarkImage(WatermarkImage);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Methods

The methods of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EnsureVisible | Ensures that the specified item is visible, scrolling the list control control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
protected method FindItem | Finds the first item that begins with the given text value.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Overridden. Sorts the items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

ListControl.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


EnsureVisible Method

ListControl.EnsureVisible Method

Ensures that the specified item is visible, scrolling the list control as necessary.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal index As Integer _
)
[C#]
 public void EnsureVisible(
   int index
);
[C++]
public: void EnsureVisible(
   int index
);
[JScript]
 public function EnsureVisible(
   index : int
);

Parameters

index
The 0-based index of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem Method

ListControl.FindItem Method

Finds the first item that begins with the given text value.

Overload List

Finds the first item that begins with the specified text value.

[Visual Basic] Overloads Public Function FindItem(String) As ListControlItem
[C#] public ListControlItem FindItem(String);
[C++] public: ListControlItem* FindItem(String);
[JScript] public function FindItem(String) : ListControlItem;

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index.

[Visual Basic] Overloads Public Function FindItem(String, Integer) As ListControlItem
[C#] public ListControlItem FindItem(String, int);
[C++] public: ListControlItem* FindItem(String, int);
[JScript]
public function FindItem(String, int) :
    ListControlItem;

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index. The matching criteria can be aplied.

[Visual Basic] Overloads Public Function FindItem(String, Integer, Boolean) As ListControlItem
[C#] public ListControlItem FindItem(String, int, bool);
[C++] public: ListControlItem* FindItem(String, int, bool);
[JScript]
public function FindItem(String, int, Boolean) :
    ListControlItem;

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String) Method

ListControl.FindItem (String) Method

Finds the first item that begins with the specified text value.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As String _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   String text
);
[C++]
public: ListControlItem* FindItem(
   String text
);
[JScript]
public function FindItem(
   text : String
) : ListControlItem;

Parameters

text
The String to search for.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String, Integer) Method

ListControl.FindItem (String, Integer) Method

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As string _
   ByVal startIndex As Integer _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   string text
   int startIndex
);
[C++]
public: ListControlItem* FindItem(
   string text
   int startIndex
);
[JScript]
public function FindItem(
   text : string
   startIndex : int
) : ListControlItem;

Parameters

text
The string to search for.
startIndex
The index of the item at which to start the search.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


FindItem (String, Integer, Boolean) Method

ListControl.FindItem (String, Integer, Boolean) Method

Finds the first item, if indicated, that begins with the specified text value. The search starts at the specified index. The matching criteria can be aplied.

[Visual Basic]
Overloads Public Function FindItem( _
   ByVal text As string _
   ByVal startIndex As Integer _
   ByVal isPrefixSearch As Boolean _
) As ListControlItem
[C#]
public ListControlItem FindItem(
   string text
   int startIndex
   bool isPrefixSearch
);
[C++]
public: ListControlItem* FindItem(
   string text
   int startIndex
   bool isPrefixSearch
);
[JScript]
public function FindItem(
   text : string
   startIndex : int
   isPrefixSearch : Boolean
) : ListControlItem;

Parameters

text
The string to search for.
startIndex
The index of the item at which to start the search.
isPrefixSearch
True to match the search text to the prefix of an item; otherwise False.

Return Value

The ListControlItem object if found, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetClientRect Method

ListControl.GetClientRect Method

Returns the client rectangle of the control.

[Visual Basic]
Overloads Public Function GetClientRect() As Rectangle
[C#]
public Rectangle GetClientRect();
[C++]
public: Rectangle* GetClientRect();
[JScript]
public function GetClientRect() : Rectangle;

Return Value

The rectangle that represents the client area of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetDropPos (ListControlItem, Point) Method

ListControl.GetDropPos (ListControlItem, Point) Method

Returns the position at which item would be inserted in the item collection, during drag&drop operation.

[Visual Basic]
Overloads Public Function GetDropPos( _
   ByVal item As ListControlItem _
   ByVal mousePos As Point _
) As Integer
[C#]
public int GetDropPos(
   ListControlItem item
   Point mousePos
);
[C++]
public: int GetDropPos(
   ListControlItem item
   Point mousePos
);
[JScript]
public function GetDropPos(
   item : ListControlItem
   mousePos : Point
) : int;

Parameters

item
The ListControlItem that is currently targeted.
mousePos
The Point which represents the mouse cursor, in client coordinates.

Return Value

The index at which the dropped item would be inserted in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt Method

ListControl.GetItemAt Method

Retrieves the item that is at the specified location.

Overload List

Retrieves the item that is at the specified point.

[Visual Basic] Overloads Public Function GetItemAt(Point) As ListControlItem
[C#] public ListControlItem GetItemAt(Point);
[C++] public: ListControlItem* GetItemAt(Point);
[JScript] public function GetItemAt(Point) : ListControlItem;

Retrieves the item at the point with the specified coordinates.

[Visual Basic] Overloads Public Function GetItemAt(Integer, Integer) As ListControlItem
[C#] public ListControlItem GetItemAt(int, int);
[C++] public: ListControlItem* GetItemAt(int, int);
[JScript] public function GetItemAt(int, int) : ListControlItem;

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Point) Method

ListControl.GetItemAt (Point) Method

Retrieves the item that is at the specified point.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal pt As Point _
) As ListControlItem
[C#]
public ListControlItem GetItemAt(
   Point pt
);
[C++]
public: ListControlItem* GetItemAt(
   Point pt
);
[JScript]
public function GetItemAt(
   pt : Point
) : ListControlItem;

Parameters

pt
The Point to evaluate and retrieve the item from.

Return Value

The ListControlItem at the specified point, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Int32, Int32) Method

ListControl.GetItemAt (Int32, Int32) Method

Retrieves the item at the point with the specified coordinates.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As ListControlItem
[C#]
public ListControlItem GetItemAt(
   int x,
   int y
);
[C++]
public: ListControlItem* GetItemAt(
   int x,
   int y
);
[JScript]
public function GetItemAt(
   x : int,
   y : int
) : ListControlItem;

Parameters

x
The X position to evaluate and retrieve the item from.
y
The Y position to evaluate and retrieve the item from.

Return Value

The ListControlItem at the specified location, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetScrollPos Method

ListControl.GetScrollPos Method

Retrieves the current position of the horizontal and vertical scrollbar thumb.

[Visual Basic]
Overloads Public Function GetScrollPos() As Point
[C#]
public Point GetScrollPos();
[C++]
public: Point* GetScrollPos();
[JScript]
public function GetScrollPos() : Point;

Return Value

The current position of the horizontal and vertical scrollbar thumb.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnAfterSelect Method

ListControl.OnAfterSelect Method

Raises the AfterSelect event.

[Visual Basic]
Protected Overridable Sub OnAfterSelect( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterSelect(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterSelect(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnBeforeSelect Method

ListControl.OnBeforeSelect Method

Raises the BeforeSelect event.

[Visual Basic]
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeSelect(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeSelect(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeSelect(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdded Method

ListControl.OnItemAdded Method

Raises the ItemAdded event.

[Visual Basic]
Protected Overridable Sub OnItemAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdding Method

ListControl.OnItemAdding Method

Raises the ItemAdding event.

[Visual Basic]
Protected Overridable Sub OnItemAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemDrag Method

ListControl.OnItemDrag Method

Raises the ItemDrag event.

[Visual Basic]
Protected Overridable Sub OnItemDrag( _
   ByVal e As ItemDragEventArgs _
)
[C#]
protected virtual void OnItemDrag(
   ItemDragEventArgs e
);
[C++]
protected: virtual void OnItemDrag(
   ItemDragEventArgs* e
);
[JScript]
protected function OnItemDrag(
   e : ItemDragEventArgs
);

Parameters

e
A ItemDragEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemMouseHover Method

ListControl.OnItemMouseHover Method

Raises the ItemMouseHover event.

[Visual Basic]
Protected Overridable Sub OnItemMouseHover( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemMouseHover(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemMouseHover(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemMouseHover(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoved Method

ListControl.OnItemRemoved Method

Raises the ItemRemoved event.

[Visual Basic]
Protected Overridable Sub OnItemRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoving Method

ListControl.OnItemRemoving Method

Raises the ItemRemoving event.

[Visual Basic]
Protected Overridable Sub OnItemRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnScrollBarVisibilityChanged Method

ListControl.OnScrollBarVisibilityChanged Method

Raises the ScrollBarVisibilityChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollBarVisibilityChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollBarVisibilityChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollBarVisibilityChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollBarVisibilityChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnScrollPosChanged Method

ListControl.OnScrollPosChanged Method

Raises the ScrollPosChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollPosChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollPosChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollPosChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollPosChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


SetScrollPos (Point) Method

ListControl.SetScrollPos (Point) Method

Sets the position of the horizontal and vertical scroll bar thumb.

[Visual Basic]
 Public Sub SetScrollPos( _
   ByVal pt As Point _
)
[C#]
public void SetScrollPos(
   Point pt
);
[C++]
public: void SetScrollPos(
   Point pt
);
[JScript]
public function SetScrollPos(
   pt : Point
);

Parameters

pt
The Point at which the horizontal and vertical scroll bar thumb will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


Sort Method

ListControl.Sort Method

Sorts the items in the list view control.

[Visual Basic]
Public Overloads Overrides Sub Sort()
[C#]
public override void Sort();
[C++]
 public: override void * Sort();
[JScript]
public function Sort() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


StopFadingEffect Method

ListControl.StopFadingEffect Method

Stops the fading of items in the list control.

[Visual Basic]
Public Overridable Sub StopFadingEffect()
[C#]
public virtual void StopFadingEffect();
[C++]
 public: virtual void * StopFadingEffect();
[JScript]
public function StopFadingEffect() ;

Remarks

Use this method to mannualy stop the fading of items in list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

ListControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControl Events

The events of the ListControl class are listed here. For a complete list of ListControl class members, see the ListControl Members topic.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the ListControlItem is added.
public event ItemAdding | OOccurs before the ListControlItem is added.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the ListControlItem is removed.
public event ItemRemoving | Occurs before the ListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ListControl Class | LidorSystems.IntegralUI.Controls Namespace


AfterSelect Event

ListControl.AfterSelect Event

Occurs after the item is selected.

[Visual Basic]
Public Event AfterSelect As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterSelect;
[C++]
public: __event ObjectEventHandler* AfterSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


BeforeSelect Event

ListControl.BeforeSelect Event

Occurs before the item is selected.

[Visual Basic]
Public Event BeforeSelect As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeSelect;
[C++]
public: __event ObjectCancelEventHandler* BeforeSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdded Event

ListControl.ItemAdded Event

Occurs after the ListControlItem is added.

[Visual Basic]
Public Event ItemAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemAdded;
[C++]
public: __event ObjectEventHandler* ItemAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdding Event

ListControl.ItemAdding Event

OOccurs before the ListControlItem is added.

[Visual Basic]
Public Event ItemAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemAdding;
[C++]
public: __event ObjectCancelEventHandler* ItemAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemDrag Event

ListControl.ItemDrag Event

Occurs when the user begins dragging an item.

[Visual Basic]
Public Event ItemDrag As ItemDragEventHandler
[C#]
public event ItemDragEventHandler ItemDrag;
[C++]
public: __event ItemDragEventHandler* ItemDrag;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ItemDragEventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemMouseHover Event

ListControl.ItemMouseHover Event

Occurs when the mouse cursor hovers for some time over an item space.

[Visual Basic]
Public Event ItemMouseHover As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemMouseHover;
[C++]
public: __event ObjectEventHandler* ItemMouseHover;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoved Event

ListControl.ItemRemoved Event

Occurs after the ListControlItem is removed.

[Visual Basic]
Public Event ItemRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemRemoved;
[C++]
public: __event ObjectEventHandler* ItemRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoving Event

ListControl.ItemRemoving Event

Occurs before the ListControlItem is removed.

[Visual Basic]
Public Event ItemRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemRemoving;
[C++]
public: __event ObjectCancelEventHandler* ItemRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollBarVisibilityChanged Event

ListControl.ScrollBarVisibilityChanged Event

Occurs when visibility of horizontal or vertical scrollbar has changed.

[Visual Basic]
Public Event ScrollBarVisibilityChanged As EventHandler
[C#]
public event EventHandler ScrollBarVisibilityChanged;
[C++]
public: __event EventHandler* ScrollBarVisibilityChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ScrollPosChanged Event

ListControl.ScrollPosChanged Event

Occurs when position of scrollbar has changed.

[Visual Basic]
Public Event ScrollPosChanged As EventHandler
[C#]
public event EventHandler ScrollPosChanged;
[C++]
public: __event EventHandler* ScrollPosChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControl Class | ListControl Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Class

A class representing the items in the ListControl control.

For a list of all members of this type, see ListControlItem Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ListControlItem

[Visual Basic]

Public Class ListControlItem
   Inherits LidorSystems.IntegralUI.ObjectBase
[C#]

 public class ListControlItem : LidorSystems.IntegralUI.ObjectBase
[C++]

public __gc class ListControlItem : public LidorSystems.IntegralUI.ObjectBase
[JScript]
public

class ListControlItem extends LidorSystems.IntegralUI.ObjectBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls.ListControl (in LidorSystems.IntegralUI.Controls.ListControl.dll)

See Also

ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Members

ListControlItem overview

Public Constructors

public constructor ListControlItem Constructor Initializes a new instance of the ListControlItem class.

Public Properties

public property Bounds | Overridden. Gets the bounds of the item.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageRect | Gets the rectangle of item's image.
public property Index | Overridden. Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent list box control that the item is assigned to.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State | Overridden. Gets a value indicating the current state of the object.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property TextRect | Gets the rectangle of item's text.
public property TextSize | Gets the size of item's text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EnsureVisible | Ensures that the item is visible, scrolling the list view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Check whether the item is present in the current visible space of the list box control.
public method Move | Moves the item to the specified position in the item collection.
public method Remove | Removes the current item from the item collection.
public method RepaintParent | Overridden. Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Overridden. Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor

Initializes a new instance of the ListControlItem class.

Overload List

Initializes a new instance of the ListControlItem class.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New()
[C#] public ListControlItem();
[C++] public: ListControlItem();
[JScript] public function ListControlItem();

Initializes a new instance of the ListControlItem class with the specified text.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New(String)
[C#] public ListControlItem(string);
[C++] public: ListControlItem(String*);
[JScript] public function ListControlItem(String);

Initializes a new instance of the ListControlItem class with the specified text and image.

[Visual Basic] Public Sub New(String, Integer)
[C#] public ListControlItem(string, int);
[C++] public: ListControlItem(String*, int);
[JScript] public function ListControlItem(String, int);

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Properties

The properties of the ListControlItem class are listed here. For a complete list of ListControlItem class members, see the ListControlItem Members topic.

Public Properties

public property Bounds | Overridden. Gets the bounds of the item.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageRect | Gets the rectangle of item's image.
public property Index | Overridden. Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent list box control that the item is assigned to.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State | Overridden. Gets a value indicating the current state of the object.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property TextRect | Gets the rectangle of item's text.
public property TextSize | Gets the size of item's text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Bounds Property

ListControlItem.Bounds Property

Gets the bounds of the item.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}
[C++]
public: __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


DisabledStyle Property

ListControlItem.DisabledStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledStyle();
public: __property void set_DisabledStyle(ListItemColorStyle);
[JScript]
public function get DisabledStyle() : ListItemColorStyle;
public function set DisabledStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

ListControlItem.FormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property FormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle FormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ListItemFormatStyle);
[JScript]
public function get FormatStyle() : ListItemFormatStyle;
public function set FormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


HoverStyle Property

ListControlItem.HoverStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverStyle();
public: __property void set_HoverStyle(ListItemColorStyle);
[JScript]
public function get HoverStyle() : ListItemColorStyle;
public function set HoverStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ImageRect Property

ListControlItem.ImageRect Property

Gets the rectangle of item's image.

[Visual Basic]
Public ReadOnly Property ImageRect As Rectangle
[C#]
public Rectangle ImageRect {get;}
[C++]
public: __property Rectangle get_ImageRect();
[JScript]
public function get ImageRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for item's image, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


Index Property

ListControlItem.Index Property

Overridden. Gets the position of the item in the item collection.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Property Value

A zero-based index value that represents the position of the item in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


NormalStyle Property

ListControlItem.NormalStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalStyle();
public: __property void set_NormalStyle(ListItemColorStyle);
[JScript]
public function get NormalStyle() : ListItemColorStyle;
public function set NormalStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


Parent Property

ListControlItem.Parent Property

Gets the parent list control that the item is assigned to.

[Visual Basic]
Public ReadOnly Property Parent As ListControl
[C#]
public ListControl Parent {get;}
[C++]
public: __property ListControl* get_Parent();
[JScript]
public function get Parent() : ListControl;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


SelectedStyle Property

ListControlItem.SelectedStyle Property

Gets or sets the drawing style of the selected item.

[Visual Basic]
Public Property SelectedStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedStyle();
public: __property void set_SelectedStyle(ListItemColorStyle);
[JScript]
public function get SelectedStyle() : ListItemColorStyle;
public function set SelectedStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


SortTag Property

ListControlItem.SortTag Property

Gets or sets the object that contains sorting data about the item.

[Visual Basic]
Public Property SortTag As Object
[C#]
public object SortTag {get; set;}
[C++]
public: __property Object* get_SortTag();
public: __property void set_SortTag(Object*);
[JScript]
public function get SortTag() : Object;
public function set SortTag(Object);

Property Value

An Object that contains sorting data about the item. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


State Property

ListControlItem.State Property

Overridden. Gets a value indicating the current state of the item.

[Visual Basic]
Public Overrides Overloads ReadOnly Property State As ObjectState
[C#]
public override ObjectState State {get;}
[C++]
public: override __property ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


StyleFromParent Property

ListControlItem.StyleFromParent Property

Determines whether the item should use style from his parent, to draw.

[Visual Basic]
Public Property StyleFromParent As Boolean
[C#]
public bool StyleFromParent {get; set;}
[C++]
public: __property bool get_StyleFromParent();
public: __property void set_StyleFromParent(bool);
[JScript]
public function get StyleFromParent() : Boolean;
public function set StyleFromParent(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

ListControlItem.TextRect Property

Gets the rectangle of item's text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for item's text, in client coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


TextSize Property

ListControlItem.TextSize Property

Gets the size of item's text.

[Visual Basic]
Public ReadOnly Property TextSize As Size
[C#]
public Size TextSize {get;}
[C++]
public: __property Size get_TextSize();
[JScript]
public function get TextSize() : Size;

Property Value

The Size of the item's text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ToolTip Property

ListControlItem.ToolTip Property

Gets or sets the item's tooltip text.

[Visual Basic]
Public Property ToolTip As String
[C#]
public String ToolTip {get; set;}
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String*);
[JScript]
public function get ToolTip() : String;
public function set ToolTip(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows 7

See Also

ListControlItem Class | ListControlItem Members | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Methods

The methods of the ListControlItem class are listed here. For a complete list of ListControlItem class members, see the ListControlItem Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EnsureVisible | Ensures that the item is visible, scrolling the list view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Check whether the item is present in the current visible space of the list box control.
public method Move | Moves the item to the specified position in the item collection.
public method Remove | Removes the current item from the item collection.
public method RepaintParent | Overridden. Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Overridden. Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

ListBoxItem.Clone Method

Overridden. Creates an exact copy of the current ListBoxItem.

[Visual Basic]
Public Overrides Overloads  Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: override Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ListBoxItem object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

ListBoxItem.EnsureVisible Method

Ensures that the item is visible, scrolling the list view control as necessary.

[Visual Basic]
Public Sub EnsureVisible()
[C#]
public void EnsureVisible();
[C++]
 public: void EnsureVisible();
[JScript]
public function EnsureVisible();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


IsVisible Method

ListBoxItem.IsVisible Method

Check whether the item is present in the current visible space of the list box control.

[Visual Basic]
Public Function IsVisible() As Boolean
[C#]
public bool IsVisible();
[C++]
public: bool IsVisible();
[JScript]
public function IsVisible() : Boolean;

Return Value

True if the item is present, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


Move Method

ListBoxItem.Move Method

Moves the item to the specified position in the item collection.

[Visual Basic]
public  Sub Move( _
   ByVal direction As ListItemMoveDirection _
)
[C#]
public void Move(
   ListItemMoveDirection direction
);
[C++]
public: void Move(
   ListItemMoveDirection* direction
);
[JScript]
public  function Move(
   direction : ListItemMoveDirection
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


Remove Method

ListBoxItem.Remove Method

Removes the current item from the item collection.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();
[C++]
 public: void Remove();
[JScript]
public function Remove();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


RepaintParent Method

ListBoxItem.RepaintParent Method

Invalidates the parent client area to repaint the item's changes.

[Visual Basic]
Public Overrides Overloads Sub RepaintParent()
[C#]
public override void RepaintParent();
[C++]
 public: override void RepaintParent();
[JScript]
public function RepaintParent();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


UpdateParent Method

ListBoxItem.UpdateParent Method

Updates the parent layout with item's changes.

[Visual Basic]
Public Overrides Overloads Sub UpdateParent()
[C#]
public override void UpdateParent();
[C++]
 public: override void UpdateParent();
[JScript]
public function UpdateParent();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBoxItem Class | ListBoxItem Members | LidorSystems.IntegralUI.Lists Namespace


MonthCalendar Class

Represents a control that enables selection of a date using calendar.

For a list of all members of this type, see MonthCalendar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.MonthCalendar

[Visual Basic]
 Public Class MonthCalendar
   Inherits Control
[C#]
public class MonthCalendar : Control
[C++]
 public __gc class MonthCalendar : public Control
[JScript]
public class MonthCalendar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Members

MonthCalendar overview

Public Constructors

public constructor MonthCalendar Constructor Initializes a new instance of the MonthCalendar class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DateFormatStyle | Gets or sets the format style of the current date.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledHeaderButtonStyle | Gets or sets the drawing style of header command buttons in disabled state.
public property DisabledHeaderStyle | Gets or sets the drawing style when control header is disabled.
public property DisplayMode | Determines how date is displayed.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FirstDayOfWeek | Gets or sets the first day of the week.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HeaderButtonFormatStyle | Gets or sets the formatting style of header command buttons.
public property HeaderFormatStyle | Gets or sets the format style of the control header.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverDateStyle | Gets or sets the drawing style of date in hover state.
public property HoverHeaderButtonStyle | Gets or sets the drawing style of header command buttons in hover state.
public property HoverHeaderStyle | Gets or sets the drawing style when control header is hovered.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaxDate | Determines the maximum date that can be set in MonthCalendar control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinDate | Determines the minimum date that can be set in MonthCalendar control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property MonthHeaderStyle | Gets or sets the drawing style of the month header.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalDateStyle | Gets or sets the drawing style of date in normal state.
public property NormalHeaderButtonStyle | Gets or sets the drawing style of header command buttons in normal state.
public property NormalHeaderStyle | Gets or sets the default drawing style of the control header.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedDate | Gets or sets currently selected date.
public property SelectedDateStyle | Gets or sets the drawing style of date in selected state.
public property SelectedHeaderButtonStyle | Gets or sets the drawing style of header command buttons in selected state.
public property SelectedHeaderStyle | Gets or sets the drawing style when control header is selected.
public property ShowTrailingDays | Determines whether the control will display days from previous and next month.
public property ShowWeekNumbers | Determines whether the control will display the week numbers.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Spacing | Gets or sets the spacing between objects.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TodayDate | Gets or sets the current date.
public property TodayDateStyle | Gets or sets the drawing style of the current date.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TrailingDateStyle | Gets or sets the drawing style of the trailing date.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event DateChanged | Occurs when the date selected in the MonthCalendar changes.
public event DateSelected | Occurs when the user makes an explicit date selection using the mouse.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDateChangedMethod | Raises the DateChanged event.
protected method OnDateSelectedMethod | Raises the DateSelected event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Constructor ()

Initializes a new instance of the MonthCalendar class.

[Visual Basic]
Public Sub New()
[C#]
public MonthCalendar();
[C++]
public: MonthCalendar();
[JScript]
public function MonthCalendar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Properties

The properties of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DateFormatStyle | Gets or sets the format style of the current date.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledHeaderButtonStyle | Gets or sets the drawing style of header command buttons in disabled state.
public property DisabledHeaderStyle | Gets or sets the drawing style when control header is disabled.
public property DisplayMode | Determines how date is displayed.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FirstDayOfWeek | Gets or sets the first day of the week.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property HeaderButtonFormatStyle | Gets or sets the formatting style of header command buttons.
public property HeaderFormatStyle | Gets or sets the format style of the control header.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverDateStyle | Gets or sets the drawing style of date in hover state.
public property HoverHeaderButtonStyle | Gets or sets the drawing style of header command buttons in hover state.
public property HoverHeaderStyle | Gets or sets the drawing style when control header is hovered.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaxDate | Determines the maximum date that can be set in MonthCalendar control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinDate | Determines the minimum date that can be set in MonthCalendar control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property MonthHeaderStyle | Gets or sets the drawing style of the month header.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalDateStyle | Gets or sets the drawing style of date in normal state.
public property NormalHeaderButtonStyle | Gets or sets the drawing style of header command buttons in normal state.
public property NormalHeaderStyle | Gets or sets the default drawing style of the control header.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedDate | Gets or sets currently selected date.
public property SelectedDateStyle | Gets or sets the drawing style of date in selected state.
public property SelectedHeaderButtonStyle | Gets or sets the drawing style of header command buttons in selected state.
public property SelectedHeaderStyle | Gets or sets the drawing style when control header is selected.
public property ShowTrailingDays | Determines whether the control will display days from previous and next month.
public property ShowWeekNumbers | Determines whether the control will display the week numbers.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Spacing | Gets or sets the spacing between objects.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TodayDate | Gets or sets the current date.
public property TodayDateStyle | Gets or sets the drawing style of the current date.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TrailingDateStyle | Gets or sets the drawing style of the trailing date.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


DateFormatStyle Property

MonthCalendar.DateFormatStyle Property

Gets or sets the format style of the current date.

[Visual Basic]
Public Property DateFormatStyle As BorderStyle
[C#]
public BorderStyle DateFormatStyle {get; set;}
[C++]
public: __property BorderStyle get_DateFormatStyle();
public: __property void set_DateFormatStyle(BorderStyle);
[JScript]
public function get DateFormatStyle() : BorderStyle;
public function set DateFormatStyle(BorderStyle);

Property Value

The BorderStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisabledHeaderButtonStyle Property

MonthCalendar.DisabledHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in disabled state.

[Visual Basic]
Public Property DisabledHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledHeaderButtonStyle();
public: __property void set_DisabledHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledHeaderButtonStyle() : CommandButtonColorStyle;
public function set DisabledHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisabledHeaderStyle Property

MonthCalendar.DisabledHeaderStyle Property

Gets or sets the drawing style when control header is disabled.

[Visual Basic]
Public Property DisabledHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle DisabledHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_DisabledHeaderStyle();
public: __property void set_DisabledHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get DisabledHeaderStyle() : ControlHeaderColorStyle;
public function set DisabledHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DisplayMode Property

MonthCalendar.DisplayMode Property

Determines how date is displayed.

[Visual Basic]
Public Property DisplayMode As CalendarDisplayMode
[C#]
public CalendarDisplayMode DisplayMode {get; set;}
[C++]
public: __property CalendarDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(CalendarDisplayMode);
[JScript]
public function get DisplayMode() : CalendarDisplayMode;
public function set DisplayMode(CalendarDisplayMode);

Property Value

The CalendarDisplayMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


FirstDayOfWeek Property

MonthCalendar.FirstDayOfWeek Property

Gets or sets the first day of the week.

[Visual Basic]
Public Property FirstDayOfWeek As Day
[C#]
public Day FirstDayOfWeek {get; set;}
[C++]
public: __property Day get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(Day);
[JScript]
public function get FirstDayOfWeek() : Day;
public function set FirstDayOfWeek(Day);

Property Value

The Day assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HeaderButtonFormatStyle Property

MonthCalendar.HeaderButtonFormatStyle Property

Gets or sets the formatting style of header command buttons.

[Visual Basic]
Public Property HeaderButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle HeaderButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_HeaderButtonFormatStyle();
public: __property void set_HeaderButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get HeaderButtonFormatStyle() : CommandButtonFormatStyle;
public function set HeaderButtonFormatStyle(CommandButtonFormatStyle);

Property Value

A CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HeaderFormatStyle Property

MonthCalendar.HeaderFormatStyle Property

Gets or sets the format style of the control header.

[Visual Basic]
Public Property HeaderFormatStyle As ControlHeaderFormatStyle
[C#]
public ControlHeaderFormatStyle HeaderFormatStyle {get; set;}
[C++]
public: __property ControlHeaderFormatStyle get_HeaderFormatStyle();
public: __property void set_HeaderFormatStyle(ControlHeaderFormatStyle);
[JScript]
public function get HeaderFormatStyle() : ControlHeaderFormatStyle;
public function set HeaderFormatStyle(ControlHeaderFormatStyle);

Property Value

A ControlHeaderFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverDateStyle Property

MonthCalendar.HoverDateStyle Property

Gets or sets the drawing style of date in hover state.

[Visual Basic]
Public Property HoverDateStyle As ControlColorStyle
[C#]
public ControlColorStyle HoverDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_HoverDateStyle();
public: __property void set_HoverDateStyle(ControlColorStyle);
[JScript]
public function get HoverDateStyle() : ControlColorStyle;
public function set HoverDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverHeaderButtonStyle Property

MonthCalendar.HoverHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in hover state.

[Visual Basic]
Public Property HoverHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverHeaderButtonStyle();
public: __property void set_HoverHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverHeaderButtonStyle() : CommandButtonColorStyle;
public function set HoverHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


HoverHeaderStyle Property

MonthCalendar.HoverHeaderStyle Property

Gets or sets the drawing style when control header is hovered.

[Visual Basic]
Public Property HoverHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle HoverHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_HoverHeaderStyle();
public: __property void set_HoverHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get HoverHeaderStyle() : ControlHeaderColorStyle;
public function set HoverHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MaxDate Property

MonthCalendar.MaxDate Property

Determines the maximum date that can be set in MonthCalendar control.

[Visual Basic]
Public Overrides Overloads Property MaxDate As DateTime
[C#]
public override DateTime MaxDate {get; set;}
[C++]
public: override __property DateTime get_MaxDate();
public: override __property void set_MaxDate(DateTime);
[JScript]
public function get MaxDate() : DateTime;
public function set MaxDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MinDate Property

MonthCalendar.MinDate Property

Determines the minimum date that can be set in MonthCalendar control.

[Visual Basic]
Public Overrides Overloads Property MinDate As DateTime
[C#]
public override DateTime MinDate {get; set;}
[C++]
public: override __property DateTime get_MinDate();
public: override __property void set_MinDate(DateTime);
[JScript]
public function get MinDate() : DateTime;
public function set MinDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthHeaderStyle Property

MonthCalendar.MonthHeaderStyle Property

Gets or sets the drawing style of the month header.

[Visual Basic]
Public Property MonthHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle MonthHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_MonthHeaderStyle();
public: __property void set_MonthHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get MonthHeaderStyle() : ControlHeaderColorStyle;
public function set MonthHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalDateStyle Property

MonthCalendar.NormalDateStyle Property

Gets or sets the drawing style of date in normal state.

[Visual Basic]
Public Property NormalDateStyle As ControlColorStyle
[C#]
public ControlColorStyle NormalDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_NormalDateStyle();
public: __property void set_NormalDateStyle(ControlColorStyle);
[JScript]
public function get NormalDateStyle() : ControlColorStyle;
public function set NormalDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalHeaderButtonStyle Property

MonthCalendar.NormalHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in normal state.

[Visual Basic]
Public Property NormalHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalHeaderButtonStyle();
public: __property void set_NormalHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalHeaderButtonStyle() : CommandButtonColorStyle;
public function set NormalHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NormalHeaderStyle Property

MonthCalendar.NormalHeaderStyle Property

Gets or sets the default drawing style of the control header.

[Visual Basic]
Public Property NormalHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle NormalHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_NormalHeaderStyle();
public: __property void set_NormalHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get NormalHeaderStyle() : ControlHeaderColorStyle;
public function set NormalHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedDate Property

MonthCalendar.SelectedDate Property

Gets or sets currently selected date.

[Visual Basic]
Public Overrides Overloads Property SelectedDate As DateTime
[C#]
public override DateTime SelectedDate {get; set;}
[C++]
public: override __property DateTime get_SelectedDate();
public: override __property void set_SelectedDate(DateTime);
[JScript]
public function get SelectedDate() : DateTime;
public function set SelectedDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedDateStyle Property

MonthCalendar.SelectedDateStyle Property

Gets or sets the drawing style of date in selected state.

[Visual Basic]
Public Property SelectedDateStyle As ControlColorStyle
[C#]
public ControlColorStyle SelectedDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_SelectedDateStyle();
public: __property void set_SelectedDateStyle(ControlColorStyle);
[JScript]
public function get SelectedDateStyle() : ControlColorStyle;
public function set SelectedDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedHeaderButtonStyle Property

MonthCalendar.SelectedHeaderButtonStyle Property

Gets or sets the drawing style of header command buttons in selected state.

[Visual Basic]
Public Property SelectedHeaderButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedHeaderButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedHeaderButtonStyle();
public: __property void set_SelectedHeaderButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedHeaderButtonStyle() : CommandButtonColorStyle;
public function set SelectedHeaderButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


SelectedHeaderStyle Property

MonthCalendar.SelectedHeaderStyle Property

Gets or sets the drawing style when control header is selected.

[Visual Basic]
Public Property SelectedHeaderStyle As ControlHeaderColorStyle
[C#]
public ControlHeaderColorStyle SelectedHeaderStyle {get; set;}
[C++]
public: __property ControlHeaderColorStyle get_SelectedHeaderStyle();
public: __property void set_SelectedHeaderStyle(ControlHeaderColorStyle);
[JScript]
public function get SelectedHeaderStyle() : ControlHeaderColorStyle;
public function set SelectedHeaderStyle(ControlHeaderColorStyle);

Property Value

A ControlHeaderColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


ShowTrailingDays Property

MonthCalendar.ShowTrailingDays Property

Determines whether the control will display days from previous and next month.

[Visual Basic]
Public Overridable Property ShowTrailingDays As Boolean
[C#]
public virtual bool ShowTrailingDays { get; set; }
[C++]
public: __property virtual bool get_ShowTrailingDays();
 public:
__property virtual void set_ShowTrailingDays(bool );
[JScript]
public function get ShowTrailingDays() : bool
public function set ShowTrailingDays(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


ShowWeekNumbers Property

MonthCalendar.ShowWeekNumbers Property

Determines whether the control will display the week numbers.

[Visual Basic]
Public Overridable Property ShowWeekNumbers As Boolean
[C#]
public virtual bool ShowWeekNumbers { get; set; }
[C++]
public: __property virtual bool get_ShowWeekNumbers();
 public:
__property virtual void set_ShowWeekNumbers(bool );
[JScript]
public function get ShowWeekNumbers() : bool
public function set ShowWeekNumbers(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


Spacing Property

MonthCalendar.Spacing Property

Gets or sets the spacing between objects.

[Visual Basic]
Public Property Spacing As Integer
[C#]
public int Spacing {get; set;}
[C++]
public: __property int get_Spacing();
public: __property void set_Spacing(int);
[JScript]
public function get Spacing() : int;
public function set Spacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TodayDate Property

MonthCalendar.TodayDate Property

Gets or sets the current date.

[Visual Basic]
Public Overrides Overloads Property TodayDate As DateTime
[C#]
public override DateTime TodayDate {get; set;}
[C++]
public: override __property DateTime get_TodayDate();
public: override __property void set_TodayDate(DateTime);
[JScript]
public function get TodayDate() : DateTime;
public function set TodayDate(DateTime);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TodayDateStyle Property

MonthCalendar.TodayDateStyle Property

Gets or sets the drawing style of the current date.

[Visual Basic]
Public Property TodayDateStyle As ControlColorStyle
[C#]
public ControlColorStyle TodayDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_TodayDateStyle();
public: __property void set_TodayDateStyle(ControlColorStyle);
[JScript]
public function get TodayDateStyle() : ControlColorStyle;
public function set TodayDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


TrailingDateStyle Property

MonthCalendar.TrailingDateStyle Property

Gets or sets the drawing style of the trailing date.

[Visual Basic]
Public Property TrailingDateStyle As ControlColorStyle
[C#]
public ControlColorStyle TrailingDateStyle {get; set;}
[C++]
public: __property ControlColorStyle get_TrailingDateStyle();
public: __property void set_TrailingDateStyle(ControlColorStyle);
[JScript]
public function get TrailingDateStyle() : ControlColorStyle;
public function set TrailingDateStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Methods

The methods of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDateChangedMethod | Raises the DateChanged event.
protected method OnDateSelectedMethod | Raises the DateSelected event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

MonthCalendar.Dispose Method

Releases all resources used by this MonthCalendar object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


OnDateChanged Method

MonthCalendar.OnDateChanged Method

Raises the DateChanged event.

[Visual Basic]
Protected Sub OnDateChanged( _
   ByVal e As DateRangeEventArgsClass _
)
[C#]
 protected void OnDateChanged(
   DateRangeEventArgsClass e
);
[C++]
 protected: void OnDateChanged(
   DateRangeEventArgsClass* e
);
[JScript]
protected function OnDateChanged(
   e : DateRangeEventArgsClass
);

Parameters

e
A DateRangeEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


OnDateSelected Method

MonthCalendar.OnDateSelected Method

Raises the DateSelected event.

[Visual Basic]
Protected Sub OnDateSelected( _
   ByVal e As DateRangeEventArgsClass _
)
[C#]
 protected void OnDateSelected(
   DateRangeEventArgsClass e
);
[C++]
 protected: void OnDateSelected(
   DateRangeEventArgsClass* e
);
[JScript]
protected function OnDateSelected(
   e : DateRangeEventArgsClass
);

Parameters

e
A DateRangeEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

MonthCalendar.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


MonthCalendar Events

The events of the MonthCalendar class are listed here. For a complete list of MonthCalendar class members, see the MonthCalendar Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event DateChanged | Occurs when the date selected in the MonthCalendar changes.
public event DateSelected | Occurs when the user makes an explicit date selection using the mouse.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

MonthCalendar Class | LidorSystems.IntegralUI.Controls Namespace


DateChanged Event

MonthCalendar.DateChanged Event

Occurs when the date selected in the MonthCalendar changes.

[Visual Basic]
Public Event DateChanged As DateRangeEventHandler
[C#]
public event DateRangeEventHandler DateChanged;
[C++]
public: __event DateRangeEventHandler* DateChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type DateRangeEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


DateSelected Event

MonthCalendar.DateSelected Event

Occurs when the user makes an explicit date selection using the mouse.

[Visual Basic]
Public Event DateSelected As DateRangeEventHandler
[C#]
public event DateRangeEventHandler DateSelected;
[C++]
public: __event DateRangeEventHandler* DateSelected;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type DateRangeEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

MonthCalendar Class | MonthCalendar Members | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Class

Displays an ordered list of items used for navigation.

For a list of all members of this type, see NumberedListControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.NumberedListControl

[Visual Basic]
 Public Class NumberedListControl
   Inherits LidorSystems.IntegralUI.Controls.ListBase
[C#]
public class NumberedListControl : LidorSystems.IntegralUI.Controls.ListBase
[C++]
 public __gc __class NumberedListControl : public LidorSystems.IntegralUI.Controls.ListBase
[JScript]
public class NumberedListControl extends LidorSystems.IntegralUI.Controls.ListBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls.NumberedListControl (in LidorSystems.IntegralUI.Controls.NumberedListControl.dll)

See Also

NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Members

NumberedListControl overview

Public Constructors

public constructor NumberedListControl Constructor Initializes a new instance of the NumberedListControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property DisplayMode | Determines how items are displayed.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property SelectedIndex | Gets or sets the index specifying the currently selected item.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property ShowSeparator | Determine whether separator line among items is visible or not.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
protected method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetHoverItem | Retrieves the item that is currently hovered.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateControlStyles | Updates the color and format styles of the control.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the NumberedListControlItem is added.
public event ItemAdding | OOccurs before the NumberedListControlItem is added.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the NumberedListControlItem is removed.
public event ItemRemoving | Occurs before the NumberedListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedIndexChanged | Occurs when the SelectedIndex property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumberedListControl Class | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Constructor ()

Initializes a new instance of the NumberedListControl class.

[Visual Basic]
Public Sub New()
[C#]
public NumberedListControl();
[C++]
public: NumberedListControl();
[JScript]
public function NumberedListControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NumberedListControl Class | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Properties

The properties of the NumberedListControl class are listed here. For a complete list of NumberedListControl class members, see the NumberedListControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the list control control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledButtonStyle | Gets or sets the drawing style of command buttons in disabled state
public property DisabledItemStyle | Gets or sets the drawing style of the disabled item.
public property DisplayMode | Determines how items are displayed.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property HoverItemStyle | Gets or sets the drawing style of the hovered item.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemFormatStyle | Gets or sets the format style of the item.
public property ItemSpacing | Gets or sets the vertical spacing between items.
public property Items | Gets the collection of items that are assigned to the list control control.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property NormalItemStyle | Gets or sets the default drawing style of the item.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property SelectedIndex | Gets or sets the index specifying the currently selected item.
public property SelectedItem | Gets or sets the item that is currently selected in the list control control.
public property SelectedItemStyle | Gets or sets the drawing style of selected item.
public property ShowSeparator | Determine whether separator line among items is visible or not.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

NumberedListControl Class | LidorSystems.IntegralUI.Controls Namespace


DisabledButtonStyle Property

NumberedListControl.DisabledButtonStyle Property

Gets or sets the drawing style of command buttons in disabled state.

[Visual Basic]
Public Property DisabledButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledButtonStyle();
public: __property void set_DisabledButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledButtonStyle() : CommandButtonColorStyle;
public function set DisabledButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Containers Namespace


DisabledItemStyle Property

NumberedListControl.DisabledItemStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledItemStyle();
public: __property void set_DisabledItemStyle(ListItemColorStyle);
[JScript]
public function get DisabledItemStyle() : ListItemColorStyle;
public function set DisabledItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the list box control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


DisplayMode Property

NumberedListControl.DisplayMode Property

Determines how items are displayed.

[Visual Basic]
Public Property DisplayMode As NumberedListControlDisplayMode
[C#]
public NumberedListControlDisplayMode DisplayMode {get; set;}
[C++]
public: __property NumberedListControlDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(NumberedListControlDisplayMode);
[JScript]
public function get DisplayMode() : NumberedListControlDisplayMode;
public function set DisplayMode(NumberedListControlDisplayMode);

Property Value

The NumberedListControlDisplayMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingEffect Property

NumberedListControl.FadingEffect Property

Gets or sets an enumeration that determines the fading effect used during hovering over objects.

[Visual Basic]
Public Property FadingEffect As FadingEffect
[C#]
public FadingEffect FadingEffect {get; set;}
[C++]
public: __property FadingEffect get_FadingEffect();
public: __property void set_FadingEffect(FadingEffect);
[JScript]
public function get FadingEffect() : FadingEffect;
public function set FadingEffect(FadingEffect);

Property Value

The FadingEffect assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


FadingSpeed Property

NumberedListControl.FadingSpeed Property

Gets or sets an enumeration that determines the speed of fading used during hovering over objects.

[Visual Basic]
Public Property FadingSpeed As FadingSpeed
[C#]
public FadingSpeed FadingSpeed {get; set;}
[C++]
public: __property FadingSpeed get_FadingSpeed();
public: __property void set_FadingSpeed(FadingSpeed);
[JScript]
public function get FadingSpeed() : FadingSpeed;
public function set FadingSpeed(FadingSpeed);

Property Value

The FadingSpeed assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


HoverButtonStyle Property

NumberedListControl.HoverButtonStyle Property

Gets or sets the drawing style of command buttons in hover state.

[Visual Basic]
Public Property HoverButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverButtonStyle();
public: __property void set_HoverButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverButtonStyle() : CommandButtonColorStyle;
public function set HoverButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Containers Namespace


HoverItemStyle Property

NumberedListControl.HoverItemStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverItemStyle();
public: __property void set_HoverItemStyle(ListItemColorStyle);
[JScript]
public function get HoverItemStyle() : ListItemColorStyle;
public function set HoverItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemFormatStyle Property

NumberedListControl.ItemFormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property ItemFormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle ItemFormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_ItemFormatStyle();
public: __property void set_ItemFormatStyle(ListItemFormatStyle);
[JScript]
public function get ItemFormatStyle() : ListItemFormatStyle;
public function set ItemFormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemSpacing Property

NumberedListControl.ItemSpacing Property

Gets or sets the spacing between items.

[Visual Basic]
Public Property ItemSpacing As Integer
[C#]
public int ItemSpacing {get; set;}
[C++]
public: __property int get_ItemSpacing();
public: __property void set_ItemSpacing(int);
[JScript]
public function get ItemSpacing() : int;
public function set ItemSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


Items Property

NumberedListControl.Items Property

Gets the collection of items that are assigned to the control.

[Visual Basic]
Public ReadOnly Property Items As NumberedListControlItemCollection
[C#]
public NumberedListControlItemCollection Items {get;}
[C++]
public: __property NumberedListControlItemCollection* get_Items();
[JScript]
public function get Items() : NumberedListControlItemCollection;

Property Value

A NumberedListControlItemCollection that represents the items assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


NormalButtonStyle Property

NumberedListControl.NormalButtonStyle Property

Gets or sets the drawing style of command buttons in normal state.

[Visual Basic]
Public Property NormalButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalButtonStyle();
public: __property void set_NormalButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalButtonStyle() : CommandButtonColorStyle;
public function set NormalButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Containers Namespace


NormalItemStyle Property

NumberedListControl.NormalItemStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalItemStyle();
public: __property void set_NormalItemStyle(ListItemColorStyle);
[JScript]
public function get NormalItemStyle() : ListItemColorStyle;
public function set NormalItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedIndex Property

NumberedListControl.SelectedIndex Property

Gets or sets the index specifying the currently selected item.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}
[C++]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(int);
[JScript]
public function get SelectedIndex() : int;
public function set SelectedIndex(int);

Property Value

A index, that represents the position of a selected item. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedItem Property

NumberedListControl.SelectedItem Property

Gets or sets the item that is currently selected in the control.

[Visual Basic]
Public Property SelectedItem As NumberedListControlItem
[C#]
public NumberedListControlItem SelectedItem {get; set;}
[C++]
public: __property NumberedListControlItem* get_SelectedItem();
public: __property void set_SelectedItem(NumberedListControlItem*);
[JScript]
public function get SelectedItem() : NumberedListControlItem;
public function set SelectedItem(NumberedListControlItem);

Property Value

The NumberedListControlItem that is currently selected in the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedButtonStyle Property

NumberedListControl.SelectedButtonStyle Property

Gets or sets the drawing style of command buttons in selected state.

[Visual Basic]
Public Property SelectedButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedButtonStyle();
public: __property void set_SelectedButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedButtonStyle() : CommandButtonColorStyle;
public function set SelectedButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Containers Namespace


SelectedItemStyle Property

NumberedListControl.SelectedItemStyle Property

Gets or sets the drawing style of selected item.

[Visual Basic]
Public Property SelectedItemStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedItemStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedItemStyle();
public: __property void set_SelectedItemStyle(ListItemColorStyle);
[JScript]
public function get SelectedItemStyle() : ListItemColorStyle;
public function set SelectedItemStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ShowSeparator Property

NumberedListControl.ShowSeparator Property

Determine whether separator line among items is visible or not.

[Visual Basic]
 Public Property ShowSeparator As Boolean
[C#]
 public bool ShowSeparator { get; set; }
[C++]
 public: __property bool
 get_ShowSeparator();
public: __property void set_ShowSeparator(bool );
[JScript]
public function get ShowSeparator() : bool
public function set ShowSeparator(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Methods

The methods of the NumberedListControl class are listed here. For a complete list of NumberedListControl class members, see the NumberedListControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Overridden. Returns the client rectangle of the control.
protected method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
protected method GetHoverItem | Retrieves the item that is currently hovered.
protected method GetItemAt | Retrieves the item that is at the specified location.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateControlStyles | Updates the color and format styles of the control.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemAdded | Raises the ItemAdded event.
protected method OnItemAdding | Raises the ItemAdding event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemRemoved | Raises the ItemRemoved event.
protected method OnItemRemoving | Raises the ItemRemoving event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumberedListControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

NumberedListControl.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonState (CommandButton) Method

NumberedListControl.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetHoverItem Method

NumberedListControl.GetHoverItem Method

Retrieves the item on which the mouse cursor hovers.

[Visual Basic]
Public Function GetHoverItem() As NumberedListControlItem
[C#]
public NumberedListControlItem GetHoverItem();
[C++]
public: NumberedListControlItem GetHoverItem();
[JScript]
public function GetHoverItem() : NumberedListControlItem;

Return Value

The NumberedListControlItem that is currently hovered if there is any, otherwise null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Lists Namespace

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


GetItemAt Method

NumberedListControl.GetItemAt Method

Retrieves the item that is at the specified location.

Overload List

Retrieves the item that is at the specified point.

[Visual Basic] Overloads Public Function GetItemAt(Point) As NumberedListControlItem
[C#] public NumberedListControlItem GetItemAt(Point);
[C++] public: NumberedListControlItem* GetItemAt(Point);
[JScript] public function GetItemAt(Point) : NumberedListControlItem;

Retrieves the item at the point with the specified coordinates.

[Visual Basic] Overloads Public Function GetItemAt(Integer, Integer) As NumberedListControlItem
[C#] public NumberedListControlItem GetItemAt(int, int);
[C++] public: NumberedListControlItem* GetItemAt(int, int);
[JScript] public function GetItemAt(int, int) : NumberedListControlItem;

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Point) Method

NumberedListControl.GetItemAt (Point) Method

Retrieves the item that is at the specified point.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal pt As Point _
) As NumberedListControlItem
[C#]
public NumberedListControlItem GetItemAt(
   Point pt
);
[C++]
public: NumberedListControlItem* GetItemAt(
   Point pt
);
[JScript]
public function GetItemAt(
   pt : Point
) : NumberedListControlItem;

Parameters

pt
The Point to evaluate and retrieve the item from.

Return Value

The NumberedListControlItem at the specified point, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetItemAt (Int32, Int32) Method

NumberedListControl.GetItemAt (Int32, Int32) Method

Retrieves the item at the point with the specified coordinates.

[Visual Basic]
Overloads Public Function GetItemAt( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As NumberedListControlItem
[C#]
public NumberedListControlItem GetItemAt(
   int x,
   int y
);
[C++]
public: NumberedListControlItem* GetItemAt(
   int x,
   int y
);
[JScript]
public function GetItemAt(
   x : int,
   y : int
) : NumberedListControlItem;

Parameters

x
The X position to evaluate and retrieve the item from.
y
The Y position to evaluate and retrieve the item from.

Return Value

The NumberedListControlItem at the specified location, in list view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


GetScrollPos Method

NumberedListControl.GetScrollPos Method

Retrieves the current position of the horizontal and vertical scrollbar thumb.

[Visual Basic]
Overloads Public Function GetScrollPos() As Point
[C#]
public Point GetScrollPos();
[C++]
public: Point* GetScrollPos();
[JScript]
public function GetScrollPos() : Point;

Return Value

The current position of the horizontal and vertical scrollbar thumb.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnAfterSelect Method

NumberedListControl.OnAfterSelect Method

Raises the AfterSelect event.

[Visual Basic]
Protected Overridable Sub OnAfterSelect( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterSelect(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterSelect(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnBeforeSelect Method

NumberedListControl.OnBeforeSelect Method

Raises the BeforeSelect event.

[Visual Basic]
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeSelect(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeSelect(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeSelect(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdded Method

NumberedListControl.OnItemAdded Method

Raises the ItemAdded event.

[Visual Basic]
Protected Overridable Sub OnItemAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemAdding Method

NumberedListControl.OnItemAdding Method

Raises the ItemAdding event.

[Visual Basic]
Protected Overridable Sub OnItemAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemMouseHover Method

NumberedListControl.OnItemMouseHover Method

Raises the ItemMouseHover event.

[Visual Basic]
Protected Overridable Sub OnItemMouseHover( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemMouseHover(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemMouseHover(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemMouseHover(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoved Method

NumberedListControl.OnItemRemoved Method

Raises the ItemRemoved event.

[Visual Basic]
Protected Overridable Sub OnItemRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnItemRemoving Method

NumberedListControl.OnItemRemoving Method

Raises the ItemRemoving event.

[Visual Basic]
Protected Overridable Sub OnItemRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnItemRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnItemRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnItemRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


OnSelectedIndexChanged Method

NumberedListControl.OnSelectedIndexChanged Method

Raises the SelectedIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnSelectedIndexChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnSelectedIndexChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnSelectedIndexChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


SetScrollPos (Point) Method

NumberedListControl.SetScrollPos (Point) Method

Sets the position of the horizontal and vertical scroll bar thumb.

[Visual Basic]
 Public Sub SetScrollPos( _
   ByVal pt As Point _
)
[C#]
public void SetScrollPos(
   Point pt
);
[C++]
public: void SetScrollPos(
   Point pt
);
[JScript]
public function SetScrollPos(
   pt : Point
);

Parameters

pt
The Point at which the horizontal and vertical scroll bar thumb will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateControlStyles () Method

NumberedListControl.UpdateControlStyles () Method

Updates the color and format styles of the control.

[Visual Basic]
Public Sub UpdateControlStyles()
[C#]
public void UpdateControlStyles();
[C++]
 public: void * UpdateControlStyles();
[JScript]
public function UpdateControlStyles() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

NumberedListControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


NumberedListControl Events

The events of the NumberedListControl class are listed here. For a complete list of NumberedListControl class members, see the NumberedListControl Members topic.

Public Events

public event AfterSelect | Occurs after the item is selected.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemAdded | Occurs after the NumberedListControlItem is added.
public event ItemAdding | OOccurs before the NumberedListControlItem is added.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemRemoved | Occurs after the NumberedListControlItem is removed.
public event ItemRemoving | Occurs before the NumberedListControlItem is removed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SelectedIndexChanged | Occurs when the SelectedIndex property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

NumberedListControl Class | LidorSystems.IntegralUI.Controls Namespace


AfterSelect Event

NumberedListControl.AfterSelect Event

Occurs after the item is selected.

[Visual Basic]
Public Event AfterSelect As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterSelect;
[C++]
public: __event ObjectEventHandler* AfterSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


BeforeSelect Event

NumberedListControl.BeforeSelect Event

Occurs before the item is selected.

[Visual Basic]
Public Event BeforeSelect As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeSelect;
[C++]
public: __event ObjectCancelEventHandler* BeforeSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdded Event

NumberedListControl.ItemAdded Event

Occurs after the NumberedListControlItem is added.

[Visual Basic]
Public Event ItemAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemAdded;
[C++]
public: __event ObjectEventHandler* ItemAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemAdding Event

NumberedListControl.ItemAdding Event

OOccurs before the NumberedListControlItem is added.

[Visual Basic]
Public Event ItemAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemAdding;
[C++]
public: __event ObjectCancelEventHandler* ItemAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemMouseHover Event

NumberedListControl.ItemMouseHover Event

Occurs when the mouse cursor hovers for some time over an item space.

[Visual Basic]
Public Event ItemMouseHover As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemMouseHover;
[C++]
public: __event ObjectEventHandler* ItemMouseHover;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoved Event

NumberedListControl.ItemRemoved Event

Occurs after the NumberedListControlItem is removed.

[Visual Basic]
Public Event ItemRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemRemoved;
[C++]
public: __event ObjectEventHandler* ItemRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


ItemRemoving Event

NumberedListControl.ItemRemoving Event

Occurs before the NumberedListControlItem is removed.

[Visual Basic]
Public Event ItemRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ItemRemoving;
[C++]
public: __event ObjectCancelEventHandler* ItemRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


SelectedIndexChanged Event

NumberedListControl.SelectedIndexChanged Event

Occurs when the SelectedIndex property value changes.

[Visual Basic]
Public Event SelectedIndexChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler SelectedIndexChanged;
[C++]
public: __event ObjectEventHandler* SelectedIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumberedListControl Class | NumberedListControl Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Class

Represents a up-down control that displays numeric values.

For a list of all members of this type, see NumericUpDown Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.NumericUpDown

[Visual Basic]
 Public Class NumericUpDown
   Inherits Control
[C#]
public class NumericUpDown : Control
[C++]
 public __gc class NumericUpDown : public Control
[JScript]
public class NumericUpDown extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Members

NumericUpDown overview

Public Constructors

public constructor NumericUpDown Constructor Initializes a new instance of the NumericUpDown class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowInput | Determines whether the value can also be inserted from edit box.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonAlign | Indicates how control will align buttons relative to its edit box.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DecimalPlaces | Gets or sets the number of decimal places.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DownLeftButtonRect | Gets the space reserved for down-left button.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased from button clicks.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThousandsSeparator | Determines whether the thousands separator will be inserted between every three decimal digits.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UpRightButtonRect | Gets the space reserved for up-right button.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in the control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in the control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Constructor ()

Initializes a new instance of the NumericUpDown class.

[Visual Basic]
Public Sub New()
[C#]
public NumericUpDown();
[C++]
public: NumericUpDown();
[JScript]
public function NumericUpDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Properties

The properties of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowInput | Determines whether the value can also be inserted from edit box.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property ButtonAlign | Indicates how control will align buttons relative to its edit box.
public property ButtonFormatStyle | Gets or sets the format style of command buttons.
public property ButtonStripStyle | Gets or sets the drawing style of control button strip.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DecimalPlaces | Gets or sets the number of decimal places.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisabledButtonStyle | Gets or sets the drawing style of tabstrip command buttons in disabled state.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DownLeftButtonRect | Gets the space reserved for down-left button.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverButtonStyle | Gets or sets the drawing style of command buttons in hover state.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased from button clicks.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NormalButtonStyle | Gets or sets the drawing style of command buttons in normal state.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property SelectedButtonStyle | Gets or sets the drawing style of command buttons in selected state.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property ThousandsSeparator | Determines whether the thousands separator will be inserted between every three decimal digits.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UpRightButtonRect | Gets the space reserved for up-right button.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


AllowInput Property

NumericUpDown.AllowInput Property

Determines whether the value can also be inserted from edit box.

[Visual Basic]
Public Overridable Property AllowInput As Boolean
[C#]
public virtual bool AllowInput { get; set; }
[C++]
public: __property virtual bool get_AllowInput();
 public:
__property virtual void set_AllowInput(bool );
[JScript]
public function get AllowInput() : bool
public function set AllowInput(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonAlign Property

NumericUpDown.ButtonAlign Property

Indicates how control will align buttons relative to its edit box.

[Visual Basic]
Public Property ButtonAlign As NumericButtonAlignment
[C#]
public NumericButtonAlignment ButtonAlign {get; set;}
[C++]
public: __property NumericButtonAlignment get_ButtonAlign();
public: __property void set_ButtonAlign(NumericButtonAlignment);
[JScript]
public function get ButtonAlign() : NumericButtonAlignment;
public function set ButtonAlign(NumericButtonAlignment);

Property Value

The NumericButtonAlignment assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonFormatStyle Property

NumericUpDown.ButtonFormatStyle Property

Gets or sets the format style of command buttons.

[Visual Basic]
Public Property ButtonFormatStyle As CommandButtonFormatStyle
[C#]
public CommandButtonFormatStyle ButtonFormatStyle {get; set;}
[C++]
public: __property CommandButtonFormatStyle get_ButtonFormatStyle();
public: __property void set_ButtonFormatStyle(CommandButtonFormatStyle);
[JScript]
public function get ButtonFormatStyle() : CommandButtonFormatStyle;
public function set ButtonFormatStyle(CommandButtonFormatStyle);

Property Value

The CommandButtonFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ButtonStripStyle Property

NumericUpDown.ButtonStripStyle Property

Gets or sets the drawing style of control button strip.

[Visual Basic]
Public Property ButtonStripStyle As CommonColorStyle
[C#]
public CommonColorStyle ButtonStripStyle {get; set;}
[C++]
public: __property CommonColorStyle get_ButtonStripStyle();
public: __property void set_ButtonStripStyle(CommonColorStyle);
[JScript]
public function get ButtonStripStyle() : CommonColorStyle;
public function set ButtonStripStyle(CommonColorStyle);

Property Value

The CommonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Content Property

NumericUpDown.Content Property

Gets the control edit box.

[Visual Basic]
Public ReadOnly Property Content As NumericTextControl
[C#]
public NumericTextControl Content {get;}
[C++]
public: __property NumericTextControl* get_Content();
[JScript]
public function get Content() : NumericTextControl;

Property Value

A NumericTextControl that represents the edit box assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DecimalPlaces Property

NumericUpDown.DecimalPlaces Property

Gets or sets the number of decimal places.

[Visual Basic]
Public Property DecimalPlaces As Integer
[C#]
public int DecimalPlaces {get; set;}
[C++]
public: __property int get_DecimalPlaces();
public: __property void set_DecimalPlaces(int);
[JScript]
public function get DecimalPlaces() : int;
public function set DecimalPlaces(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DisabledButtonStyle Property

NumericUpDown.DisabledButtonStyle Property

Gets or sets the drawing style of command buttons in disabled state.

[Visual Basic]
Public Property DisabledButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle DisabledButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_DisabledButtonStyle();
public: __property void set_DisabledButtonStyle(CommandButtonColorStyle);
[JScript]
public function get DisabledButtonStyle() : CommandButtonColorStyle;
public function set DisabledButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


DownLeftButtonRect Property

NumericUpDown.DownLeftButtonRect Property

Gets the space reserved for down-left button.

[Visual Basic]
Public ReadOnly Property DownLeftButtonRect As Rectangle
[C#]
public Rectangle DownLeftButtonRect {get;}
[C++]
public: __property Rectangle get_DownLeftButtonRect();
[JScript]
public function get DownLeftButtonRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for check box text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


HoverButtonStyle Property

NumericUpDown.HoverButtonStyle Property

Gets or sets the drawing style of command buttons in hover state.

[Visual Basic]
Public Property HoverButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle HoverButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_HoverButtonStyle();
public: __property void set_HoverButtonStyle(CommandButtonColorStyle);
[JScript]
public function get HoverButtonStyle() : CommandButtonColorStyle;
public function set HoverButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Increment Property

NumericUpDown.Increment Property

Gets or sets the amount by which the value is increased or decreased from button clicks.

[Visual Basic]
Public Overridable Property Increment As decimal
[C#]
public virtual decimal Increment { get; set; }
[C++]
public: __property virtual decimal get_Increment();
 public:
__property virtual void set_Increment(decimal );
[JScript]
public function get Increment() : decimal
public function set Increment(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Maximum Property

NumericUpDown.Maximum Property

Determines the maximum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Maximum As decimal
[C#]
public virtual decimal Maximum { get; set; }
[C++]
public: __property virtual decimal get_Maximum();
 public:
__property virtual void set_Maximum(decimal );
[JScript]
public function get Maximum() : decimal
public function set Maximum(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Minimum Property

NumericUpDown.Minimum Property

Determines the minimum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Minimum As decimal
[C#]
public virtual decimal Minimum { get; set; }
[C++]
public: __property virtual decimal get_Minimum();
 public:
__property virtual void set_Minimum(decimal );
[JScript]
public function get Minimum() : decimal
public function set Minimum(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NormalButtonStyle Property

NumericUpDown.NormalButtonStyle Property

Gets or sets the drawing style of command buttons in normal state.

[Visual Basic]
Public Property NormalButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle NormalButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_NormalButtonStyle();
public: __property void set_NormalButtonStyle(CommandButtonColorStyle);
[JScript]
public function get NormalButtonStyle() : CommandButtonColorStyle;
public function set NormalButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


SelectedButtonStyle Property

NumericUpDown.SelectedButtonStyle Property

Gets or sets the drawing style of command buttons in selected state.

[Visual Basic]
Public Property SelectedButtonStyle As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle SelectedButtonStyle {get; set;}
[C++]
public: __property CommandButtonColorStyle get_SelectedButtonStyle();
public: __property void set_SelectedButtonStyle(CommandButtonColorStyle);
[JScript]
public function get SelectedButtonStyle() : CommandButtonColorStyle;
public function set SelectedButtonStyle(CommandButtonColorStyle);

Property Value

A CommandButtonColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

NumericUpDown.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ThousandsSeparator Property

NumericUpDown.ThousandsSeparator Property

Determines whether the thousands separator will be inserted between every three decimal digits.

[Visual Basic]
Public Overridable Property ThousandsSeparator As Boolean
[C#]
public virtual bool ThousandsSeparator { get; set; }
[C++]
public: __property virtual bool get_ThousandsSeparator();
 public:
__property virtual void set_ThousandsSeparator(bool );
[JScript]
public function get ThousandsSeparator() : bool
public function set ThousandsSeparator(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


UpRightButtonRect Property

NumericUpDown.UpRightButtonRect Property

Gets the space reserved for up-right button.

[Visual Basic]
Public ReadOnly Property UpRightButtonRect As Rectangle
[C#]
public Rectangle UpRightButtonRect {get;}
[C++]
public: __property Rectangle get_UpRightButtonRect();
[JScript]
public function get UpRightButtonRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for up-right button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

NumericUpDown.Value Property

Gets or sets the current value of the control.

[Visual Basic]
Public Overridable Property Value As decimal
[C#]
public virtual decimal Value { get; set; }
[C++]
public: __property virtual decimal get_Value();
 public:
__property virtual void set_Value(decimal );
[JScript]
public function get Value() : decimal
public function set Value(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Methods

The methods of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetCmdButtonState | Returns the current state of the command button.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetCurrentButtonColorStyle | Returns the current drawing style of buttons in the control.
public method GetCurrentButtonFormatStyle | Returns the current format style of buttons in the control.
public method GetCurrentButtonStripStyle | Returns the current drawing style of the button strip in the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

NumericUpDown.Dispose Method

Releases all resources used by this NumericUpDown object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCmdButtonState (CommandButton) Method

NumericUpDown.GetCmdButtonState (CommandButton) Method

Returns the current state of the command button.

[Visual Basic]
Overloads Public Function GetCmdButtonState( _
   ByVal cmdButton As CommandButton _
) As ObjectState
[C#]
public ObjectState GetCmdButtonState(
   CommandButton cmdButton
);
[C++]
public: ObjectState* GetCmdButtonState(
   CommandButton cmdButton
);
[JScript]
public function GetCmdButtonState(
   cmdButton : CommandButton
) : ObjectState;

Parameters

cmdButton
The CommandButton to evaluate and retrieve the state from.

Return Value

The ObjectState for a specified command button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonColorStyle Method

NumericUpDown.GetCurrentButtonColorStyle Method

Returns the current drawing style of buttons in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonColorStyle() As CommandButtonColorStyle
[C#]
public CommandButtonColorStyle GetCurrentButtonColorStyle();
[C++]
public: CommandButtonColorStyle* GetCurrentButtonColorStyle();
[JScript]
public function GetCurrentButtonColorStyle() : CommandButtonColorStyle;

Return Value

The style that represents the current drawing style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonFormatStyle Method

NumericUpDown.GetCurrentButtonFormatStyle Method

Returns the current format style of buttons in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonFormatStyle() As CommandButtonFormatStylee
[C#]
public CommandButtonFormatStyle GetCurrentButtonFormatStyle();
[C++]
public: CommandButtonFormatStylee* GetCurrentButtonFormatStyle();
[JScript]
public function GetCurrentButtonFormatStyle() : CommandButtonFormatStylee;

Return Value

The style that represents the current format style of buttons.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentButtonStripStyle Method

NumericUpDown.GetCurrentButtonStripStyle Method

Returns the current drawing style of the button strip in the control.

[Visual Basic]
Overloads Public Function GetCurrentButtonStripStyle() As CommonColorStyle
[C#]
public CommonColorStyle GetCurrentButtonStripStyle();
[C++]
public: CommonColorStyle* GetCurrentButtonStripStyle();
[JScript]
public function GetCurrentButtonStripStyle() : CommonColorStyle;

Return Value

The style that represents the current drawing style of the the button strip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

NumericUpDown.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

NumericUpDown.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanging Method

NumericUpDown.OnValueChanging Method

Raises the ValueChanging event.

[Visual Basic]
Protected Overridable Sub OnValueChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnValueChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnValueChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnValueChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

NumericUpDown.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


NumericUpDown Events

The events of the NumericUpDown class are listed here. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event ValueChanging | Occurs before the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

NumericUpDown Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

NumericUpDown.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ValueChanging Event

NumericUpDown.ValueChanging Event

Occurs before the Value property changes.

[Visual Basic]
Public Event ValueChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ValueChanging;
[C++]
public: __event ObjectCancelEventHandler* ValueChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

NumericUpDown Class | NumericUpDown Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Class

Represents a control that displays progress of an operation.

For a list of all members of this type, see ProgressBar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.ProgressBar

[Visual Basic]
 Public Class ProgressBar
   Inherits Control
[C#]
public class ProgressBar : Control
[C++]
 public __gc class ProgressBar : public Control
[JScript]
public class ProgressBar extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Members

ProgressBar overview

Public Constructors

public constructor ProgressBar Constructor Initializes a new instance of the ProgressBar class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BlockSize | Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.
public property BlockSpacing | Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Gets or sets the maximum value of the range of the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Gets or sets the minimum value of the range of the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Orientation | Determines whether the progress is displayed horizontally or vertically.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property ProgressStyle | Represents the visual appearance of the ProgressBar.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Step | Gets or sets the amount by which the current position of the progress bar is increased.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current position of the progress bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Gets or sets the drawing style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method Increment | Advances the current position of the ProgressBar by the specified amount.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PerformStep | Advances the current position of the ProgressBar by the amount of the Step property.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
public method OnValueChanged | Raises the ValueChanged event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Constructor ()

Initializes a new instance of the ProgressBar class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressBar();
[C++]
public: ProgressBar();
[JScript]
public function ProgressBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Properties

The properties of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BlockSize | Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.
public property BlockSpacing | Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Gets or sets the maximum value of the range of the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Gets or sets the minimum value of the range of the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Orientation | Determines whether the progress is displayed horizontally or vertically.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property ProgressStyle | Represents the visual appearance of the ProgressBar.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Step | Gets or sets the amount by which the current position of the progress bar is increased.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current position of the progress bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


BlockSize Property

ProgressBar.BlockSize Property

Determines the size of blocks displayed, in pixels. Used only when ProgressStyle is set to Blocks.

[Visual Basic]
Public Property BlockSize As Integer
[C#]
public int BlockSize {get; set;}
[C++]
public: __property int get_BlockSize();
public: __property void set_BlockSize(int);
[JScript]
public function get BlockSize() : int;
public function set BlockSize(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


BlockSpacing Property

ProgressBar.BlockSpacing Property

Determines the space between blocks, in pixels. Used only when ProgressStyle is set to Blocks.

[Visual Basic]
Public Property BlockSpacing As Integer
[C#]
public int BlockSpacing {get; set;}
[C++]
public: __property int get_BlockSpacing();
public: __property void set_BlockSpacing(int);
[JScript]
public function get BlockSpacing() : int;
public function set BlockSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

ProgressBar.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Shadows Property ColorStyle As ProgressBarColorStyle
[C#]
public new ProgressBarColorStyle ColorStyle {get; set;}
[C++]
public: new __property ProgressBarColorStyle get_ColorStyle();
public: new __property void set_ColorStyle(ProgressBarColorStyle);
[JScript]
public function get ColorStyle() : ProgressBarColorStyle;
public function set ColorStyle(ProgressBarColorStyle);

Property Value

The ProgressBarColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Maximum Property

ProgressBar.Maximum Property

Gets or sets the maximum value of the range of the control.

[Visual Basic]
 Public Property Maximum As Integer
[C#]
 public int Maximum { get; set; }
[C++]
public: __property virtual int
 get_Maximum();
public: __property void set_Maximum(int );
[JScript]
public function get Maximum() : int
public function set Maximum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Minimum Property

ProgressBar.Minimum Property

Gets or sets the minimum value of the range of the control.

[Visual Basic]
 Public Property Minimum As Integer
[C#]
 public int Minimum { get; set; }
[C++]
public: __property virtual int
 get_Minimum();
public: __property void set_Minimum(int );
[JScript]
public function get Minimum() : int
public function set Minimum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Orientation Property

ProgressBar.Orientation Property

Determines whether the progress is displayed horizontally or vertically.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}
[C++]
public: __property Orientation get_Orientation();
public: __property void set_Orientation(Orientation);
[JScript]
public function get Orientation() : Orientation;
public function set Orientation(Orientation);

Property Value

The Orientation assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressStyle Property

ProgressBar.ProgressStyle Property

Represents the visual appearance of the ProgressBar.

[Visual Basic]
Public Property ProgressStyle As ProgressBarStyle
[C#]
public ProgressBarStyle ProgressStyle {get; set;}
[C++]
public: __property ProgressBarStyle get_ProgressStyle();
public: __property void set_ProgressStyle(ProgressBarStyle);
[JScript]
public function get ProgressStyle() : ProgressBarStyle;
public function set ProgressStyle(ProgressBarStyle);

Property Value

The ProgressBarStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Step Property

ProgressBar.Step Property

Gets or sets the amount by which the current position of the progress bar is increased.

[Visual Basic]
Public Property Step As Integer
[C#]
public int Step {get; set;}
[C++]
public: __property int get_Step();
public: __property void set_Step(int);
[JScript]
public function get Step() : int;
public function set Step(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

ProgressBar.Value Property

Gets or sets the current position of the progress bar.

[Visual Basic]
Public Property Value As Integer
[C#]
public int Value {get; set;}
[C++]
public: __property int get_Value();
public: __property void set_Value(int);
[JScript]
public function get Value() : int;
public function set Value(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Methods

The methods of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Gets or sets the drawing style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method Increment | Advances the current position of the ProgressBar by the specified amount.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PerformStep | Advances the current position of the ProgressBar by the amount of the Step property.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
public method OnValueChanged | Raises the ValueChanged event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

ProgressBar.Dispose Method

Releases all resources used by this ProgressBar object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

ProgressBar.GetCurrentColorStyle Method

Returns the drawing style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As ProgressBarColorStyle
[C#]
public new ProgressBarColorStyle GetCurrentColorStyle();
[C++]
public: new ProgressBarColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : ProgressBarColorStyle;

Return Value

The style that represents the current drawing style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


Increment Method

ProgressBar.Increment Method

Advances the current position of the ProgressBar by the specified amount.

[Visual Basic]
Public Sub Increment( _
   ByVal value As Integer _
)
[C#]
 public void Increment(
   int value
);
[C++]
public: void Increment(
   int value
);
[JScript]
 public function Increment(
   value : int
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

ProgressBar.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


PerformStep Method

ProgressBar.PerformStep Method

Advances the current position of the ProgressBar by the amount of the Step property.

[Visual Basic]
Public Sub PerformStep()
[C#]
 public void PerformStep();
[C++]
public: void PerformStep();
[JScript]
 public function PerformStep();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

ProgressBar.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


ProgressBar Events

The events of the ProgressBar class are listed here. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after the Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ProgressBar Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

ProgressBar.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBar Class | ProgressBar Members | LidorSystems.IntegralUI.Controls Namespace


RatingControl Class

Represents a rating control.

For a list of all members of this type, see RatingControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.RatingControl

[Visual Basic]
 Public Class RatingControl
   Inherits Control
[C#]
public class RatingControl : Control
[C++]
 public __gc class RatingControl : public Control
[JScript]
public class RatingControl extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


RatingControl Members

RatingControl overview

Public Constructors

public constructor RatingControl Constructor Initializes a new instance of the RatingControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowImageAnimation | Determines whether front image can be animated.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImageSpacing | Gets or sets the spacing between images.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method StartAnimation | Starts an animation of animated gifs contained in the control.
public method StopAnimation | Stops an animation of animated gifs contained in the control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after Value property changes.
public event ValueChanging | Occurs before Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

RatingControl Class | LidorSystems.IntegralUI.Controls Namespace


RatingControl Constructor ()

Initializes a new instance of the RatingControl class.

[Visual Basic]
Public Sub New()
[C#]
public RatingControl();
[C++]
public: RatingControl();
[JScript]
public function RatingControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RatingControl Class | LidorSystems.IntegralUI.Controls Namespace


RatingControl Properties

The properties of the RatingControl class are listed here. For a complete list of RatingControl class members, see the RatingControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowImageAnimation | Determines whether front image can be animated.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from CommonControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle (inherited from CommonControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImageSpacing | Gets or sets the spacing between images.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property Increment | Gets or sets the amount by which the value is increased or decreased.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property Maximum | Determines the maximum value that can be accepted by the control.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property Minimum | Determines the minimum value that can be accepted by the control.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Overridden. Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Value | Gets or sets the current value of the control.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

RatingControl Class | LidorSystems.IntegralUI.Controls Namespace


AllowImageAnimation Property

RatingControl.AllowImageAnimation Property

Determines whether front image can be animated.

[Visual Basic]
 Public Property AllowImageAnimation As Boolean
[C#]
 public bool AllowImageAnimation { get; set; }
[C++]
 public: __property bool
 get_AllowImageAnimation();
public: __property void set_AllowImageAnimation(bool );
[JScript]
public function get AllowImageAnimation() : bool
public function set AllowImageAnimation(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


ImageSpacing Property

RatingControl.ImageSpacing Property

Gets or sets the spacing between images.

[Visual Basic]
Public Property ImageSpacing As Integer
[C#]
public int ImageSpacing {get; set;}
[C++]
public: __property int get_ImageSpacing();
public: __property void set_ImageSpacing(int);
[JScript]
public function get ImageSpacing() : int;
public function set ImageSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


Increment Property

RatingControl.Increment Property

Gets or sets the amount by which the value is increased or decreased.

[Visual Basic]
Public Overridable Property Increment As decimal
[C#]
public virtual decimal Increment { get; set; }
[C++]
public: __property virtual decimal get_Increment();
 public:
__property virtual void set_Increment(decimal );
[JScript]
public function get Increment() : decimal
public function set Increment(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


Maximum Property

RatingControl.Maximum Property

Determines the maximum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Maximum As int
[C#]
public virtual int Maximum { get; set; }
[C++]
public: __property virtual int get_Maximum();
 public:
__property virtual void set_Maximum(int );
[JScript]
public function get Maximum() : int
public function set Maximum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


Minimum Property

RatingControl.Minimum Property

Determines the minimum value that can be accepted by the control.

[Visual Basic]
Public Overridable Property Minimum As int
[C#]
public virtual int Minimum { get; set; }
[C++]
public: __property virtual int get_Minimum();
 public:
__property virtual void set_Minimum(int );
[JScript]
public function get Minimum() : int
public function set Minimum(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


Value Property

RatingControl.Value Property

Gets or sets the current value of the control.

[Visual Basic]
Public Overridable Property Value As decimal
[C#]
public virtual decimal Value { get; set; }
[C++]
public: __property virtual decimal get_Value();
 public:
__property virtual void set_Value(decimal );
[JScript]
public function get Value() : decimal
public function set Value(decimal);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


RatingControl Methods

The methods of the RatingControl class are listed here. For a complete list of RatingControl class members, see the RatingControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused (inherited from CommonControlBase) | Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method StartAnimation | Starts an animation of animated gifs contained in the control.
public method StopAnimation | Stops an animation of animated gifs contained in the control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnValueChanged | Raises the ValueChanged event.
protected method OnValueChanging | Raises the ValueChanging event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

RatingControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

RatingControl.Dispose Method

Releases all resources used by this RatingControl object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanged Method

RatingControl.OnValueChanged Method

Raises the ValueChanged event.

[Visual Basic]
Protected Overridable Sub OnValueChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnValueChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnValueChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnValueChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


OnValueChanging Method

RatingControl.OnValueChanging Method

Raises the ValueChanging event.

[Visual Basic]
Protected Overridable Sub OnValueChanging( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnValueChanging(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnValueChanging(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnValueChanging(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


StartAnimation () Method

RatingControl.StartAnimation () Method

Starts an animation of animated gifs contained in the control.

[Visual Basic]
Public Sub StartAnimation()
[C#]
public void StartAnimation();
[C++]
 public: void * StartAnimation();
[JScript]
public function StartAnimation() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


StopAnimation () Method

RatingControl.StopAnimation () Method

Stops an animation of animated gifs contained in the control.

[Visual Basic]
Public Sub StopAnimation()
[C#]
public void StopAnimation();
[C++]
 public: void * StopAnimation();
[JScript]
public function StopAnimation() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

RatingControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


RatingControl Events

The events of the RatingControl class are listed here. For a complete list of RatingControl class members, see the RatingControl Members topic.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event ValueChanged | Occurs after Value property changes.
public event ValueChanging | Occurs before Value property changes.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

RatingControl Class | LidorSystems.IntegralUI.Controls Namespace


ValueChanged Event

RatingControl.ValueChanged Event

Occurs after the Value property changes.

[Visual Basic]
Public Event ValueChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ValueChanged;
[C++]
public: __event ObjectEventHandler* ValueChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


ValueChanging Event

RatingControl.ValueChanging Event

Occurs before the Value property changes.

[Visual Basic]
Public Event ValueChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler ValueChanging;
[C++]
public: __event ObjectCancelEventHandler* ValueChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventHandler containing data related to this event. The following CancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

RatingControl Class | RatingControl Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Class

Represents a text box control.

For a list of all members of this type, see TextControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Controls.CommonControlBase
LidorSystems.IntegralUI.Controls.TextControl

[Visual Basic]
 Public Class TextControl
   Inherits Control
[C#]
public class TextControl : Control
[C++]
 public __gc class TextControl : public Control
[JScript]
public class TextControl extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Members

TextControl overview

Public Constructors

public constructor TextControl Constructor Initializes a new instance of the TextControl class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSpace | Determines whether space character is allowed.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CharacterMode | Determines the type of characters that can be inserted.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Multiline | Determines whether text can span to more then one line.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Returns the drawing style of the control.
public method GetCurrentFormatStyle | Returns the format style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


TextControl Constructor ()

Initializes a new instance of the TextControl class.

[Visual Basic]
Public Sub New()
[C#]
public TextControl();
[C++]
public: TextControl();
[JScript]
public function TextControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


TextControl Properties

The properties of the TextControl class are listed here. For a complete list of TextControl class members, see the TextControl Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSpace | Determines whether space character is allowed.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from CommonControlBase) | Overridden. Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BackgroundImageSpace (inherited from CommonControlBase) | Gets or sets the space at which background image will be drawn.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CharacterMode | Determines the type of characters that can be inserted.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property Content | Gets the control edit box.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property FormatStyle | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Multiline | Determines whether text can span to more then one line.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. See Control.Text.
public property TextRect | Gets the space reserved for control text.
public property TextRect | Gets the bounds of the text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property UseTheme (inherited from CommonControlBase) | Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from CommonControlBase) | Gets or sets an enumeration that determines the renderer of the control.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


AllowSpace Property

TextControl.AllowSpace Property

Determines whether space character is allowed.

[Visual Basic]
Public Overridable Property AllowSpace As Boolean
[C#]
public virtual bool AllowSpace { get; set; }
[C++]
public: __property virtual bool get_AllowSpace();
 public:
__property virtual void set_AllowSpace(bool );
[JScript]
public function get AllowSpace() : bool
public function set AllowSpace(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


CharacterMode Property

TextControl.CharacterMode Property

Determines the type of characters that can be inserted.

[Visual Basic]
Public Property CharacterMode As CharacterMode
[C#]
public CharacterMode CharacterMode {get; set;}
[C++]
public: __property CharacterMode get_CharacterMode();
public: __property void set_CharacterMode(CharacterMode);
[JScript]
public function get CharacterMode() : CharacterMode;
public function set CharacterMode(CharacterMode);

Property Value

The CharacterMode assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


ColorStyle Property

TextControl.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Shadows Property ColorStyle As TextControlColorStyle
[C#]
public new TextControlColorStyle ColorStyle {get; set;}
[C++]
public: new __property TextControlColorStyle get_ColorStyle();
public: new __property void set_ColorStyle(TextControlColorStyle);
[JScript]
public function get ColorStyle() : TextControlColorStyle;
public function set ColorStyle(TextControlColorStyle);

Property Value

The TextControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


Content Property

TextControl.Content Property

Gets the control edit box.

[Visual Basic]
Public ReadOnly Property Content As TextControl.EditBox
[C#]
public TextControl.EditBox Content {get;}
[C++]
public: __property TextControl.EditBox* get_Content();
[JScript]
public function get Content() : TextControl.EditBox;

Property Value

A TextControl.EditBox that represents the edit box assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


FormatStyle Property

TextControl.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Shadows Property FormatStyle As TextControlFormatStyle
[C#]
public new TextControlFormatStyle FormatStyle {get; set;}
[C++]
public: new __property TextControlFormatStyle get_FormatStyle();
public: new __property void set_FormatStyle(TextControlFormatStyle);
[JScript]
public function get FormatStyle() : TextControlFormatStyle;
public function set FormatStyle(TextControlFormatStyle);

Property Value

The TextControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


Multiline Property

TextControl.Multiline Property

Determines whether text can span to more then one line.

[Visual Basic]
Public Overridable Property Multiline As Boolean
[C#]
public virtual bool Multiline { get; set; }
[C++]
public: __property virtual bool get_Multiline();
 public:
__property virtual void set_Multiline(bool );
[JScript]
public function get Multiline() : bool
public function set Multiline(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextRect Property

TextControl.TextRect Property

Gets the space reserved for control text.

[Visual Basic]
Public ReadOnly Property TextRect As Rectangle
[C#]
public Rectangle TextRect {get;}
[C++]
public: __property Rectangle get_TextRect();
[JScript]
public function get TextRect() : Rectangle;

Property Value

The Rectangle that represents the space reserved for control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


TextControl Methods

The methods of the TextControl class are listed here. For a complete list of TextControl class members, see the TextControl Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetCurrentColorStyle | Returns the drawing style of the control.
public method GetCurrentFormatStyle | Returns the format style of the control.
public method GetClientRect (inherited from CommonControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetCurrentColorStyle (inherited from CommonControlBase) | Returns the current color style of the control.
public method GetCurrentFormatStyle (inherited from CommonControlBase) | Returns the current format style of the control.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetDisplayRect (inherited from CommonControlBase) | Returns the display rectangle of the control.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsControlFocused | Overridden. Determines whether the control or its children has an input focus.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumeUpdate (inherited from CommonControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendUpdate (inherited from CommonControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnCheckStateChanged | Raises the CheckStateChanged event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TextControl Class | LidorSystems.IntegralUI.Controls Namespace


Dispose Method

TextControl.Dispose Method

Releases all resources used by this TextControl object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

TextControl.GetCurrentColorStyle Method

Returns the drawing style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As TextControlColorStyle
[C#]
public new TextControlColorStyle GetCurrentColorStyle();
[C++]
public: new TextControlColorStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : TextControlColorStyle;

Return Value

The style that represents the current drawing style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


GetCurrentColorStyle Method

TextControl.GetCurrentColorStyle Method

Returns the current format style of the control.

[Visual Basic]
Public Shadows Function GetCurrentColorStyle() As TextControlFormatStyle
[C#]
public new TextControlFormatStyle GetCurrentColorStyle();
[C++]
public: new TextControlFormatStyle* GetCurrentColorStyle();
[JScript]
public function GetCurrentColorStyle() : TextControlFormatStyle;

Return Value

The style that represents the current format style of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


IsControlFocused Method

TextControl.IsControlFocused Method

Overridden. Determines whether the control or its children has an input focus.

[Visual Basic]
Public Overloads Overrides Function IsControlFocused() As Boolean
[C#]
public override bool IsControlFocused();
[C++]
public: override bool IsControlFocused();
[JScript]
public function IsControlFocused() : Boolean;

Return Value

True if control or its children has an input focus, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


UpdateLayout () Method

TextControl.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Overloads Overrides Sub UpdateLayout()
[C#]
public override void UpdateLayout();
[C++]
 public: override void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControl Class | TextControl Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Class

A class representing a selectable button that can contain text and image.

For a list of all members of this type, see ToolButton Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolButton

[Visual Basic]

Public Class ToolButton
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolButton : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolButton : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolButton extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Members

ToolButton overview

Public Constructors

public constructor ToolButton Constructor Initializes a new instance of the ToolButton class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property Checked | Indicates whether the button is pressed in or not.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the button.
public property ItemType | Overridden. Gets the type of button.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolButton object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event CheckedChanged | Occurs when the Checked property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor

Initializes a new instance of the ToolButton class.

Overload List

Initializes a new instance of the ToolButton class.

[Visual Basic] Public Sub New()
[C#] public ToolButton();
[C++] public: ToolButton();
[JScript] public function ToolButton();

Initializes a new instance of the ToolButton class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolButton(string);
[C++] public: ToolButton(String*);
[JScript] public function ToolButton(String);

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor ()

Initializes a new instance of the ToolButton class.

[Visual Basic]
Public Sub New()
[C#]
public ToolButton();
[C++]
public: ToolButton();
[JScript]
public function ToolButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Constructor (String)

Initializes a new instance of the ToolButton class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolButton(
   string text
);
[C++]
public: ToolButton(
   String* text
);
[JScript]
public function ToolButton(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


ToolButton Properties

The properties of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property Checked | Indicates whether the button is pressed in or not.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the button.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the button.
public property ItemType | Overridden. Gets the type of button.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


Checked Property

ToolButton.Checked Property

Indicates whether the button is pressed in or not.

[Visual Basic]
Public Overridable Property Checked As Boolean
[C#]
public virtual bool Checked {get; set;}
[C++]
public: __property virtual bool get_Checked();
public: __property virtual void set_Checked(bool);
[JScript]
public function get Checked() : Boolean;
public function set Checked(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentRelation Property

ToolButton.ContentRelation Property

Specifies how text and image are aligned.

[Visual Basic]
Public Overrides Overloads Property ContentRelation As ToolContentRelation
[C#]
public override ToolContentRelation ContentRelation {get; set;}
[C++]
public: override __property ToolContentRelation get_ContentRelation();
public: override __property void set_ContentRelation(ToolContentRelation);
[JScript]
public function get ContentRelation() : ToolContentRelation;
public function set ContentRelation(ToolContentRelation);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyle Property

ToolButton.DisplayStyle Property

Specifies whether text and image are displayed.

[Visual Basic]
Public Overrides Overloads Property DisplayStyle As ToolDisplayStyle
[C#]
public override ToolDisplayStyle DisplayStyle {get; set;}
[C++]
public: override __property ToolDisplayStyle get_DisplayStyle();
public: override __property void set_DisplayStyle(ToolDisplayStyle);
[JScript]
public function get DisplayStyle() : ToolDisplayStyle;
public function set DisplayStyle(ToolDisplayStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

ToolButton.ImageIndex Property

Gets or sets the image list index value of the image displayed on the button.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

ToolButton.Image Property

The image that will be displayed on the button.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

ToolButton.ItemType Property

Overridden. Gets the type of button.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Methods

The methods of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolButton object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolButton object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnCheckedChanged | Raises the CheckedChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolButton Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

ToolButton.Clone Method

Creates an exact copy of the current ToolButton.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolButton object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnCheckedChanged Method

ToolButton.OnCheckedChanged Method

Raises the CheckedChanged event.

[Visual Basic]
Protected Overridable Sub OnCheckedChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnCheckedChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnCheckedChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnCheckedChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnContentRelationChanged Method

ToolButton.OnContentRelationChanged Method

Raises the ContentRelationChanged event.

[Visual Basic]
Protected Overridable Sub OnContentRelationChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnContentRelationChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnContentRelationChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnContentRelationChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnDisplayStyleChanged Method

ToolButton.OnDisplayStyleChanged Method

Raises the DisplayStyleChanged event.

[Visual Basic]
Protected Overridable Sub OnDisplayStyleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnDisplayStyleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

ToolButton.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


OnImageIndexChanged Method

ToolButton.OnImageIndexChanged Method

Raises the ImageIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnImageIndexChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageIndexChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageIndexChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageIndexChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolButton Events

The events of the ToolButton class are listed here. For a complete list of ToolButton class members, see the ToolButton Members topic.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event CheckedChanged | Occurs when the Checked property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

See Also

ToolButton Class | LidorSystems.IntegralUI Namespace


CheckedChanged Event

ToolButton.CheckedChanged Event

Occurs when the Checked property value has changed.

[Visual Basic]
Public Event CheckedChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler CheckedChanged;
[C++]
public: __event UpdateEventHandler* CheckedChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ContentRelationChanged Event

ToolButton.ContentRelationChanged Event

Occurs when the ContentRelation property value has changed.

[Visual Basic]
Public Event ContentRelationChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ContentRelationChanged;
[C++]
public: __event UpdateEventHandler* ContentRelationChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyleChanged Event

ToolButton.DisplayStyleChanged Event

Occurs when the DisplayStyle property value has changed.

[Visual Basic]
Public Event DisplayStyleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler DisplayStyleChanged;
[C++]
public: __event UpdateEventHandler* DisplayStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

ToolButton.ImageChanged Event

Occurs when the Image property value has changed.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndexChanged Event

ToolButton.ImageIndexChanged Event

Occurs when the ImageIndex property value has changed.

[Visual Basic]
Public Event ImageIndexChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageIndexChanged;
[C++]
public: __event UpdateEventHandler* ImageIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolButton Class | ToolButton Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Class

Provides a common implementation of members for tool item objects.

For a list of all members of this type, see ToolItemBase Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolButton
LidorSystems.IntegralUI.Controls.ToolLabel
LidorSystems.IntegralUI.Controls.ToolSeparator

[Visual Basic]

MustInherit Public Class ToolItemBase
   Inherits LidorSystems.IntegralUI.ObjectBase
[C#]

public abstract class ToolItemBase : LidorSystems.IntegralUI.ObjectBase
[C++]

public __gc __abstract class ToolItemBase : public LidorSystems.IntegralUI.ObjectBase
[JScript]
public abstract

class ToolItemBase extends LidorSystems.IntegralUI.ObjectBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Members

ToolItemBase overview

Public Constructors

public constructor ToolItemBase Constructor Initializes a new instance of the ToolItemBase class.

Public Properties

public property Alignment | Determines how tool item is aligned in parent control.
public property Bounds | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Gets the type of tool item.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone (inherited from Object) | Creates an exact copy of the current ToolItemBase object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolItemBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged | Occurs when the Alignment property value has changed.
public event FadingChanged | Occurs when fade value of the item has changed during active fading process.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged | Raises the AlignmentChanged event.
protected method OnFadingChanged | Raises the FadingChanged event.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor

Initializes a new instance of the ToolItemBase class.

Overload List

Initializes a new instance of the ToolItemBase class.

[Visual Basic] Public Sub New()
[C#] public ToolItemBase();
[C++] public: ToolItemBase();
[JScript] public function ToolItemBase();

Initializes a new instance of the ToolItemBase class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolItemBase(string);
[C++] public: ToolItemBase(String*);
[JScript] public function ToolItemBase(String);

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor ()

Initializes a new instance of the ToolItemBase class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemBase();
[C++]
public: ToolItemBase();
[JScript]
public function ToolItemBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Constructor (String)

Initializes a new instance of the ToolItemBase class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolItemBase(
   string text
);
[C++]
public: ToolItemBase(
   String* text
);
[JScript]
public function ToolItemBase(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Properties

The properties of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Properties

public property Alignment | Determines how tool item is aligned in parent control.
public property Bounds | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Gets the type of tool item.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


Alignment Property

ToolItemBase.Alignment Property

Determines how tool item is aligned in parent control.

[Visual Basic]
Public Overrides Overloads Property Alignment As ToolItemAlignment
[C#]
public override ToolItemAlignment Alignment {get; set;}
[C++]
public: override __property ToolItemAlignment get_Alignment();
public: override __property void set_Alignment(ToolItemAlignment);
[JScript]
public function get Alignment() : ToolItemAlignment;
public function set Alignment(ToolItemAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


Bounds Property

ToolItemBase.Bounds Property

Gets or sets a value specifying the tool item space. For internal use only.

[Visual Basic]
Public Overrides Overloads ReadOnly Property Bounds As Rectangle
[C#]
public override Rectangle Bounds {get;}
[C++]
public: override __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the tool item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ContentSize Property

ToolItemBase.ContentSize Property

Gets or sets the size of tool item content space. For internal use only.

[Visual Basic]
Public ReadOnly Property ContentSize As Size
[C#]
public Size ContentSize {get;}
[C++]
public: __property Size get_ContentSize();
[JScript]
public function get ContentSize() : Size;

Property Value

The Size of the tool item content space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

ToolItemBase.ItemType Property

Gets the type of tool item.

[Visual Basic]
Public Overridable ReadOnly Property ItemType As ToolItemType
[C#]
public virtual ToolItemType ItemType {get;}
[C++]
public: __property virtual ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the tool item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


Size Property

ToolItemBase.Size Property

Gets or sets the size of the tool item space. For internal use only.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

Property Value

The Size of the tool item space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Methods

The methods of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Methods

public method Clone (inherited from Object) | Creates an exact copy of the current ToolItemBase object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolItemBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged | Raises the AlignmentChanged event.
protected method OnFadingChanged | Raises the FadingChanged event.

See Also

ToolItemBase Class | LidorSystems.IntegralUI.Controls Namespace


OnAlignmentChanged Method

ToolItemBase.OnAlignmentChanged Method

Raises the AlignmentChanged event.

[Visual Basic]
Protected Overridable Sub OnAlignmentChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnAlignmentChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnAlignmentChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnAlignmentChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


OnFadingChanged Method

ToolItemBase.OnFadingChanged Method

Raises the FadingChanged event.

[Visual Basic]
Protected Sub OnFadingChanged( _
   ByVal e As EventArgs _
)
[C#]
 protected void OnFadingChanged(
   EventArgs e
);
[C++]
 protected: void OnFadingChanged(
   EventArgs* e
);
[JScript]
protected function OnFadingChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolItemBase Events

The events of the ToolItemBase class are listed here. For a complete list of ToolItemBase class members, see the ToolItemBase Members topic.

Public Events

public event AlignmentChanged | Occurs when the Alignment property value has changed.
public event FadingChanged | Occurs when fade value of the item has changed during active fading process.

See Also

ToolItemBase Class | LidorSystems.IntegralUI Namespace


AlignmentChanged Event

ToolItemBase.AlignmentChanged Event

Occurs when the Alignment property value has changed.

[Visual Basic]
Public Event AlignmentChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler AlignmentChanged;
[C++]
public: __event UpdateEventHandler* AlignmentChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


FadingChanged Event

ToolItemBase.FadingChanged Event

Occurs when fade value of the item has changed during active fading process.

[Visual Basic]
Public Event FadingChanged As EventHandler
[C#]
public event EventHandler FadingChanged;
[C++]
public: __event EventHandler* FadingChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemBase Class | ToolItemBase Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Class

A class representing a non-selectable tool item that renders text and images and can display hyperlinks.

For a list of all members of this type, see ToolLabel Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolLabel

[Visual Basic]

Public Class ToolLabel
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolLabel : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolLabel : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolLabel extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Members

ToolLabel overview

Public Constructors

public constructor ToolLabel Constructor Initializes a new instance of the ToolLabel class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the label.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the label.
public property IsLink | Indicates the behavior of the label.
public property ItemType | Overridden. Gets the type of label.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property LinkUnderlineStyle | The underline style of the link.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolLabel object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolLabel object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor

Initializes a new instance of the ToolLabel class.

Overload List

Initializes a new instance of the ToolLabel class.

[Visual Basic] Public Sub New()
[C#] public ToolLabel();
[C++] public: ToolLabel();
[JScript] public function ToolLabel();

Initializes a new instance of the ToolLabel class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ToolLabel(string);
[C++] public: ToolLabel(String*);
[JScript] public function ToolLabel(String);

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor ()

Initializes a new instance of the ToolLabel class.

[Visual Basic]
Public Sub New()
[C#]
public ToolLabel();
[C++]
public: ToolLabel();
[JScript]
public function ToolLabel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Constructor (String)

Initializes a new instance of the ToolLabel class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ToolLabel(
   string text
);
[C++]
public: ToolLabel(
   String* text
);
[JScript]
public function ToolLabel(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Properties

The properties of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentRelation | Specifies how text and image are aligned.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property DisplayStyle | Specifies whether text and image are displayed.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property Image | The image that will be displayed on the label.
public property ImageIndex | Gets or sets the image list index value of the image displayed on the label.
public property IsLink | Indicates the behavior of the label.
public property ItemType | Overridden. Gets the type of label.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property LinkUnderlineStyle | The underline style of the link.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


ContentRelation Property

ToolLabel.ContentRelation Property

Specifies how text and image are aligned.

[Visual Basic]
Public Overrides Overloads Property ContentRelation As ToolContentRelation
[C#]
public override ToolContentRelation ContentRelation {get; set;}
[C++]
public: override __property ToolContentRelation get_ContentRelation();
public: override __property void set_ContentRelation(ToolContentRelation);
[JScript]
public function get ContentRelation() : ToolContentRelation;
public function set ContentRelation(ToolContentRelation);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyle Property

ToolLabel.DisplayStyle Property

Specifies whether text and image are displayed.

[Visual Basic]
Public Overrides Overloads Property DisplayStyle As ToolDisplayStyle
[C#]
public override ToolDisplayStyle DisplayStyle {get; set;}
[C++]
public: override __property ToolDisplayStyle get_DisplayStyle();
public: override __property void set_DisplayStyle(ToolDisplayStyle);
[JScript]
public function get DisplayStyle() : ToolDisplayStyle;
public function set DisplayStyle(ToolDisplayStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndex Property

ToolLabel.ImageIndex Property

Gets or sets the image list index value of the image displayed on the button.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


Image Property

ToolLabel.Image Property

The image that will be displayed on the button.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


IsLink Property

ToolLabel.IsLink Property

Indicates the behavior of the label.

[Visual Basic]
Public Overridable Property IsLink As Boolean
[C#]
public virtual bool IsLink {get; set;}
[C++]
public: __property virtual bool get_IsLink();
public: __property virtual void set_IsLink(bool);
[JScript]
public function get IsLink() : Boolean;
public function set IsLink(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

ToolLabel.ItemType Property

Overridden. Gets the type of label.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the type of the label.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


LinkUnderlineStyle Property

ToolLabel.LinkUnderlineStyle Property

The underline style of the link.

[Visual Basic]
Public Overrides Overloads Property LinkUnderlineStyle As ToolLinkUnderlineStyle
[C#]
public override ToolLinkUnderlineStyle LinkUnderlineStyle {get; set;}
[C++]
public: override __property ToolLinkUnderlineStyle get_LinkUnderlineStyle();
public: override __property void set_LinkUnderlineStyle(ToolLinkUnderlineStyle);
[JScript]
public function get LinkUnderlineStyle() : ToolLinkUnderlineStyle;
public function set LinkUnderlineStyle(ToolLinkUnderlineStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Methods

The methods of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolLabel object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolLabel object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.
protected method OnAlignmentChanged (inherited from ToolItemBase) | Raises the AlignmentChanged event.
protected method OnContentRelationChanged | Raises the ContentRelationChanged event.
protected method OnDisplayStyleChanged | Raises the DisplayStyleChanged event.
protected method OnFadingChanged (inherited from ToolItemBase) | Raises the FadingChanged event.
protected method OnImageChanged | Raises the ImageChanged event.
protected method OnImageIndexChanged | Raises the ImageIndexChanged event.

See Also

ToolLabel Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

ToolLabel.Clone Method

Creates an exact copy of the current ToolLabel.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolLabel object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnContentRelationChanged Method

ToolLabel.OnContentRelationChanged Method

Raises the ContentRelationChanged event.

[Visual Basic]
Protected Overridable Sub OnContentRelationChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnContentRelationChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnContentRelationChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnContentRelationChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnDisplayStyleChanged Method

ToolLabel.OnDisplayStyleChanged Method

Raises the DisplayStyleChanged event.

[Visual Basic]
Protected Overridable Sub OnDisplayStyleChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnDisplayStyleChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnDisplayStyleChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnImageChanged Method

ToolLabel.OnImageChanged Method

Raises the ImageChanged event.

[Visual Basic]
Protected Overridable Sub OnImageChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


OnImageIndexChanged Method

ToolLabel.OnImageIndexChanged Method

Raises the ImageIndexChanged event.

[Visual Basic]
Protected Overridable Sub OnImageIndexChanged( _
   ByVal e As UpdateEventArgsClass _
)
[C#]
protected virtual void OnImageIndexChanged(
   UpdateEventArgsClass e
);
[C++]
protected: virtual void OnImageIndexChanged(
   UpdateEventArgsClass* e
);
[JScript]
protected function OnImageIndexChanged(
   e : UpdateEventArgsClass
);

Parameters

e
A UpdateEventArgsClass that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolLabel Events

The events of the ToolLabel class are listed here. For a complete list of ToolLabel class members, see the ToolLabel Members topic.

Public Events

public event AlignmentChanged (inherited from ToolItemBase) | Occurs when the Alignment property value has changed.
public event ContentRelationChanged | Occurs when the ContentRelation property value has changed.
public event DisplayStyleChanged | Occurs when the DisplayStyle property value has changed.
public event FadingChanged (inherited from ToolItemBase) | Occurs when fade value of the item has changed during active fading process.
public event ImageChanged | Occurs when the Image property value has changed.
public event ImageIndexChanged | Occurs when the ImageIndex property value has changed.

See Also

ToolLabel Class | LidorSystems.IntegralUI Namespace


ContentRelationChanged Event

ToolLabel.ContentRelationChanged Event

Occurs when the ContentRelation property value has changed.

[Visual Basic]
Public Event ContentRelationChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ContentRelationChanged;
[C++]
public: __event UpdateEventHandler* ContentRelationChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


DisplayStyleChanged Event

ToolLabel.DisplayStyleChanged Event

Occurs when the DisplayStyle property value has changed.

[Visual Basic]
Public Event DisplayStyleChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler DisplayStyleChanged;
[C++]
public: __event UpdateEventHandler* DisplayStyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageChanged Event

ToolLabel.ImageChanged Event

Occurs when the Image property value has changed.

[Visual Basic]
Public Event ImageChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageChanged;
[C++]
public: __event UpdateEventHandler* ImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ImageIndexChanged Event

ToolLabel.ImageIndexChanged Event

Occurs when the ImageIndex property value has changed.

[Visual Basic]
Public Event ImageIndexChanged As UpdateEventHandler
[C#]
public event UpdateEventHandler ImageIndexChanged;
[C++]
public: __event UpdateEventHandler* ImageIndexChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type UpdateEventArgsClass.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolLabel Class | ToolLabel Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Class

A class representing a line used to group tool items.

For a list of all members of this type, see ToolSeparator Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Controls.ToolItemBase
LidorSystems.IntegralUI.Controls.ToolSeparator

[Visual Basic]

Public Class ToolSeparator
   Inherits LidorSystems.IntegralUI.Controls.ToolItemBase
[C#]

public class ToolSeparator : LidorSystems.IntegralUI.Controls.ToolItemBase
[C++]

 public __gc class ToolSeparator : public LidorSystems.IntegralUI.Controls.ToolItemBase
[JScript]
public

class ToolSeparator extends LidorSystems.IntegralUI.Controls.ToolItemBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Members

ToolSeparator overview

Public Constructors

public constructor ToolSeparator Constructor Initializes a new instance of the ToolSeparator class.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Overridden. Gets the type of separator.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolSeparator object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolSeparator object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Constructor ()

Initializes a new instance of the ToolSeparator class.

[Visual Basic]
Public Sub New()
[C#]
public ToolSeparator();
[C++]
public: ToolSeparator();
[JScript]
public function ToolSeparator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Properties

The properties of the ToolSeparator class are listed here. For a complete list of ToolSeparator class members, see the ToolSeparator Members topic.

Public Properties

public property Alignment (inherited from ToolItemBase) | Determines how tool item is aligned in parent control.
public property Bounds (inherited from ToolItemBase) | Gets or sets a value specifying the tool item space. For internal use only.
public property ContentSize (inherited from ToolItemBase) | Gets or sets the size of tool item content space. For internal use only.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property ItemType | Overridden. Gets the type of separator.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property Size (inherited from ToolItemBase) | Gets or sets the size of the tool item space. For internal use only.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


ItemType Property

ToolSeparator.ItemType Property

Overridden. Gets the separator type.

[Visual Basic]
Public Overrides Overloads ReadOnly Property ItemType As ToolItemType
[C#]
public override ToolItemType ItemType {get;}
[C++]
public: __property override ToolItemType* get_ItemType();
[JScript]
public function get ItemType() : ToolItemType;

Property Value

A ToolItemType that represents the separator type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolSeparator Class | ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


ToolSeparator Methods

The methods of the ToolSeparator class are listed here. For a complete list of ToolSeparator class members, see the ToolSeparator Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolSeparator object.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ToolSeparator object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ToolSeparator Class | LidorSystems.IntegralUI.Controls Namespace


Clone Method

ToolSeparator.Clone Method

Creates an exact copy of the current ToolSeparator.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolSeparator object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolSeparator Class | ToolSeparator Members | LidorSystems.IntegralUI.Controls Namespace


CalendarDisplayMode Enumeration

Enumerator used to determine how date is displayed in MonthCalendar control.

[Visual Basic]
Public Enum CalendarDisplayMode
[C#]
public enum CalendarDisplayMode
[C++]
__value public enum CalendarDisplayMode
[JScript]
public
   enum CalendarDisplayMode

Members

Member name | Description
Day | A single day is displayed.
Month | A single month with all days is displayed.
Year | A single year with all months is displayed.
Decade | A decade is displayed.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CharacterMode Enumeration

Enumerator used to determine the type of characters that can be inserted.

[Visual Basic]
Public Enum CharacterMode
[C#]
public enum CharacterMode
[C++]
__value public enum CharacterMode
[JScript]
public
   enum CharacterMode

Members

Member name | Description
AlphaNumeric | All characters are allowed.
Numeric | Only numeric characters are allowed.
Textual | Only textual characters are allowed.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CommandButtonType Enumeration

Enumerator used to specify some predfined types of command buttons.

[Visual Basic]
Public Enum CommandButtonType
[C#]
public enum CommandButtonType
[C++]
__value public enum CommandButtonType
[JScript]
public
   enum CommandButtonType

Members

Member name | Description
CollapseUp | Represents a button used for collapsing operations.
CollapseDown | Represents a button used for expanding operations.
Default | The default button type. The appearance is determined by its image.
SplitCollapse | Represents a button used for collapsing operations in SplitContainer control.
SplitHorizontal | Represents a button used for to set horizontal orientation in SplitContainer control.
SplitVertical | Represents a button used for to set vertical orientation in SplitContainer control.
SwapButton | Represents a button used for to swap panels in SplitContainer control.
TabClose | Represents a button used to close open tabs.
TabScrollLeft | Represents a button used navigate among tabs in left/up direction.
TabScrollRight | Represents a button used navigate among tabs in right/down direction.
TabSelector | Represents a button used to select and activate a particular tab.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


CommandButtonVisibility Enumeration

Enumerator used to determine how command buttons are displayed.

[Visual Basic]
Public Enum CommandButtonVisibility
[C#]
public enum CommandButtonVisibility
[C++]
__value public enum CommandButtonVisibility
[JScript]
public
   enum CommandButtonVisibility

Members

Member name | Description
None | The buttons are not visible.
OnHover | The buttons are visible when their container is hovered.
OnClick | The buttons are visible when their container is selected.
AlwaysVisible | The buttons are always visible.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


NumericButtonAlignment Enumeration

Enumerator used to determine how control will align buttons relative to its edit box in NumericUpDown control.

[Visual Basic]
Public Enum NumericButtonAlignment
[C#]
public enum NumericButtonAlignment
[C++]
__value public enum NumericButtonAlignment
[JScript]
public
   enum NumericButtonAlignment

Members

Member name | Description
Horizontal | EditBox is located in the middle area surronding with buttons to the left and right side.
UpDownLeft | EditBox is placed to the right side and buttons are placed to the left side.
UpDownRight | EditBox is placed to the left side and buttons are placed to the right side.
Vertical | EditBox is located in the middle area surronding with buttons to the up and down side.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolContentRelation Enumeration

Enumerator used to specify how content of tool items are arranged.

[Visual Basic]
Public Enum ToolContentRelation
[C#]
public enum ToolContentRelation
[C++]
__value public enum ToolContentRelation
[JScript]
public
   enum ToolContentRelation

Members

Member name | Description
ImageBeforeText | Image is showed before text.
ImageAboveText | Image is showed above text.
TextBeforeImage | Text is showed before image.
TextAboveImage | Text is showed above image.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolDisplayStyle Enumeration

Enumerator used to specify what objects are showed in tool item space.

[Visual Basic]
Public Enum ToolDisplayStyle
[C#]
public enum ToolDisplayStyle
[C++]
__value public enum ToolDisplayStyle
[JScript]
public
   enum ToolDisplayStyle

Members

Member name | Description
None | The tool item doesn't display anything.
Text | Only a text is shown in the tool item space.
Image | Only an image is shown in the tool item space.
All | Both, text and image are shown in the tool item space.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolItemAlignment Enumeration

Enumerator used to determine the alignment of tool item in the parent container.

[Visual Basic]
Public Enum ToolItemAlignment
[C#]
public enum ToolItemAlignment
[C++]
__value public enum ToolItemAlignment
[JScript]
public
   enum ToolItemAlignment

Members

Member name | Description
Left | The tool item is aligned to the left side of its parent container.
Right | The tool item is aligned to the right side of its parent container.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolItemType Enumeration

Enumerator used to specify the type of tool item.

[Visual Basic]
Public Enum ToolItemType
[C#]
public enum ToolItemType
[C++]
__value public enum ToolItemType
[JScript]
public
   enum ToolItemType

Members

Member name | Description
Button | The tool item acts like a button.
Label | The tool item acts like a label.
Separator | The tool item acts like a separator for other tool items.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


ToolLinkUnderlineStyle Enumeration

Enumerator used to specify when an underline is shown below the text in tool label.

[Visual Basic]
Public Enum ToolLinkUnderlineStyle
[C#]
public enum ToolLinkUnderlineStyle
[C++]
__value public enum ToolLinkUnderlineStyle
[JScript]
public
   enum ToolLinkUnderlineStyle

Members

Member name | Description
None | The underline is not visible.
OnHover | The underline is visible only when tool label is hovered.
Always | The underline is always visible.

Requirements

Namespace: LidorSystems.IntegralUI.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

LidorSystems.IntegralUI.Controls Namespace


LidorSystems.IntegralUI.Controls

LidorSystems.IntegralUI.Controls.Collections Namespace

Classes

Class | Description
CommandButtonCollection | Contains a collection of CommandButton objects.
ListControlItemCollection | Contains a collection of ListControlItem objects.
ToolItemCollection | Contains a collection of ToolItemBase objects.


CommandButtonCollection Class

Contains a collection of CommandButton objects.

For a list of all members of this type, see CommandButtonCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.CommandButtonCollection

[Visual Basic]
Public Class CommandButtonCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class CommandButtonCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class CommandButtonCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class CommandButtonCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Members

CommandButtonCollection overview

Public Constructors

public constructor CommandButtonCollection Constructor Initializes a new instance of the CommandButtonCollection class.

Public Properties

public property Item | Gets a CommandButton at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the CommandButtonCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the CommandButtonCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the CommandButtonCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the CommandButtonCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the CommandButtonCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the CommandButtonCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an CommandButton is added.
protected method OnAdding | Overridden. Occurs before an CommandButton is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an CommandButton is removed.
protected method OnRemoving | Overridden. Occurs before an CommandButton is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor

Overload List

Initializes a new instance of the CommandButtonCollection class.

[Visual Basic] Public Sub New()
[C#] public CommandButtonCollection();
[C++] public: CommandButtonCollection();
[JScript] public function CommandButtonCollection();

Initializes a new instance of the CommandButtonCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public CommandButtonCollection(object);
[C++] public: CommandButtonCollection(Object*);
[JScript] public function CommandButtonCollection(Object);

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor ()

Initializes a new instance of the CommandButtonCollection class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonCollection();
[C++]
public: CommandButtonCollection();
[JScript]
public function CommandButtonCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Constructor (Object)

Initializes a new instance of the CommandButtonCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public CommandButtonCollection(
   object owner
);
[C++]
public: CommandButtonCollection(
   Object* owner
);
[JScript]
public function CommandButtonCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


CommandButtonCollection Properties

The properties of the CommandButtonCollection class are listed here. For a complete list of CommandButtonCollection class members, see the CommandButtonCollection Members topic.

Public Properties

public property Item | Gets a CommandButton at the specified location in the collection.
public property Owner (inherited from CommandButtonCollection) | Gets the object that owns the CommandButtonCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

CommandButtonCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

CommandButtonCollection.Item Property

Gets or sets a button within the collection.

Overload List

Gets a CommandButton at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a CommandButton with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Class

Contains a collection of ListControlItem objects.

For a list of all members of this type, see ListControlItemCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.ListControlItemCollection

[Visual Basic]
Public Class ListControlItemCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class ListControlItemCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class ListControlItemCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class ListControlItemCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Members

ListControlItemCollection overview

Public Constructors

public constructor ListControlItemCollection Constructor Initializes a new instance of the ListControlItemCollection class.

Public Properties

public property Item | Gets a ListControlItem at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the ListControlItemCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the ListControlItemCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the ListControlItemCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the ListControlItemCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the ListControlItemCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the ListControlItemCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an ListControlItem is added.
protected method OnAdding | Overridden. Occurs before an ListControlItem is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an ListControlItem is removed.
protected method OnRemoving | Overridden. Occurs before an ListControlItem is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor

Overload List

Initializes a new instance of the ListControlItemCollection class.

[Visual Basic] Public Sub New()
[C#] public ListControlItemCollection();
[C++] public: ListControlItemCollection();
[JScript] public function ListControlItemCollection();

Initializes a new instance of the ListControlItemCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public ListControlItemCollection(object);
[C++] public: ListControlItemCollection(Object*);
[JScript] public function ListControlItemCollection(Object);

Initializes a new instance of the ListControlItemCollection class and associates it with the parent ListControl.

[Visual Basic] Public Sub New(ListControl)
[C#] public ListControlItemCollection(ListControl);
[C++] public: ListControlItemCollection(ListControl*);
[JScript] public function ListControlItemCollection(ListControl);

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor ()

Initializes a new instance of the ListControlItemCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ListControlItemCollection();
[C++]
public: ListControlItemCollection();
[JScript]
public function ListControlItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor (Object)

Initializes a new instance of the ListControlItemCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ListControlItemCollection(
   object owner
);
[C++]
public: ListControlItemCollection(
   Object* owner
);
[JScript]
public function ListControlItemCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Constructor (ListControl)

Initializes a new instance of the ListControlItemCollection class and associates it with parent ListControl.

[Visual Basic]
Public Sub New( _
   ByVal owner As ListControl _
)
[C#]
public ListControlItemCollection(
   ListControl owner
);
[C++]
public: ListControlItemCollection(
   ListControl* owner
);
[JScript]
public function ListControlItemCollection(
   owner : ListControl
);

Parameters

owner

The ListControl to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ListControlItemCollection Properties

The properties of the ListControlItemCollection class are listed here. For a complete list of ListControlItemCollection class members, see the ListControlItemCollection Members topic.

Public Properties

public property Item | Gets a ListControlItem at the specified location in the collection.
public property Owner (inherited from ListControlItemCollection) | Gets the object that owns the ListControlItemCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ListControlItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

ListControlItemCollection.Item Property

Gets or sets a button within the collection.

Overload List

Gets a ListControlItem at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a ListControlItem with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Class

Contains a collection of ToolItemBase objects.

For a list of all members of this type, see ToolItemCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Controls.Collections.ToolItemCollection

[Visual Basic]
Public Class ToolItemCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class ToolItemCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class ToolItemCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class ToolItemCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Controls (in LidorSystems.IntegralUI.Controls.dll)

See Also

ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Members

ToolItemCollection overview

Public Constructors

public constructor ToolItemCollection Constructor Initializes a new instance of the ToolItemCollection class.

Public Properties

public property Item | Gets a ToolItemBase at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the ToolItemCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the ToolItemCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the ToolItemCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the ToolItemCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the ToolItemCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the ToolItemCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an ToolItemBase is added.
protected method OnAdding | Overridden. Occurs before an ToolItemBase is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an ToolItemBase is removed.
protected method OnRemoving | Overridden. Occurs before an ToolItemBase is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor

Overload List

Initializes a new instance of the ToolItemCollection class.

[Visual Basic] Public Sub New()
[C#] public ToolItemCollection();
[C++] public: ToolItemCollection();
[JScript] public function ToolItemCollection();

Initializes a new instance of the ToolItemCollection class and associates it with the given object.

[Visual Basic] Public Sub New(Object)
[C#] public ToolItemCollection(object);
[C++] public: ToolItemCollection(Object*);
[JScript] public function ToolItemCollection(Object);

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor ()

Initializes a new instance of the ToolItemCollection class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemCollection();
[C++]
public: ToolItemCollection();
[JScript]
public function ToolItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Properties

The properties of the ToolItemCollection class are listed here. For a complete list of ToolItemCollection class members, see the ToolItemCollection Members topic.

Public Properties

public property Item | Gets a ToolItemBase at the specified location in the collection.
public property Owner (inherited from ToolItemCollection) | Gets the object that owns the ToolItemCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Method

ToolItemCollection.Item Property

Gets or sets a tool item within the collection.

Overload List

Gets a ToolItem at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a ToolItem with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


LidorSystems.IntegralUI.Controls.Style

LidorSystems.IntegralUI.Controls.Style Namespace

Classes

Class | Description
CheckButtonBoxStyle | Represents the style for drawing the checkbox button.
CommandButtonColorStyle | Represents the style for drawing the command buttons.
CommandButtonFormatStyle | Represents the format style for command buttons.
ControlStripStyle | Represents the style for drawing the control strip space.
LabelEditStyle | Represents the style for drawing and formatting the text control used for editing.
ProgressBarColorStyle | Represents the style for drawing the ProgressBar control.
TextControlColorStyle | Represents the drawing style for TextControl.
TextControlFormatStyle | Represents the format style for TextControl.
ToolItemColorStyle | Represents the style for drawing the tool item.
ToolItemFormatStyle | Represents the format style for tool items.
ToolTipStyle | Represents the style for drawing and formatting the tool tip.

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


CheckButtonBoxStyle Class

Represents the style for drawing the checkbox button.

For a list of all members of this type, see CheckButtonBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.CheckButtonBoxStyle

[Visual Basic]
Public Class CheckButtonBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CheckButtonBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CheckButtonBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CheckButtonBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Members

CheckButtonBoxStyle overview

Public Constructors

public constructor CheckButtonBoxStyle Constructor Initializes a new instance of the CheckButtonBoxStyle class.

Public Properties

public property Alignment | Gets or sets the VerticalAlignment of the check box.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonSize | Gets or sets the button size.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Constructor ()

Initializes a new instance of the CheckButtonBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CheckButtonBoxStyle();
[C++]
public: CheckButtonBoxStyle();
[JScript]
public function CheckButtonBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Properties

The properties of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Properties

public property Alignment | Gets or sets the VerticalAlignment of the check box.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonSize | Gets or sets the button size.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Alignment Property

CheckButtonBoxStyle.Alignment Property

Gets or sets the VerticalAlignment of the check box.

[Visual Basic]
Public Property Alignment As VerticalAlignment
[C#]
public VerticalAlignment Alignment {get; set;}
[C++]
public: __property VerticalAlignment get_Alignment();
public: __property void set_Alignment(VerticalAlignment);
[JScript]
public function get Alignment() : VerticalAlignment;
public function set Alignment(VerticalAlignment);

Property Value

A VerticalAlignment of the check box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

CheckButtonBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ButtonSize Property

CheckButtonBoxStyle.ButtonSize Property

Gets or sets the button size.

[Visual Basic]
Public Property ButtonSize As Size
[C#]
public Size ButtonSize {get; set;}
[C++]
public: __property Size get_ButtonSize();
public: __property void set_ButtonSize(Size);
[JScript]
public function get ButtonSize() : Size;
public function set ButtonSize(Size);

Property Value

A Size represents the size of the button.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckColor Property

CheckButtonBoxStyle.CheckColor Property

Gets or sets the check mark Color.

[Visual Basic]
Public Property CheckColor As Color
[C#]
public Color CheckColor {get; set;}
[C++]
public: __property Color get_CheckColor();
public: __property void set_CheckColor(Color);
[JScript]
public function get CheckColor() : Color;
public function set CheckColor(Color);

Property Value

A Color represents the check mark color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckedImage Property

CheckButtonBoxStyle.CheckedImage Property

Gets or sets an custom image when the checkbox is checked.

[Visual Basic]
Public Property CheckedImage As Image
[C#]
public Image CheckedImage {get; set;}
[C++]
public: __property Image get_CheckedImage();
public: __property void set_CheckedImage(Image);
[JScript]
public function get CheckedImage() : Image;
public function set CheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IndeterminateImage Property

CheckButtonBoxStyle.IndeterminateImage Property

Gets or sets an custom image when the checkbox is indeterminated.

[Visual Basic]
Public Property IndeterminateImage As Image
[C#]
public Image IndeterminateImage {get; set;}
[C++]
public: __property Image get_IndeterminateImage();
public: __property void set_IndeterminateImage(Image);
[JScript]
public function get IndeterminateImage() : Image;
public function set IndeterminateImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


UncheckedImage Property

CheckButtonBoxStyle.UncheckedImage Property

Gets or sets an custom image when the checkbox is unchecked.

[Visual Basic]
Public Property UncheckedImage As Image
[C#]
public Image UncheckedImage {get; set;}
[C++]
public: __property Image get_UncheckedImage();
public: __property void set_UncheckedImage(Image);
[JScript]
public function get UncheckedImage() : Image;
public function set UncheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CheckButtonBoxStyle Methods

The methods of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

CheckButtonBoxStyle.Clone Method

Creates an exact copy of the current CheckButtonBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CheckButtonBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

CheckButtonBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CheckButtonBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

CheckButtonBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Class

Represents the style for drawing the command button.

For a list of all members of this type, see CommandButtonColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.CommandButtonColorStyle

[Visual Basic]
Public Class CommandButtonColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CommandButtonColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CommandButtonColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CommandButtonColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Members

CommandButtonColorStyle overview

Public Constructors

public constructor CommandButtonColorStyle Constructor Initializes a new instance of the CommandButtonColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current CommandButtonColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Constructor ()

Initializes a new instance of the CommandButtonColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonColorStyle();
[C++]
public: CommandButtonColorStyle();
[JScript]
public function CommandButtonColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Properties

The properties of the CommandButtonColorStyle class are listed here. For a complete list of CommandButtonColorStyle class members, see the CommandButtonColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

CommandButtonColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ForeColor Property

CommandButtonColorStyle.ForeColor Property

Gets or sets the color used to draw the button graphics.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color);
[JScript]
public function get ForeColor() : Color;
public function set ForeColor(Color);

Property Value

A Color represents the color used to draw the button graphics.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonColorStyle Methods

The methods of the CommandButtonColorStyle class are listed here. For a complete list of CommandButtonColorStyle class members, see the CommandButtonColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current CommandButtonColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CommandButtonColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

CommandButtonColorStyle.Clone Method

Creates an exact copy of the current CommandButtonColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CommandButtonColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

CommandButtonColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CommandButtonColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

CommandButtonColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonColorStyle Class | CommandButtonColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Class

Represents the format style for command buttons.

For a list of all members of this type, see CommandButtonFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.CommandButtonFormatStyle

[Visual Basic]
Public Class CommandButtonFormatStyle Implements
   ICloneable, IDisposable
[C#]
public class CommandButtonFormatStyle : ICloneable, IDisposable
[C++]
public __gc class CommandButtonFormatStyle : public ICloneable, IDisposable
[JScript]
public class CommandButtonFormatStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Members

CommandButtonFormatStyle overview

Public Constructors

public constructor CommandButtonFormatStyle Constructor Initializes a new instance of the CommandButtonFormatStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the button content.
public property Spacing | Specifies the distance between buttons.
public property Visibility | Specifies at which case the button is visible.

Public Events

public event StyleChanged Occurs when the CommandButtonFormatStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current CommandButtonFormatStyle.
public method Dispose | Releases all resources used by this CommandButtonFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Constructor ()

Initializes a new instance of the CommandButtonFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CommandButtonFormatStyle();
[C++]
public: CommandButtonFormatStyle();
[JScript]
public function CommandButtonFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Properties

The properties of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the button content.
public property Spacing | Specifies the distance between buttons.
public property Visibility | Specifies at which case the button is visible.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

CommandButtonFormatStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ContentSize Property

CommandButtonFormatStyle.ContentSize Property

Specifies the size of the button content.

[Visual Basic]
Public Property ContentSize As Size
[C#]
public Size ContentSize {get; set;}
[C++]
public: __property Size get_ContentSize();
public: __property void set_ContentSize(Size);
[JScript]
public function get ContentSize() : Size;
public function set ContentSize(Size);

Property Value

A Size represents the size of the button content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Spacing Property

CommandButtonFormatStyle.Spacing Property

Specifies the distance between buttons.

[Visual Basic]
Public Property Spacing As Integer
[C#]
public int Spacing {get; set;}
[C++]
public: __property int get_Spacing();
public: __property void set_Spacing(int);
[JScript]
public function get Spacing() : int;
public function set Spacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonVisibility Property

CommandButtonFormatStyle.Visibility Property

Specifies at which case the button is visible.

[Visual Basic]
Public Property Visibility As CommandButtonVisibility
[C#]
public CommandButtonVisibility Visibility {get; set;}
[C++]
public: __property CommandButtonVisibility get_Visibility();
public: __property void set_Visibility(CommandButtonVisibility);
[JScript]
public function get Visibility() : CommandButtonVisibility;
public function set Visibility(CommandButtonVisibility);

Property Value

The CommandButtonVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Methods

The methods of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current CommandButtonFormatStyle.
public method Dispose | Releases all resources used by this CommandButtonFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

CommandButtonFormatStyle.Clone Method

Creates an exact copy of the current CommandButtonFormatStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new CommandButtonFormatStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Dispose Method

CommandButtonFormatStyle.Dispose Method

Releases all resources used by this CommandButtonFormatStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

CommandButtonFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI.Controls infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the CommandButtonFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


OnStyleChanged Method

CommandButtonFormatStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

CommandButtonFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


CommandButtonFormatStyle Events

The events of the CommandButtonFormatStyle class are listed here. For a complete list of CommandButtonFormatStyle class members, see the CommandButtonFormatStyle Members topic.

Public Events

public event StyleChanged Occurs when the CommandButtonFormatStyle changes.

See Also

CommandButtonFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

CommandButtonFormatStyle.StyleChanged Event

Occurs when the CommandButtonFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonFormatStyle Class | CommandButtonFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Class

Represents the style for drawing the control strip space.

For a list of all members of this type, see ControlStripStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ControlStripStyle

[Visual Basic]
Public Class ControlStripStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlStripStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlStripStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlStripStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Members

ControlStripStyle overview

Public Constructors

public constructor ControlStripStyle Constructor Initializes a new instance of the ControlStripStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the control strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ControlStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Constructor ()

Initializes a new instance of the ControlStripStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlStripStyle();
[C++]
public: ControlStripStyle();
[JScript]
public function ControlStripStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Properties

The properties of the ControlStripStyle class are listed here. For a complete list of ControlStripStyle class members, see the ControlStripStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Padding | Gets or sets the amount of space from the control strip border, in pixels.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

ControlStripStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Padding Property

ControlStripStyle.Padding Property

Gets or sets the amount of space from the control strip border, in pixels.

[Visual Basic]
Public Property Padding As Padding
[C#]
public Padding Padding { get; set; }
[C++]
public: __property Padding get_Padding();
public: __property void set_Padding(Padding);
[JScript]
public function get Padding() : Padding
public function set Padding(Padding);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ControlStripStyle Methods

The methods of the ControlStripStyle class are listed here. For a complete list of ControlStripStyle class members, see the ControlStripStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ControlStripStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlStripStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

ControlStripStyle.Clone Method

Creates an exact copy of the current ControlStripStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlStripStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

ControlStripStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlStripStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

ControlStripStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlStripStyle Class | ControlStripStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Class

Represents the style for drawing and formatting the text control used for editing.

For a list of all members of this type, see LabelEditStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.LabelEditStyle

[Visual Basic]
Public Class LabelEditStyle Implements
   ICloneable, IDisposable
[C#]
public class LabelEditStyle : ICloneable, IDisposable
[C++]
public __gc class LabelEditStyle : public ICloneable, IDisposable
[JScript]
public class LabelEditStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Members

LabelEditStyle overview

Public Constructors

public constructor LabelEditStyle Constructor Initializes a new instance of the LabelEditStyle class.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BorderColor | Gets or sets the shape of the border corner.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderVisibility | Determines which border side will be shown.
public property TextColor | Gets or sets the Color of the text.

Public Events

public event StyleChanged Occurs when the LabelEditStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current LabelEditStyle.
public method Dispose | Releases all resources used by this LabelEditStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Constructor ()

Initializes a new instance of the LabelEditStyle class.

[Visual Basic]
Public Sub New()
[C#]
public LabelEditStyle();
[C++]
public: LabelEditStyle();
[JScript]
public function LabelEditStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Properties

The properties of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BorderColor | Gets or sets the shape of the border corner.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderVisibility | Determines which border side will be shown.
public property TextColor | Gets or sets the Color of the text.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

LabelEditStyle.BorderColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

LabelEditStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerRadius Property

LabelEditStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

LabelEditStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderVisibility Property

LabelEditStyle.BorderVisibility Property

Determines which border side will be shown.

[Visual Basic]
Public Property Visibility As BorderVisibility
[C#]
public BorderVisibility Visibility {get; set;}
[C++]
public: __property BorderVisibility get_Visibility();
public: __property void set_Visibility(BorderVisibility);
[JScript]
public function get Visibility() : BorderVisibility;
public function set Visibility(BorderVisibility);

Property Value

The BorderVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

LabelEditStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LabelEditStyle Methods

The methods of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current LabelEditStyle.
public method Dispose | Releases all resources used by this LabelEditStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

LabelEditStyle.Clone Method

Creates an exact copy of the current LabelEditStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new LabelEditStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

LabelEditStyle.Dispose Method

Releases all resources used by this LabelEditStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

LabelEditStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the LabelEditStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

LabelEditStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

LabelEditStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Style Namespace


LabelEditStyle Events

The events of the LabelEditStyle class are listed here. For a complete list of LabelEditStyle class members, see the LabelEditStyle Members topic.

Public Events

public event StyleChanged Occurs when the LabelEditStyle changes.

See Also

LabelEditStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

LabelEditStyle.StyleChanged Event

Occurs when the CommandButtonFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

LabelEditStyle Class | LabelEditStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Class

Represents the style for drawing the ProgressBar control.

For a list of all members of this type, see ProgressBarColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ProgressBarColorStyle

[Visual Basic]
Public Class ProgressBarColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ProgressBarColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ProgressBarColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ProgressBarColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Members

ProgressBarColorStyle overview

Public Constructors

public constructor ProgressBarColorStyle Constructor Initializes a new instance of the ProgressBarColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BarImage | Specifies the image object to use as a texture for drawing the progress.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ProgressColor | Gets or sets the progress Color.
public property ProgressFadeColor | Gets or sets the progress fade Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ProgressBarColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Constructor ()

Initializes a new instance of the ProgressBarColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressBarColorStyle();
[C++]
public: ProgressBarColorStyle();
[JScript]
public function ProgressBarColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Properties

The properties of the ProgressBarColorStyle class are listed here. For a complete list of ProgressBarColorStyle class members, see the ProgressBarColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BarImage | Specifies the image object to use as a texture for drawing the progress.
public property BorderColor | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ProgressColor | Gets or sets the progress Color.
public property ProgressFadeColor | Gets or sets the progress fade Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BarImage Property

ProgressBarColorStyle.BarImage Property

Specifies the image object to use as a texture for drawing the progress.

[Visual Basic]
Public Property BarImage As Image
[C#]
public Image BarImage {get; set;}
[C++]
public: __property Image get_BarImage();
public: __property void set_BarImage(Image);
[JScript]
public function get BarImage() : Image;
public function set BarImage(Image);

Property Value

A Image used as a background texture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

ProgressBarColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressColor Property

ProgressBarColorStyle.ProgressColor Property

Gets or sets the progress Color.

[Visual Basic]
Public Property ProgressColor As Color
[C#]
public Color ProgressColor {get; set;}
[C++]
public: __property Color get_ProgressColor();
public: __property void set_ProgressColor(Color);
[JScript]
public function get ProgressColor() : Color;
public function set ProgressColor(Color);

Property Value

A Color represents the progress color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressFadeColor Property

ProgressBarColorStyle.ProgressFadeColor Property

Gets or sets the progress fade Color.

[Visual Basic]
Public Property ProgressFadeColor As Color
[C#]
public Color ProgressFadeColor {get; set;}
[C++]
public: __property Color get_ProgressFadeColor();
public: __property void set_ProgressFadeColor(Color);
[JScript]
public function get ProgressFadeColor() : Color;
public function set ProgressFadeColor(Color);

Property Value

A Color represents the progress fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ProgressBarColorStyle Methods

The methods of the ProgressBarColorStyle class are listed here. For a complete list of ProgressBarColorStyle class members, see the ProgressBarColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ProgressBarColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ProgressBarColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

ProgressBarColorStyle.Clone Method

Creates an exact copy of the current ProgressBarColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ProgressBarColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

ProgressBarColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ProgressBarColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

ProgressBarColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ProgressBarColorStyle Class | ProgressBarColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Class

Represents the drawing style for TextControl.

For a list of all members of this type, see TextControlColorStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.TextControlColorStyle

[Visual Basic]
Public Class TextControlColorStyle Implements
   ICloneable, IDisposable
[C#]
public class TextControlColorStyle : ICloneable, IDisposable
[C++]
public __gc class TextControlColorStyle : public ICloneable, IDisposable
[JScript]
public class TextControlColorStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Members

TextControlColorStyle overview

Public Constructors

public constructor TextControlColorStyle Constructor Initializes a new instance of the TextControlColorStyle class.

Public Properties

public property BackColor | Gets or sets the background Color
public property BorderColor | Gets or sets the border Color
public property TextColor | Gets or sets the text Color

Public Events

public event StyleChanged Occurs when the TextControlColorStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current TextControlColorStyle.
public method Dispose | Releases all resources used by this TextControlColorStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Constructor ()

Initializes a new instance of the TextControlColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TextControlColorStyle();
[C++]
public: TextControlColorStyle();
[JScript]
public function TextControlColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Properties

The properties of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color
public property BorderColor | Gets or sets the border Color
public property TextColor | Gets or sets the text Color

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BackColor Property

TextControlColorStyle.BackColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color);
[JScript]
public function get BackColor() : Color;
public function set BackColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

TextControlColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

TextControlColorStyle.TextColor Property

Gets or sets the text Color.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Methods

The methods of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current TextControlColorStyle.
public method Dispose | Releases all resources used by this TextControlColorStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

TextControlColorStyle.Clone Method

Creates an exact copy of the current TextControlColorStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new TextControlColorStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Dispose Method

TextControlColorStyle.Dispose Method

Releases all resources used by this TextControlColorStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

TextControlColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI.Controls infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the TextControlColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


OnStyleChanged Method

TextControlColorStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

TextControlColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControlColorStyle Events

The events of the TextControlColorStyle class are listed here. For a complete list of TextControlColorStyle class members, see the TextControlColorStyle Members topic.

Public Events

public event StyleChanged Occurs when the TextControlColorStyle changes.

See Also

TextControlColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

TextControlColorStyle.StyleChanged Event

Occurs when the TextControlColorStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControlColorStyle Class | TextControlColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextControFormatStyle Members

TextControFormatStyle overview

Public Constructors

public constructor TextControFormatStyle Constructor Initializes a new instance of the TextControFormatStyle class.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the TextControFormatStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current TextControFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


TextControFormatStyle Constructor ()

Initializes a new instance of the TextControFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TextControFormatStyle();
[C++]
public: TextControFormatStyle();
[JScript]
public function TextControFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


TextControFormatStyle Properties

The properties of the TextControFormatStyle class are listed here. For a complete list of TextControFormatStyle class members, see the TextControFormatStyle Members topic.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Font Property

TextControFormatStyle.Font Property

Gets or sets the font used to display the control text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextAlign Property

TextControFormatStyle.TextAlign Property

Gets or sets the alignment of the text.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign { get; set; }
[C++]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(ContentAlignment);
[JScript]
public function get TextAlign() : ContentAlignment
public function set TextAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextControFormatStyle Methods

The methods of the TextControFormatStyle class are listed here. For a complete list of TextControFormatStyle class members, see the TextControFormatStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current TextControFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TextControFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

TextControFormatStyle.Clone Method

Creates an exact copy of the current TextControFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TextControFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

TextControFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TextControFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

TextControFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TextControFormatStyle Class | TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemColorStyle Class

Represents the style for drawing the tool item.

For a list of all members of this type, see ToolItemColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ToolItemColorStyle

[Visual Basic]
Public Class ToolItemColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ToolItemColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ToolItemColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ToolItemColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Members

ToolItemColorStyle overview

Public Constructors

public constructor ToolItemColorStyle Constructor Initializes a new instance of the ToolItemColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolItemColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Constructor ()

Initializes a new instance of the ToolItemColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemColorStyle();
[C++]
public: ToolItemColorStyle();
[JScript]
public function ToolItemColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemColorStyle Properties

The properties of the ToolItemColorStyle class are listed here. For a complete list of ToolItemColorStyle class members, see the ToolItemColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ForeColor | Gets or sets the color used to draw the button graphics.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

ToolItemColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ForeColor Property

ToolItemColorStyle.ForeColor Property

Gets or sets the color used to draw the tool item graphics.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color);
[JScript]
public function get ForeColor() : Color;
public function set ForeColor(Color);

Property Value

A Color represents the color used to draw the tool item graphics.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

ToolItemColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

ToolItemColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemColorStyle Methods

The methods of the ToolItemColorStyle class are listed here. For a complete list of ToolItemColorStyle class members, see the ToolItemColorStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolItemColorStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolItemColorStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

ToolItemColorStyle.Clone Method

Creates an exact copy of the current ToolItemColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ToolItemColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

ToolItemColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolItemColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

ToolItemColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemColorStyle Class | ToolItemColorStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Class

Represents the format style for tool items.

For a list of all members of this type, see ToolItemFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Controls.Style.ToolItemFormatStyle

[Visual Basic]
Public Class ToolItemFormatStyle Implements
   ICloneable, IDisposable
[C#]
public class ToolItemFormatStyle : ICloneable, IDisposable
[C++]
public __gc class ToolItemFormatStyle : public ICloneable, IDisposable
[JScript]
public class ToolItemFormatStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Members

ToolItemFormatStyle overview

Public Constructors

public constructor ToolItemFormatStyle Constructor Initializes a new instance of the ToolItemFormatStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the tool item content.
public property Font | Specifies at which case the tool item is visible.
public property ItemSpacing | Specifies the distance between tool items.

Public Events

public event StyleChanged Occurs when the ToolItemFormatStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current ToolItemFormatStyle.
public method Dispose | Releases all resources used by this ToolItemFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Constructor ()

Initializes a new instance of the ToolItemFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolItemFormatStyle();
[C++]
public: ToolItemFormatStyle();
[JScript]
public function ToolItemFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Properties

The properties of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property ContentSize | Specifies the size of the tool item content.
public property Font | Specifies at which case the tool item is visible.
public property ItemSpacing | Specifies the distance between tool items.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

ToolItemFormatStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ContentSize Property

ToolItemFormatStyle.ContentSize Property

Specifies the size of the tool item content.

[Visual Basic]
Public Property ContentSize As Size
[C#]
public Size ContentSize {get; set;}
[C++]
public: __property Size get_ContentSize();
public: __property void set_ContentSize(Size);
[JScript]
public function get ContentSize() : Size;
public function set ContentSize(Size);

Property Value

A Size represents the size of the tool item content.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Font Property

ToolItemFormatStyle.Font Property

Gets or sets the font used to display the tool item text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the tool item text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ItemSpacing Property

ToolItemFormatStyle.ItemSpacing Property

Specifies the distance between tool items.

[Visual Basic]
Public Property ItemSpacing As Integer
[C#]
public int ItemSpacing {get; set;}
[C++]
public: __property int get_ItemSpacing();
public: __property void set_ItemSpacing(int);
[JScript]
public function get ItemSpacing() : int;
public function set ItemSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolItemFormatStyle Methods

The methods of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current ToolItemFormatStyle.
public method Dispose | Releases all resources used by this ToolItemFormatStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

ToolItemFormatStyle.Clone Method

Creates an exact copy of the current ToolItemFormatStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ToolItemFormatStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

ToolItemFormatStyle.Dispose Method

Releases all resources used by this ToolItemFormatStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ToolItemFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolItemFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

ToolItemFormatStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ToolItemFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ToolItemFormatStyle Events

The events of the ToolItemFormatStyle class are listed here. For a complete list of ToolItemFormatStyle class members, see the ToolItemFormatStyle Members topic.

Public Events

public event StyleChanged Occurs when the ToolItemFormatStyle changes.

See Also

ToolItemFormatStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


StyleChanged Event

ToolItemFormatStyle.StyleChanged Event

Occurs when the ToolItemFormatStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemFormatStyle Class | ToolItemFormatStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Class

Represents the style for drawing and formatting the tool tip.

For a list of all members of this type, see ToolTipStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Controls.Style.ToolTipStyle

[Visual Basic]
Public Class ToolTipStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ToolTipStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ToolTipStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ToolTipStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Controls.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Members

ToolTipStyle overview

Public Constructors

public constructor ToolTipStyle Constructor Initializes a new instance of the ToolTipStyle class.

Public Properties

public property AutoPopDelay | Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the tool tip.
public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Font | Gets or sets the font used to display the tool tip text.
public property InitialDelay | Gets or sets the time that passes before the ToolTip appears.
public property TextColor | Gets or sets the Color of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolTipStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Constructor ()

Initializes a new instance of the ToolTipStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ToolTipStyle();
[C++]
public: ToolTipStyle();
[JScript]
public function ToolTipStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Properties

The properties of the ToolTipStyle class are listed here. For a complete list of ToolTipStyle class members, see the ToolTipStyle Members topic.

Public Properties

public property AutoPopDelay | Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Gets or sets an image used as a background texture for the tool tip.
public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Font | Gets or sets the font used to display the tool tip text.
public property InitialDelay | Gets or sets the time that passes before the ToolTip appears.
public property TextColor | Gets or sets the Color of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


AutoPopDelay Property

ToolTipStyle.AutoPopDelay Property

Gets or sets the period of time before the ToolTip is shown if the mouse cursor points over object with specified ToolTip text.

[Visual Basic]
Public Property AutoPopDelay As Integer
[C#]
public int AutoPopDelay {get; set;}
[C++]
public: __property int get_AutoPopDelay();
public: __property void set_AutoPopDelay(int);
[JScript]
public function get AutoPopDelay() : int;
public function set AutoPopDelay(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BackImage Property

ToolTipStyle.BackImage Property

Gets or sets an image used as a background texture for the tool tip.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a background texture for the tool tip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderColor Property

ToolTipStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerRadius Property

ToolTipStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


BorderCornerShape Property

ToolTipStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Font Property

ToolTipStyle.Font Property

Gets or sets the font used to display the tool tip text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the tool tip text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


InitialDelay Property

ToolTipStyle.InitialDelay Property

Gets or sets the time that passes before the ToolTip appears.

[Visual Basic]
Public Property InitialDelay As Integer
[C#]
public int InitialDelay {get; set;}
[C++]
public: __property int get_InitialDelay();
public: __property void set_InitialDelay(int);
[JScript]
public function get InitialDelay() : int;
public function set InitialDelay(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextColor Property

ToolTipStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextRendering Property

ToolTipStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


TextShadowColor Property

ToolTipStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


ToolTipStyle Methods

The methods of the ToolTipStyle class are listed here. For a complete list of ToolTipStyle class members, see the ToolTipStyle Members topic.

Public Methods

public method Clone | Overridden. Creates an exact copy of the current ToolTipStyle.
public method Reset | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ToolTipStyle Class | LidorSystems.IntegralUI.Controls.Style Namespace


Clone Method

ToolTipStyle.Clone Method

Creates an exact copy of the current ToolTipStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ToolTipStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


IsStyleChanged Method

ToolTipStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ToolTipStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


Reset Method

ToolTipStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolTipStyle Class | ToolTipStyle Members | LidorSystems.IntegralUI.Controls.Style Namespace


LidorSystems.IntegralUI.Lists

LidorSystems.IntegralUI.Lists Namespace

Classes

Class | Description
ListBase | Provides a common implementation of members for list controls.
ListBaseItem | Provides a common implementation of members for list item objects.
TreeNode | A class representing the nodes in the TreeView control.
TreeView | Displays a hierarchical collection of TreeNode objects.

Enumerations

Delegate | Description
ColumnContentType | Enumerator used to determine the type of column content.
ColumnFixedType | Enumerator used to determine the which side the column is fixed.
ComparerObjectType | Enumerator used to determine the type of objects in IComparer derived class.
ContentControlVisibility | Enumerator used to determine the visibility of control contained in some object.
DropMarkerType | Enumerator used to determine the type of items ordering marker during drag-and-drop operation.
FilterMatchCriteria | Enumerator used to determine the criteria by which items are filtered.
FilterMode | Enumerator used to determine how values used for filtering are combined.
ItemFixedType | Enumerator used to determine the side at which the item is fixed in its parent control.
KeySearchMode | Enumerator used to determine how items are drawn.
ListItemHighlightType | Enumerator used to determine how items are drawn.
ListItemMoveDirection | Enumerator used to determine the direction in which the item will be moved.
ListItemType | Enumerator used to determine the look and functionality of the item.
ListSearchCriteria | Enumerator used to determine the search criteria for the items.
ListViewAppearance | Enumerator used to specify how list items are displayed in a ListView control.
ListViewGroupDrawMode | Enumerator used to determine how the group background is drawed.
ScrollMode | Enumerator used to determine the search criteria for the tree nodes.
TreeNodeDisplayPosition | Enumerator used to determine whether the node will be placed above or below its parent node.
TreeNodeMoveDirection | Enumerator used to determine the direction in which the TreeNode will be moved.


ListBase Class

Provides a common implementation of members for list controls.

For a list of all members of this type, see ListBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.Lists.ListBase
LidorSystems.IntegralUI.Lists.ListBox
LidorSystems.IntegralUI.Lists.ListView
LidorSystems.IntegralUI.Lists.TreeListView
LidorSystems.IntegralUI.Lists.TreeView

[Visual Basic]
MustInherit Public Class ListBase
   Inherits Control
[C#]
public abstract class ListBase : Control
[C++]
public __gc __abstract class ListBase : public Control
[JScript]
public abstract class ListBase extends Control

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ListBase Members

ListBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ControlBase) | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSelectionCheck | Determines whether the item check box is altered during item selection.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property ApplyFocusStyle | Determines whether the focused style is in use. Best used during multiple selection.
public property BackgroundProcessStyle | Gets or sets the drawing and format style of the form displayed during execution of background process.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxes | Gets or sets a value indicating whether check box is displayed in front of the item in the list control.
public property CheckBoxStyle | Gets or sets the drawing style of the item check box.
public property CheckMode | Determines whether the item check box will have two or three states.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from ControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode (inherited from ControlBase) | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder (inherited from ControlBase) | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect (inherited from ControlBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ControlBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from ControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property LabelEdit | Gets or sets a value indicating whether the text of the item can be edited.
public property LabelEditStyle | Gets or sets the drawing style of the label edit control.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property PreserveCheckState | Gets or sets a value indicating whether the item preserves their CheckState property value unchanged.
public property PreserveSelection | Gets or sets a value indicating whether the items preserves their Selected property value unchanged.
public property PreserveVisibility | Gets or sets a value indicating whether the items preserves their Visible property value unchanged.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property ScrollMode | Specifies the method by which control content is scrolled.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a item is selected.
public property SelectionMode | Gets or sets the method in which items are selected in the list control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowProcessProgress | Determines whether a Form is shown displaying an information of the current process progress.
public property ShowStateImages | Gets or sets a value indicating whether item's state image (flag) is visible.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property StateImageList | Gets or sets the ImageList that contains the Image objects used to represent different states of the items.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from ControlBase) | Overridden. Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from ControlBase) | Overridden. Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WordWrap | Determines whether the item content objects will be automatically divided in multiple lines.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EndProcess | Ends a background process which can be activated during loading/updating of the list.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from ControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
protected method IsHScrollVisible | Check whether horizontal scrollbar is visible in the list control.
protected method IsVScrollVisible | Check whether vertical scrollbar is visible in the list control.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
protected method ResetFilter | Resets the filter to its default values. By default the filter is not active.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ControlBase) | Resumes the painting of the control.
public method ResumeUpdate (inherited from ControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetFilter | Sets the filter with specified attributes for values, matching criteria, combination mode and exact or prefix match.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Sorts the items in the list control.
protected method StartAnimation | Starts an animation of animated gifs contained in the item.
protected method StartProcess | Starts a background process which displays a Form that shows information about process progress during loading/updating of the list.
protected method StopAnimation | Stops the animation of animated gifs contained in the item.
protected method StopFadingEffect | Stops the fading of items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ControlBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate (inherited from ControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateCurrentView | Updates only the layout of objects present in current display area of the control.
protected method UpdateLayout (inherited from ControlBase) | Update layout logic of the control.
protected method UpdateProcess | Updates the current progress of an active background process started during loading/updating of the list.

Public Events

public event AfterCheck | Occurs after the item's check box is checked.
public event AfterLabelEdit | Occurs after the item text is edited.
public event AfterSelect | Occurs after the item is selected.
public event BeforeCheck | Occurs before the item's check box is checked.
public event BeforeLabelEdit | Occurs before the item text is edited.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemObjectClicked (inherited from ControlBase) | Occurs after the user clicks an custom object (placed with XML encoding) in the item space.
public event ItemObjectClicking (inherited from ControlBase) | Occurs before the user clicks an custom object (placed with XML encoding) in the item space.
public event ItemSelectionChanged | Occurs when selected state of the item has changed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollBarVisibilityChanged | Occurs when visibility of horizontal or vertical scrollbar has changed.
public event ScrollBarVisibilityChanged | Occurs when visibility of horizontal or vertical scrollbar has changed.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SelectionModeChanged | Occurs when SelectionMode property changes its value.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterCheck | Raises the AfterCheck event.
protected method OnAfterLabelEdit | Raises the AfterLabelEdit event.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeCheck | Raises the BeforeCheck event.
protected method OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemObjectClicked (inherited from ControlBase) | Raises the ItemObjectClicked event.
protected method OnItemObjectClicking (inherited from ControlBase) | Raises the ItemObjectClicking event.
protected method OnItemSelectionChanged | Raises the ItemSelectionChanged event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollBarVisibilityChanged | Raises the ScrollBarVisibilityChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListBase Class | LidorSystems.IntegralUI.Lists Namespace


ListBase Properties

The properties of the ListBase class are listed here. For a complete list of ListBase class members, see the ListBase Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ControlBase) | Determines whether objects from the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSelectionCheck | Determines whether the item check box is altered during item selection.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property ApplyFocusStyle | Determines whether the focused style is in use. Best used during multiple selection.
public property BackgroundProcessStyle | Gets or sets the drawing and format style of the form displayed during execution of background process.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxes | Gets or sets a value indicating whether check box is displayed in front of the item in the list control.
public property CheckBoxStyle | Gets or sets the drawing style of the item check box.
public property CheckMode | Determines whether the item check box will have two or three states.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle (inherited from ControlBase) | Gets or sets the drawing style of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property ComparerObjectType | Gets or sets the type of objects in IComparer derived class.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContentPanel | Returns the InnerPanel object which holds the content of the list control.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode (inherited from ControlBase) | Gets or sets the type of drag-and-drop operation.
public property DragDropReorder (inherited from ControlBase) | Determines whether reordering of items is allowed during drag&drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property FadingEffect (inherited from ControlBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ControlBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle (inherited from ControlBase) | Gets or sets the format style of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HideSelection | Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HoverSelection | Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the item.
public property ImageList | Gets or sets the ImageList that contains the Image objects used by the items.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property ItemHighlightType | Gets or sets the value indicating how the item is drawn.
public property KeySearchMode | Specifies the search method for an item when key is pressed.
public property LabelEdit | Gets or sets a value indicating whether the text of the item can be edited.
public property LabelEditStyle | Gets or sets the drawing style of the label edit control.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property ListItemSorter | Gets or sets the IComparer class used to sort the items in list control.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property PreserveCheckState | Gets or sets a value indicating whether the item preserves their CheckState property value unchanged.
public property PreserveSelection | Gets or sets a value indicating whether the items preserves their Selected property value unchanged.
public property PreserveVisibility | Gets or sets a value indicating whether the items preserves their Visible property value unchanged.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the list control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property ScrollMode | Specifies the method by which control content is scrolled.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a item is selected.
public property SelectionMode | Gets or sets the method in which items are selected in the list control.
public property ShowDropMarker | Determines whether the drop marker is shown during drag-drop operation.
public property ShowProcessProgress | Determines whether a Form is shown displaying an information of the current process progress.
public property ShowStateImages | Gets or sets a value indicating whether item's state image (flag) is visible.
public property ShowToolTips | Gets or sets a value indicating whether item tooltip is shown.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property Sorting | Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.
public property StateImageList | Gets or sets the ImageList that contains the Image objects used to represent different states of the items.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property ToolTipStyle | Gets or sets the drawing style of the scroll bars in the list control.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseTheme (inherited from ControlBase) | Overridden. Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisualStyle (inherited from ControlBase) | Overridden. Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage | Specifies the WatermarkImage object to use as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.
public property WordWrap | Determines whether the item content objects will be automatically divided in multiple lines.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

ListBase Class | LidorSystems.IntegralUI.Lists Namespace


AllowSelectionCheck Property

ListBase.AllowSelectionCheck Property

Determines whether the item check box is altered during item selection.

[Visual Basic]
Public Property AllowSelectionCheck As Boolean
[C#]
public bool AllowSelectionCheck { get; set; }
[C++]
public: __property bool get_AllowSelectionCheck();
public: __property void set_AllowSelectionCheck(bool );
[JScript]
public function get AllowSelectionCheck() : bool
public function set AllowSelectionCheck(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ApplyFocusStyle Property

ListBase.ApplyFocusStyle Property

Determines whether the focused style is in use. Best used during multiple selection.

[Visual Basic]
Public Property ApplyFocusStyle As Boolean
[C#]
public bool ApplyFocusStyle { get; set; }
[C++]
public: __property bool get_ApplyFocusStyle();
public: __property void set_ApplyFocusStyle(bool );
[JScript]
public function get ApplyFocusStyle() : bool
public function set ApplyFocusStyle(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


BackgroundProcessStyle Property

ListBase.BackgroundProcessStyle Property

Gets or sets the drawing and format style of the form displayed during execution of background process.

[Visual Basic]
Public Property BackgroundProcessStyle As BackgroundProcessStyle
[C#]
public BackgroundProcessStyle BackgroundProcessStyle {get; set;}
[C++]
public: __property BackgroundProcessStyle get_BackgroundProcessStyle();
public: __property void set_BackgroundProcessStyle(BackgroundProcessStyle);
[JScript]
public function get BackgroundProcessStyle() : BackgroundProcessStyle;
public function set BackgroundProcessStyle(BackgroundProcessStyle);

Property Value

The BackgroundProcessStyle assigned to the list control used for the form displayed during execution of background process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxes Property

ListBase.CheckBoxes Property

Gets or sets a value indicating whether check box is displayed in front of the item in the list control.

[Visual Basic]
Public Property CheckBoxes As Boolean
[C#]
public bool CheckBoxes { get; set; }
[C++]
public: __property bool get_CheckBoxes();
public: __property void set_CheckBoxes(bool );
[JScript]
public function get CheckBoxes() : bool
public function set CheckBoxes(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxStyle Property

ListBase.CheckBoxStyle Property

Gets or sets the drawing style of the item check box.

[Visual Basic]
Public Property CheckBoxStyle As CheckButtonBoxStyle
[C#]
public CheckButtonBoxStyle CheckBoxStyle {get; set;}
[C++]
public: __property CheckButtonBoxStyle get_CheckBoxStyle();
public: __property void set_CheckBoxStyle(CheckButtonBoxStyle);
[JScript]
public function get CheckBoxStyle() : CheckButtonBoxStyle;
public function set CheckBoxStyle(CheckButtonBoxStyle);

Property Value

The CheckButtonBoxStyle assigned to the list control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


CheckMode Property

ListBase.CheckMode Property

Determines whether the item check box will have two or three states.

[Visual Basic]
Public Property CheckMode As CheckMode
[C#]
public CheckMode CheckMode {get; set;}
[C++]
public: __property CheckMode get_CheckMode();
public: __property void set_CheckMode(CheckMode);
[JScript]
public function get CheckMode() : CheckMode;
public function set CheckMode(CheckMode);

Property Value

The CheckMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ComparerObjectType Property

ListBase.ComparerObjectType Property

Gets or sets the type of objects in IComparer derived class.

[Visual Basic]
Public Property ComparerObjectType As ComparerObjectType
[C#]
public ComparerObjectType ComparerObjectType {get; set;}
[C++]
public: __property ComparerObjectType get_ComparerObjectType();
public: __property void set_ComparerObjectType(ComparerObjectType);
[JScript]
public function get ComparerObjectType() : ComparerObjectType;
public function set ComparerObjectType(ComparerObjectType);

Property Value

The ComparerObjectType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ContentPanel Property

ListBase.ContentPanel Property

Returns the InnerPanel object which holds the content of the list control.

[Visual Basic]
Public Property ContentPanel As InnerPanel
[C#]
public InnerPanel ContentPanel { get; set; }
[C++]
public: __property InnerPanel* get_ContentPanel();
public: __property void set_ContentPanel(InnerPanel*);
[JScript]
public function get ContentPanel() : InnerPanel
public function set ContentPanel(InnerPanel);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


HideSelection Property

ListBase.HideSelection Property

Gets or sets a value indicating whether the selected item remains highlighted even when the list control has lost the focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection { get; set; }
[C++]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(bool );
[JScript]
public function get HideSelection() : bool
public function set HideSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


HoverSelection Property

ListBase.HoverSelection Property

Gets or sets a value indicating whether the item can be selected while mouse cursor hovers over it.

[Visual Basic]
Public Property HoverSelection As Boolean
[C#]
public bool HoverSelection { get; set; }
[C++]
public: __property bool get_HoverSelection();
public: __property void set_HoverSelection(bool );
[JScript]
public function get HoverSelection() : bool
public function set HoverSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ImageIndex Property

ListBase.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ImageList Property

ListBase.ImageList Property

Gets or sets the ImageList that contains the Image objects used by the ListBaseItems.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList*);
[JScript]
public function get ImageList() : ImageList;
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ItemHighlightType Property

ListBase.ItemHighlightType Property

Gets or sets the value indicating how the item is drawn.

[Visual Basic]
Public Property ItemHighlightType As ListItemHighlightType
[C#]
public ListItemHighlightType ItemHighlightType {get; set;}
[C++]
public: __property ListItemHighlightType get_ItemHighlightType();
public: __property void set_ItemHighlightType(ListItemHighlightType);
[JScript]
public function get ItemHighlightType() : ListItemHighlightType;
public function set ItemHighlightType(ListItemHighlightType);

Property Value

The ListItemHighlightType assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


KeySearchMode Property

ListBase.KeySearchMode Property

Specifies the search method for an item when key is pressed.

[Visual Basic]
Public Property KeySearchMode As KeySearchMode
[C#]
public KeySearchMode KeySearchMode {get; set;}
[C++]
public: __property KeySearchMode get_KeySearchMode();
public: __property void set_KeySearchMode(KeySearchMode);
[JScript]
public function get KeySearchMode() : KeySearchMode;
public function set KeySearchMode(KeySearchMode);

Property Value

The KeySearchMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


LabelEdit Property

ListBase.LabelEdit Property

Gets or sets a value indicating whether the text of the item can be edited.

[Visual Basic]
Public Property LabelEdit As Boolean
[C#]
public bool LabelEdit {get; set;}
[C++]
public: __property bool get_LabelEdit();
public: __property void set_LabelEdit(bool);
[JScript]
public function get LabelEdit() : Boolean;
public function set LabelEdit(Boolean);

Property Value

true if the label text of the item can be edited; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


LabelEditStyle Property

ListBase.LabelEditStyle Property

Gets or sets the drawing style of the label edit control.

[Visual Basic]
Public Property LabelEditStyle As LabelEditStyle
[C#]
public LabelEditStyle LabelEditStyle {get; set;}
[C++]
public: __property LabelEditStyle get_LabelEditStyle();
public: __property void set_LabelEditStyle(LabelEditStyle);
[JScript]
public function get LabelEditStyle() : LabelEditStyle;
public function set LabelEditStyle(LabelEditStyle);

Property Value

The LabelEditStyle assigned to the list control used for all items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ListItemSorter Property

ListBase.ListItemSorter Property

Gets or sets the IComparer class used to sort the items in list control.

[Visual Basic]
Public Property ListItemSorter As IComparer
[C#]
public IComparer ListItemSorter {get; set;}
[C++]
public: __property IComparer get_ListItemSorter();
public: __property void set_ListItemSorter(IComparer);
[JScript]
public function get ListItemSorter() : IComparer;
public function set ListItemSorter(IComparer);

Property Value

The IComparer assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


PreserveCheckState Property

ListBase.PreserveCheckState Property

Gets or sets a value indicating whether the item preserves their CheckState property value unchanged.

[Visual Basic]
Public Property PreserveCheckState As Boolean
[C#]
public bool PreserveCheckState { get; set; }
[C++]
public: __property bool get_PreserveCheckState();
public: __property void set_PreserveCheckState(bool );
[JScript]
public function get PreserveCheckState() : bool
public function set PreserveCheckState(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


PreserveSelection Property

ListBase.PreserveSelection Property

Gets or sets a value indicating whether the items preserves their Selected property value unchanged.

[Visual Basic]
Public Property PreserveSelection As Boolean
[C#]
public bool PreserveSelection { get; set; }
[C++]
public: __property bool get_PreserveSelection();
public: __property void set_PreserveSelection(bool );
[JScript]
public function get PreserveSelection() : bool
public function set PreserveSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


PreserveVisibility Property

ListBase.PreserveVisibility Property

Gets or sets a value indicating whether the items preserves their Visible property value unchanged.

[Visual Basic]
Public Property PreserveVisibility As Boolean
[C#]
public bool PreserveVisibility { get; set; }
[C++]
public: __property bool get_PreserveVisibility();
public: __property void set_PreserveVisibility(bool );
[JScript]
public function get PreserveVisibility() : bool
public function set PreserveVisibility(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


Scrollable Property

ListBase.Scrollable Property

Gets or sets a value indicating whether the list control displays scroll bars when they are needed.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}
[C++]
public: __property bool get_Scrollable();
public: __property void set_Scrollable(bool);
[JScript]
public function get Scrollable() : Boolean;
public function set Scrollable(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ScrollBarStyle Property

ListBase.ScrollBarStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ScrollBarStyle As ScrollBarStyle
[C#]
public ScrollBarStyle ScrollBarStyle {get; set;}
[C++]
public: __property ScrollBarStyle get_ScrollBarStyle();
public: __property void set_ScrollBarStyle(ScrollBarStyle);
[JScript]
public function get ScrollBarStyle() : ScrollBarStyle;
public function set ScrollBarStyle(ScrollBarStyle);

Property Value

The ScrollBarStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ScrollMode Property

ListBase.ScrollMode Property

Specifies the method by which control content is scrolled.

[Visual Basic]
Public Property ScrollMode As ScrollMode
[C#]
public ScrollMode ScrollMode {get; set;}
[C++]
public: __property ScrollMode get_ScrollMode();
public: __property void set_ScrollMode(ScrollMode);
[JScript]
public function get ScrollMode() : ScrollMode;
public function set ScrollMode(ScrollMode);

Property Value

The ScrollMode assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


SelectedImageIndex Property

ListBase.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when a item is selected.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}
[C++]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(int);
[JScript]
public function get SelectedImageIndex() : int;
public function set SelectedImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


SelectionMode Property

ListBase.SelectionMode Property

Gets or sets the method in which items are selected in the list control.

[Visual Basic]
Public Overridable Property SelectionMode As SelectionMode
[C#]
public virtual SelectionMode SelectionMode {get; set;}
[C++]
public: virtual __property SelectionMode get_SelectionMode();
public: virtual __property void set_SelectionMode(SelectionMode);
[JScript]
public function get SelectionMode() : SelectionMode;
public function set SelectionMode(SelectionMode);

Property Value

One of the SelectionMode values. The default is SelectionMode.One.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ShowProcessProgress Property

ListBase.ShowProcessProgress Property

Determines whether a Form is shown displaying an information of the current process progress.

[Visual Basic]
Public Property ShowProcessProgress As Boolean
[C#]
public bool ShowProcessProgress { get; set; }
[C++]
public: __property bool get_ShowProcessProgress();
public: __property void set_ShowProcessProgress(bool );
[JScript]
public function get ShowProcessProgress() : bool
public function set ShowProcessProgress(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ShowStateImages Property

ListBase.ShowStateImages Property

Gets or sets a value indicating whether item's state image (flag) is visible.

[Visual Basic]
Public Property ShowStateImages As Boolean
[C#]
public bool ShowStateImages { get; set; }
[C++]
public: __property bool get_ShowStateImages();
public: __property void set_ShowStateImages(bool );
[JScript]
public function get ShowStateImages() : bool
public function set ShowStateImages(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ShowToolTips Property

ListBase.ShowToolTips Property

Gets or sets a value indicating whether item tooltip is shown.

[Visual Basic]
Public Property ShowToolTips As Boolean
[C#]
public bool ShowToolTips { get; set; }
[C++]
public: __property bool get_ShowToolTips();
public: __property void set_ShowToolTips(bool );
[JScript]
public function get ShowToolTips() : bool
public function set ShowToolTips(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


Sorting Property

ListBase.Sorting Property

Gets or sets the sort order for items in the list control. You must specify the item's or subitem's SortTag property. Applies only during run-time.

[Visual Basic]
Public Property Sorting As SortOrder
[C#]
public SortOrder Sorting {get; set;}
[C++]
public: __property SortOrder get_Sorting();
public: __property void set_Sorting(SortOrder);
[JScript]
public function get Sorting() : SortOrder;
public function set Sorting(SortOrder);

Property Value

The SortOrder assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StateImageList Property

ListBase.StateImageList Property

Gets or sets the ImageList that contains the Image objects used to represent different states of the ListBaseItems.

[Visual Basic]
Public Property StateImageList As ImageList
[C#]
public ImageList StateImageList {get; set;}
[C++]
public: __property ImageList* get_StateImageList();
public: __property void set_StateImageList(ImageList*);
[JScript]
public function get StateImageList() : ImageList;
public function set StateImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ToolTipStyle Property

ListBase.ToolTipStyle Property

Gets or sets the drawing style of the scroll bars in the list control.

[Visual Basic]
Public Property ToolTipStyle As ToolTipStyle
[C#]
public ToolTipStyle ToolTipStyle {get; set;}
[C++]
public: __property ToolTipStyle get_ToolTipStyle();
public: __property void set_ToolTipStyle(ToolTipStyle);
[JScript]
public function get ToolTipStyle() : ToolTipStyle;
public function set ToolTipStyle(ToolTipStyle);

Property Value

The ToolTipStyle assigned to the list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


UseTheme Property

ListBase.UseTheme Property

Overridden. Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Overloads Overrides Property UseTheme As Boolean
[C#]
public override bool UseTheme { get; set; }
[C++]
public: override __property bool get_UseTheme();
 public:
override __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


VisualStyle Property

ListBase.VisualStyle Property

Overridden. Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Overloads Overrides Property VisualStyle As VisualStyle
[C#]
public override VisualStyle VisualStyle {get; set;}
[C++]
public: override __property VisualStyle get_VisualStyle();
public: override __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


WatermarkImage Property

ListBase.WatermarkImage Property

Specifies the WatermarkImage object to use as a watermark.

[Visual Basic]
Public Property WatermarkImage As WatermarkImage
[C#]
public WatermarkImage WatermarkImage { get; set; }
[C++]
public: __property WatermarkImage* get_WatermarkImage();
public: __property void set_WatermarkImage(WatermarkImage*);
[JScript]
public function get WatermarkImage() : WatermarkImage
public function set WatermarkImage(WatermarkImage);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


WordWrap Property

ListBase.WordWrap Property

Determines whether the item content objects will be automatically divided in multiple lines.

[Visual Basic]
Public Property WordWrap As Boolean
[C#]
public bool WordWrap { get; set; }
[C++]
public: __property bool get_WordWrap();
public: __property void set_WordWrap(bool );
[JScript]
public function get WordWrap() : bool
public function set WordWrap(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ListBase Methods

The methods of the ListBase class are listed here. For a complete list of ListBase class members, see the ListBase Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
protected method EndProcess | Ends a background process which can be activated during loading/updating of the list.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetClientRect (inherited from ControlBase) | Returns the client rectangle of the control.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
protected method GetDropPos | Returns the position at which item would be inserted in the item collection, during drag&drop operation.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
protected method GetScrollPos | Retrieves the current position of the horizontal and vertical scrollbar thumb.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
protected method IsHScrollVisible | Check whether horizontal scrollbar is visible in the list control.
protected method IsVScrollVisible | Check whether vertical scrollbar is visible in the list control.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
protected method ResetFilter | Resets the filter to its default values. By default the filter is not active.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ControlBase) | Resumes the painting of the control.
public method ResumeUpdate (inherited from ControlBase) | Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
protected method SetFilter | Sets the filter with specified attributes for values, matching criteria, combination mode and exact or prefix match.
protected method SetScrollPos | Sets the position of the horizontal and vertical scroll bar thumb.
public method Show (inherited from Control) | Displays the control to the user.
protected method Sort | Sorts the items in the list control.
protected method StartAnimation | Starts an animation of animated gifs contained in the item.
protected method StartProcess | Starts a background process which displays a Form that shows information about process progress during loading/updating of the list.
protected method StopAnimation | Stops the animation of animated gifs contained in the item.
protected method StopFadingEffect | Stops the fading of items in the list control.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ControlBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate (inherited from ControlBase) | Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateCurrentView | Updates only the layout of objects present in current display area of the control.
protected method UpdateLayout (inherited from ControlBase) | Update layout logic of the control.
protected method UpdateProcess | Updates the current progress of an active background process started during loading/updating of the list.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterCheck | Raises the AfterCheck event.
protected method OnAfterLabelEdit | Raises the AfterLabelEdit event.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeCheck | Raises the BeforeCheck event.
protected method OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnItemDrag | Raises the ItemDrag event.
protected method OnItemMouseHover | Raises the ItemMouseHover event.
protected method OnItemObjectClicked (inherited from ControlBase) | Raises the ItemObjectClicked event.
protected method OnItemObjectClicking (inherited from ControlBase) | Raises the ItemObjectClicking event.
protected method OnItemSelectionChanged | Raises the ItemSelectionChanged event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnScrollBarVisibilityChanged | Raises the ScrollBarVisibilityChanged event.
protected method OnScrollPosChanged | Raises the ScrollPosChanged event.
protected method OnSelectionModeChanged | Raises the SelectionModeChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

ListBase Class | LidorSystems.IntegralUI.Lists Namespace


Dispose Method

ListBase.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


EndProcess() Method

ListBase.EndProcess() Method

Ends a background process which can be activated during loading/updating of the list.

[Visual Basic]
Public Sub EndProcess()
[C#]
public void EndProcess();
[C++]
 public: void * EndProcess();
[JScript]
public function EndProcess() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


GetDropPos (ListBaseItem, Point) Method

ListBase.GetDropPos (ListBaseItem, Point) Method

Returns the position at which item would be inserted in the item collection, during drag&drop operation.

[Visual Basic]
Overloads Public Function GetDropPos( _
   ByVal item As ListBaseItem _
   ByVal mousePos As Point _
) As Integer
[C#]
public int GetDropPos(
   ListBaseItem item
   Point mousePos
);
[C++]
public: int GetDropPos(
   ListBaseItem item
   Point mousePos
);
[JScript]
public function GetDropPos(
   item : ListBaseItem
   mousePos : Point
) : int;

Parameters

item
The ListBaseItem that is currently targeted.
mousePos
The Point which represents the mouse cursor, in client coordinates.

Return Value

The index at which the dropped item would be inserted in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


GetScrollPos Method

ListBase.GetScrollPos Method

Retrieves the current position of the horizontal and vertical scrollbar thumb.

[Visual Basic]
Overloads Public Function GetScrollPos() As Point
[C#]
public Point GetScrollPos();
[C++]
public: Point* GetScrollPos();
[JScript]
public function GetScrollPos() : Point;

Return Value

The current position of the horizontal and vertical scrollbar thumb.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


IsHScrollVisible Method

ListBase.IsHScrollVisible Method

Check whether horizontal scrollbar is visible in the list control.

[Visual Basic]
Public Function IsHScrollVisible() As Boolean
[C#]
public bool IsHScrollVisible();
[C++]
public: bool IsHScrollVisible();
[JScript]
public function IsHScrollVisible() : Boolean;

Return Value

True if horizontal scrollbar is visible, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


IsVScrollVisible Method

ListBase.IsVScrollVisible Method

Check whether vertical scrollbar is visible in the list control.

[Visual Basic]
Public Function IsVScrollVisible() As Boolean
[C#]
public bool IsVScrollVisible();
[C++]
public: bool IsVScrollVisible();
[JScript]
public function IsVScrollVisible() : Boolean;

Return Value

True if vertical scrollbar is visible, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterCheck Method

ListBase.OnAfterCheck Method

Raises the AfterCheck event.

[Visual Basic]
Protected Overridable Sub OnAfterCheck( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterCheck(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterCheck(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterCheck(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterLabelEdit Method

ListBase.OnAfterLabelEdit Method

Raises the AfterLabelEdit event.

[Visual Basic]
Protected Overridable Sub OnAfterLabelEdit( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterLabelEdit(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterLabelEdit(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterLabelEdit(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterSelect Method

ListBase.OnAfterSelect Method

Raises the AfterSelect event.

[Visual Basic]
Protected Overridable Sub OnAfterSelect( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterSelect(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterSelect(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeCheck Method

ListBase.OnBeforeCheck Method

Raises the BeforeCheck event.

[Visual Basic]
Protected Overridable Sub OnBeforeCheck( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeCheck(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeCheck(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeCheck(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeLabelEdit Method

ListBase.OnBeforeLabelEdit Method

Raises the BeforeLabelEdit event.

[Visual Basic]
Protected Overridable Sub OnBeforeLabelEdit( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeLabelEdit(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeLabelEdit(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeLabelEdit(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeSelect Method

ListBase.OnBeforeSelect Method

Raises the BeforeSelect event.

[Visual Basic]
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeSelect(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeSelect(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeSelect(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnItemDrag Method

ListBase.OnItemDrag Method

Raises the ItemDrag event.

[Visual Basic]
Protected Overridable Sub OnItemDrag( _
   ByVal e As ItemDragEventArgs _
)
[C#]
protected virtual void OnItemDrag(
   ItemDragEventArgs e
);
[C++]
protected: virtual void OnItemDrag(
   ItemDragEventArgs* e
);
[JScript]
protected function OnItemDrag(
   e : ItemDragEventArgs
);

Parameters

e
A ItemDragEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnItemMouseHover Method

ListBase.OnItemMouseHover Method

Raises the ItemMouseHover event.

[Visual Basic]
Protected Overridable Sub OnItemMouseHover( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemMouseHover(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemMouseHover(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemMouseHover(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnItemSelectionChanged Method

ListBase.OnItemSelectionChanged Method

Raises the ItemSelectionChanged event.

[Visual Basic]
Protected Overridable Sub OnItemSelectionChanged( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnItemSelectionChanged(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnItemSelectionChanged(
   ObjectEventArgs* e
);
[JScript]
protected function OnItemSelectionChanged(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnResize Method

ListBase.OnResize Method

This member overrides Control.OnResize.

[Visual Basic]
Overrides Protected Sub OnResize( _
   ByVal e As EventArgs _
)
[C#]
protected override void OnResize(
   EventArgs e
);
[C++]
protected: void OnResize(
   EventArgs* e
);
[JScript]
protected override function OnResize(
   e : EventArgs
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnScrollBarVisibilityChanged Method

ListBase.OnScrollBarVisibilityChanged Method

Raises the ScrollBarVisibilityChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollBarVisibilityChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollBarVisibilityChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollBarVisibilityChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollBarVisibilityChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnScrollPosChanged Method

ListBase.OnScrollPosChanged Method

Raises the ScrollPosChanged event.

[Visual Basic]
Protected Overridable Sub OnScrollPosChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnScrollPosChanged(
   EventArgs e
);
[C++]
protected: virtual void OnScrollPosChanged(
   EventArgs* e
);
[JScript]
protected function OnScrollPosChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


OnSelectionModeChanged Method

ListBase.OnSelectionModeChanged Method

Raises the SelectionModeChanged event.

[Visual Basic]
Protected Overridable Sub OnSelectionModeChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnSelectionModeChanged(
   EventArgs e
);
[C++]
protected: virtual void OnSelectionModeChanged(
   EventArgs* e
);
[JScript]
protected function OnSelectionModeChanged(
   e : EventArgs
);

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ResetFilter Method

ListBase.ResetFilter Method

Resets the filter to its default values. By default the filter is not active.

[Visual Basic]
Public Sub ResetFilter()
[C#]
public void ResetFilter();
[C++]
 public: void * ResetFilter();
[JScript]
public function ResetFilter() ;

Remarks

Use this method to reset the filter attributes to its default state.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


SetFilter Method

ListBase.SetFilter Method

Sets the filter with specified attributes for values, matching criteria, combination mode and exact or prefix match.

[Visual Basic]
 Public Sub SetFilter( _
   ByVal values() As string _
   ByVal criteria As FilterMatchCriteria _
   ByVal mode As FilterMode _
   ByVal isPrefixSearch As Boolean _
)
[C#]
public void SetFilter(
   string[] values
   FilterMatchCriteria criteria
   FilterMode mode
   bool isPrefixSearch
);
[C++]
public: void SetFilter(
   string* values[]
   FilterMatchCriteria criteria
   FilterMode mode
   bool isPrefixSearch
);
[JScript]
public function SetFilter(
   values : string[]
   criteria : FilterMatchCriteria
   mode : FilterMode
   isPrefixSearch : Boolean
);

Parameters

values
An array of type string that contains the values used for filtering.
criteria
A criteria by which objects are filtered.
mode
Determines how values used for filtering are combined.
isPrefixSearch
The Boolean which determines whether exact or prefix match is applied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


SetScrollPos (Point) Method

ListBase.SetScrollPos (Point) Method

Sets the position of the horizontal and vertical scroll bar thumb.

[Visual Basic]
 Public Sub SetScrollPos( _
   ByVal pt As Point _
)
[C#]
public void SetScrollPos(
   Point pt
);
[C++]
public: void SetScrollPos(
   Point pt
);
[JScript]
public function SetScrollPos(
   pt : Point
);

Parameters

pt
The Point at which the horizontal and vertical scroll bar thumb will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


Sort Method

ListBase.Sort Method

Sorts the items in the list control.

[Visual Basic]
Public Overridable Sub Sort()
[C#]
public virtual void Sort();
[C++]
 public: virtual void * Sort();
[JScript]
public function Sort() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartAnimation Method

ListBase.StartAnimation Method

Overload List

Starts an animation of animated gifs contained in the item.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item)
[C#] public StartAnimation(ListBaseItem item);
[C++] public: StartAnimation(ListBaseItem* item);
[JScript] public function StartAnimation(ListBaseItem item);

Starts an animation of specified animated gif contained in the item.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item, Image img)
[C#] public StartAnimation(ListBaseItem item, Image img);
[C++] public: StartAnimation(ListBaseItem* item, Image* img);
[JScript] public function StartAnimation(ListBaseItem item, Image img);

Starts an animation of specified animated gif which is created by XML tags in item content. The image is determined by its id.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item, String id)
[C#] public StartAnimation(ListBaseItem item, String id);
[C++] public: StartAnimation(ListBaseItem* item, String* id);
[JScript] public function StartAnimation(ListBaseItem item, String id);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartAnimation (ListBaseItem) Method

ListBase.StartAnimation (ListBaseItem) Method

Starts an animation of animated gifs contained in the item.

[Visual Basic]
Public  Sub StartAnimation( _
   ByVal item As ListBaseItem _
)
[C#]
public  void StartAnimation(
   ListBaseItem item
);
[C++]
public: void StartAnimation(
   ListBaseItem* item
);
[JScript]
public function StartAnimation(
   item : ListBaseItem
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartAnimation (ListBaseItem, Image) Method

ListBase.StartAnimation (ListBaseItem, Image) Method

Starts an animation of specified animated gif contained in the item.

[Visual Basic]
Public  Sub StartAnimation( _
   ByVal item As ListBaseItem _
   ByVal img As Image _
)
[C#]
public  void StartAnimation(
   ListBaseItem item
   Image img
);
[C++]
public: void StartAnimation(
   ListBaseItem* item
   Image* img
);
[JScript]
public function StartAnimation(
   item : ListBaseItem
   img : Image
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartAnimation (ListBaseItem, String) Method

ListBase.StartAnimation (ListBaseItem, String) Method

Starts an animation of specified animated gif which is created by XML tags in item content. The image is determined by its id.

[Visual Basic]
Public  Sub StartAnimation( _
   ByVal item As ListBaseItem _
   ByVal id As String _
)
[C#]
public  void StartAnimation(
   ListBaseItem item
   String id
);
[C++]
public: void StartAnimation(
   ListBaseItem* item
   String* id
);
[JScript]
public function StartAnimation(
   item : ListBaseItem
   id : String
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartProcess Method

ListBase.StartProcess Method

Overload List

Starts a background process which displays a Form that shows information about process progress during loading/updating of the list.

[Visual Basic] Public Sub StartProcess()
[C#] public StartProcess();
[C++] public: StartProcess();
[JScript] public function StartProcess();

Starts a background process which displays a Form that shows information about process progress during loading/updating of the list and sets the limit of progress units.

[Visual Basic] Public Sub StartProcess(Integer)
[C#] public StartProcess(int);
[C++] public: StartProcess(int);
[JScript] public function StartProcess(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartAnimation Method

ListBase.StartAnimation Method

Overload List

Stops the animation of animated gifs contained in the item.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item)
[C#] public StartAnimation(ListBaseItem item);
[C++] public: StartAnimation(ListBaseItem* item);
[JScript] public function StartAnimation(ListBaseItem item);

Stops the animation of specified animated gif contained in the item.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item, Image img)
[C#] public StartAnimation(ListBaseItem item, Image img);
[C++] public: StartAnimation(ListBaseItem* item, Image* img);
[JScript] public function StartAnimation(ListBaseItem item, Image img);

Stops the animation of specified animated gif which is created by XML tags in item content. The image is determined by its id.

[Visual Basic] Public Sub StartAnimation(ListBaseItem item, String id)
[C#] public StartAnimation(ListBaseItem item, String id);
[C++] public: StartAnimation(ListBaseItem* item, String* id);
[JScript] public function StartAnimation(ListBaseItem item, String id);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StopAnimation (ListBaseItem) Method

ListBase.StopAnimation (ListBaseItem) Method

Stops the animation of animated gifs contained in the item.

[Visual Basic]
Public  Sub StopAnimation( _
   ByVal item As ListBaseItem _
)
[C#]
public  void StopAnimation(
   ListBaseItem item
);
[C++]
public: void StopAnimation(
   ListBaseItem* item
);
[JScript]
public function StopAnimation(
   item : ListBaseItem
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StopAnimation (ListBaseItem, Image) Method

ListBase.StopAnimation (ListBaseItem, Image) Method

Stops the an animation of specified animated gif contained in the item.

[Visual Basic]
Public  Sub StopAnimation( _
   ByVal item As ListBaseItem _
   ByVal img As Image _
)
[C#]
public  void StopAnimation(
   ListBaseItem item
   Image img
);
[C++]
public: void StopAnimation(
   ListBaseItem* item
   Image* img
);
[JScript]
public function StopAnimation(
   item : ListBaseItem
   img : Image
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StopAnimation (ListBaseItem, String) Method

ListBase.StopAnimation (ListBaseItem, String) Method

Stops the animation of specified animated gif which is created by XML tags in item content. The image is determined by its id.

[Visual Basic]
Public  Sub StopAnimation( _
   ByVal item As ListBaseItem _
   ByVal id As String _
)
[C#]
public  void StopAnimation(
   ListBaseItem item
   String id
);
[C++]
public: void StopAnimation(
   ListBaseItem* item
   String* id
);
[JScript]
public function StopAnimation(
   item : ListBaseItem
   id : String
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StopFadingEffect Method

ListBase.StopFadingEffect Method

Stops the fading of items in the list control.

[Visual Basic]
Public Overridable Sub StopFadingEffect()
[C#]
public virtual void StopFadingEffect();
[C++]
 public: virtual void * StopFadingEffect();
[JScript]
public function StopFadingEffect() ;

Remarks

Use this method to mannualy stop the fading of items in list control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


UpdateCurrentView Method

ListBase.UpdateCurrentView Method

Updates only the layout of objects present in current display area of the control.

[Visual Basic]
Public Overridable Sub UpdateCurrentView()
[C#]
public virtual void UpdateCurrentView();
[C++]
 public: virtual void * UpdateCurrentView();
[JScript]
public function UpdateCurrentView() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


UpdateProcess (Integer) Method

ListBase.UpdateProcess (Integer) Method

Updates the current progress of an active background process started during loading/updating of the list.

[Visual Basic]
Public  Sub UpdateProcess( _
   ByVal progress As Integer _
)
[C#]
public  void UpdateProcess(
   int progress
);
[C++]
public: void UpdateProcess(
   int progress
);
[JScript]
public function UpdateProcess(
   progress : int
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ListBase Events

The events of the ListBase class are listed here. For a complete list of ListBase class members, see the ListBase Members topic.

Public Events

public event AfterCheck | Occurs after the item's check box is checked.
public event AfterLabelEdit | Occurs after the item text is edited.
public event AfterSelect | Occurs after the item is selected.
public event BeforeCheck | Occurs before the item's check box is checked.
public event BeforeLabelEdit | Occurs before the item text is edited.
public event BeforeSelect | Occurs before the item is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event ItemDrag | Occurs when the user begins dragging an item.
public event ItemMouseHover | Occurs when the mouse cursor hovers for some time over an item space.
public event ItemObjectClicked (inherited from ControlBase) | Occurs after the user clicks an custom object (placed with XML encoding) in the item space.
public event ItemObjectClicking (inherited from ControlBase) | Occurs before the user clicks an custom object (placed with XML encoding) in the item space.
public event ItemSelectionChanged | Occurs when selected state of the item has changed.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event ScrollBarVisibilityChanged | Occurs when visibility of horizontal or vertical scrollbar has changed.
public event ScrollBarVisibilityChanged | Occurs when visibility of horizontal or vertical scrollbar has changed.
public event ScrollPosChanged | Occurs when position of scrollbar has changed.
public event SelectionModeChanged | Occurs when SelectionMode property changes its value.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ListBase Class | LidorSystems.IntegralUI.Lists Namespace


AfterCheck Event

ListBase.AfterCheck Event

Occurs after the item's check box is checked.

[Visual Basic]
Public Event AfterCheck As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterCheck;
[C++]
public: __event ObjectEventHandler* AfterCheck;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


AfterLabelEdit Event

ListBase.AfterLabelEdit Event

Occurs after the item text is edited.

[Visual Basic]
Public Event AfterLabelEdit As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterLabelEdit;
[C++]
public: __event ObjectEventHandler* AfterLabelEdit;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


AfterSelect Event

ListBase.AfterSelect Event

Occurs after the item is selected.

[Visual Basic]
Public Event AfterSelect As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterSelect;
[C++]
public: __event ObjectEventHandler* AfterSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


BeforeCheck Event

ListBase.BeforeCheck Event

Occurs before the item's check box is checked.

[Visual Basic]
Public Event BeforeCheck As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeCheck;
[C++]
public: __event ObjectCancelEventHandler* BeforeCheck;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


BeforeLabelEdit Event

ListBase.BeforeLabelEdit Event

Occurs before the item text is edited.

[Visual Basic]
Public Event BeforeLabelEdit As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeLabelEdit;
[C++]
public: __event ObjectCancelEventHandler* BeforeLabelEdit;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


BeforeSelect Event

ListBase.BeforeSelect Event

Occurs before the item is selected.

[Visual Basic]
Public Event BeforeSelect As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeSelect;
[C++]
public: __event ObjectCancelEventHandler* BeforeSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ItemDrag Event

ListBase.ItemDrag Event

Occurs when the user begins dragging an item.

[Visual Basic]
Public Event ItemDrag As ItemDragEventHandler
[C#]
public event ItemDragEventHandler ItemDrag;
[C++]
public: __event ItemDragEventHandler* ItemDrag;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ItemDragEventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ItemMouseHover Event

ListBase.ItemMouseHover Event

Occurs when the mouse cursor hovers for some time over an item space.

[Visual Basic]
Public Event ItemMouseHover As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemMouseHover;
[C++]
public: __event ObjectEventHandler* ItemMouseHover;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ItemSelectionChanged Event

ListBase.ItemSelectionChanged Event

Occurs when selected state of the item has changed.

[Visual Basic]
Public Event ItemSelectionChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler ItemSelectionChanged;
[C++]
public: __event ObjectEventHandler* ItemSelectionChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ScrollBarVisibilityChanged Event

ListBase.ScrollBarVisibilityChanged Event

Occurs when visibility of horizontal or vertical scrollbar has changed.

[Visual Basic]
Public Event ScrollBarVisibilityChanged As EventHandler
[C#]
public event EventHandler ScrollBarVisibilityChanged;
[C++]
public: __event EventHandler* ScrollBarVisibilityChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ScrollPosChanged Event

ListBase.ScrollPosChanged Event

Occurs when position of scrollbar has changed.

[Visual Basic]
Public Event ScrollPosChanged As EventHandler
[C#]
public event EventHandler ScrollPosChanged;
[C++]
public: __event EventHandler* ScrollPosChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


SelectionModeChanged Event

ListBase.SelectionModeChanged Event

Occurs when SelectionMode property changes its value.

[Visual Basic]
Public Event SelectionModeChanged As EventHandler
[C#]
public event EventHandler SelectionModeChanged;
[C++]
public: __event EventHandler* SelectionModeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type EventHandler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Class

Provides a common implementation of members for list item objects.

For a list of all members of this type, see ListBaseItem Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Lists.ListBaseItem
LidorSystems.IntegralUI.Lists.ListBoxItem
LidorSystems.IntegralUI.Lists.ListViewItem
LidorSystems.IntegralUI.Lists.TreeListViewNode
LidorSystems.IntegralUI.Lists.TreeNode

[Visual Basic]

MustInherit Public Class ListItemBase
   Inherits LidorSystems.IntegralUI.ObjectBase
[C#]

public abstract class ListItemBase : LidorSystems.IntegralUI.ObjectBase
[C++]

public __gc __abstract class ListItemBase : public LidorSystems.IntegralUI.ObjectBase
[JScript]
public abstract

class ListItemBase extends LidorSystems.IntegralUI.ObjectBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Members

ListBaseItem overview

Public Constructors

public constructor ListBaseItem Constructor Initializes a new instance of the ListBaseItem class.

Public Properties

public property AllowImageAnimation | Determines whether item's images can be animated.
public property Bounds | Gets the bounds of the item.
public property CanSelect | Determines whether the item can be selected.
public property CheckBoxVisible | Gets or sets a value indicating whether check box is displayed next to the item in the list control.
public property Checked | Indicates whether the check box of the item is checked or unchecked.
public property CheckState | Gets or sets a value representing the current state of the item check box.
public property ContentObjects | Gets the collection of objects (text, image, hyperlinks, controls etc.) assigned to the current item.
public property Content | Specifies the content of the item. Can contain various XML tags to create custom rich content.
public property ContextMenu | Gets or sets the shortcut menu associated with this ListBaseItem.
public property Controls | Gets the collection of controls assigned to the current item. Used to enrich the item content. Used only with XML tags and along with Content property.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FlatIndex | Gets the flat position of the item in the item collection.
public property Focused | Gets a value indicating whether the item has the keyboard focus.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageList | Gets or sets the image list that contains Image objects used by the item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property ItemType | Determines the look and functionality of the item.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the item is in the selected state.
public property SelectedImage | Gets or sets the image displayed when the item is in selected state.
public property Selected | Gets or sets a value indicating whether the item is selected.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property StateImageIndex | Gets or sets the image list index value of the image used to display the custom state of the item.
public property StateImage | Gets or sets the image used to display the custom state of the item.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.
public property UnFormattedText | Gets the item text without formatting tags.
public property WordWrap | Determines whether the item content will be automatically divided in multiple lines.

Public Methods

public method BeginEdit | Initiates the editing of the item text.
public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EndEdit | Ends the editing of the item text.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetPreferredSize | Calculates and returns the size of the item space.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Determines whether item is visible in current visible parent control area.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListBaseItem Class | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Constructor

Initializes a new instance of the ListBaseItem class.

Overload List

Initializes a new instance of the ListBaseItem class.

[Visual Basic] Public Sub New()
[C#] public ListBaseItem();
[C++] public: ListBaseItem();
[JScript] public function ListBaseItem();

Initializes a new instance of the ListBaseItem class with the specified text.

[Visual Basic] Public Sub New(String)
[C#] public ListBaseItem(string);
[C++] public: ListBaseItem(String*);
[JScript] public function ListBaseItem(String);

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Constructor ()

Initializes a new instance of the ListBaseItem class.

[Visual Basic]
Public Sub New()
[C#]
public ListBaseItem();
[C++]
public: ListBaseItem();
[JScript]
public function ListBaseItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListBaseItem Class | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Constructor (String)

Initializes a new instance of the ListBaseItem class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ListBaseItem(
   string text
);
[C++]
public: ListBaseItem(
   String* text
);
[JScript]
public function ListBaseItem(
   text : String
);

Parameters

text
The text of the new object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListBaseItem Class | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Properties

The properties of the ListBaseItem class are listed here. For a complete list of ListBaseItem class members, see the ListBaseItem Members topic.

Public Properties

public property AllowImageAnimation | Determines whether item's images can be animated.
public property Bounds | Gets the bounds of the item.
public property CanSelect | Determines whether the item can be selected.
public property CheckBoxVisible | Gets or sets a value indicating whether check box is displayed next to the item in the list control.
public property Checked | Indicates whether the check box of the item is checked or unchecked.
public property CheckState | Gets or sets a value representing the current state of the item check box.
public property ContentObjects | Gets the collection of objects (text, image, hyperlinks, controls etc.) assigned to the current item.
public property Content | Specifies the content of the item. Can contain various XML tags to create custom rich content.
public property ContextMenu | Gets or sets the shortcut menu associated with this ListBaseItem.
public property Controls | Gets the collection of controls assigned to the current item. Used to enrich the item content. Used only with XML tags and along with Content property.
public property DisabledStyle | Gets or sets the drawing style of the disabled item.
public property Enabled (inherited from ObjectBase) | Gets or sets a value indicating whether the object can respond to user interaction.
public property FlatIndex | Gets the flat position of the item in the item collection.
public property Focused | Gets a value indicating whether the item has the keyboard focus.
public property FocusedStyle | Gets or sets the drawing style of the focused item.
public property FormatStyle | Gets or sets the format style of the item.
public property HoverStyle | Gets or sets the drawing style of the hovered item.
public property ImageIndex | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property ImageList | Gets or sets the image list that contains Image objects used by the item.
public property Image | Gets or sets the image displayed when the item is in normal state.
public property Index (inherited from ObjectBase) | Gets the position of the object in the object collection.
public property ItemType | Determines the look and functionality of the item.
public property Key (inherited from ObjectBase) | Gets or sets a string that uniquely identifies object in a collection.
public property NormalStyle | Gets or sets the default drawing style of the item.
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the item is in the selected state.
public property SelectedImage | Gets or sets the image displayed when the item is in selected state.
public property Selected | Gets or sets a value indicating whether the item is selected.
public property SelectedStyle | Gets or sets the drawing style of the selected item.
public property SortTag | Gets or sets the object that contains sorting data about the item.
public property State (inherited from ObjectBase) | Gets a value indicating the current state of the object.
public property StateImageIndex | Gets or sets the image list index value of the image used to display the custom state of the item.
public property StateImage | Gets or sets the image used to display the custom state of the item.
public property StyleFromParent | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ObjectBase) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ObjectBase) | Gets or sets the tag string of the object.
public property Text (inherited from ObjectBase) | Gets or sets the object text.
public property ToolTip | Gets or sets the item's tooltip text.
public property Visible (inherited from ObjectBase) | Gets or sets a value indicating whether the object is displayed.
public property UnFormattedText | Gets the item text without formatting tags.
public property WordWrap | Determines whether the item content will be automatically divided in multiple lines.

See Also

ListBaseItem Class | LidorSystems.IntegralUI.Lists Namespace


AllowImageAnimation Property

ListBaseItem.AllowImageAnimation Property

Determines whether item's images can be animated.

[Visual Basic]
Public Property AllowImageAnimation As Boolean
[C#]
public bool AllowImageAnimation {get; set;}
[C++]
public: __property bool get_AllowImageAnimation();
public: __property void set_AllowImageAnimation(bool);
[JScript]
public function get AllowImageAnimation() : Boolean;
public function set AllowImageAnimation(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Bounds Property

ListBaseItem.Bounds Property

Gets the bounds of the item.

[Visual Basic]
Public Overridable ReadOnly Property Bounds As Rectangle
[C#]
public virtual Rectangle Bounds {get;}
[C++]
public: virtual __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


CanSelect Property

ListBaseItem.CanSelect Property

Determines whether the item can be selected.

[Visual Basic]
Public Property CanSelect As Boolean
[C#]
public bool CanSelect {get; set;}
[C++]
public: __property bool get_CanSelect();
public: __property void set_CanSelect(bool);
[JScript]
public function get CanSelect() : Boolean;
public function set CanSelect(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxVisible Property

ListBaseItem.CheckBoxVisible Property

Gets or sets a value indicating whether check box is displayed next to the item in the list control.

[Visual Basic]
Public Property CheckBoxVisible As Boolean
[C#]
public bool CheckBoxVisible {get; set;}
[C++]
public: __property bool get_CheckBoxVisible();
public: __property void set_CheckBoxVisible(bool);
[JScript]
public function get CheckBoxVisible() : Boolean;
public function set CheckBoxVisible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Checked Property

ListBaseItem.Checked Property

Indicates whether the check box of the item is checked or unchecked.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}
[C++]
public: __property bool get_Checked();
public: __property void set_Checked(bool);
[JScript]
public function get Checked() : Boolean;
public function set Checked(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


CheckState Property

ListBaseItem.CheckState Property

Gets or sets a value representing the current state of the item check box.

[Visual Basic]
Public Property CheckState As CheckState
[C#]
public CheckState CheckState {get; set;}
[C++]
public: __property CheckState get_CheckState();
public: __property void set_CheckState(CheckState);
[JScript]
public function get CheckState() : CheckState;
public function set CheckState(CheckState);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Content Property

ListBaseItem.Content Property

Specifies the content of the item. Can contain various XML tags to create custom rich content.

[Visual Basic]
Public Overridable Property Content As String
[C#]
public virtual String Content {get; set;}
[C++]
public: virtual __property String* get_Content();
public: virtual __property void set_Content(String*);
[JScript]
public function get Content() : String;
public function set Content(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ContentObjects Property

ListBaseItem.ContentObjects Property

Gets the collection of objects (text, image, hyperlinks, controls etc.) assigned to the current item.

[Visual Basic]
Public ReadOnly Property ContentObjects As ContentObjectCollection
[C#]
public ContentObjectCollection ContentObjects {get;}
[C++]
public: __property ContentObjectCollection* get_ContentObjects();
[JScript]
public function get ContentObjects() : ContentObjectCollection;

Property Value

A ContentObjectCollection that represents the objects assigned to the current item. This collection is primary used for XML encoding. Internal use only.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ContextMenu Property

ListBaseItem.ContextMenu Property

Gets or sets the shortcut menu associated with this ListBaseItem.

[Visual Basic]
Public Overridable Property ContextMenu As ContextMenuStrip
[C#]
public virtual ContextMenuStrip ContextMenu {get; set;}
[C++]
public: __property virtual ContextMenuStrip* get_ContextMenu();
public: __property virtual void set_ContextMenu(ContextMenuStrip*);
[JScript]
public function get ContextMenu() : ContextMenuStrip;
public function set ContextMenu(ContextMenuStrip);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Controls Property

ListBaseItem.Controls Property

Gets the collection of controls assigned to the current item. Used to enrich the item content. Used only with XML tags and along with Content property.

[Visual Basic]
Public ReadOnly Property Controls As ObjectCollection
[C#]
public ObjectCollection Controls {get;}
[C++]
public: __property ObjectCollection* get_Controls();
[JScript]
public function get Controls() : ObjectCollection;

Property Value

A ObjectCollection that represents the controls assigned to the current item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


DisabledStyle Property

ListBaseItem.DisabledStyle Property

Gets or sets the drawing style of the disabled item.

[Visual Basic]
Public Property DisabledStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledStyle();
public: __property void set_DisabledStyle(ListItemColorStyle);
[JScript]
public function get DisabledStyle() : ListItemColorStyle;
public function set DisabledStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


FlatIndex Property

ListBaseItem.FlatIndex Property

Gets the flat position of the item in the item collection.

[Visual Basic]
Public ReadOnly Property FlatIndex As Integer
[C#]
public int FlatIndex {get;}
[C++]
public: __property int get_FlatIndex();
[JScript]
public function get FlatIndex() : int;

Property Value

A zero-based index value that represents the flat position of the item in the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Focused Property

ListBaseItem.Focused Property

Gets a value indicating whether the item has the keyboard focus.

[Visual Basic]
Public Overridable ReadOnly Property Focused As Boolean
[C#]
public virtual bool Focused {get;}
[C++]
public: virtual __property bool get_Focused();
[JScript]
public function get Focused() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


FocusedStyle Property

ListBaseItem.FocusedStyle Property

Gets or sets the drawing style of the focused item.

[Visual Basic]
Public Property FocusedStyle As ListItemColorStyle
[C#]
public ListItemColorStyle FocusedStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_FocusedStyle();
public: __property void set_FocusedStyle(ListItemColorStyle);
[JScript]
public function get FocusedStyle() : ListItemColorStyle;
public function set FocusedStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


FormatStyle Property

ListBaseItem.FormatStyle Property

Gets or sets the format style of the item.

[Visual Basic]
Public Property FormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle FormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ListItemFormatStyle);
[JScript]
public function get FormatStyle() : ListItemFormatStyle;
public function set FormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


HoverStyle Property

ListBaseItem.HoverStyle Property

Gets or sets the drawing style of the hovered item.

[Visual Basic]
Public Property HoverStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverStyle();
public: __property void set_HoverStyle(ListItemColorStyle);
[JScript]
public function get HoverStyle() : ListItemColorStyle;
public function set HoverStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Image Property

ListBaseItem.Image Property

Gets or sets the image displayed when the item is in normal state.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ImageIndex Property

ListBaseItem.ImageIndex Property

Gets or sets the image list index value of the image displayed when the item is in normal state.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}
[C++]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(int);
[JScript]
public function get ImageIndex() : int;
public function set ImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ImageList Property

ListBaseItem.ImageList Property

Gets or sets the image list that contains Image objects used by the item.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList { get; set; }
[C++]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(ImageList* );
[JScript]
public function get ImageList() : ImageList
public function set ImageList(ImageList);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ItemType Property

ListBaseItem.ItemType Property

Determines the look and functionality of the item.

[Visual Basic]
Public Property ItemType As ListItemType
[C#]
public ListItemType ItemType {get; set;}
[C++]
public: __property ListItemType get_ItemType();
public: __property void set_ItemType(ListItemType);
[JScript]
public function get ItemType() : ListItemType;
public function set ItemType(ListItemType);

Property Value

The ListItemType that represents the item type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


NormalStyle Property

ListBaseItem.NormalStyle Property

Gets or sets the default drawing style of the item.

[Visual Basic]
Public Property NormalStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalStyle();
public: __property void set_NormalStyle(ListItemColorStyle);
[JScript]
public function get NormalStyle() : ListItemColorStyle;
public function set NormalStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Selected Property

ListBaseItem.Selected Property

Gets or sets a value indicating whether the item is selected.

[Visual Basic]
Public Overridable Property Selected As Boolean
[C#]
public virtual bool Selected {get; set;}
[C++]
public: virtual __property bool get_Selected();
public: virtual __property void set_Selected(bool);
[JScript]
public function get Selected() : Boolean;
public function set Selected(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


SelectedImage Property

ListBaseItem.SelectedImage Property

Gets or sets the image displayed when the item is in selected state.

[Visual Basic]
Public Property SelectedImage As Image
[C#]
public Image SelectedImage { get; set; }
[C++]
public: __property Image* get_SelectedImage();
public: __property void set_SelectedImage(Image* );
[JScript]
public function get SelectedImage() : Image
public function set SelectedImage(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


SelectedImageIndex Property

ListBaseItem.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when the item is in the selected state.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}
[C++]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(int);
[JScript]
public function get SelectedImageIndex() : int;
public function set SelectedImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


SelectedStyle Property

ListBaseItem.SelectedStyle Property

Gets or sets the drawing style of the selected item.

[Visual Basic]
Public Property SelectedStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedStyle();
public: __property void set_SelectedStyle(ListItemColorStyle);
[JScript]
public function get SelectedStyle() : ListItemColorStyle;
public function set SelectedStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


SortTag Property

ListBaseItem.SortTag Property

Gets or sets the object that contains sorting data about the item.

[Visual Basic]
Public Property SortTag As Object
[C#]
public object SortTag {get; set;}
[C++]
public: __property Object* get_SortTag();
public: __property void set_SortTag(Object*);
[JScript]
public function get SortTag() : Object;
public function set SortTag(Object);

Property Value

An Object that contains sorting data about the item. The default is a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


StateImage Property

ListBaseItem.StateImage Property

Gets or sets the image used to display the custom state of the item.

[Visual Basic]
Public Property StateImage As Image
[C#]
public Image StateImage { get; set; }
[C++]
public: __property Image* get_StateImage();
public: __property void set_StateImage(Image* );
[JScript]
public function get StateImage() : Image
public function set StateImage(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


StateImageIndex Property

ListBaseItem.StateImageIndex Property

Gets or sets the image list index value of the image used to display the custom state of the item.

[Visual Basic]
Public Property StateImageIndex As Integer
[C#]
public int StateImageIndex {get; set;}
[C++]
public: __property int get_StateImageIndex();
public: __property void set_StateImageIndex(int);
[JScript]
public function get StateImageIndex() : int;
public function set StateImageIndex(int);

Property Value

A index, that represents the position of an Image in an ImageList. The default is -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


StyleFromParent Property

ListBaseItem.StyleFromParent Property

Determines whether the item should use style from his parent, to draw.

[Visual Basic]
Public Property StyleFromParent As Boolean
[C#]
public bool StyleFromParent {get; set;}
[C++]
public: __property bool get_StyleFromParent();
public: __property void set_StyleFromParent(bool);
[JScript]
public function get StyleFromParent() : Boolean;
public function set StyleFromParent(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ToolTip Property

ListBaseItem.ToolTip Property

Gets or sets the item's tooltip text.

[Visual Basic]
Public Property ToolTip As String
[C#]
public String ToolTip {get; set;}
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String*);
[JScript]
public function get ToolTip() : String;
public function set ToolTip(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


UnFormattedText Property

ListBaseItem.UnFormattedText Property

Gets the item text without formatting tags.

[Visual Basic]
Public ReadOnly Property UnFormattedText As String
[C#]
public String UnFormattedText {get;}
[C++]
public: __property String* get_UnFormattedText();
[JScript]
public function get UnFormattedText() : String;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


WordWrap Property

ListBaseItem.WordWrap Property

Determines whether the item content will be automatically divided in multiple lines.

[Visual Basic]
Public Property WordWrap As Boolean
[C#]
public bool WordWrap {get; set;}
[C++]
public: __property bool get_WordWrap();
public: __property void set_WordWrap(bool);
[JScript]
public function get WordWrap() : Boolean;
public function set WordWrap(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


ListBaseItem Methods

The methods of the ListBaseItem class are listed here. For a complete list of ListBaseItem class members, see the ListBaseItem Members topic.

Public Methods

public method BeginEdit | Initiates the editing of the item text.
public method Clone | Overridden. Creates an exact copy of the current ListBaseItem.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ListBaseItem object.
public method EndEdit | Ends the editing of the item text.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetPreferredSize | Calculates and returns the size of the item space.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsVisible | Determines whether item is visible in current visible parent control area.
public method RepaintParent (inherited from ObjectBase) | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent (inherited from ObjectBase) | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ListBaseItem Class | LidorSystems.IntegralUI.Lists Namespace


BeginEdit Method

ListBaseItem.BeginEdit Method

Initiates the editing of the item text.

[Visual Basic]
Public Overridable Sub BeginEdit()
[C#]
public virtual void BeginEdit();
[C++]
 public: virtual void BeginEdit();
[JScript]
public function BeginEdit();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Clone Method

ListBaseItem.Clone Method

Creates an exact copy of the current ListBaseItem.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new ListBaseItem object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


Dispose Method

ListBaseItem.Dispose Method

Releases all resources used by this ListBaseItem object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


EndEdit Method

ListBaseItem.EndEdit Method

Ends the editing of the item text.

[Visual Basic]
Public Overridable Sub EndEdit()
[C#]
public virtual void EndEdit();
[C++]
 public: virtual void EndEdit();
[JScript]
public function EndEdit();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


GetPreferredSize Method

ListBaseItem.GetPreferredSize Method

Calculates and returns the size of the item space.

[Visual Basic]
Public Overridable Function GetPreferredSize() As Size
[C#]
public virtual Size GetPreferredSize();
[C++]
public: virtual Size GetPreferredSize();
[JScript]
public function GetPreferredSize() : Size;

Return Value

The size of the item space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


IsVisible Method

ListBaseItem.IsVisible Method

Determines whether item is visible in current visible parent control area.

[Visual Basic]
Public Overridable Function IsVisible() As Boolean
[C#]
public virtual bool IsVisible();
[C++]
public: virtual bool IsVisible();
[JScript]
public function IsVisible() : Boolean;

Return Value

True if the item is visible, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBaseItem Class | ListBaseItem Members | LidorSystems.IntegralUI.Lists Namespace


TreeNode Class

A class representing the nodes in the TreeView control.

For a list of all members of this type, see TreeNode Members.

System.Object
System.MarshalByRefObject
LidorSystems.IntegralUI.ObjectBase
LidorSystems.IntegralUI.Lists.ListBaseItem
LidorSystems.IntegralUI.Lists.TreeNode

[Visual Basic]
<Serializable>
Public Class TreeNode
   Inherits LidorSystems.IntegralUI.Lists.ListBaseItem
[C#]
[Serializable]
 public class TreeNode : LidorSystems.IntegralUI.Lists.ListBaseItem
[C++]
[Serializable]
public __gc class TreeNode : public LidorSystems.IntegralUI.Lists.ListBaseItem
[JScript]
public
   Serializable
class TreeNode extends LidorSystems.IntegralUI.Lists.ListBaseItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists.TreeView (in LidorSystems.IntegralUI.Lists.TreeView.dll)

See Also

TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


TreeNode Members

TreeNode overview

Public Constructors

public constructor TreeNode Constructor Initializes a new instance of the TreeNode class.

Public Properties

public property Bounds | Gets the bounds of the tree node.
public property CanSelect | Determines whether the tree node can be selected.
public property CheckBoxVisible | Gets or sets a value indicating whether check box is displayed next to the tree node in the tree view control.
public property Checked | Indicates whether the check box of the tree node is checked or unchecked.
public property CheckState | Gets or sets a value representing the current state of the check box of the tree node.
public property ContentSpacing (inherited from ListBaseItem) | Gets or sets the space between text, image and control in item.
public property ContextMenu (inherited from ListBaseItem) | Gets or sets the shortcut menu associated with this TreeNode.
public property Control | Gets or sets the Control associated with this tree node.
public property ControlAlign | Gets or sets the alignment of the control inside the tree node space.
public property DisabledStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the disabled item.
public property DisplayPosition | Determines whether the node will be placed above or below its parent node.
public property Enabled (inherited from ListBaseItem) | Gets or sets a value indicating whether the item can respond to user interaction.
public property FirstNode | Gets the first child tree node in the tree node collection.
public property Fixed | Determines whether the node is fixed to the top or bottom side of the control.
public property Focused | Overridden. Gets a value indicating whether the item has the keyboard focus.
public property FocusedStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the focused item.
public property FormatStyle (inherited from ListBaseItem) | Gets or sets the format style of the item.
public property FullPath | Gets the path from the root tree node to the current tree node.
public property HoverStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the hovered item.
public property Image (inherited from ListBaseItem) | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property Index | Overridden. Gets the position of the node in the node collection.
public property IsEditing | Gets a value indicating whether the tree node is in an editable state.
public property IsExpanded | Gets a value indicating whether the tree node is in the expanded state.
public property IsRoot | Gets a value indicating whether the tree node is a root node in tree hierarchy.
public property IsSelected | Gets a value indicating whether the tree node is in the selected state.
public property Key (inherited from ListBaseItem) | Gets or sets a string that uniquely identifies item in a collection.
public property LastNode | Gets the last child tree node.
public property Level | Gets the level of tree node in tree view structure.
public property NextNode | Gets the next sibling tree node.
public property NextVisibleNode | Gets the next visible tree node.
public property Nodes | Gets the collection of tree nodes assigned to the current tree node.
public property NormalStyle (inherited from ListBaseItem) | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent tree node of the current tree node.
public property PrevNode | Gets the previous sibling tree node.
public property PrevVisibleNode | Gets the previous visible tree node.
public property Selected (inherited from ListBaseItem) | Gets or sets a value indicating whether the item is selected.
public property SelectedImage (inherited from ListBaseItem) | Gets or sets the image displayed when the item is in selected state.
public property SelectedImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image that is displayed when the item is in the selected state.
public property SelectedStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the selected item.
public property ShowControl | Gets or sets a value indicating whether the control contained in tree node is visible.
public property ShowPlusMinus | Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree node that contain child tree nodes.
public property State | Overridden. Gets a value indicating the current state of the node.
public property StateImage (inherited from ListBaseItem) | Overridden. Gets or sets the image used to display the custom state of the node.
public property StateImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image used to display the custom state of the node.
public property StyleFromParent (inherited from ListBaseItem) | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ListBaseItem) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ListBaseItem) | Gets or sets the tag string of the item.
public property Text (inherited from ListBaseItem) | Gets or sets the item text.
public property TextElements (inherited from ListBaseItem) | Gets a collection of text parts from which the item text is created.
public property TreeView | Gets the parent tree view that the tree node is assigned to.
public property UnFormattedText (inherited from ListBaseItem) | Gets the item text without formatting tags.
public property Visible (inherited from ListBaseItem) | Gets or sets a value indicating whether the item is displayed.

Public Methods

public method BeginEdit | Initiates the editing of the tree node text.
public method Clone | Overridden. Creates an exact copy of the current TreeNode.
public method Collapse | Collapses the tree node.
public method CollapseAll | Collapses all the child tree nodes.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from ListBaseItem) | Releases all resources used by this TreeNode object.
public method EndEdit | Ends the editing of the tree node text.
public method EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method Expand | Expands the tree node.
public method ExpandAll | Expands all the child tree nodes.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNodeCount | Returns the number of child tree nodes.
public method GetPreferredSize (inherited from ListBaseItem) | Overriden. Calculates and returns the size of the item space.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsChildOf | Checks whether the node is child of a specified node.
public method IsVisible | Check whether the tree node is present in the current visible space of the tree view control.
public method Move | Moves the tree node to the specified position in the node collection.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method Remove | Removes the current tree node from the node collection.
public method Toggle | Toggles the tree node to either the expanded or collapsed state.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor

Initializes a new instance of the TreeNode class.

Overload List

Initializes a new instance of the TreeNode class.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New()
[C#] public TreeNode();
[C++] public: TreeNode();
[JScript] public function TreeNode();

Initializes a new instance of the TreeNode class with the specified text.

Supported by the .NET Compact Framework.

[Visual Basic] Public Sub New(String)
[C#] public TreeNode(string);
[C++] public: TreeNode(String*);
[JScript] public function TreeNode(String);

Initializes a new instance of the TreeNode class with the specified text and child tree nodes.

[Visual Basic] Public Sub New(String, TreeNode())
[C#] public TreeNode(string, TreeNode[]);
[C++] public: TreeNode(String*, TreeNode[]);
[JScript] public function TreeNode(String, TreeNode[]);

Initializes a new instance of the TreeNode class with the specified text and images to display when the tree node is in a selected and unselected state.

[Visual Basic] Public Sub New(String, Integer, Integer)
[C#] public TreeNode(string, int, int);
[C++] public: TreeNode(String*, int, int);
[JScript] public function TreeNode(String, int, int);

Initializes a new instance of the TreeNode class with the specified text, child tree nodes, and images to display when the tree node is in a selected and unselected state.

[Visual Basic] Public Sub New(String, Integer, Integer, TreeNode())
[C#] public TreeNode(string, int, int, TreeNode[]);
[C++] public: TreeNode(String*, int, int, TreeNode[]);
[JScript] public function TreeNode(String, int, int, TreeNode[]);

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor ()

Initializes a new instance of the TreeNode class.

[Visual Basic]
Public Sub New()
[C#]
public TreeNode();
[C++]
public: TreeNode();
[JScript]
public function TreeNode();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor (String)

Initializes a new instance of the TreeNode class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public TreeNode(
   string text
);
[C++]
public: TreeNode(
   String* text
);
[JScript]
public function TreeNode(
   text : String
);

Parameters

text
The text of the new tree node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor (String, TreeNode[])

Initializes a new instance of the TreeNode class with the specified label text and child tree nodes.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal childNodes() As TreeNode _
)
[C#]
public TreeNode(
   string text,
   TreeNode[] childNodes
);
[C++]
public: TreeNode(
   String* text,
   TreeNode* childNodes[]
);
[JScript]
public function TreeNode(
   text : String,
   childNodes : TreeNode[]
);

Parameters

text
The text of the new tree node.
childNodes
An array of child TreeNode objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor (String, Int32, Int32)

Initializes a new instance of the TreeNode class with the specified text and images to display when the tree node is in a selected and unselected state.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageIndex As Integer, _
   ByVal selImageIndex As Integer _
)
[C#]
public TreeNode(
   string text,
   int imageIndex,
   int selImageIndex
);
[C++]
public: TreeNode(
   String* text,
   int imageIndex,
   int selImageIndex
);
[JScript]
public function TreeNode(
   text : String,
   imageIndex : int,
   selImageIndex : int
);

Parameters

text
The text of the new tree node.
imageIndex
The index value of Image to display when the tree node is unselected.
selImageIndex
The index value of Image to display when the tree node is selected.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Constructor (String, Int32, Int32, TreeNode[])

Initializes a new instance of the TreeNode class with the specified text, child tree nodes, and images to display when the tree node is in a selected and unselected state.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageIndex As Integer, _
   ByVal selectedImageIndex As Integer, _
   ByVal children() As TreeNode _
)
[C#]
public TreeNode(
   string text,
   int imageIndex,
   int selectedImageIndex,
   TreeNode[] children
);
[C++]
public: TreeNode(
   String* text,
   int imageIndex,
   int selectedImageIndex,
   TreeNode* children[]
);
[JScript]
public function TreeNode(
   text : String,
   imageIndex : int,
   selectedImageIndex : int,
   children : TreeNode[]
);

Parameters

text
The text of the new tree node.
imageIndex
The index value of Image to display when the tree node is unselected.
selectedImageIndex
The index value of Image to display when the tree node is selected.
children
An array of child TreeNode objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


TreeNode Properties

The properties of the TreeNode class are listed here. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Properties

public property Bounds | Gets the bounds of the tree node.
public property CanSelect | Determines whether the tree node can be selected.
public property CheckBoxVisible | Gets or sets a value indicating whether check box is displayed next to the tree node in the tree view control.
public property Checked | Indicates whether the check box of the tree node is checked or unchecked.
public property CheckState | Gets or sets a value representing the current state of the check box of the tree node.
public property ContentSpacing (inherited from ListBaseItem) | Gets or sets the space between text, image and control in item.
public property ContextMenu (inherited from ListBaseItem) | Gets or sets the shortcut menu associated with this TreeNode.
public property Control | Gets or sets the Control associated with this tree node.
public property ControlAlign | Gets or sets the alignment of the control inside the tree node space.
public property DisabledStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the disabled item.
public property DisplayPosition | Determines whether the node will be placed above or below its parent node.
public property Enabled (inherited from ListBaseItem) | Gets or sets a value indicating whether the item can respond to user interaction.
public property FirstNode | Gets the first child tree node in the tree node collection.
public property Fixed | Determines whether the node is fixed to the top or bottom side of the control.
public property Focused | Overridden. Gets a value indicating whether the item has the keyboard focus.
public property FocusedStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the focused item.
public property FormatStyle (inherited from ListBaseItem) | Gets or sets the format style of the item.
public property FullPath | Gets the path from the root tree node to the current tree node.
public property HoverStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the hovered item.
public property Image (inherited from ListBaseItem) | Gets or sets the image displayed when the item is in normal state.
public property ImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image displayed when the item is in normal state.
public property Index | Overridden. Gets the position of the node in the node collection.
public property IsEditing | Gets a value indicating whether the tree node is in an editable state.
public property IsExpanded | Gets a value indicating whether the tree node is in the expanded state.
public property IsRoot | Gets a value indicating whether the tree node is a root node in tree hierarchy.
public property IsSelected | Gets a value indicating whether the tree node is in the selected state.
public property Key (inherited from ListBaseItem) | Gets or sets a string that uniquely identifies item in a collection.
public property LastNode | Gets the last child tree node.
public property Level | Gets the level of tree node in tree view structure.
public property NextNode | Gets the next sibling tree node.
public property NextVisibleNode | Gets the next visible tree node.
public property Nodes | Gets the collection of tree nodes assigned to the current tree node.
public property NormalStyle (inherited from ListBaseItem) | Gets or sets the default drawing style of the item.
public property Parent | Gets the parent tree node of the current tree node.
public property PrevNode | Gets the previous sibling tree node.
public property PrevVisibleNode | Gets the previous visible tree node.
public property Selected (inherited from ListBaseItem) | Gets or sets a value indicating whether the item is selected.
public property SelectedImage (inherited from ListBaseItem) | Gets or sets the image displayed when the item is in selected state.
public property SelectedImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image that is displayed when the item is in the selected state.
public property SelectedStyle (inherited from ListBaseItem) | Gets or sets the drawing style of the selected item.
public property ShowControl | Gets or sets a value indicating whether the control contained in tree node is visible.
public property ShowPlusMinus | Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree node that contain child tree nodes.
public property State | Overridden. Gets a value indicating the current state of the node.
public property StateImage (inherited from ListBaseItem) | Overridden. Gets or sets the image used to display the custom state of the node.
public property StateImageIndex (inherited from ListBaseItem) | Gets or sets the image list index value of the image used to display the custom state of the node.
public property StyleFromParent (inherited from ListBaseItem) | Determines whether the item should use style from his parent, to draw.
public property Tag (inherited from ListBaseItem) | Gets or sets the object that contains data about the item.
public property TagString (inherited from ListBaseItem) | Gets or sets the tag string of the item.
public property Text (inherited from ListBaseItem) | Gets or sets the item text.
public property TextElements (inherited from ListBaseItem) | Gets a collection of text parts from which the item text is created.
public property TreeView | Gets the parent tree view that the tree node is assigned to.
public property UnFormattedText (inherited from ListBaseItem) | Gets the item text without formatting tags.
public property Visible (inherited from ListBaseItem) | Gets or sets a value indicating whether the item is displayed.

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


Bounds Property

TreeNode.Bounds Property

Gets the bounds of the tree node.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}
[C++]
public: __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

Property Value

The Rectangle that represents the bounds of the tree node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


CanSelect Property

TreeNode.CanSelect Property

Determines whether the tree node can be selected.

[Visual Basic]
Public Property CanSelect As Boolean
[C#]
public bool CanSelect {get; set;}
[C++]
public: __property bool get_CanSelect();
public: __property void set_CanSelect(bool);
[JScript]
public function get CanSelect() : Boolean;
public function set CanSelect(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxVisible Property

TreeNode.CheckBoxVisible Property

Gets or sets a value indicating whether check box is displayed next to the tree node in the tree view control.

[Visual Basic]
Public Property CheckBoxVisible As Boolean
[C#]
public bool CheckBoxVisible {get; set;}
[C++]
public: __property bool get_CheckBoxVisible();
public: __property void set_CheckBoxVisible(bool);
[JScript]
public function get CheckBoxVisible() : Boolean;
public function set CheckBoxVisible(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Checked Property

TreeNode.Checked Property

Indicates whether the check box of the tree node is checked or unchecked.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}
[C++]
public: __property bool get_Checked();
public: __property void set_Checked(bool);
[JScript]
public function get Checked() : Boolean;
public function set Checked(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


CheckState Property

TreeNode.CheckState Property

Gets or sets a value representing the current state of the check box of the tree node.

[Visual Basic]
Public Property CheckState As CheckState
[C#]
public CheckState CheckState {get; set;}
[C++]
public: __property CheckState get_CheckState();
public: __property void set_CheckState(CheckState);
[JScript]
public function get CheckState() : CheckState;
public function set CheckState(CheckState);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Control Property

TreeNode.Control Property

Gets or sets the Control associated with this tree node.

[Visual Basic]
Public Property Control As Control
[C#]
public Control Control {get; set;}
[C++]
public: __property Control get_Control();
public: __property void set_Control(Control);
[JScript]
public function get Control() : Control;
public function set Control(Control);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


ControlAlign Property

TreeNode.ControlAlign Property

Gets or sets the alignment of the control inside the tree node space.

[Visual Basic]
Public Property ControlAlign As ControlAlignment
[C#]
public ControlAlignment ControlAlign {get; set;}
[C++]
public: __property ControlAlignment get_ControlAlign();
public: __property void set_ControlAlign(ControlAlignment);
[JScript]
public function get ControlAlign() : ControlAlignment;
public function set ControlAlign(ControlAlignment);

Property Value

The ControlAlignment assigned to the tree node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


DisplayPosition Property

TreeNode.DisplayPosition Property

Determines whether the node will be placed above or below its parent node.

[Visual Basic]
Public Property DisplayPosition As TreeNodeDisplayPosition
[C#]
public TreeNodeDisplayPosition DisplayPosition {get; set;}
[C++]
public: __property TreeNodeDisplayPosition get_DisplayPosition();
public: __property void set_DisplayPosition(TreeNodeDisplayPosition);
[JScript]
public function get DisplayPosition() : TreeNodeDisplayPosition;
public function set DisplayPosition(TreeNodeDisplayPosition);

Property Value

The TreeNodeDisplayPosition that represents the position of the node relative to its parent node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


FirstNode Property

TreeNode.FirstNode Property

Gets the first child tree node in the tree node collection.

[Visual Basic]
Public ReadOnly Property FirstNode As TreeNode
[C#]
public TreeNode FirstNode {get;}
[C++]
public: __property TreeNode* get_FirstNode();
[JScript]
public function get FirstNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Fixed Property

TreeNode.Fixed Property

Determines whether the node is fixed to the top or bottom side of the control.

[Visual Basic]
Public Property Fixed As ItemFixedType
[C#]
public ItemFixedType Fixed {get; set;}
[C++]
public: __property ItemFixedType get_Fixed();
public: __property void set_Fixed(ItemFixedType);
[JScript]
public function get Fixed() : ItemFixedType;
public function set Fixed(ItemFixedType);

Property Value

The ItemFixedType that represents the side at which node is fixed in its parent control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Focused Property

TreeNode.Focused Property

Overridden. Gets a value indicating whether the node has the keyboard focus.

[Visual Basic]
Public ReadOnly Property Focused As Boolean
[C#]
public bool Focused {get;}
[C++]
public: __property bool get_Focused();
[JScript]
public function get Focused() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


FullPath Property

TreeNode.FullPath Property

Gets the path from the root tree node to the current tree node.

[Visual Basic]
Public ReadOnly Property FullPath As String
[C#]
public string FullPath {get;}
[C++]
public: __property String* get_FullPath();
[JScript]
public function get FullPath() : String;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Index Property

TreeNode.Index Property

Overridden. Gets the position of the tree node in the node collection.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Property Value

A zero-based index value that represents the position of the node in the node collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsEditing Property

TreeNode.IsEditing Property

Gets a value indicating whether the tree node is in an editable state.

[Visual Basic]
Public ReadOnly Property IsEditing As Boolean
[C#]
public bool IsEditing {get;}
[C++]
public: __property bool get_IsEditing();
[JScript]
public function get IsEditing() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsExpanded Property

TreeNode.IsExpanded Property

Gets a value indicating whether the tree node is in the expanded state.

[Visual Basic]
Public ReadOnly Property IsExpanded As Boolean
[C#]
public bool IsExpanded {get;}
[C++]
public: __property bool get_IsExpanded();
[JScript]
public function get IsExpanded() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsRoot Property

TreeNode.IsRoot Property

Gets a value indicating whether the tree node is a root node in tree hierarchy.

[Visual Basic]
Public ReadOnly Property IsRoot As Boolean
[C#]
public bool IsRoot {get;}
[C++]
public: __property bool get_IsRoot();
[JScript]
public function get IsRoot() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsSelected Property

TreeNode.IsSelected Property

Gets a value indicating whether the tree node is in the selected state.

[Visual Basic]
Public ReadOnly Property IsSelected As Boolean
[C#]
public bool IsSelected {get;}
[C++]
public: __property bool get_IsSelected();
[JScript]
public function get IsSelected() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


LastNode Property

TreeNode.LastNode Property

Gets the last child tree node.

[Visual Basic]
Public ReadOnly Property LastNode As TreeNode
[C#]
public TreeNode LastNode {get;}
[C++]
public: __property TreeNode* get_LastNode();
[JScript]
public function get LastNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Level Property

TreeNode.Level Property

Gets the level of tree node in tree view structure.

[Visual Basic]
Public Property Level As Integer
[C#]
public int Level {get; set;}
[C++]
public: __property int get_Level();
public: __property void set_Level(int);
[JScript]
public function get Level() : int;
public function set Level(int);

Property Value

The level, showing the depth of tree node in tree view structure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


NextNode Property

TreeNode.NextNode Property

Gets the next sibling tree node.

[Visual Basic]
Public ReadOnly Property NextNode As TreeNode
[C#]
public TreeNode NextNode {get;}
[C++]
public: __property TreeNode* get_NextNode();
[JScript]
public function get NextNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


NextVisibleNode Property

TreeNode.NextVisibleNode Property

Gets the next visible tree node.

[Visual Basic]
Public ReadOnly Property NextVisibleNode As TreeNode
[C#]
public TreeNode NextVisibleNode {get;}
[C++]
public: __property TreeNode* get_NextVisibleNode();
[JScript]
public function get NextVisibleNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Nodes Property

TreeNode.Nodes Property

Gets the collection of tree nodes assigned to the current tree node.

[Visual Basic]
Public ReadOnly Property Nodes As TreeNodeCollection
[C#]
public TreeNodeCollection Nodes {get;}
[C++]
public: __property TreeNodeCollection* get_Nodes();
[JScript]
public function get Nodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the tree nodes assigned to the current tree node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Parent Property

TreeNode.Parent Property

Gets the parent tree node of the current tree node.

[Visual Basic]
Public ReadOnly Property Parent As TreeNode
[C#]
public TreeNode Parent {get;}
[C++]
public: __property TreeNode* get_Parent();
[JScript]
public function get Parent() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


PrevNode Property

TreeNode.PrevNode Property

Gets the previous sibling tree node.

[Visual Basic]
Public ReadOnly Property PrevNode As TreeNode
[C#]
public TreeNode PrevNode {get;}
[C++]
public: __property TreeNode* get_PrevNode();
[JScript]
public function get PrevNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


PrevVisibleNode Property

TreeNode.PrevVisibleNode Property

Gets the previous visible tree node.

[Visual Basic]
Public ReadOnly Property PrevVisibleNode As TreeNode
[C#]
public TreeNode PrevVisibleNode {get;}
[C++]
public: __property TreeNode* get_PrevVisibleNode();
[JScript]
public function get PrevVisibleNode() : TreeNode;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


ShowControl Property

TreeNode.ShowControl Property

Gets or sets a value indicating whether the control contained in tree node is visible.

[Visual Basic]
Public Property ShowControl As Boolean
[C#]
public bool ShowControl {get; set;}
[C++]
public: __property bool get_ShowControl();
public: __property void set_ShowControl(bool);
[JScript]
public function get ShowControl() : Boolean;
public function set ShowControl(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


ShowPlusMinus Property

TreeNode.ShowPlusMinus Property

Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree node that contain child tree nodes.

[Visual Basic]
Public Property ShowPlusMinus As Boolean
[C#]
public bool ShowPlusMinus {get; set;}
[C++]
public: __property bool get_ShowPlusMinus();
public: __property void set_ShowPlusMinus(bool);
[JScript]
public function get ShowPlusMinus() : Boolean;
public function set ShowPlusMinus(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


State Property

TreeNode.State Property

Overridden. Gets a value indicating the current state of the node.

[Visual Basic]
Public ReadOnly Property State As ObjectState
[C#]
public ObjectState State {get;}
[C++]
public: __property ObjectState* get_State();
[JScript]
public function get State() : ObjectState;

Property Value

A ObjectState that represents the current state of the node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


TreeView Property

TreeNode.TreeView Property

Gets the parent tree view that the tree node is assigned to.

[Visual Basic]
Public ReadOnly Property TreeView As TreeView
[C#]
public TreeView TreeView {get;}
[C++]
public: __property TreeView* get_TreeView();
[JScript]
public function get TreeView() : TreeView;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


TreeNode Methods

The methods of the TreeNode class are listed here. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Methods

public method BeginEdit | Initiates the editing of the tree node text.
public method Clone | Overridden. Creates an exact copy of the current TreeNode.
public method Collapse | Collapses the tree node.
public method CollapseAll | Collapses all the child tree nodes.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from ListBaseItem) | Releases all resources used by this TreeNode object.
public method EndEdit | Ends the editing of the tree node text.
public method EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method Expand | Expands the tree node.
public method ExpandAll | Expands all the child tree nodes.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNodeCount | Returns the number of child tree nodes.
public method GetPreferredSize (inherited from ListBaseItem) | Overriden. Calculates and returns the size of the item space.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsChildOf | Checks whether the node is child of a specified node.
public method IsVisible | Check whether the tree node is present in the current visible space of the tree view control.
public method Move | Moves the tree node to the specified position in the node collection.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method Remove | Removes the current tree node from the node collection.
public method Toggle | Toggles the tree node to either the expanded or collapsed state.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

TreeNode Class | LidorSystems.IntegralUI.Lists Namespace


BeginEdit Method

TreeNode.BeginEdit Method

Initiates the editing of the tree node or subitem text.

Overload List

Initiates the editing of the tree node text.

[Visual Basic] Public Sub BeginEdit()
[C#] public void BeginEdit();
[C++] public: void BeginEdit();
[JScript] public function BeginEdit();

Initiates the editing of specific text part the tree node created with XML tags.

[Visual Basic] Public Function BeginEdit(String)
[C#] public void BeginEdit(String);
[C++] public: void BeginEdit(String);
[JScript] public function BeginEdit(String);

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


BeginEdit Method

TreeNode.BeginEdit Method

Initiates the editing of the tree node text.

[Visual Basic]
Public Sub BeginEdit()
[C#]
public void BeginEdit();
[C++]
 public: void BeginEdit();
[JScript]
public function BeginEdit();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


BeginEdit Method

TreeNode.BeginEdit (String) Method

Initiates the editing of specific text part the tree node created with XML tags.

[Visual Basic]
Public Sub BeginEdit( _
   ByVal key As String _
)
[C#]
public void BeginEdit(
   String key
);
[C++]
public: void BeginEdit(
   String key
);
[JScript]
public function BeginEdit(
   key : String
)

Parameters

key

The key determined by String which specifes the text part of the node that will be edited.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Clone Method

TreeNode.Clone Method

Overridden. Creates an exact copy of the current TreeNode.

[Visual Basic]
Public Overrides Overloads  Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TreeNode object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Collapse Method

TreeNode.Collapse Method

Collapses the tree node.

[Visual Basic]
Public Sub Collapse()
[C#]
public void Collapse();
[C++]
 public: void Collapse();
[JScript]
public function Collapse();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


CollapseAll Method

TreeNode.CollapseAll Method

Collapses all the child tree nodes.

[Visual Basic]
Public Sub CollapseAll()
[C#]
public void CollapseAll();
[C++]
 public: void CollapseAll();
[JScript]
public function CollapseAll();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


EndEdit Method

TreeNode.EndEdit Method

Ends the editing of the tree node text.

[Visual Basic]
Public Sub EndEdit()
[C#]
public void EndEdit();
[C++]
 public: void EndEdit();
[JScript]
public function EndEdit();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeNode.EnsureVisible Method

Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.

Overload List

Ensures that tree node is visible in current view of the control.

[Visual Basic] Public Sub EnsureVisible()
[C#] public void EnsureVisible();
[C++] public: void EnsureVisible();
[JScript] public function EnsureVisible();

Ensures that tree node is visible in current view of the control and placed at specified vertical position.

[Visual Basic] Public Function EnsureVisible(VerticalAlignment)
[C#] public void EnsureVisible(VerticalAlignment);
[C++] public: void EnsureVisible(VerticalAlignment);
[JScript] public function EnsureVisible(VerticalAlignment);

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeNode.EnsureVisible Method

Ensures that tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.

[Visual Basic]
Public Sub EnsureVisible()
[C#]
public void EnsureVisible();
[C++]
 public: void EnsureVisible();
[JScript]
public function EnsureVisible();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeNode.EnsureVisible (VerticalAlignment) Method

Ensures that tree node is visible in current view of the control and placed at specified vertical position.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal position As VerticalAlignment _
)
[C#]
public void EnsureVisible(
   VerticalAlignment position
);
[C++]
public: void EnsureVisible(
   VerticalAlignment position
);
[JScript]
public function EnsureVisible(
   position : VerticalAlignment
)

Parameters

position

The position determined by VerticalAlignment at which the node will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Expand Method

TreeNode.Expand Method

Expands the tree node.

[Visual Basic]
Public Sub Expand()
[C#]
public void Expand();
[C++]
 public: void Expand();
[JScript]
public function Expand();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


ExpandAll Method

TreeNode.ExpandAll Method

Expands all the child tree nodes.

[Visual Basic]
Public Sub ExpandAll()
[C#]
public void ExpandAll();
[C++]
 public: void ExpandAll();
[JScript]
public function ExpandAll();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


GetNodeCount Method

TreeNode.GetNodeCount Method

Returns the number of child tree nodes.

[Visual Basic]
Public Function GetNodeCount( _
   ByVal childNodes As Boolean _
) As Integer
[C#]
public int GetNodeCount(
   bool childNodes
);
[C++]
public: int GetNodeCount(
   bool childNodes
);
[JScript]
public function GetNodeCount(
   childNodes : Boolean
) : int;

Parameters

childNodes
true if the count includes all child tree nodes; otherwise false.

Return Value

The number of child tree nodes assigned to the Nodes collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


GetPreferredSize Method

TreeNode.GetPreferredSize Method

Calculates and returns the size of the item space.

[Visual Basic]
Public Overrides Overloads  Function GetPreferredSize() As Size
[C#]
public override Size GetPreferredSize();
[C++]
public: override Size GetPreferredSize();
[JScript]
public function GetPreferredSize() : Size;

Return Value

The size of the item space.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsChildOf Method

TreeNode.IsChildOf Method

Checks whether the node is child of a specified node.

[Visual Basic]
Overloads Public Function IsChildOf( _
   ByVal node As TreeNode _
) As Boolean
[C#]
public bool IsChildOf(
   TreeNode node
);
[C++]
public: bool* IsChildOf(
   TreeNode node
);
[JScript]
public function IsChildOf(
   node : TreeNode
) : Boolean;

Return Value

True if the node is child of a specified node, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


IsVisible Method

TreeNode.IsVisible Method

Check whether the tree node is present in the current visible space of the tree view control.

[Visual Basic]
Public Function IsVisible() As Boolean
[C#]
public bool IsVisible();
[C++]
public: bool IsVisible();
[JScript]
public function IsVisible() : Boolean;

Return Value

True if the node is present, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Move Method

TreeNode.Move Method

Moves the tree node to the specified position in the node collection.

[Visual Basic]
public  Sub Move( _
   ByVal direction As TreeNodeMoveDirection _
)
[C#]
public void Move(
   TreeNodeMoveDirection direction
);
[C++]
public: void Move(
   TreeNodeMoveDirection* direction
);
[JScript]
public  function Move(
   direction : TreeNodeMoveDirection
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Remove Method

TreeNode.Remove Method

Removes the current tree node from the node collection.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();
[C++]
 public: void Remove();
[JScript]
public function Remove();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


Toggle Method

TreeNode.Toggle Method

Toggles the tree node to either the expanded or collapsed state.

[Visual Basic]
Public Sub Toggle()
[C#]
public void Toggle();
[C++]
 public: void Toggle();
[JScript]
public function Toggle();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNode Class | TreeNode Members | LidorSystems.IntegralUI.Lists Namespace


TreeView Class

Displays a hierarchical collection of TreeNode objects.

For a list of all members of this type, see TreeView Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LidorSystems.IntegralUI.ControlBase
LidorSystems.IntegralUI.Lists.ListBase
LidorSystems.IntegralUI.Lists.TreeView

[Visual Basic]
 Public Class TreeView
   Inherits LidorSystems.IntegralUI.Lists.ListBase
[C#]
public class TreeView : LidorSystems.IntegralUI.Lists.ListBase
[C++]
 public __gc class TreeView : public LidorSystems.IntegralUI.Lists.ListBase
[JScript]
public class TreeView extends LidorSystems.IntegralUI.Lists.ListBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists.TreeView (in LidorSystems.IntegralUI.Lists.TreeView.dll)

See Also

TreeView Members | LidorSystems.IntegralUI.Lists Namespace


TreeView Members

TreeView overview

Public Constructors

public constructor TreeView Constructor Initializes a new instance of the TreeView class.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ListBase) | Determines whether the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSelectionCheck | Determines whether the node check box is altered during selection.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property BottomNodes | Gets the collection of tree nodes that are fixed to bottom side of the control.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
public property CheckBoxStyle | Gets or sets the drawing style of the tree node check box.
public property CheckedNodes | Gets the collection of checked tree nodes.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the tree view control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property CurrentList | Gets the flat list of all nodes that are visible and filtered.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledNodeStyle | Gets or sets the drawing style of the disabled tree node.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property ExpandBoxStyle | Gets or sets the drawing style of the tree node expand/collapse buttons.
public property FadingEffect (inherited from ListBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ListBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property FlatNodes | Gets the flat collection of tree nodes.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusedNode | Gets or sets the tree node that has the input focus.
public property FocusedNodeStyle | Gets or sets the drawing style of the focused tree node.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle | Gets or sets the format style of the tree view control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
public property HoverNodeStyle | Gets or sets the drawing style of the hovered tree node.
public property HoverSelection | Gets or sets a value indicating whether the tree node can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
public property ImageList (inherited from ListBase) | Gets or sets the ImageList that contains the Image objects used by the TreeViewItems.
public property Indent | Gets or sets the distance to indent each of the child tree node levels.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property LabelEdit | Gets or sets a value indicating whether the text of the tree nodes can be edited.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NodeFormatStyle | Gets or sets the format style of the tree node.
public property NodeHighlightType | Gets or sets the value indicating how the tree node is drawn.
public property NodeSpacing | Gets or sets the vertical spacing between tree nodes.
public property Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
public property NormalNodeStyle | Gets or sets the default drawing style of the tree node.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property PathSeparator | Gets or sets the delimiter string that the tree node path uses.
public property PreserveCheckState | Gets or sets a value indicating whether the tree nodes preserves their CheckState property value unchanged.
public property PreserveSelection | Gets or sets a value indicating whether the tree nodes preserves their Selected property value unchanged.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drwaing style of the scroll bars in the tree view .
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
public property SelectedNode | Gets or sets the tree node that is currently selected in the tree view control.
public property SelectedNodes | Gets the collection of selected tree nodes.
public property SelectedNodeStyle | Gets or sets the drawing style of selected tree node.
public property SelectionMode | Gets or sets the method in which tree nodes are selected in the tree view control.
public property ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
public property ShowPlusMinus | Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree nodes that contain child tree nodes.
public property ShowRootLines | Indicates whether lines are displayed between root nodes.
public property ShowStateImages | Gets or sets a value indicating whether state images (flags) are visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property StateImageList (inherited from ListBase) | Gets or sets the ImageList that contains the Image objects used to represent different states of the TreeNodes.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TopNode | Gets the first fully-visible tree node in the tree view control.
public property TopNodes | Gets the collection of tree nodes that are fixed to top side of the control.
public property UseTheme | Overridden. Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control.
public property VisualStyle (inherited from ListBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage (inherited from ListBase) | Specifies the image which can be used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method ChangeCheckState | Changes the CheckState of nodes without firing BeforeCheck and AfterCheck events.
public method CollapseAll | Collapses all the tree nodes.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method ExpandAll | Expands all the tree nodes.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method FindNode | Searched for tree node using specified criteria.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetNodeAt | Retrieves the tree node that is at the specified location.
public method GetNodeCount | Retrieves the number of tree nodes and optionally including subnodes.
public method GetScrollPos | Retrieves the current position of the vertical scrollbar.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsHScrollVisible | Check whether horizontal scrollbar is visible in the tree view control.
public method IsVScrollVisible | Check whether vertical scrollbar is visible in the tree view control.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ListBase) | Resumes the painting of the control.
public method ResumeUpdate | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method SetScrollPos | Sets the position of the vertical scroll bar.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ListBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate | Overridden. Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Public Events

public event AfterCheck | Occurs after the TreeNode check box is checked.
public event AfterCollapse | Occurs after the TreeNode is collapsed.
public event AfterExpand | Occurs after the TreeNode is expanded.
public event AfterLabelEdit | Occurs after the TreeNode text is edited.
public event AfterSelect | Occurs after the TreeNode is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event BeforeCheck | Occurs before the TreeNode check box is checked.
public event BeforeCollapse | Occurs before the TreeNode is collapsed.
public event BeforeExpand | Occurs before the TreeNode is expanded.
public event BeforeLabelEdit | Occurs before the TreeNode text is edited.
public event BeforeSelect | Occurs before the TreeNode is selected.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FocusedNodeChanged | Occurs after the FocusedNode is changed.
public event FocusedNodeChanging | Occurs before the FocusedNode is changed.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event NodeAdded | Occurs after the TreeNode is added.
public event NodeAdding | Occurs before the TreeNode is added.
public event NodeRemoved | Occurs after the TreeNode is removed.
public event NodeRemoving | Occurs before the TreeNode is removed.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterCheck | Raises the AfterCheck event.
protected method OnAfterCollapse | Raises the AfterCollapse event.
protected method OnAfterExpand | Raises the AfterExpand event.
protected method OnAfterLabelEdit | Raises the AfterLabelEdit event.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeCheck | Raises the BeforeCheck event.
protected method OnBeforeCollapse | Raises the BeforeCollapse event.
protected method OnBeforeExpand | Raises the BeforeExpand event.
protected method OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNodeAdded | Raises the NodeAdded event.
protected method OnNodeAdding | Raises the NodeAdding event.
protected method OnNodeRemoved | Raises the NodeRemoved event.
protected method OnNodeRemoving | Raises the NodeRemoving event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TreeView Class | LidorSystems.IntegralUI.Lists Namespace


TreeView Constructor ()

Initializes a new instance of the TreeView class.

[Visual Basic]
Public Sub New()
[C#]
public TreeView();
[C++]
public: TreeView();
[JScript]
public function TreeView();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeView Class | LidorSystems.IntegralUI.Lists Namespace


TreeView Properties

The properties of the TreeView class are listed here. For a complete list of TreeView class members, see the TreeView Members topic.

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrag (inherited from ListBase) | Determines whether the control can be dragged.
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property AllowSelectionCheck | Determines whether the node check box is altered during selection.
public property Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
public property BottomNodes | Gets the collection of tree nodes that are fixed to bottom side of the control.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
public property CheckBoxStyle | Gets or sets the drawing style of the tree node check box.
public property CheckedNodes | Gets the collection of checked tree nodes.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property ColorStyle | Gets or sets the drawing style of the tree view control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property CurrentList | Gets the flat list of all nodes that are visible and filtered.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DisabledNodeStyle | Gets or sets the drawing style of the disabled tree node.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property DragDropMode | Gets or sets the type of drag-and-drop operation.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property ExpandBoxStyle | Gets or sets the drawing style of the tree node expand/collapse buttons.
public property FadingEffect (inherited from ListBase) | Gets or sets an enumeration that determines the fading effect used during hovering over items.
public property FadingSpeed (inherited from ListBase) | Gets or sets an enumeration that determines the speed of fading used during hovering over items.
public property FlatNodes | Gets the flat collection of tree nodes.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property FocusedNode | Gets or sets the tree node that has the input focus.
public property FocusedNodeStyle | Gets or sets the drawing style of the focused tree node.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property FormatStyle | Gets or sets the format style of the tree view control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
public property HoverNodeStyle | Gets or sets the drawing style of the hovered tree node.
public property HoverSelection | Gets or sets a value indicating whether the tree node can be selected while mouse cursor hovers over it.
public property ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
public property ImageList (inherited from ListBase) | Gets or sets the ImageList that contains the Image objects used by the TreeViewItems.
public property Indent | Gets or sets the distance to indent each of the child tree node levels.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property LabelEdit | Gets or sets a value indicating whether the text of the tree nodes can be edited.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property NodeFormatStyle | Gets or sets the format style of the tree node.
public property NodeHighlightType | Gets or sets the value indicating how the tree node is drawn.
public property NodeSpacing | Gets or sets the vertical spacing between tree nodes.
public property Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
public property NormalNodeStyle | Gets or sets the default drawing style of the tree node.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property PathSeparator | Gets or sets the delimiter string that the tree node path uses.
public property PreserveCheckState | Gets or sets a value indicating whether the tree nodes preserves their CheckState property value unchanged.
public property PreserveSelection | Gets or sets a value indicating whether the tree nodes preserves their Selected property value unchanged.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
public property ScrollBarStyle | Gets or sets the drwaing style of the scroll bars in the tree view .
public property SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
public property SelectedNode | Gets or sets the tree node that is currently selected in the tree view control.
public property SelectedNodes | Gets the collection of selected tree nodes.
public property SelectedNodeStyle | Gets or sets the drawing style of selected tree node.
public property SelectionMode | Gets or sets the method in which tree nodes are selected in the tree view control.
public property ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
public property ShowPlusMinus | Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree nodes that contain child tree nodes.
public property ShowRootLines | Indicates whether lines are displayed between root nodes.
public property ShowStateImages | Gets or sets a value indicating whether state images (flags) are visible.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property StateImageList (inherited from ListBase) | Gets or sets the ImageList that contains the Image objects used to represent different states of the TreeNodes.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text (inherited from Control) | Overridden. See Control.Text.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property TopNode | Gets the first fully-visible tree node in the tree view control.
public property TopNodes | Gets the collection of tree nodes that are fixed to top side of the control.
public property UseTheme | Overridden. Determines whether the control will render according to current system theme and color scheme.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control.
public property VisualStyle (inherited from ListBase) | Gets or sets an enumeration that determines the renderer of the control.
public property WatermarkImage (inherited from ListBase) | Specifies the image which can be used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Protected Properties

protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultSize (inherited from Control) | See Control.DefaultSize.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

TreeView Class | LidorSystems.IntegralUI.Lists Namespace


AllowSelectionCheck Property

TreeView.AllowSelectionCheck Property

Determines whether the node check box is altered during selection.

[Visual Basic]
Public Property AllowSelectionCheck As Boolean
[C#]
public bool AllowSelectionCheck { get; set; }
[C++]
public: __property bool get_AllowSelectionCheck();
public: __property void set_AllowSelectionCheck(bool );
[JScript]
public function get AllowSelectionCheck() : bool
public function set AllowSelectionCheck(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BottomNodes Property

TreeView.BottomNodes Property

Gets the collection of tree nodes that are fixed to bottom side of the control.

[Visual Basic]
Public ReadOnly Property BottomNodes As TreeNodeCollection
[C#]
public TreeNodeCollection BottomNodes {get;}
[C++]
public: __property TreeNodeCollection* get_BottomNodes();
[JScript]
public function get BottomNodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the tree nodes fixed to bottom side of the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxes Property

TreeView.CheckBoxes Property

Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.

[Visual Basic]
Public Property CheckBoxes As Boolean
[C#]
public bool CheckBoxes { get; set; }
[C++]
public: __property bool get_CheckBoxes();
public: __property void set_CheckBoxes(bool );
[JScript]
public function get CheckBoxes() : bool
public function set CheckBoxes(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


CheckBoxStyle Property

TreeView.CheckBoxStyle Property

Gets or sets the drawing style of the tree node check box.

[Visual Basic]
Public Property CheckBoxStyle As CheckButtonBoxStyle
[C#]
public CheckButtonBoxStyle CheckBoxStyle {get; set;}
[C++]
public: __property CheckButtonBoxStyle get_CheckBoxStyle();
public: __property void set_CheckBoxStyle(CheckButtonBoxStyle);
[JScript]
public function get CheckBoxStyle() : CheckButtonBoxStyle;
public function set CheckBoxStyle(CheckButtonBoxStyle);

Property Value

The CheckButtonBoxStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


CheckedNodes Property

TreeView.CheckedNodes Property

Gets the collection of checked tree nodes.

[Visual Basic]
Public ReadOnly Property CheckedNodes As TreeNodeCollection
[C#]
public TreeNodeCollection CheckedNodes {get;}
[C++]
public: __property TreeNodeCollection* get_CheckedNodes();
[JScript]
public function get CheckedNodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the checked tree nodes assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ColorStyle Property

TreeView.ColorStyle Property

Gets or sets the drawing style of the tree view control.

[Visual Basic]
Public Property ColorStyle As TreeViewColorStyle
[C#]
public TreeViewColorStyle ColorStyle {get; set;}
[C++]
public: __property TreeViewColorStyle get_ColorStyle();
public: __property void set_ColorStyle(TreeViewColorStyle);
[JScript]
public function get ColorStyle() : TreeViewColorStyle;
public function set ColorStyle(TreeViewColorStyle);

Property Value

The TreeViewColorStyle assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


CurrentList Property

TreeView.CurrentList Property

Gets the flat list of all nodes that are visible and filtered.

[Visual Basic]
Public ReadOnly Property CurrentList As TreeNodeCollection
[C#]
public TreeNodeCollection CurrentList {get;}
[C++]
public: __property TreeNodeCollection* get_CurrentList();
[JScript]
public function get CurrentList() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the single ordered list of tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


DisabledNodeStyle Property

TreeView.DisabledNodeStyle Property

Gets or sets the drawing style of the disabled tree node.

[Visual Basic]
Public Property DisabledNodeStyle As ListItemColorStyle
[C#]
public ListItemColorStyle DisabledNodeStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_DisabledNodeStyle();
public: __property void set_DisabledNodeStyle(ListItemColorStyle);
[JScript]
public function get DisabledNodeStyle() : ListItemColorStyle;
public function set DisabledNodeStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ExpandBoxStyle Property

TreeView.ExpandBoxStyle Property

Gets or sets the drawing style of the tree node expand/collapse buttons.

[Visual Basic]
Public Property ExpandBoxStyle As ExpandBoxStyle
[C#]
public ExpandBoxStyle ExpandBoxStyle {get; set;}
[C++]
public: __property ExpandBoxStyle get_ExpandBoxStyle();
public: __property void set_ExpandBoxStyle(ExpandBoxStyle);
[JScript]
public function get ExpandBoxStyle() : ExpandBoxStyle;
public function set ExpandBoxStyle(ExpandBoxStyle);

Property Value

The ExpandBoxStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FlatNodes Property

TreeView.FlatNodes Property

Gets the flat collection of tree nodes.

[Visual Basic]
Public ReadOnly Property FlatNodes As TreeNodeCollection
[C#]
public TreeNodeCollection FlatNodes {get;}
[C++]
public: __property TreeNodeCollection* get_FlatNodes();
[JScript]
public function get FlatNodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the single ordered list of tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FocusedNode Property

TreeView.FocusedNode Property

Gets or sets the tree node that has the input focus.

[Visual Basic]
Public Property FocusedNode As TreeNode
[C#]
public TreeNode FocusedNode {get; set;}
[C++]
public: __property TreeNode* get_FocusedNode();
public: __property void set_FocusedNode(TreeNode*);
[JScript]
public function get FocusedNode() : TreeNode;
public function set FocusedNode(TreeNode);

Property Value

The TreeNode that has the
                input focus in the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium
                Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista,
                Windows Server 2003 family, Windows 7

See Also

TreeView Class |
                    TreeView Members | LidorSystems.IntegralUI.Lists
                    Namespace

Send
                        comments on this topic.

Copyright © 2013 Lidor Systems. All
                        rights reserved.


FocusedNodeStyle Property

TreeView.FocusedNodeStyle Property

Gets or sets the drawing style of the focused tree node.

[Visual Basic]
Public Property FocusedNodeStyle As ListItemColorStyle
[C#]
public ListItemColorStyle FocusedNodeStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_FocusedNodeStyle();
public: __property void set_FocusedNodeStyle(ListItemColorStyle);
[JScript]
public function get FocusedNodeStyle() : ListItemColorStyle;
public function set FocusedNodeStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FormatStyle Property

TreeView.FormatStyle Property

Gets or sets the format style of the tree view control.

[Visual Basic]
Public Property FormatStyle As TreeViewFormatStyle
[C#]
public TreeViewFormatStyle FormatStyle {get; set;}
[C++]
public: __property TreeViewFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(TreeViewFormatStyle);
[JScript]
public function get FormatStyle() : TreeViewFormatStyle;
public function set FormatStyle(TreeViewFormatStyle);

Property Value

The TreeViewFormatStyle assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


HideSelection Property

TreeView.HideSelection Property

Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection { get; set; }
[C++]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(bool );
[JScript]
public function get HideSelection() : bool
public function set HideSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


HoverNodeStyle Property

TreeView.HoverNodeStyle Property

Gets or sets the drawing style of the hovered tree node.

[Visual Basic]
Public Property HoverNodeStyle As ListItemColorStyle
[C#]
public ListItemColorStyle HoverNodeStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_HoverNodeStyle();
public: __property void set_HoverNodeStyle(ListItemColorStyle);
[JScript]
public function get HoverNodeStyle() : ListItemColorStyle;
public function set HoverNodeStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


HoverSelection Property

TreeView.HoverSelection Property

Gets or sets a value indicating whether the tree node can be selected while mouse cursor hovers over it.

[Visual Basic]
Public Property HoverSelection As Boolean
[C#]
public bool HoverSelection { get; set; }
[C++]
public: __property bool get_HoverSelection();
public: __property void set_HoverSelection(bool );
[JScript]
public function get HoverSelection() : bool
public function set HoverSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


Indent Property

TreeView.Indent Property

Gets or sets the distance to indent each of the child tree node levels.

[Visual Basic]
Public Property Indent As Integer
[C#]
public int Indent {get; set;}
[C++]
public: __property int get_Indent();
public: __property void set_Indent(int);
[JScript]
public function get Indent() : int;
public function set Indent(int);

Property Value

The distance, in pixels, to indent each of the child tree node levels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


LabelEdit Property

TreeView.LabelEdit Property

Gets or sets a value indicating whether the text of the tree nodes can be edited.

[Visual Basic]
Public Property LabelEdit As Boolean
[C#]
public bool LabelEdit {get; set;}
[C++]
public: __property bool get_LabelEdit();
public: __property void set_LabelEdit(bool);
[JScript]
public function get LabelEdit() : Boolean;
public function set LabelEdit(Boolean);

Property Value

true if the label text of the tree nodes can be edited; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeFormatStyle Property

TreeView.NodeFormatStyle Property

Gets or sets the format style of the tree node.

[Visual Basic]
Public Property NodeFormatStyle As ListItemFormatStyle
[C#]
public ListItemFormatStyle NodeFormatStyle {get; set;}
[C++]
public: __property ListItemFormatStyle get_NodeFormatStyle();
public: __property void set_NodeFormatStyle(ListItemFormatStyle);
[JScript]
public function get NodeFormatStyle() : ListItemFormatStyle;
public function set NodeFormatStyle(ListItemFormatStyle);

Property Value

The ListItemFormatStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeHighlightType Property

TreeView.NodeHighlightType Property

Gets or sets the value indicating how the tree node is drawn.

[Visual Basic]
Public Property NodeHighlightType As TreeNodeHighlightType
[C#]
public TreeNodeHighlightType NodeHighlightType {get; set;}
[C++]
public: __property TreeNodeHighlightType get_NodeHighlightType();
public: __property void set_NodeHighlightType(TreeNodeHighlightType);
[JScript]
public function get NodeHighlightType() : TreeNodeHighlightType;
public function set NodeHighlightType(TreeNodeHighlightType);

Property Value

The TreeNodeHighlightType assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeSpacing Property

TreeView.NodeSpacing Property

Gets or sets the vertical spacing between tree nodes.

[Visual Basic]
Public Property NodeSpacing As Integer
[C#]
public int NodeSpacing {get; set;}
[C++]
public: __property int get_NodeSpacing();
public: __property void set_NodeSpacing(int);
[JScript]
public function get NodeSpacing() : int;
public function set NodeSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


Nodes Property

TreeView.Nodes Property

Gets the collection of tree nodes that are assigned to the tree view control.

[Visual Basic]
Public ReadOnly Property Nodes As TreeNodeCollection
[C#]
public TreeNodeCollection Nodes {get;}
[C++]
public: __property TreeNodeCollection* get_Nodes();
[JScript]
public function get Nodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the tree nodes assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NormalNodeStyle Property

TreeView.NormalNodeStyle Property

Gets or sets the default drawing style of the tree node.

[Visual Basic]
Public Property NormalNodeStyle As ListItemColorStyle
[C#]
public ListItemColorStyle NormalNodeStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_NormalNodeStyle();
public: __property void set_NormalNodeStyle(ListItemColorStyle);
[JScript]
public function get NormalNodeStyle() : ListItemColorStyle;
public function set NormalNodeStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


PathSeparator Property

TreeView.PathSeparator Property

Gets or sets the delimiter string that the tree node path uses.

[Visual Basic]
Public Property PathSeparator As String
[C#]
public string PathSeparator {get; set;}
[C++]
public: __property String* get_PathSeparator();
public: __property void set_PathSeparator(String*);
[JScript]
public function get PathSeparator() : String;
public function set PathSeparator(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


PreserveCheckState Property

TreeView.PreserveCheckState Property

Gets or sets a value indicating whether the tree nodes preserves their CheckState property value unchanged.

[Visual Basic]
Public Property PreserveCheckState As Boolean
[C#]
public bool PreserveCheckState { get; set; }
[C++]
public: __property bool get_PreserveCheckState();
public: __property void set_PreserveCheckState(bool );
[JScript]
public function get PreserveCheckState() : bool
public function set PreserveCheckState(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


PreserveSelection Property

TreeView.PreserveSelection Property

Gets or sets a value indicating whether the tree nodes preserves their Selected property value unchanged.

[Visual Basic]
Public Property PreserveSelection As Boolean
[C#]
public bool PreserveSelection { get; set; }
[C++]
public: __property bool get_PreserveSelection();
public: __property void set_PreserveSelection(bool );
[JScript]
public function get PreserveSelection() : bool
public function set PreserveSelection(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


Scrollable Property

TreeView.Scrollable Property

Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}
[C++]
public: __property bool get_Scrollable();
public: __property void set_Scrollable(bool);
[JScript]
public function get Scrollable() : Boolean;
public function set Scrollable(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ScrollBarStyle Property

TreeView.ScrollBarStyle Property

Gets or sets the drawing style of the scroll bars in the tree view.

[Visual Basic]
Public Property ScrollBarStyle As ScrollBarStyle
[C#]
public ScrollBarStyle ScrollBarStyle {get; set;}
[C++]
public: __property ScrollBarStyle get_ScrollBarStyle();
public: __property void set_ScrollBarStyle(ScrollBarStyle);
[JScript]
public function get ScrollBarStyle() : ScrollBarStyle;
public function set ScrollBarStyle(ScrollBarStyle);

Property Value

The ScrollBarStyle assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SelectedNode Property

TreeView.SelectedNode Property

Gets or sets the tree node that is currently selected in the tree view control.

[Visual Basic]
Public Property SelectedNode As TreeNode
[C#]
public TreeNode SelectedNode {get; set;}
[C++]
public: __property TreeNode* get_SelectedNode();
public: __property void set_SelectedNode(TreeNode*);
[JScript]
public function get SelectedNode() : TreeNode;
public function set SelectedNode(TreeNode);

Property Value

The TreeNode that is currently selected in the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SelectedNodes Property

TreeView.SelectedNodes Property

Gets the collection of selected tree nodes.

[Visual Basic]
Public ReadOnly Property SelectedNodes As TreeNodeCollection
[C#]
public TreeNodeCollection SelectedNodes {get;}
[C++]
public: __property TreeNodeCollection* get_SelectedNodes();
[JScript]
public function get SelectedNodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the selected tree nodes assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SelectedNodeStyle Property

TreeView.SelectedNodeStyle Property

Gets or sets the drawing style of selected tree node.

[Visual Basic]
Public Property SelectedNodeStyle As ListItemColorStyle
[C#]
public ListItemColorStyle SelectedNodeStyle {get; set;}
[C++]
public: __property ListItemColorStyle get_SelectedNodeStyle();
public: __property void set_SelectedNodeStyle(ListItemColorStyle);
[JScript]
public function get SelectedNodeStyle() : ListItemColorStyle;
public function set SelectedNodeStyle(ListItemColorStyle);

Property Value

The ListItemColorStyle assigned to the tree view control used for all tree nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SelectionMode Property

TreeView.SelectionMode Property

Gets or sets the method in which tree nodes are selected in the tree view control.

[Visual Basic]
Public Property SelectionMode As SelectionMode
[C#]
public SelectionMode SelectionMode {get; set;}
[C++]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(SelectionMode);
[JScript]
public function get SelectionMode() : SelectionMode;
public function set SelectionMode(SelectionMode);

Property Value

One of the SelectionMode values. The default is SelectionMode.One.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ShowLines Property

TreeView.ShowLines Property

Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.

[Visual Basic]
Public Property ShowLines As Boolean
[C#]
public bool ShowLines {get; set;}
[C++]
public: __property bool get_ShowLines();
public: __property void set_ShowLines(bool);
[JScript]
public function get ShowLines() : Boolean;
public function set ShowLines(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ShowPlusMinus Property

TreeView.ShowPlusMinus Property

Gets or sets a value indicating whether expand/collapse buttons are displayed next to tree nodes that contain child tree nodes.

[Visual Basic]
Public Property ShowPlusMinus As Boolean
[C#]
public bool ShowPlusMinus {get; set;}
[C++]
public: __property bool get_ShowPlusMinus();
public: __property void set_ShowPlusMinus(bool);
[JScript]
public function get ShowPlusMinus() : Boolean;
public function set ShowPlusMinus(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ShowRootLines Property

TreeView.ShowRootLines Property

Indicates whether lines are displayed between root nodes.

[Visual Basic]
Public Property ShowRootLines As Boolean
[C#]
public bool ShowRootLines {get; set;}
[C++]
public: __property bool get_ShowRootLines();
public: __property void set_ShowRootLines(bool);
[JScript]
public function get ShowRootLines() : Boolean;
public function set ShowRootLines(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


TopNode Property

TreeView.TopNode Property

Gets the first fully-visible tree node in the tree view control.

[Visual Basic]
Public ReadOnly Property TopNode As TreeNode
[C#]
public TreeNode TopNode {get;}
[C++]
public: __property TreeNode* get_TopNode();
[JScript]
public function get TopNode() : TreeNode;

Property Value

A TreeNode that represents the first fully-visible tree node in the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


TopNodes Property

TreeView.TopNodes Property

Gets the collection of tree nodes that are fixed to top side of the control.

[Visual Basic]
Public ReadOnly Property TopNodes As TreeNodeCollection
[C#]
public TreeNodeCollection TopNodes {get;}
[C++]
public: __property TreeNodeCollection* get_TopNodes();
[JScript]
public function get TopNodes() : TreeNodeCollection;

Property Value

A TreeNodeCollection that represents the checked tree nodes fixed to top side of the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


UseTheme Property

TreeView.UseTheme Property

Overridden. Determines whether the control will render according to current system theme and color scheme.

[Visual Basic]
Public Property UseTheme As Boolean
[C#]
public bool UseTheme { get; set; }
[C++]
public: __property bool get_UseTheme();
public: __property void set_UseTheme(bool );
[JScript]
public function get UseTheme() : bool
public function set UseTheme(bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


VisibleCount Property

TreeView.VisibleCount Property

Gets the number of tree nodes that can be fully visible in the tree view control.

[Visual Basic]
Public ReadOnly Property VisibleCount As Integer
[C#]
public int VisibleCount {get;}
[C++]
public: __property int get_VisibleCount();
[JScript]
public function get VisibleCount() : int;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


VisualStyle Property

TreeView.VisualStyle Property

Overridden. Gets or sets an enumeration that determines the renderer of the control.

[Visual Basic]
Public Property VisualStyle As VisualStyle
[C#]
public VisualStyle VisualStyle {get; set;}
[C++]
public: __property VisualStyle get_VisualStyle();
public: __property void set_VisualStyle(VisualStyle);
[JScript]
public function get VisualStyle() : VisualStyle;
public function set VisualStyle(VisualStyle);

Property Value

The VisualStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


TreeView Methods

The methods of the TreeView class are listed here. For a complete list of TreeView class members, see the TreeView Members topic.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method ChangeCheckState | Changes the CheckState of nodes without firing BeforeCheck and AfterCheck events.
public method CollapseAll | Collapses all the tree nodes.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method ExpandAll | Expands all the tree nodes.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method FindNode | Searched for tree node using specified criteria.
public method Focus (inherited from Control) | Sets input focus to the control.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetNodeAt | Retrieves the tree node that is at the specified location.
public method GetNodeCount | Retrieves the number of tree nodes and optionally including subnodes.
public method GetScrollPos | Retrieves the current position of the vertical scrollbar.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method IsHScrollVisible | Check whether horizontal scrollbar is visible in the tree view control.
public method IsVScrollVisible | Check whether vertical scrollbar is visible in the tree view control.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method ResumePaint (inherited from ListBase) | Resumes the painting of the control.
public method ResumeUpdate | Overridden. Resumes update of the control.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method SetScrollPos | Sets the position of the vertical scroll bar.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method SuspendPaint (inherited from ListBase) | Temporarily suspends the painting of the control.
public method SuspendUpdate | Overridden. Temporarily suspends the update of the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
protected method UpdateLayout | Overridden. Update layout logic of the control.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAfterCheck | Raises the AfterCheck event.
protected method OnAfterCollapse | Raises the AfterCollapse event.
protected method OnAfterExpand | Raises the AfterExpand event.
protected method OnAfterLabelEdit | Raises the AfterLabelEdit event.
protected method OnAfterSelect | Raises the AfterSelect event.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBeforeCheck | Raises the BeforeCheck event.
protected method OnBeforeCollapse | Raises the BeforeCollapse event.
protected method OnBeforeExpand | Raises the BeforeExpand event.
protected method OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
protected method OnBeforeSelect | Raises the BeforeSelect event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNodeAdded | Raises the NodeAdded event.
protected method OnNodeAdding | Raises the NodeAdding event.
protected method OnNodeRemoved | Raises the NodeRemoved event.
protected method OnNodeRemoving | Raises the NodeRemoving event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnResize | Overridden. See Control.OnResize.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey | Overriden. Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

TreeView Class | LidorSystems.IntegralUI.Lists Namespace


ChangeCheckState Method

TreeView.ChangeCheckState Method

Changes the CheckState of nodes without firing BeforeCheck and AfterCheck events.

[Visual Basic]
Public Sub ChangeCheckState( _
 ByVal node As TreeNode _
 ByVal value As CheckState _
)
[C#]
public void ChangeCheckState(
 TreeNode node
 CheckState value
);
[C++]
public : void ChangeCheckState(
 TreeNode* node
 CheckState value
);
[JScript]
public  function ChangeCheckState(
 node : TreeNode
 value : CheckState
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


CollapseAll Method

TreeView.CollapseAll Method

Collapses all the tree nodes.

[Visual Basic]
Public Sub CollapseAll()
[C#]
public void CollapseAll();
[C++]
 public: void CollapseAll();
[JScript]
public function CollapseAll();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


Dispose Method

TreeView.Dispose Method

This member overrides Control.Dispose.

[Visual Basic]
Overrides Overloads Protected Sub Dispose()
[C#]
protected override void Dispose();
[C++]
protected: void Dispose();
[JScript]
protected override function Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeView.EnsureVisible Method

Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.

Overload List

Ensures that sprecific tree node is visible in current view of the control.

[Visual Basic] Public Sub EnsureVisible(TreeNode)
[C#] public void EnsureVisible(TreeNode);
[C++] public: void EnsureVisible(TreeNode);
[JScript] public function EnsureVisible(TreeNode);

Ensures that sprecific tree node is visible in current view of the control and placed at specified vertical position.

[Visual Basic] Public Function EnsureVisible(TreeNode, VerticalAlignment)
[C#] public void EnsureVisible(TreeNode, VerticalAlignment);
[C++] public: void EnsureVisible(TreeNode, VerticalAlignment);
[JScript] public function EnsureVisible(TreeNode, VerticalAlignment);

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeView.EnsureVisible (TreeNode) Method

Ensures that sprecific tree node is visible in current view of the control.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal node As TreeNode)
[C#]
public void EnsureVisible(
   TreeNode node);
[C++]
public: void EnsureVisible(
   TreeNode* node);
[JScript]
public function EnsureVisible(
   node : TreeNode)

Parameters

node

The TreeNode which needs to become visible in current view of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


EnsureVisible Method

TreeView.EnsureVisible (TreeNode, VerticalAlignment) Method

Ensures that sprecific tree node is visible in current view of the control and placed at specified vertical position.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal node As TreeNode _
   ByVal position As VerticalAlignment _
)
[C#]
public void EnsureVisible(
   TreeNode node
   VerticalAlignment position
);
[C++]
public: void EnsureVisible(
   TreeNode* node
   VerticalAlignment position
);
[JScript]
public function EnsureVisible(
   node : TreeNode
   position : VerticalAlignment
)

Parameters

node

The TreeNode which needs to become visible in current view of the control.

position

The position determined by VerticalAlignment at which the node will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ExpandAll Method

TreeView.ExpandAll Method

Expands all the tree nodes.

[Visual Basic]
Public Sub ExpandAll()
[C#]
public void ExpandAll();
[C++]
 public: void ExpandAll();
[JScript]
public function ExpandAll();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FindNode Method

TreeView.FindNode Method

Searches for tree node using specified criteria.

[Visual Basic]
Public Function FindNode( _
   ByVal value As String _
   ByVal criteria As TreeNodeCriteria _
) As TreeNode
[C#]
public TreeNode FindNode(
   String value
   TreeNodeCriteria criteria
);
[C++]
public: TreeNode* FindNode(
   String* value
   TreeNodeCriteria criteria
);
[JScript]
public function FindNode(
   value : String
   criteria : TreeNodeCriteria
) : TreeNode;

Parameters

value

The value to search for

criteria

The search type specified by TreeNodeCriteria.

Return Value

The TreeNode that contains the value specified by the value parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


GetNodeAt Method

TreeView.GetNodeAt Method

Retrieves the tree node that is at the specified location.

Overload List

Retrieves the tree node that is at the specified point.

[Visual Basic] Overloads Public Function GetNodeAt(Point) As TreeNode
[C#] public TreeNode GetNodeAt(Point);
[C++] public: TreeNode* GetNodeAt(Point);
[JScript] public function GetNodeAt(Point) : TreeNode;

Retrieves the tree node at the point with the specified coordinates.

[Visual Basic] Overloads Public Function GetNodeAt(Integer, Integer) As TreeNode
[C#] public TreeNode GetNodeAt(int, int);
[C++] public: TreeNode* GetNodeAt(int, int);
[JScript] public function GetNodeAt(int, int) : TreeNode;

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


GetNodeAt (Point) Method

TreeView.GetNodeAt (Point) Method

Retrieves the tree node that is at the specified point.

[Visual Basic]
Overloads Public Function GetNodeAt( _
   ByVal pt As Point _
) As TreeNode
[C#]
public TreeNode GetNodeAt(
   Point pt
);
[C++]
public: TreeNode* GetNodeAt(
   Point pt
);
[JScript]
public function GetNodeAt(
   pt : Point
) : TreeNode;

Parameters

pt
The Point to evaluate and retrieve the node from.

Return Value

The TreeNode at the specified point, in tree view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


GetNodeAt (Int32, Int32) Method

TreeView.GetNodeAt (Int32, Int32) Method

Retrieves the tree node at the point with the specified coordinates.

[Visual Basic]
Overloads Public Function GetNodeAt( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TreeNode
[C#]
public TreeNode GetNodeAt(
   int x,
   int y
);
[C++]
public: TreeNode* GetNodeAt(
   int x,
   int y
);
[JScript]
public function GetNodeAt(
   x : int,
   y : int
) : TreeNode;

Parameters

x
The X position to evaluate and retrieve the node from.
y
The Y position to evaluate and retrieve the node from.

Return Value

The TreeNode at the specified location, in tree view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


GetNodeCount Method

TreeView.GetNodeCount Method

Retrieves the number of tree nodes and optionally including subnodes.

[Visual Basic]
Public Function GetNodeCount( _
   ByVal subNodes As Boolean _
) As Integer
[C#]
public int GetNodeCount(
   bool subNodes
);
[C++]
public: int GetNodeCount(
   bool subNodes
);
[JScript]
public function GetNodeCount(
   subNodes : Boolean
) : int;

Parameters

subNodes
If true, it will count the subnodes.

Return Value

The number of tree nodes assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


GetScrollPos Method

TreeView.GetScrollPos Method

Retrieves the current position of the vertical scrollbar.

[Visual Basic]
Overloads Public Function GetScrollPos() As Point
[C#]
public Point GetScrollPos();
[C++]
public: Point* GetScrollPos();
[JScript]
public function GetScrollPos() : Point;

Return Value

The current position of the vertical scrollbar, in tree view coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


IsHScrollVisible Method

TreeView.IsHScrollVisible Method

Check whether horizontal scrollbar is visible in the tree view control.

[Visual Basic]
Public Function IsHScrollVisible() As Boolean
[C#]
public bool IsHScrollVisible();
[C++]
public: bool IsHScrollVisible();
[JScript]
public function IsHScrollVisible() : Boolean;

Return Value

True if horizontal scrollbar is visible, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


IsVScrollVisible Method

TreeView.IsVScrollVisible Method

Check whether vertical scrollbar is visible in the tree view control.

[Visual Basic]
Public Function IsVScrollVisible() As Boolean
[C#]
public bool IsVScrollVisible();
[C++]
public: bool IsVScrollVisible();
[JScript]
public function IsVScrollVisible() : Boolean;

Return Value

True if vertical scrollbar is visible, otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterCheck Method

TreeView.OnAfterCheck Method

Raises the AfterCheck event.

[Visual Basic]
Protected Overridable Sub OnAfterCheck( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterCheck(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterCheck(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterCheck(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterCollapse Method

TreeView.OnAfterCollapse Method

Raises the AfterCollapse event.

[Visual Basic]
Protected Overridable Sub OnAfterCollapse( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterCollapse(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterCollapse(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterCollapse(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterExpand Method

TreeView.OnAfterExpand Method

Raises the AfterExpand event.

[Visual Basic]
Protected Overridable Sub OnAfterExpand( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterExpand(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterExpand(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterExpand(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterLabelEdit Method

TreeView.OnAfterLabelEdit Method

Raises the AfterLabelEdit event.

[Visual Basic]
Protected Overridable Sub OnAfterLabelEdit( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterLabelEdit(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterLabelEdit(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterLabelEdit(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnAfterSelect Method

TreeView.OnAfterSelect Method

Raises the AfterSelect event.

[Visual Basic]
Protected Overridable Sub OnAfterSelect( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnAfterSelect(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnAfterSelect(
   ObjectEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeCheck Method

TreeView.OnBeforeCheck Method

Raises the BeforeCheck event.

[Visual Basic]
Protected Overridable Sub OnBeforeCheck( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeCheck(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeCheck(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeCheck(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeCollapse Method

TreeView.OnBeforeCollapse Method

Raises the BeforeCollapse event.

[Visual Basic]
Protected Overridable Sub OnBeforeCollapse( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeCollapse(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeCollapse(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeCollapse(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeExpand Method

TreeView.OnBeforeExpand Method

Raises the BeforeExpand event.

[Visual Basic]
Protected Overridable Sub OnBeforeExpand( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeExpand(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeExpand(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeExpand(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeLabelEdit Method

TreeView.OnBeforeLabelEdit Method

Raises the BeforeLabelEdit event.

[Visual Basic]
Protected Overridable Sub OnBeforeLabelEdit( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeLabelEdit(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeLabelEdit(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeLabelEdit(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnBeforeSelect Method

TreeView.OnBeforeSelect Method

Raises the BeforeSelect event.

[Visual Basic]
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnBeforeSelect(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnBeforeSelect(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnBeforeSelect(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnNodeAdded Method

TreeView.OnNodeAdded Method

Raises the NodeAdded event.

[Visual Basic]
Protected Overridable Sub OnNodeAdded( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnNodeAdded(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnNodeAdded(
   ObjectEventArgs* e
);
[JScript]
protected function OnNodeAdded(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnNodeAdding Method

TreeView.OnNodeAdding Method

Raises the NodeAdding event.

[Visual Basic]
Protected Overridable Sub OnNodeAdding( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnNodeAdding(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnNodeAdding(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnNodeAdding(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnNodeRemoved Method

TreeView.OnNodeRemoved Method

Raises the NodeRemoved event.

[Visual Basic]
Protected Overridable Sub OnNodeRemoved( _
   ByVal e As ObjectEventArgs _
)
[C#]
protected virtual void OnNodeRemoved(
   ObjectEventArgs e
);
[C++]
protected: virtual void OnNodeRemoved(
   ObjectEventArgs* e
);
[JScript]
protected function OnNodeRemoved(
   e : ObjectEventArgs
);

Parameters

e
A ObjectEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


OnNodeRemoving Method

TreeView.OnNodeRemoving Method

Raises the NodeRemoving event.

[Visual Basic]
Protected Overridable Sub OnNodeRemoving( _
   ByVal e As ObjectCancelEventArgs _
)
[C#]
protected virtual void OnNodeRemoving(
   ObjectCancelEventArgs e
);
[C++]
protected: virtual void OnNodeRemoving(
   ObjectCancelEventArgs* e
);
[JScript]
protected function OnNodeRemoving(
   e : ObjectCancelEventArgs
);

Parameters

e
A ObjectCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ProcessCmdKey Method

TreeView.ProcessCmdKey Method

This member overrides Control.ProcessCmdKey

[Visual Basic]
Overrides Protected Function ProcessCmdKey( _
   ByRef msg As Message, _
   ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
);
[C++]
protected: bool ProcessCmdKey(
   Message* msg,
   Keys keyData
);
[JScript]
protected override function ProcessCmdKey(
   msg : Message,
   keyData : Keys
) : Boolean;

Parameters

msg
A Message, passed by reference, that represents the window message to process.
keyData
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ResumeUpdate Method

TreeView.ResumeUpdate Method

Overridden. Resumes update of the control layout.

[Visual Basic]
Public Overridable Sub ResumeUpdate()
[C#]
public virtual void ResumeUpdate();
[C++]
public: virtual void * ResumeUpdate();
[JScript]
public function ResumeUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SuspendUpdate Method

TreeView.SuspendUpdate Method

Overridden. Temporarily suspends the update of the control.

[Visual Basic]
Public Overridable Sub SuspendUpdate()
[C#]
public virtual void SuspendUpdate();
[C++]
public: virtual void * SuspendUpdate();
[JScript]
public function SuspendUpdate() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


SetScrollPos (Point) Method

TreeView.SetScrollPos (Point) Method

Sets the position of the vertical scroll bar.

[Visual Basic]
 Public Sub SetScrollPos( _
   ByVal pt As Point _
)
[C#]
public void SetScrollPos(
   Point pt
);
[C++]
public: void SetScrollPos(
   Point pt
);
[JScript]
public function SetScrollPos(
   pt : Point
);

Parameters

pt
The Point at which the vertical scroll bar will be positioned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


UpdateLayout Method

TreeView.UpdateLayout Method

Overload List

Update layout logic of the control.

[Visual Basic] Public Sub UpdateLayout()
[C#] public UpdateLayout();
[C++] public: UpdateLayout();
[JScript] public function UpdateLayout();

Update layout logic of the specified ListBaseItem object.

[Visual Basic] Public Sub UpdateLayout(ListBaseItem)
[C#] public UpdateLayout(ListBaseItem);
[C++] public: UpdateLayout(ListBaseItem);
[JScript] public function UpdateLayout(ListBaseItem);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


UpdateLayout () Method

TreeView.UpdateLayout () Method

Overridden. Update layout logic of the control.

[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
 public: void * UpdateLayout();
[JScript]
public function UpdateLayout() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


UpdateLayout (ListBaseItem) Method

TreeView.UpdateLayout (ListBaseItem) Method

Overridden. Update layout logic of the specified ListBaseItem object.

[Visual Basic]
Overrides Protected Sub UpdateLayout( _
   ByVal item As ListBaseItem _
)
[C#]
protected override void UpdateLayout(
   ListBaseItem item
);
[C++]
protected: void UpdateLayout(
   ListBaseItem* item
);
[JScript]
protected override function UpdateLayout(
   item : ListBaseItem
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


TreeView Events

The events of the TreeView class are listed here. For a complete list of TreeView class members, see the TreeView Members topic.

Public Events

public event AfterCheck | Occurs after the TreeNode check box is checked.
public event AfterCollapse | Occurs after the TreeNode is collapsed.
public event AfterExpand | Occurs after the TreeNode is expanded.
public event AfterLabelEdit | Occurs after the TreeNode text is edited.
public event AfterSelect | Occurs after the TreeNode is selected.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event BeforeCheck | Occurs before the TreeNode check box is checked.
public event BeforeCollapse | Occurs before the TreeNode is collapsed.
public event BeforeExpand | Occurs before the TreeNode is expanded.
public event BeforeLabelEdit | Occurs before the TreeNode text is edited.
public event BeforeSelect | Occurs before the TreeNode is selected.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FocusedNodeChanged | Occurs after the FocusedNode is changed.
public event FocusedNodeChanging | Occurs before the FocusedNode is changed.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event NodeAdded | Occurs after the TreeNode is added.
public event NodeAdding | Occurs before the TreeNode is added.
public event NodeRemoved | Occurs after the TreeNode is removed.
public event NodeRemoving | Occurs before the TreeNode is removed.
public event ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TreeView Class | LidorSystems.IntegralUI.Lists Namespace


AfterCheck Event

TreeView.AfterCheck Event

Occurs after the TreeNode check box is checked.

[Visual Basic]
Public Event AfterCheck As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterCheck;
[C++]
public: __event ObjectEventHandler* AfterCheck;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


AfterCollapse Event

TreeView.AfterCollapse Event

Occurs after the TreeNode is collapsed.

[Visual Basic]
Public Event AfterCollapse As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterCollapse;
[C++]
public: __event ObjectEventHandler* AfterCollapse;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


AfterExpand Event

TreeView.AfterExpand Event

Occurs after the TreeNode is expanded.

[Visual Basic]
Public Event AfterExpand As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterExpand;
[C++]
public: __event ObjectEventHandler* AfterExpand;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


AfterLabelEdit Event

TreeView.AfterLabelEdit Event

Occurs after the TreeNode text is edited.

[Visual Basic]
Public Event AfterLabelEdit As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterLabelEdit;
[C++]
public: __event ObjectEventHandler* AfterLabelEdit;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


AfterSelect Event

TreeView.AfterSelect Event

Occurs after the TreeNode is selected.

[Visual Basic]
Public Event AfterSelect As ObjectEventHandler
[C#]
public event ObjectEventHandler AfterSelect;
[C++]
public: __event ObjectEventHandler* AfterSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BeforeCheck Event

TreeView.BeforeCheck Event

Occurs before the TreeNode check box is checked.

[Visual Basic]
Public Event BeforeCheck As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeCheck;
[C++]
public: __event ObjectCancelEventHandler* BeforeCheck;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BeforeCollapse Event

TreeView.BeforeCollapse Event

Occurs before the TreeNode is collapsed.

[Visual Basic]
Public Event BeforeCollapse As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeCollapse;
[C++]
public: __event ObjectCancelEventHandler* BeforeCollapse;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BeforeExpand Event

TreeView.BeforeExpand Event

Occurs before the TreeNode is expanded.

[Visual Basic]
Public Event BeforeExpand As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeExpand;
[C++]
public: __event ObjectCancelEventHandler* BeforeExpand;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BeforeLabelEdit Event

TreeView.BeforeLabelEdit Event

Occurs before the TreeNode text is edited.

[Visual Basic]
Public Event BeforeLabelEdit As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeLabelEdit;
[C++]
public: __event ObjectCancelEventHandler* BeforeLabelEdit;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


BeforeSelect Event

TreeView.BeforeSelect Event

Occurs before the TreeNode is selected.

[Visual Basic]
Public Event BeforeSelect As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler BeforeSelect;
[C++]
public: __event ObjectCancelEventHandler* BeforeSelect;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FocusedNodeChanged Event

TreeView.FocusedNodeChanged Event

Occurs after the FocusedNode is changed.

[Visual Basic]
Public Event FocusedNodeChanged As ObjectEventHandler
[C#]
public event ObjectEventHandler FocusedNodeChanged;
[C++]
public: __event ObjectEventHandler* FocusedNodeChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FocusedNodeChanging Event

TreeView.FocusedNodeChanging Event

Occurs before the FocusedNode is changed.

[Visual Basic]
Public Event FocusedNodeChanging As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler FocusedNodeChanging;
[C++]
public: __event ObjectCancelEventHandler* FocusedNodeChanging;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeAdded Event

TreeView.NodeAdded Event

Occurs after the TreeNode is added.

[Visual Basic]
Public Event NodeAdded As ObjectEventHandler
[C#]
public event ObjectEventHandler NodeAdded;
[C++]
public: __event ObjectEventHandler* NodeAdded;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeAdding Event

TreeView.NodeAdding Event

OOccurs before the TreeNode is added.

[Visual Basic]
Public Event NodeAdding As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler NodeAdding;
[C++]
public: __event ObjectCancelEventHandler* NodeAdding;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeRemoved Event

TreeView.NodeRemoved Event

Occurs after the TreeNode is removed.

[Visual Basic]
Public Event NodeRemoved As ObjectEventHandler
[C#]
public event ObjectEventHandler NodeRemoved;
[C++]
public: __event ObjectEventHandler* NodeRemoved;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


NodeRemoving Event

TreeView.NodeRemoving Event

Occurs before the TreeNode is removed.

[Visual Basic]
Public Event NodeRemoving As ObjectCancelEventHandler
[C#]
public event ObjectCancelEventHandler NodeRemoving;
[C++]
public: __event ObjectCancelEventHandler* NodeRemoving;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type ObjectCancelEventArgs containing data related to this event. The following ObjectCancelEventArgs property provides information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


ColumnContentType Enumeration

Enumerator used to determine the type of column content.

[Visual Basic]
Public Enum ColumnContentType
[C#]
public enum ColumnContentType
[C++]
__value public enum ColumnContentType
[JScript]
public
   enum ColumnContentType

Members

Member name | Description
Image | In the column body, only images are shown.
Text | In the column body, only texts are shown.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ColumnFixedType Enumeration

Enumerator used to determine the which side the column is fixed.

[Visual Basic]
Public Enum ColumnFixedType
[C#]
public enum ColumnFixedType
[C++]
__value public enum ColumnFixedType
[JScript]
public
   enum ColumnFixedType

Members

Member name | Description
None | The column is not fixed.
Left | The column is fixed to the left side of the parent control.
Right | The column is fixed to the right side of the parent control.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ComparerObjectType Enumeration

Enumerator used to determine the type of objects in IComparer derived class.

[Visual Basic]
Public Enum ComparerObjectType
[C#]
public enum ComparerObjectType
[C++]
__value public enum ComparerObjectType
[JScript]
public
   enum ComparerObjectType

Members

Member name | Description
Double | The objects are of type double.
Integer | The objects are of type Integer.
String | The objects are of type String.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ContentControlVisibility Enumeration

Enumerator used to determine the visibility of control contained in some object.

[Visual Basic]
Public Enum ContentControlVisibility
[C#]
public enum ContentControlVisibility
[C++]
__value public enum ContentControlVisibility
[JScript]
public
   enum ContentControlVisibility

Members

Member name | Description
None | Contained control is hidden.
OnClick | Contained control is visible only when user clicks inside the object space or when the control has the input focus.
OnHover | Contained control is visible only when user hovers over the object space.
AlwaysVisible | Contained control is visible.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


DropMarkerType Enumeration

Enumerator used to determine the type of items ordering marker during drag-and-drop operation.

[Visual Basic]
Public Enum DropMarkerType
[C#]
public enum DropMarkerType
[C++]
__value public enum DropMarkerType
[JScript]
public
   enum DropMarkerType

Members

Member name | Description
Full | The marker used to show the ordering position in list structure.
Partial | The marker used to show the ordering position in hierachical structure.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ItemFixedType Enumeration

Enumerator used to determine the side at which the item is fixed in its parent control.

[Visual Basic]
Public Enum ItemFixedType
[C#]
public enum ItemFixedType
[C++]
__value public enum ItemFixedType
[JScript]
public
   enum ItemFixedType

Members

Member name | Description
None | The item is not fixed.
Top | The item is fixed to top side of parent control.
Bottom | The item is fixed to bottom side of parent control.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


KeySearchMode Enumeration

Enumerator used to determine the search method for an item when key is pressed.

[Visual Basic]
Public Enum KeySearchMode
[C#]
public enum KeySearchMode
[C++]
__value public enum KeySearchMode
[JScript]
public
   enum KeySearchMode

Members

Member name | Description
None | The search is disabled.
Partial | The search is started whenever there is a key(s) pressed.
Full | The same as Partial search, only this time the subitems (if present) are also included in searching.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ListItemHighlightType Enumeration

Enumerator used to determine how the list item is drawn.

[Visual Basic]
Public Enum ListItemHighlightType
[C#]
public enum ListItemHighlightType
[C++]
__value public enum ListItemHighlightType
[JScript]
public
   enum ListItemHighlightType

Members

Member name | Description
None | An item cannot be highlighted.
Full | An item is fully highlighted.
Partial | An item is partially highlighted.
TextOnly | Only the text of the item is highlighted.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


ListItemMoveDirection Enumeration

Enumerator used to determine the direction in which the item will be moved.

[Visual Basic]
Public Enum ListItemMoveDirection
[C#]
public enum ListItemMoveDirection
[C++]
__value public enum ListItemMoveDirection
[JScript]
public
   enum ListItemMoveDirection

Members

Member name | Description
Bottom | Moves the item to the last position in the collection.
Down | Moves the item to the next position in the hierarchy.
Top | Moves the item to the first position in the collection.
Up | Moves the item to the previous position in the hierarchy.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ListItemType Enumeration

Enumerator used to determine the look and functionality of the item.

[Visual Basic]
Public Enum ListItemType
[C#]
public enum ListItemType
[C++]
__value public enum ListItemType
[JScript]
public
   enum ListItemType

Members

Member name | Description
Item | The item is represented in its default state, showing icon, text and other content.
Separator | The item is represented as separator, showing a horizontal line.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ListSearchCriteria Enumeration

Enumerator used to determine the search criteria for items.

[Visual Basic]
Public Enum ListSearchCriteria
[C#]
public enum ListSearchCriteria
[C++]
__value public enum ListSearchCriteria
[JScript]
public
   enum ListSearchCriteria

Members

Member name | Description
byKey | Search criteria is represented by the Key property of the item.
byPath | Search criteria is represented by the FullPath property of the TreeNode.
byTagString | Search criteria is represented by the TagString property of the item.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ListViewAppearance Enumeration

Enumerator used to specify how list items are displayed in a ListView control.

[Visual Basic]
Public Enum ListViewAppearance
[C#]
public enum ListViewAppearance
[C++]
__value public enum ListViewAppearance
[JScript]
public
   enum ListViewAppearance

Members

Member name | Description
Details | Each item is displayed by it's subitems arranged in columns. The header and footer of the column can be optionaly visible.
LargeIcon | Each item is displayed with a large icon and a label below it.
List | Each item is displayed with a small icon and a label to its right.
SmallIcon | Each item is displayed with a small icon and a label to its right.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ListViewGroupDrawMode Enumeration

Enumerator used to determine how the group background is drawed.

[Visual Basic]
Public Enum ListViewGroupDrawMode
[C#]
public enum ListViewGroupDrawMode
[C++]
__value public enum ListViewGroupDrawMode
[JScript]
public
   enum ListViewGroupDrawMode

Members

Member name | Description
BottomLine | The bottom line is drawed just below the text in the group header.
CenterLine | The center line is drawed in the group header.
Gradient | The group header background is filled with gradient brush or a texture.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


ScrollMode Enumeration

Enumerator used to determine the method by which control content is scrolled.

[Visual Basic]
Public Enum ScrollMode
[C#]
public enum ScrollMode
[C++]
__value public enum ScrollMode
[JScript]
public
   enum ScrollMode

Members

Member name | Description
Default | The content is scrolled normaly, except for contained controls which are hidden.
ShowControls | The whole content including contained controls, is fully shown during scroll process.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


TreeNodeDisplayPosition Enumeration

Enumerator used to determine whether the node will be placed above or below its parent node.

[Visual Basic]
Public Enum TreeNodeDisplayPosition
[C#]
public enum TreeNodeDisplayPosition
[C++]
__value public enum TreeNodeDisplayPosition
[JScript]
public
   enum TreeNodeDisplayPosition

Members

Member name | Description
Above | The node is placed above its parent node.
Below | The node is placed below its parent node.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


TreeNodeMoveDirection Enumeration

Enumerator used to determine the direction in which the node will be moved.

[Visual Basic]
Public Enum TreeNodeMoveDirection
[C#]
public enum TreeNodeMoveDirection
[C++]
__value public enum TreeNodeMoveDirection
[JScript]
public
   enum TreeNodeMoveDirection

Members

Member name | Description
Bottom | Moves the node to the last position in the collection.
Down | Moves the node to the next position in the hierarchy.
Left | Decreases indent level of the node by one.
Right | Increases indent level of the node by one.
Top | Moves the node to the first position in the collection.
Up | Moves the node to the previous position in the hierarchy.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


LidorSystems.IntegralUI.Lists.Collections

LidorSystems.IntegralUI.Lists.Collections Namespace

Classes

Class | Description
TreeNodeCollection | Contains a collection of TreeNode objects.


TreeNodeCollection Class

Contains a collection of TreeNode objects.

For a list of all members of this type, see TreeNodeCollection Members.

System.Object
System.Collections.CollectionBase
LidorSystems.IntegralUI.Collections.ObjectCollection
LidorSystems.IntegralUI.Lists.Collections.TreeNodeCollection

[Visual Basic]
Public Class TreeNodeCollection
   Inherits LidorSystems.IntegralUI.Collections.ObjectCollection
[C#]
public class TreeNodeCollection : LidorSystems.IntegralUI.Collections.ObjectCollection
[C++]
public __gc class TreeNodeCollection : public LidorSystems.IntegralUI.Collections.ObjectCollection
[JScript]
public class TreeNodeCollection extends LidorSystems.IntegralUI.Collections.ObjectCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists.Collections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

TreeNodeCollection Members | LidorSystems.IntegralUI.Lists.Collections Namespace


TreeNodeCollection Members

TreeNodeCollection overview

Public Constructors

public constructor TreeNodeCollection Constructor Initializes a new instance of the TreeNodeCollection class.

Public Properties

public property Item | Gets a TreeNode at the specified location in the collection.
public property Owner (inherited from ObjectCollection) | Gets the object that owns the TreeNodeCollection.

Public Methods

public method Add (inherited from ObjectCollection) | Adds a new object to the end of the TreeNodeCollection.
public method AddRange (inherited from ObjectCollection) | Adds an array of objects to the TreeNodeCollection.
public method Clear (inherited from ObjectCollection) | Removes all objects from the collection.
public method Contains (inherited from ObjectCollection) | Determines whether the specified object exists in the collection.
public method Equals (inherited from Object) | Determines whether two Object instances are equal.
public method GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method IndexOf (inherited from ObjectCollection) | Returns the index of the specified object in the collection.
public method Insert (inherited from ObjectCollection) | Inserts an existing object in the TreeNodeCollection at the specified location.
public method Remove (inherited from ObjectCollection) | Removes the specified object from the TreeNodeCollection.
public method RemoveAt (inherited from ObjectCollection) | Removes the object at the specified index of the TreeNodeCollection.
public method SetChildIndex (inherited from ObjectCollection) | Sets the index of the specified object in the collection to the specified index value.
public method ToString (inherited from Object) | Returns a String that represents the current Object.

Public Events

public event Added (inherited from ObjectCollection ) | Occurs after an object is added.
public event Adding (inherited from ObjectCollection ) | Occurs before an object is added.
public event Removed (inherited from ObjectCollection ) | Occurs after an object is removed.
public event Removing (inherited from ObjectCollection ) | Occurs before an object is removing.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Methods

protected method Finalize (inherited from Object) | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnAdded | Overridden. Occurs after an TreeNode is added.
protected method OnAdding | Overridden. Occurs before an TreeNode is added.
protected method OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
protected method OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
protected method OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
protected method OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
protected method OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
protected method OnRemoved | Overridden. Occurs after an TreeNode is removed.
protected method OnRemoving | Overridden. Occurs before an TreeNode is removing.
protected method OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
protected method OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
protected method OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
protected method OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TreeNodeCollection Class | LidorSystems.IntegralUI.Lists.Collections Namespace


TreeNodeCollection Constructor

Overload List

Initializes a new instance of the TreeNodeCollection class.

[Visual Basic] Public Sub TreeNodeCollection()
[C#] public TreeNodeCollection();
[C++] public: TreeNodeCollection();
[JScript] public function TreeNodeCollection();

Initializes a new instance of the TreeNodeCollection class and associates it with the given TreeView control.

[Visual Basic] Public Sub TreeNodeCollection(LidorSystems.IntegralUI.Lists.TreeView)
[C#] public TreeNodeCollection(LidorSystems.IntegralUI.Lists.TreeView);
[C++] public: TreeNodeCollection(LidorSystems.IntegralUI.Lists.TreeView*);
[JScript] public function TreeNodeCollection(LidorSystems.IntegralUI.Lists.TreeView);

See Also

TreeNodeCollection Class | TreeNodeCollection Members | LidorSystems.IntegralUI.Lists.Collections Namespace


TreeNodeCollection Constructor ()

Initializes a new instance of the TreeNodeCollection class.

[Visual Basic]
Public Sub TreeNodeCollection()
[C#]
public TreeNodeCollection();
[C++]
public: TreeNodeCollection();
[JScript]
public function TreeNodeCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNodeCollection Class | LidorSystems.IntegralUI.Lists.Collections Namespace


TreeNodeCollection Constructor (TreeView)

Initializes a new instance of the TreeNodeCollection class and associates it with the given TreeView control.

[Visual Basic]
Public Sub TreeNodeCollection( _
   ByVal owner As TreeView _
)
[C#]
public TreeNodeCollection(
   TreeView owner
);
[C++]
public: TreeNodeCollection(
   TreeView* owner
);
[JScript]
public function TreeNodeCollection(
   owner : TreeView
);

Parameters

owner

The TreeView control to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeNodeCollection Class | LidorSystems.IntegralUI.Lists.Collections Namespace


TreeNodeCollection Properties

The properties of the TreeNodeCollection class are listed here. For a complete list of TreeNodeCollection class members, see the TreeNodeCollection Members topic.

Public Properties

public property Item | Gets a TreeNode at the specified location in the collection.
public property Owner (inherited from TreeNodeCollection) | Gets the object that owns the TreeNodeCollection.

Protected Properties

protected property InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
protected property List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

TreeNodeCollection Class | LidorSystems.IntegralUI.Lists.Collections Namespace


Item Method

TreeNodeCollection.Item Property

Gets or sets a tree node within the collection.

Overload List

Gets a TreeNode at the specified location in the collection.

[Visual Basic] Overridable Public Sub Item(Int32)
[C#] public virtual Item(Int32);
[C++] public: virtual Item(Int32);

Gets a TreeNode with the specified key from the collection.

[Visual Basic] Overridable Public Sub Item(String)
[C#] public virtual Item(String);
[C++] public: virtual Item(String);

See Also

TreeNodeCollection Class | TreeNodeCollection Members | LidorSystems.IntegralUI.Lists.Collections Namespace


Item (Int32) Property

TreeNodeCollection.Item (Int32) Property

Gets a TreeNode at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As TreeNode
[C#]
public new TreeNode this[
   int index
] {get;}
[C++]
public: __property TreeNode* get_Item(
   int index
);

Parameters

index
The 0-based index of the tree node to get.

Property Value

The TreeNode at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNodeCollection Class | TreeNodeCollection Members | LidorSystems.IntegralUI.Lists.Collections Namespace


Item Property

TreeNodeCollection.Item (String) Property

Gets a TreeNode with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As TreeNode
[C#]
 public TreeNode this[
   String key
] {get;}
[C++]
public: __property TreeNode* get_Item(
   String key
);

Parameters

key
The name of the TreeNode to retrieve from the collection.

Property Value

The TreeNode with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeNodeCollection Class | TreeNodeCollection Members | LidorSystems.IntegralUI.Lists.Collections Namespace


LidorSystems.IntegralUI.Lists.Style

LidorSystems.IntegralUI.Lists.Style Namespace

Classes

Class | Description
ListItemColorStyle | Represents the basic style for drawing the list items.
ListItemFormatStyle | Represents the basic format style for list items.
TreeViewColorStyle | Represents the style for drawing the tree view control.
TreeViewFormatStyle | Represents the format style for tree view control.


ListItemColorStyle Class

Represents the basic style for drawing the list items.

For a list of all members of this type, see ListItemColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
LidorSystems.IntegralUI.Lists.Style.ListItemColorStyle

[Visual Basic]
Public Class ListItemColorStyle
   Inherits LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[C#]
public class ListItemColorStyle : LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[C++]
public __gc class ListItemColorStyle : public LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[JScript]
public class ListItemColorStyle extends LidorSystems.IntegralUI.Lists.Style.ControlColorStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemColorStyle Members

ListItemColorStyle overview

Public Constructors

public constructor ListItemColorStyle Constructor Initializes a new instance of the ListItemColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Specifies the image object to use as a texture for drawing the background.
public property BorderColor (inherited from ControlColorStyle) | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor (inherited from ControlColorStyle) | Gets or sets the text Color.
public property TextImage | Specifies the image object to use as a texture for drawing the text.
public property TextShadowColor (inherited from ControlColorStyle) | Gets or sets the text shadow Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UnderlineColor | Gets or sets the underline Color.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ListItemColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ListItemColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ListItemColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemColorStyle Constructor ()

Initializes a new instance of the ListItemColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ListItemColorStyle();
[C++]
public: ListItemColorStyle();
[JScript]
public function ListItemColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListItemColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemColorStyle Properties

The properties of the ListItemColorStyle class are listed here. For a complete list of ListItemColorStyle class members, see the ListItemColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BackImage | Specifies the image object to use as a texture for drawing the background.
public property BorderColor (inherited from ControlColorStyle) | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property TextColor (inherited from ControlColorStyle) | Gets or sets the text Color.
public property TextImage | Specifies the image object to use as a texture for drawing the text.
public property TextShadowColor (inherited from ControlColorStyle) | Gets or sets the text shadow Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the percentage of transparency.
public property TransparencyLevel (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UnderlineColor | Gets or sets the underline Color.

See Also

ListItemColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


BackImage Property

ListItemColorStyle.BackImage Property

Specifies the image object to use as a texture for drawing the background.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a background texture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextImage Property

ListItemColorStyle.TextImage Property

Specifies the image object to use as a texture for drawing the text.

[Visual Basic]
Public Property TextImage As Image
[C#]
public Image TextImage {get; set;}
[C++]
public: __property Image get_TextImage();
public: __property void set_TextImage(Image);
[JScript]
public function get TextImage() : Image;
public function set TextImage(Image);

Property Value

A Image used as a text texture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


UnderlineColor Property

ListItemColorStyle.UnderlineColor Property

Gets or sets the underline Color.

[Visual Basic]
Public Property UnderlineColor As Color
[C#]
public Color UnderlineColor {get; set;}
[C++]
public: __property Color get_UnderlineColor();
public: __property void set_UnderlineColor(Color);
[JScript]
public function get UnderlineColor() : Color;
public function set UnderlineColor(Color);

Property Value

A Color represents the underline color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemColorStyle Methods

The methods of the ListItemColorStyle class are listed here. For a complete list of ListItemColorStyle class members, see the ListItemColorStyle Members topic.

Public Methods

public method Clone (inherited from ListItemColorStyle) | Overridden. Creates an exact copy of the current ListItemColorStyle.
public method Reset (inherited from ListItemColorStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from ListItemColorStyle) | Raises the StyleChanged event.

See Also

ListItemColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


Clone Method

ListItemColorStyle.Clone Method

Creates an exact copy of the current ListItemColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ListItemColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


IsStyleChanged Method

ListItemColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ListItemColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Reset Method

ListItemColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemColorStyle Class | ListItemColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemFormatStyle Class

Represents the basic format style for list items.

For a list of all members of this type, see ListItemFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
LidorSystems.IntegralUI.Lists.Style.ListItemFormatStyle

[Visual Basic]
Public Class ListItemFormatStyle
   Inherits LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[C#]
public class ListItemFormatStyle: LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[C++]
public __gc class ListItemFormatStyle: public LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[JScript]
public class ListItemFormatStyle extends LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemFormatStyle Members

ListItemFormatStyle overview

Public Constructors

public constructor ListItemFormatStyle Constructor Initializes a new instance of the ListItemFormatStyle class.

Public Properties

public property BorderCornerRadius | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property IconAlignment | Gets or sets the VerticalAlignment of the item icon.
public property ImageScalingFactor | Specifies the scale factor of the image in percents.
public property ImageSize | Gets or sets the image size.
public property Margin | Gets or sets the outer margin of the item, in pixels.
public property Padding | Gets or sets the amount of space from the parent list border, in pixels.
public property StateImageAlignment | Gets or sets the VerticalAlignment of the item state image.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.
public property UnderlineStyle | Specifies the type of underline.

Public Events

public event StyleChanged (inherited from BorderStyle) Occurs when the ListItemFormatStyle changes.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ListItemFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ListItemFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemFormatStyle Constructor ()

Initializes a new instance of the ListItemFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ListItemFormatStyle();
[C++]
public: ListItemFormatStyle();
[JScript]
public function ListItemFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListItemFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemFormatStyle Properties

The properties of the ListItemFormatStyle class are listed here. For a complete list of ListItemFormatStyle class members, see the ListItemFormatStyle Members topic.

Public Properties

public property BorderCornerRadius | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property IconAlignment | Gets or sets the VerticalAlignment of the item icon.
public property ImageScalingFactor | Specifies the scale factor of the image in percents.
public property ImageSize | Gets or sets the image size.
public property Margin | Gets or sets the outer margin of the item, in pixels.
public property Padding | Gets or sets the amount of space from the parent list border, in pixels.
public property StateImageAlignment | Gets or sets the VerticalAlignment of the item state image.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.
public property UnderlineStyle | Specifies the type of underline.

See Also

ListItemFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


IconAlignment Property

ListItemFormatStyle.IconAlignment Property

Gets or sets the VerticalAlignment of the item icon.

[Visual Basic]
Public Property IconAlignment As VerticalAlignment
[C#]
public VerticalAlignment IconAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_IconAlignment();
public: __property void set_IconAlignment(VerticalAlignment);
[JScript]
public function get IconAlignment() : VerticalAlignment;
public function set IconAlignment(VerticalAlignment);

Property Value

A VerticalAlignment of the item icon.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


BorderCornerRadius Property

ListItemFormatStyle.BorderCornerRadius Property

Gets or sets the radius of border corner.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ImageScaleFactor Property

ListItemFormatStyle.ImageScaleFactor Property

Specifies the scale factor of the image in percents.

[Visual Basic]
Public Property ImageScaleFactor As Point
[C#]
public Point ImageScaleFactor {get; set;}
[C++]
public: __property Point get_ImageScaleFactor();
public: __property void set_ImageScaleFactor(Point);
[JScript]
public function get ImageScaleFactor() : Point;
public function set ImageScaleFactor(Point);

Property Value

A Point represents the image width and height scalling factor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ImageSize Property

ListItemFormatStyle.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Margin Property

ListItemFormatStyle.Margin Property

Gets or sets the outer margin of the item, in pixels.

[Visual Basic]
Public Property Margin As Padding
[C#]
public Padding Margin { get; set; }
[C++]
public: __property Padding get_Margin();
public: __property void set_Margin(Padding);
[JScript]
public function get Margin() : Padding
public function set Margin(Padding);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Padding Property

ListItemFormatStyle.Padding Property

Gets or sets the amount of space from the item border, in pixels.

[Visual Basic]
Public Property Padding As Padding
[C#]
public Padding Padding { get; set; }
[C++]
public: __property Padding get_Padding();
public: __property void set_Padding(Padding);
[JScript]
public function get Padding() : Padding
public function set Padding(Padding);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


StateImageAlignment Property

ListItemFormatStyle.StateImageAlignment Property

Gets or sets the VerticalAlignment of the item state image.

[Visual Basic]
Public Property StateImageAlignment As VerticalAlignment
[C#]
public VerticalAlignment StateImageAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_StateImageAlignment();
public: __property void set_StateImageAlignment(VerticalAlignment);
[JScript]
public function get StateImageAlignment() : VerticalAlignment;
public function set StateImageAlignment(VerticalAlignment);

Property Value

A VerticalAlignment of the item state image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


UnderlineStyle Property

ListItemFormatStyle.UnderlineStyle Property

Specifies the type of underline.

[Visual Basic]
Public Property UnderlineStyle As LineStyle
[C#]
public LineStyle UnderlineStyle { get; set; }
[C++]
public: __property LineStyle get_UnderlineStyle();
public: __property void set_UnderlineStyle(LineStyle);
[JScript]
public function get UnderlineStyle() : LineStyle
public function set UnderlineStyle(LineStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ListItemFormatStyle Methods

The methods of the ListItemFormatStyle class are listed here. For a complete list of ListItemFormatStyle class members, see the ListItemFormatStyle Members topic.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ListItemFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ListItemFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


Clone Method

ListItemFormatStyle.Clone Method

Creates an exact copy of the current ListItemFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ListItemFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


IsStyleChanged Method

ListItemFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ListItemFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListItemFormatStyle Class | ListItemFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewColorStyle Class

Represents the style for drawing the TreeView control.

For a list of all members of this type, see TreeViewColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
LidorSystems.IntegralUI.Lists.Style.TreeViewColorStyle

[Visual Basic]
Public Class TreeViewColorStyle
   Inherits LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[C#]
public class TreeViewColorStyle : LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[C++]
public __gc class TreeViewColorStyle : public LidorSystems.IntegralUI.Lists.Style.ControlColorStyle
[JScript]
public class TreeViewColorStyle extends LidorSystems.IntegralUI.Lists.Style.ControlColorStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewColorStyle Members

TreeViewColorStyle overview

Public Constructors

public constructor TreeViewColorStyle Constructor Initializes a new instance of the TreeViewColorStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor (inherited from ControlColorStyle) | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property LineColor | Gets or sets the line Color.
public property NodePosColor | Gets or sets the node positioning Color, during drag-drop operation.
public property TextColor (inherited from ControlColorStyle) | Gets or sets the text Color.
public property TextShadowColor (inherited from ControlColorStyle) | Gets or sets the text shadow Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the TreeViewColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current TreeViewColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

TreeViewColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewColorStyle Constructor ()

Initializes a new instance of the TreeViewColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TreeViewColorStyle();
[C++]
public: TreeViewColorStyle();
[JScript]
public function TreeViewColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewColorStyle Properties

The properties of the TreeViewColorStyle class are listed here. For a complete list of TreeViewColorStyle class members, see the TreeViewColorStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor (inherited from ControlColorStyle) | Gets or sets the border Color.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property LineColor | Gets or sets the line Color.
public property NodePosColor | Gets or sets the node positioning Color, during drag-drop operation.
public property TextColor (inherited from ControlColorStyle) | Gets or sets the text Color.
public property TextShadowColor (inherited from ControlColorStyle) | Gets or sets the text shadow Color.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

TreeViewColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


LineColor Property

TreeViewColorStyle.LineColor Property

Gets or sets the line Color.

[Visual Basic]
Public Property LineColor As Color
[C#]
public Color LineColor {get; set;}
[C++]
public: __property Color get_LineColor();
public: __property void set_LineColor(Color);
[JScript]
public function get LineColor() : Color;
public function set LineColor(Color);

Property Value

A Color represents the line color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewColorStyle Class | TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


NodePosColor Property

TreeViewColorStyle.NodePosColor Property

Gets or sets the node positioning Color, during drag-drop operation.

[Visual Basic]
Public Property NodePosColor As Color
[C#]
public Color NodePosColor {get; set;}
[C++]
public: __property Color get_NodePosColor();
public: __property void set_NodePosColor(Color);
[JScript]
public function get NodePosColor() : Color;
public function set NodePosColor(Color);

Property Value

A Color represents the node positioning color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewColorStyle Class | TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewColorStyle Methods

The methods of the TreeViewColorStyle class are listed here. For a complete list of TreeViewColorStyle class members, see the TreeViewColorStyle Members topic.

Public Methods

public method Clone (inherited from TreeViewColorStyle) | Overridden. Creates an exact copy of the current TreeViewColorStyle.
public method Reset (inherited from TreeViewColorStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from TreeViewColorStyle) | Raises the StyleChanged event.

See Also

TreeViewColorStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


Clone Method

TreeViewColorStyle.Clone Method

Creates an exact copy of the current TreeViewColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TreeViewColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewColorStyle Class | TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


IsStyleChanged Method

TreeViewColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TreeViewColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewColorStyle Class | TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Reset Method

TreeViewColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewColorStyle Class | TreeViewColorStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewFormatStyle Class

Represents the format style for TreeView control.

For a list of all members of this type, see TreeViewFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
LidorSystems.IntegralUI.Lists.Style.TreeViewFormatStyle

[Visual Basic]
Public Class TreeViewFormatStyle
   Inherits LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[C#]
public class TreeViewFormatStyle : LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[C++]
public __gc class TreeViewFormatStyle : public LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle
[JScript]
public class TreeViewFormatStyle extends LidorSystems.IntegralUI.Lists.Style.ControlFormatStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Lists.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI.Lists (in LidorSystems.IntegralUI.Lists.dll)

See Also

TreeViewFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewFormatStyle Members

TreeViewFormatStyle overview

Public Constructors

public constructor TreeViewFormatStyle Constructor Initializes a new instance of the TreeViewFormatStyle class.

Public Properties

public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property LineStyle | Gets or sets the type of the TreeView lines.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged (inherited from BorderStyle) Occurs when the TreeViewFormatStyle changes.

Public Methods

public method Clone (inherited from BorderStyle) | Overridden. Creates an exact copy of the current TreeViewFormatStyle.
public method Reset (inherited from BorderStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

TreeViewFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewFormatStyle Constructor ()

Initializes a new instance of the TreeViewFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public TreeViewFormatStyle();
[C++]
public: TreeViewFormatStyle();
[JScript]
public function TreeViewFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewFormatStyle Properties

The properties of the TreeViewFormatStyle class are listed here. For a complete list of TreeViewFormatStyle class members, see the TreeViewFormatStyle Members topic.

Public Properties

public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property LineStyle | Gets or sets the type of the TreeView lines.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

TreeViewFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


LineStyle Property

TreeViewFormatStyle.LineStyle Property

Specifies the type of TreeView lines.

[Visual Basic]
Public Property LineStyle As LineStyle
[C#]
public LineStyle LineStyle { get; set; }
[C++]
public: __property LineStyle get_LineStyle();
public: __property void set_LineStyle(LineStyle);
[JScript]
public function get LineStyle() : LineStyle
public function set LineStyle(LineStyle);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewFormatStyle Class | TreeViewFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TreeViewFormatStyle Methods

The methods of the TreeViewFormatStyle class are listed here. For a complete list of TreeViewFormatStyle class members, see the TreeViewFormatStyle Members topic.

Public Methods

public method Clone (inherited from BorderStyle) | Overridden. Creates an exact copy of the current TreeViewFormatStyle.
public method Reset (inherited from BorderStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

TreeViewFormatStyle Class | LidorSystems.IntegralUI.Lists.Style Namespace


Clone Method

TreeViewFormatStyle.Clone Method

Creates an exact copy of the current TreeViewFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new TreeViewFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewFormatStyle Class | TreeViewFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


IsStyleChanged Method

TreeViewFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the TreeViewFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewFormatStyle Class | TreeViewFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Reset Method

TreeViewFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeViewFormatStyle Class | TreeViewFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


LidorSystems.IntegralUI.Style

LidorSystems.IntegralUI.Style Namespace

Classes

Class | Description
BackgroundStyle | Represents the common style for drawing the background of all objects.
BackgroundProcessStyle | Represents the style for drawing the form displayed when the background process is active.
BorderCornerShape | Represents the class that controls the border corners for all objects.
BorderStyle | Represents the common style for drawing the border of all controls.
CheckButtonBoxStyle | Represents the style for drawing the checkbox button.
ControlColorStyle | Represents the style for drawing the control.
ControlFormatStyle | Represents the basic format style for controls.
ExpandBoxStyle | Represents the style for drawing the expandbox button.
ScrollBarStyle | Represents the style for drawing the scrollbar.
StyleEventArgs | Provides data for style events.
WatermarkImage | Specifies the image which can be used as a watermark.

Delegates

Delegate | Description
StyleEventHandler | Represents the method that will handle style events.

Enumerations

Enumeration | Description
BorderVisibility | Enumerator used to determine the border visibility.
CornerShape | Enumerator used to set the shape of border corners.
FillStyle | Specifies the fill mode used to draw the client area.
LineStyle | Enumerator used to determine the type of the line.
StyleAction | Enumerator used to specify the action assigned to some style.
TransparencyLevel | Enumerator used to specify the level of transparency.
VisualStyle | Enumerator used to specify the appearance of object according to predefined style.

Send comments on this topic.

Copyright © 2006-2008 Lidor Systems. All rights reserved.


BackgroundStyle Class

Represents the common style for drawing the background of all objects.

For a list of all members of this type, see BackgroundStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle

[Visual Basic]
Public Class BackgroundStyle Implements
   ICloneable, IDisposable
[C#]
public class BackgroundStyle : ICloneable, IDisposable
[C++]
public __gc class BackgroundStyle : public ICloneable, IDisposable
[JScript]
public class BackgroundStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Members

BackgroundStyle overview

Public Constructors

public constructor BackgroundStyle Constructor Initializes a new instance of the BackgroundStyle class.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property Transparency | A value specifying the percentage of transparency.
public property TransparencyLevel | A value specifying the level of transparency.

Public Events

public event StyleChanged Occurs when the BackgroundStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current BackgroundStyle.
public method Dispose | Releases all resources used by this BackgroundStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Constructor ()

Initializes a new instance of the BackgroundStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BackgroundStyle();
[C++]
public: BackgroundStyle();
[JScript]
public function BackgroundStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Properties

The properties of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Properties

public property BackColor | Gets or sets the background Color.
public property BackFadeColor | Gets or sets the background fade Color.
public property FillStyle | Gets or sets an enumeration that determines the gradient direction.
public property Transparency | A value specifying the percentage of transparency.
public property TransparencyLevel | A value specifying the level of transparency.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


BackColor Property

BackgroundStyle.BackColor Property

Gets or sets the background Color.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color);
[JScript]
public function get BackColor() : Color;
public function set BackColor(Color);

Property Value

A Color represents the background color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackFadeColor Property

BackgroundStyle.BackFadeColor Property

Gets or sets the background fade Color.

[Visual Basic]
Public Property BackFadeColor As Color
[C#]
public Color BackFadeColor {get; set;}
[C++]
public: __property Color get_BackFadeColor();
public: __property void set_BackFadeColor(Color);
[JScript]
public function get BackFadeColor() : Color;
public function set BackFadeColor(Color);

Property Value

A Color represents the background fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


FillStyle Property

BackgroundStyle.FillStyle Property

Gets or sets an enumeration that determines the gradient direction.

[Visual Basic]
Public Property FillStyle As FillStyle
[C#]
public FillStyle FillStyle {get; set;}
[C++]
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(FillStyle);
[JScript]
public function get FillStyle() : FillStyle;
public function set FillStyle(FillStyle);

Property Value

The FillStyle assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Transparency Property

BackgroundStyle.Transparency Property

A value specifying the percentage of transparency.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}
[C++]
public: __property int get_Transparency();
public: __property void set_Transparency(int);
[JScript]
public function get Transparency() : int;
public function set Transparency(int);

Property Value

Transparency is in percentage, so the value can be from 0 to 100. Default setting is 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


TransparencyLevel Property

BackgroundStyle.TransparencyLevel Property

A value specifying the level of transparency.

[Visual Basic]
Public Property TransparencyLevel As TransparencyLevel
[C#]
public TransparencyLevel TransparencyLevel {get; set;}
[C++]
public: __property TransparencyLevel get_TransparencyLevel();
public: __property void set_TransparencyLevel(TransparencyLevel);
[JScript]
public function get TransparencyLevel() : TransparencyLevel;
public function set TransparencyLevel(TransparencyLevel);

Property Value

The TransparencyLevel assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Methods

The methods of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current BackgroundStyle.
public method Dispose | Releases all resources used by this BackgroundStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

BackgroundStyle.Clone Method

Creates an exact copy of the current BackgroundStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BackgroundStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

ListColumnColorStyle.Dispose Method

Releases all resources used by this ListColumnColorStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListColumnColorStyle Class | ListColumnColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

BackgroundStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the BackgroundStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

BackgroundStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

BackgroundStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundStyle Events

The events of the BackgroundStyle class are listed here. For a complete list of BackgroundStyle class members, see the BackgroundStyle Members topic.

Public Events

public event StyleChanged Occurs when the BackgroundStyle changes.

See Also

BackgroundStyle Class | LidorSystems.IntegralUI.Style Namespace


StyleChanged Event

BackgroundStyle.StyleChanged Event

Occurs when the BackgroundStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundStyle Class | BackgroundStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Class

Represents the style for drawing the form displayed when the background process is active.

For a list of all members of this type, see BackgroundProcessStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.BackgroundProcessStyle

[Visual Basic]
Public Class BackgroundProcessStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class BackgroundProcessStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class BackgroundProcessStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class BackgroundProcessStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Members

BackgroundProcessStyle overview

Public Constructors

public constructor BackgroundProcessStyle Constructor Initializes a new instance of the BackgroundProcessStyle class.

Public Properties

public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property Font | Gets or sets the font used to display the information about the process progress.
public property Image | Gets or sets an image that shows the process progress.
public property Padding | Gets or sets the amount of space from the border, in pixels.
public property TextColor | Gets or sets the Color of the text.
public property Text | Gets or sets the text that gives information about the process progress.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the BackgroundProcessStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current BackgroundProcessStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Constructor ()

Initializes a new instance of the BackgroundProcessStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BackgroundProcessStyle();
[C++]
public: BackgroundProcessStyle();
[JScript]
public function BackgroundProcessStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Properties

The properties of the BackgroundProcessStyle class are listed here. For a complete list of BackgroundProcessStyle class members, see the BackgroundProcessStyle Members topic.

Public Properties

public property BorderColor | Gets or sets the border Color.
public property BorderCornerRadius | Gets or sets the value by which the border corner will be rounded.
public property BorderCornerShape | Gets or sets the shape of the border corner.
public property Font | Gets or sets the font used to display the information about the process progress.
public property Image | Gets or sets an image that shows the process progress.
public property Padding | Gets or sets the amount of space from the border, in pixels.
public property TextColor | Gets or sets the Color of the text.
public property Text | Gets or sets the text that gives information about the process progress.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphicsobject.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

BackgroundProcessStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerRadius Property

BackgroundProcessStyle.BorderCornerRadius Property

Gets or sets the value by which the border corner will be rounded.

[Visual Basic]
Public Property BorderCornerRadius As Integer
[C#]
public int BorderCornerRadius {get; set;}
[C++]
public: __property int get_BorderCornerRadius();
public: __property void set_BorderCornerRadius(int);
[JScript]
public function get BorderCornerRadius() : int;
public function set BorderCornerRadius(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Property

BackgroundProcessStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Font Property

BackgroundProcessStyle.Font Property

Gets or sets the font used to display the information about the process progress.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font used to display the information about the process progress.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


Image Property

BackgroundProcessStyle.Image Property

Gets or sets an image that shows the process progress.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image {get; set;}
[C++]
public: __property Image get_Image();
public: __property void set_Image(Image);
[JScript]
public function get Image() : Image;
public function set Image(Image);

Property Value

A Image used to show the process progress. Accepts animated gifs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Padding Property

BackgroundProcessStyle.Padding Property

Gets or sets the amount of space from the border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextColor Property

BackgroundProcessStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Text Property

BackgroundProcessStyle.Text Property

Gets or sets the text that gives information about the process progress.

[Visual Basic]
Public Overridable Property Text As String
[C#]
public virtual String Text {get; set;}
[C++]
public: __property virtual String* get_Text();
public: __property virtual void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI Namespace


TextRendering Property

BackgroundProcessStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextShadowColor Property

BackgroundProcessStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BackgroundProcessStyle Methods

The methods of the BackgroundProcessStyle class are listed here. For a complete list of BackgroundProcessStyle class members, see the BackgroundProcessStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current BackgroundProcessStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

BackgroundProcessStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

BackgroundProcessStyle.Clone Method

Creates an exact copy of the current BackgroundProcessStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new BackgroundProcessStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

BackgroundProcessStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the BackgroundProcessStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

BackgroundProcessStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BackgroundProcessStyle Class | BackgroundProcessStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Class

Represents the class that controls the border corners for all objects.

For a list of all members of this type, see BorderCornerShape Members.

System.Object
LidorSystems.IntegralUI.Style.BorderCornerShape

[Visual Basic]
 Public Class BorderCornerShape
   Implements ICloneable
[C#]
 public class BorderCornerShape : ICloneable
[C++]
 public __gc class BorderCornerShape : public ICloneable
[JScript]
 public class BorderCornerShape implements ICloneable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Members

BorderCornerShape overview

Public Constructors

public constructor BorderCornerShape Constructor Initializes a new instance of the BorderCornerShape class.

Public Properties

public property BottomLeft | Gets or sets the bottom-left corner shape.
public property BottomRight | Gets or sets the bottom-right corner shape.
public property IsAllSquared | Checks whether all corners are squared.
public property TopLeft | Gets or sets the top-left corner shape.
public property TopRight | Gets or sets the top-right corner shape.

Public Events

public event BorderCornerChanged Occurs when the BorderCornerShape changes.

Public Methods

public method Clone Creates an exact copy of the current BorderCornerShape.
public method IsBorderChanged Determines whether the BorderCornerShape object has changed.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBorderCornerChanged | Raises the BorderCornerChanged event.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor

Overload List

Initializes a new instance of the BorderCornerShape class.

[Visual Basic] Public Sub New()
[C#] public BorderCornerShape();
[C++] public: BorderCornerShape();
[JScript] public function BorderCornerShape();

Initializes a new instance of the BorderCornerShape class and sets all corners to the given CornerShape.

[Visual Basic] Public Sub BorderCornerShape(CornerShape)
[C#] public BorderCornerShape(CornerShape);
[C++] public: BorderCornerShape(CornerShape);
[JScript] public function BorderCornerShape(CornerShape);

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor ()

Initializes a new instance of the BorderCornerShape class.

[Visual Basic]
Public Sub New()
[C#]
public BorderCornerShape();
[C++]
public: BorderCornerShape();
[JScript]
public function BorderCornerShape();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Constructor (CornerShape)

Initializes a new instance of the BorderCornerShape class and sets all corners to the given CornerShape.

[Visual Basic]
Public Sub New( _
   ByVal shape As CornerShape _
)
[C#]
public BorderCornerShape(
   CornerShape shape
);
[C++]
public: BorderCornerShape(
   CornerShape shape
);
[JScript]
public function BorderCornerShape(
   shape : CornerShape
);

Parameters

shape

The CornerShape enumeration for the new BorderCornerShape object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Properties

The properties of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Properties

public property BottomLeft | Gets or sets the bottom-left corner shape.
public property BottomRight | Gets or sets the bottom-right corner shape.
public property IsAllSquared | Checks whether all corners are squared.
public property TopLeft | Gets or sets the top-left corner shape.
public property TopRight | Gets or sets the top-right corner shape.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI Namespace


BottomLeft Property

BorderCornerShape.BottomLeft Property

Gets or sets the bottom-left corner shape.

[Visual Basic]
Public Property BottomLeft As CornerShape
[C#]
public CornerShape BottomLeft {get; set;}
[C++]
public: __property CornerShape get_BottomLeft();
public: __property void set_BottomLeft(CornerShape);
[JScript]
public function get BottomLeft() : CornerShape;
public function set BottomLeft(CornerShape);

Property Value

A CornerShape enumeration for the bottom-left corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BottomRight Property

BorderCornerShape.BottomRight Property

Gets or sets the bottom-right corner shape.

[Visual Basic]
Public Property BottomRight As CornerShape
[C#]
public CornerShape BottomRight {get; set;}
[C++]
public: __property CornerShape get_BottomRight();
public: __property void set_BottomRight(CornerShape);
[JScript]
public function get BottomRight() : CornerShape;
public function set BottomRight(CornerShape);

Property Value

A CornerShape enumeration for the bottom-right corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


TopLeft Property

BorderCornerShape.TopLeft Property

Gets or sets the top-left corner shape.

[Visual Basic]
Public Property TopLeft As CornerShape
[C#]
public CornerShape TopLeft {get; set;}
[C++]
public: __property CornerShape get_TopLeft();
public: __property void set_TopLeft(CornerShape);
[JScript]
public function get TopLeft() : CornerShape;
public function set TopLeft(CornerShape);

Property Value

A CornerShape enumeration for the top-left corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


TopRight Property

BorderCornerShape.TopRight Property

Gets or sets the top-right corner shape.

[Visual Basic]
Public Property TopRight As CornerShape
[C#]
public CornerShape TopRight {get; set;}
[C++]
public: __property CornerShape get_TopRight();
public: __property void set_TopRight(CornerShape);
[JScript]
public function get TopRight() : CornerShape;
public function set TopRight(CornerShape);

Property Value

A CornerShape enumeration for the top-right corner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Methods

The methods of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Methods

public method Clone Creates an exact copy of the current BorderCornerShape.
public method IsBorderChanged Determines whether the BorderCornerShape object has changed.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnBorderCornerChanged | Raises the BorderCornerChanged event.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

BorderCornerShape.Clone Method

Creates an exact copy of the current BorderCornerShape.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BorderCornerShape object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


IsBorderChanged Method

BorderCornerShape.IsBorderChanged Method

Determines whether the BorderCornerShape object has changed.

[Visual Basic]
Public Overridable Function IsBorderChanged() As Boolean
[C#]
public virtual bool IsBorderChanged();
[C++]
public: virtual bool IsBorderChanged();
[JScript]
public function IsBorderChanged() : Boolean;

Return Value

Returns true if the BorderCornerShape object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


OnBorderCornerChanged Method

BorderCornerShape.OnBorderCornerChanged Method

Raises the BorderCornerChanged event.

[Visual Basic]
Protected Overridable Sub OnBorderCornerChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnBorderCornerChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnBorderCornerChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnBorderCornerChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnBorderCornerChanged in a derived class, be sure to call the base class's OnBorderCornerChanged method so that registered delegates receive the event.

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Events

The events of the BorderCornerShape class are listed here. For a complete list of BorderCornerShape class members, see the BorderCornerShape Members topic.

Public Events

public event BorderCornerChanged Occurs when the BorderCornerShape changes.

See Also

BorderCornerShape Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerChanged Event

BorderCornerShape.BorderCornerChanged Event

Occurs when the BorderCornerShape changes.

[Visual Basic]
Public Event BorderCornerChanged As StyleEventHandler
[C#]
public event StyleEventHandler BorderCornerChanged;
[C++]
public: __event StyleEventHandler* BorderCornerChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Class

Represents the common style for drawing the border of all controls.

For a list of all members of this type, see BorderStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle

[Visual Basic]
Public Class BorderStyle Implements
   ICloneable, IDisposable
[C#]
public class BorderStyle : ICloneable, IDisposable
[C++]
public __gc class BorderStyle : public ICloneable, IDisposable
[JScript]
public class BorderStyle implements ICloneable, IDisposable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Members

BorderStyle overview

Public Constructors

public constructor BorderStyle Constructor Initializes a new instance of the BorderStyle class.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderLineStyle | Gets or sets the style of the border line.
public property BorderVisibility | Determines which border side will be shown.

Public Events

public event StyleChanged Occurs when the BorderStyle changes.

Public Methods

public method Clone | Creates an exact copy of the current BorderStyle.
public method Dispose | Releases all resources used by this BorderStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderStyle Constructor ()

Initializes a new instance of the BorderStyle class.

[Visual Basic]
Public Sub New()
[C#]
public BorderStyle();
[C++]
public: BorderStyle();
[JScript]
public function BorderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderStyle Properties

The properties of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Properties

public property BorderCornerShape | Gets or sets the shape of the border corner.
public property BorderLineStyle | Gets or sets the style of the border line.
public property BorderVisibility | Determines which border side will be shown.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderCornerShape Property

BorderStyle.BorderCornerShape Property

Gets or sets the shape of the border corner.

[Visual Basic]
Public Property BorderCornerShape As BorderCornerShape
[C#]
public BorderCornerShape BorderCornerShape {get; set;}
[C++]
public: __property BorderCornerShape get_BorderCornerShape();
public: __property void set_BorderCornerShape(BorderCornerShape);
[JScript]
public function get BorderCornerShape() : BorderCornerShape;
public function set BorderCornerShape(BorderCornerShape);

Property Value

A BorderCornerShape assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderLineStyle Property

BorderStyle.BorderLineStyle Property

Gets or sets the style of the border line.

[Visual Basic]
Public Property BorderLineStyle As LineStyle
[C#]
public LineStyle BorderLineStyle {get; set;}
[C++]
public: __property LineStyle get_BorderLineStyle();
public: __property void set_BorderLineStyle(LineStyle);
[JScript]
public function get BorderLineStyle() : LineStyle;
public function set BorderLineStyle(LineStyle);

Property Value

A LineStyle assigned to the border.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderVisibility Property

BorderStyle.BorderVisibility Property

Determines which border side will be shown.

[Visual Basic]
Public Property BorderVisibility As BorderVisibility
[C#]
public BorderVisibility BorderVisibility {get; set;}
[C++]
public: __property BorderVisibility get_BorderVisibility();
public: __property void set_BorderVisibility(BorderVisibility);
[JScript]
public function get BorderVisibility() : BorderVisibility;
public function set BorderVisibility(BorderVisibility);

Property Value

The BorderVisibility assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Methods

The methods of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Methods

public method Clone | Creates an exact copy of the current BorderStyle.
public method Dispose | Releases all resources used by this BorderStyle object.
public method Reset | Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged | Raises the StyleChanged event.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

BorderStyle.Clone Method

Creates an exact copy of the current BorderStyle.

[Visual Basic]
Public Overridable Function Clone() As Object Implements _
   ICloneable.Clone
[C#]
public virtual object Clone();
[C++]
public: virtual Object * Clone();
[JScript]
public function Clone() : Object;

Return Value

The new BorderStyle object that this method creates.

Implements

ICloneable.Clone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


Dispose Method

BorderStyle.Dispose Method

Releases all resources used by this BorderStyle object.

[Visual Basic]
Overloads Public Overridable Sub Dispose() Implements _
   IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

This method does not return a value.

Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

BorderStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Overridable Function IsStyleChanged() As Boolean
[C#]
public virtual bool IsStyleChanged();
[C++]
public: virtual bool IsStyleChanged();
[JScript]
public function IsStyleChanged() : Boolean;

Return Value

Returns true if the BorderStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


OnStyleChanged Method

BorderStyle.OnStyleChanged Method

Raises the StyleChanged event.

[Visual Basic]
Protected Overridable Sub OnStyleChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnStyleChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnStyleChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnStyleChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnStyleChanged in a derived class, be sure to call the base class's OnStyleChanged method so that registered delegates receive the event.

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

BorderStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderStyle Events

The events of the BorderStyle class are listed here. For a complete list of BorderStyle class members, see the BorderStyle Members topic.

Public Events

public event StyleChanged Occurs when the BorderStyle changes.

See Also

BorderStyle Class | LidorSystems.IntegralUI.Style Namespace


StyleChanged Event

BorderStyle.StyleChanged Event

Occurs when the BorderStyle changes.

[Visual Basic]
Public Event StyleChanged As StyleEventHandler
[C#]
public event StyleEventHandler StyleChanged;
[C++]
public: __event StyleEventHandler* StyleChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderStyle Class | BorderStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Class

Represents the style for drawing the checkbox button.

For a list of all members of this type, see CheckButtonBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.CheckButtonBoxStyle

[Visual Basic]
Public Class CheckButtonBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class CheckButtonBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class CheckButtonBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class CheckButtonBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Members

CheckButtonBoxStyle overview

Public Constructors

public constructor CheckButtonBoxStyle Constructor Initializes a new instance of the CheckButtonBoxStyle class.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Constructor ()

Initializes a new instance of the CheckButtonBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CheckButtonBoxStyle();
[C++]
public: CheckButtonBoxStyle();
[JScript]
public function CheckButtonBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Properties

The properties of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Properties

public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property CheckColor | Gets or sets the check mark Color.
public property CheckedImage | Gets or sets an custom image when the checkbox is checked.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property IndeterminateImage | Gets or sets an custom image when the checkbox is indeterminated.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.
public property UncheckedImage | Gets or sets an custom image when the checkbox is unchecked.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

CheckButtonBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckColor Property

CheckButtonBoxStyle.CheckColor Property

Gets or sets the check mark Color.

[Visual Basic]
Public Property CheckColor As Color
[C#]
public Color CheckColor {get; set;}
[C++]
public: __property Color get_CheckColor();
public: __property void set_CheckColor(Color);
[JScript]
public function get CheckColor() : Color;
public function set CheckColor(Color);

Property Value

A Color represents the check mark color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckedImage Property

CheckButtonBoxStyle.CheckedImage Property

Gets or sets an custom image when the checkbox is checked.

[Visual Basic]
Public Property CheckedImage As Image
[C#]
public Image CheckedImage {get; set;}
[C++]
public: __property Image get_CheckedImage();
public: __property void set_CheckedImage(Image);
[JScript]
public function get CheckedImage() : Image;
public function set CheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

CheckButtonBoxStyle.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IndeterminateImage Property

CheckButtonBoxStyle.IndeterminateImage Property

Gets or sets an custom image when the checkbox is indeterminated.

[Visual Basic]
Public Property IndeterminateImage As Image
[C#]
public Image IndeterminateImage {get; set;}
[C++]
public: __property Image get_IndeterminateImage();
public: __property void set_IndeterminateImage(Image);
[JScript]
public function get IndeterminateImage() : Image;
public function set IndeterminateImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


UncheckedImage Property

CheckButtonBoxStyle.UncheckedImage Property

Gets or sets an custom image when the checkbox is unchecked.

[Visual Basic]
Public Property UncheckedImage As Image
[C#]
public Image UncheckedImage {get; set;}
[C++]
public: __property Image get_UncheckedImage();
public: __property void set_UncheckedImage(Image);
[JScript]
public function get UncheckedImage() : Image;
public function set UncheckedImage(Image);

Property Value

A Image used for checkbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CheckButtonBoxStyle Methods

The methods of the CheckButtonBoxStyle class are listed here. For a complete list of CheckButtonBoxStyle class members, see the CheckButtonBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current CheckButtonBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

CheckButtonBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

CheckButtonBoxStyle.Clone Method

Creates an exact copy of the current CheckButtonBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new CheckButtonBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

CheckButtonBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the CheckButtonBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

CheckButtonBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CheckButtonBoxStyle Class | CheckButtonBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Members

ControlColorStyle overview

Public Constructors

public constructor ControlColorStyle Constructor Initializes a new instance of the ControlColorStyle class.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property DropMarkerColor | Gets or sets the Color of the drop marker used during drag&drop operations.
public property FocusFrameColor | Gets or sets the Color of the frame that represents that the control has input focus.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Constructor ()

Initializes a new instance of the ControlColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlColorStyle();
[C++]
public: ControlColorStyle();
[JScript]
public function ControlColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Properties

The properties of the ControlColorStyle class are listed here. For a complete list of ControlColorStyle class members, see the ControlColorStyle Members topic.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property DropMarkerColor | Gets or sets the Color of the drop marker used during drag&drop operations.
public property FocusFrameColor | Gets or sets the Color of the frame that represents that the control has input focus.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


BackImage Property

ControlColorStyle.BackImage Property

Gets or sets an image that fills the control background.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a control background.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

ControlColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


DropMarkerColor Property

ControlColorStyle.DropMarkerColor Property

Gets or sets the Color of the drop marker used during drag&drop operations.

[Visual Basic]
Public Property DropMarkerColor As Color
[C#]
public Color DropMarkerColor {get; set;}
[C++]
public: __property Color get_DropMarkerColor();
public: __property void set_DropMarkerColor(Color);
[JScript]
public function get DropMarkerColor() : Color;
public function set DropMarkerColor(Color);

Property Value

A Color of the drop marker used during drag&drop operations.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


FocusFrameColor Property

ControlColorStyle.FocusFrameColor Property

Gets or sets the Color of the frame that represents that the control has input focus.

[Visual Basic]
Public Property FocusFrameColor As Color
[C#]
public Color FocusFrameColor {get; set;}
[C++]
public: __property Color get_FocusFrameColor();
public: __property void set_FocusFrameColor(Color);
[JScript]
public function get FocusFrameColor() : Color;
public function set FocusFrameColor(Color);

Property Value

A Color of the frame that represents that the control has input focus.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextColor Property

ControlColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

ControlColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Methods

The methods of the ControlColorStyle class are listed here. For a complete list of ControlColorStyle class members, see the ControlColorStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlColorStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ControlColorStyle.Clone Method

Creates an exact copy of the current ControlColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ControlColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ControlColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlColorStyle Class | ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Class

Represents the basic format style for controls.

For a list of all members of this type, see ControlFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.ControlFormatStyle

[Visual Basic]
Public Class ControlFormatStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlFormatStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlFormatStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlFormatStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Members

ControlFormatStyle overview

Public Constructors

public constructor ControlFormatStyle Constructor Initializes a new instance of the ControlFormatStyle class.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlFormatStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Constructor ()

Initializes a new instance of the ControlFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlFormatStyle();
[C++]
public: ControlFormatStyle();
[JScript]
public function ControlFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlFormatStyle Properties

The properties of the ControlFormatStyle class are listed here. For a complete list of ControlFormatStyle class members, see the ControlFormatStyle Members topic.

Public Properties

public property Font | Gets or sets the font used to display the control text.
public property TextAlign | Gets or sets the alignment of the text.
public property TextRendering | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Font Property

ControlFormatStyle.Font Property

Gets or sets the font used to display the control text.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}
[C++]
public: __property Font get_Font();
public: __property void set_Font(Font);
[JScript]
public function get Font() : Font;
public function set Font(Font);

Property Value

The Font to display the control text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextAlign Property

ControlFormatStyle.TextAlign Property

Gets or sets the alignment of the text.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign { get; set; }
[C++]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(ContentAlignment);
[JScript]
public function get TextAlign() : ContentAlignment
public function set TextAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


TextRendering Property

ControlFormatStyle.TextRendering Property

Gets or sets the rendering mode for text associated with this Graphics object.

[Visual Basic]
Public Property TextRendering As TextRenderingHint
[C#]
public TextRenderingHint TextRendering {get; set;}
[C++]
public: __property TextRenderingHint get_TextRendering();
public: __property void set_TextRendering(TextRenderingHint);
[JScript]
public function get TextRendering() : TextRenderingHint;
public function set TextRendering(TextRenderingHint);

Property Value

This property specifies a member of the TextRenderingHint enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Lists.Style Namespace


ControlFormatStyle Methods

The methods of the ControlFormatStyle class are listed here. For a complete list of ControlFormatStyle class members, see the ControlFormatStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlFormatStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ControlFormatStyle.Clone Method

Creates an exact copy of the current ControlFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ControlFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ControlFormatStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlFormatStyle Class | ControlFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Class

Represents the style for drawing the control header.

For a list of all members of this type, see ControlHeaderColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ControlHeaderColorStyle

[Visual Basic]
Public Class ControlHeaderColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlHeaderColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlHeaderColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlHeaderColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Members

ControlHeaderColorStyle overview

Public Constructors

public constructor ControlHeaderColorStyle Constructor Initializes a new instance of the ControlHeaderColorStyle class.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlHeaderColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlHeaderColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Constructor ()

Initializes a new instance of the ControlHeaderColorStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlHeaderColorStyle();
[C++]
public: ControlHeaderColorStyle();
[JScript]
public function ControlHeaderColorStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Properties

The properties of the ControlHeaderColorStyle class are listed here. For a complete list of ControlHeaderColorStyle class members, see the ControlHeaderColorStyle Members topic.

Public Properties

public property BackImage | Gets or sets an image that fills the control background.
public property BorderColor | Gets or sets the border Color.
public property TextColor | Gets or sets the Color of the text.
public property TextShadowColor | Gets or sets the shadow Color of the text.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


BackImage Property

ControlHeaderColorStyle.BackImage Property

Gets or sets an image that fills the header background.

[Visual Basic]
Public Property BackImage As Image
[C#]
public Image BackImage {get; set;}
[C++]
public: __property Image get_BackImage();
public: __property void set_BackImage(Image);
[JScript]
public function get BackImage() : Image;
public function set BackImage(Image);

Property Value

A Image used as a header background.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

ControlHeaderColorStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextColor Property

ControlHeaderColorStyle.TextColor Property

Gets or sets the Color of the text.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(Color);
[JScript]
public function get TextColor() : Color;
public function set TextColor(Color);

Property Value

A Color represents the text color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


TextShadowColor Property

ControlHeaderColorStyle.TextShadowColor Property

Gets or sets the shadow Color of the text.

[Visual Basic]
Public Property TextShadowColor As Color
[C#]
public Color TextShadowColor {get; set;}
[C++]
public: __property Color get_TextShadowColor();
public: __property void set_TextShadowColor(Color);
[JScript]
public function get TextShadowColor() : Color;
public function set TextShadowColor(Color);

Property Value

A Color represents the text shadow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderColorStyle Methods

The methods of the ControlHeaderColorStyle class are listed here. For a complete list of ControlHeaderColorStyle class members, see the ControlHeaderColorStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ControlHeaderColorStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ControlHeaderColorStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ControlHeaderColorStyle.Clone Method

Creates an exact copy of the current ControlHeaderColorStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlHeaderColorStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ControlHeaderColorStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlHeaderColorStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ControlHeaderColorStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderColorStyle Class | ControlHeaderColorStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Class

Represents the basic format style for headers.

For a list of all members of this type, see ControlHeaderFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.ControlFormatStyle
LidorSystems.IntegralUI.Style.ControlHeaderFormatStyle

[Visual Basic]
Public Class ControlHeaderFormatStyle
   Inherits LidorSystems.IntegralUI.Style.ControlFormatStyle
[C#]
public class ControlHeaderFormatStyle: LidorSystems.IntegralUI.Style.ControlFormatStyle
[C++]
public __gc class ControlHeaderFormatStyle: public LidorSystems.IntegralUI.Style.ControlFormatStyle
[JScript]
public class ControlHeaderFormatStyle extends LidorSystems.IntegralUI.Style.ControlFormatStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Members

ControlHeaderFormatStyle overview

Public Constructors

public constructor ControlHeaderFormatStyle Constructor Initializes a new instance of the ControlHeaderFormatStyle class.

Public Properties

public property BorderCornerRadius (inherited from BorderStyle) | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property ContentSpacing | Specifies the distance between objects in header.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property Padding | Gets or sets the amount of space from the header border, in pixels.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

Public Events

public event StyleChanged (inherited from BorderStyle) Occurs when the ControlHeaderFormatStyle changes.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ControlHeaderFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Constructor ()

Initializes a new instance of the ControlHeaderFormatStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ControlHeaderFormatStyle();
[C++]
public: ControlHeaderFormatStyle();
[JScript]
public function ControlHeaderFormatStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Properties

The properties of the ControlHeaderFormatStyle class are listed here. For a complete list of ControlHeaderFormatStyle class members, see the ControlHeaderFormatStyle Members topic.

Public Properties

public property BorderCornerRadius (inherited from BorderStyle) | Gets or sets the radius of border corner.
public property BorderCornerShape (inherited from BorderStyle) | Gets or sets the shape of the border corner.
public property BorderLineStyle (inherited from BorderStyle) | Gets or sets the style of the border line.
public property BorderVisibility (inherited from BorderStyle) | Determines which border side will be shown.
public property ContentSpacing | Specifies the distance between objects in header.
public property Font (inherited from ControlFormatStyle) | Gets or sets the font used to display the control text.
public property Padding | Gets or sets the amount of space from the header border, in pixels.
public property TextAlign (inherited from ControlFormatStyle) | Gets or sets the alignment of the text.
public property TextRendering (inherited from ControlFormatStyle) | Gets or sets the rendering mode for text associated with this Graphics object.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


ContentSpacing Property

ControlHeaderFormatStyle.ContentSpacing Property

Specifies the distance between objects in header.

[Visual Basic]
Public Property ContentSpacing As Integer
[C#]
public int ContentSpacing {get; set;}
[C++]
public: __property int get_ContentSpacing();
public: __property void set_ContentSpacing(int);
[JScript]
public function get ContentSpacing() : int;
public function set ContentSpacing(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


Padding Property

ControlHeaderFormatStyle.Padding Property

Gets or sets the amount of space from the header border, in pixels.

[Visual Basic]
Public Property Padding As Margin
[C#]
public Margin Padding { get; set; }
[C++]
public: __property Margin get_Padding();
public: __property void set_Padding(Margin);
[JScript]
public function get Padding() : Margin
public function set Padding(Margin);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ControlHeaderFormatStyle Methods

The methods of the ControlHeaderFormatStyle class are listed here. For a complete list of ControlHeaderFormatStyle class members, see the ControlHeaderFormatStyle Members topic.

Public Methods

public method Clone (inherited from BorderStyle) Overridden. Creates an exact copy of the current ControlHeaderFormatStyle.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BorderStyle) | Raises the StyleChanged event.

See Also

ControlHeaderFormatStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ControlHeaderFormatStyle.Clone Method

Creates an exact copy of the current ControlHeaderFormatStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ControlHeaderFormatStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ControlHeaderFormatStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ControlHeaderFormatStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlHeaderFormatStyle Class | ControlHeaderFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Class

Represents the style for drawing the expandbox button.

For a list of all members of this type, see ExpandBoxStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ExpandBoxStyle

[Visual Basic]
Public Class ExpandBoxStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ExpandBoxStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ExpandBoxStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ExpandBoxStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Members

ExpandBoxStyle overview

Public Constructors

public constructor ExpandBoxStyle Constructor Initializes a new instance of the ExpandBoxStyle class.

Public Properties

public property Alignment | Gets or sets the VerticalAlignment of the expand box.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property CollapseImage | Gets or sets an custom image that represents the collapsed state.
public property ExpandImage | Gets or sets an custom image that represents the expanded state.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ControlColorStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ExpandBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Constructor ()

Initializes a new instance of the ExpandBoxStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ExpandBoxStyle();
[C++]
public: ExpandBoxStyle();
[JScript]
public function ExpandBoxStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Properties

The properties of the ExpandBoxStyle class are listed here. For a complete list of ExpandBoxStyle class members, see the ExpandBoxStyle Members topic.

Public Properties

public property Alignment | Gets or sets the VerticalAlignment of the expand box.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property CollapseImage | Gets or sets an custom image that represents the collapsed state.
public property ExpandImage | Gets or sets an custom image that represents the expanded state.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property ImageSize | Gets or sets the image size.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


Alignment Property

ExpandBoxStyle.Alignment Property

Gets or sets the VerticalAlignment of the expand box.

[Visual Basic]
Public Property Alignment As VerticalAlignment
[C#]
public VerticalAlignment Alignment {get; set;}
[C++]
public: __property VerticalAlignment get_Alignment();
public: __property void set_Alignment(VerticalAlignment);
[JScript]
public function get Alignment() : VerticalAlignment;
public function set Alignment(VerticalAlignment);

Property Value

A VerticalAlignment of the expand box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

ExpandBoxStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonColor Property

ExpandBoxStyle.ButtonColor Property

Gets or sets the button Color.

[Visual Basic]
Public Property ButtonColor As Color
[C#]
public Color ButtonColor {get; set;}
[C++]
public: __property Color get_ButtonColor();
public: __property void set_ButtonColor(Color);
[JScript]
public function get ButtonColor() : Color;
public function set ButtonColor(Color);

Property Value

A Color represents the button color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


CollapseImage Property

ExpandBoxStyle.CollapseImage Property

Gets or sets an custom image that represents the collapsed state.

[Visual Basic]
Public Property CollapseImage As Image
[C#]
public Image CollapseImage {get; set;}
[C++]
public: __property Image get_CollapseImage();
public: __property void set_CollapseImage(Image);
[JScript]
public function get CollapseImage() : Image;
public function set CollapseImage(Image);

Property Value

A Image used for expandbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandImage Property

ExpandBoxStyle.ExpandImage Property

Gets or sets an custom image that represents the expanded state.

[Visual Basic]
Public Property ExpandImage As Image
[C#]
public Image ExpandImage {get; set;}
[C++]
public: __property Image get_ExpandImage();
public: __property void set_ExpandImage(Image);
[JScript]
public function get ExpandImage() : Image;
public function set ExpandImage(Image);

Property Value

A Image used for expandbox appearance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

ExpandBoxStyle.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ExpandBoxStyle Methods

The methods of the ExpandBoxStyle class are listed here. For a complete list of ExpandBoxStyle class members, see the ExpandBoxStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ExpandBoxStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ExpandBoxStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ExpandBoxStyle.Clone Method

Creates an exact copy of the current ExpandBoxStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ExpandBoxStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ExpandBoxStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ExpandBoxStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ExpandBoxStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ExpandBoxStyle Class | ExpandBoxStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Class

Represents the style for drawing the scrollbar.

For a list of all members of this type, see ScrollBarStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ScrollBarStyle

[Visual Basic]
Public Class ScrollBarStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ScrollBarStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ScrollBarStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ScrollBarStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Members

ScrollBarStyle overview

Public Constructors

public constructor ScrollBarStyle Constructor Initializes a new instance of the ScrollBarStyle class.

Public Properties

public property ArrowColor | Gets or sets the arrow Color.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property ButtonFadeColor | Gets or sets the button fade Color.
public property ButtonFillStyle | Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

Public Events

public event StyleChanged (inherited from BackgroundStyle) Occurs when the ScrollBarStyle changes.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ScrollBarStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Constructor ()

Initializes a new instance of the ScrollBarStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ScrollBarStyle();
[C++]
public: ScrollBarStyle();
[JScript]
public function ScrollBarStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Properties

The properties of the ScrollBarStyle class are listed here. For a complete list of ScrollBarStyle class members, see the ScrollBarStyle Members topic.

Public Properties

public property ArrowColor | Gets or sets the arrow Color.
public property BackColor (inherited from BackgroundStyle) | Gets or sets the background Color.
public property BackFadeColor (inherited from BackgroundStyle) | Gets or sets the background fade Color.
public property BorderColor | Gets or sets the border Color.
public property ButtonColor | Gets or sets the button Color.
public property ButtonFadeColor | Gets or sets the button fade Color.
public property ButtonFillStyle | Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.
public property FillStyle (inherited from BackgroundStyle) | Gets or sets an enumeration that determines the gradient direction.
public property Transparency (inherited from BackgroundStyle) | A value specifying the level of transparency.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


ArrowColor Property

ScrollBarStyle.ArrowColor Property

Gets or sets the arrow Color.

[Visual Basic]
Public Property ArrowColor As Color
[C#]
public Color ArrowColor {get; set;}
[C++]
public: __property Color get_ArrowColor();
public: __property void set_ArrowColor(Color);
[JScript]
public function get ArrowColor() : Color;
public function set ArrowColor(Color);

Property Value

A Color represents the arrow color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


BorderColor Property

ScrollBarStyle.BorderColor Property

Gets or sets the border Color.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor {get; set;}
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
[JScript]
public function get BorderColor() : Color;
public function set BorderColor(Color);

Property Value

A Color represents the border color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonColor Property

ScrollBarStyle.ButtonColor Property

Gets or sets the button Color.

[Visual Basic]
Public Property ButtonColor As Color
[C#]
public Color ButtonColor {get; set;}
[C++]
public: __property Color get_ButtonColor();
public: __property void set_ButtonColor(Color);
[JScript]
public function get ButtonColor() : Color;
public function set ButtonColor(Color);

Property Value

A Color represents the button color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ButtonFadeColor Property

ScrollBarStyle.ButtonFadeColor Property

Gets or sets the button fade Color.

[Visual Basic]
Public Property ButtonFadeColor As Color
[C#]
public Color ButtonFadeColor {get; set;}
[C++]
public: __property Color get_ButtonFadeColor();
public: __property void set_ButtonFadeColor(Color);
[JScript]
public function get ButtonFadeColor() : Color;
public function set ButtonFadeColor(Color);

Property Value

A Color represents the button fade color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


FillStyle Property

ScrollBarStyle.FillStyle Property

Gets or sets an enumeration that determines the gradient direction for painting the scrollbar buttons.

[Visual Basic]
Public Property FillStyle As FillStyle
[C#]
public FillStyle FillStyle {get; set;}
[C++]
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(FillStyle);
[JScript]
public function get FillStyle() : FillStyle;
public function set FillStyle(FillStyle);

Property Value

The FillStyle assigned to the style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


ScrollBarStyle Methods

The methods of the ScrollBarStyle class are listed here. For a complete list of ScrollBarStyle class members, see the ScrollBarStyle Members topic.

Public Methods

public method Clone (inherited from BackgroundStyle) | Overridden. Creates an exact copy of the current ScrollBarStyle.
public method Reset (inherited from BackgroundStyle) | Overridden. Resets all properties to their default values.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnStyleChanged (inherited from BackgroundStyle) | Raises the StyleChanged event.

See Also

ScrollBarStyle Class | LidorSystems.IntegralUI.Style Namespace


Clone Method

ScrollBarStyle.Clone Method

Creates an exact copy of the current ScrollBarStyle.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
 public: Object * Clone();
[JScript]
public override function Clone() : Object;

Return Value

The new ScrollBarStyle object that this method creates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


IsStyleChanged Method

ScrollBarStyle.IsStyleChanged Method

This member supports the LidorSystems.IntegralUI infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Public Function IsStyleChanged() As Boolean
[C#]
public override bool IsStyleChanged();
[C++]
 public: bool IsStyleChanged();
[JScript]
public override function IsStyleChanged() : Boolean;

Return Value

Returns true if the ScrollBarStyle object is changed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


Reset Method

ScrollBarStyle.Reset Method

Resets all properties to their default values.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
 public: void Reset();
[JScript]
public override function Reset();

Return Value

This method does not return a value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ScrollBarStyle Class | ScrollBarStyle Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Class

Provides data for style events.

For a list of all members of this type, see StyleEventArgs Members.

System.Object
LidorSystems.IntegralUI.Style.StyleEventArgs

[Visual Basic]
Public
   Class StyleEventArgs
[C#]
 public class StyleEventArgs
[C++]
 public __gc class StyleEventArgs
[JScript]
public class StyleEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Members

StyleEventArgs overview

Public Constructors

public constructor StyleEventArgs Constructor Initializes a new instance of the StyleEventArgs class.

Public Properties

public property Object | Read-only property that returns the object associated with the StyleEventArgs.
public property Action | Read-only property that returns the StyleAction associated with the StyleEventArgs.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor

Overload List

Initializes a new instance of the StyleEventArgs class.

[Visual Basic] Public Sub New()
[C#] public StyleEventArgs();
[C++] public: StyleEventArgs();
[JScript] public function StyleEventArgs();

Initializes a new instance of the StyleEventArgs class with the specified object.

[Visual Basic] Public Sub StyleEventArgs(Object)
[C#] public StyleEventArgs(object);
[C++] public: StyleEventArgs(Object*);
[JScript] public function StyleEventArgs(Object);

Initializes a new instance of the StyleEventArgs class with the specified object and action.

[Visual Basic] Public Sub StyleEventArgs(Object, StyleAction)
[C#] public StyleEventArgs(object, StyleAction);
[C++] public: StyleEventArgs(Object*, StyleAction);
[JScript] public function StyleEventArgs(Object, StyleAction);

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor ()

Initializes a new instance of the StyleEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public StyleEventArgs();
[C++]
public: StyleEventArgs();
[JScript]
public function StyleEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor (Object)

Initializes a new instance of the StyleEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public StyleEventArgs(
   object value
);
[C++]
public: StyleEventArgs(
   Object* value
);
[JScript]
public function StyleEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Constructor (Object, StyleAction)

Initializes a new instance of the StyleEventArgs class with the specified object and action.

[Visual Basic]
Public Sub New( _
   ByVal value As Object
   ByVal action As StyleAction _
)
[C#]
public StyleEventArgs(
   object value
   StyleAction action
);
[C++]
public: StyleEventArgs(
   Object* value
   StyleAction* action
);
[JScript]
public function StyleEventArgs(
   value : Object
   action : StyleAction
);

Parameters

value

The object associated with this event.

action

The StyleAction associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


StyleEventArgs Properties

The properties of the StyleEventArgs class are listed here. For a complete list of StyleEventArgs class members, see the StyleEventArgs Members topic.

Public Properties

public property Object | Read-only property that returns the object associated with the StyleEventArgs.
public property Action | Read-only property that returns the StyleAction associated with the StyleEventArgs.

See Also

StyleEventArgs Class | LidorSystems.IntegralUI.Style Namespace


Action Property

StyleEventArgs.Action Property

Read-only property that returns the StyleAction associated with the StyleEventArgs.

[Visual Basic]
Public ReadOnly Property Action As StyleAction
[C#]
public StyleAction Action {get;}
[C++]
public: __property StyleAction* get_Action();
[JScript]
public function get Action() : StyleAction;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


Object Property

StyleEventArgs.Object Property

Read-only property that returns the object associated with the StyleEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

StyleEventArgs Class | StyleEventArgs Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Class

Specifies the image which can be used as a watermark.

For a list of all members of this type, see WatermarkImage Members.

System.Object
LidorSystems.IntegralUI.Style.WatermarkImage

[Visual Basic]
Public
   Class WatermarkImage
[C#]
 public class WatermarkImage
[C++]
 public __gc class WatermarkImage
[JScript]
public class WatermarkImage

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Members

WatermarkImage overview

Public Constructors

public constructor WatermarkImage Constructor Initializes a new instance of the WatermarkImage class.

Public Properties

public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image.
public property Image | Specifies the image object to use as a watermark.
public property ImageAlign | Gets or sets the alignment of the image.
public property ImageSize | Gets or sets the image size.

Public Events

public event WatermarkImageChanged Occurs when the WatermarkImage changes.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnWatermarkImageChanged | Raises the WatermarkImageChanged event.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Constructor ()

Initializes a new instance of the WatermarkImage class.

[Visual Basic]
Public Sub New()
[C#]
public WatermarkImage();
[C++]
public: WatermarkImage();
[JScript]
public function WatermarkImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Properties

The properties of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Properties

public property Alpha | Gets or sets the alpha value that will be applied to the colors in the image.
public property Image | Specifies the image object to use as a watermark.
public property ImageAlign | Gets or sets the alignment of the image.
public property ImageSize | Gets or sets the image size.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


Alpha Property

WatermarkImage.Alpha Property

Gets or sets the alpha value that will be applied to the colors in the image.

[Visual Basic]
Public Property Alpha As Integer
[C#]
public int Alpha {get; set;}
[C++]
public: __property int get_Alpha();
public: __property void set_Alpha(int);
[JScript]
public function get Alpha() : int;
public function set Alpha(int);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


ImageAlign Property

WatermarkImage.ImageAlign Property

Gets or sets the alignment of the image.

[Visual Basic]
Public Property ImageAlign As ContentAlignment
[C#]
public ContentAlignment ImageAlign { get; set; }
[C++]
public: __property ContentAlignment get_ImageAlign();
public: __property void set_ImageAlign(ContentAlignment);
[JScript]
public function get ImageAlign() : ContentAlignment
public function set ImageAlign(ContentAlignment);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


Image Property

WatermarkImage.Image Property

Specifies the image object to use as a watermark.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image { get; set; }
[C++]
public: __property Image* get_Image();
public: __property void set_Image(Image* );
[JScript]
public function get Image() : Image
public function set Image(Image);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


ImageSize Property

WatermarkImage.ImageSize Property

Gets or sets the image size.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}
[C++]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(Size);
[JScript]
public function get ImageSize() : Size;
public function set ImageSize(Size);

Property Value

A Size represents the size of the image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Methods

The methods of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method OnWatermarkImageChanged | Raises the WatermarkImageChanged event.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


OnWatermarkImageChanged Method

WatermarkImage.OnWatermarkImageChanged Method

Raises the WatermarkImageChanged event.

[Visual Basic]
Protected Overridable Sub OnWatermarkImageChanged( _
   ByVal e As StyleEventArgs _
)
[C#]
protected virtual void OnWatermarkImageChanged(
   StyleEventArgs e
);
[C++]
protected: virtual void OnWatermarkImageChanged(
   StyleEventArgs* e
);
[JScript]
protected function OnWatermarkImageChanged(
   e : StyleEventArgs
);

Parameters

e
A StyleEventArgs that contains the event data.

Remarks

Notes to Inheritors: When overriding OnWatermarkImageChanged in a derived class, be sure to call the base class's OnWatermarkImageChanged method so that registered delegates receive the event.

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


WatermarkImage Events

The events of the WatermarkImage class are listed here. For a complete list of WatermarkImage class members, see the WatermarkImage Members topic.

Public Events

public event WatermarkImageChanged Occurs when the WatermarkImage changes.

See Also

WatermarkImage Class | LidorSystems.IntegralUI.Style Namespace


WatermarkImageChanged Event

WatermarkImage.WatermarkImageChanged Event

Occurs when the WatermarkImage changes.

[Visual Basic]
Public Event WatermarkImageChanged As StyleEventHandler
[C#]
public event StyleEventHandler WatermarkImageChanged;
[C++]
public: __event StyleEventHandler* WatermarkImageChanged;

[JScript] In JScript, you can handle the events defined by a class, but you cannot define your own.

Event Data

The event handler receives an argument of type StyleEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

WatermarkImage Class | WatermarkImage Members | LidorSystems.IntegralUI.Style Namespace


StyleEventHandler Delegate

Represents the method that will handle style events.

[Visual Basic]
Public Delegate Sub StyleEventHandler( _
   ByVal sender As Object, _
   ByVal e As StyleEventArgs _
)
[C#]
public Delegate void StyleEventHandler(
   object sender,
   StyleEventArgs e
);
[C++]
public __gc __delegate void StyleEventHandler(
   Object* sender,
   StyleEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the StyleEventHandler Delegate declaration.

sender
The source of the event.
e
A StyleEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


BorderVisibility Enumeration

Enumerator used to determine the border visibility.

[Visual Basic]
<Flags>
Public Enum BorderVisibility
[C#]
[Flags]
public enum BorderVisibility
[C++]
[Flags]
__value public enum BorderVisibility
[JScript]
public
   Flags
enum BorderVisibility

Members

Member name | Description | Value
All | All borders are visible. | 15
Bottom | Only the bottom border is visible. | 8
Left | Only the left border is visible. | 1
None | Border is not visible. | 0
Right | Only the right border is visible. | 4
Top | Only the top border is visible. | 2

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


CornerShape Enumeration

Enumerator used to set the shape of border corners.

[Visual Basic]
Public Enum CornerShape
[C#]
public enum CornerShape
[C++]
__value public enum CornerShape
[JScript]
public
   enum CornerShape

Members

Member name | Description
Chamfered | The chamfered corner.
Rounded | The rounded corner.
Squared | The squared corner.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


FillStyle Enumeration

Specifies the fill mode used to draw the client area.

[Visual Basic]
Public Enum FillStyle
[C#]
public enum FillStyle
[C++]
__value public enum FillStyle
[JScript]
public
   enum FillStyle

Members

Member name | Description
BackwardDiagonal | Specifies a gradient from upper right to lower left.
BackwardHorizontal | Specifies a gradient from right to left.
BackwardVertical | Specifies a gradient from bottom to top.
Flat | Specifies solid color.
ForwardDiagonal | Specifies a gradient from upper left to lower right.
Horizontal | Specifies a gradient from left to right.
Texture | Specifies that custom image will be used to fill the cleint area.
Vertical | Specifies a gradient from top to bottom.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


LineStyle Enumeration

Enumerator used to determine the type of the line.

[Visual Basic]
Public Enum LineStyle
[C#]
public enum LineStyle
[C++]
__value public enum LineStyle
[JScript]
public
   enum LineStyle

Members

Member name | Description
Dash | Specifies a line consisting of dashes.
Dot | Specifies a line consisting of dots.
Double | Specifies a double solid line.
None | The line is invisible.
Solid | Specifies a solid line.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


TransparencyLevel Enumeration

Enumerator used to specify the level of transparency.

[Visual Basic]
Public Enum TransparencyLevel
[C#]
public enum TransparencyLevel
[C++]
__value public enum TransparencyLevel
[JScript]
public
   enum TransparencyLevel

Members

Member name | Description
Full | Every content (text, image, colors, etc.) of object can be transparent.
Partial | Only background and border of object can be transparent.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


VisualStyle Enumeration

Enumerator used to specify the appearance of object according to predefined style.

[Visual Basic]
Public Enum VisualStyle
[C#]
public enum VisualStyle
[C++]
__value public enum VisualStyle
[JScript]
public
   enum VisualStyle

Members

Member name | Description
Classic | Used to render objects in Windows Classic control style.
Vista | Used to render objects in Windows Vista control style.
XP | Used to render objects in Windows XP control style.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace


Product Support

This support policy may be subject to change. You are advised to check the Support section of the Lidor Systems web site for any change notices prior to purchasing. Lidor Systems Technical Support can assist you with all your technical problems, from installation to troubleshooting. Before contacting technical support please read the relevant sections of the product documentation or the ReadMe files.

Reporting Issues

You can contact Technical Support by:

  • E-Mail: Include your serial number and send as many details as possible to: support@lidorsystems.com
  • World Wide Web: Submit issues and access additional support services at: http://www.lidorsystems.com/support/forums
  • Fax: Include your serial number and send as many details as possible to: +389 32 634 944

Before contacting Technical Support, please obtain and record the following information:

  • Your company name and contact information
  • Product name and version
  • Product serial number
  • Your system configuration: operating system, network configuration, amount of RAM, environment variables, and paths
  • The details of the problem; settings, error messages
  • If the problem is repeatable, the details of how to create the problem
  • The name and version of your development tools

The amount of information you can provide us with about the nature of a problem you are having will directly affect our ability to resolve it. The more information you can provide about your environment, the steps to reproduce and any other relevant information the better - please be verbose!

Submitting Suggestions

If you have any comments or concerns about this product please direct them to suggestions@lidorsystems.com. Your feedback is important to us in order to get an idea of how to make this software a better product for you. Many of its features and significant portions of its interface have been heavily influenced by comments from users. So if you have a grand idea for a new feature, or a better way of doing something, please drop us a note.


Deploying

In order to deploy your application, you will have to re-distribute the following files:

File Name | Description
LidorSystems.IntegralUI.dll | .NET Assembly containing common classes.
LidorSystems.IntegralUI.Lists.dll | .NET Assembly containing base classes for list controls.
LidorSystems.IntegralUI.Lists.TreeView.dll | .NET Assembly containing the TreeView control.

Warning! Distribution of files mentioned above is only allowed when they are properly licensed.


BackgroundImageSpace Property

ControlBase.BackgroundImageSpace Property

Gets or sets the space at which background image will be drawn.

[Visual Basic]
Public Property BackgroundImageSpace As BackgroundImageSpace
[C#]
public BackgroundImageSpace BackgroundImageSpace {get; set;}
[C++]
public: __property BackgroundImageSpace get_BackgroundImageSpace();
public: __property void set_BackgroundImageSpace(BackgroundImageSpace);
[JScript]
public function get BackgroundImageSpace() : BackgroundImageSpace;
public function set BackgroundImageSpace(BackgroundImageSpace);

Property Value

The BackgroundImageSpace assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ColorStyle Property

ControlBase.ColorStyle Property

Gets or sets the drawing style of the control.

[Visual Basic]
Public Property ColorStyle As ControlColorStyle
[C#]
public ControlColorStyle ColorStyle {get; set;}
[C++]
public: __property ControlColorStyle get_ColorStyle();
public: __property void set_ColorStyle(ControlColorStyle);
[JScript]
public function get ColorStyle() : ControlColorStyle;
public function set ColorStyle(ControlColorStyle);

Property Value

The ControlColorStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


FormatStyle Property

ControlBase.FormatStyle Property

Gets or sets the format style of the control.

[Visual Basic]
Public Property FormatStyle As ControlFormatStyle
[C#]
public ControlFormatStyle FormatStyle {get; set;}
[C++]
public: __property ControlFormatStyle get_FormatStyle();
public: __property void set_FormatStyle(ControlFormatStyle);
[JScript]
public function get FormatStyle() : ControlFormatStyle;
public function set FormatStyle(ControlFormatStyle);

Property Value

The ControlFormatStyle assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ControlBase Class | ControlBase Members | LidorSystems.IntegralUI Namespace


ObjectBase Members

ObjectBase overview

Public Constructors

public constructor ObjectBase Constructor Initializes a new instance of the ObjectBase class.

Public Properties

public property Enabled | Gets or sets a value indicating whether the object can respond to user interaction.
public property Index | Gets the position of the object in the object collection.
public property Key | Gets or sets a string that uniquely identifies object in a collection.
public property State | Gets a value indicating the current state of the object.
public property Tag | Gets or sets the object that contains data about the item.
public property TagString | Gets or sets the tag string of the object.
public property Text | Gets or sets the object text.
public property Visible | Gets or sets a value indicating whether the object is displayed.

Public Methods

public method Clone | Creates an exact copy of the current ObjectBase.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Releases all resources used by this ObjectBase object.
public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method RepaintParent | Repaints the parent object, if any.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.
public method UpdateParent | Updates the layout of the parent object, if any.

Protected Methods

protected method Finalize (inherited from Object) Supported by the .NET Compact Framework. | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) Supported by the .NET Compact Framework. | Creates a shallow copy of the current Object.

See Also

ObjectBase Class | LidorSystems.IntegralUI Namespace


PageBase Class

Provides a common implementation of members for panel controls.

For a list of all members of this type, see PageBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
LidorSystems.IntegralUI.PageBase
LidorSystems.IntegralUI.Containers.SplitContainerPage
LidorSystems.IntegralUI.Containers.TabPage
LidorSystems.IntegralUI.ContentPanel

[Visual Basic]
MustInherit Public Class PageBase
   Inherits Panel
[C#]
public abstract class PageBase : Panel
[C++]
public __gc __abstract class PageBase : public Panel
[JScript]
public abstract class PageBase extends Panel

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

PageBase Members | LidorSystems.IntegralUI Namespace


PageBase Members

PageBase overview

Public Properties

public property AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
public property AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
public property AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
public property AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
public property AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
public property AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
public property Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
public property AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
public property AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
public property AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
public property AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
public property AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
public property AutoSize (inherited from Panel) | Overridden.
public property AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
public property BackColor (inherited from Control) | Gets or sets the background color for the control.
public property BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
public property BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
public property BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
public property BorderStyle (inherited from Panel) | Indicates the border style for the control.
public property Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
public property Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
public property CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
public property CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
public property Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
public property CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
public property public property CheckForIllegalCrossThreadCalls (inherited from Control) | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property.
public property ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
public property ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
public property CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
public property Container (inherited from Component) | Gets the IContainer that contains the Component.
public property ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
public property ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
public property ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
public property Controls (inherited from Control) | Gets the collection of controls contained within the control.
public property Created (inherited from Control) | Gets a value indicating whether the control has been created.
public property Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
public property DataBindings (inherited from Control) | Gets the data bindings for the control.
public property DefaultBackColor (inherited from Control) | Gets the default background color of the control.
public property DefaultFont (inherited from Control) | Gets the default font of the control.
public property DefaultForeColor (inherited from Control) | Gets the default foreground color of the control.
public property DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
public property Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
public property Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
public property DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
public property Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
public property Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
public property Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
public property ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
public property Handle (inherited from Control) | Gets the window handle that the control is bound to.
public property HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
public property Height (inherited from Control) | Gets or sets the height of the control.
public property HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
public property ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
public property InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
public property IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
public property IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
public property IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
public property IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
public property LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
public property Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
public property Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
public property Margin (inherited from Control) | Gets or sets the space between controls.
public property MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
public property MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
public property public property ModifierKeys (inherited from Control) | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state.
public property public property MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
public property public property MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
public property Name (inherited from Control) | Gets or sets the name of the control.
public property Padding (inherited from Control) | Gets or sets padding within the control.
public property Parent (inherited from Control) | Gets or sets the parent container of the control.
public property ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
public property ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
public property RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
public property Region (inherited from Control) | Gets or sets the window region associated with the control.
public property Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
public property RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
public property Site (inherited from Control) | Gets or sets the site of the control.
public property Size (inherited from Control) | Gets or sets the height and width of the control.
public property TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
public property TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
public property Tag (inherited from Control) | Gets or sets the object that contains data about the control.
public property Text | Overridden. The text associated with the page.
public property TextBounds | For internal use.
public property TextSize | For internal use.
public property Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
public property TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
public property UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
public property VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
public property Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
public property WatermarkImage | Specifies the image used as a watermark.
public property Width (inherited from Control) | Gets or sets the width of the control.

Public Methods

public method BeginInvoke (inherited from Control) | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on.
public method BringToFront (inherited from Control) | Brings the control to the front of the z-order.
public method Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
public method CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
public method CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
public method CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from Component) | Overloaded. Releases the resources used by the Component.
public method DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
public method DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
public method EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
public method Equals (inherited from Object) | Overloaded. Determines whether two Object instances are equal.
public method FindForm (inherited from Control) | Retrieves the form that the control is on.
public method Focus (inherited from Control) | Sets input focus to the control.
public method public method FromChildHandle (inherited from Control) | Retrieves the control that contains the specified handle.
public method public method FromHandle (inherited from Control) | Returns the control that is currently associated with the specified handle.
public method GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
public method GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
public method GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
public method GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
public method GetType (inherited from Object) | Gets the Type of the current instance.
public method Hide (inherited from Control) | Conceals the control from the user.
public method InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Invalidate (inherited from Control) | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control.
public method Invoke (inherited from Control) | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle.
public method public method IsKeyLocked (inherited from Control) | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect.
public method public method IsMnemonic (inherited from Control) | Determines if the specified character is the mnemonic character assigned to the control in the specified string.
public method PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to child controls.
public method PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
public method PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
public method PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
public method PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
public method RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
public method RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
public method Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
public method ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
public method ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
public method ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
public method ResetFont (inherited from Control) | Resets the Font property to its default value.
public method ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
public method ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
public method ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
public method ResetText (inherited from Control) | Resets the Text property to its default value.
public method ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
public method Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
public method Select (inherited from Control) | Overloaded. Activates a control.
public method SelectNextControl (inherited from Control) | Activates the next control.
public method SendToBack (inherited from Control) | Sends the control to the back of the z-order.
public method SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control.
public method Show (inherited from Control) | Displays the control to the user.
public method SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
public method ToString (inherited from Component) |
public method Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Events

public event AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property changes.
public event BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
public event BackgroundImageLayoutChanged (inherited from Control) | Occurs when the value of the BackgroundImageLayout property changes.
public event BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
public event CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
public event ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
public event Click (inherited from Control) | Occurs when the control is clicked.
public event ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
public event ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
public event ControlAdded (inherited from Control) | Occurs when a new control is added to the Control.ControlCollection.
public event ControlRemoved (inherited from Control) | Occurs when a control is removed from the Control.ControlCollection.
public event CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
public event Disposed (inherited from Component) | Adds an event handler to listen to the BackColor event on the component.
public event DockChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
public event DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
public event DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
public event DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
public event DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
public event DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
public event EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
public event Enter (inherited from Control) | Occurs when the control is entered.
public event FontChanged (inherited from Control) | Occurs when the Font property value changes.
public event ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
public event GiveFeedback (inherited from Control) | Occurs during a drag operation.
public event GotFocus (inherited from Control) | Occurs when the control receives focus.
public event HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
public event HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
public event HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
public event ImeModeChanged (inherited from Control) | Occurs when the BackColor property has changed.
public event Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
public event KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
public event KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
public event Layout (inherited from Control) | Occurs when a control should reposition its child controls.
public event Leave (inherited from Control) | Occurs when the input focus leaves the control.
public event LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
public event LostFocus (inherited from Control) | Occurs when the control loses focus.
public event MarginChanged (inherited from Control) | Occurs when the control's margin changes.
public event MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
public event MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
public event MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
public event MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
public event MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
public event MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
public event MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
public event MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
public event MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
public event MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
public event Move (inherited from Control) | Occurs when the control is moved.
public event ParentChanged (inherited from Control) | Occurs when the BackColor property value changes.
public event PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
public event QueryAccessibilityHelp (inherited from Control) | Occurs when BackColor is providing help to accessibility applications.
public event QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
public event RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
public event Resize (inherited from Control) | Occurs when the control is resized.
public event RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
public event Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
public event SizeChanged (inherited from Control) | Occurs when the Size property value changes.
public event StyleChanged (inherited from Control) | Occurs when the control style changes.
public event SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
public event TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
public event TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
public event TextChanged (inherited from Control) | Occurs when the Text property value changes.
public event Validated (inherited from Control) | Occurs when the control is finished validating.
public event Validating (inherited from Control) | Occurs when the control is validating.
public event VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Properties

protected property CanRaiseEvents (inherited from Control) | Overridden. Determines if events can be raised on the control.
protected property CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
protected property DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
protected property DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
protected property DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
protected property DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
protected property DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
protected property DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
protected property DefaultSize (inherited from Control) | Gets the default size of the control.
protected property DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property DoubleBuffered (inherited from Component) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
protected property Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
protected property FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
protected property HScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
protected property ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
protected property ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
protected property ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
protected property VScroll (inherited from ScrolableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Methods

protected method AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
protected method AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
protected method CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
protected method CreateControlsInstance (inherited from Control) | See Control.CreateControlsInstance.
protected method CreateHandle (inherited from Control) | See Control.CreateHandle.
protected method DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
protected method DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
protected method Dispose | Overloaded. Overridden. See Control.Dispose.
protected method Finalize (inherited from Component) | Overridden. Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method GetAccessibilityObjectById (inherited from Component) | Retrieves the specified AccessibleObject.
protected method GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
protected method GetScaledBounds (inherited from Component) | Retrieves the bounds within which the control is scaled.
protected method GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
protected method GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
protected method GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
protected method GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
protected method InitLayout (inherited from Control) | Called after the control has been added to another container.
protected method InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
protected method InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
protected method InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
protected method InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
protected method InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
protected method IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
protected method IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
protected method NotifyInvalidate (inherited from Object) | Raises the Invalidated event with a specified region of the control to invalidate.
protected method OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
protected method OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
protected method OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
protected method OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
protected method OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
protected method OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
protected method OnClick (inherited from Control) | Raises the Click event.
protected method OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
protected method OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
protected method OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
protected method OnControlAdded (inherited from Control) | Raises the ControlAdded event.
protected method OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
protected method OnCreateControl (inherited from Control) | Raises the CreateControl event.
protected method OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnDockChanged (inherited from Control) | Raises the DockChanged event.
protected method OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
protected method OnDragDrop (inherited from Control) | Raises the DragDrop event.
protected method OnDragEnter (inherited from Control) | Raises the DragEnter event.
protected method OnDragLeave (inherited from Control) | Raises the DragLeave event.
protected method OnDragOver (inherited from Control) | Raises the DragOver event.
protected method OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
protected method OnEnter (inherited from Control) | Raises the Enter event.
protected method OnFontChanged (inherited from Control) | Raises the FontChanged event.
protected method OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
protected method OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
protected method OnGotFocus (inherited from Control) | Raises the GotFocus event.
protected method OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
protected method OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
protected method OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
protected method OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
protected method OnInvalidated (inherited from Control) | Raises the Invalidated event.
protected method OnKeyDown (inherited from Control) | Raises the KeyDown event.
protected method OnKeyPress (inherited from Control) | Raises the KeyPress event.
protected method OnKeyUp (inherited from Control) | Raises the KeyUp event.
protected method OnLayout (inherited from Control) | Raises the Layout event.
protected method OnLeave (inherited from Control) | Raises the Leave event.
protected method OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
protected method OnLostFocus (inherited from Control) | Raises the LostFocus event.
protected method OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
protected method OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
protected method OnMouseClick (inherited from Control) | Raises the MouseClick event.
protected method OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
protected method OnMouseDown (inherited from Control) | Raises the MouseDown event.
protected method OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
protected method OnMouseHover (inherited from Control) | Raises the MouseHover event.
protected method OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
protected method OnMouseMove (inherited from Control) | Raises the MouseMove event.
protected method OnMouseUp (inherited from Control) | Raises the MouseUp event.
protected method OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
protected method OnMove (inherited from Control) | Raises the Move event.
protected method OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
protected method OnPaddingChanged (inherited from ScrollableControl) | Raises the PaddingChanged event event.
protected method OnPaint (inherited from Control) | Raises the Paint event.
protected method OnPaintBackground (inherited from Control) | Paints the background of the control.
protected method OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
protected method OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
protected method OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
protected method OnParentChanged (inherited from Control) | Raises the ParentChanged event.
protected method OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
protected method OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
protected method OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
protected method OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
protected method OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
protected method OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
protected method OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
protected method OnPrint (inherited from Control) | Raises the Paint event.
protected method OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
protected method OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
protected method OnResize (inherited from Panel) | Overridden.
protected method OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
protected method OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
protected method OnStyleChanged (inherited from Control) | See Control.OnStyleChanged.
protected method OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
protected method OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
protected method OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
protected method OnTextChanged (inherited from Control) | Raises the TextChanged event.
protected method OnValidated (inherited from Control) | Raises the Validated event.
protected method OnValidating (inherited from Control) | Raises the Validating event.
protected method OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
protected method ProcessCmdKey (inherited from Control) | Processes a command key.
protected method ProcessDialogChar (inherited from Control) | Processes a dialog character.
protected method ProcessDialogKey (inherited from Control) | Processes a dialog key.
protected method ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
protected method ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
protected method ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
protected method ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
protected method RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
protected method RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
protected method RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
protected method RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
protected method RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
protected method protected method ReflectMessage (inherited from Control) | Reflects the specified message to the control that is bound to the specified handle.
protected method ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
protected method RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text.
protected method RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
protected method RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
protected method RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
protected method ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
protected method ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
protected method Select (inherited from Control) | Overloaded. Activates a control.
protected method SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
protected method SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
protected method SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
protected method SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
protected method SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
protected method SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
protected method SetTopLevel (inherited from Control) | Sets the control as the top-level control.
protected method SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
protected method SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
protected method UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control.
protected method UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
protected method UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
protected method WndProc (inherited from Control) | Processes Windows messages.

See Also

PageBase Class | LidorSystems.IntegralUI Namespace


WatermarkImage Property

PageBase.WatermarkImage Property

Specifies the WatermarkImage object to use as a watermark.

[Visual Basic]
Public Property WatermarkImage As WatermarkImage
[C#]
public WatermarkImage WatermarkImage { get; set; }
[C++]
public: __property WatermarkImage* get_WatermarkImage();
public: __property void set_WatermarkImage(WatermarkImage*);
[JScript]
public function get WatermarkImage() : WatermarkImage
public function set WatermarkImage(WatermarkImage);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

PageBase Class | PageBase Members | LidorSystems.IntegralUI.Lists Namespace


UpdateEventArgs Class

Provides data for events used to notify about control layout or display changes.

For a list of all members of this type, see UpdateEventArgs Members.

System.Object
LidorSystems.IntegralUI.UpdateEventArgs

[Visual Basic]
Public
   Class UpdateEventArgs
[C#]
 public class UpdateEventArgs
[C++]
 public __gc class UpdateEventArgs
[JScript]
public class UpdateEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor

Overload List

Initializes a new instance of the UpdateEventArgs class.

[Visual Basic] Public Sub New()
[C#] public UpdateEventArgs();
[C++] public: UpdateEventArgs();
[JScript] public function UpdateEventArgs();

Initializes a new instance of the UpdateEventArgs class with the specified object.

[Visual Basic] Public Sub UpdateEventArgs(Object)
[C#] public UpdateEventArgs(object);
[C++] public: UpdateEventArgs(Object*);
[JScript] public function UpdateEventArgs(Object);

Initializes a new instance of the UpdateEventArgs class with the specified object and action.

[Visual Basic] Public Sub UpdateEventArgs(Object, ActionType)
[C#] public UpdateEventArgs(object, ActionType);
[C++] public: UpdateEventArgs(Object*, ActionType);
[JScript] public function UpdateEventArgs(Object, ActionType);

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor ()

Initializes a new instance of the UpdateEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public UpdateEventArgs();
[C++]
public: UpdateEventArgs();
[JScript]
public function UpdateEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


UpdateEventArgs Constructor (Object)

Initializes a new instance of the UpdateEventArgs class with the specified object.

[Visual Basic]
Public Sub New( _
   ByVal value As Object _
)
[C#]
public UpdateEventArgs(
   object value
);
[C++]
public: UpdateEventArgs(
   Object* value
);
[JScript]
public function UpdateEventArgs(
   value : Object
);

Parameters

value

The object associated with this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


UpdateEventArgs Members

UpdateEventArgs overview

Public Constructors

public constructor UpdateEventArgs Constructor Initializes a new instance of the UpdateEventArgs class.

Public Properties

public property Object | Read-only property that returns the object associated with the UpdateEventArgs.
public property Action | Read-only property that returns the ActionType associated with the UpdateEventArgs.

Public Methods

public method Equals (inherited from Object) Supported by the .NET Compact Framework. | Overloaded. Determines whether two Object instances are equal.
public method GetHashCode (inherited from Object) Supported by the .NET Compact Framework. | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetType (inherited from Object) Supported by the .NET Compact Framework. | Gets the Type of the current instance.
public method ToString (inherited from Object) Supported by the .NET Compact Framework. | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed using destructor syntax.
protected method MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateEventArgs Class | LidorSystems.IntegralUI Namespace


Action Property

UpdateEventArgs.Action Property

Read-only property that returns the ActionType associated with the UpdateEventArgs.

[Visual Basic]
Public ReadOnly Property Action As ActionType
[C#]
public ActionType Action {get;}
[C++]
public: __property ActionType* get_Action();
[JScript]
public function get Action() : ActionType;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


Object Property

UpdateEventArgs.Object Property

Read-only property that returns the object associated with the UpdateEventArgs.

[Visual Basic]
Public ReadOnly Property Object As Object
[C#]
public object Object {get;}
[C++]
public: __property Object* get_Object();
[JScript]
public function get Object() : Object;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

UpdateEventArgs Class | UpdateEventArgs Members | LidorSystems.IntegralUI Namespace


UpdateEventHandler Delegate

Represents the method that will handle events used to notify about control layout or display changes.

[Visual Basic]
Public Delegate Sub UpdateEventHandler( _
   ByVal sender As Object, _
   ByVal e As UpdateEventArgs _
)
[C#]
public Delegate void UpdateEventHandler(
   object sender,
   UpdateEventArgs e
);
[C++]
public __gc __delegate void UpdateEventHandler(
   Object* sender,
   UpdateEventArgs* e
);

[JScript] In JScript, you can use the delegates, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event handler must have the same parameters as the UpdateEventHandler Delegate declaration.

sender
The source of the event.
e
A UpdateEventArgs that contains the event data.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


BackgroundImageSpace Enumeration

Enumerator used to specify where the background image will be placed.

[Visual Basic]
Public Enum BackgroundImageSpace
[C#]
public enum BackgroundImageSpace
[C++]
__value public enum BackgroundImageSpace
[JScript]
public
   enum BackgroundImageSpace

Members

Member name | Description
Client | The image can occupy only the control client area.
Control | Default. The image can occupy the whole control area.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


CloseAction Enumeration

Enumerator used to determine how an object will be closed.

[Visual Basic]
Public Enum CloseAction
[C#]
public enum CloseAction
[C++]
__value public enum CloseAction
[JScript]
public
   enum CloseAction

Members

Member name | Description
Dispose | The closing object will be disposed.
Hide | The closing object will be hidden, but still will remain in memory.

Requirements

Namespace: LidorSystems.IntegralUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI Namespace


ListControlItem Constructor ()

Initializes a new instance of the ListControlItem class.

[Visual Basic]
Public Sub New()
[C#]
public ListControlItem();
[C++]
public: ListControlItem();
[JScript]
public function ListControlItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor (String)

Initializes a new instance of the ListControlItem class with the specified label text.

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ListControlItem(
   string text
);
[C++]
public: ListControlItem(
   String* text
);
[JScript]
public function ListControlItem(
   text : String
);

Parameters

text
The text of the new item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


ListControlItem Constructor (String, Int32)

Initializes a new instance of the ListControlItem class with the specified text and image.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageIndex As Integer, _
)
[C#]
public ListControlItem(
   string text,
   int imageIndex,
);
[C++]
public: ListControlItem(
   String* text,
   int imageIndex,
);
[JScript]
public function ListControlItem(
   text : String,
   imageIndex : int,
);

Parameters

text
The name of the new item.
imageIndex
The index value of Image to display.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ListControlItem Class | LidorSystems.IntegralUI.Controls Namespace


Item (Int32) Property

CommandButtonCollection.Item (Int32) Property

Gets a CommandButton at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As CommandButton
[C#]
public new CommandButton this[
   int index
] {get;}
[C++]
public: __property CommandButton* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The CommandButton at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

CommandButtonCollection.Item (String) Property

Gets a CommandButton with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As CommandButton
[C#]
 public CommandButton this[
   String key
] {get;}
[C++]
public: __property CommandButton* get_Item(
   String key
);

Parameters

key
The name of the CommandButton to retrieve from the collection.

Property Value

The CommandButton with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

CommandButtonCollection Class | CommandButtonCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item (Int32) Property

ListControlItemCollection.Item (Int32) Property

Gets a ListControlItem at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ListControlItem
[C#]
public new ListControlItem this[
   int index
] {get;}
[C++]
public: __property ListControlItem* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The ListControlItem at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

ListControlItemCollection.Item (String) Property

Gets a ListControlItem with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As ListControlItem
[C#]
 public ListControlItem this[
   String key
] {get;}
[C++]
public: __property ListControlItem* get_Item(
   String key
);

Parameters

key
The name of the ListControlItem to retrieve from the collection.

Property Value

The ListControlItem with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListControlItemCollection Class | ListControlItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


ToolItemCollection Constructor (Object)

Initializes a new instance of the ToolItemCollection class and associates it with the given ListBox control.

[Visual Basic]
Public Sub New( _
   ByVal owner As Object _
)
[C#]
public ToolItemCollection(
   object owner
);
[C++]
public: ToolItemCollection(
   Object* owner
);
[JScript]
public function ToolItemCollection(
   owner : Object
);

Parameters

owner

The object to be the owner of the created collection instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ToolItemCollection Class | LidorSystems.IntegralUI.Controls.Collections Namespace


Item (Int32) Property

ToolItemCollection.Item (Int32) Property

Gets a ToolItemBase at the specified location in the collection.

[Visual Basic]
Public Shadows ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ToolItemBase
[C#]
public new ToolItemBase this[
   int index
] {get;}
[C++]
public: __property ToolItemBase* get_Item(
   int index
);

Parameters

index
The 0-based index of the item to get.

Property Value

The ToolItemBase at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


Item Property

ToolItemCollection.Item (String) Property

Gets a ToolItemBase with the specified key from the collection.

[Visual Basic]
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As ToolItemBase
[C#]
 public ToolItemBase this[
   String key
] {get;}
[C++]
public: __property ToolItemBase* get_Item(
   String key
);

Parameters

key
The name of the ToolItemBase to retrieve from the collection.

Property Value

The ToolItemBase with the specified key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ToolItemCollection Class | ToolItemCollection Members | LidorSystems.IntegralUI.Controls.Collections Namespace


TextControFormatStyle Class

Represents the format style for TextControl.

For a list of all members of this type, see TextControFormatStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BorderStyle
LidorSystems.IntegralUI.Style.TextControFormatStyle

[Visual Basic]
Public Class TextControFormatStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class TextControFormatStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class TextControFormatStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class TextControFormatStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

TextControFormatStyle Members | LidorSystems.IntegralUI.Style Namespace


StartProcess () Method

ListBase.StartProcess () Method

Starts a background process which displays a Form that shows information about process progress during loading/updating of the list.

[Visual Basic]
Public Sub StartProcess()
[C#]
public void StartProcess();
[C++]
 public: void * StartProcess();
[JScript]
public function StartProcess() ;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


StartProcess (Integer) Method

ListBase.StartProcess (Integer) Method

Starts a background process which displays a Form that shows information about process progress during loading/updating of the list and sets the limit of progress units.

[Visual Basic]
Public  Sub StartProcess( _
   ByVal progressLimit As Integer _
)
[C#]
public  void StartProcess(
   int progressLimit
);
[C++]
public: void StartProcess(
   int progressLimit
);
[JScript]
public function StartProcess(
   progressLimit : int
);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

ListBase Class | ListBase Members | LidorSystems.IntegralUI.Lists Namespace


ShowStateImages Property

TreeView.ShowStateImages Property

Gets or sets a value indicating whether state images (flags) are visible.

[Visual Basic]
Public Property ShowStateImages As Boolean
[C#]
public bool ShowStateImages {get; set;}
[C++]
public: __property bool get_ShowStateImages();
public: __property void set_ShowStateImages(bool);
[JScript]
public function get ShowStateImages() : Boolean;
public function set ShowStateImages(Boolean);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

TreeView Class | TreeView Members | LidorSystems.IntegralUI.Lists Namespace


FilterMatchCriteria Enumeration

Enumerator used to determine the criteria by which items are filtered.

[Visual Basic]
Public Enum FilterMatchCriteria
[C#]
public enum FilterMatchCriteria
[C++]
__value public enum FilterMatchCriteria
[JScript]
public
   enum FilterMatchCriteria

Members

Member name | Description
byKey | Search criteria is represented by the Key property of the item.
byTag | Search criteria is represented by the Tag property of the item.
byText | Search criteria is represented by the Text property of the item.
byValue | Search criteria is represented by the Value property of the item.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


FilterMode Enumeration

Enumerator used to determine how values used for filtering are combined.

[Visual Basic]
Public Enum FilterMode
[C#]
public enum FilterMode
[C++]
__value public enum FilterMode
[JScript]
public
   enum FilterMode

Members

Member name | Description
And | Values used for filtering are combined using AND operator.
Or | Values used for filtering are combined using OR operator.

Requirements

Namespace: LidorSystems.IntegralUI.Lists

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Lists Namespace


IsAllSquared Property

BorderCornerShape.IsAllSquared Property

Checks whether all corners are squared.

[Visual Basic]
Public ReadOnly Property IsAllSquared As Boolean
[C#]
public bool IsAllSquared {get;}
[C++]
public: __property bool* get_IsAllSquared();
[JScript]
public function get IsAllSquared() : Boolean;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Vista, Windows Server 2003 family, Windows 7

See Also

BorderCornerShape Class | BorderCornerShape Members | LidorSystems.IntegralUI.Style Namespace


ControlColorStyle Class

Represents the style for drawing the control.

For a list of all members of this type, see ControlColorStyle Members.

System.Object
LidorSystems.IntegralUI.Style.BackgroundStyle
LidorSystems.IntegralUI.Style.ControlColorStyle

[Visual Basic]
Public Class ControlColorStyle Inherits
   LidorSystems.IntegralUI.Style.BackgroundStyle
[C#]
public class ControlColorStyle : LidorSystems.IntegralUI.Style.BackgroundStyle
[C++]
public __gc class ControlColorStyle : public LidorSystems.IntegralUI.Style.BackgroundStyle
[JScript]
public class ControlColorStyle extends LidorSystems.IntegralUI.Style.BackgroundStyle

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

ControlColorStyle Members | LidorSystems.IntegralUI.Style Namespace


StyleAction Enumeration

Enumerator used to specify the action assigned to some style.

[Visual Basic]
Public Enum StyleAction
[C#]
public enum StyleAction
[C++]
__value public enum StyleAction
[JScript]
public
   enum StyleAction

Members

Member name | Description
Recreate | Recreates the control handle prior updating the control layout.
Repaint | Repaints the control.
Update | Updates the control layout.

Requirements

Namespace: LidorSystems.IntegralUI.Style

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: LidorSystems.IntegralUI (in LidorSystems.IntegralUI.dll)

See Also

LidorSystems.IntegralUI.Style Namespace