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CHAPTER 1

Touring the Workspace
Lingo's workspace is flexible, uses a modern Multiple Document Interface (MDI), and gives you sev-
eral options to work the way that you want.

This chapter discusses the following:
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Main Sections of the Interface
Lingo's user interface consists of the following major sections:

n Top The top portion of the Lingo interface displays a ribbon view, which is used to access fea-
tures.
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n Left The left side of the Lingo interface is the default location for the File List window pane,
which can be used to view a list of the files in the project you are translating. You can double-
click files in the list to open them. Other window panes (e.g., TOC View pane, Source Control
Explorer) are also displayed on the left side.
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n Middle The large middle section of the Lingo interface is the default location for the main Pro-
ject Editor, as well as the Translation Editor, which is used to perform the vast majority of the
translation work in your project. It also displays the Start Page, which is used for quickly per-
forming high-level tasks and accessing information.
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n Right The right side of the Lingo interface (like the left side) is the default location for various
window panes (e.g., Dynamic Help window pane, termbase).

For the most part, the window panes on the edges of the interface are used to support the work that
you do in the middle. You have the flexibility to close or move elements around as you like, so it is not
mandatory that every window pane remain permanently in its default location.

Following are overviews of some of the most important elements that you will encounter as you
work in Lingo.
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Start Page
The Start Page in this application is a handy window pane that displays when you first launch Lingo
and remains open unless you close it. You can use the Start Page to open and create projects,
launch the Align tool, view Help resources, and more.
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Translation Editor
The large middle section of the workspace is used to display the Translation Editor, which is used to
perform the actual translation work for individual files in your project. Lingo's Translation Editor
allows you to work in Translation (or grid) mode, with the source content in one column and the tar-
get language in the next column. For some types of files—such as Flare topics, snippets, and master
pages; Microsoft Excel, PowerPoint, and Word documents; DITA files; HTML files; and XML files—
you can also switch to Live Preview mode, which allows you to view content in its intended context.
A suggestions area at the bottom of the Translation Editor lets you quickly select and insert match-
ing translations from your translation memory (TM) database.
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In the Lingo Options dialog, you can customize the way the Translation Editor and Translation
Memory Editor display translation segments. You can display the source and target segments next
to each other, or with the source segment above the target segment. You can also adjust the editor
font size, which resizes translation segments, translation suggestions, and segment notes based on
your desired font size.
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File List Window Pane
The File List window pane lets you view all of the content files in your project in alphabetical order—
or in another order, such as by file type—by clicking the heading in one of the columns. You can limit
the files that are displayed by using the file type filter. For example, if you want to see only your snip-
pet files, you could select the "Snippet Files" option from the Filter drop-down list. If you want to see
a comprehensive list of the files in the project that should be translated, you can select the "All Files"
option from the drop-down list.
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Statistics Browser
The Statistics Browser window lets you view statistics for your Lingo project, displaying information
about the translation work. This is a way to compare the project files against the TM database in
order to see how much translation work has been completed and how much still needs to be done.
This report can be useful if you are a translator and need to provide estimates to a client, or if you
are an author who is using Lingo to manage the translation process.
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Tab Between User Interface Elements
By using the CTRL+TAB and CTRL+SHIFT+TAB shortcuts, you can easily switch between elements
in the user interface. This opens a popup displaying icons of the various files and window panes that
are currently open in the user interface. Therefore, you can easily move from element to element.
By pressing CTRL+TAB, you can tab forward through the icons. By pressing CTRL+SHIFT+TAB, you
can tab backwards through the icons. When you release the keys, the element associated with the
selected icon opens.

Ribbons
The ribbon layout consists of a File drop-down with common tasks such as creating, exporting, and
updating projects, as well as computing statistics. This is followed by the Home ribbon, which is the
default, and several others related to various features in Lingo.

The ribbon view also lets you take advantage of the Quick Access toolbar, which lets you add your
favorite ribbon options to it.
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Local Toolbars
These are toolbars that are intended for a particular editor or window pane. Most editors and win-
dow panes in Lingo contain a local toolbar.

For example, this is the local toolbar from the Translation Editor:
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CHAPTER 2

Customizing the Workspace
One of the benefits of Lingo's user interface is that it is flexible and easy to customize to meet your
needs. Following are some of the ways you can customize the workspace.

This chapter discusses the following:

Moving, Docking, and Floating Elements 20

Autohiding Window Panes 21

Resizing User Interface Elements 22

Setting User Interface Options 22

Window Layouts 24

Minimizing Ribbons 26

Selecting an Interface Color Theme 27

CHAPTER 2  19



Moving, Docking, and Floating Elements
Simply because a window pane or tab is attached to a particular area of the program window by
default, does not mean it has to stay there.

n Floating and Moving User Interface Elements You can float an element that displays with a
tab by clicking the tab and dragging it down until it floats.

Another way to float an element is to click on it and select Window > Float.

You can move window panes displayed in accordion view by clicking the "Drag Pane" section
. To drag all of the window panes grouped together, click this button in the upper-left

corner of the window pane. To drag a single window pane, click this button in the accordion
bar for that window pane. Hold down your mouse and drag the window panes where you want
them. If you drop a window pane at a random location in the program window, it becomes a
"floating" window.
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n Docking User Interface Elements Docking an element that is floating means to attach it to a
particular part of the program window. To do this, click in the title bar, drag it to the edge
where you want to dock it, and drop it onto one of the small squares that appear in the inter-
face. The portion of the square that has color indicates where the window pane will be
docked.

Dock in center of workspace

Dock on left side of workspace

Dock on right side of workspace

Dock on top side of workspace

Dock on bottom side of workspace

Autohiding Window Panes
In the top-right corner of every window pane, you will see a small button that looks like a pin . If you
click this button, the window pane is hidden (or "pinned" to the edge of the program window).
However, you can still see the title of the window pane along the edge of the program window. When
you hover over the title, the window pane temporarily displays again until you move the mouse off
the window pane. Click the button again to "un-pin" the window pane.
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Resizing User Interface Elements
You can easily resize the program window, dialog windows, and floating window panes in Lingo by
clicking the edge of the element and dragging the mouse to the desired size. You can also resize
drop-down menus in the same way.

Setting User Interface Options
You can set user interface options in the Options dialog. This allows you to make global changes to
how the interface is displayed.

In the Lingo Options dialog, you can customize the way the Translation Editor and Translation
Memory Editor display translation segments. You can display the source and target segments next
to each other, or with the source segment above the target segment. You can also adjust the editor
font size, which resizes translation segments, translation suggestions, and segment notes based on
your desired font size.

CHAPTER 2  22



CHAPTER 2  23



Window Layouts
When you move window panes, explorers, or editors around in the Lingo interface, the configuration
(or "layout") of the workspace is changed. You can do several things with layouts, including the fol-
lowing.

HOW TO SAVE A WINDOW LAYOUT

You can save different layouts of the interface, in case you want to use them for different purposes.

1. Configure the workspace how you want it.

2. Select the Window ribbon. In the Window Layout section select Save Layout > Save Window
Layout As.

3. In the Save Window Layout dialog, enter a name for the layout.

4. Click OK.

HOW TO AUTO-SAVE A WINDOW LAYOUT

You can automatically save the layout of the workspace when you exit Lingo. The next time you
launch Lingo, that same layout will be displayed.

n Select the Window ribbon. In the Window Layout section select Auto-save Layout.

HOW TO SELECT A SAVED WINDOW LAYOUT

You can quickly change the configuration of your workspace by selecting a window layout that you
have saved previously.

n Select the Window ribbon. In the Window Layout section select Layout > [Name of Layout].
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HOW TO RESET THE WINDOW LAYOUT

You can return the workspace configuration to the original layout that you saw when you first
installed and launched Lingo.

n Select the Window ribbon. In the Window Layout section select Reset Layout.

HOW TO RELOAD THE WINDOW LAYOUT

You can return the workspace to the saved configuration of the layout. In other words, if you are
working in a particular layout and have opened different interface elements or moved interface ele-
ments around, you can select this option to go back to the saved configuration.

n Select the Window ribbon. In the Window Layout section select Reload Layout.

HOW TO DELETE A WINDOW LAYOUT

You can open the Manage Window Layouts dialog, which lets you select or delete an existing layout.

1. Select the Window ribbon. In the Window Layout section select Layout > Layouts.

The Manage Window Layouts dialog opens.

2. Select the layout that you want to delete.

3. Click Delete.

4. Confirm the deletion by clicking OK.

5. Click Close.

NOTE: Resetting a layout returns the interface to the way it was when you opened Lingo for
the first time. Reloading a layout means returning the interface to your last saved layout.
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Minimizing Ribbons
You can minimize the ribbons so that you only see the top portion of the ribbons until you select an
option. To do this, right-click anywhere in a ribbon and select Minimize the Ribbon from the context
menu.
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Selecting an Interface Color Theme
You can use the Interface tab on the Options dialog to choose a color scheme for the interface:
black, classic, or silver.
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HOW TO SELECT AN INTERFACE COLOR THEME

1. Select File > Options. The Options dialog opens.

2. Select the Interface tab.

3. Click in the Active Theme and select a color scheme.

4. Click OK.
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