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CHAPTER 1

Introduction
Following is the basic workflow if you are creating original content to be contributed to a MadCap
Flare project.

1. (Optional) Save Contribution Template A Flare author might email you a contribution template
for you to use when creating new documents. Contribution templates are simply files with cer-
tain settings already in place. They are a quick way to create and edit documents in a pre-set
format that the author wants you to use. You can save a contribution template and then use it
later whenever you need to create new documents to send to a Flare author. By saving the
template file in a folder called "Documents\My Templates\Contributor" you can easily select
it when you create a new document. See "Saving Contribution Templates" on page 9.
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2. Create You can create new documents from the Contributor interface. See "Creating New
Documents" on page 11.

3. (Optional) Insert Comments You can insert annotations (comments) that are associated with
specific areas of text in the document. These annotations do not become part of the content
in the document, but rather are intended for internal use between you and others.
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4. After you finish a document, you can do the following.

n "Sending Documents to Authors" on page 34

n "Saving Documents" on page 36

n "Saving Documents as XPS Files" on page 38

n "Saving Documents as XHTML Files" on page 39

n "Printing Documents" on page 40

NOTE Because documents in Contributor are often used as part of Flare projects, you may
sometimes see them referred to as "topics."
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CHAPTER 2

Saving Contribution Templates
Supported In:

A Flare author might email you a contribution template for you to use when creating new doc-
uments. Contribution templates are simply files with certain settings already in place. They are a
quick way to create and edit documents in a pre-set format that the author wants you to use. You
can save a contribution template and then use it later whenever you need to create new documents
to send to a Flare author. By saving the template file in a folder called "Documents\My Tem-
plates\Contributor" you can easily select it when you create a new document.
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HOW TO SAVE CONTRIBUTION TEMPLATES

1. In the Documents folder on your computer, create a subfolder and name it My Templates.
This subfolder can be used to hold all of the contribution templates that an author sends to
you.

2. In the My Templates folder, create a subfolder and name it Contributor.

3. Open the email message that the Flare author has sent to you, with the contribution template
as an attachment.

4. Double-click the attachment.

5. In the dialog that opens, click Save.

6. Navigate to the Documents\My Templates\Contributor folder and click Save.

NOTE In addition to contribution template files (those with an .mccot extension), Con-
tributor lets you select other types of files from the template folder as well. This includes
document template files (.mcdoct), XHTML files (.htm), stylesheet files (.css), and page lay-
out files (.mcpglt).

NOTE Any templates that you created in the past for X-Edit can still be used in Contributor,
but those files will need to be relocated to the new Contributor folder location in order to
use them when creating new documents.

CHAPTER 2  10



CHAPTER 3

Creating New Documents
Supported In:

You can create new documents (or topics) from the Contributor interface. If a Flare author has sent
you a contribution template that you have saved, you can select that template when creating the
new document.
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HOW TO CREATE A NEW DOCUMENT

1. Select File > New.

2. Select a file to use as a basis for your new document, either from a template or from another
existing file.

OPTIONS

n Factory Templates If you selected Factory Templates, you can choose from various tem-
plates provided by Contributor.

l Document.mcdoct This template creates a basic document with a header and a
little body text. You will end up with a document that has an .mcdoc extension.
Select this option if you want to create a standalone document, rather than a con-
tribution topic that will be sent to a Flare author.

l Topic.mccot This template creates a very basic topic file with a header and a little
body text. You will end up with a document that has an .mcco extension. An MCCO
file is the same as an MCDOC file, with the exception that it indicates the file was cre-
ated specifically for use as a contribution topic. If you create an MCCO document,
you can quickly email it to Flare authors for incorporation into their projects.

l XHTML Document.htm This template creates a very basic document with a header
and a little body text. You will end up with an XHTML document that has an .htm
extension. An HTM file is a good option if you want to post the file on the Internet or
an intranet, where others can view it in a browser window.

NOTE You can quickly create a new XHTML document by pressing CTRL+N
on the keyboard.
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l Stylesheet.css This template creates a cascading stylesheet (CSS). You will end up
with a file that has a .css extension, and it will open in the Stylesheet Editor. A CSS
file can be used to create elements with formatting. You can then apply the format-
ted styles to content in a document to change how it looks.

NOTE If a Flare author has provided you with a contribution template,
chances are that you will use the styles provided by the author, rather than
creating your own stylesheet.

l Page Layout.mcpglt This template creates a page layout file. You will end up with a
file that has an .flpgl extension, and it will open in the Page Layout Editor. A page lay-
out is an element that you can create in order to determine page specifications (e.g.,
size, margins) and to apply certain content (e.g., headers, footers, page numbers) to
your document for print-based output. Page layouts allow for easy configuration
through the use of content frames, a snap-to grid, dragging and dropping, alignment
features, and more.

NOTE If a Flare author has provided you with a contribution template,
chances are that you will use the page layout provided by the author, rather
than creating your own page layout.

n My Templates If you selected My Templates, you can choose from any templates that
you have saved in your "Documents\My Templates\Contributor" folder. This would likely
include any contribution templates that a Flare author has sent to you. See "Saving Con-
tribution Templates" on page 9.

NOTE Any templates that you created in the past for X-Edit can still be used in
Contributor, but those files will need to be relocated to the new Contributor folder
location in order to use them when creating new documents.
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n New from existing This lets you choose an existing file of the same type—that you've
already created and stored somewhere—as a starting point for your new file. As with tem-
plate files, your new file will take on all of the settings contained in the file you select. To
use this option, click the browse button , use the Open File dialog to find a file, and
double-click it.

3. In the Folder field, select a folder for the new document. You can browse for a folder by click-
ing the browse button . The Open File dialog, will open, allowing you to find a file.

4. In the File Name field, enter a file name.

5. Click OK.

6. For most document types, add any content, formatting, or annotations as necessary. If you
created a stylesheet or page layout, you can use the respective editors to make changes to
those types of files as well.

7. Click to save your work.
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CHAPTER 4

Tracking Changes
For documents in Contributor, you can track changes and accept or reject those alterations indi-
vidually. Each change is marked in a color (different colors for different users) and/or labeled in a
sidebar. Tracked changes are visible only in the editor in Contributor. They are not visible when view-
ing any output created from the document (e.g., saving to HTM, XPS, or PDF files).

When this feature is enabled, every change to the document—along with the user who performed
the change—will be stored in the document’s markup. For example, deleted text won’t actually be
removed from the document, but will instead be marked as deleted in the code. However, if the
change is accepted, the text will be removed from the document.

When a Flare author sends you a review package file (FLTREV) and you edit the content files within
it, your changes are automatically tracked so that the author can easily see the changes you made.
You cannot disable the track changes feature for these types of documents.

This chapter discusses the following:

Examples 16

Enabling Track Changes 18

Hiding and Showing Changes and Annotations 19

Changing Your User Name and Initials 20

Changing the Display of Tracked Changes 21

Changing the User Color for Reviews 24

Finding Changes 26

Accepting or Rejecting Tracked Changes 27
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Examples
The following images show how tracked changes work in Contributor.
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Enabling Track Changes
Supported In:

For documents that you create in Contributor, you can track changes and accept or reject those
alterations individually. Each change is marked in a color (different colors for different users) and/or
labeled in a sidebar.

When a Flare author sends you a review package file (FLTREV) and you edit the content files within
it, your changes are automatically tracked so that the author can easily see the changes you made.
You can not disable the track changes feature for these types of documents.

HOW TO ENABLE THE TRACK CHANGES FEATURE

1. Open the document that you created (not one you received for review).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Review > Track Changes.

n Keyboard Shortcut Press CTRL+SHIFT+E.
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Hiding and Showing Changes and
Annotations
Supported In:

You can hide or show tracked changes and annotations in the active document.

HOW TO HIDE AND SHOW CHANGES AND ANNOTATIONS

1. Open the document or topic.

2. Select Review > Show Changes.
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Changing Your User Name and Initials
Supported In:

When you first install and launch Contributor, your login user name is captured and stored in the
Review tab of the Options dialog (File > Options). The first two letters of the user name are also
stored as your initials. This information is employed whenever you use the track changes and
annotations features.

For example, if you insert an annotation in a topic, your initials are displayed at the beginning of the
comment so that other users know where the annotation came from.

You can always change your Contributor user name or initials to something else.

EXAMPLE

Let's say your login user name is "johndoe." In that case, your initials are stored auto-
matically as "jo." Although you want to keep your user name as is, you want to change
the initials to "jd," which other users will more readily associate with you. Therefore, you
open the Options dialog (File > Options) and use the Review tab to change only your ini-
tials.

HOW TO CHANGE THE USER NAME AND INITIALS FOR REVIEWS

1. Select Review > Review Options.

2. Change the text in either the User Name or Initials fields.

3. Click OK.
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Changing the Display of Tracked Changes
Supported In:

You can change the way tracked changes are displayed in the interface (e.g., in balloons, inline).
You can also enable or disable change bars.

HOW TO CHANGE THE DISPLAY OF TRACKED CHANGES

1. Select Review > Review Options.

2. In the Tracked Change Display section, choose any of the following.

DISPLAY ALL CHANGES IN BALLOONS

If you select this option, all changes—text and formatting—will be shown in balloons in the side-
bar.
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DISPLAY ONLY FORMAT CHANGES IN BALLOONS

If you select this option, changes that include content only (or content plus formatting) will be
shown inline. But changes that contain formatting modifications only will be shown in balloons
in the sidebar.

DISPLAY ALL NON-FORMAT CHANGES INLINE

If you select this option, all text changes will be shown inline. Balloons are not used.
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3. In the Change Bar section, select whether or not you want to turn on change bars. If you turn
on change bars, a bar appears on the left side of the paragraph where a change has been
made. Change bars appear in PDF output and the XML Editor.

4. Click OK.
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Changing the User Color for Reviews
Supported In:

The tracked changes and annotations for each user can be shown in a separate color. You also
have the option of choosing a specific color for all users.

HOW TO CHANGE THE USER COLOR FOR REVIEWS

1. Select Review > Review Options.

2. In the User Colors section, choose one of the following.

USE A DIFFERENT COLOR FOR EACH USER

Select this option if you want Contributor to automatically assign a different color for each
user.
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USE THE FOLLOWING COLOR FOR ALL USERS

Select this option if you want all changes, regardless of the user, to display in the same color.
After you choose this option, click the down arrow below to select a color.

3. Click OK.
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Finding Changes
Supported In:

You can use navigation buttons in the Review ribbon to quickly navigate to the previous or next
tracked change or annotation in the file.

HOW TO FIND CHANGES

1. Open the document or topic.

2. Make sure you have changes set to be displayed. See "Hiding and Showing Changes and
Annotations" on page 19.

3. Select Review > Next Change or Review > Previous Change.
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Accepting or Rejecting Tracked Changes
Supported In:

You can right-click on tracked changes and use a context menu to accept or reject them indi-
vidually. You can also use options in the interface to accept or reject each tracked change or all
tracked changes in a file. The reject option also removes annotations.

When you track changes, every change to the document—along with the user who performed the
change—will be stored in the document’s markup. When a change is accepted or rejected, all
markup designating it as a change is removed. When all changes in the document are resolved, they
will not contain any history of changesmade and can be considered ready for output.

HOW TO ACCEPT OR REJECT TRACKED CHANGES

1. Open the document or topic.

2. Make sure you have changes set to be displayed. See "Hiding and Showing Changes and
Annotations" on page 19.

3. You can perform any of the following tasks.

ACCEPT ALL CHANGES IN THE DOCUMENT

n Select Review > Accept Change > Accept All Changes.

ACCEPT SINGLE CHANGE

Do one of the following, depending on the part of the user interface you are using:

n Ribbon Click on the change you want to accept. Select Review > Accept Change.

n Right-Click Right-click on the change you want to accept. From the context menu,
select Accept [Type of Change].
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REJECT ALL CHANGES IN THE DOCUMENT

n Select Review > Reject Change > Reject All Changes.

REJECT SINGLE CHANGE

Do one of the following, depending on the part of the user interface you are using:

n Ribbon Click on the change you want to reject. Select Review > Reject Change.

n Right-Click Right-click on the change you want to reject. From the context menu, select
Reject [Type of Change].

4. Click to save your work.

NOTE Tracked changes are visible only in the editor in Contributor. They are not visible
when viewing any output created from the document (e.g., saving to HTM, XPS, or PDF
files).

NOTE This feature is not supported for MadCap Lingo review package (LIREV) files.
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CHAPTER 5

Annotations
Supported In:

You can insert an annotation (comment) into a document. These annotations do not become part
of the actual content, but rather are intended for internal use between you and others.

This chapter discusses the following:

Inserting Annotations 30

Editing Annotations 32

Deleting Annotations 33
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Inserting Annotations
Following are steps for inserting annotations.

HOW TO INSERT AN ANNOTATION

1. Open the document or topic.

2. Highlight the content that you want to associate with the annotation, or place your cursor on
it.

NOTE Do not highlight more than one paragraph.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Review > Insert Annotation.

n Right-Click If the track changes feature is enabled, you can right-click and select Insert
Annotation.

A rectangle extends to a sidebar on the right, with a line pointing to the selected content.
This rectangle will hold the annotation text after you type it.

Also, the selected content is shaded, indicating that the annotation refers to that text.
However, the shading will not be displayed in the output; it is for internal use only.
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4. Type your comment in the annotation rectangle.

5. Click to save your work.

NOTE When you insert an annotation, your initials are displayed next to it. The initials are
the first two letters of your login user name. However, you can change the user name and
initials (for use in Contributor) to something else.  For more information see the online Help.
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Editing Annotations
You and other individuals can insert comments and notes next to content in a topic. Annotations do
not become part of the actual content; they are simply comments for your internal use. You can eas-
ily make changes to an annotation.

HOW TO EDIT ANNOTATIONS

1. If you do not see annotations in the editor, select Review > Show Changes.

2. Click in the rectangle containing the annotation text and make your changes.

3. Click to save your work.
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Deleting Annotations
You can delete annotations that have been inserted into a document or topic.

HOW TO DELETE ANNOTATIONS

1. Open the document or topic.

2. Make sure you have changes set to be displayed. See "Hiding and Showing Changes and
Annotations" on page 19.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the annotation you want to delete. Select Review > Delete Annotation.

n Right-Click Right-click on the annotation you want to delete, and from the context menu,
select Delete Annotation.

4. Click to save your work.
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CHAPTER 6

Sending Documents to Authors
Supported In:

You can send a finished contribution document (MCCO file) to a Flare author so that it can be incor-
porated into a larger project.

NOTE There is more than one way to transfer files between individuals using Flare and Con-
tributor. For example, you can: (1) use the integrated email feature with Microsoft Outlook,
(2) add files to SharePoint or External Resources where others can access them, or (3) save
files to your computer (File > Save, then Save As or Save To) and then manually transfer
them using some method (e.g., email). If you want to use the integrated email feature, you
must have matching versions of Contributor and Outlook. If you are using 64-bit Contributor,
you need 64-bit Outlook. Likewise, if you are using 32-bit Contributor, you need 32-bit
Outlook.
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HOW TO SEND A NEW DOCUMENT TO AN AUTHOR

The following steps include the integrated Outlook email method. If your systems are not set up for
this feature, you can use one of the other methods (e.g., or save to your computer and manually
email).

1. Create or open the MCCO file.

NOTE If you have just created a new document, you must save it before you can
send it.

2. In the local toolbar of the editor click .

3. Complete the email message with the address of the recipient(s) and any message text. Then
send it.
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CHAPTER 7

Saving Documents
Supported In:

After creating a new document, you can save it in various formats.

This chapter discusses the following:

Saving Documents as PDF Files 37

Saving Documents as XPS Files 38

Saving Documents as XHTML Files 39
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Saving Documents as PDF Files
Short for "Portable Document Format," PDF is an open standard format for electronic doc-
umentation exchange invented by Adobe. PDF files are used to represent a two-dimensional doc-
ument in an device- and resolution-independent fixed-layout format.

HOW TO SAVE DOCUMENTS AS PDF FILES

1. Create or open a document.

2. Select  File > Save > Save To.

3. In the dialog that opens, navigate to the folder where you want to store the PDF document.

4. In the File name field, enter a name for the PDF document.

5. Click in the Save as type filed and select PDF File (*.pdf).

6. Click Save.
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Saving Documents as XPS Files
After creating a new document, you can save it as an XPS file. Microsoft's XML Paper Specification
(XPS) is a document format with a markup language that is a subset of XAML for Windows Present-
ation Foundation. XPS is an alternative to Adobe's Portable Document Format (PDF).

HOW TO SAVE DOCUMENTS AS XPS FILES

1. Create or open a document.

2. Select  File > Save > Save To.

3. In the dialog that opens, navigate to the folder where you want to store the XPS document.

4. In the File name field, enter a name for the XPS document.

5. Click in the Save as type field and select one of the following options.

n XPS File (Editable) (*.xps)

n XPS File (Editable. Non-Standard Extension) (*.exps)

6. Click Save.
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Saving Documents as XHTML Files
After creating a new document, you can save it as an XHTML file.

HOW TO SAVE DOCUMENTS AS XHTML FILES

1. Create or open a document.

2. Select  File > Save > Save To.

3. In the dialog that opens, navigate to the folder where you want to store the XHTML doc-
ument.

4. In the File name field, enter a name for the XHTML document.

5. Click in the Save as type field and select XHTML File (*.htm).

6. Click Save.
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CHAPTER 8

Printing Documents
Supported In:

You can print a document directly from the Contributor interface.

HOW TO PRINT DOCUMENTS

1. Create or open a document

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > Print.

n Keyboard Shortcut Press CTRL+P on your keyboard.

The Print dialog opens.

3. Complete the options in the Print dialog.

4. Click OK.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Contributor Workflow Guide

Getting Started Guide

Review Workflow Guide

Shortcuts Guide

What's New Guide
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