Introduction

Virtual Keyboard Programmer's Guide
Introduction

MindFusion Virtual Keyboard is an on-screen keyboard component that enables text and shortcut input through touch, mouse or stylus events. The control works similarly to Windows Mobile embedded keyboard, letting users input text into the currently focused entry field. It is especially useful for applications running on touch screen terminals, such as POS or industrial systems. The integration of an onscreen virtual keyboard can also be used to enhance traditional desktop applications with accessibility features. It is implemented as a .NET WPF control and can be easily integrated with any application targeting the Microsoft .NET platform.

With Virtual Keyboard you can:

  • implement text input in keyboardless environment
  • build Kiosk or POS user interfaces with a limited number of input keys
  • send keys as input to external applications
  • implement accessibility features for users with mobility impairments
  • show common words for your application as keys in the keyboard

Virtual Keyboard has been tested with the most popular .NET development environments and programming languages, and is used by companies from all around the world to create applications in C#, VB.NET and Delphi.NET.

© 2016 MindFusion


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion Virtual Keyboard:

New in version 4.4

API Changes

  • Classes have been moved to MindFusion.UI.Wpf namespace.
  • CanUnlockSpecialKey property renamed to AutoReleaseModifierKeys.
  • Repetition property renamed to Repeat.
  • GetVirtualKeyKode method renamed to GetVirtualKeyCode.
  • FpsKeyEventArgs class renamed to VirtualKeyEventArgs.


Getting Started

Getting Started

1. In Visual Studio, select File -> New -> Project -> WPF Application. Virtual Keyboard requires .NET 3.5 or newer versions, make sure selected target framework is at least .NET 3.5.

2. With default settings, Visual Studio should open the project's main window in Xaml Designer. If using Visual Studio 2010 and newer version, you should now see MindFusion Virtual Keyboard toolbox palette installed in the toolbox with the VirtualKeyboard control inside it.

Manual toolbox configuration in VS2008
If using VS2008, you can still add the .NET 3.5 components manually to toolbox from its context menu -> Choose Items command. Click the Browse button on Choose Toolbox Items dialog, navigate to CLR2 folder and select MindFusion.Keyboard.Wpf.dll. Confirm your selection until the dialog closes, and you should now see the VirtualKeyboard icon in toolbox.

3. Drag VirtualKeyboard to the window.

4. Select the keyboard control and in Properties window set its IsStandAlone property to true.

5. Press F5 and you should see working keyboard inside the window. Open Notepad or another text editor. Make sure the edit area has the keyboard focus (it shows a blinking caret). If you now click on virtual keyboard keys, you should see their contents appear in the editor.


Licensing

Licensing

There are no separate trial builds of MindFusion assemblies. When you purchase a component you can find the license key for this component listed on the Keys & Downloads page at the customer's portal [image] . Assign this license key to the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one MindFusion component, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) method from application start-up code to specify the key once instead of setting it per each control.


Programming Interface Overview

Programming Interface Overview


Virtual Keys

Virtual Keys

Keys in the virtual keyboard are represented by instances of classes derived from Key:

  • RegularKey sends a character or longer string as input to focused control and can display several labels (e.g. for lower and upper case letters). Its Content property specifies the text to send when the key is pressed. the Repeat property lets you send the text several times if set to a value larger than one.
  • SpecialKey represents modifier and function keys. It sends a virtual key code and displays a custom label specified through Content.
  • NumPadKey represents keys on the num-pad. The key code it sends depends on current state of Num lock.
  • ExtendedKey represents a sequence of other keystrokes, listed in its Keys collection property. Pressing such key sends all key codes in the sequence.

You can sends key's content to focused input control programmatically by calling its Send method. Standard modifier, function and num-pad key instances are exposed as static members of the class. For example you can simulate F12 press by calling Key.F12.Send(). To send text, create a RegularKey, set its Content and call Send. The Key class also specifies the position and size of a key within KeyboardLayout. You can set them through Left, Top, Width and Height properties.

When a modifier key such as Shift or Ctrl is pressed, the keyboard does not release it immediately but waits until a regular key is pressed. If AutoReleaseModifierKeys is set to false, modifier keys won't be released automatically, but the user must press them again to turn off their respective mode.

You can check the state of modifier keys by inspecting following properties of VirtualKeyboard:

  • ScrollLocked specifies whether Scroll Lock mode is enabled
  • NumLocked specifies whether Num Lock mode is enabled
  • CapsLocked whether Caps Lock mode is enabled
  • ControlLocked specifies whether the Ctrl key is pressed
  • ShiftLocked specifies whether the Shift key is pressed
  • AltLocked specifies whether the Alt key is pressed
  • AltGrLocked specifies whether the right AltGr key is pressed


Keyboard Layout

Keyboard Layout

The component includes two predefined keyboard layouts represented by Default and Extended members of the KeyboardMode enumeration, that can be assigned to the Mode property of VirtualKeyboard. The Default layout is similar to a laptop keyboard without a numpad. Extended mode corresponds to a full keyboard with numpad and navigational key sections.

You can also create custom layouts represented by KeyboardLayout objects by populating their Keys collections. A KeyboardLayout can be assigned to the TemplateLayout property of VirtualKeyboard to create a language-independent layout whose character labels are automatically set from current locale information. Alternatively, you could set Mode to Custom and specify the location of language-dependent layout files via LayoutsFolder.

While it is possible to create a KeyboardLayout programmatically, it is far easier to use the Keyboard Creator tool installed with the control. You can quickly generate initial layout by choosing a language from the property palette and selecting the Default Layout or Extended Layout commands from Layout menu. You can then remove unnecessary keys, move or resize existing ones or change their labels. You could as well build a layout from scratch by dragging and dropping keys from the various palettes below the menu.

Once you are happy with the result, save the layout to a file. The file can be loaded into the application by either placing it in LayoutsFolder (in which case you should also keep the locale ID part added to the name by the tool), or by calling the static Create method of KeyboardLayout and assigning the result to TemplateLayout:

C# [image] Copy Code

virtualKeyboard.TemplateLayout = KeyboardLayout.Create("mylayout.xml");


Appearance

Appearance

Appearance of keyboard keys can be customized using Xaml data templates. The following code from Styles sample project defines a DataTemplate for each Key -derived class:

Xaml [image] Copy Code

<DataTemplate DataType="{x:Type vk:RegularKey}">
<ContentControl HorizontalContentAlignment="Center" VerticalContentAlignment="Center">
<StackPanel IsHitTestVisible="False" Visibility="Visible" x:Name="sp" >
<StackPanel Orientation="Horizontal" HorizontalAlignment="Left">
<TextBlock Text="{Binding UpperCase}"/>
<TextBlock Text="{Binding AlterCase}" Foreground="Black" Margin="5 0 0 0"/>
</StackPanel>
<TextBlock Text="{Binding LowerCase}" HorizontalAlignment="Right" Foreground="Black"/>
</StackPanel>
</ContentControl>
</DataTemplate>

<DataTemplate DataType="{x:Type vk:SpecialKey}">
<ContentControl x:Name="btn" VerticalContentAlignment="Center" HorizontalContentAlignment="Center" Foreground="Black" BorderBrush="Red" BorderThickness="2">
<Grid x:Name="grid_Brnd">
<TextBlock Text="{Binding Content}" TextWrapping="Wrap" Foreground="{Binding Foreground,ElementName=btn}"/>
</Grid>
</ContentControl>
<DataTemplate.Triggers>
<DataTrigger Binding="{Binding IsLocked}" Value="True">
<Setter Property="BorderBrush" Value="Black" TargetName="btn"/>
<Setter Property="Foreground" Value="White" TargetName="btn"/>
</DataTrigger>
</DataTemplate.Triggers>
</DataTemplate>

<DataTemplate DataType="{x:Type vk:NumPadKey}">
<ContentControl x:Name="btn">
<StackPanel HorizontalAlignment="Left">
<TextBlock Text="{Binding NumCase}" Foreground="Red" HorizontalAlignment="Left"/>
<TextBlock Text="{Binding Content}" TextWrapping="Wrap" HorizontalAlignment="Left"/>
</StackPanel>
</ContentControl>
<DataTemplate.Triggers>
<DataTrigger Binding="{Binding IsLocked}" Value="True">
<Setter Property="BorderBrush" Value="Red" TargetName="btn"/>
</DataTrigger>
</DataTemplate.Triggers>
</DataTemplate>

<DataTemplate DataType="{x:Type vk:ExtendedKey}">
<ContentControl>
<TextBlock Text="{Binding Content}"/>
</ContentControl>
</DataTemplate>

The standard VirtualKeyboard and key class templates bind to brushes with following identifiers as dynamic resources. You could define them in your own resource dictionary, or use one of the pre-defined themes from MindFusion.Themes.Wpf.dll:

  • IC_Background is assigned to the Background property of the VirtualKeyboard control.
  • IC_Foreground is assigned to the Foreground property of the VirtualKeyboard control.
  • IC_ButtonBackground is assigned to Fill property of keys in normal state.
  • IC_ButtonPressedBackground is assigned to Fill property of keys in pressed state.


Keyboard Language

Keyboard Language

VirtualKeyboard automatically generates keys for languages listed below when Windows current input language changes. You can also create a custom language layout using the Keyboard Creator tool and saving the file in LayoutsFolder.

•AR Arabic 101 (Bahrain)
•AR Arabic 101 (Egypt)
•AR Arabic 101 (Iraq)
•AR Arabic 101 (Jordan)
•AR Arabic 101 (Kuwait)
•AR Arabic 101 (Lebanon)
•AR Arabic 101 (Oman)
•AR Arabic 101 (Qatar)
•AR Arabic 101 (Saudi Arabia)
•AR Arabic 101 (Syria)
•AR Arabic 101 (UAE)
•AR Arabic 101 (Yemen)
•AR Arabic 102 AZERTY (Algeria)
•AR Arabic 102 AZERTY (Libya)
•AR Arabic 102 AZERTY (Marocco)
•AR Arabic 102 AZERTY (Tunisia)
•BE Belorussian (Belorus)
•BG Bolgarian (Bulgaria)
•BN Bengal (India)
•BS Bosnian Cyrilik (Bosnia and Herzegovina)
•BS Bosnian Latin (Bosnia and Herzegovina)
•CA Catalan
•CS Czech (Czech Republic)
•CS Czech (Czech Republic) Czeck (QWERTY)
•CS Czech (Czech Republic) Czeck programmers
•CY British (Bratain)
•CY Welsh (Bratain)
•DA Danish (Denmark)
•DE German (Austria)
•DE German (Germany) German
•DE German (Germany) German (IBM)
•DE German (Liechtensein)
•DE German (Luxembourg)
•EL Greek 220 (Greece)
•EL Greek 220 Latin (Greece)
•EL Greek 319 (Greece)
•EL Greek 319 Latin (Greece)
•EL Greek Latin (Greece)
•EL Greek (Greece)
•EL Greek Politonik (Greece)
•EN English International (USA)
•EN English (Australia)
•EN English (Belize)
•EN English (Canada)
•EN English (Caribbean)
•EN English (Ireland)
•EN English (Ireland) Gaelic
•EN English (Jamaica)
•EN English (New Zealand)
•EN English (Philippines)
•EN English (South Africa)
•EN English (South Africa)
•EN English (USA)
•EN English (Zimbabwe)
•EN English British (UK)
•EN English Drovak (Belize)
•EN English Drovak (USA)
•EN English Drovak Left Hand (USA)
•EN English Drovak Right Hand (USA)
•EN English Irish (Ireland)
•ES Spanish (Argentina)
•ES Spanish (Bolivia)
•ES Spanish (Chile)
•ES Spanish (Colombia)
•ES Spanish (Costa Rica)
•ES Spanish (Dominican Republic)
•ES Spanish (Ecuador)
•ES Spanish (El Salvador)
•ES Spanish (Guatemala)
•ES Spanish (Honduras)
•ES Spanish (International)
•ES Spanish (Mexico)
•ES Spanish (Nicaragua)
•ES Spanish (Panama)
•ES Spanish (Paraguay)
•ES Spanish (Peru)
•ES Spanish (Puerto Rico)
•ES Spanish (Spaine) Traditional
•ES Spanish (Uruguay)
•ES Spanish (Venezuela)
•ET Estonian (Estonia)
•EU Euskaldunak (Euskadi)
•Fi Finnish (Finland) Finnish
•Fi Finnish (Finland) Finnish with Sami
•FR French (Belgium) Belgian French
•FR French (Canada) Canadian French
•FR French (Canada) Canadian French (Legasy))
•FR French (Canada) Canadian Multilingual Standard
•FR French (France)
•FR French (Switzerland) Swiss French
•FR French (Switzerland) Swiss German
•FY Frisian (Netherlands)
•HE Hebrew (Israel)
•HI Hindi (India)
•HR Croatian (Bosnia and Herzegovina)
•HR Croatian (Croatia)
•HU Hungarian (Hungary) Hungarian
•HU Hungarian (Hungary) Hungarian 101-key
•HY Armenian Eastern (Armenia)
•HY Armenian Western (Armenia)
•IN Indonesian (Indonesia)
•IS Icelandic (Iceland)
•IT Italian (Italy)
•IT Italian (Italy) 142
•IT Italian (Swiss)
•IU Inuktitut (Canada) Latin
•KA Georgian (Georgia)
•KA Greenlandic (Greenland)
•LB Luxembourgian (Luxembourg)
•LT Lithuanian (Lithuania)
•LT Lithuanian IBM (Lithuania)
•LV Latvian QWERTY (Latvia)
•LV Latvian (Latvia)
•MK Macedonian FYROM (Macedonia)
•ML Maltese 47 (Malta)
•ML Maltese 48 (Malta)
•MY Malayalam (India)
•NE Nepali (Nepal)
•NL Dutch (Belgian) Comma
•NL Dutch (Netherlands)
•NO Norwegian Soomy (Norway)
•NO Norwegian (Norway)
•NO Norwegian NewNorsk (Norway)
•PA Pashto (Afhghanistan)
•PL Polish (Poland)
•PL Polish Programmers (Poland)
•PT Portuguese (Brasil)
•PT Portuguese (Portugal)
•PT Portuguese ABNT(Brasil)
•RO Romanian (Romania)
•RU Russian (Russia)
•SK Slovak (Slovakia)
•SK Slovak QWERTY (Slovakia)
•SL Slovenian (Slovenia)
•SM Sami lul (Sweden)
•SQ Albanian (Albania)
•SR Serbian Cerilik (Serbia)
•SR Serbian Latin (Serbia)
•SV Sweden (Sweden)
•TH Thai Kedmanee
•TH Thai Kedmanee without SHIFTLOCK
•TH Thai Patashot
•TH Thai Patashot without SHIFTLOCK
•TR Turkish F (Turkey)
•TR Turkish Q (Turkey)
•UA Ukrainian (Ukraine)
•VI Vietnamese (Vietnam)


Key-press Dispatch

Key-press Dispatch

Virtual Keyboard generates low-level events by calling system functions used by keyboard drivers. Windows dispatches key-press messages to active window and its focused controls. If you need to send keyboard input to a specific text-entry control, you must ensure the control is focused, e.g. by calling the UIElement.Focus() method.

If you need to send keyboard input to an external process, you must ensure your own application's window does not activate when the user clicks on it. One way to do that is by setting WS_EX_NOACTIVATE flag in Win32 :

C# [image] Copy Code

const int GWL_EXSTYLE = -20;
const int WS_EX_NOACTIVATE = 0x08000000;

[DllImport("user32")]
static extern IntPtr SetWindowLong(IntPtr hWnd, int nIndex, int dwNewLong);

WindowInteropHelper interop = new WindowInteropHelper(window);
SetWindowLong(interop.Handle, GWL_EXSTYLE, WS_EX_NOACTIVATE);

The keyboard's IsStandalone property sets that flag for the control's parent window, in addition to few others such as a topmost flag.


Reference

Reference


MindFusion.UI.Wpf Namespace

MindFusion.UI.Wpf Namespace
Classes Enumerations

Classes

Class | Description
ExtendedKey | Represents a key that sends several key codes when pressed.
Key | Represents a key in the keyboard.
KeyboardLayout | Defines layout of keyboard keys.
NumPadKey | Represents a num pad key.
RegularKey | Represents regular keyboard keys that send character codes as input.
SpecialKey | Represents special keys.
VirtualKeyboard | Virtual Keyboard Control.
VirtualKeyEventArgs | Contains data about KeyPressed events.

Enumerations

Enumeration | Description
KeyboardMode | Identifies keyboard layout modes.


MindFusion.UI.Wpf.ExtendedKey Class

ExtendedKey Class
See Also
[image]

Represents a key that sends several key codes when pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class ExtendedKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class ExtendedKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.ExtendedKey

See Also

ExtendedKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Members

ExtendedKey Members
Constructors Properties Methods Events
[image]

Represents a key that sends several key codes when pressed.

The following tables list the members exposed by the ExtendedKey type.

Public Constructors

Name | Description
ExtendedKey |

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
Keys | List of regular keys sent by this key.
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this ExtendedKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey Constructor

ExtendedKey Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public ExtendedKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey Methods

ExtendedKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this ExtendedKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey.Clone Method

ExtendedKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new ExtendedKey instance.

See Also

ExtendedKey Members
ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey.Equals Method

ExtendedKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

ExtendedKey Members
ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey.GetHashCode Method

ExtendedKey.GetHashCode Method
[image]

Returns a hash code for this ExtendedKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

ExtendedKey Members
ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey.Send Method

ExtendedKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

ExtendedKey Members
ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey Properties

ExtendedKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
Keys | List of regular keys sent by this key.
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

ExtendedKey Class


MindFusion.UI.Wpf.ExtendedKey.Keys Property

ExtendedKey.Keys Property
[image]

List of regular keys sent by this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public List<Key> Keys { get; set; }

Visual Basic [image] Copy Code

Public Property Keys As List(Of Key)

Property Value

See Also

ExtendedKey Members
ExtendedKey Class


MindFusion.UI.Wpf.Key Class

Key Class
[image]

Represents a key in the keyboard.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract class Key : INotifyPropertyChanged, ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class Key
Implements INotifyPropertyChanged, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.ExtendedKey
MindFusion.UI.Wpf.NumPadKey
MindFusion.UI.Wpf.RegularKey
MindFusion.UI.Wpf.SpecialKey

See Also

Key Members


MindFusion.UI.Wpf.Key Members

Key Members
Constructors Properties Methods Events
[image]

Represents a key in the keyboard.

The following tables list the members exposed by the Key type.

Protected Constructors

Name | Description
Key |

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18
AltGr | The alt gr virtual key. Virtual Key = 165
Backspace | The backspace virtual key.
CapsLock | The caps lock virtual key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.
Context | The context menu virtual key.
Ctrl | The control virtual key. Virtual Key = 17
Delete | The delete virtual key.
End | The end virtual key.
Enter | The enter virtual key. Virtual Key = 13
Esc | The escape virtual key.
F1 | The F1 virtual key.
F10 | The F10 virtual key.
F11 | The F11 virtual key.
F12 | The F12 virtual key.
F2 | The F2 virtual key.
F3 | The F3 virtual key.
F4 | The F4 virtual key.
F5 | The F5 virtual key.
F6 | The F6 virtual key.
F7 | The F7 virtual key.
F8 | The F8 virtual key.
F9 | The F9 virtual key.
Height | The key's height.
Home | The home virtual key.
Image | Gets or sets relative path to an image that should be displayed inside this key.
Insert | The insert virtual key.
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.
IsSelected | IsSelected
KeyDown | The key down virtual key.
KeyLeft | The key left virtual key.
KeyRight | The key right virtual key.
KeyUp | The key up virtual key.
Lang | Language rotation virtual key.
Left | Horizontal position of the key.
Num5 | The numpad 5 virtual key.
NumDelete | The numpad delete virtual key.
NumDiv | The numpad / virtual key.
NumEnd | The numpad end virtual key.
NumHome | The numpad home virtual key.
NumInsert | The numpad insert virtual key.
NumKeyDown | The numpad key-down virtual key.
NumKeyLeft | The numpad key-left virtual key.
NumKeyRight | The numpad key-right virtual key.
NumKeyUp | The numpad key-up virtual key.
Numlock | The num lock virtual key.
NumMinus | The numpad - virtual key.
NumMult | The numpad * virtual key.
NumPageDown | The numpad page down virtual key.
NumPageUp | The numpad page up virtual key.
NumPlus | The numpad + virtual key.
PageDown | The page down virtual key.
PageUp | The page up virtual key.
PauseBreak | The pause / break virtual key.
PrtScr | The Print Screen virtual key.
ScrolLock | The scroll lock virtual key.
Shift | The shift virtual key. Virtual Key = 16
Space | The space virtual key.
Tab | The tab virtual key.
Top | Vertical position of the key.
Width | The key's width.
Windows | The Windows virtual key.

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this Key.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value.
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one.

Public Events

Name | Description
PropertyChanged | PropertyChanged

See Also

Key Class


MindFusion.UI.Wpf.Key Constructor

Key Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected Key ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Key Class


MindFusion.UI.Wpf.Key Methods

Key Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this Key.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value.
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one.

See Also

Key Class


MindFusion.UI.Wpf.Key.Clone Method

Key.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

A new Key instance.

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Copy Method

Key.Copy Method
[image]

Copies the properties of this key to specified one.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected void Copy (
Key key
)

Visual Basic [image] Copy Code

Protected Sub Copy( _
key As Key _
)

Parameters

key

Key

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Equals Method

Key.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.GetHashCode Method

Key.GetHashCode Method
[image]

Returns a hash code for this Key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.GetVirtualKeyCode Method

Key.GetVirtualKeyCode Method
[image]

Gets the virtual key code corresponding to a System.Windows.Input.Key value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static int GetVirtualKeyCode (
Key value
)

Visual Basic [image] Copy Code

Public Shared Function GetVirtualKeyCode( _
value As Key _
) As Integer

Parameters

value

System.Windows.Input.Key value.

Return Value

int

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Send Method

Key.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public MustOverride Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key Properties

Key Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18
AltGr | The alt gr virtual key. Virtual Key = 165
Backspace | The backspace virtual key.
CapsLock | The caps lock virtual key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.
Context | The context menu virtual key.
Ctrl | The control virtual key. Virtual Key = 17
Delete | The delete virtual key.
End | The end virtual key.
Enter | The enter virtual key. Virtual Key = 13
Esc | The escape virtual key.
F1 | The F1 virtual key.
F10 | The F10 virtual key.
F11 | The F11 virtual key.
F12 | The F12 virtual key.
F2 | The F2 virtual key.
F3 | The F3 virtual key.
F4 | The F4 virtual key.
F5 | The F5 virtual key.
F6 | The F6 virtual key.
F7 | The F7 virtual key.
F8 | The F8 virtual key.
F9 | The F9 virtual key.
Height | The key's height.
Home | The home virtual key.
Image | Gets or sets relative path to an image that should be displayed inside this key.
Insert | The insert virtual key.
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.
IsSelected | IsSelected
KeyDown | The key down virtual key.
KeyLeft | The key left virtual key.
KeyRight | The key right virtual key.
KeyUp | The key up virtual key.
Lang | Language rotation virtual key.
Left | Horizontal position of the key.
Num5 | The numpad 5 virtual key.
NumDelete | The numpad delete virtual key.
NumDiv | The numpad / virtual key.
NumEnd | The numpad end virtual key.
NumHome | The numpad home virtual key.
NumInsert | The numpad insert virtual key.
NumKeyDown | The numpad key-down virtual key.
NumKeyLeft | The numpad key-left virtual key.
NumKeyRight | The numpad key-right virtual key.
NumKeyUp | The numpad key-up virtual key.
Numlock | The num lock virtual key.
NumMinus | The numpad - virtual key.
NumMult | The numpad * virtual key.
NumPageDown | The numpad page down virtual key.
NumPageUp | The numpad page up virtual key.
NumPlus | The numpad + virtual key.
PageDown | The page down virtual key.
PageUp | The page up virtual key.
PauseBreak | The pause / break virtual key.
PrtScr | The Print Screen virtual key.
ScrolLock | The scroll lock virtual key.
Shift | The shift virtual key. Virtual Key = 16
Space | The space virtual key.
Tab | The tab virtual key.
Top | Vertical position of the key.
Width | The key's width.
Windows | The Windows virtual key.

See Also

Key Class


MindFusion.UI.Wpf.Key.Alt Property

Key.Alt Property
[image]

The alt virtual key. Virtual Key = 18

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Alt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alt As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.AltGr Property

Key.AltGr Property
[image]

The alt gr virtual key. Virtual Key = 165

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key AltGr { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltGr As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Backspace Property

Key.Backspace Property
[image]

The backspace virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Backspace { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Backspace As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.CapsLock Property

Key.CapsLock Property
[image]

The caps lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key CapsLock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CapsLock As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Content Property

Key.Content Property
[image]

Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Object Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As Object

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Context Property

Key.Context Property
[image]

The context menu virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Context { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Context As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Ctrl Property

Key.Ctrl Property
[image]

The control virtual key. Virtual Key = 17

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Ctrl { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ctrl As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Delete Property

Key.Delete Property
[image]

The delete virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Delete { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delete As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.End Property

Key.End Property
[image]

The end virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key End { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property End As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Enter Property

Key.Enter Property
[image]

The enter virtual key. Virtual Key = 13

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Enter { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Enter As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Esc Property

Key.Esc Property
[image]

The escape virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Esc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Esc As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F1 Property

Key.F1 Property
[image]

The F1 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F1 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F10 Property

Key.F10 Property
[image]

The F10 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F10 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F10 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F11 Property

Key.F11 Property
[image]

The F11 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F11 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F11 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F12 Property

Key.F12 Property
[image]

The F12 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F12 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F12 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F2 Property

Key.F2 Property
[image]

The F2 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F2 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F3 Property

Key.F3 Property
[image]

The F3 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F3 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F4 Property

Key.F4 Property
[image]

The F4 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F4 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F5 Property

Key.F5 Property
[image]

The F5 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F5 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F6 Property

Key.F6 Property
[image]

The F6 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F6 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F7 Property

Key.F7 Property
[image]

The F7 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F7 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F8 Property

Key.F8 Property
[image]

The F8 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F8 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.F9 Property

Key.F9 Property
[image]

The F9 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F9 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Height Property

Key.Height Property
[image]

The key's height.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Home Property

Key.Home Property
[image]

The home virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Home { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Home As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Image Property

Key.Image Property
[image]

Gets or sets relative path to an image that should be displayed inside this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As String

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Insert Property

Key.Insert Property
[image]

The insert virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Insert { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Insert As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.IsLocked Property

Key.IsLocked Property
[image]

IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsLocked { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsLocked As Boolean

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.IsSelected Property

Key.IsSelected Property
[image]

IsSelected

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.KeyDown Property

Key.KeyDown Property
[image]

The key down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyDown As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.KeyLeft Property

Key.KeyLeft Property
[image]

The key left virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyLeft { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyLeft As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.KeyRight Property

Key.KeyRight Property
[image]

The key right virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyRight { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyRight As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.KeyUp Property

Key.KeyUp Property
[image]

The key up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyUp As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Lang Property

Key.Lang Property
[image]

Language rotation virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Lang { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lang As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Left Property

Key.Left Property
[image]

Horizontal position of the key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Double

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Num5 Property

Key.Num5 Property
[image]

The numpad 5 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Num5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Num5 As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumDelete Property

Key.NumDelete Property
[image]

The numpad delete virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumDelete { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumDelete As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumDiv Property

Key.NumDiv Property
[image]

The numpad / virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumDiv { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumDiv As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumEnd Property

Key.NumEnd Property
[image]

The numpad end virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumEnd { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumEnd As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumHome Property

Key.NumHome Property
[image]

The numpad home virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumHome { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumHome As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumInsert Property

Key.NumInsert Property
[image]

The numpad insert virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumInsert { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumInsert As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumKeyDown Property

Key.NumKeyDown Property
[image]

The numpad key-down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyDown As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumKeyLeft Property

Key.NumKeyLeft Property
[image]

The numpad key-left virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyLeft { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyLeft As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumKeyRight Property

Key.NumKeyRight Property
[image]

The numpad key-right virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyRight { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyRight As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumKeyUp Property

Key.NumKeyUp Property
[image]

The numpad key-up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyUp As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Numlock Property

Key.Numlock Property
[image]

The num lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Numlock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Numlock As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumMinus Property

Key.NumMinus Property
[image]

The numpad - virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumMinus { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumMinus As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumMult Property

Key.NumMult Property
[image]

The numpad * virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumMult { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumMult As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumPageDown Property

Key.NumPageDown Property
[image]

The numpad page down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPageDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPageDown As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumPageUp Property

Key.NumPageUp Property
[image]

The numpad page up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPageUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPageUp As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.NumPlus Property

Key.NumPlus Property
[image]

The numpad + virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPlus { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPlus As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.PageDown Property

Key.PageDown Property
[image]

The page down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PageDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PageDown As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.PageUp Property

Key.PageUp Property
[image]

The page up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PageUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PageUp As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.PauseBreak Property

Key.PauseBreak Property
[image]

The pause / break virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PauseBreak { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PauseBreak As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.PrtScr Property

Key.PrtScr Property
[image]

The Print Screen virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PrtScr { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrtScr As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.ScrolLock Property

Key.ScrolLock Property
[image]

The scroll lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key ScrolLock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ScrolLock As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Shift Property

Key.Shift Property
[image]

The shift virtual key. Virtual Key = 16

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Shift { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shift As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Space Property

Key.Space Property
[image]

The space virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Space { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Space As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Tab Property

Key.Tab Property
[image]

The tab virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Tab { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tab As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Top Property

Key.Top Property
[image]

Vertical position of the key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Double

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Width Property

Key.Width Property
[image]

The key's width.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key.Windows Property

Key.Windows Property
[image]

The Windows virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Windows { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Windows As Key

Property Value

See Also

Key Members
Key Class


MindFusion.UI.Wpf.Key Events

Key Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged

See Also

Key Class


MindFusion.UI.Wpf.Key.PropertyChanged Event

Key.PropertyChanged Event
[image]

PropertyChanged

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Key Members
Key Class


MindFusion.UI.Wpf.KeyboardLayout Class

KeyboardLayout Class
[image]

Defines layout of keyboard keys.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class KeyboardLayout : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class KeyboardLayout
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.KeyboardLayout

See Also

KeyboardLayout Members


MindFusion.UI.Wpf.KeyboardLayout Members

KeyboardLayout Members
Constructors Properties Methods Events
[image]

Defines layout of keyboard keys.

The following tables list the members exposed by the KeyboardLayout type.

Public Constructors

Name | Description
KeyboardLayout | Initializes a new instance of the KeyboardLayout class.

Public Properties

Name | Description
Height | Gets or sets the keyboard height.
KeyboardLayoutId | Gets or sets the layout id.
Keys | Gets or sets the keys displayed in this layout.
Width | Gets or sets the keyboard width.

Public Methods

Name | Description
Create | Overloaded.

Public Events

Name | Description
PropertyChanged | PropertyChanged event

See Also

KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout Constructor

KeyboardLayout Constructor
[image]

Initializes a new instance of the KeyboardLayout class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout Methods

KeyboardLayout Methods
[image]

Public Methods

Name | Description
Create | Overloaded.

See Also

KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Create Method

KeyboardLayout.Create Method
[image]

Overload List

Name | Description
KeyboardLayout.Create (Stream) | Loads keyboard layout from a stream.
KeyboardLayout.Create (String) | Loads keyboard layout from a file.

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Create Method (Stream)

KeyboardLayout.Create Method (Stream)
See Also
[image]

Loads keyboard layout from a stream.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static KeyboardLayout Create (
Stream input
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
input As Stream _
) As KeyboardLayout

Parameters

input

A stream containing layout XML.

Return Value

A KeyboardLayout instance.

See Also

Create Method Overload List
KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Create Method (String)

KeyboardLayout.Create Method (String)
See Also
[image]

Loads keyboard layout from a file.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static KeyboardLayout Create (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
fileName As String _
) As KeyboardLayout

Parameters

fileName

Path to a file containing layout XML.

Return Value

A KeyboardLayout instance.

See Also

Create Method Overload List
KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout Properties

KeyboardLayout Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the keyboard height.
KeyboardLayoutId | Gets or sets the layout id.
Keys | Gets or sets the keys displayed in this layout.
Width | Gets or sets the keyboard width.

See Also

KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Height Property

KeyboardLayout.Height Property
[image]

Gets or sets the keyboard height.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.KeyboardLayoutId Property

KeyboardLayout.KeyboardLayoutId Property
[image]

Gets or sets the layout id.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public long KeyboardLayoutId { get; set; }

Visual Basic [image] Copy Code

Public Property KeyboardLayoutId As Long

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Keys Property

KeyboardLayout.Keys Property
[image]

Gets or sets the keys displayed in this layout.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Key> Keys { get; set; }

Visual Basic [image] Copy Code

Public Property Keys As ObservableCollection(Of Key)

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.Width Property

KeyboardLayout.Width Property
[image]

Gets or sets the keyboard width.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout Events

KeyboardLayout Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged event

See Also

KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardLayout.PropertyChanged Event

KeyboardLayout.PropertyChanged Event
[image]

PropertyChanged event

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

KeyboardLayout Members
KeyboardLayout Class


MindFusion.UI.Wpf.KeyboardMode Enumeration

KeyboardMode Enumeration
[image]

Identifies keyboard layout modes.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public enum KeyboardMode

Visual Basic [image] Copy Code

Public Enum KeyboardMode

Members

Member name | Description
Custom | Custom layout. You must design a layout and save it in Layouts folder before using this mode. Or use TemplateLayout property to define keyboard common view.
Default | Default layout.
Extended | Extended layout.

See Also

MindFusion.UI.Wpf Namespace

© 2016 MindFusion


MindFusion.UI.Wpf.NumPadKey Class

NumPadKey Class
[image]

Represents a num pad key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class NumPadKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class NumPadKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.NumPadKey

See Also

NumPadKey Members


MindFusion.UI.Wpf.NumPadKey Members

NumPadKey Members
Constructors Properties Methods Events
[image]

Represents a num pad key.

The following tables list the members exposed by the NumPadKey type.

Public Constructors

Name | Description
NumPadKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumCase | Gets or sets the key label.
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this NumPadKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Constructor

NumPadKey Constructor
[image]

Overload List

Name | Description
NumPadKey () | Initializes a new instance of the NumPadKey class.
NumPadKey (Int32) | Initializes a new instance of the NumPadKey class with specified virtual key code.
NumPadKey (Int32, Object) | Initializes a new instance of the NumPadKey class with specified virtual key code and content.

See Also

NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Constructor ()

NumPadKey Constructor ()
See Also
[image]

Initializes a new instance of the NumPadKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NumPadKey Constructor Overload List
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Constructor (Int32)

NumPadKey Constructor (Int32)
See Also
[image]

Initializes a new instance of the NumPadKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

NumPadKey Constructor Overload List
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Constructor (Int32, Object)

NumPadKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instance of the NumPadKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

Label of the key's alternative function.

See Also

NumPadKey Constructor Overload List
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Methods

NumPadKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this NumPadKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.Clone Method

NumPadKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new NumPadKey instance.

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.Equals Method

NumPadKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.GetHashCode Method

NumPadKey.GetHashCode Method
[image]

Returns a hash code for this NumPadKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.Send Method

NumPadKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release special keys, or false otherwise.

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey Properties

NumPadKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumCase | Gets or sets the key label.
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.NumCase Property

NumPadKey.NumCase Property
[image]

Gets or sets the key label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string NumCase { get; set; }

Visual Basic [image] Copy Code

Public Property NumCase As String

Property Value

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.NumPadKey.VirtualKey Property

NumPadKey.VirtualKey Property
[image]

Gets or sets the key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

NumPadKey Members
NumPadKey Class


MindFusion.UI.Wpf.RegularKey Class

RegularKey Class
[image]

Represents regular keyboard keys that send character codes as input.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class RegularKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class RegularKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.RegularKey

See Also

RegularKey Members


MindFusion.UI.Wpf.RegularKey Members

RegularKey Members
Constructors Properties Methods Events
[image]

Represents regular keyboard keys that send character codes as input.

The following tables list the members exposed by the RegularKey type.

Public Constructors

Name | Description
RegularKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AlterCase | The alter-case label to display.
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
AltGrLock | AltGrLock; obsolete.
AltLock | AltLock; obsolete.
Backspace | The backspace virtual key. (Inherited from Key.)
CapitalCase | The capital-case label to display.
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
ControlLock | ControlLock; obsolete.
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
CurrentCase | Gets current character label depending on state of keys such as shift, alt etc.
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | The lower-case label to display.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
ShiftLock | ShiftLock; obsolete.
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | The upper-case label to display.
VirtualKey | Gets or sets the virtual key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this RegularKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

RegularKey Class


MindFusion.UI.Wpf.RegularKey Constructor

RegularKey Constructor
[image]

Overload List

Name | Description
RegularKey () | Initializes a new instance of the RegularKey class.
RegularKey (Int32) | Initializes a new instance of the RegularKey class with specified virtual key code.
RegularKey (Int32, Object) | Initializes a new instance of the RegularKey class with specified virtual key code and content.

See Also

RegularKey Class


MindFusion.UI.Wpf.RegularKey Constructor ()

RegularKey Constructor ()
See Also
[image]

Initializes a new instance of the RegularKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RegularKey Constructor Overload List
RegularKey Class


MindFusion.UI.Wpf.RegularKey Constructor (Int32)

RegularKey Constructor (Int32)
See Also
[image]

Initializes a new instance of the RegularKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

RegularKey Constructor Overload List
RegularKey Class


MindFusion.UI.Wpf.RegularKey Constructor (Int32, Object)

RegularKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instance of the RegularKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

Content sent as input to the focused control.

See Also

RegularKey Constructor Overload List
RegularKey Class


MindFusion.UI.Wpf.RegularKey Methods

RegularKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this RegularKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

RegularKey Class


MindFusion.UI.Wpf.RegularKey.Clone Method

RegularKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new RegularKey instance.

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.Equals Method

RegularKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.GetHashCode Method

RegularKey.GetHashCode Method
[image]

Returns a hash code for this RegularKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.Send Method

RegularKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey Properties

RegularKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AlterCase | The alter-case label to display.
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
AltGrLock | AltGrLock; obsolete.
AltLock | AltLock; obsolete.
Backspace | The backspace virtual key. (Inherited from Key.)
CapitalCase | The capital-case label to display.
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
ControlLock | ControlLock; obsolete.
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
CurrentCase | Gets current character label depending on state of keys such as shift, alt etc.
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | The lower-case label to display.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
ShiftLock | ShiftLock; obsolete.
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | The upper-case label to display.
VirtualKey | Gets or sets the virtual key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

RegularKey Class


MindFusion.UI.Wpf.RegularKey.AlterCase Property

RegularKey.AlterCase Property
[image]

The alter-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string AlterCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AlterCase As String

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.AltGrLock Property

RegularKey.AltGrLock Property
[image]

AltGrLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AltGrLock { get; set; }

Visual Basic [image] Copy Code

Public Property AltGrLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.AltLock Property

RegularKey.AltLock Property
[image]

AltLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AltLock { get; set; }

Visual Basic [image] Copy Code

Public Property AltLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.CapitalCase Property

RegularKey.CapitalCase Property
[image]

The capital-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string CapitalCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CapitalCase As String

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.ControlLock Property

RegularKey.ControlLock Property
[image]

ControlLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool ControlLock { get; set; }

Visual Basic [image] Copy Code

Public Property ControlLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.CurrentCase Property

RegularKey.CurrentCase Property
[image]

Gets current character label depending on state of keys such as shift, alt etc.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string CurrentCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentCase As String

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.LowerCase Property

RegularKey.LowerCase Property
[image]

The lower-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LowerCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LowerCase As String

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.Repeat Property

RegularKey.Repeat Property
[image]

Gets or sets how many times to send the key code when this key is pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As Integer

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.ShiftLock Property

RegularKey.ShiftLock Property
[image]

ShiftLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool ShiftLock { get; set; }

Visual Basic [image] Copy Code

Public Property ShiftLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.UpperCase Property

RegularKey.UpperCase Property
[image]

The upper-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string UpperCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UpperCase As String

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.RegularKey.VirtualKey Property

RegularKey.VirtualKey Property
[image]

Gets or sets the virtual key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

RegularKey Members
RegularKey Class


MindFusion.UI.Wpf.SpecialKey Class

SpecialKey Class
[image]

Represents special keys.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class SpecialKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class SpecialKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.SpecialKey

See Also

SpecialKey Members


MindFusion.UI.Wpf.SpecialKey Members

SpecialKey Members
Constructors Properties Methods Events
[image]

Represents special keys.

The following tables list the members exposed by the SpecialKey type.

Public Constructors

Name | Description
SpecialKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this SpecialKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Constructor

SpecialKey Constructor
[image]

Overload List

Name | Description
SpecialKey () | Initializes a new instace of the SpecialKey class.
SpecialKey (Int32) | Initializes a new instace of the SpecialKey class with specified virtual key code.
SpecialKey (Int32, Object) | Initializes a new instace of the SpecialKey class with specified virtual key code and content.

See Also

SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Constructor ()

SpecialKey Constructor ()
See Also
[image]

Initializes a new instace of the SpecialKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpecialKey Constructor Overload List
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Constructor (Int32)

SpecialKey Constructor (Int32)
See Also
[image]

Initializes a new instace of the SpecialKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

SpecialKey Constructor Overload List
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Constructor (Int32, Object)

SpecialKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instace of the SpecialKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

The key's label.

See Also

SpecialKey Constructor Overload List
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Methods

SpecialKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this SpecialKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

SpecialKey Class


MindFusion.UI.Wpf.SpecialKey.Clone Method

SpecialKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new SpecialKey instance.

See Also

SpecialKey Members
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey.Equals Method

SpecialKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

SpecialKey Members
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey.GetHashCode Method

SpecialKey.GetHashCode Method
[image]

Returns a hash code for this SpecialKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

SpecialKey Members
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey.Send Method

SpecialKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

SpecialKey Members
SpecialKey Class


MindFusion.UI.Wpf.SpecialKey Properties

SpecialKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
Numlock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrolLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

SpecialKey Class


MindFusion.UI.Wpf.SpecialKey.VirtualKey Property

SpecialKey.VirtualKey Property
[image]

Gets or sets the key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

SpecialKey Members
SpecialKey Class


MindFusion.UI.Wpf.VirtualKeyboard Class

VirtualKeyboard Class
[image]

Virtual Keyboard Control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class VirtualKeyboard : Control

Visual Basic [image] Copy Code

Public Class VirtualKeyboard
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.VirtualKeyboard

See Also

VirtualKeyboard Members


MindFusion.UI.Wpf.VirtualKeyboard Members

VirtualKeyboard Members
Constructors Fields Properties Methods Events
[image]

Virtual Keyboard Control.

The following tables list the members exposed by the VirtualKeyboard type.

Public Constructors

Name | Description
VirtualKeyboard | Initializes a new instance of VirtualKeyboard.

Public Fields

Name | Description
AttachedWindowProperty | Identifies the AttachedWindow dependency property.
AutoFillProperty | Identifies the AutoFill dependency property.
AutoReleaseModifierKeysProperty | Identifies the AutoReleaseModifierKeys dependency property.
CurrentCultureProperty | Identifies the CurrentCulture dependency property.
DefaultLayoutProperty | Identifies the DefaultLayout dependency property.
IsStandAloneProperty | Identifies the IsStandAlone dependency property
LayoutProperty | Identifies the Layout dependency property.
LayoutsFolderProperty | Identifies the LayoutsFolder dependency property.
ModeProperty | Identifies the Mode dependency property.
TemplateLayoutProperty | Identifies the TemplateLayout dependency property.

Public Properties

Name | Description
AltGrLocked | Gets the state of the AltGr key.
AltLocked | Gets the state of the Alt key.
AttachedWindow | Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.
AutoFill | Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.
AutoReleaseModifierKeys | Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.
CapsLocked | Gets the state of the Caps lock key.
ControlLocked | Gets the state of the Control key.
CurrentCulture | Gets or sets the current input language. This is a dependency property.
DefaultLayout | Obsolete; Gets or sets the default kayboard layout. This is a dependency property.
IsStandAlone | Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.
Layout | Gets the current keyboard layout. This is a dependency property.
LayoutsFolder | Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.
LicenseKey | Gets or sets the license key of the control.
Mode | Gets or sets the layout mode. This is a dependency property.
NumLocked | Gets the state of the Num lock key.
ScrollLocked | Gets the state of the Scroll lock key.
ShiftLocked | Gets the state of the Shift key.
TemplateLayout | Gets or sets the keyboard's template layout. This is a dependency property.

Public Methods

Name | Description
ForceUpdateLayout | Updates the keyboard layout.
OnApplyTemplate | Control.OnApplyTemplate override.
SendKey | Sends the specified key input to active window.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseUp | Control..OnPreviewMouseUp override.

Public Events

Name | Description
KeyPressed | Raised when a key has been pressed.

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard Fields

VirtualKeyboard Fields
[image]

Public Fields

Name | Description
AttachedWindowProperty | Identifies the AttachedWindow dependency property.
AutoFillProperty | Identifies the AutoFill dependency property.
AutoReleaseModifierKeysProperty | Identifies the AutoReleaseModifierKeys dependency property.
CurrentCultureProperty | Identifies the CurrentCulture dependency property.
DefaultLayoutProperty | Identifies the DefaultLayout dependency property.
IsStandAloneProperty | Identifies the IsStandAlone dependency property
LayoutProperty | Identifies the Layout dependency property.
LayoutsFolderProperty | Identifies the LayoutsFolder dependency property.
ModeProperty | Identifies the Mode dependency property.
TemplateLayoutProperty | Identifies the TemplateLayout dependency property.

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AttachedWindowProperty Field

VirtualKeyboard.AttachedWindowProperty Field
[image]

Identifies the AttachedWindow dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AttachedWindowProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AttachedWindowProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AutoFillProperty Field

VirtualKeyboard.AutoFillProperty Field
[image]

Identifies the AutoFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoFillProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AutoReleaseModifierKeysProperty Field

VirtualKeyboard.AutoReleaseModifierKeysProperty Field
[image]

Identifies the AutoReleaseModifierKeys dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoReleaseModifierKeysProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoReleaseModifierKeysProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.CurrentCultureProperty Field

VirtualKeyboard.CurrentCultureProperty Field
[image]

Identifies the CurrentCulture dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentCultureProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentCultureProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.DefaultLayoutProperty Field

VirtualKeyboard.DefaultLayoutProperty Field
[image]

Identifies the DefaultLayout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultLayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.IsStandAloneProperty Field

VirtualKeyboard.IsStandAloneProperty Field
[image]

Identifies the IsStandAlone dependency property

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsStandAloneProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsStandAloneProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.LayoutProperty Field

VirtualKeyboard.LayoutProperty Field
[image]

Identifies the Layout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.LayoutsFolderProperty Field

VirtualKeyboard.LayoutsFolderProperty Field
[image]

Identifies the LayoutsFolder dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LayoutsFolderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LayoutsFolderProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.ModeProperty Field

VirtualKeyboard.ModeProperty Field
[image]

Identifies the Mode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModeProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.TemplateLayoutProperty Field

VirtualKeyboard.TemplateLayoutProperty Field
[image]

Identifies the TemplateLayout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TemplateLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TemplateLayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard Constructor

VirtualKeyboard Constructor
[image]

Initializes a new instance of VirtualKeyboard.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public VirtualKeyboard ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard Methods

VirtualKeyboard Methods
[image]

Public Methods

Name | Description
ForceUpdateLayout | Updates the keyboard layout.
OnApplyTemplate | Control.OnApplyTemplate override.
SendKey | Sends the specified key input to active window.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseUp | Control..OnPreviewMouseUp override.

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.ForceUpdateLayout Method

VirtualKeyboard.ForceUpdateLayout Method
[image]

Updates the keyboard layout.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public void ForceUpdateLayout ()

Visual Basic [image] Copy Code

Public Sub ForceUpdateLayout ()

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.OnApplyTemplate Method

VirtualKeyboard.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewMouseDown Method

VirtualKeyboard.OnPreviewMouseDown Method
[image]

Control.OnPreviewMouseDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

MouseButtonEventArgs

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewMouseUp Method

VirtualKeyboard.OnPreviewMouseUp Method
[image]

Control..OnPreviewMouseUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

MouseButtonEventArgs

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.SendKey Method

VirtualKeyboard.SendKey Method
[image]

Sends the specified key input to active window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public virtual void SendKey (
Key objKey
)

Visual Basic [image] Copy Code

Public Overridable Sub SendKey( _
objKey As Key _
)

Parameters

objKey

Key

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard Properties

VirtualKeyboard Properties
[image]

Public Properties

Name | Description
AltGrLocked | Gets the state of the AltGr key.
AltLocked | Gets the state of the Alt key.
AttachedWindow | Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.
AutoFill | Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.
AutoReleaseModifierKeys | Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.
CapsLocked | Gets the state of the Caps lock key.
ControlLocked | Gets the state of the Control key.
CurrentCulture | Gets or sets the current input language. This is a dependency property.
DefaultLayout | Obsolete; Gets or sets the default kayboard layout. This is a dependency property.
IsStandAlone | Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.
Layout | Gets the current keyboard layout. This is a dependency property.
LayoutsFolder | Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.
LicenseKey | Gets or sets the license key of the control.
Mode | Gets or sets the layout mode. This is a dependency property.
NumLocked | Gets the state of the Num lock key.
ScrollLocked | Gets the state of the Scroll lock key.
ShiftLocked | Gets the state of the Shift key.
TemplateLayout | Gets or sets the keyboard's template layout. This is a dependency property.

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AltGrLocked Property

VirtualKeyboard.AltGrLocked Property
[image]

Gets the state of the AltGr key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool AltGrLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltGrLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AltLocked Property

VirtualKeyboard.AltLocked Property
[image]

Gets the state of the Alt key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool AltLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AttachedWindow Property

VirtualKeyboard.AttachedWindow Property
[image]

Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public IntPtr AttachedWindow { get; set; }

Visual Basic [image] Copy Code

Public Property AttachedWindow As IntPtr

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AutoFill Property

VirtualKeyboard.AutoFill Property
[image]

Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoFill { get; set; }

Visual Basic [image] Copy Code

Public Property AutoFill As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.AutoReleaseModifierKeys Property

VirtualKeyboard.AutoReleaseModifierKeys Property
[image]

Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoReleaseModifierKeys { get; set; }

Visual Basic [image] Copy Code

Public Property AutoReleaseModifierKeys As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.CapsLocked Property

VirtualKeyboard.CapsLocked Property
[image]

Gets the state of the Caps lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool CapsLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CapsLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.ControlLocked Property

VirtualKeyboard.ControlLocked Property
[image]

Gets the state of the Control key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ControlLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ControlLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.CurrentCulture Property

VirtualKeyboard.CurrentCulture Property
[image]

Gets or sets the current input language. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public CultureInfo CurrentCulture { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentCulture As CultureInfo

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.DefaultLayout Property

VirtualKeyboard.DefaultLayout Property
[image]

Obsolete; Gets or sets the default kayboard layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout DefaultLayout { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultLayout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.IsStandAlone Property

VirtualKeyboard.IsStandAlone Property
[image]

Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsStandAlone { get; set; }

Visual Basic [image] Copy Code

Public Property IsStandAlone As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.Layout Property

VirtualKeyboard.Layout Property
[image]

Gets the current keyboard layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout Layout { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.LayoutsFolder Property

VirtualKeyboard.LayoutsFolder Property
[image]

Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LayoutsFolder { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutsFolder As String

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.LicenseKey Property

VirtualKeyboard.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.Mode Property

VirtualKeyboard.Mode Property
[image]

Gets or sets the layout mode. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardMode Mode { get; set; }

Visual Basic [image] Copy Code

Public Property Mode As KeyboardMode

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.NumLocked Property

VirtualKeyboard.NumLocked Property
[image]

Gets the state of the Num lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool NumLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.ScrollLocked Property

VirtualKeyboard.ScrollLocked Property
[image]

Gets the state of the Scroll lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ScrollLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ScrollLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.ShiftLocked Property

VirtualKeyboard.ShiftLocked Property
[image]

Gets the state of the Shift key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ShiftLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ShiftLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.TemplateLayout Property

VirtualKeyboard.TemplateLayout Property
[image]

Gets or sets the keyboard's template layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout TemplateLayout { get; set; }

Visual Basic [image] Copy Code

Public Property TemplateLayout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard Events

VirtualKeyboard Events
[image]

Public Events

Name | Description
KeyPressed | Raised when a key has been pressed.

See Also

VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyboard.KeyPressed Event

VirtualKeyboard.KeyPressed Event
[image]

Raised when a key has been pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<VirtualKeyEventArgs> KeyPressed

Visual Basic [image] Copy Code

Public Event KeyPressed As EventHandler(Of VirtualKeyEventArgs)

See Also

VirtualKeyboard Members
VirtualKeyboard Class


MindFusion.UI.Wpf.VirtualKeyEventArgs Class

VirtualKeyEventArgs Class
[image]

Contains data about KeyPressed events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class VirtualKeyEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class VirtualKeyEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.VirtualKeyEventArgs

See Also

VirtualKeyEventArgs Members


MindFusion.UI.Wpf.VirtualKeyEventArgs Members

VirtualKeyEventArgs Members
Constructors Properties
[image]

Contains data about KeyPressed events.

The following tables list the members exposed by the VirtualKeyEventArgs type.

Public Constructors

Name | Description
VirtualKeyEventArgs | Initializes a new instance of the VirtualKeyEventArgs class.

Public Properties

Name | Description
Key | Gets an instance of a Key-derived class that identifies the pressed key.

See Also

VirtualKeyEventArgs Class


MindFusion.UI.Wpf.VirtualKeyEventArgs Constructor

VirtualKeyEventArgs Constructor
[image]

Initializes a new instance of the VirtualKeyEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public VirtualKeyEventArgs (
Key key
)

Visual Basic [image] Copy Code

Public New ( _
key As Key _
)

Parameters

key

MindFusion.UI.Wpf.Key

See Also

VirtualKeyEventArgs Class


MindFusion.UI.Wpf.VirtualKeyEventArgs Properties

VirtualKeyEventArgs Properties
[image]

Public Properties

Name | Description
Key | Gets an instance of a Key-derived class that identifies the pressed key.

See Also

VirtualKeyEventArgs Class


MindFusion.UI.Wpf.VirtualKeyEventArgs.Key Property

VirtualKeyEventArgs.Key Property
[image]

Gets an instance of a Key-derived class that identifies the pressed key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Key Key { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Key As Key

Property Value

See Also

VirtualKeyEventArgs Members
VirtualKeyEventArgs Class


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question on the discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?catselect=keyboard

or visit our Help Desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding Virtual Keyboard. We do take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download
Diagramming for Xamarin | Product Information

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download
Scheduling for Xamarin | Product Information

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Animations

MindFusion.Diagramming Programmer's Guide
Animations

Animating Diagram Items

To animate a DiagramItem, instantiate a new Animation object specifying it's properties and call the start method to begin the animation. The following example will animate a node along it's Y-axis from 5 to 100 Y-coordinate, using the Power animation function and the EaseOut easing function:

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var AnimationType = MindFusion.Animations.AnimationType;
var EasingType = MindFusion.Animations.EasingType;

var options =
{
duration: 500,
fromValue: 5,
toValue: 100,
animationType: AnimationType.Power,
param: 2,
easingType: EasingType.EaseOut
};
var animation = new Animation(node, options);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 1

Looping Animations

To create looping animations, use the repeat and reverse properties. To stop an animation, call its stop method.

JavaScript [image] Copy Code

// Use this property to repeat the animation until stopped.
animation.setRepeat(true);
// Use this property to reverse the to and from values.
animation.setReverse(true);

// Use the stop method to complete the animation.
animation.stop();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 2

OnUpdate Callback

In order to specify which property will be animated, when instantiating an Animation instance, pass an onUpdateCallback function as a parameter to the object's constructor. This callback function can be used to specify which property of the animated item will be animated. The callback signature should contain two arguments - the animation object instance and a value representing the animated property delta. This callback is called at every animation timer "tick". The following example creates a pulse-like effect, using an onUpdateCallback:

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var Utils = MindFusion.Diagramming.Utils;

var options =
{
duration: 550,
fromValue: -0.15,
toValue: 0.15,
repeat: true,
reverse: true
};

/**
* @param [Animation] animation The animation object instance.
* @param [Number] animationDelta A number representing the percentage of displacement
* of the animated property's value in the [fromValue, toValue] range.
*/
function pulse(animation, animationDelta)
{
var bounds = animation.item.getBounds().clone();
var to = animation.getToValue();
bounds = Utils.inflate(bounds, to * animationDelta, to * animationDelta);
animation.item.setBounds(bounds, true);
}

var animation = new Animation(node, options, pulse);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 3

Default Animation and Easing Functions

The following example demonstrates the built-in animation and easing functions that the Animation class provides:

EaseIn EaseOut EaseInOut EaseOutIn
This page requires a browser that supports HTML 5 Canvas element.

Example 4

Custom Animation Functions

In addition to the provided default animation functions, it is also possible to define custom animation effects. Set the AnimationType to Custom and pass a custom animation function callback to the Animation constructor. The callback signature should contain two arguments - the time progressed as a percentage from the start of the animation and the user-set parameter, used in the animation function. The following example uses a custom function [image] where x is a value between 0 and 1 and y is a parameter, passed as an argument to the Animation constructor.

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var AnimationType = MindFusion.Animations.AnimationType;

var options =
{
duration: 500,
fromValue: 5,
toValue: 100,
param: 5,
animationType: AnimationType.Custom
};

/**
* @param [Number] progress The time progress in the animation loop. A value between 0 and 1.
* @param [Object] param The user-set value, used to parameterize the animation function.
*/
function custom(progress, param)
{
return Math.pow(Math.E, 1 - (1 / Math.pow(progress, param)));
}

var animation = new Animation(node, options, null, custom);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 5

© 2014 MindFusion